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Introduction
This document explains how to install and setup μManager for use with the iXon EMCCD Cameras (iXon Ultra 
and Life, 897 and 888).  In order for the camera to work to its full specification it is necessary to perform the 
installation as described in this document.

Updates to the Manual
Changes are periodically made to the product and these will be incorporated into new editions of the manual. 
Please check for new releases of the manual at: andor.oxinst.com/downloads. If you find an issue in this manu-
al please contact your customer support respresentative with a description of the issue. 

Trademarks and Patent Information
Andor®, the Andor logo, iXon Ultra and Life EMCCD and Solis are trademarks of Andor Technology. Andor is an 
Oxford Instruments company.  μManager is an open source application developed at UCSF and is funded by an 
NIH grant R01-EB007187 from the National Institute of Biomedical Imaging and Bioengineering (NBIB). ImageJ 
is a freely available public domain Java image processing program. All other marks are property of their own-
ers.

Front page image courtesy of Prof. Jan Liphardt and Dr. Alan Lowe, University of California, Berkeley, USA

Revision History

Version Released Description

1.0 31 Oct 2012 Initial Release

1.1 28 May 2013
General updates to improve presentation and procedures throughout.
Updated Minimum Exposure and Frame Rate data in Section 3.4-3.6.

1.3 13 May 2014
Added Software feature Matrix (Section 3.7)

Updated presentation (All sections)

1.4 21 May 2014 Correction to Andor weblink (Section 1.1)

1.5 19 Jan 2015 Updated for iXon Ultra 888

1.6 28 Sep 2021
Updated branding throughout. Updated hyperlinks and screenshots throughout. 

Updated Figure 3 array sizes. Updated to reflect current Ultra and Life iXon models.

http://andor.oxinst.com/downloads
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Section 1: Installation
This section outlines how to install μManager on your PC for use with the iXon EMCCD cameras (iXon Ultra 897 
and 888).

1.1 	Installing μManager
NOTE: The driver required to run the iXon Ultra range of cameras in μManager is already included in 
μManager and therefore you do not need Andor SDK.

1.	 Download the latest full version of μManager from the ‘Downloads’ section of https://micro-manager.
org/.

2.	 Run the executable when it downloads and follow the steps in the setup wizard through until 
μManager is installed.

https://micro-manager.org/
https://micro-manager.org/
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3.	 Once μManager has been installed, uncheck the box that says ‘Launch Micro-Manager’ and click ‘Fin-
ish’.

4.	 To ensure that everything is correct it is advisable to download the latest Andor Driver Pack for iXon 
EMCCD  from the following link: https://andor.oxinst.com/downloads/ 

5.	 Start the installation and install to the Micro-Manager directory

 THIS IS VERY IMPORTANT. IF THE ANDOR DRIVER PACK IS NOT INSTALLED TO THIS DIREC-
TORY THE IXON EMCCD CAMERA WILL NOT BE DETECTED IN THE CONFIGURATION SET-

UP.
6.	 Complete the installation steps and click ‘Finish’. 
7.	 Select ‘Yes Restart the computer now’.

https://andor.oxinst.com/downloads/
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Section 2: Configuring μManager

2.1 	Configuring μManager

1.	 Power on the iXon EMCCD camera.
2.	 Run μManager from the Start Menu>Programs.
3.	 A dialog box allows the user to load a camera from a configuration file on start-up. Initially you won’t 

have any configuration files so select ‘(none)’ and click ‘OK’.

4.	 To load a camera open the Hardware Configuration Wizard by clicking Tools->Hardware Configura-
tion Wizard

5.	 In the first screen select ‘Create new configuration’ and click ‘Next >’.
6.	 In Step 2 expand the ‘Andor’ folder, select ‘Generic Andor camera Adapter’ as shown and click ‘Add...’.
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7.	 Confirm the camera name is ‘iXon Ultra’ and click OK to return to the Hardware Configuration Wizard.

8.	 Continue to click ‘Next >’ until Step 6 of 6.
9.	 Enter a configuration filename to save these settings.
10.	 Click ‘Finish’.
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Section 3: Using μManager to control the iXon EMCCD 

Open μManager
1.	 To access camera settings open the Device/Property Browser by clicking Tools->Device/Property 

Browser. On start-up, μManager sets the values in the property browser by reading them from the 
camera’s current state.

2.	 Once you have input the acquisition settings for your iXon EMCCD camera you can close the Property 
Browser window.

3.	 You are now in the main μManager window.
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3.1 	Continuous Live view and Snapshot
For a continuous live view click the ‘Live’ button and ensure that the software trigger is 
selected in the Device/Property browser.

To acquire a snapshot click the ‘Snap’ button on Acquisition/Live window.

If no image is visible when you select the live mode, auto-scale the image by pressing Auto on the main 
acquisition window (see below).
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3.2 	Setting-up a Kinetic Series/Time-lapse Experiments

To set up a kinetic series/time-lapse experiment using Multi-D Acq
In the Multi-Dimension Acquisition window you will only use the Time points and Save im-

ages tabs to control the iXon EMCCD camera, the other controls are for other devices. The summary section 
of the Multi-D Acquisition window provides information as to the number of images/frames in the acquisition 
and the total memory required to store these.

1.	 Click the Multi-D Acq button.
2.	 Select Time points and input the number of frames/time points you want to capture and set the Inter-

val between frames. If the interval is set longer than the exposure time, μManager will acquire images 
at its own rate via software triggers. If the interval is less than the exposure time then μManager calls 
the camera to do a sequence acquisition and therefore the interval time is ignored and the camera 
acquires images at the frame rate set up through the Device/Property Browser.

3.	 Select the Save images option at the bottom of the window. The kinetic series/time-lapse can be 
saved as single image files, where each frame/time point is an individual file or as a multi-image file 
where all the frames/time points will be contained in one file. Both file formats can be imported into 
ImageJ after acquisition in μManager and processed.

4.	 Once you are happy with your settings press the Acquire! button and acquisition will begin.
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3.2.1	 Viewing an Acquired Kinetic Series/Time-lapse Experiment
To view the acquired kinetic series/time-lapse experiment, the latest version of Image IO for ImageJ needs to 
be downloaded.

3.2.1.1	 Downloading the ImageJ I/O Plugin

1.	 You can download the lateset plugin from the following link: https://github.com/ij-plugins/ijp-toolkit/
wiki.

2.	 Follow the download link and then look for ‘ij-ImageIO_jar’ with the highest release number.
3.	 Copy this file into the plugins directory which you will find in the μManager folder in the program files in 

the C-drive.
4.	 Restart ImageJ to load the newly installed plugins.

3.2.1.2	 Viewing the Kinetic Series/Time-lapse

1.	 Once the plugins have been installed, open ImageJ>File>Import>micromanager.
2.	 Choose the folder where the kinetic series/time-lapse was saved to and select the first file of the 

single-image files or the multi-image file.

https://github.com/ij-plugins/ijp-toolkit/wiki
https://github.com/ij-plugins/ijp-toolkit/wiki
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3.3 	Setting Custom Regions of Interest (ROI) in μManager

3.3.1	 Defining a Custom ROI

3.	 Go Live to see the full field of view and snap an image. To define the ROI use the rectangular drawing 
tool in ImageJ and draw a region onto the snapped image. Select ROI to define this as your new image 
size.

4.	 Select ‘Live’ to see new ROI.
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5.	 To further define the ROI with a specific width, height and position on the sensor, go to 
ImageJ>Edit>Selection>Specify

NOTE: Always remember to press the ROI button in the main μManager window after changing width and 
height in the ‘Specify’ window and this will instruct the software to choose the new edited region.
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3.4 	Setting the Exposure for a ROI
In order to achieve the maximum frame rates for ROI, the minimum exposure must be set in μManager. In ad-
dition, ensure ‘Frame Transfer’ is ON and the minimum vertical shift speed is selected (see the Property/Device 
browser).

3.5 	iXon Ultra and Life, 897 and 888 Frame Rates in μManager
The acquisition speeds of the iXon Ultra and Life, 897 and 888 in μManager are consistent with Andor Solis 
(shown in the following graphs).
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Figure 1: Comparison of Frame Rates (fps) in Micro-Manager and Solis for the iXon Ultra 897
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Figure 2: Comparison of Frame Rates (fps) in Micro-Manager and Solis for the iXon Ultra 888
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3.6 	Crop Mode Frame Rates in μManager
In order to achieve even faster speeds with the iXon Ultra and Life, 897 and 888 an Optomask can be used 
to optically mask part of the sensor and fool it into thinking it is smaller than its actual size. For this option to 
be functional, the ‘Isolated Crop Mode’ must be enabled in the Device/Property Browser window. Crop mode 
works effectively in recent releases of μManager (see figures below) and it can be turned ON in the Property/
Device browser.
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Figure 3: Comparison of Cropped Mode Frame Rates (fps) for the iXon Ultra 897
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Figure 4: Comparison of Cropped Mode Frame Rates (fps) for the iXon Ultra 888
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3.7 	iXon Ultra & Life, 897 & 888 Feature Matrix in μManager

iXon Ultra iXon Life

Trigger Modes

Internal P P

External P P

External exposure P P

Software trigger P P

Fast external P P

External start P P

Acquisition Modes

Single image P P

Continuous - camera acquires until aborted P P

Kinetic series - frame number and rate control P P

Accumulate mode - specify number and rate to accumulate images P P

Fast kinetics - increase frame rate for user defined rows (requires 
masked area)

P P

Readout Modes

Imaging - full image readout from sensor P P

Overlap - also called  frame transfer (selected modes only) P P

Full vertical binning (FVB) P P

Multi track - user defined depth of vertically binned rows at user de-
fined spacings

O O

Crop mode (corner tethered and optically centered) P P

ROI - arbitrary size region anywhere on sensor P P

Camera binning - user defined* O O

Readout Parameters

Exposure time P P

EM pixel readout rate - 17 MHz, 10 MHz, 5 MHz, 1 MHz P P

Conventional pixel readout rate  - 3 MHz, 1 MHz, 0.08 MHz P NA

Pre amp gain - 1,2 and 4 P P

Vertical shift speed (3.3 μs, 1.7 μs, 0.9 μs, 0.5 μs and 0.3 μs) P P

Vertical clock amplitude (normal, +1,+2, +3, and +4) P P

Electron multiplying mode - Real gains from x2 to 300,  - Real gains 
(x1000 in extended mode) 

P P

Optaquire

Enable specific mode P P

Add/delete user defined mode O O
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iXon Ultra iXon Life

iCam

Change exposure time during acquisition - (limitations apply, see 
manual)

O O

Change EM gain and control P P

Metadata

Timestamp clock (current timestamp reading on camera) +/- 10 ns and 
time of subsequent frames

O O

For USB cameras FIFO fill level recorder in meta data O O

Image Processing

Spurious noise filter (median, level above, interquartile range) -on cam-
era correction

P P

Data averaging filter O O

Shutter Control

Internal shutter (Open/Closed/Auto (open on power up)) P NA

External shutter P P

Fan Control

High, Low, Off P P

Operating System Support

Windows 8 & 10, 32 & 64 bit (Windows 10, 64 bit is recommended) P P

Recommended Application Features

Image flip - horizontal and vertical (conventional and EM registers 
readout raw data in a different order by default) 

P P

Image rotation - 90 degrees clockwise, 90 degrees anticlockwise P P

Image streaming to disk at all sustained frame rates O O

Supported file formats should contain all acquisition information in 
header 

P P

* Fixed binning options 1, 2, 4 & 8 available
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