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Chapter 1: Introduction

There are several sample macros provided within Clampfit Batch Analysis Software. There is
also corresponding sample data that you can import.

The following sections provide a brief explanation about using macros. To see the
configuration details of a macro in the program, double-click on the macro steps to view
their configuration dialogs.

Configuring MDC File Server

The MDC File Server runs on Windows 7 and 10 computer operating systems. The computer
it runs on requires enough hard drive space to store your data files. The storage location can
be changed if it becomes full, and the database keeps track of data files in multiple storage
locations. If you set a new storage location, keep the existing data storage location.

Before starting Clampfit Software to run Batch Analysis the first time, you must first
configure MDC File Server. MDC File Server is required for managing imported data. It runs
quietly in the background while you use Batch Analysis. MDC File Server must be running for
Clampfit Software Batch Analysis to run.

To configure MDC File Server:

1. After you install the pCLAMP Software,open the MDC File Server Manager from Start >
All Programs > Molecular Devices > MDC File Server > MDC File Server, right-click and
Run as administrator.
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2. Inthe MDC File Server Manager dialog, click Select file directory.

A CAUTION! Ifyou select a computer other than the local one, you must have
access permissions to the folder location at all times.

i~ MDC File Server Manager 1.1.0.21

Configure

Select file direckary |

| Ci\FileServer

Select port; | 9200
Apply

MDCFileServer .exe versions  1.1.0.22

Close

3. Click Create new folder, type the name FILESERVER, and click OK.

* Tip: You can name the new folder something other than FILESERVER if needed.

4. Inthe Select port field, type 9200, and click Apply.

5. Click the Start button and wait for the Start button to disable.
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6. When the Start button is inactive, click Close.

i MDC File Server Manager 1.1.0.21

| Stop

Configure

Select File direckory |

| A\ FileServer

Select port: | 9200
Apply

MODCFileServer . exe version:  1.1.0.22

First Time Use Database Configuration

If this is the first time using Clampfit Software Batch Analysis, you must do the following to
configure your data storage folder:

1. Ensure that your Clampfit Software license key dongle is installed on the same computer
that the software is installed.

2. Start Clampfit Software.
3. Select Analyze > Batch Analysis.

4. After the Batch Analysis window appears, when you see the Storage Location message,
click OK.

Storage Location >

The current database does not have a data file storage location set up yet.

Set up a file storage location in the Storage Location dialog, which will cpen
automatically when you click OK on this dialog.

oK
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5. When the Storage Location Type dialog appears, click the + (add) button.

i;i Select Storage Type

Choose File Storage Location

[#1] [[A]

Display Mame Server Mame

Port Type Availzble

Cancel

6. Inthe Create New File Storage dialog, do the following:

a. Inthe Display Name field, type a name for your data file storage folder. See
Configuring MDC File Server on page 5.

b. Inthe Server Name field, type the exact name of your computer (local computer

name).
c. Inthe Port field, type 9200.
d. Tofinish, click OK.

Create Mew File Storage

Display Mame: | FileServer
Server Mame: | DESKTOP-GCY5EII2
Port: | 5200 |

Cancel

7. Inthe Storage Location Type dialog, for your file storage entry, confirm that under the

Available heading, Yes appears.

8. To finish, select your file storage entry row and click OK.
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Importing Data Files

The Clampfit Advanced Analysis Software installer includes a few sample macros to use to
familiarize yourself with the Batch Analysis functionality. To use these sample macros the
first time, you must import the provided sample data files. When you import your own data
files they must be .abf files from Clampex Software.

The following procedure uses the imported sample data Peak Data to be used with the
installed sample macro DemoPeak.These same procedures apply to any other imported
sample data used with any of the other corresponding sample macros. Where you see Peak
Data in the following procedure you can select an alternative data folder.

To import data files:

1. Inthe Batch Analysis dialog, select File > Import Data > Entire Folder.

2. Navigate to and select C:\Program Files\Molecular Devices\pCLAMP 11\Sample
Macros\Peak Data.

3. Click Open.

* Tip: Windows 10 users, if clicking Open fails, double-click on Peak Data.

4. When the import confirmation dialog appears, click OK.

Batch Analysis >

o 5 of 5 files were successfully imported.

] 4
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Running a Sample Macro

10

The following procedure uses the imported sample data Peak Data with the installed sample
macro DemoPeak. See Importing Data Files on page 9. These same procedures apply to any
other imported sample data used with any of the other corresponding sample macros.

Where you see DemoPeak in the following procedure select an alternative macro.

To run a sample macro:

1. Inthetop left quadrant of the Batch Analysis window under Data Selector, double-click
on the data folder you imported to load the Trials.

T3 Batch Analysis - [Unsaved Dataset2] =3 R
€3 File Edit View Datoset TriolEditing Analysis Mscros Database Window Help BEE
60 -~ F @
Data Selector (=] . —— G
[ 2017-03-19 - [Trisk: Date] Smper: e EEIE
Analyze Status Triak Name Trisk Dste Trial: Time Acquisition Program  Acquisition Version Acquisition Mode
17919005.abf  2017-09_. 151224 Clampex 10.7 Gap-free
Yes  OK  17019006.abf  207-09.. 151230  Clampex 107 Gap-free
Yes  OK  17919007.abf  207-09.. 151250  Clampex 107 Gap-free
Yes  OK  17919008.abf  2017-09.. 151303  Clampex 107 Gap-free
Yes  OK  17019009.abf  2017-00.. 154315  Clampex 107 Gap-free
o i v
19985 s AD9sEss 491168 A1987Ts
11.0pA ASS5pA 9.2 pA A-12pA
1 2 3 4
8000
= g ~la00
0 -
0 i [ g 10
Time (s)
B W v
13 " ¥ Triats | @ Cell Procedures | BT Dataset Results
Bt vato [ anaeis Trials'5 _ Cell Procedures:5
2. Inthe bottom left, click the Analysis tab.
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In the Macros panel, in the Sample tree, right-click on DemoPeak and select Run Macro.

When a macro runs successfully, the lower right panel displays the measurements table
and associated graph.

3 Batch Analysis - [Unsaved Dataset2] =0 R ==
O3 File Edit View Dataset TrialEditing Analysis Macros Datsbase Window Help [Cl=]x]
5 &0/ -~ F @

[3 Command History ﬂ[ﬂ Temporary: Cell Procedures
43 1 DemePeak

Analyze Status
Yes ]
Ves ]

ves |
Yes ]

M

<
[ DI v [EEER XY

'
Cell Procedure Results: 52
@ User 1.4: Measurements a Measurements
Startor . Time of Sp—
8, Sheret 54 Trial N, | T7ace o ?:;::(fcm == m;zm pea oS = & ek
G Sample (the Help menu has directions for sll sample [ s Teace O | Tt (51) | rent ) | (Troger | o)
4 DemoPeak s) (S1R1) (ms)|
N Demo To43458940 T ooo0o0| oooo00 | S73s30| 573830 | Teeeevord ror
LTP Demo. K
&
8796-
0
7 S 5
— - Time of Peak (CP) (5 )
< i, ] 3 AT 1T 1.2: Measurements [
< , ' | ¥ Trials Gf Cell Procedures | Ry D. |
Biosta S Analysis

Trials:5  Cell Procedures: 5
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Creating a Macro

Any number of commands from the Analysis menu can be tied together as a single analysis
sequence and stored in a macro. These new macros get stored in the Macros pane of the
Analysis tab.

To create a macro:
1. Inthe Batch Analysis dialog, select Macros > Record.

2. When the Record Macro dialog appears, type your new macro name in the Name field.
Do not press <Enter>.

I | et

Name: | TESTMACRO

3. Goto the Analysis menu and select options as needed and specify settings as needed.
The steps appear in the Record Macro dialog as they are added.

I | I

Name: | TESTMACRO

1 Measurements
i 2 Add Graph
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4. When you are finished adding steps, in the Record Macro dialog, click the Stop button.
Your new macro saves and appears in the Macros pane of the Analysis tab under User.

O D B> G | e
B} User

. - TESTMACRO
- Shared
- Sample (the Help menu has direct

£ >

£fData i Analysis

Ready

* Tip: Macros in the User tree are editable.
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Modifying the Sample Macros

Macros in the Sample tree are read-only. To view macro step settings, in the Macros pane of
the Analysis tab, expand the macro name and double-click on the step name.

& Batch Analysis - [Unsaved Dataset2]
[ File Edit View Dataset Trial Editing Analysis Macros Database

&9 ~~ T @
Command History @@

Analyze Status

[=IE=]

Window Help

Temporary: Cell Procedures
144 1 DemoPeak

Yes ]
Yes | Measurements (read only) ==
Yo | [Wessrements | auput| Baa |
easurements
Nes utput ata
Yes Search Number 1 %
From: 4911600 2] ms (sample time = 4911600 ms)
Tor 6879300 2] ms (sample time = 679.300 ms)
eak ampliuds funt) (] Masimum decay slope [urit/ms)
ime of peak [ms) ] Time of masimum decay slape (ms]
[ &ntipeak amplitude [uni] (7] Slope [unit/ms)
[ Time of antipeak [ms] (7] Baseline [unit]
] Mean funit) [C] Rise slope [urit/ms] I =
7] Standard devistion [urit) [l Rise time [ms)
[7] &rea (urit - ms) (7] Decay slope (urit/ms) »
} Eil 10
[ Half-width (ms] (] Decay time ms]
D ME [ Mavimun rise slope (unit/ms] [7] Ewent duration (ms) 50/
7] Time of maximum rise slope [ms]
O3 User — Select Al Select None Measurements
&7 Shared Peak Polarity # Peak (STR1)
-0 Sample (the Help menu has directions for all sample Signak INO []an @ Positive () Negative () Absolute
o DET;:“" g Baseine
£} 1 Messurements o @ Meanleve! From: 1998500 2 ms [sample ine = 199.500 ms)
4} 2 Add Graph 2
% VDemo 2 © Firedat 0o Tor 2343800 (2] msfsampls fime = 2343300 ms) .
z
G148 LTP Demo = Smoothing Window
& [ Apply 3
7
8
B [] Use acepisiion meastrements seitings for each tial
10 T T
i 5 8
= Time of Peak (CP) (<)
“ 12
« I

e " | ¥ Trials gf Cell Procedures

Dataset Results

Trialss 5 Cell Precedures: 5
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To edit macros, right-click on the sample macro name and select Make a User copy . It is
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copied to the User macro tree, where you can open the Analysis steps within the macro to
reconfigure them. Click OK to save changes.

Measurements

Measurements  Output  Data
[+ Search Number: :

Range: | Curzors 3.4

Peak amplitude [pd)
Time of peak [mz]
[] &ntipeak, amplitude [pé)
[ Time of antipeak [ms]
[ Mean [pa4)
[ 5tandard deviation [pd)
[ &rea [pa. - ms]
Half-width [mz)
b aximum rize slope [pd/ms]
Time of masimum rize slope [mz)

Peak Polarity

Signal: 130

Bazeline

(®) Mean level: |Cursarz 1.2
() Fised at: .00

Smoathing #indow
(] &pply

Import fram current tial

From: |4911.600 = mz [zample time = 4311.600 ms)
Tor  |g279.300 = s [zample time = 373,300 ms)

[] M aximum decay slope [pé/ms)
[ Time of masimum decay slope [ms)

e

Slope [pd/me]
[J Baseline [pa)
Rise slope [péms) } 7 5
: E4 : 4
[ Rise time [ms)] From: = To =

Decay slope [pd./msz)
[] Decay time [mz]
[J Event duration [ms) a0

Select Al

Al (® Positive () Negative () Absolute

~ | From: (1958500 = me [zample time = 1993500 ms)
To 2943900 2 me [sample time = 2343900 ms)

Uze acquisiion measurements settings for each tral

Cancel

Select Mone

You can rename the macros and change their comments from the right-click menu as well.

You cannot add or remove steps to a macro when you edit it. To do this, record a new macro

and use Run Step to copy the steps from the existing macro into the new one. Skip steps

that are not wanted, or add new steps from the dialogs in the Analysis menu.

To delete a macro from the User tree, select the name and press Delete.
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