vcDP5_USB_Repeat Test C++ SDK: Main Page

vcDP5_USB_Repeat Test C++ SDK 20170920
DPP USB C++ Demonstration
  • Main Page
  • Namespaces
  • Classes
  • Files
vcDP5_USB_Repeat Test C++ SDK Documentation

vcDP5_USB_Repeat

vcDP5_USB_Repeat is a MFC Dialog application that demonstrates how Amptek DPP communications can be easily integrated into other programs.

vcDP5_USB_Repeat also demonstrates repeat spectrum acquisition.

Sockets and Serial Communications has been remove to simplify communications.

What vcDP5_USB does.

vcDP5_USB_Repeat communicates to a DPP device and demonstrates a minimal set of acquisition related commands.

vcDP5_USB_Repeat Classes

  • CvcDP5Dlg (Central function control.)
  • CDppWinUSB (Windows WinUSB communication class.)
  • CDP5Status (DPP status processing.)
  • CParsePacket (DPP packet parsing.)
  • CDP5Protocol (Defines and implements DPP protocol.)
  • CSendCommand (Generates command packet to be sent.)

vcDP5_USB_Repeat Main Function

  • CvcDP5Dlg (DPP MFC Dialog Demonstration.)

More Information

http://amptek.com/products/dp5-digital-pulse-processor-software/ Amptek Software Page

Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringSplit Namespace Reference

  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Typedefs | Functions
stringSplit Namespace Reference

Typedefs

typedef string::size_type(string::* | FindToken )(const string &strDelimiter, string::size_type sztOffset) const

Functions

vector< string > | Split (const string &strIn, const string &strDelimiters, bool bRemoveEmpty=false, bool bMatchAll=false)

Typedef Documentation

typedef string::size_type(string::* stringSplit::FindToken)(const string &strDelimiter, string::size_type sztOffset) const

Definition at line 7 of file stringSplit.h.

Function Documentation

vector<string> stringSplit::Split | ( | const string & | strIn,
 |  | const string & | strDelimiters,
 |  | bool | bRemoveEmpty = false,
 |  | bool | bMatchAll = false
 | ) |  |

Definition at line 13 of file stringSplit.h.

Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
Here is a list of all namespace members with links to the namespace documentation for each member:
  • FindToken : stringSplit
  • Split() : stringSplit
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Split() : stringSplit
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • FindToken : stringSplit
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _CONFIG_OPTIONS Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_CONFIG_OPTIONS Struct Reference

#include <SendCommand.h>

List of all members.

Public Attributes

bool | PC5_PRESENT
int | DppType
if true pc5 commands are supported
string | HwCfgDP5Out
device type indicator
bool | SendCoarseFineGain
custom configuration string
bool | isDP5_RevDxGains
false=Send GAIN, true=Send GAIA,GAIF
unsigned char | DPP_ECO
use dp5 dx gains

Detailed Description

Definition at line 6 of file SendCommand.h.

Member Data Documentation

unsigned char _CONFIG_OPTIONS::DPP_ECO

use dp5 dx gains

Definition at line 13 of file SendCommand.h.

int _CONFIG_OPTIONS::DppType

if true pc5 commands are supported

Definition at line 9 of file SendCommand.h.

string _CONFIG_OPTIONS::HwCfgDP5Out

device type indicator

Definition at line 10 of file SendCommand.h.

bool _CONFIG_OPTIONS::isDP5_RevDxGains

false=Send GAIN, true=Send GAIA,GAIF

Definition at line 12 of file SendCommand.h.

bool _CONFIG_OPTIONS::PC5_PRESENT

Definition at line 8 of file SendCommand.h.

bool _CONFIG_OPTIONS::SendCoarseFineGain

custom configuration string

Definition at line 11 of file SendCommand.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/SendCommand.h
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _COORD_LONG Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_COORD_LONG Struct Reference

#include <PlotCanvas.h>

List of all members.

Public Attributes

long | X
long | Y

Detailed Description

Definition at line 38 of file PlotCanvas.h.

Member Data Documentation

long _COORD_LONG::X

Definition at line 39 of file PlotCanvas.h.

long _COORD_LONG::Y

Definition at line 40 of file PlotCanvas.h.

The documentation for this struct was generated from the following file:
  • Controls/PlotCanvas.h
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _DiagDataType Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_DiagDataType Struct Reference

#include <DP5Status.h>

List of all members.

Public Attributes

float | ADC_V [12]
float | PC5_V [4]
bool | PC5_PRESENT
long | PC5_SN
unsigned char | Firmware
unsigned char | FPGA
bool | SRAMTestPass
long | SRAMTestData
int | TempOffset
string | strTempRaw
string | strTempCal
bool | PC5Initialized
float | PC5DCAL
bool | IsPosHV
bool | Is8_5VPreAmp
bool | Sup9VOn
bool | PreAmpON
bool | HVOn
bool | TECOn
unsigned char | DiagData [192]

Detailed Description

Definition at line 80 of file DP5Status.h.

Member Data Documentation

float _DiagDataType::ADC_V[12]

Definition at line 82 of file DP5Status.h.

unsigned char _DiagDataType::DiagData[192]

Definition at line 101 of file DP5Status.h.

unsigned char _DiagDataType::Firmware

Definition at line 86 of file DP5Status.h.

unsigned char _DiagDataType::FPGA

Definition at line 87 of file DP5Status.h.

bool _DiagDataType::HVOn

Definition at line 99 of file DP5Status.h.

bool _DiagDataType::Is8_5VPreAmp

Definition at line 96 of file DP5Status.h.

bool _DiagDataType::IsPosHV

Definition at line 95 of file DP5Status.h.

bool _DiagDataType::PC5_PRESENT

Definition at line 84 of file DP5Status.h.

long _DiagDataType::PC5_SN

Definition at line 85 of file DP5Status.h.

float _DiagDataType::PC5_V[4]

Definition at line 83 of file DP5Status.h.

float _DiagDataType::PC5DCAL

Definition at line 94 of file DP5Status.h.

bool _DiagDataType::PC5Initialized

Definition at line 93 of file DP5Status.h.

bool _DiagDataType::PreAmpON

Definition at line 98 of file DP5Status.h.

long _DiagDataType::SRAMTestData

Definition at line 89 of file DP5Status.h.

bool _DiagDataType::SRAMTestPass

Definition at line 88 of file DP5Status.h.

string _DiagDataType::strTempCal

Definition at line 92 of file DP5Status.h.

string _DiagDataType::strTempRaw

Definition at line 91 of file DP5Status.h.

bool _DiagDataType::Sup9VOn

Definition at line 97 of file DP5Status.h.

bool _DiagDataType::TECOn

Definition at line 100 of file DP5Status.h.

int _DiagDataType::TempOffset

Definition at line 90 of file DP5Status.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Status.h
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _DppStateType Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_DppStateType Struct Reference

#include <ParsePacket.h>

List of all members.

Public Attributes

CommType Interface
string | strPort
unsigned long | ReqProcess
bool | HaveScopeData
bool | ScopeAutoRearm
bool | ScopeOverFlow

Detailed Description

Definition at line 33 of file ParsePacket.h.

Member Data Documentation

bool _DppStateType::HaveScopeData

Definition at line 37 of file ParsePacket.h.

CommType _DppStateType::Interface

Definition at line 34 of file ParsePacket.h.

unsigned long _DppStateType::ReqProcess

Definition at line 36 of file ParsePacket.h.

bool _DppStateType::ScopeAutoRearm

Definition at line 38 of file ParsePacket.h.

bool _DppStateType::ScopeOverFlow

Definition at line 39 of file ParsePacket.h.

string _DppStateType::strPort

Definition at line 35 of file ParsePacket.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/ParsePacket.h
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _Packet_In Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_Packet_In Struct Reference

#include <DP5Protocol.h>

List of all members.

Public Attributes

unsigned char | PID1
unsigned char | PID2
unsigned short | LEN
unsigned char | STATUS
unsigned char | DATA [32768]
long | CheckSum

Detailed Description

Definition at line 276 of file DP5Protocol.h.

Member Data Documentation

long _Packet_In::CheckSum

Definition at line 282 of file DP5Protocol.h.

unsigned char _Packet_In::DATA[32768]

Definition at line 281 of file DP5Protocol.h.

unsigned short _Packet_In::LEN

Definition at line 279 of file DP5Protocol.h.

unsigned char _Packet_In::PID1

Definition at line 277 of file DP5Protocol.h.

unsigned char _Packet_In::PID2

Definition at line 278 of file DP5Protocol.h.

unsigned char _Packet_In::STATUS

Definition at line 280 of file DP5Protocol.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _SpectrumFileType Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_SpectrumFileType Struct Reference

#include <vcDP5Dlg.h>

List of all members.

Public Attributes

string | strTag
string | strDescription
short | m_iNumChan
unsigned long | SerialNumber
string | strStartTime
string | strSpectrumConfig
string | strSpectrumStatus

Detailed Description

Definition at line 20 of file vcDP5Dlg.h.

Member Data Documentation

short _SpectrumFileType::m_iNumChan

Definition at line 23 of file vcDP5Dlg.h.

unsigned long _SpectrumFileType::SerialNumber

Definition at line 24 of file vcDP5Dlg.h.

string _SpectrumFileType::strDescription

Definition at line 22 of file vcDP5Dlg.h.

string _SpectrumFileType::strSpectrumConfig

Definition at line 26 of file vcDP5Dlg.h.

string _SpectrumFileType::strSpectrumStatus

Definition at line 27 of file vcDP5Dlg.h.

string _SpectrumFileType::strStartTime

Definition at line 25 of file vcDP5Dlg.h.

string _SpectrumFileType::strTag

Definition at line 21 of file vcDP5Dlg.h.

The documentation for this struct was generated from the following file:
  • vcDP5Dlg.h
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _WINUSB_PIPE_INFORMATION Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_WINUSB_PIPE_INFORMATION Struct Reference

#include <WINUSBIO.H>

List of all members.

Public Attributes

USBD_PIPE_TYPE | PipeType
UCHAR | PipeId
USHORT | MaximumPacketSize
UCHAR | Interval

Detailed Description

Definition at line 71 of file WINUSBIO.H.

Member Data Documentation

UCHAR _WINUSB_PIPE_INFORMATION::Interval

Definition at line 75 of file WINUSBIO.H.

USHORT _WINUSB_PIPE_INFORMATION::MaximumPacketSize

Definition at line 74 of file WINUSBIO.H.

UCHAR _WINUSB_PIPE_INFORMATION::PipeId

Definition at line 73 of file WINUSBIO.H.

USBD_PIPE_TYPE _WINUSB_PIPE_INFORMATION::PipeType

Definition at line 72 of file WINUSBIO.H.

The documentation for this struct was generated from the following file:
  • DeviceIO/WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: _WINUSB_SETUP_PACKET Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
_WINUSB_SETUP_PACKET Struct Reference

#include <WINUSB.H>

List of all members.

Public Attributes

UCHAR | RequestType
UCHAR | Request
USHORT | Value
USHORT | Index
USHORT | Length

Detailed Description

Definition at line 50 of file WINUSB.H.

Member Data Documentation

USHORT _WINUSB_SETUP_PACKET::Index

Definition at line 54 of file WINUSB.H.

USHORT _WINUSB_SETUP_PACKET::Length

Definition at line 55 of file WINUSB.H.

UCHAR _WINUSB_SETUP_PACKET::Request

Definition at line 52 of file WINUSB.H.

UCHAR _WINUSB_SETUP_PACKET::RequestType

Definition at line 51 of file WINUSB.H.

USHORT _WINUSB_SETUP_PACKET::Value

Definition at line 53 of file WINUSB.H.

The documentation for this struct was generated from the following file:
  • DeviceIO/WINUSB.H
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CAboutDlg Class Reference

  • Class List
  • Class Index
  • Class Members
Public Types | Public Member Functions | Protected Member Functions
CAboutDlg Class Reference

List of all members.

Public Types

enum | { IDD = IDD_ABOUTBOX }

Public Member Functions

CAboutDlg ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Detailed Description

Definition at line 25 of file vcDP5Dlg.cpp.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 31 of file vcDP5Dlg.cpp.

Constructor & Destructor Documentation

CAboutDlg::CAboutDlg ( )

Definition at line 41 of file vcDP5Dlg.cpp.

Member Function Documentation

void CAboutDlg::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 45 of file vcDP5Dlg.cpp.

The documentation for this class was generated from the following file:
  • vcDP5Dlg.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: cAnimWnd Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes
cAnimWnd Class Reference

#include <AnimWnd.h>

Collaboration diagram for cAnimWnd:
[legend]

List of all members.

Public Member Functions

cAnimWnd ()
void | SetImageList (UINT BitmapID, short Size, short Sizey, COLORREF TransparentColor=-1)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
int | GetImageCount ()
BOOL | StopAnim ()
INT_PTR | StartAnim (short Delay=50)
virtual | ~cAnimWnd ()

Protected Member Functions

afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnPaint ()

Protected Attributes

int | m_ImageIndex
COLORREF | m_TransparentColor
short | m_Width
short | m_Height
CBitmap | m_Bitmap
cMemDC * m_MemDC

Detailed Description

Definition at line 26 of file AnimWnd.h.

Constructor & Destructor Documentation

cAnimWnd::cAnimWnd ( )

Definition at line 10 of file AnimWnd.cpp.

cAnimWnd::~cAnimWnd ( ) [virtual]

Definition at line 16 of file AnimWnd.cpp.

Member Function Documentation

BOOL cAnimWnd::Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL
 | ) |  | [virtual]

Definition at line 107 of file AnimWnd.cpp.

Here is the caller graph for this function:

int cAnimWnd::GetImageCount ( )

Definition at line 120 of file AnimWnd.cpp.

Here is the caller graph for this function:

void cAnimWnd::OnPaint ( ) [protected]

Definition at line 55 of file AnimWnd.cpp.

void cAnimWnd::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 74 of file AnimWnd.cpp.

Here is the call graph for this function:

void cAnimWnd::SetImageList | ( | UINT | BitmapID,
 |  | short | Size,
 |  | short | Sizey,
 |  | COLORREF | TransparentColor = -1
 | ) |  |

Definition at line 37 of file AnimWnd.cpp.

Here is the caller graph for this function:

INT_PTR cAnimWnd::StartAnim ( short Delay = 50 )

Definition at line 93 of file AnimWnd.cpp.

Here is the caller graph for this function:

BOOL cAnimWnd::StopAnim ( )

Definition at line 99 of file AnimWnd.cpp.

Member Data Documentation

CBitmap cAnimWnd::m_Bitmap [protected]

Definition at line 40 of file AnimWnd.h.

short cAnimWnd::m_Height [protected]

Definition at line 39 of file AnimWnd.h.

int cAnimWnd::m_ImageIndex [protected]

Definition at line 36 of file AnimWnd.h.

cMemDC* cAnimWnd::m_MemDC [protected]

Definition at line 41 of file AnimWnd.h.

COLORREF cAnimWnd::m_TransparentColor [protected]

Definition at line 37 of file AnimWnd.h.

short cAnimWnd::m_Width [protected]

Definition at line 38 of file AnimWnd.h.

The documentation for this class was generated from the following files:
  • waitdlg/AnimWnd.h
  • waitdlg/AnimWnd.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CAsciiCmdUtilities Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CAsciiCmdUtilities Class Reference

#include <AsciiCmdUtilities.h>

List of all members.

Public Member Functions

CAsciiCmdUtilities (void)
~CAsciiCmdUtilities (void)
std::string | MakeUpper (std::string myString)
Forces all characters to uppercase. (All DPP command must be in upper case.)
std::string | RemWhitespace (std::string strLine)
Removes Whitespace characters from a command string.
std::string | GetDP5CfgStr (std::string strFilename)
Reads a DPP configuration from a file.
std::string | GetDP5ScaStr (std::string strFilename)
Reads a SCA configuration from a file.
std::string | CreateResTestReadBackCmd (bool bSendCoarseFineGain, int DppType)
std::string | CreateFullReadBackCmd (bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
Generates a configuration readback command from a list of all commands.
std::string | CreateFullReadBackCmdMCA8000D (int DppType)
Generates a configuration readback command from a list of all commands.
std::string | RemoveCmd (std::string strCmd, std::string strCfgData)
Remove a specified command from the command stream.
std::string | RemoveCmdByDeviceType (std::string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
Remove illegal commands from the command stream by device type.
std::string | RemoveCmdByDeviceTypeDP5DxK (std::string strCfgDataIn, bool PC5_PRESENT, int DppType)
Remove illegal commands from the command stream by device type.
std::string | Remove_MCA8000D_Cmds (std::string strCfgDataIn, int DppType)
std::string | ReplaceCmdText (std::string strInTextIn, std::string strFrom, std::string strTo)
int | GetCmdChunk (std::string strCmd)
bool | CopyAsciiData (unsigned char Data[], string strCfg, long lLen)
Force string to ASCII bytes.

Detailed Description

Definition at line 18 of file AsciiCmdUtilities.h.

Constructor & Destructor Documentation

CAsciiCmdUtilities::CAsciiCmdUtilities ( void )

Definition at line 3 of file AsciiCmdUtilities.cpp.

CAsciiCmdUtilities::~CAsciiCmdUtilities ( void )

Definition at line 7 of file AsciiCmdUtilities.cpp.

Member Function Documentation

bool CAsciiCmdUtilities::CopyAsciiData | ( | unsigned char | Data[],
 |  | string | strCfg,
 |  | long | lLen
 | ) |  |

Force string to ASCII bytes.

Definition at line 578 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::CreateFullReadBackCmd | ( | bool | PC5_PRESENT,
 |  | int | DppType,
 |  | bool | isDP5_RevDxGains,
 |  | unsigned char | DPP_ECO
 | ) |  |

Generates a configuration readback command from a list of all commands.

Definition at line 202 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::CreateFullReadBackCmdMCA8000D ( int DppType )

Generates a configuration readback command from a list of all commands.

Definition at line 308 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::CreateResTestReadBackCmd | ( | bool | bSendCoarseFineGain,
 |  | int | DppType
 | ) |  |

Definition at line 177 of file AsciiCmdUtilities.cpp.

int CAsciiCmdUtilities::GetCmdChunk ( std::string strCmd )

Definition at line 558 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::GetDP5CfgStr ( std::string strFilename )

Reads a DPP configuration from a file.

Definition at line 42 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::GetDP5ScaStr ( std::string strFilename )

Reads a SCA configuration from a file.

Definition at line 97 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

string CAsciiCmdUtilities::MakeUpper ( std::string myString )

Forces all characters to uppercase. (All DPP command must be in upper case.)

Definition at line 11 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::Remove_MCA8000D_Cmds | ( | std::string | strCfgDataIn,
 |  | int | DppType
 | ) |  |

Definition at line 482 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemoveCmd | ( | std::string | strCmd,
 |  | std::string | strCfgData
 | ) |  |

Remove a specified command from the command stream.

Definition at line 351 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemoveCmdByDeviceType | ( | std::string | strCfgDataIn,
 |  | bool | PC5_PRESENT,
 |  | int | DppType,
 |  | bool | isDP5_RevDxGains,
 |  | unsigned char | DPP_ECO
 | ) |  |

Remove illegal commands from the command stream by device type.

Definition at line 370 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemoveCmdByDeviceTypeDP5DxK | ( | std::string | strCfgDataIn,
 |  | bool | PC5_PRESENT,
 |  | int | DppType
 | ) |  |

Remove illegal commands from the command stream by device type.

Definition at line 432 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

string CAsciiCmdUtilities::RemWhitespace ( std::string strLine )

Removes Whitespace characters from a command string.

Definition at line 21 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

std::string CAsciiCmdUtilities::ReplaceCmdText | ( | std::string | strInTextIn,
 |  | std::string | strFrom,
 |  | std::string | strTo
 | ) |  |

Definition at line 532 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • DeviceIO/AsciiCmdUtilities.h
  • DeviceIO/AsciiCmdUtilities.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CDP5Protocol Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CDP5Protocol Class Reference

#include <DP5Protocol.h>

Collaboration diagram for CDP5Protocol:
[legend]

List of all members.

Public Member Functions

CDP5Protocol (void)
~CDP5Protocol (void)

Public Attributes

short | InPacketType
Inidicates the incoming packet type;.
unsigned char | PacketIn [24648]
long | RS232BytesInBuffer
Tracks the RS232 number of bytes in the input buffer.
long | RS232_RThreshold
RS232 receive buffer threshold.
bool | RS232HeaderReceived
RS232 header received indicator.
short | RS232PacketPtr
Points to the current incoming data save position in the input buffer.
bool | ScaleAuto
Auto plot scale indicator.
unsigned char | Scope [2048]
Oscilloscope data buffer.
unsigned char | MiscData [512]
Miscellaneous data buffer.
bool | CommError
Communications error indicator.
unsigned char | BufferOUT [520]
Output data buffer.
Spec SPECTRUM
Spectrum data buffer.
Packet_In PIN
Packet input buffer.
bool | ACK_Received
ACK received indicator.
bool | Packet_Received
Packet received indicator.
bool | Timeout_flag
Communication timeout error indicator flag.
int | UDP_offset
bool | Netfinder_active
int | Netfinder_Seq
bool | USB_Default_Timeout
USB default timeout is the longest time period that the USB interface will wait for a transaction.

Detailed Description

Definition at line 302 of file DP5Protocol.h.

Constructor & Destructor Documentation

CDP5Protocol::CDP5Protocol ( void )

Definition at line 3 of file DP5Protocol.cpp.

CDP5Protocol::~CDP5Protocol ( void )

Definition at line 7 of file DP5Protocol.cpp.

Member Data Documentation

bool CDP5Protocol::ACK_Received

ACK received indicator.

Definition at line 338 of file DP5Protocol.h.

unsigned char CDP5Protocol::BufferOUT[520]

Output data buffer.

Definition at line 331 of file DP5Protocol.h.

bool CDP5Protocol::CommError

Communications error indicator.

Definition at line 329 of file DP5Protocol.h.

short CDP5Protocol::InPacketType

Inidicates the incoming packet type;.

Definition at line 309 of file DP5Protocol.h.

unsigned char CDP5Protocol::MiscData[512]

Miscellaneous data buffer.

Definition at line 327 of file DP5Protocol.h.

bool CDP5Protocol::Netfinder_active

Definition at line 345 of file DP5Protocol.h.

int CDP5Protocol::Netfinder_Seq

Definition at line 346 of file DP5Protocol.h.

bool CDP5Protocol::Packet_Received

Packet received indicator.

Definition at line 340 of file DP5Protocol.h.

unsigned char CDP5Protocol::PacketIn[24648]

Definition at line 311 of file DP5Protocol.h.

Packet_In CDP5Protocol::PIN

Packet input buffer.

Definition at line 335 of file DP5Protocol.h.

long CDP5Protocol::RS232_RThreshold

RS232 receive buffer threshold.

Definition at line 316 of file DP5Protocol.h.

long CDP5Protocol::RS232BytesInBuffer

Tracks the RS232 number of bytes in the input buffer.

Definition at line 314 of file DP5Protocol.h.

bool CDP5Protocol::RS232HeaderReceived

RS232 header received indicator.

Definition at line 318 of file DP5Protocol.h.

short CDP5Protocol::RS232PacketPtr

Points to the current incoming data save position in the input buffer.

Definition at line 320 of file DP5Protocol.h.

bool CDP5Protocol::ScaleAuto

Auto plot scale indicator.

Definition at line 323 of file DP5Protocol.h.

unsigned char CDP5Protocol::Scope[2048]

Oscilloscope data buffer.

Definition at line 325 of file DP5Protocol.h.

Spec CDP5Protocol::SPECTRUM

Spectrum data buffer.

Definition at line 333 of file DP5Protocol.h.

bool CDP5Protocol::Timeout_flag

Communication timeout error indicator flag.

Definition at line 342 of file DP5Protocol.h.

int CDP5Protocol::UDP_offset

Definition at line 344 of file DP5Protocol.h.

bool CDP5Protocol::USB_Default_Timeout

USB default timeout is the longest time period that the USB interface will wait for a transaction.

Definition at line 349 of file DP5Protocol.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DP5Protocol.h
  • DeviceIO/DP5Protocol.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CDP5Status Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CDP5Status Class Reference

#include <DP5Status.h>

Collaboration diagram for CDP5Status:
[legend]

List of all members.

Public Member Functions

CDP5Status (void)
~CDP5Status (void)
void | Process_Status (DP4_FORMAT_STATUS *m_DP5_Status)
Convert a DPP status packet into DP4_FORMAT_STATUS data.
string | DP5_Dx_OptionFlags (unsigned char DP5_Dx_Options)
string | ShowStatusValueStrings (DP4_FORMAT_STATUS m_DP5_Status)
Convert DP4_FORMAT_STATUS data into a status display string.
string | PX5_OptionsString (DP4_FORMAT_STATUS m_DP5_Status)
string | GetStatusValueStrings (DP4_FORMAT_STATUS m_DP5_Status)
void | Process_Diagnostics (Packet_In PIN, DiagDataType *dd, int device_type)
Convert a DPP diagnostic data packet into DiagDataType data.
string | DiagnosticsToString (DiagDataType dd, int device_type)
Convert DiagDataType data into a diagnostic display string.
string | DiagStrPX5Option (DiagDataType dd, int device_type)
Convert PX5 Options into a display string.
string | FmtHvPwr (float fVal)
Format a high voltage power value.
string | FmtPc5Pwr (float fVal)
Format a pc5 power value.
string | FmtPc5Temp (float fVal)
Format a pc5 temperature value.
string | FmtHex (long FmtHex, long HexDig)
Format a hexadecimal value.
string | FmtLng (long lVal)
Format a long value.
string | VersionToStr (unsigned char bVersion)
Format a version number value.
string | OnOffStr (bool bOn)
Format an OnOFF indicator value.
string | IsAorB (bool bIsA, string strA, string strB)
Format a boolean indicator value.
string | GetDeviceNameFromVal (int DeviceTypeVal)
Format a device type indicator as a device name string.
string | DisplayBufferArray (unsigned char buffer[], unsigned long bufSizeIn)
Format an string array from a data byte array of values.
void | SaveStringDataToFile (string strData)
Saves a data string to a default file (vcDP5_Data.txt).

Public Attributes

CDppUtilities DppUtil
Utilities to help data processing.
DP4_FORMAT_STATUS m_DP5_Status
DPP status storage.
DiagDataType DiagData
DPP diagnostic data storage.

Detailed Description

Definition at line 104 of file DP5Status.h.

Constructor & Destructor Documentation

CDP5Status::CDP5Status ( void )

Definition at line 9 of file DP5Status.cpp.

CDP5Status::~CDP5Status ( void )

Definition at line 13 of file DP5Status.cpp.

Member Function Documentation

string CDP5Status::DiagnosticsToString | ( | DiagDataType | dd,
 |  | int | device_type
 | ) |  |

Convert DiagDataType data into a diagnostic display string.

Definition at line 447 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::DiagStrPX5Option | ( | DiagDataType | dd,
 |  | int | device_type
 | ) |  |

Convert PX5 Options into a display string.

Definition at line 535 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::DisplayBufferArray | ( | unsigned char | buffer[],
 |  | unsigned long | bufSizeIn
 | ) |  |

Format an string array from a data byte array of values.

Definition at line 683 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::DP5_Dx_OptionFlags ( unsigned char DP5_Dx_Options )

Definition at line 152 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::FmtHex | ( | long | FmtHex,
 |  | long | HexDig
 | ) |  |

Format a hexadecimal value.

Definition at line 605 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtHvPwr ( float fVal )

Format a high voltage power value.

Definition at line 581 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtLng ( long lVal )

Format a long value.

Definition at line 616 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtPc5Pwr ( float fVal )

Format a pc5 power value.

Definition at line 589 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtPc5Temp ( float fVal )

Format a pc5 temperature value.

Definition at line 597 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::GetDeviceNameFromVal ( int DeviceTypeVal )

Format a device type indicator as a device name string.

Definition at line 654 of file DP5Status.cpp.

Here is the caller graph for this function:

string CDP5Status::GetStatusValueStrings ( DP4_FORMAT_STATUS m_DP5_Status )

Definition at line 259 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::IsAorB | ( | bool | bIsA,
 |  | string | strA,
 |  | string | strB
 | ) |  |

Format a boolean indicator value.

Definition at line 645 of file DP5Status.cpp.

Here is the caller graph for this function:

string CDP5Status::OnOffStr ( bool bOn )

Format an OnOFF indicator value.

Definition at line 636 of file DP5Status.cpp.

Here is the caller graph for this function:

void CDP5Status::Process_Diagnostics | ( | Packet_In | PIN,
 |  | DiagDataType * | dd,
 |  | int | device_type
 | ) |  |

Convert a DPP diagnostic data packet into DiagDataType data.

Definition at line 332 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDP5Status::Process_Status ( DP4_FORMAT_STATUS * m_DP5_Status )

Convert a DPP status packet into DP4_FORMAT_STATUS data.

Definition at line 17 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::PX5_OptionsString ( DP4_FORMAT_STATUS m_DP5_Status )

Definition at line 221 of file DP5Status.cpp.

Here is the caller graph for this function:

void CDP5Status::SaveStringDataToFile ( string strData )

Saves a data string to a default file (vcDP5_Data.txt).

Definition at line 705 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::ShowStatusValueStrings ( DP4_FORMAT_STATUS m_DP5_Status )

Convert DP4_FORMAT_STATUS data into a status display string.

Definition at line 174 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::VersionToStr ( unsigned char bVersion )

Format a version number value.

Definition at line 624 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

DiagDataType CDP5Status::DiagData

DPP diagnostic data storage.

Definition at line 116 of file DP5Status.h.

CDppUtilities CDP5Status::DppUtil

Utilities to help data processing.

Definition at line 111 of file DP5Status.h.

DP4_FORMAT_STATUS CDP5Status::m_DP5_Status

DPP status storage.

Definition at line 114 of file DP5Status.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DP5Status.h
  • DeviceIO/DP5Status.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CDppLibUsb Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CDppLibUsb Class Reference

#include <DppLibUsb.h>

List of all members.

Public Member Functions

CDppLibUsb (void)
~CDppLibUsb (void)
int | InitializeLibusb ()
void | DeinitializeLibusb ()
libusb_device_handle * | FindUSBDevice (int idxAmptekDevice)
void | CloseUSBDevice (libusb_device_handle *devh)
int | SendPacketUSB (libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[])
bool | isAmptekDP5Device (libusb_device_descriptor desc)
int | CountDP5LibusbDevices ()
void | PrintDevices ()
const char * | libusb_strerror (enum libusb_error error_code)

Public Attributes

unsigned char | data_in [MAX_BULK_IN_TRANSFER_SIZE]
unsigned char | data_out [MAX_BULK_OUT_TRANSFER_SIZE]
libusb_device_handle * | DppLibusbHandle
int | NumDevices
int | CurrentDevice
bool | bLibusbReady
bool | bDeviceReady
char | LastLibUsbError [256]
bool | bDeviceConnected

Detailed Description

Definition at line 36 of file DppLibUsb.h.

Constructor & Destructor Documentation

CDppLibUsb::CDppLibUsb ( void )

Definition at line 3 of file DppLibUsb.cpp.

CDppLibUsb::~CDppLibUsb ( void )

Definition at line 7 of file DppLibUsb.cpp.

Member Function Documentation

void CDppLibUsb::CloseUSBDevice ( libusb_device_handle * devh )

Definition at line 91 of file DppLibUsb.cpp.

Here is the call graph for this function:

int CDppLibUsb::CountDP5LibusbDevices ( )

Definition at line 154 of file DppLibUsb.cpp.

Here is the call graph for this function:

void CDppLibUsb::DeinitializeLibusb ( )

Definition at line 25 of file DppLibUsb.cpp.

libusb_device_handle * CDppLibUsb::FindUSBDevice ( int idxAmptekDevice )

Definition at line 32 of file DppLibUsb.cpp.

Here is the call graph for this function:

int CDppLibUsb::InitializeLibusb ( )

Definition at line 13 of file DppLibUsb.cpp.

Here is the call graph for this function:

bool CDppLibUsb::isAmptekDP5Device ( libusb_device_descriptor desc )

Definition at line 142 of file DppLibUsb.cpp.

Here is the caller graph for this function:

const char * CDppLibUsb::libusb_strerror ( enum libusb_error error_code )

Definition at line 207 of file DppLibUsb.cpp.

Here is the caller graph for this function:

void CDppLibUsb::PrintDevices ( )

Definition at line 179 of file DppLibUsb.cpp.

Here is the call graph for this function:

int CDppLibUsb::SendPacketUSB | ( | libusb_device_handle * | devh,
 |  | unsigned char | data_out[],
 |  | unsigned char | data_in[]
 | ) |  |

Definition at line 103 of file DppLibUsb.cpp.

Member Data Documentation

bool CDppLibUsb::bDeviceConnected

Definition at line 51 of file DppLibUsb.h.

bool CDppLibUsb::bDeviceReady

Definition at line 49 of file DppLibUsb.h.

bool CDppLibUsb::bLibusbReady

Definition at line 48 of file DppLibUsb.h.

int CDppLibUsb::CurrentDevice

Definition at line 47 of file DppLibUsb.h.

unsigned char CDppLibUsb::data_in[MAX_BULK_IN_TRANSFER_SIZE]

Definition at line 42 of file DppLibUsb.h.

unsigned char CDppLibUsb::data_out[MAX_BULK_OUT_TRANSFER_SIZE]

Definition at line 43 of file DppLibUsb.h.

libusb_device_handle* CDppLibUsb::DppLibusbHandle

Definition at line 45 of file DppLibUsb.h.

char CDppLibUsb::LastLibUsbError[256]

Definition at line 50 of file DppLibUsb.h.

int CDppLibUsb::NumDevices

Definition at line 46 of file DppLibUsb.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DppLibUsb.h
  • DeviceIO/DppLibUsb.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CDppSlowThreshold Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CDppSlowThreshold Class Reference

#include <DppSlowThreshold.h>

List of all members.

Public Member Functions

CDppSlowThreshold (void)
~CDppSlowThreshold (void)
UCHAR | GetSlowChThreshold ()
void | SetSlowChThreshold (UCHAR SlowChThresholdVal)
void | Thresholds_Setup (CSpinButtonCtrl *udThresholdObj, CEdit *lblThresholdObj, CEdit *lblThresholdChannelsObj)
void | SetSlowChThresholdFromStr (CString strSlowThresh)
void | SetSlowChThresholdFromVal (int intSlowThresh)
void | SetSlowChThresholdConfigFromStr (CString strSlowThresh)
void | DPPThreshold (int SpinPos)
CString | GetSlowThreshPcntStr ()
CString | GetSlowChThresStrFromVal (UCHAR byteSlowThres)
void | txtSlowThreshold_Click ()
void | txtSlowThresholdChannels_Click ()
void | SetGain (long GainVal)
CString | GetSlowThreshChStr ()
CString | GetSlowThreshChStrFromVal (UCHAR byteSlowThres)
void | UpdateSlowThresChDisplay ()
UCHAR | GetSlowThresholdSettingFromChannels (double dblSlowThreshChannels)
UCHAR | GetSlowThresholdSettingFromPercent (double dblSlowThresh)

Detailed Description

Definition at line 3 of file DppSlowThreshold.h.

Constructor & Destructor Documentation

CDppSlowThreshold::CDppSlowThreshold ( void )

Definition at line 25 of file DppSlowThreshold.cpp.

CDppSlowThreshold::~CDppSlowThreshold ( void )

Definition at line 29 of file DppSlowThreshold.cpp.

Member Function Documentation

void CDppSlowThreshold::DPPThreshold ( int SpinPos )

Definition at line 116 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

UCHAR CDppSlowThreshold::GetSlowChThreshold ( )

Definition at line 34 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

CString CDppSlowThreshold::GetSlowChThresStrFromVal ( UCHAR byteSlowThres )

Definition at line 133 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

CString CDppSlowThreshold::GetSlowThreshChStr ( )

Definition at line 261 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

CString CDppSlowThreshold::GetSlowThreshChStrFromVal ( UCHAR byteSlowThres )

Definition at line 273 of file DppSlowThreshold.cpp.

UCHAR CDppSlowThreshold::GetSlowThresholdSettingFromChannels ( double dblSlowThreshChannels )

Definition at line 237 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

UCHAR CDppSlowThreshold::GetSlowThresholdSettingFromPercent ( double dblSlowThresh )

Definition at line 176 of file DppSlowThreshold.cpp.

CString CDppSlowThreshold::GetSlowThreshPcntStr ( )

Definition at line 124 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppSlowThreshold::SetGain ( long GainVal )

Definition at line 68 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

void CDppSlowThreshold::SetSlowChThreshold ( UCHAR SlowChThresholdVal )

Definition at line 38 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::SetSlowChThresholdConfigFromStr ( CString strSlowThresh )

Definition at line 102 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::SetSlowChThresholdFromStr ( CString strSlowThresh )

Definition at line 84 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::SetSlowChThresholdFromVal ( int intSlowThresh )

Definition at line 93 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::Thresholds_Setup | ( | CSpinButtonCtrl * | udThresholdObj,
 |  | CEdit * | lblThresholdObj,
 |  | CEdit * | lblThresholdChannelsObj
 | ) |  |

Definition at line 46 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

void CDppSlowThreshold::txtSlowThreshold_Click ( )

Definition at line 149 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

void CDppSlowThreshold::txtSlowThresholdChannels_Click ( )

Definition at line 204 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

void CDppSlowThreshold::UpdateSlowThresChDisplay ( )

Definition at line 286 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

The documentation for this class was generated from the following files:
  • Config/DppSlowThreshold.h
  • Config/DppSlowThreshold.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CDppUtilities Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CDppUtilities Class Reference

#include <DppUtilities.h>

List of all members.

Public Member Functions

CDppUtilities (void)
~CDppUtilities (void)
double | LongWordToDouble (int lwStart, unsigned char buffer[])
Covert a long word into a double.
double | BYTEVersionToDouble (unsigned char Version)
Convert a byte version value into a double.
string | BYTEVersionToString (unsigned char Version)
Convert a byte version value into a string.

Detailed Description

Definition at line 7 of file DppUtilities.h.

Constructor & Destructor Documentation

CDppUtilities::CDppUtilities ( void )

Definition at line 4 of file DppUtilities.cpp.

CDppUtilities::~CDppUtilities ( void )

Definition at line 8 of file DppUtilities.cpp.

Member Function Documentation

double CDppUtilities::BYTEVersionToDouble ( unsigned char Version )

Convert a byte version value into a double.

Definition at line 29 of file DppUtilities.cpp.

Here is the call graph for this function:

string CDppUtilities::BYTEVersionToString ( unsigned char Version )

Convert a byte version value into a string.

Definition at line 40 of file DppUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

double CDppUtilities::LongWordToDouble | ( | int | lwStart,
 |  | unsigned char | buffer[]
 | ) |  |

Covert a long word into a double.

Definition at line 15 of file DppUtilities.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • DeviceIO/DppUtilities.h
  • DeviceIO/DppUtilities.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CDppWinUSB Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CDppWinUSB Class Reference

#include <DppWinUSB.h>

Collaboration diagram for CDppWinUSB:
[legend]

List of all members.

Public Member Functions

CDppWinUSB (void)
~CDppWinUSB (void)
void | Disable_WinUsb ()
void | InitDeviceInfo ()
Initializes the DEVICE_INFO data.
void | CloseDeviceHandle ()
Closes the system device handle.
void | CloseWinUsbDevice ()
Closes the WinUSB device interface handle and frees the resources.
BOOL | GetDevicePath (LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex)
Returns the device path string for a selcted device.
HANDLE | OpenDevice (BOOL bSync, DWORD MemberIndex)
Opens a connection to a selected DPP device.
BOOL | Initialize_Device (DWORD MemberIndex)
Initializes the selected DPP device.
DPP_USB_STATUS | FindUSBDevice (DWORD MemberIndex)
Finds a USB DPP device and sets DEVICE_INFO status indicators. DPP_USB_STATUS is not supported for console applications.
int | CountDP5WinusbDevices (void)
Returns the number of USB devices found.
string | DisplayBufferArray (unsigned char buffer[], unsigned long bufSizeIn)
void | SaveStringDataToFile (string strData)
string | USBStatusString (DPP_USB_STATUS USBStatus)
bool | SendPacketUSB (unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[])
Sends a USB buffer and returns any data read back.

Public Attributes

bool | WinUsb_Disabled
DEVICE_INFO devInfo
Holds the current USB device information.
int | NumPipes
Number of endpoints.
HANDLE | PipeId [MAXPIPES]
Pipe ID array for the current pipes.
unsigned long | PipeTimeout [MAXPIPES]
Pipe timeout value array for the current pipes.
int | CurrentDevice
USB device index. CurrentDevice index starts at 1 for display purposes. WinUSB device indexes (MemberIndex) start at 0.
int | NumDevices
Number of devices found.
bool | isDppFound
Indicates a DPP device has been found.
bool | USB_Default_Timeout

Detailed Description

Definition at line 66 of file DppWinUSB.h.

Constructor & Destructor Documentation

CDppWinUSB::CDppWinUSB ( void )

Definition at line 4 of file DppWinUSB.cpp.

Here is the call graph for this function:

CDppWinUSB::~CDppWinUSB ( void )

Definition at line 14 of file DppWinUSB.cpp.

Member Function Documentation

void CDppWinUSB::CloseDeviceHandle ( )

Closes the system device handle.

Definition at line 30 of file DppWinUSB.cpp.

Here is the caller graph for this function:

void CDppWinUSB::CloseWinUsbDevice ( )

Closes the WinUSB device interface handle and frees the resources.

Definition at line 38 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CDppWinUSB::CountDP5WinusbDevices ( void )

Returns the number of USB devices found.

Definition at line 217 of file DppWinUSB.cpp.

Here is the caller graph for this function:

void CDppWinUSB::Disable_WinUsb ( )

Definition at line 18 of file DppWinUSB.cpp.

string CDppWinUSB::DisplayBufferArray | ( | unsigned char | buffer[],
 |  | unsigned long | bufSizeIn
 | ) |  |

Definition at line 276 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

DPP_USB_STATUS CDppWinUSB::FindUSBDevice ( DWORD MemberIndex )

Finds a USB DPP device and sets DEVICE_INFO status indicators. DPP_USB_STATUS is not supported for console applications.

Definition at line 183 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CDppWinUSB::GetDevicePath | ( | LPGUID | InterfaceGuid,
 |  | PCHAR | DevicePath,
 |  | size_t | BufLen,
 |  | DWORD | MemberIndex
 | ) |  |

Returns the device path string for a selcted device.

Definition at line 51 of file DppWinUSB.cpp.

Here is the caller graph for this function:

void CDppWinUSB::InitDeviceInfo ( )

Initializes the DEVICE_INFO data.

Definition at line 23 of file DppWinUSB.cpp.

Here is the caller graph for this function:

BOOL CDppWinUSB::Initialize_Device ( DWORD MemberIndex )

Initializes the selected DPP device.

Definition at line 117 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

HANDLE CDppWinUSB::OpenDevice | ( | BOOL | bSync,
 |  | DWORD | MemberIndex
 | ) |  |

Opens a connection to a selected DPP device.

Definition at line 97 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppWinUSB::SaveStringDataToFile ( string strData )

Definition at line 295 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CDppWinUSB::SendPacketUSB | ( | unsigned char | Buffer[],
 |  | DEVICE_INFO | TestDevInfo,
 |  | unsigned char | PacketIn[]
 | ) |  |

Sends a USB buffer and returns any data read back.

Definition at line 313 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDppWinUSB::USBStatusString ( DPP_USB_STATUS USBStatus )

Definition at line 261 of file DppWinUSB.cpp.

Here is the caller graph for this function:

Member Data Documentation

int CDppWinUSB::CurrentDevice

USB device index. CurrentDevice index starts at 1 for display purposes. WinUSB device indexes (MemberIndex) start at 0.

Definition at line 104 of file DppWinUSB.h.

DEVICE_INFO CDppWinUSB::devInfo

Holds the current USB device information.

Definition at line 76 of file DppWinUSB.h.

bool CDppWinUSB::isDppFound

Indicates a DPP device has been found.

Definition at line 108 of file DppWinUSB.h.

int CDppWinUSB::NumDevices

Number of devices found.

Definition at line 106 of file DppWinUSB.h.

int CDppWinUSB::NumPipes

Number of endpoints.

Definition at line 78 of file DppWinUSB.h.

HANDLE CDppWinUSB::PipeId[MAXPIPES]

Pipe ID array for the current pipes.

Definition at line 81 of file DppWinUSB.h.

unsigned long CDppWinUSB::PipeTimeout[MAXPIPES]

Pipe timeout value array for the current pipes.

Definition at line 83 of file DppWinUSB.h.

bool CDppWinUSB::USB_Default_Timeout

Definition at line 117 of file DppWinUSB.h.

bool CDppWinUSB::WinUsb_Disabled

Definition at line 72 of file DppWinUSB.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DppWinUSB.h
  • DeviceIO/DppWinUSB.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CFileBrowse Class Reference

  • Class List
  • Class Index
  • Class Members
Public Types | Public Member Functions | Public Attributes
CFileBrowse Class Reference

#include <FileBrowse.h>

List of all members.

Public Types

enum | DialogType { SAVE, OPEN }

Public Member Functions

CFileBrowse (void)
~CFileBrowse (void)
BOOL | DoModal (int DlgType, CString DlgTitle, CString FileFilter, CString DefaultExt, CString InitDir, CString *Filename)

Public Attributes

CString | CfgFileFilter
CString | TxtFileFilter
CString | ExeFileFilter
CString | BmpFileFilter
CString | McaFileFilter
CString | LibFileFilter
CString | AllFileFilter

Detailed Description

Definition at line 3 of file FileBrowse.h.

Member Enumeration Documentation

enum CFileBrowse::DialogType
Enumerator:
SAVE
OPEN

Definition at line 14 of file FileBrowse.h.

Constructor & Destructor Documentation

CFileBrowse::CFileBrowse ( void )

Definition at line 4 of file FileBrowse.cpp.

CFileBrowse::~CFileBrowse ( void )

Definition at line 16 of file FileBrowse.cpp.

Member Function Documentation

BOOL CFileBrowse::DoModal | ( | int | DlgType,
 |  | CString | DlgTitle,
 |  | CString | FileFilter,
 |  | CString | DefaultExt,
 |  | CString | InitDir,
 |  | CString * | Filename
 | ) |  |

Definition at line 20 of file FileBrowse.cpp.

Here is the caller graph for this function:

Member Data Documentation

CString CFileBrowse::AllFileFilter

Definition at line 25 of file FileBrowse.h.

CString CFileBrowse::BmpFileFilter

Definition at line 22 of file FileBrowse.h.

CString CFileBrowse::CfgFileFilter

Definition at line 19 of file FileBrowse.h.

CString CFileBrowse::ExeFileFilter

Definition at line 21 of file FileBrowse.h.

CString CFileBrowse::LibFileFilter

Definition at line 24 of file FileBrowse.h.

CString CFileBrowse::McaFileFilter

Definition at line 23 of file FileBrowse.h.

CString CFileBrowse::TxtFileFilter

Definition at line 20 of file FileBrowse.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/FileBrowse.h
  • DP5Cfg/FileBrowse.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CINI Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CINI Class Reference

#include <INI.h>

List of all members.

Public Member Functions

void | setINIFileName (CString strINIFile)
CStringList * | getSectionData (CString strSection)
CStringList * | getSectionNames ()
BOOL | sectionExists (CString strSection)
long | setKey (CString strValue, CString strKey, CString strSection)
long | DeleteKey (CString strKey, CString strSection)
long | DeleteSection (CString strSection)
CString | getKeyValue (CString strKey, CString strSection)
CINI (CString strFile)
CINI ()
virtual | ~CINI ()

Detailed Description

Definition at line 40 of file INI.h.

Constructor & Destructor Documentation

CINI::CINI ( CString strFile )

Definition at line 41 of file INI.cpp.

CINI::CINI ( ) [inline]

Definition at line 52 of file INI.h.

CINI::~CINI ( ) [virtual]

Definition at line 48 of file INI.cpp.

Member Function Documentation

long CINI::DeleteKey | ( | CString | strKey,
 |  | CString | strSection
 | ) |  |

Definition at line 77 of file INI.cpp.

Here is the caller graph for this function:

long CINI::DeleteSection ( CString strSection )

Definition at line 86 of file INI.cpp.

CString CINI::getKeyValue | ( | CString | strKey,
 |  | CString | strSection
 | ) |  |

Definition at line 55 of file INI.cpp.

Here is the caller graph for this function:

CStringList * CINI::getSectionData ( CString strSection )

Definition at line 133 of file INI.cpp.

Here is the caller graph for this function:

CStringList * CINI::getSectionNames ( )

Definition at line 109 of file INI.cpp.

BOOL CINI::sectionExists ( CString strSection )

Definition at line 95 of file INI.cpp.

Here is the caller graph for this function:

void CINI::setINIFileName ( CString strINIFile )

Definition at line 155 of file INI.cpp.

Here is the caller graph for this function:

long CINI::setKey | ( | CString | strValue,
 |  | CString | strKey,
 |  | CString | strSection
 | ) |  |

Definition at line 68 of file INI.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • CIni/INI.h
  • CIni/INI.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIniEx Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CIniEx Class Reference

#include <IniEx.h>

List of all members.

Public Member Functions

CIniEx (void)
~CIniEx (void)

Detailed Description

Definition at line 6 of file IniEx.h.

Constructor & Destructor Documentation

CIniEx::CIniEx ( void )

Definition at line 3 of file IniEx.cpp.

CIniEx::~CIniEx ( void )

Definition at line 7 of file IniEx.cpp.

The documentation for this class was generated from the following files:
  • CIni/IniEx.h
  • CIni/IniEx.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIniUtil Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CIniUtil Class Reference

#include <IniUtil.h>

Collaboration diagram for CIniUtil:
[legend]

List of all members.

Public Member Functions

CIniUtil (void)
~CIniUtil (void)
BOOL | GetDP5Data (CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comments)
BOOL | SaveDP5Data (CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comments)
BOOL | GetDP5Section (CString m_strINIFile, CString m_strSection, CStringList *m_strListDP5section)
CString | ConvertCmdListToCString (CStringList *strCmdList, BOOL AddNewLines, BOOL RemoveComments)
CString | GetMsIniItem (CString strCmdIn)
BOOL | DeleteDP5Key (CString m_strINIFile, CString m_strSection, CString cmdKey)

Public Attributes

CINI ini

Detailed Description

Definition at line 6 of file IniUtil.h.

Constructor & Destructor Documentation

CIniUtil::CIniUtil ( void )

Definition at line 4 of file IniUtil.cpp.

CIniUtil::~CIniUtil ( void )

Definition at line 9 of file IniUtil.cpp.

Member Function Documentation

CString CIniUtil::ConvertCmdListToCString | ( | CStringList * | strCmdList,
 |  | BOOL | AddNewLines,
 |  | BOOL | RemoveComments
 | ) |  |

Definition at line 111 of file IniUtil.cpp.

Here is the call graph for this function:

BOOL CIniUtil::DeleteDP5Key | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CString | cmdKey
 | ) |  |

Definition at line 169 of file IniUtil.cpp.

Here is the call graph for this function:

BOOL CIniUtil::GetDP5Data | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CString | cmdKey,
 |  | CString * | cmdData,
 |  | CString * | Comments
 | ) |  |

Definition at line 13 of file IniUtil.cpp.

Here is the call graph for this function:

BOOL CIniUtil::GetDP5Section | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CStringList * | m_strListDP5section
 | ) |  |

Definition at line 62 of file IniUtil.cpp.

Here is the call graph for this function:

CString CIniUtil::GetMsIniItem ( CString strCmdIn )

Definition at line 146 of file IniUtil.cpp.

Here is the caller graph for this function:

BOOL CIniUtil::SaveDP5Data | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CString | cmdKey,
 |  | CString | cmdData,
 |  | CString | Comments
 | ) |  |

Definition at line 44 of file IniUtil.cpp.

Here is the call graph for this function:

Member Data Documentation

CINI CIniUtil::ini

Definition at line 11 of file IniUtil.h.

The documentation for this class was generated from the following files:
  • CIni/IniUtil.h
  • CIni/IniUtil.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CLabel Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CLabel Class Reference

#include <Label.h>

List of all members.

Public Member Functions

CLabel ()
CLabel & | SetBkColor (COLORREF crBkgnd)
CLabel & | SetTextColor (COLORREF crText)
CLabel & | SetText (const CString &strText)
CLabel & | SetFontBold (BOOL bBold)
CLabel & | SetFontName (const CString &strFont)
CLabel & | SetFontUnderline (BOOL bSet)
CLabel & | SetFontItalic (BOOL bSet)
CLabel & | SetFontSize (int nSize)
CLabel & | SetSunken (BOOL bSet)
CLabel & | SetBorder (BOOL bSet)
CLabel & | FlashText (BOOL bActivate)
CLabel & | FlashBackground (BOOL bActivate)
CLabel & | SetLink (BOOL bLink)
CLabel & | SetLinkCursor (HCURSOR hCursor)
void | SetNullColor ()
void | SetLastColor ()
virtual | ~CLabel ()

Public Attributes

BOOL | NullSet
COLORREF | NullBkColor
COLORREF | NullTextColor
COLORREF | LastBkColor
COLORREF | LastTextColor

Protected Member Functions

void | ReconstructFont ()
afx_msg HBRUSH | CtlColor (CDC *pDC, UINT nCtlColor)
afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg BOOL | OnSetCursor (CWnd *pWnd, UINT nHitTest, UINT message)

Protected Attributes

COLORREF | m_crText
HBRUSH | m_hBrush
HBRUSH | m_hwndBrush
LOGFONT | m_lf
CFont | m_font
CString | m_strText
BOOL | m_bState
BOOL | m_bTimer
BOOL | m_bLink
FlashType m_Type
HCURSOR | m_hCursor

Detailed Description

Definition at line 15 of file Label.h.

Constructor & Destructor Documentation

CLabel::CLabel ( )

Definition at line 17 of file Label.cpp.

CLabel::~CLabel ( ) [virtual]

Definition at line 41 of file Label.cpp.

Member Function Documentation

HBRUSH CLabel::CtlColor | ( | CDC * | pDC,
 |  | UINT | nCtlColor
 | ) |  | [protected]

Definition at line 146 of file Label.cpp.

Here is the call graph for this function:

CLabel & CLabel::FlashBackground ( BOOL bActivate )

Definition at line 199 of file Label.cpp.

CLabel & CLabel::FlashText ( BOOL bActivate )

Definition at line 178 of file Label.cpp.

void CLabel::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  | [protected]

Definition at line 253 of file Label.cpp.

BOOL CLabel::OnSetCursor | ( | CWnd * | pWnd,
 |  | UINT | nHitTest,
 |  | UINT | message
 | ) |  | [protected]

Definition at line 263 of file Label.cpp.

void CLabel::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 219 of file Label.cpp.

void CLabel::ReconstructFont ( ) [protected]

Definition at line 169 of file Label.cpp.

Here is the caller graph for this function:

CLabel & CLabel::SetBkColor ( COLORREF crBkgnd )

Definition at line 115 of file Label.cpp.

Here is the caller graph for this function:

CLabel & CLabel::SetBorder ( BOOL bSet )

Definition at line 95 of file Label.cpp.

CLabel & CLabel::SetFontBold ( BOOL bBold )

Definition at line 61 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontItalic ( BOOL bSet )

Definition at line 77 of file Label.cpp.

Here is the call graph for this function:

CLabel & CLabel::SetFontName ( const CString & strFont )

Definition at line 125 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontSize ( int nSize )

Definition at line 105 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontUnderline ( BOOL bSet )

Definition at line 69 of file Label.cpp.

Here is the call graph for this function:

void CLabel::SetLastColor ( )

Definition at line 288 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetLink ( BOOL bLink )

Definition at line 241 of file Label.cpp.

CLabel & CLabel::SetLinkCursor ( HCURSOR hCursor )

Definition at line 274 of file Label.cpp.

void CLabel::SetNullColor ( )

Definition at line 280 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetSunken ( BOOL bSet )

Definition at line 85 of file Label.cpp.

CLabel & CLabel::SetText ( const CString & strText )

Definition at line 47 of file Label.cpp.

Here is the caller graph for this function:

CLabel & CLabel::SetTextColor ( COLORREF crText )

Definition at line 53 of file Label.cpp.

Here is the caller graph for this function:

Member Data Documentation

COLORREF CLabel::LastBkColor

Definition at line 40 of file Label.h.

COLORREF CLabel::LastTextColor

Definition at line 41 of file Label.h.

BOOL CLabel::m_bLink [protected]

Definition at line 55 of file Label.h.

BOOL CLabel::m_bState [protected]

Definition at line 53 of file Label.h.

BOOL CLabel::m_bTimer [protected]

Definition at line 54 of file Label.h.

COLORREF CLabel::m_crText [protected]

Definition at line 47 of file Label.h.

CFont CLabel::m_font [protected]

Definition at line 51 of file Label.h.

HBRUSH CLabel::m_hBrush [protected]

Definition at line 48 of file Label.h.

HCURSOR CLabel::m_hCursor [protected]

Definition at line 57 of file Label.h.

HBRUSH CLabel::m_hwndBrush [protected]

Definition at line 49 of file Label.h.

LOGFONT CLabel::m_lf [protected]

Definition at line 50 of file Label.h.

CString CLabel::m_strText [protected]

Definition at line 52 of file Label.h.

FlashType CLabel::m_Type [protected]

Definition at line 56 of file Label.h.

COLORREF CLabel::NullBkColor

Definition at line 38 of file Label.h.

BOOL CLabel::NullSet

Definition at line 37 of file Label.h.

COLORREF CLabel::NullTextColor

Definition at line 39 of file Label.h.

The documentation for this class was generated from the following files:
  • Controls/Label.h
  • Controls/Label.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: cMemDC Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
cMemDC Class Reference

#include <memdc.h>

List of all members.

Public Member Functions

cMemDC (CDC *pDC, const CRect &rcBounds, long BackColor=RGB(255, 255, 255))
~cMemDC ()
cMemDC * operator-> ()

Detailed Description

Definition at line 20 of file memdc.h.

Constructor & Destructor Documentation

cMemDC::cMemDC | ( | CDC * | pDC,
 |  | const CRect & | rcBounds,
 |  | long | BackColor = RGB(255,255,255)
 | ) |  | [inline]

Definition at line 28 of file memdc.h.

cMemDC::~cMemDC ( ) [inline]

Definition at line 42 of file memdc.h.

Member Function Documentation

cMemDC* cMemDC::operator-> ( ) [inline]

Definition at line 48 of file memdc.h.

The documentation for this class was generated from the following file:
  • waitdlg/memdc.h
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CMSecTimer Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CMSecTimer Class Reference

#include <MSecTimer.h>

List of all members.

Public Member Functions

CMSecTimer (void)
~CMSecTimer (void)
DWORD | msTimeDiff (DWORD msStartTime, DWORD msTestTime)
BOOL | msTimeExpired (DWORD msStartTime, DWORD msDelay)
BOOL | msTimer (DWORD msDelay)

Detailed Description

Definition at line 6 of file MSecTimer.h.

Constructor & Destructor Documentation

CMSecTimer::CMSecTimer ( void )

Definition at line 3 of file MSecTimer.cpp.

CMSecTimer::~CMSecTimer ( void )

Definition at line 7 of file MSecTimer.cpp.

Member Function Documentation

DWORD CMSecTimer::msTimeDiff | ( | DWORD | msStartTime,
 |  | DWORD | msTestTime
 | ) |  |

Definition at line 11 of file MSecTimer.cpp.

Here is the caller graph for this function:

BOOL CMSecTimer::msTimeExpired | ( | DWORD | msStartTime,
 |  | DWORD | msDelay
 | ) |  |

Definition at line 33 of file MSecTimer.cpp.

Here is the caller graph for this function:

BOOL CMSecTimer::msTimer ( DWORD msDelay )

Definition at line 60 of file MSecTimer.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • DeviceIO/MSecTimer.h
  • DeviceIO/MSecTimer.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CMsgBox Class Reference

  • Class List
  • Class Index
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions
CMsgBox Class Reference

#include <MsgBox.h>

List of all members.

Public Types

enum | { IDD = IDD_MESSAGE_BOX }

Public Member Functions

CMsgBox (CWnd *pParent=NULL)
virtual | ~CMsgBox ()
virtual BOOL | OnInitDialog ()
void | SetMessage (string cstrMsg, string m_strDelimiter)

Public Attributes

string | m_strTitle
string | m_strMessage
string | m_strDelimiter

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Detailed Description

Definition at line 6 of file MsgBox.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 15 of file MsgBox.h.

Constructor & Destructor Documentation

CMsgBox::CMsgBox ( CWnd * pParent = NULL )

Definition at line 13 of file MsgBox.cpp.

CMsgBox::~CMsgBox ( ) [virtual]

Definition at line 18 of file MsgBox.cpp.

Member Function Documentation

void CMsgBox::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 22 of file MsgBox.cpp.

BOOL CMsgBox::OnInitDialog ( ) [virtual]

Definition at line 34 of file MsgBox.cpp.

void CMsgBox::SetMessage | ( | string | cstrMsg,
 |  | string | m_strDelimiter
 | ) |  |

Definition at line 47 of file MsgBox.cpp.

Member Data Documentation

string CMsgBox::m_strDelimiter

Definition at line 25 of file MsgBox.h.

string CMsgBox::m_strMessage

Definition at line 24 of file MsgBox.h.

string CMsgBox::m_strTitle

Definition at line 23 of file MsgBox.h.

The documentation for this class was generated from the following files:
  • MsgBox.h
  • MsgBox.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CNetFinder Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CNetFinder Class Reference

#include <NetFinder.h>

Collaboration diagram for CNetFinder:
[legend]

List of all members.

Public Member Functions

CNetFinder (void)
~CNetFinder (void)
CString | EntryToStr (NETDISPLAY_ENTRY *pEntry)
CString | EntryToStrRS232 (NETDISPLAY_ENTRY *pEntry, CString strPort)
CString | EntryToStrUSB (NETDISPLAY_ENTRY *pEntry, CString strPort)
COLORREF | AlertEntryToCOLORREF (NETDISPLAY_ENTRY *pEntry)
COLORREF | AlertByteToCOLORREF (unsigned char alert_level)
int | FindEntry (unsigned long SockAddr)
CString | SockAddr_DlgToStr (CDialog *dlg, int id1, int id2, int id3, int id4)
UINT | SockPort_DlgToUINT (CDialog *dlg, int id1)
in_addr | SockAddr_ByteToInAddr (unsigned char *ip)
unsigned long | SockAddr_ByteToULong (unsigned char *ip)
CString | SockAddr_ByteToStr (unsigned char *ip)
in_addr | SockAddr_StrToInAddr (CString strSockAddr)
unsigned long | SockAddr_StrToULong (CString strSockAddr)
in_addr | SockAddr_ULongToInAddr (unsigned long SockAddr)
CString | SockAddr_ULongToStr (unsigned long SockAddr)
CString | SockAddr_InAddrToStr (in_addr inSockAddr)
void | InitEntry (NETDISPLAY_ENTRY *pEntry)
void | InitAllEntries ()
void | AddEntry (NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort)

Public Attributes

int | m_rand
NETDISPLAY_ENTRY DppEntries [MAX_ENTRIES]
int | LastEntry
unsigned long | DppSockAddr
int | DppEntryIdx
BOOL | DppFound

Detailed Description

Definition at line 45 of file NetFinder.h.

Constructor & Destructor Documentation

CNetFinder::CNetFinder ( void )

Definition at line 6 of file NetFinder.cpp.

Here is the call graph for this function:

CNetFinder::~CNetFinder ( void )

Definition at line 13 of file NetFinder.cpp.

Member Function Documentation

void CNetFinder::AddEntry | ( | NETDISPLAY_ENTRY * | pEntry,
 |  | unsigned char * | buffer,
 |  | UINT | destPort
 | ) |  |

Definition at line 307 of file NetFinder.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

COLORREF CNetFinder::AlertByteToCOLORREF ( unsigned char alert_level )

Definition at line 25 of file NetFinder.cpp.

Here is the caller graph for this function:

COLORREF CNetFinder::AlertEntryToCOLORREF ( NETDISPLAY_ENTRY * pEntry )

Definition at line 18 of file NetFinder.cpp.

Here is the call graph for this function:

CString CNetFinder::EntryToStr ( NETDISPLAY_ENTRY * pEntry )

Definition at line 51 of file NetFinder.cpp.

Here is the caller graph for this function:

CString CNetFinder::EntryToStrRS232 | ( | NETDISPLAY_ENTRY * | pEntry,
 |  | CString | strPort
 | ) |  |

Definition at line 114 of file NetFinder.cpp.

CString CNetFinder::EntryToStrUSB | ( | NETDISPLAY_ENTRY * | pEntry,
 |  | CString | strPort
 | ) |  |

Definition at line 178 of file NetFinder.cpp.

Here is the caller graph for this function:

int CNetFinder::FindEntry ( unsigned long SockAddr )

Definition at line 242 of file NetFinder.cpp.

void CNetFinder::InitAllEntries ( )

Definition at line 298 of file NetFinder.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CNetFinder::InitEntry ( NETDISPLAY_ENTRY * pEntry )

Definition at line 256 of file NetFinder.cpp.

Here is the caller graph for this function:

in_addr CNetFinder::SockAddr_ByteToInAddr ( unsigned char * ip )

Definition at line 412 of file NetFinder.cpp.

Here is the caller graph for this function:

CString CNetFinder::SockAddr_ByteToStr ( unsigned char * ip )

Definition at line 429 of file NetFinder.cpp.

unsigned long CNetFinder::SockAddr_ByteToULong ( unsigned char * ip )

Definition at line 422 of file NetFinder.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CNetFinder::SockAddr_DlgToStr | ( | CDialog * | dlg,
 |  | int | id1,
 |  | int | id2,
 |  | int | id3,
 |  | int | id4
 | ) |  |

Definition at line 374 of file NetFinder.cpp.

CString CNetFinder::SockAddr_InAddrToStr ( in_addr inSockAddr )

Definition at line 468 of file NetFinder.cpp.

in_addr CNetFinder::SockAddr_StrToInAddr ( CString strSockAddr )

Definition at line 436 of file NetFinder.cpp.

unsigned long CNetFinder::SockAddr_StrToULong ( CString strSockAddr )

Definition at line 445 of file NetFinder.cpp.

in_addr CNetFinder::SockAddr_ULongToInAddr ( unsigned long SockAddr )

Definition at line 452 of file NetFinder.cpp.

CString CNetFinder::SockAddr_ULongToStr ( unsigned long SockAddr )

Definition at line 459 of file NetFinder.cpp.

UINT CNetFinder::SockPort_DlgToUINT | ( | CDialog * | dlg,
 |  | int | id1
 | ) |  |

Definition at line 401 of file NetFinder.cpp.

Member Data Documentation

NETDISPLAY_ENTRY CNetFinder::DppEntries[MAX_ENTRIES]

Definition at line 52 of file NetFinder.h.

int CNetFinder::DppEntryIdx

Definition at line 56 of file NetFinder.h.

BOOL CNetFinder::DppFound

Definition at line 57 of file NetFinder.h.

unsigned long CNetFinder::DppSockAddr

Definition at line 55 of file NetFinder.h.

int CNetFinder::LastEntry

Definition at line 53 of file NetFinder.h.

int CNetFinder::m_rand

Definition at line 51 of file NetFinder.h.

The documentation for this class was generated from the following files:
  • DeviceIO/NetFinder.h
  • DeviceIO/NetFinder.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CParsePacket Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CParsePacket Class Reference

#include <ParsePacket.h>

Collaboration diagram for CParsePacket:
[legend]

List of all members.

Public Member Functions

CParsePacket (void)
~CParsePacket (void)
void | ParsePacketStatus (unsigned char P[], Packet_In *PIN)
Parses DPP packet status, determines further processing.
string | PID2_TextToString (string strPacketSource, unsigned char PID2)
Processes DPP return ACKS, NAKS and errors.
long | ParsePacket (unsigned char P[], Packet_In *PIN)
Parses incoming DPP packet, tests packet, populates packet information, sets packet state.

Public Attributes

DppStateType DppState
DPP packet parser state indicator.

Detailed Description

Definition at line 42 of file ParsePacket.h.

Constructor & Destructor Documentation

CParsePacket::CParsePacket ( void )

Definition at line 3 of file ParsePacket.cpp.

CParsePacket::~CParsePacket ( void )

Definition at line 7 of file ParsePacket.cpp.

Member Function Documentation

long CParsePacket::ParsePacket | ( | unsigned char | P[],
 |  | Packet_In * | PIN
 | ) |  |

Parses incoming DPP packet, tests packet, populates packet information, sets packet state.

Definition at line 117 of file ParsePacket.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CParsePacket::ParsePacketStatus | ( | unsigned char | P[],
 |  | Packet_In * | PIN
 | ) |  |

Parses DPP packet status, determines further processing.

Definition at line 11 of file ParsePacket.cpp.

Here is the caller graph for this function:

string CParsePacket::PID2_TextToString | ( | string | strPacketSource,
 |  | unsigned char | PID2
 | ) |  |

Processes DPP return ACKS, NAKS and errors.

Definition at line 49 of file ParsePacket.cpp.

Here is the caller graph for this function:

Member Data Documentation

DppStateType CParsePacket::DppState

DPP packet parser state indicator.

Definition at line 48 of file ParsePacket.h.

The documentation for this class was generated from the following files:
  • DeviceIO/ParsePacket.h
  • DeviceIO/ParsePacket.cpp
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CPlotCanvas Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions
CPlotCanvas Class Reference

#include <PlotCanvas.h>

Collaboration diagram for CPlotCanvas:
[legend]

List of all members.

Public Member Functions

CPlotCanvas ()
void | Invalidate ()
void | PlotTrace (long YPlotBufferIn[8192])
virtual | ~CPlotCanvas ()
void | ClearTrace ()
void | DrawCursor ()
void | OnRefreshBkgnd ()
void | SetPersistenceMode (bool Persistence)
void | SetCursorPosition (int CursorPos)
void | DrawCursor (CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
void | DataAcq (long DataBuffer[8192], int NumChan)

Public Attributes

COLORREF | m_crDisplayBGColor
COLORREF | m_crPlotColor
COLORREF | m_crCursorColor
COLORREF | m_crTextFGColor
COLORREF | m_crTextBGColor
bool | hasBackground
bool | PersistenceMode
int | CursorPosition
int | OldCursorPosition
COORD_LONG PlotCursor
COORD_LONG OldPlotCursor
long | YPlotBuffer [8192]
long | YPlotMAX
long | XPlotMAX
bool | OptScaleType
bool | OptPlotType

Protected Member Functions

afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg void | OnPaint ()

Detailed Description

Definition at line 46 of file PlotCanvas.h.

Constructor & Destructor Documentation

CPlotCanvas::CPlotCanvas ( )

Definition at line 9 of file PlotCanvas.cpp.

CPlotCanvas::~CPlotCanvas ( ) [virtual]

Definition at line 29 of file PlotCanvas.cpp.

Member Function Documentation

void CPlotCanvas::ClearTrace ( )

Definition at line 211 of file PlotCanvas.cpp.

Here is the caller graph for this function:

void CPlotCanvas::DataAcq | ( | long | DataBuffer[8192],
 |  | int | NumChan
 | ) |  |

Definition at line 265 of file PlotCanvas.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CPlotCanvas::DrawCursor ( )

Definition at line 226 of file PlotCanvas.cpp.

Here is the caller graph for this function:

void CPlotCanvas::DrawCursor | ( | CDC * | dcMem,
 |  | long | YPlotBufferIn[8192],
 |  | bool | EraseCursor = false
 | ) |  |

Definition at line 182 of file PlotCanvas.cpp.

void CPlotCanvas::Invalidate ( )
BOOL CPlotCanvas::OnEraseBkgnd ( CDC * pDC ) [protected]

Definition at line 46 of file PlotCanvas.cpp.

void CPlotCanvas::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  |

Definition at line 255 of file PlotCanvas.cpp.

Here is the call graph for this function:

void CPlotCanvas::OnPaint ( ) [protected]

Definition at line 60 of file PlotCanvas.cpp.

void CPlotCanvas::OnRefreshBkgnd ( )

Definition at line 53 of file PlotCanvas.cpp.

Here is the caller graph for this function:

void CPlotCanvas::PlotTrace ( long YPlotBufferIn[8192] )

Definition at line 197 of file PlotCanvas.cpp.

void CPlotCanvas::SetCursorPosition ( int CursorPos )

Definition at line 249 of file PlotCanvas.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CPlotCanvas::SetPersistenceMode ( bool Persistence )

Definition at line 240 of file PlotCanvas.cpp.

Here is the call graph for this function:

Member Data Documentation

int CPlotCanvas::CursorPosition

Definition at line 62 of file PlotCanvas.h.

bool CPlotCanvas::hasBackground

Definition at line 60 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crCursorColor

Definition at line 56 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crDisplayBGColor

Definition at line 54 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crPlotColor

Definition at line 55 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crTextBGColor

Definition at line 58 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crTextFGColor

Definition at line 57 of file PlotCanvas.h.

int CPlotCanvas::OldCursorPosition

Definition at line 63 of file PlotCanvas.h.

COORD_LONG CPlotCanvas::OldPlotCursor

Definition at line 66 of file PlotCanvas.h.

bool CPlotCanvas::OptPlotType

Definition at line 72 of file PlotCanvas.h.

bool CPlotCanvas::OptScaleType

Definition at line 71 of file PlotCanvas.h.

bool CPlotCanvas::PersistenceMode

Definition at line 61 of file PlotCanvas.h.

COORD_LONG CPlotCanvas::PlotCursor

Definition at line 65 of file PlotCanvas.h.

long CPlotCanvas::XPlotMAX

Definition at line 69 of file PlotCanvas.h.

long CPlotCanvas::YPlotBuffer[8192]

Definition at line 67 of file PlotCanvas.h.

long CPlotCanvas::YPlotMAX

Definition at line 68 of file PlotCanvas.h.

The documentation for this class was generated from the following files:
  • Controls/PlotCanvas.h
  • Controls/PlotCanvas.cpp
Generated on Fri Sep 22 2017 10:01:05 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CSelectDP5 Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CSelectDP5 Class Reference

#include <SelectDP5.h>

Collaboration diagram for CSelectDP5:
[legend]

List of all members.

Public Member Functions

CSelectDP5 ()
virtual BOOL | OnInitDialog ()
void | SetDataRcvTimer (long Bytes)
void | ReqDataStatus ()
afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnBnClickedButtonFindUsbDevice ()
virtual BOOL | DestroyWindow ()
void | EnableCommFunctions (int ControlGroup)
afx_msg void | OnBnClickedRadioCommtype2 ()
afx_msg void | OnBnClickedOk ()
afx_msg void | OnBnClickedButtonCountDevices ()
afx_msg void | OnDeltaposSpinSelectDevice (NMHDR *pNMHDR, LRESULT *pResult)
afx_msg void | OnBnClickedButtonCloseDevice ()
afx_msg void | OnBnClickedConnectOK ()
virtual void | OnOK ()
void | CopyTextToClip (CString strTitle, CString strDesc)
void | SetModified (BOOL bChanged)
afx_msg void | OnEnChangeSpectrumRefreshTime ()
afx_msg void | OnBnClickedButtonSpectrumRefreshDefault ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)

Public Attributes

CComboBox | cboComPort
DP4_FORMAT_STATUS m_DP5_Status
BYTE | DataIn [4096]
CNetFinder FindDpp
CNetFinder FindDppUSB
CLabel | lblDppFound [3]
CSpinButtonCtrl | m_SpinSelectDevice
BOOL | m_bModified
CEdit | m_SpectrumRefreshTimeCtrl

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 26 of file SelectDP5.h.

Constructor & Destructor Documentation

CSelectDP5::CSelectDP5 ( )

Definition at line 39 of file SelectDP5.cpp.

Member Function Documentation

void CSelectDP5::CopyTextToClip | ( | CString | strTitle,
 |  | CString | strDesc
 | ) |  |

Definition at line 304 of file SelectDP5.cpp.

BOOL CSelectDP5::DestroyWindow ( ) [virtual]

Definition at line 104 of file SelectDP5.cpp.

void CSelectDP5::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 48 of file SelectDP5.cpp.

void CSelectDP5::EnableCommFunctions ( int ControlGroup )

Definition at line 165 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonCloseDevice ( )

Definition at line 271 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonCountDevices ( )

Definition at line 207 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonFindUsbDevice ( )

Definition at line 116 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonSpectrumRefreshDefault ( )

Definition at line 328 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedConnectOK ( )

Definition at line 281 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedOk ( )

Definition at line 201 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedRadioCommtype2 ( )

Definition at line 109 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnDeltaposSpinSelectDevice | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  |

Definition at line 233 of file SelectDP5.cpp.

void CSelectDP5::OnEnChangeSpectrumRefreshTime ( )

Definition at line 323 of file SelectDP5.cpp.

Here is the call graph for this function:

BOOL CSelectDP5::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 335 of file SelectDP5.cpp.

BOOL CSelectDP5::OnInitDialog ( ) [virtual]

Definition at line 60 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnOK ( ) [virtual]

Definition at line 299 of file SelectDP5.cpp.

Here is the caller graph for this function:

afx_msg void CSelectDP5::OnTimer ( UINT nIDEvent )
void CSelectDP5::ReqDataStatus ( )
void CSelectDP5::SetDataRcvTimer ( long Bytes )
void CSelectDP5::SetModified ( BOOL bChanged )

Definition at line 318 of file SelectDP5.cpp.

Here is the caller graph for this function:

Member Data Documentation

CComboBox CSelectDP5::cboComPort

Definition at line 48 of file SelectDP5.h.

BYTE CSelectDP5::DataIn[4096]

Definition at line 52 of file SelectDP5.h.

CNetFinder CSelectDP5::FindDpp

Definition at line 60 of file SelectDP5.h.

CNetFinder CSelectDP5::FindDppUSB

Definition at line 61 of file SelectDP5.h.

CLabel CSelectDP5::lblDppFound[3]

Definition at line 71 of file SelectDP5.h.

BOOL CSelectDP5::m_bModified

Definition at line 84 of file SelectDP5.h.

DP4_FORMAT_STATUS CSelectDP5::m_DP5_Status

Definition at line 50 of file SelectDP5.h.

CEdit CSelectDP5::m_SpectrumRefreshTimeCtrl

Definition at line 86 of file SelectDP5.h.

CSpinButtonCtrl CSelectDP5::m_SpinSelectDevice

Definition at line 76 of file SelectDP5.h.

CToolTipCtrl CSelectDP5::m_ToolTip [protected]

Definition at line 42 of file SelectDP5.h.

The documentation for this class was generated from the following files:
  • DeviceIO/SelectDP5.h
  • DeviceIO/SelectDP5.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CSendCommand Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CSendCommand Class Reference

#include <SendCommand.h>

Collaboration diagram for CSendCommand:
[legend]

List of all members.

Public Member Functions

CSendCommand (void)
~CSendCommand (void)
bool | TestPacketCkSumOK (unsigned char Data[])
Packet checksum test for commands with data.
bool | DP5_CMD (unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd)
Creates a DPP command that does not require additional processing.
bool | DP5_CMD_Config (unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions)
Creates a DPP command that requires configuration data options processing.
bool | DP5_CMD_Data (unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[])
Creates a DPP command that requires data.
bool | POUT_Buffer (Packet_Out POUT, unsigned char Buffer[])
Creates a packet output buffer from a command byte data array.

Public Attributes

CAsciiCmdUtilities AsciiCmdUtil

Detailed Description

CSendCommand prepares all command packets to be sent. Call CSendCommand::DP5_CMD, CSendCommand::DP5_CMD_Config or CSendCommand::DP5_CMD_Data along with the TRANSMIT_PACKET_TYPE and any additional data or options.

A command array of 8-bit bytes is generated.

Definition at line 23 of file SendCommand.h.

Constructor & Destructor Documentation

CSendCommand::CSendCommand ( void )

Definition at line 4 of file SendCommand.cpp.

CSendCommand::~CSendCommand ( void )

Definition at line 8 of file SendCommand.cpp.

Member Function Documentation

bool CSendCommand::DP5_CMD | ( | unsigned char | Buffer[],
 |  | TRANSMIT_PACKET_TYPE | XmtCmd
 | ) |  |

Creates a DPP command that does not require additional processing.

Definition at line 42 of file SendCommand.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CSendCommand::DP5_CMD_Config | ( | unsigned char | Buffer[],
 |  | TRANSMIT_PACKET_TYPE | XmtCmd,
 |  | CONFIG_OPTIONS | CfgOptions
 | ) |  |

Creates a DPP command that requires configuration data options processing.

Definition at line 273 of file SendCommand.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CSendCommand::DP5_CMD_Data | ( | unsigned char | Buffer[],
 |  | TRANSMIT_PACKET_TYPE | XmtCmd,
 |  | unsigned char | DataOut[]
 | ) |  |

Creates a DPP command that requires data.

Definition at line 404 of file SendCommand.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CSendCommand::POUT_Buffer | ( | Packet_Out | POUT,
 |  | unsigned char | Buffer[]
 | ) |  |

Creates a packet output buffer from a command byte data array.

Definition at line 446 of file SendCommand.cpp.

Here is the caller graph for this function:

bool CSendCommand::TestPacketCkSumOK ( unsigned char Data[] )

Packet checksum test for commands with data.

Definition at line 12 of file SendCommand.cpp.

Here is the caller graph for this function:

Member Data Documentation

CAsciiCmdUtilities CSendCommand::AsciiCmdUtil

Definition at line 28 of file SendCommand.h.

The documentation for this class was generated from the following files:
  • DeviceIO/SendCommand.h
  • DeviceIO/SendCommand.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CSProfile Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CSProfile Class Reference

#include <SProfile.h>

List of all members.

Public Member Functions

CSProfile (void)
~CSProfile (void)
CString | Get (LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
int | Get (LPCTSTR profile, LPCTSTR entry, int def)
BOOL | Put (LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
BOOL | Put (LPCTSTR profile, LPCTSTR entry, int def)
void | LoadProfile ()
void | SaveProfile ()

Public Attributes

BOOL | isScaleLog
BOOL | isPlotLine
CString | profile
int | device_type
int | data_refresh
string | strDevice

Detailed Description

Definition at line 17 of file SProfile.h.

Constructor & Destructor Documentation

CSProfile::CSProfile ( void )

Definition at line 6 of file SProfile.cpp.

CSProfile::~CSProfile ( void )

Definition at line 12 of file SProfile.cpp.

Member Function Documentation

CString CSProfile::Get | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | LPCTSTR | def
 | ) |  |

Definition at line 16 of file SProfile.cpp.

int CSProfile::Get | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | int | def
 | ) |  |

Definition at line 21 of file SProfile.cpp.

void CSProfile::LoadProfile ( )

Definition at line 36 of file SProfile.cpp.

Here is the caller graph for this function:

BOOL CSProfile::Put | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | LPCTSTR | def
 | ) |  |

Definition at line 26 of file SProfile.cpp.

BOOL CSProfile::Put | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | int | def
 | ) |  |

Definition at line 31 of file SProfile.cpp.

void CSProfile::SaveProfile ( )

Definition at line 44 of file SProfile.cpp.

Here is the caller graph for this function:

Member Data Documentation

int CSProfile::data_refresh

Definition at line 37 of file SProfile.h.

int CSProfile::device_type

Definition at line 36 of file SProfile.h.

BOOL CSProfile::isPlotLine

Definition at line 33 of file SProfile.h.

BOOL CSProfile::isScaleLog

Definition at line 32 of file SProfile.h.

CString CSProfile::profile

Definition at line 35 of file SProfile.h.

string CSProfile::strDevice

Definition at line 38 of file SProfile.h.

The documentation for this class was generated from the following files:
  • SProfile.h
  • SProfile.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CTuneSlowThreshold Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CTuneSlowThreshold Class Reference

#include <TuneSlowThreshold.h>

List of all members.

Public Member Functions

CTuneSlowThreshold (void)
~CTuneSlowThreshold (void)
double | SetSlowThreshToChPos (int ChPosIn, int mcaCH)
void | DelayTask (DWORD d)
int | GetSlowThreshCalStart (double *SpectrumBuffer, double UpperChMax, int mcaCH)
double | GetUpperChCounts (double *SpectrumBuffer, int mcaCH)
double | GetUpperChMax (double *SpectrumBuffer, int mcaCH)
void | GetSpectrumData (double *dblMCAData, long *lngMCAData, int mcaCH)
int | UpdatePlotCursorPosFromIntChPos (int CurCh, double dblPixPerChan)
void | DisplaySpecBuf25 (double *SpectrumBuffer)
int | GetSlowThreshChStrFromVal (UCHAR byteSlowThres, int mcaCH)

Detailed Description

Definition at line 9 of file TuneSlowThreshold.h.

Constructor & Destructor Documentation

CTuneSlowThreshold::CTuneSlowThreshold ( void )

Definition at line 8 of file TuneSlowThreshold.cpp.

CTuneSlowThreshold::~CTuneSlowThreshold ( void )

Definition at line 12 of file TuneSlowThreshold.cpp.

Member Function Documentation

void CTuneSlowThreshold::DelayTask ( DWORD d )

Definition at line 105 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

void CTuneSlowThreshold::DisplaySpecBuf25 ( double * SpectrumBuffer )

Definition at line 132 of file TuneSlowThreshold.cpp.

int CTuneSlowThreshold::GetSlowThreshCalStart | ( | double * | SpectrumBuffer,
 |  | double | UpperChMax,
 |  | int | mcaCH
 | ) |  |

Definition at line 39 of file TuneSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CTuneSlowThreshold::GetSlowThreshChStrFromVal | ( | UCHAR | byteSlowThres,
 |  | int | mcaCH
 | ) |  |

Definition at line 146 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

void CTuneSlowThreshold::GetSpectrumData | ( | double * | dblMCAData,
 |  | long * | lngMCAData,
 |  | int | mcaCH
 | ) |  |

Definition at line 16 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

double CTuneSlowThreshold::GetUpperChCounts | ( | double * | SpectrumBuffer,
 |  | int | mcaCH
 | ) |  |

Definition at line 79 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

double CTuneSlowThreshold::GetUpperChMax | ( | double * | SpectrumBuffer,
 |  | int | mcaCH
 | ) |  |

Definition at line 93 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

double CTuneSlowThreshold::SetSlowThreshToChPos | ( | int | ChPosIn,
 |  | int | mcaCH
 | ) |  |

Definition at line 22 of file TuneSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CTuneSlowThreshold::UpdatePlotCursorPosFromIntChPos | ( | int | CurCh,
 |  | double | dblPixPerChan
 | ) |  |

Definition at line 119 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • Config/TuneSlowThreshold.h
  • Config/TuneSlowThreshold.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CvcDP5App Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
CvcDP5App Class Reference

#include <vcDP5.h>

List of all members.

Public Member Functions

CvcDP5App ()
virtual BOOL InitInstance ()

Detailed Description

Definition at line 20 of file vcDP5.h.

Constructor & Destructor Documentation

CvcDP5App::CvcDP5App ( )

Definition at line 25 of file vcDP5.cpp.

Member Function Documentation

BOOL CvcDP5App::InitInstance ( ) [virtual]

Definition at line 45 of file vcDP5.cpp.

Here is the call graph for this function:

The documentation for this class was generated from the following files:
  • vcDP5.h
  • vcDP5.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CvcDP5Dlg Class Reference

  • Class List
  • Class Index
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CvcDP5Dlg Class Reference

#include <vcDP5Dlg.h>

Collaboration diagram for CvcDP5Dlg:
[legend]

List of all members.

Public Types

enum | { IDD = IDD_vcDP5_DIALOG }

Public Member Functions

CvcDP5Dlg (CWnd *pParent=NULL)
~CvcDP5Dlg ()
bool | BOOL_TO_bool (BOOL bValue)
afx_msg void | OnBnClickedButtonFindDevice ()
afx_msg BOOL | OnDeviceChange (UINT nEventType, DWORD_PTR dwData)
afx_msg void | OnDestroy ()
ULONG | DataTest ()
void | SetCheckButtonState (int iCheckBox, bool bChecked)
afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnBnClickedButtonArmTrigger ()
void | SaveTestSpectrumFile (int iFileIndex)
afx_msg void | OnBnClickedButtonSaveFile ()
afx_msg void | OnBnClickedButtonClearDataAndGraph ()
afx_msg void | OnBnClickedButtonSingleUpdate ()
afx_msg void | OnBnClickedButtonClearMiscData ()
afx_msg void | OnBnClickedButtonReadMiscData ()
afx_msg void | OnBnClickedButtonWriteMiscData ()
void | ShowStatus (string strStatus)
void | ParsePacketEx (Packet_In PIN, DppStateType DppState)
void | ProcessDiagDataEx (Packet_In PIN, DppStateType DppState)
void | ProcessStatusEx (Packet_In PIN, DppStateType DppState)
void | ProcessSpectrumEx (Packet_In PIN, DppStateType DppState)
void | ProcessScopeDataEx (Packet_In PIN, DppStateType DppState)
void | ProcessTextDataEx (Packet_In PIN, DppStateType DppState)
void | ProcessAck (BYTE PID2)
void | DisplayError (Packet_In PIN, DppStateType DppState)
void | RequestScopeData (BOOL ScopeDataReady)
void | SendCommand (TRANSMIT_PACKET_TYPE XmtCmd)
void | SendCommandConfig (TRANSMIT_PACKET_TYPE XmtCmd)
string | CreateSpectrumConfig (string strRawCfgIn)
void | SendCommandData (TRANSMIT_PACKET_TYPE XmtCmd, BYTE DataOut[])
void | RemCallParsePacket (BYTE PacketIn[])
void | PlotData (long DataBuffer[8192], int NumChan)
void | UpdatePlot ()
void | ScopeDisplay (BYTE ScopeData[2048])
void | UpdateScope ()
void | EnableDPPFunctions (BOOL isEnabled)
afx_msg void | OnBnClickedButtonDiag ()
afx_msg LONG | OnReceive (UINT, LONG)
afx_msg void | OnBnClickedButtonSelectComm ()
void | OnResetCommunications ()
afx_msg void | OnBnClickedButtonGetSpectrum ()
void | ShowRepeatStatus (bool bShowStatus)
afx_msg void | OnBnClickedButtonStartAcquisition ()
afx_msg void | OnBnClickedButtonStopAcquisition ()
string | GetDeviceNameFromVal (int DeviceTypeVal)
BOOL | isConnectedTest ()
afx_msg LRESULT | DppSendConfigToHw (WPARAM wParam, LPARAM lParam)
void | ProcessCfgReadEx (Packet_In PIN, DppStateType DppState)
string | GetCmdData (string strCmd, string strCfgData)
string | GetCmdDesc (string strCmd)
string | ReplaceCmdDesc (string strCmd, string strCfgData)
string | AppendCmdDesc (string strCmd, string strCfgData)
vector< string > | MakeDp5CmdList ()
void | CopyDp5CfgToClip (string strCfg, string strDesc)
afx_msg LRESULT | CallReadDppConfig (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | CallReadScaConfig (WPARAM wParam, LPARAM lParam)
afx_msg void | OnBnClickedButtonShowConfig ()
void | SendConfigFromFileToDpp ()
void | ButtonSendStringCfgToHardware (CString strCfgIn)
afx_msg void | OnBnClickedRadioPlotScaleLinear ()
afx_msg void | OnBnClickedRadioPlotScaleLog ()
afx_msg void | OnBnClickedRadioPlotTypeSolid ()
afx_msg void | OnBnClickedRadioPlotTypeLine ()
void | SaveMCAFile (string strFilename, string strMCA)
afx_msg void | OnBnClickedBtnSaveFile ()
string | CreateMCAData (long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst)
void | SetStartTime ()
afx_msg void | OnStnClickedPlotpicturecontrol ()
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
afx_msg void | OnBnClickedOk ()
afx_msg void | OnBnClickedCancel ()
void | SetPlotChannel ()
afx_msg BOOL | OnToolTipNotify (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
afx_msg void | TuneFastSlowThresh ()
afx_msg void | OnBnClickedButtonAutotune ()
double | GetPixPerChannel ()
string | CreateDTS (string strFormat)
afx_msg void | OnBnClickedCheckRepeatSpectrum ()
CString | ParsePerformanceNotes (CString str)
CString | TextToBlockString (CString &str, char *prefix)
CString | CreateTextBlockTest ()
void | SendDppInfoTextBlock (CString strLowerTextBlock, CString strInfoTextBlock)
void | WriteTextBlock ()
void | ParseTextBlockNotes (CString strTextBlock)
BOOL | ExtractNote (CString &rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep)
void | CopyTextToClip (CString strTextIn)
void | OnBnClickedButtonWriteTextBlock ()
bool | SendManufacturingTextBlock (CString generalNotes)

Public Attributes

UINT_PTR | m_nTmrRS232Id
UINT_PTR | m_nTmrRS232EventId
UINT | m_nTmrRS232Elapse
UINT_PTR | m_nTmrSpectrumId
UINT_PTR | m_nTmrSpectrumEventId
UINT | m_nTmrSpectrumElapse
UINT_PTR | m_nTmrTimeoutId
UINT_PTR | m_nTmrTimeoutEventId
UINT | m_nTmrTimeoutElapse
BOOL | TimeoutFlag
CPlotCanvas m_PicturePlot
long | PlotBuffer [8192]
char | szSettings [3000]
long | XPlotMAX
long | YPlotMAX
BOOL | HavePlot
CStatic | m_PictureScope
BYTE | ScopeBuffer [2048]
BOOL | HaveTrace
CLabel lblSelectCommunications
CLabel lblStatus
CLabel lblMiscStatus
vector< string > | Dp5CmdList
CPoint | CursorPosition
int | CurrentChannel
BOOL | b80MHzMode
BOOL | DisplayCfg
BOOL | CfgReadBack
BOOL | DisplaySca
BOOL | ScaReadBack
BOOL | SaveCfg
BOOL | PrintCfg
string | strPresetCmd
string | strPresetVal
int | DeviceType
BOOL | isDeltaMode
long | mcaCH
string | strAnalogOut
string | strInputOffset
string | strOutputOffset
string | strScopeGain
string | strTriggerSource
string | strTriggerPosition
string | strTriggerSlope
BOOL | UpdateScopeCfg
string | strMcaMode
UCHAR | AcqMode
UCHAR | SlowChThreshold
double | SlowThresholdPct
UCHAR | FastChThreshold
double | RiseUS
string | strGainDisplayValue
double | PresetRt
double | PresetAcq
unsigned long | PresetCount
BOOL | isDppConnected
string | HwCfgDP5
string | HwCfgDP5Out
BOOL | HwCfgReady
BOOL | HwCfgExReady
CParsePacket ParsePkt
CDP5Status DP5Stat
HWND | hWnd_Main
int | idxCurrentSpectrum
int | idxTotalSpectra
bool | bSpectraTestRunning
CString | strLowerMiscData
CString | strUpperMiscData

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | OnInitDialog ()
afx_msg void | OnSysCommand (UINT nID, LPARAM lParam)
afx_msg void | OnPaint ()
afx_msg HCURSOR | OnQueryDragIcon ()

Protected Attributes

HICON | m_hIcon

Detailed Description

Definition at line 31 of file vcDP5Dlg.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 39 of file vcDP5Dlg.h.

Constructor & Destructor Documentation

CvcDP5Dlg::CvcDP5Dlg ( CWnd * pParent = NULL )

Definition at line 58 of file vcDP5Dlg.cpp.

CvcDP5Dlg::~CvcDP5Dlg ( )

Definition at line 98 of file vcDP5Dlg.cpp.

Member Function Documentation

string CvcDP5Dlg::AppendCmdDesc | ( | string | strCmd,
 |  | string | strCfgData
 | ) |  |

Definition at line 1210 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CvcDP5Dlg::BOOL_TO_bool ( BOOL bValue )

Definition at line 228 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::ButtonSendStringCfgToHardware ( CString strCfgIn )

Definition at line 1477 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

LRESULT CvcDP5Dlg::CallReadDppConfig | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 991 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

LRESULT CvcDP5Dlg::CallReadScaConfig | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 1000 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::CopyDp5CfgToClip | ( | string | strCfg,
 |  | string | strDesc
 | ) |  |

Definition at line 1434 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::CopyTextToClip ( CString strTextIn )

Definition at line 2210 of file vcDP5Dlg.cpp.

string CvcDP5Dlg::CreateDTS ( string strFormat )

Definition at line 2033 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CvcDP5Dlg::CreateMCAData | ( | long | m_larDataBuffer[],
 |  | SpectrumFileType | sfInfo,
 |  | DP4_FORMAT_STATUS | cfgStatusLst
 | ) |  |

Definition at line 1700 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CvcDP5Dlg::CreateSpectrumConfig ( string strRawCfgIn )

Definition at line 597 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CvcDP5Dlg::CreateTextBlockTest ( )

Definition at line 2227 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

ULONG CvcDP5Dlg::DataTest ( )

Definition at line 344 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::DisplayError | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 448 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 103 of file vcDP5Dlg.cpp.

LRESULT CvcDP5Dlg::DppSendConfigToHw | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 971 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::EnableDPPFunctions ( BOOL isEnabled )

Definition at line 808 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

BOOL CvcDP5Dlg::ExtractNote | ( | CString & | rString,
 |  | LPCTSTR | lpszFullString,
 |  | int | iSubString,
 |  | TCHAR | chSep
 | ) |  |

Definition at line 2182 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

string CvcDP5Dlg::GetCmdData | ( | string | strCmd,
 |  | string | strCfgData
 | ) |  |

Definition at line 1168 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

string CvcDP5Dlg::GetCmdDesc ( string strCmd )

Definition at line 1297 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

string CvcDP5Dlg::GetDeviceNameFromVal ( int DeviceTypeVal )

Definition at line 873 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

double CvcDP5Dlg::GetPixPerChannel ( )

Definition at line 1861 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

BOOL CvcDP5Dlg::isConnectedTest ( )

Definition at line 900 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

vector< string > CvcDP5Dlg::MakeDp5CmdList ( )

Definition at line 1232 of file vcDP5Dlg.cpp.

afx_msg void CvcDP5Dlg::OnBnClickedBtnSaveFile ( )
void CvcDP5Dlg::OnBnClickedButtonArmTrigger ( )

Definition at line 692 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonAutotune ( )

Definition at line 2021 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonClearDataAndGraph ( )

Definition at line 697 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::OnBnClickedButtonClearMiscData ( )

Definition at line 719 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedButtonDiag ( )

Definition at line 833 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonFindDevice ( )

Definition at line 375 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

afx_msg void CvcDP5Dlg::OnBnClickedButtonGetSpectrum ( )
void CvcDP5Dlg::OnBnClickedButtonReadMiscData ( )

Definition at line 724 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonSaveFile ( )

Definition at line 1646 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonSelectComm ( )

Definition at line 838 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonShowConfig ( )

Definition at line 1448 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonSingleUpdate ( )

Definition at line 705 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonStartAcquisition ( )

Definition at line 931 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonStopAcquisition ( )

Definition at line 965 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonWriteMiscData ( )

Definition at line 729 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonWriteTextBlock ( )
void CvcDP5Dlg::OnBnClickedCancel ( )

Definition at line 1877 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedCheckRepeatSpectrum ( )

Definition at line 2050 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::OnBnClickedOk ( )

Definition at line 1872 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotScaleLinear ( )

Definition at line 1567 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotScaleLog ( )

Definition at line 1578 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotTypeLine ( )

Definition at line 1600 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotTypeSolid ( )

Definition at line 1589 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnDestroy ( )

Definition at line 330 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

BOOL CvcDP5Dlg::OnDeviceChange | ( | UINT | nEventType,
 |  | DWORD_PTR | dwData
 | ) |  |

Definition at line 287 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

BOOL CvcDP5Dlg::OnInitDialog ( ) [protected, virtual]

Definition at line 155 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  |

Definition at line 1784 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnPaint ( ) [protected]

Definition at line 254 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

HCURSOR CvcDP5Dlg::OnQueryDragIcon ( ) [protected]

Definition at line 282 of file vcDP5Dlg.cpp.

afx_msg LONG CvcDP5Dlg::OnReceive | ( | UINT | ,
 |  | LONG |
 | ) |  |
void CvcDP5Dlg::OnResetCommunications ( )

Definition at line 323 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::OnStnClickedPlotpicturecontrol ( )

Definition at line 1771 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnSysCommand | ( | UINT | nID,
 |  | LPARAM | lParam
 | ) |  | [protected]

Definition at line 237 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnTimer ( UINT nIDEvent )

Definition at line 643 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

BOOL CvcDP5Dlg::OnToolTipNotify | ( | UINT | id,
 |  | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  |

Definition at line 1885 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::ParsePacketEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 395 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CvcDP5Dlg::ParsePerformanceNotes ( CString str )

Definition at line 2063 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::ParseTextBlockNotes ( CString strTextBlock )

Definition at line 2131 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::PlotData | ( | long | DataBuffer[8192],
 |  | int | NumChan
 | ) |  |
BOOL CvcDP5Dlg::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 1802 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::ProcessAck ( BYTE PID2 )

Definition at line 460 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessCfgReadEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 1009 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessDiagDataEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 476 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessScopeDataEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 521 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessSpectrumEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 484 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessStatusEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 465 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessTextDataEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 529 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::RemCallParsePacket ( BYTE PacketIn[] )

Definition at line 389 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CvcDP5Dlg::ReplaceCmdDesc | ( | string | strCmd,
 |  | string | strCfgData
 | ) |  |

Definition at line 1187 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::RequestScopeData ( BOOL ScopeDataReady )

Definition at line 544 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SaveMCAFile | ( | string | strFilename,
 |  | string | strMCA
 | ) |  |

Definition at line 1693 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::SaveTestSpectrumFile ( int iFileIndex )

Definition at line 1608 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ScopeDisplay ( BYTE ScopeData[2048] )

Definition at line 798 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendCommand ( TRANSMIT_PACKET_TYPE XmtCmd )

Definition at line 551 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendCommandConfig ( TRANSMIT_PACKET_TYPE XmtCmd )

Definition at line 573 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendCommandData | ( | TRANSMIT_PACKET_TYPE | XmtCmd,
 |  | BYTE | DataOut[]
 | ) |  |

Definition at line 614 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendConfigFromFileToDpp ( )

Definition at line 1461 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::SendDppInfoTextBlock | ( | CString | strLowerTextBlock,
 |  | CString | strInfoTextBlock
 | ) |  |

Definition at line 2243 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CvcDP5Dlg::SendManufacturingTextBlock ( CString generalNotes )

Definition at line 2324 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::SetCheckButtonState | ( | int | iCheckBox,
 |  | bool | bChecked
 | ) |  |

Definition at line 630 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::SetPlotChannel ( )

Definition at line 1835 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SetStartTime ( )
void CvcDP5Dlg::ShowRepeatStatus ( bool bShowStatus = false )

Definition at line 920 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ShowStatus ( string strStatus )

Definition at line 749 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

CString CvcDP5Dlg::TextToBlockString | ( | CString & | str,
 |  | char * | prefix
 | ) |  |

Definition at line 2103 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::TuneFastSlowThresh ( )

Definition at line 1919 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::UpdatePlot ( )
void CvcDP5Dlg::UpdateScope ( )

Definition at line 758 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::WriteTextBlock ( )

Definition at line 2269 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Member Data Documentation

UCHAR CvcDP5Dlg::AcqMode

Definition at line 222 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::b80MHzMode

Definition at line 191 of file vcDP5Dlg.h.

bool CvcDP5Dlg::bSpectraTestRunning

Definition at line 247 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::CfgReadBack

Definition at line 194 of file vcDP5Dlg.h.

int CvcDP5Dlg::CurrentChannel

Definition at line 177 of file vcDP5Dlg.h.

CPoint CvcDP5Dlg::CursorPosition

Definition at line 176 of file vcDP5Dlg.h.

int CvcDP5Dlg::DeviceType

Definition at line 205 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::DisplayCfg

Definition at line 193 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::DisplaySca

Definition at line 196 of file vcDP5Dlg.h.

vector<string> CvcDP5Dlg::Dp5CmdList

Definition at line 152 of file vcDP5Dlg.h.

CDP5Status CvcDP5Dlg::DP5Stat

Definition at line 242 of file vcDP5Dlg.h.

UCHAR CvcDP5Dlg::FastChThreshold

Definition at line 225 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::HavePlot

Definition at line 116 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::HaveTrace

Definition at line 122 of file vcDP5Dlg.h.

string CvcDP5Dlg::HwCfgDP5

Definition at line 234 of file vcDP5Dlg.h.

string CvcDP5Dlg::HwCfgDP5Out

Definition at line 235 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::HwCfgExReady

Definition at line 237 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::HwCfgReady

Definition at line 236 of file vcDP5Dlg.h.

HWND CvcDP5Dlg::hWnd_Main

Definition at line 243 of file vcDP5Dlg.h.

int CvcDP5Dlg::idxCurrentSpectrum

Definition at line 245 of file vcDP5Dlg.h.

int CvcDP5Dlg::idxTotalSpectra

Definition at line 246 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::isDeltaMode

Definition at line 206 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::isDppConnected

Definition at line 233 of file vcDP5Dlg.h.

CLabel CvcDP5Dlg::lblMiscStatus

Definition at line 133 of file vcDP5Dlg.h.

CLabel CvcDP5Dlg::lblSelectCommunications

Definition at line 131 of file vcDP5Dlg.h.

CLabel CvcDP5Dlg::lblStatus

Definition at line 132 of file vcDP5Dlg.h.

HICON CvcDP5Dlg::m_hIcon [protected]

Definition at line 47 of file vcDP5Dlg.h.

UINT CvcDP5Dlg::m_nTmrRS232Elapse

Definition at line 93 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrRS232EventId

Definition at line 92 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrRS232Id

Definition at line 91 of file vcDP5Dlg.h.

UINT CvcDP5Dlg::m_nTmrSpectrumElapse

Definition at line 98 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrSpectrumEventId

Definition at line 97 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrSpectrumId

Definition at line 96 of file vcDP5Dlg.h.

UINT CvcDP5Dlg::m_nTmrTimeoutElapse

Definition at line 103 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrTimeoutEventId

Definition at line 102 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrTimeoutId

Definition at line 101 of file vcDP5Dlg.h.

CPlotCanvas CvcDP5Dlg::m_PicturePlot

Definition at line 107 of file vcDP5Dlg.h.

CStatic CvcDP5Dlg::m_PictureScope

Definition at line 118 of file vcDP5Dlg.h.

long CvcDP5Dlg::mcaCH

Definition at line 208 of file vcDP5Dlg.h.

CParsePacket CvcDP5Dlg::ParsePkt

Definition at line 240 of file vcDP5Dlg.h.

long CvcDP5Dlg::PlotBuffer[8192]

Definition at line 111 of file vcDP5Dlg.h.

double CvcDP5Dlg::PresetAcq

Definition at line 229 of file vcDP5Dlg.h.

unsigned long CvcDP5Dlg::PresetCount

Definition at line 230 of file vcDP5Dlg.h.

double CvcDP5Dlg::PresetRt

Definition at line 228 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::PrintCfg

Definition at line 200 of file vcDP5Dlg.h.

double CvcDP5Dlg::RiseUS

Definition at line 226 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::SaveCfg

Definition at line 199 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::ScaReadBack

Definition at line 197 of file vcDP5Dlg.h.

BYTE CvcDP5Dlg::ScopeBuffer[2048]

Definition at line 121 of file vcDP5Dlg.h.

UCHAR CvcDP5Dlg::SlowChThreshold

Definition at line 223 of file vcDP5Dlg.h.

double CvcDP5Dlg::SlowThresholdPct

Definition at line 224 of file vcDP5Dlg.h.

string CvcDP5Dlg::strAnalogOut

Definition at line 212 of file vcDP5Dlg.h.

string CvcDP5Dlg::strGainDisplayValue

Definition at line 227 of file vcDP5Dlg.h.

string CvcDP5Dlg::strInputOffset

Definition at line 213 of file vcDP5Dlg.h.

CString CvcDP5Dlg::strLowerMiscData

Definition at line 254 of file vcDP5Dlg.h.

string CvcDP5Dlg::strMcaMode

Definition at line 221 of file vcDP5Dlg.h.

string CvcDP5Dlg::strOutputOffset

Definition at line 214 of file vcDP5Dlg.h.

string CvcDP5Dlg::strPresetCmd

Definition at line 202 of file vcDP5Dlg.h.

string CvcDP5Dlg::strPresetVal

Definition at line 203 of file vcDP5Dlg.h.

string CvcDP5Dlg::strScopeGain

Definition at line 215 of file vcDP5Dlg.h.

string CvcDP5Dlg::strTriggerPosition

Definition at line 217 of file vcDP5Dlg.h.

string CvcDP5Dlg::strTriggerSlope

Definition at line 218 of file vcDP5Dlg.h.

string CvcDP5Dlg::strTriggerSource

Definition at line 216 of file vcDP5Dlg.h.

CString CvcDP5Dlg::strUpperMiscData

Definition at line 255 of file vcDP5Dlg.h.

char CvcDP5Dlg::szSettings[3000]

Definition at line 112 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::TimeoutFlag

Definition at line 104 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::UpdateScopeCfg

Definition at line 219 of file vcDP5Dlg.h.

long CvcDP5Dlg::XPlotMAX

Definition at line 113 of file vcDP5Dlg.h.

long CvcDP5Dlg::YPlotMAX

Definition at line 114 of file vcDP5Dlg.h.

The documentation for this class was generated from the following files:
  • vcDP5Dlg.h
  • vcDP5Dlg.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: cWaitDialog Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
cWaitDialog Class Reference

#include <CmdWaitDlg.h>

Collaboration diagram for cWaitDialog:
[legend]

List of all members.

Public Member Functions

void | Close ()
void | Show ()
virtual | ~cWaitDialog ()

Public Attributes

cWaitDlgThread * m_Thread
bool | m_bShowCancelButton
HANDLE | m_Event
CString | m_Text
CString | m_EventName

Detailed Description

Definition at line 25 of file CmdWaitDlg.h.

Constructor & Destructor Documentation

cWaitDialog::~cWaitDialog ( ) [virtual]

Definition at line 26 of file CmdWaitDlg.cpp.

Member Function Documentation

void cWaitDialog::Close ( )

Definition at line 51 of file CmdWaitDlg.cpp.

Here is the caller graph for this function:

void cWaitDialog::Show ( )

Definition at line 40 of file CmdWaitDlg.cpp.

Here is the caller graph for this function:

Member Data Documentation

bool cWaitDialog::m_bShowCancelButton

Definition at line 34 of file CmdWaitDlg.h.

HANDLE cWaitDialog::m_Event

Definition at line 35 of file CmdWaitDlg.h.

CString cWaitDialog::m_EventName

Definition at line 37 of file CmdWaitDlg.h.

CString cWaitDialog::m_Text

Definition at line 36 of file CmdWaitDlg.h.

cWaitDlgThread* cWaitDialog::m_Thread

Definition at line 33 of file CmdWaitDlg.h.

The documentation for this class was generated from the following files:
  • waitdlg/CmdWaitDlg.h
  • waitdlg/CmdWaitDlg.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: cWaitDlg Class Reference

  • Class List
  • Class Index
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions
cWaitDlg Class Reference

#include <WaitDlg.h>

Collaboration diagram for cWaitDlg:
[legend]

List of all members.

Public Types

enum | { IDD = IDD_BUSY_DLG }

Public Member Functions

cWaitDlg (CWnd *pParent=NULL)

Public Attributes

cWaitDlgThread * m_Thread
cAnimWnd m_Anim
CString | m_Text
bool | m_bShowCancelButton

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual void | OnCancel ()
virtual void | OnOK ()
virtual BOOL | OnInitDialog ()
afx_msg void | OnTimer (UINT nIDEvent)

Detailed Description

Definition at line 18 of file WaitDlg.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 26 of file WaitDlg.h.

Constructor & Destructor Documentation

cWaitDlg::cWaitDlg ( CWnd * pParent = NULL )

Definition at line 19 of file WaitDlg.cpp.

Member Function Documentation

void cWaitDlg::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 30 of file WaitDlg.cpp.

void cWaitDlg::OnCancel ( ) [protected, virtual]

Definition at line 47 of file WaitDlg.cpp.

BOOL cWaitDlg::OnInitDialog ( ) [protected, virtual]

Definition at line 63 of file WaitDlg.cpp.

Here is the call graph for this function:

void cWaitDlg::OnOK ( ) [protected, virtual]

Definition at line 53 of file WaitDlg.cpp.

Here is the caller graph for this function:

void cWaitDlg::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 86 of file WaitDlg.cpp.

Here is the call graph for this function:

Member Data Documentation

cAnimWnd cWaitDlg::m_Anim

Definition at line 30 of file WaitDlg.h.

bool cWaitDlg::m_bShowCancelButton

Definition at line 32 of file WaitDlg.h.

CString cWaitDlg::m_Text

Definition at line 31 of file WaitDlg.h.

cWaitDlgThread* cWaitDlg::m_Thread

Definition at line 29 of file WaitDlg.h.

The documentation for this class was generated from the following files:
  • waitdlg/WaitDlg.h
  • waitdlg/WaitDlg.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: cWaitDlgThread Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
cWaitDlgThread Class Reference

#include <WaitDlgThread.h>

List of all members.

Public Member Functions

cWaitDlgThread ()
virtual BOOL | InitInstance ()
virtual int | ExitInstance ()
virtual | ~cWaitDlgThread ()

Public Attributes

CString | m_Eventname
CEvent * | m_Event
bool | m_bShowCancelButton
CString | m_Text

Detailed Description

Definition at line 25 of file WaitDlgThread.h.

Constructor & Destructor Documentation

cWaitDlgThread::cWaitDlgThread ( )

Definition at line 21 of file WaitDlgThread.cpp.

cWaitDlgThread::~cWaitDlgThread ( ) [virtual]

Definition at line 27 of file WaitDlgThread.cpp.

Member Function Documentation

int cWaitDlgThread::ExitInstance ( ) [virtual]

Definition at line 47 of file WaitDlgThread.cpp.

BOOL cWaitDlgThread::InitInstance ( ) [virtual]

Definition at line 31 of file WaitDlgThread.cpp.

Member Data Documentation

bool cWaitDlgThread::m_bShowCancelButton

Definition at line 38 of file WaitDlgThread.h.

CEvent* cWaitDlgThread::m_Event

Definition at line 37 of file WaitDlgThread.h.

CString cWaitDlgThread::m_Eventname

Definition at line 36 of file WaitDlgThread.h.

CString cWaitDlgThread::m_Text

Definition at line 39 of file WaitDlgThread.h.

The documentation for this class was generated from the following files:
  • waitdlg/WaitDlgThread.h
  • waitdlg/WaitDlgThread.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CWinusbNotify Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions | Public Attributes
CWinusbNotify Class Reference

#include <WinusbNotify.h>

List of all members.

Public Member Functions

CWinusbNotify (void)
~CWinusbNotify (void)
void | InitDeviceInfo ()
void | SetNotificationWindow (HWND m_hWnd)
void | RegDeviceNotification ()
BOOL | GetDevNotifyInfo (DWORD_PTR dwData, char devicePath[])
void | RemoveDeviceNotification ()
BOOL | UnregDeviceNotification (HDEVNOTIFY Handle)

Public Attributes

HDEVNOTIFY | DeviceNotificationHandle
HWND | m_hWndOwner

Detailed Description

CWinusbNotify CWinusbNotify

Definition at line 5 of file WinusbNotify.h.

Constructor & Destructor Documentation

CWinusbNotify::CWinusbNotify ( void )

Definition at line 4 of file WinusbNotify.cpp.

CWinusbNotify::~CWinusbNotify ( void )

Definition at line 10 of file WinusbNotify.cpp.

Member Function Documentation

BOOL CWinusbNotify::GetDevNotifyInfo | ( | DWORD_PTR | dwData,
 |  | char | devicePath[]
 | ) |  |

Definition at line 35 of file WinusbNotify.cpp.

Here is the caller graph for this function:

void CWinusbNotify::InitDeviceInfo ( )

Definition at line 19 of file WinusbNotify.cpp.

void CWinusbNotify::RegDeviceNotification ( )

Definition at line 24 of file WinusbNotify.cpp.

void CWinusbNotify::RemoveDeviceNotification ( )

Definition at line 56 of file WinusbNotify.cpp.

Here is the caller graph for this function:

void CWinusbNotify::SetNotificationWindow ( HWND m_hWnd )

Definition at line 14 of file WinusbNotify.cpp.

Here is the caller graph for this function:

BOOL CWinusbNotify::UnregDeviceNotification ( HDEVNOTIFY Handle )

Definition at line 63 of file WinusbNotify.cpp.

Member Data Documentation

HDEVNOTIFY CWinusbNotify::DeviceNotificationHandle

Definition at line 10 of file WinusbNotify.h.

HWND CWinusbNotify::m_hWndOwner

Definition at line 12 of file WinusbNotify.h.

The documentation for this class was generated from the following files:
  • DeviceIO/WinusbNotify.h
  • DeviceIO/WinusbNotify.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DP5_DP4_FORMAT_STATUS Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
DP5_DP4_FORMAT_STATUS Struct Reference

#include <DP5Status.h>

List of all members.

Public Attributes

unsigned char | RAW [64]
unsigned long | SerialNumber
double | FastCount
double | SlowCount
unsigned char | FPGA
unsigned char | Firmware
unsigned char | Build
double | AccumulationTime
double | RealTime
double | LiveTime
double | HV
double | DET_TEMP
double | DP5_TEMP
bool | PX4
bool | AFAST_LOCKED
bool | MCA_EN
bool | PRECNT_REACHED
bool | PresetRtDone
bool | PresetLtDone
bool | SUPPLIES_ON
bool | SCOPE_DR
bool | DP5_CONFIGURED
double | GP_COUNTER
bool | AOFFSET_LOCKED
bool | MCS_DONE
bool | RAM_TEST_RUN
bool | RAM_TEST_ERROR
double | DCAL
unsigned char | PZCORR
unsigned char | UC_TEMP_OFFSET
double | AN_IN
double | VREF_IN
unsigned long | PC5_SN
bool | PC5_PRESENT
bool | PC5_HV_POL
bool | PC5_8_5V
double | ADC_GAIN_CAL
unsigned char | ADC_OFFSET_CAL
long | SPECTRUM_OFFSET
bool | b80MHzMode
bool | bFPGAAutoClock
unsigned char | DEVICE_ID
bool | ReBootFlag
unsigned char | DPP_options
bool | HPGe_HV_INH
bool | HPGe_HV_INH_POL
double | TEC_Voltage
unsigned char | DPP_ECO
bool | AU34_2
bool | isAscInstalled
bool | isAscEnabled
bool | bScintHas80MHzOption
bool | isDP5_RevDxGains

Detailed Description

Definition at line 23 of file DP5Status.h.

Member Data Documentation

double DP5_DP4_FORMAT_STATUS::AccumulationTime

Definition at line 32 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::ADC_GAIN_CAL

Definition at line 61 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::ADC_OFFSET_CAL

Definition at line 62 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::AFAST_LOCKED

Definition at line 39 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::AN_IN

Definition at line 55 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::AOFFSET_LOCKED

Definition at line 48 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::AU34_2

Definition at line 73 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::b80MHzMode

Definition at line 64 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::bFPGAAutoClock

Definition at line 65 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::bScintHas80MHzOption

Definition at line 76 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::Build

Definition at line 31 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::DCAL

Definition at line 52 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::DET_TEMP

Definition at line 36 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::DEVICE_ID

Definition at line 66 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::DP5_CONFIGURED

Definition at line 46 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::DP5_TEMP

Definition at line 37 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::DPP_ECO

Definition at line 72 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::DPP_options

Definition at line 68 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::FastCount

Definition at line 27 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::Firmware

Definition at line 30 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::FPGA

Definition at line 29 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::GP_COUNTER

Definition at line 47 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::HPGe_HV_INH

Definition at line 69 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::HPGe_HV_INH_POL

Definition at line 70 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::HV

Definition at line 35 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::isAscEnabled

Definition at line 75 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::isAscInstalled

Definition at line 74 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::isDP5_RevDxGains

Definition at line 77 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::LiveTime

Definition at line 34 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::MCA_EN

Definition at line 40 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::MCS_DONE

Definition at line 49 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PC5_8_5V

Definition at line 60 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PC5_HV_POL

Definition at line 59 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PC5_PRESENT

Definition at line 58 of file DP5Status.h.

unsigned long DP5_DP4_FORMAT_STATUS::PC5_SN

Definition at line 57 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PRECNT_REACHED

Definition at line 41 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PresetLtDone

Definition at line 43 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PresetRtDone

Definition at line 42 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PX4

Definition at line 38 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::PZCORR

Definition at line 53 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::RAM_TEST_ERROR

Definition at line 51 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::RAM_TEST_RUN

Definition at line 50 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::RAW[64]

Definition at line 25 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::RealTime

Definition at line 33 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::ReBootFlag

Definition at line 67 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::SCOPE_DR

Definition at line 45 of file DP5Status.h.

unsigned long DP5_DP4_FORMAT_STATUS::SerialNumber

Definition at line 26 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::SlowCount

Definition at line 28 of file DP5Status.h.

long DP5_DP4_FORMAT_STATUS::SPECTRUM_OFFSET

Definition at line 63 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::SUPPLIES_ON

Definition at line 44 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::TEC_Voltage

Definition at line 71 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::UC_TEMP_OFFSET

Definition at line 54 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::VREF_IN

Definition at line 56 of file DP5Status.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Status.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: NETDISPLAY_ENTRY Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
NETDISPLAY_ENTRY Struct Reference

#include <NetFinder.h>

List of all members.

Public Attributes

unsigned char | alert_level
UINT | event1_days
unsigned char | event1_hours
unsigned char | event1_minutes
UINT | event2_days
unsigned char | event2_hours
unsigned char | event2_minutes
unsigned char | event1_seconds
unsigned char | event2_seconds
unsigned char | mac [6]
unsigned char | ip [4]
USHORT | port
unsigned char | subnet [4]
unsigned char | gateway [4]
CString | str_type
CString | str_description
CString | str_ev1
CString | str_ev2
CString | str_display
COLORREF | ccConnectRGB
BOOL | HasData
unsigned long | SockAddr

Detailed Description

Definition at line 8 of file NetFinder.h.

Member Data Documentation

unsigned char NETDISPLAY_ENTRY::alert_level

Definition at line 9 of file NetFinder.h.

COLORREF NETDISPLAY_ENTRY::ccConnectRGB

Definition at line 34 of file NetFinder.h.

UINT NETDISPLAY_ENTRY::event1_days

Definition at line 11 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event1_hours

Definition at line 12 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event1_minutes

Definition at line 13 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event1_seconds

Definition at line 19 of file NetFinder.h.

UINT NETDISPLAY_ENTRY::event2_days

Definition at line 15 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event2_hours

Definition at line 16 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event2_minutes

Definition at line 17 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event2_seconds

Definition at line 20 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::gateway[4]

Definition at line 26 of file NetFinder.h.

BOOL NETDISPLAY_ENTRY::HasData

Definition at line 36 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::ip[4]

Definition at line 23 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::mac[6]

Definition at line 22 of file NetFinder.h.

USHORT NETDISPLAY_ENTRY::port

Definition at line 24 of file NetFinder.h.

unsigned long NETDISPLAY_ENTRY::SockAddr

Definition at line 38 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_description

Definition at line 29 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_display

Definition at line 33 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_ev1

Definition at line 30 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_ev2

Definition at line 31 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_type

Definition at line 28 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::subnet[4]

Definition at line 25 of file NetFinder.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/NetFinder.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Packet_Out Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
Packet_Out Struct Reference

#include <DP5Protocol.h>

List of all members.

Public Attributes

unsigned char | PID1
unsigned char | PID2
unsigned short | LEN
unsigned char | EXPECTEDRESPONSE
unsigned char | DATA [514]

Detailed Description

Definition at line 285 of file DP5Protocol.h.

Member Data Documentation

unsigned char Packet_Out::DATA[514]

Definition at line 290 of file DP5Protocol.h.

unsigned char Packet_Out::EXPECTEDRESPONSE

Definition at line 289 of file DP5Protocol.h.

unsigned short Packet_Out::LEN

Definition at line 288 of file DP5Protocol.h.

unsigned char Packet_Out::PID1

Definition at line 286 of file DP5Protocol.h.

unsigned char Packet_Out::PID2

Definition at line 287 of file DP5Protocol.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Spec Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
Spec Struct Reference

#include <DP5Protocol.h>

List of all members.

Public Attributes

long | DATA [MAX_BUFFER_DATA]
short | CHANNELS

Detailed Description

Definition at line 297 of file DP5Protocol.h.

Member Data Documentation

short Spec::CHANNELS

Definition at line 299 of file DP5Protocol.h.

long Spec::DATA[MAX_BUFFER_DATA]

Definition at line 298 of file DP5Protocol.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringex Class Reference

  • Class List
  • Class Index
  • Class Members
Public Member Functions
stringex Class Reference

#include <stringex.h>

List of all members.

Public Member Functions

stringex (void)
~stringex (void)
std::string | Format (const char *fmt,...)
std::string | MakeUpper (string StdString)
std::string | MakeLower (string StdString)

Detailed Description

Definition at line 16 of file stringex.h.

Constructor & Destructor Documentation

stringex::stringex ( void )

Definition at line 8 of file stringex.cpp.

stringex::~stringex ( void )

Definition at line 12 of file stringex.cpp.

Member Function Documentation

std::string stringex::Format | ( | const char * | fmt,
 |  |  | ...
 | ) |  |

Definition at line 33 of file stringex.cpp.

Here is the caller graph for this function:

std::string stringex::MakeLower ( string StdString )

Definition at line 52 of file stringex.cpp.

std::string stringex::MakeUpper ( string StdString )

Definition at line 42 of file stringex.cpp.

The documentation for this class was generated from the following files:
  • stringex.h
  • stringex.cpp
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: WINUSB_DEVICE_INFO Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes
WINUSB_DEVICE_INFO Struct Reference

Holds WinUSB device information. More...

#include <DppWinUSB.h>

List of all members.

Public Attributes

HANDLE | deviceHandle
System device handle opened with CreateFile using a device path.
WINUSB_INTERFACE_HANDLE winUSBHandle
WinUSB device interface handle opened with WinUsb_Initialize using a CreateFile device handle.
unsigned char | deviceSpeed
USB device speed indicator.
unsigned char | bulkInPipe
Bulk in pipe identifier.
unsigned char | bulkOutPipe
Bulk out pipe identifier.
unsigned char | interruptPipe
Interrupt pipe identifier.
char | devicePath [MAX_DEVPATH_LENGTH]
Device path identifier string used in opening a connection to a USB device.
BOOL | deviceConnected
True if a USB deevice is connected.

Detailed Description

Holds WinUSB device information.

Definition at line 46 of file DppWinUSB.h.

Member Data Documentation

unsigned char WINUSB_DEVICE_INFO::bulkInPipe

Bulk in pipe identifier.

Definition at line 55 of file DppWinUSB.h.

unsigned char WINUSB_DEVICE_INFO::bulkOutPipe

Bulk out pipe identifier.

Definition at line 57 of file DppWinUSB.h.

BOOL WINUSB_DEVICE_INFO::deviceConnected

True if a USB deevice is connected.

Definition at line 63 of file DppWinUSB.h.

HANDLE WINUSB_DEVICE_INFO::deviceHandle

System device handle opened with CreateFile using a device path.

Definition at line 49 of file DppWinUSB.h.

char WINUSB_DEVICE_INFO::devicePath[MAX_DEVPATH_LENGTH]

Device path identifier string used in opening a connection to a USB device.

Definition at line 61 of file DppWinUSB.h.

unsigned char WINUSB_DEVICE_INFO::deviceSpeed

USB device speed indicator.

Definition at line 53 of file DppWinUSB.h.

unsigned char WINUSB_DEVICE_INFO::interruptPipe

Interrupt pipe identifier.

Definition at line 59 of file DppWinUSB.h.

WINUSB_INTERFACE_HANDLE WINUSB_DEVICE_INFO::winUSBHandle

WinUSB device interface handle opened with WinUsb_Initialize using a CreateFile device handle.

Definition at line 51 of file DppWinUSB.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DppWinUSB.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • AccumulationTime : DP5_DP4_FORMAT_STATUS
  • ACK_Received : CDP5Protocol
  • AcqMode : CvcDP5Dlg
  • ADC_GAIN_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_OFFSET_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_V : _DiagDataType
  • AddEntry() : CNetFinder
  • AFAST_LOCKED : DP5_DP4_FORMAT_STATUS
  • alert_level : NETDISPLAY_ENTRY
  • AlertByteToCOLORREF() : CNetFinder
  • AlertEntryToCOLORREF() : CNetFinder
  • AllFileFilter : CFileBrowse
  • AN_IN : DP5_DP4_FORMAT_STATUS
  • AOFFSET_LOCKED : DP5_DP4_FORMAT_STATUS
  • AppendCmdDesc() : CvcDP5Dlg
  • AsciiCmdUtil : CSendCommand
  • AU34_2 : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • b80MHzMode : DP5_DP4_FORMAT_STATUS , CvcDP5Dlg
  • bDeviceConnected : CDppLibUsb
  • bDeviceReady : CDppLibUsb
  • bFPGAAutoClock : DP5_DP4_FORMAT_STATUS
  • bLibusbReady : CDppLibUsb
  • BmpFileFilter : CFileBrowse
  • BOOL_TO_bool() : CvcDP5Dlg
  • bScintHas80MHzOption : DP5_DP4_FORMAT_STATUS
  • bSpectraTestRunning : CvcDP5Dlg
  • BufferOUT : CDP5Protocol
  • Build : DP5_DP4_FORMAT_STATUS
  • bulkInPipe : WINUSB_DEVICE_INFO
  • bulkOutPipe : WINUSB_DEVICE_INFO
  • ButtonSendStringCfgToHardware() : CvcDP5Dlg
  • BYTEVersionToDouble() : CDppUtilities
  • BYTEVersionToString() : CDppUtilities
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • CAboutDlg() : CAboutDlg
  • CallReadDppConfig() : CvcDP5Dlg
  • CallReadScaConfig() : CvcDP5Dlg
  • cAnimWnd() : cAnimWnd
  • CAsciiCmdUtilities() : CAsciiCmdUtilities
  • cboComPort : CSelectDP5
  • ccConnectRGB : NETDISPLAY_ENTRY
  • CDP5Protocol() : CDP5Protocol
  • CDP5Status() : CDP5Status
  • CDppLibUsb() : CDppLibUsb
  • CDppSlowThreshold() : CDppSlowThreshold
  • CDppUtilities() : CDppUtilities
  • CDppWinUSB() : CDppWinUSB
  • CfgFileFilter : CFileBrowse
  • CfgReadBack : CvcDP5Dlg
  • CFileBrowse() : CFileBrowse
  • CHANNELS : Spec
  • CheckSum : _Packet_In
  • CINI() : CINI
  • CIniEx() : CIniEx
  • CIniUtil() : CIniUtil
  • CLabel() : CLabel
  • ClearTrace() : CPlotCanvas
  • Close() : cWaitDialog
  • CloseDeviceHandle() : CDppWinUSB
  • CloseUSBDevice() : CDppLibUsb
  • CloseWinUsbDevice() : CDppWinUSB
  • cMemDC() : cMemDC
  • CMSecTimer() : CMSecTimer
  • CMsgBox() : CMsgBox
  • CNetFinder() : CNetFinder
  • CommError : CDP5Protocol
  • ConvertCmdListToCString() : CIniUtil
  • CopyAsciiData() : CAsciiCmdUtilities
  • CopyDp5CfgToClip() : CvcDP5Dlg
  • CopyTextToClip() : CSelectDP5 , CvcDP5Dlg
  • CountDP5LibusbDevices() : CDppLibUsb
  • CountDP5WinusbDevices() : CDppWinUSB
  • CParsePacket() : CParsePacket
  • CPlotCanvas() : CPlotCanvas
  • Create() : cAnimWnd
  • CreateDTS() : CvcDP5Dlg
  • CreateFullReadBackCmd() : CAsciiCmdUtilities
  • CreateFullReadBackCmdMCA8000D() : CAsciiCmdUtilities
  • CreateMCAData() : CvcDP5Dlg
  • CreateResTestReadBackCmd() : CAsciiCmdUtilities
  • CreateSpectrumConfig() : CvcDP5Dlg
  • CreateTextBlockTest() : CvcDP5Dlg
  • CSelectDP5() : CSelectDP5
  • CSendCommand() : CSendCommand
  • CSProfile() : CSProfile
  • CtlColor() : CLabel
  • CTuneSlowThreshold() : CTuneSlowThreshold
  • CurrentChannel : CvcDP5Dlg
  • CurrentDevice : CDppWinUSB , CDppLibUsb
  • CursorPosition : CPlotCanvas , CvcDP5Dlg
  • CvcDP5App() : CvcDP5App
  • CvcDP5Dlg() : CvcDP5Dlg
  • cWaitDlg() : cWaitDlg
  • cWaitDlgThread() : cWaitDlgThread
  • CWinusbNotify() : CWinusbNotify
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • DATA : _Packet_In , Packet_Out , Spec
  • data_in : CDppLibUsb
  • data_out : CDppLibUsb
  • data_refresh : CSProfile
  • DataAcq() : CPlotCanvas
  • DataIn : CSelectDP5
  • DataTest() : CvcDP5Dlg
  • DCAL : DP5_DP4_FORMAT_STATUS
  • DeinitializeLibusb() : CDppLibUsb
  • DelayTask() : CTuneSlowThreshold
  • DeleteDP5Key() : CIniUtil
  • DeleteKey() : CINI
  • DeleteSection() : CINI
  • DestroyWindow() : CSelectDP5
  • DET_TEMP : DP5_DP4_FORMAT_STATUS
  • DEVICE_ID : DP5_DP4_FORMAT_STATUS
  • device_type : CSProfile
  • deviceConnected : WINUSB_DEVICE_INFO
  • deviceHandle : WINUSB_DEVICE_INFO
  • DeviceNotificationHandle : CWinusbNotify
  • devicePath : WINUSB_DEVICE_INFO
  • deviceSpeed : WINUSB_DEVICE_INFO
  • DeviceType : CvcDP5Dlg
  • devInfo : CDppWinUSB
  • DiagData : _DiagDataType , CDP5Status
  • DiagnosticsToString() : CDP5Status
  • DiagStrPX5Option() : CDP5Status
  • DialogType : CFileBrowse
  • Disable_WinUsb() : CDppWinUSB
  • DisplayBufferArray() : CDP5Status , CDppWinUSB
  • DisplayCfg : CvcDP5Dlg
  • DisplayError() : CvcDP5Dlg
  • DisplaySca : CvcDP5Dlg
  • DisplaySpecBuf25() : CTuneSlowThreshold
  • DoDataExchange() : CMsgBox , CAboutDlg , CvcDP5Dlg , cWaitDlg , CSelectDP5
  • DoModal() : CFileBrowse
  • DP5_CMD() : CSendCommand
  • DP5_CMD_Config() : CSendCommand
  • DP5_CMD_Data() : CSendCommand
  • DP5_CONFIGURED : DP5_DP4_FORMAT_STATUS
  • DP5_Dx_OptionFlags() : CDP5Status
  • DP5_TEMP : DP5_DP4_FORMAT_STATUS
  • Dp5CmdList : CvcDP5Dlg
  • DP5Stat : CvcDP5Dlg
  • DPP_ECO : _CONFIG_OPTIONS , DP5_DP4_FORMAT_STATUS
  • DPP_options : DP5_DP4_FORMAT_STATUS
  • DppEntries : CNetFinder
  • DppEntryIdx : CNetFinder
  • DppFound : CNetFinder
  • DppLibusbHandle : CDppLibUsb
  • DppSendConfigToHw() : CvcDP5Dlg
  • DppSockAddr : CNetFinder
  • DppState : CParsePacket
  • DPPThreshold() : CDppSlowThreshold
  • DppType : _CONFIG_OPTIONS
  • DppUtil : CDP5Status
  • DrawCursor() : CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • EnableCommFunctions() : CSelectDP5
  • EnableDPPFunctions() : CvcDP5Dlg
  • EntryToStr() : CNetFinder
  • EntryToStrRS232() : CNetFinder
  • EntryToStrUSB() : CNetFinder
  • event1_days : NETDISPLAY_ENTRY
  • event1_hours : NETDISPLAY_ENTRY
  • event1_minutes : NETDISPLAY_ENTRY
  • event1_seconds : NETDISPLAY_ENTRY
  • event2_days : NETDISPLAY_ENTRY
  • event2_hours : NETDISPLAY_ENTRY
  • event2_minutes : NETDISPLAY_ENTRY
  • event2_seconds : NETDISPLAY_ENTRY
  • ExeFileFilter : CFileBrowse
  • ExitInstance() : cWaitDlgThread
  • EXPECTEDRESPONSE : Packet_Out
  • ExtractNote() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FastChThreshold : CvcDP5Dlg
  • FastCount : DP5_DP4_FORMAT_STATUS
  • FindDpp : CSelectDP5
  • FindDppUSB : CSelectDP5
  • FindEntry() : CNetFinder
  • FindUSBDevice() : CDppLibUsb , CDppWinUSB
  • Firmware : DP5_DP4_FORMAT_STATUS , _DiagDataType
  • FlashBackground() : CLabel
  • FlashText() : CLabel
  • FmtHex() : CDP5Status
  • FmtHvPwr() : CDP5Status
  • FmtLng() : CDP5Status
  • FmtPc5Pwr() : CDP5Status
  • FmtPc5Temp() : CDP5Status
  • Format() : stringex
  • FPGA : DP5_DP4_FORMAT_STATUS , _DiagDataType
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • gateway : NETDISPLAY_ENTRY
  • Get() : CSProfile
  • GetCmdChunk() : CAsciiCmdUtilities
  • GetCmdData() : CvcDP5Dlg
  • GetCmdDesc() : CvcDP5Dlg
  • GetDeviceNameFromVal() : CvcDP5Dlg , CDP5Status
  • GetDevicePath() : CDppWinUSB
  • GetDevNotifyInfo() : CWinusbNotify
  • GetDP5CfgStr() : CAsciiCmdUtilities
  • GetDP5Data() : CIniUtil
  • GetDP5ScaStr() : CAsciiCmdUtilities
  • GetDP5Section() : CIniUtil
  • GetImageCount() : cAnimWnd
  • getKeyValue() : CINI
  • GetMsIniItem() : CIniUtil
  • GetPixPerChannel() : CvcDP5Dlg
  • getSectionData() : CINI
  • getSectionNames() : CINI
  • GetSlowChThreshold() : CDppSlowThreshold
  • GetSlowChThresStrFromVal() : CDppSlowThreshold
  • GetSlowThreshCalStart() : CTuneSlowThreshold
  • GetSlowThreshChStr() : CDppSlowThreshold
  • GetSlowThreshChStrFromVal() : CDppSlowThreshold , CTuneSlowThreshold
  • GetSlowThresholdSettingFromChannels() : CDppSlowThreshold
  • GetSlowThresholdSettingFromPercent() : CDppSlowThreshold
  • GetSlowThreshPcntStr() : CDppSlowThreshold
  • GetSpectrumData() : CTuneSlowThreshold
  • GetStatusValueStrings() : CDP5Status
  • GetUpperChCounts() : CTuneSlowThreshold
  • GetUpperChMax() : CTuneSlowThreshold
  • GP_COUNTER : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • hasBackground : CPlotCanvas
  • HasData : NETDISPLAY_ENTRY
  • HavePlot : CvcDP5Dlg
  • HaveScopeData : _DppStateType
  • HaveTrace : CvcDP5Dlg
  • HPGe_HV_INH : DP5_DP4_FORMAT_STATUS
  • HPGe_HV_INH_POL : DP5_DP4_FORMAT_STATUS
  • HV : DP5_DP4_FORMAT_STATUS
  • HVOn : _DiagDataType
  • HwCfgDP5 : CvcDP5Dlg
  • HwCfgDP5Out : _CONFIG_OPTIONS , CvcDP5Dlg
  • HwCfgExReady : CvcDP5Dlg
  • HwCfgReady : CvcDP5Dlg
  • hWnd_Main : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IDD : CMsgBox , CAboutDlg , cWaitDlg , CvcDP5Dlg
  • idxCurrentSpectrum : CvcDP5Dlg
  • idxTotalSpectra : CvcDP5Dlg
  • Index : _WINUSB_SETUP_PACKET
  • ini : CIniUtil
  • InitAllEntries() : CNetFinder
  • InitDeviceInfo() : CDppWinUSB , CWinusbNotify
  • InitEntry() : CNetFinder
  • Initialize_Device() : CDppWinUSB
  • InitializeLibusb() : CDppLibUsb
  • InitInstance() : cWaitDlgThread , CvcDP5App
  • InPacketType : CDP5Protocol
  • Interface : _DppStateType
  • interruptPipe : WINUSB_DEVICE_INFO
  • Interval : _WINUSB_PIPE_INFORMATION
  • Invalidate() : CPlotCanvas
  • ip : NETDISPLAY_ENTRY
  • Is8_5VPreAmp : _DiagDataType
  • isAmptekDP5Device() : CDppLibUsb
  • IsAorB() : CDP5Status
  • isAscEnabled : DP5_DP4_FORMAT_STATUS
  • isAscInstalled : DP5_DP4_FORMAT_STATUS
  • isConnectedTest() : CvcDP5Dlg
  • isDeltaMode : CvcDP5Dlg
  • isDP5_RevDxGains : _CONFIG_OPTIONS , DP5_DP4_FORMAT_STATUS
  • isDppConnected : CvcDP5Dlg
  • isDppFound : CDppWinUSB
  • isPlotLine : CSProfile
  • IsPosHV : _DiagDataType
  • isScaleLog : CSProfile
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LastBkColor : CLabel
  • LastEntry : CNetFinder
  • LastLibUsbError : CDppLibUsb
  • LastTextColor : CLabel
  • lblDppFound : CSelectDP5
  • lblMiscStatus : CvcDP5Dlg
  • lblSelectCommunications : CvcDP5Dlg
  • lblStatus : CvcDP5Dlg
  • LEN : _Packet_In , Packet_Out
  • Length : _WINUSB_SETUP_PACKET
  • LibFileFilter : CFileBrowse
  • libusb_strerror() : CDppLibUsb
  • LiveTime : DP5_DP4_FORMAT_STATUS
  • LoadProfile() : CSProfile
  • LongWordToDouble() : CDppUtilities
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_Anim : cWaitDlg
  • m_Bitmap : cAnimWnd
  • m_bLink : CLabel
  • m_bModified : CSelectDP5
  • m_bShowCancelButton : cWaitDialog , cWaitDlg , cWaitDlgThread
  • m_bState : CLabel
  • m_bTimer : CLabel
  • m_crCursorColor : CPlotCanvas
  • m_crDisplayBGColor : CPlotCanvas
  • m_crPlotColor : CPlotCanvas
  • m_crText : CLabel
  • m_crTextBGColor : CPlotCanvas
  • m_crTextFGColor : CPlotCanvas
  • m_DP5_Status : CDP5Status , CSelectDP5
  • m_Event : cWaitDialog , cWaitDlgThread
  • m_Eventname : cWaitDlgThread
  • m_EventName : cWaitDialog
  • m_font : CLabel
  • m_hBrush : CLabel
  • m_hCursor : CLabel
  • m_Height : cAnimWnd
  • m_hIcon : CvcDP5Dlg
  • m_hwndBrush : CLabel
  • m_hWndOwner : CWinusbNotify
  • m_ImageIndex : cAnimWnd
  • m_iNumChan : _SpectrumFileType
  • m_lf : CLabel
  • m_MemDC : cAnimWnd
  • m_nTmrRS232Elapse : CvcDP5Dlg
  • m_nTmrRS232EventId : CvcDP5Dlg
  • m_nTmrRS232Id : CvcDP5Dlg
  • m_nTmrSpectrumElapse : CvcDP5Dlg
  • m_nTmrSpectrumEventId : CvcDP5Dlg
  • m_nTmrSpectrumId : CvcDP5Dlg
  • m_nTmrTimeoutElapse : CvcDP5Dlg
  • m_nTmrTimeoutEventId : CvcDP5Dlg
  • m_nTmrTimeoutId : CvcDP5Dlg
  • m_PicturePlot : CvcDP5Dlg
  • m_PictureScope : CvcDP5Dlg
  • m_rand : CNetFinder
  • m_SpectrumRefreshTimeCtrl : CSelectDP5
  • m_SpinSelectDevice : CSelectDP5
  • m_strDelimiter : CMsgBox
  • m_strMessage : CMsgBox
  • m_strText : CLabel
  • m_strTitle : CMsgBox
  • m_Text : cWaitDlgThread , cWaitDialog , cWaitDlg
  • m_Thread : cWaitDialog , cWaitDlg
  • m_ToolTip : CSelectDP5
  • m_TransparentColor : cAnimWnd
  • m_Type : CLabel
  • m_Width : cAnimWnd
  • mac : NETDISPLAY_ENTRY
  • MakeDp5CmdList() : CvcDP5Dlg
  • MakeLower() : stringex
  • MakeUpper() : stringex , CAsciiCmdUtilities
  • MaximumPacketSize : _WINUSB_PIPE_INFORMATION
  • MCA_EN : DP5_DP4_FORMAT_STATUS
  • mcaCH : CvcDP5Dlg
  • McaFileFilter : CFileBrowse
  • MCS_DONE : DP5_DP4_FORMAT_STATUS
  • MiscData : CDP5Protocol
  • msTimeDiff() : CMSecTimer
  • msTimeExpired() : CMSecTimer
  • msTimer() : CMSecTimer
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • Netfinder_active : CDP5Protocol
  • Netfinder_Seq : CDP5Protocol
  • NullBkColor : CLabel
  • NullSet : CLabel
  • NullTextColor : CLabel
  • NumDevices : CDppLibUsb , CDppWinUSB
  • NumPipes : CDppWinUSB
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • OldCursorPosition : CPlotCanvas
  • OldPlotCursor : CPlotCanvas
  • OnBnClickedBtnSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonArmTrigger() : CvcDP5Dlg
  • OnBnClickedButtonAutotune() : CvcDP5Dlg
  • OnBnClickedButtonClearDataAndGraph() : CvcDP5Dlg
  • OnBnClickedButtonClearMiscData() : CvcDP5Dlg
  • OnBnClickedButtonCloseDevice() : CSelectDP5
  • OnBnClickedButtonCountDevices() : CSelectDP5
  • OnBnClickedButtonDiag() : CvcDP5Dlg
  • OnBnClickedButtonFindDevice() : CvcDP5Dlg
  • OnBnClickedButtonFindUsbDevice() : CSelectDP5
  • OnBnClickedButtonGetSpectrum() : CvcDP5Dlg
  • OnBnClickedButtonReadMiscData() : CvcDP5Dlg
  • OnBnClickedButtonSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonSelectComm() : CvcDP5Dlg
  • OnBnClickedButtonShowConfig() : CvcDP5Dlg
  • OnBnClickedButtonSingleUpdate() : CvcDP5Dlg
  • OnBnClickedButtonSpectrumRefreshDefault() : CSelectDP5
  • OnBnClickedButtonStartAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonStopAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonWriteMiscData() : CvcDP5Dlg
  • OnBnClickedButtonWriteTextBlock() : CvcDP5Dlg
  • OnBnClickedCancel() : CvcDP5Dlg
  • OnBnClickedCheckRepeatSpectrum() : CvcDP5Dlg
  • OnBnClickedConnectOK() : CSelectDP5
  • OnBnClickedOk() : CSelectDP5 , CvcDP5Dlg
  • OnBnClickedRadioCommtype2() : CSelectDP5
  • OnBnClickedRadioPlotScaleLinear() : CvcDP5Dlg
  • OnBnClickedRadioPlotScaleLog() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeLine() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeSolid() : CvcDP5Dlg
  • OnCancel() : cWaitDlg
  • OnDeltaposSpinSelectDevice() : CSelectDP5
  • OnDestroy() : CvcDP5Dlg
  • OnDeviceChange() : CvcDP5Dlg
  • OnEnChangeSpectrumRefreshTime() : CSelectDP5
  • OnEraseBkgnd() : CPlotCanvas
  • OnHelpInfo() : CSelectDP5
  • OnInitDialog() : CSelectDP5 , CMsgBox , cWaitDlg , CvcDP5Dlg
  • OnLButtonDown() : CLabel , CPlotCanvas , CvcDP5Dlg
  • OnOffStr() : CDP5Status
  • OnOK() : CSelectDP5 , cWaitDlg
  • OnPaint() : CPlotCanvas , CvcDP5Dlg , cAnimWnd
  • OnQueryDragIcon() : CvcDP5Dlg
  • OnReceive() : CvcDP5Dlg
  • OnRefreshBkgnd() : CPlotCanvas
  • OnResetCommunications() : CvcDP5Dlg
  • OnSetCursor() : CLabel
  • OnStnClickedPlotpicturecontrol() : CvcDP5Dlg
  • OnSysCommand() : CvcDP5Dlg
  • OnTimer() : CLabel , cAnimWnd , cWaitDlg , CvcDP5Dlg , CSelectDP5
  • OnToolTipNotify() : CvcDP5Dlg
  • OPEN : CFileBrowse
  • OpenDevice() : CDppWinUSB
  • operator->() : cMemDC
  • OptPlotType : CPlotCanvas
  • OptScaleType : CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Packet_Received : CDP5Protocol
  • PacketIn : CDP5Protocol
  • ParsePacket() : CParsePacket
  • ParsePacketEx() : CvcDP5Dlg
  • ParsePacketStatus() : CParsePacket
  • ParsePerformanceNotes() : CvcDP5Dlg
  • ParsePkt : CvcDP5Dlg
  • ParseTextBlockNotes() : CvcDP5Dlg
  • PC5_8_5V : DP5_DP4_FORMAT_STATUS
  • PC5_HV_POL : DP5_DP4_FORMAT_STATUS
  • PC5_PRESENT : DP5_DP4_FORMAT_STATUS , _DiagDataType , _CONFIG_OPTIONS
  • PC5_SN : DP5_DP4_FORMAT_STATUS , _DiagDataType
  • PC5_V : _DiagDataType
  • PC5DCAL : _DiagDataType
  • PC5Initialized : _DiagDataType
  • PersistenceMode : CPlotCanvas
  • PID1 : _Packet_In , Packet_Out
  • PID2 : _Packet_In , Packet_Out
  • PID2_TextToString() : CParsePacket
  • PIN : CDP5Protocol
  • PipeId : CDppWinUSB , _WINUSB_PIPE_INFORMATION
  • PipeTimeout : CDppWinUSB
  • PipeType : _WINUSB_PIPE_INFORMATION
  • PlotBuffer : CvcDP5Dlg
  • PlotCursor : CPlotCanvas
  • PlotData() : CvcDP5Dlg
  • PlotTrace() : CPlotCanvas
  • port : NETDISPLAY_ENTRY
  • POUT_Buffer() : CSendCommand
  • PreAmpON : _DiagDataType
  • PRECNT_REACHED : DP5_DP4_FORMAT_STATUS
  • PresetAcq : CvcDP5Dlg
  • PresetCount : CvcDP5Dlg
  • PresetLtDone : DP5_DP4_FORMAT_STATUS
  • PresetRt : CvcDP5Dlg
  • PresetRtDone : DP5_DP4_FORMAT_STATUS
  • PreTranslateMessage() : CvcDP5Dlg
  • PrintCfg : CvcDP5Dlg
  • PrintDevices() : CDppLibUsb
  • Process_Diagnostics() : CDP5Status
  • Process_Status() : CDP5Status
  • ProcessAck() : CvcDP5Dlg
  • ProcessCfgReadEx() : CvcDP5Dlg
  • ProcessDiagDataEx() : CvcDP5Dlg
  • ProcessScopeDataEx() : CvcDP5Dlg
  • ProcessSpectrumEx() : CvcDP5Dlg
  • ProcessStatusEx() : CvcDP5Dlg
  • ProcessTextDataEx() : CvcDP5Dlg
  • profile : CSProfile
  • Put() : CSProfile
  • PX4 : DP5_DP4_FORMAT_STATUS
  • PX5_OptionsString() : CDP5Status
  • PZCORR : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RAM_TEST_ERROR : DP5_DP4_FORMAT_STATUS
  • RAM_TEST_RUN : DP5_DP4_FORMAT_STATUS
  • RAW : DP5_DP4_FORMAT_STATUS
  • RealTime : DP5_DP4_FORMAT_STATUS
  • ReBootFlag : DP5_DP4_FORMAT_STATUS
  • ReconstructFont() : CLabel
  • RegDeviceNotification() : CWinusbNotify
  • RemCallParsePacket() : CvcDP5Dlg
  • Remove_MCA8000D_Cmds() : CAsciiCmdUtilities
  • RemoveCmd() : CAsciiCmdUtilities
  • RemoveCmdByDeviceType() : CAsciiCmdUtilities
  • RemoveCmdByDeviceTypeDP5DxK() : CAsciiCmdUtilities
  • RemoveDeviceNotification() : CWinusbNotify
  • RemWhitespace() : CAsciiCmdUtilities
  • ReplaceCmdDesc() : CvcDP5Dlg
  • ReplaceCmdText() : CAsciiCmdUtilities
  • ReqDataStatus() : CSelectDP5
  • ReqProcess : _DppStateType
  • Request : _WINUSB_SETUP_PACKET
  • RequestScopeData() : CvcDP5Dlg
  • RequestType : _WINUSB_SETUP_PACKET
  • RiseUS : CvcDP5Dlg
  • RS232_RThreshold : CDP5Protocol
  • RS232BytesInBuffer : CDP5Protocol
  • RS232HeaderReceived : CDP5Protocol
  • RS232PacketPtr : CDP5Protocol
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SAVE : CFileBrowse
  • SaveCfg : CvcDP5Dlg
  • SaveDP5Data() : CIniUtil
  • SaveMCAFile() : CvcDP5Dlg
  • SaveProfile() : CSProfile
  • SaveStringDataToFile() : CDP5Status , CDppWinUSB
  • SaveTestSpectrumFile() : CvcDP5Dlg
  • ScaleAuto : CDP5Protocol
  • ScaReadBack : CvcDP5Dlg
  • Scope : CDP5Protocol
  • SCOPE_DR : DP5_DP4_FORMAT_STATUS
  • ScopeAutoRearm : _DppStateType
  • ScopeBuffer : CvcDP5Dlg
  • ScopeDisplay() : CvcDP5Dlg
  • ScopeOverFlow : _DppStateType
  • sectionExists() : CINI
  • SendCoarseFineGain : _CONFIG_OPTIONS
  • SendCommand() : CvcDP5Dlg
  • SendCommandConfig() : CvcDP5Dlg
  • SendCommandData() : CvcDP5Dlg
  • SendConfigFromFileToDpp() : CvcDP5Dlg
  • SendDppInfoTextBlock() : CvcDP5Dlg
  • SendManufacturingTextBlock() : CvcDP5Dlg
  • SendPacketUSB() : CDppLibUsb , CDppWinUSB
  • SerialNumber : DP5_DP4_FORMAT_STATUS , _SpectrumFileType
  • SetBkColor() : CLabel
  • SetBorder() : CLabel
  • SetCheckButtonState() : CvcDP5Dlg
  • SetCursorPosition() : CPlotCanvas
  • SetDataRcvTimer() : CSelectDP5
  • SetFontBold() : CLabel
  • SetFontItalic() : CLabel
  • SetFontName() : CLabel
  • SetFontSize() : CLabel
  • SetFontUnderline() : CLabel
  • SetGain() : CDppSlowThreshold
  • SetImageList() : cAnimWnd
  • setINIFileName() : CINI
  • setKey() : CINI
  • SetLastColor() : CLabel
  • SetLink() : CLabel
  • SetLinkCursor() : CLabel
  • SetMessage() : CMsgBox
  • SetModified() : CSelectDP5
  • SetNotificationWindow() : CWinusbNotify
  • SetNullColor() : CLabel
  • SetPersistenceMode() : CPlotCanvas
  • SetPlotChannel() : CvcDP5Dlg
  • SetSlowChThreshold() : CDppSlowThreshold
  • SetSlowChThresholdConfigFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromVal() : CDppSlowThreshold
  • SetSlowThreshToChPos() : CTuneSlowThreshold
  • SetStartTime() : CvcDP5Dlg
  • SetSunken() : CLabel
  • SetText() : CLabel
  • SetTextColor() : CLabel
  • Show() : cWaitDialog
  • ShowRepeatStatus() : CvcDP5Dlg
  • ShowStatus() : CvcDP5Dlg
  • ShowStatusValueStrings() : CDP5Status
  • SlowChThreshold : CvcDP5Dlg
  • SlowCount : DP5_DP4_FORMAT_STATUS
  • SlowThresholdPct : CvcDP5Dlg
  • SockAddr : NETDISPLAY_ENTRY
  • SockAddr_ByteToInAddr() : CNetFinder
  • SockAddr_ByteToStr() : CNetFinder
  • SockAddr_ByteToULong() : CNetFinder
  • SockAddr_DlgToStr() : CNetFinder
  • SockAddr_InAddrToStr() : CNetFinder
  • SockAddr_StrToInAddr() : CNetFinder
  • SockAddr_StrToULong() : CNetFinder
  • SockAddr_ULongToInAddr() : CNetFinder
  • SockAddr_ULongToStr() : CNetFinder
  • SockPort_DlgToUINT() : CNetFinder
  • SPECTRUM : CDP5Protocol
  • SPECTRUM_OFFSET : DP5_DP4_FORMAT_STATUS
  • SRAMTestData : _DiagDataType
  • SRAMTestPass : _DiagDataType
  • StartAnim() : cAnimWnd
  • STATUS : _Packet_In
  • StopAnim() : cAnimWnd
  • str_description : NETDISPLAY_ENTRY
  • str_display : NETDISPLAY_ENTRY
  • str_ev1 : NETDISPLAY_ENTRY
  • str_ev2 : NETDISPLAY_ENTRY
  • str_type : NETDISPLAY_ENTRY
  • strAnalogOut : CvcDP5Dlg
  • strDescription : _SpectrumFileType
  • strDevice : CSProfile
  • strGainDisplayValue : CvcDP5Dlg
  • stringex() : stringex
  • strInputOffset : CvcDP5Dlg
  • strLowerMiscData : CvcDP5Dlg
  • strMcaMode : CvcDP5Dlg
  • strOutputOffset : CvcDP5Dlg
  • strPort : _DppStateType
  • strPresetCmd : CvcDP5Dlg
  • strPresetVal : CvcDP5Dlg
  • strScopeGain : CvcDP5Dlg
  • strSpectrumConfig : _SpectrumFileType
  • strSpectrumStatus : _SpectrumFileType
  • strStartTime : _SpectrumFileType
  • strTag : _SpectrumFileType
  • strTempCal : _DiagDataType
  • strTempRaw : _DiagDataType
  • strTriggerPosition : CvcDP5Dlg
  • strTriggerSlope : CvcDP5Dlg
  • strTriggerSource : CvcDP5Dlg
  • strUpperMiscData : CvcDP5Dlg
  • subnet : NETDISPLAY_ENTRY
  • Sup9VOn : _DiagDataType
  • SUPPLIES_ON : DP5_DP4_FORMAT_STATUS
  • szSettings : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • TEC_Voltage : DP5_DP4_FORMAT_STATUS
  • TECOn : _DiagDataType
  • TempOffset : _DiagDataType
  • TestPacketCkSumOK() : CSendCommand
  • TextToBlockString() : CvcDP5Dlg
  • Thresholds_Setup() : CDppSlowThreshold
  • Timeout_flag : CDP5Protocol
  • TimeoutFlag : CvcDP5Dlg
  • TuneFastSlowThresh() : CvcDP5Dlg
  • TxtFileFilter : CFileBrowse
  • txtSlowThreshold_Click() : CDppSlowThreshold
  • txtSlowThresholdChannels_Click() : CDppSlowThreshold
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UC_TEMP_OFFSET : DP5_DP4_FORMAT_STATUS
  • UDP_offset : CDP5Protocol
  • UnregDeviceNotification() : CWinusbNotify
  • UpdatePlot() : CvcDP5Dlg
  • UpdatePlotCursorPosFromIntChPos() : CTuneSlowThreshold
  • UpdateScope() : CvcDP5Dlg
  • UpdateScopeCfg : CvcDP5Dlg
  • UpdateSlowThresChDisplay() : CDppSlowThreshold
  • USB_Default_Timeout : CDP5Protocol , CDppWinUSB
  • USBStatusString() : CDppWinUSB
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • Value : _WINUSB_SETUP_PACKET
  • VersionToStr() : CDP5Status
  • VREF_IN : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WinUsb_Disabled : CDppWinUSB
  • winUSBHandle : WINUSB_DEVICE_INFO
  • WriteTextBlock() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • X : _COORD_LONG
  • XPlotMAX : CvcDP5Dlg , CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- y -

  • Y : _COORD_LONG
  • YPlotBuffer : CPlotCanvas
  • YPlotMAX : CPlotCanvas , CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~cAnimWnd() : cAnimWnd
  • ~CAsciiCmdUtilities() : CAsciiCmdUtilities
  • ~CDP5Protocol() : CDP5Protocol
  • ~CDP5Status() : CDP5Status
  • ~CDppLibUsb() : CDppLibUsb
  • ~CDppSlowThreshold() : CDppSlowThreshold
  • ~CDppUtilities() : CDppUtilities
  • ~CDppWinUSB() : CDppWinUSB
  • ~CFileBrowse() : CFileBrowse
  • ~CINI() : CINI
  • ~CIniEx() : CIniEx
  • ~CIniUtil() : CIniUtil
  • ~CLabel() : CLabel
  • ~cMemDC() : cMemDC
  • ~CMSecTimer() : CMSecTimer
  • ~CMsgBox() : CMsgBox
  • ~CNetFinder() : CNetFinder
  • ~CParsePacket() : CParsePacket
  • ~CPlotCanvas() : CPlotCanvas
  • ~CSendCommand() : CSendCommand
  • ~CSProfile() : CSProfile
  • ~CTuneSlowThreshold() : CTuneSlowThreshold
  • ~CvcDP5Dlg() : CvcDP5Dlg
  • ~cWaitDialog() : cWaitDialog
  • ~cWaitDlgThread() : cWaitDlgThread
  • ~CWinusbNotify() : CWinusbNotify
  • ~stringex() : stringex
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AddEntry() : CNetFinder
  • AlertByteToCOLORREF() : CNetFinder
  • AlertEntryToCOLORREF() : CNetFinder
  • AppendCmdDesc() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • BOOL_TO_bool() : CvcDP5Dlg
  • ButtonSendStringCfgToHardware() : CvcDP5Dlg
  • BYTEVersionToDouble() : CDppUtilities
  • BYTEVersionToString() : CDppUtilities
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CAboutDlg() : CAboutDlg
  • CallReadDppConfig() : CvcDP5Dlg
  • CallReadScaConfig() : CvcDP5Dlg
  • cAnimWnd() : cAnimWnd
  • CAsciiCmdUtilities() : CAsciiCmdUtilities
  • CDP5Protocol() : CDP5Protocol
  • CDP5Status() : CDP5Status
  • CDppLibUsb() : CDppLibUsb
  • CDppSlowThreshold() : CDppSlowThreshold
  • CDppUtilities() : CDppUtilities
  • CDppWinUSB() : CDppWinUSB
  • CFileBrowse() : CFileBrowse
  • CINI() : CINI
  • CIniEx() : CIniEx
  • CIniUtil() : CIniUtil
  • CLabel() : CLabel
  • ClearTrace() : CPlotCanvas
  • Close() : cWaitDialog
  • CloseDeviceHandle() : CDppWinUSB
  • CloseUSBDevice() : CDppLibUsb
  • CloseWinUsbDevice() : CDppWinUSB
  • cMemDC() : cMemDC
  • CMSecTimer() : CMSecTimer
  • CMsgBox() : CMsgBox
  • CNetFinder() : CNetFinder
  • ConvertCmdListToCString() : CIniUtil
  • CopyAsciiData() : CAsciiCmdUtilities
  • CopyDp5CfgToClip() : CvcDP5Dlg
  • CopyTextToClip() : CvcDP5Dlg , CSelectDP5
  • CountDP5LibusbDevices() : CDppLibUsb
  • CountDP5WinusbDevices() : CDppWinUSB
  • CParsePacket() : CParsePacket
  • CPlotCanvas() : CPlotCanvas
  • Create() : cAnimWnd
  • CreateDTS() : CvcDP5Dlg
  • CreateFullReadBackCmd() : CAsciiCmdUtilities
  • CreateFullReadBackCmdMCA8000D() : CAsciiCmdUtilities
  • CreateMCAData() : CvcDP5Dlg
  • CreateResTestReadBackCmd() : CAsciiCmdUtilities
  • CreateSpectrumConfig() : CvcDP5Dlg
  • CreateTextBlockTest() : CvcDP5Dlg
  • CSelectDP5() : CSelectDP5
  • CSendCommand() : CSendCommand
  • CSProfile() : CSProfile
  • CtlColor() : CLabel
  • CTuneSlowThreshold() : CTuneSlowThreshold
  • CvcDP5App() : CvcDP5App
  • CvcDP5Dlg() : CvcDP5Dlg
  • cWaitDlg() : cWaitDlg
  • cWaitDlgThread() : cWaitDlgThread
  • CWinusbNotify() : CWinusbNotify
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DataAcq() : CPlotCanvas
  • DataTest() : CvcDP5Dlg
  • DeinitializeLibusb() : CDppLibUsb
  • DelayTask() : CTuneSlowThreshold
  • DeleteDP5Key() : CIniUtil
  • DeleteKey() : CINI
  • DeleteSection() : CINI
  • DestroyWindow() : CSelectDP5
  • DiagnosticsToString() : CDP5Status
  • DiagStrPX5Option() : CDP5Status
  • Disable_WinUsb() : CDppWinUSB
  • DisplayBufferArray() : CDP5Status , CDppWinUSB
  • DisplayError() : CvcDP5Dlg
  • DisplaySpecBuf25() : CTuneSlowThreshold
  • DoDataExchange() : CSelectDP5 , CMsgBox , CAboutDlg , cWaitDlg , CvcDP5Dlg
  • DoModal() : CFileBrowse
  • DP5_CMD() : CSendCommand
  • DP5_CMD_Config() : CSendCommand
  • DP5_CMD_Data() : CSendCommand
  • DP5_Dx_OptionFlags() : CDP5Status
  • DppSendConfigToHw() : CvcDP5Dlg
  • DPPThreshold() : CDppSlowThreshold
  • DrawCursor() : CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EnableCommFunctions() : CSelectDP5
  • EnableDPPFunctions() : CvcDP5Dlg
  • EntryToStr() : CNetFinder
  • EntryToStrRS232() : CNetFinder
  • EntryToStrUSB() : CNetFinder
  • ExitInstance() : cWaitDlgThread
  • ExtractNote() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • FindEntry() : CNetFinder
  • FindUSBDevice() : CDppLibUsb , CDppWinUSB
  • FlashBackground() : CLabel
  • FlashText() : CLabel
  • FmtHex() : CDP5Status
  • FmtHvPwr() : CDP5Status
  • FmtLng() : CDP5Status
  • FmtPc5Pwr() : CDP5Status
  • FmtPc5Temp() : CDP5Status
  • Format() : stringex
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • Get() : CSProfile
  • GetCmdChunk() : CAsciiCmdUtilities
  • GetCmdData() : CvcDP5Dlg
  • GetCmdDesc() : CvcDP5Dlg
  • GetDeviceNameFromVal() : CDP5Status , CvcDP5Dlg
  • GetDevicePath() : CDppWinUSB
  • GetDevNotifyInfo() : CWinusbNotify
  • GetDP5CfgStr() : CAsciiCmdUtilities
  • GetDP5Data() : CIniUtil
  • GetDP5ScaStr() : CAsciiCmdUtilities
  • GetDP5Section() : CIniUtil
  • GetImageCount() : cAnimWnd
  • getKeyValue() : CINI
  • GetMsIniItem() : CIniUtil
  • GetPixPerChannel() : CvcDP5Dlg
  • getSectionData() : CINI
  • getSectionNames() : CINI
  • GetSlowChThreshold() : CDppSlowThreshold
  • GetSlowChThresStrFromVal() : CDppSlowThreshold
  • GetSlowThreshCalStart() : CTuneSlowThreshold
  • GetSlowThreshChStr() : CDppSlowThreshold
  • GetSlowThreshChStrFromVal() : CTuneSlowThreshold , CDppSlowThreshold
  • GetSlowThresholdSettingFromChannels() : CDppSlowThreshold
  • GetSlowThresholdSettingFromPercent() : CDppSlowThreshold
  • GetSlowThreshPcntStr() : CDppSlowThreshold
  • GetSpectrumData() : CTuneSlowThreshold
  • GetStatusValueStrings() : CDP5Status
  • GetUpperChCounts() : CTuneSlowThreshold
  • GetUpperChMax() : CTuneSlowThreshold
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • InitAllEntries() : CNetFinder
  • InitDeviceInfo() : CDppWinUSB , CWinusbNotify
  • InitEntry() : CNetFinder
  • Initialize_Device() : CDppWinUSB
  • InitializeLibusb() : CDppLibUsb
  • InitInstance() : cWaitDlgThread , CvcDP5App
  • Invalidate() : CPlotCanvas
  • isAmptekDP5Device() : CDppLibUsb
  • IsAorB() : CDP5Status
  • isConnectedTest() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • libusb_strerror() : CDppLibUsb
  • LoadProfile() : CSProfile
  • LongWordToDouble() : CDppUtilities
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MakeDp5CmdList() : CvcDP5Dlg
  • MakeLower() : stringex
  • MakeUpper() : stringex , CAsciiCmdUtilities
  • msTimeDiff() : CMSecTimer
  • msTimeExpired() : CMSecTimer
  • msTimer() : CMSecTimer
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OnBnClickedBtnSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonArmTrigger() : CvcDP5Dlg
  • OnBnClickedButtonAutotune() : CvcDP5Dlg
  • OnBnClickedButtonClearDataAndGraph() : CvcDP5Dlg
  • OnBnClickedButtonClearMiscData() : CvcDP5Dlg
  • OnBnClickedButtonCloseDevice() : CSelectDP5
  • OnBnClickedButtonCountDevices() : CSelectDP5
  • OnBnClickedButtonDiag() : CvcDP5Dlg
  • OnBnClickedButtonFindDevice() : CvcDP5Dlg
  • OnBnClickedButtonFindUsbDevice() : CSelectDP5
  • OnBnClickedButtonGetSpectrum() : CvcDP5Dlg
  • OnBnClickedButtonReadMiscData() : CvcDP5Dlg
  • OnBnClickedButtonSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonSelectComm() : CvcDP5Dlg
  • OnBnClickedButtonShowConfig() : CvcDP5Dlg
  • OnBnClickedButtonSingleUpdate() : CvcDP5Dlg
  • OnBnClickedButtonSpectrumRefreshDefault() : CSelectDP5
  • OnBnClickedButtonStartAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonStopAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonWriteMiscData() : CvcDP5Dlg
  • OnBnClickedButtonWriteTextBlock() : CvcDP5Dlg
  • OnBnClickedCancel() : CvcDP5Dlg
  • OnBnClickedCheckRepeatSpectrum() : CvcDP5Dlg
  • OnBnClickedConnectOK() : CSelectDP5
  • OnBnClickedOk() : CSelectDP5 , CvcDP5Dlg
  • OnBnClickedRadioCommtype2() : CSelectDP5
  • OnBnClickedRadioPlotScaleLinear() : CvcDP5Dlg
  • OnBnClickedRadioPlotScaleLog() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeLine() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeSolid() : CvcDP5Dlg
  • OnCancel() : cWaitDlg
  • OnDeltaposSpinSelectDevice() : CSelectDP5
  • OnDestroy() : CvcDP5Dlg
  • OnDeviceChange() : CvcDP5Dlg
  • OnEnChangeSpectrumRefreshTime() : CSelectDP5
  • OnEraseBkgnd() : CPlotCanvas
  • OnHelpInfo() : CSelectDP5
  • OnInitDialog() : CMsgBox , CvcDP5Dlg , cWaitDlg , CSelectDP5
  • OnLButtonDown() : CPlotCanvas , CvcDP5Dlg , CLabel
  • OnOffStr() : CDP5Status
  • OnOK() : CSelectDP5 , cWaitDlg
  • OnPaint() : CvcDP5Dlg , CPlotCanvas , cAnimWnd
  • OnQueryDragIcon() : CvcDP5Dlg
  • OnReceive() : CvcDP5Dlg
  • OnRefreshBkgnd() : CPlotCanvas
  • OnResetCommunications() : CvcDP5Dlg
  • OnSetCursor() : CLabel
  • OnStnClickedPlotpicturecontrol() : CvcDP5Dlg
  • OnSysCommand() : CvcDP5Dlg
  • OnTimer() : cAnimWnd , CSelectDP5 , CvcDP5Dlg , CLabel , cWaitDlg
  • OnToolTipNotify() : CvcDP5Dlg
  • OpenDevice() : CDppWinUSB
  • operator->() : cMemDC
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • ParsePacket() : CParsePacket
  • ParsePacketEx() : CvcDP5Dlg
  • ParsePacketStatus() : CParsePacket
  • ParsePerformanceNotes() : CvcDP5Dlg
  • ParseTextBlockNotes() : CvcDP5Dlg
  • PID2_TextToString() : CParsePacket
  • PlotData() : CvcDP5Dlg
  • PlotTrace() : CPlotCanvas
  • POUT_Buffer() : CSendCommand
  • PreTranslateMessage() : CvcDP5Dlg
  • PrintDevices() : CDppLibUsb
  • Process_Diagnostics() : CDP5Status
  • Process_Status() : CDP5Status
  • ProcessAck() : CvcDP5Dlg
  • ProcessCfgReadEx() : CvcDP5Dlg
  • ProcessDiagDataEx() : CvcDP5Dlg
  • ProcessScopeDataEx() : CvcDP5Dlg
  • ProcessSpectrumEx() : CvcDP5Dlg
  • ProcessStatusEx() : CvcDP5Dlg
  • ProcessTextDataEx() : CvcDP5Dlg
  • Put() : CSProfile
  • PX5_OptionsString() : CDP5Status
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • ReconstructFont() : CLabel
  • RegDeviceNotification() : CWinusbNotify
  • RemCallParsePacket() : CvcDP5Dlg
  • Remove_MCA8000D_Cmds() : CAsciiCmdUtilities
  • RemoveCmd() : CAsciiCmdUtilities
  • RemoveCmdByDeviceType() : CAsciiCmdUtilities
  • RemoveCmdByDeviceTypeDP5DxK() : CAsciiCmdUtilities
  • RemoveDeviceNotification() : CWinusbNotify
  • RemWhitespace() : CAsciiCmdUtilities
  • ReplaceCmdDesc() : CvcDP5Dlg
  • ReplaceCmdText() : CAsciiCmdUtilities
  • ReqDataStatus() : CSelectDP5
  • RequestScopeData() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • SaveDP5Data() : CIniUtil
  • SaveMCAFile() : CvcDP5Dlg
  • SaveProfile() : CSProfile
  • SaveStringDataToFile() : CDP5Status , CDppWinUSB
  • SaveTestSpectrumFile() : CvcDP5Dlg
  • ScopeDisplay() : CvcDP5Dlg
  • sectionExists() : CINI
  • SendCommand() : CvcDP5Dlg
  • SendCommandConfig() : CvcDP5Dlg
  • SendCommandData() : CvcDP5Dlg
  • SendConfigFromFileToDpp() : CvcDP5Dlg
  • SendDppInfoTextBlock() : CvcDP5Dlg
  • SendManufacturingTextBlock() : CvcDP5Dlg
  • SendPacketUSB() : CDppWinUSB , CDppLibUsb
  • SetBkColor() : CLabel
  • SetBorder() : CLabel
  • SetCheckButtonState() : CvcDP5Dlg
  • SetCursorPosition() : CPlotCanvas
  • SetDataRcvTimer() : CSelectDP5
  • SetFontBold() : CLabel
  • SetFontItalic() : CLabel
  • SetFontName() : CLabel
  • SetFontSize() : CLabel
  • SetFontUnderline() : CLabel
  • SetGain() : CDppSlowThreshold
  • SetImageList() : cAnimWnd
  • setINIFileName() : CINI
  • setKey() : CINI
  • SetLastColor() : CLabel
  • SetLink() : CLabel
  • SetLinkCursor() : CLabel
  • SetMessage() : CMsgBox
  • SetModified() : CSelectDP5
  • SetNotificationWindow() : CWinusbNotify
  • SetNullColor() : CLabel
  • SetPersistenceMode() : CPlotCanvas
  • SetPlotChannel() : CvcDP5Dlg
  • SetSlowChThreshold() : CDppSlowThreshold
  • SetSlowChThresholdConfigFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromVal() : CDppSlowThreshold
  • SetSlowThreshToChPos() : CTuneSlowThreshold
  • SetStartTime() : CvcDP5Dlg
  • SetSunken() : CLabel
  • SetText() : CLabel
  • SetTextColor() : CLabel
  • Show() : cWaitDialog
  • ShowRepeatStatus() : CvcDP5Dlg
  • ShowStatus() : CvcDP5Dlg
  • ShowStatusValueStrings() : CDP5Status
  • SockAddr_ByteToInAddr() : CNetFinder
  • SockAddr_ByteToStr() : CNetFinder
  • SockAddr_ByteToULong() : CNetFinder
  • SockAddr_DlgToStr() : CNetFinder
  • SockAddr_InAddrToStr() : CNetFinder
  • SockAddr_StrToInAddr() : CNetFinder
  • SockAddr_StrToULong() : CNetFinder
  • SockAddr_ULongToInAddr() : CNetFinder
  • SockAddr_ULongToStr() : CNetFinder
  • SockPort_DlgToUINT() : CNetFinder
  • StartAnim() : cAnimWnd
  • StopAnim() : cAnimWnd
  • stringex() : stringex
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • TestPacketCkSumOK() : CSendCommand
  • TextToBlockString() : CvcDP5Dlg
  • Thresholds_Setup() : CDppSlowThreshold
  • TuneFastSlowThresh() : CvcDP5Dlg
  • txtSlowThreshold_Click() : CDppSlowThreshold
  • txtSlowThresholdChannels_Click() : CDppSlowThreshold
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • UnregDeviceNotification() : CWinusbNotify
  • UpdatePlot() : CvcDP5Dlg
  • UpdatePlotCursorPosFromIntChPos() : CTuneSlowThreshold
  • UpdateScope() : CvcDP5Dlg
  • UpdateSlowThresChDisplay() : CDppSlowThreshold
  • USBStatusString() : CDppWinUSB
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • VersionToStr() : CDP5Status
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WriteTextBlock() : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~cAnimWnd() : cAnimWnd
  • ~CAsciiCmdUtilities() : CAsciiCmdUtilities
  • ~CDP5Protocol() : CDP5Protocol
  • ~CDP5Status() : CDP5Status
  • ~CDppLibUsb() : CDppLibUsb
  • ~CDppSlowThreshold() : CDppSlowThreshold
  • ~CDppUtilities() : CDppUtilities
  • ~CDppWinUSB() : CDppWinUSB
  • ~CFileBrowse() : CFileBrowse
  • ~CINI() : CINI
  • ~CIniEx() : CIniEx
  • ~CIniUtil() : CIniUtil
  • ~CLabel() : CLabel
  • ~cMemDC() : cMemDC
  • ~CMSecTimer() : CMSecTimer
  • ~CMsgBox() : CMsgBox
  • ~CNetFinder() : CNetFinder
  • ~CParsePacket() : CParsePacket
  • ~CPlotCanvas() : CPlotCanvas
  • ~CSendCommand() : CSendCommand
  • ~CSProfile() : CSProfile
  • ~CTuneSlowThreshold() : CTuneSlowThreshold
  • ~CvcDP5Dlg() : CvcDP5Dlg
  • ~cWaitDialog() : cWaitDialog
  • ~cWaitDlgThread() : cWaitDlgThread
  • ~CWinusbNotify() : CWinusbNotify
  • ~stringex() : stringex
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • AccumulationTime : DP5_DP4_FORMAT_STATUS
  • ACK_Received : CDP5Protocol
  • AcqMode : CvcDP5Dlg
  • ADC_GAIN_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_OFFSET_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_V : _DiagDataType
  • AFAST_LOCKED : DP5_DP4_FORMAT_STATUS
  • alert_level : NETDISPLAY_ENTRY
  • AllFileFilter : CFileBrowse
  • AN_IN : DP5_DP4_FORMAT_STATUS
  • AOFFSET_LOCKED : DP5_DP4_FORMAT_STATUS
  • AsciiCmdUtil : CSendCommand
  • AU34_2 : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • b80MHzMode : DP5_DP4_FORMAT_STATUS , CvcDP5Dlg
  • bDeviceConnected : CDppLibUsb
  • bDeviceReady : CDppLibUsb
  • bFPGAAutoClock : DP5_DP4_FORMAT_STATUS
  • bLibusbReady : CDppLibUsb
  • BmpFileFilter : CFileBrowse
  • bScintHas80MHzOption : DP5_DP4_FORMAT_STATUS
  • bSpectraTestRunning : CvcDP5Dlg
  • BufferOUT : CDP5Protocol
  • Build : DP5_DP4_FORMAT_STATUS
  • bulkInPipe : WINUSB_DEVICE_INFO
  • bulkOutPipe : WINUSB_DEVICE_INFO
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • cboComPort : CSelectDP5
  • ccConnectRGB : NETDISPLAY_ENTRY
  • CfgFileFilter : CFileBrowse
  • CfgReadBack : CvcDP5Dlg
  • CHANNELS : Spec
  • CheckSum : _Packet_In
  • CommError : CDP5Protocol
  • CurrentChannel : CvcDP5Dlg
  • CurrentDevice : CDppWinUSB , CDppLibUsb
  • CursorPosition : CvcDP5Dlg , CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • DATA : _Packet_In , Packet_Out , Spec
  • data_in : CDppLibUsb
  • data_out : CDppLibUsb
  • data_refresh : CSProfile
  • DataIn : CSelectDP5
  • DCAL : DP5_DP4_FORMAT_STATUS
  • DET_TEMP : DP5_DP4_FORMAT_STATUS
  • DEVICE_ID : DP5_DP4_FORMAT_STATUS
  • device_type : CSProfile
  • deviceConnected : WINUSB_DEVICE_INFO
  • deviceHandle : WINUSB_DEVICE_INFO
  • DeviceNotificationHandle : CWinusbNotify
  • devicePath : WINUSB_DEVICE_INFO
  • deviceSpeed : WINUSB_DEVICE_INFO
  • DeviceType : CvcDP5Dlg
  • devInfo : CDppWinUSB
  • DiagData : _DiagDataType , CDP5Status
  • DisplayCfg : CvcDP5Dlg
  • DisplaySca : CvcDP5Dlg
  • DP5_CONFIGURED : DP5_DP4_FORMAT_STATUS
  • DP5_TEMP : DP5_DP4_FORMAT_STATUS
  • Dp5CmdList : CvcDP5Dlg
  • DP5Stat : CvcDP5Dlg
  • DPP_ECO : _CONFIG_OPTIONS , DP5_DP4_FORMAT_STATUS
  • DPP_options : DP5_DP4_FORMAT_STATUS
  • DppEntries : CNetFinder
  • DppEntryIdx : CNetFinder
  • DppFound : CNetFinder
  • DppLibusbHandle : CDppLibUsb
  • DppSockAddr : CNetFinder
  • DppState : CParsePacket
  • DppType : _CONFIG_OPTIONS
  • DppUtil : CDP5Status
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • event1_days : NETDISPLAY_ENTRY
  • event1_hours : NETDISPLAY_ENTRY
  • event1_minutes : NETDISPLAY_ENTRY
  • event1_seconds : NETDISPLAY_ENTRY
  • event2_days : NETDISPLAY_ENTRY
  • event2_hours : NETDISPLAY_ENTRY
  • event2_minutes : NETDISPLAY_ENTRY
  • event2_seconds : NETDISPLAY_ENTRY
  • ExeFileFilter : CFileBrowse
  • EXPECTEDRESPONSE : Packet_Out
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • FastChThreshold : CvcDP5Dlg
  • FastCount : DP5_DP4_FORMAT_STATUS
  • FindDpp : CSelectDP5
  • FindDppUSB : CSelectDP5
  • Firmware : DP5_DP4_FORMAT_STATUS , _DiagDataType
  • FPGA : _DiagDataType , DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • gateway : NETDISPLAY_ENTRY
  • GP_COUNTER : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • hasBackground : CPlotCanvas
  • HasData : NETDISPLAY_ENTRY
  • HavePlot : CvcDP5Dlg
  • HaveScopeData : _DppStateType
  • HaveTrace : CvcDP5Dlg
  • HPGe_HV_INH : DP5_DP4_FORMAT_STATUS
  • HPGe_HV_INH_POL : DP5_DP4_FORMAT_STATUS
  • HV : DP5_DP4_FORMAT_STATUS
  • HVOn : _DiagDataType
  • HwCfgDP5 : CvcDP5Dlg
  • HwCfgDP5Out : _CONFIG_OPTIONS , CvcDP5Dlg
  • HwCfgExReady : CvcDP5Dlg
  • HwCfgReady : CvcDP5Dlg
  • hWnd_Main : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • idxCurrentSpectrum : CvcDP5Dlg
  • idxTotalSpectra : CvcDP5Dlg
  • Index : _WINUSB_SETUP_PACKET
  • ini : CIniUtil
  • InPacketType : CDP5Protocol
  • Interface : _DppStateType
  • interruptPipe : WINUSB_DEVICE_INFO
  • Interval : _WINUSB_PIPE_INFORMATION
  • ip : NETDISPLAY_ENTRY
  • Is8_5VPreAmp : _DiagDataType
  • isAscEnabled : DP5_DP4_FORMAT_STATUS
  • isAscInstalled : DP5_DP4_FORMAT_STATUS
  • isDeltaMode : CvcDP5Dlg
  • isDP5_RevDxGains : _CONFIG_OPTIONS , DP5_DP4_FORMAT_STATUS
  • isDppConnected : CvcDP5Dlg
  • isDppFound : CDppWinUSB
  • isPlotLine : CSProfile
  • IsPosHV : _DiagDataType
  • isScaleLog : CSProfile
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • LastBkColor : CLabel
  • LastEntry : CNetFinder
  • LastLibUsbError : CDppLibUsb
  • LastTextColor : CLabel
  • lblDppFound : CSelectDP5
  • lblMiscStatus : CvcDP5Dlg
  • lblSelectCommunications : CvcDP5Dlg
  • lblStatus : CvcDP5Dlg
  • LEN : _Packet_In , Packet_Out
  • Length : _WINUSB_SETUP_PACKET
  • LibFileFilter : CFileBrowse
  • LiveTime : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • m_Anim : cWaitDlg
  • m_Bitmap : cAnimWnd
  • m_bLink : CLabel
  • m_bModified : CSelectDP5
  • m_bShowCancelButton : cWaitDialog , cWaitDlg , cWaitDlgThread
  • m_bState : CLabel
  • m_bTimer : CLabel
  • m_crCursorColor : CPlotCanvas
  • m_crDisplayBGColor : CPlotCanvas
  • m_crPlotColor : CPlotCanvas
  • m_crText : CLabel
  • m_crTextBGColor : CPlotCanvas
  • m_crTextFGColor : CPlotCanvas
  • m_DP5_Status : CDP5Status , CSelectDP5
  • m_Event : cWaitDialog , cWaitDlgThread
  • m_Eventname : cWaitDlgThread
  • m_EventName : cWaitDialog
  • m_font : CLabel
  • m_hBrush : CLabel
  • m_hCursor : CLabel
  • m_Height : cAnimWnd
  • m_hIcon : CvcDP5Dlg
  • m_hwndBrush : CLabel
  • m_hWndOwner : CWinusbNotify
  • m_ImageIndex : cAnimWnd
  • m_iNumChan : _SpectrumFileType
  • m_lf : CLabel
  • m_MemDC : cAnimWnd
  • m_nTmrRS232Elapse : CvcDP5Dlg
  • m_nTmrRS232EventId : CvcDP5Dlg
  • m_nTmrRS232Id : CvcDP5Dlg
  • m_nTmrSpectrumElapse : CvcDP5Dlg
  • m_nTmrSpectrumEventId : CvcDP5Dlg
  • m_nTmrSpectrumId : CvcDP5Dlg
  • m_nTmrTimeoutElapse : CvcDP5Dlg
  • m_nTmrTimeoutEventId : CvcDP5Dlg
  • m_nTmrTimeoutId : CvcDP5Dlg
  • m_PicturePlot : CvcDP5Dlg
  • m_PictureScope : CvcDP5Dlg
  • m_rand : CNetFinder
  • m_SpectrumRefreshTimeCtrl : CSelectDP5
  • m_SpinSelectDevice : CSelectDP5
  • m_strDelimiter : CMsgBox
  • m_strMessage : CMsgBox
  • m_strText : CLabel
  • m_strTitle : CMsgBox
  • m_Text : cWaitDlgThread , cWaitDlg , cWaitDialog
  • m_Thread : cWaitDlg , cWaitDialog
  • m_ToolTip : CSelectDP5
  • m_TransparentColor : cAnimWnd
  • m_Type : CLabel
  • m_Width : cAnimWnd
  • mac : NETDISPLAY_ENTRY
  • MaximumPacketSize : _WINUSB_PIPE_INFORMATION
  • MCA_EN : DP5_DP4_FORMAT_STATUS
  • mcaCH : CvcDP5Dlg
  • McaFileFilter : CFileBrowse
  • MCS_DONE : DP5_DP4_FORMAT_STATUS
  • MiscData : CDP5Protocol
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • Netfinder_active : CDP5Protocol
  • Netfinder_Seq : CDP5Protocol
  • NullBkColor : CLabel
  • NullSet : CLabel
  • NullTextColor : CLabel
  • NumDevices : CDppLibUsb , CDppWinUSB
  • NumPipes : CDppWinUSB
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • OldCursorPosition : CPlotCanvas
  • OldPlotCursor : CPlotCanvas
  • OptPlotType : CPlotCanvas
  • OptScaleType : CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • Packet_Received : CDP5Protocol
  • PacketIn : CDP5Protocol
  • ParsePkt : CvcDP5Dlg
  • PC5_8_5V : DP5_DP4_FORMAT_STATUS
  • PC5_HV_POL : DP5_DP4_FORMAT_STATUS
  • PC5_PRESENT : _CONFIG_OPTIONS , DP5_DP4_FORMAT_STATUS , _DiagDataType
  • PC5_SN : DP5_DP4_FORMAT_STATUS , _DiagDataType
  • PC5_V : _DiagDataType
  • PC5DCAL : _DiagDataType
  • PC5Initialized : _DiagDataType
  • PersistenceMode : CPlotCanvas
  • PID1 : Packet_Out , _Packet_In
  • PID2 : _Packet_In , Packet_Out
  • PIN : CDP5Protocol
  • PipeId : CDppWinUSB , _WINUSB_PIPE_INFORMATION
  • PipeTimeout : CDppWinUSB
  • PipeType : _WINUSB_PIPE_INFORMATION
  • PlotBuffer : CvcDP5Dlg
  • PlotCursor : CPlotCanvas
  • port : NETDISPLAY_ENTRY
  • PreAmpON : _DiagDataType
  • PRECNT_REACHED : DP5_DP4_FORMAT_STATUS
  • PresetAcq : CvcDP5Dlg
  • PresetCount : CvcDP5Dlg
  • PresetLtDone : DP5_DP4_FORMAT_STATUS
  • PresetRt : CvcDP5Dlg
  • PresetRtDone : DP5_DP4_FORMAT_STATUS
  • PrintCfg : CvcDP5Dlg
  • profile : CSProfile
  • PX4 : DP5_DP4_FORMAT_STATUS
  • PZCORR : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • RAM_TEST_ERROR : DP5_DP4_FORMAT_STATUS
  • RAM_TEST_RUN : DP5_DP4_FORMAT_STATUS
  • RAW : DP5_DP4_FORMAT_STATUS
  • RealTime : DP5_DP4_FORMAT_STATUS
  • ReBootFlag : DP5_DP4_FORMAT_STATUS
  • ReqProcess : _DppStateType
  • Request : _WINUSB_SETUP_PACKET
  • RequestType : _WINUSB_SETUP_PACKET
  • RiseUS : CvcDP5Dlg
  • RS232_RThreshold : CDP5Protocol
  • RS232BytesInBuffer : CDP5Protocol
  • RS232HeaderReceived : CDP5Protocol
  • RS232PacketPtr : CDP5Protocol
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • SaveCfg : CvcDP5Dlg
  • ScaleAuto : CDP5Protocol
  • ScaReadBack : CvcDP5Dlg
  • Scope : CDP5Protocol
  • SCOPE_DR : DP5_DP4_FORMAT_STATUS
  • ScopeAutoRearm : _DppStateType
  • ScopeBuffer : CvcDP5Dlg
  • ScopeOverFlow : _DppStateType
  • SendCoarseFineGain : _CONFIG_OPTIONS
  • SerialNumber : DP5_DP4_FORMAT_STATUS , _SpectrumFileType
  • SlowChThreshold : CvcDP5Dlg
  • SlowCount : DP5_DP4_FORMAT_STATUS
  • SlowThresholdPct : CvcDP5Dlg
  • SockAddr : NETDISPLAY_ENTRY
  • SPECTRUM : CDP5Protocol
  • SPECTRUM_OFFSET : DP5_DP4_FORMAT_STATUS
  • SRAMTestData : _DiagDataType
  • SRAMTestPass : _DiagDataType
  • STATUS : _Packet_In
  • str_description : NETDISPLAY_ENTRY
  • str_display : NETDISPLAY_ENTRY
  • str_ev1 : NETDISPLAY_ENTRY
  • str_ev2 : NETDISPLAY_ENTRY
  • str_type : NETDISPLAY_ENTRY
  • strAnalogOut : CvcDP5Dlg
  • strDescription : _SpectrumFileType
  • strDevice : CSProfile
  • strGainDisplayValue : CvcDP5Dlg
  • strInputOffset : CvcDP5Dlg
  • strLowerMiscData : CvcDP5Dlg
  • strMcaMode : CvcDP5Dlg
  • strOutputOffset : CvcDP5Dlg
  • strPort : _DppStateType
  • strPresetCmd : CvcDP5Dlg
  • strPresetVal : CvcDP5Dlg
  • strScopeGain : CvcDP5Dlg
  • strSpectrumConfig : _SpectrumFileType
  • strSpectrumStatus : _SpectrumFileType
  • strStartTime : _SpectrumFileType
  • strTag : _SpectrumFileType
  • strTempCal : _DiagDataType
  • strTempRaw : _DiagDataType
  • strTriggerPosition : CvcDP5Dlg
  • strTriggerSlope : CvcDP5Dlg
  • strTriggerSource : CvcDP5Dlg
  • strUpperMiscData : CvcDP5Dlg
  • subnet : NETDISPLAY_ENTRY
  • Sup9VOn : _DiagDataType
  • SUPPLIES_ON : DP5_DP4_FORMAT_STATUS
  • szSettings : CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • TEC_Voltage : DP5_DP4_FORMAT_STATUS
  • TECOn : _DiagDataType
  • TempOffset : _DiagDataType
  • Timeout_flag : CDP5Protocol
  • TimeoutFlag : CvcDP5Dlg
  • TxtFileFilter : CFileBrowse
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • UC_TEMP_OFFSET : DP5_DP4_FORMAT_STATUS
  • UDP_offset : CDP5Protocol
  • UpdateScopeCfg : CvcDP5Dlg
  • USB_Default_Timeout : CDP5Protocol , CDppWinUSB
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • Value : _WINUSB_SETUP_PACKET
  • VREF_IN : DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WinUsb_Disabled : CDppWinUSB
  • winUSBHandle : WINUSB_DEVICE_INFO
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • X : _COORD_LONG
  • XPlotMAX : CvcDP5Dlg , CPlotCanvas
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • Y : _COORD_LONG
  • YPlotBuffer : CPlotCanvas
  • YPlotMAX : CPlotCanvas , CvcDP5Dlg
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Enumerations

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • DialogType : CFileBrowse
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Members - Enumerator

  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • IDD : CMsgBox , cWaitDlg , CvcDP5Dlg , CAboutDlg
  • OPEN : CFileBrowse
  • SAVE : CFileBrowse
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: MsgBox.cpp File Reference

  • File List
  • File Members
MsgBox.cpp File Reference
#include "stdafx.h"
#include "resource.h"
#include "MsgBox.h"
Include dependency graph for MsgBox.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: MsgBox.h File Reference

Classes
MsgBox.h File Reference
#include "stringex.h"
Include dependency graph for MsgBox.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CMsgBox
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: resource.h File Reference

Defines
resource.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDM_ABOUTBOX 16
#define | IDD_ABOUTBOX 100
#define | IDS_ABOUTBOX 101
#define | IDC_BUSY_PIC 1029
#define | IDC_BUSY_TEXT 1030
#define | IDC_MESSAGE1 1105
#define | IDC_MESSAGE2 1106
#define | IDC_BUTTON_ADD_ROI 2304
#define | IDC_BUTTON_ARM_TRIGGER 2305
#define | IDC_BUTTON_CLEAR_DATA_AND_GRAPH 2306
#define | IDC_BUTTON_CLEAR_MISC_DATA 2307
#define | IDC_BUTTON_CLEAR_ROI 2308
#define | IDC_BUTTON_DIAG 2309
#define | IDC_BUTTON_EDIT_CONFIG 2310
#define | IDC_BUTTON_FIND_DEVICE 2311
#define | IDC_BUTTON_READ_MISC_DATA 2312
#define | IDC_BUTTON_ROI_END 2313
#define | IDC_BUTTON_ROI_START 2314
#define | IDC_BUTTON_SAVE_FILE 2315
#define | IDC_BUTTON_SELECT_COMM 2316
#define | IDC_BUTTON_SHOW_CONFIG 2317
#define | IDC_BUTTON_SINGLE_UPDATE 2318
#define | IDC_BUTTON_START_ACQUISITION 2319
#define | IDC_BUTTON_STOP_ACQUISITION 2320
#define | IDC_BUTTON_WRITE_MISC_DATA 2321
#define | IDC_CHECK_AUTO_REARM 2322
#define | IDC_CHECK_DELTA 2323
#define | IDC_EDIT_DESCRIPTION 2324
#define | IDC_EDIT_DIAG 2325
#define | IDC_EDIT_MISC_DATA 2326
#define | IDC_EDIT_START_TIME 2327
#define | IDC_EDIT_STATUS 2328
#define | IDC_CHECK_REPEAT_SPECTRUM 2328
#define | IDC_EDIT_TAG 2329
#define | IDC_GROUP_PLOT_SCALE 2330
#define | IDC_PICTURE_PLOT 2331
#define | IDC_PICTURE_SCOPE 2332
#define | IDC_PLOTTYPEGROUP 2333
#define | IDC_RADIO_PLOT_SCALE_LINEAR 2334
#define | IDC_RADIO_PLOT_SCALE_LOG 2335
#define | IDC_RADIO_PLOT_TYPE_SOLID 2336
#define | IDC_RADIO_PLOT_TYPE_LINE 2337
#define | IDC_STATIC_ 2338
#define | IDC_STATIC_MISC_STATUS 2339
#define | IDC_STATIC_ROI_COUNT 2340
#define | IDC_STATIC_ROI_END 2341
#define | IDC_STATIC_ROI_INDEX 2342
#define | IDC_STATIC_ROI_START 2343
#define | IDC_STATIC_SELECT_COMMUNICATIONS 2344
#define | IDC_STATIC_SPECTRUM_STATUS 2345
#define | IDC_STATIC_STATUS 2346
#define | IDC_BUTTON_AUTOTUNE 2347
#define | IDC_STATIC_START_TIME 2348
#define | IDC_EDIT_PRESET_CMD 2349
#define | IDC_EDIT_REPEAT_LOOPS 2350
#define | IDC_STATIC_PRESET_CMD 2351
#define | IDC_STATIC_LOOPS 2352
#define | IDC_STATIC_REPEAT_STATUS 2353
#define | IDB_BITMAP_DP5_DLG 4105
#define | IDB_SPECTRUM_ANIM 4144
#define | IDD_BUSY_DLG 4150
#define | IDD_MESSAGE_BOX 4159
#define | IDP_SOCKETS_INIT_FAILED 4186
#define | IDR_MAINFRAME 4188
#define | IDR_MENU 4189
#define | IDR_TOOLBAR 4196
#define | IDR_TOOLBAR_DP5_DLG 4197
#define | IDS_BTNSTRING_MODAL 4198
#define | IDS_BTNSTRING_MODELESS 4199
#define | IDS_CAPTION 4200
#define | IDD_vcDP5_DIALOG 7168
#define | ID_FILE_TAB 33064
#define | ID_GAINPZ_TAB 33073
#define | ID_MCA_TAB 33092
#define | ID_MISC_TAB 33095
#define | ID_POWER_TAB 33102
#define | ID_SHAPING_TAB 33120
#define | ID_HELP_ABOUT 40003

Define Documentation

#define ID_FILE_TAB 33064

Definition at line 76 of file resource.h.

#define ID_GAINPZ_TAB 33073

Definition at line 77 of file resource.h.

#define ID_HELP_ABOUT 40003

Definition at line 82 of file resource.h.

#define ID_MCA_TAB 33092

Definition at line 78 of file resource.h.

#define ID_MISC_TAB 33095

Definition at line 79 of file resource.h.

#define ID_POWER_TAB 33102

Definition at line 80 of file resource.h.

#define ID_SHAPING_TAB 33120

Definition at line 81 of file resource.h.

#define IDB_BITMAP_DP5_DLG 4105

Definition at line 63 of file resource.h.

#define IDB_SPECTRUM_ANIM 4144

Definition at line 64 of file resource.h.

#define IDC_BUSY_PIC 1029

Definition at line 8 of file resource.h.

#define IDC_BUSY_TEXT 1030

Definition at line 9 of file resource.h.

#define IDC_BUTTON_ADD_ROI 2304

Definition at line 12 of file resource.h.

#define IDC_BUTTON_ARM_TRIGGER 2305

Definition at line 13 of file resource.h.

#define IDC_BUTTON_AUTOTUNE 2347

Definition at line 56 of file resource.h.

#define IDC_BUTTON_CLEAR_DATA_AND_GRAPH 2306

Definition at line 14 of file resource.h.

#define IDC_BUTTON_CLEAR_MISC_DATA 2307

Definition at line 15 of file resource.h.

#define IDC_BUTTON_CLEAR_ROI 2308

Definition at line 16 of file resource.h.

#define IDC_BUTTON_DIAG 2309

Definition at line 17 of file resource.h.

#define IDC_BUTTON_EDIT_CONFIG 2310

Definition at line 18 of file resource.h.

#define IDC_BUTTON_FIND_DEVICE 2311

Definition at line 19 of file resource.h.

#define IDC_BUTTON_READ_MISC_DATA 2312

Definition at line 20 of file resource.h.

#define IDC_BUTTON_ROI_END 2313

Definition at line 21 of file resource.h.

#define IDC_BUTTON_ROI_START 2314

Definition at line 22 of file resource.h.

#define IDC_BUTTON_SAVE_FILE 2315

Definition at line 23 of file resource.h.

#define IDC_BUTTON_SELECT_COMM 2316

Definition at line 24 of file resource.h.

#define IDC_BUTTON_SHOW_CONFIG 2317

Definition at line 25 of file resource.h.

#define IDC_BUTTON_SINGLE_UPDATE 2318

Definition at line 26 of file resource.h.

#define IDC_BUTTON_START_ACQUISITION 2319

Definition at line 27 of file resource.h.

#define IDC_BUTTON_STOP_ACQUISITION 2320

Definition at line 28 of file resource.h.

#define IDC_BUTTON_WRITE_MISC_DATA 2321

Definition at line 29 of file resource.h.

#define IDC_CHECK_AUTO_REARM 2322

Definition at line 30 of file resource.h.

#define IDC_CHECK_DELTA 2323

Definition at line 31 of file resource.h.

#define IDC_CHECK_REPEAT_SPECTRUM 2328

Definition at line 37 of file resource.h.

#define IDC_EDIT_DESCRIPTION 2324

Definition at line 32 of file resource.h.

#define IDC_EDIT_DIAG 2325

Definition at line 33 of file resource.h.

#define IDC_EDIT_MISC_DATA 2326

Definition at line 34 of file resource.h.

#define IDC_EDIT_PRESET_CMD 2349

Definition at line 58 of file resource.h.

#define IDC_EDIT_REPEAT_LOOPS 2350

Definition at line 59 of file resource.h.

#define IDC_EDIT_START_TIME 2327

Definition at line 35 of file resource.h.

#define IDC_EDIT_STATUS 2328

Definition at line 36 of file resource.h.

#define IDC_EDIT_TAG 2329

Definition at line 38 of file resource.h.

#define IDC_GROUP_PLOT_SCALE 2330

Definition at line 39 of file resource.h.

#define IDC_MESSAGE1 1105

Definition at line 10 of file resource.h.

#define IDC_MESSAGE2 1106

Definition at line 11 of file resource.h.

#define IDC_PICTURE_PLOT 2331

Definition at line 40 of file resource.h.

#define IDC_PICTURE_SCOPE 2332

Definition at line 41 of file resource.h.

#define IDC_PLOTTYPEGROUP 2333

Definition at line 42 of file resource.h.

#define IDC_RADIO_PLOT_SCALE_LINEAR 2334

Definition at line 43 of file resource.h.

#define IDC_RADIO_PLOT_SCALE_LOG 2335

Definition at line 44 of file resource.h.

#define IDC_RADIO_PLOT_TYPE_LINE 2337

Definition at line 46 of file resource.h.

#define IDC_RADIO_PLOT_TYPE_SOLID 2336

Definition at line 45 of file resource.h.

#define IDC_STATIC_ 2338

Definition at line 47 of file resource.h.

#define IDC_STATIC_LOOPS 2352

Definition at line 61 of file resource.h.

#define IDC_STATIC_MISC_STATUS 2339

Definition at line 48 of file resource.h.

#define IDC_STATIC_PRESET_CMD 2351

Definition at line 60 of file resource.h.

#define IDC_STATIC_REPEAT_STATUS 2353

Definition at line 62 of file resource.h.

#define IDC_STATIC_ROI_COUNT 2340

Definition at line 49 of file resource.h.

#define IDC_STATIC_ROI_END 2341

Definition at line 50 of file resource.h.

#define IDC_STATIC_ROI_INDEX 2342

Definition at line 51 of file resource.h.

#define IDC_STATIC_ROI_START 2343

Definition at line 52 of file resource.h.

#define IDC_STATIC_SELECT_COMMUNICATIONS 2344

Definition at line 53 of file resource.h.

#define IDC_STATIC_SPECTRUM_STATUS 2345

Definition at line 54 of file resource.h.

#define IDC_STATIC_START_TIME 2348

Definition at line 57 of file resource.h.

#define IDC_STATIC_STATUS 2346

Definition at line 55 of file resource.h.

#define IDD_ABOUTBOX 100

Definition at line 6 of file resource.h.

#define IDD_BUSY_DLG 4150

Definition at line 65 of file resource.h.

#define IDD_MESSAGE_BOX 4159

Definition at line 66 of file resource.h.

#define IDD_vcDP5_DIALOG 7168

Definition at line 75 of file resource.h.

#define IDM_ABOUTBOX 16

Definition at line 5 of file resource.h.

#define IDP_SOCKETS_INIT_FAILED 4186

Definition at line 67 of file resource.h.

#define IDR_MAINFRAME 4188

Definition at line 68 of file resource.h.

#define IDR_MENU 4189

Definition at line 69 of file resource.h.

#define IDR_TOOLBAR 4196

Definition at line 70 of file resource.h.

#define IDR_TOOLBAR_DP5_DLG 4197

Definition at line 71 of file resource.h.

#define IDS_ABOUTBOX 101

Definition at line 7 of file resource.h.

#define IDS_BTNSTRING_MODAL 4198

Definition at line 72 of file resource.h.

#define IDS_BTNSTRING_MODELESS 4199

Definition at line 73 of file resource.h.

#define IDS_CAPTION 4200

Definition at line 74 of file resource.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: SProfile.cpp File Reference

SProfile.cpp File Reference
#include "StdAfx.h"
#include "SProfile.h"
#include <time.h>
#include <math.h>
Include dependency graph for SProfile.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: SProfile.h File Reference

Classes | Defines | Variables
SProfile.h File Reference
#include "stdafx.h"
#include "vcDP5.h"
Include dependency graph for SProfile.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CSProfile

Defines

#define | GETPD(p1, i1, data) str = Get(p1, #i1, data); i1 = atof(str)
#define | PUTPD(p1, i1) str.Format("%g", i1); Put(p1, #i1, str)
#define | GETP1(p1, i1, data) i1 = Get(p1, #i1, data)
#define | PUTP1(p1, i1) Put(p1, #i1, i1)

Variables

const CString | regDP5Comm = "DP5_Communication"
const CString | regDP5Device = "DP5_Device"
const CString | regDP5Config = "DP5_Configuration"
CSProfile Profile

Define Documentation

#define GETP1 | ( | p1,
 |  | i1,
 |  | data
 | ) | i1 = Get(p1, #i1, data)

Definition at line 10 of file SProfile.h.

#define GETPD | ( | p1,
 |  | i1,
 |  | data
 | ) | str = Get(p1, #i1, data); i1 = atof(str)

Definition at line 6 of file SProfile.h.

#define PUTP1 | ( | p1,
 |  | i1
 | ) | Put(p1, #i1, i1)

Definition at line 11 of file SProfile.h.

#define PUTPD | ( | p1,
 |  | i1
 | ) | str.Format("%g", i1); Put(p1, #i1, str)

Definition at line 7 of file SProfile.h.

Variable Documentation

CSProfile Profile

Definition at line 41 of file vcDP5.cpp.

const CString regDP5Comm = "DP5_Communication"

Definition at line 13 of file SProfile.h.

const CString regDP5Config = "DP5_Configuration"

Definition at line 15 of file SProfile.h.

const CString regDP5Device = "DP5_Device"

Definition at line 14 of file SProfile.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: StdAfx.cpp File Reference

StdAfx.cpp File Reference
#include "stdafx.h"
Include dependency graph for StdAfx.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: StdAfx.h File Reference

Defines
StdAfx.h File Reference
#include <afxwin.h>
#include <afxext.h>
#include <afxole.h>
#include <afxdisp.h>
#include <afxdtctl.h>
#include <vector>
#include <afxcmn.h>
#include <afxdlgs.h>
#include <afxtempl.h>
#include <afxsock.h>
Include dependency graph for StdAfx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | _CRT_SECURE_NO_DEPRECATE 1
#define | _SETUPAPI_VER 0x0501
#define | WINVER 0x0501
#define | _WIN32_WINNT 0x0501
#define | _WIN32_WINDOWS 0x0410
#define | _WIN32_IE 0x0600
#define | VC_EXTRALEAN

Define Documentation

#define _CRT_SECURE_NO_DEPRECATE 1

Definition at line 9 of file StdAfx.h.

#define _SETUPAPI_VER 0x0501

Definition at line 13 of file StdAfx.h.

#define _WIN32_IE 0x0600

Definition at line 32 of file StdAfx.h.

#define _WIN32_WINDOWS 0x0410

Definition at line 28 of file StdAfx.h.

#define _WIN32_WINNT 0x0501

Definition at line 24 of file StdAfx.h.

#define VC_EXTRALEAN

Definition at line 39 of file StdAfx.h.

#define WINVER 0x0501

Definition at line 19 of file StdAfx.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringex.cpp File Reference

stringex.cpp File Reference
#include "stringex.h"
Include dependency graph for stringex.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringex.h File Reference

Classes
stringex.h File Reference
#include <stdio.h>
#include <stdarg.h>
#include <cstdarg>
#include <vector>
#include <string>
#include <cctype>
Include dependency graph for stringex.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class stringex
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: STypes.cpp File Reference

STypes.cpp File Reference
#include "StdAfx.h"
#include "STypes.h"
Include dependency graph for STypes.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: STypes.h File Reference

Defines | Enumerations
STypes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | MIN_PLOT_X_PIXELS 100
#define | MIN_PLOT_Y_PIXELS 80
#define | MIN_FRAME_X_PIXELS 200
#define | MIN_FRAME_Y_PIXELS 160
#define | MAX_CHANNELS 0x4000ul
#define | MAX_COUNTS 0xFFFFFFFFul
#define | MIN_PLOT_CHANNELS 64
#define | MIN_PLOT_COUNTS 32
#define | MIN_GAIN 256
#define | MAX_GAIN_INDEX 6
#define | GAIN_FROM_INDEX(index) (MIN_GAIN << index)
#define | GETULONG(d) ((unsigned long) floor(d + 0.5))
#define | TOULONG(d)
#define | GETLONG(d) ((long) floor(d + 0.5))
#define | TOLONG(d)
#define | SCREEN_SCALE 10000
#define | MAX_SPECTRA 20

Enumerations

enum SCALE_TYPE {
LIN_SCALE, LOG_SCALE,
SQRT_SCALE
}
enum SMOOTH_TYPE {
INVALID_SMOOTH = -2, NO_SMOOTH,
THREE_SMOOTH, FIVE_SMOOTH
}
enum GAIN_TYPE {
GAIN_256, GAIN_512,
GAIN_1024, GAIN_2048,
GAIN_4096, GAIN_8192,
GAIN_16384
}

Define Documentation

#define GAIN_FROM_INDEX ( index ) (MIN_GAIN << index)

Definition at line 29 of file STypes.h.

#define GETLONG ( d ) ((long) floor(d + 0.5))

Definition at line 33 of file STypes.h.

#define GETULONG ( d ) ((unsigned long) floor(d + 0.5))

Definition at line 30 of file STypes.h.

#define MAX_CHANNELS 0x4000ul

Definition at line 20 of file STypes.h.

#define MAX_COUNTS 0xFFFFFFFFul

Definition at line 21 of file STypes.h.

#define MAX_GAIN_INDEX 6

Definition at line 27 of file STypes.h.

#define MAX_SPECTRA 20

Definition at line 39 of file STypes.h.

#define MIN_FRAME_X_PIXELS 200

Definition at line 17 of file STypes.h.

#define MIN_FRAME_Y_PIXELS 160

Definition at line 18 of file STypes.h.

#define MIN_GAIN 256

Definition at line 26 of file STypes.h.

#define MIN_PLOT_CHANNELS 64

Definition at line 23 of file STypes.h.

#define MIN_PLOT_COUNTS 32

Definition at line 24 of file STypes.h.

#define MIN_PLOT_X_PIXELS 100

Definition at line 14 of file STypes.h.

#define MIN_PLOT_Y_PIXELS 80

Definition at line 15 of file STypes.h.

#define SCREEN_SCALE 10000

Definition at line 37 of file STypes.h.

#define TOLONG ( d )
Value:
(d <= LONG_MIN ? LONG_MIN : \
        (d > LONG_MAX ? LONG_MAX : GETLONG(d)))

Definition at line 34 of file STypes.h.

#define TOULONG ( d )
Value:
(d <= 0.0 ? 0 : \
        (d > ULONG_MAX ? ULONG_MAX : GETULONG(d)))

Definition at line 31 of file STypes.h.

Enumeration Type Documentation

enum GAIN_TYPE
Enumerator:
GAIN_256
GAIN_512
GAIN_1024
GAIN_2048
GAIN_4096
GAIN_8192
GAIN_16384

Definition at line 57 of file STypes.h.

enum SCALE_TYPE
Enumerator:
LIN_SCALE
LOG_SCALE
SQRT_SCALE

Definition at line 42 of file STypes.h.

enum SMOOTH_TYPE
Enumerator:
INVALID_SMOOTH
NO_SMOOTH
THREE_SMOOTH
FIVE_SMOOTH

Definition at line 49 of file STypes.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: UserMsgs.h File Reference

Defines
UserMsgs.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | WM_USER_PMCA_REQUEST_PARAMETER (WM_USER + 256)
#define | WM_USER_FPGUI_REQUEST_PARAMETER (WM_USER + 257)
#define | WM_USER_LOAD_FILE (WM_USER + 300)
#define | WM_USER_UPDATE_STATUS_BAR (WM_USER + 301)
#define | WM_USER_UPDATE_MENU (WM_USER + 302)
#define | WM_USER_SHOW_SPECTRA_LIST_DLG (WM_USER + 303)
#define | WM_USER_SEND_CONFIG_TO_HW (WM_USER + 305)
#define | WM_USER_REPEAT_MEASUREMENT (WM_USER + 306)
#define | WM_USER_READ_DPP_CONFIG (WM_USER + 307)
#define | WM_USER_SAVE_CONFIG_TO_FILE (WM_USER + 309)
#define | WM_USER_COARSE_AUTO_INPUT_OFFSET (WM_USER + 312)
#define | WM_USER_FINE_AUTO_INPUT_OFFSET (WM_USER + 313)
#define | WM_USER_DPP_AUTO_FAST_THESHOLD (WM_USER + 314)
#define | WM_USER_DPP_AUTO_SLOW_THESHOLD (WM_USER + 315)
#define | WM_USER_SHOW_CONNECT_DIALOG (WM_USER + 316)
#define | WM_USER_READ_SCA_CONFIG (WM_USER + 317)
#define | WM_USER_READ_DPP_CONFIG_EX (WM_USER + 319)

Define Documentation

#define WM_USER_COARSE_AUTO_INPUT_OFFSET (WM_USER + 312)

Definition at line 20 of file UserMsgs.h.

#define WM_USER_DPP_AUTO_FAST_THESHOLD (WM_USER + 314)

Definition at line 22 of file UserMsgs.h.

#define WM_USER_DPP_AUTO_SLOW_THESHOLD (WM_USER + 315)

Definition at line 23 of file UserMsgs.h.

#define WM_USER_FINE_AUTO_INPUT_OFFSET (WM_USER + 313)

Definition at line 21 of file UserMsgs.h.

#define WM_USER_FPGUI_REQUEST_PARAMETER (WM_USER + 257)

Definition at line 5 of file UserMsgs.h.

#define WM_USER_LOAD_FILE (WM_USER + 300)

Definition at line 7 of file UserMsgs.h.

#define WM_USER_PMCA_REQUEST_PARAMETER (WM_USER + 256)

Definition at line 4 of file UserMsgs.h.

#define WM_USER_READ_DPP_CONFIG (WM_USER + 307)

Definition at line 15 of file UserMsgs.h.

#define WM_USER_READ_DPP_CONFIG_EX (WM_USER + 319)

Definition at line 26 of file UserMsgs.h.

#define WM_USER_READ_SCA_CONFIG (WM_USER + 317)

Definition at line 25 of file UserMsgs.h.

#define WM_USER_REPEAT_MEASUREMENT (WM_USER + 306)

Definition at line 14 of file UserMsgs.h.

#define WM_USER_SAVE_CONFIG_TO_FILE (WM_USER + 309)

Definition at line 17 of file UserMsgs.h.

#define WM_USER_SEND_CONFIG_TO_HW (WM_USER + 305)

Definition at line 13 of file UserMsgs.h.

#define WM_USER_SHOW_CONNECT_DIALOG (WM_USER + 316)

Definition at line 24 of file UserMsgs.h.

#define WM_USER_SHOW_SPECTRA_LIST_DLG (WM_USER + 303)

Definition at line 10 of file UserMsgs.h.

#define WM_USER_UPDATE_MENU (WM_USER + 302)

Definition at line 9 of file UserMsgs.h.

#define WM_USER_UPDATE_STATUS_BAR (WM_USER + 301)

Definition at line 8 of file UserMsgs.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5.cpp File Reference

Variables
vcDP5.cpp File Reference
#include "stdafx.h"
#include "vcDP5.h"
#include "vcDP5Dlg.h"
#include "DppWinUSB.h"
#include "DP5Protocol.h"
#include "WinusbNotify.h"
Include dependency graph for vcDP5.cpp:

Go to the source code of this file.

Variables

CvcDP5App theApp
CWinusbNotify WinusbNotify
CDppWinUSB DppWinUSB
CSendCommand SndCmd
CDP5Protocol DP5Proto
CSProfile Profile

Variable Documentation

CDP5Protocol DP5Proto

Definition at line 40 of file vcDP5.cpp.

CDppWinUSB DppWinUSB

Definition at line 38 of file vcDP5.cpp.

CSProfile Profile

Definition at line 41 of file vcDP5.cpp.

CSendCommand SndCmd

Definition at line 39 of file vcDP5.cpp.

CvcDP5App theApp

Definition at line 36 of file vcDP5.cpp.

CWinusbNotify WinusbNotify

Definition at line 37 of file vcDP5.cpp.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5.h File Reference

Classes | Variables
vcDP5.h File Reference
#include "resource.h"
#include <SetupAPI.h>
#include "SendCommand.h"
#include "SProfile.h"
#include "DppConst.h"
Include dependency graph for vcDP5.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CvcDP5App

Variables

CvcDP5App theApp

Variable Documentation

CvcDP5App theApp

Definition at line 36 of file vcDP5.cpp.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5_Shared_HIDD.h File Reference

Defines
vcDP5_Shared_HIDD.h File Reference

Go to the source code of this file.

Defines

#define | HIDD_DP5_CONNECT 0x20191
#define | HIDD_FILE_PAGE 0x20192
#define | HIDD_MCA_PAGE 0x20193
#define | HIDD_SHAPING_PAGE 0x20194
#define | HIDD_GAINPZ_PAGE 0x20195
#define | HIDD_POWER_PAGE 0x20196
#define | HIDD_MISC_PAGE 0x20197

Define Documentation

#define HIDD_DP5_CONNECT 0x20191

Definition at line 11 of file vcDP5_Shared_HIDD.h.

#define HIDD_FILE_PAGE 0x20192

Definition at line 12 of file vcDP5_Shared_HIDD.h.

#define HIDD_GAINPZ_PAGE 0x20195

Definition at line 15 of file vcDP5_Shared_HIDD.h.

#define HIDD_MCA_PAGE 0x20193

Definition at line 13 of file vcDP5_Shared_HIDD.h.

#define HIDD_MISC_PAGE 0x20197

Definition at line 17 of file vcDP5_Shared_HIDD.h.

#define HIDD_POWER_PAGE 0x20196

Definition at line 16 of file vcDP5_Shared_HIDD.h.

#define HIDD_SHAPING_PAGE 0x20194

Definition at line 14 of file vcDP5_Shared_HIDD.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5_Shared_IDD.h File Reference

Defines
vcDP5_Shared_IDD.h File Reference

Go to the source code of this file.

Defines

#define | IDD_DP5_CONNECT 401
#define | IDD_FILE_PAGE 402
#define | IDD_MCA_PAGE 403
#define | IDD_SHAPING_PAGE 404
#define | IDD_GAINPZ_PAGE 405
#define | IDD_POWER_PAGE 406
#define | IDD_MISC_PAGE 407

Define Documentation

#define IDD_DP5_CONNECT 401

Definition at line 1 of file vcDP5_Shared_IDD.h.

#define IDD_FILE_PAGE 402

Definition at line 2 of file vcDP5_Shared_IDD.h.

#define IDD_GAINPZ_PAGE 405

Definition at line 5 of file vcDP5_Shared_IDD.h.

#define IDD_MCA_PAGE 403

Definition at line 3 of file vcDP5_Shared_IDD.h.

#define IDD_MISC_PAGE 407

Definition at line 7 of file vcDP5_Shared_IDD.h.

#define IDD_POWER_PAGE 406

Definition at line 6 of file vcDP5_Shared_IDD.h.

#define IDD_SHAPING_PAGE 404

Definition at line 4 of file vcDP5_Shared_IDD.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5Dlg.cpp File Reference

Classes
vcDP5Dlg.cpp File Reference
#include "stdafx.h"
#include "DppWinUSB.h"
#include "vcDP5.h"
#include "vcDP5Dlg.h"
#include "SelectDP5.h"
#include ".\msectimer.h"
#include ".\waitdlg\CmdWaitDlg.h"
#include "UserMsgs.h"
#include "FileBrowse.h"
#include "afxadv.h"
#include "TuneSlowThreshold.h"
#include "MsgBox.h"
#include "AsciiCmdUtilities.h"
Include dependency graph for vcDP5Dlg.cpp:

Go to the source code of this file.

Classes

class CAboutDlg
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5Dlg.h File Reference

Classes | Defines | Typedefs | Variables
vcDP5Dlg.h File Reference
#include "stdafx.h"
#include "afxwin.h"
#include "Resource.h"
#include "ParsePacket.h"
#include "Label.h"
#include "PlotCanvas.h"
#include "DP5Status.h"
#include "stringex.h"
#include "WinusbNotify.h"
Include dependency graph for vcDP5Dlg.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _SpectrumFileType
class | CvcDP5Dlg

Defines

#define | LINEAR_PLOT_SCALE 0
#define | LOG_PLOT_SCALE 1
#define | SOLID_PLOT_TYPE 0
#define | LINE_PLOT_TYPE 1

Typedefs

typedef struct _SpectrumFileType | SpectrumFileType

Variables

CDP5Protocol DP5Proto
CDppWinUSB DppWinUSB
CWinusbNotify WinusbNotify

Define Documentation

#define LINE_PLOT_TYPE 1

Definition at line 18 of file vcDP5Dlg.h.

#define LINEAR_PLOT_SCALE 0

Definition at line 15 of file vcDP5Dlg.h.

#define LOG_PLOT_SCALE 1

Definition at line 16 of file vcDP5Dlg.h.

#define SOLID_PLOT_TYPE 0

Definition at line 17 of file vcDP5Dlg.h.

Typedef Documentation

typedef struct _SpectrumFileType SpectrumFileType

Variable Documentation

CDP5Protocol DP5Proto

Definition at line 40 of file vcDP5.cpp.

CDppWinUSB DppWinUSB

Definition at line 38 of file vcDP5.cpp.

CWinusbNotify WinusbNotify

Definition at line 37 of file vcDP5.cpp.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/INI.cpp File Reference

CIni/INI.cpp File Reference
#include "stdafx.h"
#include "INI.h"
#include <afxcoll.h>
Include dependency graph for INI.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/INI.h File Reference

Classes | Defines
CIni/INI.h File Reference
#include <afxcoll.h>
Include dependency graph for INI.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CINI

Defines

#define | MAX_SECTION_SIZE 0x7FFF
#define | MAX_KEY_DATA_SIZE 0xFF

Define Documentation

#define MAX_KEY_DATA_SIZE 0xFF

Definition at line 15 of file INI.h.

#define MAX_SECTION_SIZE 0x7FFF

Definition at line 14 of file INI.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniEx.cpp File Reference

CIni/IniEx.cpp File Reference
#include "IniEx.h"
Include dependency graph for IniEx.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniEx.h File Reference

Classes
CIni/IniEx.h File Reference
#include "stdafx.h"
Include dependency graph for IniEx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CIniEx
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniUtil.cpp File Reference

CIni/IniUtil.cpp File Reference
#include "IniUtil.h"
Include dependency graph for IniUtil.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniUtil.h File Reference

Classes
CIni/IniUtil.h File Reference
#include "stdafx.h"
#include "INI.h"
Include dependency graph for IniUtil.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CIniUtil
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/DppSlowThreshold.cpp File Reference

Config/DppSlowThreshold.cpp File Reference
#include "stdafx.h"
#include ".\dppslowthreshold.h"
Include dependency graph for DppSlowThreshold.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/DppSlowThreshold.h File Reference

Classes
Config/DppSlowThreshold.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CDppSlowThreshold
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/TuneSlowThreshold.cpp File Reference

Config/TuneSlowThreshold.cpp File Reference
#include "stdafx.h"
#include ".\tuneslowthreshold.h"
#include "DppSlowThreshold.h"
#include "UserMsgs.h"
Include dependency graph for TuneSlowThreshold.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/TuneSlowThreshold.h File Reference

Classes
Config/TuneSlowThreshold.h File Reference
#include "afxcmn.h"
#include "afxwin.h"
#include "resource.h"
Include dependency graph for TuneSlowThreshold.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CTuneSlowThreshold
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/Label.cpp File Reference

Controls/Label.cpp File Reference
#include "stdafx.h"
#include "Resource.h"
#include "Label.h"
Include dependency graph for Label.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/Label.h File Reference

Classes | Enumerations
Controls/Label.h File Reference
#include "X11Color.h"
Include dependency graph for Label.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CLabel

Enumerations

enum FlashType {
None, Text,
Background
}

Enumeration Type Documentation

enum FlashType
Enumerator:
None
Text
Background

Definition at line 13 of file Label.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/PlotCanvas.cpp File Reference

Controls/PlotCanvas.cpp File Reference
#include "stdafx.h"
#include <math.h>
#include "PlotCanvas.h"
Include dependency graph for PlotCanvas.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/PlotCanvas.h File Reference

Classes | Defines | Typedefs
Controls/PlotCanvas.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _COORD_LONG
class | CPlotCanvas

Defines

#define | CC_SYSCOLOR(ind) (0x80000000|((ind) & ~CLR_DEFAULT))
#define | ctrlColBlue RGB(0x00,0x00,0xFF)
#define | ctrlColSkyBlue RGB(0x32,0x99,0xCC)
#define | ctrlColLightBlue RGB(0xC0,0xD9,0xD9)
#define | ctrlColLightCyan RGB(0xE0,0xFF,0xFF)
#define | ctrlColYellow RGB(0x00,0xFF,0xFF)
#define | ctrlColGreen RGB(0x00,0xFF,0x00)
#define | ctrlDarkGreen RGB(0x2F,0x4F,0x2F)
#define | ctrlDarkGreenCopper RGB(0x4A,0x76,0x6E)
#define | ctrlDarkOliveGreen RGB(0x4F,0x4F,0x2F)
#define | ctrlColRed RGB(0xFF,0x00,0x00)
#define | ctrlColBlack RGB(0x00,0x00,0x00)
#define | ctrlColWhite RGB(0xFF,0xFF,0xFF)
#define | ctrlColDefault CLR_DEFAULT
#define | ctrlColWinBk GetSysColor(0x80000005L)
#define | ctrlColWinText CC_SYSCOLOR(COLOR_WINDOWTEXT)
#define | ctrlColBtnFace CC_SYSCOLOR(COLOR_BTNFACE)
#define | ctrlColInfoBk CC_SYSCOLOR(COLOR_INFOBK)
#define | ctrlColInfoText CC_SYSCOLOR(COLOR_INFOTEXT)
#define | ctrlColJavaGray RGB(0x64,0x64,0x64)
#define | ctrlColLightGray RGB(0xA8,0xA8,0xA8)
#define | ctrlColGray RGB(0xC0,0xC0,0xC0)

Typedefs

typedef struct _COORD_LONG | COORD_LONG

Define Documentation

#define CC_SYSCOLOR ( ind ) (0x80000000|((ind) & ~CLR_DEFAULT))

Definition at line 12 of file PlotCanvas.h.

#define ctrlColBlack RGB(0x00,0x00,0x00)

Definition at line 24 of file PlotCanvas.h.

#define ctrlColBlue RGB(0x00,0x00,0xFF)

Definition at line 14 of file PlotCanvas.h.

#define ctrlColBtnFace CC_SYSCOLOR(COLOR_BTNFACE)

Definition at line 30 of file PlotCanvas.h.

#define ctrlColDefault CLR_DEFAULT

Definition at line 26 of file PlotCanvas.h.

#define ctrlColGray RGB(0xC0,0xC0,0xC0)

Definition at line 36 of file PlotCanvas.h.

#define ctrlColGreen RGB(0x00,0xFF,0x00)

Definition at line 19 of file PlotCanvas.h.

#define ctrlColInfoBk CC_SYSCOLOR(COLOR_INFOBK)

Definition at line 31 of file PlotCanvas.h.

#define ctrlColInfoText CC_SYSCOLOR(COLOR_INFOTEXT)

Definition at line 32 of file PlotCanvas.h.

#define ctrlColJavaGray RGB(0x64,0x64,0x64)

Definition at line 34 of file PlotCanvas.h.

#define ctrlColLightBlue RGB(0xC0,0xD9,0xD9)

Definition at line 16 of file PlotCanvas.h.

#define ctrlColLightCyan RGB(0xE0,0xFF,0xFF)

Definition at line 17 of file PlotCanvas.h.

#define ctrlColLightGray RGB(0xA8,0xA8,0xA8)

Definition at line 35 of file PlotCanvas.h.

#define ctrlColRed RGB(0xFF,0x00,0x00)

Definition at line 23 of file PlotCanvas.h.

#define ctrlColSkyBlue RGB(0x32,0x99,0xCC)

Definition at line 15 of file PlotCanvas.h.

#define ctrlColWhite RGB(0xFF,0xFF,0xFF)

Definition at line 25 of file PlotCanvas.h.

#define ctrlColWinBk GetSysColor(0x80000005L)

Definition at line 28 of file PlotCanvas.h.

#define ctrlColWinText CC_SYSCOLOR(COLOR_WINDOWTEXT)

Definition at line 29 of file PlotCanvas.h.

#define ctrlColYellow RGB(0x00,0xFF,0xFF)

Definition at line 18 of file PlotCanvas.h.

#define ctrlDarkGreen RGB(0x2F,0x4F,0x2F)

Definition at line 20 of file PlotCanvas.h.

#define ctrlDarkGreenCopper RGB(0x4A,0x76,0x6E)

Definition at line 21 of file PlotCanvas.h.

#define ctrlDarkOliveGreen RGB(0x4F,0x4F,0x2F)

Definition at line 22 of file PlotCanvas.h.

Typedef Documentation

typedef struct _COORD_LONG COORD_LONG
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/X11Color.h File Reference

Variables
Controls/X11Color.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Variables

const COLORREF | colorAliceBlue = RGB(0xF0,0xF8,0xFF)
const COLORREF | colorAmptekBlue = RGB(0x7A,0xCE,0xFC)
const COLORREF | colorAntiqueWhite = RGB(0xFA,0xEB,0xD7)
const COLORREF | colorAqua = RGB(0x00,0xFF,0xFF)
const COLORREF | colorAquamarine = RGB(0x7F,0xFF,0xD4)
const COLORREF | colorAzure = RGB(0xF0,0xFF,0xFF)
const COLORREF | colorBeige = RGB(0xF5,0xF5,0xDC)
const COLORREF | colorBisque = RGB(0xFF,0xE4,0xC4)
const COLORREF | colorBlack = RGB(0x00,0x00,0x00)
const COLORREF | colorBlanchedAlmond = RGB(0xFF,0xEB,0xCD)
const COLORREF | colorBlue = RGB(0x00,0x00,0xFF)
const COLORREF | colorBlueViolet = RGB(0x8A,0x2B,0xE2)
const COLORREF | colorBrown = RGB(0xA5,0x2A,0x2A)
const COLORREF | colorBurlyWood = RGB(0xDE,0xB8,0x87)
const COLORREF | colorCadetBlue = RGB(0x5F,0x9E,0xA0)
const COLORREF | colorChartreuse = RGB(0x7F,0xFF,0x00)
const COLORREF | colorChocolate = RGB(0xD2,0x69,0x1E)
const COLORREF | colorCoral = RGB(0xFF,0x7F,0x50)
const COLORREF | colorCornflowerBlue = RGB(0x64,0x95,0xED)
const COLORREF | colorCornsilk = RGB(0xFF,0xF8,0xDC)
const COLORREF | colorCrimson = RGB(0xDC,0x14,0x3C)
const COLORREF | colorCyan = RGB(0x00,0xFF,0xFF)
const COLORREF | colorDarkBlue = RGB(0x00,0x00,0x8B)
const COLORREF | colorDarkCyan = RGB(0x00,0x8B,0x8B)
const COLORREF | colorDarkGoldenrod = RGB(0xB8,0x86,0x0B)
const COLORREF | colorDarkGray = RGB(0xA9,0xA9,0xA9)
const COLORREF | colorDarkGreen = RGB(0x00,0x64,0x00)
const COLORREF | colorDarkKhaki = RGB(0xBD,0xB7,0x6B)
const COLORREF | colorDarkMagenta = RGB(0x8B,0x00,0x8B)
const COLORREF | colorDarkOliveGreen = RGB(0x55,0x6B,0x2F)
const COLORREF | colorDarkOrange = RGB(0xFF,0x8C,0x00)
const COLORREF | colorDarkOrchid = RGB(0x99,0x32,0xCC)
const COLORREF | colorDarkRed = RGB(0x8B,0x00,0x00)
const COLORREF | colorDarkSalmon = RGB(0xE9,0x96,0x7A)
const COLORREF | colorDarkSeaGreen = RGB(0x8F,0xBC,0x8F)
const COLORREF | colorDarkSlateBlue = RGB(0x48,0x3D,0x8B)
const COLORREF | colorDarkSlateGray = RGB(0x2F,0x4F,0x4F)
const COLORREF | colorDarkTurquoise = RGB(0x00,0xCE,0xD1)
const COLORREF | colorDarkViolet = RGB(0x94,0x00,0xD3)
const COLORREF | colorDeepPink = RGB(0xFF,0x14,0x93)
const COLORREF | colorDeepSkyBlue = RGB(0x00,0xBF,0xFF)
const COLORREF | colorDimGray = RGB(0x69,0x69,0x69)
const COLORREF | colorDodgerBlue = RGB(0x1E,0x90,0xFF)
const COLORREF | colorFireBrick = RGB(0xB2,0x22,0x22)
const COLORREF | colorFloralWhite = RGB(0xFF,0xFA,0xF0)
const COLORREF | colorForestGreen = RGB(0x22,0x8B,0x22)
const COLORREF | colorFuchsia = RGB(0xFF,0x00,0xFF)
const COLORREF | colorGainsboro = RGB(0xDC,0xDC,0xDC)
const COLORREF | colorGhostWhite = RGB(0xF8,0xF8,0xFF)
const COLORREF | colorGold = RGB(0xFF,0xD7,0x00)
const COLORREF | colorGoldenrod = RGB(0xDA,0xA5,0x20)
const COLORREF | colorGray = RGB(0x80,0x80,0x80)
const COLORREF | colorGreen = RGB(0x00,0x80,0x00)
const COLORREF | colorGreenYellow = RGB(0xAD,0xFF,0x2F)
const COLORREF | colorHoneydew = RGB(0xF0,0xFF,0xF0)
const COLORREF | colorHotPink = RGB(0xFF,0x69,0xB4)
const COLORREF | colorIndianRed = RGB(0xCD,0x5C,0x5C)
const COLORREF | colorIndigo = RGB(0x4B,0x00,0x82)
const COLORREF | colorIvory = RGB(0xFF,0xFF,0xF0)
const COLORREF | colorKhaki = RGB(0xF0,0xE6,0x8C)
const COLORREF | colorLavender = RGB(0xE6,0xE6,0xFA)
const COLORREF | colorLavenderBlush = RGB(0xFF,0xF0,0xF5)
const COLORREF | colorLawnGreen = RGB(0x7C,0xFC,0x00)
const COLORREF | colorLemonChiffon = RGB(0xFF,0xFA,0xCD)
const COLORREF | colorLightBlue = RGB(0xAD,0xD8,0xE6)
const COLORREF | colorLightCoral = RGB(0xF0,0x80,0x80)
const COLORREF | colorLightCyan = RGB(0xE0,0xFF,0xFF)
const COLORREF | colorLightGoldenrodYellow = RGB(0xFA,0xFA,0xD2)
const COLORREF | colorLightGray = RGB(0xD3,0xD3,0xD3)
const COLORREF | colorLightGreen = RGB(0x90,0xEE,0x90)
const COLORREF | colorLightGrey = RGB(0xD3,0xD3,0xD3)
const COLORREF | colorLightPink = RGB(0xFF,0xB6,0xC1)
const COLORREF | colorLightSalmon = RGB(0xFF,0xA0,0x7A)
const COLORREF | colorLightSeaGreen = RGB(0x20,0xB2,0xAA)
const COLORREF | colorLightSkyBlue = RGB(0x87,0xCE,0xFA)
const COLORREF | colorLightSlateGray = RGB(0x77,0x88,0x99)
const COLORREF | colorLightSteelBlue = RGB(0xB0,0xC4,0xDE)
const COLORREF | colorLightYellow = RGB(0xFF,0xFF,0xE0)
const COLORREF | colorLime = RGB(0x00,0xFF,0x00)
const COLORREF | colorLimeGreen = RGB(0x32,0xCD,0x32)
const COLORREF | colorLinen = RGB(0xFA,0xF0,0xE6)
const COLORREF | colorMagenta = RGB(0xFF,0x00,0xFF)
const COLORREF | colorMaroon = RGB(0x80,0x00,0x00)
const COLORREF | colorMediumAquamarine = RGB(0x66,0xCD,0xAA)
const COLORREF | colorMediumBlue = RGB(0x00,0x00,0xCD)
const COLORREF | colorMediumOrchid = RGB(0xBA,0x55,0xD3)
const COLORREF | colorMediumPurple = RGB(0x93,0x70,0xDB)
const COLORREF | colorMediumSeaGreen = RGB(0x3C,0xB3,0x71)
const COLORREF | colorMediumSlateBlue = RGB(0x7B,0x68,0xEE)
const COLORREF | colorMediumSpringGreen = RGB(0x00,0xFA,0x9A)
const COLORREF | colorMediumTurquoise = RGB(0x48,0xD1,0xCC)
const COLORREF | colorMediumVioletRed = RGB(0xC7,0x15,0x85)
const COLORREF | colorMidnightBlue = RGB(0x19,0x19,0x70)
const COLORREF | colorMintCream = RGB(0xF5,0xFF,0xFA)
const COLORREF | colorMistyRose = RGB(0xFF,0xE4,0xE1)
const COLORREF | colorMoccasin = RGB(0xFF,0xE4,0xB5)
const COLORREF | colorNavajoWhite = RGB(0xFF,0xDE,0xAD)
const COLORREF | colorNavy = RGB(0x00,0x00,0x80)
const COLORREF | colorOldLace = RGB(0xFD,0xF5,0xE6)
const COLORREF | colorOlive = RGB(0x80,0x80,0x00)
const COLORREF | colorOliveDrab = RGB(0x6B,0x8E,0x23)
const COLORREF | colorOrange = RGB(0xFF,0xA5,0x00)
const COLORREF | colorOrangeRed = RGB(0xFF,0x45,0x00)
const COLORREF | colorOrchid = RGB(0xDA,0x70,0xD6)
const COLORREF | colorPaleGoldenrod = RGB(0xEE,0xE8,0xAA)
const COLORREF | colorPaleGreen = RGB(0x98,0xFB,0x98)
const COLORREF | colorPaleTurquoise = RGB(0xAF,0xEE,0xEE)
const COLORREF | colorPaleVioletRed = RGB(0xDB,0x70,0x93)
const COLORREF | colorPapayaWhip = RGB(0xFF,0xEF,0xD5)
const COLORREF | colorPeachPuff = RGB(0xFF,0xDA,0xB9)
const COLORREF | colorPeru = RGB(0xCD,0x85,0x3F)
const COLORREF | colorPink = RGB(0xFF,0xC0,0xCB)
const COLORREF | colorPlum = RGB(0xDD,0xA0,0xDD)
const COLORREF | colorPowderBlue = RGB(0xB0,0xE0,0xE6)
const COLORREF | colorPurple = RGB(0x80,0x00,0x80)
const COLORREF | colorRed = RGB(0xFF,0x00,0x00)
const COLORREF | colorRosyBrown = RGB(0xBC,0x8F,0x8F)
const COLORREF | colorRoyalBlue = RGB(0x41,0x69,0xE1)
const COLORREF | colorSaddleBrown = RGB(0x8B,0x45,0x13)
const COLORREF | colorSalmon = RGB(0xFA,0x80,0x72)
const COLORREF | colorSandyBrown = RGB(0xF4,0xA4,0x60)
const COLORREF | colorSeaGreen = RGB(0x2E,0x8B,0x57)
const COLORREF | colorSeaShell = RGB(0xFF,0xF5,0xEE)
const COLORREF | colorSienna = RGB(0xA0,0x52,0x2D)
const COLORREF | colorSilver = RGB(0xC0,0xC0,0xC0)
const COLORREF | colorSkyBlue = RGB(0x87,0xCE,0xEB)
const COLORREF | colorSlateBlue = RGB(0x6A,0x5A,0xCD)
const COLORREF | colorSlateGray = RGB(0x70,0x80,0x90)
const COLORREF | colorSnow = RGB(0xFF,0xFA,0xFA)
const COLORREF | colorSpringGreen = RGB(0x00,0xFF,0x7F)
const COLORREF | colorSteelBlue = RGB(0x46,0x82,0xB4)
const COLORREF | colorTan = RGB(0xD2,0xB4,0x8C)
const COLORREF | colorTeal = RGB(0x00,0x80,0x80)
const COLORREF | colorThistle = RGB(0xD8,0xBF,0xD8)
const COLORREF | colorTomato = RGB(0xFF,0x63,0x47)
const COLORREF | colorTurquoise = RGB(0x40,0xE0,0xD0)
const COLORREF | colorViolet = RGB(0xEE,0x82,0xEE)
const COLORREF | colorWheat = RGB(0xF5,0xDE,0xB3)
const COLORREF | colorWhite = RGB(0xFF,0xFF,0xFF)
const COLORREF | colorWhiteSmoke = RGB(0xF5,0xF5,0xF5)
const COLORREF | colorYellow = RGB(0xFF,0xFF,0x00)
const COLORREF | colorYellowGreen = RGB(0x9A,0xCD,0x32)

Variable Documentation

const COLORREF colorAliceBlue = RGB(0xF0,0xF8,0xFF)

Definition at line 9 of file X11Color.h.

const COLORREF colorAmptekBlue = RGB(0x7A,0xCE,0xFC)

Definition at line 10 of file X11Color.h.

const COLORREF colorAntiqueWhite = RGB(0xFA,0xEB,0xD7)

Definition at line 11 of file X11Color.h.

const COLORREF colorAqua = RGB(0x00,0xFF,0xFF)

Definition at line 12 of file X11Color.h.

const COLORREF colorAquamarine = RGB(0x7F,0xFF,0xD4)

Definition at line 13 of file X11Color.h.

const COLORREF colorAzure = RGB(0xF0,0xFF,0xFF)

Definition at line 14 of file X11Color.h.

const COLORREF colorBeige = RGB(0xF5,0xF5,0xDC)

Definition at line 15 of file X11Color.h.

const COLORREF colorBisque = RGB(0xFF,0xE4,0xC4)

Definition at line 16 of file X11Color.h.

const COLORREF colorBlack = RGB(0x00,0x00,0x00)

Definition at line 17 of file X11Color.h.

const COLORREF colorBlanchedAlmond = RGB(0xFF,0xEB,0xCD)

Definition at line 18 of file X11Color.h.

const COLORREF colorBlue = RGB(0x00,0x00,0xFF)

Definition at line 19 of file X11Color.h.

const COLORREF colorBlueViolet = RGB(0x8A,0x2B,0xE2)

Definition at line 20 of file X11Color.h.

const COLORREF colorBrown = RGB(0xA5,0x2A,0x2A)

Definition at line 21 of file X11Color.h.

const COLORREF colorBurlyWood = RGB(0xDE,0xB8,0x87)

Definition at line 22 of file X11Color.h.

const COLORREF colorCadetBlue = RGB(0x5F,0x9E,0xA0)

Definition at line 23 of file X11Color.h.

const COLORREF colorChartreuse = RGB(0x7F,0xFF,0x00)

Definition at line 24 of file X11Color.h.

const COLORREF colorChocolate = RGB(0xD2,0x69,0x1E)

Definition at line 25 of file X11Color.h.

const COLORREF colorCoral = RGB(0xFF,0x7F,0x50)

Definition at line 26 of file X11Color.h.

const COLORREF colorCornflowerBlue = RGB(0x64,0x95,0xED)

Definition at line 27 of file X11Color.h.

const COLORREF colorCornsilk = RGB(0xFF,0xF8,0xDC)

Definition at line 28 of file X11Color.h.

const COLORREF colorCrimson = RGB(0xDC,0x14,0x3C)

Definition at line 29 of file X11Color.h.

const COLORREF colorCyan = RGB(0x00,0xFF,0xFF)

Definition at line 30 of file X11Color.h.

const COLORREF colorDarkBlue = RGB(0x00,0x00,0x8B)

Definition at line 31 of file X11Color.h.

const COLORREF colorDarkCyan = RGB(0x00,0x8B,0x8B)

Definition at line 32 of file X11Color.h.

const COLORREF colorDarkGoldenrod = RGB(0xB8,0x86,0x0B)

Definition at line 33 of file X11Color.h.

const COLORREF colorDarkGray = RGB(0xA9,0xA9,0xA9)

Definition at line 34 of file X11Color.h.

const COLORREF colorDarkGreen = RGB(0x00,0x64,0x00)

Definition at line 35 of file X11Color.h.

const COLORREF colorDarkKhaki = RGB(0xBD,0xB7,0x6B)

Definition at line 36 of file X11Color.h.

const COLORREF colorDarkMagenta = RGB(0x8B,0x00,0x8B)

Definition at line 37 of file X11Color.h.

const COLORREF colorDarkOliveGreen = RGB(0x55,0x6B,0x2F)

Definition at line 38 of file X11Color.h.

const COLORREF colorDarkOrange = RGB(0xFF,0x8C,0x00)

Definition at line 39 of file X11Color.h.

const COLORREF colorDarkOrchid = RGB(0x99,0x32,0xCC)

Definition at line 40 of file X11Color.h.

const COLORREF colorDarkRed = RGB(0x8B,0x00,0x00)

Definition at line 41 of file X11Color.h.

const COLORREF colorDarkSalmon = RGB(0xE9,0x96,0x7A)

Definition at line 42 of file X11Color.h.

const COLORREF colorDarkSeaGreen = RGB(0x8F,0xBC,0x8F)

Definition at line 43 of file X11Color.h.

const COLORREF colorDarkSlateBlue = RGB(0x48,0x3D,0x8B)

Definition at line 44 of file X11Color.h.

const COLORREF colorDarkSlateGray = RGB(0x2F,0x4F,0x4F)

Definition at line 45 of file X11Color.h.

const COLORREF colorDarkTurquoise = RGB(0x00,0xCE,0xD1)

Definition at line 46 of file X11Color.h.

const COLORREF colorDarkViolet = RGB(0x94,0x00,0xD3)

Definition at line 47 of file X11Color.h.

const COLORREF colorDeepPink = RGB(0xFF,0x14,0x93)

Definition at line 48 of file X11Color.h.

const COLORREF colorDeepSkyBlue = RGB(0x00,0xBF,0xFF)

Definition at line 49 of file X11Color.h.

const COLORREF colorDimGray = RGB(0x69,0x69,0x69)

Definition at line 50 of file X11Color.h.

const COLORREF colorDodgerBlue = RGB(0x1E,0x90,0xFF)

Definition at line 51 of file X11Color.h.

const COLORREF colorFireBrick = RGB(0xB2,0x22,0x22)

Definition at line 52 of file X11Color.h.

const COLORREF colorFloralWhite = RGB(0xFF,0xFA,0xF0)

Definition at line 53 of file X11Color.h.

const COLORREF colorForestGreen = RGB(0x22,0x8B,0x22)

Definition at line 54 of file X11Color.h.

const COLORREF colorFuchsia = RGB(0xFF,0x00,0xFF)

Definition at line 55 of file X11Color.h.

const COLORREF colorGainsboro = RGB(0xDC,0xDC,0xDC)

Definition at line 56 of file X11Color.h.

const COLORREF colorGhostWhite = RGB(0xF8,0xF8,0xFF)

Definition at line 57 of file X11Color.h.

const COLORREF colorGold = RGB(0xFF,0xD7,0x00)

Definition at line 58 of file X11Color.h.

const COLORREF colorGoldenrod = RGB(0xDA,0xA5,0x20)

Definition at line 59 of file X11Color.h.

const COLORREF colorGray = RGB(0x80,0x80,0x80)

Definition at line 60 of file X11Color.h.

const COLORREF colorGreen = RGB(0x00,0x80,0x00)

Definition at line 61 of file X11Color.h.

const COLORREF colorGreenYellow = RGB(0xAD,0xFF,0x2F)

Definition at line 62 of file X11Color.h.

const COLORREF colorHoneydew = RGB(0xF0,0xFF,0xF0)

Definition at line 63 of file X11Color.h.

const COLORREF colorHotPink = RGB(0xFF,0x69,0xB4)

Definition at line 64 of file X11Color.h.

const COLORREF colorIndianRed = RGB(0xCD,0x5C,0x5C)

Definition at line 65 of file X11Color.h.

const COLORREF colorIndigo = RGB(0x4B,0x00,0x82)

Definition at line 66 of file X11Color.h.

const COLORREF colorIvory = RGB(0xFF,0xFF,0xF0)

Definition at line 67 of file X11Color.h.

const COLORREF colorKhaki = RGB(0xF0,0xE6,0x8C)

Definition at line 68 of file X11Color.h.

const COLORREF colorLavender = RGB(0xE6,0xE6,0xFA)

Definition at line 69 of file X11Color.h.

const COLORREF colorLavenderBlush = RGB(0xFF,0xF0,0xF5)

Definition at line 70 of file X11Color.h.

const COLORREF colorLawnGreen = RGB(0x7C,0xFC,0x00)

Definition at line 71 of file X11Color.h.

const COLORREF colorLemonChiffon = RGB(0xFF,0xFA,0xCD)

Definition at line 72 of file X11Color.h.

const COLORREF colorLightBlue = RGB(0xAD,0xD8,0xE6)

Definition at line 73 of file X11Color.h.

const COLORREF colorLightCoral = RGB(0xF0,0x80,0x80)

Definition at line 74 of file X11Color.h.

const COLORREF colorLightCyan = RGB(0xE0,0xFF,0xFF)

Definition at line 75 of file X11Color.h.

const COLORREF colorLightGoldenrodYellow = RGB(0xFA,0xFA,0xD2)

Definition at line 76 of file X11Color.h.

const COLORREF colorLightGray = RGB(0xD3,0xD3,0xD3)

Definition at line 77 of file X11Color.h.

const COLORREF colorLightGreen = RGB(0x90,0xEE,0x90)

Definition at line 78 of file X11Color.h.

const COLORREF colorLightGrey = RGB(0xD3,0xD3,0xD3)

Definition at line 79 of file X11Color.h.

const COLORREF colorLightPink = RGB(0xFF,0xB6,0xC1)

Definition at line 80 of file X11Color.h.

const COLORREF colorLightSalmon = RGB(0xFF,0xA0,0x7A)

Definition at line 81 of file X11Color.h.

const COLORREF colorLightSeaGreen = RGB(0x20,0xB2,0xAA)

Definition at line 82 of file X11Color.h.

const COLORREF colorLightSkyBlue = RGB(0x87,0xCE,0xFA)

Definition at line 83 of file X11Color.h.

const COLORREF colorLightSlateGray = RGB(0x77,0x88,0x99)

Definition at line 84 of file X11Color.h.

const COLORREF colorLightSteelBlue = RGB(0xB0,0xC4,0xDE)

Definition at line 85 of file X11Color.h.

const COLORREF colorLightYellow = RGB(0xFF,0xFF,0xE0)

Definition at line 86 of file X11Color.h.

const COLORREF colorLime = RGB(0x00,0xFF,0x00)

Definition at line 87 of file X11Color.h.

const COLORREF colorLimeGreen = RGB(0x32,0xCD,0x32)

Definition at line 88 of file X11Color.h.

const COLORREF colorLinen = RGB(0xFA,0xF0,0xE6)

Definition at line 89 of file X11Color.h.

const COLORREF colorMagenta = RGB(0xFF,0x00,0xFF)

Definition at line 90 of file X11Color.h.

const COLORREF colorMaroon = RGB(0x80,0x00,0x00)

Definition at line 91 of file X11Color.h.

const COLORREF colorMediumAquamarine = RGB(0x66,0xCD,0xAA)

Definition at line 92 of file X11Color.h.

const COLORREF colorMediumBlue = RGB(0x00,0x00,0xCD)

Definition at line 93 of file X11Color.h.

const COLORREF colorMediumOrchid = RGB(0xBA,0x55,0xD3)

Definition at line 94 of file X11Color.h.

const COLORREF colorMediumPurple = RGB(0x93,0x70,0xDB)

Definition at line 95 of file X11Color.h.

const COLORREF colorMediumSeaGreen = RGB(0x3C,0xB3,0x71)

Definition at line 96 of file X11Color.h.

const COLORREF colorMediumSlateBlue = RGB(0x7B,0x68,0xEE)

Definition at line 97 of file X11Color.h.

const COLORREF colorMediumSpringGreen = RGB(0x00,0xFA,0x9A)

Definition at line 98 of file X11Color.h.

const COLORREF colorMediumTurquoise = RGB(0x48,0xD1,0xCC)

Definition at line 99 of file X11Color.h.

const COLORREF colorMediumVioletRed = RGB(0xC7,0x15,0x85)

Definition at line 100 of file X11Color.h.

const COLORREF colorMidnightBlue = RGB(0x19,0x19,0x70)

Definition at line 101 of file X11Color.h.

const COLORREF colorMintCream = RGB(0xF5,0xFF,0xFA)

Definition at line 102 of file X11Color.h.

const COLORREF colorMistyRose = RGB(0xFF,0xE4,0xE1)

Definition at line 103 of file X11Color.h.

const COLORREF colorMoccasin = RGB(0xFF,0xE4,0xB5)

Definition at line 104 of file X11Color.h.

const COLORREF colorNavajoWhite = RGB(0xFF,0xDE,0xAD)

Definition at line 105 of file X11Color.h.

const COLORREF colorNavy = RGB(0x00,0x00,0x80)

Definition at line 106 of file X11Color.h.

const COLORREF colorOldLace = RGB(0xFD,0xF5,0xE6)

Definition at line 107 of file X11Color.h.

const COLORREF colorOlive = RGB(0x80,0x80,0x00)

Definition at line 108 of file X11Color.h.

const COLORREF colorOliveDrab = RGB(0x6B,0x8E,0x23)

Definition at line 109 of file X11Color.h.

const COLORREF colorOrange = RGB(0xFF,0xA5,0x00)

Definition at line 110 of file X11Color.h.

const COLORREF colorOrangeRed = RGB(0xFF,0x45,0x00)

Definition at line 111 of file X11Color.h.

const COLORREF colorOrchid = RGB(0xDA,0x70,0xD6)

Definition at line 112 of file X11Color.h.

const COLORREF colorPaleGoldenrod = RGB(0xEE,0xE8,0xAA)

Definition at line 113 of file X11Color.h.

const COLORREF colorPaleGreen = RGB(0x98,0xFB,0x98)

Definition at line 114 of file X11Color.h.

const COLORREF colorPaleTurquoise = RGB(0xAF,0xEE,0xEE)

Definition at line 115 of file X11Color.h.

const COLORREF colorPaleVioletRed = RGB(0xDB,0x70,0x93)

Definition at line 116 of file X11Color.h.

const COLORREF colorPapayaWhip = RGB(0xFF,0xEF,0xD5)

Definition at line 117 of file X11Color.h.

const COLORREF colorPeachPuff = RGB(0xFF,0xDA,0xB9)

Definition at line 118 of file X11Color.h.

const COLORREF colorPeru = RGB(0xCD,0x85,0x3F)

Definition at line 119 of file X11Color.h.

const COLORREF colorPink = RGB(0xFF,0xC0,0xCB)

Definition at line 120 of file X11Color.h.

const COLORREF colorPlum = RGB(0xDD,0xA0,0xDD)

Definition at line 121 of file X11Color.h.

const COLORREF colorPowderBlue = RGB(0xB0,0xE0,0xE6)

Definition at line 122 of file X11Color.h.

const COLORREF colorPurple = RGB(0x80,0x00,0x80)

Definition at line 123 of file X11Color.h.

const COLORREF colorRed = RGB(0xFF,0x00,0x00)

Definition at line 124 of file X11Color.h.

const COLORREF colorRosyBrown = RGB(0xBC,0x8F,0x8F)

Definition at line 125 of file X11Color.h.

const COLORREF colorRoyalBlue = RGB(0x41,0x69,0xE1)

Definition at line 126 of file X11Color.h.

const COLORREF colorSaddleBrown = RGB(0x8B,0x45,0x13)

Definition at line 127 of file X11Color.h.

const COLORREF colorSalmon = RGB(0xFA,0x80,0x72)

Definition at line 128 of file X11Color.h.

const COLORREF colorSandyBrown = RGB(0xF4,0xA4,0x60)

Definition at line 129 of file X11Color.h.

const COLORREF colorSeaGreen = RGB(0x2E,0x8B,0x57)

Definition at line 130 of file X11Color.h.

const COLORREF colorSeaShell = RGB(0xFF,0xF5,0xEE)

Definition at line 131 of file X11Color.h.

const COLORREF colorSienna = RGB(0xA0,0x52,0x2D)

Definition at line 132 of file X11Color.h.

const COLORREF colorSilver = RGB(0xC0,0xC0,0xC0)

Definition at line 133 of file X11Color.h.

const COLORREF colorSkyBlue = RGB(0x87,0xCE,0xEB)

Definition at line 134 of file X11Color.h.

const COLORREF colorSlateBlue = RGB(0x6A,0x5A,0xCD)

Definition at line 135 of file X11Color.h.

const COLORREF colorSlateGray = RGB(0x70,0x80,0x90)

Definition at line 136 of file X11Color.h.

const COLORREF colorSnow = RGB(0xFF,0xFA,0xFA)

Definition at line 137 of file X11Color.h.

const COLORREF colorSpringGreen = RGB(0x00,0xFF,0x7F)

Definition at line 138 of file X11Color.h.

const COLORREF colorSteelBlue = RGB(0x46,0x82,0xB4)

Definition at line 139 of file X11Color.h.

const COLORREF colorTan = RGB(0xD2,0xB4,0x8C)

Definition at line 140 of file X11Color.h.

const COLORREF colorTeal = RGB(0x00,0x80,0x80)

Definition at line 141 of file X11Color.h.

const COLORREF colorThistle = RGB(0xD8,0xBF,0xD8)

Definition at line 142 of file X11Color.h.

const COLORREF colorTomato = RGB(0xFF,0x63,0x47)

Definition at line 143 of file X11Color.h.

const COLORREF colorTurquoise = RGB(0x40,0xE0,0xD0)

Definition at line 144 of file X11Color.h.

const COLORREF colorViolet = RGB(0xEE,0x82,0xEE)

Definition at line 145 of file X11Color.h.

const COLORREF colorWheat = RGB(0xF5,0xDE,0xB3)

Definition at line 146 of file X11Color.h.

const COLORREF colorWhite = RGB(0xFF,0xFF,0xFF)

Definition at line 147 of file X11Color.h.

const COLORREF colorWhiteSmoke = RGB(0xF5,0xF5,0xF5)

Definition at line 148 of file X11Color.h.

const COLORREF colorYellow = RGB(0xFF,0xFF,0x00)

Definition at line 149 of file X11Color.h.

const COLORREF colorYellowGreen = RGB(0x9A,0xCD,0x32)

Definition at line 150 of file X11Color.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/AsciiCmdUtilities.cpp File Reference

DeviceIO/AsciiCmdUtilities.cpp File Reference
#include "AsciiCmdUtilities.h"
Include dependency graph for AsciiCmdUtilities.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/AsciiCmdUtilities.h File Reference

Classes | Defines
DeviceIO/AsciiCmdUtilities.h File Reference
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <string>
#include <cctype>
#include "stringex.h"
#include "DppConst.h"
Include dependency graph for AsciiCmdUtilities.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CAsciiCmdUtilities

Defines

#define | DP4_PX4_OLD_CFG_SIZE 64
#define | DP5_MAX_CFG_SIZE 512
#define | Whitespace "\t\n\v\f\r\0x20"

Define Documentation

#define DP4_PX4_OLD_CFG_SIZE 64

Definition at line 14 of file AsciiCmdUtilities.h.

#define DP5_MAX_CFG_SIZE 512

Definition at line 15 of file AsciiCmdUtilities.h.

#define Whitespace "\t\n\v\f\r\0x20"

Definition at line 16 of file AsciiCmdUtilities.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Protocol.cpp File Reference

DeviceIO/DP5Protocol.cpp File Reference
#include "DP5Protocol.h"
Include dependency graph for DP5Protocol.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Protocol.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/DP5Protocol.h File Reference
#include <math.h>
Include dependency graph for DP5Protocol.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _Packet_In
struct | Packet_Out
struct | Spec
class | CDP5Protocol

Defines

#define | ACK 0
#define | SYNC1_ 0xF5
#define | SYNC2_ 0xFA
#define | RS232 0
#define | USB 1
#define | ETHERNET 2
#define | ETHERNET_TIMEOUT 1000
#define | RS232_TIMEOUT 2500
#define | USB_TIMEOUT 500
#define | Retries 2
#define | MAX_BUFFER_DATA 8192
#define | MAX_SCOPE_DATA 2048
#define | USB_DiagDataDelayMS 2500

Typedefs

typedef struct _Packet_In | Packet_In

Enumerations

enum TRANSMIT_PACKET_TYPE {
XMTPT_SEND_STATUS, XMTPT_SEND_SPECTRUM,
XMTPT_SEND_CLEAR_SPECTRUM, XMTPT_SEND_SPECTRUM_STATUS,
XMTPT_SEND_CLEAR_SPECTRUM_STATUS, XMTPT_BUFFER_SPECTRUM,
XMTPT_BUFFER_CLEAR_SPECTRUM, XMTPT_SEND_BUFFER,
XMTPT_SEND_DP4_STYLE_STATUS, XMTPT_SEND_PX4_CONFIG,
XMTPT_SEND_SCOPE_DATA, XMTPT_SEND_512_BYTE_MISC_DATA,
XMTPT_SEND_SCOPE_DATA_REARM, XMTPT_SEND_ETHERNET_SETTINGS,
XMTPT_SEND_DIAGNOSTIC_DATA, XMTPT_SEND_NETFINDER_PACKET,
XMTPT_SEND_HARDWARE_DESCRIPTION, XMTPT_SEND_SCA,
XMTPT_LATCH_SEND_SCA, XMTPT_LATCH_CLEAR_SEND_SCA,
XMTPT_SEND_ROI_OR_FIXED_BLOCK, XMTPT_PX4_STYLE_CONFIG_PACKET,
XMTPT_SEND_CONFIG_PACKET_EX, XMTPT_SEND_CONFIG_PACKET_TO_HW,
XMTPT_READ_CONFIG_PACKET, XMTPT_READ_CONFIG_PACKET_EX,
XMTPT_FULL_READ_CONFIG_PACKET, XMTPT_SCA_READ_CONFIG_PACKET,
XMTPT_ERASE_FPGA_IMAGE, XMTPT_UPLOAD_PACKET_FPGA,
XMTPT_REINITIALIZE_FPGA, XMTPT_ERASE_UC_IMAGE_0,
XMTPT_ERASE_UC_IMAGE_1, XMTPT_ERASE_UC_IMAGE_2,
XMTPT_UPLOAD_PACKET_UC, XMTPT_SWITCH_TO_UC_IMAGE_0,
XMTPT_SWITCH_TO_UC_IMAGE_1, XMTPT_SWITCH_TO_UC_IMAGE_2,
XMTPT_UC_FPGA_CHECKSUMS, XMTPT_CLEAR_SPECTRUM_BUFFER_A,
XMTPT_ENABLE_MCA_MCS, XMTPT_DISABLE_MCA_MCS,
XMTPT_ARM_DIGITAL_OSCILLOSCOPE, XMTPT_AUTOSET_INPUT_OFFSET,
XMTPT_AUTOSET_FAST_THRESHOLD, XMTPT_READ_IO3_0,
XMTPT_WRITE_IO3_0, XMTPT_WRITE_512_BYTE_MISC_DATA,
XMTPT_SET_DCAL, XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ,
XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC, XMTPT_SET_BOOT_FLAGS,
XMTPT_SET_HV_DP4_EMULATION, XMTPT_SET_TEC_DP4_EMULATION,
XMTPT_SET_INPUT_OFFSET_DP4_EMULATION, XMTPT_SET_ADC_CAL_GAIN_OFFSET,
XMTPT_SET_SPECTRUM_OFFSET, XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS,
XMTPT_SET_SERIAL_NUMBER, XMTPT_CLEAR_GP_COUNTER,
XMTPT_SWITCH_SUPPLIES, XMTPT_SEND_TEST_PACKET,
XMTPT_REQ_ACK_PACKET, XMTPT_FORCE_SCOPE_TRIGGER,
XMTPT_READ_MCA8000D_OPTION_PA_CAL, XMTPT_AU34_2_RESTART
}
enum PID1_TYPE {
PID1_REQ_STATUS = 0x01, PID1_REQ_SPECTRUM = 0x02,
PID1_REQ_SCOPE_MISC = 0x03, PID1_REQ_SCA = 0x04,
PID1_REQ_CONFIG = 0x20, PID1_REQ_FPGA_UC = 0x30,
PID1_RCV_STATUS = 0x80, PID1_RCV_SPECTRUM = 0x81,
PID1_RCV_SCOPE_MISC = 0x82, PID1_RCV_SCA = 0x83,
PID1_VENDOR_REQ = 0xF0, PID1_COMM_TEST = 0xF1,
PID1_ACK = 0xFF
}
enum | PID2_REQ_STATUS_TYPE { PID2_SEND_DP4_STYLE_STATUS = 0x01 }
enum PID2_REQ_SPECTRUM_TYPE {
PID2_SEND_SPECTRUM = 0x01, PID2_SEND_CLEAR_SPECTRUM = 0x02,
PID2_SEND_SPECTRUM_STATUS = 0x03, PID2_SEND_CLEAR_SPECTRUM_STATUS = 0x04
}
enum PID2_REQ_SCOPE_MISC_TYPE {
PID2_SEND_SCOPE_DATA = 0x01, PID2_SEND_512_BYTE_MISC_DATA = 0x02,
PID2_SEND_SCOPE_DATA_REARM = 0x03, PID2_SEND_ETHERNET_SETTINGS = 0x04,
PID2_SEND_DIAGNOSTIC_DATA = 0x05, PID2_SEND_HARDWARE_DESCRIPTION = 0x06,
PID2_SEND_NETFINDER_READBACK = 0x07, PID2_SEND_I2C_DATA = 0x08,
PID2_SEND_LIST_MODE_DATA = 0x09, PID2_SEND_OPTION_PA_CALIBRATION = 0x0A
}
enum PID2_REQ_SCA_TYPE {
PID2_SEND_SCA = 0x01, PID2_LATCH_SEND_SCA = 0x02,
PID2_LATCH_CLEAR_SEND_SCA = 0x03
}
enum PID2_REQ_CONFIG_TYPE {
PID2_PX4_STYLE_CONFIG_PACKET = 0x01, PID2_TEXT_CONFIG_PACKET = 0x02,
PID2_CONFIG_READBACK_PACKET = 0x03
}
enum PID2_REQ_FPGA_UC_TYPE {
PID2_ERASE_FPGA_IMAGE = 0x01, PID2_UPLOAD_PACKET_FPGA = 0x02,
PID2_REINITIALIZE_FPGA = 0x03, PID2_ERASE_UC_IMAGE_0 = 0x04,
PID2_ERASE_UC_IMAGE_1 = 0x05, PID2_ERASE_UC_IMAGE_2 = 0x06,
PID2_UPLOAD_PACKET_UC = 0x07, PID2_SWITCH_TO_UC_IMAGE_0 = 0x08,
PID2_SWITCH_TO_UC_IMAGE_1 = 0x09, PID2_SWITCH_TO_UC_IMAGE_2 = 0x0A
}
enum PID2_VENDOR_REQ_TYPE {
PID2_CLEAR_SPECTRUM_BUFFER_A = 0x01, PID2_ENABLE_MCA_MCS = 0x02,
PID2_DISABLE_MCA_MCS = 0x03, PID2_ARM_DIGITAL_OSCILLOSCOPE = 0x04,
PID2_AUTOSET_INPUT_OFFSET = 0x05, PID2_AUTOSET_FAST_THRESHOLD = 0x06,
PID2_READ_IO3_0 = 0x07, PID2_WRITE_IO3_0 = 0x08,
PID2_WRITE_512_BYTE_MISC_DATA = 0x09, PID2_SET_DCAL = 0x0A,
PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ = 0x0B, PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC = 0x0C,
PID2_SET_BOOT_FLAGS = 0x0D, PID2_SET_ADC_CAL_GAIN_OFFSET = 0x0E,
PID2_SET_SERIAL_NUMBER = 0x0F, PID2_CLEAR_GP_COUNTER = 0x10,
PID2_SET_ETHERNET_SETTINGS = 0x11, PID2_ETHERNET_ALLOW_SHAREING = 0x20,
PID2_ETHERNET_NO_SHARING = 0x21, PID2_ETHERNET_LOCK_IP = 0x22,
PID2_GENERIC_FPGA_WRITE = 0x89
}
enum | PID2_RCV_STATUS_TYPE { RCVPT_DP4_STYLE_STATUS = 0x01 }
enum PID2_RCV_SPECTRUM_TYPE {
RCVPT_256_CHANNEL_SPECTRUM = 0x01, RCVPT_256_CHANNEL_SPECTRUM_STATUS = 0x02,
RCVPT_512_CHANNEL_SPECTRUM = 0x03, RCVPT_512_CHANNEL_SPECTRUM_STATUS = 0x04,
RCVPT_1024_CHANNEL_SPECTRUM = 0x05, RCVPT_1024_CHANNEL_SPECTRUM_STATUS = 0x06,
RCVPT_2048_CHANNEL_SPECTRUM = 0x07, RCVPT_2048_CHANNEL_SPECTRUM_STATUS = 0x08,
RCVPT_4096_CHANNEL_SPECTRUM = 0x09, RCVPT_4096_CHANNEL_SPECTRUM_STATUS = 0x0A,
RCVPT_8192_CHANNEL_SPECTRUM = 0x0B, RCVPT_8192_CHANNEL_SPECTRUM_STATUS = 0x0C
}
enum PID2_RCV_SCOPE_MISC_TYPE {
RCVPT_SCOPE_DATA = 0x01, RCVPT_512_BYTE_MISC_DATA = 0x02,
RCVPT_SCOPE_DATA_WITH_OVERFLOW = 0x03, RCVPT_ETHERNET_SETTINGS = 0x04,
RCVPT_DIAGNOSTIC_DATA = 0x05, RCVPT_HARDWARE_DESCRIPTION = 0x06,
RCVPT_CONFIG_READBACK = 0x07, RCVPT_NETFINDER_READBACK = 0x08,
RCVPT_I2C_DATA = 0x09, RCVPT_LIST_MODE_DATA = 0x0A,
RCVPT_LIST_MODE_DATA_FIFO_FULL = 0x0B, RCVPT_OPTION_PA_CALIBRATION = 0x0C
}
enum | PID2_RCV_SCA_TYPE { RCVPT_SCA = 0x01 }
enum PID2_ACK_TYPE {
PID2_ACK_OK = 0x00, PID2_ACK_SYNC_ERROR = 0x01,
PID2_ACK_PID_ERROR = 0x02, PID2_ACK_LEN_ERROR = 0x03,
PID2_ACK_CHECKSUM_ERROR = 0x04, PID2_ACK_BAD_PARAM = 0x05,
PID2_ACK_BAD_HEX_REC = 0x06, PID2_ACK_UNRECOG = 0x07,
PID2_ACK_FPGA_ERROR = 0x08, PID2_ACK_CP2201_NOT_FOUND = 0x09,
PID2_ACK_SCOPE_DATA_NOT_AVAIL = 0x0A, PID2_ACK_PC5_NOT_PRESENT = 0x0B,
PID2_ACK_OK_ETHERNET_SHARE_REQ = 0x0C, PID2_ACK_ETHERNET_BUSY = 0x0D,
PID2_ACK_I2C_ERROR = 0x0E, PID2_ACK_OK_FPGA_UPLOAD_ADDR = 0x0F,
PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED = 0x10, PID2_ACK_CAL_DATA_NOT_PRESENT = 0x11
}

Define Documentation

#define ACK 0

Definition at line 260 of file DP5Protocol.h.

#define ETHERNET 2

Definition at line 268 of file DP5Protocol.h.

#define ETHERNET_TIMEOUT 1000

Definition at line 270 of file DP5Protocol.h.

#define MAX_BUFFER_DATA 8192

Definition at line 293 of file DP5Protocol.h.

#define MAX_SCOPE_DATA 2048

Definition at line 294 of file DP5Protocol.h.

#define Retries 2

Definition at line 274 of file DP5Protocol.h.

#define RS232 0

Definition at line 266 of file DP5Protocol.h.

#define RS232_TIMEOUT 2500

Definition at line 271 of file DP5Protocol.h.

#define SYNC1_ 0xF5

Definition at line 263 of file DP5Protocol.h.

#define SYNC2_ 0xFA

Definition at line 264 of file DP5Protocol.h.

#define USB 1

Definition at line 267 of file DP5Protocol.h.

#define USB_DiagDataDelayMS 2500

Definition at line 295 of file DP5Protocol.h.

#define USB_TIMEOUT 500

Definition at line 272 of file DP5Protocol.h.

Typedef Documentation

typedef struct _Packet_In Packet_In

Enumeration Type Documentation

enum PID1_TYPE
Enumerator:
PID1_REQ_STATUS
PID1_REQ_SPECTRUM
PID1_REQ_SCOPE_MISC
PID1_REQ_SCA
PID1_REQ_CONFIG
PID1_REQ_FPGA_UC
PID1_RCV_STATUS
PID1_RCV_SPECTRUM
PID1_RCV_SCOPE_MISC
PID1_RCV_SCA
PID1_VENDOR_REQ
PID1_COMM_TEST
PID1_ACK

Definition at line 98 of file DP5Protocol.h.

enum PID2_ACK_TYPE
Enumerator:
PID2_ACK_OK
PID2_ACK_SYNC_ERROR
PID2_ACK_PID_ERROR
PID2_ACK_LEN_ERROR
PID2_ACK_CHECKSUM_ERROR
PID2_ACK_BAD_PARAM
PID2_ACK_BAD_HEX_REC
PID2_ACK_UNRECOG
PID2_ACK_FPGA_ERROR
PID2_ACK_CP2201_NOT_FOUND
PID2_ACK_SCOPE_DATA_NOT_AVAIL
PID2_ACK_PC5_NOT_PRESENT
PID2_ACK_OK_ETHERNET_SHARE_REQ
PID2_ACK_ETHERNET_BUSY
PID2_ACK_I2C_ERROR
PID2_ACK_OK_FPGA_UPLOAD_ADDR
PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED
PID2_ACK_CAL_DATA_NOT_PRESENT

Definition at line 237 of file DP5Protocol.h.

enum PID2_RCV_SCA_TYPE
Enumerator:
RCVPT_SCA

Definition at line 233 of file DP5Protocol.h.

enum PID2_RCV_SCOPE_MISC_TYPE
Enumerator:
RCVPT_SCOPE_DATA
RCVPT_512_BYTE_MISC_DATA
RCVPT_SCOPE_DATA_WITH_OVERFLOW
RCVPT_ETHERNET_SETTINGS
RCVPT_DIAGNOSTIC_DATA
RCVPT_HARDWARE_DESCRIPTION
RCVPT_CONFIG_READBACK
RCVPT_NETFINDER_READBACK
RCVPT_I2C_DATA
RCVPT_LIST_MODE_DATA
RCVPT_LIST_MODE_DATA_FIFO_FULL
RCVPT_OPTION_PA_CALIBRATION

Definition at line 218 of file DP5Protocol.h.

enum PID2_RCV_SPECTRUM_TYPE
Enumerator:
RCVPT_256_CHANNEL_SPECTRUM
RCVPT_256_CHANNEL_SPECTRUM_STATUS
RCVPT_512_CHANNEL_SPECTRUM
RCVPT_512_CHANNEL_SPECTRUM_STATUS
RCVPT_1024_CHANNEL_SPECTRUM
RCVPT_1024_CHANNEL_SPECTRUM_STATUS
RCVPT_2048_CHANNEL_SPECTRUM
RCVPT_2048_CHANNEL_SPECTRUM_STATUS
RCVPT_4096_CHANNEL_SPECTRUM
RCVPT_4096_CHANNEL_SPECTRUM_STATUS
RCVPT_8192_CHANNEL_SPECTRUM
RCVPT_8192_CHANNEL_SPECTRUM_STATUS

Definition at line 203 of file DP5Protocol.h.

enum PID2_RCV_STATUS_TYPE
Enumerator:
RCVPT_DP4_STYLE_STATUS

Definition at line 199 of file DP5Protocol.h.

enum PID2_REQ_CONFIG_TYPE
Enumerator:
PID2_PX4_STYLE_CONFIG_PACKET
PID2_TEXT_CONFIG_PACKET
PID2_CONFIG_READBACK_PACKET

Definition at line 149 of file DP5Protocol.h.

enum PID2_REQ_FPGA_UC_TYPE
Enumerator:
PID2_ERASE_FPGA_IMAGE
PID2_UPLOAD_PACKET_FPGA
PID2_REINITIALIZE_FPGA
PID2_ERASE_UC_IMAGE_0
PID2_ERASE_UC_IMAGE_1
PID2_ERASE_UC_IMAGE_2
PID2_UPLOAD_PACKET_UC
PID2_SWITCH_TO_UC_IMAGE_0
PID2_SWITCH_TO_UC_IMAGE_1
PID2_SWITCH_TO_UC_IMAGE_2

Definition at line 155 of file DP5Protocol.h.

enum PID2_REQ_SCA_TYPE
Enumerator:
PID2_SEND_SCA
PID2_LATCH_SEND_SCA
PID2_LATCH_CLEAR_SEND_SCA

Definition at line 143 of file DP5Protocol.h.

enum PID2_REQ_SCOPE_MISC_TYPE
Enumerator:
PID2_SEND_SCOPE_DATA
PID2_SEND_512_BYTE_MISC_DATA
PID2_SEND_SCOPE_DATA_REARM
PID2_SEND_ETHERNET_SETTINGS
PID2_SEND_DIAGNOSTIC_DATA
PID2_SEND_HARDWARE_DESCRIPTION
PID2_SEND_NETFINDER_READBACK
PID2_SEND_I2C_DATA
PID2_SEND_LIST_MODE_DATA
PID2_SEND_OPTION_PA_CALIBRATION

Definition at line 130 of file DP5Protocol.h.

enum PID2_REQ_SPECTRUM_TYPE
Enumerator:
PID2_SEND_SPECTRUM
PID2_SEND_CLEAR_SPECTRUM
PID2_SEND_SPECTRUM_STATUS
PID2_SEND_CLEAR_SPECTRUM_STATUS

Definition at line 118 of file DP5Protocol.h.

enum PID2_REQ_STATUS_TYPE
Enumerator:
PID2_SEND_DP4_STYLE_STATUS

Definition at line 114 of file DP5Protocol.h.

enum PID2_VENDOR_REQ_TYPE
Enumerator:
PID2_CLEAR_SPECTRUM_BUFFER_A
PID2_ENABLE_MCA_MCS
PID2_DISABLE_MCA_MCS
PID2_ARM_DIGITAL_OSCILLOSCOPE
PID2_AUTOSET_INPUT_OFFSET
PID2_AUTOSET_FAST_THRESHOLD
PID2_READ_IO3_0
PID2_WRITE_IO3_0
PID2_WRITE_512_BYTE_MISC_DATA
PID2_SET_DCAL
PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ
PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC
PID2_SET_BOOT_FLAGS
PID2_SET_ADC_CAL_GAIN_OFFSET
PID2_SET_SERIAL_NUMBER
PID2_CLEAR_GP_COUNTER
PID2_SET_ETHERNET_SETTINGS
PID2_ETHERNET_ALLOW_SHAREING
PID2_ETHERNET_NO_SHARING
PID2_ETHERNET_LOCK_IP
PID2_GENERIC_FPGA_WRITE

Definition at line 169 of file DP5Protocol.h.

enum TRANSMIT_PACKET_TYPE

CDP5Protocol CDP5Protocol

Enumerator:
XMTPT_SEND_STATUS
XMTPT_SEND_SPECTRUM
XMTPT_SEND_CLEAR_SPECTRUM
XMTPT_SEND_SPECTRUM_STATUS
XMTPT_SEND_CLEAR_SPECTRUM_STATUS
XMTPT_BUFFER_SPECTRUM
XMTPT_BUFFER_CLEAR_SPECTRUM
XMTPT_SEND_BUFFER
XMTPT_SEND_DP4_STYLE_STATUS
XMTPT_SEND_PX4_CONFIG
XMTPT_SEND_SCOPE_DATA
XMTPT_SEND_512_BYTE_MISC_DATA
XMTPT_SEND_SCOPE_DATA_REARM
XMTPT_SEND_ETHERNET_SETTINGS
XMTPT_SEND_DIAGNOSTIC_DATA
XMTPT_SEND_NETFINDER_PACKET
XMTPT_SEND_HARDWARE_DESCRIPTION
XMTPT_SEND_SCA
XMTPT_LATCH_SEND_SCA
XMTPT_LATCH_CLEAR_SEND_SCA
XMTPT_SEND_ROI_OR_FIXED_BLOCK
XMTPT_PX4_STYLE_CONFIG_PACKET
XMTPT_SEND_CONFIG_PACKET_EX
XMTPT_SEND_CONFIG_PACKET_TO_HW
XMTPT_READ_CONFIG_PACKET
XMTPT_READ_CONFIG_PACKET_EX
XMTPT_FULL_READ_CONFIG_PACKET
XMTPT_SCA_READ_CONFIG_PACKET
XMTPT_ERASE_FPGA_IMAGE
XMTPT_UPLOAD_PACKET_FPGA
XMTPT_REINITIALIZE_FPGA
XMTPT_ERASE_UC_IMAGE_0
XMTPT_ERASE_UC_IMAGE_1
XMTPT_ERASE_UC_IMAGE_2
XMTPT_UPLOAD_PACKET_UC
XMTPT_SWITCH_TO_UC_IMAGE_0
XMTPT_SWITCH_TO_UC_IMAGE_1
XMTPT_SWITCH_TO_UC_IMAGE_2
XMTPT_UC_FPGA_CHECKSUMS
XMTPT_CLEAR_SPECTRUM_BUFFER_A
XMTPT_ENABLE_MCA_MCS
XMTPT_DISABLE_MCA_MCS
XMTPT_ARM_DIGITAL_OSCILLOSCOPE
XMTPT_AUTOSET_INPUT_OFFSET
XMTPT_AUTOSET_FAST_THRESHOLD
XMTPT_READ_IO3_0
XMTPT_WRITE_IO3_0
XMTPT_WRITE_512_BYTE_MISC_DATA
XMTPT_SET_DCAL
XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ
XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC
XMTPT_SET_BOOT_FLAGS
XMTPT_SET_HV_DP4_EMULATION
XMTPT_SET_TEC_DP4_EMULATION
XMTPT_SET_INPUT_OFFSET_DP4_EMULATION
XMTPT_SET_ADC_CAL_GAIN_OFFSET
XMTPT_SET_SPECTRUM_OFFSET
XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS
XMTPT_SET_SERIAL_NUMBER
XMTPT_CLEAR_GP_COUNTER
XMTPT_SWITCH_SUPPLIES
XMTPT_SEND_TEST_PACKET
XMTPT_REQ_ACK_PACKET
XMTPT_FORCE_SCOPE_TRIGGER
XMTPT_READ_MCA8000D_OPTION_PA_CAL
XMTPT_AU34_2_RESTART

Definition at line 5 of file DP5Protocol.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Status.cpp File Reference

DeviceIO/DP5Status.cpp File Reference
#include "DP5Status.h"
#include "stringex.h"
#include "DppConst.h"
Include dependency graph for DP5Status.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Status.h File Reference

Classes | Typedefs | Enumerations
DeviceIO/DP5Status.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include "DP5Protocol.h"
#include "DppUtilities.h"
Include dependency graph for DP5Status.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | DP5_DP4_FORMAT_STATUS
struct | _DiagDataType
class | CDP5Status

Typedefs

typedef enum _PX5_OPTIONS | PX5_OPTIONS
typedef struct
DP5_DP4_FORMAT_STATUS 		DP4_FORMAT_STATUS
typedef struct
DP5_DP4_FORMAT_STATUS * 		PDP4_FORMAT_STATUS
typedef struct _DiagDataType | DiagDataType
typedef struct _DiagDataType * | PDDiagDataType

Enumerations

enum _PX5_OPTIONS {
PX5_OPTION_NONE = 0, PX5_OPTION_HPGe_HVPS = 1,
PX5_OPTION_TEST_TEK = 4, PX5_OPTION_TEST_MOX = 5,
PX5_OPTION_TEST_AMP = 6, PX5_OPTION_TEST_MODE_1 = 8,
PX5_OPTION_TEST_MODE_2 = 9
}

Typedef Documentation

typedef struct _DiagDataType DiagDataType
typedef struct DP5_DP4_FORMAT_STATUS DP4_FORMAT_STATUS
typedef struct _DiagDataType * PDDiagDataType
typedef struct DP5_DP4_FORMAT_STATUS * PDP4_FORMAT_STATUS
typedef enum _PX5_OPTIONS PX5_OPTIONS

CDP5Status CDP5Status

Enumeration Type Documentation

enum _PX5_OPTIONS

CDP5Status CDP5Status

Enumerator:
PX5_OPTION_NONE
PX5_OPTION_HPGe_HVPS
PX5_OPTION_TEST_TEK
PX5_OPTION_TEST_MOX
PX5_OPTION_TEST_AMP
PX5_OPTION_TEST_MODE_1
PX5_OPTION_TEST_MODE_2

Definition at line 9 of file DP5Status.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppConst.h File Reference

Defines | Typedefs | Enumerations
DeviceIO/DppConst.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | DP5_DPP_TYPES_FIRST dppDP5
#define | DP5_DPP_TYPES_LAST dppDP5X

Typedefs

typedef enum DP5_DPP_TYPES | dp5DppTypes

Enumerations

enum DP5_DPP_TYPES {
dppDP5, dppPX5,
dppDP5G, dppMCA8000D,
dppTB5, dppDP5X
}

Define Documentation

#define DP5_DPP_TYPES_FIRST dppDP5

Definition at line 20 of file DppConst.h.

#define DP5_DPP_TYPES_LAST dppDP5X

Definition at line 21 of file DppConst.h.

Typedef Documentation

typedef enum DP5_DPP_TYPES dp5DppTypes

Enumeration Type Documentation

enum DP5_DPP_TYPES
Enumerator:
dppDP5

DP5 uses DPP new (this) protocol is supported in this application ==0.

dppPX5

PX5 uses DPP new (this) protocol is supported in this application ==1.

dppDP5G

DP5G uses DPP new (this) protocol is supported in this application ==2.

dppMCA8000D

MCA8000D uses DPP new (this) protocol is supported in this application ==3.

dppTB5

TB5 uses DPP new (this) protocol is supported in this application ==4.

dppDP5X

DP5X uses DPP new (this) protocol is supported in this application ==5.

Definition at line 4 of file DppConst.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppLibUsb.cpp File Reference

DeviceIO/DppLibUsb.cpp File Reference
#include "DppLibUsb.h"
Include dependency graph for DppLibUsb.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppLibUsb.h File Reference

Classes | Defines
DeviceIO/DppLibUsb.h File Reference
#include <libusb.h>
#include <stdio.h>
#include <sys/types.h>
#include <string.h>
Include dependency graph for DppLibUsb.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppLibUsb

Defines

#define | AMPTEK_DP5_VENDOR_ID 0x10C4
#define | AMPTEK_DP5_PRODUCT_ID 0x842A
#define | INTERFACE_NUMBER 0
#define | TIMEOUT_MS 5000
#define | BULK_IN_ENDPOINT 0x81
#define | BULK_OUT_ENDPOINT 0x02
#define | MAX_BULK_IN_TRANSFER_SIZE 32768
#define | MAX_BULK_OUT_TRANSFER_SIZE 520
#define | STATUS_PACKET_SIZE 64
#define | DP5_USB_TIMEOUT 500
#define | DP5_DIAGDATA_TIMEOUT 2500
#define | PID1_REQ_SCOPE_MISC_TO 0x03
#define | PID2_SEND_DIAGNOSTIC_DATA_TO 0x05

Define Documentation

#define AMPTEK_DP5_PRODUCT_ID 0x842A

Definition at line 21 of file DppLibUsb.h.

#define AMPTEK_DP5_VENDOR_ID 0x10C4

Definition at line 20 of file DppLibUsb.h.

#define BULK_IN_ENDPOINT 0x81

Definition at line 25 of file DppLibUsb.h.

#define BULK_OUT_ENDPOINT 0x02

Definition at line 26 of file DppLibUsb.h.

#define DP5_DIAGDATA_TIMEOUT 2500

Definition at line 31 of file DppLibUsb.h.

#define DP5_USB_TIMEOUT 500

Definition at line 30 of file DppLibUsb.h.

#define INTERFACE_NUMBER 0

Definition at line 23 of file DppLibUsb.h.

#define MAX_BULK_IN_TRANSFER_SIZE 32768

Definition at line 27 of file DppLibUsb.h.

#define MAX_BULK_OUT_TRANSFER_SIZE 520

Definition at line 28 of file DppLibUsb.h.

#define PID1_REQ_SCOPE_MISC_TO 0x03

Definition at line 32 of file DppLibUsb.h.

#define PID2_SEND_DIAGNOSTIC_DATA_TO 0x05

Definition at line 33 of file DppLibUsb.h.

#define STATUS_PACKET_SIZE 64

Definition at line 29 of file DppLibUsb.h.

#define TIMEOUT_MS 5000

Definition at line 24 of file DppLibUsb.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppUtilities.cpp File Reference

DeviceIO/DppUtilities.cpp File Reference
#include "DppUtilities.h"
#include "stringex.h"
Include dependency graph for DppUtilities.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppUtilities.h File Reference

Classes
DeviceIO/DppUtilities.h File Reference
#include <stdlib.h>
#include <math.h>
#include <string>
Include dependency graph for DppUtilities.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CDppUtilities
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppWinUSB.cpp File Reference

DeviceIO/DppWinUSB.cpp File Reference
#include "StdAfx.h"
#include "DppWinUSB.h"
Include dependency graph for DppWinUSB.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppWinUSB.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/DppWinUSB.h File Reference
#include <Windows.h>
#include <Strsafe.h>
#include "stringex.h"
#include <Winusb.h>
#include <Setupapi.h>
#include "guid.h"
#include <Dbt.h>
#include "DP5Protocol.h"
Include dependency graph for DppWinUSB.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | WINUSB_DEVICE_INFO
Holds WinUSB device information. More...
class | CDppWinUSB

Defines

#define | MAX_DEVPATH_LENGTH 256
#define | MAXDP5S 128
#define | MAXREGBUFFER 128
#define | WinUSBService "SYSTEM\\CurrentControlSet\\Services\\WinUSB\\Enum"
#define | WinUsbDP5 "USB\\Vid_10c4&Pid_842a"
#define | WinUsbDP5Size 21
#define | DRV_INFO_OPTION_NONE 0x00
#define | DRV_INFO_OPTION_MFG_NAME 0x01
#define | DRV_INFO_OPTION_PROV_NAME 0x02
#define | DRV_INFO_OPTION_DESC 0x04
#define | DRV_INFO_OPTION_DATE 0x08
#define | DRV_INFO_OPTION_VER 0x10
#define | DRV_INFO_OPTION_MS_TERM 0x20
#define | DRV_INFO_OPTION_UX_TERM 0x40
#define | DRV_INFO_OPTION_LABEL 0x80
#define | DRV_INFO_OPTION_ALL 0xFF
#define | MAXPIPES 10

Typedefs

typedef enum _DPP_USB_STATUS | DPP_USB_STATUS
typedef struct WINUSB_DEVICE_INFO | DEVICE_INFO
Holds WinUSB device information.
typedef struct WINUSB_DEVICE_INFO * | PDEVICE_INFO

Enumerations

enum _DPP_USB_STATUS {
dusbStatNoAction, dusbStatNewConnect,
dusbStatConnectFail
}

Define Documentation

#define DRV_INFO_OPTION_ALL 0xFF

Definition at line 35 of file DppWinUSB.h.

#define DRV_INFO_OPTION_DATE 0x08

Definition at line 30 of file DppWinUSB.h.

#define DRV_INFO_OPTION_DESC 0x04

Definition at line 29 of file DppWinUSB.h.

#define DRV_INFO_OPTION_LABEL 0x80

Definition at line 34 of file DppWinUSB.h.

#define DRV_INFO_OPTION_MFG_NAME 0x01

Definition at line 27 of file DppWinUSB.h.

#define DRV_INFO_OPTION_MS_TERM 0x20

Definition at line 32 of file DppWinUSB.h.

#define DRV_INFO_OPTION_NONE 0x00

Definition at line 26 of file DppWinUSB.h.

#define DRV_INFO_OPTION_PROV_NAME 0x02

Definition at line 28 of file DppWinUSB.h.

#define DRV_INFO_OPTION_UX_TERM 0x40

Definition at line 33 of file DppWinUSB.h.

#define DRV_INFO_OPTION_VER 0x10

Definition at line 31 of file DppWinUSB.h.

#define MAX_DEVPATH_LENGTH 256

CDppWinUSB CDppWinUSB

Definition at line 20 of file DppWinUSB.h.

#define MAXDP5S 128

Definition at line 21 of file DppWinUSB.h.

#define MAXPIPES 10

Definition at line 36 of file DppWinUSB.h.

#define MAXREGBUFFER 128

Definition at line 22 of file DppWinUSB.h.

#define WinUsbDP5 "USB\\Vid_10c4&Pid_842a"

Definition at line 24 of file DppWinUSB.h.

#define WinUsbDP5Size 21

Definition at line 25 of file DppWinUSB.h.

#define WinUSBService "SYSTEM\\CurrentControlSet\\Services\\WinUSB\\Enum"

Definition at line 23 of file DppWinUSB.h.

Typedef Documentation

typedef struct WINUSB_DEVICE_INFO DEVICE_INFO

Holds WinUSB device information.

typedef enum _DPP_USB_STATUS DPP_USB_STATUS
typedef struct WINUSB_DEVICE_INFO * PDEVICE_INFO

Enumeration Type Documentation

enum _DPP_USB_STATUS
Enumerator:
dusbStatNoAction
dusbStatNewConnect
dusbStatConnectFail

Definition at line 38 of file DppWinUSB.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/guid.h File Reference

Functions
DeviceIO/guid.h File Reference
#include <objbase.h>
#include <initguid.h>
Include dependency graph for guid.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Functions

DEFINE_GUID (GUID_DP5_INTERFACE_CLASS, 0x5a8ed6a1, 0x7fc3, 0x4b6a, 0xa5, 0x36, 0x95, 0xdf, 0x35, 0xd0, 0x34, 0x48)
Device Interface ID {5A8ED6A1-7FC3-4b6a-A536-95DF35D03448}.
DEFINE_GUID (GUID_DP5_SETUP_CLASS, 0x6a4e9a2d, 0x9368, 0x4f01, 0x8e, 0x60, 0xb3, 0xf9, 0xcd, 0xba, 0xb5, 0xe8)
Setup Class ID {6A4E9A2D-9368-4f01-8E60-B3F9CDBAB5E8}.

Function Documentation

DEFINE_GUID | ( | GUID_DP5_INTERFACE_CLASS | ,
 |  | 0x5a8ed6a1 | ,
 |  | 0x7fc3 | ,
 |  | 0x4b6a | ,
 |  | 0xa5 | ,
 |  | 0x36 | ,
 |  | 0x95 | ,
 |  | 0xdf | ,
 |  | 0x35 | ,
 |  | 0xd0 | ,
 |  | 0x34 | ,
 |  | 0x48 |
 | ) |  |

Device Interface ID {5A8ED6A1-7FC3-4b6a-A536-95DF35D03448}.

DEFINE_GUID | ( | GUID_DP5_SETUP_CLASS | ,
 |  | 0x6a4e9a2d | ,
 |  | 0x9368 | ,
 |  | 0x4f01 | ,
 |  | 0x8e | ,
 |  | 0x60 | ,
 |  | 0xb3 | ,
 |  | 0xf9 | ,
 |  | 0xcd | ,
 |  | 0xba | ,
 |  | 0xb5 | ,
 |  | 0xe8 |
 | ) |  |

Setup Class ID {6A4E9A2D-9368-4f01-8E60-B3F9CDBAB5E8}.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/MSecTimer.cpp File Reference

DeviceIO/MSecTimer.cpp File Reference
#include ".\msectimer.h"
Include dependency graph for MSecTimer.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/MSecTimer.h File Reference

Classes
DeviceIO/MSecTimer.h File Reference
#include "stdafx.h"
#include <math.h>
#include <Mmsystem.h>
Include dependency graph for MSecTimer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CMSecTimer
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/NetFinder.cpp File Reference

DeviceIO/NetFinder.cpp File Reference
#include "StdAfx.h"
#include "NetFinder.h"
#include <time.h>
#include <math.h>
Include dependency graph for NetFinder.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/NetFinder.h File Reference

Classes | Typedefs | Variables
DeviceIO/NetFinder.h File Reference
#include "stdafx.h"
#include "X11Color.h"
Include dependency graph for NetFinder.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | NETDISPLAY_ENTRY
class | CNetFinder

Typedefs

typedef struct NETDISPLAY_ENTRY | NETDISPLAY_ENTRY

Variables

const int | NO_ENTRIES = -1
const int | MAX_ENTRIES = 10

Typedef Documentation

typedef struct NETDISPLAY_ENTRY NETDISPLAY_ENTRY

Variable Documentation

const int MAX_ENTRIES = 10

Definition at line 43 of file NetFinder.h.

const int NO_ENTRIES = -1

Definition at line 42 of file NetFinder.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/ParsePacket.cpp File Reference

DeviceIO/ParsePacket.cpp File Reference
#include "ParsePacket.h"
Include dependency graph for ParsePacket.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/ParsePacket.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/ParsePacket.h File Reference
#include <string>
#include "DP5Protocol.h"
Include dependency graph for ParsePacket.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _DppStateType
class | CParsePacket

Defines

#define | preqProcessNone 0x0
#define | preqProcessStatus 0x1
#define | preqProcessSpectrum 0x2
#define | preqRequestScopeData 0x4
#define | preqProcessScopeData 0x8
#define | preqProcessTextData 0x10
#define | preqProcessScopeDataOverFlow 0x20
#define | preqProcessInetSettings 0x40
#define | preqProcessDiagData 0x80
#define | preqProcessHwDesc 0x100
#define | preqProcessCfgRead 0x200
#define | preqProcessNetFindRead 0x400
#define | preqProcessPaCal 0x800
#define | preqProcessSCAData 0x2000
#define | preqProcessAck 0x4000
#define | preqProcessError 0x8000

Typedefs

typedef enum _CommType | CommType
typedef struct _DppStateType | DppStateType

Enumerations

enum _CommType {
commNone = 0, commRS232 = 1,
commUSB = 2, commSockets = 3
}

Define Documentation

#define preqProcessAck 0x4000

Definition at line 30 of file ParsePacket.h.

#define preqProcessCfgRead 0x200

Definition at line 25 of file ParsePacket.h.

#define preqProcessDiagData 0x80

Definition at line 23 of file ParsePacket.h.

#define preqProcessError 0x8000

Definition at line 31 of file ParsePacket.h.

#define preqProcessHwDesc 0x100

Definition at line 24 of file ParsePacket.h.

#define preqProcessInetSettings 0x40

Definition at line 22 of file ParsePacket.h.

#define preqProcessNetFindRead 0x400

Definition at line 26 of file ParsePacket.h.

#define preqProcessNone 0x0

Definition at line 15 of file ParsePacket.h.

#define preqProcessPaCal 0x800

Definition at line 27 of file ParsePacket.h.

#define preqProcessSCAData 0x2000

Definition at line 29 of file ParsePacket.h.

#define preqProcessScopeData 0x8

Definition at line 19 of file ParsePacket.h.

#define preqProcessScopeDataOverFlow 0x20

Definition at line 21 of file ParsePacket.h.

#define preqProcessSpectrum 0x2

Definition at line 17 of file ParsePacket.h.

#define preqProcessStatus 0x1

Definition at line 16 of file ParsePacket.h.

#define preqProcessTextData 0x10

Definition at line 20 of file ParsePacket.h.

#define preqRequestScopeData 0x4

Definition at line 18 of file ParsePacket.h.

Typedef Documentation

typedef enum _CommType CommType
typedef struct _DppStateType DppStateType

Enumeration Type Documentation

enum _CommType
Enumerator:
commNone
commRS232
commUSB
commSockets

Definition at line 8 of file ParsePacket.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SelectDP5.cpp File Reference

Defines
DeviceIO/SelectDP5.cpp File Reference
#include "stdafx.h"
#include "DppWinUSB.h"
#include "SelectDP5.h"
#include "SelectDP5Res.h"
#include "SProfile.h"
Include dependency graph for SelectDP5.cpp:

Go to the source code of this file.

Defines

#define HIDD_DP5_CONNECT 0x20191

Define Documentation

#define HIDD_DP5_CONNECT 0x20191

Definition at line 9 of file SelectDP5.cpp.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SelectDP5.h File Reference

Classes | Defines | Variables
DeviceIO/SelectDP5.h File Reference
#include "afxwin.h"
#include "afxadv.h"
#include "Label.h"
#include "NetFinder.h"
#include "DP5Status.h"
#include "SendCommand.h"
#include "WinusbNotify.h"
Include dependency graph for SelectDP5.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CSelectDP5

Defines

#define | isDebug false

Variables

CDP5Protocol DP5Proto
CSendCommand SndCmd
CDppWinUSB DppWinUSB
CWinusbNotify WinusbNotify

Define Documentation

#define isDebug false

Definition at line 16 of file SelectDP5.h.

Variable Documentation

CDP5Protocol DP5Proto

Definition at line 40 of file vcDP5.cpp.

CDppWinUSB DppWinUSB

Definition at line 38 of file vcDP5.cpp.

CSendCommand SndCmd

Definition at line 39 of file vcDP5.cpp.

CWinusbNotify WinusbNotify

Definition at line 37 of file vcDP5.cpp.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SelectDP5Res.h File Reference

Defines
DeviceIO/SelectDP5Res.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_BUTTON_CLIPBOARD_COPY 2048
#define | IDC_BUTTON_CLOSE_DEVICE 2049
#define | IDC_BUTTON_CLOSE_PORT 2050
#define | IDC_BUTTON_COUNT_DEVICES 2051
#define | IDC_BUTTON_FIND_DP5_IP 2052
#define | IDC_BUTTON_FIND_USB_DEVICE 2053
#define | IDC_BUTTON_IP_SELECT1 2054
#define | IDC_BUTTON_IP_SELECT2 2055
#define | IDC_BUTTON_IP_SELECT3 2056
#define | IDC_BUTTON_IP_SELECT4 2057
#define | IDC_BUTTON_OPEN_PORT 2058
#define | IDC_BUTTON_SERIAL_REQ_DATA 2059
#define | IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT 2060
#define | IDC_CONNECTOK 2063
#define | IDC_EDIT_DPPCOMM_STATUS 2064
#define | IDC_EDIT_STATUS2 2070
#define | IDC_RADIO_COMMTYPE1 2071
#define | IDC_RADIO_COMMTYPE2 2072
#define | IDC_RADIO_COMMTYPE3 2073
#define | IDC_SPECTRUM_REFRESH_TIME 2074
#define | IDC_SPIN_SELECT_DEVICE 2075
#define | IDC_STATIC_FOUND1 2076
#define | IDC_STATIC_FOUND2 2077
#define | IDC_STATIC_FOUND3 2078
#define | IDC_STATIC_IP_ADDRESS_LABEL 2079
#define | IDC_STATIC_IP_SERIAL_NUM 2080
#define | IDC_STATIC_NUM_DEVICES 2089
#define | IDC_STATIC_NUM_DEVICES2 2090
#define | IDC_STATIC_PORT_LABEL 2091
#define | IDC_STATIC_SELECT_USB_DEVICE_LABEL 2092

Define Documentation

#define IDC_BUTTON_CLIPBOARD_COPY 2048

Definition at line 5 of file SelectDP5Res.h.

#define IDC_BUTTON_CLOSE_DEVICE 2049

Definition at line 6 of file SelectDP5Res.h.

#define IDC_BUTTON_CLOSE_PORT 2050

Definition at line 7 of file SelectDP5Res.h.

#define IDC_BUTTON_COUNT_DEVICES 2051

Definition at line 8 of file SelectDP5Res.h.

#define IDC_BUTTON_FIND_DP5_IP 2052

Definition at line 9 of file SelectDP5Res.h.

#define IDC_BUTTON_FIND_USB_DEVICE 2053

Definition at line 10 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT1 2054

Definition at line 11 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT2 2055

Definition at line 12 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT3 2056

Definition at line 13 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT4 2057

Definition at line 14 of file SelectDP5Res.h.

#define IDC_BUTTON_OPEN_PORT 2058

Definition at line 15 of file SelectDP5Res.h.

#define IDC_BUTTON_SERIAL_REQ_DATA 2059

Definition at line 16 of file SelectDP5Res.h.

#define IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT 2060

Definition at line 17 of file SelectDP5Res.h.

#define IDC_CONNECTOK 2063

Definition at line 18 of file SelectDP5Res.h.

#define IDC_EDIT_DPPCOMM_STATUS 2064

Definition at line 19 of file SelectDP5Res.h.

#define IDC_EDIT_STATUS2 2070

Definition at line 20 of file SelectDP5Res.h.

#define IDC_RADIO_COMMTYPE1 2071

Definition at line 21 of file SelectDP5Res.h.

#define IDC_RADIO_COMMTYPE2 2072

Definition at line 22 of file SelectDP5Res.h.

#define IDC_RADIO_COMMTYPE3 2073

Definition at line 23 of file SelectDP5Res.h.

#define IDC_SPECTRUM_REFRESH_TIME 2074

Definition at line 24 of file SelectDP5Res.h.

#define IDC_SPIN_SELECT_DEVICE 2075

Definition at line 25 of file SelectDP5Res.h.

#define IDC_STATIC_FOUND1 2076

Definition at line 26 of file SelectDP5Res.h.

#define IDC_STATIC_FOUND2 2077

Definition at line 27 of file SelectDP5Res.h.

#define IDC_STATIC_FOUND3 2078

Definition at line 28 of file SelectDP5Res.h.

#define IDC_STATIC_IP_ADDRESS_LABEL 2079

Definition at line 29 of file SelectDP5Res.h.

#define IDC_STATIC_IP_SERIAL_NUM 2080

Definition at line 30 of file SelectDP5Res.h.

#define IDC_STATIC_NUM_DEVICES 2089

Definition at line 31 of file SelectDP5Res.h.

#define IDC_STATIC_NUM_DEVICES2 2090

Definition at line 32 of file SelectDP5Res.h.

#define IDC_STATIC_PORT_LABEL 2091

Definition at line 33 of file SelectDP5Res.h.

#define IDC_STATIC_SELECT_USB_DEVICE_LABEL 2092

Definition at line 34 of file SelectDP5Res.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SendCommand.cpp File Reference

DeviceIO/SendCommand.cpp File Reference
#include "SendCommand.h"
#include "stringex.h"
Include dependency graph for SendCommand.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SendCommand.h File Reference

Classes | Typedefs
DeviceIO/SendCommand.h File Reference
#include "DppConst.h"
#include "DP5Protocol.h"
#include "AsciiCmdUtilities.h"
Include dependency graph for SendCommand.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _CONFIG_OPTIONS
class | CSendCommand

Typedefs

typedef struct _CONFIG_OPTIONS | CONFIG_OPTIONS

Typedef Documentation

typedef struct _CONFIG_OPTIONS CONFIG_OPTIONS
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WINUSB.H File Reference

Classes | Typedefs | Functions
DeviceIO/WINUSB.H File Reference
#include "winusbio.h"
Include dependency graph for WINUSB.H:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _WINUSB_SETUP_PACKET

Typedefs

typedef PVOID | WINUSB_INTERFACE_HANDLE
typedef PVOID * | PWINUSB_INTERFACE_HANDLE
typedef struct _WINUSB_SETUP_PACKET | WINUSB_SETUP_PACKET
typedef struct
_WINUSB_SETUP_PACKET * 		PWINUSB_SETUP_PACKET

Functions

BOOL __stdcall | WinUsb_Initialize (IN HANDLE DeviceHandle, OUT PWINUSB_INTERFACE_HANDLE InterfaceHandle)
BOOL __stdcall | WinUsb_Free (IN WINUSB_INTERFACE_HANDLE InterfaceHandle)
BOOL __stdcall | WinUsb_GetAssociatedInterface (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR AssociatedInterfaceIndex, OUT PWINUSB_INTERFACE_HANDLE AssociatedInterfaceHandle)
BOOL __stdcall | WinUsb_GetDescriptor (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR DescriptorType, IN UCHAR Index, IN USHORT LanguageID, OUT PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred)
BOOL __stdcall | WinUsb_QueryInterfaceSettings (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR AlternateInterfaceNumber, OUT PUSB_INTERFACE_DESCRIPTOR UsbAltInterfaceDescriptor)
BOOL __stdcall | WinUsb_QueryDeviceInformation (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN ULONG InformationType, IN OUT PULONG BufferLength, OUT PVOID Buffer)
BOOL __stdcall | WinUsb_SetCurrentAlternateSetting (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR SettingNumber)
BOOL __stdcall | WinUsb_GetCurrentAlternateSetting (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, OUT PUCHAR SettingNumber)
BOOL __stdcall | WinUsb_QueryPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR AlternateInterfaceNumber, IN UCHAR PipeIndex, OUT PWINUSB_PIPE_INFORMATION PipeInformation)
BOOL __stdcall | WinUsb_SetPipePolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN ULONG PolicyType, IN ULONG ValueLength, IN PVOID Value)
BOOL __stdcall | WinUsb_GetPipePolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN ULONG PolicyType, IN OUT PULONG ValueLength, OUT PVOID Value)
BOOL __stdcall | WinUsb_ReadPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred, IN LPOVERLAPPED Overlapped)
BOOL __stdcall | WinUsb_WritePipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred, IN LPOVERLAPPED Overlapped)
BOOL __stdcall | WinUsb_ControlTransfer (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN WINUSB_SETUP_PACKET SetupPacket, IN PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred, IN LPOVERLAPPED Overlapped)
BOOL __stdcall | WinUsb_ResetPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID)
BOOL __stdcall | WinUsb_AbortPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID)
BOOL __stdcall | WinUsb_FlushPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID)
BOOL __stdcall | WinUsb_SetPowerPolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN ULONG PolicyType, IN ULONG ValueLength, IN PVOID Value)
BOOL __stdcall | WinUsb_GetPowerPolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN ULONG PolicyType, IN OUT PULONG ValueLength, OUT PVOID Value)
BOOL __stdcall | WinUsb_GetOverlappedResult (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN LPOVERLAPPED lpOverlapped, OUT LPDWORD lpNumberOfBytesTransferred, BOOL bWait)
PUSB_INTERFACE_DESCRIPTOR __stdcall | WinUsb_ParseConfigurationDescriptor (IN PUSB_CONFIGURATION_DESCRIPTOR ConfigurationDescriptor, IN PVOID StartPosition, IN LONG InterfaceNumber, IN LONG AlternateSetting, IN LONG InterfaceClass, IN LONG InterfaceSubClass, IN LONG InterfaceProtocol)
PUSB_COMMON_DESCRIPTOR __stdcall | WinUsb_ParseDescriptors (IN PVOID DescriptorBuffer, IN ULONG TotalLength, IN PVOID StartPosition, IN LONG DescriptorType)

Typedef Documentation

typedef PVOID * PWINUSB_INTERFACE_HANDLE

Definition at line 45 of file WINUSB.H.

typedef struct _WINUSB_SETUP_PACKET * PWINUSB_SETUP_PACKET
typedef PVOID WINUSB_INTERFACE_HANDLE

Definition at line 45 of file WINUSB.H.

typedef struct _WINUSB_SETUP_PACKET WINUSB_SETUP_PACKET

Function Documentation

BOOL __stdcall WinUsb_AbortPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID
 | ) |  |
BOOL __stdcall WinUsb_ControlTransfer | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN WINUSB_SETUP_PACKET | SetupPacket,
 |  | IN PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred,
 |  | IN LPOVERLAPPED | Overlapped
 | ) |  |
BOOL __stdcall WinUsb_FlushPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID
 | ) |  |
BOOL __stdcall WinUsb_Free ( IN WINUSB_INTERFACE_HANDLE InterfaceHandle )

Here is the caller graph for this function:

BOOL __stdcall WinUsb_GetAssociatedInterface | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | AssociatedInterfaceIndex,
 |  | OUT PWINUSB_INTERFACE_HANDLE | AssociatedInterfaceHandle
 | ) |  |
BOOL __stdcall WinUsb_GetCurrentAlternateSetting | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | OUT PUCHAR | SettingNumber
 | ) |  |
BOOL __stdcall WinUsb_GetDescriptor | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | DescriptorType,
 |  | IN UCHAR | Index,
 |  | IN USHORT | LanguageID,
 |  | OUT PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred
 | ) |  |
BOOL __stdcall WinUsb_GetOverlappedResult | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN LPOVERLAPPED | lpOverlapped,
 |  | OUT LPDWORD | lpNumberOfBytesTransferred,
 |  | BOOL | bWait
 | ) |  |
BOOL __stdcall WinUsb_GetPipePolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN ULONG | PolicyType,
 |  | IN OUT PULONG | ValueLength,
 |  | OUT PVOID | Value
 | ) |  |
BOOL __stdcall WinUsb_GetPowerPolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN ULONG | PolicyType,
 |  | IN OUT PULONG | ValueLength,
 |  | OUT PVOID | Value
 | ) |  |
BOOL __stdcall WinUsb_Initialize | ( | IN HANDLE | DeviceHandle,
 |  | OUT PWINUSB_INTERFACE_HANDLE | InterfaceHandle
 | ) |  |

Here is the caller graph for this function:

PUSB_INTERFACE_DESCRIPTOR __stdcall WinUsb_ParseConfigurationDescriptor | ( | IN PUSB_CONFIGURATION_DESCRIPTOR | ConfigurationDescriptor,
 |  | IN PVOID | StartPosition,
 |  | IN LONG | InterfaceNumber,
 |  | IN LONG | AlternateSetting,
 |  | IN LONG | InterfaceClass,
 |  | IN LONG | InterfaceSubClass,
 |  | IN LONG | InterfaceProtocol
 | ) |  |
PUSB_COMMON_DESCRIPTOR __stdcall WinUsb_ParseDescriptors | ( | IN PVOID | DescriptorBuffer,
 |  | IN ULONG | TotalLength,
 |  | IN PVOID | StartPosition,
 |  | IN LONG | DescriptorType
 | ) |  |
BOOL __stdcall WinUsb_QueryDeviceInformation | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN ULONG | InformationType,
 |  | IN OUT PULONG | BufferLength,
 |  | OUT PVOID | Buffer
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_QueryInterfaceSettings | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | AlternateInterfaceNumber,
 |  | OUT PUSB_INTERFACE_DESCRIPTOR | UsbAltInterfaceDescriptor
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_QueryPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | AlternateInterfaceNumber,
 |  | IN UCHAR | PipeIndex,
 |  | OUT PWINUSB_PIPE_INFORMATION | PipeInformation
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_ReadPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred,
 |  | IN LPOVERLAPPED | Overlapped
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_ResetPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID
 | ) |  |
BOOL __stdcall WinUsb_SetCurrentAlternateSetting | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | SettingNumber
 | ) |  |
BOOL __stdcall WinUsb_SetPipePolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN ULONG | PolicyType,
 |  | IN ULONG | ValueLength,
 |  | IN PVOID | Value
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_SetPowerPolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN ULONG | PolicyType,
 |  | IN ULONG | ValueLength,
 |  | IN PVOID | Value
 | ) |  |
BOOL __stdcall WinUsb_WritePipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred,
 |  | IN LPOVERLAPPED | Overlapped
 | ) |  |

Here is the caller graph for this function:

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WINUSBIO.H File Reference

Classes | Defines | Typedefs | Functions
DeviceIO/WINUSBIO.H File Reference
#include "usb.h"
#include <initguid.h>
Include dependency graph for WINUSBIO.H:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _WINUSB_PIPE_INFORMATION

Defines

#define | SHORT_PACKET_TERMINATE 0x01
#define | AUTO_CLEAR_STALL 0x02
#define | PIPE_TRANSFER_TIMEOUT 0x03
#define | IGNORE_SHORT_PACKETS 0x04
#define | ALLOW_PARTIAL_READS 0x05
#define | AUTO_FLUSH 0x06
#define | RAW_IO 0x07
#define | MAXIMUM_TRANSFER_SIZE 0x08
#define | AUTO_SUSPEND 0x81
#define | SUSPEND_DELAY 0x83
#define | DEVICE_SPEED 0x01
#define | LowSpeed 0x01
#define | FullSpeed 0x02
#define | HighSpeed 0x03

Typedefs

typedef struct
_WINUSB_PIPE_INFORMATION 		WINUSB_PIPE_INFORMATION
typedef struct
_WINUSB_PIPE_INFORMATION * 		PWINUSB_PIPE_INFORMATION

Functions

DEFINE_GUID (WinUSB_TestGuid, 0xda812bff, 0x12c3, 0x46a2, 0x8e, 0x2b, 0xdb, 0xd3, 0xb7, 0x83, 0x4c, 0x43)

Define Documentation

#define ALLOW_PARTIAL_READS 0x05

Definition at line 44 of file WINUSBIO.H.

#define AUTO_CLEAR_STALL 0x02

Definition at line 41 of file WINUSBIO.H.

#define AUTO_FLUSH 0x06

Definition at line 45 of file WINUSBIO.H.

#define AUTO_SUSPEND 0x81

Definition at line 55 of file WINUSBIO.H.

#define DEVICE_SPEED 0x01

Definition at line 59 of file WINUSBIO.H.

#define FullSpeed 0x02

Definition at line 63 of file WINUSBIO.H.

#define HighSpeed 0x03

Definition at line 64 of file WINUSBIO.H.

#define IGNORE_SHORT_PACKETS 0x04

Definition at line 43 of file WINUSBIO.H.

#define LowSpeed 0x01

Definition at line 62 of file WINUSBIO.H.

#define MAXIMUM_TRANSFER_SIZE 0x08

Definition at line 47 of file WINUSBIO.H.

#define PIPE_TRANSFER_TIMEOUT 0x03

Definition at line 42 of file WINUSBIO.H.

#define RAW_IO 0x07

Definition at line 46 of file WINUSBIO.H.

#define SHORT_PACKET_TERMINATE 0x01

Definition at line 40 of file WINUSBIO.H.

#define SUSPEND_DELAY 0x83

Definition at line 56 of file WINUSBIO.H.

Typedef Documentation

typedef struct _WINUSB_PIPE_INFORMATION * PWINUSB_PIPE_INFORMATION
typedef struct _WINUSB_PIPE_INFORMATION WINUSB_PIPE_INFORMATION

Function Documentation

DEFINE_GUID | ( | WinUSB_TestGuid | ,
 |  | 0xda812bff | ,
 |  | 0x12c3 | ,
 |  | 0x46a2 | ,
 |  | 0x8e | ,
 |  | 0x2b | ,
 |  | 0xdb | ,
 |  | 0xd3 | ,
 |  | 0xb7 | ,
 |  | 0x83 | ,
 |  | 0x4c | ,
 |  | 0x43 |
 | ) |  |
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WinusbNotify.cpp File Reference

DeviceIO/WinusbNotify.cpp File Reference
#include "StdAfx.h"
#include "WinusbNotify.h"
Include dependency graph for WinusbNotify.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WinusbNotify.h File Reference

Classes
DeviceIO/WinusbNotify.h File Reference
#include "DppWinUSB.h"
Include dependency graph for WinusbNotify.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CWinusbNotify
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DP5Cfg/FileBrowse.cpp File Reference

DP5Cfg/FileBrowse.cpp File Reference
#include "stdafx.h"
#include ".\filebrowse.h"
Include dependency graph for FileBrowse.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DP5Cfg/FileBrowse.h File Reference

Classes
DP5Cfg/FileBrowse.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CFileBrowse
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: hlp/HTMLDefines.h File Reference

Defines
hlp/HTMLDefines.h File Reference

Go to the source code of this file.

Defines

#define | HIDM_ABOUTBOX 0x10010
#define | HID_FILE_TAB 0x18128
#define | HID_GAINPZ_TAB 0x18131
#define | HID_MCA_TAB 0x18144
#define | HID_MISC_TAB 0x18147
#define | HID_POWER_TAB 0x1814E
#define | HID_SHAPING_TAB 0x18160
#define | HID_HELP_ABOUT 0x19C43
#define | HIDP_SOCKETS_INIT_FAILED 0x3105A
#define | HIDR_MAINFRAME 0x2105C
#define | HIDR_MENU 0x2105D
#define | HIDR_TOOLBAR 0x21064
#define | HIDR_TOOLBAR_DP5_DLG 0x21065
#define | HIDD_ABOUTBOX 0x20064
#define | HIDD_BUSY_DLG 0x21036
#define | HIDD_MESSAGE_BOX 0x2103F
#define | HIDD_vcDP5_DIALOG 0x21C00
#define | HID_HT_NOWHERE 0x40000
#define | HID_HT_CAPTION 0x40002
#define | HID_HT_SIZE 0x40004
#define | HID_HT_HSCROLL 0x40006
#define | HID_HT_VSCROLL 0x40007
#define | HID_HT_MINBUTTON 0x40008
#define | HID_HT_MAXBUTTON 0x40009
#define | HID_HT_SIZE 0x4000A
#define | HID_HT_SIZE 0x4000B
#define | HID_HT_SIZE 0x4000C
#define | HID_HT_SIZE 0x4000D
#define | HID_HT_SIZE 0x4000E
#define | HID_HT_SIZE 0x4000F
#define | HID_HT_SIZE 0x40010
#define | HID_HT_SIZE 0x40011
#define | HID_HT_SIZE 0x40012
#define | HID_HT_OBJECT 0x40013
#define | HID_HT_CLOSE 0x40014
#define | HID_HT_HELP 0x40015
#define | HID_SC_SIZE 0x1EF00
#define | HID_SC_MOVE 0x1EF01
#define | HID_SC_MINIMIZE 0x1EF02
#define | HID_SC_MAXIMIZE 0x1EF03
#define | HID_SC_NEXTWINDOW 0x1EF04
#define | HID_SC_PREVWINDOW 0x1EF05
#define | HID_SC_CLOSE 0x1EF06
#define | HID_SC_RESTORE 0x1EF12
#define | HID_SC_TASKLIST 0x1EF13
#define | HID_FILE_MRU_FILE1 0x1E110
#define | HID_FILE_MRU_FILE1 0x1E111
#define | HID_FILE_MRU_FILE1 0x1E112
#define | HID_FILE_MRU_FILE1 0x1E113
#define | HID_FILE_MRU_FILE1 0x1E114
#define | HID_FILE_MRU_FILE1 0x1E115
#define | HID_FILE_MRU_FILE1 0x1E116
#define | HID_FILE_MRU_FILE1 0x1E117
#define | HID_FILE_MRU_FILE1 0x1E118
#define | HID_FILE_MRU_FILE1 0x1E119
#define | HID_FILE_MRU_FILE1 0x1E11A
#define | HID_FILE_MRU_FILE1 0x1E11B
#define | HID_FILE_MRU_FILE1 0x1E11C
#define | HID_FILE_MRU_FILE1 0x1E11D
#define | HID_FILE_MRU_FILE1 0x1E11E
#define | HID_FILE_MRU_FILE1 0x1E11F
#define | HID_WINDOW_ALL 0x1EF1F
#define | HID_OLE_VERB_1 0x1E210
#define | HID_OLE_VERB_1 0x1E211
#define | HID_OLE_VERB_1 0x1E212
#define | HID_OLE_VERB_1 0x1E213
#define | HID_OLE_VERB_1 0x1E214
#define | HID_OLE_VERB_1 0x1E215
#define | HID_OLE_VERB_1 0x1E216
#define | HID_OLE_VERB_1 0x1E217
#define | HID_OLE_VERB_1 0x1E218
#define | HID_OLE_VERB_1 0x1E219
#define | HID_OLE_VERB_1 0x1E21A
#define | HID_OLE_VERB_1 0x1E21B
#define | HID_OLE_VERB_1 0x1E21C
#define | HID_OLE_VERB_1 0x1E21D
#define | HID_OLE_VERB_1 0x1E21E
#define | HID_OLE_VERB_1 0x1E21F
#define | HID_FILE_NEW 0x1E100
#define | HID_FILE_OPEN 0x1E101
#define | HID_FILE_CLOSE 0x1E102
#define | HID_FILE_SAVE 0x1E103
#define | HID_FILE_SAVE_AS 0x1E104
#define | HID_FILE_PAGE_SETUP 0x1E105
#define | HID_FILE_PRINT_SETUP 0x1E106
#define | HID_FILE_PRINT 0x1E107
#define | HID_FILE_PRINT_DIRECT 0x1E108
#define | HID_FILE_PRINT_PREVIEW 0x1E109
#define | HID_FILE_UPDATE 0x1E10A
#define | HID_FILE_SAVE_COPY_AS 0x1E10B
#define | HID_FILE_SEND_MAIL 0x1E10C
#define | HID_EDIT_CLEAR 0x1E120
#define | HID_EDIT_CLEAR_ALL 0x1E121
#define | HID_EDIT_COPY 0x1E122
#define | HID_EDIT_CUT 0x1E123
#define | HID_EDIT_FIND 0x1E124
#define | HID_EDIT_PASTE 0x1E125
#define | HID_EDIT_PASTE_LINK 0x1E126
#define | HID_EDIT_PASTE_SPECIAL 0x1E127
#define | HID_EDIT_REPEAT 0x1E128
#define | HID_EDIT_REPLACE 0x1E129
#define | HID_EDIT_SELECT_ALL 0x1E12A
#define | HID_EDIT_UNDO 0x1E12B
#define | HID_EDIT_REDO 0x1E12C
#define | HID_WINDOW_NEW 0x1E130
#define | HID_WINDOW_ARRANGE 0x1E131
#define | HID_WINDOW_CASCADE 0x1E132
#define | HID_WINDOW_TILE_HORZ 0x1E133
#define | HID_WINDOW_TILE_VERT 0x1E134
#define | HID_WINDOW_SPLIT 0x1E135
#define | HID_APP_ABOUT 0x1E140
#define | HID_APP_EXIT 0x1E141
#define | HID_HELP_INDEX 0x1E142
#define | HID_HELP_FINDER 0x1E143
#define | HID_HELP_USING 0x1E144
#define | HID_CONTEXT_HELP 0x1E145
#define | HID_NEXT_PANE 0x1E150
#define | HID_PREV_PANE 0x1E151
#define | HID_FORMAT_FONT 0x1E160
#define | HID_OLE_INSERT_NEW 0x1E200
#define | HID_OLE_EDIT_LINKS 0x1E201
#define | HID_OLE_EDIT_CONVERT 0x1E202
#define | HID_OLE_EDIT_CHANGE_ICON 0x1E203
#define | HID_OLE_EDIT_PROPERTIES 0x1E204
#define | HID_VIEW_TOOLBAR 0x1E800
#define | HID_VIEW_STATUS_BAR 0x1E801
#define | HID_RECORD_FIRST 0x1E900
#define | HID_RECORD_LAST 0x1E901
#define | HID_RECORD_NEXT 0x1E902
#define | HID_RECORD_PREV 0x1E903
#define | HID_WIZBACK 0x13023
#define | HID_WIZNEXT 0x13024
#define | HID_WIZFINISH 0x13025
#define | AFX_HIDD_FILEOPEN 0x27004
#define | AFX_HIDD_FILESAVE 0x27005
#define | AFX_HIDD_FONT 0x27006
#define | AFX_HIDD_COLOR 0x27007
#define | AFX_HIDD_PRINT 0x27008
#define | AFX_HIDD_PRINTSETUP 0x27009
#define | AFX_HIDD_FIND 0x2700A
#define | AFX_HIDD_REPLACE 0x2700B
#define | AFX_HIDD_NEWTYPEDLG 0x27801
#define | AFX_HIDD_PRINTDLG 0x27802
#define | AFX_HIDD_PREVIEW_TOOLBAR 0x27803
#define | AFX_HIDD_PREVIEW_SHORTTOOLBAR 0x2780B
#define | AFX_HIDD_INSERTOBJECT 0x27804
#define | AFX_HIDD_CHANGEICON 0x27805
#define | AFX_HIDD_CONVERT 0x27806
#define | AFX_HIDD_PASTESPECIAL 0x27807
#define | AFX_HIDD_EDITLINKS 0x27808
#define | AFX_HIDD_FILEBROWSE 0x27809
#define | AFX_HIDD_BUSY 0x2780A
#define | AFX_HIDD_OBJECTPROPERTIES 0x2780C
#define | AFX_HIDD_CHANGESOURCE 0x2780D
#define | AFX_HIDP_NO_ERROR_AVAILABLE 0x3F020
#define | AFX_HIDP_INVALID_FILENAME 0x3F100
#define | AFX_HIDP_FAILED_TO_OPEN_DOC 0x3F101
#define | AFX_HIDP_FAILED_TO_SAVE_DOC 0x3F102
#define | AFX_HIDP_ASK_TO_SAVE 0x3F103
#define | AFX_HIDP_FAILED_TO_CREATE_DOC 0x3F104
#define | AFX_HIDP_FILE_TOO_LARGE 0x3F105
#define | AFX_HIDP_FAILED_TO_START_PRINT 0x3F106
#define | AFX_HIDP_FAILED_TO_LAUNCH_HELP 0x3F107
#define | AFX_HIDP_INTERNAL_FAILURE 0x3F108
#define | AFX_HIDP_COMMAND_FAILURE 0x3F109
#define | AFX_HIDP_FAILED_MEMORY_ALLOC 0x3F10A
#define | AFX_HIDP_UNREG_DONE 0x3F10B
#define | AFX_HIDP_UNREG_FAILURE 0x3F10C
#define | AFX_HIDP_DLL_LOAD_FAILED 0x3F10D
#define | AFX_HIDP_DLL_BAD_VERSION 0x3F10E
#define | AFX_HIDP_PARSE_INT 0x3F110
#define | AFX_HIDP_PARSE_REAL 0x3F111
#define | AFX_HIDP_PARSE_INT_RANGE 0x3F112
#define | AFX_HIDP_PARSE_REAL_RANGE 0x3F113
#define | AFX_HIDP_PARSE_STRING_SIZE 0x3F114
#define | AFX_HIDP_PARSE_RADIO_BUTTON 0x3F115
#define | AFX_HIDP_PARSE_BYTE 0x3F116
#define | AFX_HIDP_PARSE_UINT 0x3F117
#define | AFX_HIDP_PARSE_DATETIME 0x3F118
#define | AFX_HIDP_PARSE_CURRENCY 0x3F119
#define | AFX_HIDP_FAILED_INVALID_FORMAT 0x3F120
#define | AFX_HIDP_FAILED_INVALID_PATH 0x3F121
#define | AFX_HIDP_FAILED_DISK_FULL 0x3F122
#define | AFX_HIDP_FAILED_ACCESS_READ 0x3F123
#define | AFX_HIDP_FAILED_ACCESS_WRITE 0x3F124
#define | AFX_HIDP_FAILED_IO_ERROR_READ 0x3F125
#define | AFX_HIDP_FAILED_IO_ERROR_WRITE 0x3F126
#define | AFX_HIDP_STATIC_OBJECT 0x3F180
#define | AFX_HIDP_FAILED_TO_CONNECT 0x3F181
#define | AFX_HIDP_SERVER_BUSY 0x3F182
#define | AFX_HIDP_BAD_VERB 0x3F183
#define | AFX_HIDP_FAILED_TO_NOTIFY 0x3F185
#define | AFX_HIDP_FAILED_TO_LAUNCH 0x3F186
#define | AFX_HIDP_ASK_TO_UPDATE 0x3F187
#define | AFX_HIDP_FAILED_TO_UPDATE 0x3F188
#define | AFX_HIDP_FAILED_TO_REGISTER 0x3F189
#define | AFX_HIDP_FAILED_TO_AUTO_REGISTER 0x3F18A
#define | AFX_HIDP_FAILED_TO_CONVERT 0x3F18B
#define | AFX_HIDP_GET_NOT_SUPPORTED 0x3F18C
#define | AFX_HIDP_SET_NOT_SUPPORTED 0x3F18D
#define | AFX_HIDP_ASK_TO_DISCARD 0x3F18E
#define | AFX_HIDP_FAILED_TO_CREATE 0x3F18F
#define | AFX_HIDP_FAILED_MAPI_LOAD 0x3F190
#define | AFX_HIDP_INVALID_MAPI_DLL 0x3F191
#define | AFX_HIDP_FAILED_MAPI_SEND 0x3F192
#define | AFX_HIDP_FILE_NONE 0x3F1A0
#define | AFX_HIDP_FILE_GENERIC 0x3F1A1
#define | AFX_HIDP_FILE_NOT_FOUND 0x3F1A2
#define | AFX_HIDP_FILE_BAD_PATH 0x3F1A3
#define | AFX_HIDP_FILE_TOO_MANY_OPEN 0x3F1A4
#define | AFX_HIDP_FILE_ACCESS_DENIED 0x3F1A5
#define | AFX_HIDP_FILE_INVALID_FILE 0x3F1A6
#define | AFX_HIDP_FILE_REMOVE_CURRENT 0x3F1A7
#define | AFX_HIDP_FILE_DIR_FULL 0x3F1A8
#define | AFX_HIDP_FILE_BAD_SEEK 0x3F1A9
#define | AFX_HIDP_FILE_HARD_IO 0x3F1AA
#define | AFX_HIDP_FILE_SHARING 0x3F1AB
#define | AFX_HIDP_FILE_LOCKING 0x3F1AC
#define | AFX_HIDP_FILE_DISKFULL 0x3F1AD
#define | AFX_HIDP_FILE_EOF 0x3F1AE
#define | AFX_HIDP_ARCH_NONE 0x3F1B0
#define | AFX_HIDP_ARCH_GENERIC 0x3F1B1
#define | AFX_HIDP_ARCH_READONLY 0x3F1B2
#define | AFX_HIDP_ARCH_ENDOFFILE 0x3F1B3
#define | AFX_HIDP_ARCH_WRITEONLY 0x3F1B4
#define | AFX_HIDP_ARCH_BADINDEX 0x3F1B5
#define | AFX_HIDP_ARCH_BADCLASS 0x3F1B6
#define | AFX_HIDP_ARCH_BADSCHEMA 0x3F1B7
#define | AFX_HIDP_SQL_CONNECT_FAIL 0x3F281
#define | AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY 0x3F282
#define | AFX_HIDP_SQL_EMPTY_COLUMN_LIST 0x3F283
#define | AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH 0x3F284
#define | AFX_HIDP_SQL_ILLEGAL_MODE 0x3F285
#define | AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED 0x3F286
#define | AFX_HIDP_SQL_NO_CURRENT_RECORD 0x3F287
#define | AFX_HIDP_SQL_NO_ROWS_AFFECTED 0x3F288
#define | AFX_HIDP_SQL_RECORDSET_READONLY 0x3F289
#define | AFX_HIDP_SQL_SQL_NO_TOTAL 0x3F28A
#define | AFX_HIDP_SQL_ODBC_LOAD_FAILED 0x3F28B
#define | AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED 0x3F28C
#define | AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED 0x3F28D
#define | AFX_HIDP_SQL_API_CONFORMANCE 0x3F28E
#define | AFX_HIDP_SQL_SQL_CONFORMANCE 0x3F28F
#define | AFX_HIDP_SQL_NO_DATA_FOUND 0x3F290
#define | AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED 0x3F291
#define | AFX_HIDP_SQL_ODBC_V2_REQUIRED 0x3F292
#define | AFX_HIDP_SQL_NO_POSITIONED_UPDATES 0x3F293
#define | AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED 0x3F294
#define | AFX_HIDP_SQL_DATA_TRUNCATED 0x3F295
#define | AFX_HIDP_SQL_ROW_FETCH 0x3F296
#define | AFX_HIDP_SQL_INCORRECT_ODBC 0x3F297
#define | AFX_HIDP_SQL_UPDATE_DELETE_FAILED 0x3F298
#define | AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED 0x3F299
#define | AFX_HIDP_SQL_FIELD_NOT_FOUND 0x3F29A
#define | AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED 0x3F29B
#define | AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED 0x3F29C
#define | AFX_HIDP_DAO_ENGINE_INITIALIZATION 0x3F2B0
#define | AFX_HIDP_DAO_DFX_BIND 0x3F2B1
#define | AFX_HIDP_DAO_OBJECT_NOT_OPEN 0x3F2B2
#define | AFX_HIDP_DAO_ROWTOOSHORT 0x3F2B3
#define | AFX_HIDP_DAO_BADBINDINFO 0x3F2B4
#define | AFX_HIDP_DAO_COLUMNUNAVAILABLE 0x3F2B5
#define | AFX_HIDW_TOOLBAR 0x5E800
#define | AFX_HIDW_STATUS_BAR 0x5E801
#define | AFX_HIDW_PREVIEW_BAR 0x5E802
#define | AFX_HIDW_RESIZE_BAR 0x5E803
#define | AFX_HIDW_DOCKBAR_TOP 0x5E81B
#define | AFX_HIDW_DOCKBAR_LEFT 0x5E81C
#define | AFX_HIDW_DOCKBAR_RIGHT 0x5E81D
#define | AFX_HIDW_DOCKBAR_BOTTOM 0x5E81E
#define | AFX_HIDW_DOCKBAR_FLOAT 0x5E81F

Define Documentation

#define AFX_HIDD_BUSY 0x2780A

Definition at line 185 of file HTMLDefines.h.

#define AFX_HIDD_CHANGEICON 0x27805

Definition at line 180 of file HTMLDefines.h.

#define AFX_HIDD_CHANGESOURCE 0x2780D

Definition at line 187 of file HTMLDefines.h.

#define AFX_HIDD_COLOR 0x27007

Definition at line 170 of file HTMLDefines.h.

#define AFX_HIDD_CONVERT 0x27806

Definition at line 181 of file HTMLDefines.h.

#define AFX_HIDD_EDITLINKS 0x27808

Definition at line 183 of file HTMLDefines.h.

#define AFX_HIDD_FILEBROWSE 0x27809

Definition at line 184 of file HTMLDefines.h.

#define AFX_HIDD_FILEOPEN 0x27004

Definition at line 167 of file HTMLDefines.h.

#define AFX_HIDD_FILESAVE 0x27005

Definition at line 168 of file HTMLDefines.h.

#define AFX_HIDD_FIND 0x2700A

Definition at line 173 of file HTMLDefines.h.

#define AFX_HIDD_FONT 0x27006

Definition at line 169 of file HTMLDefines.h.

#define AFX_HIDD_INSERTOBJECT 0x27804

Definition at line 179 of file HTMLDefines.h.

#define AFX_HIDD_NEWTYPEDLG 0x27801

Definition at line 175 of file HTMLDefines.h.

#define AFX_HIDD_OBJECTPROPERTIES 0x2780C

Definition at line 186 of file HTMLDefines.h.

#define AFX_HIDD_PASTESPECIAL 0x27807

Definition at line 182 of file HTMLDefines.h.

#define AFX_HIDD_PREVIEW_SHORTTOOLBAR 0x2780B

Definition at line 178 of file HTMLDefines.h.

#define AFX_HIDD_PREVIEW_TOOLBAR 0x27803

Definition at line 177 of file HTMLDefines.h.

#define AFX_HIDD_PRINT 0x27008

Definition at line 171 of file HTMLDefines.h.

#define AFX_HIDD_PRINTDLG 0x27802

Definition at line 176 of file HTMLDefines.h.

#define AFX_HIDD_PRINTSETUP 0x27009

Definition at line 172 of file HTMLDefines.h.

#define AFX_HIDD_REPLACE 0x2700B

Definition at line 174 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_BADCLASS 0x3F1B6

Definition at line 262 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_BADINDEX 0x3F1B5

Definition at line 261 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_BADSCHEMA 0x3F1B7

Definition at line 263 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_ENDOFFILE 0x3F1B3

Definition at line 259 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_GENERIC 0x3F1B1

Definition at line 257 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_NONE 0x3F1B0

Definition at line 256 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_READONLY 0x3F1B2

Definition at line 258 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_WRITEONLY 0x3F1B4

Definition at line 260 of file HTMLDefines.h.

#define AFX_HIDP_ASK_TO_DISCARD 0x3F18E

Definition at line 236 of file HTMLDefines.h.

#define AFX_HIDP_ASK_TO_SAVE 0x3F103

Definition at line 194 of file HTMLDefines.h.

#define AFX_HIDP_ASK_TO_UPDATE 0x3F187

Definition at line 229 of file HTMLDefines.h.

#define AFX_HIDP_BAD_VERB 0x3F183

Definition at line 226 of file HTMLDefines.h.

#define AFX_HIDP_COMMAND_FAILURE 0x3F109

Definition at line 200 of file HTMLDefines.h.

#define AFX_HIDP_DAO_BADBINDINFO 0x3F2B4

Definition at line 296 of file HTMLDefines.h.

#define AFX_HIDP_DAO_COLUMNUNAVAILABLE 0x3F2B5

Definition at line 297 of file HTMLDefines.h.

#define AFX_HIDP_DAO_DFX_BIND 0x3F2B1

Definition at line 293 of file HTMLDefines.h.

#define AFX_HIDP_DAO_ENGINE_INITIALIZATION 0x3F2B0

Definition at line 292 of file HTMLDefines.h.

#define AFX_HIDP_DAO_OBJECT_NOT_OPEN 0x3F2B2

Definition at line 294 of file HTMLDefines.h.

#define AFX_HIDP_DAO_ROWTOOSHORT 0x3F2B3

Definition at line 295 of file HTMLDefines.h.

#define AFX_HIDP_DLL_BAD_VERSION 0x3F10E

Definition at line 205 of file HTMLDefines.h.

#define AFX_HIDP_DLL_LOAD_FAILED 0x3F10D

Definition at line 204 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_ACCESS_READ 0x3F123

Definition at line 219 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_ACCESS_WRITE 0x3F124

Definition at line 220 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_DISK_FULL 0x3F122

Definition at line 218 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_INVALID_FORMAT 0x3F120

Definition at line 216 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_INVALID_PATH 0x3F121

Definition at line 217 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_IO_ERROR_READ 0x3F125

Definition at line 221 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_IO_ERROR_WRITE 0x3F126

Definition at line 222 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_MAPI_LOAD 0x3F190

Definition at line 238 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_MAPI_SEND 0x3F192

Definition at line 240 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_MEMORY_ALLOC 0x3F10A

Definition at line 201 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_AUTO_REGISTER 0x3F18A

Definition at line 232 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CONNECT 0x3F181

Definition at line 224 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CONVERT 0x3F18B

Definition at line 233 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CREATE 0x3F18F

Definition at line 237 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CREATE_DOC 0x3F104

Definition at line 195 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_LAUNCH 0x3F186

Definition at line 228 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_LAUNCH_HELP 0x3F107

Definition at line 198 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_NOTIFY 0x3F185

Definition at line 227 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_OPEN_DOC 0x3F101

Definition at line 192 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_REGISTER 0x3F189

Definition at line 231 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_SAVE_DOC 0x3F102

Definition at line 193 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_START_PRINT 0x3F106

Definition at line 197 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_UPDATE 0x3F188

Definition at line 230 of file HTMLDefines.h.

#define AFX_HIDP_FILE_ACCESS_DENIED 0x3F1A5

Definition at line 246 of file HTMLDefines.h.

#define AFX_HIDP_FILE_BAD_PATH 0x3F1A3

Definition at line 244 of file HTMLDefines.h.

#define AFX_HIDP_FILE_BAD_SEEK 0x3F1A9

Definition at line 250 of file HTMLDefines.h.

#define AFX_HIDP_FILE_DIR_FULL 0x3F1A8

Definition at line 249 of file HTMLDefines.h.

#define AFX_HIDP_FILE_DISKFULL 0x3F1AD

Definition at line 254 of file HTMLDefines.h.

#define AFX_HIDP_FILE_EOF 0x3F1AE

Definition at line 255 of file HTMLDefines.h.

#define AFX_HIDP_FILE_GENERIC 0x3F1A1

Definition at line 242 of file HTMLDefines.h.

#define AFX_HIDP_FILE_HARD_IO 0x3F1AA

Definition at line 251 of file HTMLDefines.h.

#define AFX_HIDP_FILE_INVALID_FILE 0x3F1A6

Definition at line 247 of file HTMLDefines.h.

#define AFX_HIDP_FILE_LOCKING 0x3F1AC

Definition at line 253 of file HTMLDefines.h.

#define AFX_HIDP_FILE_NONE 0x3F1A0

Definition at line 241 of file HTMLDefines.h.

#define AFX_HIDP_FILE_NOT_FOUND 0x3F1A2

Definition at line 243 of file HTMLDefines.h.

#define AFX_HIDP_FILE_REMOVE_CURRENT 0x3F1A7

Definition at line 248 of file HTMLDefines.h.

#define AFX_HIDP_FILE_SHARING 0x3F1AB

Definition at line 252 of file HTMLDefines.h.

#define AFX_HIDP_FILE_TOO_LARGE 0x3F105

Definition at line 196 of file HTMLDefines.h.

#define AFX_HIDP_FILE_TOO_MANY_OPEN 0x3F1A4

Definition at line 245 of file HTMLDefines.h.

#define AFX_HIDP_GET_NOT_SUPPORTED 0x3F18C

Definition at line 234 of file HTMLDefines.h.

#define AFX_HIDP_INTERNAL_FAILURE 0x3F108

Definition at line 199 of file HTMLDefines.h.

#define AFX_HIDP_INVALID_FILENAME 0x3F100

Definition at line 191 of file HTMLDefines.h.

#define AFX_HIDP_INVALID_MAPI_DLL 0x3F191

Definition at line 239 of file HTMLDefines.h.

#define AFX_HIDP_NO_ERROR_AVAILABLE 0x3F020

Definition at line 190 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_BYTE 0x3F116

Definition at line 212 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_CURRENCY 0x3F119

Definition at line 215 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_DATETIME 0x3F118

Definition at line 214 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_INT 0x3F110

Definition at line 206 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_INT_RANGE 0x3F112

Definition at line 208 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_RADIO_BUTTON 0x3F115

Definition at line 211 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_REAL 0x3F111

Definition at line 207 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_REAL_RANGE 0x3F113

Definition at line 209 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_STRING_SIZE 0x3F114

Definition at line 210 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_UINT 0x3F117

Definition at line 213 of file HTMLDefines.h.

#define AFX_HIDP_SERVER_BUSY 0x3F182

Definition at line 225 of file HTMLDefines.h.

#define AFX_HIDP_SET_NOT_SUPPORTED 0x3F18D

Definition at line 235 of file HTMLDefines.h.

#define AFX_HIDP_SQL_API_CONFORMANCE 0x3F28E

Definition at line 277 of file HTMLDefines.h.

#define AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED 0x3F29C

Definition at line 291 of file HTMLDefines.h.

#define AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED 0x3F29B

Definition at line 290 of file HTMLDefines.h.

#define AFX_HIDP_SQL_CONNECT_FAIL 0x3F281

Definition at line 264 of file HTMLDefines.h.

#define AFX_HIDP_SQL_DATA_TRUNCATED 0x3F295

Definition at line 284 of file HTMLDefines.h.

#define AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED 0x3F299

Definition at line 288 of file HTMLDefines.h.

#define AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED 0x3F28C

Definition at line 275 of file HTMLDefines.h.

#define AFX_HIDP_SQL_EMPTY_COLUMN_LIST 0x3F283

Definition at line 266 of file HTMLDefines.h.

#define AFX_HIDP_SQL_FIELD_NOT_FOUND 0x3F29A

Definition at line 289 of file HTMLDefines.h.

#define AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH 0x3F284

Definition at line 267 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ILLEGAL_MODE 0x3F285

Definition at line 268 of file HTMLDefines.h.

#define AFX_HIDP_SQL_INCORRECT_ODBC 0x3F297

Definition at line 286 of file HTMLDefines.h.

#define AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED 0x3F294

Definition at line 283 of file HTMLDefines.h.

#define AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED 0x3F286

Definition at line 269 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_CURRENT_RECORD 0x3F287

Definition at line 270 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_DATA_FOUND 0x3F290

Definition at line 279 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_POSITIONED_UPDATES 0x3F293

Definition at line 282 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_ROWS_AFFECTED 0x3F288

Definition at line 271 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ODBC_LOAD_FAILED 0x3F28B

Definition at line 274 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ODBC_V2_REQUIRED 0x3F292

Definition at line 281 of file HTMLDefines.h.

#define AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY 0x3F282

Definition at line 265 of file HTMLDefines.h.

#define AFX_HIDP_SQL_RECORDSET_READONLY 0x3F289

Definition at line 272 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ROW_FETCH 0x3F296

Definition at line 285 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED 0x3F291

Definition at line 280 of file HTMLDefines.h.

#define AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED 0x3F28D

Definition at line 276 of file HTMLDefines.h.

#define AFX_HIDP_SQL_SQL_CONFORMANCE 0x3F28F

Definition at line 278 of file HTMLDefines.h.

#define AFX_HIDP_SQL_SQL_NO_TOTAL 0x3F28A

Definition at line 273 of file HTMLDefines.h.

#define AFX_HIDP_SQL_UPDATE_DELETE_FAILED 0x3F298

Definition at line 287 of file HTMLDefines.h.

#define AFX_HIDP_STATIC_OBJECT 0x3F180

Definition at line 223 of file HTMLDefines.h.

#define AFX_HIDP_UNREG_DONE 0x3F10B

Definition at line 202 of file HTMLDefines.h.

#define AFX_HIDP_UNREG_FAILURE 0x3F10C

Definition at line 203 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_BOTTOM 0x5E81E

Definition at line 307 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_FLOAT 0x5E81F

Definition at line 308 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_LEFT 0x5E81C

Definition at line 305 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_RIGHT 0x5E81D

Definition at line 306 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_TOP 0x5E81B

Definition at line 304 of file HTMLDefines.h.

#define AFX_HIDW_PREVIEW_BAR 0x5E802

Definition at line 302 of file HTMLDefines.h.

#define AFX_HIDW_RESIZE_BAR 0x5E803

Definition at line 303 of file HTMLDefines.h.

#define AFX_HIDW_STATUS_BAR 0x5E801

Definition at line 301 of file HTMLDefines.h.

#define AFX_HIDW_TOOLBAR 0x5E800

Definition at line 300 of file HTMLDefines.h.

#define HID_APP_ABOUT 0x1E140

Definition at line 142 of file HTMLDefines.h.

#define HID_APP_EXIT 0x1E141

Definition at line 143 of file HTMLDefines.h.

#define HID_CONTEXT_HELP 0x1E145

Definition at line 147 of file HTMLDefines.h.

#define HID_EDIT_CLEAR 0x1E120

Definition at line 123 of file HTMLDefines.h.

#define HID_EDIT_CLEAR_ALL 0x1E121

Definition at line 124 of file HTMLDefines.h.

#define HID_EDIT_COPY 0x1E122

Definition at line 125 of file HTMLDefines.h.

#define HID_EDIT_CUT 0x1E123

Definition at line 126 of file HTMLDefines.h.

#define HID_EDIT_FIND 0x1E124

Definition at line 127 of file HTMLDefines.h.

#define HID_EDIT_PASTE 0x1E125

Definition at line 128 of file HTMLDefines.h.

#define HID_EDIT_PASTE_LINK 0x1E126

Definition at line 129 of file HTMLDefines.h.

#define HID_EDIT_PASTE_SPECIAL 0x1E127

Definition at line 130 of file HTMLDefines.h.

#define HID_EDIT_REDO 0x1E12C

Definition at line 135 of file HTMLDefines.h.

#define HID_EDIT_REPEAT 0x1E128

Definition at line 131 of file HTMLDefines.h.

#define HID_EDIT_REPLACE 0x1E129

Definition at line 132 of file HTMLDefines.h.

#define HID_EDIT_SELECT_ALL 0x1E12A

Definition at line 133 of file HTMLDefines.h.

#define HID_EDIT_UNDO 0x1E12B

Definition at line 134 of file HTMLDefines.h.

#define HID_FILE_CLOSE 0x1E102

Definition at line 112 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E110

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E111

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E112

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E113

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E114

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E115

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E116

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E117

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E118

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E119

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11A

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11B

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11C

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11D

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11E

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11F

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_NEW 0x1E100

Definition at line 110 of file HTMLDefines.h.

#define HID_FILE_OPEN 0x1E101

Definition at line 111 of file HTMLDefines.h.

#define HID_FILE_PAGE_SETUP 0x1E105

Definition at line 115 of file HTMLDefines.h.

#define HID_FILE_PRINT 0x1E107

Definition at line 117 of file HTMLDefines.h.

#define HID_FILE_PRINT_DIRECT 0x1E108

Definition at line 118 of file HTMLDefines.h.

#define HID_FILE_PRINT_PREVIEW 0x1E109

Definition at line 119 of file HTMLDefines.h.

#define HID_FILE_PRINT_SETUP 0x1E106

Definition at line 116 of file HTMLDefines.h.

#define HID_FILE_SAVE 0x1E103

Definition at line 113 of file HTMLDefines.h.

#define HID_FILE_SAVE_AS 0x1E104

Definition at line 114 of file HTMLDefines.h.

#define HID_FILE_SAVE_COPY_AS 0x1E10B

Definition at line 121 of file HTMLDefines.h.

#define HID_FILE_SEND_MAIL 0x1E10C

Definition at line 122 of file HTMLDefines.h.

#define HID_FILE_TAB 0x18128

Definition at line 4 of file HTMLDefines.h.

#define HID_FILE_UPDATE 0x1E10A

Definition at line 120 of file HTMLDefines.h.

#define HID_FORMAT_FONT 0x1E160

Definition at line 150 of file HTMLDefines.h.

#define HID_GAINPZ_TAB 0x18131

Definition at line 5 of file HTMLDefines.h.

#define HID_HELP_ABOUT 0x19C43

Definition at line 10 of file HTMLDefines.h.

#define HID_HELP_FINDER 0x1E143

Definition at line 145 of file HTMLDefines.h.

#define HID_HELP_INDEX 0x1E142

Definition at line 144 of file HTMLDefines.h.

#define HID_HELP_USING 0x1E144

Definition at line 146 of file HTMLDefines.h.

#define HID_HT_CAPTION 0x40002

Definition at line 40 of file HTMLDefines.h.

#define HID_HT_CLOSE 0x40014

Definition at line 56 of file HTMLDefines.h.

#define HID_HT_HELP 0x40015

Definition at line 57 of file HTMLDefines.h.

#define HID_HT_HSCROLL 0x40006

Definition at line 42 of file HTMLDefines.h.

#define HID_HT_MAXBUTTON 0x40009

Definition at line 45 of file HTMLDefines.h.

#define HID_HT_MINBUTTON 0x40008

Definition at line 44 of file HTMLDefines.h.

#define HID_HT_NOWHERE 0x40000

Definition at line 39 of file HTMLDefines.h.

#define HID_HT_OBJECT 0x40013

Definition at line 55 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40004

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000A

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000B

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000C

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000D

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000E

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000F

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40010

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40011

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40012

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_VSCROLL 0x40007

Definition at line 43 of file HTMLDefines.h.

#define HID_MCA_TAB 0x18144

Definition at line 6 of file HTMLDefines.h.

#define HID_MISC_TAB 0x18147

Definition at line 7 of file HTMLDefines.h.

#define HID_NEXT_PANE 0x1E150

Definition at line 148 of file HTMLDefines.h.

#define HID_OLE_EDIT_CHANGE_ICON 0x1E203

Definition at line 154 of file HTMLDefines.h.

#define HID_OLE_EDIT_CONVERT 0x1E202

Definition at line 153 of file HTMLDefines.h.

#define HID_OLE_EDIT_LINKS 0x1E201

Definition at line 152 of file HTMLDefines.h.

#define HID_OLE_EDIT_PROPERTIES 0x1E204

Definition at line 155 of file HTMLDefines.h.

#define HID_OLE_INSERT_NEW 0x1E200

Definition at line 151 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E210

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E211

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E212

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E213

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E214

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E215

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E216

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E217

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E218

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E219

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21A

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21B

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21C

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21D

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21E

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21F

Definition at line 107 of file HTMLDefines.h.

#define HID_POWER_TAB 0x1814E

Definition at line 8 of file HTMLDefines.h.

#define HID_PREV_PANE 0x1E151

Definition at line 149 of file HTMLDefines.h.

#define HID_RECORD_FIRST 0x1E900

Definition at line 158 of file HTMLDefines.h.

#define HID_RECORD_LAST 0x1E901

Definition at line 159 of file HTMLDefines.h.

#define HID_RECORD_NEXT 0x1E902

Definition at line 160 of file HTMLDefines.h.

#define HID_RECORD_PREV 0x1E903

Definition at line 161 of file HTMLDefines.h.

#define HID_SC_CLOSE 0x1EF06

Definition at line 66 of file HTMLDefines.h.

#define HID_SC_MAXIMIZE 0x1EF03

Definition at line 63 of file HTMLDefines.h.

#define HID_SC_MINIMIZE 0x1EF02

Definition at line 62 of file HTMLDefines.h.

#define HID_SC_MOVE 0x1EF01

Definition at line 61 of file HTMLDefines.h.

#define HID_SC_NEXTWINDOW 0x1EF04

Definition at line 64 of file HTMLDefines.h.

#define HID_SC_PREVWINDOW 0x1EF05

Definition at line 65 of file HTMLDefines.h.

#define HID_SC_RESTORE 0x1EF12

Definition at line 67 of file HTMLDefines.h.

#define HID_SC_SIZE 0x1EF00

Definition at line 60 of file HTMLDefines.h.

#define HID_SC_TASKLIST 0x1EF13

Definition at line 68 of file HTMLDefines.h.

#define HID_SHAPING_TAB 0x18160

Definition at line 9 of file HTMLDefines.h.

#define HID_VIEW_STATUS_BAR 0x1E801

Definition at line 157 of file HTMLDefines.h.

#define HID_VIEW_TOOLBAR 0x1E800

Definition at line 156 of file HTMLDefines.h.

#define HID_WINDOW_ALL 0x1EF1F

Definition at line 89 of file HTMLDefines.h.

#define HID_WINDOW_ARRANGE 0x1E131

Definition at line 137 of file HTMLDefines.h.

#define HID_WINDOW_CASCADE 0x1E132

Definition at line 138 of file HTMLDefines.h.

#define HID_WINDOW_NEW 0x1E130

Definition at line 136 of file HTMLDefines.h.

#define HID_WINDOW_SPLIT 0x1E135

Definition at line 141 of file HTMLDefines.h.

#define HID_WINDOW_TILE_HORZ 0x1E133

Definition at line 139 of file HTMLDefines.h.

#define HID_WINDOW_TILE_VERT 0x1E134

Definition at line 140 of file HTMLDefines.h.

#define HID_WIZBACK 0x13023

Definition at line 162 of file HTMLDefines.h.

#define HID_WIZFINISH 0x13025

Definition at line 164 of file HTMLDefines.h.

#define HID_WIZNEXT 0x13024

Definition at line 163 of file HTMLDefines.h.

#define HIDD_ABOUTBOX 0x20064

Definition at line 22 of file HTMLDefines.h.

#define HIDD_BUSY_DLG 0x21036

Definition at line 23 of file HTMLDefines.h.

#define HIDD_MESSAGE_BOX 0x2103F

Definition at line 24 of file HTMLDefines.h.

#define HIDD_vcDP5_DIALOG 0x21C00

Definition at line 25 of file HTMLDefines.h.

#define HIDM_ABOUTBOX 0x10010

Definition at line 3 of file HTMLDefines.h.

#define HIDP_SOCKETS_INIT_FAILED 0x3105A

Definition at line 13 of file HTMLDefines.h.

#define HIDR_MAINFRAME 0x2105C

Definition at line 16 of file HTMLDefines.h.

#define HIDR_MENU 0x2105D

Definition at line 17 of file HTMLDefines.h.

#define HIDR_TOOLBAR 0x21064

Definition at line 18 of file HTMLDefines.h.

#define HIDR_TOOLBAR_DP5_DLG 0x21065

Definition at line 19 of file HTMLDefines.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/AnimWnd.cpp File Reference

waitdlg/AnimWnd.cpp File Reference
#include "stdafx.h"
#include "AnimWnd.h"
Include dependency graph for AnimWnd.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/AnimWnd.h File Reference

Classes | Defines
waitdlg/AnimWnd.h File Reference
#include "memdc.h"
Include dependency graph for AnimWnd.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | cAnimWnd

Defines

#define | TIMER_ID 13

Define Documentation

#define TIMER_ID 13

Definition at line 25 of file AnimWnd.h.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/CmdWaitDlg.cpp File Reference

waitdlg/CmdWaitDlg.cpp File Reference
#include "stdafx.h"
#include "CmdWaitDlg.h"
Include dependency graph for CmdWaitDlg.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/CmdWaitDlg.h File Reference

Classes
waitdlg/CmdWaitDlg.h File Reference
#include "WaitDlgThread.h"
Include dependency graph for CmdWaitDlg.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cWaitDialog
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/memdc.h File Reference

Classes
waitdlg/memdc.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cMemDC
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlg.cpp File Reference

waitdlg/WaitDlg.cpp File Reference
#include "stdafx.h"
#include "WaitDlg.h"
#include "resource.h"
Include dependency graph for WaitDlg.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlg.h File Reference

Classes
waitdlg/WaitDlg.h File Reference
#include <afxmt.h>
#include "WaitDlgThread.h"
#include "AnimWnd.h"
#include "resource.h"
Include dependency graph for WaitDlg.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cWaitDlg
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlgThread.cpp File Reference

waitdlg/WaitDlgThread.cpp File Reference
#include "stdafx.h"
#include "WaitDlgThread.h"
#include "WaitDlg.h"
Include dependency graph for WaitDlgThread.cpp:

Go to the source code of this file.

Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlgThread.h File Reference

Classes
waitdlg/WaitDlgThread.h File Reference
#include <afxmt.h>
Include dependency graph for WaitDlgThread.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cWaitDlgThread
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- _ -

  • _CommType : ParsePacket.h
  • _CRT_SECURE_NO_DEPRECATE : StdAfx.h
  • _DPP_USB_STATUS : DppWinUSB.h
  • _PX5_OPTIONS : DP5Status.h
  • _SETUPAPI_VER : StdAfx.h
  • _WIN32_IE : StdAfx.h
  • _WIN32_WINDOWS : StdAfx.h
  • _WIN32_WINNT : StdAfx.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- a -

  • ACK : DP5Protocol.h
  • AFX_HIDD_BUSY : HTMLDefines.h
  • AFX_HIDD_CHANGEICON : HTMLDefines.h
  • AFX_HIDD_CHANGESOURCE : HTMLDefines.h
  • AFX_HIDD_COLOR : HTMLDefines.h
  • AFX_HIDD_CONVERT : HTMLDefines.h
  • AFX_HIDD_EDITLINKS : HTMLDefines.h
  • AFX_HIDD_FILEBROWSE : HTMLDefines.h
  • AFX_HIDD_FILEOPEN : HTMLDefines.h
  • AFX_HIDD_FILESAVE : HTMLDefines.h
  • AFX_HIDD_FIND : HTMLDefines.h
  • AFX_HIDD_FONT : HTMLDefines.h
  • AFX_HIDD_INSERTOBJECT : HTMLDefines.h
  • AFX_HIDD_NEWTYPEDLG : HTMLDefines.h
  • AFX_HIDD_OBJECTPROPERTIES : HTMLDefines.h
  • AFX_HIDD_PASTESPECIAL : HTMLDefines.h
  • AFX_HIDD_PREVIEW_SHORTTOOLBAR : HTMLDefines.h
  • AFX_HIDD_PREVIEW_TOOLBAR : HTMLDefines.h
  • AFX_HIDD_PRINT : HTMLDefines.h
  • AFX_HIDD_PRINTDLG : HTMLDefines.h
  • AFX_HIDD_PRINTSETUP : HTMLDefines.h
  • AFX_HIDD_REPLACE : HTMLDefines.h
  • AFX_HIDP_ARCH_BADCLASS : HTMLDefines.h
  • AFX_HIDP_ARCH_BADINDEX : HTMLDefines.h
  • AFX_HIDP_ARCH_BADSCHEMA : HTMLDefines.h
  • AFX_HIDP_ARCH_ENDOFFILE : HTMLDefines.h
  • AFX_HIDP_ARCH_GENERIC : HTMLDefines.h
  • AFX_HIDP_ARCH_NONE : HTMLDefines.h
  • AFX_HIDP_ARCH_READONLY : HTMLDefines.h
  • AFX_HIDP_ARCH_WRITEONLY : HTMLDefines.h
  • AFX_HIDP_ASK_TO_DISCARD : HTMLDefines.h
  • AFX_HIDP_ASK_TO_SAVE : HTMLDefines.h
  • AFX_HIDP_ASK_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_BAD_VERB : HTMLDefines.h
  • AFX_HIDP_COMMAND_FAILURE : HTMLDefines.h
  • AFX_HIDP_DAO_BADBINDINFO : HTMLDefines.h
  • AFX_HIDP_DAO_COLUMNUNAVAILABLE : HTMLDefines.h
  • AFX_HIDP_DAO_DFX_BIND : HTMLDefines.h
  • AFX_HIDP_DAO_ENGINE_INITIALIZATION : HTMLDefines.h
  • AFX_HIDP_DAO_OBJECT_NOT_OPEN : HTMLDefines.h
  • AFX_HIDP_DAO_ROWTOOSHORT : HTMLDefines.h
  • AFX_HIDP_DLL_BAD_VERSION : HTMLDefines.h
  • AFX_HIDP_DLL_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_DISK_FULL : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_FORMAT : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_PATH : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_LOAD : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_SEND : HTMLDefines.h
  • AFX_HIDP_FAILED_MEMORY_ALLOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_AUTO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONNECT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONVERT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH_HELP : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_NOTIFY : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_OPEN_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_SAVE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_START_PRINT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_FILE_ACCESS_DENIED : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_PATH : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_SEEK : HTMLDefines.h
  • AFX_HIDP_FILE_DIR_FULL : HTMLDefines.h
  • AFX_HIDP_FILE_DISKFULL : HTMLDefines.h
  • AFX_HIDP_FILE_EOF : HTMLDefines.h
  • AFX_HIDP_FILE_GENERIC : HTMLDefines.h
  • AFX_HIDP_FILE_HARD_IO : HTMLDefines.h
  • AFX_HIDP_FILE_INVALID_FILE : HTMLDefines.h
  • AFX_HIDP_FILE_LOCKING : HTMLDefines.h
  • AFX_HIDP_FILE_NONE : HTMLDefines.h
  • AFX_HIDP_FILE_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_FILE_REMOVE_CURRENT : HTMLDefines.h
  • AFX_HIDP_FILE_SHARING : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_LARGE : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_MANY_OPEN : HTMLDefines.h
  • AFX_HIDP_GET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_INTERNAL_FAILURE : HTMLDefines.h
  • AFX_HIDP_INVALID_FILENAME : HTMLDefines.h
  • AFX_HIDP_INVALID_MAPI_DLL : HTMLDefines.h
  • AFX_HIDP_NO_ERROR_AVAILABLE : HTMLDefines.h
  • AFX_HIDP_PARSE_BYTE : HTMLDefines.h
  • AFX_HIDP_PARSE_CURRENCY : HTMLDefines.h
  • AFX_HIDP_PARSE_DATETIME : HTMLDefines.h
  • AFX_HIDP_PARSE_INT : HTMLDefines.h
  • AFX_HIDP_PARSE_INT_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_RADIO_BUTTON : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_STRING_SIZE : HTMLDefines.h
  • AFX_HIDP_PARSE_UINT : HTMLDefines.h
  • AFX_HIDP_SERVER_BUSY : HTMLDefines.h
  • AFX_HIDP_SET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_API_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_CONNECT_FAIL : HTMLDefines.h
  • AFX_HIDP_SQL_DATA_TRUNCATED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_EMPTY_COLUMN_LIST : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH : HTMLDefines.h
  • AFX_HIDP_SQL_ILLEGAL_MODE : HTMLDefines.h
  • AFX_HIDP_SQL_INCORRECT_ODBC : HTMLDefines.h
  • AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_NO_CURRENT_RECORD : HTMLDefines.h
  • AFX_HIDP_SQL_NO_DATA_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_NO_POSITIONED_UPDATES : HTMLDefines.h
  • AFX_HIDP_SQL_NO_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_V2_REQUIRED : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_READONLY : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_FETCH : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_NO_TOTAL : HTMLDefines.h
  • AFX_HIDP_SQL_UPDATE_DELETE_FAILED : HTMLDefines.h
  • AFX_HIDP_STATIC_OBJECT : HTMLDefines.h
  • AFX_HIDP_UNREG_DONE : HTMLDefines.h
  • AFX_HIDP_UNREG_FAILURE : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_BOTTOM : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_FLOAT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_LEFT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_RIGHT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_TOP : HTMLDefines.h
  • AFX_HIDW_PREVIEW_BAR : HTMLDefines.h
  • AFX_HIDW_RESIZE_BAR : HTMLDefines.h
  • AFX_HIDW_STATUS_BAR : HTMLDefines.h
  • AFX_HIDW_TOOLBAR : HTMLDefines.h
  • ALLOW_PARTIAL_READS : WINUSBIO.H
  • AMPTEK_DP5_PRODUCT_ID : DppLibUsb.h
  • AMPTEK_DP5_VENDOR_ID : DppLibUsb.h
  • AUTO_CLEAR_STALL : WINUSBIO.H
  • AUTO_FLUSH : WINUSBIO.H
  • AUTO_SUSPEND : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- b -

  • Background : Label.h
  • BULK_IN_ENDPOINT : DppLibUsb.h
  • BULK_OUT_ENDPOINT : DppLibUsb.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- c -

  • CC_SYSCOLOR : PlotCanvas.h
  • colorAliceBlue : X11Color.h
  • colorAmptekBlue : X11Color.h
  • colorAntiqueWhite : X11Color.h
  • colorAqua : X11Color.h
  • colorAquamarine : X11Color.h
  • colorAzure : X11Color.h
  • colorBeige : X11Color.h
  • colorBisque : X11Color.h
  • colorBlack : X11Color.h
  • colorBlanchedAlmond : X11Color.h
  • colorBlue : X11Color.h
  • colorBlueViolet : X11Color.h
  • colorBrown : X11Color.h
  • colorBurlyWood : X11Color.h
  • colorCadetBlue : X11Color.h
  • colorChartreuse : X11Color.h
  • colorChocolate : X11Color.h
  • colorCoral : X11Color.h
  • colorCornflowerBlue : X11Color.h
  • colorCornsilk : X11Color.h
  • colorCrimson : X11Color.h
  • colorCyan : X11Color.h
  • colorDarkBlue : X11Color.h
  • colorDarkCyan : X11Color.h
  • colorDarkGoldenrod : X11Color.h
  • colorDarkGray : X11Color.h
  • colorDarkGreen : X11Color.h
  • colorDarkKhaki : X11Color.h
  • colorDarkMagenta : X11Color.h
  • colorDarkOliveGreen : X11Color.h
  • colorDarkOrange : X11Color.h
  • colorDarkOrchid : X11Color.h
  • colorDarkRed : X11Color.h
  • colorDarkSalmon : X11Color.h
  • colorDarkSeaGreen : X11Color.h
  • colorDarkSlateBlue : X11Color.h
  • colorDarkSlateGray : X11Color.h
  • colorDarkTurquoise : X11Color.h
  • colorDarkViolet : X11Color.h
  • colorDeepPink : X11Color.h
  • colorDeepSkyBlue : X11Color.h
  • colorDimGray : X11Color.h
  • colorDodgerBlue : X11Color.h
  • colorFireBrick : X11Color.h
  • colorFloralWhite : X11Color.h
  • colorForestGreen : X11Color.h
  • colorFuchsia : X11Color.h
  • colorGainsboro : X11Color.h
  • colorGhostWhite : X11Color.h
  • colorGold : X11Color.h
  • colorGoldenrod : X11Color.h
  • colorGray : X11Color.h
  • colorGreen : X11Color.h
  • colorGreenYellow : X11Color.h
  • colorHoneydew : X11Color.h
  • colorHotPink : X11Color.h
  • colorIndianRed : X11Color.h
  • colorIndigo : X11Color.h
  • colorIvory : X11Color.h
  • colorKhaki : X11Color.h
  • colorLavender : X11Color.h
  • colorLavenderBlush : X11Color.h
  • colorLawnGreen : X11Color.h
  • colorLemonChiffon : X11Color.h
  • colorLightBlue : X11Color.h
  • colorLightCoral : X11Color.h
  • colorLightCyan : X11Color.h
  • colorLightGoldenrodYellow : X11Color.h
  • colorLightGray : X11Color.h
  • colorLightGreen : X11Color.h
  • colorLightGrey : X11Color.h
  • colorLightPink : X11Color.h
  • colorLightSalmon : X11Color.h
  • colorLightSeaGreen : X11Color.h
  • colorLightSkyBlue : X11Color.h
  • colorLightSlateGray : X11Color.h
  • colorLightSteelBlue : X11Color.h
  • colorLightYellow : X11Color.h
  • colorLime : X11Color.h
  • colorLimeGreen : X11Color.h
  • colorLinen : X11Color.h
  • colorMagenta : X11Color.h
  • colorMaroon : X11Color.h
  • colorMediumAquamarine : X11Color.h
  • colorMediumBlue : X11Color.h
  • colorMediumOrchid : X11Color.h
  • colorMediumPurple : X11Color.h
  • colorMediumSeaGreen : X11Color.h
  • colorMediumSlateBlue : X11Color.h
  • colorMediumSpringGreen : X11Color.h
  • colorMediumTurquoise : X11Color.h
  • colorMediumVioletRed : X11Color.h
  • colorMidnightBlue : X11Color.h
  • colorMintCream : X11Color.h
  • colorMistyRose : X11Color.h
  • colorMoccasin : X11Color.h
  • colorNavajoWhite : X11Color.h
  • colorNavy : X11Color.h
  • colorOldLace : X11Color.h
  • colorOlive : X11Color.h
  • colorOliveDrab : X11Color.h
  • colorOrange : X11Color.h
  • colorOrangeRed : X11Color.h
  • colorOrchid : X11Color.h
  • colorPaleGoldenrod : X11Color.h
  • colorPaleGreen : X11Color.h
  • colorPaleTurquoise : X11Color.h
  • colorPaleVioletRed : X11Color.h
  • colorPapayaWhip : X11Color.h
  • colorPeachPuff : X11Color.h
  • colorPeru : X11Color.h
  • colorPink : X11Color.h
  • colorPlum : X11Color.h
  • colorPowderBlue : X11Color.h
  • colorPurple : X11Color.h
  • colorRed : X11Color.h
  • colorRosyBrown : X11Color.h
  • colorRoyalBlue : X11Color.h
  • colorSaddleBrown : X11Color.h
  • colorSalmon : X11Color.h
  • colorSandyBrown : X11Color.h
  • colorSeaGreen : X11Color.h
  • colorSeaShell : X11Color.h
  • colorSienna : X11Color.h
  • colorSilver : X11Color.h
  • colorSkyBlue : X11Color.h
  • colorSlateBlue : X11Color.h
  • colorSlateGray : X11Color.h
  • colorSnow : X11Color.h
  • colorSpringGreen : X11Color.h
  • colorSteelBlue : X11Color.h
  • colorTan : X11Color.h
  • colorTeal : X11Color.h
  • colorThistle : X11Color.h
  • colorTomato : X11Color.h
  • colorTurquoise : X11Color.h
  • colorViolet : X11Color.h
  • colorWheat : X11Color.h
  • colorWhite : X11Color.h
  • colorWhiteSmoke : X11Color.h
  • colorYellow : X11Color.h
  • colorYellowGreen : X11Color.h
  • commNone : ParsePacket.h
  • commRS232 : ParsePacket.h
  • commSockets : ParsePacket.h
  • CommType : ParsePacket.h
  • commUSB : ParsePacket.h
  • CONFIG_OPTIONS : SendCommand.h
  • COORD_LONG : PlotCanvas.h
  • ctrlColBlack : PlotCanvas.h
  • ctrlColBlue : PlotCanvas.h
  • ctrlColBtnFace : PlotCanvas.h
  • ctrlColDefault : PlotCanvas.h
  • ctrlColGray : PlotCanvas.h
  • ctrlColGreen : PlotCanvas.h
  • ctrlColInfoBk : PlotCanvas.h
  • ctrlColInfoText : PlotCanvas.h
  • ctrlColJavaGray : PlotCanvas.h
  • ctrlColLightBlue : PlotCanvas.h
  • ctrlColLightCyan : PlotCanvas.h
  • ctrlColLightGray : PlotCanvas.h
  • ctrlColRed : PlotCanvas.h
  • ctrlColSkyBlue : PlotCanvas.h
  • ctrlColWhite : PlotCanvas.h
  • ctrlColWinBk : PlotCanvas.h
  • ctrlColWinText : PlotCanvas.h
  • ctrlColYellow : PlotCanvas.h
  • ctrlDarkGreen : PlotCanvas.h
  • ctrlDarkGreenCopper : PlotCanvas.h
  • ctrlDarkOliveGreen : PlotCanvas.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- d -

  • DEFINE_GUID() : guid.h , WINUSBIO.H
  • DEVICE_INFO : DppWinUSB.h
  • DEVICE_SPEED : WINUSBIO.H
  • DiagDataType : DP5Status.h
  • DP4_FORMAT_STATUS : DP5Status.h
  • DP4_PX4_OLD_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_DIAGDATA_TIMEOUT : DppLibUsb.h
  • DP5_DPP_TYPES : DppConst.h
  • DP5_DPP_TYPES_FIRST : DppConst.h
  • DP5_DPP_TYPES_LAST : DppConst.h
  • DP5_MAX_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_USB_TIMEOUT : DppLibUsb.h
  • dp5DppTypes : DppConst.h
  • DP5Proto : SelectDP5.h , vcDP5.cpp , vcDP5Dlg.h
  • DPP_USB_STATUS : DppWinUSB.h
  • dppDP5 : DppConst.h
  • dppDP5G : DppConst.h
  • dppDP5X : DppConst.h
  • dppMCA8000D : DppConst.h
  • dppPX5 : DppConst.h
  • DppStateType : ParsePacket.h
  • dppTB5 : DppConst.h
  • DppWinUSB : SelectDP5.h , vcDP5.cpp , vcDP5Dlg.h
  • DRV_INFO_OPTION_ALL : DppWinUSB.h
  • DRV_INFO_OPTION_DATE : DppWinUSB.h
  • DRV_INFO_OPTION_DESC : DppWinUSB.h
  • DRV_INFO_OPTION_LABEL : DppWinUSB.h
  • DRV_INFO_OPTION_MFG_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_MS_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_NONE : DppWinUSB.h
  • DRV_INFO_OPTION_PROV_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_UX_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_VER : DppWinUSB.h
  • dusbStatConnectFail : DppWinUSB.h
  • dusbStatNewConnect : DppWinUSB.h
  • dusbStatNoAction : DppWinUSB.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- e -

  • ETHERNET : DP5Protocol.h
  • ETHERNET_TIMEOUT : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- f -

  • FIVE_SMOOTH : STypes.h
  • FlashType : Label.h
  • FullSpeed : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- g -

  • GAIN_1024 : STypes.h
  • GAIN_16384 : STypes.h
  • GAIN_2048 : STypes.h
  • GAIN_256 : STypes.h
  • GAIN_4096 : STypes.h
  • GAIN_512 : STypes.h
  • GAIN_8192 : STypes.h
  • GAIN_FROM_INDEX : STypes.h
  • GAIN_TYPE : STypes.h
  • GETLONG : STypes.h
  • GETP1 : SProfile.h
  • GETPD : SProfile.h
  • GETULONG : STypes.h
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- h -

  • HID_APP_ABOUT : HTMLDefines.h
  • HID_APP_EXIT : HTMLDefines.h
  • HID_CONTEXT_HELP : HTMLDefines.h
  • HID_EDIT_CLEAR : HTMLDefines.h
  • HID_EDIT_CLEAR_ALL : HTMLDefines.h
  • HID_EDIT_COPY : HTMLDefines.h
  • HID_EDIT_CUT : HTMLDefines.h
  • HID_EDIT_FIND : HTMLDefines.h
  • HID_EDIT_PASTE : HTMLDefines.h
  • HID_EDIT_PASTE_LINK : HTMLDefines.h
  • HID_EDIT_PASTE_SPECIAL : HTMLDefines.h
  • HID_EDIT_REDO : HTMLDefines.h
  • HID_EDIT_REPEAT : HTMLDefines.h
  • HID_EDIT_REPLACE : HTMLDefines.h
  • HID_EDIT_SELECT_ALL : HTMLDefines.h
  • HID_EDIT_UNDO : HTMLDefines.h
  • HID_FILE_CLOSE : HTMLDefines.h
  • HID_FILE_MRU_FILE1 : HTMLDefines.h
  • HID_FILE_NEW : HTMLDefines.h
  • HID_FILE_OPEN : HTMLDefines.h
  • HID_FILE_PAGE_SETUP : HTMLDefines.h
  • HID_FILE_PRINT : HTMLDefines.h
  • HID_FILE_PRINT_DIRECT : HTMLDefines.h
  • HID_FILE_PRINT_PREVIEW : HTMLDefines.h
  • HID_FILE_PRINT_SETUP : HTMLDefines.h
  • HID_FILE_SAVE : HTMLDefines.h
  • HID_FILE_SAVE_AS : HTMLDefines.h
  • HID_FILE_SAVE_COPY_AS : HTMLDefines.h
  • HID_FILE_SEND_MAIL : HTMLDefines.h
  • HID_FILE_TAB : HTMLDefines.h
  • HID_FILE_UPDATE : HTMLDefines.h
  • HID_FORMAT_FONT : HTMLDefines.h
  • HID_GAINPZ_TAB : HTMLDefines.h
  • HID_HELP_ABOUT : HTMLDefines.h
  • HID_HELP_FINDER : HTMLDefines.h
  • HID_HELP_INDEX : HTMLDefines.h
  • HID_HELP_USING : HTMLDefines.h
  • HID_HT_CAPTION : HTMLDefines.h
  • HID_HT_CLOSE : HTMLDefines.h
  • HID_HT_HELP : HTMLDefines.h
  • HID_HT_HSCROLL : HTMLDefines.h
  • HID_HT_MAXBUTTON : HTMLDefines.h
  • HID_HT_MINBUTTON : HTMLDefines.h
  • HID_HT_NOWHERE : HTMLDefines.h
  • HID_HT_OBJECT : HTMLDefines.h
  • HID_HT_SIZE : HTMLDefines.h
  • HID_HT_VSCROLL : HTMLDefines.h
  • HID_MCA_TAB : HTMLDefines.h
  • HID_MISC_TAB : HTMLDefines.h
  • HID_NEXT_PANE : HTMLDefines.h
  • HID_OLE_EDIT_CHANGE_ICON : HTMLDefines.h
  • HID_OLE_EDIT_CONVERT : HTMLDefines.h
  • HID_OLE_EDIT_LINKS : HTMLDefines.h
  • HID_OLE_EDIT_PROPERTIES : HTMLDefines.h
  • HID_OLE_INSERT_NEW : HTMLDefines.h
  • HID_OLE_VERB_1 : HTMLDefines.h
  • HID_POWER_TAB : HTMLDefines.h
  • HID_PREV_PANE : HTMLDefines.h
  • HID_RECORD_FIRST : HTMLDefines.h
  • HID_RECORD_LAST : HTMLDefines.h
  • HID_RECORD_NEXT : HTMLDefines.h
  • HID_RECORD_PREV : HTMLDefines.h
  • HID_SC_CLOSE : HTMLDefines.h
  • HID_SC_MAXIMIZE : HTMLDefines.h
  • HID_SC_MINIMIZE : HTMLDefines.h
  • HID_SC_MOVE : HTMLDefines.h
  • HID_SC_NEXTWINDOW : HTMLDefines.h
  • HID_SC_PREVWINDOW : HTMLDefines.h
  • HID_SC_RESTORE : HTMLDefines.h
  • HID_SC_SIZE : HTMLDefines.h
  • HID_SC_TASKLIST : HTMLDefines.h
  • HID_SHAPING_TAB : HTMLDefines.h
  • HID_VIEW_STATUS_BAR : HTMLDefines.h
  • HID_VIEW_TOOLBAR : HTMLDefines.h
  • HID_WINDOW_ALL : HTMLDefines.h
  • HID_WINDOW_ARRANGE : HTMLDefines.h
  • HID_WINDOW_CASCADE : HTMLDefines.h
  • HID_WINDOW_NEW : HTMLDefines.h
  • HID_WINDOW_SPLIT : HTMLDefines.h
  • HID_WINDOW_TILE_HORZ : HTMLDefines.h
  • HID_WINDOW_TILE_VERT : HTMLDefines.h
  • HID_WIZBACK : HTMLDefines.h
  • HID_WIZFINISH : HTMLDefines.h
  • HID_WIZNEXT : HTMLDefines.h
  • HIDD_ABOUTBOX : HTMLDefines.h
  • HIDD_BUSY_DLG : HTMLDefines.h
  • HIDD_DP5_CONNECT : vcDP5_Shared_HIDD.h , SelectDP5.cpp
  • HIDD_FILE_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_GAINPZ_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MCA_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MESSAGE_BOX : HTMLDefines.h
  • HIDD_MISC_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_POWER_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_SHAPING_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_vcDP5_DIALOG : HTMLDefines.h
  • HIDM_ABOUTBOX : HTMLDefines.h
  • HIDP_SOCKETS_INIT_FAILED : HTMLDefines.h
  • HIDR_MAINFRAME : HTMLDefines.h
  • HIDR_MENU : HTMLDefines.h
  • HIDR_TOOLBAR : HTMLDefines.h
  • HIDR_TOOLBAR_DP5_DLG : HTMLDefines.h
  • HighSpeed : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- i -

  • ID_FILE_TAB : resource.h
  • ID_GAINPZ_TAB : resource.h
  • ID_HELP_ABOUT : resource.h
  • ID_MCA_TAB : resource.h
  • ID_MISC_TAB : resource.h
  • ID_POWER_TAB : resource.h
  • ID_SHAPING_TAB : resource.h
  • IDB_BITMAP_DP5_DLG : resource.h
  • IDB_SPECTRUM_ANIM : resource.h
  • IDC_BUSY_PIC : resource.h
  • IDC_BUSY_TEXT : resource.h
  • IDC_BUTTON_ADD_ROI : resource.h
  • IDC_BUTTON_ARM_TRIGGER : resource.h
  • IDC_BUTTON_AUTOTUNE : resource.h
  • IDC_BUTTON_CLEAR_DATA_AND_GRAPH : resource.h
  • IDC_BUTTON_CLEAR_MISC_DATA : resource.h
  • IDC_BUTTON_CLEAR_ROI : resource.h
  • IDC_BUTTON_CLIPBOARD_COPY : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_PORT : SelectDP5Res.h
  • IDC_BUTTON_COUNT_DEVICES : SelectDP5Res.h
  • IDC_BUTTON_DIAG : resource.h
  • IDC_BUTTON_EDIT_CONFIG : resource.h
  • IDC_BUTTON_FIND_DEVICE : resource.h
  • IDC_BUTTON_FIND_DP5_IP : SelectDP5Res.h
  • IDC_BUTTON_FIND_USB_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT1 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT2 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT3 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT4 : SelectDP5Res.h
  • IDC_BUTTON_OPEN_PORT : SelectDP5Res.h
  • IDC_BUTTON_READ_MISC_DATA : resource.h
  • IDC_BUTTON_ROI_END : resource.h
  • IDC_BUTTON_ROI_START : resource.h
  • IDC_BUTTON_SAVE_FILE : resource.h
  • IDC_BUTTON_SELECT_COMM : resource.h
  • IDC_BUTTON_SERIAL_REQ_DATA : SelectDP5Res.h
  • IDC_BUTTON_SHOW_CONFIG : resource.h
  • IDC_BUTTON_SINGLE_UPDATE : resource.h
  • IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT : SelectDP5Res.h
  • IDC_BUTTON_START_ACQUISITION : resource.h
  • IDC_BUTTON_STOP_ACQUISITION : resource.h
  • IDC_BUTTON_WRITE_MISC_DATA : resource.h
  • IDC_CHECK_AUTO_REARM : resource.h
  • IDC_CHECK_DELTA : resource.h
  • IDC_CHECK_REPEAT_SPECTRUM : resource.h
  • IDC_CONNECTOK : SelectDP5Res.h
  • IDC_EDIT_DESCRIPTION : resource.h
  • IDC_EDIT_DIAG : resource.h
  • IDC_EDIT_DPPCOMM_STATUS : SelectDP5Res.h
  • IDC_EDIT_MISC_DATA : resource.h
  • IDC_EDIT_PRESET_CMD : resource.h
  • IDC_EDIT_REPEAT_LOOPS : resource.h
  • IDC_EDIT_START_TIME : resource.h
  • IDC_EDIT_STATUS : resource.h
  • IDC_EDIT_STATUS2 : SelectDP5Res.h
  • IDC_EDIT_TAG : resource.h
  • IDC_GROUP_PLOT_SCALE : resource.h
  • IDC_MESSAGE1 : resource.h
  • IDC_MESSAGE2 : resource.h
  • IDC_PICTURE_PLOT : resource.h
  • IDC_PICTURE_SCOPE : resource.h
  • IDC_PLOTTYPEGROUP : resource.h
  • IDC_RADIO_COMMTYPE1 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE2 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE3 : SelectDP5Res.h
  • IDC_RADIO_PLOT_SCALE_LINEAR : resource.h
  • IDC_RADIO_PLOT_SCALE_LOG : resource.h
  • IDC_RADIO_PLOT_TYPE_LINE : resource.h
  • IDC_RADIO_PLOT_TYPE_SOLID : resource.h
  • IDC_SPECTRUM_REFRESH_TIME : SelectDP5Res.h
  • IDC_SPIN_SELECT_DEVICE : SelectDP5Res.h
  • IDC_STATIC_ : resource.h
  • IDC_STATIC_FOUND1 : SelectDP5Res.h
  • IDC_STATIC_FOUND2 : SelectDP5Res.h
  • IDC_STATIC_FOUND3 : SelectDP5Res.h
  • IDC_STATIC_IP_ADDRESS_LABEL : SelectDP5Res.h
  • IDC_STATIC_IP_SERIAL_NUM : SelectDP5Res.h
  • IDC_STATIC_LOOPS : resource.h
  • IDC_STATIC_MISC_STATUS : resource.h
  • IDC_STATIC_NUM_DEVICES : SelectDP5Res.h
  • IDC_STATIC_NUM_DEVICES2 : SelectDP5Res.h
  • IDC_STATIC_PORT_LABEL : SelectDP5Res.h
  • IDC_STATIC_PRESET_CMD : resource.h
  • IDC_STATIC_REPEAT_STATUS : resource.h
  • IDC_STATIC_ROI_COUNT : resource.h
  • IDC_STATIC_ROI_END : resource.h
  • IDC_STATIC_ROI_INDEX : resource.h
  • IDC_STATIC_ROI_START : resource.h
  • IDC_STATIC_SELECT_COMMUNICATIONS : resource.h
  • IDC_STATIC_SELECT_USB_DEVICE_LABEL : SelectDP5Res.h
  • IDC_STATIC_SPECTRUM_STATUS : resource.h
  • IDC_STATIC_START_TIME : resource.h
  • IDC_STATIC_STATUS : resource.h
  • IDD_ABOUTBOX : resource.h
  • IDD_BUSY_DLG : resource.h
  • IDD_DP5_CONNECT : vcDP5_Shared_IDD.h
  • IDD_FILE_PAGE : vcDP5_Shared_IDD.h
  • IDD_GAINPZ_PAGE : vcDP5_Shared_IDD.h
  • IDD_MCA_PAGE : vcDP5_Shared_IDD.h
  • IDD_MESSAGE_BOX : resource.h
  • IDD_MISC_PAGE : vcDP5_Shared_IDD.h
  • IDD_POWER_PAGE : vcDP5_Shared_IDD.h
  • IDD_SHAPING_PAGE : vcDP5_Shared_IDD.h
  • IDD_vcDP5_DIALOG : resource.h
  • IDM_ABOUTBOX : resource.h
  • IDP_SOCKETS_INIT_FAILED : resource.h
  • IDR_MAINFRAME : resource.h
  • IDR_MENU : resource.h
  • IDR_TOOLBAR : resource.h
  • IDR_TOOLBAR_DP5_DLG : resource.h
  • IDS_ABOUTBOX : resource.h
  • IDS_BTNSTRING_MODAL : resource.h
  • IDS_BTNSTRING_MODELESS : resource.h
  • IDS_CAPTION : resource.h
  • IGNORE_SHORT_PACKETS : WINUSBIO.H
  • INTERFACE_NUMBER : DppLibUsb.h
  • INVALID_SMOOTH : STypes.h
  • isDebug : SelectDP5.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- l -

  • LIN_SCALE : STypes.h
  • LINE_PLOT_TYPE : vcDP5Dlg.h
  • LINEAR_PLOT_SCALE : vcDP5Dlg.h
  • LOG_PLOT_SCALE : vcDP5Dlg.h
  • LOG_SCALE : STypes.h
  • LowSpeed : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- m -

  • MAX_BUFFER_DATA : DP5Protocol.h
  • MAX_BULK_IN_TRANSFER_SIZE : DppLibUsb.h
  • MAX_BULK_OUT_TRANSFER_SIZE : DppLibUsb.h
  • MAX_CHANNELS : STypes.h
  • MAX_COUNTS : STypes.h
  • MAX_DEVPATH_LENGTH : DppWinUSB.h
  • MAX_ENTRIES : NetFinder.h
  • MAX_GAIN_INDEX : STypes.h
  • MAX_KEY_DATA_SIZE : INI.h
  • MAX_SCOPE_DATA : DP5Protocol.h
  • MAX_SECTION_SIZE : INI.h
  • MAX_SPECTRA : STypes.h
  • MAXDP5S : DppWinUSB.h
  • MAXIMUM_TRANSFER_SIZE : WINUSBIO.H
  • MAXPIPES : DppWinUSB.h
  • MAXREGBUFFER : DppWinUSB.h
  • MIN_FRAME_X_PIXELS : STypes.h
  • MIN_FRAME_Y_PIXELS : STypes.h
  • MIN_GAIN : STypes.h
  • MIN_PLOT_CHANNELS : STypes.h
  • MIN_PLOT_COUNTS : STypes.h
  • MIN_PLOT_X_PIXELS : STypes.h
  • MIN_PLOT_Y_PIXELS : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- n -

  • NETDISPLAY_ENTRY : NetFinder.h
  • NO_ENTRIES : NetFinder.h
  • NO_SMOOTH : STypes.h
  • None : Label.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- p -

  • Packet_In : DP5Protocol.h
  • PDDiagDataType : DP5Status.h
  • PDEVICE_INFO : DppWinUSB.h
  • PDP4_FORMAT_STATUS : DP5Status.h
  • PID1_ACK : DP5Protocol.h
  • PID1_COMM_TEST : DP5Protocol.h
  • PID1_RCV_SCA : DP5Protocol.h
  • PID1_RCV_SCOPE_MISC : DP5Protocol.h
  • PID1_RCV_SPECTRUM : DP5Protocol.h
  • PID1_RCV_STATUS : DP5Protocol.h
  • PID1_REQ_CONFIG : DP5Protocol.h
  • PID1_REQ_FPGA_UC : DP5Protocol.h
  • PID1_REQ_SCA : DP5Protocol.h
  • PID1_REQ_SCOPE_MISC : DP5Protocol.h
  • PID1_REQ_SCOPE_MISC_TO : DppLibUsb.h
  • PID1_REQ_SPECTRUM : DP5Protocol.h
  • PID1_REQ_STATUS : DP5Protocol.h
  • PID1_TYPE : DP5Protocol.h
  • PID1_VENDOR_REQ : DP5Protocol.h
  • PID2_ACK_BAD_HEX_REC : DP5Protocol.h
  • PID2_ACK_BAD_PARAM : DP5Protocol.h
  • PID2_ACK_CAL_DATA_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_CHECKSUM_ERROR : DP5Protocol.h
  • PID2_ACK_CP2201_NOT_FOUND : DP5Protocol.h
  • PID2_ACK_ETHERNET_BUSY : DP5Protocol.h
  • PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED : DP5Protocol.h
  • PID2_ACK_FPGA_ERROR : DP5Protocol.h
  • PID2_ACK_I2C_ERROR : DP5Protocol.h
  • PID2_ACK_LEN_ERROR : DP5Protocol.h
  • PID2_ACK_OK : DP5Protocol.h
  • PID2_ACK_OK_ETHERNET_SHARE_REQ : DP5Protocol.h
  • PID2_ACK_OK_FPGA_UPLOAD_ADDR : DP5Protocol.h
  • PID2_ACK_PC5_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_PID_ERROR : DP5Protocol.h
  • PID2_ACK_SCOPE_DATA_NOT_AVAIL : DP5Protocol.h
  • PID2_ACK_SYNC_ERROR : DP5Protocol.h
  • PID2_ACK_TYPE : DP5Protocol.h
  • PID2_ACK_UNRECOG : DP5Protocol.h
  • PID2_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • PID2_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • PID2_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • PID2_CLEAR_GP_COUNTER : DP5Protocol.h
  • PID2_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • PID2_CONFIG_READBACK_PACKET : DP5Protocol.h
  • PID2_DISABLE_MCA_MCS : DP5Protocol.h
  • PID2_ENABLE_MCA_MCS : DP5Protocol.h
  • PID2_ERASE_FPGA_IMAGE : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • PID2_ETHERNET_ALLOW_SHAREING : DP5Protocol.h
  • PID2_ETHERNET_LOCK_IP : DP5Protocol.h
  • PID2_ETHERNET_NO_SHARING : DP5Protocol.h
  • PID2_GENERIC_FPGA_WRITE : DP5Protocol.h
  • PID2_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • PID2_LATCH_SEND_SCA : DP5Protocol.h
  • PID2_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • PID2_RCV_SCA_TYPE : DP5Protocol.h
  • PID2_RCV_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_RCV_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_RCV_STATUS_TYPE : DP5Protocol.h
  • PID2_READ_IO3_0 : DP5Protocol.h
  • PID2_REINITIALIZE_FPGA : DP5Protocol.h
  • PID2_REQ_CONFIG_TYPE : DP5Protocol.h
  • PID2_REQ_FPGA_UC_TYPE : DP5Protocol.h
  • PID2_REQ_SCA_TYPE : DP5Protocol.h
  • PID2_REQ_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_REQ_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_REQ_STATUS_TYPE : DP5Protocol.h
  • PID2_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • PID2_SEND_DIAGNOSTIC_DATA_TO : DppLibUsb.h
  • PID2_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • PID2_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • PID2_SEND_I2C_DATA : DP5Protocol.h
  • PID2_SEND_LIST_MODE_DATA : DP5Protocol.h
  • PID2_SEND_NETFINDER_READBACK : DP5Protocol.h
  • PID2_SEND_OPTION_PA_CALIBRATION : DP5Protocol.h
  • PID2_SEND_SCA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • PID2_SEND_SPECTRUM : DP5Protocol.h
  • PID2_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • PID2_SET_BOOT_FLAGS : DP5Protocol.h
  • PID2_SET_DCAL : DP5Protocol.h
  • PID2_SET_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • PID2_SET_SERIAL_NUMBER : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • PID2_TEXT_CONFIG_PACKET : DP5Protocol.h
  • PID2_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • PID2_UPLOAD_PACKET_UC : DP5Protocol.h
  • PID2_VENDOR_REQ_TYPE : DP5Protocol.h
  • PID2_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_WRITE_IO3_0 : DP5Protocol.h
  • PIPE_TRANSFER_TIMEOUT : WINUSBIO.H
  • preqProcessAck : ParsePacket.h
  • preqProcessCfgRead : ParsePacket.h
  • preqProcessDiagData : ParsePacket.h
  • preqProcessError : ParsePacket.h
  • preqProcessHwDesc : ParsePacket.h
  • preqProcessInetSettings : ParsePacket.h
  • preqProcessNetFindRead : ParsePacket.h
  • preqProcessNone : ParsePacket.h
  • preqProcessPaCal : ParsePacket.h
  • preqProcessSCAData : ParsePacket.h
  • preqProcessScopeData : ParsePacket.h
  • preqProcessScopeDataOverFlow : ParsePacket.h
  • preqProcessSpectrum : ParsePacket.h
  • preqProcessStatus : ParsePacket.h
  • preqProcessTextData : ParsePacket.h
  • preqRequestScopeData : ParsePacket.h
  • Profile : SProfile.h , vcDP5.cpp
  • PUTP1 : SProfile.h
  • PUTPD : SProfile.h
  • PWINUSB_INTERFACE_HANDLE : WINUSB.H
  • PWINUSB_PIPE_INFORMATION : WINUSBIO.H
  • PWINUSB_SETUP_PACKET : WINUSB.H
  • PX5_OPTION_HPGe_HVPS : DP5Status.h
  • PX5_OPTION_NONE : DP5Status.h
  • PX5_OPTION_TEST_AMP : DP5Status.h
  • PX5_OPTION_TEST_MODE_1 : DP5Status.h
  • PX5_OPTION_TEST_MODE_2 : DP5Status.h
  • PX5_OPTION_TEST_MOX : DP5Status.h
  • PX5_OPTION_TEST_TEK : DP5Status.h
  • PX5_OPTIONS : DP5Status.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- r -

  • RAW_IO : WINUSBIO.H
  • RCVPT_1024_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_1024_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_512_BYTE_MISC_DATA : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_CONFIG_READBACK : DP5Protocol.h
  • RCVPT_DIAGNOSTIC_DATA : DP5Protocol.h
  • RCVPT_DP4_STYLE_STATUS : DP5Protocol.h
  • RCVPT_ETHERNET_SETTINGS : DP5Protocol.h
  • RCVPT_HARDWARE_DESCRIPTION : DP5Protocol.h
  • RCVPT_I2C_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA_FIFO_FULL : DP5Protocol.h
  • RCVPT_NETFINDER_READBACK : DP5Protocol.h
  • RCVPT_OPTION_PA_CALIBRATION : DP5Protocol.h
  • RCVPT_SCA : DP5Protocol.h
  • RCVPT_SCOPE_DATA : DP5Protocol.h
  • RCVPT_SCOPE_DATA_WITH_OVERFLOW : DP5Protocol.h
  • regDP5Comm : SProfile.h
  • regDP5Config : SProfile.h
  • regDP5Device : SProfile.h
  • Retries : DP5Protocol.h
  • RS232 : DP5Protocol.h
  • RS232_TIMEOUT : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- s -

  • SCALE_TYPE : STypes.h
  • SCREEN_SCALE : STypes.h
  • SHORT_PACKET_TERMINATE : WINUSBIO.H
  • SMOOTH_TYPE : STypes.h
  • SndCmd : SelectDP5.h , vcDP5.cpp
  • SOLID_PLOT_TYPE : vcDP5Dlg.h
  • SpectrumFileType : vcDP5Dlg.h
  • SQRT_SCALE : STypes.h
  • STATUS_PACKET_SIZE : DppLibUsb.h
  • SUSPEND_DELAY : WINUSBIO.H
  • SYNC1_ : DP5Protocol.h
  • SYNC2_ : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- t -

  • Text : Label.h
  • theApp : vcDP5.cpp , vcDP5.h
  • THREE_SMOOTH : STypes.h
  • TIMEOUT_MS : DppLibUsb.h
  • TIMER_ID : AnimWnd.h
  • TOLONG : STypes.h
  • TOULONG : STypes.h
  • TRANSMIT_PACKET_TYPE : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- u -

  • USB : DP5Protocol.h
  • USB_DiagDataDelayMS : DP5Protocol.h
  • USB_TIMEOUT : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- v -

  • VC_EXTRALEAN : StdAfx.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- w -

  • Whitespace : AsciiCmdUtilities.h
  • WinUsb_AbortPipe() : WINUSB.H
  • WinUsb_ControlTransfer() : WINUSB.H
  • WinUsb_FlushPipe() : WINUSB.H
  • WinUsb_Free() : WINUSB.H
  • WinUsb_GetAssociatedInterface() : WINUSB.H
  • WinUsb_GetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_GetDescriptor() : WINUSB.H
  • WinUsb_GetOverlappedResult() : WINUSB.H
  • WinUsb_GetPipePolicy() : WINUSB.H
  • WinUsb_GetPowerPolicy() : WINUSB.H
  • WinUsb_Initialize() : WINUSB.H
  • WINUSB_INTERFACE_HANDLE : WINUSB.H
  • WinUsb_ParseConfigurationDescriptor() : WINUSB.H
  • WinUsb_ParseDescriptors() : WINUSB.H
  • WINUSB_PIPE_INFORMATION : WINUSBIO.H
  • WinUsb_QueryDeviceInformation() : WINUSB.H
  • WinUsb_QueryInterfaceSettings() : WINUSB.H
  • WinUsb_QueryPipe() : WINUSB.H
  • WinUsb_ReadPipe() : WINUSB.H
  • WinUsb_ResetPipe() : WINUSB.H
  • WinUsb_SetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_SetPipePolicy() : WINUSB.H
  • WinUsb_SetPowerPolicy() : WINUSB.H
  • WINUSB_SETUP_PACKET : WINUSB.H
  • WinUsb_WritePipe() : WINUSB.H
  • WinUsbDP5 : DppWinUSB.h
  • WinUsbDP5Size : DppWinUSB.h
  • WinusbNotify : vcDP5Dlg.h , SelectDP5.h , vcDP5.cpp
  • WinUSBService : DppWinUSB.h
  • WINVER : StdAfx.h
  • WM_USER_COARSE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_DPP_AUTO_FAST_THESHOLD : UserMsgs.h
  • WM_USER_DPP_AUTO_SLOW_THESHOLD : UserMsgs.h
  • WM_USER_FINE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_FPGUI_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_LOAD_FILE : UserMsgs.h
  • WM_USER_PMCA_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG_EX : UserMsgs.h
  • WM_USER_READ_SCA_CONFIG : UserMsgs.h
  • WM_USER_REPEAT_MEASUREMENT : UserMsgs.h
  • WM_USER_SAVE_CONFIG_TO_FILE : UserMsgs.h
  • WM_USER_SEND_CONFIG_TO_HW : UserMsgs.h
  • WM_USER_SHOW_CONNECT_DIALOG : UserMsgs.h
  • WM_USER_SHOW_SPECTRA_LIST_DLG : UserMsgs.h
  • WM_USER_UPDATE_MENU : UserMsgs.h
  • WM_USER_UPDATE_STATUS_BAR : UserMsgs.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- x -

  • XMTPT_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • XMTPT_AU34_2_RESTART : DP5Protocol.h
  • XMTPT_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • XMTPT_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • XMTPT_BUFFER_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_BUFFER_SPECTRUM : DP5Protocol.h
  • XMTPT_CLEAR_GP_COUNTER : DP5Protocol.h
  • XMTPT_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • XMTPT_DISABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ENABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ERASE_FPGA_IMAGE : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_FORCE_SCOPE_TRIGGER : DP5Protocol.h
  • XMTPT_FULL_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • XMTPT_LATCH_SEND_SCA : DP5Protocol.h
  • XMTPT_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_READ_IO3_0 : DP5Protocol.h
  • XMTPT_READ_MCA8000D_OPTION_PA_CAL : DP5Protocol.h
  • XMTPT_REINITIALIZE_FPGA : DP5Protocol.h
  • XMTPT_REQ_ACK_PACKET : DP5Protocol.h
  • XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS : DP5Protocol.h
  • XMTPT_SCA_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_SEND_BUFFER : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_TO_HW : DP5Protocol.h
  • XMTPT_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • XMTPT_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • XMTPT_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • XMTPT_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • XMTPT_SEND_NETFINDER_PACKET : DP5Protocol.h
  • XMTPT_SEND_PX4_CONFIG : DP5Protocol.h
  • XMTPT_SEND_ROI_OR_FIXED_BLOCK : DP5Protocol.h
  • XMTPT_SEND_SCA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_STATUS : DP5Protocol.h
  • XMTPT_SEND_TEST_PACKET : DP5Protocol.h
  • XMTPT_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • XMTPT_SET_BOOT_FLAGS : DP5Protocol.h
  • XMTPT_SET_DCAL : DP5Protocol.h
  • XMTPT_SET_HV_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_INPUT_OFFSET_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • XMTPT_SET_SERIAL_NUMBER : DP5Protocol.h
  • XMTPT_SET_SPECTRUM_OFFSET : DP5Protocol.h
  • XMTPT_SET_TEC_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SWITCH_SUPPLIES : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_UC_FPGA_CHECKSUMS : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_UC : DP5Protocol.h
  • XMTPT_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_WRITE_IO3_0 : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • DEFINE_GUID() : guid.h , WINUSBIO.H , guid.h
  • WinUsb_AbortPipe() : WINUSB.H
  • WinUsb_ControlTransfer() : WINUSB.H
  • WinUsb_FlushPipe() : WINUSB.H
  • WinUsb_Free() : WINUSB.H
  • WinUsb_GetAssociatedInterface() : WINUSB.H
  • WinUsb_GetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_GetDescriptor() : WINUSB.H
  • WinUsb_GetOverlappedResult() : WINUSB.H
  • WinUsb_GetPipePolicy() : WINUSB.H
  • WinUsb_GetPowerPolicy() : WINUSB.H
  • WinUsb_Initialize() : WINUSB.H
  • WinUsb_ParseConfigurationDescriptor() : WINUSB.H
  • WinUsb_ParseDescriptors() : WINUSB.H
  • WinUsb_QueryDeviceInformation() : WINUSB.H
  • WinUsb_QueryInterfaceSettings() : WINUSB.H
  • WinUsb_QueryPipe() : WINUSB.H
  • WinUsb_ReadPipe() : WINUSB.H
  • WinUsb_ResetPipe() : WINUSB.H
  • WinUsb_SetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_SetPipePolicy() : WINUSB.H
  • WinUsb_SetPowerPolicy() : WINUSB.H
  • WinUsb_WritePipe() : WINUSB.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • c
  • d
  • m
  • n
  • p
  • r
  • s
  • t
  • w

- c -

  • colorAliceBlue : X11Color.h
  • colorAmptekBlue : X11Color.h
  • colorAntiqueWhite : X11Color.h
  • colorAqua : X11Color.h
  • colorAquamarine : X11Color.h
  • colorAzure : X11Color.h
  • colorBeige : X11Color.h
  • colorBisque : X11Color.h
  • colorBlack : X11Color.h
  • colorBlanchedAlmond : X11Color.h
  • colorBlue : X11Color.h
  • colorBlueViolet : X11Color.h
  • colorBrown : X11Color.h
  • colorBurlyWood : X11Color.h
  • colorCadetBlue : X11Color.h
  • colorChartreuse : X11Color.h
  • colorChocolate : X11Color.h
  • colorCoral : X11Color.h
  • colorCornflowerBlue : X11Color.h
  • colorCornsilk : X11Color.h
  • colorCrimson : X11Color.h
  • colorCyan : X11Color.h
  • colorDarkBlue : X11Color.h
  • colorDarkCyan : X11Color.h
  • colorDarkGoldenrod : X11Color.h
  • colorDarkGray : X11Color.h
  • colorDarkGreen : X11Color.h
  • colorDarkKhaki : X11Color.h
  • colorDarkMagenta : X11Color.h
  • colorDarkOliveGreen : X11Color.h
  • colorDarkOrange : X11Color.h
  • colorDarkOrchid : X11Color.h
  • colorDarkRed : X11Color.h
  • colorDarkSalmon : X11Color.h
  • colorDarkSeaGreen : X11Color.h
  • colorDarkSlateBlue : X11Color.h
  • colorDarkSlateGray : X11Color.h
  • colorDarkTurquoise : X11Color.h
  • colorDarkViolet : X11Color.h
  • colorDeepPink : X11Color.h
  • colorDeepSkyBlue : X11Color.h
  • colorDimGray : X11Color.h
  • colorDodgerBlue : X11Color.h
  • colorFireBrick : X11Color.h
  • colorFloralWhite : X11Color.h
  • colorForestGreen : X11Color.h
  • colorFuchsia : X11Color.h
  • colorGainsboro : X11Color.h
  • colorGhostWhite : X11Color.h
  • colorGold : X11Color.h
  • colorGoldenrod : X11Color.h
  • colorGray : X11Color.h
  • colorGreen : X11Color.h
  • colorGreenYellow : X11Color.h
  • colorHoneydew : X11Color.h
  • colorHotPink : X11Color.h
  • colorIndianRed : X11Color.h
  • colorIndigo : X11Color.h
  • colorIvory : X11Color.h
  • colorKhaki : X11Color.h
  • colorLavender : X11Color.h
  • colorLavenderBlush : X11Color.h
  • colorLawnGreen : X11Color.h
  • colorLemonChiffon : X11Color.h
  • colorLightBlue : X11Color.h
  • colorLightCoral : X11Color.h
  • colorLightCyan : X11Color.h
  • colorLightGoldenrodYellow : X11Color.h
  • colorLightGray : X11Color.h
  • colorLightGreen : X11Color.h
  • colorLightGrey : X11Color.h
  • colorLightPink : X11Color.h
  • colorLightSalmon : X11Color.h
  • colorLightSeaGreen : X11Color.h
  • colorLightSkyBlue : X11Color.h
  • colorLightSlateGray : X11Color.h
  • colorLightSteelBlue : X11Color.h
  • colorLightYellow : X11Color.h
  • colorLime : X11Color.h
  • colorLimeGreen : X11Color.h
  • colorLinen : X11Color.h
  • colorMagenta : X11Color.h
  • colorMaroon : X11Color.h
  • colorMediumAquamarine : X11Color.h
  • colorMediumBlue : X11Color.h
  • colorMediumOrchid : X11Color.h
  • colorMediumPurple : X11Color.h
  • colorMediumSeaGreen : X11Color.h
  • colorMediumSlateBlue : X11Color.h
  • colorMediumSpringGreen : X11Color.h
  • colorMediumTurquoise : X11Color.h
  • colorMediumVioletRed : X11Color.h
  • colorMidnightBlue : X11Color.h
  • colorMintCream : X11Color.h
  • colorMistyRose : X11Color.h
  • colorMoccasin : X11Color.h
  • colorNavajoWhite : X11Color.h
  • colorNavy : X11Color.h
  • colorOldLace : X11Color.h
  • colorOlive : X11Color.h
  • colorOliveDrab : X11Color.h
  • colorOrange : X11Color.h
  • colorOrangeRed : X11Color.h
  • colorOrchid : X11Color.h
  • colorPaleGoldenrod : X11Color.h
  • colorPaleGreen : X11Color.h
  • colorPaleTurquoise : X11Color.h
  • colorPaleVioletRed : X11Color.h
  • colorPapayaWhip : X11Color.h
  • colorPeachPuff : X11Color.h
  • colorPeru : X11Color.h
  • colorPink : X11Color.h
  • colorPlum : X11Color.h
  • colorPowderBlue : X11Color.h
  • colorPurple : X11Color.h
  • colorRed : X11Color.h
  • colorRosyBrown : X11Color.h
  • colorRoyalBlue : X11Color.h
  • colorSaddleBrown : X11Color.h
  • colorSalmon : X11Color.h
  • colorSandyBrown : X11Color.h
  • colorSeaGreen : X11Color.h
  • colorSeaShell : X11Color.h
  • colorSienna : X11Color.h
  • colorSilver : X11Color.h
  • colorSkyBlue : X11Color.h
  • colorSlateBlue : X11Color.h
  • colorSlateGray : X11Color.h
  • colorSnow : X11Color.h
  • colorSpringGreen : X11Color.h
  • colorSteelBlue : X11Color.h
  • colorTan : X11Color.h
  • colorTeal : X11Color.h
  • colorThistle : X11Color.h
  • colorTomato : X11Color.h
  • colorTurquoise : X11Color.h
  • colorViolet : X11Color.h
  • colorWheat : X11Color.h
  • colorWhite : X11Color.h
  • colorWhiteSmoke : X11Color.h
  • colorYellow : X11Color.h
  • colorYellowGreen : X11Color.h

- d -

  • DP5Proto : SelectDP5.h , vcDP5.cpp , vcDP5Dlg.h
  • DppWinUSB : SelectDP5.h , vcDP5.cpp , vcDP5Dlg.h

- m -

  • MAX_ENTRIES : NetFinder.h

- n -

  • NO_ENTRIES : NetFinder.h

- p -

  • Profile : SProfile.h , vcDP5.cpp

- r -

  • regDP5Comm : SProfile.h
  • regDP5Config : SProfile.h
  • regDP5Device : SProfile.h

- s -

  • SndCmd : SelectDP5.h , vcDP5.cpp

- t -

  • theApp : vcDP5.cpp , vcDP5.h

- w -

  • WinusbNotify : SelectDP5.h , vcDP5Dlg.h , vcDP5.cpp
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • CommType : ParsePacket.h
  • CONFIG_OPTIONS : SendCommand.h
  • COORD_LONG : PlotCanvas.h
  • DEVICE_INFO : DppWinUSB.h
  • DiagDataType : DP5Status.h
  • DP4_FORMAT_STATUS : DP5Status.h
  • dp5DppTypes : DppConst.h
  • DPP_USB_STATUS : DppWinUSB.h
  • DppStateType : ParsePacket.h
  • NETDISPLAY_ENTRY : NetFinder.h
  • Packet_In : DP5Protocol.h
  • PDDiagDataType : DP5Status.h
  • PDEVICE_INFO : DppWinUSB.h
  • PDP4_FORMAT_STATUS : DP5Status.h
  • PWINUSB_INTERFACE_HANDLE : WINUSB.H
  • PWINUSB_PIPE_INFORMATION : WINUSBIO.H
  • PWINUSB_SETUP_PACKET : WINUSB.H
  • PX5_OPTIONS : DP5Status.h
  • SpectrumFileType : vcDP5Dlg.h
  • WINUSB_INTERFACE_HANDLE : WINUSB.H
  • WINUSB_PIPE_INFORMATION : WINUSBIO.H
  • WINUSB_SETUP_PACKET : WINUSB.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _CommType : ParsePacket.h
  • _DPP_USB_STATUS : DppWinUSB.h
  • _PX5_OPTIONS : DP5Status.h
  • DP5_DPP_TYPES : DppConst.h
  • FlashType : Label.h
  • GAIN_TYPE : STypes.h
  • PID1_TYPE : DP5Protocol.h
  • PID2_ACK_TYPE : DP5Protocol.h
  • PID2_RCV_SCA_TYPE : DP5Protocol.h
  • PID2_RCV_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_RCV_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_RCV_STATUS_TYPE : DP5Protocol.h
  • PID2_REQ_CONFIG_TYPE : DP5Protocol.h
  • PID2_REQ_FPGA_UC_TYPE : DP5Protocol.h
  • PID2_REQ_SCA_TYPE : DP5Protocol.h
  • PID2_REQ_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_REQ_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_REQ_STATUS_TYPE : DP5Protocol.h
  • PID2_VENDOR_REQ_TYPE : DP5Protocol.h
  • SCALE_TYPE : STypes.h
  • SMOOTH_TYPE : STypes.h
  • TRANSMIT_PACKET_TYPE : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- b -

  • Background : Label.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- c -

  • commNone : ParsePacket.h
  • commRS232 : ParsePacket.h
  • commSockets : ParsePacket.h
  • commUSB : ParsePacket.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- d -

  • dppDP5 : DppConst.h
  • dppDP5G : DppConst.h
  • dppDP5X : DppConst.h
  • dppMCA8000D : DppConst.h
  • dppPX5 : DppConst.h
  • dppTB5 : DppConst.h
  • dusbStatConnectFail : DppWinUSB.h
  • dusbStatNewConnect : DppWinUSB.h
  • dusbStatNoAction : DppWinUSB.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- f -

  • FIVE_SMOOTH : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- g -

  • GAIN_1024 : STypes.h
  • GAIN_16384 : STypes.h
  • GAIN_2048 : STypes.h
  • GAIN_256 : STypes.h
  • GAIN_4096 : STypes.h
  • GAIN_512 : STypes.h
  • GAIN_8192 : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- i -

  • INVALID_SMOOTH : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- l -

  • LIN_SCALE : STypes.h
  • LOG_SCALE : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- n -

  • NO_SMOOTH : STypes.h
  • None : Label.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- p -

  • PID1_ACK : DP5Protocol.h
  • PID1_COMM_TEST : DP5Protocol.h
  • PID1_RCV_SCA : DP5Protocol.h
  • PID1_RCV_SCOPE_MISC : DP5Protocol.h
  • PID1_RCV_SPECTRUM : DP5Protocol.h
  • PID1_RCV_STATUS : DP5Protocol.h
  • PID1_REQ_CONFIG : DP5Protocol.h
  • PID1_REQ_FPGA_UC : DP5Protocol.h
  • PID1_REQ_SCA : DP5Protocol.h
  • PID1_REQ_SCOPE_MISC : DP5Protocol.h
  • PID1_REQ_SPECTRUM : DP5Protocol.h
  • PID1_REQ_STATUS : DP5Protocol.h
  • PID1_VENDOR_REQ : DP5Protocol.h
  • PID2_ACK_BAD_HEX_REC : DP5Protocol.h
  • PID2_ACK_BAD_PARAM : DP5Protocol.h
  • PID2_ACK_CAL_DATA_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_CHECKSUM_ERROR : DP5Protocol.h
  • PID2_ACK_CP2201_NOT_FOUND : DP5Protocol.h
  • PID2_ACK_ETHERNET_BUSY : DP5Protocol.h
  • PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED : DP5Protocol.h
  • PID2_ACK_FPGA_ERROR : DP5Protocol.h
  • PID2_ACK_I2C_ERROR : DP5Protocol.h
  • PID2_ACK_LEN_ERROR : DP5Protocol.h
  • PID2_ACK_OK : DP5Protocol.h
  • PID2_ACK_OK_ETHERNET_SHARE_REQ : DP5Protocol.h
  • PID2_ACK_OK_FPGA_UPLOAD_ADDR : DP5Protocol.h
  • PID2_ACK_PC5_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_PID_ERROR : DP5Protocol.h
  • PID2_ACK_SCOPE_DATA_NOT_AVAIL : DP5Protocol.h
  • PID2_ACK_SYNC_ERROR : DP5Protocol.h
  • PID2_ACK_UNRECOG : DP5Protocol.h
  • PID2_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • PID2_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • PID2_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • PID2_CLEAR_GP_COUNTER : DP5Protocol.h
  • PID2_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • PID2_CONFIG_READBACK_PACKET : DP5Protocol.h
  • PID2_DISABLE_MCA_MCS : DP5Protocol.h
  • PID2_ENABLE_MCA_MCS : DP5Protocol.h
  • PID2_ERASE_FPGA_IMAGE : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • PID2_ETHERNET_ALLOW_SHAREING : DP5Protocol.h
  • PID2_ETHERNET_LOCK_IP : DP5Protocol.h
  • PID2_ETHERNET_NO_SHARING : DP5Protocol.h
  • PID2_GENERIC_FPGA_WRITE : DP5Protocol.h
  • PID2_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • PID2_LATCH_SEND_SCA : DP5Protocol.h
  • PID2_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • PID2_READ_IO3_0 : DP5Protocol.h
  • PID2_REINITIALIZE_FPGA : DP5Protocol.h
  • PID2_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • PID2_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • PID2_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • PID2_SEND_I2C_DATA : DP5Protocol.h
  • PID2_SEND_LIST_MODE_DATA : DP5Protocol.h
  • PID2_SEND_NETFINDER_READBACK : DP5Protocol.h
  • PID2_SEND_OPTION_PA_CALIBRATION : DP5Protocol.h
  • PID2_SEND_SCA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • PID2_SEND_SPECTRUM : DP5Protocol.h
  • PID2_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • PID2_SET_BOOT_FLAGS : DP5Protocol.h
  • PID2_SET_DCAL : DP5Protocol.h
  • PID2_SET_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • PID2_SET_SERIAL_NUMBER : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • PID2_TEXT_CONFIG_PACKET : DP5Protocol.h
  • PID2_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • PID2_UPLOAD_PACKET_UC : DP5Protocol.h
  • PID2_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_WRITE_IO3_0 : DP5Protocol.h
  • PX5_OPTION_HPGe_HVPS : DP5Status.h
  • PX5_OPTION_NONE : DP5Status.h
  • PX5_OPTION_TEST_AMP : DP5Status.h
  • PX5_OPTION_TEST_MODE_1 : DP5Status.h
  • PX5_OPTION_TEST_MODE_2 : DP5Status.h
  • PX5_OPTION_TEST_MOX : DP5Status.h
  • PX5_OPTION_TEST_TEK : DP5Status.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- r -

  • RCVPT_1024_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_1024_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_512_BYTE_MISC_DATA : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_CONFIG_READBACK : DP5Protocol.h
  • RCVPT_DIAGNOSTIC_DATA : DP5Protocol.h
  • RCVPT_DP4_STYLE_STATUS : DP5Protocol.h
  • RCVPT_ETHERNET_SETTINGS : DP5Protocol.h
  • RCVPT_HARDWARE_DESCRIPTION : DP5Protocol.h
  • RCVPT_I2C_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA_FIFO_FULL : DP5Protocol.h
  • RCVPT_NETFINDER_READBACK : DP5Protocol.h
  • RCVPT_OPTION_PA_CALIBRATION : DP5Protocol.h
  • RCVPT_SCA : DP5Protocol.h
  • RCVPT_SCOPE_DATA : DP5Protocol.h
  • RCVPT_SCOPE_DATA_WITH_OVERFLOW : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- s -

  • SQRT_SCALE : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- t -

  • Text : Label.h
  • THREE_SMOOTH : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- x -

  • XMTPT_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • XMTPT_AU34_2_RESTART : DP5Protocol.h
  • XMTPT_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • XMTPT_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • XMTPT_BUFFER_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_BUFFER_SPECTRUM : DP5Protocol.h
  • XMTPT_CLEAR_GP_COUNTER : DP5Protocol.h
  • XMTPT_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • XMTPT_DISABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ENABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ERASE_FPGA_IMAGE : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_FORCE_SCOPE_TRIGGER : DP5Protocol.h
  • XMTPT_FULL_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • XMTPT_LATCH_SEND_SCA : DP5Protocol.h
  • XMTPT_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_READ_IO3_0 : DP5Protocol.h
  • XMTPT_READ_MCA8000D_OPTION_PA_CAL : DP5Protocol.h
  • XMTPT_REINITIALIZE_FPGA : DP5Protocol.h
  • XMTPT_REQ_ACK_PACKET : DP5Protocol.h
  • XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS : DP5Protocol.h
  • XMTPT_SCA_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_SEND_BUFFER : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_TO_HW : DP5Protocol.h
  • XMTPT_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • XMTPT_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • XMTPT_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • XMTPT_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • XMTPT_SEND_NETFINDER_PACKET : DP5Protocol.h
  • XMTPT_SEND_PX4_CONFIG : DP5Protocol.h
  • XMTPT_SEND_ROI_OR_FIXED_BLOCK : DP5Protocol.h
  • XMTPT_SEND_SCA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_STATUS : DP5Protocol.h
  • XMTPT_SEND_TEST_PACKET : DP5Protocol.h
  • XMTPT_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • XMTPT_SET_BOOT_FLAGS : DP5Protocol.h
  • XMTPT_SET_DCAL : DP5Protocol.h
  • XMTPT_SET_HV_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_INPUT_OFFSET_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • XMTPT_SET_SERIAL_NUMBER : DP5Protocol.h
  • XMTPT_SET_SPECTRUM_OFFSET : DP5Protocol.h
  • XMTPT_SET_TEC_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SWITCH_SUPPLIES : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_UC_FPGA_CHECKSUMS : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_UC : DP5Protocol.h
  • XMTPT_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_WRITE_IO3_0 : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- _ -

  • _CRT_SECURE_NO_DEPRECATE : StdAfx.h
  • _SETUPAPI_VER : StdAfx.h
  • _WIN32_IE : StdAfx.h
  • _WIN32_WINDOWS : StdAfx.h
  • _WIN32_WINNT : StdAfx.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ACK : DP5Protocol.h
  • AFX_HIDD_BUSY : HTMLDefines.h
  • AFX_HIDD_CHANGEICON : HTMLDefines.h
  • AFX_HIDD_CHANGESOURCE : HTMLDefines.h
  • AFX_HIDD_COLOR : HTMLDefines.h
  • AFX_HIDD_CONVERT : HTMLDefines.h
  • AFX_HIDD_EDITLINKS : HTMLDefines.h
  • AFX_HIDD_FILEBROWSE : HTMLDefines.h
  • AFX_HIDD_FILEOPEN : HTMLDefines.h
  • AFX_HIDD_FILESAVE : HTMLDefines.h
  • AFX_HIDD_FIND : HTMLDefines.h
  • AFX_HIDD_FONT : HTMLDefines.h
  • AFX_HIDD_INSERTOBJECT : HTMLDefines.h
  • AFX_HIDD_NEWTYPEDLG : HTMLDefines.h
  • AFX_HIDD_OBJECTPROPERTIES : HTMLDefines.h
  • AFX_HIDD_PASTESPECIAL : HTMLDefines.h
  • AFX_HIDD_PREVIEW_SHORTTOOLBAR : HTMLDefines.h
  • AFX_HIDD_PREVIEW_TOOLBAR : HTMLDefines.h
  • AFX_HIDD_PRINT : HTMLDefines.h
  • AFX_HIDD_PRINTDLG : HTMLDefines.h
  • AFX_HIDD_PRINTSETUP : HTMLDefines.h
  • AFX_HIDD_REPLACE : HTMLDefines.h
  • AFX_HIDP_ARCH_BADCLASS : HTMLDefines.h
  • AFX_HIDP_ARCH_BADINDEX : HTMLDefines.h
  • AFX_HIDP_ARCH_BADSCHEMA : HTMLDefines.h
  • AFX_HIDP_ARCH_ENDOFFILE : HTMLDefines.h
  • AFX_HIDP_ARCH_GENERIC : HTMLDefines.h
  • AFX_HIDP_ARCH_NONE : HTMLDefines.h
  • AFX_HIDP_ARCH_READONLY : HTMLDefines.h
  • AFX_HIDP_ARCH_WRITEONLY : HTMLDefines.h
  • AFX_HIDP_ASK_TO_DISCARD : HTMLDefines.h
  • AFX_HIDP_ASK_TO_SAVE : HTMLDefines.h
  • AFX_HIDP_ASK_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_BAD_VERB : HTMLDefines.h
  • AFX_HIDP_COMMAND_FAILURE : HTMLDefines.h
  • AFX_HIDP_DAO_BADBINDINFO : HTMLDefines.h
  • AFX_HIDP_DAO_COLUMNUNAVAILABLE : HTMLDefines.h
  • AFX_HIDP_DAO_DFX_BIND : HTMLDefines.h
  • AFX_HIDP_DAO_ENGINE_INITIALIZATION : HTMLDefines.h
  • AFX_HIDP_DAO_OBJECT_NOT_OPEN : HTMLDefines.h
  • AFX_HIDP_DAO_ROWTOOSHORT : HTMLDefines.h
  • AFX_HIDP_DLL_BAD_VERSION : HTMLDefines.h
  • AFX_HIDP_DLL_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_DISK_FULL : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_FORMAT : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_PATH : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_LOAD : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_SEND : HTMLDefines.h
  • AFX_HIDP_FAILED_MEMORY_ALLOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_AUTO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONNECT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONVERT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH_HELP : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_NOTIFY : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_OPEN_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_SAVE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_START_PRINT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_FILE_ACCESS_DENIED : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_PATH : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_SEEK : HTMLDefines.h
  • AFX_HIDP_FILE_DIR_FULL : HTMLDefines.h
  • AFX_HIDP_FILE_DISKFULL : HTMLDefines.h
  • AFX_HIDP_FILE_EOF : HTMLDefines.h
  • AFX_HIDP_FILE_GENERIC : HTMLDefines.h
  • AFX_HIDP_FILE_HARD_IO : HTMLDefines.h
  • AFX_HIDP_FILE_INVALID_FILE : HTMLDefines.h
  • AFX_HIDP_FILE_LOCKING : HTMLDefines.h
  • AFX_HIDP_FILE_NONE : HTMLDefines.h
  • AFX_HIDP_FILE_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_FILE_REMOVE_CURRENT : HTMLDefines.h
  • AFX_HIDP_FILE_SHARING : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_LARGE : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_MANY_OPEN : HTMLDefines.h
  • AFX_HIDP_GET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_INTERNAL_FAILURE : HTMLDefines.h
  • AFX_HIDP_INVALID_FILENAME : HTMLDefines.h
  • AFX_HIDP_INVALID_MAPI_DLL : HTMLDefines.h
  • AFX_HIDP_NO_ERROR_AVAILABLE : HTMLDefines.h
  • AFX_HIDP_PARSE_BYTE : HTMLDefines.h
  • AFX_HIDP_PARSE_CURRENCY : HTMLDefines.h
  • AFX_HIDP_PARSE_DATETIME : HTMLDefines.h
  • AFX_HIDP_PARSE_INT : HTMLDefines.h
  • AFX_HIDP_PARSE_INT_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_RADIO_BUTTON : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_STRING_SIZE : HTMLDefines.h
  • AFX_HIDP_PARSE_UINT : HTMLDefines.h
  • AFX_HIDP_SERVER_BUSY : HTMLDefines.h
  • AFX_HIDP_SET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_API_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_CONNECT_FAIL : HTMLDefines.h
  • AFX_HIDP_SQL_DATA_TRUNCATED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_EMPTY_COLUMN_LIST : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH : HTMLDefines.h
  • AFX_HIDP_SQL_ILLEGAL_MODE : HTMLDefines.h
  • AFX_HIDP_SQL_INCORRECT_ODBC : HTMLDefines.h
  • AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_NO_CURRENT_RECORD : HTMLDefines.h
  • AFX_HIDP_SQL_NO_DATA_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_NO_POSITIONED_UPDATES : HTMLDefines.h
  • AFX_HIDP_SQL_NO_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_V2_REQUIRED : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_READONLY : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_FETCH : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_NO_TOTAL : HTMLDefines.h
  • AFX_HIDP_SQL_UPDATE_DELETE_FAILED : HTMLDefines.h
  • AFX_HIDP_STATIC_OBJECT : HTMLDefines.h
  • AFX_HIDP_UNREG_DONE : HTMLDefines.h
  • AFX_HIDP_UNREG_FAILURE : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_BOTTOM : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_FLOAT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_LEFT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_RIGHT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_TOP : HTMLDefines.h
  • AFX_HIDW_PREVIEW_BAR : HTMLDefines.h
  • AFX_HIDW_RESIZE_BAR : HTMLDefines.h
  • AFX_HIDW_STATUS_BAR : HTMLDefines.h
  • AFX_HIDW_TOOLBAR : HTMLDefines.h
  • ALLOW_PARTIAL_READS : WINUSBIO.H
  • AMPTEK_DP5_PRODUCT_ID : DppLibUsb.h
  • AMPTEK_DP5_VENDOR_ID : DppLibUsb.h
  • AUTO_CLEAR_STALL : WINUSBIO.H
  • AUTO_FLUSH : WINUSBIO.H
  • AUTO_SUSPEND : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BULK_IN_ENDPOINT : DppLibUsb.h
  • BULK_OUT_ENDPOINT : DppLibUsb.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CC_SYSCOLOR : PlotCanvas.h
  • ctrlColBlack : PlotCanvas.h
  • ctrlColBlue : PlotCanvas.h
  • ctrlColBtnFace : PlotCanvas.h
  • ctrlColDefault : PlotCanvas.h
  • ctrlColGray : PlotCanvas.h
  • ctrlColGreen : PlotCanvas.h
  • ctrlColInfoBk : PlotCanvas.h
  • ctrlColInfoText : PlotCanvas.h
  • ctrlColJavaGray : PlotCanvas.h
  • ctrlColLightBlue : PlotCanvas.h
  • ctrlColLightCyan : PlotCanvas.h
  • ctrlColLightGray : PlotCanvas.h
  • ctrlColRed : PlotCanvas.h
  • ctrlColSkyBlue : PlotCanvas.h
  • ctrlColWhite : PlotCanvas.h
  • ctrlColWinBk : PlotCanvas.h
  • ctrlColWinText : PlotCanvas.h
  • ctrlColYellow : PlotCanvas.h
  • ctrlDarkGreen : PlotCanvas.h
  • ctrlDarkGreenCopper : PlotCanvas.h
  • ctrlDarkOliveGreen : PlotCanvas.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • DEVICE_SPEED : WINUSBIO.H
  • DP4_PX4_OLD_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_DIAGDATA_TIMEOUT : DppLibUsb.h
  • DP5_DPP_TYPES_FIRST : DppConst.h
  • DP5_DPP_TYPES_LAST : DppConst.h
  • DP5_MAX_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_USB_TIMEOUT : DppLibUsb.h
  • DRV_INFO_OPTION_ALL : DppWinUSB.h
  • DRV_INFO_OPTION_DATE : DppWinUSB.h
  • DRV_INFO_OPTION_DESC : DppWinUSB.h
  • DRV_INFO_OPTION_LABEL : DppWinUSB.h
  • DRV_INFO_OPTION_MFG_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_MS_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_NONE : DppWinUSB.h
  • DRV_INFO_OPTION_PROV_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_UX_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_VER : DppWinUSB.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • ETHERNET : DP5Protocol.h
  • ETHERNET_TIMEOUT : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FullSpeed : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GAIN_FROM_INDEX : STypes.h
  • GETLONG : STypes.h
  • GETP1 : SProfile.h
  • GETPD : SProfile.h
  • GETULONG : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HID_APP_ABOUT : HTMLDefines.h
  • HID_APP_EXIT : HTMLDefines.h
  • HID_CONTEXT_HELP : HTMLDefines.h
  • HID_EDIT_CLEAR : HTMLDefines.h
  • HID_EDIT_CLEAR_ALL : HTMLDefines.h
  • HID_EDIT_COPY : HTMLDefines.h
  • HID_EDIT_CUT : HTMLDefines.h
  • HID_EDIT_FIND : HTMLDefines.h
  • HID_EDIT_PASTE : HTMLDefines.h
  • HID_EDIT_PASTE_LINK : HTMLDefines.h
  • HID_EDIT_PASTE_SPECIAL : HTMLDefines.h
  • HID_EDIT_REDO : HTMLDefines.h
  • HID_EDIT_REPEAT : HTMLDefines.h
  • HID_EDIT_REPLACE : HTMLDefines.h
  • HID_EDIT_SELECT_ALL : HTMLDefines.h
  • HID_EDIT_UNDO : HTMLDefines.h
  • HID_FILE_CLOSE : HTMLDefines.h
  • HID_FILE_MRU_FILE1 : HTMLDefines.h
  • HID_FILE_NEW : HTMLDefines.h
  • HID_FILE_OPEN : HTMLDefines.h
  • HID_FILE_PAGE_SETUP : HTMLDefines.h
  • HID_FILE_PRINT : HTMLDefines.h
  • HID_FILE_PRINT_DIRECT : HTMLDefines.h
  • HID_FILE_PRINT_PREVIEW : HTMLDefines.h
  • HID_FILE_PRINT_SETUP : HTMLDefines.h
  • HID_FILE_SAVE : HTMLDefines.h
  • HID_FILE_SAVE_AS : HTMLDefines.h
  • HID_FILE_SAVE_COPY_AS : HTMLDefines.h
  • HID_FILE_SEND_MAIL : HTMLDefines.h
  • HID_FILE_TAB : HTMLDefines.h
  • HID_FILE_UPDATE : HTMLDefines.h
  • HID_FORMAT_FONT : HTMLDefines.h
  • HID_GAINPZ_TAB : HTMLDefines.h
  • HID_HELP_ABOUT : HTMLDefines.h
  • HID_HELP_FINDER : HTMLDefines.h
  • HID_HELP_INDEX : HTMLDefines.h
  • HID_HELP_USING : HTMLDefines.h
  • HID_HT_CAPTION : HTMLDefines.h
  • HID_HT_CLOSE : HTMLDefines.h
  • HID_HT_HELP : HTMLDefines.h
  • HID_HT_HSCROLL : HTMLDefines.h
  • HID_HT_MAXBUTTON : HTMLDefines.h
  • HID_HT_MINBUTTON : HTMLDefines.h
  • HID_HT_NOWHERE : HTMLDefines.h
  • HID_HT_OBJECT : HTMLDefines.h
  • HID_HT_SIZE : HTMLDefines.h
  • HID_HT_VSCROLL : HTMLDefines.h
  • HID_MCA_TAB : HTMLDefines.h
  • HID_MISC_TAB : HTMLDefines.h
  • HID_NEXT_PANE : HTMLDefines.h
  • HID_OLE_EDIT_CHANGE_ICON : HTMLDefines.h
  • HID_OLE_EDIT_CONVERT : HTMLDefines.h
  • HID_OLE_EDIT_LINKS : HTMLDefines.h
  • HID_OLE_EDIT_PROPERTIES : HTMLDefines.h
  • HID_OLE_INSERT_NEW : HTMLDefines.h
  • HID_OLE_VERB_1 : HTMLDefines.h
  • HID_POWER_TAB : HTMLDefines.h
  • HID_PREV_PANE : HTMLDefines.h
  • HID_RECORD_FIRST : HTMLDefines.h
  • HID_RECORD_LAST : HTMLDefines.h
  • HID_RECORD_NEXT : HTMLDefines.h
  • HID_RECORD_PREV : HTMLDefines.h
  • HID_SC_CLOSE : HTMLDefines.h
  • HID_SC_MAXIMIZE : HTMLDefines.h
  • HID_SC_MINIMIZE : HTMLDefines.h
  • HID_SC_MOVE : HTMLDefines.h
  • HID_SC_NEXTWINDOW : HTMLDefines.h
  • HID_SC_PREVWINDOW : HTMLDefines.h
  • HID_SC_RESTORE : HTMLDefines.h
  • HID_SC_SIZE : HTMLDefines.h
  • HID_SC_TASKLIST : HTMLDefines.h
  • HID_SHAPING_TAB : HTMLDefines.h
  • HID_VIEW_STATUS_BAR : HTMLDefines.h
  • HID_VIEW_TOOLBAR : HTMLDefines.h
  • HID_WINDOW_ALL : HTMLDefines.h
  • HID_WINDOW_ARRANGE : HTMLDefines.h
  • HID_WINDOW_CASCADE : HTMLDefines.h
  • HID_WINDOW_NEW : HTMLDefines.h
  • HID_WINDOW_SPLIT : HTMLDefines.h
  • HID_WINDOW_TILE_HORZ : HTMLDefines.h
  • HID_WINDOW_TILE_VERT : HTMLDefines.h
  • HID_WIZBACK : HTMLDefines.h
  • HID_WIZFINISH : HTMLDefines.h
  • HID_WIZNEXT : HTMLDefines.h
  • HIDD_ABOUTBOX : HTMLDefines.h
  • HIDD_BUSY_DLG : HTMLDefines.h
  • HIDD_DP5_CONNECT : vcDP5_Shared_HIDD.h , SelectDP5.cpp
  • HIDD_FILE_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_GAINPZ_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MCA_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MESSAGE_BOX : HTMLDefines.h
  • HIDD_MISC_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_POWER_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_SHAPING_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_vcDP5_DIALOG : HTMLDefines.h
  • HIDM_ABOUTBOX : HTMLDefines.h
  • HIDP_SOCKETS_INIT_FAILED : HTMLDefines.h
  • HIDR_MAINFRAME : HTMLDefines.h
  • HIDR_MENU : HTMLDefines.h
  • HIDR_TOOLBAR : HTMLDefines.h
  • HIDR_TOOLBAR_DP5_DLG : HTMLDefines.h
  • HighSpeed : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • ID_FILE_TAB : resource.h
  • ID_GAINPZ_TAB : resource.h
  • ID_HELP_ABOUT : resource.h
  • ID_MCA_TAB : resource.h
  • ID_MISC_TAB : resource.h
  • ID_POWER_TAB : resource.h
  • ID_SHAPING_TAB : resource.h
  • IDB_BITMAP_DP5_DLG : resource.h
  • IDB_SPECTRUM_ANIM : resource.h
  • IDC_BUSY_PIC : resource.h
  • IDC_BUSY_TEXT : resource.h
  • IDC_BUTTON_ADD_ROI : resource.h
  • IDC_BUTTON_ARM_TRIGGER : resource.h
  • IDC_BUTTON_AUTOTUNE : resource.h
  • IDC_BUTTON_CLEAR_DATA_AND_GRAPH : resource.h
  • IDC_BUTTON_CLEAR_MISC_DATA : resource.h
  • IDC_BUTTON_CLEAR_ROI : resource.h
  • IDC_BUTTON_CLIPBOARD_COPY : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_PORT : SelectDP5Res.h
  • IDC_BUTTON_COUNT_DEVICES : SelectDP5Res.h
  • IDC_BUTTON_DIAG : resource.h
  • IDC_BUTTON_EDIT_CONFIG : resource.h
  • IDC_BUTTON_FIND_DEVICE : resource.h
  • IDC_BUTTON_FIND_DP5_IP : SelectDP5Res.h
  • IDC_BUTTON_FIND_USB_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT1 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT2 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT3 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT4 : SelectDP5Res.h
  • IDC_BUTTON_OPEN_PORT : SelectDP5Res.h
  • IDC_BUTTON_READ_MISC_DATA : resource.h
  • IDC_BUTTON_ROI_END : resource.h
  • IDC_BUTTON_ROI_START : resource.h
  • IDC_BUTTON_SAVE_FILE : resource.h
  • IDC_BUTTON_SELECT_COMM : resource.h
  • IDC_BUTTON_SERIAL_REQ_DATA : SelectDP5Res.h
  • IDC_BUTTON_SHOW_CONFIG : resource.h
  • IDC_BUTTON_SINGLE_UPDATE : resource.h
  • IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT : SelectDP5Res.h
  • IDC_BUTTON_START_ACQUISITION : resource.h
  • IDC_BUTTON_STOP_ACQUISITION : resource.h
  • IDC_BUTTON_WRITE_MISC_DATA : resource.h
  • IDC_CHECK_AUTO_REARM : resource.h
  • IDC_CHECK_DELTA : resource.h
  • IDC_CHECK_REPEAT_SPECTRUM : resource.h
  • IDC_CONNECTOK : SelectDP5Res.h
  • IDC_EDIT_DESCRIPTION : resource.h
  • IDC_EDIT_DIAG : resource.h
  • IDC_EDIT_DPPCOMM_STATUS : SelectDP5Res.h
  • IDC_EDIT_MISC_DATA : resource.h
  • IDC_EDIT_PRESET_CMD : resource.h
  • IDC_EDIT_REPEAT_LOOPS : resource.h
  • IDC_EDIT_START_TIME : resource.h
  • IDC_EDIT_STATUS : resource.h
  • IDC_EDIT_STATUS2 : SelectDP5Res.h
  • IDC_EDIT_TAG : resource.h
  • IDC_GROUP_PLOT_SCALE : resource.h
  • IDC_MESSAGE1 : resource.h
  • IDC_MESSAGE2 : resource.h
  • IDC_PICTURE_PLOT : resource.h
  • IDC_PICTURE_SCOPE : resource.h
  • IDC_PLOTTYPEGROUP : resource.h
  • IDC_RADIO_COMMTYPE1 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE2 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE3 : SelectDP5Res.h
  • IDC_RADIO_PLOT_SCALE_LINEAR : resource.h
  • IDC_RADIO_PLOT_SCALE_LOG : resource.h
  • IDC_RADIO_PLOT_TYPE_LINE : resource.h
  • IDC_RADIO_PLOT_TYPE_SOLID : resource.h
  • IDC_SPECTRUM_REFRESH_TIME : SelectDP5Res.h
  • IDC_SPIN_SELECT_DEVICE : SelectDP5Res.h
  • IDC_STATIC_ : resource.h
  • IDC_STATIC_FOUND1 : SelectDP5Res.h
  • IDC_STATIC_FOUND2 : SelectDP5Res.h
  • IDC_STATIC_FOUND3 : SelectDP5Res.h
  • IDC_STATIC_IP_ADDRESS_LABEL : SelectDP5Res.h
  • IDC_STATIC_IP_SERIAL_NUM : SelectDP5Res.h
  • IDC_STATIC_LOOPS : resource.h
  • IDC_STATIC_MISC_STATUS : resource.h
  • IDC_STATIC_NUM_DEVICES : SelectDP5Res.h
  • IDC_STATIC_NUM_DEVICES2 : SelectDP5Res.h
  • IDC_STATIC_PORT_LABEL : SelectDP5Res.h
  • IDC_STATIC_PRESET_CMD : resource.h
  • IDC_STATIC_REPEAT_STATUS : resource.h
  • IDC_STATIC_ROI_COUNT : resource.h
  • IDC_STATIC_ROI_END : resource.h
  • IDC_STATIC_ROI_INDEX : resource.h
  • IDC_STATIC_ROI_START : resource.h
  • IDC_STATIC_SELECT_COMMUNICATIONS : resource.h
  • IDC_STATIC_SELECT_USB_DEVICE_LABEL : SelectDP5Res.h
  • IDC_STATIC_SPECTRUM_STATUS : resource.h
  • IDC_STATIC_START_TIME : resource.h
  • IDC_STATIC_STATUS : resource.h
  • IDD_ABOUTBOX : resource.h
  • IDD_BUSY_DLG : resource.h
  • IDD_DP5_CONNECT : vcDP5_Shared_IDD.h
  • IDD_FILE_PAGE : vcDP5_Shared_IDD.h
  • IDD_GAINPZ_PAGE : vcDP5_Shared_IDD.h
  • IDD_MCA_PAGE : vcDP5_Shared_IDD.h
  • IDD_MESSAGE_BOX : resource.h
  • IDD_MISC_PAGE : vcDP5_Shared_IDD.h
  • IDD_POWER_PAGE : vcDP5_Shared_IDD.h
  • IDD_SHAPING_PAGE : vcDP5_Shared_IDD.h
  • IDD_vcDP5_DIALOG : resource.h
  • IDM_ABOUTBOX : resource.h
  • IDP_SOCKETS_INIT_FAILED : resource.h
  • IDR_MAINFRAME : resource.h
  • IDR_MENU : resource.h
  • IDR_TOOLBAR : resource.h
  • IDR_TOOLBAR_DP5_DLG : resource.h
  • IDS_ABOUTBOX : resource.h
  • IDS_BTNSTRING_MODAL : resource.h
  • IDS_BTNSTRING_MODELESS : resource.h
  • IDS_CAPTION : resource.h
  • IGNORE_SHORT_PACKETS : WINUSBIO.H
  • INTERFACE_NUMBER : DppLibUsb.h
  • isDebug : SelectDP5.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • LINE_PLOT_TYPE : vcDP5Dlg.h
  • LINEAR_PLOT_SCALE : vcDP5Dlg.h
  • LOG_PLOT_SCALE : vcDP5Dlg.h
  • LowSpeed : WINUSBIO.H
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MAX_BUFFER_DATA : DP5Protocol.h
  • MAX_BULK_IN_TRANSFER_SIZE : DppLibUsb.h
  • MAX_BULK_OUT_TRANSFER_SIZE : DppLibUsb.h
  • MAX_CHANNELS : STypes.h
  • MAX_COUNTS : STypes.h
  • MAX_DEVPATH_LENGTH : DppWinUSB.h
  • MAX_GAIN_INDEX : STypes.h
  • MAX_KEY_DATA_SIZE : INI.h
  • MAX_SCOPE_DATA : DP5Protocol.h
  • MAX_SECTION_SIZE : INI.h
  • MAX_SPECTRA : STypes.h
  • MAXDP5S : DppWinUSB.h
  • MAXIMUM_TRANSFER_SIZE : WINUSBIO.H
  • MAXPIPES : DppWinUSB.h
  • MAXREGBUFFER : DppWinUSB.h
  • MIN_FRAME_X_PIXELS : STypes.h
  • MIN_FRAME_Y_PIXELS : STypes.h
  • MIN_GAIN : STypes.h
  • MIN_PLOT_CHANNELS : STypes.h
  • MIN_PLOT_COUNTS : STypes.h
  • MIN_PLOT_X_PIXELS : STypes.h
  • MIN_PLOT_Y_PIXELS : STypes.h
Generated on Fri Sep 22 2017 10:01:07 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PID1_REQ_SCOPE_MISC_TO : DppLibUsb.h
  • PID2_SEND_DIAGNOSTIC_DATA_TO : DppLibUsb.h
  • PIPE_TRANSFER_TIMEOUT : WINUSBIO.H
  • preqProcessAck : ParsePacket.h
  • preqProcessCfgRead : ParsePacket.h
  • preqProcessDiagData : ParsePacket.h
  • preqProcessError : ParsePacket.h
  • preqProcessHwDesc : ParsePacket.h
  • preqProcessInetSettings : ParsePacket.h
  • preqProcessNetFindRead : ParsePacket.h
  • preqProcessNone : ParsePacket.h
  • preqProcessPaCal : ParsePacket.h
  • preqProcessSCAData : ParsePacket.h
  • preqProcessScopeData : ParsePacket.h
  • preqProcessScopeDataOverFlow : ParsePacket.h
  • preqProcessSpectrum : ParsePacket.h
  • preqProcessStatus : ParsePacket.h
  • preqProcessTextData : ParsePacket.h
  • preqRequestScopeData : ParsePacket.h
  • PUTP1 : SProfile.h
  • PUTPD : SProfile.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • RAW_IO : WINUSBIO.H
  • Retries : DP5Protocol.h
  • RS232 : DP5Protocol.h
  • RS232_TIMEOUT : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • SCREEN_SCALE : STypes.h
  • SHORT_PACKET_TERMINATE : WINUSBIO.H
  • SOLID_PLOT_TYPE : vcDP5Dlg.h
  • STATUS_PACKET_SIZE : DppLibUsb.h
  • SUSPEND_DELAY : WINUSBIO.H
  • SYNC1_ : DP5Protocol.h
  • SYNC2_ : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TIMEOUT_MS : DppLibUsb.h
  • TIMER_ID : AnimWnd.h
  • TOLONG : STypes.h
  • TOULONG : STypes.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • USB : DP5Protocol.h
  • USB_DiagDataDelayMS : DP5Protocol.h
  • USB_TIMEOUT : DP5Protocol.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • VC_EXTRALEAN : StdAfx.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • Whitespace : AsciiCmdUtilities.h
  • WinUsbDP5 : DppWinUSB.h
  • WinUsbDP5Size : DppWinUSB.h
  • WinUSBService : DppWinUSB.h
  • WINVER : StdAfx.h
  • WM_USER_COARSE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_DPP_AUTO_FAST_THESHOLD : UserMsgs.h
  • WM_USER_DPP_AUTO_SLOW_THESHOLD : UserMsgs.h
  • WM_USER_FINE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_FPGUI_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_LOAD_FILE : UserMsgs.h
  • WM_USER_PMCA_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG_EX : UserMsgs.h
  • WM_USER_READ_SCA_CONFIG : UserMsgs.h
  • WM_USER_REPEAT_MEASUREMENT : UserMsgs.h
  • WM_USER_SAVE_CONFIG_TO_FILE : UserMsgs.h
  • WM_USER_SEND_CONFIG_TO_HW : UserMsgs.h
  • WM_USER_SHOW_CONNECT_DIALOG : UserMsgs.h
  • WM_USER_SHOW_SPECTRA_LIST_DLG : UserMsgs.h
  • WM_USER_UPDATE_MENU : UserMsgs.h
  • WM_USER_UPDATE_STATUS_BAR : UserMsgs.h
Generated on Fri Sep 22 2017 10:01:08 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/AnimWnd.cpp Source File

waitdlg/AnimWnd.cpp
Go to the documentation of this file.
00001 // cAnimWnd.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "AnimWnd.h"
00006
00008 // cAnimWnd
00009
00010 cAnimWnd::cAnimWnd()
00011 {
00012    m_ImageIndex = -1;
00013    m_MemDC = NULL;
00014 }
00015
00016 cAnimWnd::~cAnimWnd()
00017 {
00018    if (m_MemDC)
00019       delete m_MemDC;
00020
00021    m_Bitmap.Detach();
00022    m_Bitmap.DeleteObject();
00023 }
00024
00025
00026 BEGIN_MESSAGE_MAP(cAnimWnd, CWnd)
00027         //{{AFX_MSG_MAP(cAnimWnd)
00028         ON_WM_TIMER()
00029         ON_WM_PAINT()
00030         //}}AFX_MSG_MAP
00031 END_MESSAGE_MAP()
00032
00033
00035 // cAnimWnd message handlers
00036
00037 void cAnimWnd::SetImageList(UINT BitmapID, short Sizex, short Sizey, COLORREF TransparentColor)
00038 {
00039    m_TransparentColor = TransparentColor;
00040
00041    m_Bitmap.LoadBitmap(BitmapID);
00042    m_Width = Sizex;
00043    m_Height = Sizey;
00044
00045    CPoint ptSize;
00046    BITMAP bm_info;
00047    m_Bitmap.GetBitmap(&bm_info);
00048    ptSize.x = bm_info.bmWidth;
00049         ptSize.y = bm_info.bmHeight;
00050
00051    m_MemDC = new cMemDC(this->GetDC(), CRect(0,0,ptSize.x, ptSize.y));
00052    m_MemDC->SelectObject(&m_Bitmap);
00053 }
00054
00055 void cAnimWnd::OnPaint()
00056 {
00057         CPaintDC dc(this); // device context for painting
00058
00059         // TODO: Add your message handler code here
00060    if (m_MemDC)
00061       {
00062       // paint current image
00063       dc.BitBlt(0,0,m_Width, m_Height, m_MemDC, ((m_ImageIndex) * m_Width),0,SRCCOPY);
00064       }
00065    else
00066       {
00067            CWnd::DefWindowProc(WM_PAINT, (WPARAM)dc.m_hDC, 0);
00068       return;
00069       }
00070
00071         // Do not call CWnd::OnPaint() for painting messages
00072 }
00073
00074 void cAnimWnd::OnTimer(UINT nIDEvent)
00075 {
00076         // TODO: Add your message handler code here and/or call default
00077         switch (nIDEvent)
00078       {
00079       case TIMER_ID:
00080          {
00081          if (m_MemDC)
00082             {
00083             if (m_ImageIndex++ >= GetImageCount() - 1)
00084                m_ImageIndex = 0;
00085             Invalidate(TRUE);
00086             }
00087          }
00088       }
00089
00090         CWnd::OnTimer(nIDEvent);
00091 }
00092
00093 INT_PTR cAnimWnd::StartAnim(short Delay)
00094 {
00095    INT_PTR ret = SetTimer(TIMER_ID, Delay, NULL);
00096    return ret;
00097 }
00098
00099 BOOL cAnimWnd::StopAnim()
00100 {
00101    if (!KillTimer(TIMER_ID))
00102       return FALSE;
00103
00104    return TRUE;
00105 }
00106
00107 BOOL cAnimWnd::Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID, CCreateContext* pContext)
00108 {
00109         // TODO: Add your specialized code here and/or call the base class
00110    CString wndclass = ::AfxRegisterWndClass(CS_DBLCLKS,
00111      ::LoadCursor(NULL, IDC_ARROW),
00112      ::GetSysColorBrush(COLOR_BTNFACE), 0);
00113
00114         BOOL ret = CWnd::CreateEx(0L, wndclass, NULL, dwStyle, rect, pParentWnd, nID, pContext);
00115
00116    return ret;
00117 }
00118
00119
00120 int cAnimWnd::GetImageCount()
00121 {
00122    BITMAP bm_info;
00123    m_Bitmap.GetBitmap(&bm_info);
00124    int x = bm_info.bmWidth;
00125
00126    return (int)(x / m_Width);
00127 }
00128
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/AnimWnd.h Source File

waitdlg/AnimWnd.h
Go to the documentation of this file.
00001 #if !defined(AFX_cANIMWND_H__7F9C97E1_F7F4_11D2_837C_00500406DAEB__INCLUDED_)
00002 #define AFX_cANIMWND_H__7F9C97E1_F7F4_11D2_837C_00500406DAEB__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // cAnimWnd.h : header file
00008 //
00010 // Author: Todd Andrews
00011 // Email:  tmandrews@mindspring.com
00012 // Copyright 1999, Todd Andrews
00013 //
00014 // You may freely use or modify this code provided this
00015 // Copyright is included in all derived versions.
00016 //
00017 //
00018 // This class implements an animated bitmap
00019
00020 #include "memdc.h"
00021
00023 // cAnimWnd window
00024
00025 #define TIMER_ID 13
00026 class cAnimWnd : public CWnd
00027 {
00028 // Construction
00029 public:
00030         cAnimWnd();
00031
00032 // Attributes
00033 public:
00034
00035 protected:
00036    int            m_ImageIndex;
00037    COLORREF       m_TransparentColor;
00038    short          m_Width;
00039    short          m_Height;
00040    CBitmap        m_Bitmap;
00041    cMemDC         *m_MemDC;
00042
00043 // Operations
00044 public:
00045    void SetImageList(UINT BitmapID, short Size, short Sizey, COLORREF TransparentColor = -1);
00046
00047 // Overrides
00048         // ClassWizard generated virtual function overrides
00049         //{{AFX_VIRTUAL(cAnimWnd)
00050         public:
00051         virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
00052         //}}AFX_VIRTUAL
00053
00054 // Implementation
00055 public:
00056         int GetImageCount();
00057         BOOL StopAnim();
00058         INT_PTR StartAnim(short Delay = 50);
00059         virtual ~cAnimWnd();
00060
00061         // Generated message map functions
00062 protected:
00063         //{{AFX_MSG(cAnimWnd)
00064         afx_msg void OnTimer(UINT nIDEvent);
00065         afx_msg void OnPaint();
00066         //}}AFX_MSG
00067         DECLARE_MESSAGE_MAP()
00068 };
00069
00071
00072 //{{AFX_INSERT_LOCATION}}
00073 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00074
00075 #endif // !defined(AFX_cANIMWND_H__7F9C97E1_F7F4_11D2_837C_00500406DAEB__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/AsciiCmdUtilities.cpp Source File

DeviceIO/AsciiCmdUtilities.cpp
Go to the documentation of this file.
00001 #include "AsciiCmdUtilities.h"
00002
00003 CAsciiCmdUtilities::CAsciiCmdUtilities(void)
00004 {
00005 }
00006
00007 CAsciiCmdUtilities::~CAsciiCmdUtilities(void)
00008 {
00009 }
00010
00011 string CAsciiCmdUtilities::MakeUpper(string StdString)
00012 {
00013   const int length = (int)StdString.length();
00014   for(int i=0; i<length ; ++i)
00015   {
00016     StdString[i] = std::toupper(StdString[i]);
00017   }
00018   return StdString;
00019 }
00020
00021 string CAsciiCmdUtilities::RemWhitespace(string strLine)
00022 {
00023         unsigned int idxCh;
00024         string strCh;
00025         string strNoWSp;
00026
00027         strNoWSp = "";
00028         if (strLine.find_first_of(Whitespace, 0) == std::string::npos) {                // string has no whitespace
00029                 return strLine;
00030         } else {                        // remove whitespace
00031                 for (idxCh=0;idxCh<strLine.length();idxCh++) {
00032                         strCh = strLine.substr(idxCh,1);
00033                         if (strCh.find_first_of(Whitespace, 0) == std::string::npos) {          // char is not whitespace
00034                                 strNoWSp += strCh;
00035                         }
00036                 }
00037                 return strNoWSp;
00038         }
00039 }
00040
00041 //read and format [DP5 Configuration File]
00042 string CAsciiCmdUtilities::GetDP5CfgStr(string strFilename)
00043 {
00044         FILE *txtFile;
00045         char chLine[LINE_MAX];
00046         string strCfg;
00047         string strLine;
00048         long lPos;
00049         char ch;
00050         bool bCfgSection;
00051         int iCmpCfg;
00052         long lPosCfg;
00053         stringex strfn;
00054
00055         bCfgSection = false;
00056         iCmpCfg = 1;
00057         if (( txtFile = fopen(strFilename.c_str(), "r")) == NULL) {  // Can't open input file
00058                 return "";
00059         }
00060         strCfg = "";
00061         while((fgets(chLine, LINE_MAX, txtFile)) != NULL) {
00062                 strLine = strfn.Format("%s",chLine);
00063                 lPosCfg = (long)strLine.find('[');                              // find a section (-1=not found,0=section found,>0=undefined)
00064                 if (lPosCfg == 0) {                                                             // Locate DP5 Configuration Section
00065                         iCmpCfg = (long)strLine.find("[DP5 Configuration File]");
00066                         if (iCmpCfg == 0) {                                                     // Configuration Section Found
00067                                 bCfgSection = true;
00068                         } else {                                                                        // Non-Configuration Section Found
00069                                 bCfgSection = false;
00070                         }
00071                 }
00072                 if (bCfgSection) {                                                              // Save Configuration Section Only
00073                         strLine = MakeUpper(strLine);                           // make all uppercase
00074                         lPos = (long)strLine.find(';');                         // find the delimiter (-1=not found,0=commented line)
00075                         if (lPos > 0) {                                                         // if has delimiter that is not first char
00076                                 strLine = strLine.substr(0,lPos + 1);   // remove string right of delimiter
00077                                 ch = strLine.at(0);
00078                                 if ((ch >= 'A') && (ch <= 'Z')) {               // if is valid value
00079                                         strLine = RemWhitespace(strLine);       // remove whitespace in command sequence
00080                                         if (strLine.length() > 1) {                     // check if command w/delimiter left
00081                                                 strCfg += strLine;                              // add to command string
00082                                         }
00083                                 }
00084                         }
00085                 }
00086                 strLine = "";
00087         }
00088         fclose(txtFile);
00089         if (strCfg.length() > 0) {
00090                 return strCfg;
00091         } else {
00092                 return "";
00093         }
00094 }
00095
00096 //read and format [DP5 SCA Configuration]
00097 string CAsciiCmdUtilities::GetDP5ScaStr(string strFilename)
00098 {
00099         FILE *txtFile;
00100         char chLine[LINE_MAX];
00101         string strCfg;
00102         string strLine;
00103         long lPos;
00104         char ch;
00105         bool bCfgSection;
00106         int iCmpCfg;
00107         long lPosCfg;
00108         stringex strfn;
00109         char chScaOld;
00110         char chSCA;
00111         int iScaBytes;
00112         string strScaIdx;
00113         string strScaCmd = "";
00114
00115         bCfgSection = false;
00116         iCmpCfg = 1;
00117         if (( txtFile = fopen(strFilename.c_str(), "r")) == NULL) {  // Can't open input file
00118                 return "";
00119         }
00120         chScaOld = '0';
00121         chSCA = '9';
00122         strCfg = "";
00123         while((fgets(chLine, LINE_MAX, txtFile)) != NULL) {
00124                 strLine = strfn.Format("%s",chLine);
00125                 lPosCfg = (long)strLine.find('[');                              // find a section (-1=not found,0=section found,>0=undefined)
00126                 if (lPosCfg == 0) {                                                             // Locate DP5 Configuration Section
00127                         iCmpCfg = (long)strLine.find("[DP5 SCA Configuration]");
00128                         if (iCmpCfg == 0) {                                                     // Configuration Section Found
00129                                 bCfgSection = true;
00130                         } else {                                                                        // Non-Configuration Section Found
00131                                 bCfgSection = false;
00132                         }
00133                 }
00134                 if (bCfgSection) {                                                              // Save Configuration Section Only
00135                         strLine = MakeUpper(strLine);                           // make all uppercase
00136                         lPos = (long)strLine.find(';');                         // find the delimiter (-1=not found,0=commented line)
00137                         if (lPos > 0) {                                                         // if has delimiter that is not first char
00138                                 strLine = strLine.substr(0,lPos + 1);   // remove string right of delimiter
00139                                 ch = strLine.at(0);
00140                                 if ((ch >= 'A') && (ch <= 'Z')) {               // if is valid value
00141                                         strLine = RemWhitespace(strLine);       // remove whitespace in command sequence
00142                                         if (strLine.length() > 1) {                     // check if command w/delimiter left
00143                                                 //strCfg += strLine;                            // add to command string
00144                                                 //strcat(strCfg,chLine);                                // add to command string
00145                                                 chSCA = strLine.at(4);                          // determine SCA Index
00146                                                 // remove index from SCA Command to create DPP ASCII Command format
00147                                                 if ((chSCA > '0') && (chSCA < '9')) {
00148                                                         if (chSCA != chScaOld) {                // Is same as current index?
00149                                                                 chScaOld = chSCA;                       // if no, save current index
00150                                                                 // insert index command into string (SCAI=%c;)
00151                                                                 strScaIdx = strfn.Format("SCAI=%c;",chSCA);
00152                                                                 strCfg += strScaIdx;                            // add sca index command to string
00153                                                                 strScaIdx = "";
00154                                                         }
00155                                                         strScaCmd = strLine.substr(0,4);
00156                                                         for (iScaBytes=5;iScaBytes<=lPos;iScaBytes++) {
00157                                                                 strScaCmd += strLine.at(iScaBytes);
00158                                                         }
00159                                                         strCfg += strScaCmd;                            // add to command string
00160                                                 } else {        // no index to remove, cmd was saved with SCAI command
00161                                                         strCfg += strLine;                                      // add to command string
00162                                                 }
00163                                         }
00164                                 }
00165                         }
00166                 }
00167                 strLine = "";
00168         }
00169         fclose(txtFile);
00170         if (strCfg.length() > 0) {
00171                 return strCfg;
00172         } else {
00173                 return "";
00174         }
00175 }
00176
00177 string CAsciiCmdUtilities::CreateResTestReadBackCmd(bool bSendCoarseFineGain, int DppType)
00178 {
00179         string strCfg("");
00180     bool isINOF;
00181
00182     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00183         strCfg = "";
00184         strCfg += "CLCK=?;";
00185         strCfg += "TPEA=?;";
00186         if (bSendCoarseFineGain) { strCfg += "GAIF=?;"; }
00187         if (!bSendCoarseFineGain) { strCfg += "GAIN=?;"; }
00188         strCfg += "RESL=?;";
00189         strCfg += "TFLA=?;";
00190         strCfg += "TPFA=?;";
00191         strCfg += "PURE=?;";
00192         strCfg += "RTDE=?;";
00193         strCfg += "MCAS=?;";
00194         strCfg += "MCAC=?;";
00195         strCfg += "SOFF=?;";
00196         strCfg += "AINP=?;";
00197         if (isINOF) { strCfg += "INOF=?;"; }
00198         if (bSendCoarseFineGain) { strCfg += "GAIA=?;"; }
00199         return strCfg;
00200 }
00201
00202 string CAsciiCmdUtilities::CreateFullReadBackCmd(bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
00203 {
00204         string strCfg("");
00205     bool isHVSE;
00206     bool isPAPS;
00207     bool isTECS;
00208     bool isVOLU;
00209         bool isCON1;
00210         bool isCON2;
00211     bool isINOF;
00212     bool isBOOT;
00213         bool isGATE;
00214     bool isPAPZ;
00215         bool isSCTC;
00216         bool isDP5_DxK=false;
00217         bool isDP5_DxL=false;
00218
00219         if (DppType == dppMCA8000D) {
00220                 strCfg = CreateFullReadBackCmdMCA8000D(DppType);
00221                 return strCfg;
00222         }
00223
00224         // DP5 Rev Dx K,L needs PAPZ
00225         if ((DppType == dppDP5) && isDP5_RevDxGains) {
00226                 if ((DPP_ECO & 0x0F) == 0x0A) {
00227                         isDP5_DxK = true;
00228                 }
00229                 if ((DPP_ECO & 0x0F) == 0x0B) {
00230                         isDP5_DxL = true;
00231                 }
00232         }
00233
00234     isHVSE = (((DppType != dppPX5) && PC5_PRESENT) || DppType == dppPX5);
00235     isPAPS = (DppType != dppDP5G) && (DppType != dppTB5);
00236     isTECS = (((DppType == dppDP5) && PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00237     isVOLU = (DppType == dppPX5);
00238     isCON1 = ((DppType != dppDP5) && (DppType != dppDP5X));
00239     isCON2 = ((DppType != dppDP5) && (DppType != dppDP5X));
00240     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00241     isSCTC = (DppType == dppDP5G) || (DppType == dppTB5);
00242     isBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00243         isGATE = ((DppType == dppDP5) || (DppType == dppDP5X));
00244         isPAPZ = (DppType == dppPX5) || isDP5_DxK || isDP5_DxL;
00245
00246         strCfg = "";
00247         strCfg += "RESC=?;";
00248         strCfg += "CLCK=?;";
00249         strCfg += "TPEA=?;";
00250         strCfg += "GAIF=?;";
00251         strCfg += "GAIN=?;";
00252         strCfg += "RESL=?;";
00253         strCfg += "TFLA=?;";
00254         strCfg += "TPFA=?;";
00255         strCfg += "PURE=?;";
00256         if (isSCTC) { strCfg += "SCTC=?;"; }
00257         strCfg += "RTDE=?;";
00258         strCfg += "MCAS=?;";
00259         strCfg += "MCAC=?;";
00260         strCfg += "SOFF=?;";
00261         strCfg += "AINP=?;";
00262         if (isINOF) { strCfg += "INOF=?;"; }
00263         strCfg += "GAIA=?;";
00264         strCfg += "CUSP=?;";
00265         strCfg += "PDMD=?;";
00266         strCfg += "THSL=?;";
00267         strCfg += "TLLD=?;";
00268         strCfg += "THFA=?;";
00269         strCfg += "DACO=?;";
00270         strCfg += "DACF=?;";
00271         strCfg += "RTDS=?;";
00272         strCfg += "RTDT=?;";
00273         strCfg += "BLRM=?;";
00274         strCfg += "BLRD=?;";
00275         strCfg += "BLRU=?;";
00276         if (isGATE) { strCfg += "GATE=?;"; }
00277         strCfg += "AUO1=?;";
00278         strCfg += "PRET=?;";
00279         strCfg += "PRER=?;";
00280         strCfg += "PREC=?;";
00281         strCfg += "PRCL=?;";
00282         strCfg += "PRCH=?;";
00283         if (isHVSE) { strCfg += "HVSE=?;"; }
00284         if (isTECS) { strCfg += "TECS=?;"; }
00285         if (isPAPZ) { strCfg += "PAPZ=?;"; }
00286         if (isPAPS) { strCfg += "PAPS=?;"; }
00287         strCfg += "SCOE=?;";
00288         strCfg += "SCOT=?;";
00289         strCfg += "SCOG=?;";
00290         strCfg += "MCSL=?;";
00291         strCfg += "MCSH=?;";
00292         strCfg += "MCST=?;";
00293         strCfg += "AUO2=?;";
00294         strCfg += "TPMO=?;";
00295         strCfg += "GPED=?;";
00296         strCfg += "GPIN=?;";
00297         strCfg += "GPME=?;";
00298         strCfg += "GPGA=?;";
00299         strCfg += "GPMC=?;";
00300         strCfg += "MCAE=?;";
00301         if (isVOLU) { strCfg += "VOLU=?;"; }
00302         if (isCON1) { strCfg += "CON1=?;"; }
00303         if (isCON2) { strCfg += "CON2=?;"; }
00304         if (isBOOT) { strCfg += "BOOT=?;"; }
00305         return strCfg;
00306 }
00307
00308 string CAsciiCmdUtilities::CreateFullReadBackCmdMCA8000D(int DppType)
00309 {
00310         string strCfg("");
00311
00312         if (DppType == dppMCA8000D) {
00313                 strCfg += "RESC=?;";
00314                 strCfg += "PURE=?;";
00315                 strCfg += "MCAS=?;";
00316                 strCfg += "MCAC=?;";
00317                 strCfg += "SOFF=?;";
00318                 strCfg += "GAIA=?;";
00319                 strCfg += "PDMD=?;";
00320                 strCfg += "THSL=?;";
00321                 strCfg += "TLLD=?;";
00322                 strCfg += "GATE=?;";
00323                 strCfg += "AUO1=?;";
00324                 //strCfg += "PRET=?;";
00325                 strCfg += "PRER=?;";
00326                 strCfg += "PREL=?;";
00327                 strCfg += "PREC=?;";
00328                 strCfg += "PRCL=?;";
00329                 strCfg += "PRCH=?;";
00330                 strCfg += "SCOE=?;";
00331                 strCfg += "SCOT=?;";
00332                 strCfg += "SCOG=?;";
00333                 strCfg += "MCSL=?;";
00334                 strCfg += "MCSH=?;";
00335                 strCfg += "MCST=?;";
00336                 strCfg += "AUO2=?;";
00337                 strCfg += "GPED=?;";
00338                 strCfg += "GPIN=?;";
00339                 strCfg += "GPME=?;";
00340                 strCfg += "GPGA=?;";
00341                 strCfg += "GPMC=?;";
00342                 strCfg += "MCAE=?;";
00343                 //strCfg += "VOLU=?;";
00344                 //strCfg += "CON1=?;";
00345                 //strCfg += "CON2=?;";
00346                 strCfg += "PDMD=?;";
00347         }
00348         return strCfg;
00349 }
00350
00351 string CAsciiCmdUtilities::RemoveCmd(string strCmd, string strCfgData)
00352 {
00353         int iStart,iEnd,iCmd;
00354         string strNew;
00355
00356         strNew = "";
00357         if (strCfgData.length() < 7) { return strCfgData; }     // no data
00358         if (strCmd.length() != 4) {     return strCfgData; }            // bad command
00359         iCmd = (int)strCfgData.find(strCmd+"=",0);
00360         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
00361         iStart = iCmd;
00362         iEnd = (int)strCfgData.find(";",iCmd);
00363         if (iEnd == -1) { return strCfgData; }                                          // end not found
00364         if (iEnd <= iStart) { return strCfgData; }                                      // unknown error
00365         strNew = strCfgData.substr(0,iStart) + strCfgData.substr(iEnd+1);
00366         return strNew;
00367 }
00368
00370 string CAsciiCmdUtilities::RemoveCmdByDeviceType(string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
00371 {
00372         string strCfgData;
00373     bool isHVSE;
00374     bool isPAPS;
00375     bool isTECS;
00376     bool isVOLU;
00377         bool isCON1;
00378         bool isCON2;
00379     bool isINOF;
00380     bool isBOOT;
00381         bool isGATE;
00382         bool isPAPZ;
00383         bool isSCTC;
00384         bool isPREL;
00385         bool isDP5_DxK=false;
00386         bool isDP5_DxL=false;
00387
00388         strCfgData = strCfgDataIn;
00389         if (DppType == dppMCA8000D) {
00390                 strCfgData = Remove_MCA8000D_Cmds(strCfgData,DppType);
00391                 return strCfgData;
00392         }
00393
00394         // DP5 Rev Dx K,L needs PAPZ
00395         if ((DppType == dppDP5) && isDP5_RevDxGains) {
00396                 if ((DPP_ECO & 0x0F) == 0x0A) {
00397                         isDP5_DxK = true;
00398                 }
00399                 if ((DPP_ECO & 0x0F) == 0x0B) {
00400                         isDP5_DxL = true;
00401                 }
00402         }
00403
00404     isHVSE = (((DppType != dppPX5) && PC5_PRESENT) || DppType == dppPX5);
00405     isPAPS = (DppType != dppDP5G) && (DppType != dppTB5);
00406     isTECS = (((DppType == dppDP5) && PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00407     isVOLU = (DppType == dppPX5);
00408     isCON1 = ((DppType != dppDP5) && (DppType != dppDP5X));
00409     isCON2 = ((DppType != dppDP5) && (DppType != dppDP5X));
00410     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00411         isSCTC = (DppType == dppDP5G) || (DppType == dppTB5);
00412     isBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00413         isGATE = ((DppType == dppDP5) || (DppType == dppDP5X));
00414         isPAPZ = (DppType == dppPX5) || isDP5_DxK || isDP5_DxL;
00415         isPREL = (DppType == dppMCA8000D);
00416         if (!isHVSE) { strCfgData = RemoveCmd("HVSE", strCfgData); }  //High Voltage Bias
00417         if (!isPAPS) { strCfgData = RemoveCmd("PAPS", strCfgData); }  //Preamp Voltage
00418         if (!isTECS) { strCfgData = RemoveCmd("TECS", strCfgData); }  //Cooler Temperature
00419         if (!isVOLU) { strCfgData = RemoveCmd("VOLU", strCfgData); }  //px5 speaker
00420         if (!isCON1) { strCfgData = RemoveCmd("CON1", strCfgData); }  //connector 1
00421         if (!isCON2) { strCfgData = RemoveCmd("CON2", strCfgData); }  //connector 2
00422         if (!isINOF) { strCfgData = RemoveCmd("INOF", strCfgData); }  //input offset
00423         if (!isBOOT) { strCfgData = RemoveCmd("BOOT", strCfgData); }  //PC5 On At StartUp
00424         if (!isGATE) { strCfgData = RemoveCmd("GATE", strCfgData); }  //Gate input
00425         if (!isPAPZ) { strCfgData = RemoveCmd("PAPZ", strCfgData); }  //Pole-Zero
00426         if (!isSCTC) { strCfgData = RemoveCmd("SCTC", strCfgData); }  //Scintillator Time Constant
00427         if (!isPREL) { strCfgData = RemoveCmd("PREL", strCfgData); }  //Preset Live Time
00428         return strCfgData;
00429 }
00430
00432 string CAsciiCmdUtilities::RemoveCmdByDeviceTypeDP5DxK(string strCfgDataIn, bool PC5_PRESENT, int DppType)
00433 {
00434         string strCfgData;
00435     bool isHVSE;
00436     bool isPAPS;
00437     bool isTECS;
00438     bool isVOLU;
00439         bool isCON1;
00440         bool isCON2;
00441     bool isINOF;
00442     bool isBOOT;
00443         bool isGATE;
00444         bool isPAPZ;
00445         bool isSCTC;
00446         bool isPREL;
00447
00448         strCfgData = strCfgDataIn;
00449         //if (DppType == dppMCA8000D) {
00450         //      strCfgData = Remove_MCA8000D_Cmds(strCfgData,DppType);
00451         //      return strCfgData;
00452         //}
00453     isHVSE = (((DppType != dppPX5) && PC5_PRESENT) || DppType == dppPX5);
00454     isPAPS = (DppType != dppDP5G) && (DppType != dppTB5);
00455     isTECS = (((DppType == dppDP5) && PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00456     isVOLU = (DppType == dppPX5);
00457     isCON1 = ((DppType != dppDP5) && (DppType != dppDP5X));
00458     isCON2 = ((DppType != dppDP5) && (DppType != dppDP5X));
00459     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00460         isSCTC = (DppType == dppDP5G) || (DppType == dppTB5);
00461     isBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00462         isGATE = ((DppType == dppDP5) || (DppType == dppDP5X));
00463         //isPAPZ = (DppType == dppPX5);         // DP5 Rev Dx K,L needs PAPZ
00464         isPAPZ = true;                                                  // DP5 Rev Dx K,L needs PAPZ
00465         isPREL = (DppType == dppMCA8000D);
00466         if (!isHVSE) { strCfgData = RemoveCmd("HVSE", strCfgData); }  //High Voltage Bias
00467         if (!isPAPS) { strCfgData = RemoveCmd("PAPS", strCfgData); }  //Preamp Voltage
00468         if (!isTECS) { strCfgData = RemoveCmd("TECS", strCfgData); }  //Cooler Temperature
00469         if (!isVOLU) { strCfgData = RemoveCmd("VOLU", strCfgData); }  //px5 speaker
00470         if (!isCON1) { strCfgData = RemoveCmd("CON1", strCfgData); }  //connector 1
00471         if (!isCON2) { strCfgData = RemoveCmd("CON2", strCfgData); }  //connector 2
00472         if (!isINOF) { strCfgData = RemoveCmd("INOF", strCfgData); }  //input offset
00473         if (!isBOOT) { strCfgData = RemoveCmd("BOOT", strCfgData); }  //PC5 On At StartUp
00474         if (!isGATE) { strCfgData = RemoveCmd("GATE", strCfgData); }  //Gate input
00475         if (!isPAPZ) { strCfgData = RemoveCmd("PAPZ", strCfgData); }  //Pole-Zero
00476         if (!isSCTC) { strCfgData = RemoveCmd("SCTC", strCfgData); }  //Scintillator Time Constant
00477         if (!isPREL) { strCfgData = RemoveCmd("PREL", strCfgData); }  //Preset Live Time
00478         return strCfgData;
00479 }
00480
00482 string CAsciiCmdUtilities::Remove_MCA8000D_Cmds(string strCfgDataIn, int DppType)
00483 {
00484         string strCfgData;
00485
00486         strCfgData = strCfgDataIn;
00487         if (DppType == dppMCA8000D) {
00488                 strCfgData = RemoveCmd("CLCK", strCfgData);
00489                 strCfgData = RemoveCmd("TPEA", strCfgData);
00490                 strCfgData = RemoveCmd("GAIF", strCfgData);
00491                 strCfgData = RemoveCmd("GAIN", strCfgData);
00492                 strCfgData = RemoveCmd("RESL", strCfgData);
00493                 strCfgData = RemoveCmd("TFLA", strCfgData);
00494                 strCfgData = RemoveCmd("TPFA", strCfgData);
00495                 //strCfgData = RemoveCmd("PURE", strCfgData);
00496                 strCfgData = RemoveCmd("RTDE", strCfgData);
00497                 strCfgData = RemoveCmd("AINP", strCfgData);
00498                 strCfgData = RemoveCmd("INOF", strCfgData);
00499                 strCfgData = RemoveCmd("CUSP", strCfgData);
00500                 strCfgData = RemoveCmd("THFA", strCfgData);
00501                 strCfgData = RemoveCmd("DACO", strCfgData);
00502                 strCfgData = RemoveCmd("DACF", strCfgData);
00503                 strCfgData = RemoveCmd("RTDS", strCfgData);
00504                 strCfgData = RemoveCmd("RTDT", strCfgData);
00505                 strCfgData = RemoveCmd("BLRM", strCfgData);
00506                 strCfgData = RemoveCmd("BLRD", strCfgData);
00507                 strCfgData = RemoveCmd("BLRU", strCfgData);
00508                 strCfgData = RemoveCmd("PRET", strCfgData);
00509                 strCfgData = RemoveCmd("HVSE", strCfgData);
00510                 strCfgData = RemoveCmd("TECS", strCfgData);
00511                 strCfgData = RemoveCmd("PAPZ", strCfgData);
00512                 strCfgData = RemoveCmd("PAPS", strCfgData);
00513                 strCfgData = RemoveCmd("TPMO", strCfgData);
00514                 strCfgData = RemoveCmd("SCAH", strCfgData);
00515                 strCfgData = RemoveCmd("SCAI", strCfgData);
00516                 strCfgData = RemoveCmd("SCAL", strCfgData);
00517                 strCfgData = RemoveCmd("SCAO", strCfgData);
00518                 strCfgData = RemoveCmd("SCAW", strCfgData);
00519                 strCfgData = RemoveCmd("BOOT", strCfgData);
00520
00521                 // added to list late, recheck at later date 20120817
00522                 strCfgData = RemoveCmd("CON1", strCfgData);
00523                 strCfgData = RemoveCmd("CON2", strCfgData);
00524
00525                 // not implemented as of 20120817, will be implemented at some time
00526                 strCfgData = RemoveCmd("VOLU", strCfgData);
00527         }
00528         return strCfgData;
00529 }
00530
00531 // replaces all occurrences of substring in string
00532 std::string CAsciiCmdUtilities::ReplaceCmdText(std::string strInTextIn, std::string strFrom, std::string strTo)
00533 {
00534         std::string strReplaceText;
00535         std::string strInText;
00536         std::string strOutText;
00537         int lFromLen;
00538         int lMatchPos;
00539
00540         strInText = strInTextIn;
00541         strOutText = "";
00542         lFromLen = (int)strFrom.length();
00543         while (strInText.length()>0) {
00544                 lMatchPos = (1+(int)strInText.find(strFrom));
00545                 if (lMatchPos==0) {
00546                         strOutText = strOutText+strInText;
00547                         strInText = "";
00548                 } else {
00549                         strOutText = strOutText+strInText.substr(0,lMatchPos-1)+strTo;
00550                         strInText = std::string(strInText).substr(lMatchPos+lFromLen-1);
00551                 }
00552         }
00553         strReplaceText = strOutText;
00554         return strReplaceText;
00555 }
00556
00557 // breaks ASCII Command string into two chuncks, returns split position
00558 int CAsciiCmdUtilities::GetCmdChunk(std::string strCmd)
00559 {
00560         int GetCmdChunk = 0;
00561         int idxCfg;
00562         int lChunk;
00563         int lEnd;
00564         GetCmdChunk = 0;
00565         lChunk = 0;
00566         lEnd = 0;
00567         for(idxCfg=1; idxCfg<=(int)strCmd.length();idxCfg++) {
00568                 lChunk = (int)(1+strCmd.find(";", lEnd));
00569                 if ((lChunk==0) || (lChunk>512)) {
00570                         break;
00571                 }
00572                 lEnd = lChunk;
00573         }
00574         GetCmdChunk = lEnd;
00575         return GetCmdChunk;
00576 }
00577
00578 bool CAsciiCmdUtilities::CopyAsciiData(unsigned char Data[], string strCfg, long lLen)
00579 {
00580         long idxData;
00581         const char *c_str1 = strCfg.c_str();
00582
00583         if (lLen > 0) {
00584                 for(idxData=0;idxData<lLen;idxData++) {
00585                         Data[idxData] = c_str1[idxData];
00586                 }
00587                 return true;
00588         } else {
00589                 return false;
00590         }
00591         return false;
00592 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/AsciiCmdUtilities.h Source File

DeviceIO/AsciiCmdUtilities.h
Go to the documentation of this file.
00001 #pragma once
00002 #include <stdlib.h>
00003 #include <stdio.h>
00004 #include <math.h>
00005 #include <string>
00006 #include <cctype> // std::toupper, std::tolower
00007 using namespace std;
00008 #include "stringex.h"
00009 #include "DppConst.h"
00010
00011 #ifndef LINE_MAX
00012         #define LINE_MAX 256
00013 #endif
00014 #define DP4_PX4_OLD_CFG_SIZE 64
00015 #define DP5_MAX_CFG_SIZE 512            /// 512 + 8 Bytes (2 SYNC,2 PID,2 LEN,2 CHKSUM)
00016 #define Whitespace "\t\n\v\f\r\0x20"    /// $ = Chr$(0) + Chr$(9) + Chr$(10) + Chr$(11) + Chr$(12) + Chr$(13) + Chr$(32)
00017
00018 class CAsciiCmdUtilities
00019 {
00020 public:
00021         CAsciiCmdUtilities(void);
00022         ~CAsciiCmdUtilities(void);
00024         std::string MakeUpper(std::string myString);
00026         std::string RemWhitespace(std::string strLine);
00028         std::string GetDP5CfgStr(std::string strFilename);
00030         std::string GetDP5ScaStr(std::string strFilename);
00031         std::string CreateResTestReadBackCmd(bool bSendCoarseFineGain, int DppType);
00033         std::string CreateFullReadBackCmd(bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO);
00035         std::string CreateFullReadBackCmdMCA8000D(int DppType);
00037         std::string RemoveCmd(std::string strCmd, std::string strCfgData);
00039         std::string RemoveCmdByDeviceType(std::string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO);
00041         std::string RemoveCmdByDeviceTypeDP5DxK(std::string strCfgDataIn, bool PC5_PRESENT, int DppType);
00043         std::string Remove_MCA8000D_Cmds(std::string strCfgDataIn, int DppType);
00044         // replaces all occurrences of substring in string
00045         std::string ReplaceCmdText(std::string strInTextIn, std::string strFrom, std::string strTo);
00046         // breaks ASCII Command string into two chuncks, returns split position
00047         int GetCmdChunk(std::string strCmd);
00049         bool CopyAsciiData(unsigned char Data[], string strCfg, long lLen);
00050 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/CmdWaitDlg.cpp Source File

waitdlg/CmdWaitDlg.cpp
Go to the documentation of this file.
00001 // cWaitDialog.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "WaitDialog.h"
00006 #include "CmdWaitDlg.h"
00007
00008 //#ifdef _DEBUG
00009 //#define new DEBUG_NEW
00010 //#undef THIS_FILE
00011 //static char THIS_FILE[] = __FILE__;
00012 //#endif
00013
00015 // cWaitDialog
00016
00017 IMPLEMENT_DYNCREATE(cWaitDialog, CCmdTarget)
00018
00019 cWaitDialog::cWaitDialog()
00020 {
00021    m_bShowCancelButton = false;
00022    m_Text = "";
00023    m_EventName = "";
00024 }
00025
00026 cWaitDialog::~cWaitDialog()
00027 {
00028 }
00029
00030
00031 BEGIN_MESSAGE_MAP(cWaitDialog, CCmdTarget)
00032         //{{AFX_MSG_MAP(cWaitDialog)
00033                 // NOTE - the ClassWizard will add and remove mapping macros here.
00034         //}}AFX_MSG_MAP
00035 END_MESSAGE_MAP()
00036
00038 // cWaitDialog message handlers
00039
00040 void cWaitDialog::Show()
00041 {
00042    m_Event = CreateEvent(NULL, TRUE, FALSE, m_EventName);
00043    m_Thread = (cWaitDlgThread *)AfxBeginThread(RUNTIME_CLASS(cWaitDlgThread), THREAD_PRIORITY_NORMAL, 0, CREATE_SUSPENDED);
00044    m_Thread->m_Eventname = m_EventName;
00045    m_Thread->m_Text = m_Text;
00046    m_Thread->m_bShowCancelButton = m_bShowCancelButton;
00047    m_Thread->ResumeThread();
00048
00049 }
00050
00051 void cWaitDialog::Close()
00052 {
00053    m_Thread->m_Event->SetEvent();
00054    CloseHandle(m_Event);
00055 }
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/CmdWaitDlg.h Source File

waitdlg/CmdWaitDlg.h
Go to the documentation of this file.
00001 #if !defined(AFX_cWAITDIALOG_H__25FAD201_F98F_11D2_8127_F91DB0F31875__INCLUDED_)
00002 #define AFX_cWAITDIALOG_H__25FAD201_F98F_11D2_8127_F91DB0F31875__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // cWaitDialog.h : header file
00008 //
00010 // Author: Todd Andrews
00011 // Email:  tmandrews@mindspring.com
00012 // Copyright 1999, Todd Andrews
00013 //
00014 // You may freely use or modify this code provided this
00015 // Copyright is included in all derived versions.
00016 //
00017 //
00018 // This class implements a wrapper for a worker thread and dialog
00019
00020 #include "WaitDlgThread.h"
00021
00023 // cWaitDialog command target
00024
00025 class cWaitDialog : public CCmdTarget
00026 {
00027         DECLARE_DYNCREATE(cWaitDialog)
00028
00029         cWaitDialog();           // protected constructor used by dynamic creation
00030
00031 // Attributes
00032 public:
00033         cWaitDlgThread     *m_Thread;
00034         bool                          m_bShowCancelButton;
00035    HANDLE            m_Event;
00036    CString           m_Text;
00037    CString           m_EventName;
00038
00039 // Operations
00040 public:
00041         void Close();
00042         void Show();
00043
00044 // Overrides
00045         // ClassWizard generated virtual function overrides
00046         //{{AFX_VIRTUAL(cWaitDialog)
00047         //}}AFX_VIRTUAL
00048
00049 // Implementation
00050 public:
00051    virtual ~cWaitDialog();
00052 protected:
00053
00054         // Generated message map functions
00055         //{{AFX_MSG(cWaitDialog)
00056                 // NOTE - the ClassWizard will add and remove member functions here.
00057         //}}AFX_MSG
00058
00059         DECLARE_MESSAGE_MAP()
00060 };
00061
00063
00064 //{{AFX_INSERT_LOCATION}}
00065 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00066
00067 #endif // !defined(AFX_cWAITDIALOG_H__25FAD201_F98F_11D2_8127_F91DB0F31875__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Protocol.cpp Source File

DeviceIO/DP5Protocol.cpp
Go to the documentation of this file.
00001 #include "DP5Protocol.h"
00002
00003 CDP5Protocol::CDP5Protocol(void)
00004 {
00005 }
00006
00007 CDP5Protocol::~CDP5Protocol(void)
00008 {
00009 }
00010
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Protocol.h Source File

DeviceIO/DP5Protocol.h
Go to the documentation of this file.
00001
00002 #pragma once
00003 #include <math.h>
00004
00005 enum TRANSMIT_PACKET_TYPE {
00006      //REQUEST_PACKETS_TO_DP5
00007         XMTPT_SEND_STATUS,
00008     XMTPT_SEND_SPECTRUM,
00009     XMTPT_SEND_CLEAR_SPECTRUM,
00010     XMTPT_SEND_SPECTRUM_STATUS,
00011     XMTPT_SEND_CLEAR_SPECTRUM_STATUS,
00012     XMTPT_BUFFER_SPECTRUM,
00013     XMTPT_BUFFER_CLEAR_SPECTRUM,
00014     XMTPT_SEND_BUFFER,
00015     XMTPT_SEND_DP4_STYLE_STATUS,
00016     XMTPT_SEND_PX4_CONFIG,
00017     XMTPT_SEND_SCOPE_DATA,
00018     XMTPT_SEND_512_BYTE_MISC_DATA,
00019     XMTPT_SEND_SCOPE_DATA_REARM,
00020     XMTPT_SEND_ETHERNET_SETTINGS,
00021     XMTPT_SEND_DIAGNOSTIC_DATA,
00022         XMTPT_SEND_NETFINDER_PACKET,
00023     XMTPT_SEND_HARDWARE_DESCRIPTION,
00024     XMTPT_SEND_SCA,
00025     XMTPT_LATCH_SEND_SCA,
00026     XMTPT_LATCH_CLEAR_SEND_SCA,
00027     XMTPT_SEND_ROI_OR_FIXED_BLOCK,
00028     XMTPT_PX4_STYLE_CONFIG_PACKET,
00029     XMTPT_SEND_CONFIG_PACKET_EX,
00030         XMTPT_SEND_CONFIG_PACKET_TO_HW,
00031     XMTPT_READ_CONFIG_PACKET,
00032     XMTPT_READ_CONFIG_PACKET_EX,
00033     XMTPT_FULL_READ_CONFIG_PACKET,
00034     XMTPT_SCA_READ_CONFIG_PACKET,
00035     XMTPT_ERASE_FPGA_IMAGE,
00036     XMTPT_UPLOAD_PACKET_FPGA,
00037     XMTPT_REINITIALIZE_FPGA,
00038     XMTPT_ERASE_UC_IMAGE_0,
00039     XMTPT_ERASE_UC_IMAGE_1,
00040     XMTPT_ERASE_UC_IMAGE_2,
00041     XMTPT_UPLOAD_PACKET_UC,
00042     XMTPT_SWITCH_TO_UC_IMAGE_0,
00043     XMTPT_SWITCH_TO_UC_IMAGE_1,
00044     XMTPT_SWITCH_TO_UC_IMAGE_2,
00045     XMTPT_UC_FPGA_CHECKSUMS,
00046
00047     //VENDOR_REQUESTS_TO_DP5
00048     XMTPT_CLEAR_SPECTRUM_BUFFER_A,
00049     XMTPT_ENABLE_MCA_MCS,
00050     XMTPT_DISABLE_MCA_MCS,
00051     XMTPT_ARM_DIGITAL_OSCILLOSCOPE,
00052     XMTPT_AUTOSET_INPUT_OFFSET,
00053     XMTPT_AUTOSET_FAST_THRESHOLD,
00054     XMTPT_READ_IO3_0,
00055     XMTPT_WRITE_IO3_0,
00056     XMTPT_WRITE_512_BYTE_MISC_DATA,
00057     XMTPT_SET_DCAL,
00058     XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ,
00059     XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC,
00060     XMTPT_SET_BOOT_FLAGS,
00061     XMTPT_SET_HV_DP4_EMULATION,
00062     XMTPT_SET_TEC_DP4_EMULATION,
00063     XMTPT_SET_INPUT_OFFSET_DP4_EMULATION,
00064     XMTPT_SET_ADC_CAL_GAIN_OFFSET,
00065     XMTPT_SET_SPECTRUM_OFFSET,
00066     XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS,
00067     XMTPT_SET_SERIAL_NUMBER,
00068     XMTPT_CLEAR_GP_COUNTER,
00069     XMTPT_SWITCH_SUPPLIES,
00070
00071     XMTPT_SEND_TEST_PACKET,
00072         XMTPT_REQ_ACK_PACKET,
00073         XMTPT_FORCE_SCOPE_TRIGGER,
00074         XMTPT_READ_MCA8000D_OPTION_PA_CAL,
00075         XMTPT_AU34_2_RESTART
00076 };  //TRANSMIT_PACKET_TYPE
00077
00078 //enum RECEIVE_PACKET_TYPE {
00079 //     //RESPONSE_PACKETS_FROM_DP5
00080 //    RCVPT_DP4_STYLE_STATUS,
00081 //    RCVPT_256_CHANNEL_SPECTRUM,
00082 //    RCVPT_256_CHANNEL_SPECTRUM_STATUS,
00083 //    RCVPT_512_CHANNEL_SPECTRUM,
00084 //    RCVPT_512_CHANNEL_SPECTRUM_STATUS,
00085 //    RCVPT_1024_CHANNEL_SPECTRUM,
00086 //    RCVPT_1024_CHANNEL_SPECTRUM_STATUS,
00087 //    RCVPT_2048_CHANNEL_SPECTRUM,
00088 //    RCVPT_2048_CHANNEL_SPECTRUM_STATUS,
00089 //    RCVPT_4096_CHANNEL_SPECTRUM,
00090 //    RCVPT_4096_CHANNEL_SPECTRUM_STATUS,
00091 //    RCVPT_8192_CHANNEL_SPECTRUM,
00092 //    RCVPT_8192_CHANNEL_SPECTRUM_STATUS,
00093 //    RCVPT_SCOPE_DATA,
00094 //    RCVPT_512_BYTE_MISC_DATA,
00095 //    RCVPT_IO3_0_STATE
00096 //};  //RECEIVE_PACKET_TYPE
00097
00098 enum PID1_TYPE {
00099     PID1_REQ_STATUS = 0x01,
00100     PID1_REQ_SPECTRUM = 0x02,
00101     PID1_REQ_SCOPE_MISC = 0x03,
00102     PID1_REQ_SCA = 0x04,
00103     PID1_REQ_CONFIG = 0x20,
00104     PID1_REQ_FPGA_UC = 0x30,
00105     PID1_RCV_STATUS = 0x80,
00106     PID1_RCV_SPECTRUM = 0x81,
00107     PID1_RCV_SCOPE_MISC = 0x82,
00108     PID1_RCV_SCA = 0x83,
00109     PID1_VENDOR_REQ = 0xF0,
00110         PID1_COMM_TEST = 0xF1,
00111     PID1_ACK = 0xFF
00112 };  //PID1_TYPE
00113
00114 enum PID2_REQ_STATUS_TYPE {
00115     PID2_SEND_DP4_STYLE_STATUS = 0x01
00116 };  //PID2_REQ_STATUS_TYPE
00117
00118 enum PID2_REQ_SPECTRUM_TYPE {
00119     // REQUEST_PACKETS_TO_DP5
00120     PID2_SEND_SPECTRUM = 0x01,
00121     PID2_SEND_CLEAR_SPECTRUM = 0x02,
00122     PID2_SEND_SPECTRUM_STATUS = 0x03,
00123     PID2_SEND_CLEAR_SPECTRUM_STATUS = 0x04
00124     //PID2_BUFFER_SPECTRUM,
00125     //PID2_BUFFER_CLEAR_SPECTRUM,
00126     //PID2_SEND_BUFFER,
00127     //PID2_SEND_CONFIG
00128 };  //PID2_REQ_SPECTRUM_TYPE
00129
00130 enum PID2_REQ_SCOPE_MISC_TYPE {
00131     PID2_SEND_SCOPE_DATA = 0x01,
00132     PID2_SEND_512_BYTE_MISC_DATA = 0x02,
00133     PID2_SEND_SCOPE_DATA_REARM = 0x03,
00134     PID2_SEND_ETHERNET_SETTINGS = 0x04,
00135     PID2_SEND_DIAGNOSTIC_DATA = 0x05,
00136     PID2_SEND_HARDWARE_DESCRIPTION = 0x06,
00137         PID2_SEND_NETFINDER_READBACK = 0x07,
00138         PID2_SEND_I2C_DATA = 0x08,
00139         PID2_SEND_LIST_MODE_DATA = 0x09,
00140         PID2_SEND_OPTION_PA_CALIBRATION = 0x0A
00141 };  //PID2_REQ_SCOPE_MISC_TYPE
00142
00143 enum PID2_REQ_SCA_TYPE {
00144     PID2_SEND_SCA = 0x01,
00145     PID2_LATCH_SEND_SCA = 0x02,
00146     PID2_LATCH_CLEAR_SEND_SCA = 0x03
00147 };  //PID2_REQ_SCA_TYPE
00148
00149 enum PID2_REQ_CONFIG_TYPE {
00150     PID2_PX4_STYLE_CONFIG_PACKET = 0x01,
00151     PID2_TEXT_CONFIG_PACKET = 0x02,
00152     PID2_CONFIG_READBACK_PACKET = 0x03
00153 };  //PID2_SEND_CONFIG_TYPE
00154
00155 enum PID2_REQ_FPGA_UC_TYPE {
00156     PID2_ERASE_FPGA_IMAGE = 0x01,
00157     PID2_UPLOAD_PACKET_FPGA = 0x02,
00158     PID2_REINITIALIZE_FPGA = 0x03,
00159     PID2_ERASE_UC_IMAGE_0 = 0x04,
00160     PID2_ERASE_UC_IMAGE_1 = 0x05,
00161     PID2_ERASE_UC_IMAGE_2 = 0x06,
00162     PID2_UPLOAD_PACKET_UC = 0x07,
00163     PID2_SWITCH_TO_UC_IMAGE_0 = 0x08,
00164     PID2_SWITCH_TO_UC_IMAGE_1 = 0x09,
00165     PID2_SWITCH_TO_UC_IMAGE_2 = 0x0A
00166     //PID2_UC_FPGA_CHECKSUMS
00167 };  //PID2_REQ_FPGA_UC_TYPE
00168
00169 enum PID2_VENDOR_REQ_TYPE {
00170     PID2_CLEAR_SPECTRUM_BUFFER_A = 0x01,
00171     PID2_ENABLE_MCA_MCS = 0x02,
00172     PID2_DISABLE_MCA_MCS = 0x03,
00173     PID2_ARM_DIGITAL_OSCILLOSCOPE = 0x04,
00174     PID2_AUTOSET_INPUT_OFFSET = 0x05,
00175     PID2_AUTOSET_FAST_THRESHOLD = 0x06,
00176     PID2_READ_IO3_0 = 0x07,
00177     PID2_WRITE_IO3_0 = 0x08,
00178     PID2_WRITE_512_BYTE_MISC_DATA = 0x09,
00179     PID2_SET_DCAL = 0x0A,
00180     PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ = 0x0B,
00181     PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC = 0x0C,
00182     PID2_SET_BOOT_FLAGS = 0x0D,
00183     //PID2_SET_HV_DP4_EMULATION
00184     //PID2_SET_TEC_DP4_EMULATION
00185     //PID2_SET_INPUT_OFFSET_DP4_EMULATION
00186     PID2_SET_ADC_CAL_GAIN_OFFSET = 0x0E,
00187     //PID2_SET_SPECTRUM_OFFSET
00188     //PID2_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS
00189     PID2_SET_SERIAL_NUMBER = 0x0F,
00190     PID2_CLEAR_GP_COUNTER = 0x10,
00191     PID2_SET_ETHERNET_SETTINGS = 0x11,
00192     //PID2_SWITCH_SUPPLIES
00193     PID2_ETHERNET_ALLOW_SHAREING = 0x20,
00194     PID2_ETHERNET_NO_SHARING = 0x21,
00195     PID2_ETHERNET_LOCK_IP = 0x22,
00196         PID2_GENERIC_FPGA_WRITE = 0x89
00197 };  //PID2_VENDOR_REQ_TYPE
00198
00199 enum PID2_RCV_STATUS_TYPE {
00200     RCVPT_DP4_STYLE_STATUS = 0x01
00201 };  //PID2_RCV_STATUS_TYPE
00202
00203 enum PID2_RCV_SPECTRUM_TYPE {
00204     RCVPT_256_CHANNEL_SPECTRUM = 0x01,
00205     RCVPT_256_CHANNEL_SPECTRUM_STATUS = 0x02,
00206     RCVPT_512_CHANNEL_SPECTRUM = 0x03,
00207     RCVPT_512_CHANNEL_SPECTRUM_STATUS = 0x04,
00208     RCVPT_1024_CHANNEL_SPECTRUM = 0x05,
00209     RCVPT_1024_CHANNEL_SPECTRUM_STATUS = 0x06,
00210     RCVPT_2048_CHANNEL_SPECTRUM = 0x07,
00211     RCVPT_2048_CHANNEL_SPECTRUM_STATUS = 0x08,
00212     RCVPT_4096_CHANNEL_SPECTRUM = 0x09,
00213     RCVPT_4096_CHANNEL_SPECTRUM_STATUS = 0x0A,
00214     RCVPT_8192_CHANNEL_SPECTRUM = 0x0B,
00215     RCVPT_8192_CHANNEL_SPECTRUM_STATUS = 0x0C
00216 };  //PID2_RCV_SPECTRUM_TYPE
00217
00218 enum PID2_RCV_SCOPE_MISC_TYPE {
00219     RCVPT_SCOPE_DATA = 0x01,
00220     RCVPT_512_BYTE_MISC_DATA = 0x02,
00221     RCVPT_SCOPE_DATA_WITH_OVERFLOW = 0x03,
00222     RCVPT_ETHERNET_SETTINGS = 0x04,
00223     RCVPT_DIAGNOSTIC_DATA = 0x05,
00224     RCVPT_HARDWARE_DESCRIPTION = 0x06,
00225         RCVPT_CONFIG_READBACK = 0x07,
00226         RCVPT_NETFINDER_READBACK = 0x08,
00227         RCVPT_I2C_DATA = 0x09,
00228         RCVPT_LIST_MODE_DATA = 0x0A,
00229         RCVPT_LIST_MODE_DATA_FIFO_FULL = 0x0B,
00230         RCVPT_OPTION_PA_CALIBRATION = 0x0C
00231 };  //PID2_REQ_SCOPE_MISC_TYPE
00232
00233 enum PID2_RCV_SCA_TYPE {
00234     RCVPT_SCA = 0x01
00235 };  //PID2_REQ_SCA_TYPE
00236
00237 enum PID2_ACK_TYPE {  //PID1_ACK, PID2_ACK_TYPE)
00238     PID2_ACK_OK = 0x00,
00239     PID2_ACK_SYNC_ERROR = 0x01,
00240     PID2_ACK_PID_ERROR = 0x02,
00241     PID2_ACK_LEN_ERROR = 0x03,
00242     PID2_ACK_CHECKSUM_ERROR = 0x04,
00243     PID2_ACK_BAD_PARAM = 0x05,
00244     PID2_ACK_BAD_HEX_REC = 0x06,
00245     PID2_ACK_UNRECOG = 0x07,
00246     PID2_ACK_FPGA_ERROR = 0x08,
00247     PID2_ACK_CP2201_NOT_FOUND = 0x09,
00248     PID2_ACK_SCOPE_DATA_NOT_AVAIL = 0x0A,
00249     PID2_ACK_PC5_NOT_PRESENT = 0x0B,
00250     PID2_ACK_OK_ETHERNET_SHARE_REQ = 0x0C,
00251         PID2_ACK_ETHERNET_BUSY = 0x0D,
00252         PID2_ACK_I2C_ERROR = 0x0E,
00253         PID2_ACK_OK_FPGA_UPLOAD_ADDR = 0x0F,
00254         PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED = 0x10,
00255         PID2_ACK_CAL_DATA_NOT_PRESENT = 0x11
00256 };  //PID2_ACK_TYPE
00257
00258 //#define PID1_ACK 0xFF
00259
00260 #define ACK 0
00261 //#define STATUS 1
00262 //#define SPECTRUM 2
00263 #define SYNC1_ 0xF5
00264 #define SYNC2_ 0xFA
00265
00266 #define RS232 0
00267 #define USB 1
00268 #define ETHERNET 2
00269
00270 #define ETHERNET_TIMEOUT 1000   // default timeout of 1000mS
00271 #define RS232_TIMEOUT 2500      // default timeout of 2500mS (8K spectrum ~2.2s)
00272 #define USB_TIMEOUT 500         // default timeout of 500mS
00273
00274 #define Retries 2   // total of 3 attempts
00275
00276 typedef struct _Packet_In {
00277     unsigned char PID1;
00278     unsigned char PID2;
00279     unsigned short LEN;  // signed, but data payload always less than 32768
00280     unsigned char STATUS;
00281     unsigned char DATA[32768];
00282     long CheckSum;
00283 } Packet_In;
00284
00285 struct Packet_Out {
00286     unsigned char PID1;
00287     unsigned char PID2;
00288     unsigned short LEN;  // signed, but data payload always less than 32768
00289     unsigned char EXPECTEDRESPONSE;
00290     unsigned char DATA[514];
00291 };
00292
00293 #define MAX_BUFFER_DATA         8192
00294 #define MAX_SCOPE_DATA          2048
00295 #define USB_DiagDataDelayMS 2500
00296
00297 struct Spec {
00298         long DATA[MAX_BUFFER_DATA];   // this keeps total of static data under 64K VB limit
00299         short CHANNELS;
00300 };
00301
00302 class CDP5Protocol
00303 {
00304 public:
00305         CDP5Protocol(void);
00306         ~CDP5Protocol(void);
00307
00309         short InPacketType;
00310         // Incoming packet buffer. (24648==largest possible IN packet.)
00311         unsigned char PacketIn[24648];
00312
00314         long RS232BytesInBuffer;
00316         long RS232_RThreshold;
00318         bool RS232HeaderReceived;
00320         short RS232PacketPtr;
00321
00323         bool ScaleAuto;
00325         unsigned char Scope[2048];
00327         unsigned char MiscData[512];
00329         bool CommError;
00331         unsigned char BufferOUT[520];
00333         Spec SPECTRUM;
00335         Packet_In PIN;
00336
00338         bool ACK_Received;
00340         bool Packet_Received;
00342         bool Timeout_flag;
00343
00344         int UDP_offset;
00345         bool Netfinder_active;
00346         int Netfinder_Seq;
00347
00349         bool USB_Default_Timeout;
00350 };
00351
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Status.cpp Source File

DeviceIO/DP5Status.cpp
Go to the documentation of this file.
00001
00002 #include "DP5Status.h"
00003 #include "stringex.h"
00004 #include "DppConst.h"
00005 #ifdef _MSC_VER
00006     #pragma warning(disable:4996)
00007 #endif
00008
00009 CDP5Status::CDP5Status(void)
00010 {
00011 }
00012
00013 CDP5Status::~CDP5Status(void)
00014 {
00015 }
00016
00017 void CDP5Status::Process_Status(DP4_FORMAT_STATUS *m_DP5_Status)
00018 {
00019         bool bDMCA_LiveTime = false;
00020         unsigned int uiFwBuild = 0;
00021
00022         m_DP5_Status->DEVICE_ID = m_DP5_Status->RAW[39];
00023     m_DP5_Status->FastCount = DppUtil.LongWordToDouble(0, m_DP5_Status->RAW);
00024     m_DP5_Status->SlowCount = DppUtil.LongWordToDouble(4, m_DP5_Status->RAW);
00025     m_DP5_Status->GP_COUNTER = DppUtil.LongWordToDouble(8, m_DP5_Status->RAW);
00026     m_DP5_Status->AccumulationTime = (float)m_DP5_Status->RAW[12] * 0.001 + (float)(m_DP5_Status->RAW[13] + (float)m_DP5_Status->RAW[14] * 256.0 + (float)m_DP5_Status->RAW[15] * 65536.0) * 0.1;
00027         m_DP5_Status->RealTime = ((double)m_DP5_Status->RAW[20] + ((double)m_DP5_Status->RAW[21] * 256.0) + ((double)m_DP5_Status->RAW[22] * 65536.0) + ((double)m_DP5_Status->RAW[23] * 16777216.0)) * 0.001;
00028
00029         m_DP5_Status->Firmware = m_DP5_Status->RAW[24];
00030     m_DP5_Status->FPGA = m_DP5_Status->RAW[25];
00031
00032         if (m_DP5_Status->Firmware > 0x65) {
00033                 m_DP5_Status->Build = m_DP5_Status->RAW[37] & 0xF;              //Build # added in FW6.06
00034         } else {
00035                 m_DP5_Status->Build = 0;
00036         }
00037
00038         //Firmware Version:  6.07  Build:  0 has LiveTime and PREL
00039         //DEVICE_ID 0=DP5,1=PX5,2=DP5G,3=MCA8000D,4=TB5
00040         if (m_DP5_Status->DEVICE_ID == dppMCA8000D) {
00041                 if (m_DP5_Status->Firmware >= 0x67) {
00042                         bDMCA_LiveTime = true;
00043                 }
00044         }
00045
00046         if (bDMCA_LiveTime) {
00047                 m_DP5_Status->LiveTime = ((double)m_DP5_Status->RAW[16] + ((double)m_DP5_Status->RAW[17] * 256.0) + ((double)m_DP5_Status->RAW[18] * 65536.0) + ((double)m_DP5_Status->RAW[19] * 16777216.0)) * 0.001;
00048         } else {
00049                 m_DP5_Status->LiveTime = 0;
00050         }
00051
00052     if (m_DP5_Status->RAW[29] < 128) {
00053         m_DP5_Status->SerialNumber = (unsigned long)DppUtil.LongWordToDouble(26, m_DP5_Status->RAW);
00054     } else {
00055         m_DP5_Status->SerialNumber = -1;
00056     }
00057
00058         // m_DP5_Status->HV = (double)(m_DP5_Status->RAW[31] + (m_DP5_Status->RAW[30] & 15) * 256) * 0.5;                                       // 0.5V/count
00059
00060         if (m_DP5_Status->RAW[30] < 128)  {    // not negative
00061         m_DP5_Status->HV = ((double)m_DP5_Status->RAW[31] + ((double)m_DP5_Status->RAW[30] * 256.0)) * 0.5;  // 0.5V/count
00062         } else {
00063                 m_DP5_Status->HV = (((double)m_DP5_Status->RAW[31] + ((double)m_DP5_Status->RAW[30] * 256)) - 65536.0) * 0.5; // 0.5V/count
00064         }
00065
00066         m_DP5_Status->DET_TEMP = (double)((m_DP5_Status->RAW[33]) + (m_DP5_Status->RAW[32] & 15) * 256) * 0.1; // - 273.16;             // 0.1K/count
00067     m_DP5_Status->DP5_TEMP = m_DP5_Status->RAW[34] - ((m_DP5_Status->RAW[34] & 128) * 2);
00068
00069     m_DP5_Status->PresetRtDone = ((m_DP5_Status->RAW[35] & 128) == 128);
00070
00071         //unsigned char:35 BIT:D6
00072         // == Preset LiveTime Done for MCA8000D
00073         // == FAST Thresh locked for other dpp devices
00074         m_DP5_Status->PresetLtDone = false;
00075         m_DP5_Status->AFAST_LOCKED = false;
00076         if (bDMCA_LiveTime) {           // test for MCA8000D
00077                 m_DP5_Status->PresetLtDone = ((m_DP5_Status->RAW[35] & 64) == 64);
00078         } else {
00079                 m_DP5_Status->AFAST_LOCKED = ((m_DP5_Status->RAW[35] & 64) == 64);
00080         }
00081     m_DP5_Status->MCA_EN = ((m_DP5_Status->RAW[35] & 32) == 32);
00082     m_DP5_Status->PRECNT_REACHED = ((m_DP5_Status->RAW[35] & 16) == 16);
00083     m_DP5_Status->SCOPE_DR = ((m_DP5_Status->RAW[35] & 4) == 4);
00084     m_DP5_Status->DP5_CONFIGURED = ((m_DP5_Status->RAW[35] & 2) == 2);
00085
00086     m_DP5_Status->AOFFSET_LOCKED = ((m_DP5_Status->RAW[36] & 128) == 0);  // 0=locked, 1=searching
00087     m_DP5_Status->MCS_DONE = ((m_DP5_Status->RAW[36] & 64) == 64);
00088
00089     m_DP5_Status->b80MHzMode = ((m_DP5_Status->RAW[36] & 2) == 2);
00090     m_DP5_Status->bFPGAAutoClock = ((m_DP5_Status->RAW[36] & 1) == 1);
00091
00092     m_DP5_Status->PC5_PRESENT = ((m_DP5_Status->RAW[38] & 128) == 128);
00093     if  (m_DP5_Status->PC5_PRESENT) {
00094         m_DP5_Status->PC5_HV_POL = ((m_DP5_Status->RAW[38] & 64) == 64);
00095         m_DP5_Status->PC5_8_5V = ((m_DP5_Status->RAW[38] & 32) == 32);
00096     } else {
00097         m_DP5_Status->PC5_HV_POL = false;
00098         m_DP5_Status->PC5_8_5V = false;
00099     }
00100
00101         if (m_DP5_Status->Firmware >= 0x65) {           // reboot flag added FW6.05
00102                 if ((m_DP5_Status->RAW[36] & 32) == 32) {
00103             m_DP5_Status->ReBootFlag = true;
00104                 } else {
00105                         m_DP5_Status->ReBootFlag = false;
00106                 }
00107         } else {
00108         m_DP5_Status->ReBootFlag = false;
00109         }
00110
00111         m_DP5_Status->TEC_Voltage = (((double)(m_DP5_Status->RAW[40] & 15) * 256.0) + (double)(m_DP5_Status->RAW[41])) / 758.5;
00112         m_DP5_Status->DPP_ECO = m_DP5_Status->RAW[49];
00113         m_DP5_Status->bScintHas80MHzOption = false;
00114         m_DP5_Status->DPP_options = (m_DP5_Status->RAW[42] & 15);
00115         m_DP5_Status->HPGe_HV_INH = false;
00116         m_DP5_Status->HPGe_HV_INH_POL = false;
00117         m_DP5_Status->AU34_2 = false;
00118         m_DP5_Status->isAscInstalled = false;
00119         m_DP5_Status->isDP5_RevDxGains = false;
00120         if (m_DP5_Status->DEVICE_ID == dppPX5) {
00121                 if (m_DP5_Status->DPP_options == PX5_OPTION_HPGe_HVPS) {
00122                         m_DP5_Status->HPGe_HV_INH = ((m_DP5_Status->RAW[42] & 32) == 32);
00123                         m_DP5_Status->HPGe_HV_INH_POL = ((m_DP5_Status->RAW[42] & 16) == 16);
00124                         if (m_DP5_Status->DPP_ECO == 1) {
00125                                 m_DP5_Status->isAscInstalled = true;
00126                                 m_DP5_Status->AU34_2 = ((m_DP5_Status->RAW[42] & 64) == 64);
00127                         }
00128                 }
00129         } else if ((m_DP5_Status->DEVICE_ID == dppDP5G) || (m_DP5_Status->DEVICE_ID == dppTB5)) {
00130                 if ((m_DP5_Status->DPP_ECO == 1) || (m_DP5_Status->DPP_ECO == 2)) {
00131                         // DPP_ECO == 2 80MHz option added 20150409
00132                         m_DP5_Status->bScintHas80MHzOption = true;
00133                 }
00134         } else if (m_DP5_Status->DEVICE_ID == dppDP5) {
00135                 uiFwBuild = m_DP5_Status->Firmware;
00136                 uiFwBuild = uiFwBuild << 8;
00137                 uiFwBuild = uiFwBuild + m_DP5_Status->Build;
00138                 // uiFwBuild - firmware with build for comparison
00139                 if (uiFwBuild >= 0x686) {
00140                         // 0xFF Value indicates old Analog Gain Count of 16
00141                         // Values < 0xFF indicate new gain count of 24 and new board rev
00142                         // "DP5 G3 Configuration P" will not be used (==0xFF)
00143                         if (m_DP5_Status->DPP_ECO < 0xFF) {
00144                                 m_DP5_Status->isDP5_RevDxGains = true;
00145                         }
00146
00147                 }
00148
00149         }
00150 }
00151
00152 string CDP5Status::DP5_Dx_OptionFlags(unsigned char DP5_Dx_Options) {
00153         unsigned char D7D6;
00154         unsigned char D5D4;
00155         unsigned char D3D0;
00156         string strRev("");
00157         stringex strfn;
00158
00159         //D7-D6: 0 = DP5 Rev D
00160         //       1 = DP5 Rev E (future)
00161         //       2 = DP5 Rev F (future)
00162         //       3 = DP5 Rev G (future)
00163         D7D6 = ((DP5_Dx_Options >> 6) & 0x03) + 'D';
00164         //D5-D4: minor rev, 0-3 (i.e. Rev D0, D1 etc.)
00165         D5D4 = ((DP5_Dx_Options >> 4) & 0x03);
00166         //D3-D0: Configuration 0 = A, 1=B, 2=C... 15=P.
00167         D3D0 = (DP5_Dx_Options & 0x0F) + 'A';
00168
00169         strRev = strfn.Format("DP5 Rev %c%d Configuration %c",D7D6,D5D4,D3D0);
00170         return(strRev);
00171
00172 }
00173
00174 string CDP5Status::ShowStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status)
00175 {
00176     string strConfig("");
00177     string strTemp;
00178         string strIntPart;
00179         string strFracPart;
00180         stringex strfn;
00181
00182         strTemp = GetDeviceNameFromVal(m_DP5_Status.DEVICE_ID);
00183         strConfig = "Device Type: " + strTemp + "\r\n";
00184         strTemp = strfn.Format("Serial Number: %lu\r\n",m_DP5_Status.SerialNumber);     //SerialNumber
00185         strConfig += strTemp;
00186         strTemp = "Firmware: " + DppUtil.BYTEVersionToString(m_DP5_Status.Firmware);
00187         strConfig += strTemp;
00188         if (m_DP5_Status.Firmware > 0x65) {
00189                 strTemp = strfn.Format("  Build:  %d\r\n", m_DP5_Status.Build);
00190                 strConfig += strTemp;
00191         } else {
00192                 strConfig += "\r\n";
00193         }
00194         strTemp = "FPGA: " + DppUtil.BYTEVersionToString(m_DP5_Status.FPGA) + "\r\n";
00195         strConfig += strTemp;
00196         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00197                 strTemp = strfn.Format("Fast Count: %.0f\r\n",m_DP5_Status.FastCount);          //FastCount
00198                 strConfig += strTemp;
00199         }
00200         strTemp = strfn.Format("Slow Count: %.0f\r\n",m_DP5_Status.SlowCount);          //SlowCount
00201         strConfig += strTemp;
00202         strTemp = strfn.Format("GP Count: %.0f\r\n",m_DP5_Status.GP_COUNTER);           //GP Count
00203         strConfig += strTemp;
00204
00205         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00206                 strTemp = strfn.Format("Accumulation Time: %.0f\r\n",m_DP5_Status.AccumulationTime);        //AccumulationTime
00207                 strConfig += strTemp;
00208         }
00209
00210         strTemp = strfn.Format("Real Time: %.0f\r\n",m_DP5_Status.RealTime);        //RealTime
00211         strConfig += strTemp;
00212
00213         if (m_DP5_Status.DEVICE_ID == dppMCA8000D) {
00214                 strTemp = strfn.Format("Live Time: %.0f\r\n",m_DP5_Status.LiveTime);        //RealTime
00215                 strConfig += strTemp;
00216         }
00217
00218         return strConfig;
00219 }
00220
00221 string CDP5Status::PX5_OptionsString(DP4_FORMAT_STATUS m_DP5_Status)
00222 {
00223         string strOptions("");
00224         string strValue("");
00225
00226         if (m_DP5_Status.DEVICE_ID == dppPX5) {
00227         //m_DP5_Status.DPP_options = 1;
00228         //m_DP5_Status.HPGe_HV_INH = true;
00229         //m_DP5_Status.HPGe_HV_INH_POL = true;
00230         if (m_DP5_Status.DPP_options > 0) {
00231             //===============PX5 Options==================
00232             strOptions += "PX5 Options: ";
00233             if ((m_DP5_Status.DPP_options & 1) == 1) {
00234                 strOptions += "HPGe HVPS\r\n";
00235             } else {
00236                 strOptions += "Unknown\r\n";
00237             }
00238             //===============HPGe HVPS HV Status==================
00239             strOptions += "HPGe HV: ";
00240             if (m_DP5_Status.HPGe_HV_INH) {
00241                 strOptions += "not inhibited\r\n";
00242             } else {
00243                 strOptions += "inhibited\r\n";
00244             }
00245             //===============HPGe HVPS Inhibit Status==================
00246             strOptions += "INH Polarity: ";
00247             if (m_DP5_Status.HPGe_HV_INH_POL) {
00248                 strOptions += "high\r\n";
00249             } else {
00250                 strOptions += "low\r\n";
00251             }
00252         } else {
00253             strOptions += "PX5 Options: None\r\n";  //           strOptions += "No Options Installed"
00254         }
00255     }
00256         return strOptions;
00257 }
00258
00259 string CDP5Status::GetStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status)
00260 {
00261     string strConfig("");
00262     string strTemp;
00263         string strIntPart;
00264         string strFracPart;
00265         stringex strfn;
00266
00267         strTemp = GetDeviceNameFromVal(m_DP5_Status.DEVICE_ID);
00268         strConfig = "Device Type: " + strTemp + "\r\n";
00269         strTemp = strfn.Format("Serial Number: %lu\r\n",m_DP5_Status.SerialNumber);     //SerialNumber
00270         strConfig += strTemp;
00271         strTemp = "Firmware: " + DppUtil.BYTEVersionToString(m_DP5_Status.Firmware);
00272         strConfig += strTemp;
00273         if (m_DP5_Status.Firmware > 0x65) {
00274                 strTemp = strfn.Format("  Build:  %d\r\n", m_DP5_Status.Build);
00275                 strConfig += strTemp;
00276         } else {
00277                 strConfig += "\r\n";
00278         }
00279         strTemp = "FPGA: " + DppUtil.BYTEVersionToString(m_DP5_Status.FPGA) + "\r\n";
00280         strConfig += strTemp;
00281         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00282                 strTemp = strfn.Format("Fast Count: %.0f\r\n",m_DP5_Status.FastCount);          //FastCount
00283                 strConfig += strTemp;
00284         }
00285         strTemp = strfn.Format("Slow Count: %.0f\r\n",m_DP5_Status.SlowCount);          //SlowCount
00286         strConfig += strTemp;
00287         strTemp = strfn.Format("GP Count: %.0f\r\n",m_DP5_Status.GP_COUNTER);           //GP Count
00288         strConfig += strTemp;
00289
00290         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00291                 strTemp = strfn.Format("Accumulation Time: %.0f\r\n",m_DP5_Status.AccumulationTime);        //AccumulationTime
00292                 strConfig += strTemp;
00293         }
00294
00295         strTemp = strfn.Format("Real Time: %.0f\r\n",m_DP5_Status.RealTime);        //RealTime
00296         strConfig += strTemp;
00297
00298         if (m_DP5_Status.DEVICE_ID == dppMCA8000D) {
00299                 strTemp = strfn.Format("Live Time: %.0f\r\n",m_DP5_Status.LiveTime);        //RealTime
00300                 strConfig += strTemp;
00301         }
00302
00303    if ((m_DP5_Status.DEVICE_ID != dppDP5G) && (m_DP5_Status.DEVICE_ID != dppTB5) && (m_DP5_Status.DEVICE_ID != dppMCA8000D)) {
00304         strTemp = strfn.Format("Detector Temp: %.0fK\r\n",m_DP5_Status.DET_TEMP);               //"##0°C") ' round to nearest degree
00305                 strConfig += strTemp;
00306                 strTemp = strfn.Format("Detector HV: %.0fV\r\n",m_DP5_Status.HV);
00307                 strConfig += strTemp;
00308                 strTemp = strfn.Format("Board Temp: %d°C\r\n",(int)m_DP5_Status.DP5_TEMP);
00309                 strConfig += strTemp;
00310         } else if ((m_DP5_Status.DEVICE_ID == dppDP5G) || (m_DP5_Status.DEVICE_ID == dppTB5)) {         // GAMMARAD5,TB5
00311                 if (m_DP5_Status.DET_TEMP > 0) {
00312                         strTemp = strfn.Format("Detector Temp: %.1fK\r\n",m_DP5_Status.DET_TEMP);
00313                         strConfig += strTemp;
00314                 } else {
00315                         strConfig += "";
00316                 }
00317                 strTemp = strfn.Format("HV Set: %.0fV\r\n",m_DP5_Status.HV);
00318                 strConfig += strTemp;
00319         } else if (m_DP5_Status.DEVICE_ID == dppMCA8000D) {             // Digital MCA
00320                 strTemp = strfn.Format("Board Temp: %d°C\r\n",(int)m_DP5_Status.DP5_TEMP);
00321                 strConfig += strTemp;
00322         }
00323         if (m_DP5_Status.DEVICE_ID == dppPX5) {
00324                 strTemp = PX5_OptionsString(m_DP5_Status);
00325                 strConfig += strTemp;
00326                 strTemp = strfn.Format("TEC V: %.3fV\r\n",m_DP5_Status.TEC_Voltage);
00327                 strConfig += strTemp;
00328         }
00329         return strConfig;
00330 }
00331
00332 void CDP5Status::Process_Diagnostics(Packet_In PIN, DiagDataType *dd, int device_type)
00333 {
00334     long idxVal;
00335     string strVal;
00336         double DP5_ADC_Gain[10];  // convert each ADC count to engineering units - values calculated in FORM.LOAD
00337         double PC5_ADC_Gain[3];
00338         double PX5_ADC_Gain[12];
00339     stringex strfn;
00340
00341     DP5_ADC_Gain[0] = 1.0 / 0.00286;                // 2.86mV/C
00342     DP5_ADC_Gain[1] = 1.0;                          // Vdd mon (out-of-scale)
00343     DP5_ADC_Gain[2] = (30.1 + 20.0) / 20.0;           // PWR
00344     DP5_ADC_Gain[3] = (13.0 + 20.0) / 20.0;            // 3.3V
00345     DP5_ADC_Gain[4] = (4.99 + 20.0) / 20.0;         // 2.5V
00346     DP5_ADC_Gain[5] = 1.0;                          // 1.2V
00347     DP5_ADC_Gain[6] = (35.7 + 20.0) / 20.0;          // 5.5V
00348     DP5_ADC_Gain[7] = (35.7 + 75.0) / 35.7;        // -5.5V (this one is tricky)
00349     DP5_ADC_Gain[8] = 1.0;                          // AN_IN
00350     DP5_ADC_Gain[9] = 1.0;                          // VREF_IN
00351
00352     PC5_ADC_Gain[0] = 500.0;                        // HV: 1500V/3V
00353     PC5_ADC_Gain[1] = 100.0;                        // TEC: 300K/3V
00354     PC5_ADC_Gain[2] = (20.0 + 10.0) / 10.0;            // +8.5/5V
00355
00356         //PX5_ADC_Gain[0] = (30.1 + 20.0) / 20.0;          // PWR
00357         PX5_ADC_Gain[0] = (69.8 + 20.0) / 20.0;          // 9V (was originally PWR)
00358     PX5_ADC_Gain[1] = (13.0 + 20.0) / 20.0;            // 3.3V
00359     PX5_ADC_Gain[2] = (4.99 + 20.0) / 20.0;          // 2.5V
00360     PX5_ADC_Gain[3] = 1.0;                         // 1.2V
00361     PX5_ADC_Gain[4] = (30.1 + 20.0) / 20.0;          // 5V
00362     PX5_ADC_Gain[5] = (10.7 + 75.0) / 10.7;         // -5V (this one is tricky)
00363     PX5_ADC_Gain[6] = (64.9 + 20.0) / 20.0;          // +PA
00364     PX5_ADC_Gain[7] = (10.7 + 75) / 10.7;        // -PA
00365     PX5_ADC_Gain[8] = (16.0 + 20.0) / 20.0;            // +TEC
00366     PX5_ADC_Gain[9] = 500.0;                       // HV: 1500V/3V
00367     PX5_ADC_Gain[10] = 100.0;                       // TEC: 300K/3V
00368     PX5_ADC_Gain[11] = 1.0 / 0.00286;               // 2.86mV/C
00369
00370     dd->Firmware = PIN.DATA[0];
00371     dd->FPGA = PIN.DATA[1];
00372     strVal = "0x0" + FmtHex(PIN.DATA[2], 2) + FmtHex(PIN.DATA[3], 2) + FmtHex(PIN.DATA[4], 2);
00373     dd->SRAMTestData = strtol(strVal.c_str(),NULL,0);
00374     dd->SRAMTestPass = (dd->SRAMTestData == 0xFFFFFF);
00375     dd->TempOffset = PIN.DATA[180] + 256 * (PIN.DATA[180] > 127);  // 8-bit signed value
00376
00377         if ((device_type == dppDP5) || (device_type == dppDP5X)) {
00378                 for(idxVal=0;idxVal<10;idxVal++){
00379                         dd->ADC_V[idxVal] = (float)((((PIN.DATA[5 + idxVal * 2] & 3) * 256) + PIN.DATA[6 + idxVal * 2]) * 2.44 / 1024.0 * DP5_ADC_Gain[idxVal]); // convert counts to engineering units (C or V)
00380                 }
00381                 dd->ADC_V[7] = dd->ADC_V[7] + dd->ADC_V[6] * (float)(1.0 - DP5_ADC_Gain[7]);  // -5.5V is a function of +5.5V
00382                 dd->strTempRaw = strfn.Format("%   #.0f0C", dd->ADC_V[0] - 271.3);
00383                 dd->strTempCal = strfn.Format("%   #.0f0C", (dd->ADC_V[0] - 280.0 + dd->TempOffset));
00384         } else if (device_type == dppPX5) {
00385         for(idxVal=0;idxVal<11;idxVal++){
00386             dd->ADC_V[idxVal] = (float)((((PIN.DATA[5 + idxVal * 2] & 15) * 256) + PIN.DATA[6 + idxVal * 2]) * 3.0 / 4096.0 * PX5_ADC_Gain[idxVal]);   // convert counts to engineering units (C or V)
00387                 }
00388         dd->ADC_V[11] = (float)((((PIN.DATA[5 + 11 * 2] & 3) * 256) + PIN.DATA[6 + 11 * 2]) * 3.0 / 1024.0 * PX5_ADC_Gain[11]);  // convert counts to engineering units (C or V)
00389         dd->ADC_V[5] = (float)(dd->ADC_V[5] - (3.0 * PX5_ADC_Gain[5]) + 3.0); // -5V uses +3VR
00390         dd->ADC_V[7] = (float)(dd->ADC_V[7] - (3.0 * PX5_ADC_Gain[7]) + 3.0); // -PA uses +3VR
00391                 dd->strTempRaw = strfn.Format("%#.1fC", dd->ADC_V[11] - 271.3);
00392                 dd->strTempCal = strfn.Format("%#.1fC", (dd->ADC_V[11] - 280.0 + dd->TempOffset));
00393         }
00394
00395     dd->PC5_PRESENT = false;  // assume no PC5, then check to see if there are any non-zero bytes
00396         for(idxVal=25;idxVal<=38;idxVal++) {
00397                 if (PIN.DATA[idxVal] > 0) {
00398             dd->PC5_PRESENT = true;
00399             break;
00400         }
00401     }
00402
00403     if (dd->PC5_PRESENT) {
00404                 for(idxVal=0;idxVal<=2;idxVal++) {
00405                         dd->PC5_V[idxVal] = (float)((((PIN.DATA[25 + idxVal * 2] & 15) * 256) + PIN.DATA[26 + idxVal * 2]) * 3.0 / 4096.0 * PC5_ADC_Gain[idxVal]); // convert counts to engineering units (C or V)
00406                 }
00407                 if (PIN.DATA[34] < 128) {
00408                         dd->PC5_SN = (unsigned long)DppUtil.LongWordToDouble(31, PIN.DATA);
00409                 } else {
00410                         dd->PC5_SN = -1; // no PC5 S/N
00411                 }
00412                 if ((PIN.DATA[35] == 255) && (PIN.DATA[36] == 255)) {
00413                         dd->PC5Initialized = false;
00414                         dd->PC5DCAL = 0;
00415                 } else {
00416                         dd->PC5Initialized = true;
00417                         dd->PC5DCAL = (float)(((float)(PIN.DATA[35]) * 256.0 + (float)(PIN.DATA[36])) * 3.0 / 4096.0);
00418                 }
00419                 dd->IsPosHV = ((PIN.DATA[37] & 128) == 128);
00420                 dd->Is8_5VPreAmp = ((PIN.DATA[37] & 64) == 64);
00421                 dd->Sup9VOn = ((PIN.DATA[38] & 8) == 8);
00422                 dd->PreAmpON = ((PIN.DATA[38] & 4) == 4);
00423                 dd->HVOn = ((PIN.DATA[38] & 2) == 2);
00424                 dd->TECOn = ((PIN.DATA[38] & 1) == 1);
00425         } else {
00426         for(idxVal=0;idxVal<=2;idxVal++) {
00427             dd->PC5_V[idxVal] = 0;
00428                 }
00429         dd->PC5_SN = -1; // no PC5 S/N
00430         dd->PC5Initialized = false;
00431         dd->PC5DCAL = 0;
00432         dd->IsPosHV = false;
00433         dd->Is8_5VPreAmp = false;
00434         dd->Sup9VOn = false;
00435         dd->PreAmpON = false;
00436         dd->HVOn = false;
00437         dd->TECOn = false;
00438     }
00439         for(idxVal=0;idxVal<=191;idxVal++) {
00440         dd->DiagData[idxVal] = PIN.DATA[idxVal + 39];
00441     }
00442         //string strData;
00443         //strData = DisplayBufferArray(PIN.DATA, 256);
00444         //SaveStringDataToFile(strData);
00445 }
00446
00447 string CDP5Status::DiagnosticsToString(DiagDataType dd, int device_type)
00448 {
00449     long idxVal;
00450         string strVal;
00451     string strDiag;
00452         stringex strfn;
00453
00454     strDiag = "Firmware: " + VersionToStr(dd.Firmware) + "\r\n";
00455     strDiag += "FPGA: " + VersionToStr(dd.FPGA) + "\r\n";
00456     strDiag += "SRAM Test: ";
00457     if (dd.SRAMTestPass) {
00458         strDiag += "PASS\r\n";
00459     } else {
00460         strDiag += "ERROR @ 0x" + FmtHex(dd.SRAMTestData, 6) + "\r\n";
00461     }
00462
00463         if ((device_type == dppDP5) || (device_type == dppDP5X)) {
00464                 strDiag += "DP5 Temp (raw): " + dd.strTempRaw + "\r\n";
00465                 strDiag += "DP5 Temp (cal'd): " + dd.strTempCal + "\r\n";
00466                 strDiag += "PWR: " + FmtPc5Pwr(dd.ADC_V[2]) + "\r\n";
00467                 strDiag += "3.3V: " + FmtPc5Pwr(dd.ADC_V[3]) + "\r\n";
00468                 strDiag += "2.5V: " + FmtPc5Pwr(dd.ADC_V[4]) + "\r\n";
00469                 strDiag += "1.2V: " + FmtPc5Pwr(dd.ADC_V[5]) + "\r\n";
00470                 strDiag += "+5.5V: " + FmtPc5Pwr(dd.ADC_V[6]) + "\r\n";
00471                 strDiag += "-5.5V: " + FmtPc5Pwr(dd.ADC_V[7]) + "\r\n";
00472                 strDiag += "AN_IN: " + FmtPc5Pwr(dd.ADC_V[8]) + "\r\n";
00473                 strDiag += "VREF_IN: " + FmtPc5Pwr(dd.ADC_V[9]) + "\r\n";
00474
00475                 strDiag += "\r\n";
00476                 if (dd.PC5_PRESENT) {
00477                         strDiag += "PC5: Present\r\n";
00478                         strVal = strfn.Format("%dV",(int)(dd.PC5_V[0]));
00479                         strDiag += "HV: " + strVal + "\r\n";
00480                         strVal = strfn.Format("%#.1fK",dd.PC5_V[1]);
00481                         strDiag += "Detector Temp: " + strVal + "\r\n";
00482                         strDiag += "+8.5/5V: " + FmtPc5Pwr(dd.PC5_V[2]) + "\r\n";
00483                         if (dd.PC5_SN > -1) {
00484                                 strDiag += "PC5 S/N: " + FmtLng(dd.PC5_SN) + "\r\n";
00485                         } else {
00486                                 strDiag += "PC5 S/N: none\r\n";
00487                         }
00488                         if (dd.PC5Initialized) {
00489                                 strDiag += "PC5 DCAL: " + FmtPc5Pwr(dd.PC5DCAL) + "\r\n";
00490                         } else {
00491                                 strDiag += "PC5 DCAL: Uninitialized\r\n";
00492                         }
00493                         strDiag += "PC5 Flavor: ";
00494                         strDiag += IsAorB(dd.IsPosHV, "+HV, ", "-HV, ");
00495                         strDiag += IsAorB(dd.Is8_5VPreAmp, "8.5V preamp", "5V preamp") + "\r\n";
00496                         strDiag += "PC5 Supplies:\r\n";
00497                         strDiag += "9V: " + OnOffStr(dd.Sup9VOn) + "\r\n";
00498                         strDiag += "Preamp: " + OnOffStr(dd.PreAmpON) + "\r\n";
00499                         strDiag += "HV: " + OnOffStr(dd.HVOn) + "\r\n";
00500                         strDiag += "TEC: " + OnOffStr(dd.TECOn) + "\r\n";
00501                 } else {
00502                         strDiag += "PC5: Not Present\r\n";
00503                 }
00504         } else if (device_type == dppPX5) {
00505                 strDiag += "PX5 Temp (raw): " + dd.strTempRaw + "\r\n";
00506                 strDiag += "PX5 Temp (cal'd): " + dd.strTempCal + "\r\n";
00507                 //strDiag += "PWR: " + FmtPc5Pwr(dd.ADC_V[0]) + "\r\n";
00508                 strDiag += "9V: " + FmtPc5Pwr(dd.ADC_V[0]) + "\r\n";
00509                 strDiag += "3.3V: " + FmtPc5Pwr(dd.ADC_V[1]) + "\r\n";
00510                 strDiag += "2.5V: " + FmtPc5Pwr(dd.ADC_V[2]) + "\r\n";
00511                 strDiag += "1.2V: " + FmtPc5Pwr(dd.ADC_V[3]) + "\r\n";
00512                 strDiag += "+5V: " + FmtPc5Pwr(dd.ADC_V[4]) + "\r\n";
00513                 strDiag += "-5V: " + FmtPc5Pwr(dd.ADC_V[5]) + "\r\n";
00514                 strDiag += "+PA: " + FmtPc5Pwr(dd.ADC_V[6]) + "\r\n";
00515                 strDiag += "-PA: " + FmtPc5Pwr(dd.ADC_V[7]) + "\r\n";
00516                 strDiag += "TEC: " + FmtPc5Pwr(dd.ADC_V[8]) + "\r\n";
00517                 strDiag += "ABS(HV): " + FmtHvPwr(dd.ADC_V[9]) + "\r\n";
00518                 strDiag += "DET_TEMP: " + FmtPc5Temp(dd.ADC_V[10]) + "\r\n";
00519         }
00520
00521     strDiag += "\r\nDiagnostic Data\r\n";
00522     strDiag += "---------------\r\n";
00523         for(idxVal=0;idxVal<=191;idxVal++) {
00524         if ((idxVal % 8) == 0) {
00525                         strDiag += FmtHex(idxVal, 2) + ":";
00526                 }
00527         strDiag += FmtHex(dd.DiagData[idxVal], 2) + " ";
00528         if ((idxVal % 8) == 7) {
00529                         strDiag += "\r\n";
00530                 }
00531     }
00532     return (strDiag);
00533 }
00534
00535 string CDP5Status::DiagStrPX5Option(DiagDataType dd, int device_type)
00536 {
00537     long idxVal;
00538         string strVal;
00539     string strDiag;
00540         stringex strfn;
00541
00542     strDiag = "Firmware: " + VersionToStr(dd.Firmware) + "\r\n";
00543     strDiag += "FPGA: " + VersionToStr(dd.FPGA) + "\r\n";
00544     strDiag += "SRAM Test: ";
00545     if (dd.SRAMTestPass) {
00546         strDiag += "PASS\r\n";
00547     } else {
00548         strDiag += "ERROR @ 0x" + FmtHex(dd.SRAMTestData, 6) + "\r\n";
00549     }
00550
00551         if (device_type == dppPX5) {
00552                 strDiag += "PX5 Temp (raw): " + dd.strTempRaw + "\r\n";
00553                 strDiag += "PX5 Temp (cal'd): " + dd.strTempCal + "\r\n";
00554                 strDiag += "9V: " + FmtPc5Pwr(dd.ADC_V[0]) + "\r\n";
00555                 strDiag += "3.3V: " + FmtPc5Pwr(dd.ADC_V[1]) + "\r\n";
00556                 strDiag += "2.5V: " + FmtPc5Pwr(dd.ADC_V[2]) + "\r\n";
00557                 strDiag += "TDET: " + FmtPc5Pwr(dd.ADC_V[3]) + "\r\n";
00558                 strDiag += "+5V: " + FmtPc5Pwr(dd.ADC_V[4]) + "\r\n";
00559                 strDiag += "-5V: " + FmtPc5Pwr(dd.ADC_V[5]) + "\r\n";
00560                 strDiag += "+PA: " + FmtPc5Pwr(dd.ADC_V[6]) + "\r\n";
00561                 strDiag += "-PA: " + FmtPc5Pwr(dd.ADC_V[7]) + "\r\n";
00562                 strDiag += "TEC: " + FmtPc5Pwr(dd.ADC_V[8]) + "\r\n";
00563                 strDiag += "ABS(HV): " + FmtHvPwr(dd.ADC_V[9]) + "\r\n";
00564                 strDiag += "DET_TEMP: " + FmtPc5Temp(dd.ADC_V[10]) + "\r\n";
00565         }
00566
00567     strDiag += "\r\nDiagnostic Data\r\n";
00568     strDiag += "---------------\r\n";
00569         for(idxVal=0;idxVal<=191;idxVal++) {
00570         if ((idxVal % 8) == 0) {
00571                         strDiag += FmtHex(idxVal, 2) + ":";
00572                 }
00573         strDiag += FmtHex(dd.DiagData[idxVal], 2) + " ";
00574         if ((idxVal % 8) == 7) {
00575                         strDiag += "\r\n";
00576                 }
00577     }
00578     return (strDiag);
00579 }
00580
00581 string CDP5Status::FmtHvPwr(float fVal)
00582 {
00583         string strVal;
00584         stringex strfn;
00585         strVal = strfn.Format("%#.1fV", fVal);  // "#.##0V"
00586         return strVal;
00587 }
00588
00589 string CDP5Status::FmtPc5Pwr(float fVal)
00590 {
00591         string strVal;
00592         stringex strfn;
00593         strVal = strfn.Format("%#.3fV", fVal);  // "#.##0V"
00594         return strVal;
00595 }
00596
00597 string CDP5Status::FmtPc5Temp(float fVal)
00598 {
00599         string strVal;
00600         stringex strfn;
00601         strVal = strfn.Format("%#.1fK", fVal);  // "#.##0V"
00602         return strVal;
00603 }
00604
00605 string CDP5Status::FmtHex(long FmtHex, long HexDig)
00606 {
00607         string strHex;
00608         string strFmt;
00609         stringex strfn;
00610         strFmt = strfn.Format("%d",HexDig);             // max size of 0 pad
00611         strFmt = "%0" + strFmt + "X";           // string format specifier
00612         strHex = strfn.Format(strFmt.c_str(), FmtHex);  // create padded string
00613         return strHex;
00614 }
00615
00616 string CDP5Status::FmtLng(long lVal)
00617 {
00618         string strVal;
00619         stringex strfn;
00620         strVal = strfn.Format("%d", lVal);
00621         return strVal;
00622 }
00623
00624 string CDP5Status::VersionToStr(unsigned char bVersion)
00625 {
00626         string strVerMajor;
00627         string strVerMinor;
00628         string strVer;
00629         stringex strfn;
00630         strVerMajor = strfn.Format("%d",((bVersion & 0xF0) / 16));
00631         strVerMinor = strfn.Format("%02d",(bVersion & 0x0F));
00632         strVer = strVerMajor + "." + strVerMinor;
00633         return (strVer);
00634 }
00635
00636 string CDP5Status::OnOffStr(bool bOn)
00637 {
00638     if (bOn) {
00639         return("ON");
00640     } else {
00641         return("OFF");
00642     }
00643 }
00644
00645 string CDP5Status::IsAorB(bool bIsA, string strA, string strB)
00646 {
00647     if (bIsA) {
00648         return(strA);
00649     } else {
00650         return(strB);
00651     }
00652 }
00653
00654 string CDP5Status::GetDeviceNameFromVal(int DeviceTypeVal)
00655 {
00656     string strDeviceType;
00657         switch(DeviceTypeVal) {
00658                 case 0:
00659             strDeviceType = "DP5";
00660                         break;
00661                 case 1:
00662             strDeviceType = "PX5";
00663                         break;
00664                 case 2:
00665             strDeviceType = "DP5G";
00666                         break;
00667                 case 3:
00668             strDeviceType = "MCA8000D";
00669                         break;
00670                 case 4:
00671             strDeviceType = "TB5";
00672                         break;
00673                 case 5:
00674             strDeviceType = "DP5-X";
00675                         break;
00676                 default:           //if unknown set to DP5
00677             strDeviceType = "DP5";
00678                         break;
00679         }
00680     return strDeviceType;
00681 }
00682
00683 string CDP5Status::DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn)
00684 {
00685     unsigned long i;
00686         string strVal("");
00687         string strMsg("");
00688         stringex strfn;
00689         for(i=0;i<bufSizeIn;i++) {
00690                 strVal = strfn.Format("%.2X ",buffer[i]);
00691                 strMsg += strVal;
00692                 //if (((i+1) % 16) == 0 ) {
00693                 //      strMsg += "\r\n";
00694                 //} else
00695                 if (((i+1) % 8) == 0 ) {
00696                 //      strMsg += "   ";
00697                         //strMsg += "\r\n";
00698                         strMsg += "\n";
00699                 }
00700         }
00701         //strMsg += "\n";
00702         return strMsg;
00703 }
00704
00705 void CDP5Status::SaveStringDataToFile(string strData)
00706 {
00707         FILE  *out;
00708         string strFilename;
00709         string strError;
00710         stringex strfn;
00711
00712         strFilename = "vcDP5_Data.txt";
00713
00714         if ( (out = fopen(strFilename.c_str(),"w")) == (FILE *) NULL)
00715                 strError = strfn.Format("Couldn't open %s for writing.\n", strFilename.c_str());
00716         else
00717         {
00718                 fprintf(out,"%s\n",strData.c_str());
00719         }
00720         fclose(out);
00721 }
00722
00723
00724
00725
00726
00727
00728
00729
00730
00731
00732
00733
00734
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DP5Status.h Source File

DeviceIO/DP5Status.h
Go to the documentation of this file.
00001
00003 #pragma once
00004 #include <stdio.h>
00005 #include <stdlib.h>
00006 #include "DP5Protocol.h"
00007 #include "DppUtilities.h"
00008
00009 typedef enum _PX5_OPTIONS
00010 {
00011         PX5_OPTION_NONE=0,
00012         PX5_OPTION_HPGe_HVPS=1,
00013         PX5_OPTION_TEST_TEK=4,
00014         PX5_OPTION_TEST_MOX=5,
00015         PX5_OPTION_TEST_AMP=6,
00016         PX5_OPTION_TEST_MODE_1=8,
00017         PX5_OPTION_TEST_MODE_2=9
00018 } PX5_OPTIONS;
00019
00020 //PX5_OPTION_TEST_MODE_1 reserved for future use
00021 //PX5_OPTION_TEST_MODE_2 reserved for future use
00022
00023 typedef struct DP5_DP4_FORMAT_STATUS
00024 {
00025     unsigned char RAW[64];
00026     unsigned long SerialNumber;
00027     double FastCount;
00028     double SlowCount;
00029     unsigned char FPGA;
00030     unsigned char Firmware;
00031         unsigned char Build;
00032     double AccumulationTime;
00033     double RealTime;
00034     double LiveTime;
00035     double HV;
00036     double DET_TEMP;
00037     double DP5_TEMP;
00038     bool PX4;
00039     bool AFAST_LOCKED;
00040     bool MCA_EN;
00041     bool PRECNT_REACHED;
00042         bool PresetRtDone;
00043         bool PresetLtDone;
00044     bool SUPPLIES_ON;
00045     bool SCOPE_DR;
00046     bool DP5_CONFIGURED;
00047     double GP_COUNTER;
00048     bool AOFFSET_LOCKED;
00049     bool MCS_DONE;
00050     bool RAM_TEST_RUN;
00051     bool RAM_TEST_ERROR;
00052     double DCAL;
00053     unsigned char PZCORR;                               // or single?
00054     unsigned char UC_TEMP_OFFSET;
00055     double AN_IN;
00056     double VREF_IN;
00057     unsigned long PC5_SN;
00058     bool PC5_PRESENT;
00059     bool PC5_HV_POL;
00060     bool PC5_8_5V;
00061     double ADC_GAIN_CAL;
00062     unsigned char ADC_OFFSET_CAL;
00063     long SPECTRUM_OFFSET;     // or single?
00064         bool b80MHzMode;
00065         bool bFPGAAutoClock;
00066         unsigned char DEVICE_ID;
00067         bool ReBootFlag;
00068         unsigned char DPP_options;
00069         bool HPGe_HV_INH;
00070         bool HPGe_HV_INH_POL;
00071         double TEC_Voltage;
00072         unsigned char DPP_ECO;
00073         bool AU34_2;
00074         bool isAscInstalled;
00075         bool isAscEnabled;
00076         bool bScintHas80MHzOption;
00077         bool isDP5_RevDxGains;
00078 } DP4_FORMAT_STATUS, *PDP4_FORMAT_STATUS;
00079
00080 typedef struct _DiagDataType
00081 {
00082     float ADC_V[12];
00083     float PC5_V[4];
00084     bool PC5_PRESENT;
00085     long PC5_SN;
00086     unsigned char Firmware;
00087     unsigned char FPGA;
00088     bool SRAMTestPass;
00089     long SRAMTestData;
00090     int TempOffset;
00091     string strTempRaw;
00092     string strTempCal;
00093     bool PC5Initialized;
00094     float PC5DCAL;
00095     bool IsPosHV;
00096     bool Is8_5VPreAmp;
00097     bool Sup9VOn;
00098     bool PreAmpON;
00099     bool HVOn;
00100     bool TECOn;
00101     unsigned char DiagData[192];
00102 } DiagDataType, *PDDiagDataType;
00103
00104 class CDP5Status
00105 {
00106 public:
00107         CDP5Status(void);
00108         ~CDP5Status(void);
00109
00111         CDppUtilities DppUtil;
00112
00114         DP4_FORMAT_STATUS m_DP5_Status;
00116         DiagDataType DiagData;
00118         void Process_Status(DP4_FORMAT_STATUS *m_DP5_Status);
00119         string DP5_Dx_OptionFlags(unsigned char DP5_Dx_Options);
00121         string ShowStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status);
00122         string PX5_OptionsString(DP4_FORMAT_STATUS m_DP5_Status);
00123         string GetStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status);
00124
00126         void Process_Diagnostics(Packet_In PIN, DiagDataType *dd, int device_type);
00128         string DiagnosticsToString(DiagDataType dd, int device_type);
00130         string DiagStrPX5Option(DiagDataType dd, int device_type);
00131
00133         string FmtHvPwr(float fVal);
00135         string FmtPc5Pwr(float fVal);
00137         string FmtPc5Temp(float fVal) ;
00139         string FmtHex(long FmtHex, long HexDig);
00141         string FmtLng(long lVal);
00143         string VersionToStr(unsigned char bVersion);
00145         string OnOffStr(bool bOn);
00147         string IsAorB(bool bIsA, string strA, string strB);
00149         string GetDeviceNameFromVal(int DeviceTypeVal) ;
00151         string DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn);
00153         void SaveStringDataToFile(string strData);
00154
00155 };
00156
00157
00158
00159
00160
00161
00162
00163
00164
00165
00166
00167
00168
00169
00170
00171
00172
00173
00174
00175
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppConst.h Source File

DeviceIO/DppConst.h
Go to the documentation of this file.
00001
00002 #pragma once
00003
00004 typedef enum DP5_DPP_TYPES
00005 {
00007         dppDP5,
00009         dppPX5,
00011         dppDP5G,
00013         dppMCA8000D,
00015         dppTB5,
00017         dppDP5X
00018 } dp5DppTypes;
00019
00020 #define DP5_DPP_TYPES_FIRST dppDP5
00021 #define DP5_DPP_TYPES_LAST dppDP5X
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppLibUsb.cpp Source File

DeviceIO/DppLibUsb.cpp
Go to the documentation of this file.
00001 #include "DppLibUsb.h"
00002
00003 CDppLibUsb::CDppLibUsb(void)
00004 {
00005
00006 }
00007 CDppLibUsb::~CDppLibUsb(void)
00008 {
00009
00010 }
00011
00012 // InitializeLibusb must be call before any other libusb operations
00013 int CDppLibUsb::InitializeLibusb()
00014 {
00015         int iStatus=0;
00016         iStatus = libusb_init(NULL);
00017         if (iStatus != 0) {
00018                 fprintf(stderr, "Unable to initialize libusb. %s\n", libusb_strerror((libusb_error)iStatus));
00019         }
00020         return iStatus;
00021 }
00022
00023 // DeinitializeLibusb must be called after all libusb operations
00024 // have been completed and all devices/lists are closed
00025 void CDppLibUsb::DeinitializeLibusb()
00026 {
00027         libusb_exit(NULL);
00028 }
00029
00030 // devices start at 1
00031 // Do only when no devices are connected
00032 libusb_device_handle * CDppLibUsb::FindUSBDevice(int idxAmptekDevice)
00033 {
00034         struct libusb_device **devs;
00035         struct libusb_device *found = NULL;
00036         struct libusb_device_handle *handle = NULL;
00037         struct libusb_device_descriptor desc;
00038         struct libusb_device *device = NULL;
00039         ssize_t devcnt = 0;
00040         ssize_t iDev = 0;
00041         int r;
00042         int idxDev=1;
00043
00044         bDeviceConnected = false;
00045         devcnt = libusb_get_device_list(NULL, &devs);
00046         if (devcnt < 0) {
00047                 fprintf(stderr, "failed to get device list");
00048                 return NULL;
00049         }
00050         for (iDev = 0; iDev < devcnt; iDev++) {
00051                 device = devs[iDev];
00052                 int r = libusb_get_device_descriptor (device, &desc);
00053                 if (r < 0) {
00054                         fprintf(stderr, libusb_strerror((libusb_error)r));
00055                         goto out;
00056                         //continue;
00057                 }
00058                 if (isAmptekDP5Device(desc)) {
00059                         if (idxAmptekDevice==idxDev) {
00060                                 found = device;
00061                                 break;
00062                         } else {        // inc counter to next device
00063                                 idxDev++;
00064                         }
00065                 }
00066         }
00067         if (found) {
00068                 r = libusb_open(found, &handle);
00069                 if (r < 0) {
00070                         fprintf(stderr, libusb_strerror((libusb_error)r));
00071                         handle = NULL;
00072                 } else {
00073                         if (handle != NULL) {
00074                                 r = libusb_claim_interface(handle, INTERFACE_NUMBER);
00075                                 if (r >= 0) {
00076                                         bDeviceConnected = true; // have interface
00077                                 } else {
00078                                         fprintf(stderr, "libusb_claim_interface error %s\n", libusb_strerror((libusb_error)r));
00079                                 }
00080                         } else {
00081                                 fprintf(stderr, "Unable to find a dpp device.\n");
00082                         }
00083                 }
00084         }
00085
00086 out:
00087         libusb_free_device_list(devs, 1);
00088         return handle;
00089 }
00090
00091 void CDppLibUsb::CloseUSBDevice(libusb_device_handle * devh)
00092 {
00093         int r;
00094         if (devh != NULL) {
00095                 r = libusb_release_interface(devh, INTERFACE_NUMBER);
00096                 if (r < 0) {
00097                         fprintf(stderr, "libusb_release_interface error %s\n", libusb_strerror((libusb_error)r));
00098                 }
00099                 libusb_close(devh);
00100         }
00101 }
00102
00103 int CDppLibUsb::SendPacketUSB(libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[])
00104 {
00105         int bytes_transferred;
00106         unsigned int timeout = 5000;
00107         int result = 0;
00108         int length = 0;
00109
00110         if ((data_out[2] == PID1_REQ_SCOPE_MISC_TO) && data_out[3] == PID2_SEND_DIAGNOSTIC_DATA_TO) {
00111                 timeout = DP5_DIAGDATA_TIMEOUT;
00112         } else {
00113                 timeout = DP5_USB_TIMEOUT;
00114         }
00115
00116         length = data_out[4];
00117         length *= 256;
00118         length += data_out[5];
00119         length += 8;
00120
00121         result = libusb_bulk_transfer(devh, BULK_OUT_ENDPOINT, data_out, length, &bytes_transferred, timeout);
00122         if (result >= 0) {
00123                 result = libusb_bulk_transfer(devh, BULK_IN_ENDPOINT, data_in, MAX_BULK_IN_TRANSFER_SIZE, &bytes_transferred, timeout);
00124                 if (result >= 0) {
00125                         if (bytes_transferred > 0) {
00126                                 return bytes_transferred;
00127                         } else {
00128                                 fprintf(stderr, "No data received in bulk transfer (%d)\n", result);
00129                                 return -1;
00130                         }
00131                 } else {
00132                         fprintf(stderr, "Error receiving data via bulk transfer %d\n", result);
00133                         return result;
00134                 }
00135         } else {
00136                 fprintf(stderr, "Error sending data via bulk transfer %d\n", result);
00137                 return result;
00138         }
00139         return 0;
00140  }
00141
00142 bool CDppLibUsb::isAmptekDP5Device(libusb_device_descriptor desc)
00143 {
00144         bool isDevice=false;
00145         if ((desc.idVendor == AMPTEK_DP5_VENDOR_ID) && (desc.idProduct == AMPTEK_DP5_PRODUCT_ID))
00146         {
00147                 isDevice=true;
00148         }
00149         return isDevice;
00150 }
00151
00152 // Counts number of dpp devices
00153 // Do only when no devices are connected
00154 int CDppLibUsb::CountDP5LibusbDevices()
00155 {
00156         libusb_device **devs;
00157         int iDppCount=0;
00158
00159         ssize_t cnt = libusb_get_device_list (NULL, &devs);
00160         if (cnt < 0)
00161                 return (-1);
00162         int nr = 0, i = 0;
00163         struct libusb_device_descriptor desc;
00164         for (i = 0; i < cnt; ++i)
00165         {
00166                 int r = libusb_get_device_descriptor (devs[i], &desc);
00167                 if (r != 0) {
00168                         fprintf(stderr, libusb_strerror((libusb_error)r));
00169                         continue;
00170                 }
00171                 if (isAmptekDP5Device(desc)) { nr++; }
00172         }
00173         libusb_free_device_list (devs, 1);
00174         iDppCount = (int)nr;
00175         return iDppCount;
00176 }
00177
00178 // Do only when no devices are connected
00179 void CDppLibUsb::PrintDevices()
00180 {
00181         struct libusb_device **devs;
00182         struct libusb_device *dev = NULL;
00183         int i = 0;
00184         ssize_t cnt = 0;
00185
00186         cnt = libusb_get_device_list(NULL, &devs);
00187         if (cnt < 0) {
00188                 fprintf(stderr, "failed to get device list");
00189                 return;
00190         }
00191
00192         while ((dev = devs[i++]) != NULL) {
00193                 struct libusb_device_descriptor desc;
00194                 int r = libusb_get_device_descriptor(dev, &desc);
00195                 if (r < 0) {
00196                         fprintf(stderr, "device descriptor error: %s", libusb_strerror((libusb_error)r));
00197                         return;
00198                 }
00199                 if (isAmptekDP5Device(desc)) {
00200                         printf("%04x:%04x (bus %d, device %d)\n", desc.idVendor, desc.idProduct, libusb_get_bus_number(dev), libusb_get_device_address(dev));
00201                 }
00202         }
00203         libusb_free_device_list(devs, 1);
00204 }
00205
00206 #ifndef LIBUSB_WINUSB_BACKEND
00207 const char * CDppLibUsb::libusb_strerror(enum libusb_error error_code)
00208 {
00209         switch (error_code) {
00210         case LIBUSB_SUCCESS:
00211                 return "Success";
00212         case LIBUSB_ERROR_IO:
00213                 return "Input/output error";
00214         case LIBUSB_ERROR_INVALID_PARAM:
00215                 return "Invalid parameter";
00216         case LIBUSB_ERROR_ACCESS:
00217                 return "Access denied (insufficient permissions)";
00218         case LIBUSB_ERROR_NO_DEVICE:
00219                 return "No such device (it may have been disconnected)";
00220         case LIBUSB_ERROR_NOT_FOUND:
00221                 return "Entity not found";
00222         case LIBUSB_ERROR_BUSY:
00223                 return "Resource busy";
00224         case LIBUSB_ERROR_TIMEOUT:
00225                 return "Operation timed out";
00226         case LIBUSB_ERROR_OVERFLOW:
00227                 return "Overflow";
00228         case LIBUSB_ERROR_PIPE:
00229                 return "Pipe error";
00230         case LIBUSB_ERROR_INTERRUPTED:
00231                 return "System call interrupted (perhaps due to signal)";
00232         case LIBUSB_ERROR_NO_MEM:
00233                 return "Insufficient memory";
00234         case LIBUSB_ERROR_NOT_SUPPORTED:
00235                 return "Operation not supported or unimplemented on this platform";
00236         case LIBUSB_ERROR_OTHER:
00237                 return "Other error";
00238         }
00239         return "Unknown error";
00240 }
00241 #endif
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppLibUsb.h Source File

DeviceIO/DppLibUsb.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 #ifdef _WIN32
00004         #define LIBUSB_WINUSB_BACKEND 1
00005 #endif
00006
00007 #ifdef LIBUSB_WINUSB_BACKEND
00008         #include "libusb.h"
00009         #ifdef _MSC_VER
00010                 #pragma comment(lib, ".\\DeviceIO\\libusb.lib")
00011         #endif
00012 #else
00013         #include <libusb.h>
00014 #endif
00015
00016 #include <stdio.h>
00017 #include <sys/types.h>
00018 #include <string.h>
00019
00020 #define AMPTEK_DP5_VENDOR_ID 0x10C4
00021 #define AMPTEK_DP5_PRODUCT_ID 0x842A
00022
00023 #define INTERFACE_NUMBER 0
00024 #define TIMEOUT_MS 5000
00025 #define BULK_IN_ENDPOINT 0x81
00026 #define BULK_OUT_ENDPOINT 0x02
00027 #define MAX_BULK_IN_TRANSFER_SIZE 32768
00028 #define MAX_BULK_OUT_TRANSFER_SIZE 520
00029 #define STATUS_PACKET_SIZE 64
00030 #define DP5_USB_TIMEOUT 500         // default timeout (500mS)
00031 #define DP5_DIAGDATA_TIMEOUT 2500       // diag data timeout
00032 #define PID1_REQ_SCOPE_MISC_TO 0x03
00033 #define PID2_SEND_DIAGNOSTIC_DATA_TO 0x05
00034
00035
00036 class CDppLibUsb
00037 {
00038 public:
00039         CDppLibUsb(void);
00040         ~CDppLibUsb(void);
00041
00042         unsigned char data_in[MAX_BULK_IN_TRANSFER_SIZE];               // data bytes in
00043         unsigned char data_out[MAX_BULK_OUT_TRANSFER_SIZE];             // data bytes out
00044
00045         libusb_device_handle *DppLibusbHandle;
00046         int NumDevices;
00047         int CurrentDevice;
00048         bool bLibusbReady;
00049         bool bDeviceReady;
00050         char LastLibUsbError[256];
00051         bool bDeviceConnected;
00052
00053         int InitializeLibusb();
00054         void DeinitializeLibusb();
00055         libusb_device_handle * FindUSBDevice(int idxAmptekDevice);
00056         void CloseUSBDevice(libusb_device_handle * devh);
00057         int SendPacketUSB(libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[]);
00058         bool isAmptekDP5Device(libusb_device_descriptor desc);
00059         int CountDP5LibusbDevices();
00060         void PrintDevices();
00061
00062 #ifndef LIBUSB_WINUSB_BACKEND
00063         const char * libusb_strerror(enum libusb_error error_code);
00064 #endif
00065
00066 };
00067
00068
00069
00070
00071
00072
00073
00074
00075
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/DppSlowThreshold.cpp Source File

Config/DppSlowThreshold.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\dppslowthreshold.h"
00003
00004 //--------------------------------------------------------------------------------------
00005 //@doc CDppSlowThreshold
00006 //
00007 //@module DppSlowThreshold.cpp | Threshold Control Functions
00008 //
00009 //This class has the software functionality for Threshold
00010 //controls.
00011 //
00012 // Copyright (c)2004 Amptek, All Rights Reserved
00013 //
00014 //@devnote The Threshold Control Functions run independantly
00015 //from the clsDPPConfig class. Anytime a function is called that updates a
00016 //value, the corresponding clsDPPConfig variable must updated as well.
00017 //
00018 //@devnote Version: v20040629_1613
00019 //
00020 //@head3 CDppSlowThreshold Members |
00021 //@index | CDppSlowThreshold
00022 //
00023 //--------------------------------------------------------------------------------------
00024
00025 CDppSlowThreshold::CDppSlowThreshold(void)
00026 {
00027 }
00028
00029 CDppSlowThreshold::~CDppSlowThreshold(void)
00030 {
00031 }
00032
00033 //@bfield SlowChThreshold | Byte | Slow channel threshold, Events with amplitude lower not added to spectrum
00034 UCHAR CDppSlowThreshold::GetSlowChThreshold() {
00035     return mSlowChThreshold;
00036 }
00037
00038 void CDppSlowThreshold::SetSlowChThreshold(UCHAR SlowChThresholdVal) {
00039     mSlowChThreshold = SlowChThresholdVal;
00040 }
00041
00042 //@mfunc <c CDppSlowThreshold> Threshold Control Setup and Initialization.
00043 //@parm Slow Threshold UpDown Control
00044 //@parm Slow Threshold label
00045 //@parm Slow Threshold label
00046 void CDppSlowThreshold::Thresholds_Setup(CSpinButtonCtrl *udThresholdObj,  CEdit *lblThresholdObj,  CEdit *lblThresholdChannelsObj) {
00047     udThreshold = udThresholdObj;
00048     lblThreshold = lblThresholdObj;
00049     lblThresholdChannels = lblThresholdChannelsObj;
00050         GainChannels = 1024;
00051     //udThreshold.ToolTipText = "Shaped threshold"
00052         udThreshold->SetRange32(0,250);         // set control min,max
00053     //udThreshold.Wrap = True
00054     //udThreshold.Enabled = True
00055     //lblSlowThreshold.Caption = "Slow Threshold"
00056     //lblThreshold.Caption = "lblThreshold"
00057     //lblThreshold.ToolTipText = "Slow Channel Threshold excludes events that should not be added to the stored spectrum"
00058     //udThreshold.Value = 4       // default threhold=4
00059         udThreshold->SetPos(4);                 // default fast threshold=100 // udFThreshold.Value = 100
00060         DPPThreshold(4);
00061 }
00062
00063 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00064 //from a slow threshold value string
00065 //@parm slow threshold value string
00066 //@devnote Used by clsDPPFile.SetDPPControlsFromStr, must set
00067 //clsDPPConfig.SlowChThreshold variable after running.
00068 void CDppSlowThreshold::SetGain(long GainVal)
00069 {
00070         if (GainVal > 8192) {
00071                 GainChannels = 8192;
00072         } else if (GainVal < 256) {
00073                 GainChannels = 256;
00074         } else {
00075                 GainChannels = GainVal;
00076         }
00077 }
00078
00079 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00080 //from a slow threshold value string
00081 //@parm slow threshold value string
00082 //@devnote Used by clsDPPFile.SetDPPControlsFromStr, must set
00083 //clsDPPConfig.SlowChThreshold variable after running.
00084 void CDppSlowThreshold::SetSlowChThresholdFromStr(CString strSlowThresh) {
00085         udThreshold->SetPos(atoi(strSlowThresh));
00086 }
00087
00088 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00089 //from a slow threshold value
00090 //@parm slow threshold value
00091 //@devnote Used by clsDPPFile.SetDPPControlsFromVal, must set
00092 //clsDPPConfig.SlowChThreshold variable after running.
00093 void CDppSlowThreshold::SetSlowChThresholdFromVal(int intSlowThresh) {
00094         udThreshold->SetPos(intSlowThresh);     //udThreshold.Value = intSlowThresh
00095 }
00096
00097 //@mfunc <c CDppSlowThreshold> Set Slow threshold value from a Slow threshold value string
00098 //@parm Slow threshold value string
00099 //@devnote Must set clsDPPConfig.SlowChThreshold variable after running,
00100 //does not update the controls, used for direct
00101 //initialization of the clsDPPConfig class.
00102 void CDppSlowThreshold::SetSlowChThresholdConfigFromStr(CString strSlowThresh) {
00103     mSlowChThreshold = atoi(strSlowThresh);
00104 }
00105
00106 //@mfunc <c CDppSlowThreshold> Slow Threshold Selection Control function.
00107 //
00108 //@comm This sub is used with the udFThreshold control change event.
00109 //
00110 //@ex Calling DPPFThreshold from a control |
00111 //
00112 //Private Sub udFThreshold_Change()
00113 //    clsThreshold.DPPFThreshold
00114 //    dlgDPPCONFIG.SlowChThreshold = clsThreshold.SlowChThreshold
00115 //}
00116 void CDppSlowThreshold::DPPThreshold(int SpinPos) {
00117     //mSlowChThreshold = udThreshold->GetPos();
00118     mSlowChThreshold = SpinPos;
00119     lblThreshold->SetWindowText(GetSlowThreshPcntStr());
00120         lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00121 }
00122
00123 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from current Slow Threshold.
00124 CString CDppSlowThreshold::GetSlowThreshPcntStr() {
00125         CString cstrSlowThresh;
00126         cstrSlowThresh = GetSlowChThresStrFromVal(mSlowChThreshold);
00127         return cstrSlowThresh;
00128 }
00129
00130 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from Slow Threshold value.
00131 //@parm Slow Threshold value
00132 //@rdesc Slow Threshold display text string
00133 CString CDppSlowThreshold::GetSlowChThresStrFromVal(UCHAR byteSlowThres) {
00134         CString cstrSlowThresh;
00135         cstrSlowThresh.Format("%.2f%% FS",((byteSlowThres * 100.0 * 4.0 / 4096 * 100) / 100));
00136         return cstrSlowThresh;
00137 }
00138
00139 //@mfunc <c CDppSlowThreshold> Slow Threshold Selection Control function.
00140 //
00141 //@comm This sub is used with the udFThreshold control change event.
00142 //
00143 //@ex Calling DPPFThreshold from a control |
00144 //
00145 //Private Sub udFThreshold_Change()
00146 //    clsThreshold.DPPFThreshold
00147 //    dlgDPPCONFIG.SlowChThreshold = clsThreshold.SlowChThreshold
00148 //}
00149 void CDppSlowThreshold::txtSlowThreshold_Click()
00150 {
00151         CString cstrSlowThresh;
00152         double dblSlowThresh;
00153         double FSReal;
00154         int FSCFG;
00155     // get value, cast to double, convert to real percent
00156         lblThreshold->GetWindowText(cstrSlowThresh);
00157         dblSlowThresh = atof(cstrSlowThresh);
00158         FSReal = dblSlowThresh / 100.0;
00159         if (FSReal < 0.0) {
00160                 FSReal = 0.0;
00161         } else if (FSReal > 0.2441) {
00162                 FSReal = 0.2441;                                // max is 24.41 percent
00163         }
00164         // convert FSReal to FSCFG to get closest actual setting
00165         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00166         // xtra check
00167         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00168         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00169         // set controls to value, textbox, ud, (when added,) channels textbox
00170     mSlowChThreshold = FSCFG;
00171         udThreshold->SetPos(FSCFG);
00172     lblThreshold->SetWindowText(GetSlowThreshPcntStr());
00173         lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00174 }
00175
00176 UCHAR CDppSlowThreshold::GetSlowThresholdSettingFromPercent(double dblSlowThresh)
00177 {
00178         double FSReal;
00179         int FSCFG;
00180         FSReal = dblSlowThresh / 100.0;
00181         if (FSReal < 0.0) {
00182                 FSReal = 0.0;
00183         } else if (FSReal > 0.2441) {
00184                 FSReal = 0.2441;                                // max is 24.41 percent
00185         }
00186         // convert FSReal to FSCFG to get closest actual setting
00187         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00188         // xtra check
00189         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00190         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00191         return FSCFG;
00192 }
00193
00194 //@mfunc <c CDppSlowThreshold> Slow Threshold Selection Control function.
00195 //
00196 //@comm This sub is used with the udFThreshold control change event.
00197 //
00198 //@ex Calling DPPFThreshold from a control |
00199 //
00200 //Private Sub udFThreshold_Change()
00201 //    clsThreshold.DPPFThreshold
00202 //    dlgDPPCONFIG.SlowChThreshold = clsThreshold.SlowChThreshold
00203 //}
00204 void CDppSlowThreshold::txtSlowThresholdChannels_Click()
00205 {
00206         CString cstrSlowThresh;
00207         double dblSlowThresh;
00208         double FSReal;
00209         int FSCFG;
00210     // get value, cast to double, convert to real percent
00211         lblThresholdChannels->GetWindowText(cstrSlowThresh);
00212         dblSlowThresh = atof(cstrSlowThresh);
00213         FSReal = dblSlowThresh / (double)GainChannels;
00214         if (FSReal < 0.0) {
00215                 FSReal = 0.0;
00216         } else if (FSReal > 0.2441) {
00217                 FSReal = 0.2441;                                // max is 24.41 percent
00218         }
00219         // convert FSReal to FSCFG to get closest actual setting
00220         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00221         // xtra check
00222         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00223         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00224         // set controls to value, textbox, ud, (when added,) channels textbox
00225     mSlowChThreshold = FSCFG;
00226         udThreshold->SetPos(FSCFG);
00227     lblThreshold->SetWindowText(GetSlowThreshPcntStr());
00228         if (!(cstrSlowThresh == GetSlowThreshChStr())) {
00229                 lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00230         }
00231 }
00232
00233 //@mfunc <c SetSlowThresholdFromChannels> Set Slow Threshold from channels value.
00234 //
00235 //@comm This sub is used with auto threshold scaling.
00236 //
00237 UCHAR CDppSlowThreshold::GetSlowThresholdSettingFromChannels(double dblSlowThreshChannels)
00238 {
00239         double FSReal;
00240         int FSCFG;
00241     // get value, cast to double, convert to real percent
00242         FSReal = dblSlowThreshChannels / (double)GainChannels;
00243         if (FSReal < 0.0) {
00244                 FSReal = 0.0;
00245         } else if (FSReal > 0.2441) {
00246                 FSReal = 0.2441;                                // max is 24.41 percent
00247         }
00248         // convert FSReal to FSCFG to get closest actual setting
00249         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00250         // xtra check
00251         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00252         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00253         // set controls to value, textbox, ud, (when added,) channels textbox
00254     mSlowChThreshold = FSCFG;
00255         return mSlowChThreshold;
00256 }
00257
00258 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from Slow Threshold value.
00259 //@parm Slow Threshold value
00260 //@rdesc Slow Threshold display text string
00261 CString CDppSlowThreshold::GetSlowThreshChStr()
00262 {
00263         long lngSlowThresh;
00264         CString cstrSlowThresh;
00265         lngSlowThresh = (long)(((double)mSlowChThreshold * (double)GainChannels / 1024.0) + 0.5);
00266         cstrSlowThresh.Format("%d",lngSlowThresh);
00267         return cstrSlowThresh;
00268 }
00269
00270 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from Slow Threshold value.
00271 //@parm Slow Threshold value
00272 //@rdesc Slow Threshold display text string
00273 CString CDppSlowThreshold::GetSlowThreshChStrFromVal(UCHAR byteSlowThres)
00274 {
00275         long lngSlowThresh;
00276         CString cstrSlowThresh;
00277         lngSlowThresh = (long)(((double)byteSlowThres * (double)GainChannels / 1024.0) + 0.5);
00278         cstrSlowThresh.Format("%d",lngSlowThresh);
00279         return cstrSlowThresh;
00280 }
00281
00282 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00283 //from a slow threshold value string
00284 //@devnote Used by clsDPPFile.SetDPPControlsFromStr, must set
00285 //clsDPPConfig.SlowChThreshold variable after running.
00286 void CDppSlowThreshold::UpdateSlowThresChDisplay()
00287 {
00288         lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00289 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/DppSlowThreshold.h Source File

Config/DppSlowThreshold.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 class CDppSlowThreshold
00004 {
00005
00006 private:
00007         UCHAR mSlowChThreshold;  //Slow ch threshold, Events w/amp lower not added to spectrum
00008         CSpinButtonCtrl *udThreshold;
00009         CEdit *lblThreshold;
00010         CEdit *lblThresholdChannels;
00011         long GainChannels;
00012
00013 public:
00014         CDppSlowThreshold(void);
00015         ~CDppSlowThreshold(void);
00016         UCHAR GetSlowChThreshold();
00017         void SetSlowChThreshold(UCHAR SlowChThresholdVal);
00018         void Thresholds_Setup(CSpinButtonCtrl *udThresholdObj,  CEdit *lblThresholdObj,  CEdit *lblThresholdChannelsObj);
00019         void SetSlowChThresholdFromStr(CString strSlowThresh);
00020         void SetSlowChThresholdFromVal(int intSlowThresh);
00021         void SetSlowChThresholdConfigFromStr(CString strSlowThresh);
00022         void DPPThreshold(int SpinPos);
00023         CString GetSlowThreshPcntStr();
00024         CString GetSlowChThresStrFromVal(UCHAR byteSlowThres);
00025         void txtSlowThreshold_Click();
00026         void txtSlowThresholdChannels_Click();
00027         void SetGain(long GainVal);
00028         CString GetSlowThreshChStr();
00029         CString GetSlowThreshChStrFromVal(UCHAR byteSlowThres);
00030         void UpdateSlowThresChDisplay();
00031         UCHAR GetSlowThresholdSettingFromChannels(double dblSlowThreshChannels);
00032         UCHAR GetSlowThresholdSettingFromPercent(double dblSlowThresh);
00033
00034 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppUtilities.cpp Source File

DeviceIO/DppUtilities.cpp
Go to the documentation of this file.
00001 #include "DppUtilities.h"
00002 #include "stringex.h"
00003
00004 CDppUtilities::CDppUtilities(void)
00005 {
00006 }
00007
00008 CDppUtilities::~CDppUtilities(void)
00009 {
00010 }
00011
00012 // convert a 4 byte long word to a double
00013 // lwStart - starting index of longword
00014 // buffer - byte buffer
00015 double CDppUtilities::LongWordToDouble(int lwStart, unsigned char buffer[])
00016 {
00017         double dblVal;
00018         int idx;
00019         double ByteMask;
00020         dblVal = 0;
00021         for(idx=0;idx<4;idx++) {                // build 4 bytes (lwStart-lwStart+3) into double
00022                 ByteMask = pow(2.0,(8 * idx));
00023                 dblVal = dblVal + (buffer[(lwStart + idx)] * ByteMask);
00024         }
00025         return dblVal;
00026 }
00027
00028 // calculate major.minor version from unsigned char, convert/save to double
00029 double CDppUtilities::BYTEVersionToDouble(unsigned char Version)
00030 {
00031         double dblVersion = 0.0;
00032         stringex strfn;
00033         string strTemp;
00034         strTemp = strfn.Format("%d.%02d",((Version & 240) / 16),(Version & 15));
00035         dblVersion = atof(strTemp.c_str());
00036         return dblVersion;
00037 }
00038
00039 // calculate major.minor version from unsigned char, convert/save to string
00040 string CDppUtilities::BYTEVersionToString(unsigned char Version)
00041 {
00042         string strTemp;
00043         stringex strfn;
00044         strTemp = strfn.Format("%d.%02d",((Version & 240) / 16),(Version & 15));
00045         return strTemp;
00046 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppUtilities.h Source File

DeviceIO/DppUtilities.h
Go to the documentation of this file.
00001 #pragma once
00002 #include <stdlib.h>
00003 #include <math.h>
00004 #include <string>
00005 using namespace std;
00006
00007 class CDppUtilities
00008 {
00009 public:
00010         CDppUtilities(void);
00011         ~CDppUtilities(void);
00013         double LongWordToDouble(int lwStart, unsigned char buffer[]);
00015         double BYTEVersionToDouble(unsigned char Version);
00017         string BYTEVersionToString(unsigned char Version);
00018 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppWinUSB.cpp Source File

DeviceIO/DppWinUSB.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "DppWinUSB.h"
00003
00004 CDppWinUSB::CDppWinUSB(void)
00005 {
00006         WinUsb_Disabled = false;
00007         InitDeviceInfo();
00008         NumPipes = -1;
00009         CurrentDevice = 1;
00010         NumDevices = 0;
00011         USB_Default_Timeout = FALSE;     // flag that non-default timeout is in use
00012 }
00013
00014 CDppWinUSB::~CDppWinUSB(void)
00015 {
00016 }
00017
00018 void CDppWinUSB::Disable_WinUsb()
00019 {
00020         WinUsb_Disabled = true;
00021 }
00022
00023 void CDppWinUSB::InitDeviceInfo()
00024 {
00025         devInfo.deviceHandle = INVALID_HANDLE_VALUE;
00026         devInfo.winUSBHandle = NULL;
00027         devInfo.deviceConnected = FALSE;
00028 }
00029
00030 void CDppWinUSB::CloseDeviceHandle()
00031 {
00032         if ((devInfo.deviceHandle != NULL) && (devInfo.deviceHandle != INVALID_HANDLE_VALUE)) {
00033                 CloseHandle(devInfo.deviceHandle);
00034                 devInfo.deviceHandle = NULL;
00035         }
00036 }
00037
00038 void CDppWinUSB::CloseWinUsbDevice()
00039 {
00040         if (WinUsb_Disabled) return;
00041     if (devInfo.winUSBHandle) {
00042         if (!WinUsb_Free(devInfo.winUSBHandle)) {
00043                         //DSYSERR("-WinUsb_Free failed");
00044                         //MessageBox(NULL,"WinUsb_Free failed","Closing WinUSB",MB_OK);
00045         }
00046         devInfo.winUSBHandle = NULL;
00047     }
00048         CloseDeviceHandle();
00049 }
00050
00051 BOOL CDppWinUSB::GetDevicePath(LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex)
00052 {
00053         BOOL bResult = FALSE;
00054         HDEVINFO deviceInfo;
00055         SP_DEVICE_INTERFACE_DATA interfaceData;
00056         PSP_DEVICE_INTERFACE_DETAIL_DATA detailData = NULL;
00057         unsigned long length;
00058         unsigned long requiredLength=0;
00059         HRESULT hr;
00060
00061         if (WinUsb_Disabled) return FALSE;
00062
00063         // get device information handle
00064         deviceInfo = SetupDiGetClassDevs(InterfaceGuid, NULL, NULL, DIGCF_PRESENT | DIGCF_DEVICEINTERFACE);
00065
00066         // ===== Loop here to find multiple devices ====================
00067         // get interface data for device enumeration (first
00068         interfaceData.cbSize = sizeof(SP_DEVICE_INTERFACE_DATA);
00069         bResult = SetupDiEnumDeviceInterfaces(deviceInfo, NULL, InterfaceGuid, MemberIndex, &interfaceData);
00070         //bResult = SetupDiEnumDeviceInterfaces(deviceInfo, NULL, InterfaceGuid, 0, &interfaceData);
00071         if(FALSE == bResult)  { return FALSE; }
00072
00073         // get the details for the current device interface
00074         bResult = SetupDiGetDeviceInterfaceDetail(deviceInfo, &interfaceData, NULL, 0, &requiredLength, NULL);
00075         detailData = (PSP_DEVICE_INTERFACE_DETAIL_DATA)LocalAlloc(LMEM_FIXED, requiredLength);
00076         if(NULL == detailData) {
00077                 SetupDiDestroyDeviceInfoList(deviceInfo);
00078                 return FALSE;
00079         }
00080         detailData->cbSize = sizeof(SP_DEVICE_INTERFACE_DETAIL_DATA);
00081         length = requiredLength;
00082         bResult = SetupDiGetDeviceInterfaceDetail(deviceInfo, &interfaceData, detailData, length, &requiredLength, NULL);
00083         if(FALSE == bResult)   {
00084                 LocalFree(detailData);
00085                 return FALSE;
00086         }
00087         // copy the device path
00088         hr = StringCchCopy(DevicePath, BufLen, detailData->DevicePath);
00089         if(FAILED(hr)) {
00090                 SetupDiDestroyDeviceInfoList(deviceInfo);
00091                 LocalFree(detailData);
00092         }
00093         LocalFree(detailData);
00094         return bResult;
00095 }
00096
00097 HANDLE CDppWinUSB::OpenDevice(BOOL bSync, DWORD MemberIndex)
00098 {
00099         HANDLE hDev = NULL;
00100         char devicePath[MAX_DEVPATH_LENGTH];
00101         BOOL retVal;
00102
00103         if (WinUsb_Disabled) return INVALID_HANDLE_VALUE;
00104
00105         retVal = GetDevicePath((LPGUID) &GUID_DP5_INTERFACE_CLASS, devicePath, sizeof(devicePath), MemberIndex);
00106         //Error-handling code omitted.
00107         if (retVal) {
00108                 HRESULT hr;
00109                 hr = StringCchCopy(devInfo.devicePath, sizeof(devicePath), devicePath);
00110         }
00111         hDev = CreateFile(devicePath, GENERIC_WRITE | GENERIC_READ, FILE_SHARE_WRITE | FILE_SHARE_READ,
00112                                                 NULL, OPEN_EXISTING, FILE_ATTRIBUTE_NORMAL | FILE_FLAG_OVERLAPPED, NULL);
00113         //Error-handling code omitted.
00114         return hDev;
00115 }
00116
00117 BOOL CDppWinUSB::Initialize_Device(DWORD MemberIndex)
00118 {
00119         BOOL bResult;
00120         WINUSB_INTERFACE_HANDLE usbHandle;
00121         USB_INTERFACE_DESCRIPTOR ifaceDescriptor;
00122         WINUSB_PIPE_INFORMATION pipeInfo;
00123         unsigned char speed;
00124         unsigned long length;
00125         unsigned char bFalse = 0;
00126         unsigned char bTrue = 1;
00127         unsigned long pipeTimeout;
00128
00129         if (WinUsb_Disabled) return false;
00130
00131         pipeTimeout = 500;   // 2/4/10 - seems like 500mS should be plenty?
00132         //Change timeout for Erase FPGA (4 Sec), and Diagnostic Data (2.5 Sec) commands
00133
00134         InitDeviceInfo();
00135         devInfo.deviceHandle = OpenDevice(TRUE, MemberIndex);
00136         bResult = WinUsb_Initialize(devInfo.deviceHandle, &usbHandle);
00137         //[1]
00138         if(bResult) {
00139                 devInfo.winUSBHandle = usbHandle;
00140                 length = sizeof(unsigned char);
00141                 bResult = WinUsb_QueryDeviceInformation(devInfo.winUSBHandle, DEVICE_SPEED, &length, &speed);
00142         }
00143         //[2]
00144         if(bResult)
00145         {
00146                 devInfo.deviceSpeed = speed;
00147                 bResult = WinUsb_QueryInterfaceSettings(devInfo.winUSBHandle, 0, &ifaceDescriptor);
00148         }
00149         if(bResult) {
00150                 NumPipes = ifaceDescriptor.bNumEndpoints;
00151                 for(int i=0;i<ifaceDescriptor.bNumEndpoints;i++) {
00152                         PipeId[i] = INVALID_HANDLE_VALUE;
00153                         PipeTimeout[i] = 500;
00154                         //[3]
00155                         bResult = WinUsb_QueryPipe(devInfo.winUSBHandle, 0, (unsigned char) i, &pipeInfo);
00156                         PipeId[i] = (HANDLE)pipeInfo.PipeId;
00157                         PipeTimeout[i] = pipeTimeout;
00158                         //[4]
00159                         if(pipeInfo.PipeType == UsbdPipeTypeBulk && USB_ENDPOINT_DIRECTION_IN(pipeInfo.PipeId)) {
00160                                 devInfo.bulkInPipe = pipeInfo.PipeId;
00161                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, IGNORE_SHORT_PACKETS, sizeof(unsigned char), &bFalse);
00162                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, AUTO_CLEAR_STALL, sizeof(unsigned char), &bTrue);
00163                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, ALLOW_PARTIAL_READS, sizeof(unsigned char), &bFalse);
00164                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00165                         } else if(pipeInfo.PipeType == UsbdPipeTypeBulk && USB_ENDPOINT_DIRECTION_OUT(pipeInfo.PipeId)) {
00166                                 devInfo.bulkOutPipe = pipeInfo.PipeId;
00167                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, IGNORE_SHORT_PACKETS, sizeof(unsigned char), &bFalse);
00168                                 //WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, SHORT_PACKET_TERMINATE, sizeof(unsigned char), &bTrue);
00169                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, SHORT_PACKET_TERMINATE, sizeof(unsigned char), &bFalse);
00170                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, AUTO_CLEAR_STALL, sizeof(unsigned char), &bTrue);
00171                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00172                         } else if(pipeInfo.PipeType == UsbdPipeTypeInterrupt) {
00173                                 devInfo.interruptPipe = pipeInfo.PipeId;
00174                         } else {
00175                                 bResult = FALSE;
00176                                 break;
00177                         }
00178                 }
00179         }
00180         return bResult;
00181 }
00182
00183 DPP_USB_STATUS CDppWinUSB::FindUSBDevice(DWORD MemberIndex)
00184 {
00185         BOOL bResult;
00186         DPP_USB_STATUS USBStatus;       //0=do nothing, 1=new connect, 2=cannot connect
00187
00188         if (WinUsb_Disabled) return dusbStatConnectFail;
00189
00190         USBStatus = dusbStatNoAction;
00191         if (devInfo.deviceConnected) {          // already connected,do nothing
00192                 return (USBStatus);
00193         }
00194         USBStatus = dusbStatConnectFail;
00195         bResult = Initialize_Device(MemberIndex);               // begin connect sequence
00196         if (! bResult) {                                                                // failed to initialize
00197                 devInfo.deviceConnected = FALSE;
00198                 return (USBStatus);                                                     // return ConnectFail
00199         }
00200         if (devInfo.deviceHandle == NULL) {     // NULL device handle,do nothing
00201                 USBStatus = dusbStatNoAction;
00202                 return (USBStatus);
00203         }
00204         if (devInfo.deviceHandle != INVALID_HANDLE_VALUE) {
00205                 devInfo.deviceConnected = true;
00206                 USBStatus = dusbStatNewConnect;                         // return NewConnect
00207         } else {                                                                                // return ConnectFail
00208                 devInfo.deviceConnected = false;
00209                 CloseWinUsbDevice();
00210         }
00211         //if (devInfo.deviceConnected) {
00212         //      RegDeviceNotification();
00213         //}
00214         return (USBStatus);
00215 }
00216
00217 int CDppWinUSB::CountDP5WinusbDevices(void)
00218 {
00219         int NumDevices = 0;
00220     HKEY hKey;
00221     DWORD retCode;
00222         unsigned char DevicePath[MAXREGBUFFER];
00223     DWORD cbDevicePath;
00224     char KeyName[MAX_PATH];
00225         DWORD cbKeyName;
00226         char ErrMsg[MAXREGBUFFER];
00227         DWORD cbErrMsg;
00228
00229         char* lpDevicePath;
00230
00231         retCode = RegOpenKeyEx(HKEY_LOCAL_MACHINE, WinUSBService, 0, KEY_QUERY_VALUE, &hKey);
00232     if (retCode != ERROR_SUCCESS) {
00233         return 0;
00234     }
00235         // Test ALL Keys (0,1,... are device paths, Count,NextInstance,(Default) have other info)
00236         for (DWORD idxDP5 = 0; idxDP5 < MAXDP5S + 3; idxDP5++) {        //devs + 3 other keys
00237                 cbKeyName = MAX_PATH;
00238                 cbDevicePath = MAXREGBUFFER;
00239                 retCode = RegEnumValue(hKey, idxDP5, KeyName, &cbKeyName, NULL, NULL, &DevicePath[0], &cbDevicePath);
00240                 if (retCode == ERROR_SUCCESS) {
00241                         lpDevicePath = (char*)DevicePath;
00242                         if (!_strnicmp(KeyName, "Count", 5)) {
00243                                 continue;
00244                         } else if (!_strnicmp(lpDevicePath, WinUsbDP5, WinUsbDP5Size)) {        // DP5 device path found
00245                                 //TRACE("DP5 device [%d]: %s=%s\r\n", (NumDevices + 1), KeyName, DevicePath);
00246                                 NumDevices++;
00247                                 continue;
00248                         }
00249                 } else if (retCode == ERROR_NO_MORE_ITEMS) {    // no more values to read
00250                         break;
00251                 } else {                                                                                // error reading values
00252                         cbErrMsg = MAXREGBUFFER;
00253                         FormatMessage(FORMAT_MESSAGE_FROM_SYSTEM, NULL, retCode, MAKELANGID(LANG_NEUTRAL, SUBLANG_DEFAULT), ErrMsg, cbErrMsg, NULL);
00254                         break;
00255                 }
00256         }
00257         RegCloseKey(hKey);
00258     return NumDevices;          /* return number of devices */
00259 }
00260
00261 string CDppWinUSB::USBStatusString(DPP_USB_STATUS USBStatus)
00262 {
00263         string strStatus;
00264         strStatus = "";
00265         switch (USBStatus) {
00266                 case dusbStatNewConnect:
00267                         strStatus = "USB DPP device connected.";
00268                         break;
00269                 case dusbStatConnectFail:
00270                         strStatus = "Cannot connect to USB DPP device.";
00271                         break;
00272         }
00273         return (strStatus);
00274 }
00275
00276 string CDppWinUSB::DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn)
00277 {
00278     unsigned long i;
00279         string strVal("");
00280         string strMsg("");
00281         stringex strfn;
00282         for(i=0;i<bufSizeIn;i++) {
00283                 strVal = strfn.Format("%.2X ",buffer[i]);
00284                 strMsg += strVal;
00285                 if (((i+1) % 16) == 0 ) {
00286                         strMsg += "\r\n";
00287                 } else if (((i+1) % 8) == 0 ) {
00288                         strMsg += "   ";
00289                 }
00290         }
00291         strMsg += "\r\n";
00292         return strMsg;
00293 }
00294
00295 void CDppWinUSB::SaveStringDataToFile(string strData)
00296 {
00297    FILE  *out;
00298    string strFilename;
00299    string strError;
00300    stringex strfn;
00301
00302    strFilename = "CfgHex.txt";
00303
00304    if ( (out = fopen(strFilename.c_str(),"w")) == (FILE *) NULL)
00305       strError = strfn.Format("Couldn't open %s for writing.\n", strFilename.c_str());
00306    else
00307    {
00308       fprintf(out,"%s\n",strData.c_str());
00309    }
00310    fclose(out);
00311 }
00312
00313 bool CDppWinUSB::SendPacketUSB(unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[])
00314 {
00315     unsigned long bytesWritten;
00316         unsigned long bytesRead;
00317     int success;
00318     long PLen;
00319         unsigned long pipeTimeout;
00320
00321     if ((Buffer[2] == PID1_REQ_SCOPE_MISC) && Buffer[3] == PID2_SEND_DIAGNOSTIC_DATA) {
00322                 // Request Diagnostic Packet delay 'USB_DiagDataDelayMS
00323                 pipeTimeout = USB_DiagDataDelayMS;
00324                 success = WinUsb_SetPipePolicy(TestDevInfo.winUSBHandle, TestDevInfo.bulkInPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00325         USB_Default_Timeout = false;     // flag that non-default timeout is in use
00326         } else {
00327         if (USB_Default_Timeout == false) {  // change pipetimeout to default if it isn't already set that way
00328                         pipeTimeout = USB_TIMEOUT;
00329                         success = WinUsb_SetPipePolicy(TestDevInfo.winUSBHandle, TestDevInfo.bulkInPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00330             USB_Default_Timeout = true;      // flag that default timeout is in use
00331         }
00332         }
00333
00334         bytesWritten = NULL;
00335         bytesRead = NULL;
00336         PLen = (Buffer[4] * 256) + Buffer[5] + 8;
00337         success = WinUsb_WritePipe(TestDevInfo.winUSBHandle, TestDevInfo.bulkOutPipe, Buffer, PLen, &bytesWritten, NULL);
00338         Sleep(50);                              // 20110907 Added to improve usb communications while running other processes
00339         if (success) {
00340                 success = WinUsb_ReadPipe(TestDevInfo.winUSBHandle, TestDevInfo.bulkInPipe, PacketIn, 32767, &bytesRead, NULL);
00341                 if (success) {
00342                         return true;
00343                 } else {
00344                         return false;
00345                 }
00346         } else {
00347                 return false;
00348         }
00349 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/DppWinUSB.h Source File

DeviceIO/DppWinUSB.h
Go to the documentation of this file.
00001
00002 #pragma once
00003
00004 // MS var redef bug fix
00005 #ifdef _MP
00006         #undef _MP
00007 #endif
00008 // ====================
00009 // Include Windows headers
00010 #include <Windows.h>
00011 #include <Strsafe.h>
00012 #include "stringex.h"
00013 // Include WinUSB headers
00014 #include <Winusb.h>
00015 #include <Setupapi.h>
00016 #include "guid.h"
00017 #include <Dbt.h>
00018 #include "DP5Protocol.h"
00019
00020 #define MAX_DEVPATH_LENGTH 256
00021 #define MAXDP5S 128                             // max number of devices
00022 #define MAXREGBUFFER 128
00023 #define WinUSBService "SYSTEM\\CurrentControlSet\\Services\\WinUSB\\Enum"
00024 #define WinUsbDP5 "USB\\Vid_10c4&Pid_842a"
00025 #define WinUsbDP5Size 21
00026 #define DRV_INFO_OPTION_NONE 0x00
00027 #define DRV_INFO_OPTION_MFG_NAME 0x01
00028 #define DRV_INFO_OPTION_PROV_NAME 0x02
00029 #define DRV_INFO_OPTION_DESC 0x04
00030 #define DRV_INFO_OPTION_DATE 0x08
00031 #define DRV_INFO_OPTION_VER 0x10
00032 #define DRV_INFO_OPTION_MS_TERM 0x20
00033 #define DRV_INFO_OPTION_UX_TERM 0x40
00034 #define DRV_INFO_OPTION_LABEL 0x80
00035 #define DRV_INFO_OPTION_ALL 0xFF
00036 #define MAXPIPES 10
00037
00038 typedef enum _DPP_USB_STATUS
00039 {
00040         dusbStatNoAction,
00041         dusbStatNewConnect,
00042         dusbStatConnectFail
00043 } DPP_USB_STATUS;
00044
00046 typedef struct WINUSB_DEVICE_INFO
00047 {
00049         HANDLE deviceHandle;
00051         WINUSB_INTERFACE_HANDLE winUSBHandle;
00053         unsigned char deviceSpeed;
00055         unsigned char bulkInPipe;
00057         unsigned char bulkOutPipe;
00059         unsigned char interruptPipe;
00061         char devicePath[MAX_DEVPATH_LENGTH];
00063         BOOL deviceConnected;
00064 } DEVICE_INFO, *PDEVICE_INFO;
00065
00066 class CDppWinUSB
00067 {
00068 public:
00069         CDppWinUSB(void);
00070         ~CDppWinUSB(void);
00071
00072         bool WinUsb_Disabled;
00073         void Disable_WinUsb();
00074
00076         DEVICE_INFO devInfo;
00078         int NumPipes;
00079
00081         HANDLE PipeId[MAXPIPES];
00083         unsigned long PipeTimeout[MAXPIPES];
00085         void InitDeviceInfo();
00087         void CloseDeviceHandle();
00089         void CloseWinUsbDevice();
00091         BOOL GetDevicePath(LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex);
00093         HANDLE OpenDevice(BOOL bSync, DWORD MemberIndex);
00095         BOOL Initialize_Device(DWORD MemberIndex);
00096
00097         // dialog helper functions
00098
00100         DPP_USB_STATUS FindUSBDevice(DWORD MemberIndex);
00102         int CountDP5WinusbDevices(void);
00104         int CurrentDevice;
00106         int NumDevices;
00108         bool isDppFound;
00109
00110         string DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn);
00111         void SaveStringDataToFile(string strData);
00112
00113         string USBStatusString(DPP_USB_STATUS USBStatus);
00114
00116         bool SendPacketUSB(unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[]);
00117         bool USB_Default_Timeout;
00118
00119 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DP5Cfg/FileBrowse.cpp Source File

DP5Cfg/FileBrowse.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\filebrowse.h"
00003
00004 CFileBrowse::CFileBrowse(void)
00005 {
00006         CfgFileFilter = _T("Configuration Files (*.txt)|*.txt|Text Files (*.txt)|*.txt|All Files (*.*)|*.*||");
00007         TxtFileFilter = _T("Text Files (*.txt)|*.txt|All Files (*.*)|*.*||");
00008         ExeFileFilter = _T("Programs (*.exe)|*.exe|All Files (*.*)|*.*||");
00009         BmpFileFilter = _T("Windows Bitmap (*.bmp)|*.bmp|All Files (*.*)|*.*||");
00010
00011         McaFileFilter = _T("Spectra Data Files (*.mca)|*.mca|All Files (*.*)|*.*||");
00012         LibFileFilter = _T("Library Files (*.lib)|*.lib|All Files (*.*)|*.*||");
00013         AllFileFilter = _T("All Files (*.*)|*.*||");
00014 }
00015
00016 CFileBrowse::~CFileBrowse(void)
00017 {
00018 }
00019
00020 BOOL CFileBrowse::DoModal(int DlgType,
00021                                                 CString DlgTitle,
00022                                                 CString FileFilter,
00023                                                 CString DefaultExt,
00024                                                 CString InitDir,
00025                                                 CString* Filename)
00026 {
00027         BOOL bResult = FALSE;
00028         CString strFilter("");
00029         CString strExtension("");
00030         DWORD dwFlags = 0;
00031
00032         if (FileFilter.GetLength() > 1) {
00033                 strFilter = FileFilter;
00034         }
00035         if (DefaultExt.GetLength() > 1) {
00036                 strExtension = DefaultExt;
00037         }
00038         dwFlags = (DlgType) ? OFN_FILEMUSTEXIST : OFN_OVERWRITEPROMPT;
00039         dwFlags |= OFN_HIDEREADONLY;
00040         dwFlags |= OFN_ENABLESIZING;
00041         dwFlags &= ~OFN_CREATEPROMPT; //prevent forced file creation on open
00042
00043         CFileDialog FileDlg(DlgType, strExtension, (*Filename), dwFlags, strFilter);
00044         FileDlg.m_ofn.lpstrTitle = DlgTitle;
00045         if (InitDir.GetLength() > 1) {
00046                 FileDlg.m_ofn.lpstrInitialDir = InitDir;
00047         }
00048         if (FileDlg.DoModal() == IDOK) {
00049                 bResult = TRUE;
00050                 *Filename = FileDlg.GetPathName();
00051         }
00052         return bResult;
00053 }
00054
00055
00056
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DP5Cfg/FileBrowse.h Source File

DP5Cfg/FileBrowse.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 class CFileBrowse {
00004
00005 public:
00006         CFileBrowse(void);
00007         ~CFileBrowse(void);
00008         BOOL DoModal(int DlgType,
00009                                         CString DlgTitle,
00010                                         CString FileFilter,
00011                                         CString DefaultExt,
00012                                         CString InitDir,
00013                                         CString* Filename);
00014         enum DialogType {
00015                 SAVE,
00016                 OPEN
00017         };
00018         // Filter strings
00019         CString CfgFileFilter;
00020         CString TxtFileFilter;
00021         CString ExeFileFilter;
00022         CString BmpFileFilter;
00023         CString McaFileFilter;
00024         CString LibFileFilter;
00025         CString AllFileFilter;
00026 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: hlp/HTMLDefines.h Source File

hlp/HTMLDefines.h
Go to the documentation of this file.
00001
00002 // Commands (ID_* and IDM_*)
00003 #define HIDM_ABOUTBOX                           0x10010
00004 #define HID_FILE_TAB                            0x18128
00005 #define HID_GAINPZ_TAB                          0x18131
00006 #define HID_MCA_TAB                             0x18144
00007 #define HID_MISC_TAB                            0x18147
00008 #define HID_POWER_TAB                           0x1814E
00009 #define HID_SHAPING_TAB                         0x18160
00010 #define HID_HELP_ABOUT                          0x19C43
00011
00012 // Prompts (IDP_*)
00013 #define HIDP_SOCKETS_INIT_FAILED                0x3105A
00014
00015 // Resources (IDR_*)
00016 #define HIDR_MAINFRAME                          0x2105C
00017 #define HIDR_MENU                               0x2105D
00018 #define HIDR_TOOLBAR                            0x21064
00019 #define HIDR_TOOLBAR_DP5_DLG                    0x21065
00020
00021 // Dialogs (IDD_*)
00022 #define HIDD_ABOUTBOX                           0x20064
00023 #define HIDD_BUSY_DLG                           0x21036
00024 #define HIDD_MESSAGE_BOX                        0x2103F
00025 #define HIDD_vcDP5_DIALOG                       0x21C00
00026
00027 // Frame Controls (IDW_*)
00028 // This is a part of the Microsoft Foundation Classes C++ library.
00029 // Copyright (C) Microsoft Corporation
00030 // All rights reserved.
00031 //
00032 // This source code is only intended as a supplement to the
00033 // Microsoft Foundation Classes Reference and related
00034 // electronic documentation provided with the library.
00035 // See these sources for detailed information regarding the
00036 // Microsoft Foundation Classes product.
00037
00038 // Non-Client HitTest help IDs
00039 #define HID_HT_NOWHERE                          0x40000
00040 #define HID_HT_CAPTION                          0x40002
00041 #define HID_HT_SIZE                             0x40004
00042 #define HID_HT_HSCROLL                          0x40006
00043 #define HID_HT_VSCROLL                          0x40007
00044 #define HID_HT_MINBUTTON                        0x40008
00045 #define HID_HT_MAXBUTTON                        0x40009
00046 #define HID_HT_SIZE                             0x4000A // alias: ID_HT_LEFT
00047 #define HID_HT_SIZE                             0x4000B // alias: ID_HT_RIGHT
00048 #define HID_HT_SIZE                             0x4000C // alias: ID_HT_TOP
00049 #define HID_HT_SIZE                             0x4000D // alias: ID_HT_TOPLEFT
00050 #define HID_HT_SIZE                             0x4000E // alias: ID_HT_TOPRIGHT
00051 #define HID_HT_SIZE                             0x4000F // alias: ID_HT_BOTTOM
00052 #define HID_HT_SIZE                             0x40010 // alias: ID_HT_BOTTOMLEFT
00053 #define HID_HT_SIZE                             0x40011 // alias: ID_HT_BOTTOMRIGHT
00054 #define HID_HT_SIZE                             0x40012 // alias: ID_HT_BORDER
00055 #define HID_HT_OBJECT                                                   0x40013
00056 #define HID_HT_CLOSE                                                    0x40014
00057 #define HID_HT_HELP                                                             0x40015
00058
00059 // WM_SYSCOMMAND help IDs
00060 #define HID_SC_SIZE                             0x1EF00
00061 #define HID_SC_MOVE                             0x1EF01
00062 #define HID_SC_MINIMIZE                         0x1EF02
00063 #define HID_SC_MAXIMIZE                         0x1EF03
00064 #define HID_SC_NEXTWINDOW                       0x1EF04
00065 #define HID_SC_PREVWINDOW                       0x1EF05
00066 #define HID_SC_CLOSE                            0x1EF06
00067 #define HID_SC_RESTORE                          0x1EF12
00068 #define HID_SC_TASKLIST                         0x1EF13
00069
00070 // File MRU and aliases
00071 #define HID_FILE_MRU_FILE1                      0x1E110
00072 #define HID_FILE_MRU_FILE1                      0x1E111 // aliases: MRU_2 - MRU_16
00073 #define HID_FILE_MRU_FILE1                      0x1E112
00074 #define HID_FILE_MRU_FILE1                      0x1E113
00075 #define HID_FILE_MRU_FILE1                      0x1E114
00076 #define HID_FILE_MRU_FILE1                      0x1E115
00077 #define HID_FILE_MRU_FILE1                      0x1E116
00078 #define HID_FILE_MRU_FILE1                      0x1E117
00079 #define HID_FILE_MRU_FILE1                      0x1E118
00080 #define HID_FILE_MRU_FILE1                      0x1E119
00081 #define HID_FILE_MRU_FILE1                      0x1E11A
00082 #define HID_FILE_MRU_FILE1                      0x1E11B
00083 #define HID_FILE_MRU_FILE1                      0x1E11C
00084 #define HID_FILE_MRU_FILE1                      0x1E11D
00085 #define HID_FILE_MRU_FILE1                      0x1E11E
00086 #define HID_FILE_MRU_FILE1                      0x1E11F
00087
00088 // Window menu list
00089 #define HID_WINDOW_ALL                          0x1EF1F
00090
00091 // OLE menu and aliases
00092 #define HID_OLE_VERB_1                          0x1E210
00093 #define HID_OLE_VERB_1                          0x1E211 // aliases: VERB_2 -> VERB_16
00094 #define HID_OLE_VERB_1                          0x1E212
00095 #define HID_OLE_VERB_1                          0x1E213
00096 #define HID_OLE_VERB_1                          0x1E214
00097 #define HID_OLE_VERB_1                          0x1E215
00098 #define HID_OLE_VERB_1                          0x1E216
00099 #define HID_OLE_VERB_1                          0x1E217
00100 #define HID_OLE_VERB_1                          0x1E218
00101 #define HID_OLE_VERB_1                          0x1E219
00102 #define HID_OLE_VERB_1                          0x1E21A
00103 #define HID_OLE_VERB_1                          0x1E21B
00104 #define HID_OLE_VERB_1                          0x1E21C
00105 #define HID_OLE_VERB_1                          0x1E21D
00106 #define HID_OLE_VERB_1                          0x1E21E
00107 #define HID_OLE_VERB_1                          0x1E21F
00108
00109 // Commands (HID_*)
00110 #define HID_FILE_NEW                            0x1E100
00111 #define HID_FILE_OPEN                           0x1E101
00112 #define HID_FILE_CLOSE                          0x1E102
00113 #define HID_FILE_SAVE                           0x1E103
00114 #define HID_FILE_SAVE_AS                        0x1E104
00115 #define HID_FILE_PAGE_SETUP                     0x1E105
00116 #define HID_FILE_PRINT_SETUP                    0x1E106
00117 #define HID_FILE_PRINT                          0x1E107
00118 #define HID_FILE_PRINT_DIRECT                   0x1E108
00119 #define HID_FILE_PRINT_PREVIEW                  0x1E109
00120 #define HID_FILE_UPDATE                         0x1E10A
00121 #define HID_FILE_SAVE_COPY_AS                   0x1E10B
00122 #define HID_FILE_SEND_MAIL                      0x1E10C
00123 #define HID_EDIT_CLEAR                          0x1E120
00124 #define HID_EDIT_CLEAR_ALL                      0x1E121
00125 #define HID_EDIT_COPY                           0x1E122
00126 #define HID_EDIT_CUT                            0x1E123
00127 #define HID_EDIT_FIND                           0x1E124
00128 #define HID_EDIT_PASTE                          0x1E125
00129 #define HID_EDIT_PASTE_LINK                     0x1E126
00130 #define HID_EDIT_PASTE_SPECIAL                  0x1E127
00131 #define HID_EDIT_REPEAT                         0x1E128
00132 #define HID_EDIT_REPLACE                        0x1E129
00133 #define HID_EDIT_SELECT_ALL                     0x1E12A
00134 #define HID_EDIT_UNDO                           0x1E12B
00135 #define HID_EDIT_REDO                           0x1E12C
00136 #define HID_WINDOW_NEW                          0x1E130
00137 #define HID_WINDOW_ARRANGE                      0x1E131
00138 #define HID_WINDOW_CASCADE                      0x1E132
00139 #define HID_WINDOW_TILE_HORZ                    0x1E133
00140 #define HID_WINDOW_TILE_VERT                    0x1E134
00141 #define HID_WINDOW_SPLIT                        0x1E135
00142 #define HID_APP_ABOUT                           0x1E140
00143 #define HID_APP_EXIT                            0x1E141
00144 #define HID_HELP_INDEX                          0x1E142
00145 #define HID_HELP_FINDER                         0x1E143
00146 #define HID_HELP_USING                          0x1E144
00147 #define HID_CONTEXT_HELP                        0x1E145
00148 #define HID_NEXT_PANE                           0x1E150
00149 #define HID_PREV_PANE                           0x1E151
00150 #define HID_FORMAT_FONT                         0x1E160
00151 #define HID_OLE_INSERT_NEW                      0x1E200
00152 #define HID_OLE_EDIT_LINKS                      0x1E201
00153 #define HID_OLE_EDIT_CONVERT                    0x1E202
00154 #define HID_OLE_EDIT_CHANGE_ICON                0x1E203
00155 #define HID_OLE_EDIT_PROPERTIES                 0x1E204
00156 #define HID_VIEW_TOOLBAR                        0x1E800
00157 #define HID_VIEW_STATUS_BAR                     0x1E801
00158 #define HID_RECORD_FIRST                        0x1E900
00159 #define HID_RECORD_LAST                         0x1E901
00160 #define HID_RECORD_NEXT                         0x1E902
00161 #define HID_RECORD_PREV                         0x1E903
00162 #define HID_WIZBACK                             0x13023
00163 #define HID_WIZNEXT                             0x13024
00164 #define HID_WIZFINISH                           0x13025
00165
00166 // Dialogs (AFX_HIDD_*)
00167 #define AFX_HIDD_FILEOPEN                       0x27004
00168 #define AFX_HIDD_FILESAVE                       0x27005
00169 #define AFX_HIDD_FONT                           0x27006
00170 #define AFX_HIDD_COLOR                          0x27007
00171 #define AFX_HIDD_PRINT                          0x27008
00172 #define AFX_HIDD_PRINTSETUP                     0x27009
00173 #define AFX_HIDD_FIND                           0x2700A
00174 #define AFX_HIDD_REPLACE                        0x2700B
00175 #define AFX_HIDD_NEWTYPEDLG                     0x27801
00176 #define AFX_HIDD_PRINTDLG                       0x27802
00177 #define AFX_HIDD_PREVIEW_TOOLBAR                0x27803
00178 #define AFX_HIDD_PREVIEW_SHORTTOOLBAR           0x2780B
00179 #define AFX_HIDD_INSERTOBJECT                   0x27804
00180 #define AFX_HIDD_CHANGEICON                     0x27805
00181 #define AFX_HIDD_CONVERT                        0x27806
00182 #define AFX_HIDD_PASTESPECIAL                   0x27807
00183 #define AFX_HIDD_EDITLINKS                      0x27808
00184 #define AFX_HIDD_FILEBROWSE                     0x27809
00185 #define AFX_HIDD_BUSY                           0x2780A
00186 #define AFX_HIDD_OBJECTPROPERTIES               0x2780C
00187 #define AFX_HIDD_CHANGESOURCE                   0x2780D
00188
00189 // Prompts/Errors (AFX_HIDP_*)
00190 #define AFX_HIDP_NO_ERROR_AVAILABLE             0x3F020
00191 #define AFX_HIDP_INVALID_FILENAME               0x3F100
00192 #define AFX_HIDP_FAILED_TO_OPEN_DOC             0x3F101
00193 #define AFX_HIDP_FAILED_TO_SAVE_DOC             0x3F102
00194 #define AFX_HIDP_ASK_TO_SAVE                    0x3F103
00195 #define AFX_HIDP_FAILED_TO_CREATE_DOC           0x3F104
00196 #define AFX_HIDP_FILE_TOO_LARGE                 0x3F105
00197 #define AFX_HIDP_FAILED_TO_START_PRINT          0x3F106
00198 #define AFX_HIDP_FAILED_TO_LAUNCH_HELP          0x3F107
00199 #define AFX_HIDP_INTERNAL_FAILURE               0x3F108
00200 #define AFX_HIDP_COMMAND_FAILURE                0x3F109
00201 #define AFX_HIDP_FAILED_MEMORY_ALLOC            0x3F10A
00202 #define AFX_HIDP_UNREG_DONE                     0x3F10B
00203 #define AFX_HIDP_UNREG_FAILURE                  0x3F10C
00204 #define AFX_HIDP_DLL_LOAD_FAILED                0x3F10D
00205 #define AFX_HIDP_DLL_BAD_VERSION                0x3F10E
00206 #define AFX_HIDP_PARSE_INT                      0x3F110
00207 #define AFX_HIDP_PARSE_REAL                     0x3F111
00208 #define AFX_HIDP_PARSE_INT_RANGE                0x3F112
00209 #define AFX_HIDP_PARSE_REAL_RANGE               0x3F113
00210 #define AFX_HIDP_PARSE_STRING_SIZE              0x3F114
00211 #define AFX_HIDP_PARSE_RADIO_BUTTON             0x3F115
00212 #define AFX_HIDP_PARSE_BYTE                     0x3F116
00213 #define AFX_HIDP_PARSE_UINT                     0x3F117
00214 #define AFX_HIDP_PARSE_DATETIME                 0x3F118
00215 #define AFX_HIDP_PARSE_CURRENCY                 0x3F119
00216 #define AFX_HIDP_FAILED_INVALID_FORMAT          0x3F120
00217 #define AFX_HIDP_FAILED_INVALID_PATH            0x3F121
00218 #define AFX_HIDP_FAILED_DISK_FULL               0x3F122
00219 #define AFX_HIDP_FAILED_ACCESS_READ             0x3F123
00220 #define AFX_HIDP_FAILED_ACCESS_WRITE            0x3F124
00221 #define AFX_HIDP_FAILED_IO_ERROR_READ           0x3F125
00222 #define AFX_HIDP_FAILED_IO_ERROR_WRITE          0x3F126
00223 #define AFX_HIDP_STATIC_OBJECT                  0x3F180
00224 #define AFX_HIDP_FAILED_TO_CONNECT              0x3F181
00225 #define AFX_HIDP_SERVER_BUSY                    0x3F182
00226 #define AFX_HIDP_BAD_VERB                       0x3F183
00227 #define AFX_HIDP_FAILED_TO_NOTIFY               0x3F185
00228 #define AFX_HIDP_FAILED_TO_LAUNCH               0x3F186
00229 #define AFX_HIDP_ASK_TO_UPDATE                  0x3F187
00230 #define AFX_HIDP_FAILED_TO_UPDATE               0x3F188
00231 #define AFX_HIDP_FAILED_TO_REGISTER             0x3F189
00232 #define AFX_HIDP_FAILED_TO_AUTO_REGISTER        0x3F18A
00233 #define AFX_HIDP_FAILED_TO_CONVERT              0x3F18B
00234 #define AFX_HIDP_GET_NOT_SUPPORTED              0x3F18C
00235 #define AFX_HIDP_SET_NOT_SUPPORTED              0x3F18D
00236 #define AFX_HIDP_ASK_TO_DISCARD                 0x3F18E
00237 #define AFX_HIDP_FAILED_TO_CREATE               0x3F18F
00238 #define AFX_HIDP_FAILED_MAPI_LOAD               0x3F190
00239 #define AFX_HIDP_INVALID_MAPI_DLL               0x3F191
00240 #define AFX_HIDP_FAILED_MAPI_SEND               0x3F192
00241 #define AFX_HIDP_FILE_NONE                      0x3F1A0
00242 #define AFX_HIDP_FILE_GENERIC                   0x3F1A1
00243 #define AFX_HIDP_FILE_NOT_FOUND                 0x3F1A2
00244 #define AFX_HIDP_FILE_BAD_PATH                  0x3F1A3
00245 #define AFX_HIDP_FILE_TOO_MANY_OPEN             0x3F1A4
00246 #define AFX_HIDP_FILE_ACCESS_DENIED             0x3F1A5
00247 #define AFX_HIDP_FILE_INVALID_FILE              0x3F1A6
00248 #define AFX_HIDP_FILE_REMOVE_CURRENT            0x3F1A7
00249 #define AFX_HIDP_FILE_DIR_FULL                  0x3F1A8
00250 #define AFX_HIDP_FILE_BAD_SEEK                  0x3F1A9
00251 #define AFX_HIDP_FILE_HARD_IO                   0x3F1AA
00252 #define AFX_HIDP_FILE_SHARING                   0x3F1AB
00253 #define AFX_HIDP_FILE_LOCKING                   0x3F1AC
00254 #define AFX_HIDP_FILE_DISKFULL                  0x3F1AD
00255 #define AFX_HIDP_FILE_EOF                       0x3F1AE
00256 #define AFX_HIDP_ARCH_NONE                      0x3F1B0
00257 #define AFX_HIDP_ARCH_GENERIC                   0x3F1B1
00258 #define AFX_HIDP_ARCH_READONLY                  0x3F1B2
00259 #define AFX_HIDP_ARCH_ENDOFFILE                 0x3F1B3
00260 #define AFX_HIDP_ARCH_WRITEONLY                 0x3F1B4
00261 #define AFX_HIDP_ARCH_BADINDEX                  0x3F1B5
00262 #define AFX_HIDP_ARCH_BADCLASS                  0x3F1B6
00263 #define AFX_HIDP_ARCH_BADSCHEMA                 0x3F1B7
00264 #define AFX_HIDP_SQL_CONNECT_FAIL               0x3F281
00265 #define AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY     0x3F282
00266 #define AFX_HIDP_SQL_EMPTY_COLUMN_LIST          0x3F283
00267 #define AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH      0x3F284
00268 #define AFX_HIDP_SQL_ILLEGAL_MODE               0x3F285
00269 #define AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED     0x3F286
00270 #define AFX_HIDP_SQL_NO_CURRENT_RECORD          0x3F287
00271 #define AFX_HIDP_SQL_NO_ROWS_AFFECTED           0x3F288
00272 #define AFX_HIDP_SQL_RECORDSET_READONLY         0x3F289
00273 #define AFX_HIDP_SQL_SQL_NO_TOTAL               0x3F28A
00274 #define AFX_HIDP_SQL_ODBC_LOAD_FAILED           0x3F28B
00275 #define AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED      0x3F28C
00276 #define AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED     0x3F28D
00277 #define AFX_HIDP_SQL_API_CONFORMANCE            0x3F28E
00278 #define AFX_HIDP_SQL_SQL_CONFORMANCE            0x3F28F
00279 #define AFX_HIDP_SQL_NO_DATA_FOUND              0x3F290
00280 #define AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED   0x3F291
00281 #define AFX_HIDP_SQL_ODBC_V2_REQUIRED           0x3F292
00282 #define AFX_HIDP_SQL_NO_POSITIONED_UPDATES      0x3F293
00283 #define AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED    0x3F294
00284 #define AFX_HIDP_SQL_DATA_TRUNCATED             0x3F295
00285 #define AFX_HIDP_SQL_ROW_FETCH                  0x3F296
00286 #define AFX_HIDP_SQL_INCORRECT_ODBC             0x3F297
00287 #define AFX_HIDP_SQL_UPDATE_DELETE_FAILED       0x3F298
00288 #define AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED       0x3F299
00289 #define AFX_HIDP_SQL_FIELD_NOT_FOUND            0x3F29A
00290 #define AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED    0x3F29B
00291 #define AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED      0x3F29C
00292 #define AFX_HIDP_DAO_ENGINE_INITIALIZATION      0x3F2B0
00293 #define AFX_HIDP_DAO_DFX_BIND                   0x3F2B1
00294 #define AFX_HIDP_DAO_OBJECT_NOT_OPEN            0x3F2B2
00295 #define AFX_HIDP_DAO_ROWTOOSHORT                0x3F2B3
00296 #define AFX_HIDP_DAO_BADBINDINFO                0x3F2B4
00297 #define AFX_HIDP_DAO_COLUMNUNAVAILABLE          0x3F2B5
00298
00299 // Frame Controls (AFX_HIDW_*)
00300 #define AFX_HIDW_TOOLBAR                        0x5E800
00301 #define AFX_HIDW_STATUS_BAR                     0x5E801
00302 #define AFX_HIDW_PREVIEW_BAR                    0x5E802
00303 #define AFX_HIDW_RESIZE_BAR                     0x5E803
00304 #define AFX_HIDW_DOCKBAR_TOP                    0x5E81B
00305 #define AFX_HIDW_DOCKBAR_LEFT                   0x5E81C
00306 #define AFX_HIDW_DOCKBAR_RIGHT                  0x5E81D
00307 #define AFX_HIDW_DOCKBAR_BOTTOM                 0x5E81E
00308 #define AFX_HIDW_DOCKBAR_FLOAT                  0x5E81F
00309
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/INI.cpp Source File

CIni/INI.cpp
Go to the documentation of this file.
00001 // IniFile.cpp: implementation of the CINI class.
00002 //
00004
00005 #include "stdafx.h"
00006 //#include "Readini.h"
00007 #include "INI.h"
00008 #include <afxcoll.h>
00009
00010 #ifdef _DEBUG
00011 #undef THIS_FILE
00012 static char THIS_FILE[]=__FILE__;
00013 #define new DEBUG_NEW
00014 #endif
00015
00016 //
00017 //setINIFileName
00018 // Sets the INI File name to read and write.
00019 //
00020 //getKeyValue
00021 // Used to retrieve a key value given the section and key name.
00022 //
00023 //getSectionData
00024 // Used to retrieve all key/value pairs of a given section.
00025 //
00026 //getSectionNames
00027 // Used to retrieve all the sections in an ini file
00028 //
00029 //sectionExists
00030 // Used to find out if a given section exists.
00031 //
00032 //setKey
00033 // Used to modify the key value or to create a key value pair for the specified section.
00034 //
00035
00036
00038 // Construction/Destruction
00040
00041 CINI::CINI(CString strFile)
00042 {
00043         m_strFileName = strFile;
00044         m_sectionList = new CStringList();
00045         m_sectionDataList = new CStringList();
00046 }
00047
00048 CINI::~CINI()
00049 {
00050         delete m_sectionList;
00051         delete m_sectionDataList;
00052 }
00053
00054 // Used to retrieve a value give the section and key
00055 CString CINI::getKeyValue(CString strKey,CString strSection)
00056 {
00057         char ac_Result[MAX_KEY_DATA_SIZE];
00058
00059         // Get the info from the .ini file
00060         m_lRetValue = GetPrivateProfileString((LPCTSTR)strSection,(LPCTSTR)strKey,
00061                 "",ac_Result, MAX_KEY_DATA_SIZE, (LPCTSTR)m_strFileName);
00062
00063         CString strResult(ac_Result);
00064         return strResult;
00065 }
00066
00067 // Used to add or set a key value pair to a section
00068 long CINI::setKey(CString strValue, CString strKey, CString strSection)
00069 {
00070         m_lRetValue = WritePrivateProfileString (strSection, strKey,
00071                              strValue, m_strFileName);
00072
00073         return m_lRetValue;
00074 }
00075
00076 // Used to delete a key value pair to a section
00077 long CINI::DeleteKey(CString strKey, CString strSection)
00078 {
00079         m_lRetValue = WritePrivateProfileString (strSection, strKey,
00080                              NULL, m_strFileName);
00081
00082         return m_lRetValue;
00083 }
00084
00085 // Used to delete a key value pair to a section
00086 long CINI::DeleteSection(CString strSection)
00087 {
00088         m_lRetValue = WritePrivateProfileString (strSection, NULL,
00089                              NULL, m_strFileName);
00090
00091         return m_lRetValue;
00092 }
00093
00094 // Used to find out if a given section exists
00095 BOOL CINI::sectionExists(CString strSection)
00096 {
00097         char ac_Result[MAX_KEY_DATA_SIZE];
00098         CString csAux;
00099         // Get the info from the .ini file
00100         m_lRetValue = GetPrivateProfileString((LPCTSTR)strSection,NULL,
00101                 "",ac_Result, MAX_KEY_DATA_SIZE, (LPCTSTR)m_strFileName);
00102         // Return if we could retrieve any info from that section
00103         //csAux.Format("%d",m_lRetValue);
00104         //MessageBox(NULL,csAux,"",MB_OK);
00105         return (m_lRetValue > 0);
00106 }
00107
00108 // Used to retrieve all of the  section names in the ini file
00109 CStringList* CINI::getSectionNames()  //returns collection of section names
00110 {
00111         char ac_Result[MAX_SECTION_SIZE];
00112         m_sectionList->RemoveAll();
00113
00114         m_lRetValue = GetPrivateProfileSectionNames(ac_Result,MAX_SECTION_SIZE,(LPCTSTR)m_strFileName);
00115
00116         CString strSectionName;
00117         for(int i=0; i<m_lRetValue; i++)
00118         {
00119                 if(ac_Result[i] != '\0') {
00120                         strSectionName = strSectionName + ac_Result[i];
00121                 } else {
00122                         if(strSectionName != "") {
00123                                 m_sectionList->InsertAfter(m_sectionList->GetTailPosition(),strSectionName);
00124                         }
00125                         strSectionName = "";
00126                 }
00127         }
00128
00129         return m_sectionList;
00130 }
00131
00132 // Used to retrieve all key/value pairs of a given section.
00133 CStringList* CINI::getSectionData(CString strSection)
00134 {
00135         char ac_Result[MAX_SECTION_SIZE];  //change size depending on needs
00136         m_sectionDataList->RemoveAll();
00137         m_lRetValue = GetPrivateProfileSection((LPCTSTR)strSection, ac_Result, MAX_SECTION_SIZE, (LPCTSTR)m_strFileName);
00138
00139         CString strSectionData;
00140         for(int i=0; i<m_lRetValue; i++)
00141         {
00142                 if(ac_Result[i] != '\0') {
00143                         strSectionData = strSectionData + ac_Result[i];
00144                 } else {
00145                         if(strSectionData != "") {
00146                                 m_sectionDataList->InsertAfter(m_sectionDataList->GetTailPosition(),strSectionData);
00147                         }
00148                         strSectionData = "";
00149                 }
00150         }
00151
00152         return m_sectionDataList;
00153 }
00154
00155 void CINI::setINIFileName(CString strINIFile)
00156 {
00157         m_strFileName = strINIFile;
00158 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/INI.h Source File

CIni/INI.h
Go to the documentation of this file.
00001 // IniFile.h: interface for the CINI class.
00002 //
00004
00005 #if !defined(AFX_INIFILE_H__99976B4B_DBA1_4D1E_AA14_CBEB63042FD1__INCLUDED_)
00006 #define AFX_INIFILE_H__99976B4B_DBA1_4D1E_AA14_CBEB63042FD1__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include <afxcoll.h>
00013
00014 #define MAX_SECTION_SIZE 0x7FFF
00015 #define MAX_KEY_DATA_SIZE 0xFF
00016
00017
00018 //
00019 //setINIFileName
00020 // Sets the INI File name to read and write.
00021 //
00022 //getKeyValue
00023 // Used to retrieve a key value given the section and key name.
00024 //
00025 //getSectionData
00026 // Used to retrieve all key/value pairs of a given section.
00027 //
00028 //getSectionNames
00029 // Used to retrieve all the sections in an ini file
00030 //
00031 //sectionExists
00032 // Used to find out if a given section exists.
00033 //
00034 //setKey
00035 // Used to modify the key value or to create a key value pair for the specified section.
00036 //
00037
00038
00039
00040 class CINI
00041 {
00042 public:
00043         void setINIFileName(CString strINIFile);
00044         CStringList* getSectionData(CString strSection);
00045         CStringList* getSectionNames();
00046         BOOL sectionExists(CString strSection);
00047         long setKey(CString strValue, CString strKey, CString strSection);
00048         long DeleteKey(CString strKey, CString strSection);
00049         long CINI::DeleteSection(CString strSection);
00050         CString getKeyValue(CString strKey,CString strSection);
00051         CINI(CString strFile);
00052         CINI()
00053         {
00054                 m_sectionList = new CStringList();
00055                 m_sectionDataList = new CStringList();
00056         }
00057         virtual ~CINI();
00058
00059 private:
00060         CStringList *m_sectionDataList;
00061         CStringList *m_sectionList;
00062         CString m_strSection;
00063         long m_lRetValue;
00064         CString m_strFileName;
00065 };
00066
00067 #endif // !defined(AFX_INIFILE_H__99976B4B_DBA1_4D1E_AA14_CBEB63042FD1__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniEx.cpp Source File

CIni/IniEx.cpp
Go to the documentation of this file.
00001 #include "IniEx.h"
00002
00003 CIniEx::CIniEx(void)
00004 {
00005 }
00006
00007 CIniEx::~CIniEx(void)
00008 {
00009 }
00010
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniEx.h Source File

CIni/IniEx.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 //IniEx.h
00004
00005
00006 class CIniEx
00007 {
00008 public:
00009         CIniEx(void);
00010         ~CIniEx(void);
00011 };
00012
00013
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniUtil.cpp Source File

CIni/IniUtil.cpp
Go to the documentation of this file.
00001
00002 #include "IniUtil.h"
00003
00004 CIniUtil::CIniUtil(void)
00005 {
00006         //m_ValSection = _T("DP5 Configuration Values");
00007 }
00008
00009 CIniUtil::~CIniUtil(void)
00010 {
00011 }
00012
00013 BOOL CIniUtil::GetDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comment)
00014 {
00015         CString m_strSectionName;
00016         CString m_strKeyValue;
00017         int ScPos;
00018         CString strData;
00019         CString strComment;
00020
00021         m_strSectionName = m_strSection;
00022         if(m_strINIFile.IsEmpty()) { return FALSE; }            //Specify INI File name
00023         if(m_strSectionName.IsEmpty()) { return FALSE; }        //Specify section name
00024         ini.setINIFileName(m_strINIFile);
00025         BOOL bExists = ini.sectionExists(m_strSectionName);
00026         if(!bExists) { return FALSE; }                                          //Section doesn't exist
00027         strData.Empty();
00028         m_strKeyValue = ini.getKeyValue(cmdKey,m_strSectionName);
00029         m_strKeyValue.Trim();
00030         if (m_strKeyValue.GetLength() == 0) { return FALSE; }
00031         strComment = "";
00032         ScPos = m_strKeyValue.Find(";",0);
00033         if (ScPos > 0) {                                                                        // save the value if comment
00034                 strData = m_strKeyValue.Left(ScPos);
00035                 strComment = m_strKeyValue.Mid(ScPos + 1);
00036         } else {
00037                 strData = m_strKeyValue;
00038         }
00039         *cmdData = strData;
00040         *Comment = strComment;
00041         return TRUE;
00042 }
00043
00044 BOOL CIniUtil::SaveDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comment)
00045 {
00046         CString m_strSectionName;
00047         CString m_strKeyValue;
00048         CString strData;
00049         BOOL m_lRetValue;
00050
00051         m_strSectionName = m_strSection;
00052         //if(m_strINIFile.IsEmpty()) { return FALSE; }          //Specify INI File name
00053         //if(m_strSectionName.IsEmpty()) { return FALSE; }      //Specify section name
00054         ini.setINIFileName(m_strINIFile);
00055         //BOOL bExists = ini.sectionExists(m_strSectionName);
00056         //if(!bExists) { return FALSE; }                                                //Section doesn't exist
00057         strData = cmdData + ";" + Comment;
00058         m_lRetValue = ini.setKey(strData,cmdKey,m_strSection);
00059         return m_lRetValue;
00060 }
00061
00062 BOOL CIniUtil::GetDP5Section(CString m_strINIFile, CString m_strSection, CStringList* m_strListDP5section)
00063 {
00064         if(m_strINIFile.IsEmpty())
00065         {
00066                 //AfxMessageBox("INI File name error");
00067                 return FALSE;
00068         }
00069         if(m_strSection.IsEmpty())
00070         {
00071                 //AfxMessageBox("Section name error");
00072                 return FALSE;
00073         }
00074
00075         ini.setINIFileName(m_strINIFile);
00076         BOOL bExists = ini.sectionExists(m_strSection);
00077
00078         if(!bExists)
00079         {
00080                 //AfxMessageBox("Section doesn't exist error");
00081                 return FALSE;
00082         }
00083         CStringList* strlstSection = ini.getSectionData(m_strSection);
00084
00085         POSITION posCmd;
00086         //BOOL isComment;
00087         //CString strKey;
00088         //int EqPos;
00089         m_strListDP5section->RemoveAll();
00090         CString strCMD;
00091         for(posCmd = strlstSection->GetHeadPosition(); posCmd != NULL; )
00092         {
00093                 strCMD = strlstSection->GetNext(posCmd);
00094                 //if (isComment) {
00095                 //      strKey = myOtherList->GetNext(position);
00096                 //      EqPos = strKey.Find("=",0);
00097                 //      strKey = strKey.Left(EqPos);
00098                 //      m_ListSectionData.AddString(strKey);
00099                 //} else {
00100
00101                 if(strCMD != "") {
00102                         m_strListDP5section->InsertAfter(m_strListDP5section->GetTailPosition(),strCMD);
00103                 }
00104                 strCMD = "";
00105                 //}
00106         }
00107
00108         return TRUE;
00109 }
00110
00111 CString CIniUtil::ConvertCmdListToCString(CStringList* strCmdList, BOOL AddNewLines, BOOL RemoveComments)
00112 {
00113         CString strCmdCStr;
00114         POSITION posCmd;
00115         int ComPos;
00116         CString strCMD;
00117         strCmdCStr = "";
00118         strCMD = "";
00119         for(posCmd = strCmdList->GetHeadPosition(); posCmd != NULL; )
00120         {
00121                 strCMD = strCmdList->GetNext(posCmd);
00122                 strCMD = strCMD.Trim();
00123                 if (RemoveComments && (strCMD != "")) {
00124                         ComPos = strCMD.Find(";",0);
00125                         //CMDV=*;
00126                         //0123456
00127                         if (ComPos > 5) {                                       // remove the comments
00128                                 strCMD = strCMD.Left(ComPos);
00129                                 strCMD = strCMD.Trim() + ";";
00130                         } else if (ComPos >= 0) {                               // error
00131                                 strCMD = "";
00132                         } else {                                                // check for MS style ini entry
00133                                 strCMD = GetMsIniItem(strCMD);
00134                         }
00135                 }
00136                 if(strCMD != "") {
00137                         if (AddNewLines) { strCMD += "\r\n"; }
00138                         strCmdCStr += strCMD;
00139                 }
00140                 strCMD = "";
00141         }
00142
00143         return strCmdCStr;
00144 }
00145
00146 CString CIniUtil::GetMsIniItem(CString strCmdIn)
00147 {
00148         CString strMsCmd;
00149         int iStart,iEnd;
00150         CString strKey;
00151         CString strData;
00152         CString strCMD;
00153
00154         strCMD = strCmdIn.Trim();
00155         // test for valid command parameters
00156         if (strCMD.GetLength() < 6) { return ""; }      // no data possible
00157         iStart = strCMD.Find("=",0);
00158         if (iStart != 4) { return ""; }                         // data start not found
00159         iEnd = strCMD.Find(";",0);
00160         if (iEnd != -1) {       // terminator found, just strip comments
00161                 strMsCmd = strCMD.Left(iEnd+1);
00162                 return strMsCmd;
00163         }
00164         // appear to have ms ini key data pair, terminate cmd, ret
00165         strMsCmd = strCMD + ";";
00166         return strMsCmd;
00167 }
00168
00169 BOOL CIniUtil::DeleteDP5Key(CString m_strINIFile, CString m_strSection, CString cmdKey)
00170 {
00171         CString m_strSectionName;
00172         CString m_strKeyValue;
00173
00174         m_strSectionName = m_strSection;
00175         if(m_strINIFile.IsEmpty()) { return FALSE; }            //Specify INI File name
00176         if(m_strSectionName.IsEmpty()) { return FALSE; }        //Specify section name
00177         ini.setINIFileName(m_strINIFile);
00178         BOOL bExists = ini.sectionExists(m_strSectionName);
00179         if(!bExists) { return FALSE; }                                          //Section doesn't exist
00180         BOOL isDeleted = ini.DeleteKey(cmdKey,m_strSection);
00181         return TRUE;
00182 }
00183
00184
00185
00186 //void CIniUtil::ListSections()
00187 //{
00188 //      if(m_strINIFile.IsEmpty())
00189 //      {
00190 //              AfxMessageBox("Specify INI File name");
00191 //              return;
00192 //      }
00193 //
00194 //      ini.setINIFileName(m_strINIFile);
00195 //      m_ListSections.ResetContent();
00196 //      m_ListSectionData.ResetContent();
00197 //
00198 //      m_strKeyValue.Empty();
00199 //      UpdateData(FALSE);
00200 //
00201 //      //load listbox from collection returned from getSectionNames();
00202 //      CStringList* strSectionList = ini.getSectionNames();
00203 //      POSITION pos;
00204 //      for(pos = myStringList->GetHeadPosition(); pos != NULL; ) {
00205 //              m_ListSections.AddString(myStringList->GetNext(pos));
00206 //      }
00207 //}
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: CIni/IniUtil.h Source File

CIni/IniUtil.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "INI.h"
00004
00005
00006 class CIniUtil
00007 {
00008 public:
00009         CIniUtil(void);
00010         ~CIniUtil(void);
00011         CINI ini;
00012
00013         BOOL GetDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comments);
00014         BOOL SaveDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comments);
00015         BOOL GetDP5Section(CString m_strINIFile, CString m_strSection, CStringList* m_strListDP5section);
00016         CString ConvertCmdListToCString(CStringList* strCmdList, BOOL AddNewLines, BOOL RemoveComments);
00017         CString GetMsIniItem(CString strCmdIn);
00018         BOOL DeleteDP5Key(CString m_strINIFile, CString m_strSection, CString cmdKey);
00019 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/Label.cpp Source File

Controls/Label.cpp
Go to the documentation of this file.
00001 // Label.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "Resource.h"
00006 #include "Label.h"
00007
00008 #ifdef _DEBUG
00009 #define new DEBUG_NEW
00010 #undef THIS_FILE
00011 static char THIS_FILE[] = __FILE__;
00012 #endif
00013
00015 // CLabel
00016
00017 CLabel::CLabel()
00018 {
00019         NullSet = FALSE;
00020         NullBkColor = GetSysColor(COLOR_3DFACE);
00021         NullTextColor = GetSysColor(COLOR_GRAYTEXT);
00022         LastBkColor = GetSysColor(COLOR_3DFACE);
00023         LastTextColor = GetSysColor(COLOR_WINDOWTEXT);
00024
00025         m_crText = GetSysColor(COLOR_WINDOWTEXT);
00026         m_hBrush = ::CreateSolidBrush(GetSysColor(COLOR_3DFACE));
00027
00028         ::GetObject((HFONT)GetStockObject(DEFAULT_GUI_FONT),sizeof(m_lf),&m_lf);
00029
00030         m_font.CreateFontIndirect(&m_lf);
00031         m_bTimer = FALSE;
00032         m_bState = FALSE;
00033         m_bLink = TRUE;
00034         m_hCursor = NULL;
00035         m_Type = None;
00036
00037         m_hwndBrush = ::CreateSolidBrush(GetSysColor(COLOR_3DFACE));
00038 }
00039
00040
00041 CLabel::~CLabel()
00042 {
00043         m_font.DeleteObject();
00044         ::DeleteObject(m_hBrush);
00045 }
00046
00047 CLabel& CLabel::SetText(const CString& strText)
00048 {
00049         SetWindowText(strText);
00050         return *this;
00051 }
00052
00053 CLabel& CLabel::SetTextColor(COLORREF crText)
00054 {
00055         if (!NullSet) LastTextColor = crText;
00056         m_crText = crText;
00057         RedrawWindow();
00058         return *this;
00059 }
00060
00061 CLabel& CLabel::SetFontBold(BOOL bBold)
00062 {
00063         m_lf.lfWeight = bBold ? FW_BOLD : FW_NORMAL;
00064         ReconstructFont();
00065         RedrawWindow();
00066         return *this;
00067 }
00068
00069 CLabel& CLabel::SetFontUnderline(BOOL bSet)
00070 {
00071         m_lf.lfUnderline = bSet;
00072         ReconstructFont();
00073         RedrawWindow();
00074         return *this;
00075 }
00076
00077 CLabel& CLabel::SetFontItalic(BOOL bSet)
00078 {
00079         m_lf.lfItalic = bSet;
00080         ReconstructFont();
00081         RedrawWindow();
00082         return *this;
00083 }
00084
00085 CLabel& CLabel::SetSunken(BOOL bSet)
00086 {
00087         if (!bSet)
00088                 ModifyStyleEx(WS_EX_STATICEDGE,0,SWP_DRAWFRAME);
00089         else
00090                 ModifyStyleEx(0,WS_EX_STATICEDGE,SWP_DRAWFRAME);
00091
00092         return *this;
00093 }
00094
00095 CLabel& CLabel::SetBorder(BOOL bSet)
00096 {
00097         if (!bSet)
00098                 ModifyStyle(WS_BORDER,0,SWP_DRAWFRAME);
00099         else
00100                 ModifyStyle(0,WS_BORDER,SWP_DRAWFRAME);
00101
00102         return *this;
00103 }
00104
00105 CLabel& CLabel::SetFontSize(int nSize)
00106 {
00107         nSize*=-1;
00108         m_lf.lfHeight = nSize;
00109         ReconstructFont();
00110         RedrawWindow();
00111         return *this;
00112 }
00113
00114
00115 CLabel& CLabel::SetBkColor(COLORREF crBkgnd)
00116 {
00117         if (!NullSet) LastBkColor = crBkgnd;
00118         if (m_hBrush)
00119                 ::DeleteObject(m_hBrush);
00120
00121         m_hBrush = ::CreateSolidBrush(crBkgnd);
00122         return *this;
00123 }
00124
00125 CLabel& CLabel::SetFontName(const CString& strFont)
00126 {
00127         strcpy(m_lf.lfFaceName,strFont);
00128         ReconstructFont();
00129         RedrawWindow();
00130         return *this;
00131 }
00132
00133
00134 BEGIN_MESSAGE_MAP(CLabel, CStatic)
00135         //{{AFX_MSG_MAP(CLabel)
00136         ON_WM_CTLCOLOR_REFLECT()
00137         ON_WM_TIMER()
00138         ON_WM_LBUTTONDOWN()
00139         ON_WM_SETCURSOR()
00140         //}}AFX_MSG_MAP
00141 END_MESSAGE_MAP()
00142
00144 // CLabel message handlers
00145
00146 HBRUSH CLabel::CtlColor(CDC* pDC, UINT nCtlColor)
00147 {
00148         // TODO: Change any attributes of the DC here
00149
00150         // TODO: Return a non-NULL brush if the parent's handler should not be called
00151
00152         if (CTLCOLOR_STATIC == nCtlColor)
00153         {
00154                 pDC->SelectObject(&m_font);
00155                 pDC->SetTextColor(m_crText);
00156                 pDC->SetBkMode(TRANSPARENT);
00157         }
00158
00159
00160         if (m_Type == Background)
00161         {
00162                 if (!m_bState)
00163                         return m_hwndBrush;
00164         }
00165
00166         return m_hBrush;
00167 }
00168
00169 void CLabel::ReconstructFont()
00170 {
00171         m_font.DeleteObject();
00172         BOOL bCreated = m_font.CreateFontIndirect(&m_lf);
00173
00174         ASSERT(bCreated);
00175 }
00176
00177
00178 CLabel& CLabel::FlashText(BOOL bActivate)
00179 {
00180         if (m_bTimer)
00181         {
00182                 SetWindowText(m_strText);
00183                 KillTimer(1);
00184         }
00185
00186         if (bActivate)
00187         {
00188                 GetWindowText(m_strText);
00189                 m_bState = FALSE;
00190
00191                 m_bTimer = TRUE;
00192                 SetTimer(1,500,NULL);
00193                 m_Type = Text;
00194         }
00195
00196         return *this;
00197 }
00198
00199 CLabel& CLabel::FlashBackground(BOOL bActivate)
00200 {
00201
00202         if (m_bTimer)
00203                 KillTimer(1);
00204
00205         if (bActivate)
00206         {
00207                 m_bState = FALSE;
00208
00209                 m_bTimer = TRUE;
00210                 SetTimer(1,500,NULL);
00211
00212                 m_Type = Background;
00213         }
00214
00215         return *this;
00216 }
00217
00218
00219 void CLabel::OnTimer(UINT nIDEvent)
00220 {
00221         m_bState = !m_bState;
00222
00223         switch (m_Type)
00224         {
00225                 case Text:
00226                         if (m_bState)
00227                                 SetWindowText("");
00228                         else
00229                                 SetWindowText(m_strText);
00230                 break;
00231
00232                 case Background:
00233                         InvalidateRect(NULL,FALSE);
00234                         UpdateWindow();
00235                 break;
00236         }
00237
00238         CStatic::OnTimer(nIDEvent);
00239 }
00240
00241 CLabel& CLabel::SetLink(BOOL bLink)
00242 {
00243         m_bLink = bLink;
00244
00245         if (bLink)
00246                 ModifyStyle(0,SS_NOTIFY);
00247         else
00248                 ModifyStyle(SS_NOTIFY,0);
00249
00250         return *this;
00251 }
00252
00253 void CLabel::OnLButtonDown(UINT nFlags, CPoint point)
00254 {
00255         CString strLink;
00256
00257         GetWindowText(strLink);
00258         ShellExecute(NULL,"open",strLink,NULL,NULL,SW_SHOWNORMAL);
00259
00260         CStatic::OnLButtonDown(nFlags, point);
00261 }
00262
00263 BOOL CLabel::OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message)
00264 {
00265         if (m_hCursor)
00266         {
00267                 ::SetCursor(m_hCursor);
00268                 return TRUE;
00269         }
00270
00271         return CStatic::OnSetCursor(pWnd, nHitTest, message);
00272 }
00273
00274 CLabel& CLabel::SetLinkCursor(HCURSOR hCursor)
00275 {
00276         m_hCursor = hCursor;
00277         return *this;
00278 }
00279
00280 void CLabel::SetNullColor()
00281 {
00282         NullSet = TRUE;
00283         SetBkColor(NullBkColor);
00284         SetTextColor(NullTextColor);
00285         NullSet = FALSE;
00286 }
00287
00288 void CLabel::SetLastColor()
00289 {
00290         NullSet = TRUE;
00291         SetBkColor(LastBkColor);
00292         SetTextColor(LastTextColor);
00293         NullSet = FALSE;
00294 }
00295
00296
00297
00298
00299
00300
00301
00302
00303
00304
00305
00306
00307
00308
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/Label.h Source File

Controls/Label.h
Go to the documentation of this file.
00001 #if !defined(AFX_LABEL_H__INCLUDED_)
00002 #define AFX_LABEL_H__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // Label.h : header file
00008 //
00009 #include "X11Color.h"
00010
00012 // CLabel window
00013 enum FlashType {None, Text, Background };
00014
00015 class CLabel : public CStatic
00016 {
00017 // Construction
00018 public:
00019         CLabel();
00020         CLabel& SetBkColor(COLORREF crBkgnd);
00021         CLabel& SetTextColor(COLORREF crText);
00022         CLabel& SetText(const CString& strText);
00023         CLabel& SetFontBold(BOOL bBold);
00024         CLabel& SetFontName(const CString& strFont);
00025         CLabel& SetFontUnderline(BOOL bSet);
00026         CLabel& SetFontItalic(BOOL bSet);
00027         CLabel& SetFontSize(int nSize);
00028         CLabel& SetSunken(BOOL bSet);
00029         CLabel& SetBorder(BOOL bSet);
00030         CLabel& FlashText(BOOL bActivate);
00031         CLabel& FlashBackground(BOOL bActivate);
00032         CLabel& SetLink(BOOL bLink);
00033         CLabel& SetLinkCursor(HCURSOR hCursor);
00034
00035 // Attributes
00036 public:
00037         BOOL NullSet;
00038         COLORREF NullBkColor;
00039         COLORREF NullTextColor;
00040         COLORREF LastBkColor;
00041         COLORREF LastTextColor;
00042         void SetNullColor();
00043         void SetLastColor();
00044
00045 protected:
00046         void ReconstructFont();
00047         COLORREF        m_crText;
00048         HBRUSH          m_hBrush;
00049         HBRUSH          m_hwndBrush;
00050         LOGFONT         m_lf;
00051         CFont           m_font;
00052         CString         m_strText;
00053         BOOL            m_bState;
00054         BOOL            m_bTimer;
00055         BOOL            m_bLink;
00056         FlashType       m_Type;
00057         HCURSOR         m_hCursor;
00058                         // Operations
00059 public:
00060 // Overrides
00061         // ClassWizard generated virtual function overrides
00062         //{{AFX_VIRTUAL(CLabel)
00063         //}}AFX_VIRTUAL
00064
00065 // Implementation
00066 public:
00067         virtual ~CLabel();
00068
00069         // Generated message map functions
00070 protected:
00071         //{{AFX_MSG(CLabel)
00072         afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
00073         afx_msg void OnTimer(UINT nIDEvent);
00074         afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
00075         afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
00076         //}}AFX_MSG
00077
00078         DECLARE_MESSAGE_MAP()
00079 };
00080
00082
00083 //{{AFX_INSERT_LOCATION}}
00084 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00085
00086 #endif // !defined(AFX_LABEL_H__INCLUDED_)
00087
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/MSecTimer.cpp Source File

DeviceIO/MSecTimer.cpp
Go to the documentation of this file.
00001 #include ".\msectimer.h"
00002
00003 CMSecTimer::CMSecTimer(void)
00004 {
00005 }
00006
00007 CMSecTimer::~CMSecTimer(void)
00008 {
00009 }
00010
00011 DWORD CMSecTimer::msTimeDiff(DWORD msStartTime, DWORD msTestTime)
00012 {
00013         DWORD64 RollOver = (DWORD)pow(2.0,32);
00014         DWORD64 msStartTime64;
00015         DWORD64 msTestTime64;
00016         DWORD64 msTimeDiff64;
00017         DWORD msTimeDiff32;
00018         if (msStartTime > msTestTime) { // rollover
00019                 msTestTime64 = (DWORD64)msTestTime + RollOver;
00020                 msStartTime64 = (DWORD64)msStartTime;
00021                 msTimeDiff64 = msTestTime64 - msTestTime64;
00022                 if (msTimeDiff64 < RollOver) {
00023                         msTimeDiff32 = (DWORD)(msTimeDiff64);
00024                 } else {
00025                         msTimeDiff32 = 0;
00026                 }
00027         } else {
00028                 msTimeDiff32 = msTestTime - msStartTime;
00029         }
00030         return (msTimeDiff32);
00031 }
00032
00033 BOOL CMSecTimer::msTimeExpired(DWORD msStartTime, DWORD msDelay)
00034 {
00035         BOOL isExpired;
00036         DWORD msTestTime;
00037         DWORD64 RollOver = (DWORD)pow(2.0,32);
00038         DWORD64 msStartTime64;
00039         DWORD64 msTestTime64;
00040         DWORD64 msTimeDiff64;
00041         DWORD msTimeDiff32;
00042
00043         msTestTime = timeGetTime();
00044         if (msStartTime > msTestTime) { // rollover
00045                 msTestTime64 = (DWORD64)msTestTime + RollOver;
00046                 msStartTime64 = (DWORD64)msStartTime;
00047                 msTimeDiff64 = msTestTime64 - msTestTime64;
00048                 if (msTimeDiff64 < RollOver) {
00049                         msTimeDiff32 = (DWORD)(msTimeDiff64);
00050                 } else {
00051                         msTimeDiff32 = 0;
00052                 }
00053         } else {
00054                 msTimeDiff32 = msTestTime - msStartTime;
00055         }
00056         isExpired = (msTimeDiff32 >= msDelay);
00057         return (isExpired);
00058 }
00059
00060 BOOL CMSecTimer::msTimer(DWORD msDelay)
00061 {
00062         MSG msg;
00063         DWORD msStartTime;
00064         DWORD msTestTime;
00065         BOOL isExpired = FALSE;
00066         DWORD msTimeDiff32 = 0;
00067         msStartTime = timeGetTime();
00068         msTestTime = timeGetTime();
00069         do {
00070                 isExpired = msTimeExpired(msStartTime, msDelay);
00071                 msTimeDiff32 = msTimeDiff(msStartTime, msTestTime);
00072                 if (PeekMessage(&msg, NULL, NULL, NULL, PM_REMOVE))
00073                 {
00074                 TranslateMessage(&msg);
00075                 DispatchMessage(&msg);
00076                 }
00077         } while (!isExpired && (msTimeDiff32 <= msDelay));
00078         return (TRUE);
00079 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/MSecTimer.h Source File

DeviceIO/MSecTimer.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include <math.h>
00004 #include <Mmsystem.h>
00005
00006 class CMSecTimer
00007 {
00008 public:
00009         CMSecTimer(void);
00010         ~CMSecTimer(void);
00011         DWORD msTimeDiff(DWORD msStartTime, DWORD msTestTime);
00012         BOOL msTimeExpired(DWORD msStartTime, DWORD msDelay);
00013         BOOL msTimer(DWORD msDelay);
00014 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: MsgBox.cpp Source File

MsgBox.cpp
Go to the documentation of this file.
00001 // MsgBox.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "resource.h"
00006 #include "MsgBox.h"
00007 #include ".\msgbox.h"
00008
00009
00010 // CMsgBox dialog
00011
00012 IMPLEMENT_DYNAMIC(CMsgBox, CDialog)
00013 CMsgBox::CMsgBox(CWnd* pParent /*=NULL*/)
00014         : CDialog(CMsgBox::IDD, pParent)
00015 {
00016 }
00017
00018 CMsgBox::~CMsgBox()
00019 {
00020 }
00021
00022 void CMsgBox::DoDataExchange(CDataExchange* pDX)
00023 {
00024         CDialog::DoDataExchange(pDX);
00025 }
00026
00027
00028 BEGIN_MESSAGE_MAP(CMsgBox, CDialog)
00029 END_MESSAGE_MAP()
00030
00031
00032 // CMsgBox message handlers
00033
00034 BOOL CMsgBox::OnInitDialog()
00035 {
00036         CDialog::OnInitDialog();
00037
00038         SetWindowText(m_strTitle.c_str());
00039         SetMessage(m_strMessage, m_strDelimiter);
00040
00041         // TODO:  Add extra initialization here
00042
00043         return TRUE;  // return TRUE unless you set the focus to a control
00044         // EXCEPTION: OCX Property Pages should return FALSE
00045 }
00046
00047 void CMsgBox::SetMessage(string strMsg, string strDelimiter)
00048 {
00049         int iHalf;
00050         int iDelimiter; // \r\n ms win
00051         if (strMsg.length() == 0) { return; }
00052         if (strMsg.length() < 100) {
00053                 GetDlgItem(IDC_MESSAGE1)->SetWindowText(strMsg.c_str());
00054                 GetDlgItem(IDC_MESSAGE2)->SetWindowText("");
00055         } else {
00056                 iHalf = (int)(strMsg.length() / 2);
00057                 iDelimiter = (int)strMsg.find(strDelimiter,iHalf);
00058                 if (iDelimiter >= iHalf) {                      // try to find next \r\n
00059                         GetDlgItem(IDC_MESSAGE1)->SetWindowText(strMsg.substr(0,iDelimiter+1).c_str());
00060                         GetDlgItem(IDC_MESSAGE2)->SetWindowText(strMsg.substr(iDelimiter+2).c_str());
00061                 }
00062         }
00063 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: MsgBox.h Source File

MsgBox.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stringex.h"
00003
00004 // CMsgBox dialog
00005
00006 class CMsgBox : public CDialog
00007 {
00008         DECLARE_DYNAMIC(CMsgBox)
00009
00010 public:
00011         CMsgBox(CWnd* pParent = NULL);   // standard constructor
00012         virtual ~CMsgBox();
00013
00014 // Dialog Data
00015         enum { IDD = IDD_MESSAGE_BOX };
00016
00017 protected:
00018         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00019
00020         DECLARE_MESSAGE_MAP()
00021 public:
00022         virtual BOOL OnInitDialog();
00023         string m_strTitle;
00024         string m_strMessage;
00025         string m_strDelimiter;
00026         void SetMessage(string cstrMsg, string m_strDelimiter);
00027
00028
00029 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/NetFinder.cpp Source File

DeviceIO/NetFinder.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "NetFinder.h"
00003 #include <time.h>
00004 #include <math.h>
00005
00006 CNetFinder::CNetFinder(void)
00007 {
00008         InitAllEntries();
00009         m_rand = 0;
00010         LastEntry = NO_ENTRIES;
00011 }
00012
00013 CNetFinder::~CNetFinder(void)
00014 {
00015
00016 }
00017
00018 COLORREF CNetFinder::AlertEntryToCOLORREF(NETDISPLAY_ENTRY *pEntry)
00019 {
00020         COLORREF DppConnectionColor;
00021         DppConnectionColor = AlertByteToCOLORREF(pEntry->alert_level);
00022         return (DppConnectionColor);
00023 }
00024
00025 COLORREF CNetFinder::AlertByteToCOLORREF(unsigned char alert_level)
00026 {
00027         COLORREF DppConnectionColor;
00028         switch(alert_level){                    // Alert Level
00029                 case 0x00:      //0 = Interface is open (unconnected);
00030                         DppConnectionColor = colorGreen;
00031                         break;
00032                 case 0x01:      //1 = Interface is connected (sharing is allowed);
00033                         DppConnectionColor = colorYellow;
00034                         break;
00035                 case 0x02:      //2 = Interface is connected (sharing is not allowed);
00036                         DppConnectionColor = colorRed;
00037                         break;
00038                 case 0x03:      //3 = Interface is locked
00039                         DppConnectionColor = colorRed;
00040                         break;
00041                 case 0x04:      //4 = Interface is unavailable because USB is connected
00042                         DppConnectionColor = colorSilver;
00043                         break;
00044                 default:        //Interface configuration unknown
00045                         DppConnectionColor = colorWhite;
00046                         break;
00047         }
00048         return (DppConnectionColor);
00049 }
00050
00051 CString CNetFinder::EntryToStr(NETDISPLAY_ENTRY *pEntry)
00052 {
00053         CString strAlertLevel;
00054         CString strDeviceType;
00055         CString strIpAddress;
00056         CString strEvent1, strEvent2;
00057         CString strAdditionalDesc;
00058         CString strMacAddress;
00059         CString strEntry;
00060         CString temp_str, temp_str2;
00061
00062         strAlertLevel = "Connection: ";
00063         switch(pEntry->alert_level){                    // Alert Level
00064                 case 0x00:      //0 = Interface is open (unconnected);
00065                         strAlertLevel += "Interface is open (unconnected)";
00066                         break;
00067                 case 0x01:      //1 = Interface is connected (sharing is allowed);
00068                         strAlertLevel += "Interface is connected (sharing is allowed)";
00069                         break;
00070                 case 0x02:      //2 = Interface is connected (sharing is not allowed);
00071                         strAlertLevel += "Interface is connected (sharing is not allowed)";
00072                         break;
00073                 case 0x03:      //3 = Interface is locked
00074                         strAlertLevel += "Interface is locked";
00075                         break;
00076                 case 0x04:      //4 = Interface is unavailable because USB is connected
00077                         strAlertLevel += "Interface is unavailable because USB is connected";
00078                         break;
00079                 default:
00080                         strAlertLevel += "Interface configuration unknown";
00081                         break;
00082         }
00083         strDeviceType = pEntry->str_type;               // Device Name/Type
00084         // IP Address String
00085         strIpAddress.Format("IP Address: %u.%u.%u.%u", (unsigned short) pEntry->ip[0], (unsigned short) pEntry->ip[1],(unsigned short) pEntry->ip[2],(unsigned short) pEntry->ip[3]);
00086         strAdditionalDesc = pEntry->str_description;    // Additional Description
00087         // MacAddress
00088         strMacAddress.Format("MAC Address: %02x-%02x-%02x-%02x-%02x-%02x", (unsigned short) pEntry->mac[0], (unsigned short) pEntry->mac[1],(unsigned short) pEntry->mac[2],(unsigned short) pEntry->mac[3],(unsigned short) pEntry->mac[4],(unsigned short) pEntry->mac[5]);
00089         // Event1 Time
00090         temp_str = pEntry->str_ev1 + " ";
00091         if(pEntry->event1_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event1_days,pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00092         else if(pEntry->event1_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00093         else if(pEntry->event1_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event1_minutes, pEntry->event1_seconds );
00094         else temp_str2.Format("%i seconds", pEntry->event1_seconds );
00095         strEvent1 = temp_str + temp_str2;
00096         // Event2 Time
00097         temp_str = pEntry->str_ev2 + " ";
00098         if(pEntry->event2_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event2_days,pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00099         else if(pEntry->event2_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00100         else if(pEntry->event2_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event2_minutes, pEntry->event2_seconds );
00101         else temp_str2.Format("%i seconds", pEntry->event2_seconds );
00102         strEvent2 = temp_str + temp_str2;
00103
00104         strEntry = strDeviceType + "\r\n";
00105         strEntry += strAlertLevel + "\r\n";
00106         strEntry += strIpAddress + "\r\n";
00107         strEntry += strAdditionalDesc + "\r\n";
00108         strEntry += strMacAddress + "\r\n";
00109         strEntry += strEvent1 + "\r\n";
00110         strEntry += strEvent2 + "\r\n";
00111         return strEntry;
00112 }
00113
00114 CString CNetFinder::EntryToStrRS232(NETDISPLAY_ENTRY *pEntry, CString strPort)
00115 {
00116         CString strAlertLevel;
00117         CString strDeviceType;
00118         CString strIpAddress;
00119         CString strEvent1, strEvent2;
00120         CString strAdditionalDesc;
00121         CString strMacAddress;
00122         CString strEntry;
00123         CString temp_str, temp_str2;
00124
00125         strAlertLevel = "Connection: ";
00126         strAlertLevel += strPort;
00127         //switch(pEntry->alert_level){                  // Alert Level
00128         //      case 0x00:      //0 = Interface is open (unconnected);
00129         //              strAlertLevel += "Interface is open (unconnected)";
00130         //              break;
00131         //      case 0x01:      //1 = Interface is connected (sharing is allowed);
00132         //              strAlertLevel += "Interface is connected (sharing is allowed)";
00133         //              break;
00134         //      case 0x02:      //2 = Interface is connected (sharing is not allowed);
00135         //              strAlertLevel += "Interface is connected (sharing is not allowed)";
00136         //              break;
00137         //      case 0x03:      //3 = Interface is locked
00138         //              strAlertLevel += "Interface is locked";
00139         //              break;
00140         //      case 0x04:      //4 = Interface is unavailable because USB is connected
00141         //              strAlertLevel += "Interface is unavailable because USB is connected";
00142         //              break;
00143         //      default:
00144         //              strAlertLevel += "Interface configuration unknown";
00145         //              break;
00146         //}
00147         strDeviceType = pEntry->str_type;               // Device Name/Type
00148         // IP Address String
00149         strIpAddress.Format("IP Address: %u.%u.%u.%u", (unsigned short) pEntry->ip[0], (unsigned short) pEntry->ip[1],(unsigned short) pEntry->ip[2],(unsigned short) pEntry->ip[3]);
00150         strAdditionalDesc = pEntry->str_description;    // Additional Description
00151         // MacAddress
00152         strMacAddress.Format("MAC Address: %02x-%02x-%02x-%02x-%02x-%02x", (unsigned short) pEntry->mac[0], (unsigned short) pEntry->mac[1],(unsigned short) pEntry->mac[2],(unsigned short) pEntry->mac[3],(unsigned short) pEntry->mac[4],(unsigned short) pEntry->mac[5]);
00153         // Event1 Time
00154         temp_str = pEntry->str_ev1 + " ";
00155         if(pEntry->event1_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event1_days,pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00156         else if(pEntry->event1_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00157         else if(pEntry->event1_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event1_minutes, pEntry->event1_seconds );
00158         else temp_str2.Format("%i seconds", pEntry->event1_seconds );
00159         strEvent1 = temp_str + temp_str2;
00160         // Event2 Time
00161         temp_str = pEntry->str_ev2 + " ";
00162         if(pEntry->event2_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event2_days,pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00163         else if(pEntry->event2_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00164         else if(pEntry->event2_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event2_minutes, pEntry->event2_seconds );
00165         else temp_str2.Format("%i seconds", pEntry->event2_seconds );
00166         strEvent2 = temp_str + temp_str2;
00167
00168         strEntry = strDeviceType + "\r\n";
00169         strEntry += strAlertLevel + "\r\n";
00170         //strEntry += strIpAddress + "\r\n";
00171         strEntry += strAdditionalDesc + "\r\n";
00172         strEntry += strMacAddress + "\r\n";
00173         strEntry += strEvent1 + "\r\n";
00174         //strEntry += strEvent2 + "\r\n";
00175         return strEntry;
00176 }
00177
00178 CString CNetFinder::EntryToStrUSB(NETDISPLAY_ENTRY *pEntry, CString strPort)
00179 {
00180         CString strAlertLevel;
00181         CString strDeviceType;
00182         CString strIpAddress;
00183         CString strEvent1, strEvent2;
00184         CString strAdditionalDesc;
00185         CString strMacAddress;
00186         CString strEntry;
00187         CString temp_str, temp_str2;
00188
00189         strAlertLevel = "Connection: ";
00190         strAlertLevel += strPort;
00191         //switch(pEntry->alert_level){                  // Alert Level
00192         //      case 0x00:      //0 = Interface is open (unconnected);
00193         //              strAlertLevel += "Interface is open (unconnected)";
00194         //              break;
00195         //      case 0x01:      //1 = Interface is connected (sharing is allowed);
00196         //              strAlertLevel += "Interface is connected (sharing is allowed)";
00197         //              break;
00198         //      case 0x02:      //2 = Interface is connected (sharing is not allowed);
00199         //              strAlertLevel += "Interface is connected (sharing is not allowed)";
00200         //              break;
00201         //      case 0x03:      //3 = Interface is locked
00202         //              strAlertLevel += "Interface is locked";
00203         //              break;
00204         //      case 0x04:      //4 = Interface is unavailable because USB is connected
00205         //              strAlertLevel += "Interface is unavailable because USB is connected";
00206         //              break;
00207         //      default:
00208         //              strAlertLevel += "Interface configuration unknown";
00209         //              break;
00210         //}
00211         strDeviceType = pEntry->str_type;               // Device Name/Type
00212         // IP Address String
00213         strIpAddress.Format("IP Address: %u.%u.%u.%u", (unsigned short) pEntry->ip[0], (unsigned short) pEntry->ip[1],(unsigned short) pEntry->ip[2],(unsigned short) pEntry->ip[3]);
00214         strAdditionalDesc = pEntry->str_description;    // Additional Description
00215         // MacAddress
00216         strMacAddress.Format("MAC Address: %02x-%02x-%02x-%02x-%02x-%02x", (unsigned short) pEntry->mac[0], (unsigned short) pEntry->mac[1],(unsigned short) pEntry->mac[2],(unsigned short) pEntry->mac[3],(unsigned short) pEntry->mac[4],(unsigned short) pEntry->mac[5]);
00217         // Event1 Time
00218         temp_str = pEntry->str_ev1 + " ";
00219         if(pEntry->event1_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event1_days,pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00220         else if(pEntry->event1_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00221         else if(pEntry->event1_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event1_minutes, pEntry->event1_seconds );
00222         else temp_str2.Format("%i seconds", pEntry->event1_seconds );
00223         strEvent1 = temp_str + temp_str2;
00224         // Event2 Time
00225         temp_str = pEntry->str_ev2 + " ";
00226         if(pEntry->event2_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event2_days,pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00227         else if(pEntry->event2_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00228         else if(pEntry->event2_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event2_minutes, pEntry->event2_seconds );
00229         else temp_str2.Format("%i seconds", pEntry->event2_seconds );
00230         strEvent2 = temp_str + temp_str2;
00231
00232         strEntry = strDeviceType + "\r\n";
00233         strEntry += strAlertLevel + "\r\n";
00234         //strEntry += strIpAddress + "\r\n";
00235         strEntry += strAdditionalDesc + "\r\n";
00236         strEntry += strMacAddress + "\r\n";
00237         strEntry += strEvent1 + "\r\n";
00238         //strEntry += strEvent2 + "\r\n";
00239         return strEntry;
00240 }
00241
00242 int CNetFinder::FindEntry(unsigned long SockAddr)
00243 {
00244         int idxEntry;
00245         int EntryFound;
00246         EntryFound = NO_ENTRIES;
00247         for (idxEntry=0;idxEntry<=LastEntry;idxEntry++){
00248                 if (SockAddr == DppEntries[idxEntry].SockAddr) {
00249                         EntryFound = idxEntry;
00250                         break;
00251                 }
00252         }
00253         return (EntryFound);
00254 }
00255
00256 void CNetFinder::InitEntry(NETDISPLAY_ENTRY *pEntry)
00257 {
00258         int idxInit;
00259         pEntry->alert_level = 0;
00260
00261         pEntry->event1_days = 0;
00262         pEntry->event1_hours = 0;
00263         pEntry->event1_minutes = 0;
00264
00265         pEntry->event2_days = 0;
00266         pEntry->event2_hours = 0;
00267         pEntry->event2_minutes = 0;
00268
00269         pEntry->event1_seconds = 0;
00270         pEntry->event2_seconds = 0;
00271
00272         pEntry->port = 0; // Get port from UDP header
00273
00274         for (idxInit=0;idxInit<4;idxInit++){
00275                 pEntry->mac[idxInit] = 0;
00276                 pEntry->ip[idxInit] = 0;
00277                 pEntry->subnet[idxInit] = 0;
00278                 pEntry->gateway[idxInit] = 0;
00279         }
00280
00281         pEntry->mac[4] = 0;
00282         pEntry->mac[5] = 0;
00283
00284         pEntry->str_type = "";
00285         pEntry->str_description = "";
00286         pEntry->str_ev1 = "";
00287         pEntry->str_ev2 = "";
00288
00289         pEntry->str_display = "";
00290         pEntry->ccConnectRGB = colorWhite;
00291
00292         pEntry->HasData = FALSE;
00293
00294         pEntry->SockAddr = 0;
00295
00296 }
00297
00298 void CNetFinder::InitAllEntries()
00299 {
00300         for (int idxEntry=0;idxEntry<MAX_ENTRIES;idxEntry++){
00301                 InitEntry(&DppEntries[idxEntry]);
00302         }
00303         LastEntry = NO_ENTRIES;
00304         m_rand = 0;
00305 }
00306
00307 void CNetFinder::AddEntry(NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort)
00308 {
00309         pEntry->alert_level = buffer[1];
00310         pEntry->port = destPort;
00311
00312         int i = 4; // Start buffer index at 4
00313
00314         pEntry->event1_days = ( (int) buffer[i++]<<8 );
00315         pEntry->event1_days |= buffer[i++];
00316
00317         pEntry->event1_hours = buffer[i++];
00318         pEntry->event1_minutes = buffer[i++];
00319
00320         pEntry->event2_days = ( (int) buffer[i++]<<8 );
00321         pEntry->event2_days |= buffer[i++];
00322
00323         pEntry->event2_hours = buffer[i++];
00324         pEntry->event2_minutes = buffer[i++];
00325
00326         pEntry->event1_seconds = buffer[i++];
00327         pEntry->event2_seconds = buffer[i++];
00328
00329         pEntry->mac[0] = buffer[i++];
00330         pEntry->mac[1] = buffer[i++];
00331         pEntry->mac[2] = buffer[i++];
00332         pEntry->mac[3] = buffer[i++];
00333         pEntry->mac[4] = buffer[i++];
00334         pEntry->mac[5] = buffer[i++];
00335
00336         pEntry->ip[0] = buffer[i++];
00337         pEntry->ip[1] = buffer[i++];
00338         pEntry->ip[2] = buffer[i++];
00339         pEntry->ip[3] = buffer[i++];
00340
00341         pEntry->subnet[0] = buffer[i++];
00342         pEntry->subnet[1] = buffer[i++];
00343         pEntry->subnet[2] = buffer[i++];
00344         pEntry->subnet[3] = buffer[i++];
00345
00346         pEntry->gateway[0] = buffer[i++];
00347         pEntry->gateway[1] = buffer[i++];
00348         pEntry->gateway[2] = buffer[i++];
00349         pEntry->gateway[3] = buffer[i++];
00350
00351         pEntry->str_type = &buffer[i];
00352         i += (pEntry->str_type.GetLength()+1);
00353
00354         pEntry->str_description = &buffer[i];
00355         i += (pEntry->str_description.GetLength()+1);
00356
00357         // Copy the Event1+2 text descripion without the ": "
00358         pEntry->str_ev1 = &buffer[i];
00359         i += (pEntry->str_ev1.GetLength()+1);
00360
00361         pEntry->str_ev2 = &buffer[i];
00362         i += (pEntry->str_ev2.GetLength()+1);
00363
00364         // Add ": " to str_ev1 and str_ev2
00365         pEntry->str_ev1 += ": ";
00366         pEntry->str_ev2 += ": ";
00367
00368         pEntry->ccConnectRGB = AlertByteToCOLORREF(pEntry->alert_level);
00369         pEntry->HasData = TRUE;
00370         pEntry->SockAddr = SockAddr_ByteToULong(&buffer[20]);
00371         pEntry->str_display = EntryToStr(pEntry);       // Convert Entry infor to string
00372 }
00373
00374 CString CNetFinder::SockAddr_DlgToStr(CDialog *dlg, int id1, int id2, int id3, int id4)
00375 {
00376         char szAddr[10];
00377         CString strAddr;
00378         CString strID;
00379
00380         memset(&szAddr, 0, sizeof(szAddr));
00381         ::GetDlgItemText(dlg->GetSafeHwnd(), id1, szAddr, sizeof(szAddr));
00382         strID.Format("%s",szAddr);
00383         strAddr = strID.Trim();
00384         memset(&szAddr, 0, sizeof(szAddr));
00385         ::GetDlgItemText(dlg->GetSafeHwnd(), id2, szAddr, sizeof(szAddr));
00386         strID.Format(".%s",szAddr);
00387         strAddr += strID.Trim();
00388         memset(&szAddr, 0, sizeof(szAddr));
00389         ::GetDlgItemText(dlg->GetSafeHwnd(), id3, szAddr, sizeof(szAddr));
00390         strID.Format(".%s",szAddr);
00391         strAddr += strID.Trim();
00392         memset(&szAddr, 0, sizeof(szAddr));
00393         ::GetDlgItemText(dlg->GetSafeHwnd(), id4, szAddr, sizeof(szAddr));
00394         strID.Format(".%s",szAddr);
00395         strAddr += strID.Trim();
00396         return(strAddr);
00397
00398 }
00399
00400
00401 UINT CNetFinder::SockPort_DlgToUINT(CDialog *dlg, int id1)
00402 {
00403         char szPort[10];
00404         UINT Port;
00405         CString strPort;
00406         memset(&szPort, 0, sizeof(szPort));
00407         ::GetDlgItemText(dlg->GetSafeHwnd(), id1, szPort, sizeof(szPort));
00408         Port = atoi(szPort);
00409         return(Port);
00410 }
00411
00412 in_addr CNetFinder::SockAddr_ByteToInAddr(unsigned char *ip)
00413 {
00414         in_addr inSockAddr;
00415         inSockAddr.S_un.S_un_b.s_b1 = ip[0];
00416         inSockAddr.S_un.S_un_b.s_b2 = ip[1];
00417         inSockAddr.S_un.S_un_b.s_b3 = ip[2];
00418         inSockAddr.S_un.S_un_b.s_b4 = ip[3];
00419         return (inSockAddr);
00420 }
00421
00422 unsigned long CNetFinder::SockAddr_ByteToULong(unsigned char *ip)
00423 {
00424         in_addr inSockAddr;
00425         inSockAddr = SockAddr_ByteToInAddr(ip);
00426         return (inSockAddr.S_un.S_addr);
00427 }
00428
00429 CString CNetFinder::SockAddr_ByteToStr(unsigned char *ip)
00430 {
00431         CString strSockAddr;
00432         strSockAddr.Format("%d.%d.%d.%d",ip[0],ip[1],ip[2],ip[3]);
00433         return (strSockAddr);
00434 }
00435
00436 in_addr CNetFinder::SockAddr_StrToInAddr(CString strSockAddr)
00437 {
00438         unsigned long SockAddr;
00439         in_addr inSockAddr;
00440         SockAddr = inet_addr(strSockAddr);
00441         inSockAddr.S_un.S_addr = SockAddr;
00442         return (inSockAddr);
00443 }
00444
00445 unsigned long CNetFinder::SockAddr_StrToULong(CString strSockAddr)
00446 {
00447         unsigned long SockAddr;
00448         SockAddr = inet_addr(strSockAddr);
00449         return (SockAddr);
00450 }
00451
00452 in_addr CNetFinder::SockAddr_ULongToInAddr(unsigned long SockAddr)
00453 {
00454         in_addr inSockAddr;
00455         inSockAddr.S_un.S_addr = SockAddr;
00456         return (inSockAddr);
00457 }
00458
00459 CString CNetFinder::SockAddr_ULongToStr(unsigned long SockAddr)
00460 {
00461         CString strSockAddr;
00462         in_addr inSockAddr;
00463         inSockAddr.S_un.S_addr = SockAddr;
00464         strSockAddr.Format("%s",_T(inet_ntoa(inSockAddr)));
00465         return (strSockAddr);
00466 }
00467
00468 CString CNetFinder::SockAddr_InAddrToStr(in_addr inSockAddr)
00469 {
00470         CString strSockAddr;
00471         strSockAddr.Format("%s",_T(inet_ntoa(inSockAddr)));
00472         return (strSockAddr);
00473 }
00474
00475
00476
00477
00478
00479
00480
00481
00482
00483
00484
00485
00486
00487
00488
00489
00490
00491
00492
00493
00494
00495
00496
00497
00498
00499
00500
00501
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/NetFinder.h Source File

DeviceIO/NetFinder.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "X11Color.h"
00004
00006 // NetFinder Data
00007
00008 typedef struct NETDISPLAY_ENTRY {
00009         unsigned char alert_level;
00010
00011         UINT event1_days;
00012         unsigned char event1_hours;
00013         unsigned char event1_minutes;
00014
00015         UINT event2_days;
00016         unsigned char event2_hours;
00017         unsigned char event2_minutes;
00018
00019         unsigned char event1_seconds;
00020         unsigned char event2_seconds;
00021
00022         unsigned char mac[6];
00023         unsigned char ip[4];
00024         USHORT port; // Get port from UDP header
00025         unsigned char subnet[4];
00026         unsigned char gateway[4];
00027
00028         CString str_type;
00029         CString str_description;
00030         CString str_ev1;
00031         CString str_ev2;
00032
00033         CString str_display;
00034         COLORREF ccConnectRGB;
00035
00036         BOOL HasData;
00037
00038         unsigned long SockAddr;
00039
00040 } NETDISPLAY_ENTRY;
00041
00042 const int NO_ENTRIES = -1;
00043 const int MAX_ENTRIES = 10;
00044
00045 class CNetFinder
00046 {
00047 public:
00048         CNetFinder(void);
00049         ~CNetFinder(void);
00050
00051         int m_rand;
00052         NETDISPLAY_ENTRY DppEntries[MAX_ENTRIES];       // 20140430 changed hardcode to const var
00053         int LastEntry;
00054
00055         unsigned long DppSockAddr;                                      // socket address of selected DPP
00056         int DppEntryIdx;                                        // entry index of selected DPP
00057         BOOL DppFound;                                          // selected DPP found
00058
00059         CString EntryToStr(NETDISPLAY_ENTRY *pEntry);
00060         CString EntryToStrRS232(NETDISPLAY_ENTRY *pEntry, CString strPort);
00061         CString EntryToStrUSB(NETDISPLAY_ENTRY *pEntry, CString strPort);
00062         COLORREF AlertEntryToCOLORREF(NETDISPLAY_ENTRY *pEntry);
00063         COLORREF AlertByteToCOLORREF(unsigned char alert_level);
00064
00065         int FindEntry(unsigned long SockAddr);
00066
00067         CString SockAddr_DlgToStr(CDialog *dlg, int id1, int id2, int id3, int id4);
00068         UINT SockPort_DlgToUINT(CDialog *dlg, int id1);
00069
00070         in_addr SockAddr_ByteToInAddr(unsigned char *ip);
00071         unsigned long SockAddr_ByteToULong(unsigned char *ip);
00072         CString SockAddr_ByteToStr(unsigned char *ip);
00073
00074         in_addr SockAddr_StrToInAddr(CString strSockAddr);      // BYTES in_addr.S_un.S_un_b.s_b*
00075         unsigned long SockAddr_StrToULong(CString strSockAddr);
00076
00077         in_addr SockAddr_ULongToInAddr(unsigned long SockAddr);
00078         CString SockAddr_ULongToStr(unsigned long SockAddr);
00079
00080         CString SockAddr_InAddrToStr(in_addr inSockAddr);
00081
00082         void InitEntry(NETDISPLAY_ENTRY *pEntry);
00083         void InitAllEntries();
00084         void AddEntry(NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort);
00085
00086 };
00087
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/ParsePacket.cpp Source File

DeviceIO/ParsePacket.cpp
Go to the documentation of this file.
00001 #include "ParsePacket.h"
00002
00003 CParsePacket::CParsePacket(void)
00004 {
00005 }
00006
00007 CParsePacket::~CParsePacket(void)
00008 {
00009 }
00010
00011 void CParsePacket::ParsePacketStatus(unsigned char P[], Packet_In *PIN)
00012 {
00013     short X;
00014     long CSum;
00015
00016     CSum = 0;
00017     if (P[0] == SYNC1_) {
00018         if (P[1] == SYNC2_) {
00019             if (P[4] < 128) {  // LEN MSB < 128, i.e. LEN < 32768
00020                 PIN->LEN = (P[4] * 256) + P[5];
00021                 PIN->PID1 = P[2];
00022                 PIN->PID2 = P[3];
00023                                 for (X=0;X <=(PIN->LEN+5);X++) {        // add up all the bytes except checksum
00024                     CSum = CSum + P[X];
00025                 }
00026                 CSum = CSum + 256 * (long)(P[PIN->LEN + 6]) + (long)(P[PIN->LEN + 7]);
00027                 PIN->CheckSum = CSum;
00028                 if ((CSum & 0xFFFF) == 0) {
00029                     PIN->STATUS = 0;      // packet is OK
00030                     if (PIN->LEN > 0) {
00031                                                 for (X=6;X <=(PIN->LEN+5);X++) {
00032                             PIN->DATA[X - 6] = P[X];
00033                                                 }
00034                     }
00035                 } else {
00036                     PIN->STATUS = PID2_ACK_CHECKSUM_ERROR;    // checksum error
00037                 }
00038             } else {
00039                 PIN->STATUS = PID2_ACK_LEN_ERROR;        // length error
00040             }
00041         } else {
00042             PIN->STATUS = PID2_ACK_SYNC_ERROR;            // sync error
00043         }
00044     } else {
00045         PIN->STATUS = PID2_ACK_SYNC_ERROR ;               // sync error
00046     }
00047 }
00048
00049 string CParsePacket::PID2_TextToString(string strPacketSource, unsigned char PID2)
00050 {
00051         string strPID2;
00052         strPID2 = "";
00053         switch (PID2) {
00054                 case PID2_ACK_OK:    // ACK OK
00055             //PID2_TextToString = strPacketSource + ": OK\t";
00056             //strPID2 = "ACK_OK";
00057                         strPID2 = "";
00058             //ACK_Received = True
00059                         break;
00060         case PID2_ACK_SYNC_ERROR:
00061             strPID2 = strPacketSource + ": Sync Error\t";
00062                         break;
00063         case PID2_ACK_PID_ERROR:
00064             strPID2 = strPacketSource + ": PID Error\t";
00065                         break;
00066         case PID2_ACK_LEN_ERROR:
00067             strPID2 = strPacketSource + ": Length Error\t";
00068                         break;
00069         case PID2_ACK_CHECKSUM_ERROR:
00070             strPID2 = strPacketSource + ": Checksum Error\t";
00071                         break;
00072         case PID2_ACK_BAD_PARAM:        // now msg includes bad parameter
00073                         // put the error extractor in a new function
00074                 //[] If PIN.LEN > 0 Then ' BAD CMD (PID2=7), BAD PARAM (PID2=5), NO PC5 (PID2=11) errors return offending command string
00075       //        [] T$ = ""
00076       //        [] For X = 0 To PIN.LEN - 1
00077       //                [] T$ = T$ + Chr(PIN.DATA(X))
00078       //        [] Next X
00079       //        [] End If
00080             strPID2 = strPacketSource + ": Bad Parameter\t";
00081                         break;
00082         case PID2_ACK_BAD_HEX_REC:
00083             strPID2 = strPacketSource + ": Bad HEX Record\t";
00084                         break;
00085         case PID2_ACK_FPGA_ERROR:
00086             strPID2 = strPacketSource + ": FPGA not initialized\t";
00087                         break;
00088         case PID2_ACK_CP2201_NOT_FOUND:
00089             strPID2 = strPacketSource + ": CP2201 not found\t";
00090                         break;
00091         case PID2_ACK_SCOPE_DATA_NOT_AVAIL:
00092             strPID2 = strPacketSource + ": No scope data\t";
00093                         break;
00094         case PID2_ACK_PC5_NOT_PRESENT:
00095             strPID2 = strPacketSource + ": PC5 not present\t";
00096                         break;
00097         case PID2_ACK_OK_ETHERNET_SHARE_REQ:
00098             strPID2 = strPacketSource + ": Ethernet sharing request\t";
00099                         break;
00100         case PID2_ACK_ETHERNET_BUSY:
00101             strPID2 = strPacketSource + ": Ethernet sharing request\t";
00102                         break;
00103                 //[] Case :TextLog "ACK: PC5 NOT DETECTED '" + T$ + "'" + vbCrLf
00104         case PID2_ACK_CAL_DATA_NOT_PRESENT:
00105             strPID2 = strPacketSource + ": Calibration data not present\t";
00106                         break;
00107         case PID2_ACK_UNRECOG:
00108             strPID2 = strPacketSource + ": Unrecognized Command\t";
00109                         break;
00110                 default:
00111                         strPID2 = strPacketSource + ": Unrecognized Error\t";
00112                         break;
00113         }
00114         return strPID2;
00115 }
00116
00117 long CParsePacket::ParsePacket(unsigned char P[], Packet_In *PIN)
00118 {
00119         long ParsePkt;
00120     ParsePkt = preqProcessNone;
00121     ParsePacketStatus (P, PIN);
00122     if (PIN->STATUS == PID2_ACK_OK) { // no errors
00123         if ((PIN->PID1 == PID1_RCV_STATUS) && (PIN->PID2 == PID2_SEND_DP4_STYLE_STATUS)) { // DP4-style status
00124             ParsePkt = preqProcessStatus;
00125         } else if ((PIN->PID1 == PID1_RCV_SPECTRUM) && ((PIN->PID2 >= RCVPT_256_CHANNEL_SPECTRUM) && (PIN->PID2 <= RCVPT_8192_CHANNEL_SPECTRUM_STATUS))) { // spectrum / spectrum+status
00126             ParsePkt = preqProcessSpectrum;
00127         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == PID2_SEND_SCOPE_DATA)) { //scope data packet
00128         //    ParsePkt = preqProcessScopeData;
00129         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == PID2_SEND_512_BYTE_MISC_DATA)) { //text data packet
00130         //    ParsePkt = preqProcessTextData;
00131         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_SCOPE_DATA)) { //scope data packet
00132             //ScopeOverFlow = false;
00133             ParsePkt = preqProcessScopeData;
00134         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_512_BYTE_MISC_DATA)) { //text data packet
00135             ParsePkt = preqProcessTextData;
00136         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_SCOPE_DATA_WITH_OVERFLOW)) { //scope data with overflow packet
00137             //ScopeOverFlow = true;
00138             //ParsePkt = preqProcessScopeData;
00139             ParsePkt = preqProcessScopeDataOverFlow;
00140         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_ETHERNET_SETTINGS)) { //ethernet settings packet
00141             //ParsePkt = preqProcessInetSettings;
00142         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_DIAGNOSTIC_DATA)) { //diagnostic data  packet
00143             ParsePkt = preqProcessDiagData;
00144         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_HARDWARE_DESCRIPTION)) { //hardware description packet
00145             //ParsePkt = preqProcessHwDesc;
00146         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_CONFIG_READBACK)) {
00147             ParsePkt = preqProcessCfgRead;
00148         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_NETFINDER_READBACK)) {
00149             //ParsePkt = preqProcessNetFindRead;
00150         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_OPTION_PA_CALIBRATION)) {
00151             ParsePkt = preqProcessPaCal;
00152         } else if (PIN->PID1 == PID1_ACK) {
00153             ParsePkt = preqProcessAck;
00154         } else {
00155             PIN->STATUS = PID2_ACK_PID_ERROR;  // unknown PID
00156             ParsePkt = preqProcessError;
00157         }
00158     } else {
00159         ParsePkt = preqProcessError;
00160     }
00161
00162     //PIN->PID1 = 0;    // overwrite the PIDs so packet can't be erroneously processed again
00163     //PIN->PID2 = 0;
00164
00165         return ParsePkt;
00166 }
00167
00168 //ElseIf PIN.PID2 = 7 Then ' Config readback response packet
00169 //    txtConfig.Text = ""
00170 //    For X = 0 To PIN.LEN - 1
00171 //        txtConfig.Text = txtConfig.Text + Chr(PIN.DATA(X))
00172 //        If Chr(PIN.DATA(X)) = ";" Then
00173 //            txtConfig.Text = txtConfig.Text + vbCrLf
00174 //        End If
00175 //    Next X
00176
00177
00178
00179
00180
00181
00182
00183
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/ParsePacket.h Source File

DeviceIO/ParsePacket.h
Go to the documentation of this file.
00001
00002 #pragma once
00003
00004 #include <string>
00005 #include "DP5Protocol.h"
00006 using namespace std;
00007
00008 typedef enum _CommType {
00009     commNone = 0,
00010     commRS232 = 1,
00011     commUSB = 2,
00012     commSockets = 3
00013 } CommType;
00014
00015 #define preqProcessNone 0x0
00016 #define preqProcessStatus 0x1
00017 #define preqProcessSpectrum 0x2
00018 #define preqRequestScopeData 0x4
00019 #define preqProcessScopeData 0x8
00020 #define preqProcessTextData 0x10
00021 #define preqProcessScopeDataOverFlow 0x20
00022 #define preqProcessInetSettings 0x40
00023 #define preqProcessDiagData 0x80
00024 #define preqProcessHwDesc 0x100
00025 #define preqProcessCfgRead 0x200
00026 #define preqProcessNetFindRead 0x400
00027 #define preqProcessPaCal 0x800
00028 //...
00029 #define preqProcessSCAData 0x2000
00030 #define preqProcessAck 0x4000
00031 #define preqProcessError 0x8000
00032
00033 typedef struct _DppStateType {
00034     CommType Interface;
00035     string strPort;
00036     unsigned long ReqProcess;
00037     bool HaveScopeData;
00038     bool ScopeAutoRearm;
00039         bool ScopeOverFlow;
00040 } DppStateType;
00041
00042 class CParsePacket
00043 {
00044 public:
00045         CParsePacket(void);
00046         ~CParsePacket(void);
00048         DppStateType DppState;
00050         void ParsePacketStatus(unsigned char P[], Packet_In *PIN);
00052         string PID2_TextToString(string strPacketSource, unsigned char PID2);
00054         long ParsePacket(unsigned char P[], Packet_In *PIN);
00055 };
00056
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/PlotCanvas.cpp Source File

Controls/PlotCanvas.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include <math.h>
00003 #include "PlotCanvas.h"
00004 #include ".\PlotCanvas.h"
00005
00007 // CPlotCanvas
00008
00009 CPlotCanvas::CPlotCanvas()
00010 {
00011         m_crDisplayBGColor = ctrlColWhite;
00012         m_crPlotColor = ctrlColRed;
00013         m_crCursorColor = ctrlColBlack;
00014         m_crTextFGColor = ctrlColBlack;
00015         m_crTextBGColor = ctrlColWhite;
00016
00017         hasBackground = false;
00018         PersistenceMode = false;
00019         CursorPosition = -1;    // don't plot if not set
00020         XPlotMAX = 0;
00021         YPlotMAX = 0;
00022         for(int i=0; i<8192;i++) {
00023                 YPlotBuffer[i] = 0;
00024         }
00025         OptScaleType = false;   //true = log,false=linear
00026         OptPlotType = false;    //true = line,false=solid
00027 }
00028
00029 CPlotCanvas::~CPlotCanvas()
00030 {
00031 }
00032
00033 BEGIN_MESSAGE_MAP(CPlotCanvas, CStatic)
00034         //{{AFX_MSG_MAP(CPlotCanvas)
00035         ON_WM_ERASEBKGND()
00036         ON_WM_PAINT()
00037         ON_WM_LBUTTONDOWN()
00038         //}}AFX_MSG_MAP
00039 END_MESSAGE_MAP()
00040
00042 // CPlotCanvas message handlers
00043
00046 BOOL CPlotCanvas::OnEraseBkgnd(CDC* pDC)
00047 {
00048         return TRUE;    // do not erase background
00049 }
00050
00053 void CPlotCanvas::OnRefreshBkgnd()
00054 {
00055         hasBackground = false;  // redraw background
00056 }
00057
00060 void CPlotCanvas::OnPaint()
00061 {
00062         CPaintDC dc(this); // device context for painting
00063         CRect rect;
00064         GetClientRect(&rect);
00065         DrawPlotCanvas(&rect,&dc);
00066 }
00067
00069 // DrawPlotCanvas
00070 // The DrawPlotCanvas method will draw a compas with the heading centered.
00072 void CPlotCanvas::DrawPlotCanvas(CRect *pRect, CDC *pDCa)
00073 {
00074         BOOL isPlotPen = TRUE;
00075         BOOL CurrentPen = TRUE;         //true=plot pen, false =roi pen
00076         CDC *pDC = pDCa;                                        // Get DC if no DC is passed
00077         if(pDCa == NULL) pDC = GetDC();
00078         CDC dcMem;                                                      // Create temporary work DC (memory DC) and bitmap
00079         CBitmap bmTemp;
00080         dcMem.CreateCompatibleDC(pDC);
00081         bmTemp.CreateCompatibleBitmap( pDC,pRect->Width(),pRect->Height() );
00082         CBitmap *pbmOld = dcMem.SelectObject(&bmTemp);
00083         CRect rect = *pRect;
00084         dcMem.BitBlt(0, 0, rect.Width(), rect.Height(), pDC, 0, 0, SRCCOPY) ;
00085         CString strRectInfo;
00086         strRectInfo.Format("Width: %d  Height: %d", rect.Width(), rect.Height());
00087
00088         // Draw background rectangle
00089         CBrush WorkSpaceBrush( m_crDisplayBGColor );
00090         CBrush *pOldBrush = dcMem.SelectObject(&WorkSpaceBrush);
00091         CPen *pOldPen = (CPen *)dcMem.SelectStockObject( NULL_PEN );
00092         if (!hasBackground || !PersistenceMode) {
00093                 dcMem.Rectangle(&rect);
00094                 dcMem.Draw3dRect(&rect, (COLORREF)GetSysColor(COLOR_3DSHADOW), (COLORREF)GetSysColor(COLOR_3DHILIGHT));
00095                 hasBackground = true;
00096         }
00097         //dcMem.SelectStockObject( BLACK_PEN);
00098         dcMem.SelectStockObject(WHITE_PEN);
00099         CRgn rgnRect;                           // Create rgn
00100         rgnRect.CreateRectRgn(rect.left,rect.top,rect.right,rect.bottom);
00101         dcMem.SelectClipRgn(&rgnRect);
00102         rect = *pRect;
00103
00104         // Create a font and set color
00105         CFont cFont,*cpOldFont;
00106         cFont.CreatePointFont(70,_T("Arial"));
00107         cpOldFont = (CFont *)dcMem.SelectObject(&cFont);
00108         COLORREF crOldBkColor = dcMem.SetBkColor( m_crDisplayBGColor );
00109         TEXTMETRIC tm;
00110         dcMem.GetTextMetrics(&tm);
00111         // change color of plotting pen
00112         CPen PlottingPen( PS_SOLID, 1, RGB(255,0,0) );
00113         CPen RoiPen( PS_SOLID, 1, RGB(0,0,255) );
00114         dcMem.SelectObject( &PlottingPen );
00115         dcMem.MoveTo(0, rect.bottom - YPlotBuffer[0]);
00116         double XScaleFactor;
00117         if (XPlotMAX > 0) {
00118                 XScaleFactor = (double) rect.Width();
00119                 XScaleFactor /= (double)(XPlotMAX + 1);
00120         } else {
00121                 XScaleFactor = (double) rect.Width();
00122         }
00123         double YScaleFactor;
00124         if (YPlotMAX > 0) {
00125                 YScaleFactor = (double) rect.Height();
00126                 YScaleFactor /= (double)(YPlotMAX + 1);
00127         } else {
00128                 YScaleFactor = (double) rect.Height();
00129         }
00130         for(int X=0; X<=XPlotMAX; X++) {
00136
00141
00142                 if (OptPlotType) {
00143                         dcMem.LineTo((int)(X * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X]* YScaleFactor)));
00144                         dcMem.LineTo((int)((X + 1) * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X + 1]* YScaleFactor)));
00145                 } else {
00146                         dcMem.LineTo((int)(X * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X]* YScaleFactor)));
00147                         dcMem.LineTo((int)((X + 1) * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X + 1]* YScaleFactor)));
00148                         dcMem.MoveTo((int)(X * XScaleFactor),rect.bottom);
00149                         dcMem.LineTo((int)(X * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X]* YScaleFactor)));
00150                         dcMem.MoveTo((int)((X + 1) * XScaleFactor), rect.bottom);
00151                         dcMem.LineTo((int)((X + 1) * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X + 1]* YScaleFactor)));
00152                 }
00153     }
00154         CPen MarkerPen( PS_SOLID, 1, RGB(0,0,255) );
00155         dcMem.SelectObject( &MarkerPen );
00156         DrawCursor( &dcMem, YPlotBuffer, false);
00157         dcMem.SelectObject( &MarkerPen );
00158
00159         //
00160         // finally draw to screen from temperary dc
00161         //
00162         pDC->BitBlt(0,0,rect.Width(),rect.Height(),&dcMem,0,0,SRCCOPY);
00163
00165         pDC->SelectClipRgn(NULL);
00166         rgnRect.DeleteObject();
00167         dcMem.SelectObject(pOldBrush);
00168         WorkSpaceBrush.DeleteObject();
00169         dcMem.SetBkColor( crOldBkColor );
00170         dcMem.SelectObject(pbmOld);
00171         bmTemp.DeleteObject();
00172         dcMem.SelectObject(cpOldFont);
00173         cFont.DeleteObject();
00174         dcMem.SelectObject(pOldPen);
00175
00176         dcMem.SelectObject(cpOldFont);
00177
00179         if(pDCa == NULL) ReleaseDC(pDC);
00180 }
00181
00182 void CPlotCanvas::DrawCursor(CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor = false)
00183 {
00184         CPen TriggerFGPen( PS_SOLID, 1, m_crCursorColor );
00185         CPen TriggerBGPen( PS_SOLID, 1, m_crDisplayBGColor );
00186         dcMem->SelectObject( &TriggerFGPen );
00187         CRect rect;
00188         GetClientRect(&rect);
00189         dcMem->MoveTo(CursorPosition, 0);
00190         dcMem->LineTo(CursorPosition, rect.Height());
00191 }
00192
00194 // Name:                PlotTrace
00195 // Description: Plots trace from dpp scope data.
00197 void CPlotCanvas::PlotTrace(long YPlotBufferIn[8192])
00198 {
00199         CRect rect;
00200         GetClientRect(&rect);
00201         for(int i=0; i<8192;i++) {
00202                 YPlotBuffer[i] = YPlotBufferIn[i];
00203         }
00204         DrawPlotCanvas(&rect);
00205 }
00206
00208 // Name:                PlotTrace
00209 // Description: Plots trace from dpp scope data.
00211 void CPlotCanvas::ClearTrace()
00212 {
00213         CRect rect;
00214         GetClientRect(&rect);
00215         hasBackground = false;  // redraw background
00216         for(int i=0; i<8192;i++) {
00217                 YPlotBuffer[i] = 0;
00218         }
00219         DrawPlotCanvas(&rect);
00220 }
00221
00223 // Name:                PlotTrace
00224 // Description: Plots trace from dpp scope data.
00226 void CPlotCanvas::DrawCursor()
00227 {
00228         CRect rect;
00229         GetClientRect(&rect);
00230         hasBackground = false;  // redraw background
00231         //for(int i=0; i<8192;i++) {
00232         //      YPlotBuffer[i] = 0;
00233         //}
00234         DrawPlotCanvas(&rect);
00235 }
00236
00239
00240 void CPlotCanvas::SetPersistenceMode(bool Persistence)
00241 {
00242         PersistenceMode = Persistence;
00243         OnRefreshBkgnd();
00244 }
00245
00248
00249 void CPlotCanvas::SetCursorPosition(int CursorPos)
00250 {
00251         CursorPosition = CursorPos;
00252         OnRefreshBkgnd();
00253 }
00254
00255 void CPlotCanvas::OnLButtonDown(UINT nFlags, CPoint point)
00256 {
00257         //AfxMessageBox("CPlotCanvas::OnLButtonDown");
00258         SetCursorPosition(point.x);
00259         CRect rect;
00260         GetClientRect(&rect);
00261         DrawPlotCanvas(&rect);
00262         CStatic::OnLButtonDown(nFlags, point);
00263 }
00264
00265 void CPlotCanvas::DataAcq(long DataBuffer[8192], int NumChan)
00266 {
00267     int i;
00268         long YMAX;
00269     double y1;
00270
00271     XPlotMAX = NumChan - 1;
00272         if (NumChan > 0) {                      //plot data
00273         YMAX = 0;
00274         for(i = 0; i < NumChan; i++) { //get the largest value to be displayed
00275             if (OptScaleType) {
00276                                 if (log(1.0 + DataBuffer[i]) > YMAX) { YMAX = (long)(log(1.0 + DataBuffer[i])); }
00277             } else {
00278                 if (DataBuffer[i] > YMAX) { YMAX = DataBuffer[i]; }
00279             }
00280         }
00281         if (YMAX < 1) {
00282                         ClearTrace();
00283                         return;
00284                 }         //if no y scale exit sub
00285         if (OptScaleType) {     //adjust plot to include entire high peak
00286             YMAX = (YMAX * 10) + 10;
00287         } else {
00288             if (YMAX < 20) {
00289                 YMAX = YMAX + 2;
00290             } else {
00291                 YMAX = YMAX + 10;
00292             }
00293         }
00294         for (i = 0; i < NumChan;i++ ) { //get the largest value to be displayed
00295             if (OptScaleType) {
00296                 y1 = log(1.0 + DataBuffer[i]) * 10;
00297             } else {
00298                                 y1 = DataBuffer[i];
00299             }
00300             YPlotBuffer[i] = (long)(y1);
00301         }
00302         YPlotMAX = YMAX;
00303                 CRect rect;
00304                 GetClientRect(&rect);
00305                 hasBackground = false;  // redraw background
00306                 DrawPlotCanvas(&rect);
00307         }
00308 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/PlotCanvas.h Source File

Controls/PlotCanvas.h
Go to the documentation of this file.
00001 #if !defined(AFX_PlotCanvas_H__INCLUDED_)
00002 #define AFX_PlotCanvas_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007
00008
00009
00010
00011 // PlotCanvas.h : header file
00012 #define CC_SYSCOLOR(ind) (0x80000000|((ind) & ~CLR_DEFAULT))
00013
00014 #define ctrlColBlue RGB(0x00,0x00,0xFF)
00015 #define ctrlColSkyBlue RGB(0x32,0x99,0xCC)
00016 #define ctrlColLightBlue RGB(0xC0,0xD9,0xD9)
00017 #define ctrlColLightCyan RGB(0xE0,0xFF,0xFF)
00018 #define ctrlColYellow RGB(0x00,0xFF,0xFF)
00019 #define ctrlColGreen RGB(0x00,0xFF,0x00)
00020 #define ctrlDarkGreen RGB(0x2F,0x4F,0x2F)
00021 #define ctrlDarkGreenCopper RGB(0x4A,0x76,0x6E)
00022 #define ctrlDarkOliveGreen RGB(0x4F,0x4F,0x2F)
00023 #define ctrlColRed RGB(0xFF,0x00,0x00)
00024 #define ctrlColBlack RGB(0x00,0x00,0x00)
00025 #define ctrlColWhite RGB(0xFF,0xFF,0xFF)
00026 #define ctrlColDefault CLR_DEFAULT
00027 //#define ctrlColWinBk CC_SYSCOLOR(COLOR_WINDOW)
00028 #define ctrlColWinBk GetSysColor(0x80000005L)
00029 #define ctrlColWinText CC_SYSCOLOR(COLOR_WINDOWTEXT)
00030 #define ctrlColBtnFace CC_SYSCOLOR(COLOR_BTNFACE)
00031 #define ctrlColInfoBk CC_SYSCOLOR(COLOR_INFOBK)
00032 #define ctrlColInfoText CC_SYSCOLOR(COLOR_INFOTEXT)
00033
00034 #define ctrlColJavaGray RGB(0x64,0x64,0x64)
00035 #define ctrlColLightGray RGB(0xA8,0xA8,0xA8)
00036 #define ctrlColGray RGB(0xC0,0xC0,0xC0)
00037
00038 typedef struct _COORD_LONG { // coord.
00039     long X;      // horizontal coordinate
00040     long Y;      // vertical coordinate
00041 } COORD_LONG;
00042
00044 // CPlotCanvas window
00045
00046 class CPlotCanvas : public CStatic
00047 {
00048 // Construction
00049 public:
00050         CPlotCanvas();
00051
00052 // Attributes
00053 public:
00054         COLORREF m_crDisplayBGColor;
00055         COLORREF m_crPlotColor;
00056         COLORREF m_crCursorColor;
00057         COLORREF m_crTextFGColor;
00058         COLORREF m_crTextBGColor;
00059         //COLORREF m_crGridColor;
00060         bool hasBackground;
00061         bool PersistenceMode;
00062         int CursorPosition;
00063         int OldCursorPosition;
00064
00065         COORD_LONG PlotCursor;
00066         COORD_LONG OldPlotCursor;
00067         long YPlotBuffer[8192];    //holds y position data for cursor updates
00068         long YPlotMAX;
00069         long XPlotMAX;
00070
00071         bool OptScaleType;
00072         bool OptPlotType;
00073
00074 // Operations
00075 public:
00076
00077 // Overrides
00078         // ClassWizard generated virtual function overrides
00079         //{{AFX_VIRTUAL(CPlotCanvas)
00080         //}}AFX_VIRTUAL
00081
00082 // Implementation
00083 public:
00084         void Invalidate();
00085         void PlotTrace(long YPlotBufferIn[8192]);
00086         virtual ~CPlotCanvas();
00087
00088         // Generated message map functions
00089 protected:
00090         //{{AFX_MSG(CPlotCanvas)
00091         afx_msg BOOL OnEraseBkgnd(CDC* pDC);
00092         afx_msg void OnPaint();
00093         //}}AFX_MSG
00094
00095         DECLARE_MESSAGE_MAP()
00096 private:
00097         void DrawPlotCanvas(CRect *pRect, CDC *pDCa = NULL);
00098 public:
00099         //void MakePlot(long YPlotBufferIn[8192]);
00100         void ClearTrace();
00101         void DrawCursor();
00102         void OnRefreshBkgnd();
00103         void SetPersistenceMode(bool Persistence);
00104         void SetCursorPosition(int CursorPos);
00105         void DrawCursor(CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor);
00106
00107         afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
00108         void DataAcq(long DataBuffer[8192], int NumChan);
00109
00110 };
00111
00112 //{{AFX_INSERT_LOCATION}}
00113 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00114
00115 #endif // !defined(AFX_PlotCanvas_H__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: SProfile.cpp Source File

SProfile.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "SProfile.h"
00003 #include <time.h>
00004 #include <math.h>
00005
00006 CSProfile::CSProfile(void)
00007 {
00008         // seed random number generator
00009         srand((unsigned)time(NULL));    //Seed the random-number generator with current time
00010 }
00011
00012 CSProfile::~CSProfile(void)
00013 {
00014 }
00015
00016 CString CSProfile::Get(LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
00017 {
00018         return(theApp.GetProfileString(profile, entry, def));
00019 }
00020
00021 int CSProfile::Get(LPCTSTR profile, LPCTSTR entry, int def)
00022 {
00023         return(theApp.GetProfileInt(profile, entry, def));
00024 }
00025
00026 BOOL CSProfile::Put(LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
00027 {
00028         return(theApp.WriteProfileString(profile, entry, def));
00029 }
00030
00031 BOOL CSProfile::Put(LPCTSTR profile, LPCTSTR entry, int def)
00032 {
00033         return(theApp.WriteProfileInt(profile, entry, def));
00034 }
00035
00036 void CSProfile::LoadProfile()
00037 {
00038         // plot type
00039         GETP1(regDP5Comm, isScaleLog, FALSE);   //TRUE=log, FALSE=linear, default=FALSE
00040         GETP1(regDP5Comm, isPlotLine, FALSE);   //TRUE=line, FALSE=solid, default=FALSE
00041
00042 }
00043
00044 void CSProfile::SaveProfile()
00045 {
00046         // plot type
00047         PUTP1(regDP5Comm, isScaleLog);
00048         PUTP1(regDP5Comm, isPlotLine);
00049 }
00050
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: SProfile.h Source File

SProfile.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "vcDP5.h"
00004
00005 // Get/Save a double format value
00006 #define GETPD(p1, i1, data) str = Get(p1, #i1, data); i1 = atof(str)
00007 #define PUTPD(p1, i1) str.Format("%g", i1); Put(p1, #i1, str)
00008
00009 // Get/Save a parameter value
00010 #define GETP1(p1, i1, data) i1 = Get(p1, #i1, data)
00011 #define PUTP1(p1, i1) Put(p1, #i1, i1)
00012
00013 const CString regDP5Comm = "DP5_Communication";
00014 const CString regDP5Device = "DP5_Device";
00015 const CString regDP5Config = "DP5_Configuration";
00016
00017 class CSProfile
00018 {
00019 public:
00020         CSProfile(void);
00021         ~CSProfile(void);
00022
00023         // Save/Load Registry Settings Support functions
00024     CString Get(LPCTSTR profile, LPCTSTR entry, LPCTSTR def);
00025     int Get(LPCTSTR profile, LPCTSTR entry, int def);
00026     BOOL Put(LPCTSTR profile, LPCTSTR entry, LPCTSTR def);
00027     BOOL Put(LPCTSTR profile, LPCTSTR entry, int def);
00028         void LoadProfile();
00029         void SaveProfile();
00030
00031         // save plot type
00032         BOOL isScaleLog;        //TRUE=log, FALSE=linear, default=FALSE
00033         BOOL isPlotLine;        //TRUE=line, FALSE=solid, default=FALSE
00034
00035         CString profile;
00036         int device_type;        // DPP Device Type
00037         int data_refresh;       // usb data refresh rate in milli seconds
00038         string strDevice; // Holds the live device type name for display // DPP5 20071010_1245
00039 };
00040
00041 extern CSProfile Profile;
00042
00043
00044
00045
00046
00047
00048
00049
00050
00051
00052
00053
00054
00055
00056
00057
00058
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: STypes.cpp Source File

STypes.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "STypes.h"
00003
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: STypes.h Source File

STypes.h
Go to the documentation of this file.
00001 // STypes.h: s.
00002 //
00004
00005 // This file defines types that can be used in other header files
00006
00007 #if !defined(AFX_GLBTYPES_H__3724B201_2C60_11D2_9A26_00403354E42C__INCLUDED_)
00008 #define AFX_GLBTYPES_H__3724B201_2C60_11D2_9A26_00403354E42C__INCLUDED_
00009
00010 #if _MSC_VER >= 1000
00011 #pragma once
00012 #endif // _MSC_VER >= 1000
00013
00014 #define MIN_PLOT_X_PIXELS 100
00015 #define MIN_PLOT_Y_PIXELS 80
00016
00017 #define MIN_FRAME_X_PIXELS 200
00018 #define MIN_FRAME_Y_PIXELS 160
00019
00020 #define MAX_CHANNELS 0x4000ul
00021 #define MAX_COUNTS 0xFFFFFFFFul
00022
00023 #define MIN_PLOT_CHANNELS 64
00024 #define MIN_PLOT_COUNTS 32
00025
00026 #define MIN_GAIN 256
00027 #define MAX_GAIN_INDEX 6
00028
00029 #define GAIN_FROM_INDEX(index) (MIN_GAIN << index)
00030 #define GETULONG(d) ((unsigned long) floor(d + 0.5))
00031 #define TOULONG(d) (d <= 0.0 ? 0 : \
00032         (d > ULONG_MAX ? ULONG_MAX : GETULONG(d)))
00033 #define GETLONG(d) ((long) floor(d + 0.5))
00034 #define TOLONG(d) (d <= LONG_MIN ? LONG_MIN : \
00035         (d > LONG_MAX ? LONG_MAX : GETLONG(d)))
00036
00037 #define SCREEN_SCALE 10000
00038
00039 #define MAX_SPECTRA 20
00040
00041
00042 typedef enum
00043 {
00044     LIN_SCALE,
00045     LOG_SCALE,
00046     SQRT_SCALE
00047 } SCALE_TYPE;
00048
00049 typedef enum
00050 {
00051     INVALID_SMOOTH = -2,
00052     NO_SMOOTH,
00053     THREE_SMOOTH,
00054     FIVE_SMOOTH
00055 } SMOOTH_TYPE;
00056
00057 typedef enum
00058 {
00059     GAIN_256,
00060     GAIN_512,
00061     GAIN_1024,
00062     GAIN_2048,
00063     GAIN_4096,
00064     GAIN_8192,
00065     GAIN_16384
00066 } GAIN_TYPE;
00067
00068 #endif // !defined(AFX_GLBTYPES_H__3724B201_2C60_11D2_9A26_00403354E42C__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SelectDP5.cpp Source File

DeviceIO/SelectDP5.cpp
Go to the documentation of this file.
00001 // SelectDP5.cpp : implementation file
00002 //
00003 #include "stdafx.h"
00004 #include "DppWinUSB.h"
00005 #include "SelectDP5.h"
00006 #include "SelectDP5Res.h"
00007 #include ".\selectdp5.h"
00008 #include "SProfile.h"
00009 #define HIDD_DP5_CONNECT                        0x20191
00010
00011 BEGIN_MESSAGE_MAP(CSelectDP5, CDialog)
00012         ON_WM_DESTROY()
00013         ON_BN_CLICKED(IDC_RADIO_COMMTYPE2, OnBnClickedRadioCommtype2)
00014         ON_BN_CLICKED(IDC_BUTTON_FIND_USB_DEVICE, OnBnClickedButtonFindUsbDevice)
00015         ON_BN_CLICKED(IDC_CONNECTOK, OnBnClickedConnectOK)
00016         ON_BN_CLICKED(IDOK, OnOK)
00017
00018         ON_BN_CLICKED(IDC_BUTTON_COUNT_DEVICES, OnBnClickedButtonCountDevices)
00019         ON_NOTIFY(UDN_DELTAPOS, IDC_SPIN_SELECT_DEVICE, OnDeltaposSpinSelectDevice)
00020         ON_BN_CLICKED(IDC_BUTTON_CLOSE_DEVICE, OnBnClickedButtonCloseDevice)
00021         ON_EN_CHANGE(IDC_SPECTRUM_REFRESH_TIME, OnEnChangeSpectrumRefreshTime)
00022         ON_BN_CLICKED(IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT, OnBnClickedButtonSpectrumRefreshDefault)
00023         ON_WM_HELPINFO()
00024 END_MESSAGE_MAP()
00025
00026 // CSelectDP5 dialog
00027
00028 //IDD_DP5_CONNECT
00029
00030 //IMPLEMENT_DYNAMIC(CSelectDP5, CDialog)
00031 //CSelectDP5::CSelectDP5(CWnd* pParent /*=NULL*/)
00032 //      : CDialog(CSelectDP5::IDD, pParent)
00033
00034 //CSelectDP5::CSelectDP5(CWnd* pParent /*=NULL*/)
00035 //      : CDialog(_T("IDD_DP5_CONNECT"), pParent)
00036 //CSelectDP5::CSelectDP5(CWnd* pParent /*=NULL*/)
00037 //      : CDialog("IDD_DP5_CONNECT")
00038
00039 CSelectDP5::CSelectDP5() : CDialog(_T("IDD_DP5_CONNECT"))
00040 {
00041         //
00042 }
00043
00044 //CSelectDP5::~CSelectDP5()
00045 //{
00046 //}
00047
00048 void CSelectDP5::DoDataExchange(CDataExchange* pDX)
00049 {
00050         CDialog::DoDataExchange(pDX);
00051         //{{AFX_DATA_MAP(CSpectrumDlg)
00052         DDX_Control(pDX, IDC_STATIC_FOUND2, lblDppFound[1]);
00053         DDX_Control(pDX, IDC_SPIN_SELECT_DEVICE, m_SpinSelectDevice);
00054         DDX_Control(pDX, IDC_SPECTRUM_REFRESH_TIME, m_SpectrumRefreshTimeCtrl);
00055         //}}AFX_DATA_MAP
00056 }
00057
00058
00059
00060 BOOL CSelectDP5::OnInitDialog()
00061 {
00062         CDialog::OnInitDialog();
00063
00064         m_bModified = FALSE;
00065
00066         CString cstrDataRefresh;
00067         long lDataRefresh;
00068         lDataRefresh = Profile.data_refresh;
00069         if ((lDataRefresh < 500) || (lDataRefresh > 20000)) { // 500-20,000 milli seconds
00070                 lDataRefresh = 1000;
00071                 Profile.data_refresh = 1000;
00072         }
00073         cstrDataRefresh.Format("%d",Profile.data_refresh);
00074         m_SpectrumRefreshTimeCtrl.SetWindowText(cstrDataRefresh);
00075
00076         DppWinUSB.NumDevices = 0;
00077         GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText("0");
00078         DppWinUSB.CurrentDevice = 1;
00079         m_SpinSelectDevice.SetRange(1,1);
00080         m_SpinSelectDevice.SetPos(1);
00081         GetDlgItem(IDC_STATIC_NUM_DEVICES2)->SetWindowText("1");
00082
00083         lblDppFound[USB]
00084                 .SetFontName("Arial")
00085                 .SetFontSize(14)
00086                 .SetTextColor(colorLightSlateGray)
00087                 .SetBkColor(colorLightSteelBlue)
00088                 .SetFontBold(TRUE);
00089
00090         if (DppWinUSB.devInfo.deviceConnected) {
00091                 lblDppFound[USB].ShowWindow(SW_SHOW);
00092         } else {
00093                 lblDppFound[USB].ShowWindow(SW_HIDE);
00094         }
00095         CheckRadioButton(IDC_RADIO_COMMTYPE2, IDC_RADIO_COMMTYPE2, IDC_RADIO_COMMTYPE2);
00096         EnableCommFunctions(USB);       // initialize interface selection
00097         OnBnClickedButtonCountDevices();
00098         OnBnClickedButtonFindUsbDevice();
00099         CenterWindow();
00100         return TRUE;  // return TRUE unless you set the focus to a control
00101         // EXCEPTION: OCX Property Pages should return FALSE
00102 }
00103
00104 BOOL CSelectDP5::DestroyWindow()
00105 {
00106         return CDialog::DestroyWindow();
00107 }
00108
00109 void CSelectDP5::OnBnClickedRadioCommtype2()
00110 {
00111         EnableCommFunctions(USB);
00112         OnBnClickedButtonCountDevices();
00113         OnBnClickedButtonFindUsbDevice();
00114 }
00115
00116 void CSelectDP5::OnBnClickedButtonFindUsbDevice()
00117 {
00118         TRANSMIT_PACKET_TYPE XmtCmd;
00119     BOOL HaveBuffer;
00120     BOOL SentPkt;
00121
00122         string strUSBStatus;
00123         DPP_USB_STATUS USBStatus;       //0=do nothing, 1=new connect, 2=cannot connect
00124
00125         long pktLen;
00126         BYTE buffer[4096] = {0};
00127
00128         OnBnClickedButtonCloseDevice();
00129
00130         USBStatus = DppWinUSB.FindUSBDevice(DppWinUSB.CurrentDevice - 1);
00131         if (USBStatus != dusbStatNoAction) {
00132                 strUSBStatus = DppWinUSB.USBStatusString(USBStatus);
00133                 GetDlgItem(IDC_EDIT_STATUS2)->SetWindowText(strUSBStatus.c_str());
00134                 if (USBStatus == dusbStatNewConnect) {
00135                         // new usb connection
00136                 }
00137         }
00138         if (DppWinUSB.devInfo.deviceConnected) {
00139                 lblDppFound[USB].ShowWindow(SW_SHOW);
00140                 DppWinUSB.isDppFound = TRUE;
00141                 XmtCmd = XMTPT_SEND_NETFINDER_PACKET;
00142                 HaveBuffer = SndCmd.DP5_CMD(DP5Proto.BufferOUT, XmtCmd);
00143                 if (HaveBuffer) {
00144                         SentPkt = DppWinUSB.SendPacketUSB(DP5Proto.BufferOUT, DppWinUSB.devInfo, DP5Proto.PacketIn);
00145                 }
00146                 if (SentPkt) {
00147                         FindDppUSB.InitAllEntries();
00148                         pktLen = (long)((DP5Proto.PacketIn[4] * 256) + DP5Proto.PacketIn[5] + 8);   // temporarily save the length field
00149                         for (int i=0; i< pktLen;i++) {
00150                                 buffer[i] = DP5Proto.PacketIn[i+6];
00151                         }
00152                         FindDppUSB.AddEntry(&FindDppUSB.DppEntries[0], buffer, 0);
00153                         CString cstrStatus;
00154                         CString cstrDeviceInfo;
00155                         cstrDeviceInfo.Format("USB Device %d of %d", DppWinUSB.CurrentDevice, DppWinUSB.NumDevices);
00156                         cstrStatus = FindDppUSB.EntryToStrUSB(&FindDppUSB.DppEntries[0], cstrDeviceInfo);
00157                         GetDlgItem(IDC_EDIT_STATUS2)->SetWindowText(cstrStatus);
00158                 }
00159         } else {
00160                 lblDppFound[USB].ShowWindow(SW_HIDE);
00161                 DppWinUSB.isDppFound = FALSE;
00162         }
00163 }
00164
00165 void CSelectDP5::EnableCommFunctions(int ControlGroup)
00166 {
00167         BOOL isDUSBEnabled;
00168         int ShowDUSBEnabled;
00169         isDUSBEnabled = FALSE;
00170         ShowDUSBEnabled = SW_HIDE;
00171
00172         switch (ControlGroup) {
00173                 case USB:
00174                         isDUSBEnabled = TRUE;
00175                         ShowDUSBEnabled = isDUSBEnabled * SW_SHOW;
00176                         break;
00177         }
00178
00179         // WinUsb
00180         GetDlgItem(IDC_BUTTON_FIND_USB_DEVICE)->EnableWindow(isDUSBEnabled);
00181         GetDlgItem(IDC_EDIT_STATUS2)->EnableWindow(isDUSBEnabled);
00182
00183         GetDlgItem(IDC_BUTTON_COUNT_DEVICES)->EnableWindow(isDUSBEnabled);
00184         GetDlgItem(IDC_STATIC_NUM_DEVICES)->EnableWindow(isDUSBEnabled);
00185         GetDlgItem(IDC_STATIC_SELECT_USB_DEVICE_LABEL)->EnableWindow(isDUSBEnabled);
00186         GetDlgItem(IDC_SPIN_SELECT_DEVICE)->EnableWindow(isDUSBEnabled);
00187         GetDlgItem(IDC_STATIC_NUM_DEVICES2)->EnableWindow(isDUSBEnabled);
00188         GetDlgItem(IDC_BUTTON_CLOSE_DEVICE)->EnableWindow(isDUSBEnabled);
00189
00190         GetDlgItem(IDC_EDIT_STATUS2)->ShowWindow(ShowDUSBEnabled);
00191
00192         if (ControlGroup != USB) {
00193                 lblDppFound[USB].SetNullColor();
00194         } else {
00195                 lblDppFound[USB].SetLastColor();
00196         }
00197         GetDlgItem(IDC_RADIO_COMMTYPE2)->EnableWindow(TRUE);    // WinUsb
00198
00199 }
00200
00201 void CSelectDP5::OnBnClickedOk()
00202 {
00203         // TODO: Add your control notification handler code here
00204         OnOK();
00205 }
00206
00207 void CSelectDP5::OnBnClickedButtonCountDevices()
00208 {
00209
00210         CDppWinUSB DppWinUSB1;
00211         CString cstrNumDevices;
00212         DppWinUSB.NumDevices = DppWinUSB1.CountDP5WinusbDevices();
00213         if (DppWinUSB.CurrentDevice > DppWinUSB.NumDevices) {
00214                 DppWinUSB.CurrentDevice = 1;
00215                 m_SpinSelectDevice.SetPos(1);
00216                 GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText("1");
00217         }
00218         if (DppWinUSB.NumDevices > 1) {
00219                 m_SpinSelectDevice.SetRange(1,DppWinUSB.NumDevices);
00220                 m_SpinSelectDevice.EnableWindow(TRUE);
00221         } else {
00222                 DppWinUSB.CurrentDevice = 1;
00223                 m_SpinSelectDevice.SetPos(1);
00224                 m_SpinSelectDevice.SetRange(1,1);
00225                 GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText("1");
00226                 m_SpinSelectDevice.EnableWindow(FALSE);
00227         }
00228         cstrNumDevices.Format("%d",DppWinUSB.NumDevices);
00229         GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText(cstrNumDevices);
00230         UpdateData(FALSE);      // DDEX from var to cntrl, ie sends var value to control
00231 }
00232
00233 void CSelectDP5::OnDeltaposSpinSelectDevice(NMHDR *pNMHDR, LRESULT *pResult)
00234 {
00235         LPNMUPDOWN pNMUpDown = reinterpret_cast<LPNMUPDOWN>(pNMHDR);
00236         CString cstrPos;
00237         int iMax = 1;
00238         int iMin = 1;
00239         int iVal = 1;           // old value
00240         int iPos = 1;           // new value (if updated)
00241         int iDelta = 0;         // direction of change
00242         int iNewPos = 1;        // final value
00243         m_SpinSelectDevice.GetRange(iMin, iMax);
00244         if ((iMin != 1) || (iMax < 1)) { return; }      // max/min value errors
00245         if (iMax == 1) {                                                        // 0 or 1 devices
00246                 iNewPos = 1;
00247         } else {                                                                        // max must be greater than 1
00248                 GetDlgItem(IDC_STATIC_NUM_DEVICES2)->GetWindowText(cstrPos);
00249                 iVal = atoi(cstrPos);
00250                 iPos = pNMUpDown->iPos;
00251                 iDelta = pNMUpDown->iDelta;
00252                 if (iVal != iPos) {                                             // value was updated
00253                         iNewPos = iPos;
00254                 } else {                                                                // control just enabled, has delta but pos not updated
00255                         iNewPos = iPos + iDelta;                        // update value
00256                         if (iNewPos > iMax) {                           // do wrap if needed
00257                                 iNewPos = iMin;
00258                         } else if (iNewPos < iMin) {
00259                                 iNewPos = iMax;
00260                         }
00261                 }
00262         }
00263         //cstrPos.Format("iVal %d iPos %d iDelta %d iNewPos %d", iVal, iPos, iDelta, iNewPos);
00264         cstrPos.Format("%d", iNewPos);
00265         //AfxMessageBox(cstrPos);
00266         DppWinUSB.CurrentDevice = iNewPos;
00267         GetDlgItem(IDC_STATIC_NUM_DEVICES2)->SetWindowText(cstrPos);
00268         *pResult = 0;
00269 }
00270
00271 void CSelectDP5::OnBnClickedButtonCloseDevice()
00272 {
00273         DppWinUSB.devInfo.deviceConnected = FALSE;
00274         DppWinUSB.CloseWinUsbDevice();
00275         WinusbNotify.RemoveDeviceNotification();
00276         GetDlgItem(IDC_EDIT_STATUS2)->SetWindowText("Device Connection Closed");
00277         lblDppFound[USB].ShowWindow(SW_HIDE);
00278         DppWinUSB.isDppFound = FALSE;
00279 }
00280
00281 void CSelectDP5::OnBnClickedConnectOK()
00282 {
00283         CString cstrDataRefresh;
00284         long lDataRefresh;
00285
00286         if (m_bModified) {
00287                 m_SpectrumRefreshTimeCtrl.GetWindowText(cstrDataRefresh);
00288                 lDataRefresh = atoi(cstrDataRefresh);
00289                 if ((lDataRefresh < 500) || (lDataRefresh > 20000)) { // 500-20,000 milli seconds
00290                         lDataRefresh = 1000;
00291                         Profile.data_refresh = 1000;
00292                 } else {
00293                         Profile.data_refresh = lDataRefresh;
00294                 }
00295         }
00296         CDialog::OnOK();
00297 }
00298
00299 void CSelectDP5::OnOK()
00300 {
00301         //DISABLE DEFAULT
00302 }
00303
00304 void CSelectDP5::CopyTextToClip(CString strTitle, CString strDesc)
00305 {
00306         CString cstrText;
00307         cstrText = strTitle + "\r\n" + "\r\n" + strDesc + "\r\n" ;
00308         AfxGetApp()->m_pMainWnd->OpenClipboard() ;
00309         EmptyClipboard();
00310         CSharedFile     sf(GMEM_MOVEABLE|GMEM_DDESHARE|GMEM_ZEROINIT);
00311         sf.Write(cstrText, cstrText.GetLength());
00312         HGLOBAL hMem = sf.Detach();
00313         if (!hMem) return;
00314         SetClipboardData(CF_TEXT, hMem);
00315         CloseClipboard();
00316 }
00317
00318 void CSelectDP5::SetModified(BOOL bChanged)
00319 {
00320         m_bModified = bChanged;
00321 }
00322
00323 void CSelectDP5::OnEnChangeSpectrumRefreshTime()
00324 {
00325         SetModified(TRUE);
00326 }
00327
00328 void CSelectDP5::OnBnClickedButtonSpectrumRefreshDefault()
00329 {
00330         m_SpectrumRefreshTimeCtrl.SetWindowText("1000");
00331         Profile.data_refresh = 1000;
00332         SetModified(FALSE);
00333 }
00334
00335 BOOL CSelectDP5::OnHelpInfo(HELPINFO* pHelpInfo)
00336 {
00337         CString cstrHelp;
00338         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
00339                 if (pHelpInfo->dwContextId == 0) {
00340                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_DP5_CONNECT);
00341                 } else {
00342                         //
00343                 }
00344         }
00345         return true;
00346 }
00347
00348
00349
00350
00351
00352
00353
00354
00355
00356
00357
00358
00359
00360
00361
00362
00363
00364
00365
00366
00367
00368
00369
00370
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SelectDP5.h Source File

DeviceIO/SelectDP5.h
Go to the documentation of this file.
00001 #pragma once
00002 #ifndef SELECTDP5_H
00003 #define SELECTDP5_H
00004 #include "afxwin.h"
00005 #include "afxadv.h"     // for cfg file clipboard copy
00006 #include "Label.h"
00007 #include "NetFinder.h"
00008 #include "DP5Status.h"
00009 #include "SendCommand.h"
00010 #include "WinusbNotify.h"
00011
00012
00013 #ifdef _DEBUG
00014 #define isDebug true
00015 #else
00016 #define isDebug false
00017 #endif
00018
00019
00020
00021 // CSelectDP5 dialog
00022
00023 //DS_FIXEDSYS |
00024 //#define IDD_DP5_CONNECT                 129
00025
00026 class CSelectDP5 : public CDialog
00027 {
00028         //DECLARE_DYNAMIC(CSelectDP5)
00029
00030 public:
00031         //CSelectDP5(CWnd* pParent = NULL);   // standard constructor
00032         CSelectDP5();
00033         //virtual ~CSelectDP5();
00034
00035 // Dialog Data
00036         //enum { IDD = IDD_DP5_CONNECT };
00037
00038 protected:
00039         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00040
00041         DECLARE_MESSAGE_MAP()
00042         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00043
00044 public:
00045         virtual BOOL OnInitDialog();
00046
00047         void SetDataRcvTimer(long Bytes);
00048         CComboBox cboComPort;
00049         void ReqDataStatus();
00050         DP4_FORMAT_STATUS m_DP5_Status;
00051
00052         BYTE DataIn[4096];
00053         afx_msg void OnTimer(UINT nIDEvent);
00054         // ======================================================
00055
00056         // ===== USB ============================================
00057         afx_msg void OnBnClickedButtonFindUsbDevice();
00058         // ======================================================
00059
00060         CNetFinder FindDpp;                                     // netfinder helper class
00061         CNetFinder FindDppUSB;                                  // netfinder helper class
00062
00063         // ======================================================
00064
00065         virtual BOOL DestroyWindow();                                   // has ethernet previous owner swap
00066
00067         // ===== shared functions ===============================
00068         void EnableCommFunctions(int ControlGroup);             // enables/disables control groups
00069         // radio button selects communications type
00070         afx_msg void OnBnClickedRadioCommtype2();               // usb
00071         CLabel lblDppFound[3];                                                  // displays dpp found by comm type
00072         // ======================================================
00073
00074         afx_msg void OnBnClickedOk();
00075         afx_msg void OnBnClickedButtonCountDevices();
00076         CSpinButtonCtrl m_SpinSelectDevice;
00077         afx_msg void OnDeltaposSpinSelectDevice(NMHDR *pNMHDR, LRESULT *pResult);
00078         afx_msg void OnBnClickedButtonCloseDevice();
00079
00080         afx_msg void OnBnClickedConnectOK();
00081         virtual void OnOK();
00082         void CopyTextToClip(CString strTitle, CString strDesc);
00083         void SetModified(BOOL bChanged);
00084         BOOL m_bModified;
00085
00086         CEdit m_SpectrumRefreshTimeCtrl;
00087         afx_msg void OnEnChangeSpectrumRefreshTime();
00088         afx_msg void OnBnClickedButtonSpectrumRefreshDefault();
00089
00090         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00091
00092 };
00093
00094 extern CDP5Protocol DP5Proto;
00095 extern CSendCommand SndCmd;
00096 extern CDppWinUSB DppWinUSB;
00097 extern CWinusbNotify WinusbNotify;
00098
00099
00100 #endif //SELECTDP5_H
00101
00102
00103
00104
00105
00106
00107
00108
00109
00110
00111
00112
00113
00114
00115
00116
00117
00118
00119
00120
00121
00122
00123
00124
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SelectDP5Res.h Source File

DeviceIO/SelectDP5Res.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by SelectDP5.rc
00004 //
00005 #define IDC_BUTTON_CLIPBOARD_COPY       2048
00006 #define IDC_BUTTON_CLOSE_DEVICE         2049
00007 #define IDC_BUTTON_CLOSE_PORT           2050
00008 #define IDC_BUTTON_COUNT_DEVICES        2051
00009 #define IDC_BUTTON_FIND_DP5_IP          2052
00010 #define IDC_BUTTON_FIND_USB_DEVICE      2053
00011 #define IDC_BUTTON_IP_SELECT1           2054
00012 #define IDC_BUTTON_IP_SELECT2           2055
00013 #define IDC_BUTTON_IP_SELECT3           2056
00014 #define IDC_BUTTON_IP_SELECT4           2057
00015 #define IDC_BUTTON_OPEN_PORT            2058
00016 #define IDC_BUTTON_SERIAL_REQ_DATA      2059
00017 #define IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT 2060
00018 #define IDC_CONNECTOK                   2063
00019 #define IDC_EDIT_DPPCOMM_STATUS         2064
00020 #define IDC_EDIT_STATUS2                2070
00021 #define IDC_RADIO_COMMTYPE1             2071
00022 #define IDC_RADIO_COMMTYPE2             2072
00023 #define IDC_RADIO_COMMTYPE3             2073
00024 #define IDC_SPECTRUM_REFRESH_TIME       2074
00025 #define IDC_SPIN_SELECT_DEVICE          2075
00026 #define IDC_STATIC_FOUND1               2076
00027 #define IDC_STATIC_FOUND2               2077
00028 #define IDC_STATIC_FOUND3               2078
00029 #define IDC_STATIC_IP_ADDRESS_LABEL     2079
00030 #define IDC_STATIC_IP_SERIAL_NUM        2080
00031 #define IDC_STATIC_NUM_DEVICES          2089
00032 #define IDC_STATIC_NUM_DEVICES2         2090
00033 #define IDC_STATIC_PORT_LABEL           2091
00034 #define IDC_STATIC_SELECT_USB_DEVICE_LABEL 2092
00035
00036 // Next default values for new objects
00037 //
00038 #ifdef APSTUDIO_INVOKED
00039 #ifndef APSTUDIO_READONLY_SYMBOLS
00040 #define _APS_NEXT_RESOURCE_VALUE        6656
00041 #define _APS_NEXT_COMMAND_VALUE         33424
00042 #define _APS_NEXT_CONTROL_VALUE         2093
00043 #define _APS_NEXT_SYMED_VALUE           6656
00044 #endif
00045 #endif
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SendCommand.cpp Source File

DeviceIO/SendCommand.cpp
Go to the documentation of this file.
00001 #include "SendCommand.h"
00002 #include "stringex.h"
00003
00004 CSendCommand::CSendCommand(void)
00005 {
00006 }
00007
00008 CSendCommand::~CSendCommand(void)
00009 {
00010 }
00011
00012 bool CSendCommand::TestPacketCkSumOK(unsigned char Data[])
00013 {
00014     long idxBuffer;
00015     long CS;
00016         long PktLen;
00017         unsigned char CHKSUM_MSB;
00018     //unsigned char CHKSUM_LSB;
00019
00020         PktLen = (Data[4] * 256) + Data[5];
00021     CS = Data[0] + Data[1] + Data[2] + Data[3] + Data[4] + Data[5];
00022         if (PktLen > 0) {
00023                 for (idxBuffer=0; idxBuffer<PktLen;idxBuffer++) {
00024             CS = CS + Data[idxBuffer + 6];
00025                 }
00026     }
00027     CS = (CS ^ 0xFFFF) + 1;
00028     CHKSUM_MSB = (unsigned char)((CS & 0xFF00) / 256);  // calculated checksum
00029     //CHKSUM_LSB = (unsigned char)(CS & 0xFF);
00030         if ((Data[PktLen + 6] == CHKSUM_MSB) && (Data[PktLen + 7] == (CS & 0xFF))) {
00031                 return true;
00032         } else {
00033                 return false;
00034         }
00035 }
00036
00037 //Extend Packet_Out to include entire message
00038 //include send packet data finishing into dp5_cmd
00039 //remove control and interface objects
00040 //move send packet to separate function
00041
00042 bool CSendCommand::DP5_CMD(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd)
00043 {
00044     bool bCmdFound;
00045     string D;
00046     Packet_Out POUT;
00047
00048     bCmdFound = true;
00049     POUT.LEN = 0;
00050         string strCfg;
00051         long lLen;
00052         //long idxData;
00053
00054         switch (XmtCmd) {
00056                 case XMTPT_SEND_STATUS:
00057             POUT.PID1 = PID1_REQ_STATUS;
00058             POUT.PID2 = PID2_SEND_DP4_STYLE_STATUS;   // send status only
00059                         break;
00060         //case XMTPT_SEND_SPECTRUM:
00061                         //break;
00062         //case XMTPT_SEND_CLEAR_SPECTRUM:
00063                         //break;
00064         case XMTPT_SEND_SPECTRUM_STATUS:
00065             POUT.PID1 = PID1_REQ_SPECTRUM;
00066             POUT.PID2 = PID2_SEND_SPECTRUM_STATUS;   // send spectrum & status
00067                         break;
00068         case XMTPT_SEND_CLEAR_SPECTRUM_STATUS:
00069             POUT.PID1 = PID1_REQ_SPECTRUM;
00070             POUT.PID2 = PID2_SEND_CLEAR_SPECTRUM_STATUS;   // send & clear spectrum & status
00071                         break;
00072         //case XMTPT_BUFFER_SPECTRUM:
00073                         //break;
00074         //case XMTPT_BUFFER_CLEAR_SPECTRUM:
00075                         //break;
00076         //case XMTPT_SEND_BUFFER:
00077                         //break;
00078         //case XMTPT_SEND_DP4_STYLE_STATUS:
00079                         //break;
00080         //case XMTPT_SEND_CONFIG:
00081                         //break;
00082         case XMTPT_SEND_SCOPE_DATA:
00083             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00084             POUT.PID2 = PID2_SEND_SCOPE_DATA;
00085                         break;
00086         case XMTPT_SEND_512_BYTE_MISC_DATA:
00087             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00088             POUT.PID2 = PID2_SEND_512_BYTE_MISC_DATA; // request misc data
00089                         break;
00090         case XMTPT_SEND_SCOPE_DATA_REARM:
00091             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00092             POUT.PID2 = PID2_SEND_SCOPE_DATA_REARM;
00093                         break;
00094         //case XMTPT_SEND_ETHERNET_SETTINGS:
00095                         //break;
00096         case XMTPT_SEND_DIAGNOSTIC_DATA:
00097             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00098             POUT.PID2 = PID2_SEND_DIAGNOSTIC_DATA;   // Request Diagnostic Packet
00099             POUT.LEN = 0;
00100                         break;
00101         case XMTPT_SEND_NETFINDER_PACKET:
00102             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00103             POUT.PID2 = PID2_SEND_NETFINDER_READBACK;   // Request NetFinder Packet
00104             POUT.LEN = 0;
00105                         break;
00106         //case XMTPT_SEND_HARDWARE_DESCRIPTION:
00107                         //break;
00108         //case XMTPT_SEND_SCA:
00109                         //break;
00110         //case XMTPT_LATCH_SEND_SCA:
00111                         //break;
00112         //case XMTPT_LATCH_CLEAR_SEND_SCA:
00113                         //break;
00114         //case XMTPT_SEND_ROI_OR_FIXED_BLOCK:
00115                         //break;
00116         //case XMTPT_PX4_STYLE_CONFIG_PACKET:
00117                         //break;
00118                 case XMTPT_SCA_READ_CONFIG_PACKET:
00119                         strCfg = "";
00120                         strCfg = "SCAW=?;";
00121                         strCfg +="SCAI=1;SCAL=?;SCAH=?;SCAO=?;";
00122                         strCfg +="SCAI=2;SCAL=?;SCAH=?;SCAO=?;";
00123                         strCfg +="SCAI=3;SCAL=?;SCAH=?;SCAO=?;";
00124                         strCfg +="SCAI=4;SCAL=?;SCAH=?;SCAO=?;";
00125                         strCfg +="SCAI=5;SCAL=?;SCAH=?;SCAO=?;";
00126                         strCfg +="SCAI=6;SCAL=?;SCAH=?;SCAO=?;";
00127                         strCfg +="SCAI=7;SCAL=?;SCAH=?;SCAO=?;";
00128                         strCfg +="SCAI=8;SCAL=?;SCAH=?;SCAO=?;";
00129                         lLen = (long)strCfg.length();
00130                         if (lLen > 0) {
00131                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00132                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00133                         }
00134             POUT.PID1 = PID1_REQ_CONFIG;
00135             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // read config packet
00136             POUT.LEN = (unsigned short)lLen;
00137                         break;
00138                  case XMTPT_ERASE_FPGA_IMAGE:
00139             POUT.PID1 = PID1_REQ_FPGA_UC;
00140             POUT.PID2 = PID2_ERASE_FPGA_IMAGE;
00141             POUT.LEN = 2;
00142             POUT.DATA[0] = 0x12;
00143             POUT.DATA[1] = 0x34;
00144                         break;
00145         //case XMTPT_UPLOAD_PACKET_FPGA:
00146                         //break;
00147         //case XMTPT_REINITIALIZE_FPGA:
00148                         //break;
00149         //case XMTPT_ERASE_UC_IMAGE_0:
00150                         //break;
00151         case XMTPT_ERASE_UC_IMAGE_1:
00152             POUT.PID1 = PID1_REQ_FPGA_UC;
00153             POUT.PID2 = PID2_ERASE_UC_IMAGE_1;   // erase image #1 (sector 5)
00154             POUT.LEN = 2;
00155             POUT.DATA[0] = 0x12;
00156             POUT.DATA[1] = 0x34;
00157                         break;
00158         //case XMTPT_ERASE_UC_IMAGE_2:
00159                         //break;
00160         //case XMTPT_UPLOAD_PACKET_UC:
00161                         //break;
00162         //case XMTPT_SWITCH_TO_UC_IMAGE_0:
00163                         //break;
00164         case XMTPT_SWITCH_TO_UC_IMAGE_1:
00165             POUT.PID1 = PID1_REQ_FPGA_UC;
00166             POUT.PID2 = PID2_SWITCH_TO_UC_IMAGE_1;   // switch to uC image #1
00167             POUT.LEN = 2;
00168             POUT.DATA[0] = 0xA5; // uC FLASH unlock keys
00169             POUT.DATA[1] = 0xF1;
00170                         break;
00171         //case XMTPT_SWITCH_TO_UC_IMAGE_2:
00172                         //break;
00173         //case XMTPT_UC_FPGA_CHECKSUMS:
00174                         //break;
00176         //case XMTPT_CLEAR_SPECTRUM_BUFFER_A:
00177                         //break;
00178         case XMTPT_ENABLE_MCA_MCS:
00179             POUT.PID1 = PID1_VENDOR_REQ;
00180             POUT.PID2 = PID2_ENABLE_MCA_MCS;
00181             POUT.LEN = 0;
00182                         break;
00183         case XMTPT_DISABLE_MCA_MCS:
00184             POUT.PID1 = PID1_VENDOR_REQ;
00185             POUT.PID2 = PID2_DISABLE_MCA_MCS;
00186             POUT.LEN = 0;
00187                         break;
00188         case XMTPT_ARM_DIGITAL_OSCILLOSCOPE:
00189             POUT.PID1 = PID1_VENDOR_REQ;
00190             POUT.PID2 = PID2_ARM_DIGITAL_OSCILLOSCOPE;   // arm trigger
00191                         break;
00192         //case XMTPT_AUTOSET_INPUT_OFFSET:
00193                         //break;
00194         case XMTPT_AUTOSET_FAST_THRESHOLD:
00195             POUT.PID1 = PID1_VENDOR_REQ;
00196             POUT.PID2 = PID2_AUTOSET_FAST_THRESHOLD;
00197             POUT.LEN = 0;
00198                         break;
00199         //case XMTPT_READ_IO3_0:
00200                         //break;
00201         //case XMTPT_WRITE_IO3_0:
00202                         //break;
00203         //case XMTPT_SET_DCAL:
00204                         //break;
00205         //case XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL:
00206                         //break;
00207         //case XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL:
00208                         //break;
00209         //case XMTPT_SET_BOOT_FLAGS:
00210                         //break;
00211         //case XMTPT_SET_HV_DP4_EMULATION:
00212                         //break;
00213         //case XMTPT_SET_TEC_DP4_EMULATION:
00214                         //break;
00215         //case XMTPT_SET_INPUT_OFFSET_DP4_EMULATION:
00216                         //break;
00217         //case XMTPT_SET_ADC_CAL_GAIN_OFFSET:
00218                         //break;
00219         //case XMTPT_SET_SPECTRUM_OFFSET:
00220                         //break;
00221         //case XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS:
00222                         //break;
00223         //case XMTPT_SET_SERIAL_NUMBER:
00224                         //break;
00225         //case XMTPT_CLEAR_GP_COUNTER:
00226                         //break;
00227         //case XMTPT_SWITCH_SUPPLIES:
00228                         //break;
00229         //case XMTPT_SEND_TEST_PACKET:
00230                         //break;
00231         case XMTPT_REQ_ACK_PACKET:
00232             POUT.PID1 = PID1_COMM_TEST;
00233             POUT.PID2 = PID2_ACK_OK;
00234             POUT.LEN = 0;
00235                         break;
00236                 case XMTPT_FORCE_SCOPE_TRIGGER:
00237             POUT.PID1 = PID1_VENDOR_REQ;
00238             POUT.PID2 = PID2_GENERIC_FPGA_WRITE;        // generic FPGA write
00239             POUT.LEN = 2;
00240             POUT.DATA[0] = 119;                                         // force scope trigger
00241             POUT.DATA[1] = 0;                                           // data doesn't matter
00242                         break;
00243                 case XMTPT_AU34_2_RESTART:
00244             POUT.PID1 = PID1_VENDOR_REQ;
00245             POUT.PID2 = PID2_GENERIC_FPGA_WRITE;        // generic FPGA write
00246             POUT.LEN = 2;
00247             POUT.DATA[0] = 0x73;                                        // AU34_2_RESTART
00248             POUT.DATA[1] = 0;                                           // data doesn't matter
00249                         break;
00250         case XMTPT_READ_MCA8000D_OPTION_PA_CAL:
00251             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00252             POUT.PID2 = PID2_SEND_OPTION_PA_CALIBRATION;
00253             POUT.LEN = 0;
00254                         break;
00255                 default:
00256             bCmdFound = false;
00257                         break;
00258         }
00259         if (bCmdFound) {
00260         if (! POUT_Buffer(POUT, Buffer)) {
00261             bCmdFound = false;
00262         }
00263     }
00264         return bCmdFound;
00265 }
00266
00267 //DP5_CMD_Config is for: (requires pc5 and device info)
00268 //              XMTPT_SEND_CONFIG_PACKET_TO_HW
00269 //              XMTPT_SEND_CONFIG_PACKET_EX
00270 //              XMTPT_FULL_READ_CONFIG_PACKET
00271 //              XMTPT_READ_CONFIG_PACKET
00272 //              XMTPT_READ_CONFIG_PACKET_EX
00273 bool CSendCommand::DP5_CMD_Config(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions)
00274 {
00275     bool bCmdFound;
00276     string D;
00277     Packet_Out POUT;
00278     bCmdFound = true;
00279     POUT.LEN = 0;
00280         string strCfg;
00281         long lLen;
00282
00283         switch (XmtCmd) {
00284         case XMTPT_SEND_CONFIG_PACKET_TO_HW:
00285                         // CONFIG_OPTIONS Needed:
00286                         //              CfgOptions.HwCfgDP5Out
00287                         //              CfgOptions.SendCoarseFineGain
00288                         //              CfgOptions.PC5_PRESENT
00289                         //              CfgOptions.DppType
00290                         strCfg = "";
00291                         strCfg = CfgOptions.HwCfgDP5Out;
00292
00293                         if (CfgOptions.SendCoarseFineGain) {
00294                                 strCfg = AsciiCmdUtil.RemoveCmd("GAIN",strCfg);
00295                         } else {
00296                                 strCfg = AsciiCmdUtil.RemoveCmd("GAIA",strCfg);
00297                                 strCfg = AsciiCmdUtil.RemoveCmd("GAIF",strCfg);
00298                         }
00299                         strCfg = AsciiCmdUtil.RemoveCmdByDeviceType(strCfg, CfgOptions.PC5_PRESENT, CfgOptions.DppType, CfgOptions.isDP5_RevDxGains, CfgOptions.DPP_ECO);
00300                         lLen = (long)strCfg.length();
00301                         if (lLen > 0) {
00302                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00303                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00304                         }
00305             POUT.PID1 = PID1_REQ_CONFIG;
00306             POUT.PID2 = PID2_TEXT_CONFIG_PACKET;   // text config packet
00307             POUT.LEN = (unsigned short)lLen;
00308                         break;
00309         case XMTPT_SEND_CONFIG_PACKET_EX:                       // bypass any filters
00310                         // CONFIG_OPTIONS Needed:
00311                         //              CfgOptions.HwCfgDP5Out
00312                         strCfg = "";
00313                         strCfg = CfgOptions.HwCfgDP5Out;
00314                         lLen = (long)strCfg.length();
00315                         if (lLen > 0) {
00316                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00317                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00318                         }
00319             POUT.PID1 = PID1_REQ_CONFIG;
00320             POUT.PID2 = PID2_TEXT_CONFIG_PACKET;   // text config packet
00321             POUT.LEN = (unsigned short)lLen;
00322                         break;
00323          case XMTPT_FULL_READ_CONFIG_PACKET:
00324                         // CONFIG_OPTIONS Needed:
00325                         //              CfgOptions.PC5_PRESENT
00326                         //              CfgOptions.DppType
00327                         strCfg = "";
00328                         strCfg = AsciiCmdUtil.CreateFullReadBackCmd(CfgOptions.PC5_PRESENT, CfgOptions.DppType, CfgOptions.isDP5_RevDxGains, CfgOptions.DPP_ECO);
00329                         lLen = (long)strCfg.length();
00330                         if (lLen > 0) {
00331                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00332                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00333                         }
00334             POUT.PID1 = PID1_REQ_CONFIG;
00335             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // read config packet
00336             POUT.LEN = (unsigned short)lLen;
00337                         break;
00338         case XMTPT_READ_CONFIG_PACKET_EX:                                       // bypass any filters
00339                         strCfg = "";
00340                         strCfg = CfgOptions.HwCfgDP5Out;
00341                         lLen = (long)strCfg.length();
00342                         if (lLen > 0) {
00343                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00344                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);    //ForceASCII_20110606
00345                         }
00346             POUT.PID1 = PID1_REQ_CONFIG;
00347             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // text config packet
00348             POUT.LEN = (unsigned short)lLen;
00349                         break;
00350                 case XMTPT_READ_CONFIG_PACKET:
00351                         strCfg = "";
00352                         strCfg += "CLCK=?;"; // FPGA clock
00353                         strCfg += "TPEA=?;"; // peak time
00354                         strCfg += "GAIN=?;"; // gain
00355                         if (CfgOptions.DppType == dppMCA8000D) {
00356                                 strCfg += "GAIA=?;"; // coarse gain
00357                         }
00358                         strCfg += "MCAS=?;"; // mca mode
00359                         strCfg += "MCAC=?;"; // channels
00360                         strCfg += "INOF=?;"; // osc. Input offset
00361                         strCfg += "THSL=?;"; // LLD thresh
00362                         strCfg += "TFLA=?;"; // flat top width
00363                         strCfg += "THFA=?;"; // fast thresh
00364                         strCfg += "DACO=?;"; // osc. DAC output
00365                         strCfg += "DACF=?;"; // osc. DAC offset
00366                         strCfg += "AUO1=?;"; // osc. AUX_OUT1
00367                         strCfg += "PRET=?;"; // preset actual time
00368                         strCfg += "PRER=?;"; // preset real time
00369                         strCfg += "PREC=?;"; // preset count
00370                         if (CfgOptions.DppType == dppMCA8000D) {
00371                                 strCfg += "PREL=?;"; // preset real time
00372                         }
00373                         strCfg += "HVSE=?;"; // high voltage setting for manufacuting test
00374                         strCfg += "SCOE=?;"; // osc. Scope trigger edge
00375                         strCfg += "SCOT=?;"; // osc. Scope trigger position
00376                         strCfg += "SCOG=?;"; // osc. Scope gain
00377
00378                         lLen = (long)strCfg.length();
00379                         if (lLen > 0) {
00380                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00381                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00382                         }
00383             POUT.PID1 = PID1_REQ_CONFIG;
00384             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // read config packet
00385             POUT.LEN = (unsigned short)lLen;
00386                         break;
00387                 default:
00388             bCmdFound = false;
00389                         break;
00390         }
00391         if (bCmdFound) {
00392         if (! POUT_Buffer(POUT, Buffer)) {
00393             bCmdFound = false;
00394         }
00395     }
00396         return bCmdFound;
00397 }
00398
00399
00400 //Extend Packet_Out to include entire message
00401 //include send packet data finishing into dp5_cmd
00402 //remove control and interface objects
00403 //move send packet to separate function
00404 bool CSendCommand::DP5_CMD_Data(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[])
00405 {
00406     bool bCmdFound;
00407     short idxMiscData;
00408     Packet_Out POUT;
00409     long PktLen;
00410
00411     bCmdFound = false;
00412     POUT.LEN = 0;
00413         string strCfg;
00414         long idxData;
00415         switch (XmtCmd) {       //REQUEST_PACKETS_TO_DP5
00416         case XMTPT_WRITE_512_BYTE_MISC_DATA:
00417             POUT.PID1 = PID1_VENDOR_REQ;
00418             POUT.PID2 = PID2_WRITE_512_BYTE_MISC_DATA;                          // write misc data
00419             POUT.LEN = 512;
00420                         for (idxMiscData=0;idxMiscData<=511;idxMiscData++) {    // byte array padded w/NULLs
00421                 POUT.DATA[idxMiscData] = DataOut[idxMiscData];
00422                         }
00423                         bCmdFound = true;
00424                         if (! POUT_Buffer(POUT, Buffer)) {
00425                                 bCmdFound = false;
00426                         }
00427                         break;
00428          case XMTPT_SEND_TEST_PACKET:
00429                         PktLen = (DataOut[4] * 256) + DataOut[5] + 8;           // get entire packet size
00430                         if ((PktLen >= 8) && (PktLen <= 12)) {                          // test data len 0-4 bytes
00431                                 if (TestPacketCkSumOK(DataOut)) {                               // check the message for correct check sum
00432                                         for(idxData=0;idxData<PktLen;idxData++) {       // load the data into the command buffer
00433                                                 Buffer[idxData] = DataOut[idxData];
00434                                         }
00435                                         bCmdFound = true;
00436                                 }
00437                         }
00438                         break;
00439                 default:
00440             bCmdFound = false;
00441                         break;
00442         }
00443         return bCmdFound;
00444 }
00445
00446 bool CSendCommand::POUT_Buffer(Packet_Out POUT, unsigned char Buffer[])
00447 {
00448     long idxBuffer;
00449     long CS;
00450
00451     Buffer[0] = SYNC1_;
00452     Buffer[1] = SYNC2_;
00453     Buffer[2] = POUT.PID1;
00454     Buffer[3] = POUT.PID2;
00455     Buffer[4] = (POUT.LEN & 0xFF00) / 256;
00456     Buffer[5] = POUT.LEN & 0xFF;
00457
00458     CS = SYNC1_ + SYNC2_ + POUT.PID1 + POUT.PID2 + ((POUT.LEN & 0xFF00) / 256) + (POUT.LEN & 0xFF);
00459
00460         if (POUT.LEN > 0) {
00461                 for (idxBuffer=0; idxBuffer<POUT.LEN;idxBuffer++) {
00462             Buffer[idxBuffer + 6] = POUT.DATA[idxBuffer];
00463             CS = CS + POUT.DATA[idxBuffer];
00464                 }
00465     }
00466     CS = (CS ^ 0xFFFF) + 1;
00467     Buffer[POUT.LEN + 6] = (unsigned char)((CS & 0xFF00) / 256);
00468     Buffer[POUT.LEN + 7] = (unsigned char)(CS & 0xFF);
00469     return true;
00470 }
00471
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/SendCommand.h Source File

DeviceIO/SendCommand.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "DppConst.h"
00003 #include "DP5Protocol.h"
00004 #include "AsciiCmdUtilities.h"
00005
00006 typedef struct _CONFIG_OPTIONS
00007 {
00008     bool PC5_PRESENT;
00009     int DppType;
00010         string HwCfgDP5Out;
00011         bool SendCoarseFineGain;
00012         bool isDP5_RevDxGains;
00013         unsigned char DPP_ECO;
00014 } CONFIG_OPTIONS;
00015
00023 class CSendCommand
00024 {
00025 public:
00026         CSendCommand(void);
00027         ~CSendCommand(void);
00028     CAsciiCmdUtilities AsciiCmdUtil;
00029
00031         bool TestPacketCkSumOK(unsigned char Data[]);
00033         bool DP5_CMD(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd);
00035         bool DP5_CMD_Config(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions);
00037         bool DP5_CMD_Data(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[]);
00039         bool POUT_Buffer(Packet_Out POUT, unsigned char Buffer[]);
00040 };
00041
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: StdAfx.cpp Source File

StdAfx.cpp
Go to the documentation of this file.
00001 // stdafx.cpp : source file that includes just the standard includes
00002 //      Pmca.pch will be the pre-compiled header
00003 //      stdafx.obj will contain the pre-compiled type information
00004
00005 #include "stdafx.h"
00006
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: StdAfx.h Source File

StdAfx.h
Go to the documentation of this file.
00001 // stdafx.h : include file for standard system include files,
00002 //  or project specific include files that are used frequently, but
00003 //      are changed infrequently
00004 //
00005
00006 #if !defined(AFX_STDAFX_H__3767FA76_575A_11D2_9A26_00403354E42C__INCLUDED_)
00007 #define AFX_STDAFX_H__3767FA76_575A_11D2_9A26_00403354E42C__INCLUDED_
00008
00009 #define _CRT_SECURE_NO_DEPRECATE 1
00010 #pragma warning(disable:4995)
00011 #pragma warning(disable:4996)
00012
00013 #define _SETUPAPI_VER 0x0501
00014
00015 // Modify the following defines if you have to target an OS before the ones
00016 // specified in the following code. See MSDN for the latest information
00017 // about corresponding values for different operating systems.
00018 #ifndef WINVER          // Permit use of features specific to Windows 95 and Windows NT 4.0 or later.
00019 #define WINVER 0x0501   // Change this to the appropriate value to target
00020 #endif                     // Windows 98 and Windows 2000 or later.
00021
00022 // _WIN32_WINNT to be #defined at 0x0500 for vs2010
00023 #ifndef _WIN32_WINNT    // Permit use of features specific to Windows NT 4.0 or later.
00024 #define _WIN32_WINNT 0x0501     // Change this to the appropriate value to target
00025 #endif                   // Windows 98 and Windows 2000 or later.
00026
00027 #ifndef _WIN32_WINDOWS        // Permit use of features specific to Windows 98 or later.
00028 #define _WIN32_WINDOWS 0x0410    // Change this to the appropriate value to target
00029 #endif                        // Windows Millennium Edition or later.
00030
00031 #ifndef _WIN32_IE               // Permit use of features specific to Internet Explorer 4.0 or later.
00032 #define _WIN32_IE 0x0600   // Change this to the appropriate value to target
00033 #endif                  // Internet Explorer 5.0 or later.
00034
00035 #if _MSC_VER >= 1000
00036 #pragma once
00037 #endif // _MSC_VER >= 1000
00038
00039 #define VC_EXTRALEAN            // Exclude rarely-used stuff from Windows headers
00040
00041 #include <afxwin.h>         // MFC core and standard components
00042 #include <afxext.h>         // MFC extensions
00043 #include <afxole.h>         // MFC OLE classes
00044 #include <afxdisp.h>        // MFC Automation classes
00045 #include <afxdtctl.h>           // MFC support for Internet Explorer 4 Common Controls
00046 #include <vector>
00047 #ifndef _AFX_NO_AFXCMN_SUPPORT
00048 #include <afxcmn.h>                     // MFC support for Windows Common Controls
00049 #endif // _AFX_NO_AFXCMN_SUPPORT
00050 #include <afxdlgs.h>
00051 #include <afxtempl.h>
00052
00053 #include <afxsock.h>            // MFC socket extensions
00054
00055 //{{AFX_INSERT_LOCATION}}
00056 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00057
00058 #endif // !defined(AFX_STDAFX_H__3767FA76_575A_11D2_9A26_00403354E42C__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/TuneSlowThreshold.cpp Source File

Config/TuneSlowThreshold.cpp
Go to the documentation of this file.
00001
00002 //vcDP5 SDK
00003 #include "stdafx.h"
00004 #include ".\tuneslowthreshold.h"
00005 #include "DppSlowThreshold.h"
00006 #include "UserMsgs.h"
00007
00008 CTuneSlowThreshold::CTuneSlowThreshold(void)
00009 {
00010 }
00011
00012 CTuneSlowThreshold::~CTuneSlowThreshold(void)
00013 {
00014 }
00015
00016 void CTuneSlowThreshold::GetSpectrumData(double * dblMCAData, long * lngMCAData, int mcaCH)
00017 {
00018         for (int chan=0; chan < mcaCH; chan++)
00019                 dblMCAData[chan] = lngMCAData[chan];
00020 }
00021
00022 double CTuneSlowThreshold::SetSlowThreshToChPos(int ChPosIn, int mcaCH)
00023 {
00024         CDppSlowThreshold SlowThreshNew;
00025         CString cstrChPos;
00026         int ChPos;
00027         double FSReal;
00028         UCHAR SlowChThreshold;
00029
00030         ChPos = ChPosIn;
00031         if (ChPos == 0) ChPos = 1;
00032         SlowThreshNew.SetGain(mcaCH);
00033         SlowThreshNew.GetSlowThresholdSettingFromChannels((double)ChPos);
00034         SlowChThreshold = SlowThreshNew.GetSlowChThreshold();
00035         FSReal = (double)SlowChThreshold / 1024.0;
00036         return FSReal;
00037 }
00038
00039 int CTuneSlowThreshold::GetSlowThreshCalStart(double * SpectrumBuffer, double UpperChMax, int mcaCH)
00040 {
00041         int MinValidChan = 40;
00042         int MaxValidChan = 245;
00043         int LastSlwCh = (int)(mcaCH * 0.24);
00044         int StartCh = LastSlwCh;
00045         CString cstrStatus;
00046
00047         //DisplaySpecBuf25(SpectrumBuffer);
00048         for (int i = LastSlwCh; i >= 0; i--) {
00049                 if (SpectrumBuffer[i] <= UpperChMax) {
00050                         if (i < StartCh) StartCh = i;
00051                         cstrStatus.Format(" Finding Slow Threshold Test Channel %d ...", i);
00052                 } else {
00053                         break;
00054                 }
00055         }
00056         if ((StartCh > 1) && (StartCh < LastSlwCh - 1)) StartCh++;      // remove the last (bad) ch
00057         // try to tweak 3x if really bad
00058         if ((SpectrumBuffer[StartCh] > UpperChMax) && (StartCh < LastSlwCh - 1)) {
00059                 StartCh++;
00060         }
00061         if ((SpectrumBuffer[StartCh] > UpperChMax) && (StartCh < LastSlwCh - 1)) {
00062                 StartCh++;
00063         }
00064         if ((SpectrumBuffer[StartCh] > UpperChMax) && (StartCh < LastSlwCh - 1)) {
00065                 StartCh++;
00066         }
00067         MinValidChan = GetSlowThreshChStrFromVal(6, mcaCH);
00068         if (StartCh < MinValidChan) {   // set to >= 0.5% FS if no slow thresh needed
00069                 StartCh = MinValidChan;
00070         }
00071         MaxValidChan = GetSlowThreshChStrFromVal(245, mcaCH);
00072         if (StartCh > MaxValidChan) {   // set to >= 24.02% FS if no slow thresh needed
00073                 StartCh = MaxValidChan;
00074                 AfxMessageBox("Slow threshold value too high. \n Please check your settings.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
00075         }
00076         return StartCh;
00077 }
00078
00079 double CTuneSlowThreshold::GetUpperChCounts(double * SpectrumBuffer, int mcaCH)
00080 {
00081         int LastSlwCh = (int)(mcaCH * 0.24);
00082         double ChCounts = 0;
00083         double CurChCount = 0;
00084         for (int i = LastSlwCh; i < mcaCH; i++) {
00085                 CurChCount = SpectrumBuffer[i];
00086                 if (CurChCount > 0) {
00087                         ChCounts += CurChCount;
00088                 }
00089         }
00090         return ChCounts;
00091 }
00092
00093 double CTuneSlowThreshold::GetUpperChMax(double * SpectrumBuffer, int mcaCH)
00094 {
00095         int LastSlwCh = (int)(mcaCH * 0.24);
00096         double ChCount = 0;
00097         double CurChCount = 0;
00098         for (int i = LastSlwCh; i < mcaCH; i++) {
00099                 CurChCount = SpectrumBuffer[i];
00100                 if (CurChCount > ChCount) ChCount = CurChCount;
00101         }
00102         return ChCount;
00103 }
00104
00105 void CTuneSlowThreshold::DelayTask(DWORD d)
00106 {
00107     MSG msg;
00108     d += GetCurrentTime();
00109     while (GetCurrentTime() < d)
00110     {
00111                 if (PeekMessage(&msg, NULL, NULL, NULL, PM_REMOVE))
00112                 {
00113                 TranslateMessage(&msg);
00114                 DispatchMessage(&msg);
00115                 }
00116         }
00117 }
00118
00119 int CTuneSlowThreshold::UpdatePlotCursorPosFromIntChPos(int CurCh, double dblPixPerChan)
00120 {
00121         double dblPixPos;
00122         double dblChanPerPix;
00123         if (dblPixPerChan > 0.0) {
00124                 dblChanPerPix = 1.0 / dblPixPerChan;
00125                 dblPixPos = (double)CurCh * dblChanPerPix;
00126                 int dpos = (int)dblPixPos;
00127         return dpos;    } else {
00128                 return CurCh;
00129         }
00130 }
00131
00132 void CTuneSlowThreshold::DisplaySpecBuf25(double * SpectrumBuffer)
00133 {
00134         CString cstrBuffer("");
00135         CString cstrChan("");
00136         for (int i=0;i<25;i++) {
00137                 cstrChan.Format("%f\n",SpectrumBuffer[i]);
00138                 cstrBuffer += cstrChan;
00139         }
00140         AfxMessageBox(cstrBuffer);
00141 }
00142
00146 int CTuneSlowThreshold::GetSlowThreshChStrFromVal(UCHAR byteSlowThres, int mcaCH)
00147 {
00148         long intSlowThresh;
00149         double GainChannels;
00150         GainChannels = (double)mcaCH;
00151         intSlowThresh = (int)(((double)byteSlowThres * GainChannels / 1024.0) + 0.5);
00152         return intSlowThresh;
00153 }
00154
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Config/TuneSlowThreshold.h Source File

Config/TuneSlowThreshold.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 //vcDP5 SDK
00004
00005 #include "afxcmn.h"
00006 #include "afxwin.h"
00007 #include "resource.h"
00008
00009 class CTuneSlowThreshold
00010 {
00011 public:
00012         CTuneSlowThreshold(void);
00013         ~CTuneSlowThreshold(void);
00014         double SetSlowThreshToChPos(int ChPosIn, int mcaCH);
00015         void DelayTask(DWORD d);
00016         int GetSlowThreshCalStart(double * SpectrumBuffer, double UpperChMax, int mcaCH);
00017         double GetUpperChCounts(double * SpectrumBuffer, int mcaCH);
00018         double GetUpperChMax(double * SpectrumBuffer, int mcaCH);
00019         void GetSpectrumData(double * dblMCAData, long * lngMCAData, int mcaCH);
00020         int UpdatePlotCursorPosFromIntChPos(int CurCh, double dblPixPerChan);
00021         void DisplaySpecBuf25(double * SpectrumBuffer);
00022         int GetSlowThreshChStrFromVal(UCHAR byteSlowThres, int mcaCH);
00023 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: UserMsgs.h Source File

UserMsgs.h
Go to the documentation of this file.
00001 #ifndef __FPUSERMSGS_H__
00002 #define __FPUSERMSGS_H__
00003
00004 #define WM_USER_PMCA_REQUEST_PARAMETER          (WM_USER + 256)
00005 #define WM_USER_FPGUI_REQUEST_PARAMETER         (WM_USER + 257)
00006
00007 #define WM_USER_LOAD_FILE                                       (WM_USER + 300)
00008 #define WM_USER_UPDATE_STATUS_BAR                       (WM_USER + 301)
00009 #define WM_USER_UPDATE_MENU                                     (WM_USER + 302)
00010 #define WM_USER_SHOW_SPECTRA_LIST_DLG           (WM_USER + 303)
00011
00012 //#define WM_USER_USB_CONNECT                                   (WM_USER + 304)
00013 #define WM_USER_SEND_CONFIG_TO_HW                       (WM_USER + 305)
00014 #define WM_USER_REPEAT_MEASUREMENT                      (WM_USER + 306)
00015 #define WM_USER_READ_DPP_CONFIG                         (WM_USER + 307)
00016 //#define WM_USER_DISPLAY_SCOPE_DIALOG      (WM_USER + 308)
00017 #define WM_USER_SAVE_CONFIG_TO_FILE             (WM_USER + 309)
00018 //#define WM_USER_RESTART_DLG_WITH_NEW_CONFIG   (WM_USER + 310)
00019 //#define WM_USER_RESTART_DLG_WITH_NEWCONFIG2 (WM_USER + 311)
00020 #define WM_USER_COARSE_AUTO_INPUT_OFFSET        (WM_USER + 312)
00021 #define WM_USER_FINE_AUTO_INPUT_OFFSET      (WM_USER + 313)
00022 #define WM_USER_DPP_AUTO_FAST_THESHOLD      (WM_USER + 314)
00023 #define WM_USER_DPP_AUTO_SLOW_THESHOLD      (WM_USER + 315)
00024 #define WM_USER_SHOW_CONNECT_DIALOG                     (WM_USER + 316)
00025 #define WM_USER_READ_SCA_CONFIG                         (WM_USER + 317)
00026 #define WM_USER_READ_DPP_CONFIG_EX                      (WM_USER + 319)
00027
00028 #endif
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WINUSB.H Source File

DeviceIO/WINUSB.H
Go to the documentation of this file.
00001 /*++
00002
00003 Copyright (c) 2002 Microsoft Corporation
00004
00005 Module Name:
00006
00007         wusb.h
00008
00009 Abstract:
00010
00011         Public interface to winusb.dll
00012
00013 Environment:
00014
00015         Kernel Mode Only
00016
00017 Notes:
00018
00019         THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY
00020         KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00021         IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR
00022         PURPOSE.
00023
00024         Copyright (c) 2001 Microsoft Corporation.  All Rights Reserved.
00025
00026
00027 Revision History:
00028
00029         11/19/2002 : created
00030
00031 Authors:
00032
00033 --*/
00034
00035 #ifndef __WUSB_H__
00036 #define __WUSB_H__
00037
00038 #ifdef __cplusplus
00039 extern "C" {
00040 #endif
00041
00042 #include "winusbio.h"
00043
00044
00045 typedef PVOID WINUSB_INTERFACE_HANDLE, *PWINUSB_INTERFACE_HANDLE;
00046
00047
00048 #pragma pack(1)
00049
00050 typedef struct _WINUSB_SETUP_PACKET {
00051     UCHAR   RequestType;
00052     UCHAR   Request;
00053     USHORT  Value;
00054     USHORT  Index;
00055     USHORT  Length;
00056 } WINUSB_SETUP_PACKET, *PWINUSB_SETUP_PACKET;
00057
00058 #pragma pack()
00059
00060
00061
00062 BOOL __stdcall
00063 WinUsb_Initialize(
00064     IN HANDLE DeviceHandle,
00065     OUT PWINUSB_INTERFACE_HANDLE InterfaceHandle
00066     );
00067
00068
00069 BOOL __stdcall
00070 WinUsb_Free(
00071     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle
00072     );
00073
00074
00075 BOOL __stdcall
00076 WinUsb_GetAssociatedInterface(
00077     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00078     IN UCHAR AssociatedInterfaceIndex,
00079     OUT PWINUSB_INTERFACE_HANDLE AssociatedInterfaceHandle
00080     );
00081
00082
00083
00084 BOOL __stdcall
00085 WinUsb_GetDescriptor(
00086     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00087     IN  UCHAR DescriptorType,
00088     IN  UCHAR Index,
00089     IN  USHORT LanguageID,
00090     OUT PUCHAR Buffer,
00091     IN  ULONG BufferLength,
00092     OUT PULONG LengthTransferred
00093     );
00094
00095 BOOL __stdcall
00096 WinUsb_QueryInterfaceSettings(
00097     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00098     IN UCHAR AlternateInterfaceNumber,
00099     OUT PUSB_INTERFACE_DESCRIPTOR UsbAltInterfaceDescriptor
00100     );
00101
00102 BOOL __stdcall
00103 WinUsb_QueryDeviceInformation(
00104     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00105     IN ULONG InformationType,
00106     IN OUT PULONG BufferLength,
00107     OUT PVOID Buffer
00108     );
00109
00110 BOOL __stdcall
00111 WinUsb_SetCurrentAlternateSetting(
00112     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00113     IN  UCHAR SettingNumber
00114     );
00115
00116 BOOL __stdcall
00117 WinUsb_GetCurrentAlternateSetting(
00118     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00119     OUT PUCHAR SettingNumber
00120     );
00121
00122
00123 BOOL __stdcall
00124 WinUsb_QueryPipe(
00125     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00126     IN  UCHAR AlternateInterfaceNumber,
00127     IN  UCHAR PipeIndex,
00128     OUT PWINUSB_PIPE_INFORMATION PipeInformation
00129     );
00130
00131
00132 BOOL __stdcall
00133 WinUsb_SetPipePolicy(
00134     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00135     IN  UCHAR PipeID,
00136     IN  ULONG PolicyType,
00137     IN  ULONG ValueLength,
00138     IN  PVOID Value
00139     );
00140
00141 BOOL __stdcall
00142 WinUsb_GetPipePolicy(
00143     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00144     IN UCHAR PipeID,
00145     IN ULONG PolicyType,
00146     IN OUT PULONG ValueLength,
00147     OUT PVOID Value
00148     );
00149
00150 BOOL __stdcall
00151 WinUsb_ReadPipe(
00152     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00153     IN  UCHAR PipeID,
00154     IN  PUCHAR Buffer,
00155     IN  ULONG BufferLength,
00156     OUT PULONG LengthTransferred,
00157     IN  LPOVERLAPPED Overlapped
00158     );
00159
00160 BOOL __stdcall
00161 WinUsb_WritePipe(
00162     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00163     IN  UCHAR PipeID,
00164     IN  PUCHAR Buffer,
00165     IN  ULONG BufferLength,
00166     OUT PULONG LengthTransferred,
00167     IN  LPOVERLAPPED Overlapped
00168     );
00169
00170 BOOL __stdcall
00171 WinUsb_ControlTransfer(
00172     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00173     IN  WINUSB_SETUP_PACKET SetupPacket,
00174     IN  PUCHAR Buffer,
00175     IN  ULONG BufferLength,
00176     OUT PULONG LengthTransferred,
00177     IN  LPOVERLAPPED Overlapped
00178     );
00179
00180 BOOL __stdcall
00181 WinUsb_ResetPipe(
00182     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00183     IN  UCHAR PipeID
00184     );
00185
00186 BOOL __stdcall
00187 WinUsb_AbortPipe(
00188     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00189     IN  UCHAR PipeID
00190     );
00191
00192 BOOL __stdcall
00193 WinUsb_FlushPipe(
00194     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00195     IN  UCHAR PipeID
00196     );
00197
00198 BOOL __stdcall
00199 WinUsb_SetPowerPolicy(
00200     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00201     IN  ULONG PolicyType,
00202     IN  ULONG ValueLength,
00203     IN  PVOID Value
00204     );
00205
00206 BOOL __stdcall
00207 WinUsb_GetPowerPolicy(
00208     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00209     IN ULONG PolicyType,
00210     IN OUT PULONG ValueLength,
00211     OUT PVOID Value
00212     );
00213
00214 BOOL __stdcall
00215 WinUsb_GetOverlappedResult(
00216     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00217     IN LPOVERLAPPED lpOverlapped,
00218     OUT LPDWORD lpNumberOfBytesTransferred,
00219     BOOL bWait
00220     );
00221
00222
00223 PUSB_INTERFACE_DESCRIPTOR __stdcall
00224 WinUsb_ParseConfigurationDescriptor(
00225     IN PUSB_CONFIGURATION_DESCRIPTOR ConfigurationDescriptor,
00226     IN PVOID StartPosition,
00227     IN LONG InterfaceNumber,
00228     IN LONG AlternateSetting,
00229     IN LONG InterfaceClass,
00230     IN LONG InterfaceSubClass,
00231     IN LONG InterfaceProtocol
00232     );
00233
00234 PUSB_COMMON_DESCRIPTOR __stdcall
00235 WinUsb_ParseDescriptors(
00236     IN PVOID    DescriptorBuffer,
00237     IN ULONG    TotalLength,
00238     IN PVOID    StartPosition,
00239     IN LONG     DescriptorType
00240     );
00241
00242
00243 #ifdef __cplusplus
00244 }
00245 #endif
00246
00247
00248 #endif //__WUSB_H__
00249
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WINUSBIO.H Source File

DeviceIO/WINUSBIO.H
Go to the documentation of this file.
00001 /***************************************************************************
00002
00003 Copyright (c) 2002 Microsoft Corporation
00004
00005 Module Name:
00006
00007         wusbio.h
00008
00009 Abstract:
00010
00011         Public header for WINUSB
00012
00013 Environment:
00014
00015         User and Kernel Mode
00016
00017 Notes:
00018
00019         THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY
00020         KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00021         IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR
00022         PURPOSE.
00023
00024         Copyright (c) 2001 Microsoft Corporation.  All Rights Reserved.
00025
00026
00027 Revision History:
00028
00029         11/12/2002 : created
00030
00031
00032 ****************************************************************************/
00033
00034 #ifndef __WUSBIO_H__
00035 #define __WUSBIO_H__
00036
00037 #include "usb.h"
00038
00039 // Pipe policy types
00040 #define SHORT_PACKET_TERMINATE  0x01
00041 #define AUTO_CLEAR_STALL        0x02
00042 #define PIPE_TRANSFER_TIMEOUT   0x03
00043 #define IGNORE_SHORT_PACKETS    0x04
00044 #define ALLOW_PARTIAL_READS     0x05
00045 #define AUTO_FLUSH              0x06
00046 #define RAW_IO                  0x07
00047 #define MAXIMUM_TRANSFER_SIZE   0x08
00048
00049 // Power policy types
00050 //
00051 // Add 0x80 for Power policy types in order to prevent overlap with
00052 // Pipe policy types to prevent "accidentally" setting the wrong value for the
00053 // wrong type.
00054 //
00055 #define AUTO_SUSPEND            0x81
00056 #define SUSPEND_DELAY           0x83
00057
00058 // Device Information types
00059 #define DEVICE_SPEED            0x01
00060
00061 // Device Speeds
00062 #define LowSpeed                0x01
00063 #define FullSpeed               0x02
00064 #define HighSpeed               0x03
00065
00066 // {DA812BFF-12C3-46a2-8E2B-DBD3B7834C43}
00067 #include <initguid.h>
00068 DEFINE_GUID(WinUSB_TestGuid, 0xda812bff, 0x12c3, 0x46a2, 0x8e, 0x2b, 0xdb, 0xd3, 0xb7, 0x83, 0x4c, 0x43);
00069
00070
00071 typedef struct _WINUSB_PIPE_INFORMATION {
00072     USBD_PIPE_TYPE  PipeType;
00073     UCHAR           PipeId;
00074     USHORT          MaximumPacketSize;
00075     UCHAR           Interval;
00076 } WINUSB_PIPE_INFORMATION, *PWINUSB_PIPE_INFORMATION;
00077
00078 #endif // __WUSBIO_H__
00079
00080
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlg.cpp Source File

waitdlg/WaitDlg.cpp
Go to the documentation of this file.
00001 // WaitDlg.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "WaitDialog.h"
00006 #include "WaitDlg.h"
00007 #include "resource.h"
00008
00009 //#ifdef _DEBUG
00010 //#define new DEBUG_NEW
00011 //#undef THIS_FILE
00012 //static char THIS_FILE[] = __FILE__;
00013 //#endif
00014
00016 // cWaitDlg dialog
00017
00018
00019 cWaitDlg::cWaitDlg(CWnd* pParent /*=NULL*/)
00020         : CDialog(cWaitDlg::IDD, pParent)
00021 {
00022         //{{AFX_DATA_INIT(cWaitDlg)
00023                 // NOTE: the ClassWizard will add member initialization here
00024         //}}AFX_DATA_INIT
00025    m_Text = "";
00026    m_bShowCancelButton = false;
00027 }
00028
00029
00030 void cWaitDlg::DoDataExchange(CDataExchange* pDX)
00031 {
00032         CDialog::DoDataExchange(pDX);
00033         //{{AFX_DATA_MAP(cWaitDlg)
00034                 // NOTE: the ClassWizard will add DDX and DDV calls here
00035         //}}AFX_DATA_MAP
00036 }
00037
00038
00039 BEGIN_MESSAGE_MAP(cWaitDlg, CDialog)
00040         //{{AFX_MSG_MAP(cWaitDlg)
00041         ON_WM_TIMER()
00042         //}}AFX_MSG_MAP
00043 END_MESSAGE_MAP()
00044
00046 // cWaitDlg message handlers
00047 void cWaitDlg::OnCancel()
00048 {
00049    //Override this so the user cannot cancel by hiting ESC
00050    return;
00051 }
00052
00053 void cWaitDlg::OnOK()
00054 {
00055    //Ignore this unless the button is visible
00056    if (m_bShowCancelButton)
00057       {
00058            m_Thread->m_Event->SetEvent();
00059            CDialog::OnOK();
00060       }
00061 }
00062
00063 BOOL cWaitDlg::OnInitDialog()
00064 {
00065         CDialog::OnInitDialog();
00066
00067    if (m_Text.GetLength() > 0)
00068       GetDlgItem(IDC_BUSY_TEXT)->SetWindowText(m_Text);
00069
00070    GetDlgItem(IDOK)->ShowWindow(m_bShowCancelButton ? SW_SHOW : SW_HIDE);
00071
00072    CRect rect;
00073    GetDlgItem(IDC_BUSY_PIC)->GetWindowRect(rect);
00074    ScreenToClient(&rect);
00075
00076    m_Anim.Create(WS_VISIBLE|WS_CHILD, rect, this, IDC_BUSY_PIC);
00077    m_Anim.SetImageList(IDB_SPECTRUM_ANIM, 70, 56, RGB(255,0,255));
00078    m_Anim.StartAnim(250);
00079
00080         //SetTimer(1,500,NULL);
00081         SetTimer(1,250,NULL);
00082         return TRUE;  // return TRUE unless you set the focus to a control
00083                       // EXCEPTION: OCX Property Pages should return FALSE
00084 }
00085
00086 void cWaitDlg::OnTimer(UINT nIDEvent)
00087 {
00088         CSingleLock lock(m_Thread->m_Event, FALSE);
00089
00090    if (lock.Lock(0))
00091       {
00092       CDialog::OnOK();
00093       }
00094
00095         //CDialog::OnTimer(nIDEvent);
00096 }
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlg.h Source File

waitdlg/WaitDlg.h
Go to the documentation of this file.
00001 #if !defined(AFX_WAITDLG_H__55050813_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
00002 #define AFX_WAITDLG_H__55050813_F8E6_11D2_837D_00500406DAEB__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // WaitDlg.h : header file
00008 //
00009 #include <afxmt.h>
00010
00011 #include "WaitDlgThread.h"
00012 #include "AnimWnd.h"
00013 #include "resource.h"
00014
00016 // cWaitDlg dialog
00017
00018 class cWaitDlg : public CDialog
00019 {
00020 // Construction
00021 public:
00022         cWaitDlg(CWnd* pParent = NULL);   // standard constructor
00023
00024 // Dialog Data
00025         //{{AFX_DATA(cWaitDlg)
00026         enum { IDD = IDD_BUSY_DLG };
00027                 // NOTE: the ClassWizard will add data members here
00028         //}}AFX_DATA
00029    cWaitDlgThread       *m_Thread;
00030    cAnimWnd                m_Anim;
00031    CString        m_Text;
00032    bool           m_bShowCancelButton;
00033
00034 // Overrides
00035         // ClassWizard generated virtual function overrides
00036         //{{AFX_VIRTUAL(cWaitDlg)
00037         protected:
00038         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00039         //}}AFX_VIRTUAL
00040
00041 // Implementation
00042 protected:
00043
00044         virtual void OnCancel();
00045         // Generated message map functions
00046         //{{AFX_MSG(cWaitDlg)
00047         virtual void OnOK();
00048         virtual BOOL OnInitDialog();
00049         afx_msg void OnTimer(UINT nIDEvent);
00050         //}}AFX_MSG
00051         DECLARE_MESSAGE_MAP()
00052 };
00053
00054 //{{AFX_INSERT_LOCATION}}
00055 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00056
00057 #endif // !defined(AFX_WAITDLG_H__55050813_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlgThread.cpp Source File

waitdlg/WaitDlgThread.cpp
Go to the documentation of this file.
00001 // WaitDlgThread.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "WaitDialog.h"
00006 #include "WaitDlgThread.h"
00007 #include "WaitDlg.h"
00008
00009
00010 //#ifdef _DEBUG
00011 //#define new DEBUG_NEW
00012 //#undef THIS_FILE
00013 //static char THIS_FILE[] = __FILE__;
00014 //#endif
00015
00017 // cWaitDlgThread
00018
00019 IMPLEMENT_DYNCREATE(cWaitDlgThread, CWinThread)
00020
00021 cWaitDlgThread::cWaitDlgThread()
00022 {
00023    m_bShowCancelButton = false;
00024    m_Text = "";
00025 }
00026
00027 cWaitDlgThread::~cWaitDlgThread()
00028 {
00029 }
00030
00031 BOOL cWaitDlgThread::InitInstance()
00032 {
00033         // TODO:  perform and per-thread initialization here
00034    cWaitDlg dlg;
00035
00036    m_pMainWnd = &dlg;
00037    m_Event = new CEvent(FALSE, TRUE, m_Eventname);
00038    dlg.m_bShowCancelButton = m_bShowCancelButton;
00039    dlg.m_Text = m_Text;
00040    dlg.m_Thread = this;
00041    dlg.DoModal();
00042    delete m_Event;
00043
00044    return FALSE;
00045 }
00046
00047 int cWaitDlgThread::ExitInstance()
00048 {
00049         // TODO:  perform any per-thread cleanup here
00050   return CWinThread::ExitInstance();
00051 }
00052
00053 BEGIN_MESSAGE_MAP(cWaitDlgThread, CWinThread)
00054         //{{AFX_MSG_MAP(cWaitDlgThread)
00055                 // NOTE - the ClassWizard will add and remove mapping macros here.
00056         //}}AFX_MSG_MAP
00057 END_MESSAGE_MAP()
00058
00060 // cWaitDlgThread message handlers
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/WaitDlgThread.h Source File

waitdlg/WaitDlgThread.h
Go to the documentation of this file.
00001 #if !defined(AFX_WAITDLGTHREAD_H__55050812_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
00002 #define AFX_WAITDLGTHREAD_H__55050812_F8E6_11D2_837D_00500406DAEB__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // WaitDlgThread.h : header file
00008 //
00010 // Author: Todd Andrews
00011 // Email:  tmandrews@mindspring.com
00012 // Copyright 1999, Todd Andrews
00013 //
00014 // You may freely use or modify this code provided this
00015 // Copyright is included in all derived versions.
00016 //
00017 //
00018 // This class implements a worker thread
00019
00020 #include <afxmt.h>
00021
00023 // WaitDlgThread thread
00024
00025 class cWaitDlgThread : public CWinThread
00026 {
00027         DECLARE_DYNCREATE(cWaitDlgThread)
00028
00029 public:
00030    cWaitDlgThread();           // protected constructor used by dynamic creation
00031
00032 protected:
00033 // Attributes
00034
00035 public:
00036    CString  m_Eventname;
00037    CEvent   *m_Event;
00038    bool     m_bShowCancelButton;
00039    CString  m_Text;
00040
00041 // Operations
00042 public:
00043
00044 // Overrides
00045         // ClassWizard generated virtual function overrides
00046         //{{AFX_VIRTUAL(cWaitDlgThread)
00047         public:
00048         virtual BOOL InitInstance();
00049         virtual int ExitInstance();
00050         //}}AFX_VIRTUAL
00051
00052 // Implementation
00053 public:
00054         virtual ~cWaitDlgThread();
00055
00056 protected:
00057
00058         // Generated message map functions
00059         //{{AFX_MSG(cWaitDlgThread)
00060                 // NOTE - the ClassWizard will add and remove member functions here.
00061         //}}AFX_MSG
00062
00063         DECLARE_MESSAGE_MAP()
00064 };
00065
00067
00068 //{{AFX_INSERT_LOCATION}}
00069 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00070
00071 #endif // !defined(AFX_WAITDLGTHREAD_H__55050812_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WinusbNotify.cpp Source File

DeviceIO/WinusbNotify.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "WinusbNotify.h"
00003
00004 CWinusbNotify::CWinusbNotify(void)
00005 {
00006         m_hWndOwner = NULL;
00007         DeviceNotificationHandle = NULL;
00008 }
00009
00010 CWinusbNotify::~CWinusbNotify(void)
00011 {
00012 }
00013
00014 void CWinusbNotify::SetNotificationWindow(HWND m_hWnd)
00015 {
00016         m_hWndOwner = m_hWnd;
00017 }
00018
00019 void CWinusbNotify::InitDeviceInfo()
00020 {
00021         DeviceNotificationHandle = NULL;
00022 }
00023
00024 void CWinusbNotify::RegDeviceNotification()
00025 {
00026         DEV_BROADCAST_DEVICEINTERFACE DevBroadcastDeviceInterface;
00027         DevBroadcastDeviceInterface.dbcc_size = sizeof(DevBroadcastDeviceInterface);
00028         DevBroadcastDeviceInterface.dbcc_devicetype = DBT_DEVTYP_DEVICEINTERFACE;
00029         DevBroadcastDeviceInterface.dbcc_classguid = GUID_DP5_INTERFACE_CLASS;
00030         DeviceNotificationHandle = RegisterDeviceNotification(m_hWndOwner,
00031                                                                         &DevBroadcastDeviceInterface,
00032                                                                         DEVICE_NOTIFY_WINDOW_HANDLE);
00033 }
00034
00035 BOOL CWinusbNotify::GetDevNotifyInfo(DWORD_PTR dwData, char devicePath[])
00036 {
00037         CString DeviceNameString;
00038         //CString strDevicepath("%s", devicePath);
00039         PDEV_BROADCAST_HDR lDBH = (PDEV_BROADCAST_HDR)dwData;
00040         if (lDBH->dbch_devicetype == DBT_DEVTYP_DEVICEINTERFACE)
00041         {
00042                 PDEV_BROADCAST_DEVICEINTERFACE lDBDI = (PDEV_BROADCAST_DEVICEINTERFACE)dwData;
00043                 DeviceNameString = lDBDI->dbcc_name;
00044                 //AfxMessageBox(DeviceNameString);
00045                 if      ((DeviceNameString.CompareNoCase(devicePath)) == 0) {
00046                         //AfxMessageBox("The names match.");
00047                         return true;
00048                 } else {
00049                         //AfxMessageBox("It’s a different device.");
00050                         return false;
00051                 }
00052         }
00053         return false;
00054 }
00055
00056 void CWinusbNotify::RemoveDeviceNotification()
00057 {
00058         if (DeviceNotificationHandle != NULL) {
00059                 UnregisterDeviceNotification(DeviceNotificationHandle);
00060         }
00061 }
00062
00063 BOOL CWinusbNotify::UnregDeviceNotification(HDEVNOTIFY Handle)
00064 {
00065         return UnregisterDeviceNotification(Handle);
00066 }
00067
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/WinusbNotify.h Source File

DeviceIO/WinusbNotify.h
Go to the documentation of this file.
00001
00002 #pragma once
00003 #include "DppWinUSB.h"
00004
00005 class CWinusbNotify
00006 {
00007 public:
00008         CWinusbNotify(void);
00009         ~CWinusbNotify(void);
00010         HDEVNOTIFY DeviceNotificationHandle;
00011         void InitDeviceInfo();
00012         HWND m_hWndOwner;
00013         void SetNotificationWindow(HWND m_hWnd);
00014         void RegDeviceNotification();
00015         BOOL GetDevNotifyInfo(DWORD_PTR dwData, char devicePath[]);
00016         void RemoveDeviceNotification();
00017         BOOL UnregDeviceNotification(HDEVNOTIFY Handle);
00018
00019 };
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Controls/X11Color.h Source File

Controls/X11Color.h
Go to the documentation of this file.
00001 #ifndef __X11COLOR_H__INCLUDED_
00002 #define __X11COLOR_H__INCLUDED_
00003
00004 #pragma once
00005
00006 // X11Color.h : header file
00007
00008
00009 const COLORREF colorAliceBlue            = RGB(0xF0,0xF8,0xFF); //RGB(240,248,255)
00010 const COLORREF colorAmptekBlue           = RGB(0x7A,0xCE,0xFC); //RGB(122,206,252)
00011 const COLORREF colorAntiqueWhite         = RGB(0xFA,0xEB,0xD7); //RGB(250,235,215)
00012 const COLORREF colorAqua                 = RGB(0x00,0xFF,0xFF); //RGB(  0,255,255)
00013 const COLORREF colorAquamarine           = RGB(0x7F,0xFF,0xD4); //RGB(127,255,212)
00014 const COLORREF colorAzure                = RGB(0xF0,0xFF,0xFF); //RGB(240,255,255)
00015 const COLORREF colorBeige                = RGB(0xF5,0xF5,0xDC); //RGB(245,245,220)
00016 const COLORREF colorBisque               = RGB(0xFF,0xE4,0xC4); //RGB(255,228,196)
00017 const COLORREF colorBlack                = RGB(0x00,0x00,0x00); //RGB(  0,  0,  0)
00018 const COLORREF colorBlanchedAlmond       = RGB(0xFF,0xEB,0xCD); //RGB(255,235,205)
00019 const COLORREF colorBlue                 = RGB(0x00,0x00,0xFF); //RGB(  0,  0,255)
00020 const COLORREF colorBlueViolet           = RGB(0x8A,0x2B,0xE2); //RGB(138, 43,226)
00021 const COLORREF colorBrown                = RGB(0xA5,0x2A,0x2A); //RGB(165, 42, 42)
00022 const COLORREF colorBurlyWood            = RGB(0xDE,0xB8,0x87); //RGB(222,184,135)
00023 const COLORREF colorCadetBlue            = RGB(0x5F,0x9E,0xA0); //RGB( 95,158,160)
00024 const COLORREF colorChartreuse           = RGB(0x7F,0xFF,0x00); //RGB(127,255,  0)
00025 const COLORREF colorChocolate            = RGB(0xD2,0x69,0x1E); //RGB(210,105, 30)
00026 const COLORREF colorCoral                = RGB(0xFF,0x7F,0x50); //RGB(255,127, 80)
00027 const COLORREF colorCornflowerBlue       = RGB(0x64,0x95,0xED); //RGB(100,149,237)
00028 const COLORREF colorCornsilk             = RGB(0xFF,0xF8,0xDC); //RGB(255,248,220)
00029 const COLORREF colorCrimson              = RGB(0xDC,0x14,0x3C); //RGB(220, 20, 60)
00030 const COLORREF colorCyan                 = RGB(0x00,0xFF,0xFF); //RGB(  0,255,255)
00031 const COLORREF colorDarkBlue             = RGB(0x00,0x00,0x8B); //RGB(  0,  0,139)
00032 const COLORREF colorDarkCyan             = RGB(0x00,0x8B,0x8B); //RGB(  0,139,139)
00033 const COLORREF colorDarkGoldenrod        = RGB(0xB8,0x86,0x0B); //RGB(184,134, 11)
00034 const COLORREF colorDarkGray             = RGB(0xA9,0xA9,0xA9); //RGB(169,169,169)
00035 const COLORREF colorDarkGreen            = RGB(0x00,0x64,0x00); //RGB(  0,100,  0)
00036 const COLORREF colorDarkKhaki            = RGB(0xBD,0xB7,0x6B); //RGB(189,183,107)
00037 const COLORREF colorDarkMagenta          = RGB(0x8B,0x00,0x8B); //RGB(139,  0,139)
00038 const COLORREF colorDarkOliveGreen       = RGB(0x55,0x6B,0x2F); //RGB( 85,107, 47)
00039 const COLORREF colorDarkOrange           = RGB(0xFF,0x8C,0x00); //RGB(255,140,  0)
00040 const COLORREF colorDarkOrchid           = RGB(0x99,0x32,0xCC); //RGB(153, 50,204)
00041 const COLORREF colorDarkRed              = RGB(0x8B,0x00,0x00); //RGB(139,  0,  0)
00042 const COLORREF colorDarkSalmon           = RGB(0xE9,0x96,0x7A); //RGB(233,150,122)
00043 const COLORREF colorDarkSeaGreen         = RGB(0x8F,0xBC,0x8F); //RGB(143,188,143)
00044 const COLORREF colorDarkSlateBlue        = RGB(0x48,0x3D,0x8B); //RGB( 72, 61,139)
00045 const COLORREF colorDarkSlateGray        = RGB(0x2F,0x4F,0x4F); //RGB( 47, 79, 79)
00046 const COLORREF colorDarkTurquoise        = RGB(0x00,0xCE,0xD1); //RGB(  0,206,209)
00047 const COLORREF colorDarkViolet           = RGB(0x94,0x00,0xD3); //RGB(148,  0,211)
00048 const COLORREF colorDeepPink             = RGB(0xFF,0x14,0x93); //RGB(255, 20,147)
00049 const COLORREF colorDeepSkyBlue          = RGB(0x00,0xBF,0xFF); //RGB(  0,191,255)
00050 const COLORREF colorDimGray              = RGB(0x69,0x69,0x69); //RGB(105,105,105)
00051 const COLORREF colorDodgerBlue           = RGB(0x1E,0x90,0xFF); //RGB( 30,144,255)
00052 const COLORREF colorFireBrick            = RGB(0xB2,0x22,0x22); //RGB(178, 34, 34)
00053 const COLORREF colorFloralWhite          = RGB(0xFF,0xFA,0xF0); //RGB(255,250,240)
00054 const COLORREF colorForestGreen          = RGB(0x22,0x8B,0x22); //RGB( 34,139, 34)
00055 const COLORREF colorFuchsia              = RGB(0xFF,0x00,0xFF); //RGB(255,  0,255)
00056 const COLORREF colorGainsboro            = RGB(0xDC,0xDC,0xDC); //RGB(220,220,220)
00057 const COLORREF colorGhostWhite           = RGB(0xF8,0xF8,0xFF); //RGB(248,248,255)
00058 const COLORREF colorGold                 = RGB(0xFF,0xD7,0x00); //RGB(255,215,  0)
00059 const COLORREF colorGoldenrod            = RGB(0xDA,0xA5,0x20); //RGB(218,165, 32)
00060 const COLORREF colorGray                 = RGB(0x80,0x80,0x80); //RGB(128,128,128)
00061 const COLORREF colorGreen                = RGB(0x00,0x80,0x00); //RGB(  0,128,  0)
00062 const COLORREF colorGreenYellow          = RGB(0xAD,0xFF,0x2F); //RGB(173,255, 47)
00063 const COLORREF colorHoneydew             = RGB(0xF0,0xFF,0xF0); //RGB(240,255,240)
00064 const COLORREF colorHotPink              = RGB(0xFF,0x69,0xB4); //RGB(255,105,180)
00065 const COLORREF colorIndianRed            = RGB(0xCD,0x5C,0x5C); //RGB(205, 92, 92)
00066 const COLORREF colorIndigo               = RGB(0x4B,0x00,0x82); //RGB( 75,  0,130)
00067 const COLORREF colorIvory                = RGB(0xFF,0xFF,0xF0); //RGB(255,255,240)
00068 const COLORREF colorKhaki                = RGB(0xF0,0xE6,0x8C); //RGB(240,230,140)
00069 const COLORREF colorLavender             = RGB(0xE6,0xE6,0xFA); //RGB(230,230,250)
00070 const COLORREF colorLavenderBlush        = RGB(0xFF,0xF0,0xF5); //RGB(255,240,245)
00071 const COLORREF colorLawnGreen            = RGB(0x7C,0xFC,0x00); //RGB(124,252,  0)
00072 const COLORREF colorLemonChiffon         = RGB(0xFF,0xFA,0xCD); //RGB(255,250,205)
00073 const COLORREF colorLightBlue            = RGB(0xAD,0xD8,0xE6); //RGB(173,216,230)
00074 const COLORREF colorLightCoral           = RGB(0xF0,0x80,0x80); //RGB(240,128,128)
00075 const COLORREF colorLightCyan            = RGB(0xE0,0xFF,0xFF); //RGB(224,255,255)
00076 const COLORREF colorLightGoldenrodYellow = RGB(0xFA,0xFA,0xD2); //RGB(250,250,210)
00077 const COLORREF colorLightGray            = RGB(0xD3,0xD3,0xD3); //RGB(211,211,211)
00078 const COLORREF colorLightGreen           = RGB(0x90,0xEE,0x90); //RGB(144,238,144)
00079 const COLORREF colorLightGrey            = RGB(0xD3,0xD3,0xD3); //RGB(211,211,211)
00080 const COLORREF colorLightPink            = RGB(0xFF,0xB6,0xC1); //RGB(255,182,193)
00081 const COLORREF colorLightSalmon          = RGB(0xFF,0xA0,0x7A); //RGB(255,160,122)
00082 const COLORREF colorLightSeaGreen        = RGB(0x20,0xB2,0xAA); //RGB( 32,178,170)
00083 const COLORREF colorLightSkyBlue         = RGB(0x87,0xCE,0xFA); //RGB(135,206,250)
00084 const COLORREF colorLightSlateGray       = RGB(0x77,0x88,0x99); //RGB(119,136,153)
00085 const COLORREF colorLightSteelBlue       = RGB(0xB0,0xC4,0xDE); //RGB(176,196,222)
00086 const COLORREF colorLightYellow          = RGB(0xFF,0xFF,0xE0); //RGB(255,255,224)
00087 const COLORREF colorLime                 = RGB(0x00,0xFF,0x00); //RGB(  0,255,  0)
00088 const COLORREF colorLimeGreen            = RGB(0x32,0xCD,0x32); //RGB( 50,205, 50)
00089 const COLORREF colorLinen                = RGB(0xFA,0xF0,0xE6); //RGB(250,240,230)
00090 const COLORREF colorMagenta              = RGB(0xFF,0x00,0xFF); //RGB(255,  0,255)
00091 const COLORREF colorMaroon               = RGB(0x80,0x00,0x00); //RGB(128,  0,  0)
00092 const COLORREF colorMediumAquamarine     = RGB(0x66,0xCD,0xAA); //RGB(102,205,170)
00093 const COLORREF colorMediumBlue           = RGB(0x00,0x00,0xCD); //RGB(  0,  0,205)
00094 const COLORREF colorMediumOrchid         = RGB(0xBA,0x55,0xD3); //RGB(186, 85,211)
00095 const COLORREF colorMediumPurple         = RGB(0x93,0x70,0xDB); //RGB(147,112,219)
00096 const COLORREF colorMediumSeaGreen       = RGB(0x3C,0xB3,0x71); //RGB( 60,179,113)
00097 const COLORREF colorMediumSlateBlue      = RGB(0x7B,0x68,0xEE); //RGB(123,104,238)
00098 const COLORREF colorMediumSpringGreen    = RGB(0x00,0xFA,0x9A); //RGB(  0,250,154)
00099 const COLORREF colorMediumTurquoise      = RGB(0x48,0xD1,0xCC); //RGB( 72,209,204)
00100 const COLORREF colorMediumVioletRed      = RGB(0xC7,0x15,0x85); //RGB(199, 21,133)
00101 const COLORREF colorMidnightBlue         = RGB(0x19,0x19,0x70); //RGB( 25, 25,112)
00102 const COLORREF colorMintCream            = RGB(0xF5,0xFF,0xFA); //RGB(245,255,250)
00103 const COLORREF colorMistyRose            = RGB(0xFF,0xE4,0xE1); //RGB(255,228,225)
00104 const COLORREF colorMoccasin             = RGB(0xFF,0xE4,0xB5); //RGB(255,228,181)
00105 const COLORREF colorNavajoWhite          = RGB(0xFF,0xDE,0xAD); //RGB(255,222,173)
00106 const COLORREF colorNavy                 = RGB(0x00,0x00,0x80); //RGB(  0,  0,128)
00107 const COLORREF colorOldLace              = RGB(0xFD,0xF5,0xE6); //RGB(253,245,230)
00108 const COLORREF colorOlive                = RGB(0x80,0x80,0x00); //RGB(128,128,  0)
00109 const COLORREF colorOliveDrab            = RGB(0x6B,0x8E,0x23); //RGB(107,142, 35)
00110 const COLORREF colorOrange               = RGB(0xFF,0xA5,0x00); //RGB(255,165,  0)
00111 const COLORREF colorOrangeRed            = RGB(0xFF,0x45,0x00); //RGB(255, 69,  0)
00112 const COLORREF colorOrchid               = RGB(0xDA,0x70,0xD6); //RGB(218,112,214)
00113 const COLORREF colorPaleGoldenrod        = RGB(0xEE,0xE8,0xAA); //RGB(238,232,170)
00114 const COLORREF colorPaleGreen            = RGB(0x98,0xFB,0x98); //RGB(152,251,152)
00115 const COLORREF colorPaleTurquoise        = RGB(0xAF,0xEE,0xEE); //RGB(175,238,238)
00116 const COLORREF colorPaleVioletRed        = RGB(0xDB,0x70,0x93); //RGB(219,112,147)
00117 const COLORREF colorPapayaWhip           = RGB(0xFF,0xEF,0xD5); //RGB(255,239,213)
00118 const COLORREF colorPeachPuff            = RGB(0xFF,0xDA,0xB9); //RGB(255,218,185)
00119 const COLORREF colorPeru                 = RGB(0xCD,0x85,0x3F); //RGB(205,133, 63)
00120 const COLORREF colorPink                 = RGB(0xFF,0xC0,0xCB); //RGB(255,192,203)
00121 const COLORREF colorPlum                 = RGB(0xDD,0xA0,0xDD); //RGB(221,160,221)
00122 const COLORREF colorPowderBlue           = RGB(0xB0,0xE0,0xE6); //RGB(176,224,230)
00123 const COLORREF colorPurple               = RGB(0x80,0x00,0x80); //RGB(128,  0,128)
00124 const COLORREF colorRed                  = RGB(0xFF,0x00,0x00); //RGB(255,  0,  0)
00125 const COLORREF colorRosyBrown            = RGB(0xBC,0x8F,0x8F); //RGB(188,143,143)
00126 const COLORREF colorRoyalBlue            = RGB(0x41,0x69,0xE1); //RGB( 65,105,225)
00127 const COLORREF colorSaddleBrown          = RGB(0x8B,0x45,0x13); //RGB(139, 69, 19)
00128 const COLORREF colorSalmon               = RGB(0xFA,0x80,0x72); //RGB(250,128,114)
00129 const COLORREF colorSandyBrown           = RGB(0xF4,0xA4,0x60); //RGB(244,164, 96)
00130 const COLORREF colorSeaGreen             = RGB(0x2E,0x8B,0x57); //RGB( 46,139, 87)
00131 const COLORREF colorSeaShell             = RGB(0xFF,0xF5,0xEE); //RGB(255,245,238)
00132 const COLORREF colorSienna               = RGB(0xA0,0x52,0x2D); //RGB(160, 82, 45)
00133 const COLORREF colorSilver               = RGB(0xC0,0xC0,0xC0); //RGB(192,192,192)
00134 const COLORREF colorSkyBlue              = RGB(0x87,0xCE,0xEB); //RGB(135,206,235)
00135 const COLORREF colorSlateBlue            = RGB(0x6A,0x5A,0xCD); //RGB(106, 90,205)
00136 const COLORREF colorSlateGray            = RGB(0x70,0x80,0x90); //RGB(112,128,144)
00137 const COLORREF colorSnow                 = RGB(0xFF,0xFA,0xFA); //RGB(255,250,250)
00138 const COLORREF colorSpringGreen          = RGB(0x00,0xFF,0x7F); //RGB(  0,255,127)
00139 const COLORREF colorSteelBlue            = RGB(0x46,0x82,0xB4); //RGB( 70,130,180)
00140 const COLORREF colorTan                  = RGB(0xD2,0xB4,0x8C); //RGB(210,180,140)
00141 const COLORREF colorTeal                 = RGB(0x00,0x80,0x80); //RGB(  0,128,128)
00142 const COLORREF colorThistle              = RGB(0xD8,0xBF,0xD8); //RGB(216,191,216)
00143 const COLORREF colorTomato               = RGB(0xFF,0x63,0x47); //RGB(255, 99, 71)
00144 const COLORREF colorTurquoise            = RGB(0x40,0xE0,0xD0); //RGB( 64,224,208)
00145 const COLORREF colorViolet               = RGB(0xEE,0x82,0xEE); //RGB(238,130,238)
00146 const COLORREF colorWheat                = RGB(0xF5,0xDE,0xB3); //RGB(245,222,179)
00147 const COLORREF colorWhite                = RGB(0xFF,0xFF,0xFF); //RGB(255,255,255)
00148 const COLORREF colorWhiteSmoke           = RGB(0xF5,0xF5,0xF5); //RGB(245,245,245)
00149 const COLORREF colorYellow               = RGB(0xFF,0xFF,0x00); //RGB(255,255,  0)
00150 const COLORREF colorYellowGreen          = RGB(0x9A,0xCD,0x32); //RGB(154,205, 50)
00151
00152 #endif // __X11COLOR_H__INCLUDED_
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
_CONFIG_OPTIONS |
_COORD_LONG |
_DiagDataType |
_DppStateType |
_Packet_In |
_SpectrumFileType |
_WINUSB_PIPE_INFORMATION |
_WINUSB_SETUP_PACKET |
CAboutDlg |
cAnimWnd |
CAsciiCmdUtilities |
CDP5Protocol |
CDP5Status |
CDppLibUsb |
CDppSlowThreshold |
CDppUtilities |
CDppWinUSB |
CFileBrowse |
CINI |
CIniEx |
CIniUtil |
CLabel |
cMemDC |
CMSecTimer |
CMsgBox |
CNetFinder |
CParsePacket |
CPlotCanvas |
CSelectDP5 |
CSendCommand |
CSProfile |
CTuneSlowThreshold |
CvcDP5App |
CvcDP5Dlg |
cWaitDialog |
cWaitDlg |
cWaitDlgThread |
CWinusbNotify |
DP5_DP4_FORMAT_STATUS |
NETDISPLAY_ENTRY |
Packet_Out |
Spec |
stringex |
WINUSB_DEVICE_INFO | Holds WinUSB device information
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CAboutDlg Member List
This is the complete list of members for CAboutDlg, including all inherited members.
CAboutDlg() | CAboutDlg |
DoDataExchange(CDataExchange *pDX) | CAboutDlg | [protected, virtual]
IDD enum value | CAboutDlg |
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CAsciiCmdUtilities Member List
This is the complete list of members for CAsciiCmdUtilities, including all inherited members.
CAsciiCmdUtilities(void) | CAsciiCmdUtilities
CopyAsciiData(unsigned char Data[], string strCfg, long lLen) | CAsciiCmdUtilities
CreateFullReadBackCmd(bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO) | CAsciiCmdUtilities
CreateFullReadBackCmdMCA8000D(int DppType) | CAsciiCmdUtilities
CreateResTestReadBackCmd(bool bSendCoarseFineGain, int DppType) | CAsciiCmdUtilities
GetCmdChunk(std::string strCmd) | CAsciiCmdUtilities
GetDP5CfgStr(std::string strFilename) | CAsciiCmdUtilities
GetDP5ScaStr(std::string strFilename) | CAsciiCmdUtilities
MakeUpper(std::string myString) | CAsciiCmdUtilities
Remove_MCA8000D_Cmds(std::string strCfgDataIn, int DppType) | CAsciiCmdUtilities
RemoveCmd(std::string strCmd, std::string strCfgData) | CAsciiCmdUtilities
RemoveCmdByDeviceType(std::string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO) | CAsciiCmdUtilities
RemoveCmdByDeviceTypeDP5DxK(std::string strCfgDataIn, bool PC5_PRESENT, int DppType) | CAsciiCmdUtilities
RemWhitespace(std::string strLine) | CAsciiCmdUtilities
ReplaceCmdText(std::string strInTextIn, std::string strFrom, std::string strTo) | CAsciiCmdUtilities
~CAsciiCmdUtilities(void) | CAsciiCmdUtilities
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CDP5Protocol Member List
This is the complete list of members for CDP5Protocol, including all inherited members.
ACK_Received | CDP5Protocol
BufferOUT | CDP5Protocol
CDP5Protocol(void) | CDP5Protocol
CommError | CDP5Protocol
InPacketType | CDP5Protocol
MiscData | CDP5Protocol
Netfinder_active | CDP5Protocol
Netfinder_Seq | CDP5Protocol
Packet_Received | CDP5Protocol
PacketIn | CDP5Protocol
PIN | CDP5Protocol
RS232_RThreshold | CDP5Protocol
RS232BytesInBuffer | CDP5Protocol
RS232HeaderReceived | CDP5Protocol
RS232PacketPtr | CDP5Protocol
ScaleAuto | CDP5Protocol
Scope | CDP5Protocol
SPECTRUM | CDP5Protocol
Timeout_flag | CDP5Protocol
UDP_offset | CDP5Protocol
USB_Default_Timeout | CDP5Protocol
~CDP5Protocol(void) | CDP5Protocol
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CDP5Status Member List
This is the complete list of members for CDP5Status, including all inherited members.
CDP5Status(void) | CDP5Status
DiagData | CDP5Status
DiagnosticsToString(DiagDataType dd, int device_type) | CDP5Status
DiagStrPX5Option(DiagDataType dd, int device_type) | CDP5Status
DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn) | CDP5Status
DP5_Dx_OptionFlags(unsigned char DP5_Dx_Options) | CDP5Status
DppUtil | CDP5Status
FmtHex(long FmtHex, long HexDig) | CDP5Status
FmtHvPwr(float fVal) | CDP5Status
FmtLng(long lVal) | CDP5Status
FmtPc5Pwr(float fVal) | CDP5Status
FmtPc5Temp(float fVal) | CDP5Status
GetDeviceNameFromVal(int DeviceTypeVal) | CDP5Status
GetStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status) | CDP5Status
IsAorB(bool bIsA, string strA, string strB) | CDP5Status
m_DP5_Status | CDP5Status
OnOffStr(bool bOn) | CDP5Status
Process_Diagnostics(Packet_In PIN, DiagDataType *dd, int device_type) | CDP5Status
Process_Status(DP4_FORMAT_STATUS *m_DP5_Status) | CDP5Status
PX5_OptionsString(DP4_FORMAT_STATUS m_DP5_Status) | CDP5Status
SaveStringDataToFile(string strData) | CDP5Status
ShowStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status) | CDP5Status
VersionToStr(unsigned char bVersion) | CDP5Status
~CDP5Status(void) | CDP5Status
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CDppLibUsb Member List
This is the complete list of members for CDppLibUsb, including all inherited members.
bDeviceConnected | CDppLibUsb
bDeviceReady | CDppLibUsb
bLibusbReady | CDppLibUsb
CDppLibUsb(void) | CDppLibUsb
CloseUSBDevice(libusb_device_handle *devh) | CDppLibUsb
CountDP5LibusbDevices() | CDppLibUsb
CurrentDevice | CDppLibUsb
data_in | CDppLibUsb
data_out | CDppLibUsb
DeinitializeLibusb() | CDppLibUsb
DppLibusbHandle | CDppLibUsb
FindUSBDevice(int idxAmptekDevice) | CDppLibUsb
InitializeLibusb() | CDppLibUsb
isAmptekDP5Device(libusb_device_descriptor desc) | CDppLibUsb
LastLibUsbError | CDppLibUsb
libusb_strerror(enum libusb_error error_code) | CDppLibUsb
NumDevices | CDppLibUsb
PrintDevices() | CDppLibUsb
SendPacketUSB(libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[]) | CDppLibUsb
~CDppLibUsb(void) | CDppLibUsb
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CDppSlowThreshold Member List
This is the complete list of members for CDppSlowThreshold, including all inherited members.
CDppSlowThreshold(void) | CDppSlowThreshold
DPPThreshold(int SpinPos) | CDppSlowThreshold
GetSlowChThreshold() | CDppSlowThreshold
GetSlowChThresStrFromVal(UCHAR byteSlowThres) | CDppSlowThreshold
GetSlowThreshChStr() | CDppSlowThreshold
GetSlowThreshChStrFromVal(UCHAR byteSlowThres) | CDppSlowThreshold
GetSlowThresholdSettingFromChannels(double dblSlowThreshChannels) | CDppSlowThreshold
GetSlowThresholdSettingFromPercent(double dblSlowThresh) | CDppSlowThreshold
GetSlowThreshPcntStr() | CDppSlowThreshold
SetGain(long GainVal) | CDppSlowThreshold
SetSlowChThreshold(UCHAR SlowChThresholdVal) | CDppSlowThreshold
SetSlowChThresholdConfigFromStr(CString strSlowThresh) | CDppSlowThreshold
SetSlowChThresholdFromStr(CString strSlowThresh) | CDppSlowThreshold
SetSlowChThresholdFromVal(int intSlowThresh) | CDppSlowThreshold
Thresholds_Setup(CSpinButtonCtrl *udThresholdObj, CEdit *lblThresholdObj, CEdit *lblThresholdChannelsObj) | CDppSlowThreshold
txtSlowThreshold_Click() | CDppSlowThreshold
txtSlowThresholdChannels_Click() | CDppSlowThreshold
UpdateSlowThresChDisplay() | CDppSlowThreshold
~CDppSlowThreshold(void) | CDppSlowThreshold
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CDppUtilities Member List
This is the complete list of members for CDppUtilities, including all inherited members.
BYTEVersionToDouble(unsigned char Version) | CDppUtilities
BYTEVersionToString(unsigned char Version) | CDppUtilities
CDppUtilities(void) | CDppUtilities
LongWordToDouble(int lwStart, unsigned char buffer[]) | CDppUtilities
~CDppUtilities(void) | CDppUtilities
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CDppWinUSB Member List
This is the complete list of members for CDppWinUSB, including all inherited members.
CDppWinUSB(void) | CDppWinUSB
CloseDeviceHandle() | CDppWinUSB
CloseWinUsbDevice() | CDppWinUSB
CountDP5WinusbDevices(void) | CDppWinUSB
CurrentDevice | CDppWinUSB
devInfo | CDppWinUSB
Disable_WinUsb() | CDppWinUSB
DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn) | CDppWinUSB
FindUSBDevice(DWORD MemberIndex) | CDppWinUSB
GetDevicePath(LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex) | CDppWinUSB
InitDeviceInfo() | CDppWinUSB
Initialize_Device(DWORD MemberIndex) | CDppWinUSB
isDppFound | CDppWinUSB
NumDevices | CDppWinUSB
NumPipes | CDppWinUSB
OpenDevice(BOOL bSync, DWORD MemberIndex) | CDppWinUSB
PipeId | CDppWinUSB
PipeTimeout | CDppWinUSB
SaveStringDataToFile(string strData) | CDppWinUSB
SendPacketUSB(unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[]) | CDppWinUSB
USB_Default_Timeout | CDppWinUSB
USBStatusString(DPP_USB_STATUS USBStatus) | CDppWinUSB
WinUsb_Disabled | CDppWinUSB
~CDppWinUSB(void) | CDppWinUSB
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CFileBrowse Member List
This is the complete list of members for CFileBrowse, including all inherited members.
AllFileFilter | CFileBrowse
BmpFileFilter | CFileBrowse
CfgFileFilter | CFileBrowse
CFileBrowse(void) | CFileBrowse
DialogType enum name | CFileBrowse
DoModal(int DlgType, CString DlgTitle, CString FileFilter, CString DefaultExt, CString InitDir, CString *Filename) | CFileBrowse
ExeFileFilter | CFileBrowse
LibFileFilter | CFileBrowse
McaFileFilter | CFileBrowse
OPEN enum value | CFileBrowse
SAVE enum value | CFileBrowse
TxtFileFilter | CFileBrowse
~CFileBrowse(void) | CFileBrowse
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CINI Member List
This is the complete list of members for CINI, including all inherited members.
CINI(CString strFile) | CINI |
CINI() | CINI | [inline]
DeleteKey(CString strKey, CString strSection) | CINI |
DeleteSection(CString strSection) | CINI |
getKeyValue(CString strKey, CString strSection) | CINI |
getSectionData(CString strSection) | CINI |
getSectionNames() | CINI |
sectionExists(CString strSection) | CINI |
setINIFileName(CString strINIFile) | CINI |
setKey(CString strValue, CString strKey, CString strSection) | CINI |
~CINI() | CINI | [virtual]
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CIniEx Member List
This is the complete list of members for CIniEx, including all inherited members.
CIniEx(void) | CIniEx
~CIniEx(void) | CIniEx
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CIniUtil Member List
This is the complete list of members for CIniUtil, including all inherited members.
CIniUtil(void) | CIniUtil
ConvertCmdListToCString(CStringList *strCmdList, BOOL AddNewLines, BOOL RemoveComments) | CIniUtil
DeleteDP5Key(CString m_strINIFile, CString m_strSection, CString cmdKey) | CIniUtil
GetDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comments) | CIniUtil
GetDP5Section(CString m_strINIFile, CString m_strSection, CStringList *m_strListDP5section) | CIniUtil
GetMsIniItem(CString strCmdIn) | CIniUtil
ini | CIniUtil
SaveDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comments) | CIniUtil
~CIniUtil(void) | CIniUtil
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CLabel Member List
This is the complete list of members for CLabel, including all inherited members.
CLabel() | CLabel |
CtlColor(CDC *pDC, UINT nCtlColor) | CLabel | [protected]
FlashBackground(BOOL bActivate) | CLabel |
FlashText(BOOL bActivate) | CLabel |
LastBkColor | CLabel |
LastTextColor | CLabel |
m_bLink | CLabel | [protected]
m_bState | CLabel | [protected]
m_bTimer | CLabel | [protected]
m_crText | CLabel | [protected]
m_font | CLabel | [protected]
m_hBrush | CLabel | [protected]
m_hCursor | CLabel | [protected]
m_hwndBrush | CLabel | [protected]
m_lf | CLabel | [protected]
m_strText | CLabel | [protected]
m_Type | CLabel | [protected]
NullBkColor | CLabel |
NullSet | CLabel |
NullTextColor | CLabel |
OnLButtonDown(UINT nFlags, CPoint point) | CLabel | [protected]
OnSetCursor(CWnd *pWnd, UINT nHitTest, UINT message) | CLabel | [protected]
OnTimer(UINT nIDEvent) | CLabel | [protected]
ReconstructFont() | CLabel | [protected]
SetBkColor(COLORREF crBkgnd) | CLabel |
SetBorder(BOOL bSet) | CLabel |
SetFontBold(BOOL bBold) | CLabel |
SetFontItalic(BOOL bSet) | CLabel |
SetFontName(const CString &strFont) | CLabel |
SetFontSize(int nSize) | CLabel |
SetFontUnderline(BOOL bSet) | CLabel |
SetLastColor() | CLabel |
SetLink(BOOL bLink) | CLabel |
SetLinkCursor(HCURSOR hCursor) | CLabel |
SetNullColor() | CLabel |
SetSunken(BOOL bSet) | CLabel |
SetText(const CString &strText) | CLabel |
SetTextColor(COLORREF crText) | CLabel |
~CLabel() | CLabel | [virtual]
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CMSecTimer Member List
This is the complete list of members for CMSecTimer, including all inherited members.
CMSecTimer(void) | CMSecTimer
msTimeDiff(DWORD msStartTime, DWORD msTestTime) | CMSecTimer
msTimeExpired(DWORD msStartTime, DWORD msDelay) | CMSecTimer
msTimer(DWORD msDelay) | CMSecTimer
~CMSecTimer(void) | CMSecTimer
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CMsgBox Member List
This is the complete list of members for CMsgBox, including all inherited members.
CMsgBox(CWnd *pParent=NULL) | CMsgBox |
DoDataExchange(CDataExchange *pDX) | CMsgBox | [protected, virtual]
IDD enum value | CMsgBox |
m_strDelimiter | CMsgBox |
m_strMessage | CMsgBox |
m_strTitle | CMsgBox |
OnInitDialog() | CMsgBox | [virtual]
SetMessage(string cstrMsg, string m_strDelimiter) | CMsgBox |
~CMsgBox() | CMsgBox | [virtual]
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CNetFinder Member List
This is the complete list of members for CNetFinder, including all inherited members.
AddEntry(NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort) | CNetFinder
AlertByteToCOLORREF(unsigned char alert_level) | CNetFinder
AlertEntryToCOLORREF(NETDISPLAY_ENTRY *pEntry) | CNetFinder
CNetFinder(void) | CNetFinder
DppEntries | CNetFinder
DppEntryIdx | CNetFinder
DppFound | CNetFinder
DppSockAddr | CNetFinder
EntryToStr(NETDISPLAY_ENTRY *pEntry) | CNetFinder
EntryToStrRS232(NETDISPLAY_ENTRY *pEntry, CString strPort) | CNetFinder
EntryToStrUSB(NETDISPLAY_ENTRY *pEntry, CString strPort) | CNetFinder
FindEntry(unsigned long SockAddr) | CNetFinder
InitAllEntries() | CNetFinder
InitEntry(NETDISPLAY_ENTRY *pEntry) | CNetFinder
LastEntry | CNetFinder
m_rand | CNetFinder
SockAddr_ByteToInAddr(unsigned char *ip) | CNetFinder
SockAddr_ByteToStr(unsigned char *ip) | CNetFinder
SockAddr_ByteToULong(unsigned char *ip) | CNetFinder
SockAddr_DlgToStr(CDialog *dlg, int id1, int id2, int id3, int id4) | CNetFinder
SockAddr_InAddrToStr(in_addr inSockAddr) | CNetFinder
SockAddr_StrToInAddr(CString strSockAddr) | CNetFinder
SockAddr_StrToULong(CString strSockAddr) | CNetFinder
SockAddr_ULongToInAddr(unsigned long SockAddr) | CNetFinder
SockAddr_ULongToStr(unsigned long SockAddr) | CNetFinder
SockPort_DlgToUINT(CDialog *dlg, int id1) | CNetFinder
~CNetFinder(void) | CNetFinder
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CParsePacket Member List
This is the complete list of members for CParsePacket, including all inherited members.
CParsePacket(void) | CParsePacket
DppState | CParsePacket
ParsePacket(unsigned char P[], Packet_In *PIN) | CParsePacket
ParsePacketStatus(unsigned char P[], Packet_In *PIN) | CParsePacket
PID2_TextToString(string strPacketSource, unsigned char PID2) | CParsePacket
~CParsePacket(void) | CParsePacket
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CPlotCanvas Member List
This is the complete list of members for CPlotCanvas, including all inherited members.
ClearTrace() | CPlotCanvas |
CPlotCanvas() | CPlotCanvas |
CursorPosition | CPlotCanvas |
DataAcq(long DataBuffer[8192], int NumChan) | CPlotCanvas |
DrawCursor() | CPlotCanvas |
DrawCursor(CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor) | CPlotCanvas |
hasBackground | CPlotCanvas |
Invalidate() | CPlotCanvas |
m_crCursorColor | CPlotCanvas |
m_crDisplayBGColor | CPlotCanvas |
m_crPlotColor | CPlotCanvas |
m_crTextBGColor | CPlotCanvas |
m_crTextFGColor | CPlotCanvas |
OldCursorPosition | CPlotCanvas |
OldPlotCursor | CPlotCanvas |
OnEraseBkgnd(CDC *pDC) | CPlotCanvas | [protected]
OnLButtonDown(UINT nFlags, CPoint point) | CPlotCanvas |
OnPaint() | CPlotCanvas | [protected]
OnRefreshBkgnd() | CPlotCanvas |
OptPlotType | CPlotCanvas |
OptScaleType | CPlotCanvas |
PersistenceMode | CPlotCanvas |
PlotCursor | CPlotCanvas |
PlotTrace(long YPlotBufferIn[8192]) | CPlotCanvas |
SetCursorPosition(int CursorPos) | CPlotCanvas |
SetPersistenceMode(bool Persistence) | CPlotCanvas |
XPlotMAX | CPlotCanvas |
YPlotBuffer | CPlotCanvas |
YPlotMAX | CPlotCanvas |
~CPlotCanvas() | CPlotCanvas | [virtual]
Generated on Fri Sep 22 2017 10:01:05 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CSProfile Member List
This is the complete list of members for CSProfile, including all inherited members.
CSProfile(void) | CSProfile
data_refresh | CSProfile
device_type | CSProfile
Get(LPCTSTR profile, LPCTSTR entry, LPCTSTR def) | CSProfile
Get(LPCTSTR profile, LPCTSTR entry, int def) | CSProfile
isPlotLine | CSProfile
isScaleLog | CSProfile
LoadProfile() | CSProfile
profile | CSProfile
Put(LPCTSTR profile, LPCTSTR entry, LPCTSTR def) | CSProfile
Put(LPCTSTR profile, LPCTSTR entry, int def) | CSProfile
SaveProfile() | CSProfile
strDevice | CSProfile
~CSProfile(void) | CSProfile
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CSelectDP5 Member List
This is the complete list of members for CSelectDP5, including all inherited members.
cboComPort | CSelectDP5 |
CopyTextToClip(CString strTitle, CString strDesc) | CSelectDP5 |
CSelectDP5() | CSelectDP5 |
DataIn | CSelectDP5 |
DestroyWindow() | CSelectDP5 | [virtual]
DoDataExchange(CDataExchange *pDX) | CSelectDP5 | [protected, virtual]
EnableCommFunctions(int ControlGroup) | CSelectDP5 |
FindDpp | CSelectDP5 |
FindDppUSB | CSelectDP5 |
lblDppFound | CSelectDP5 |
m_bModified | CSelectDP5 |
m_DP5_Status | CSelectDP5 |
m_SpectrumRefreshTimeCtrl | CSelectDP5 |
m_SpinSelectDevice | CSelectDP5 |
m_ToolTip | CSelectDP5 | [protected]
OnBnClickedButtonCloseDevice() | CSelectDP5 |
OnBnClickedButtonCountDevices() | CSelectDP5 |
OnBnClickedButtonFindUsbDevice() | CSelectDP5 |
OnBnClickedButtonSpectrumRefreshDefault() | CSelectDP5 |
OnBnClickedConnectOK() | CSelectDP5 |
OnBnClickedOk() | CSelectDP5 |
OnBnClickedRadioCommtype2() | CSelectDP5 |
OnDeltaposSpinSelectDevice(NMHDR *pNMHDR, LRESULT *pResult) | CSelectDP5 |
OnEnChangeSpectrumRefreshTime() | CSelectDP5 |
OnHelpInfo(HELPINFO *pHelpInfo) | CSelectDP5 |
OnInitDialog() | CSelectDP5 | [virtual]
OnOK() | CSelectDP5 | [virtual]
OnTimer(UINT nIDEvent) | CSelectDP5 |
ReqDataStatus() | CSelectDP5 |
SetDataRcvTimer(long Bytes) | CSelectDP5 |
SetModified(BOOL bChanged) | CSelectDP5 |
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CSendCommand Member List
This is the complete list of members for CSendCommand, including all inherited members.
AsciiCmdUtil | CSendCommand
CSendCommand(void) | CSendCommand
DP5_CMD(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd) | CSendCommand
DP5_CMD_Config(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions) | CSendCommand
DP5_CMD_Data(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[]) | CSendCommand
POUT_Buffer(Packet_Out POUT, unsigned char Buffer[]) | CSendCommand
TestPacketCkSumOK(unsigned char Data[]) | CSendCommand
~CSendCommand(void) | CSendCommand
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CTuneSlowThreshold Member List
This is the complete list of members for CTuneSlowThreshold, including all inherited members.
CTuneSlowThreshold(void) | CTuneSlowThreshold
DelayTask(DWORD d) | CTuneSlowThreshold
DisplaySpecBuf25(double *SpectrumBuffer) | CTuneSlowThreshold
GetSlowThreshCalStart(double *SpectrumBuffer, double UpperChMax, int mcaCH) | CTuneSlowThreshold
GetSlowThreshChStrFromVal(UCHAR byteSlowThres, int mcaCH) | CTuneSlowThreshold
GetSpectrumData(double *dblMCAData, long *lngMCAData, int mcaCH) | CTuneSlowThreshold
GetUpperChCounts(double *SpectrumBuffer, int mcaCH) | CTuneSlowThreshold
GetUpperChMax(double *SpectrumBuffer, int mcaCH) | CTuneSlowThreshold
SetSlowThreshToChPos(int ChPosIn, int mcaCH) | CTuneSlowThreshold
UpdatePlotCursorPosFromIntChPos(int CurCh, double dblPixPerChan) | CTuneSlowThreshold
~CTuneSlowThreshold(void) | CTuneSlowThreshold
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CWinusbNotify Member List
This is the complete list of members for CWinusbNotify, including all inherited members.
CWinusbNotify(void) | CWinusbNotify
DeviceNotificationHandle | CWinusbNotify
GetDevNotifyInfo(DWORD_PTR dwData, char devicePath[]) | CWinusbNotify
InitDeviceInfo() | CWinusbNotify
m_hWndOwner | CWinusbNotify
RegDeviceNotification() | CWinusbNotify
RemoveDeviceNotification() | CWinusbNotify
SetNotificationWindow(HWND m_hWnd) | CWinusbNotify
UnregDeviceNotification(HDEVNOTIFY Handle) | CWinusbNotify
~CWinusbNotify(void) | CWinusbNotify
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CvcDP5App Member List
This is the complete list of members for CvcDP5App, including all inherited members.
CvcDP5App() | CvcDP5App |
InitInstance() | CvcDP5App | [virtual]
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
CvcDP5Dlg Member List
This is the complete list of members for CvcDP5Dlg, including all inherited members.
AcqMode | CvcDP5Dlg |
AppendCmdDesc(string strCmd, string strCfgData) | CvcDP5Dlg |
b80MHzMode | CvcDP5Dlg |
BOOL_TO_bool(BOOL bValue) | CvcDP5Dlg |
bSpectraTestRunning | CvcDP5Dlg |
ButtonSendStringCfgToHardware(CString strCfgIn) | CvcDP5Dlg |
CallReadDppConfig(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
CallReadScaConfig(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
CfgReadBack | CvcDP5Dlg |
CopyDp5CfgToClip(string strCfg, string strDesc) | CvcDP5Dlg |
CopyTextToClip(CString strTextIn) | CvcDP5Dlg |
CreateDTS(string strFormat) | CvcDP5Dlg |
CreateMCAData(long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst) | CvcDP5Dlg |
CreateSpectrumConfig(string strRawCfgIn) | CvcDP5Dlg |
CreateTextBlockTest() | CvcDP5Dlg |
CurrentChannel | CvcDP5Dlg |
CursorPosition | CvcDP5Dlg |
CvcDP5Dlg(CWnd *pParent=NULL) | CvcDP5Dlg |
DataTest() | CvcDP5Dlg |
DeviceType | CvcDP5Dlg |
DisplayCfg | CvcDP5Dlg |
DisplayError(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
DisplaySca | CvcDP5Dlg |
DoDataExchange(CDataExchange *pDX) | CvcDP5Dlg | [protected, virtual]
Dp5CmdList | CvcDP5Dlg |
DP5Stat | CvcDP5Dlg |
DppSendConfigToHw(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
EnableDPPFunctions(BOOL isEnabled) | CvcDP5Dlg |
ExtractNote(CString &rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep) | CvcDP5Dlg |
FastChThreshold | CvcDP5Dlg |
GetCmdData(string strCmd, string strCfgData) | CvcDP5Dlg |
GetCmdDesc(string strCmd) | CvcDP5Dlg |
GetDeviceNameFromVal(int DeviceTypeVal) | CvcDP5Dlg |
GetPixPerChannel() | CvcDP5Dlg |
HavePlot | CvcDP5Dlg |
HaveTrace | CvcDP5Dlg |
HwCfgDP5 | CvcDP5Dlg |
HwCfgDP5Out | CvcDP5Dlg |
HwCfgExReady | CvcDP5Dlg |
HwCfgReady | CvcDP5Dlg |
hWnd_Main | CvcDP5Dlg |
IDD enum value | CvcDP5Dlg |
idxCurrentSpectrum | CvcDP5Dlg |
idxTotalSpectra | CvcDP5Dlg |
isConnectedTest() | CvcDP5Dlg |
isDeltaMode | CvcDP5Dlg |
isDppConnected | CvcDP5Dlg |
lblMiscStatus | CvcDP5Dlg |
lblSelectCommunications | CvcDP5Dlg |
lblStatus | CvcDP5Dlg |
m_hIcon | CvcDP5Dlg | [protected]
m_nTmrRS232Elapse | CvcDP5Dlg |
m_nTmrRS232EventId | CvcDP5Dlg |
m_nTmrRS232Id | CvcDP5Dlg |
m_nTmrSpectrumElapse | CvcDP5Dlg |
m_nTmrSpectrumEventId | CvcDP5Dlg |
m_nTmrSpectrumId | CvcDP5Dlg |
m_nTmrTimeoutElapse | CvcDP5Dlg |
m_nTmrTimeoutEventId | CvcDP5Dlg |
m_nTmrTimeoutId | CvcDP5Dlg |
m_PicturePlot | CvcDP5Dlg |
m_PictureScope | CvcDP5Dlg |
MakeDp5CmdList() | CvcDP5Dlg |
mcaCH | CvcDP5Dlg |
OnBnClickedBtnSaveFile() | CvcDP5Dlg |
OnBnClickedButtonArmTrigger() | CvcDP5Dlg |
OnBnClickedButtonAutotune() | CvcDP5Dlg |
OnBnClickedButtonClearDataAndGraph() | CvcDP5Dlg |
OnBnClickedButtonClearMiscData() | CvcDP5Dlg |
OnBnClickedButtonDiag() | CvcDP5Dlg |
OnBnClickedButtonFindDevice() | CvcDP5Dlg |
OnBnClickedButtonGetSpectrum() | CvcDP5Dlg |
OnBnClickedButtonReadMiscData() | CvcDP5Dlg |
OnBnClickedButtonSaveFile() | CvcDP5Dlg |
OnBnClickedButtonSelectComm() | CvcDP5Dlg |
OnBnClickedButtonShowConfig() | CvcDP5Dlg |
OnBnClickedButtonSingleUpdate() | CvcDP5Dlg |
OnBnClickedButtonStartAcquisition() | CvcDP5Dlg |
OnBnClickedButtonStopAcquisition() | CvcDP5Dlg |
OnBnClickedButtonWriteMiscData() | CvcDP5Dlg |
OnBnClickedButtonWriteTextBlock() | CvcDP5Dlg |
OnBnClickedCancel() | CvcDP5Dlg |
OnBnClickedCheckRepeatSpectrum() | CvcDP5Dlg |
OnBnClickedOk() | CvcDP5Dlg |
OnBnClickedRadioPlotScaleLinear() | CvcDP5Dlg |
OnBnClickedRadioPlotScaleLog() | CvcDP5Dlg |
OnBnClickedRadioPlotTypeLine() | CvcDP5Dlg |
OnBnClickedRadioPlotTypeSolid() | CvcDP5Dlg |
OnDestroy() | CvcDP5Dlg |
OnDeviceChange(UINT nEventType, DWORD_PTR dwData) | CvcDP5Dlg |
OnInitDialog() | CvcDP5Dlg | [protected, virtual]
OnLButtonDown(UINT nFlags, CPoint point) | CvcDP5Dlg |
OnPaint() | CvcDP5Dlg | [protected]
OnQueryDragIcon() | CvcDP5Dlg | [protected]
OnReceive(UINT, LONG) | CvcDP5Dlg |
OnResetCommunications() | CvcDP5Dlg |
OnStnClickedPlotpicturecontrol() | CvcDP5Dlg |
OnSysCommand(UINT nID, LPARAM lParam) | CvcDP5Dlg | [protected]
OnTimer(UINT nIDEvent) | CvcDP5Dlg |
OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult) | CvcDP5Dlg |
ParsePacketEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ParsePerformanceNotes(CString str) | CvcDP5Dlg |
ParsePkt | CvcDP5Dlg |
ParseTextBlockNotes(CString strTextBlock) | CvcDP5Dlg |
PlotBuffer | CvcDP5Dlg |
PlotData(long DataBuffer[8192], int NumChan) | CvcDP5Dlg |
PresetAcq | CvcDP5Dlg |
PresetCount | CvcDP5Dlg |
PresetRt | CvcDP5Dlg |
PreTranslateMessage(MSG *pMsg) | CvcDP5Dlg | [virtual]
PrintCfg | CvcDP5Dlg |
ProcessAck(BYTE PID2) | CvcDP5Dlg |
ProcessCfgReadEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessDiagDataEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessScopeDataEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessSpectrumEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessStatusEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessTextDataEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
RemCallParsePacket(BYTE PacketIn[]) | CvcDP5Dlg |
ReplaceCmdDesc(string strCmd, string strCfgData) | CvcDP5Dlg |
RequestScopeData(BOOL ScopeDataReady) | CvcDP5Dlg |
RiseUS | CvcDP5Dlg |
SaveCfg | CvcDP5Dlg |
SaveMCAFile(string strFilename, string strMCA) | CvcDP5Dlg |
SaveTestSpectrumFile(int iFileIndex) | CvcDP5Dlg |
ScaReadBack | CvcDP5Dlg |
ScopeBuffer | CvcDP5Dlg |
ScopeDisplay(BYTE ScopeData[2048]) | CvcDP5Dlg |
SendCommand(TRANSMIT_PACKET_TYPE XmtCmd) | CvcDP5Dlg |
SendCommandConfig(TRANSMIT_PACKET_TYPE XmtCmd) | CvcDP5Dlg |
SendCommandData(TRANSMIT_PACKET_TYPE XmtCmd, BYTE DataOut[]) | CvcDP5Dlg |
SendConfigFromFileToDpp() | CvcDP5Dlg |
SendDppInfoTextBlock(CString strLowerTextBlock, CString strInfoTextBlock) | CvcDP5Dlg |
SendManufacturingTextBlock(CString generalNotes) | CvcDP5Dlg |
SetCheckButtonState(int iCheckBox, bool bChecked) | CvcDP5Dlg |
SetPlotChannel() | CvcDP5Dlg |
SetStartTime() | CvcDP5Dlg |
ShowRepeatStatus(bool bShowStatus) | CvcDP5Dlg |
ShowStatus(string strStatus) | CvcDP5Dlg |
SlowChThreshold | CvcDP5Dlg |
SlowThresholdPct | CvcDP5Dlg |
strAnalogOut | CvcDP5Dlg |
strGainDisplayValue | CvcDP5Dlg |
strInputOffset | CvcDP5Dlg |
strLowerMiscData | CvcDP5Dlg |
strMcaMode | CvcDP5Dlg |
strOutputOffset | CvcDP5Dlg |
strPresetCmd | CvcDP5Dlg |
strPresetVal | CvcDP5Dlg |
strScopeGain | CvcDP5Dlg |
strTriggerPosition | CvcDP5Dlg |
strTriggerSlope | CvcDP5Dlg |
strTriggerSource | CvcDP5Dlg |
strUpperMiscData | CvcDP5Dlg |
szSettings | CvcDP5Dlg |
TextToBlockString(CString &str, char *prefix) | CvcDP5Dlg |
TimeoutFlag | CvcDP5Dlg |
TuneFastSlowThresh() | CvcDP5Dlg |
UpdatePlot() | CvcDP5Dlg |
UpdateScope() | CvcDP5Dlg |
UpdateScopeCfg | CvcDP5Dlg |
WriteTextBlock() | CvcDP5Dlg |
XPlotMAX | CvcDP5Dlg |
YPlotMAX | CvcDP5Dlg |
~CvcDP5Dlg() | CvcDP5Dlg |
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
cAnimWnd Member List
This is the complete list of members for cAnimWnd, including all inherited members.
cAnimWnd() | cAnimWnd |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | cAnimWnd | [virtual]
GetImageCount() | cAnimWnd |
m_Bitmap | cAnimWnd | [protected]
m_Height | cAnimWnd | [protected]
m_ImageIndex | cAnimWnd | [protected]
m_MemDC | cAnimWnd | [protected]
m_TransparentColor | cAnimWnd | [protected]
m_Width | cAnimWnd | [protected]
OnPaint() | cAnimWnd | [protected]
OnTimer(UINT nIDEvent) | cAnimWnd | [protected]
SetImageList(UINT BitmapID, short Size, short Sizey, COLORREF TransparentColor=-1) | cAnimWnd |
StartAnim(short Delay=50) | cAnimWnd |
StopAnim() | cAnimWnd |
~cAnimWnd() | cAnimWnd | [virtual]
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
cMemDC Member List
This is the complete list of members for cMemDC, including all inherited members.
cMemDC(CDC *pDC, const CRect &rcBounds, long BackColor=RGB(255, 255, 255)) | cMemDC | [inline]
operator->() | cMemDC | [inline]
~cMemDC() | cMemDC | [inline]
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
cWaitDialog Member List
This is the complete list of members for cWaitDialog, including all inherited members.
Close() | cWaitDialog |
m_bShowCancelButton | cWaitDialog |
m_Event | cWaitDialog |
m_EventName | cWaitDialog |
m_Text | cWaitDialog |
m_Thread | cWaitDialog |
Show() | cWaitDialog |
~cWaitDialog() | cWaitDialog | [virtual]
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
cWaitDlg Member List
This is the complete list of members for cWaitDlg, including all inherited members.
cWaitDlg(CWnd *pParent=NULL) | cWaitDlg |
DoDataExchange(CDataExchange *pDX) | cWaitDlg | [protected, virtual]
IDD enum value | cWaitDlg |
m_Anim | cWaitDlg |
m_bShowCancelButton | cWaitDlg |
m_Text | cWaitDlg |
m_Thread | cWaitDlg |
OnCancel() | cWaitDlg | [protected, virtual]
OnInitDialog() | cWaitDlg | [protected, virtual]
OnOK() | cWaitDlg | [protected, virtual]
OnTimer(UINT nIDEvent) | cWaitDlg | [protected]
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
cWaitDlgThread Member List
This is the complete list of members for cWaitDlgThread, including all inherited members.
cWaitDlgThread() | cWaitDlgThread |
ExitInstance() | cWaitDlgThread | [virtual]
InitInstance() | cWaitDlgThread | [virtual]
m_bShowCancelButton | cWaitDlgThread |
m_Event | cWaitDlgThread |
m_Eventname | cWaitDlgThread |
m_Text | cWaitDlgThread |
~cWaitDlgThread() | cWaitDlgThread | [virtual]
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
C | D | N | P | S | W | _
C
CINI CSProfile
P
_COORD_LONG
CIniEx CTuneSlowThreshold _DiagDataType
CAboutDlg CIniUtil CvcDP5App Packet_Out _DppStateType
cAnimWnd CLabel CvcDP5Dlg
S
_Packet_In
CAsciiCmdUtilities cMemDC cWaitDialog _SpectrumFileType
CDP5Protocol CMSecTimer cWaitDlg Spec _WINUSB_PIPE_INFORMATION
CDP5Status CMsgBox cWaitDlgThread stringex _WINUSB_SETUP_PACKET
CDppLibUsb CNetFinder CWinusbNotify
W
CDppSlowThreshold CParsePacket
D
CDppUtilities CPlotCanvas WINUSB_DEVICE_INFO
CDppWinUSB CSelectDP5 DP5_DP4_FORMAT_STATUS
_
CFileBrowse CSendCommand
N
_CONFIG_OPTIONS
NETDISPLAY_ENTRY
C | D | N | P | S | W | _
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
stringex Member List
This is the complete list of members for stringex, including all inherited members.
Format(const char *fmt,...) | stringex
MakeLower(string StdString) | stringex
MakeUpper(string StdString) | stringex
stringex(void) | stringex
~stringex(void) | stringex
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: File List

File List
Here is a list of all files with brief descriptions:
MsgBox.cpp [code]
MsgBox.h [code]
resource.h [code]
SProfile.cpp [code]
SProfile.h [code]
StdAfx.cpp [code]
StdAfx.h [code]
stringex.cpp [code]
stringex.h [code]
stringSplit.h [code]
STypes.cpp [code]
STypes.h [code]
UserMsgs.h [code]
vcDP5.cpp [code]
vcDP5.h [code]
vcDP5_Shared_HIDD.h [code]
vcDP5_Shared_IDD.h [code]
vcDP5Dlg.cpp [code]
vcDP5Dlg.h [code]
CIni/INI.cpp [code]
CIni/INI.h [code]
CIni/IniEx.cpp [code]
CIni/IniEx.h [code]
CIni/IniUtil.cpp [code]
CIni/IniUtil.h [code]
Config/DppSlowThreshold.cpp [code]
Config/DppSlowThreshold.h [code]
Config/TuneSlowThreshold.cpp [code]
Config/TuneSlowThreshold.h [code]
Controls/Label.cpp [code]
Controls/Label.h [code]
Controls/PlotCanvas.cpp [code]
Controls/PlotCanvas.h [code]
Controls/X11Color.h [code]
DeviceIO/AsciiCmdUtilities.cpp [code]
DeviceIO/AsciiCmdUtilities.h [code]
DeviceIO/DP5Protocol.cpp [code]
DeviceIO/DP5Protocol.h [code]
DeviceIO/DP5Status.cpp [code]
DeviceIO/DP5Status.h [code]
DeviceIO/DppConst.h [code]
DeviceIO/DppLibUsb.cpp [code]
DeviceIO/DppLibUsb.h [code]
DeviceIO/DppUtilities.cpp [code]
DeviceIO/DppUtilities.h [code]
DeviceIO/DppWinUSB.cpp [code]
DeviceIO/DppWinUSB.h [code]
DeviceIO/guid.h [code]
DeviceIO/MSecTimer.cpp [code]
DeviceIO/MSecTimer.h [code]
DeviceIO/NetFinder.cpp [code]
DeviceIO/NetFinder.h [code]
DeviceIO/ParsePacket.cpp [code]
DeviceIO/ParsePacket.h [code]
DeviceIO/SelectDP5.cpp [code]
DeviceIO/SelectDP5.h [code]
DeviceIO/SelectDP5Res.h [code]
DeviceIO/SendCommand.cpp [code]
DeviceIO/SendCommand.h [code]
DeviceIO/WINUSB.H [code]
DeviceIO/WINUSBIO.H [code]
DeviceIO/WinusbNotify.cpp [code]
DeviceIO/WinusbNotify.h [code]
DP5Cfg/FileBrowse.cpp [code]
DP5Cfg/FileBrowse.h [code]
hlp/HTMLDefines.h [code]
waitdlg/AnimWnd.cpp [code]
waitdlg/AnimWnd.h [code]
waitdlg/CmdWaitDlg.cpp [code]
waitdlg/CmdWaitDlg.h [code]
waitdlg/memdc.h [code]
waitdlg/WaitDlg.cpp [code]
waitdlg/WaitDlg.h [code]
waitdlg/WaitDlgThread.cpp [code]
waitdlg/WaitDlgThread.h [code]
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: DeviceIO/guid.h Source File

DeviceIO/guid.h
Go to the documentation of this file.
00001 //
00002 // $History: guid.h $
00003 //
00004 //Amptek DP5 WinUSB    Date: 03/08/2011    Time: 02:49:49 PM
00005
00006 #ifndef GUID_INC
00007 #define GUID_INC
00008
00009 #pragma once
00010
00011 #ifndef DEFINE_GUID
00012 #include <objbase.h>
00013 #endif
00014
00015 #include <initguid.h>
00016
00018 DEFINE_GUID(GUID_DP5_INTERFACE_CLASS, 0x5a8ed6a1, 0x7fc3, 0x4b6a, 0xa5, 0x36, 0x95, 0xdf, 0x35, 0xd0, 0x34, 0x48);
00019
00021 DEFINE_GUID(GUID_DP5_SETUP_CLASS, 0x6a4e9a2d, 0x9368, 0x4f01, 0x8e, 0x60, 0xb3, 0xf9, 0xcd, 0xba, 0xb5, 0xe8);
00022
00023
00024 #endif // end, #ifndef GUID_INC
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: waitdlg/memdc.h Source File

waitdlg/memdc.h
Go to the documentation of this file.
00001 #ifndef _MEMDC_H_
00002 #define _MEMDC_H_
00003
00005 // Author: Keith Rule
00006 // Email:  keithr@europa.com
00007 // Copyright 1996-1997, Keith Rule
00008 //
00009 // You may freely use or modify this code provided this
00010 // Copyright is included in all derived versions
00011 //
00012 // History - 10/3/97 Fixed scrolling bug.
00013 //                   Added print support.//
00014 // This class implements a memory Device Context
00015
00016 // History - 3/1/99 Modified from Keith Rule's CMemDC.
00017 //
00018 // This class implements a memory Device Context
00019
00020 class cMemDC : public CDC
00021 {
00022 private:
00023         CBitmap*        m_bitmap;
00024         CBitmap*        m_oldBitmap;
00025         CDC*            m_pDC;
00026         CRect           m_rcBounds;
00027 public:
00028         cMemDC(CDC* pDC, const CRect& rcBounds, long BackColor = RGB(255,255,255)) :
00029       CDC(), m_oldBitmap(NULL), m_pDC(pDC), m_rcBounds(rcBounds)
00030            {
00031                 CreateCompatibleDC(pDC);
00032                 m_bitmap = new CBitmap;
00033                 m_bitmap->CreateCompatibleBitmap(pDC, rcBounds.Width(), rcBounds.Height());
00034                 CBrush *pBack = new CBrush(BackColor);
00035       FillRect(m_rcBounds, pBack);
00036       delete pBack;
00037       m_oldBitmap = SelectObject(m_bitmap);
00038                 //m_pDC = pDC;
00039                 //m_rcBounds = rcBounds;
00040            }
00041
00042         ~cMemDC()
00043            {
00044                 SelectObject(m_oldBitmap);
00045                 if (m_bitmap != NULL) delete m_bitmap;
00046            }
00047
00048    cMemDC* operator->() {return this;}
00049 };
00050
00051 #endif
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
stringSplit
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: readme.txt File Reference

readme.txt File Reference
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: resource.h Source File

resource.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by vcDP5.rc
00004 //
00005 #define IDM_ABOUTBOX                    16
00006 #define IDD_ABOUTBOX                    100
00007 #define IDS_ABOUTBOX                    101
00008 #define IDC_BUSY_PIC                    1029
00009 #define IDC_BUSY_TEXT                   1030
00010 #define IDC_MESSAGE1                    1105
00011 #define IDC_MESSAGE2                    1106
00012 #define IDC_BUTTON_ADD_ROI              2304
00013 #define IDC_BUTTON_ARM_TRIGGER          2305
00014 #define IDC_BUTTON_CLEAR_DATA_AND_GRAPH 2306
00015 #define IDC_BUTTON_CLEAR_MISC_DATA      2307
00016 #define IDC_BUTTON_CLEAR_ROI            2308
00017 #define IDC_BUTTON_DIAG                 2309
00018 #define IDC_BUTTON_EDIT_CONFIG          2310
00019 #define IDC_BUTTON_FIND_DEVICE          2311
00020 #define IDC_BUTTON_READ_MISC_DATA       2312
00021 #define IDC_BUTTON_ROI_END              2313
00022 #define IDC_BUTTON_ROI_START            2314
00023 #define IDC_BUTTON_SAVE_FILE            2315
00024 #define IDC_BUTTON_SELECT_COMM          2316
00025 #define IDC_BUTTON_SHOW_CONFIG          2317
00026 #define IDC_BUTTON_SINGLE_UPDATE        2318
00027 #define IDC_BUTTON_START_ACQUISITION    2319
00028 #define IDC_BUTTON_STOP_ACQUISITION     2320
00029 #define IDC_BUTTON_WRITE_MISC_DATA      2321
00030 #define IDC_CHECK_AUTO_REARM            2322
00031 #define IDC_CHECK_DELTA                 2323
00032 #define IDC_EDIT_DESCRIPTION            2324
00033 #define IDC_EDIT_DIAG                   2325
00034 #define IDC_EDIT_MISC_DATA              2326
00035 #define IDC_EDIT_START_TIME             2327
00036 #define IDC_EDIT_STATUS                 2328
00037 #define IDC_CHECK_REPEAT_SPECTRUM       2328
00038 #define IDC_EDIT_TAG                    2329
00039 #define IDC_GROUP_PLOT_SCALE            2330
00040 #define IDC_PICTURE_PLOT                2331
00041 #define IDC_PICTURE_SCOPE               2332
00042 #define IDC_PLOTTYPEGROUP               2333
00043 #define IDC_RADIO_PLOT_SCALE_LINEAR     2334
00044 #define IDC_RADIO_PLOT_SCALE_LOG        2335
00045 #define IDC_RADIO_PLOT_TYPE_SOLID       2336
00046 #define IDC_RADIO_PLOT_TYPE_LINE        2337
00047 #define IDC_STATIC_                     2338
00048 #define IDC_STATIC_MISC_STATUS          2339
00049 #define IDC_STATIC_ROI_COUNT            2340
00050 #define IDC_STATIC_ROI_END              2341
00051 #define IDC_STATIC_ROI_INDEX            2342
00052 #define IDC_STATIC_ROI_START            2343
00053 #define IDC_STATIC_SELECT_COMMUNICATIONS 2344
00054 #define IDC_STATIC_SPECTRUM_STATUS      2345
00055 #define IDC_STATIC_STATUS               2346
00056 #define IDC_BUTTON_AUTOTUNE             2347
00057 #define IDC_STATIC_START_TIME           2348
00058 #define IDC_EDIT_PRESET_CMD             2349
00059 #define IDC_EDIT_REPEAT_LOOPS           2350
00060 #define IDC_STATIC_PRESET_CMD           2351
00061 #define IDC_STATIC_LOOPS                2352
00062 #define IDC_STATIC_REPEAT_STATUS        2353
00063 #define IDB_BITMAP_DP5_DLG              4105
00064 #define IDB_SPECTRUM_ANIM               4144
00065 #define IDD_BUSY_DLG                    4150
00066 #define IDD_MESSAGE_BOX                 4159
00067 #define IDP_SOCKETS_INIT_FAILED         4186
00068 #define IDR_MAINFRAME                   4188
00069 #define IDR_MENU                        4189
00070 #define IDR_TOOLBAR                     4196
00071 #define IDR_TOOLBAR_DP5_DLG             4197
00072 #define IDS_BTNSTRING_MODAL             4198
00073 #define IDS_BTNSTRING_MODELESS          4199
00074 #define IDS_CAPTION                     4200
00075 #define IDD_vcDP5_DIALOG                7168
00076 #define ID_FILE_TAB                     33064
00077 #define ID_GAINPZ_TAB                   33073
00078 #define ID_MCA_TAB                      33092
00079 #define ID_MISC_TAB                     33095
00080 #define ID_POWER_TAB                    33102
00081 #define ID_SHAPING_TAB                  33120
00082 #define ID_HELP_ABOUT                   40003
00083
00084 // Next default values for new objects
00085 //
00086 #ifdef APSTUDIO_INVOKED
00087 #ifndef APSTUDIO_READONLY_SYMBOLS
00088 #define _APS_NEXT_RESOURCE_VALUE        7171
00089 #define _APS_NEXT_COMMAND_VALUE         33456
00090 #define _APS_NEXT_CONTROL_VALUE         2354
00091 #define _APS_NEXT_SYMED_VALUE           7171
00092 #endif
00093 #endif
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringSplit.h File Reference

Namespaces | Typedefs | Functions
stringSplit.h File Reference
#include <string>
#include <vector>
Include dependency graph for stringSplit.h:

Go to the source code of this file.

Namespaces

namespace | stringSplit

Typedefs

typedef string::size_type(string::* | stringSplit::FindToken )(const string &strDelimiter, string::size_type sztOffset) const

Functions

vector< string > | stringSplit::Split (const string &strIn, const string &strDelimiters, bool bRemoveEmpty=false, bool bMatchAll=false)
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringSplit.h Source File

stringSplit.h
Go to the documentation of this file.
00001 #include <string>
00002 #include <vector>
00003
00004 namespace stringSplit
00005 {
00006     using namespace std;
00007     typedef string::size_type (string::*FindToken)(const string& strDelimiter, string::size_type sztOffset) const;
00008     // Split a string using a delimiter string or string character set, returns split string as a vector<string>
00009         // strIn - string being split
00010         // strDelimiters - delimiter string or character list in a string for splitting strIn
00011         // bRemoveEmpty - remove empty strings from list
00012         // bMatchAll - true=use delimiter string, false=use string as character set matching any chars in set
00013     vector<string> Split(const string& strIn, const string& strDelimiters, bool bRemoveEmpty=false, bool bMatchAll=false)
00014     {
00015         vector<string> VecStrTokens;                                            // return container for strTokens
00016         string::size_type SearchStart = 0;                                      // starting position for searches
00017         string::size_type SkipPosition = 1;                                     // positions to SkipPosition after a strDelimiters
00018         FindToken FindPosition = &string::find_first_of;        // search algorithm for matches
00019         if (bMatchAll)
00020         {
00021             SkipPosition = strDelimiters.length();
00022             FindPosition = &string::find;
00023         }
00024         while (SearchStart != string::npos)
00025         {
00026             string::size_type SearchEnd = (strIn.*FindPosition)(strDelimiters, SearchStart);    // get a complete range [SearchStart..SearchEnd)
00027             if (SkipPosition == 0) SearchEnd = string::npos;    // no match ret whole string if skip is null
00028             string strToken = strIn.substr(SearchStart, SearchEnd - SearchStart);
00029             if (!(bRemoveEmpty && strToken.empty()))
00030             {
00031                 VecStrTokens.push_back(strToken);                                 // extract the strToken and add it to the VecStrTokens list
00032             }
00033             if ((SearchStart = SearchEnd) != string::npos) SearchStart += SkipPosition; // SearchStart the next range
00034         }
00035         return VecStrTokens;
00036     }
00037 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringex.cpp Source File

stringex.cpp
Go to the documentation of this file.
00001 #include "stringex.h"
00002
00003 #ifdef _MSC_VER
00004         #pragma warning(disable:4996)
00005         #define vsnprintf _vsnprintf
00006 #endif
00007
00008 stringex::stringex(void)
00009 {
00010 }
00011
00012 stringex::~stringex(void)
00013 {
00014 }
00015
00016 std::string stringex::vformat (const char *fmt, va_list ap)
00017 {
00018     size_t size = 1024;
00019     char stackbuf[1024];
00020     std::vector<char> dynamicbuf;
00021     char *buf = &stackbuf[0];
00022     while (1) {
00023         int needed = vsnprintf (buf, size, fmt, ap);
00024         if (needed <= (int)size && needed >= 0) {
00025             return std::string (buf, (size_t) needed);
00026         }
00027         size = (needed > 0) ? (needed+1) : (size*2);
00028         dynamicbuf.resize (size);
00029         buf = &dynamicbuf[0];
00030     }
00031 }
00032
00033 std::string stringex::Format (const char *fmt, ...)
00034 {
00035     va_list ap;
00036     va_start (ap, fmt);
00037     std::string buf = vformat (fmt, ap);
00038     va_end (ap);
00039     return buf;
00040 }
00041
00042 std::string stringex::MakeUpper(string StdString)
00043 {
00044   const int length = (int)StdString.length();
00045   for(int i=0; i<length ; ++i)
00046   {
00047           StdString[i] = std::toupper(StdString[i]);
00048   }
00049   return StdString;
00050 }
00051
00052 std::string stringex::MakeLower(string StdString)
00053 {
00054   const int length = (int)StdString.length();
00055   for(int i=0; i<length ; ++i)
00056   {
00057           StdString[i] = std::tolower(StdString[i]);
00058   }
00059   return StdString;
00060 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: stringex.h Source File

stringex.h
Go to the documentation of this file.
00001 #pragma once
00002 #ifndef STRINGEX_H
00003 #define STRINGEX_H
00004 #ifdef _MSC_VER
00005         #pragma warning(disable:4996)  // uses _vsnprintf, disable warning, can use _CRT_SECURE_NO_WARNINGS
00006 //      #define _CRT_SECURE_NO_WARNINGS
00007 #endif
00008 #include <stdio.h>
00009 #include <stdarg.h>
00010 #include <cstdarg>
00011 #include <vector>
00012 #include <string>
00013 #include <cctype> // std::toupper, std::tolower
00014 using namespace std;
00015
00016 class stringex
00017 {
00018 public:
00019         stringex(void);
00020         ~stringex(void);
00021         std::string Format (const char *fmt, ...);
00022         std::string MakeUpper(string StdString);
00023         std::string MakeLower(string StdString);
00024
00025 private:
00026         std::string vformat (const char *fmt, va_list ap);
00027
00028 };
00029
00030 #endif
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_CONFIG_OPTIONS Member List
This is the complete list of members for _CONFIG_OPTIONS, including all inherited members.
DPP_ECO | _CONFIG_OPTIONS
DppType | _CONFIG_OPTIONS
HwCfgDP5Out | _CONFIG_OPTIONS
isDP5_RevDxGains | _CONFIG_OPTIONS
PC5_PRESENT | _CONFIG_OPTIONS
SendCoarseFineGain | _CONFIG_OPTIONS
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_COORD_LONG Member List
This is the complete list of members for _COORD_LONG, including all inherited members.
X | _COORD_LONG
Y | _COORD_LONG
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_DiagDataType Member List
This is the complete list of members for _DiagDataType, including all inherited members.
ADC_V | _DiagDataType
DiagData | _DiagDataType
Firmware | _DiagDataType
FPGA | _DiagDataType
HVOn | _DiagDataType
Is8_5VPreAmp | _DiagDataType
IsPosHV | _DiagDataType
PC5_PRESENT | _DiagDataType
PC5_SN | _DiagDataType
PC5_V | _DiagDataType
PC5DCAL | _DiagDataType
PC5Initialized | _DiagDataType
PreAmpON | _DiagDataType
SRAMTestData | _DiagDataType
SRAMTestPass | _DiagDataType
strTempCal | _DiagDataType
strTempRaw | _DiagDataType
Sup9VOn | _DiagDataType
TECOn | _DiagDataType
TempOffset | _DiagDataType
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_DppStateType Member List
This is the complete list of members for _DppStateType, including all inherited members.
HaveScopeData | _DppStateType
Interface | _DppStateType
ReqProcess | _DppStateType
ScopeAutoRearm | _DppStateType
ScopeOverFlow | _DppStateType
strPort | _DppStateType
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_Packet_In Member List
This is the complete list of members for _Packet_In, including all inherited members.
CheckSum | _Packet_In
DATA | _Packet_In
LEN | _Packet_In
PID1 | _Packet_In
PID2 | _Packet_In
STATUS | _Packet_In
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_SpectrumFileType Member List
This is the complete list of members for _SpectrumFileType, including all inherited members.
m_iNumChan | _SpectrumFileType
SerialNumber | _SpectrumFileType
strDescription | _SpectrumFileType
strSpectrumConfig | _SpectrumFileType
strSpectrumStatus | _SpectrumFileType
strStartTime | _SpectrumFileType
strTag | _SpectrumFileType
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_WINUSB_PIPE_INFORMATION Member List
This is the complete list of members for _WINUSB_PIPE_INFORMATION, including all inherited members.
Interval | _WINUSB_PIPE_INFORMATION
MaximumPacketSize | _WINUSB_PIPE_INFORMATION
PipeId | _WINUSB_PIPE_INFORMATION
PipeType | _WINUSB_PIPE_INFORMATION
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
_WINUSB_SETUP_PACKET Member List
This is the complete list of members for _WINUSB_SETUP_PACKET, including all inherited members.
Index | _WINUSB_SETUP_PACKET
Length | _WINUSB_SETUP_PACKET
Request | _WINUSB_SETUP_PACKET
RequestType | _WINUSB_SETUP_PACKET
Value | _WINUSB_SETUP_PACKET
Generated on Fri Sep 22 2017 10:01:03 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
DP5_DP4_FORMAT_STATUS Member List
This is the complete list of members for DP5_DP4_FORMAT_STATUS, including all inherited members.
AccumulationTime | DP5_DP4_FORMAT_STATUS
ADC_GAIN_CAL | DP5_DP4_FORMAT_STATUS
ADC_OFFSET_CAL | DP5_DP4_FORMAT_STATUS
AFAST_LOCKED | DP5_DP4_FORMAT_STATUS
AN_IN | DP5_DP4_FORMAT_STATUS
AOFFSET_LOCKED | DP5_DP4_FORMAT_STATUS
AU34_2 | DP5_DP4_FORMAT_STATUS
b80MHzMode | DP5_DP4_FORMAT_STATUS
bFPGAAutoClock | DP5_DP4_FORMAT_STATUS
bScintHas80MHzOption | DP5_DP4_FORMAT_STATUS
Build | DP5_DP4_FORMAT_STATUS
DCAL | DP5_DP4_FORMAT_STATUS
DET_TEMP | DP5_DP4_FORMAT_STATUS
DEVICE_ID | DP5_DP4_FORMAT_STATUS
DP5_CONFIGURED | DP5_DP4_FORMAT_STATUS
DP5_TEMP | DP5_DP4_FORMAT_STATUS
DPP_ECO | DP5_DP4_FORMAT_STATUS
DPP_options | DP5_DP4_FORMAT_STATUS
FastCount | DP5_DP4_FORMAT_STATUS
Firmware | DP5_DP4_FORMAT_STATUS
FPGA | DP5_DP4_FORMAT_STATUS
GP_COUNTER | DP5_DP4_FORMAT_STATUS
HPGe_HV_INH | DP5_DP4_FORMAT_STATUS
HPGe_HV_INH_POL | DP5_DP4_FORMAT_STATUS
HV | DP5_DP4_FORMAT_STATUS
isAscEnabled | DP5_DP4_FORMAT_STATUS
isAscInstalled | DP5_DP4_FORMAT_STATUS
isDP5_RevDxGains | DP5_DP4_FORMAT_STATUS
LiveTime | DP5_DP4_FORMAT_STATUS
MCA_EN | DP5_DP4_FORMAT_STATUS
MCS_DONE | DP5_DP4_FORMAT_STATUS
PC5_8_5V | DP5_DP4_FORMAT_STATUS
PC5_HV_POL | DP5_DP4_FORMAT_STATUS
PC5_PRESENT | DP5_DP4_FORMAT_STATUS
PC5_SN | DP5_DP4_FORMAT_STATUS
PRECNT_REACHED | DP5_DP4_FORMAT_STATUS
PresetLtDone | DP5_DP4_FORMAT_STATUS
PresetRtDone | DP5_DP4_FORMAT_STATUS
PX4 | DP5_DP4_FORMAT_STATUS
PZCORR | DP5_DP4_FORMAT_STATUS
RAM_TEST_ERROR | DP5_DP4_FORMAT_STATUS
RAM_TEST_RUN | DP5_DP4_FORMAT_STATUS
RAW | DP5_DP4_FORMAT_STATUS
RealTime | DP5_DP4_FORMAT_STATUS
ReBootFlag | DP5_DP4_FORMAT_STATUS
SCOPE_DR | DP5_DP4_FORMAT_STATUS
SerialNumber | DP5_DP4_FORMAT_STATUS
SlowCount | DP5_DP4_FORMAT_STATUS
SPECTRUM_OFFSET | DP5_DP4_FORMAT_STATUS
SUPPLIES_ON | DP5_DP4_FORMAT_STATUS
TEC_Voltage | DP5_DP4_FORMAT_STATUS
UC_TEMP_OFFSET | DP5_DP4_FORMAT_STATUS
VREF_IN | DP5_DP4_FORMAT_STATUS
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
NETDISPLAY_ENTRY Member List
This is the complete list of members for NETDISPLAY_ENTRY, including all inherited members.
alert_level | NETDISPLAY_ENTRY
ccConnectRGB | NETDISPLAY_ENTRY
event1_days | NETDISPLAY_ENTRY
event1_hours | NETDISPLAY_ENTRY
event1_minutes | NETDISPLAY_ENTRY
event1_seconds | NETDISPLAY_ENTRY
event2_days | NETDISPLAY_ENTRY
event2_hours | NETDISPLAY_ENTRY
event2_minutes | NETDISPLAY_ENTRY
event2_seconds | NETDISPLAY_ENTRY
gateway | NETDISPLAY_ENTRY
HasData | NETDISPLAY_ENTRY
ip | NETDISPLAY_ENTRY
mac | NETDISPLAY_ENTRY
port | NETDISPLAY_ENTRY
SockAddr | NETDISPLAY_ENTRY
str_description | NETDISPLAY_ENTRY
str_display | NETDISPLAY_ENTRY
str_ev1 | NETDISPLAY_ENTRY
str_ev2 | NETDISPLAY_ENTRY
str_type | NETDISPLAY_ENTRY
subnet | NETDISPLAY_ENTRY
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
Packet_Out Member List
This is the complete list of members for Packet_Out, including all inherited members.
DATA | Packet_Out
EXPECTEDRESPONSE | Packet_Out
LEN | Packet_Out
PID1 | Packet_Out
PID2 | Packet_Out
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
Spec Member List
This is the complete list of members for Spec, including all inherited members.
CHANNELS | Spec
DATA | Spec
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Members
WINUSB_DEVICE_INFO Member List
This is the complete list of members for WINUSB_DEVICE_INFO, including all inherited members.
bulkInPipe | WINUSB_DEVICE_INFO
bulkOutPipe | WINUSB_DEVICE_INFO
deviceConnected | WINUSB_DEVICE_INFO
deviceHandle | WINUSB_DEVICE_INFO
devicePath | WINUSB_DEVICE_INFO
deviceSpeed | WINUSB_DEVICE_INFO
interruptPipe | WINUSB_DEVICE_INFO
winUSBHandle | WINUSB_DEVICE_INFO
Generated on Fri Sep 22 2017 10:01:06 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5.cpp Source File

vcDP5.cpp
Go to the documentation of this file.
00001 // vcDP5.cpp : Defines the class behaviors for the application.
00002 //
00003
00004 #include "stdafx.h"
00005 #include "vcDP5.h"
00006 #include "vcDP5Dlg.h"
00007 #include "DppWinUSB.h"
00008 #include "DP5Protocol.h"
00009 #include "WinusbNotify.h"
00010
00011 #ifdef _DEBUG
00012 #define new DEBUG_NEW
00013 #endif
00014
00015
00016 // CvcDP5App
00017
00018 BEGIN_MESSAGE_MAP(CvcDP5App, CWinApp)
00019         ON_COMMAND(ID_HELP, CWinApp::OnHelp)
00020 END_MESSAGE_MAP()
00021
00022
00023 // CvcDP5App construction
00024
00025 CvcDP5App::CvcDP5App()
00026 {
00027         EnableHtmlHelp();
00028
00029         // TODO: add construction code here,
00030         // Place all significant initialization in InitInstance
00031 }
00032
00033
00034 // The one and only CvcDP5App object
00035
00036 CvcDP5App theApp;
00037 CWinusbNotify WinusbNotify;
00038 CDppWinUSB DppWinUSB;           // WinUSB
00039 CSendCommand SndCmd;
00040 CDP5Protocol DP5Proto;
00041 CSProfile Profile;
00042
00043 // CvcDP5App initialization
00044
00045 BOOL CvcDP5App::InitInstance()
00046 {
00047         // InitCommonControls() is required on Windows XP if an application
00048         // manifest specifies use of ComCtl32.dll version 6 or later to enable
00049         // visual styles.  Otherwise, any window creation will fail.
00050         InitCommonControls();
00051
00052         CWinApp::InitInstance();
00053
00054         if (!AfxSocketInit())
00055         {
00056                 AfxMessageBox(IDP_SOCKETS_INIT_FAILED);
00057                 return FALSE;
00058         }
00059
00060         AfxEnableControlContainer();
00061
00062         // Standard initialization
00063         // If you are not using these features and wish to reduce the size
00064         // of your final executable, you should remove from the following
00065         // the specific initialization routines you do not need
00066         // Change the registry key under which our settings are stored
00067         // TODO: You should modify this string to be something appropriate
00068         // such as the name of your company or organization
00069         SetRegistryKey(_T("Amptek\\vcDP5"));
00070         Profile.LoadProfile();
00071
00072         CvcDP5Dlg dlg;
00073         m_pMainWnd = &dlg;
00074         INT_PTR nResponse = dlg.DoModal();
00075         if (nResponse == IDOK)
00076         {
00077                 // TODO: Place code here to handle when the dialog is
00078                 //  dismissed with OK
00079         }
00080         else if (nResponse == IDCANCEL)
00081         {
00082                 // TODO: Place code here to handle when the dialog is
00083                 //  dismissed with Cancel
00084         }
00085
00086         // Since the dialog has been closed, return FALSE so that we exit the
00087         //  application, rather than start the application's message pump.
00088         return FALSE;
00089 }
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5.h Source File

vcDP5.h
Go to the documentation of this file.
00001 // vcDP5.h : main header file for the PROJECT_NAME application
00002 //
00003
00004 #pragma once
00005
00006 #ifndef __AFXWIN_H__
00007         #error include 'stdafx.h' before including this file for PCH
00008 #endif
00009
00010 #include "resource.h"           // main symbols
00011 #include <SetupAPI.h>
00012 #include "SendCommand.h"
00013 #include "SProfile.h"
00014 #include "DppConst.h"
00015
00016 // CvcDP5App:
00017 // See vcDP5.cpp for the implementation of this class
00018 //
00019
00020 class CvcDP5App : public CWinApp
00021 {
00022 public:
00023         CvcDP5App();
00024
00025 // Overrides
00026         public:
00027         virtual BOOL InitInstance();
00028
00029 // Implementation
00030
00031         DECLARE_MESSAGE_MAP()
00032 };
00033
00034 extern CvcDP5App theApp;
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5_Shared_HIDD.h Source File

vcDP5_Shared_HIDD.h
Go to the documentation of this file.
00001
00002 // Generated Help Map file.  Used by vcDP5.HHP.
00003 // Shared dialogs do not have integer IDD_ defines.
00005
00007 // HTML Defines for Shared Dialogs
00009
00010 // Dialogs (IDD_*)
00011 #define HIDD_DP5_CONNECT                        0x20191
00012 #define HIDD_FILE_PAGE                          0x20192
00013 #define HIDD_MCA_PAGE                           0x20193
00014 #define HIDD_SHAPING_PAGE                       0x20194
00015 #define HIDD_GAINPZ_PAGE                        0x20195
00016 #define HIDD_POWER_PAGE                         0x20196
00017 #define HIDD_MISC_PAGE                          0x20197
00018
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5_Shared_IDD.h Source File

vcDP5_Shared_IDD.h
Go to the documentation of this file.
00001 #define IDD_DP5_CONNECT                 401
00002 #define IDD_FILE_PAGE                   402
00003 #define IDD_MCA_PAGE                    403
00004 #define IDD_SHAPING_PAGE                404
00005 #define IDD_GAINPZ_PAGE                 405
00006 #define IDD_POWER_PAGE                  406
00007 #define IDD_MISC_PAGE                   407
00008
Generated on Fri Sep 22 2017 10:01:01 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5Dlg.cpp Source File

vcDP5Dlg.cpp
Go to the documentation of this file.
00001 // vcDP5Dlg.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "DppWinUSB.h"
00006 #include "vcDP5.h"
00007 #include "vcDP5Dlg.h"
00008 #include ".\vcdp5dlg.h"
00009 #include "SelectDP5.h"
00010 #include ".\msectimer.h"
00011 #include ".\waitdlg\CmdWaitDlg.h"
00012 #include "UserMsgs.h"
00013 #include "FileBrowse.h"
00014 #include "afxadv.h"     // for cfg file clipboard copy
00015 #include "TuneSlowThreshold.h"
00016 #include "MsgBox.h"
00017 #include "AsciiCmdUtilities.h"
00018
00019 #ifdef _DEBUG
00020 #define new DEBUG_NEW
00021 #endif
00022
00023 // CAboutDlg dialog used for App About
00024
00025 class CAboutDlg : public CDialog
00026 {
00027 public:
00028         CAboutDlg();
00029
00030 // Dialog Data
00031         enum { IDD = IDD_ABOUTBOX };
00032
00033         protected:
00034         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00035
00036 // Implementation
00037 protected:
00038         DECLARE_MESSAGE_MAP()
00039 };
00040
00041 CAboutDlg::CAboutDlg() : CDialog(CAboutDlg::IDD)
00042 {
00043 }
00044
00045 void CAboutDlg::DoDataExchange(CDataExchange* pDX)
00046 {
00047         CDialog::DoDataExchange(pDX);
00048 }
00049
00050 BEGIN_MESSAGE_MAP(CAboutDlg, CDialog)
00051 END_MESSAGE_MAP()
00052
00053
00054 // CvcDP5Dlg dialog
00055
00056
00057
00058 CvcDP5Dlg::CvcDP5Dlg(CWnd* pParent /*=NULL*/)
00059         : CDialog(CvcDP5Dlg::IDD, pParent)
00060 {
00061         int idxBuffer;
00062         m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME);
00063         m_PicturePlot.SetCursorPosition(0);
00064
00065         // assign the timer values
00066         m_nTmrRS232EventId = 1;
00067         m_nTmrSpectrumEventId = 2;
00068         m_nTmrTimeoutEventId = 3;
00069
00070         m_nTmrSpectrumId = 0;
00071
00072         m_nTmrRS232Elapse = 100;
00073         m_nTmrSpectrumElapse = 1000;
00074         m_nTmrTimeoutElapse = 10;
00075
00076         HavePlot = FALSE;
00077         HaveTrace = FALSE;
00078         for(idxBuffer = 0; idxBuffer < 8192; idxBuffer++) {
00079                 PlotBuffer[idxBuffer] = 0;    //holds y position data for cursor updates
00080         }
00081         for(idxBuffer = 0; idxBuffer < 2048; idxBuffer++) {
00082                 ScopeBuffer[idxBuffer] = 0;
00083         }
00084         XPlotMAX = 0;
00085         YPlotMAX = 0;
00086         m_PicturePlot.OptScaleType = false;
00087         m_PicturePlot.OptPlotType = false;
00088
00089         //MakeDp5CmdList(&Dp5CmdList);
00090     Dp5CmdList = MakeDp5CmdList();      // ascii text command list for adding comments
00091         HwCfgDP5 = "";
00092
00093         DP5Proto.SPECTRUM.CHANNELS = 1024;
00094         CurrentChannel = 0;
00095
00096 }
00097
00098 CvcDP5Dlg::~CvcDP5Dlg()
00099 {
00100
00101 }
00102
00103 void CvcDP5Dlg::DoDataExchange(CDataExchange* pDX)
00104 {
00105         CDialog::DoDataExchange(pDX);
00106         DDX_Control(pDX, IDC_PICTURE_PLOT, m_PicturePlot);
00107         DDX_Control(pDX, IDC_PICTURE_SCOPE, m_PictureScope);
00108         DDX_Control(pDX, IDC_STATIC_SELECT_COMMUNICATIONS, lblSelectCommunications);
00109         DDX_Control(pDX, IDC_STATIC_STATUS, lblStatus);
00110         DDX_Control(pDX, IDC_STATIC_MISC_STATUS, lblMiscStatus);
00111 }
00112
00113 BEGIN_MESSAGE_MAP(CvcDP5Dlg, CDialog)
00114         ON_MESSAGE(WM_USER_SEND_CONFIG_TO_HW, DppSendConfigToHw)
00115         ON_MESSAGE(WM_USER_READ_DPP_CONFIG, CallReadDppConfig)
00116         ON_MESSAGE(WM_USER_READ_SCA_CONFIG, CallReadScaConfig)
00117
00118         ON_WM_SYSCOMMAND()
00119         ON_WM_PAINT()
00120         ON_WM_QUERYDRAGICON()
00121         //}}AFX_MSG_MAP
00122         ON_WM_DEVICECHANGE()
00123         ON_WM_DESTROY()
00124         ON_BN_CLICKED(IDC_BUTTON_FIND_DEVICE, OnBnClickedButtonFindDevice)
00125         ON_WM_TIMER()
00126         ON_BN_CLICKED(IDC_BUTTON_ARM_TRIGGER, OnBnClickedButtonArmTrigger)
00127         ON_BN_CLICKED(IDC_BUTTON_SAVE_FILE, OnBnClickedButtonSaveFile)
00128         ON_BN_CLICKED(IDC_BUTTON_CLEAR_DATA_AND_GRAPH, OnBnClickedButtonClearDataAndGraph)
00129         ON_BN_CLICKED(IDC_BUTTON_SINGLE_UPDATE, OnBnClickedButtonSingleUpdate)
00130         ON_BN_CLICKED(IDC_BUTTON_CLEAR_MISC_DATA, OnBnClickedButtonClearMiscData)
00131         ON_BN_CLICKED(IDC_BUTTON_READ_MISC_DATA, OnBnClickedButtonReadMiscData)
00132         ON_BN_CLICKED(IDC_BUTTON_WRITE_MISC_DATA, OnBnClickedButtonWriteMiscData)
00133         ON_BN_CLICKED(IDC_BUTTON_DIAG, OnBnClickedButtonDiag)
00134         ON_BN_CLICKED(IDC_BUTTON_SELECT_COMM, OnBnClickedButtonSelectComm)
00135         ON_BN_CLICKED(IDC_BUTTON_START_ACQUISITION, OnBnClickedButtonStartAcquisition)
00136         ON_BN_CLICKED(IDC_BUTTON_STOP_ACQUISITION, OnBnClickedButtonStopAcquisition)
00137         ON_BN_CLICKED(IDC_BUTTON_SHOW_CONFIG, OnBnClickedButtonShowConfig)
00138         ON_BN_CLICKED(IDC_RADIO_PLOT_SCALE_LINEAR, OnBnClickedRadioPlotScaleLinear)
00139         ON_BN_CLICKED(IDC_RADIO_PLOT_SCALE_LOG, OnBnClickedRadioPlotScaleLog)
00140         ON_BN_CLICKED(IDC_RADIO_PLOT_TYPE_SOLID, OnBnClickedRadioPlotTypeSolid)
00141         ON_BN_CLICKED(IDC_RADIO_PLOT_TYPE_LINE, OnBnClickedRadioPlotTypeLine)
00142
00143         ON_STN_CLICKED(IDC_PICTURE_PLOT, OnStnClickedPlotpicturecontrol)
00144         ON_WM_LBUTTONDOWN()
00145         ON_BN_CLICKED(IDOK, OnBnClickedOk)
00146         ON_BN_CLICKED(IDCANCEL, OnBnClickedCancel)
00147         ON_NOTIFY_EX_RANGE(TTN_NEEDTEXT, 0, 0xFFFF, OnToolTipNotify)
00148         ON_BN_CLICKED(IDC_BUTTON_AUTOTUNE, OnBnClickedButtonAutotune)
00149         ON_BN_CLICKED(IDC_CHECK_REPEAT_SPECTRUM, OnBnClickedCheckRepeatSpectrum)
00150 END_MESSAGE_MAP()
00151
00152
00153 // CvcDP5Dlg message handlers
00154
00155 BOOL CvcDP5Dlg::OnInitDialog()
00156 {
00157         CDialog::OnInitDialog();
00158
00159         EnableToolTips();
00160         // Add "About..." menu item to system menu.
00161
00162         // IDM_ABOUTBOX must be in the system command range.
00163         ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);
00164         ASSERT(IDM_ABOUTBOX < 0xF000);
00165
00166         CMenu* pSysMenu = GetSystemMenu(FALSE);
00167         if (pSysMenu != NULL)
00168         {
00169                 CString cstrAboutMenu;
00170                 cstrAboutMenu.LoadString(IDS_ABOUTBOX);
00171                 if (!cstrAboutMenu.IsEmpty())
00172                 {
00173                         pSysMenu->AppendMenu(MF_SEPARATOR);
00174                         pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, cstrAboutMenu);
00175                 }
00176         }
00177
00178         lblSelectCommunications
00179                 .SetFontName("Arial")
00180                 .SetFontSize(14)
00181                 .SetTextColor(colorBlack)
00182                 .SetBkColor(colorAmptekBlue)
00183                 .SetFontBold(TRUE);
00184
00185         lblMiscStatus
00186                 .SetTextColor(colorBlue)
00187                 .SetBkColor(colorAmptekBlue);
00188
00189
00190         // Set the icon for this dialog.  The framework does this automatically
00191         //  when the application's main window is not a dialog
00192         SetIcon(m_hIcon, TRUE);                 // Set big icon
00193         SetIcon(m_hIcon, FALSE);                // Set small icon
00194
00195         hWnd_Main = this->GetSafeHwnd();
00196
00197         // TODO: Add extra initialization here
00198         WinusbNotify.SetNotificationWindow(this->m_hWnd);
00199         DppWinUSB.devInfo.deviceConnected = FALSE;
00200
00201         // no device selected upon startup
00202         DppWinUSB.isDppFound = FALSE;
00203
00204         m_PicturePlot.OptScaleType = BOOL_TO_bool(Profile.isScaleLog);
00205         m_PicturePlot.OptPlotType = BOOL_TO_bool(Profile.isPlotLine);
00206
00207         if (m_PicturePlot.OptScaleType) {
00208                 CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LOG);
00209         } else {
00210                 CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LINEAR);
00211         }
00212
00213         if (m_PicturePlot.OptPlotType) {
00214                 CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_LINE);
00215         } else {
00216                 CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_SOLID);
00217         }
00218
00219         EnableDPPFunctions(FALSE);
00220
00221         GetDlgItem(IDC_EDIT_REPEAT_LOOPS)->SetWindowText("10");
00222         GetDlgItem(IDC_EDIT_PRESET_CMD)->SetWindowText("PRET=20;");
00223         //GetDlgItem(IDC_EDIT_PRESET_CMD)->SetWindowText("PRER=60;");
00224
00225         return TRUE;  // return TRUE  unless you set the focus to a control
00226 }
00227
00228 bool CvcDP5Dlg::BOOL_TO_bool(BOOL bValue)
00229 {
00230         if (bValue) {
00231                 return true;
00232         } else {
00233                 return false;
00234         }
00235 }
00236
00237 void CvcDP5Dlg::OnSysCommand(UINT nID, LPARAM lParam)
00238 {
00239         if ((nID & 0xFFF0) == IDM_ABOUTBOX)
00240         {
00241                 CAboutDlg dlgAbout;
00242                 dlgAbout.DoModal();
00243         }
00244         else
00245         {
00246                 CDialog::OnSysCommand(nID, lParam);
00247         }
00248 }
00249
00250 // if you add a minimize button to your dialog, you will need the code below
00251 //  to draw the icon.  For MFC applications using the document/view model,
00252 //  this is automatically done for you by the framework.
00253
00254 void CvcDP5Dlg::OnPaint()
00255 {
00256         if (IsIconic())
00257         {
00258                 CPaintDC dc(this); // device context for painting
00259
00260                 SendMessage(WM_ICONERASEBKGND, reinterpret_cast<WPARAM>(dc.GetSafeHdc()), 0);
00261
00262                 // Center icon in client rectangle
00263                 int cxIcon = GetSystemMetrics(SM_CXICON);
00264                 int cyIcon = GetSystemMetrics(SM_CYICON);
00265                 CRect rect;
00266                 GetClientRect(&rect);
00267                 int x = (rect.Width() - cxIcon + 1) / 2;
00268                 int y = (rect.Height() - cyIcon + 1) / 2;
00269
00270                 // Draw the icon
00271                 dc.DrawIcon(x, y, m_hIcon);
00272         }
00273         else
00274         {
00275                 UpdateScope();
00276                 CDialog::OnPaint();
00277         }
00278 }
00279
00280 // The system calls this function to obtain the cursor to display while the user drags
00281 //  the minimized window.
00282 HCURSOR CvcDP5Dlg::OnQueryDragIcon()
00283 {
00284         return static_cast<HCURSOR>(m_hIcon);
00285 }
00286
00287 BOOL CvcDP5Dlg::OnDeviceChange(UINT nEventType, DWORD_PTR dwData)
00288 {
00289         //CDialog::OnDeviceChange(nEventType, dwData);
00290         string strStatus;
00291         string strDevice;
00292
00293         switch(nEventType) {
00294                 case DBT_DEVICEARRIVAL:
00295                         //return TRUE;
00296                         lblStatus.SetText(strStatus.c_str());
00297                         if (WinusbNotify.GetDevNotifyInfo(dwData, DppWinUSB.devInfo.devicePath)) {
00298                                 strStatus = "                                          ";
00299                                 lblStatus.SetText(strStatus.c_str());
00300                                 strStatus = "";
00301                                 lblStatus.SetText(strStatus.c_str());
00302                                 strStatus = "Device Connected. Reconnecting to device.";
00303                                 lblStatus.SetText(strStatus.c_str());
00304                                 OnBnClickedButtonFindDevice();
00305                         }
00306                         break;
00307                 case DBT_DEVICEREMOVECOMPLETE:
00308                         if (WinusbNotify.GetDevNotifyInfo(dwData, DppWinUSB.devInfo.devicePath)) {
00309                                 EnableDPPFunctions(FALSE);
00310                                 DppWinUSB.devInfo.deviceConnected = FALSE;
00311                                 strStatus = "Device Removed";
00312                                 lblStatus.SetText(strStatus.c_str());
00313                         }
00314                         break;
00315                 default:
00316                         break;
00317                         //AfxMessageBox("Unknown");
00318         }
00319         // TODO: Add your message handler code here
00320         return true;
00321 }
00322
00323 void CvcDP5Dlg::OnResetCommunications()
00324 {
00325         DppWinUSB.devInfo.deviceConnected = FALSE;
00326         DppWinUSB.CloseWinUsbDevice();
00327         WinusbNotify.RemoveDeviceNotification();
00328 }
00329
00330 void CvcDP5Dlg::OnDestroy()
00331 {
00332         isDppConnected = FALSE;
00333         CDialog::OnDestroy();
00334         CMSecTimer tmr;
00335         Profile.SaveProfile();
00336         if (m_nTmrSpectrumId > 0) {
00337                 KillTimer(m_nTmrSpectrumId);
00338                 m_nTmrSpectrumId = 0;
00339                 tmr.msTimer(1000);              // put refresh rate here
00340         }
00341         OnResetCommunications();
00342 }
00343
00344 ULONG CvcDP5Dlg::DataTest()
00345 {
00346         BOOL bResult;
00347         USHORT bufSizeOut = 8;
00348         BYTE szBufferOut[8] = { 0xF5, 0xFA, 0x02, 0x03, 0x00, 0x00, 0xFE, 0x0C };
00349         ULONG bytesWritten;
00350         USHORT bufSizeIn = 32767;
00351         BYTE szBufferIn[32767];
00352         ULONG bytesRead;
00353         string bufOut;
00354         USHORT idxStatus;
00355
00356         bytesRead = 0;
00357         bResult = WinUsb_WritePipe(DppWinUSB.devInfo.winUSBHandle, DppWinUSB.devInfo.bulkOutPipe, szBufferOut, bufSizeOut, &bytesWritten, NULL);
00358         Sleep(10);
00359         if (bResult) {
00360                 bResult = WinUsb_ReadPipe(DppWinUSB.devInfo.winUSBHandle, DppWinUSB.devInfo.bulkInPipe, szBufferIn, bufSizeIn, &bytesRead, NULL);
00361                 if (bResult) {
00362                         if (bytesRead == 840) {
00363                                 for(idxStatus = 0; idxStatus<64; idxStatus++) {
00364                                         DP5Stat.m_DP5_Status.RAW[idxStatus] = szBufferIn[774 + idxStatus];
00365                                         DP5Stat.Process_Status(&DP5Stat.m_DP5_Status);
00366                                 }
00367                                 bufOut = DppWinUSB.DisplayBufferArray(szBufferIn, bytesRead);
00368                                 DppWinUSB.SaveStringDataToFile(bufOut);
00369                         }
00370                 }
00371     }
00372         return bytesRead;
00373 }
00374
00375 void CvcDP5Dlg::OnBnClickedButtonFindDevice()
00376 {
00377         string strUSBStatus;
00378         DPP_USB_STATUS USBStatus;       //0=do nothing, 1=new connect, 2=cannot connect
00379         USBStatus = DppWinUSB.FindUSBDevice(DppWinUSB.CurrentDevice - 1);
00380         if (USBStatus != dusbStatNoAction) {
00381                 strUSBStatus = DppWinUSB.USBStatusString(USBStatus);
00382                 lblStatus.SetText(strUSBStatus.c_str());
00383                 if (USBStatus == dusbStatNewConnect) {
00384                         EnableDPPFunctions(TRUE);
00385                 }
00386         }
00387 }
00388
00389 void CvcDP5Dlg::RemCallParsePacket(BYTE PacketIn[])
00390 {
00391     ParsePkt.DppState.ReqProcess = ParsePkt.ParsePacket(PacketIn, &DP5Proto.PIN);
00392     ParsePacketEx(DP5Proto.PIN, ParsePkt.DppState);
00393 }
00394
00395 void CvcDP5Dlg::ParsePacketEx(Packet_In PIN, DppStateType DppState)
00396 {
00397     switch (DppState.ReqProcess) {
00398         case preqProcessStatus:
00399             ProcessStatusEx(PIN, DppState);
00400                         break;
00401         case preqProcessSpectrum:
00402             ProcessSpectrumEx(PIN, DppState);
00403                         break;
00404         case preqProcessScopeData:
00405             ProcessScopeDataEx(PIN, DppState);
00406                         break;
00407         case preqProcessTextData:
00408             ProcessTextDataEx(PIN, DppState);
00409                         break;
00410
00411 //====================================================================
00412 //        case preqProcessScopeDataOverFlow:
00413 //            ProcessScopeDataEx(PIN, DppState);
00414 //            //ProcessScopeDataOverFlowEx(PIN, DppState);
00415 //                      break;
00416 //        case preqProcessInetSettings:
00417 //            ProcessInetSettingsEx(PIN, DppState);
00418 //                      break;
00419         case preqProcessDiagData:
00420             ProcessDiagDataEx(PIN, DppState);
00421                         break;
00422 //        case preqProcessHwDesc:
00423 //            rocessHwDescEx(PIN, DppState);
00424 //                      break;
00425                 case preqProcessCfgRead:
00426                         ProcessCfgReadEx(PIN, DppState);
00427                         break;
00428         //     case preqProcessNetFindRead:
00429         //         //ProcessNetFindReadEx(PIN, DppState);
00430                         //break;
00431 //        case preqProcessSCAData:
00432 //            ProcessSCADataEx(PIN, DppState);
00433 //                      break;
00434 //====================================================================
00435
00436         case preqProcessAck:
00437             ProcessAck(PIN.PID2);
00438                         break;
00439         case preqProcessError:
00440             DisplayError(PIN, DppState);
00441                         break;
00442         default:
00443             //do nothing
00444                                 break;
00445     }
00446 }
00447
00448 void CvcDP5Dlg::DisplayError(Packet_In PIN, DppStateType DppState)
00449 {
00450         string strError;
00451         stringex strfn;
00452         ShowStatus(ParsePkt.PID2_TextToString("Received Packet", PIN.STATUS));
00453     // bad PID, assigned by ParsePacket
00454     if (PIN.STATUS == PID2_ACK_PID_ERROR) {
00455                 strError = strfn.Format("Received packet: PID1=0x.2X PID1=0x.2X LEN=%d",PIN.PID1,PIN.PID2,PIN.LEN);
00456                 ShowStatus(strError);
00457     }
00458 }
00459
00460 void CvcDP5Dlg::ProcessAck(BYTE PID2)
00461 {
00462     ShowStatus(ParsePkt.PID2_TextToString("ACK", PID2));
00463 }
00464
00465 void CvcDP5Dlg::ProcessStatusEx(Packet_In PIN, DppStateType DppState)
00466 {
00467     long idxStatus;
00468         for(idxStatus=0;idxStatus<64;idxStatus++) {
00469         DP5Stat.m_DP5_Status.RAW[idxStatus] = PIN.DATA[idxStatus];
00470         }
00471     DP5Stat.Process_Status(&DP5Stat.m_DP5_Status);
00472     RequestScopeData(DP5Stat.m_DP5_Status.SCOPE_DR);
00473     ShowStatus("Received Status");
00474 }
00475
00476 void CvcDP5Dlg::ProcessDiagDataEx(Packet_In PIN, DppStateType DppState)
00477 {
00478         string strDiagData;
00479         DP5Stat.Process_Diagnostics(PIN, &DP5Stat.DiagData, Profile.device_type);
00480         strDiagData = DP5Stat.DiagnosticsToString(DP5Stat.DiagData, Profile.device_type);
00481         GetDlgItem(IDC_EDIT_DIAG)->SetWindowText(strDiagData.c_str());
00482 }
00483
00484 void CvcDP5Dlg::ProcessSpectrumEx(Packet_In PIN, DppStateType DppState)
00485 {
00486         long idxSpectrum;
00487         long idxStatus;
00488         string strStatus;
00489
00490         DP5Proto.SPECTRUM.CHANNELS = (SHORT)(256 * pow(2.0,(((PIN.PID2 - 1) & 14) / 2)));
00491
00492         for(idxSpectrum=0;idxSpectrum<DP5Proto.SPECTRUM.CHANNELS;idxSpectrum++) {
00493         DP5Proto.SPECTRUM.DATA[idxSpectrum] = (long)(PIN.DATA[idxSpectrum * 3]) + (long)(PIN.DATA[idxSpectrum * 3 + 1]) * 256 + (long)(PIN.DATA[idxSpectrum * 3 + 2]) * 65536;
00494         }
00495
00496     if ((PIN.PID2 & 1) == 0) {    // spectrum + status
00497                 for(idxStatus=0;idxStatus<64;idxStatus++) {
00498                         DP5Stat.m_DP5_Status.RAW[idxStatus] = PIN.DATA[idxStatus + DP5Proto.SPECTRUM.CHANNELS * 3];
00499                 }
00500         DP5Stat.Process_Status(&DP5Stat.m_DP5_Status);
00501                 //strStatus = DP5Stat.ShowStatusValueStrings(DP5Stat.m_DP5_Status);
00502                 strStatus = DP5Stat.GetStatusValueStrings(DP5Stat.m_DP5_Status);
00503
00504                 //IDC_STATIC_SPECTRUM_STATUS
00505                 GetDlgItem(IDC_STATIC_SPECTRUM_STATUS)->SetWindowText(strStatus.c_str());
00506                 string strMiscInfo;
00507
00508                 strMiscInfo = "Preset Mode  ";
00509                 strMiscInfo += strPresetCmd;
00510                 strMiscInfo += "\r\n";
00511                 strMiscInfo += "Preset       ";
00512                 strMiscInfo += strPresetVal;
00513                 strMiscInfo += "\r\n";
00514
00515                 lblMiscStatus.SetText(strMiscInfo.c_str());
00516         RequestScopeData(DP5Stat.m_DP5_Status.SCOPE_DR);
00517     }
00518         m_PicturePlot.DataAcq(DP5Proto.SPECTRUM.DATA, DP5Proto.SPECTRUM.CHANNELS);      // plot data
00519 }
00520
00521 void CvcDP5Dlg::ProcessScopeDataEx(Packet_In PIN, DppStateType DppState)
00522 {
00523         ScopeDisplay(PIN.DATA);
00524         if (IsDlgButtonChecked(IDC_CHECK_AUTO_REARM)) {
00525                 SendCommand(XMTPT_ARM_DIGITAL_OSCILLOSCOPE);  //Call btnArmTrigger_Click
00526         }
00527 }
00528
00529 void CvcDP5Dlg::ProcessTextDataEx(Packet_In PIN, DppStateType DppState)
00530 {
00531     long idxTextData;
00532         string strTextData;
00533         string strCh;
00534         stringex strfn; // = strfn.
00535
00536     strTextData = "";
00537         for(idxTextData=0;idxTextData<512;idxTextData++) {
00538                 strCh = strfn.Format("%c",PIN.DATA[idxTextData]);
00539         strTextData += strCh;
00540         }
00541         GetDlgItem(IDC_EDIT_MISC_DATA)->SetWindowText(strTextData.c_str());
00542 }
00543
00544 void CvcDP5Dlg::RequestScopeData(BOOL ScopeDataReady)
00545 {
00546     if (ScopeDataReady) {
00547                 SendCommand(XMTPT_SEND_SCOPE_DATA);
00548         }
00549 }
00550
00551 void CvcDP5Dlg::SendCommand(TRANSMIT_PACKET_TYPE XmtCmd)
00552 {
00553     BOOL HaveBuffer;
00554     BOOL SentPkt;
00555
00556     HaveBuffer = SndCmd.DP5_CMD(DP5Proto.BufferOUT, XmtCmd);
00557     if (HaveBuffer) {
00558         SentPkt = DppWinUSB.SendPacketUSB(DP5Proto.BufferOUT, DppWinUSB.devInfo, DP5Proto.PacketIn);
00559         if (SentPkt) {
00560             RemCallParsePacket(DP5Proto.PacketIn);
00561                 } else {
00562             //Timer2.Enabled = False
00563         }
00564     }
00565 }
00566
00567 //DP5_CMD_Config is for: (requires pc5 and device info)
00568 //              XMTPT_SEND_CONFIG_PACKET_TO_HW
00569 //              XMTPT_SEND_CONFIG_PACKET_EX
00570 //              XMTPT_FULL_READ_CONFIG_PACKET
00571 //              XMTPT_READ_CONFIG_PACKET
00572 //              XMTPT_READ_CONFIG_PACKET_EX
00573 void CvcDP5Dlg::SendCommandConfig(TRANSMIT_PACKET_TYPE XmtCmd)
00574 {
00575     BOOL HaveBuffer;
00576     BOOL SentPkt;
00577         CONFIG_OPTIONS CfgOptions;
00578
00579         CfgOptions.DppType = DP5Stat.m_DP5_Status.DEVICE_ID;
00580         CfgOptions.HwCfgDP5Out = HwCfgDP5Out;
00581         CfgOptions.PC5_PRESENT = DP5Stat.m_DP5_Status.PC5_PRESENT;
00582         CfgOptions.SendCoarseFineGain = FALSE;
00583         CfgOptions.isDP5_RevDxGains = DP5Stat.m_DP5_Status.isDP5_RevDxGains;
00584         CfgOptions.DPP_ECO = DP5Stat.m_DP5_Status.DPP_ECO;
00585
00586     HaveBuffer = SndCmd.DP5_CMD_Config(DP5Proto.BufferOUT, XmtCmd, CfgOptions);
00587     if (HaveBuffer) {
00588         SentPkt = DppWinUSB.SendPacketUSB(DP5Proto.BufferOUT, DppWinUSB.devInfo, DP5Proto.PacketIn);
00589         if (SentPkt) {
00590             RemCallParsePacket(DP5Proto.PacketIn);
00591                 } else {
00592             //Timer2.Enabled = False
00593         }
00594     }
00595 }
00596
00597 string CvcDP5Dlg::CreateSpectrumConfig(string strRawCfgIn)
00598 {
00599         string strDisplayCfgOut;
00600         string strCmdD;
00601
00602         strDisplayCfgOut = strRawCfgIn;
00603         if (Dp5CmdList.size() > 0) {
00604                 for (unsigned int idxCmd=0;idxCmd<Dp5CmdList.size();idxCmd++) {
00605                         strCmdD = Dp5CmdList[idxCmd];
00606                         if (strCmdD.length() > 0) {
00607                                 strDisplayCfgOut = AppendCmdDesc(strCmdD,strDisplayCfgOut);
00608                         }
00609                 }
00610         }
00611         return strDisplayCfgOut;
00612 }
00613
00614 void CvcDP5Dlg::SendCommandData(TRANSMIT_PACKET_TYPE XmtCmd, BYTE DataOut[])
00615 {
00616     BOOL HaveBuffer;
00617     BOOL SentPkt;
00618
00619     HaveBuffer = SndCmd.DP5_CMD_Data(DP5Proto.BufferOUT, XmtCmd, DataOut);
00620     if (HaveBuffer) {
00621         SentPkt = DppWinUSB.SendPacketUSB(DP5Proto.BufferOUT, DppWinUSB.devInfo, DP5Proto.PacketIn);
00622         if (SentPkt) {
00623             RemCallParsePacket(DP5Proto.PacketIn);
00624                 } else {
00625             //Timer2.Enabled = False
00626         }
00627     }
00628 }
00629
00630 void CvcDP5Dlg::SetCheckButtonState(int iCheckBox, bool bChecked)
00631 {
00632         CButton* pCheckBox=(CButton*)GetDlgItem(iCheckBox);
00633         if (bChecked)
00634         {
00635                 pCheckBox->SetCheck(BST_CHECKED);
00636         }
00637         else
00638         {
00639                 pCheckBox->SetCheck(BST_UNCHECKED);
00640         }
00641 }
00642
00643 void CvcDP5Dlg::OnTimer(UINT nIDEvent)
00644 {
00645         bool bPresetReached = false;
00646         if (nIDEvent == m_nTmrSpectrumId) {     // 1000ms AutoSpectrum
00647                 if (IsDlgButtonChecked(IDC_CHECK_DELTA)) {
00648                         SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00649                 } else {
00650                         SendCommand(XMTPT_SEND_SPECTRUM_STATUS);                // get the spectrum and status
00651                         if (IsDlgButtonChecked(IDC_CHECK_REPEAT_SPECTRUM)) {
00652                                 if (DP5Stat.m_DP5_Status.MCA_EN &&
00653                                         ((DP5Stat.m_DP5_Status.PRECNT_REACHED)                  // preset counts
00654                                                 || (DP5Stat.m_DP5_Status.PresetRtDone)          // preset real time
00655                                                 || (DP5Stat.m_DP5_Status.PresetLtDone))) {      // preset live time
00656                                         bPresetReached = true;
00657                                 } else if (!DP5Stat.m_DP5_Status.MCA_EN) {                      // preset accum time
00658                                         bPresetReached = true;
00659                                 }
00660                                 if (bPresetReached) {
00661                                         idxCurrentSpectrum++;
00662                                         if (idxCurrentSpectrum <= idxTotalSpectra) {    // save spectrum
00663                                                 SaveTestSpectrumFile(idxCurrentSpectrum);
00664                                         }
00665                                         if (idxCurrentSpectrum >= idxTotalSpectra) {    // we're done
00666                                                 if (m_nTmrSpectrumId > 0) {
00667                                                         KillTimer(m_nTmrSpectrumId);
00668                                                         m_nTmrSpectrumId = 0;
00669                                                 }
00670                                                 SetCheckButtonState(IDC_CHECK_REPEAT_SPECTRUM,false);
00671                                                 OnBnClickedCheckRepeatSpectrum();
00672                                                 ShowRepeatStatus(false);
00673                                                 GetDlgItem(IDC_STATIC_STATUS)->SetWindowText("Repeat Spectrum Done");
00674                                         } else {                                                                                // get next spectrum
00675                                                 SendCommand(XMTPT_DISABLE_MCA_MCS);
00676                                                 SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00677                                                 m_PicturePlot.ClearTrace();
00678                                                 string strStartTime = CreateDTS("%m/%d/%Y %H:%M:%S");
00679                                                 GetDlgItem(IDC_EDIT_START_TIME)->SetWindowText(strStartTime.c_str());
00680                                                 SendCommand(XMTPT_ENABLE_MCA_MCS);
00681                                                 ShowRepeatStatus(true);
00682                                         }
00683                                 }
00684                         }
00685                 }
00686         } else if (nIDEvent == m_nTmrTimeoutId) {       // 10ms Comm TimeOut
00687                 TimeoutFlag = TRUE;
00688         }
00689         CDialog::OnTimer(nIDEvent);
00690 }
00691
00692 void CvcDP5Dlg::OnBnClickedButtonArmTrigger()
00693 {
00694         SendCommand(XMTPT_ARM_DIGITAL_OSCILLOSCOPE);
00695 }
00696
00697 void CvcDP5Dlg::OnBnClickedButtonClearDataAndGraph()
00698 {
00699         SetCheckButtonState(IDC_CHECK_REPEAT_SPECTRUM,false);
00700     SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00701         GetDlgItem(IDC_STATIC_REPEAT_STATUS)->SetWindowText("");
00702         m_PicturePlot.ClearTrace();
00703 }
00704
00705 void CvcDP5Dlg::OnBnClickedButtonSingleUpdate()
00706 {
00707         SetCheckButtonState(IDC_CHECK_REPEAT_SPECTRUM,false);
00708         if (m_nTmrSpectrumId > 0) {
00709                 KillTimer(m_nTmrSpectrumId);
00710                 m_nTmrSpectrumId = 0;
00711         }
00712         if (IsDlgButtonChecked(IDC_CHECK_DELTA)) {
00713                 SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00714         } else {
00715                 SendCommand(XMTPT_SEND_SPECTRUM_STATUS);
00716         }
00717 }
00718
00719 void CvcDP5Dlg::OnBnClickedButtonClearMiscData()
00720 {
00721         GetDlgItem(IDC_EDIT_MISC_DATA)->SetWindowText("");
00722 }
00723
00724 void CvcDP5Dlg::OnBnClickedButtonReadMiscData()
00725 {
00726         SendCommand(XMTPT_SEND_512_BYTE_MISC_DATA);
00727 }
00728
00729 void CvcDP5Dlg::OnBnClickedButtonWriteMiscData()
00730 {
00731         string strMiscData;
00732         BYTE byteMiscData[512];
00733         int idxCh;
00734         int DataLen;
00735         strMiscData.reserve(512+1);
00736
00737         GetDlgItem(IDC_EDIT_MISC_DATA)->GetWindowText((char*)strMiscData.c_str(), 512+1);
00738         DataLen = (int)strMiscData.length();
00739         for(idxCh=0;idxCh<512;idxCh++) {
00740                 if (idxCh < DataLen) {
00741                         byteMiscData[idxCh] = (BYTE)strMiscData.at(idxCh);
00742                 } else {
00743                         byteMiscData[idxCh] = 0;
00744                 }
00745         }
00746     SendCommandData(XMTPT_WRITE_512_BYTE_MISC_DATA, byteMiscData);
00747 }
00748
00749 void CvcDP5Dlg::ShowStatus(string strStatus)
00750 {
00751         GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strStatus.c_str());
00752 }
00753
00754 //-------------------------------------------------------------------
00755 // UpdateScope
00756 // Draws the scope display with the current scope buffer
00757 //-------------------------------------------------------------------
00758 void CvcDP5Dlg::UpdateScope()
00759 {
00760         CDC *dc=m_PictureScope.GetDC();                 // device context for plot
00761         CRect rect;
00762         CPen pen,*oldpen;
00763         m_PictureScope.GetClientRect(&rect);            // get plot client area
00764
00765         // Draw background rectangle
00766         if (HaveTrace) {
00767                 pen.CreatePen(PS_SOLID,1,RGB(0xFF,0x00,0x00));                  // drawing pen color
00768         } else {
00769                 pen.CreatePen(PS_SOLID,1,RGB(0xFF,0xFF,0xFF));                  // drawing pen color
00770         }
00771         oldpen=dc->SelectObject(&pen);                                                  // save old pen to restore
00772         CBrush WorkSpaceBrush( RGB(0xFF,0xFF,0xFF) );                   // fill brush color
00773         CBrush *oldbrush = dc->SelectObject(&WorkSpaceBrush);   // save old brush to restore
00774         dc->Rectangle(&rect);
00775         dc->Draw3dRect(&rect, (COLORREF)GetSysColor(COLOR_3DSHADOW), (COLORREF)GetSysColor(COLOR_3DHILIGHT));
00776
00777         // === needs to be updated,
00778         dc->SetMapMode(MM_ANISOTROPIC);                                         // x!=y
00779         dc->SetViewportOrg(0,rect.Height());                            // move 0,0 to bottom left
00780         dc->SetWindowExt(2048, -256);   // 2048 scope channels, 256 levels (invert y scale)
00781         dc->SetViewportExt(rect.Width(), rect.Height());        // viewport is pic control size
00782         //double y1, y2;
00783         for(int X=0; X<2047; X++) {
00784                 dc->MoveTo(X, ScopeBuffer[X]);
00785                 dc->LineTo(X+1, ScopeBuffer[X+1]);
00786         }
00787         dc->SelectObject(oldpen);
00788         pen.DeleteObject();
00789         dc->SelectObject(oldbrush);
00790         WorkSpaceBrush.DeleteObject();
00791         m_PictureScope.ReleaseDC(dc);
00792 }
00793
00794 //-------------------------------------------------------------------
00795 // ScopeDisplay
00796 // Calculates and saves the plot buffer data then calls UpdatePlot
00797 //-------------------------------------------------------------------
00798 void CvcDP5Dlg::ScopeDisplay(BYTE ScopeData[2048])
00799 {
00800         int i;
00801     for (i = 0; i < 2048;i++ ) {                //get the largest value to be displayed
00802                 ScopeBuffer[i] = ScopeData[i];
00803     }
00804         HaveTrace = TRUE;
00805         UpdateScope();
00806 }
00807
00808 void CvcDP5Dlg::EnableDPPFunctions(BOOL isEnabled)
00809 {
00810         // Config
00811         GetDlgItem(IDC_BUTTON_SHOW_CONFIG)->EnableWindow(isEnabled);    //CONFIG
00812
00813         // MCA functions
00814         GetDlgItem(IDC_BUTTON_SINGLE_UPDATE)->EnableWindow(isEnabled);  //Single Update
00815         GetDlgItem(IDC_BUTTON_START_ACQUISITION)->EnableWindow(isEnabled);      //Start Acquire
00816         GetDlgItem(IDC_BUTTON_STOP_ACQUISITION)->EnableWindow(isEnabled);       //Stop Acquire
00817         GetDlgItem(IDC_BUTTON_CLEAR_DATA_AND_GRAPH)->EnableWindow(isEnabled);   //Clear Data and Graph
00818         GetDlgItem(IDC_BUTTON_SAVE_FILE)->EnableWindow(isEnabled);      //Save File
00819
00820         // Scope
00821         GetDlgItem(IDC_BUTTON_ARM_TRIGGER)->EnableWindow(isEnabled); //Arm Trigger
00822
00823         //Text Data Buttons
00824         GetDlgItem(IDC_BUTTON_READ_MISC_DATA)->EnableWindow(isEnabled); //Read
00825         GetDlgItem(IDC_BUTTON_WRITE_MISC_DATA)->EnableWindow(isEnabled);        //Write
00826         GetDlgItem(IDC_BUTTON_CLEAR_MISC_DATA)->EnableWindow(isEnabled);        //Clear
00827
00828         // diagnostics
00829         GetDlgItem(IDC_BUTTON_DIAG)->EnableWindow(isEnabled);   //CONFIG
00830
00831 }
00832
00833 void CvcDP5Dlg::OnBnClickedButtonDiag()
00834 {
00835         SendCommand(XMTPT_SEND_DIAGNOSTIC_DATA);
00836 }
00837
00838 void CvcDP5Dlg::OnBnClickedButtonSelectComm()
00839 {
00840         string strSelected;
00841         CSelectDP5 SelectDP5;
00842         CMSecTimer tmr;
00843         cWaitDialog dlg;        // display dialog box
00844         dlg.m_Text = "Adjusting Communications...please wait";
00845         dlg.Show();
00846         strSelected = "Select Communications";
00847         if (m_nTmrSpectrumId > 0) {
00848                 KillTimer(m_nTmrSpectrumId);
00849                 m_nTmrSpectrumId = 0;
00850                 tmr.msTimer(1000);              // put refresh rate here
00851         }
00852         OnResetCommunications();
00853         tmr.msTimer(200);
00854         dlg.Close();            // close wait dlg
00855         INT_PTR nResponse = SelectDP5.DoModal();
00856         if (nResponse == IDOK)
00857         {
00858                 EnableDPPFunctions(FALSE);
00859                 if (DppWinUSB.devInfo.deviceConnected) {
00860                         strSelected = "USB - WinUSB";
00861                         EnableDPPFunctions(TRUE);
00862                 }
00863                 isConnectedTest();
00864                 lblSelectCommunications.SetText(strSelected.c_str());
00865         }
00866         else if (nResponse == IDCANCEL)
00867         {
00868                 // TODO: Place code here to handle when the dialog is
00869                 //  dismissed with Cancel
00870         }
00871 }
00872
00873 string CvcDP5Dlg::GetDeviceNameFromVal(int DeviceTypeVal)
00874 {
00875     string strDeviceType;
00876         switch(DeviceTypeVal) {
00877                 case dppDP5:
00878             strDeviceType = "DP5";
00879                         break;
00880                 case dppPX5:
00881             strDeviceType = "PX5";
00882                         break;
00883                 case dppDP5G:
00884             strDeviceType = "DP5G";
00885                         break;
00886                 case dppMCA8000D:
00887             strDeviceType = "MCA8000D";
00888                         break;
00889                 case dppTB5:
00890             strDeviceType = "TB5";
00891                         break;
00892                 default:           //if unknown set to DP5
00893             strDeviceType = "DP5";
00894                         break;
00895         }
00896     return strDeviceType;
00897 }
00898
00899 // sets/returns if DPP is connected based on USB Interface and isDppFound[]
00900 BOOL CvcDP5Dlg::isConnectedTest()
00901 {
00902         BOOL isDppFound;
00903         CMSecTimer tmr;
00904
00905         isDppFound = DppWinUSB.isDppFound;
00906         isDppConnected = isDppFound;
00907         if (isDppConnected ) {
00908                 SendCommand(XMTPT_SEND_STATUS); // request status
00909                 tmr.msTimer(500);
00910                 Profile.device_type = DP5Stat.m_DP5_Status.DEVICE_ID;
00911                 DeviceType = DP5Stat.m_DP5_Status.DEVICE_ID;
00912                 Profile.strDevice = GetDeviceNameFromVal(Profile.device_type);
00913                 return isDppFound;
00914         } else {
00915                 isDppConnected = FALSE;
00916                 return FALSE;
00917         }
00918 }
00919
00920 void CvcDP5Dlg::ShowRepeatStatus(bool bShowStatus = false)
00921 {
00922         string strStatus("");
00923         stringex strfn; // = strfn.
00924
00925         if (bShowStatus) {      // display count
00926                 strStatus = strfn.Format("%d of %d", idxCurrentSpectrum+1, idxTotalSpectra);
00927         }
00928         GetDlgItem(IDC_STATIC_REPEAT_STATUS)->SetWindowText(strStatus.c_str());
00929 }
00930
00931 void CvcDP5Dlg::OnBnClickedButtonStartAcquisition()
00932 {
00933         string strCmd("");
00934         string strLoops("");
00935         bSpectraTestRunning = false;
00936         idxCurrentSpectrum = 0;
00937         idxTotalSpectra = 0;
00938         if (IsDlgButtonChecked(IDC_CHECK_REPEAT_SPECTRUM)) {
00939                 strLoops.reserve(10);
00940                 GetDlgItem(IDC_EDIT_REPEAT_LOOPS)->GetWindowText((char*)strLoops.c_str(),10);
00941                 idxTotalSpectra = atoi(strLoops.c_str());
00942                 string strStartTime = CreateDTS("%m/%d/%Y %H:%M:%S");
00943                 GetDlgItem(IDC_EDIT_START_TIME)->SetWindowText(strStartTime.c_str());
00944                 strLoops.reserve(20);
00945                 GetDlgItem(IDC_EDIT_PRESET_CMD)->GetWindowText((char*)strCmd.c_str(),20);
00946                 HwCfgDP5Out = strCmd.c_str();
00947                 HwCfgReady = TRUE;
00948                 SendCommandConfig(XMTPT_SEND_CONFIG_PACKET_EX); // send the packet
00949                 HwCfgExReady = FALSE;
00950                 SendCommand(XMTPT_DISABLE_MCA_MCS);
00951         SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00952                 m_PicturePlot.ClearTrace();
00953                 bSpectraTestRunning = true;
00954                 CMSecTimer tmr;
00955                 ShowRepeatStatus(true);
00956                 tmr.msTimer(200);
00957                 DP5Stat.m_DP5_Status.PRECNT_REACHED = FALSE;    // preset counts
00958                 DP5Stat.m_DP5_Status.PresetRtDone = FALSE;      // preset real time
00959                 DP5Stat.m_DP5_Status.PresetLtDone = FALSE;      // preset live time
00960         }
00961         SendCommand(XMTPT_ENABLE_MCA_MCS);
00962         m_nTmrSpectrumId = SetTimer(m_nTmrSpectrumEventId, m_nTmrSpectrumElapse, NULL);
00963 }
00964
00965 void CvcDP5Dlg::OnBnClickedButtonStopAcquisition()
00966 {
00967         SetCheckButtonState(IDC_CHECK_REPEAT_SPECTRUM,false);
00968         SendCommand(XMTPT_DISABLE_MCA_MCS);
00969 }
00970
00971 LRESULT CvcDP5Dlg::DppSendConfigToHw(WPARAM wParam, LPARAM lParam)
00972 {
00973         if (isDppConnected ) {
00974                 if (HwCfgReady) {
00975                         SendCommandConfig(XMTPT_SEND_CONFIG_PACKET_TO_HW);      // send the packet
00976                         HwCfgReady = FALSE;
00977                 } else if (HwCfgExReady) {
00978                         SendCommandConfig(XMTPT_SEND_CONFIG_PACKET_EX); // send the packet
00979                         HwCfgExReady = FALSE;
00980                 }
00981         }
00982         CMSecTimer tmr;
00983         if (isDppConnected ) {
00984                 tmr.msTimer(20);
00985                 SendCommandConfig(XMTPT_READ_CONFIG_PACKET);  // get info for display
00986                 tmr.msTimer(20);
00987         }
00988         return (Default());
00989 }
00990
00991 LRESULT CvcDP5Dlg::CallReadDppConfig(WPARAM wParam, LPARAM lParam)
00992 {
00993         if (isDppConnected ) {
00994                 CfgReadBack = TRUE;
00995                 SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
00996         }
00997         return (Default());
00998 }
00999
01000 LRESULT CvcDP5Dlg::CallReadScaConfig(WPARAM wParam, LPARAM lParam)
01001 {
01002         if (isDppConnected ) {
01003                 ScaReadBack = TRUE;
01004                 SendCommand(XMTPT_SCA_READ_CONFIG_PACKET);
01005         }
01006         return (Default());
01007 }
01008
01009 void CvcDP5Dlg::ProcessCfgReadEx(Packet_In PIN, DppStateType DppState)
01010 {
01011         string strRawCfgIn;
01012         string strRawCfgOut;
01013         string strCh;
01014         string strCmdData;
01015         strRawCfgIn = "";
01016         string strCmdD;
01017         string strCfg;
01018         BOOL isScaCfg = FALSE;
01019         string strDisplayCfgOut;
01020         stringex strfn; // = strfn.
01021
01022         strRawCfgOut = "";
01023         // ==========================================================
01024         // ===== Create Raw Configuration Buffer From Hardware ======
01025         for (int idxCfg=0;idxCfg<PIN.LEN;idxCfg++) {
01026                 strCh = strfn.Format("%c",PIN.DATA[idxCfg]);
01027                 strRawCfgIn += strCh;
01028                 strRawCfgOut += strCh;
01029                 if (PIN.DATA[idxCfg] == ';') {
01030                         strRawCfgIn += "\r\n";
01031                 }
01032         }
01033
01034         // ==========================================================
01035         if (DisplayCfg) {
01036                 DisplayCfg = FALSE;
01037                 strCfg = strRawCfgIn;
01038                 strDisplayCfgOut = strRawCfgIn;
01039                 for (unsigned int idxCmd=0;idxCmd<Dp5CmdList.size();idxCmd++) {
01040                         strCmdD = Dp5CmdList[idxCmd];
01041                         if (strCmdD.length() > 0) {
01042                                 strDisplayCfgOut = ReplaceCmdDesc(strCmdD,strDisplayCfgOut);
01043                         }
01044                 }
01045                 CopyDp5CfgToClip(strCfg,strDisplayCfgOut);
01046                 CMsgBox MsgBox;
01047                 MsgBox.m_strTitle = "DPP Configuration";
01048                 MsgBox.m_strMessage = strDisplayCfgOut;
01049                 MsgBox.m_strDelimiter = ";";
01050                 MsgBox.DoModal();
01051                 return;
01052         } else if (CfgReadBack) {
01053                 CfgReadBack = FALSE;
01054                 HwCfgDP5 = strRawCfgIn;
01055                 HwCfgReady = TRUE;
01056         }
01057         SaveCfg = FALSE;
01058         PrintCfg = FALSE;
01059         DisplayCfg = FALSE;
01060         CfgReadBack = FALSE;
01061
01062         isScaCfg = (BOOL)(ScaReadBack || DisplaySca);
01063         ScaReadBack = FALSE;
01064         DisplaySca = FALSE;
01065         if (isScaCfg) {
01066                 return;
01067         }
01068         strCmdData = GetCmdData("MCAS",strRawCfgIn); // mca mode
01069         strCmdData = GetCmdData("MCAC",strRawCfgIn); // channels
01070         if ((atoi(strCmdData.c_str()) > 0) && (atoi(strCmdData.c_str()) <= 8192)) {
01071                 mcaCH = atoi(strCmdData.c_str());
01072         } else {
01073                 mcaCH = 1024;
01074         }
01075
01076         strCmdData = GetCmdData("THSL",strRawCfgIn); // LLD thresh
01077         SlowThresholdPct = atof(strCmdData.c_str());
01078
01079         strCmdData = GetCmdData("THFA",strRawCfgIn); // fast thresh
01080         FastChThreshold = atoi(strCmdData.c_str());
01081
01082         strCmdData = GetCmdData("TPEA",strRawCfgIn); // peak time
01083         RiseUS = atof(strCmdData.c_str());
01084
01085         strCmdData = GetCmdData("GAIN",strRawCfgIn); // gain
01086         strGainDisplayValue = strCmdData + "x";
01087
01088         strPresetCmd = "";
01089         strPresetVal = "";
01090
01091         strCmdData = GetCmdData("PREC",strRawCfgIn); //preset count
01092         PresetCount = atoi(strCmdData.c_str());
01093         if (PresetCount > 0) {
01094                 if (strPresetCmd.length() > 0) { strPresetCmd += "/"; }
01095                 if (strPresetVal.length() > 0) { strPresetVal += "/"; }
01096                 strPresetCmd += "Cnt";
01097                 strPresetVal += strCmdData;
01098         }
01099
01100         strCmdData = GetCmdData("PRET",strRawCfgIn); //preset actual time
01101         PresetAcq = atof(strCmdData.c_str());
01102         if (PresetAcq > 0) {
01103                 if (strPresetCmd.length() > 0) { strPresetCmd += "/"; }
01104                 if (strPresetVal.length() > 0) { strPresetVal += "/"; }
01105                 strPresetCmd += "Acq";
01106                 strPresetVal += strCmdData;
01107         }
01108
01109         strCmdData = GetCmdData("PRER",strRawCfgIn); // preset real time
01110         PresetRt = atof(strCmdData.c_str());
01111         if (PresetRt > 0) {
01112                 if (strPresetCmd.length() > 0) { strPresetCmd += "/"; }
01113                 if (strPresetVal.length() > 0) { strPresetVal += "/"; }
01114                 strPresetCmd += "Real";
01115                 strPresetVal += strCmdData;
01116         }
01117
01118         if (strPresetCmd.length() == 0) {
01119                 strPresetCmd += "None";
01120         }
01121         if (strPresetVal.length() == 0) {
01122                 //strPresetVal += "";
01123         }
01124
01125         strCmdData = GetCmdData("CLCK",strRawCfgIn); // fpga clock mode
01126         if (atoi(strCmdData.c_str()) == 80) {
01127                 b80MHzMode = TRUE;
01128         } else {
01129                 b80MHzMode = FALSE;
01130         }
01131
01132         // DP5 oscilloscope support
01133         strCmdData = GetCmdData("INOF",strRawCfgIn); // osc. Input offset
01134         strInputOffset = strCmdData;
01135
01136         strCmdData = GetCmdData("DACO",strRawCfgIn); // osc. DAC output
01137         strAnalogOut = strCmdData;
01138
01139         strCmdData = GetCmdData("DACF",strRawCfgIn); // osc. DAC offset
01140         strOutputOffset = strCmdData;
01141
01142         strCmdData = GetCmdData("AUO1",strRawCfgIn); // osc. AUX_OUT1
01143         strTriggerSource = strCmdData;
01144
01145         strCmdData = GetCmdData("SCOE",strRawCfgIn); // osc. Scope trigger edge
01146         strTriggerSlope = strCmdData;
01147
01148         strCmdData = GetCmdData("SCOT",strRawCfgIn); // osc. Scope trigger position
01149         strTriggerPosition = strCmdData;
01150
01151         strCmdData = GetCmdData("SCOG",strRawCfgIn); // osc. Scope gain
01152         strScopeGain = strCmdData;
01153
01154         strCmdData = GetCmdData("MCAS",strRawCfgIn); // Acq Mode
01155         AcqMode = 0;
01156         strMcaMode = "MCA";
01157         if (strCmdData == "NORM") {
01158                 strMcaMode = "MCA";
01159         } else if (strCmdData == "MCS") {
01160                 strMcaMode = "MCS";
01161                 AcqMode = 1;
01162         } else if (strCmdData.length() > 0) {
01163                 strMcaMode = strCmdData;
01164         }
01165         UpdateScopeCfg = TRUE;
01166 }
01167
01168 string CvcDP5Dlg::GetCmdData(string strCmd, string strCfgData)
01169 {
01170         int iStart,iEnd,iCmd;
01171         string strCmdData;
01172
01173         strCmdData = "";
01174         if (strCfgData.length() < 7) { return strCmdData; }     // no data
01175         if (strCmd.length() != 4) {     return strCmdData; }            // bad command
01176         iCmd = (int)strCfgData.find(strCmd+"=",0);
01177         if (iCmd == -1) { return strCmdData; }                  // cmd not found
01178         iStart = (int)strCfgData.find("=",iCmd);
01179         if (iStart == -1) { return strCmdData; }                // data start not found
01180         iEnd = (int)strCfgData.find(";",iCmd);
01181         if (iEnd == -1) {return strCmdData; }                   // data end found
01182         if (iStart >= iEnd) { return strCmdData; }              // data error
01183         strCmdData = strCfgData.substr(iStart+1,(iEnd - (iStart+1)));
01184         return strCmdData;
01185 }
01186
01187 string CvcDP5Dlg::ReplaceCmdDesc(string strCmd, string strCfgData)
01188 {
01189         int iStart,iCmd;        //iEnd,
01190         string strNew;
01191         string strDesc;
01192
01193         strNew = "";
01194         if (strCfgData.length() < 7) { return strCfgData; }     // no data
01195         if (strCmd.length() != 4) {     return strCfgData; }            // bad command
01196         iCmd = (int)strCfgData.find(strCmd+"=",0);
01197         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
01198
01199         strDesc = GetCmdDesc(strCmd);
01200         if (strDesc.length() == 0) { return strCfgData; }               // cmd desc  not found
01201         iStart = (int)strCfgData.find("=",iCmd);
01202         if (iStart != (iCmd + 4)) { return strCfgData; }                        // data start not found
01203         if (iCmd <= 0) {        // usually left string has iCmd-1
01204                 iCmd = 1;               // in this case left has 0 chars, set offset
01205         }
01206         strNew = strCfgData.substr(0,iCmd-1) + strDesc + strCfgData.substr(iStart);
01207         return strNew;
01208 }
01209
01210 string CvcDP5Dlg::AppendCmdDesc(string strCmd, string strCfgData)
01211 {
01212         int iStart,iEnd,iCmd;
01213         string strNew;
01214         string strDesc;
01215
01216         strNew = "";
01217         if (strCfgData.length() < 7) { return strCfgData; }     // no data
01218         if (strCmd.length() != 4) {     return strCfgData; }            // bad command
01219         iCmd = (int)strCfgData.find(strCmd+"=",0);
01220         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
01221         iEnd = (int)strCfgData.find(";",iCmd);
01222         if (iEnd == -1) {return strCfgData; }                   // data end found
01223         iStart = (int)strCfgData.find("=",iCmd);
01224         if (iStart != (iCmd + 4)) { return strCfgData; }                        // data start not found
01225         if (iStart >= iEnd) { return strCfgData; }              // data error
01226         strDesc = GetCmdDesc(strCmd);
01227         if (strDesc.length() == 0) { return strCfgData; }               // cmd desc  not found
01228         strNew = strCfgData.substr(0,iEnd+1) + "    " + strDesc + strCfgData.substr(iEnd+1);
01229         return strNew;
01230 }
01231
01232 vector<string> CvcDP5Dlg::MakeDp5CmdList()
01233 {
01234         vector<string> cstrCfgArr;
01235         cstrCfgArr.clear();
01236         cstrCfgArr.push_back("RESC");
01237         cstrCfgArr.push_back("CLCK");
01238         cstrCfgArr.push_back("TPEA");
01239         cstrCfgArr.push_back("GAIF");
01240         cstrCfgArr.push_back("GAIN");
01241         cstrCfgArr.push_back("RESL");
01242         cstrCfgArr.push_back("TFLA");
01243         cstrCfgArr.push_back("TPFA");
01244         cstrCfgArr.push_back("PURE");
01245         cstrCfgArr.push_back("RTDE");
01246         cstrCfgArr.push_back("MCAS");
01247         cstrCfgArr.push_back("MCAC");
01248         cstrCfgArr.push_back("SOFF");
01249         cstrCfgArr.push_back("AINP");
01250         cstrCfgArr.push_back("INOF");
01251         cstrCfgArr.push_back("GAIA");
01252         cstrCfgArr.push_back("CUSP");
01253         cstrCfgArr.push_back("PDMD");
01254         cstrCfgArr.push_back("THSL");
01255         cstrCfgArr.push_back("TLLD");
01256         cstrCfgArr.push_back("THFA");
01257         cstrCfgArr.push_back("DACO");
01258         cstrCfgArr.push_back("DACF");
01259         cstrCfgArr.push_back("RTDS");
01260         cstrCfgArr.push_back("RTDT");
01261         cstrCfgArr.push_back("BLRM");
01262         cstrCfgArr.push_back("BLRD");
01263         cstrCfgArr.push_back("BLRU");
01264         cstrCfgArr.push_back("GATE");
01265         cstrCfgArr.push_back("AUO1");
01266         cstrCfgArr.push_back("PRET");
01267         cstrCfgArr.push_back("PRER");
01268         cstrCfgArr.push_back("PREL");
01269         cstrCfgArr.push_back("PREC");
01270         cstrCfgArr.push_back("PRCL");
01271         cstrCfgArr.push_back("PRCH");
01272         cstrCfgArr.push_back("HVSE");
01273         cstrCfgArr.push_back("TECS");
01274         cstrCfgArr.push_back("PAPZ");
01275         cstrCfgArr.push_back("PAPS");
01276         cstrCfgArr.push_back("SCOE");
01277         cstrCfgArr.push_back("SCOT");
01278         cstrCfgArr.push_back("SCOG");
01279         cstrCfgArr.push_back("MCSL");
01280         cstrCfgArr.push_back("MCSH");
01281         cstrCfgArr.push_back("MCST");
01282         cstrCfgArr.push_back("AUO2");
01283         cstrCfgArr.push_back("TPMO");
01284         cstrCfgArr.push_back("GPED");
01285         cstrCfgArr.push_back("GPIN");
01286         cstrCfgArr.push_back("GPME");
01287         cstrCfgArr.push_back("GPGA");
01288         cstrCfgArr.push_back("GPMC");
01289         cstrCfgArr.push_back("MCAE");
01290         cstrCfgArr.push_back("VOLU");
01291         cstrCfgArr.push_back("CON1");
01292         cstrCfgArr.push_back("CON2");
01293         cstrCfgArr.push_back("BOOT");
01294         return cstrCfgArr;
01295 }
01296
01297 string CvcDP5Dlg::GetCmdDesc(string strCmd)
01298 {
01299         string strCmdName = "";
01300         if (strCmd == "RESC") {
01301                 strCmdName = "Reset Configuration";
01302         } else if (strCmd == "CLCK") {
01303                 strCmdName = "20MHz/80MHz";
01304         } else if (strCmd == "TPEA") {
01305                 strCmdName = "peaking time";
01306         } else if (strCmd == "GAIF") {
01307                 strCmdName = "Fine gain";
01308         } else if (strCmd == "GAIN") {
01309                 strCmdName = "Total Gain (analog * fine)";
01310         } else if (strCmd == "RESL") {
01311                 strCmdName = "Detector Reset lockout";
01312         } else if (strCmd == "TFLA") {
01313                 strCmdName = "Flat top";
01314         } else if (strCmd == "TPFA") {
01315                 strCmdName = "Fast channel peaking time";
01316         } else if (strCmd == "RTDE") {
01317                 strCmdName = "RTD on/off";
01318         } else if (strCmd == "MCAS") {
01319                 strCmdName = "MCA Source";
01320         } else if (strCmd == "RTDD") {
01321                 strCmdName = "Custom RTD oneshot delay";
01322         } else if (strCmd == "RTDW") {
01323                 strCmdName = "Custom RTD oneshot width";
01324         } else if (strCmd == "PURE") {
01325                 strCmdName = "PUR interval on/off";
01326         } else if (strCmd == "SOFF") {
01327                 strCmdName = "Set spectrum offset";
01328         } else if (strCmd == "INOF") {
01329                 strCmdName = "Input offset";
01330         } else if (strCmd == "ACKE") {
01331                 strCmdName = "ACK / Don't ACK packets with errors";
01332         } else if (strCmd == "AINP") {
01333                 strCmdName = "Analog input pos/neg";
01334         } else if (strCmd == "AUO1") {
01335                 strCmdName = "AUX_OUT selection";
01336         } else if (strCmd == "AUO2") {
01337                 strCmdName = "AUX_OUT2 selection";
01338         } else if (strCmd == "BLRD") {
01339                 strCmdName = "BLR down correction";
01340         } else if (strCmd == "BLRM") {
01341                 strCmdName = "BLR mode";
01342         } else if (strCmd == "BLRU") {
01343                 strCmdName = "BLR up correction";
01344         } else if (strCmd == "BOOT") {
01345                 strCmdName = "Turn supplies on/off at power up";
01346         } else if (strCmd == "CUSP") {
01347                 strCmdName = "Non-trapezoidal shaping";
01348         } else if (strCmd == "DACF") {
01349                 strCmdName = "DAC offset";
01350         } else if (strCmd == "DACO") {
01351                 strCmdName = "DAC output";
01352         } else if (strCmd == "GAIA") {
01353                 strCmdName = "Analog gain index";
01354         } else if (strCmd == "GATE") {
01355                 strCmdName = "Gate control";
01356         } else if (strCmd == "GPED") {
01357                 strCmdName = "G.P. counter edge";
01358         } else if (strCmd == "GPGA") {
01359                 strCmdName = "G.P. counter uses GATE?";
01360         } else if (strCmd == "GPIN") {
01361                 strCmdName = "G.P. counter input";
01362         } else if (strCmd == "GPMC") {
01363                 strCmdName = "G.P. counter cleared with MCA counters?";
01364         } else if (strCmd == "GPME") {
01365                 strCmdName = "G.P. counter uses MCA_EN?";
01366         } else if (strCmd == "HVSE") {
01367                 strCmdName = "HV set";
01368         } else if (strCmd == "MCAC") {
01369                 strCmdName = "MCA/MCS channels";
01370         } else if (strCmd == "MCAE") {
01371                 strCmdName = "MCA/MCS enable";
01372         } else if (strCmd == "MCSL") {
01373                 strCmdName = "MCS low threshold";
01374         } else if (strCmd == "MCSH") {
01375                 strCmdName = "MCS high threshold";
01376         } else if (strCmd == "MCST") {
01377                 strCmdName = "MCS timebase";
01378         } else if (strCmd == "PAPS") {
01379                 strCmdName = "preamp 8.5/5 (N/A)";
01380         } else if (strCmd == "PAPZ") {
01381                 strCmdName = "Pole-Zero";
01382         } else if (strCmd == "PDMD") {
01383                 strCmdName = "Peak detect mode (min/max)";
01384         } else if (strCmd == "PRCL") {
01385                 strCmdName = "Preset counts low threshold";
01386         } else if (strCmd == "PRCH") {
01387                 strCmdName = "Preset counts high threshold";
01388         } else if (strCmd == "PREC") {
01389                 strCmdName = "Preset counts";
01390         } else if (strCmd == "PRER") {
01391                 strCmdName = "Preset Real Time";
01392         } else if (strCmd == "PRET") {
01393                 strCmdName = "Preset time";
01394         } else if (strCmd == "RTDS") {
01395                 strCmdName = "RTD sensitivity";
01396         } else if (strCmd == "RTDT") {
01397                 strCmdName = "RTD threshold";
01398         } else if (strCmd == "SCAH") {
01399                 strCmdName = "SCAx high threshold";
01400         } else if (strCmd == "SCAI") {
01401                 strCmdName = "SCA index";
01402         } else if (strCmd == "SCAL") {
01403                 strCmdName = "SCAx low theshold";
01404         } else if (strCmd == "SCAO") {
01405                 strCmdName = "SCAx output (SCA1-8 only)";
01406         } else if (strCmd == "SCAW") {
01407                 strCmdName = "SCA pulse width (not indexed - SCA1-8)";
01408         } else if (strCmd == "SCOE") {
01409                 strCmdName = "Scope trigger edge";
01410         } else if (strCmd == "SCOG") {
01411                 strCmdName = "Digital scope gain";
01412         } else if (strCmd == "SCOT") {
01413                 strCmdName = "Scope trigger position";
01414         } else if (strCmd == "TECS") {
01415                 strCmdName = "TEC set";
01416         } else if (strCmd == "THFA") {
01417                 strCmdName = "Fast threshold";
01418         } else if (strCmd == "THSL") {
01419                 strCmdName = "Slow threshold";
01420         } else if (strCmd == "TLLD") {
01421                 strCmdName = "LLD threshold";
01422         } else if (strCmd == "TPMO") {
01423                 strCmdName = "Test pulser on/off";
01424         } else if (strCmd == "VOLU") {
01425                 strCmdName = "Speaker On/Off";
01426         } else if (strCmd == "CON1") {
01427                 strCmdName = "Connector 1";
01428         } else if (strCmd == "CON2") {
01429                 strCmdName = "Connector 2";
01430         }
01431         return strCmdName;
01432 }
01433
01434 void CvcDP5Dlg::CopyDp5CfgToClip(string strCfg, string strDesc)
01435 {
01436         string strConfig;
01437         strConfig = "[DP5 Configuration File]\r\n" + strCfg + "\r\n" + "\r\n" + strDesc;
01438         AfxGetApp()->m_pMainWnd->OpenClipboard() ;
01439         EmptyClipboard();
01440         CSharedFile     sf(GMEM_MOVEABLE|GMEM_DDESHARE|GMEM_ZEROINIT);
01441         sf.Write(strConfig.c_str(), (unsigned int)strConfig.length());
01442         HGLOBAL hMem = sf.Detach();
01443         if (!hMem) return;
01444         SetClipboardData(CF_TEXT, hMem);
01445         CloseClipboard();
01446 }
01447
01448 void CvcDP5Dlg::OnBnClickedButtonShowConfig()
01449 {
01450         if (isDppConnected ) {
01451                 DisplayCfg = TRUE;
01452                 SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
01453         }
01454 }
01455
01456 //      ON_BN_CLICKED(IDC_BUTTON_READ_CONFIG, OnBnClickedButtonReadConfig)
01457 // GetDlgItem(IDC_BUTTON_READ_CONFIG)->EnableWindow(bEnable);
01458 // #define IDC_BUTTON_READ_CONFIG          1921
01459 //     PUSHBUTTON      "Open Configuration File",IDC_BUTTON_READ_CONFIG,19,78,117,14
01460
01461 void CvcDP5Dlg::SendConfigFromFileToDpp()
01462 {
01463         CFileBrowse BR;
01464         CAsciiCmdUtilities AsciiCmdUtil;        //ASCII command utility library
01465         CString cstrDfltExt("txt");
01466         CString cstrFilename("");
01467         string strFilename("");
01468         std::string strCfg("");
01469         BOOL isFileOk=FALSE;
01470         isFileOk = BR.DoModal(BR.OPEN,"Open Configuration",BR.CfgFileFilter,cstrDfltExt,_T(""),&cstrFilename);
01471         if (isFileOk) {
01472                 strFilename = cstrFilename;
01473                 strCfg = AsciiCmdUtil.GetDP5CfgStr(strFilename);
01474         }
01475 }
01476
01477 void CvcDP5Dlg::ButtonSendStringCfgToHardware(CString strCfgIn)
01478 {
01479         CMSecTimer tmr;
01480         CString strCfgMFC("");
01481         std::string strCfg("");
01482         bool isPC5Present=false;                        //Needed to remove pc5 commands
01483         int DppType=0;                                          //Needed to remove
01484         CAsciiCmdUtilities AsciiCmdUtil;        //ASCII command utility library
01485         long lCfgLen=0;                                         //ASCII Configuration Command String Length
01486         int idxSplitCfg=0;                                      //Configuration split position, only if necessary
01487         bool bSplitCfg=false;                           //Configuration split flag
01488         std::string strSplitCfg("");            //Configuration split string second buffer
01489         bool isDP5_RevDxGains;
01490         unsigned char DPP_ECO;
01491
01492         strCfgMFC = strCfgIn;
01493         DppType = DP5Stat.m_DP5_Status.DEVICE_ID;
01494         isPC5Present = DP5Stat.m_DP5_Status.PC5_PRESENT;
01495         isDP5_RevDxGains = DP5Stat.m_DP5_Status.isDP5_RevDxGains;
01496         DPP_ECO = DP5Stat.m_DP5_Status.DPP_ECO;
01497
01498         HwCfgReady = FALSE;
01499         HwCfgExReady = FALSE;
01500         HwCfgDP5Out = "";
01501         strCfg = strCfgMFC;
01502
01503         // Configuration Oversize Fix 20141224
01504         // The hardware cannot handle ASCII Configurations Larger than 512 Bytes
01505         // The original solution was to separately send the SCA Commands
01506         // Now the number of command excluding SCA command may exceed 512 Bytes
01507         // New methods of controlling the size of the cfg string are needed
01508
01509         //      1. Run the RemoveCmdByDeviceType here (is also in CSendCommand::WM_USER_SEND_CONFIG_TO_HW)
01510         //              --> RemoveCmdByDeviceType is done here to accurately measure size.
01511         //      2. Measure final ASCII cfg string size
01512
01513         strCfg = AsciiCmdUtil.RemoveCmdByDeviceType(strCfg, isPC5Present, DppType, isDP5_RevDxGains, DPP_ECO);
01514         lCfgLen = (long)strCfg.length();        //Test configuration size
01515
01516         //      3. If needed shorten cmds, ReMeasure final ASCII cfg string size
01517         if (lCfgLen > 512) {            //configuration is too large, try to reduce
01518         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "US;", ";");
01519         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "OFF;", "OF;");
01520         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "RISING;", "RI;");
01521         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "FALLING;", "FA;");
01522         lCfgLen = (long)strCfg.length();        //Test configuration size
01523                 //      4. If needed split cmd string, send cfg in two blocks
01524                 if (lCfgLen > 512) {    //configuration is still too large, split cfg
01525             bSplitCfg = true;
01526             idxSplitCfg = AsciiCmdUtil.GetCmdChunk(strCfg);
01527             strSplitCfg = strCfg.substr(idxSplitCfg);
01528                         strCfg = strCfg.substr(0, idxSplitCfg);
01529                 }
01530         }
01531
01532         strCfgMFC = strCfg.c_str();
01533         HwCfgDP5Out = strCfgMFC;
01534         if (HwCfgDP5Out.length() >0 ) {
01535                 HwCfgReady = TRUE;                      // filter out messages by device, gain, and option types
01536                 ::PostMessage(hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
01537         }
01538
01539         if (bSplitCfg) {
01540                 tmr.msTimer(500);
01541                 HwCfgReady = FALSE;
01542                 HwCfgExReady = FALSE;
01543                 strCfgMFC = strSplitCfg.c_str();
01544                 HwCfgDP5Out = strCfgMFC;
01545                 if (HwCfgDP5Out.length() >0 ) {
01546                         HwCfgReady = TRUE;                      // filter out messages by device, gain, and option types
01547                         ::PostMessage(hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
01548                 }
01549         }
01550
01551         //if (SCAEnabled) {
01552         //      tmr.msTimer(500);
01553         //      HwCfgReady = FALSE;
01554         //      HwCfgExReady = FALSE;
01555         //      HwCfgDP5Out = s.scafn.SCAStringALL(s.sca, TRUE);
01556         //      if (HwCfgDP5Out.GetLength() >0 ) {
01557         //              HwCfgExReady = TRUE;            // bypass command filters for scas
01558         //              ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
01559         //      }
01560         //}
01561 }
01562
01563 //-------------------------------------------------------------------
01564 // OnBnClickedPlotscaleradiolinear
01565 // Selects linear plot scale
01566 //-------------------------------------------------------------------
01567 void CvcDP5Dlg::OnBnClickedRadioPlotScaleLinear()
01568 {
01569         m_PicturePlot.OptScaleType = LINEAR_PLOT_SCALE;
01570         CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LINEAR);
01571         Profile.isScaleLog = FALSE;
01572 }
01573
01574 //-------------------------------------------------------------------
01575 // OnBnClickedPlotscaleradiolog
01576 // Selects log plot scale
01577 //-------------------------------------------------------------------
01578 void CvcDP5Dlg::OnBnClickedRadioPlotScaleLog()
01579 {
01580         m_PicturePlot.OptScaleType = LOG_PLOT_SCALE;
01581         CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LOG);
01582         Profile.isScaleLog = TRUE;
01583 }
01584
01585 //-------------------------------------------------------------------
01586 // OnBnClickedPlottyperadiosolid
01587 // Selects solid (bar) plot type
01588 //-------------------------------------------------------------------
01589 void CvcDP5Dlg::OnBnClickedRadioPlotTypeSolid()
01590 {
01591         m_PicturePlot.OptPlotType = SOLID_PLOT_TYPE;
01592         CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_SOLID);
01593         Profile.isPlotLine = FALSE;
01594 }
01595
01596 //-------------------------------------------------------------------
01597 // OnBnClickedPlottyperadioline
01598 // Selects line plot type
01599 //-------------------------------------------------------------------
01600 void CvcDP5Dlg::OnBnClickedRadioPlotTypeLine()
01601 {
01602         m_PicturePlot.OptPlotType = LINE_PLOT_TYPE;
01603         CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_LINE);
01604         Profile.isPlotLine = TRUE;
01605 }
01606
01607 // Saving spectrum file
01608 void CvcDP5Dlg::SaveTestSpectrumFile(int iFileIndex)
01609 {
01610         string strSpectrum;                                                                                     // holds final spectrum file
01611         SpectrumFileType sfInfo;
01612         string strFilename;
01613         string strIndex;
01614         stringex strfn; // = strfn.
01615         string sCurrentDir = AfxGetApp()->m_pszHelpFilePath;
01616         sCurrentDir = sCurrentDir.substr(0,sCurrentDir.find_last_of('\\'));
01617
01618         CfgReadBack = TRUE;
01619         DisplayCfg = FALSE;
01620         SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
01621         sfInfo.strSpectrumConfig = CreateSpectrumConfig(HwCfgDP5);      // append configuration comments
01622         sfInfo.strTag.reserve(20);
01623         GetDlgItemText(IDC_EDIT_TAG,(char*)sfInfo.strTag.c_str(),20);                                   // tag
01624         if (sfInfo.strTag.length() == 0) {
01625                 sfInfo.strTag = "TestTag";
01626         }
01627         sfInfo.strDescription.reserve(128);
01628         GetDlgItemText(IDC_EDIT_DESCRIPTION, (char*)sfInfo.strDescription.c_str(),128); // description
01629         if (sfInfo.strDescription.length() == 0) {
01630                 sfInfo.strDescription = "Amptek Spectrum File";
01631         }
01632         sfInfo.strStartTime.reserve(40);
01633         GetDlgItemText(IDC_EDIT_START_TIME, (char*)sfInfo.strStartTime.c_str(),40);
01634         // save last status after acquisition
01635         sfInfo.strSpectrumStatus = DP5Stat.ShowStatusValueStrings(DP5Stat.m_DP5_Status);
01636         sfInfo.m_iNumChan = DP5Proto.SPECTRUM.CHANNELS;                                         // number channels in spectrum
01637         sfInfo.SerialNumber = DP5Stat.m_DP5_Status.SerialNumber;        // dpp serial number
01638         // create spectrum file, save file to string
01639     strSpectrum = CreateMCAData(DP5Proto.SPECTRUM.DATA,sfInfo,DP5Stat.m_DP5_Status);
01640         strIndex = strfn.Format("%03d",iFileIndex);
01641         strFilename = sCurrentDir + "\\TestSpectrum_" + strIndex + ".mca";
01642         SaveMCAFile(strFilename, strSpectrum);          // save spectrum file string to file
01643 }
01644
01645 //    SaveSpectrum(SPECTRUM, STATUS, CommonDialog1)
01646 void CvcDP5Dlg::OnBnClickedButtonSaveFile()
01647 {
01648         CFileBrowse BR;
01649         CString strDfltExt;
01650         string strSpectrum;                                                                                     // holds final spectrum file
01651         SpectrumFileType sfInfo;
01652         CString strFilename;
01653
01654         CfgReadBack = TRUE;
01655         DisplayCfg = FALSE;
01656         SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
01657         sfInfo.strSpectrumConfig = CreateSpectrumConfig(HwCfgDP5);      // append configuration comments
01658     sfInfo.strTag.reserve(20);
01659         GetDlgItemText(IDC_EDIT_TAG, (char*)sfInfo.strTag.c_str(),20);                                  // tag
01660         if (sfInfo.strTag.length() == 0) {
01661                 sfInfo.strTag = "TestTag";
01662         }
01663         sfInfo.strDescription.reserve(128);
01664         GetDlgItemText(IDC_EDIT_DESCRIPTION, (char*)sfInfo.strDescription.c_str(),128); // description
01665         if (sfInfo.strDescription.length() == 0) {
01666                 sfInfo.strDescription = "Amptek Spectrum File";
01667         }
01668         sfInfo.strStartTime.reserve(64);
01669         GetDlgItemText(IDC_EDIT_START_TIME, (char*)sfInfo.strStartTime.c_str(),64);
01670         // save last status after acquisition
01671         sfInfo.strSpectrumStatus = DP5Stat.ShowStatusValueStrings(DP5Stat.m_DP5_Status);
01672         sfInfo.m_iNumChan = DP5Proto.SPECTRUM.CHANNELS;                                         // number channels in spectrum
01673         sfInfo.SerialNumber = DP5Stat.m_DP5_Status.SerialNumber;        // dpp serial number
01674         // create spectrum file, save file to string
01675     strSpectrum = CreateMCAData(DP5Proto.SPECTRUM.DATA,sfInfo,DP5Stat.m_DP5_Status);
01676
01677         if (strSpectrum.length() > 256) {
01678                 strDfltExt = _T("mca");
01679                 if (BR.DoModal(BR.SAVE,
01680                                 "Save Spectrum",
01681                                 BR.McaFileFilter,
01682                                 strDfltExt,
01683                                 _T(""),
01684                                 &strFilename)) {
01685
01686                         std::string stdstrFilename(strFilename, strFilename.GetLength());
01687
01688                         SaveMCAFile(stdstrFilename, strSpectrum);               // save spectrum file string to file
01689                 }
01690         }
01691 }
01692
01693 void CvcDP5Dlg::SaveMCAFile(string strFilename, string strMCA)
01694 {
01695         CFile cf(strFilename.c_str(), CFile::modeCreate | CFile::modeWrite);
01696         cf.Write(strMCA.c_str(), (unsigned int)strMCA.length());
01697         cf.Close();
01698 }
01699
01700 string CvcDP5Dlg::CreateMCAData(long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst)
01701 {
01702         string strMCA;
01703         string strText;
01704         string strADC;
01705         long idxChan;
01706         string strData;
01707         stringex strfn; // = strfn.
01708
01709         if (cfgStatusLst.SerialNumber <= 0)
01710         {
01711                 return ("");
01712         }
01713         strText = "";
01714         strMCA = "";
01715     switch(sfInfo.m_iNumChan){
01716         case 16384:
01717             strADC = "6";
01718                                 break;
01719         case 8192:
01720             strADC = "5";
01721                                 break;
01722         case 4096:
01723             strADC = "4";
01724                                 break;
01725         case 2048:
01726             strADC = "3";
01727                                 break;
01728         case 1024:
01729             strADC = "2";
01730                                 break;
01731         case 512:
01732             strADC = "1";
01733                                 break;
01734         case 256:
01735             strADC = "0";
01736                                 break;
01737     }
01738         strMCA += "<<PMCA SPECTRUM>>\r\n";
01739         strMCA += "TAG - " + sfInfo.strTag + "\r\n";
01740         strMCA += "DESCRIPTION - " + sfInfo.strDescription + "\r\n";
01741         strMCA += "GAIN - " + strADC + "\r\n";
01742         strMCA += "THRESHOLD - 0\r\n";
01743         strMCA += "LIVE_MODE - 0\r\n";
01744         strMCA += "PRESET_TIME - \r\n";
01745         strText = strfn.Format("%lf", cfgStatusLst.AccumulationTime);
01746         strMCA += "LIVE_TIME - " + strText + "\r\n";
01747         strText = strfn.Format("%lf", cfgStatusLst.RealTime);
01748         strMCA += "REAL_TIME - " + strText + "\r\n";
01749         strMCA += "START_TIME - \r\n";
01750         strText = strfn.Format("%i", sfInfo.SerialNumber);
01751         strMCA += "SERIAL_NUMBER - " + strText + "\r\n";
01752         strMCA += "<<DATA>>\r\n";
01753         for (idxChan=0;idxChan<sfInfo.m_iNumChan;idxChan++) {
01754                 strData = strfn.Format("%i", m_larDataBuffer[idxChan]);
01755                 strMCA += strData + "\r\n";
01756         }
01757         strMCA += "<<END>>\r\n";
01758         strMCA += "<<DP5 CONFIGURATION>>\r\n";
01759         strMCA += sfInfo.strSpectrumConfig;
01760         strMCA += "<<DP5 CONFIGURATION END>>\r\n";
01761         strMCA += "<<DPP STATUS>>\r\n";
01762         strMCA += sfInfo.strSpectrumStatus;     // this functin is included in most examples
01763         strMCA += "<<DPP STATUS END>>\r\n";
01764         return (strMCA);
01765 }
01766
01767 //-------------------------------------------------------------------
01768 // OnStnClickedPlotpicturecontrol
01769 // Moves cursor
01770 //-------------------------------------------------------------------
01771 void CvcDP5Dlg::OnStnClickedPlotpicturecontrol()
01772 {
01773         m_PicturePlot.SetCursorPosition(CursorPosition.x);
01774         //string strCursorPos;
01775         //strCursorPos.Format("%d,%d",CursorPosition.x,CursorPosition.y);
01776         //AfxMessageBox(strCursorPos);
01777         m_PicturePlot.DrawCursor();
01778 }
01779
01780 //-------------------------------------------------------------------
01781 // OnLButtonDown
01782 // Moves cursor
01783 //-------------------------------------------------------------------
01784 void CvcDP5Dlg::OnLButtonDown(UINT nFlags, CPoint point)
01785 {
01786         CursorPosition = point;
01787         stringex strfn; // = strfn.
01788
01789         //check if in picturebox rectangle (13,13)-(442,259)
01790         if (((CursorPosition.x > 12) && (CursorPosition.x < 443)) &&
01791                 ((CursorPosition.y > 12) && (CursorPosition.y < 260))) {
01792                 m_PicturePlot.SetCursorPosition(CursorPosition.x-14);   //14=sprite pointer offset
01793                 string strCursorPos;
01794                 strCursorPos = strfn.Format("%d,%d",CursorPosition.x,CursorPosition.y);
01795                 //GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strCursorPos);
01796                 m_PicturePlot.DrawCursor();
01797                 SetPlotChannel();
01798         }
01799         CDialog::OnLButtonDown(nFlags, point);
01800 }
01801
01802 BOOL CvcDP5Dlg::PreTranslateMessage(MSG* pMsg)
01803 {
01804         POINT pt;
01805         string strCursorPos;
01806         stringex strfn; // = strfn.
01807
01808         if (pMsg->message == WM_KEYDOWN) {
01809                 GetCursorPos(&pt);                      // Get the cursor position for a screen
01810                 ScreenToClient(&pt);            // Convert to  window co-ordinates
01811                 strCursorPos = strfn.Format("%d,%d",pt.x,pt.y);
01812                 //GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strCursorPos);
01813                 if (((pt.x > 12) && (pt.x < 443)) &&
01814                         ((pt.y > 12) && (pt.y < 260))) {
01815                         if(pMsg->message == WM_KEYDOWN){
01816                                 // DIRECTION
01817                                 if (pMsg->wParam == 37)        //left
01818                                 {
01819                                         CursorPosition.x--;
01820                                 }
01821                                 if (pMsg->wParam == 39)       //right
01822                                 {
01823                                         CursorPosition.x++;
01824                                 }
01825                         }
01826                         if (CursorPosition.x < 12) { CursorPosition.x = 12; }
01827                         if (CursorPosition.x > 443) { CursorPosition.x = 443; }
01828                         SetPlotChannel();
01829                         return TRUE;
01830                 }
01831         }
01832         return CDialog::PreTranslateMessage(pMsg);
01833 }
01834
01835 void CvcDP5Dlg::SetPlotChannel()
01836 {
01837         double m_xCursorData;   // Cursor position (channels)
01838         stringex strfn; // = strfn.
01839
01840         m_PicturePlot.SetCursorPosition(CursorPosition.x - 14); //14=sprite pointer offset
01841         m_PicturePlot.DrawCursor();
01842         CRect rect;
01843         m_PicturePlot.GetClientRect(&rect);
01844         int x_min = 0;
01845         int x_max = rect.Width();
01846         if (DP5Proto.SPECTRUM.CHANNELS < 256) { DP5Proto.SPECTRUM.CHANNELS = 1024; }
01847         double pixperchan = (double)DP5Proto.SPECTRUM.CHANNELS / (double)x_max;
01848         if ((CursorPosition.x - 14) < 0) { CursorPosition.x = 14; }
01849         if ((CursorPosition.x - 14) > x_max) { CursorPosition.x = x_max + 14; }
01850         m_xCursorData = (double)(CursorPosition.x - 14) * pixperchan;
01851         string strChan;
01852         int CurChan = (int)(m_xCursorData + 0.5);
01853         if (CurChan > DP5Proto.SPECTRUM.CHANNELS - 1) {
01854                 CurChan = DP5Proto.SPECTRUM.CHANNELS - 1;
01855         }
01856         CurrentChannel = CurChan;
01857         strChan = strfn.Format("Channel %d",CurChan);
01858         GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strChan.c_str());
01859 }
01860
01861 double CvcDP5Dlg::GetPixPerChannel()
01862 {
01863         CRect rect;
01864         m_PicturePlot.GetClientRect(&rect);
01865         int x_min = 0;
01866         int x_max = rect.Width();
01867         if (DP5Proto.SPECTRUM.CHANNELS < 256) { DP5Proto.SPECTRUM.CHANNELS = 1024; }
01868         double pixperchan = (double)DP5Proto.SPECTRUM.CHANNELS / (double)x_max;
01869         return pixperchan;
01870 }
01871
01872 void CvcDP5Dlg::OnBnClickedOk()
01873 {
01874         OnOK();
01875 }
01876
01877 void CvcDP5Dlg::OnBnClickedCancel()
01878 {
01879         OnCancel();
01880 }
01881
01882 //EnableToolTips();
01883 //ON_NOTIFY_EX_RANGE(TTN_NEEDTEXT, 0, 0xFFFF, OnToolTipNotify)
01884 //afx_msg BOOL OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult);
01885 BOOL CvcDP5Dlg::OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult)
01886 {
01887     TOOLTIPTEXT *pTTT = (TOOLTIPTEXT *)pNMHDR;
01888     UINT_PTR CtrlHandle = pNMHDR->idFrom;
01889     if (pTTT->uFlags & TTF_IDISHWND) {
01890         UINT_PTR nID = ::GetDlgCtrlID(HWND(CtrlHandle));
01891                 CWnd *p = CWnd::FromHandle(pNMHDR->hwndFrom);
01892                 p->SendMessage(TTM_SETMAXTIPWIDTH, 0, 300);
01893         switch(nID) {
01894         case IDC_BUTTON_SELECT_COMM:
01895             pTTT->lpszText = _T("Open Connect Dialog \r\nto select Amptek DPP device.");
01896             break;
01897         case IDC_RADIO_PLOT_TYPE_LINE:
01898             pTTT->lpszText = _T("Line Plot Type");
01899             break;
01900         default:
01901             //pTTT->lpszText = _T("Default Tooltip");
01902             break;
01903         }
01904         return TRUE;
01905         } else {
01906                 AfxMessageBox("!");
01907     }
01908     return FALSE;
01909 }
01910
01912 // Function:   TuneFastSlowThresh
01913 //      Calls CalcFastThresh and CalcSlowThresh usb functions
01914 // Arguments:
01915 //      none
01916 // Returns:
01917 //      Default
01919 void CvcDP5Dlg::TuneFastSlowThresh()
01920 {
01921
01922         if (! isDppConnected ) { return; }
01923
01924         CMSecTimer tmr;
01925
01926         // fast threshold vars
01927         DWORD MaxTime = 5000;           // max timeout for tuning
01928         int LoopCounter = 0;
01929
01930         // slow threshold vars
01931         bool WasInMCAMode = false;
01932         int SlowThreshCh = 0;
01933         double UpperChCounts = 0.0;
01934         double UpperChMax = 0.0;
01935         CTuneSlowThreshold TuneSlowThresh;
01936         int mcaCh;
01937         stringex strfn;
01938
01939         cWaitDialog dlg;
01940         dlg.m_Text = "Tuning...please wait";
01941         dlg.Show();
01942         tmr.msTimer(200);
01943         if (m_nTmrSpectrumId == 0) {            // acquire Status != ACQUIRING
01944                 dlg.Close();
01945                 tmr.msTimer(100);
01946                 AfxMessageBox("Please start an acquisition then remove the source before setting the thresholds.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
01947                 return;
01948         }
01949
01950         // Status byte 23, D6=0 -> auto fast threshold not locked; =1 -> locked
01951         DP5Stat.m_DP5_Status.AFAST_LOCKED = FALSE;      // reset flag before call
01952         SendCommand(XMTPT_AUTOSET_FAST_THRESHOLD); // call tune fast thresh
01953         tmr.msTimer(50);
01954     MaxTime += GetCurrentTime();                        // monitor flag until done or timeout
01955     while ((GetCurrentTime() < MaxTime) && (!DP5Stat.m_DP5_Status.AFAST_LOCKED))
01956     {
01957                 tmr.msTimer(100);
01958                 LoopCounter++;
01959                 if (LoopCounter > 5) {
01960                         LoopCounter = 0;
01961                         SendCommand(XMTPT_SEND_STATUS);
01962                 }
01963         }
01964         if (!DP5Stat.m_DP5_Status.AFAST_LOCKED) {
01965                 dlg.Close();
01966                 AfxMessageBox("Tune fast threshold error.\nPlease remove source if present.\nSet thresholds manually if out of auto tuning range.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
01967                 return;
01968         }
01969         ::SendMessage(hWnd_Main,WM_USER_READ_DPP_CONFIG,0L,0L);
01970         tmr.msTimer(200);
01971         tmr.msTimer(200);
01972         if (! isDeltaMode) { // check delta mode, if not in delta, set to delta
01973                 WasInMCAMode = true;
01974                 isDeltaMode = (! isDeltaMode);
01975                 TuneSlowThresh.DelayTask(1000);                 // 1 second to convert to delta mode
01976         }
01977         mcaCh = (int)DP5Proto.SPECTRUM.CHANNELS;
01978         double FSReal;
01979         FSReal = TuneSlowThresh.SetSlowThreshToChPos(0, mcaCh); // set slow thresh to 0
01980         if (isDppConnected) {
01981                 HwCfgDP5Out = strfn.Format("THSL=%.2f;",(FSReal * 100.0));
01982                 HwCfgReady = TRUE;
01983                 ::PostMessage(hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
01984         }
01985         TuneSlowThresh.DelayTask(1200); // wait 1 sec to settle
01986         HGLOBAL hGlobal;
01987         double *SpectrumBuffer;
01988         hGlobal = GlobalAlloc( GPTR, 16384 * sizeof(double) );
01989         if (!hGlobal) {
01990                 dlg.Close();
01991                 tmr.msTimer(100);
01992                 AfxMessageBox("Tune slow threshold error.\nMemory allocation error.\nPlease try again.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
01993                 return;
01994         }
01995         SpectrumBuffer = (double *)GlobalLock( hGlobal );                                       // allocate spectrum buffer
01996         TuneSlowThresh.GetSpectrumData(SpectrumBuffer, DP5Proto.SPECTRUM.DATA, mcaCh);
01997         UpperChCounts = TuneSlowThresh.GetUpperChCounts(SpectrumBuffer, mcaCh); // this can be used ave noise
01998         UpperChMax = TuneSlowThresh.GetUpperChMax(SpectrumBuffer, mcaCh);                       // this is the max noise
01999         SlowThreshCh = TuneSlowThresh.GetSlowThreshCalStart(SpectrumBuffer, UpperChMax, mcaCh);
02000
02001         double dblPixPerChan = GetPixPerChannel();
02002         int CurPos = TuneSlowThresh.UpdatePlotCursorPosFromIntChPos(SlowThreshCh, dblPixPerChan);
02003         m_PicturePlot.SetCursorPosition(CurPos);
02004         m_PicturePlot.DrawCursor();
02005         FSReal = TuneSlowThresh.SetSlowThreshToChPos(SlowThreshCh, mcaCh);                      // set the calculated setting
02006         if (isDppConnected) {
02007                 HwCfgDP5Out = strfn.Format("THSL=%.2f;",(FSReal * 100.0));
02008                 HwCfgReady = TRUE;
02009                 ::PostMessage(hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
02010         }
02011         GlobalUnlock( hGlobal );
02012         GlobalFree( hGlobal );
02013         if (WasInMCAMode) { // set old delta mode, if in mca, set to delta to false
02014                 isDeltaMode = false;
02015         }
02016         dlg.Close();
02017         tmr.msTimer(200);
02018         OnBnClickedButtonClearDataAndGraph();
02019 }
02020
02021 void CvcDP5Dlg::OnBnClickedButtonAutotune()
02022 {
02023
02024         DisplayCfg = FALSE;
02025         TuneFastSlowThresh();
02026 }
02027
02028 //CTime theTime = CTime::GetCurrentTime();
02029 //string strTime = theTime.Format( "%m/%d/%Y %H:%M:%S" );
02030 //StartTime = strTime;
02031
02032 //#include <time.h>
02033 string CvcDP5Dlg::CreateDTS(string strFormat)
02034 {
02035         //string strFormat("_%Y%m%d_%H%M%S");           // for append filename dts
02036         //string strFormat("%m/%d/%Y %H:%M:%S");   // for spectrum dts
02037         char buffer[256];
02038         time_t rawtime;
02039         struct tm * timeinfo;
02040         string str("");
02041         stringex strfn;
02042
02043         time (&rawtime);
02044         timeinfo = localtime (&rawtime);
02045         strftime(buffer, sizeof(buffer), strFormat.c_str(), timeinfo);
02046         str = strfn.Format("%s",buffer);
02047         return str;
02048 }
02049
02050 void CvcDP5Dlg::OnBnClickedCheckRepeatSpectrum()
02051 {
02052         if (IsDlgButtonChecked(IDC_CHECK_REPEAT_SPECTRUM)) {
02053                 GetDlgItem(IDC_BUTTON_START_ACQUISITION)->SetWindowText("Repeat Spectrum");
02054         } else {
02055                 GetDlgItem(IDC_BUTTON_START_ACQUISITION)->SetWindowText("Start Acquisition");
02056                 ShowRepeatStatus(false);
02057         }
02058 }
02059
02061 // ParsePerformanceNotes formats a test string into an Additional Note
02063 CString CvcDP5Dlg::ParsePerformanceNotes(CString str)
02064 {
02065         int iStart,iHvBias,iEnd;
02066         CString strNote("");
02067         iStart = 0;
02068         iHvBias = 0;
02069         iEnd = 0;
02070         //Test the prefix + first four characters
02071         iStart = str.Find("<not>T = ",0);                               // test for the first line
02072         if (iStart == -1) {
02073                 iStart = str.Find("<not>Ampt",0);                       // test for the last line
02074                 if (iStart == 0) {                                                      // the line starts at 0
02075                         strNote = str.Mid(0, 34) + "\r\n";
02076                         if (strNote.GetLength() == 36) {                // found detector part number
02077                                 return (strNote);
02078                         }
02079                 }
02080         } else {
02081                 if (iStart == 0) {                                                      // the line starts at 0
02082                         iHvBias = str.Find("HV Bias:",0);               // test for the first line
02083                         if (iHvBias > -1) {                                             // the line end test starts at iHvBias
02084                                 iEnd = str.Find(",",iHvBias);                           // test for the end of line
02085                                 if (iEnd > -1) {
02086                                         strNote = str.Mid(0,iEnd+1) + " \r\n";
02087                                         return (strNote);
02088                                 }
02089                         }
02090                 }
02091         }
02092         if (iStart == -1) { return (""); }                      // string not found
02093         return ("");    // string found with parse error
02094 }
02095
02097 // TextToBlockString(CString &str, char *prefix)
02098 // -------------------------------------------------------------------
02099 // Formats Additional Notes Line into TextBlock String
02100 // -------------------------------------------------------------------
02101 // Similar function to SaveMultiString(ar, m_attr.notesNotes, "<not>");
02103 CString CvcDP5Dlg::TextToBlockString(CString &str, char *prefix)
02104 {
02105         int pos;
02106         int length;
02107         int endPos;
02108         CString out;
02109         CString TextBlock;
02110         endPos = (int)strlen(str);
02111         out = "";
02112         TextBlock = "";
02113         for (pos = 0 ; pos < endPos; )
02114         {
02115                 length = str.Mid(pos).Find("\r");
02116                 if (length == -1) length = endPos - pos;
02117                 out = prefix + str.Mid(pos, length) + "\r\n";
02118                 if (prefix == "<not>") {
02119                         out = ParsePerformanceNotes(out);
02120                 }
02121                 TextBlock += out;
02122                 out = "";
02123                 pos += length + 2;
02124         }
02125         return (TextBlock);
02126 }
02127
02129 // Parses TextBlock Additional Manufacturing Notes from DPP
02131 void CvcDP5Dlg::ParseTextBlockNotes(CString strTextBlock)
02132 {
02133         CString strNote;
02134         CStringArray strNotes;
02135         int idxNote = 0;
02136         CString strDisplay;
02137         strDisplay = "";
02138         // last argument is the delimitter
02139         //while (AfxExtractSubString(strNote,strTextBlock,idxNote,_T('\n')))
02140         CString generalNotes("");                       // "<gen>"
02141         CString systemNotes("");                        // "<sys>"
02142         CString notesNotes("");                         // "<not>"
02143
02144         while (ExtractNote(strNote,strTextBlock,idxNote,_T('\n')))
02145         {
02146                 if (strNote.GetLength() > 3) {
02147                         if (strNote.Find("<gen>") == 0) {
02148                                 generalNotes += strNote.Mid(5);
02149                         } else if (strNote.Find("<sys>") == 0) {
02150                                 systemNotes += strNote.Mid(5);
02151                         } else if (strNote.Find("<not>") == 0) {
02152                                 notesNotes += strNote.Mid(5);
02153                         }
02154                         strNotes.Add(strNote);
02155                         //AfxMessageBox(strNote);
02156                 }
02157                 ++idxNote;
02158         }
02159
02160    for (int i = 0; i <= strNotes.GetUpperBound(); i++)
02161       strDisplay += strNotes[i]+"\n";
02162    //CopyTextToClip(strDisplay);
02163    int iPos = 0;
02164    int lCount = 0 ;
02165    for (idxNote = 0; idxNote <= strDisplay.GetLength(); idxNote++) {
02166                 iPos = strDisplay.Find("\n",iPos + 1);
02167                 if (iPos >= 0) {
02168                         lCount +=1;
02169                 } else {
02170                         break;
02171                 }
02172    }
02173         strNote.Format("%d",lCount);
02174         //AfxMessageBox(strNote);
02175         //AfxMessageBox(strDisplay);
02176
02177 }
02178
02180 // Reads/Extracts One Additional Note Text Line from text block of Additional Notes
02182 BOOL CvcDP5Dlg::ExtractNote(CString& rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep)
02183 {
02184         if (lpszFullString == NULL)
02185                 return FALSE;
02186
02187         while (iSubString--)
02188         {
02189                 lpszFullString = _tcschr(lpszFullString, chSep);
02190                 if (lpszFullString == NULL)
02191                 {
02192                         rString.Empty();        // return empty string as well
02193                         return FALSE;
02194                 }
02195                 lpszFullString++;       // point past the separator
02196         }
02197         LPCTSTR lpchEnd = _tcschr(lpszFullString, chSep);
02198         int nLen = (lpchEnd == NULL) ?
02199                 lstrlen(lpszFullString) : (int)(lpchEnd - lpszFullString);
02200         ASSERT(nLen >= 0);
02201         memcpy(rString.GetBufferSetLength(nLen), lpszFullString, nLen*sizeof(TCHAR));
02202         rString.ReleaseBuffer();        // Need to call ReleaseBuffer
02203                                                                 // after calling GetBufferSetLength
02204         return TRUE;
02205 }
02206
02208 // Copies Text to clipboard -- not needed for TextBlock -- testing only
02210 void CvcDP5Dlg::CopyTextToClip(CString strTextIn)
02211 {
02212         CString strText;
02213         strText = strTextIn;
02214         AfxGetApp()->m_pMainWnd->OpenClipboard() ;
02215         EmptyClipboard();
02216         CSharedFile     sf(GMEM_MOVEABLE|GMEM_DDESHARE|GMEM_ZEROINIT);
02217         sf.Write(strText, strText.GetLength());
02218         HGLOBAL hMem = sf.Detach();
02219         if (!hMem) return;
02220         SetClipboardData(CF_TEXT, hMem);
02221         CloseClipboard();
02222 }
02223
02224 //<gen>X-123 S/N: X014487, AXRCR S/N: 158334
02225 //<not>T = 240.0 Degrees K, FWHM@5894.960keV:234.779keV, Tested with 6.4uS Peak Time, HV Bias: 180.0 Volts,
02226 //<not>Amptek Code # ZY-FS43AMD-G3SP
02227 CString CvcDP5Dlg::CreateTextBlockTest()
02228 {
02229         CString strGeneral;
02230         CString strNotes;
02231         CString strTextBlock;
02232         strGeneral = "X-123 S/N: X014487, AXRCR S/N: 158334\r\n";
02233         strTextBlock += TextToBlockString(strGeneral, "<gen>");
02234         strNotes = "T = 240.0 Degrees K, FWHM@5894.960keV:234.779keV, Tested with 6.4uS Peak Time, HV Bias: 180.0 Volts, \r\n";
02235         strNotes += "Amptek Code # ZY-FS43AMD-G3SP\r\n";
02236         strTextBlock += TextToBlockString(strNotes, "<not>");
02237         //AfxMessageBox(strTextBlock);
02238         return (strTextBlock);
02239 }
02240
02241 // strLowerTextBlock bytes 0-255
02242 // strInfoTextBlock bytes 256-511
02243 void CvcDP5Dlg::SendDppInfoTextBlock(CString strLowerTextBlock, CString strInfoTextBlock)
02244 {
02245         BYTE byteMiscData[512];
02246         int idxCh;
02247         int DataLen;
02248
02249         //GetDlgItem(IDC_EDIT_MISC_DATA)->GetWindowText(strMiscData);
02250         DataLen = strLowerTextBlock.GetLength();
02251         for(idxCh=0;idxCh<256;idxCh++) {
02252                 if (idxCh < DataLen) {
02253                         byteMiscData[idxCh] = (BYTE)strLowerTextBlock.GetAt(idxCh);
02254                 } else {
02255                         byteMiscData[idxCh] = 0;
02256                 }
02257         }
02258         DataLen = strInfoTextBlock.GetLength();
02259         for(idxCh=0;(idxCh+256)<512;idxCh++) {
02260                 if (idxCh < DataLen) {
02261                         byteMiscData[idxCh+256] = (BYTE)strInfoTextBlock.GetAt(idxCh);
02262                 } else {
02263                         byteMiscData[idxCh+256] = 0;
02264                 }
02265         }
02266     SendCommandData(XMTPT_WRITE_512_BYTE_MISC_DATA, byteMiscData);
02267 }
02268
02269 void CvcDP5Dlg::WriteTextBlock()
02270 {
02271         CString strInfoTextBlock("");
02272         strInfoTextBlock = CreateTextBlockTest();
02273
02274         // get lower text block
02275         CString strLowerTextBlock("PX5 ATE Test");
02276         SendDppInfoTextBlock(strLowerTextBlock, strInfoTextBlock);
02277
02282
02293 }
02294
02296 // Functions to be completed
02298 // when writing the text block in the future
02299 // 1. Read the Whole Text Block
02300 // 2. Overwrite/edit the lower half (256 bytes) only
02301 // 3. Save the upper half as is
02302 // when reading the user text block
02303 // 1. Read the Whole Text Block
02304 // 2. Only display/edit the lower half (256 bytes) only
02305 // 3. Save the upper half as is
02306 // when reading the manufacturing test information
02307 // 1. Read the Whole Text Block
02308 // 2. Only read the upper half of the buffer
02309 // 3. The upper half is only edited during manufacturing test
02311
02312
02314 // Send Manufacturing Text Block Test
02315 // ----------------------------------
02316 // 20150928 TextBlock
02317 // Test DPP Notes Here for Text Block Save
02318 // if (General Notes (generalNotes) -> ((X-123 S/N: or PX5 S/N: or PC5 S/N:)
02319 //              AND have performance notes (notesNotes)
02320 // parse notesNotes
02321 //              save generalNotes and parsed notesNotes
02322 //              save data to text block
02324 bool CvcDP5Dlg::SendManufacturingTextBlock(CString generalNotes)
02325 {
02326         int iPX5=-1;                    //px5
02327         int iX123=-1;                   //x123
02328         int iPC5=-1;                    //dp5 with pc5
02329         CString strPX5("PX5 S/N:");             //px5
02330         CString strX123("X-123 S/N:");  //x123
02331         CString strPC5("PC5 S/N:");             //dp5 with pc5
02332         bool bSendBlock=false;
02333
02334         iPX5 = generalNotes.Find(strPX5,0);
02335         iX123 = generalNotes.Find(strX123,0);
02336         iPC5 = generalNotes.Find(strPC5,0);
02337         if ((iPX5 >= 0) || (iX123 >= 0) || (iPC5 >= 0)) {
02338                 bSendBlock = true;
02339         }
02340         return bSendBlock;
02341 }
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1


vcDP5_USB_Repeat Test C++ SDK: vcDP5Dlg.h Source File

vcDP5Dlg.h
Go to the documentation of this file.
00001 // vcDP5Dlg.h : header file
00002 //
00003
00004 #pragma once
00005 #include "stdafx.h"
00006 #include "afxwin.h"
00007 #include "Resource.h"
00008 #include "ParsePacket.h"
00009 #include "Label.h"
00010 #include "PlotCanvas.h"
00011 #include "DP5Status.h"
00012 #include "stringex.h"
00013 #include "WinusbNotify.h"
00014
00015 #define LINEAR_PLOT_SCALE 0
00016 #define LOG_PLOT_SCALE 1
00017 #define SOLID_PLOT_TYPE 0
00018 #define LINE_PLOT_TYPE 1
00019
00020 typedef struct _SpectrumFileType {
00021     string strTag;
00022     string strDescription;
00023     short m_iNumChan;
00024         unsigned long SerialNumber;
00025         string strStartTime;
00026         string strSpectrumConfig;
00027         string strSpectrumStatus;
00028 } SpectrumFileType;
00029
00030 // CvcDP5Dlg dialog
00031 class CvcDP5Dlg : public CDialog
00032 {
00033 // Construction
00034 public:
00035         CvcDP5Dlg(CWnd* pParent = NULL);        // standard constructor
00036         ~CvcDP5Dlg();
00037
00038 // Dialog Data
00039         enum { IDD = IDD_vcDP5_DIALOG };
00040
00041         protected:
00042         virtual void DoDataExchange(CDataExchange* pDX);        // DDX/DDV support
00043
00044
00045 // Implementation
00046 protected:
00047         HICON m_hIcon;
00048
00049         // Generated message map functions
00050         virtual BOOL OnInitDialog();
00051         afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
00052         afx_msg void OnPaint();
00053         afx_msg HCURSOR OnQueryDragIcon();
00054         DECLARE_MESSAGE_MAP()
00055 public:
00056         bool BOOL_TO_bool(BOOL bValue);
00057         afx_msg void OnBnClickedButtonFindDevice();
00058         afx_msg BOOL OnDeviceChange(UINT nEventType, DWORD_PTR dwData);
00059         afx_msg void OnDestroy();
00060
00061         ULONG DataTest();
00062         void SetCheckButtonState(int iCheckBox, bool bChecked);
00063         afx_msg void OnTimer(UINT nIDEvent);
00064         afx_msg void OnBnClickedButtonArmTrigger();
00065         void SaveTestSpectrumFile(int iFileIndex);
00066         afx_msg void OnBnClickedButtonSaveFile();
00067         afx_msg void OnBnClickedButtonClearDataAndGraph();
00068         afx_msg void OnBnClickedButtonSingleUpdate();
00069         afx_msg void OnBnClickedButtonClearMiscData();
00070         afx_msg void OnBnClickedButtonReadMiscData();
00071         afx_msg void OnBnClickedButtonWriteMiscData();
00072         void ShowStatus(string strStatus);
00073
00074         void ParsePacketEx(Packet_In PIN, DppStateType DppState);
00075         void ProcessDiagDataEx(Packet_In PIN, DppStateType DppState);
00076         void ProcessStatusEx(Packet_In PIN, DppStateType DppState);
00077         void ProcessSpectrumEx(Packet_In PIN, DppStateType DppState);
00078         void ProcessScopeDataEx(Packet_In PIN, DppStateType DppState);
00079         void ProcessTextDataEx(Packet_In PIN, DppStateType DppState);
00080         void ProcessAck(BYTE PID2);
00081         void DisplayError(Packet_In PIN, DppStateType DppState);
00082         void RequestScopeData(BOOL ScopeDataReady);
00083         void SendCommand(TRANSMIT_PACKET_TYPE XmtCmd);
00084         void SendCommandConfig(TRANSMIT_PACKET_TYPE XmtCmd);
00085         string CreateSpectrumConfig(string strRawCfgIn);
00086         void SendCommandData(TRANSMIT_PACKET_TYPE XmtCmd, BYTE DataOut[]);
00087         void RemCallParsePacket(BYTE PacketIn[]);
00088
00089         // Communications Timers
00090         // RS232 100ms Timer 1
00091         UINT_PTR m_nTmrRS232Id;                 // return SetTimer Return Value (0=false,TimerID if OK)
00092         UINT_PTR m_nTmrRS232EventId;            // Timer Event Identifier
00093         UINT m_nTmrRS232Elapse;         // Timeout value in milliseconds
00094
00095         // AutoSpectrum 1000ms Timer 2
00096         UINT_PTR m_nTmrSpectrumId;                      // return SetTimer Return Value (0=false,TimerID if OK)
00097         UINT_PTR m_nTmrSpectrumEventId;         // Timer Event Identifier
00098         UINT m_nTmrSpectrumElapse;              // Timeout value in milliseconds
00099
00100         // General Purpose Event Timeout Flag 10ms Timer 3
00101         UINT_PTR m_nTmrTimeoutId;                       // return SetTimer Return Value (0=false,TimerID if OK)
00102         UINT_PTR m_nTmrTimeoutEventId;          // Timer Event Identifier
00103         UINT m_nTmrTimeoutElapse;               // Timeout value in milliseconds
00104         BOOL TimeoutFlag;
00105
00106         //CStatic m_PicturePlot;                // plot display
00107         CPlotCanvas m_PicturePlot;              // plot display
00108
00109         void PlotData(long DataBuffer[8192], int NumChan);      // calculates plot data
00110         void UpdatePlot();                                                                      // draws plot display
00111         long PlotBuffer[8192];  // holds plot data
00112         char szSettings[3000];  // holds settings for mca plot
00113         long XPlotMAX;
00114         long YPlotMAX;
00115
00116         BOOL HavePlot;
00117
00118         CStatic m_PictureScope;                                         // plot display
00119         void ScopeDisplay(BYTE ScopeData[2048]);        // calculates plot data
00120         void UpdateScope();                                                                     // draws plot display
00121         BYTE ScopeBuffer[2048]; // holds plot data
00122         BOOL HaveTrace;
00123
00124         void EnableDPPFunctions(BOOL isEnabled);
00125         afx_msg void OnBnClickedButtonDiag();
00126
00127         //void OnReceive(int nErrorCode);       //Sockets Comm
00128         afx_msg LONG OnReceive(UINT, LONG);
00129
00130         afx_msg void OnBnClickedButtonSelectComm();
00131         CLabel lblSelectCommunications; //CStatic
00132         CLabel lblStatus; //CStatic IDC_STATIC_STATUS
00133         CLabel lblMiscStatus; //CStatic IDC_STATIC_MISC_STATUS
00134         void OnResetCommunications();
00135         afx_msg void OnBnClickedButtonGetSpectrum();
00136         void ShowRepeatStatus(bool bShowStatus);
00137         afx_msg void OnBnClickedButtonStartAcquisition();
00138         afx_msg void OnBnClickedButtonStopAcquisition();
00139
00140         string GetDeviceNameFromVal(int DeviceTypeVal);
00141         BOOL isConnectedTest();
00142         afx_msg LRESULT DppSendConfigToHw(WPARAM wParam, LPARAM lParam);
00143         void ProcessCfgReadEx(Packet_In PIN, DppStateType DppState);
00144
00145         //==== Configuration
00146         //==============================================================
00147         string GetCmdData(string strCmd, string strCfgData);
00148         string GetCmdDesc(string strCmd);
00149         string ReplaceCmdDesc(string strCmd, string strCfgData);
00150         string AppendCmdDesc(string strCmd, string strCfgData);
00151
00152         vector<string> Dp5CmdList;
00153         //void MakeDp5CmdList(stringArray *strCfgArr);
00154         vector<string> CvcDP5Dlg::MakeDp5CmdList();
00155         void CopyDp5CfgToClip(string strCfg, string strDesc);
00156         afx_msg LRESULT CallReadDppConfig(WPARAM wParam, LPARAM lParam);
00157         afx_msg LRESULT CallReadScaConfig(WPARAM wParam, LPARAM lParam);
00158         //==============================================================
00159
00160         afx_msg void OnBnClickedButtonShowConfig();
00161         void SendConfigFromFileToDpp();
00162         void ButtonSendStringCfgToHardware(CString strCfgIn);
00163         afx_msg void OnBnClickedRadioPlotScaleLinear();
00164         afx_msg void OnBnClickedRadioPlotScaleLog();
00165         afx_msg void OnBnClickedRadioPlotTypeSolid();
00166         afx_msg void OnBnClickedRadioPlotTypeLine();
00167
00168         //==== Configuration
00169         //==============================================================
00170         void SaveMCAFile(string strFilename, string strMCA);
00171         afx_msg void OnBnClickedBtnSaveFile();
00172         string CreateMCAData(long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst);
00173         void SetStartTime();
00174         //==============================================================
00175
00176         CPoint CursorPosition;
00177         int CurrentChannel;
00178         afx_msg void OnStnClickedPlotpicturecontrol();
00179         afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
00180         virtual BOOL PreTranslateMessage(MSG* pMsg);
00181
00182         afx_msg void OnBnClickedOk();
00183         afx_msg void OnBnClickedCancel();
00184         void SetPlotChannel();
00185         afx_msg BOOL OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult);
00186         afx_msg void TuneFastSlowThresh();
00187         afx_msg void OnBnClickedButtonAutotune();
00188         double GetPixPerChannel();
00189
00190         // configuration values global to dialog
00191         BOOL b80MHzMode;
00192
00193         BOOL DisplayCfg;
00194         BOOL CfgReadBack;
00195
00196         BOOL DisplaySca;
00197         BOOL ScaReadBack;
00198
00199         BOOL SaveCfg;
00200         BOOL PrintCfg;
00201
00202         string strPresetCmd;
00203         string strPresetVal;
00204
00205         int DeviceType;                         //@cmember device type 0=mca8ka,1=dp4,2=px4,3=DP5(DP4 emul),4=DP5 (PX4 Emulation)
00206         BOOL isDeltaMode;                       //@cmember false=MCA mode, true=Delta mode
00207
00208         long mcaCH;                                     //@cmember actual number of channels 0,256,512,1024,2048,4096,8192
00209
00210
00211         // DP5 oscilloscope support
00212         string strAnalogOut;
00213         string strInputOffset;
00214         string strOutputOffset;
00215         string strScopeGain;
00216         string strTriggerSource;
00217         string strTriggerPosition;
00218         string strTriggerSlope;
00219         BOOL UpdateScopeCfg;                            //@cmember scope indicates scope cfg needs update
00220
00221         string strMcaMode;
00222         UCHAR AcqMode;                          //@cmember acquisition mode 0=MCA,1=MCS
00223         UCHAR SlowChThreshold;          //@cmember Slow ch threshold, Events w/amp lower not added to spectrum
00224         double SlowThresholdPct;
00225         UCHAR FastChThreshold;          //@cmember Fast Ch Threshold, events w/fch amp below this are rejected
00226         double RiseUS;
00227         string strGainDisplayValue;     //@cmember stores display string for px4 toolbar/menu gain change function
00228         double PresetRt;                                //@cmember var holds preset time, used in usb
00229         double PresetAcq;                               //@cmember var holds preset time, used in usb
00230         unsigned long PresetCount;      //@cmember preset count in selected channels, ch are set in SCA8
00231
00232         // communications
00233         BOOL isDppConnected; // Current Interface selected and device found
00234         string HwCfgDP5;
00235         string HwCfgDP5Out;
00236         BOOL HwCfgReady;
00237         BOOL HwCfgExReady;
00238
00239         //DP5 Protocol Support
00240         CParsePacket ParsePkt;
00241         //CStringArray Dp5CmdList;
00242         CDP5Status DP5Stat;
00243         HWND hWnd_Main;
00244         string CreateDTS(string strFormat);
00245         int idxCurrentSpectrum;
00246         int idxTotalSpectra;
00247         bool bSpectraTestRunning;
00248
00249         afx_msg void OnBnClickedCheckRepeatSpectrum();
00250
00254         CString strLowerMiscData;               // lower 256 bytes of misc data buffer
00255         CString strUpperMiscData;               // upper 256 bytes of misc data buffer
00256         CString ParsePerformanceNotes(CString str);
00257         CString TextToBlockString(CString &str, char *prefix);
00258         CString CreateTextBlockTest();
00259         void SendDppInfoTextBlock(CString strLowerTextBlock, CString strInfoTextBlock);
00261         void WriteTextBlock();
00262
00263         void ParseTextBlockNotes(CString strTextBlock);
00264         BOOL ExtractNote(CString& rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep);
00265         void CopyTextToClip(CString strTextIn);
00266         void OnBnClickedButtonWriteTextBlock();
00267         bool SendManufacturingTextBlock(CString generalNotes);
00268
00269 };
00270
00271 extern CDP5Protocol DP5Proto;
00272 extern CDppWinUSB DppWinUSB;
00273 extern CWinusbNotify WinusbNotify;
Generated on Fri Sep 22 2017 10:01:02 for vcDP5_USB_Repeat Test C++ SDK by doxygen 1.7.6.1