vcDP5 Test C++ SDK: Main Page

vcDP5 Test C++ SDK 20170920
DPP C++ Demonstration
  • Main Page
  • Namespaces
  • Classes
  • Files
vcDP5 Test C++ SDK Documentation

vcDP5

vcDP5 is a MFC Dialog application that demonstrates how Amptek DPP communications can be easily integrated into other programs.

What vcDP5 does.

vcDP5 communicates to a DPP device and demonstrates a minimal set of acquisition related commands.

vcDP5 Classes

  • CSCommon (Central function control.)
  • CDppWinUSB (Windows WinUSB communication class.)
  • CDP5Status (DPP status processing.)
  • CParsePacket (DPP packet parsing.)
  • CDP5Protocol (Defines and implements DPP protocol.)
  • CSendCommand (Generates command packet to be sent.)

vcDP5 Main Function

  • CvcDP5Dlg (DPP MFC Dialog Demonstration.)

More Information

http://amptek.com/products/dp5-digital-pulse-processor-software/ Amptek Software Page

Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringSplit Namespace Reference

  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Typedefs | Functions
stringSplit Namespace Reference

Typedefs

typedef string::size_type(string::* | FindToken )(const string &strDelimiter, string::size_type sztOffset) const

Functions

vector< string > | Split (const string &strIn, const string &strDelimiters, bool bRemoveEmpty=false, bool bMatchAll=false)

Typedef Documentation

typedef string::size_type(string::* stringSplit::FindToken)(const string &strDelimiter, string::size_type sztOffset) const

Definition at line 7 of file stringSplit.h.

Function Documentation

vector<string> stringSplit::Split | ( | const string & | strIn,
 |  | const string & | strDelimiters,
 |  | bool | bRemoveEmpty = false,
 |  | bool | bMatchAll = false
 | ) |  |

Definition at line 13 of file stringSplit.h.

Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
Here is a list of all namespace members with links to the namespace documentation for each member:
  • FindToken : stringSplit
  • Split() : stringSplit
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • Split() : stringSplit
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Typedefs
  • FindToken : stringSplit
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _CONFIG_OPTIONS Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_CONFIG_OPTIONS Struct Reference

#include <SendCommand.h>

List of all members.

Public Attributes

bool | PC5_PRESENT
int | DppType
if true pc5 commands are supported
string | HwCfgDP5Out
device type indicator
bool | SendCoarseFineGain
custom configuration string
bool | isDP5_RevDxGains
false=Send GAIN, true=Send GAIA,GAIF
unsigned char | DPP_ECO
use dp5 dx gains

Detailed Description

Definition at line 6 of file SendCommand.h.

Member Data Documentation

unsigned char _CONFIG_OPTIONS::DPP_ECO

use dp5 dx gains

Definition at line 13 of file SendCommand.h.

int _CONFIG_OPTIONS::DppType

if true pc5 commands are supported

Definition at line 9 of file SendCommand.h.

string _CONFIG_OPTIONS::HwCfgDP5Out

device type indicator

Definition at line 10 of file SendCommand.h.

bool _CONFIG_OPTIONS::isDP5_RevDxGains

false=Send GAIN, true=Send GAIA,GAIF

Definition at line 12 of file SendCommand.h.

bool _CONFIG_OPTIONS::PC5_PRESENT

Definition at line 8 of file SendCommand.h.

bool _CONFIG_OPTIONS::SendCoarseFineGain

custom configuration string

Definition at line 11 of file SendCommand.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/SendCommand.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _COORD_LONG Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_COORD_LONG Struct Reference

#include <PlotCanvas.h>

List of all members.

Public Attributes

long | X
long | Y

Detailed Description

Definition at line 38 of file PlotCanvas.h.

Member Data Documentation

long _COORD_LONG::X

Definition at line 39 of file PlotCanvas.h.

long _COORD_LONG::Y

Definition at line 40 of file PlotCanvas.h.

The documentation for this struct was generated from the following file:
  • Controls/PlotCanvas.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _DiagDataType Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_DiagDataType Struct Reference

#include <DP5Status.h>

List of all members.

Public Attributes

float | ADC_V [12]
float | PC5_V [4]
bool | PC5_PRESENT
long | PC5_SN
unsigned char | Firmware
unsigned char | FPGA
bool | SRAMTestPass
long | SRAMTestData
int | TempOffset
string | strTempRaw
string | strTempCal
bool | PC5Initialized
float | PC5DCAL
bool | IsPosHV
bool | Is8_5VPreAmp
bool | Sup9VOn
bool | PreAmpON
bool | HVOn
bool | TECOn
unsigned char | DiagData [192]

Detailed Description

Definition at line 80 of file DP5Status.h.

Member Data Documentation

float _DiagDataType::ADC_V[12]

Definition at line 82 of file DP5Status.h.

unsigned char _DiagDataType::DiagData[192]

Definition at line 101 of file DP5Status.h.

unsigned char _DiagDataType::Firmware

Definition at line 86 of file DP5Status.h.

unsigned char _DiagDataType::FPGA

Definition at line 87 of file DP5Status.h.

bool _DiagDataType::HVOn

Definition at line 99 of file DP5Status.h.

bool _DiagDataType::Is8_5VPreAmp

Definition at line 96 of file DP5Status.h.

bool _DiagDataType::IsPosHV

Definition at line 95 of file DP5Status.h.

bool _DiagDataType::PC5_PRESENT

Definition at line 84 of file DP5Status.h.

long _DiagDataType::PC5_SN

Definition at line 85 of file DP5Status.h.

float _DiagDataType::PC5_V[4]

Definition at line 83 of file DP5Status.h.

float _DiagDataType::PC5DCAL

Definition at line 94 of file DP5Status.h.

bool _DiagDataType::PC5Initialized

Definition at line 93 of file DP5Status.h.

bool _DiagDataType::PreAmpON

Definition at line 98 of file DP5Status.h.

long _DiagDataType::SRAMTestData

Definition at line 89 of file DP5Status.h.

bool _DiagDataType::SRAMTestPass

Definition at line 88 of file DP5Status.h.

string _DiagDataType::strTempCal

Definition at line 92 of file DP5Status.h.

string _DiagDataType::strTempRaw

Definition at line 91 of file DP5Status.h.

bool _DiagDataType::Sup9VOn

Definition at line 97 of file DP5Status.h.

bool _DiagDataType::TECOn

Definition at line 100 of file DP5Status.h.

int _DiagDataType::TempOffset

Definition at line 90 of file DP5Status.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Status.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _DP5_CONFIGURATION Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_DP5_CONFIGURATION Struct Reference

#include <DP5ControlUtil.h>

List of all members.

Public Attributes

CString | Command
int | ListCtrlID
int | TextCtrlID
DP5_CTRL_TYPE CtrlType
DP5_CTRL_GROUP CtrlGroup
CString | Description
CString | Units
CString | Limits
CString | Setting
CString | TextValue
CString | ComboValue
int | ComboIndex
CString | Comments
CString | ValComments
BOOL | bAppendUnits

Detailed Description

Definition at line 118 of file DP5ControlUtil.h.

Member Data Documentation

BOOL _DP5_CONFIGURATION::bAppendUnits

Definition at line 135 of file DP5ControlUtil.h.

int _DP5_CONFIGURATION::ComboIndex

Definition at line 132 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::ComboValue

Definition at line 131 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::Command

Definition at line 120 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::Comments

Definition at line 133 of file DP5ControlUtil.h.

DP5_CTRL_GROUP _DP5_CONFIGURATION::CtrlGroup

Definition at line 124 of file DP5ControlUtil.h.

DP5_CTRL_TYPE _DP5_CONFIGURATION::CtrlType

Definition at line 123 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::Description

Definition at line 125 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::Limits

Definition at line 127 of file DP5ControlUtil.h.

int _DP5_CONFIGURATION::ListCtrlID

Definition at line 121 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::Setting

Definition at line 129 of file DP5ControlUtil.h.

int _DP5_CONFIGURATION::TextCtrlID

Definition at line 122 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::TextValue

Definition at line 130 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::Units

Definition at line 126 of file DP5ControlUtil.h.

CString _DP5_CONFIGURATION::ValComments

Definition at line 134 of file DP5ControlUtil.h.

The documentation for this struct was generated from the following file:
  • CIni/DP5ControlUtil.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _DppStateType Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_DppStateType Struct Reference

#include <ParsePacket.h>

List of all members.

Public Attributes

CommType Interface
string | strPort
unsigned long | ReqProcess
bool | HaveScopeData
bool | ScopeAutoRearm
bool | ScopeOverFlow

Detailed Description

Definition at line 33 of file ParsePacket.h.

Member Data Documentation

bool _DppStateType::HaveScopeData

Definition at line 37 of file ParsePacket.h.

CommType _DppStateType::Interface

Definition at line 34 of file ParsePacket.h.

unsigned long _DppStateType::ReqProcess

Definition at line 36 of file ParsePacket.h.

bool _DppStateType::ScopeAutoRearm

Definition at line 38 of file ParsePacket.h.

bool _DppStateType::ScopeOverFlow

Definition at line 39 of file ParsePacket.h.

string _DppStateType::strPort

Definition at line 35 of file ParsePacket.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/ParsePacket.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _Packet_In Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_Packet_In Struct Reference

#include <DP5Protocol.h>

List of all members.

Public Attributes

unsigned char | PID1
unsigned char | PID2
unsigned short | LEN
unsigned char | STATUS
unsigned char | DATA [32768]
long | CheckSum

Detailed Description

Definition at line 276 of file DP5Protocol.h.

Member Data Documentation

long _Packet_In::CheckSum

Definition at line 282 of file DP5Protocol.h.

unsigned char _Packet_In::DATA[32768]

Definition at line 281 of file DP5Protocol.h.

unsigned short _Packet_In::LEN

Definition at line 279 of file DP5Protocol.h.

unsigned char _Packet_In::PID1

Definition at line 277 of file DP5Protocol.h.

unsigned char _Packet_In::PID2

Definition at line 278 of file DP5Protocol.h.

unsigned char _Packet_In::STATUS

Definition at line 280 of file DP5Protocol.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _SpectrumFileType Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_SpectrumFileType Struct Reference

#include <vcDP5Dlg.h>

List of all members.

Public Attributes

string | strTag
string | strDescription
short | m_iNumChan
unsigned long | SerialNumber
string | strStartTime
string | strSpectrumConfig
string | strSpectrumStatus

Detailed Description

Definition at line 19 of file vcDP5Dlg.h.

Member Data Documentation

short _SpectrumFileType::m_iNumChan

Definition at line 22 of file vcDP5Dlg.h.

unsigned long _SpectrumFileType::SerialNumber

Definition at line 23 of file vcDP5Dlg.h.

string _SpectrumFileType::strDescription

Definition at line 21 of file vcDP5Dlg.h.

string _SpectrumFileType::strSpectrumConfig

Definition at line 25 of file vcDP5Dlg.h.

string _SpectrumFileType::strSpectrumStatus

Definition at line 26 of file vcDP5Dlg.h.

string _SpectrumFileType::strStartTime

Definition at line 24 of file vcDP5Dlg.h.

string _SpectrumFileType::strTag

Definition at line 20 of file vcDP5Dlg.h.

The documentation for this struct was generated from the following file:
  • vcDP5Dlg.h
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _WINUSB_PIPE_INFORMATION Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_WINUSB_PIPE_INFORMATION Struct Reference

#include <WINUSBIO.H>

List of all members.

Public Attributes

USBD_PIPE_TYPE | PipeType
UCHAR | PipeId
USHORT | MaximumPacketSize
UCHAR | Interval

Detailed Description

Definition at line 71 of file WINUSBIO.H.

Member Data Documentation

UCHAR _WINUSB_PIPE_INFORMATION::Interval

Definition at line 75 of file WINUSBIO.H.

USHORT _WINUSB_PIPE_INFORMATION::MaximumPacketSize

Definition at line 74 of file WINUSBIO.H.

UCHAR _WINUSB_PIPE_INFORMATION::PipeId

Definition at line 73 of file WINUSBIO.H.

USBD_PIPE_TYPE _WINUSB_PIPE_INFORMATION::PipeType

Definition at line 72 of file WINUSBIO.H.

The documentation for this struct was generated from the following file:
  • DeviceIO/WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: _WINUSB_SETUP_PACKET Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
_WINUSB_SETUP_PACKET Struct Reference

#include <WINUSB.H>

List of all members.

Public Attributes

UCHAR | RequestType
UCHAR | Request
USHORT | Value
USHORT | Index
USHORT | Length

Detailed Description

Definition at line 50 of file WINUSB.H.

Member Data Documentation

USHORT _WINUSB_SETUP_PACKET::Index

Definition at line 54 of file WINUSB.H.

USHORT _WINUSB_SETUP_PACKET::Length

Definition at line 55 of file WINUSB.H.

UCHAR _WINUSB_SETUP_PACKET::Request

Definition at line 52 of file WINUSB.H.

UCHAR _WINUSB_SETUP_PACKET::RequestType

Definition at line 51 of file WINUSB.H.

USHORT _WINUSB_SETUP_PACKET::Value

Definition at line 53 of file WINUSB.H.

The documentation for this struct was generated from the following file:
  • DeviceIO/WINUSB.H
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CAboutDlg Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions
CAboutDlg Class Reference

List of all members.

Public Types

enum | { IDD = IDD_ABOUTBOX }

Public Member Functions

CAboutDlg ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Detailed Description

Definition at line 24 of file vcDP5Dlg.cpp.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 30 of file vcDP5Dlg.cpp.

Constructor & Destructor Documentation

CAboutDlg::CAboutDlg ( )

Definition at line 40 of file vcDP5Dlg.cpp.

Member Function Documentation

void CAboutDlg::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 44 of file vcDP5Dlg.cpp.

The documentation for this class was generated from the following file:
  • vcDP5Dlg.cpp
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: cAnimWnd Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes
cAnimWnd Class Reference

#include <AnimWnd.h>

Collaboration diagram for cAnimWnd:
[legend]

List of all members.

Public Member Functions

cAnimWnd ()
void | SetImageList (UINT BitmapID, short Size, short Sizey, COLORREF TransparentColor=-1)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
int | GetImageCount ()
BOOL | StopAnim ()
INT_PTR | StartAnim (short Delay=50)
virtual | ~cAnimWnd ()

Protected Member Functions

afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnPaint ()

Protected Attributes

int | m_ImageIndex
COLORREF | m_TransparentColor
short | m_Width
short | m_Height
CBitmap | m_Bitmap
cMemDC * m_MemDC

Detailed Description

Definition at line 26 of file AnimWnd.h.

Constructor & Destructor Documentation

cAnimWnd::cAnimWnd ( )

Definition at line 10 of file AnimWnd.cpp.

cAnimWnd::~cAnimWnd ( ) [virtual]

Definition at line 16 of file AnimWnd.cpp.

Member Function Documentation

BOOL cAnimWnd::Create | ( | DWORD | dwStyle,
 |  | const RECT & | rect,
 |  | CWnd * | pParentWnd,
 |  | UINT | nID,
 |  | CCreateContext * | pContext = NULL
 | ) |  | [virtual]

Definition at line 107 of file AnimWnd.cpp.

Here is the caller graph for this function:

int cAnimWnd::GetImageCount ( )

Definition at line 120 of file AnimWnd.cpp.

Here is the caller graph for this function:

void cAnimWnd::OnPaint ( ) [protected]

Definition at line 55 of file AnimWnd.cpp.

void cAnimWnd::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 74 of file AnimWnd.cpp.

Here is the call graph for this function:

void cAnimWnd::SetImageList | ( | UINT | BitmapID,
 |  | short | Size,
 |  | short | Sizey,
 |  | COLORREF | TransparentColor = -1
 | ) |  |

Definition at line 37 of file AnimWnd.cpp.

Here is the caller graph for this function:

INT_PTR cAnimWnd::StartAnim ( short Delay = 50 )

Definition at line 93 of file AnimWnd.cpp.

Here is the caller graph for this function:

BOOL cAnimWnd::StopAnim ( )

Definition at line 99 of file AnimWnd.cpp.

Member Data Documentation

CBitmap cAnimWnd::m_Bitmap [protected]

Definition at line 40 of file AnimWnd.h.

short cAnimWnd::m_Height [protected]

Definition at line 39 of file AnimWnd.h.

int cAnimWnd::m_ImageIndex [protected]

Definition at line 36 of file AnimWnd.h.

cMemDC* cAnimWnd::m_MemDC [protected]

Definition at line 41 of file AnimWnd.h.

COLORREF cAnimWnd::m_TransparentColor [protected]

Definition at line 37 of file AnimWnd.h.

short cAnimWnd::m_Width [protected]

Definition at line 38 of file AnimWnd.h.

The documentation for this class was generated from the following files:
  • waitdlg/AnimWnd.h
  • waitdlg/AnimWnd.cpp
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CAsciiCmdUtilities Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CAsciiCmdUtilities Class Reference

#include <AsciiCmdUtilities.h>

List of all members.

Public Member Functions

CAsciiCmdUtilities (void)
~CAsciiCmdUtilities (void)
std::string | MakeUpper (std::string myString)
Forces all characters to uppercase. (All DPP command must be in upper case.)
std::string | RemWhitespace (std::string strLine)
Removes Whitespace characters from a command string.
std::string | GetDP5CfgStr (std::string strFilename)
Reads a DPP configuration from a file.
std::string | GetDP5ScaStr (std::string strFilename)
Reads a SCA configuration from a file.
std::string | CreateResTestReadBackCmd (bool bSendCoarseFineGain, int DppType)
std::string | CreateFullReadBackCmd (bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
Generates a configuration readback command from a list of all commands.
std::string | CreateFullReadBackCmdMCA8000D (int DppType)
Generates a configuration readback command from a list of all commands.
std::string | RemoveCmd (std::string strCmd, std::string strCfgData)
Remove a specified command from the command stream.
std::string | RemoveCmdByDeviceType (std::string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
Remove illegal commands from the command stream by device type.
std::string | RemoveCmdByDeviceTypeDP5DxK (std::string strCfgDataIn, bool PC5_PRESENT, int DppType)
Remove illegal commands from the command stream by device type.
std::string | Remove_MCA8000D_Cmds (std::string strCfgDataIn, int DppType)
std::string | ReplaceCmdText (std::string strInTextIn, std::string strFrom, std::string strTo)
int | GetCmdChunk (std::string strCmd)
bool | CopyAsciiData (unsigned char Data[], string strCfg, long lLen)
Force string to ASCII bytes.

Detailed Description

Definition at line 18 of file AsciiCmdUtilities.h.

Constructor & Destructor Documentation

CAsciiCmdUtilities::CAsciiCmdUtilities ( void )

Definition at line 3 of file AsciiCmdUtilities.cpp.

CAsciiCmdUtilities::~CAsciiCmdUtilities ( void )

Definition at line 7 of file AsciiCmdUtilities.cpp.

Member Function Documentation

bool CAsciiCmdUtilities::CopyAsciiData | ( | unsigned char | Data[],
 |  | string | strCfg,
 |  | long | lLen
 | ) |  |

Force string to ASCII bytes.

Definition at line 578 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::CreateFullReadBackCmd | ( | bool | PC5_PRESENT,
 |  | int | DppType,
 |  | bool | isDP5_RevDxGains,
 |  | unsigned char | DPP_ECO
 | ) |  |

Generates a configuration readback command from a list of all commands.

Definition at line 202 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::CreateFullReadBackCmdMCA8000D ( int DppType )

Generates a configuration readback command from a list of all commands.

Definition at line 308 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::CreateResTestReadBackCmd | ( | bool | bSendCoarseFineGain,
 |  | int | DppType
 | ) |  |

Definition at line 177 of file AsciiCmdUtilities.cpp.

int CAsciiCmdUtilities::GetCmdChunk ( std::string strCmd )

Definition at line 558 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::GetDP5CfgStr ( std::string strFilename )

Reads a DPP configuration from a file.

Definition at line 42 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

string CAsciiCmdUtilities::GetDP5ScaStr ( std::string strFilename )

Reads a SCA configuration from a file.

Definition at line 97 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

string CAsciiCmdUtilities::MakeUpper ( std::string myString )

Forces all characters to uppercase. (All DPP command must be in upper case.)

Definition at line 11 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::Remove_MCA8000D_Cmds | ( | std::string | strCfgDataIn,
 |  | int | DppType
 | ) |  |

Definition at line 482 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemoveCmd | ( | std::string | strCmd,
 |  | std::string | strCfgData
 | ) |  |

Remove a specified command from the command stream.

Definition at line 351 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemoveCmdByDeviceType | ( | std::string | strCfgDataIn,
 |  | bool | PC5_PRESENT,
 |  | int | DppType,
 |  | bool | isDP5_RevDxGains,
 |  | unsigned char | DPP_ECO
 | ) |  |

Remove illegal commands from the command stream by device type.

Definition at line 370 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemoveCmdByDeviceTypeDP5DxK | ( | std::string | strCfgDataIn,
 |  | bool | PC5_PRESENT,
 |  | int | DppType
 | ) |  |

Remove illegal commands from the command stream by device type.

Definition at line 432 of file AsciiCmdUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CAsciiCmdUtilities::RemWhitespace ( std::string strLine )

Removes Whitespace characters from a command string.

Definition at line 21 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

std::string CAsciiCmdUtilities::ReplaceCmdText | ( | std::string | strInTextIn,
 |  | std::string | strFrom,
 |  | std::string | strTo
 | ) |  |

Definition at line 532 of file AsciiCmdUtilities.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • DeviceIO/AsciiCmdUtilities.h
  • DeviceIO/AsciiCmdUtilities.cpp
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CBootOptPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions
CBootOptPage Class Reference

#include <BootOptPage.h>

Inheritance diagram for CBootOptPage:
[legend]
Collaboration diagram for CBootOptPage:
[legend]

List of all members.

Public Types

enum | { IDD = IDD_BOOTOPT_PAGE }

Public Member Functions

CBootOptPage ()
~CBootOptPage ()
virtual BOOL | OnSetActive ()
virtual BOOL | OnInitDialog ()
void | InitControls ()
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | CboUpdate (int nID_dci)

Public Attributes

CLabel m_BootOptPageLabel

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Detailed Description

Definition at line 17 of file BootOptPage.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 28 of file BootOptPage.h.

Constructor & Destructor Documentation

CBootOptPage::CBootOptPage ( )

Definition at line 20 of file BootOptPage.cpp.

CBootOptPage::~CBootOptPage ( )

Definition at line 27 of file BootOptPage.cpp.

Member Function Documentation

void CBootOptPage::CboUpdate ( int nID_dci )

Definition at line 115 of file BootOptPage.cpp.

void CBootOptPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 32 of file BootOptPage.cpp.

void CBootOptPage::InitControls ( )

Definition at line 76 of file BootOptPage.cpp.

Here is the caller graph for this function:

void CBootOptPage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 82 of file BootOptPage.cpp.

Here is the call graph for this function:

BOOL CBootOptPage::OnInitDialog ( ) [virtual]

Definition at line 55 of file BootOptPage.cpp.

Here is the call graph for this function:

BOOL CBootOptPage::OnSetActive ( ) [virtual]

Definition at line 48 of file BootOptPage.cpp.

Member Data Documentation

CLabel CBootOptPage::m_BootOptPageLabel

Definition at line 47 of file BootOptPage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/BootOptPage.h
  • DP5Cfg/BootOptPage.cpp
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CCfgPropPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions
CCfgPropPage Class Reference

#include <CfgPropSheet.h>

Inheritance diagram for CCfgPropPage:
[legend]

List of all members.

Public Member Functions

CCfgPropPage ()
CCfgPropPage (UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0)
CCfgPropPage (LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0)
~CCfgPropPage ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
BOOL | OnToolTipText (UINT, NMHDR *pNMHDR, LRESULT *pResult)

Detailed Description

Definition at line 17 of file CfgPropSheet.h.

Constructor & Destructor Documentation

CCfgPropPage::CCfgPropPage ( )

Definition at line 737 of file CfgPropSheet.cpp.

CCfgPropPage::CCfgPropPage | ( | UINT | nIDTemplate,
 |  | UINT | nIDCaption = 0,
 |  | UINT | nIDHeaderTitle = 0,
 |  | UINT | nIDHeaderSubTitle = 0
 | ) |  |

Definition at line 741 of file CfgPropSheet.cpp.

CCfgPropPage::CCfgPropPage | ( | LPCTSTR | lpszTemplateName,
 |  | UINT | nIDCaption = 0,
 |  | UINT | nIDHeaderTitle = 0,
 |  | UINT | nIDHeaderSubTitle = 0
 | ) |  |

Definition at line 746 of file CfgPropSheet.cpp.

CCfgPropPage::~CCfgPropPage ( )

Definition at line 751 of file CfgPropSheet.cpp.

Member Function Documentation

void CCfgPropPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented in CShapingPage, CFilePage, CGainPzPage, CMcaPage, CMiscPage, CPowerPage, and CBootOptPage.

Definition at line 755 of file CfgPropSheet.cpp.

void CCfgPropPage::OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  | [protected]

Definition at line 781 of file CfgPropSheet.cpp.

Here is the call graph for this function:

BOOL CCfgPropPage::OnToolTipText | ( | UINT | i,
 |  | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  | [protected]

Definition at line 772 of file CfgPropSheet.cpp.

Here is the call graph for this function:

The documentation for this class was generated from the following files:
  • DP5Cfg/CfgPropSheet.h
  • DP5Cfg/CfgPropSheet.cpp
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CCfgPropSheet Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Friends
CCfgPropSheet Class Reference

#include <CfgPropSheet.h>

Inheritance diagram for CCfgPropSheet:
[legend]
Collaboration diagram for CCfgPropSheet:
[legend]

List of all members.

Public Member Functions

CCfgPropSheet (UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0, HBITMAP hbmWatermark=NULL, HPALETTE hpalWatermark=NULL, HBITMAP hbmHeader=NULL)
CCfgPropSheet (LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0, HBITMAP hbmWatermark=NULL, HPALETTE hpalWatermark=NULL, HBITMAP hbmHeader=NULL)
BOOL | InitCfgPropSheet (BOOL bToolTips=FALSE, BOOL bStatusBar=FALSE, UINT *pIndicators=NULL, UINT nIndicators=0, UINT uiMenu=0, UINT uiToolBar=0, DWORD dwToolBarStyle=TBSTYLE_FLAT|WS_CHILD|WS_VISIBLE|CBRS_TOP|CBRS_GRIPPER|CBRS_TOOLTIPS|CBRS_FLYBY|CBRS_SIZE_DYNAMIC)
void | AddPage (CCfgPropPage *pPage)
CStatusBar * | GetStatusBar ()
CToolBar * | GetToolBar ()
virtual void | OnCancel ()
virtual INT_PTR | DoModal ()
afx_msg void | OnFileTab ()
afx_msg void | OnMcaTab ()
afx_msg void | OnShapingTab ()
afx_msg void | OnGainPzTab ()
afx_msg void | OnPowerTab ()
afx_msg void | OnMiscTab ()
void | OnSelectTab (UINT NewActivePage, int nPage)
void | UpdateAll ()
afx_msg void | OnFileTab2 (CCmdUI *pCmdUI)
afx_msg void | OnMcaTab2 (CCmdUI *pCmdUI)
afx_msg void | OnShapingTab2 (CCmdUI *pCmdUI)
afx_msg void | OnGainPzTab2 (CCmdUI *pCmdUI)
afx_msg void | OnPowerTab2 (CCmdUI *pCmdUI)
afx_msg void | OnMiscTab2 (CCmdUI *pCmdUI)
void | GetCurrentButtonState ()
void | OnTB1 ()

Public Attributes

UINT | ActivePage

Protected Member Functions

virtual void | PostNcDestroy ()
afx_msg void | OnEnterIdle (UINT nWhy, CWnd *pWho)
afx_msg LRESULT | OnPopMessageString (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnSetMessageString (WPARAM wParam, LPARAM lParam=0L)
afx_msg void | OnMenuSelect (UINT nItemID, UINT nFlags, HMENU hSysMenu)
afx_msg void | OnUpdateKeyIndicator (CCmdUI *pCmdUI)
afx_msg void | OnUpdateStatusBarMenu (CCmdUI *pCmdUI)
afx_msg void | OnStatusBarCheck ()
afx_msg void | OnToolBarCheck ()
afx_msg void | OnUpdateToolBarMenu (CCmdUI *pCmdUI)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg void | OnInitMenuPopup (CMenu *pPopupMenu, UINT nIndex, BOOL bSysMenu)
afx_msg LRESULT | OnKickIdle (WPARAM, LPARAM lCount)
afx_msg void | OnTimer (UINT nIDEvent)
BOOL | OnToolTipText (UINT, NMHDR *pNMHDR, LRESULT *pResult)

Protected Attributes

CDlgStatusBar m_CSBCtrlStatus
CDlgToolBar m_CSToolBar
UINT | m_nIDTracking
UINT | m_nIDLastMessage
BOOL | m_bResetPrompt
BOOL | m_bToolTips
BOOL | m_bStatusBar
BOOL | m_bToolBar
BOOL | m_bMenu
BOOL | m_bKillItself
BOOL | m_bModal
UINT | m_Timer

Friends

class | CCfgPropPage

Detailed Description

Definition at line 57 of file CfgPropSheet.h.

Constructor & Destructor Documentation

CCfgPropSheet::CCfgPropSheet | ( | UINT | nIDCaption,
 |  | CWnd * | pParentWnd = NULL,
 |  | UINT | iSelectPage = 0,
 |  | HBITMAP | hbmWatermark = NULL,
 |  | HPALETTE | hpalWatermark = NULL,
 |  | HBITMAP | hbmHeader = NULL
 | ) |  |

Definition at line 28 of file CfgPropSheet.cpp.

CCfgPropSheet::CCfgPropSheet | ( | LPCTSTR | pszCaption,
 |  | CWnd * | pParentWnd = NULL,
 |  | UINT | iSelectPage = 0,
 |  | HBITMAP | hbmWatermark = NULL,
 |  | HPALETTE | hpalWatermark = NULL,
 |  | HBITMAP | hbmHeader = NULL
 | ) |  |

Definition at line 46 of file CfgPropSheet.cpp.

Member Function Documentation

void CCfgPropSheet::AddPage ( CCfgPropPage * pPage )

Definition at line 164 of file CfgPropSheet.cpp.

Here is the caller graph for this function:

INT_PTR CCfgPropSheet::DoModal ( ) [virtual]

Reimplemented in CDP5CfgWnd.

Definition at line 401 of file CfgPropSheet.cpp.

void CCfgPropSheet::GetCurrentButtonState ( )

Definition at line 213 of file CfgPropSheet.cpp.

CStatusBar* CCfgPropSheet::GetStatusBar ( ) [inline]

Definition at line 72 of file CfgPropSheet.h.

CToolBar* CCfgPropSheet::GetToolBar ( ) [inline]

Definition at line 73 of file CfgPropSheet.h.

BOOL CCfgPropSheet::InitCfgPropSheet | ( | BOOL | bToolTips = FALSE,
 |  | BOOL | bStatusBar = FALSE,
 |  | UINT * | pIndicators = NULL,
 |  | UINT | nIndicators = 0,
 |  | UINT | uiMenu = 0,
 |  | UINT | uiToolBar = 0,
 |  | DWORD | dwToolBarStyle = TBSTYLE_FLAT | WS_CHILD | WS_VISIBLE | CBRS_TOP | CBRS_GRIPPER | CBRS_TOOLTIPS | CBRS_FLYBY | CBRS_SIZE_DYNAMIC
 | ) |  |

Definition at line 64 of file CfgPropSheet.cpp.

Here is the call graph for this function:

void CCfgPropSheet::OnCancel ( ) [virtual]

Definition at line 415 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnEnterIdle | ( | UINT | nWhy,
 |  | CWnd * | pWho
 | ) |  | [protected]

Definition at line 424 of file CfgPropSheet.cpp.

Here is the call graph for this function:

void CCfgPropSheet::OnFileTab ( )

Definition at line 269 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnFileTab2 ( CCmdUI * pCmdUI )

Definition at line 348 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnGainPzTab ( )

Definition at line 290 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnGainPzTab2 ( CCmdUI * pCmdUI )

Definition at line 368 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnInitMenuPopup | ( | CMenu * | pPopupMenu,
 |  | UINT | nIndex,
 |  | BOOL | bSysMenu
 | ) |  | [protected]

Definition at line 441 of file CfgPropSheet.cpp.

LRESULT CCfgPropSheet::OnKickIdle | ( | WPARAM | ,
 |  | LPARAM | lCount
 | ) |  | [protected]

Definition at line 712 of file CfgPropSheet.cpp.

Here is the caller graph for this function:

void CCfgPropSheet::OnMcaTab ( )

Definition at line 280 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnMcaTab2 ( CCmdUI * pCmdUI )

Definition at line 354 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnMenuSelect | ( | UINT | nItemID,
 |  | UINT | nFlags,
 |  | HMENU | hSysMenu
 | ) |  | [protected]

Definition at line 476 of file CfgPropSheet.cpp.

Here is the call graph for this function:

void CCfgPropSheet::OnMiscTab ( )

Definition at line 300 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnMiscTab2 ( CCmdUI * pCmdUI )

Definition at line 386 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnMouseMove | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  | [protected]

Definition at line 494 of file CfgPropSheet.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

LRESULT CCfgPropSheet::OnPopMessageString | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  | [protected]

Definition at line 703 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnPowerTab ( )

Definition at line 295 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnPowerTab2 ( CCmdUI * pCmdUI )

Definition at line 377 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnSelectTab | ( | UINT | NewActivePage,
 |  | int | nPage
 | ) |  |

Definition at line 306 of file CfgPropSheet.cpp.

LRESULT CCfgPropSheet::OnSetMessageString | ( | WPARAM | wParam,
 |  | LPARAM | lParam = 0L
 | ) |  | [protected]

Definition at line 666 of file CfgPropSheet.cpp.

Here is the caller graph for this function:

void CCfgPropSheet::OnShapingTab ( )

Definition at line 285 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnShapingTab2 ( CCmdUI * pCmdUI )

Definition at line 359 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnStatusBarCheck ( ) [protected]

Definition at line 613 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnTB1 ( )

Definition at line 396 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 720 of file CfgPropSheet.cpp.

Here is the call graph for this function:

void CCfgPropSheet::OnToolBarCheck ( ) [protected]

Definition at line 558 of file CfgPropSheet.cpp.

BOOL CCfgPropSheet::OnToolTipText | ( | UINT | ,
 |  | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  | [protected]

Definition at line 504 of file CfgPropSheet.cpp.

Here is the caller graph for this function:

void CCfgPropSheet::OnUpdateKeyIndicator ( CCmdUI * pCmdUI ) [protected]

Definition at line 641 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnUpdateStatusBarMenu ( CCmdUI * pCmdUI ) [protected]

Definition at line 607 of file CfgPropSheet.cpp.

void CCfgPropSheet::OnUpdateToolBarMenu ( CCmdUI * pCmdUI ) [protected]

Definition at line 552 of file CfgPropSheet.cpp.

void CCfgPropSheet::PostNcDestroy ( ) [protected, virtual]

Definition at line 408 of file CfgPropSheet.cpp.

void CCfgPropSheet::UpdateAll ( )

Definition at line 312 of file CfgPropSheet.cpp.

Here is the caller graph for this function:

Friends And Related Function Documentation

friend class CCfgPropPage [friend]

Definition at line 155 of file CfgPropSheet.h.

Member Data Documentation

UINT CCfgPropSheet::ActivePage

Definition at line 112 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bKillItself [protected]

Definition at line 87 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bMenu [protected]

Definition at line 85 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bModal [protected]

Reimplemented in CDP5CfgWnd.

Definition at line 89 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bResetPrompt [protected]

Definition at line 80 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bStatusBar [protected]

Definition at line 83 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bToolBar [protected]

Definition at line 84 of file CfgPropSheet.h.

BOOL CCfgPropSheet::m_bToolTips [protected]

Definition at line 82 of file CfgPropSheet.h.

CDlgStatusBar CCfgPropSheet::m_CSBCtrlStatus [protected]

Definition at line 76 of file CfgPropSheet.h.

CDlgToolBar CCfgPropSheet::m_CSToolBar [protected]

Definition at line 77 of file CfgPropSheet.h.

UINT CCfgPropSheet::m_nIDLastMessage [protected]

Definition at line 79 of file CfgPropSheet.h.

UINT CCfgPropSheet::m_nIDTracking [protected]

Definition at line 78 of file CfgPropSheet.h.

UINT CCfgPropSheet::m_Timer [protected]

Definition at line 90 of file CfgPropSheet.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/CfgPropSheet.h
  • DP5Cfg/CfgPropSheet.cpp
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDlgStatusBar Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions
CDlgStatusBar Class Reference

#include <Dlgbars.h>

List of all members.

Public Member Functions

CDlgStatusBar ()
virtual | ~CDlgStatusBar ()

Protected Member Functions

afx_msg LRESULT | OnIdleUpdateCmdUI (WPARAM wParam, LPARAM)

Detailed Description

Definition at line 65 of file Dlgbars.h.

Constructor & Destructor Documentation

CDlgStatusBar::CDlgStatusBar ( )

Definition at line 107 of file Dlgbars.cpp.

CDlgStatusBar::~CDlgStatusBar ( ) [virtual]

Definition at line 111 of file Dlgbars.cpp.

Member Function Documentation

LRESULT CDlgStatusBar::OnIdleUpdateCmdUI | ( | WPARAM | wParam,
 |  | LPARAM |
 | ) |  | [protected]

Definition at line 129 of file Dlgbars.cpp.

The documentation for this class was generated from the following files:
  • DP5Cfg/Dlgbars.h
  • DP5Cfg/Dlgbars.cpp
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDlgToolBar Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes
CDlgToolBar Class Reference

#include <Dlgbars.h>

List of all members.

Public Member Functions

CDlgToolBar ()
virtual | ~CDlgToolBar ()
void | EnableButton (int nId, BOOL bEnable)

Protected Member Functions

afx_msg LRESULT | OnIdleUpdateCmdUI (WPARAM wParam, LPARAM)

Protected Attributes

CMap< int, int &, BOOL, BOOL & > | tbBtnMap

Detailed Description

Definition at line 45 of file Dlgbars.h.

Constructor & Destructor Documentation

CDlgToolBar::CDlgToolBar ( )

Definition at line 37 of file Dlgbars.cpp.

CDlgToolBar::~CDlgToolBar ( ) [virtual]

Definition at line 41 of file Dlgbars.cpp.

Member Function Documentation

void CDlgToolBar::EnableButton | ( | int | nId,
 |  | BOOL | bEnable
 | ) |  |

Definition at line 86 of file Dlgbars.cpp.

LRESULT CDlgToolBar::OnIdleUpdateCmdUI | ( | WPARAM | wParam,
 |  | LPARAM |
 | ) |  | [protected]

Definition at line 59 of file Dlgbars.cpp.

Member Data Documentation

CMap<int,int&,BOOL,BOOL&> CDlgToolBar::tbBtnMap [protected]

Definition at line 57 of file Dlgbars.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/Dlgbars.h
  • DP5Cfg/Dlgbars.cpp
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDP5CfgWnd Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions
CDP5CfgWnd Class Reference

#include <DP5CfgWnd.h>

Inheritance diagram for CDP5CfgWnd:
[legend]
Collaboration diagram for CDP5CfgWnd:
[legend]

List of all members.

Public Member Functions

CDP5CfgWnd (UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
CDP5CfgWnd (LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0)
virtual BOOL | OnInitDialog ()
virtual INT_PTR | DoModal ()
virtual | ~CDP5CfgWnd ()

Public Attributes

CFilePage m_FilePage
CMcaPage m_McaPage
CShapingPage m_ShapingPage
CGainPzPage m_GainPzPage
CPowerPage m_PowerPage
CMiscPage m_MiscPage
BOOL | m_bModal

Protected Member Functions

void | AddPages (void)

Detailed Description

Definition at line 22 of file DP5CfgWnd.h.

Constructor & Destructor Documentation

CDP5CfgWnd::CDP5CfgWnd | ( | UINT | nIDCaption,
 |  | CWnd * | pParentWnd = NULL,
 |  | UINT | iSelectPage = 0
 | ) |  |

Definition at line 21 of file DP5CfgWnd.cpp.

CDP5CfgWnd::CDP5CfgWnd | ( | LPCTSTR | pszCaption,
 |  | CWnd * | pParentWnd = NULL,
 |  | UINT | iSelectPage = 0
 | ) |  |

Definition at line 29 of file DP5CfgWnd.cpp.

Here is the call graph for this function:

CDP5CfgWnd::~CDP5CfgWnd ( ) [virtual]

Definition at line 37 of file DP5CfgWnd.cpp.

Member Function Documentation

void CDP5CfgWnd::AddPages ( void ) [protected]

Definition at line 42 of file DP5CfgWnd.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

INT_PTR CDP5CfgWnd::DoModal ( ) [virtual]

Reimplemented from CCfgPropSheet.

Definition at line 77 of file DP5CfgWnd.cpp.

Here is the caller graph for this function:

BOOL CDP5CfgWnd::OnInitDialog ( ) [virtual]

Definition at line 61 of file DP5CfgWnd.cpp.

Member Data Documentation

BOOL CDP5CfgWnd::m_bModal

Reimplemented from CCfgPropSheet.

Definition at line 41 of file DP5CfgWnd.h.

CFilePage CDP5CfgWnd::m_FilePage

Definition at line 33 of file DP5CfgWnd.h.

CGainPzPage CDP5CfgWnd::m_GainPzPage

Definition at line 36 of file DP5CfgWnd.h.

CMcaPage CDP5CfgWnd::m_McaPage

Definition at line 34 of file DP5CfgWnd.h.

CMiscPage CDP5CfgWnd::m_MiscPage

Definition at line 38 of file DP5CfgWnd.h.

CPowerPage CDP5CfgWnd::m_PowerPage

Definition at line 37 of file DP5CfgWnd.h.

CShapingPage CDP5CfgWnd::m_ShapingPage

Definition at line 35 of file DP5CfgWnd.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/DP5CfgWnd.h
  • DP5Cfg/DP5CfgWnd.cpp
Generated on Thu Sep 21 2017 15:25:21 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDP5ControlUtil Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDP5ControlUtil Class Reference

#include <DP5ControlUtil.h>

List of all members.

Public Member Functions

CDP5ControlUtil (void)
~CDP5ControlUtil (void)
int | FindCboIdxExact (HWND hDlg, int cboDP5CtrlID, CString strVal)
int | FindCboIdx (HWND hDlg, int cboDP5CtrlID, CString strVal)
void | SetCboIdxByStr (HWND hDlg, DP5_CONFIGURATION cfg)
int | FindUnitsInString (CString strValue, CString strUnits)
void | RemoveUnitsFromDecString (DP5_CONFIGURATION *cfg)
CString | AppendUnitsToString (CString strValue, CString strUnits)
void | AppendUnitsToSettingString (DP5_CONFIGURATION *cfg)
void | UpdateSetting (DP5_CONFIGURATION *cfg)
void | UpdateSettingOsc (DP5_CONFIGURATION *cfg)
int | OrderOut (int IndexIn)
BOOL | IsAllNumericString (CString strValue)
CString | GetValueWithUnitsString (DP5_CONFIGURATION cfg)

Public Attributes

BOOL | LoadingCfg
CString | strFindTab
CString | strFindCtrl
CString | strFindIdx

Detailed Description

Definition at line 142 of file DP5ControlUtil.h.

Constructor & Destructor Documentation

CDP5ControlUtil::CDP5ControlUtil ( void )

Definition at line 3 of file DP5ControlUtil.cpp.

CDP5ControlUtil::~CDP5ControlUtil ( void )

Definition at line 7 of file DP5ControlUtil.cpp.

Member Function Documentation

void CDP5ControlUtil::AppendUnitsToSettingString ( DP5_CONFIGURATION * cfg )

Definition at line 109 of file DP5ControlUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CDP5ControlUtil::AppendUnitsToString | ( | CString | strValue,
 |  | CString | strUnits
 | ) |  |

Definition at line 96 of file DP5ControlUtil.cpp.

Here is the caller graph for this function:

int CDP5ControlUtil::FindCboIdx | ( | HWND | hDlg,
 |  | int | cboDP5CtrlID,
 |  | CString | strVal
 | ) |  |

Definition at line 30 of file DP5ControlUtil.cpp.

Here is the caller graph for this function:

int CDP5ControlUtil::FindCboIdxExact | ( | HWND | hDlg,
 |  | int | cboDP5CtrlID,
 |  | CString | strVal
 | ) |  |

Definition at line 20 of file DP5ControlUtil.cpp.

Here is the caller graph for this function:

int CDP5ControlUtil::FindUnitsInString | ( | CString | strValue,
 |  | CString | strUnits
 | ) |  |

Definition at line 53 of file DP5ControlUtil.cpp.

Here is the caller graph for this function:

CString CDP5ControlUtil::GetValueWithUnitsString ( DP5_CONFIGURATION cfg )

Definition at line 126 of file DP5ControlUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CDP5ControlUtil::IsAllNumericString ( CString strValue )

Definition at line 175 of file DP5ControlUtil.cpp.

Here is the caller graph for this function:

int CDP5ControlUtil::OrderOut ( int IndexIn )

Definition at line 11 of file DP5ControlUtil.cpp.

Here is the caller graph for this function:

void CDP5ControlUtil::RemoveUnitsFromDecString ( DP5_CONFIGURATION * cfg )

Definition at line 65 of file DP5ControlUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDP5ControlUtil::SetCboIdxByStr | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 40 of file DP5ControlUtil.cpp.

Here is the call graph for this function:

void CDP5ControlUtil::UpdateSetting ( DP5_CONFIGURATION * cfg )

Definition at line 139 of file DP5ControlUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDP5ControlUtil::UpdateSettingOsc ( DP5_CONFIGURATION * cfg )

Definition at line 157 of file DP5ControlUtil.cpp.

Member Data Documentation

BOOL CDP5ControlUtil::LoadingCfg

Definition at line 147 of file DP5ControlUtil.h.

CString CDP5ControlUtil::strFindCtrl

Definition at line 149 of file DP5ControlUtil.h.

CString CDP5ControlUtil::strFindIdx

Definition at line 150 of file DP5ControlUtil.h.

CString CDP5ControlUtil::strFindTab

Definition at line 148 of file DP5ControlUtil.h.

The documentation for this class was generated from the following files:
  • CIni/DP5ControlUtil.h
  • CIni/DP5ControlUtil.cpp
Generated on Thu Sep 21 2017 15:25:21 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDP5Protocol Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDP5Protocol Class Reference

#include <DP5Protocol.h>

Collaboration diagram for CDP5Protocol:
[legend]

List of all members.

Public Member Functions

CDP5Protocol (void)
~CDP5Protocol (void)

Public Attributes

short | InPacketType
Inidicates the incoming packet type;.
unsigned char | PacketIn [24648]
long | RS232BytesInBuffer
Tracks the RS232 number of bytes in the input buffer.
long | RS232_RThreshold
RS232 receive buffer threshold.
bool | RS232HeaderReceived
RS232 header received indicator.
short | RS232PacketPtr
Points to the current incoming data save position in the input buffer.
bool | ScaleAuto
Auto plot scale indicator.
unsigned char | Scope [2048]
Oscilloscope data buffer.
unsigned char | MiscData [512]
Miscellaneous data buffer.
bool | CommError
Communications error indicator.
unsigned char | BufferOUT [520]
Output data buffer.
Spec SPECTRUM
Spectrum data buffer.
Packet_In PIN
Packet input buffer.
bool | ACK_Received
ACK received indicator.
bool | Packet_Received
Packet received indicator.
bool | Timeout_flag
Communication timeout error indicator flag.
int | UDP_offset
bool | Netfinder_active
int | Netfinder_Seq
bool | USB_Default_Timeout
USB default timeout is the longest time period that the USB interface will wait for a transaction.

Detailed Description

Definition at line 302 of file DP5Protocol.h.

Constructor & Destructor Documentation

CDP5Protocol::CDP5Protocol ( void )

Definition at line 3 of file DP5Protocol.cpp.

CDP5Protocol::~CDP5Protocol ( void )

Definition at line 7 of file DP5Protocol.cpp.

Member Data Documentation

bool CDP5Protocol::ACK_Received

ACK received indicator.

Definition at line 338 of file DP5Protocol.h.

unsigned char CDP5Protocol::BufferOUT[520]

Output data buffer.

Definition at line 331 of file DP5Protocol.h.

bool CDP5Protocol::CommError

Communications error indicator.

Definition at line 329 of file DP5Protocol.h.

short CDP5Protocol::InPacketType

Inidicates the incoming packet type;.

Definition at line 309 of file DP5Protocol.h.

unsigned char CDP5Protocol::MiscData[512]

Miscellaneous data buffer.

Definition at line 327 of file DP5Protocol.h.

bool CDP5Protocol::Netfinder_active

Definition at line 345 of file DP5Protocol.h.

int CDP5Protocol::Netfinder_Seq

Definition at line 346 of file DP5Protocol.h.

bool CDP5Protocol::Packet_Received

Packet received indicator.

Definition at line 340 of file DP5Protocol.h.

unsigned char CDP5Protocol::PacketIn[24648]

Definition at line 311 of file DP5Protocol.h.

Packet_In CDP5Protocol::PIN

Packet input buffer.

Definition at line 335 of file DP5Protocol.h.

long CDP5Protocol::RS232_RThreshold

RS232 receive buffer threshold.

Definition at line 316 of file DP5Protocol.h.

long CDP5Protocol::RS232BytesInBuffer

Tracks the RS232 number of bytes in the input buffer.

Definition at line 314 of file DP5Protocol.h.

bool CDP5Protocol::RS232HeaderReceived

RS232 header received indicator.

Definition at line 318 of file DP5Protocol.h.

short CDP5Protocol::RS232PacketPtr

Points to the current incoming data save position in the input buffer.

Definition at line 320 of file DP5Protocol.h.

bool CDP5Protocol::ScaleAuto

Auto plot scale indicator.

Definition at line 323 of file DP5Protocol.h.

unsigned char CDP5Protocol::Scope[2048]

Oscilloscope data buffer.

Definition at line 325 of file DP5Protocol.h.

Spec CDP5Protocol::SPECTRUM

Spectrum data buffer.

Definition at line 333 of file DP5Protocol.h.

bool CDP5Protocol::Timeout_flag

Communication timeout error indicator flag.

Definition at line 342 of file DP5Protocol.h.

int CDP5Protocol::UDP_offset

Definition at line 344 of file DP5Protocol.h.

bool CDP5Protocol::USB_Default_Timeout

USB default timeout is the longest time period that the USB interface will wait for a transaction.

Definition at line 349 of file DP5Protocol.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DP5Protocol.h
  • DeviceIO/DP5Protocol.cpp
Generated on Thu Sep 21 2017 15:25:21 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDP5Status Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDP5Status Class Reference

#include <DP5Status.h>

Collaboration diagram for CDP5Status:
[legend]

List of all members.

Public Member Functions

CDP5Status (void)
~CDP5Status (void)
void | Process_Status (DP4_FORMAT_STATUS *m_DP5_Status)
Convert a DPP status packet into DP4_FORMAT_STATUS data.
string | DP5_Dx_OptionFlags (unsigned char DP5_Dx_Options)
string | ShowStatusValueStrings (DP4_FORMAT_STATUS m_DP5_Status)
Convert DP4_FORMAT_STATUS data into a status display string.
string | PX5_OptionsString (DP4_FORMAT_STATUS m_DP5_Status)
string | GetStatusValueStrings (DP4_FORMAT_STATUS m_DP5_Status)
void | Process_Diagnostics (Packet_In PIN, DiagDataType *dd, int device_type)
Convert a DPP diagnostic data packet into DiagDataType data.
string | DiagnosticsToString (DiagDataType dd, int device_type)
Convert DiagDataType data into a diagnostic display string.
string | DiagStrPX5Option (DiagDataType dd, int device_type)
Convert PX5 Options into a display string.
string | FmtHvPwr (float fVal)
Format a high voltage power value.
string | FmtPc5Pwr (float fVal)
Format a pc5 power value.
string | FmtPc5Temp (float fVal)
Format a pc5 temperature value.
string | FmtHex (long FmtHex, long HexDig)
Format a hexadecimal value.
string | FmtLng (long lVal)
Format a long value.
string | VersionToStr (unsigned char bVersion)
Format a version number value.
string | OnOffStr (bool bOn)
Format an OnOFF indicator value.
string | IsAorB (bool bIsA, string strA, string strB)
Format a boolean indicator value.
string | GetDeviceNameFromVal (int DeviceTypeVal)
Format a device type indicator as a device name string.
string | DisplayBufferArray (unsigned char buffer[], unsigned long bufSizeIn)
Format an string array from a data byte array of values.
void | SaveStringDataToFile (string strData)
Saves a data string to a default file (vcDP5_Data.txt).

Public Attributes

CDppUtilities DppUtil
Utilities to help data processing.
DP4_FORMAT_STATUS m_DP5_Status
DPP status storage.
DiagDataType DiagData
DPP diagnostic data storage.

Detailed Description

Definition at line 104 of file DP5Status.h.

Constructor & Destructor Documentation

CDP5Status::CDP5Status ( void )

Definition at line 9 of file DP5Status.cpp.

CDP5Status::~CDP5Status ( void )

Definition at line 13 of file DP5Status.cpp.

Member Function Documentation

string CDP5Status::DiagnosticsToString | ( | DiagDataType | dd,
 |  | int | device_type
 | ) |  |

Convert DiagDataType data into a diagnostic display string.

Definition at line 447 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::DiagStrPX5Option | ( | DiagDataType | dd,
 |  | int | device_type
 | ) |  |

Convert PX5 Options into a display string.

Definition at line 535 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::DisplayBufferArray | ( | unsigned char | buffer[],
 |  | unsigned long | bufSizeIn
 | ) |  |

Format an string array from a data byte array of values.

Definition at line 683 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::DP5_Dx_OptionFlags ( unsigned char DP5_Dx_Options )

Definition at line 152 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::FmtHex | ( | long | FmtHex,
 |  | long | HexDig
 | ) |  |

Format a hexadecimal value.

Definition at line 605 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtHvPwr ( float fVal )

Format a high voltage power value.

Definition at line 581 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtLng ( long lVal )

Format a long value.

Definition at line 616 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtPc5Pwr ( float fVal )

Format a pc5 power value.

Definition at line 589 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::FmtPc5Temp ( float fVal )

Format a pc5 temperature value.

Definition at line 597 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::GetDeviceNameFromVal ( int DeviceTypeVal )

Format a device type indicator as a device name string.

Definition at line 654 of file DP5Status.cpp.

Here is the caller graph for this function:

string CDP5Status::GetStatusValueStrings ( DP4_FORMAT_STATUS m_DP5_Status )

Definition at line 259 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::IsAorB | ( | bool | bIsA,
 |  | string | strA,
 |  | string | strB
 | ) |  |

Format a boolean indicator value.

Definition at line 645 of file DP5Status.cpp.

Here is the caller graph for this function:

string CDP5Status::OnOffStr ( bool bOn )

Format an OnOFF indicator value.

Definition at line 636 of file DP5Status.cpp.

Here is the caller graph for this function:

void CDP5Status::Process_Diagnostics | ( | Packet_In | PIN,
 |  | DiagDataType * | dd,
 |  | int | device_type
 | ) |  |

Convert a DPP diagnostic data packet into DiagDataType data.

Definition at line 332 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDP5Status::Process_Status ( DP4_FORMAT_STATUS * m_DP5_Status )

Convert a DPP status packet into DP4_FORMAT_STATUS data.

Definition at line 17 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::PX5_OptionsString ( DP4_FORMAT_STATUS m_DP5_Status )

Definition at line 221 of file DP5Status.cpp.

Here is the caller graph for this function:

void CDP5Status::SaveStringDataToFile ( string strData )

Saves a data string to a default file (vcDP5_Data.txt).

Definition at line 705 of file DP5Status.cpp.

Here is the call graph for this function:

string CDP5Status::ShowStatusValueStrings ( DP4_FORMAT_STATUS m_DP5_Status )

Convert DP4_FORMAT_STATUS data into a status display string.

Definition at line 174 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDP5Status::VersionToStr ( unsigned char bVersion )

Format a version number value.

Definition at line 624 of file DP5Status.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

DiagDataType CDP5Status::DiagData

DPP diagnostic data storage.

Definition at line 116 of file DP5Status.h.

CDppUtilities CDP5Status::DppUtil

Utilities to help data processing.

Definition at line 111 of file DP5Status.h.

DP4_FORMAT_STATUS CDP5Status::m_DP5_Status

DPP status storage.

Definition at line 114 of file DP5Status.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DP5Status.h
  • DeviceIO/DP5Status.cpp
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppComm Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes
CDppComm Class Reference

#include <DppComm.h>

List of all members.

Public Member Functions

CDppComm ()
virtual | ~CDppComm ()
BOOL | Settings (CWnd *hPortWnd, UINT PortID=1, UINT BaudRate=115200, char Parity= 'N', UINT DataBits=8, UINT StopBits=1, DWORD dwCommEvents=EV_RXCHAR, UINT nBufferSize=1024)
BOOL | OpenPort ()
BOOL | ClosePort ()
BOOL | IsPortOpen ()
UINT | GetComPortID ()
void | WriteData (unsigned char *string, size_t NumBytes)
bool | SendPacketRS232 (unsigned char Buffer[], CDppComm *CommPort)

Protected Member Functions

void | GetCommErrStr (char *ErrorText)

Static Protected Member Functions

static UINT | DppCommThread (LPVOID pParam)
static void | ReceiveByte (CDppComm *port, COMSTAT comStat)
static void | WriteByte (CDppComm *port)

Protected Attributes

CWinThread * | m_WinThread
CRITICAL_SECTION | m_csCommunicationSync
BOOL | m_bThreadRunning
HANDLE | ghThreadExitEvent
HANDLE | m_hDppComm
HANDLE | m_hWriteEvent
HANDLE | m_hEvents [3]
OVERLAPPED | osIO
COMMTIMEOUTS | m_CommTimeouts
DCB | m_dcb
CWnd * | m_pOwner
unsigned char * | m_szWriteBuffer
DWORD | m_dwCommEvents
DWORD | m_nWriteBufferSize
UINT | PortIDSetting
BOOL | PortIsOpen

Detailed Description

Definition at line 11 of file DppComm.h.

Constructor & Destructor Documentation

CDppComm::CDppComm ( )

Definition at line 5 of file DppComm.cpp.

CDppComm::~CDppComm ( ) [virtual]

Definition at line 23 of file DppComm.cpp.

Member Function Documentation

BOOL CDppComm::ClosePort ( )

Definition at line 231 of file DppComm.cpp.

Here is the caller graph for this function:

UINT CDppComm::DppCommThread ( LPVOID pParam ) [static, protected]

Definition at line 145 of file DppComm.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppComm::GetCommErrStr ( char * ErrorText ) [protected]

Definition at line 259 of file DppComm.cpp.

Here is the caller graph for this function:

UINT CDppComm::GetComPortID ( )

Definition at line 409 of file DppComm.cpp.

BOOL CDppComm::IsPortOpen ( )

Definition at line 414 of file DppComm.cpp.

Here is the caller graph for this function:

BOOL CDppComm::OpenPort ( )

Definition at line 220 of file DppComm.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppComm::ReceiveByte | ( | CDppComm * | port,
 |  | COMSTAT | comStat
 | ) |  | [static, protected]

Definition at line 333 of file DppComm.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CDppComm::SendPacketRS232 | ( | unsigned char | Buffer[],
 |  | CDppComm * | CommPort
 | ) |  |

Definition at line 419 of file DppComm.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CDppComm::Settings | ( | CWnd * | hPortWnd,
 |  | UINT | PortID = 1,
 |  | UINT | BaudRate = 115200,
 |  | char | Parity = 'N',
 |  | UINT | DataBits = 8,
 |  | UINT | StopBits = 1,
 |  | DWORD | dwCommEvents = EV_RXCHAR,
 |  | UINT | nBufferSize = 1024
 | ) |  |

Definition at line 45 of file DppComm.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppComm::WriteByte ( CDppComm * port ) [static, protected]

Definition at line 281 of file DppComm.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppComm::WriteData | ( | unsigned char * | string,
 |  | size_t | NumBytes
 | ) |  |

Definition at line 397 of file DppComm.cpp.

Here is the caller graph for this function:

Member Data Documentation

HANDLE CDppComm::ghThreadExitEvent [protected]

Definition at line 32 of file DppComm.h.

BOOL CDppComm::m_bThreadRunning [protected]

Definition at line 31 of file DppComm.h.

COMMTIMEOUTS CDppComm::m_CommTimeouts [protected]

Definition at line 37 of file DppComm.h.

CRITICAL_SECTION CDppComm::m_csCommunicationSync [protected]

Definition at line 30 of file DppComm.h.

DCB CDppComm::m_dcb [protected]

Definition at line 38 of file DppComm.h.

DWORD CDppComm::m_dwCommEvents [protected]

Definition at line 41 of file DppComm.h.

HANDLE CDppComm::m_hDppComm [protected]

Definition at line 33 of file DppComm.h.

HANDLE CDppComm::m_hEvents[3] [protected]

Definition at line 35 of file DppComm.h.

HANDLE CDppComm::m_hWriteEvent [protected]

Definition at line 34 of file DppComm.h.

DWORD CDppComm::m_nWriteBufferSize [protected]

Definition at line 42 of file DppComm.h.

CWnd* CDppComm::m_pOwner [protected]

Definition at line 39 of file DppComm.h.

unsigned char* CDppComm::m_szWriteBuffer [protected]

Definition at line 40 of file DppComm.h.

CWinThread* CDppComm::m_WinThread [protected]

Definition at line 29 of file DppComm.h.

OVERLAPPED CDppComm::osIO [protected]

Definition at line 36 of file DppComm.h.

UINT CDppComm::PortIDSetting [protected]

Definition at line 43 of file DppComm.h.

BOOL CDppComm::PortIsOpen [protected]

Definition at line 44 of file DppComm.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DppComm.h
  • DeviceIO/DppComm.cpp
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppConfig Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDppConfig Class Reference

#include <DppConfig.h>

List of all members.

Public Member Functions

CDppConfig (void)
~CDppConfig (void)
long | ProcessUSBData ()
CString | GetDeviceNameFromVal (int DeviceTypeVal)
double | UCHARVersionToDouble (unsigned char Version)

Public Attributes

bool | isCfgChanged
BOOL | DisplayCfg
BOOL | CfgReadBack
BOOL | DisplaySca
BOOL | ScaReadBack
BOOL | SaveCfg
BOOL | PrintCfg
int | Port
double | SlowCount
double | GPCount
double | FastCount
double | AccumulationTime
double | RealTime
double | LiveTime
unsigned char | Firmware
unsigned char | Build
bool | isDPP5
unsigned long | SerialNumber
long | Preset
double | PresetRt
double | PresetLt
double | PresetAcq
CString | strPresetCmd
CString | strPresetVal
int | Avg
int | FlatTop
double | FlatTopUS
unsigned char | DetReset
unsigned char | SlowChThreshold
double | SlowThresholdPct
unsigned char | FastChThreshold
long | Offset
unsigned char | DAC_Enable
int | DAC
int | MCA
long | mcaCH
BOOL | MCAEnable
BOOL | PUREnable
int | Rise
double | RiseUS
BOOL | BaselineOn
unsigned char | RTDSlow
int | Gain
unsigned char | RTDOn
unsigned char | RTDFast
unsigned char | BLR
unsigned char | FPGA
unsigned char | Gate
unsigned char | BufferSelect
unsigned char | AcqMode
unsigned char | MCSEnable
unsigned char | MCSTimebase
BOOL | MCSDone
BOOL | PresetRtDone
BOOL | PresetLtDone
BOOL | isPresetAcq
bool | TECEnabled
long | TEC
double | TECMonitor
CString | TECMonitorCStr
BOOL | HVEnabled
long | HV
double | HVMonitor
CString | HVMonitorCStr
BOOL | XR100
BOOL | SEL8_5V
long | PoleZero
long | PX4InputOffset
long | PX4FineGain
BOOL | InvertEn
BOOL | IndLED
BOOL | IndBuzzer
BOOL | PwrCtrl9V
BOOL | PwrCtrl5VA
int | AuxOut
unsigned long | PresetCount
unsigned long | SCA [8]
int | BoardTemp
CString | BoardTempCStr
unsigned char | BootStatus
bool | PwrBtnConfig
BOOL | SwConfigRcvd
BOOL | StatMcaEnabled
int | DeviceType
bool | isDeltaMode
double | GainDelta
double | PX4Gain
CString | strGainDisplayValue
int | HVRangeInd
int | StatDevInd
BOOL | PresetCountExpired
bool | NavPanelUpdate
bool | HwCfgFromDLG
CString | strPercentDeadTime
CString | StartTime
int | USBDataRefreshRate
bool | RefreshDppGeneral
bool | RefreshDppMCA
bool | RefreshDppShaping
bool | RefreshDppPower
bool | RefreshDppGainPZ
bool | RefreshDppMisc
bool | RefreshDppTest
double | DCal
bool | ScopeTriggerFalling
int | ScopeTriggerPosition
unsigned char | Scope [USB_SCOPE_SIZE]
BOOL | UpdateScopeCfg
BOOL | LoadRestartInProgress
CString | LoadRestartStatus
BOOL | LoadRestartInputOffset
BOOL | LoadRestartInputOffsetSlow
BOOL | LoadRestartFastThresh
BOOL | LoadRestartSlowThresh
BOOL | SetFastThreshDone
BOOL | SetInputOffsetDone
int | CfgModCount
double | bb_DeadTimeCounter
USHORT | bb_DiodeCalDACSet
USHORT | bb_TECCurrentLimit
USHORT | bb_BootFlags
USHORT | bb_HVDACSet
USHORT | bb_TECDACSet
USHORT | bb_InputOffsetTuning
USHORT | bb_uCTempCal
USHORT | bb_SpectrumOffset
BOOL | NeedsDP5ReBoot
BOOL | b80MHzMode
BOOL | b80MHzModeCfg
BOOL | bFPGAAutoClock
BOOL | bGammaRadHVMode
BOOL | bConfigHVPolarity
double | dblConfigHV
BOOL | bPC5Detected
BOOL | bBootHVPolarity
BOOL | bAnalogPolarity
CString | strAnalogOut
CString | strInputOffset
CString | strOutputOffset
CString | strScopeGain
CString | strTriggerSource
CString | strTriggerPosition
CString | strTriggerSlope
CString | strMcaMode

Detailed Description

Definition at line 43 of file DppConfig.h.

Constructor & Destructor Documentation

CDppConfig::CDppConfig ( void )

Definition at line 14 of file DppConfig.cpp.

CDppConfig::~CDppConfig ( void )

Definition at line 61 of file DppConfig.cpp.

Member Function Documentation

CString CDppConfig::GetDeviceNameFromVal ( int DeviceTypeVal )
long CDppConfig::ProcessUSBData ( )
double CDppConfig::UCHARVersionToDouble ( unsigned char Version )

Member Data Documentation

double CDppConfig::AccumulationTime

Definition at line 75 of file DppConfig.h.

unsigned char CDppConfig::AcqMode

Definition at line 120 of file DppConfig.h.

int CDppConfig::AuxOut

Definition at line 157 of file DppConfig.h.

int CDppConfig::Avg

Definition at line 95 of file DppConfig.h.

BOOL CDppConfig::b80MHzMode

Definition at line 229 of file DppConfig.h.

BOOL CDppConfig::b80MHzModeCfg

Definition at line 230 of file DppConfig.h.

BOOL CDppConfig::bAnalogPolarity

Definition at line 239 of file DppConfig.h.

BOOL CDppConfig::BaselineOn

Definition at line 111 of file DppConfig.h.

USHORT CDppConfig::bb_BootFlags

Definition at line 222 of file DppConfig.h.

double CDppConfig::bb_DeadTimeCounter

Definition at line 219 of file DppConfig.h.

USHORT CDppConfig::bb_DiodeCalDACSet

Definition at line 220 of file DppConfig.h.

USHORT CDppConfig::bb_HVDACSet

Definition at line 223 of file DppConfig.h.

USHORT CDppConfig::bb_InputOffsetTuning

Definition at line 225 of file DppConfig.h.

USHORT CDppConfig::bb_SpectrumOffset

Definition at line 227 of file DppConfig.h.

USHORT CDppConfig::bb_TECCurrentLimit

Definition at line 221 of file DppConfig.h.

USHORT CDppConfig::bb_TECDACSet

Definition at line 224 of file DppConfig.h.

USHORT CDppConfig::bb_uCTempCal

Definition at line 226 of file DppConfig.h.

BOOL CDppConfig::bBootHVPolarity

Definition at line 238 of file DppConfig.h.

BOOL CDppConfig::bConfigHVPolarity

Definition at line 235 of file DppConfig.h.

BOOL CDppConfig::bFPGAAutoClock

Definition at line 231 of file DppConfig.h.

BOOL CDppConfig::bGammaRadHVMode

Definition at line 234 of file DppConfig.h.

unsigned char CDppConfig::BLR

Definition at line 116 of file DppConfig.h.

int CDppConfig::BoardTemp

Definition at line 161 of file DppConfig.h.

CString CDppConfig::BoardTempCStr

Definition at line 162 of file DppConfig.h.

unsigned char CDppConfig::BootStatus

Definition at line 163 of file DppConfig.h.

BOOL CDppConfig::bPC5Detected

Definition at line 237 of file DppConfig.h.

unsigned char CDppConfig::BufferSelect

Definition at line 119 of file DppConfig.h.

unsigned char CDppConfig::Build

Definition at line 81 of file DppConfig.h.

int CDppConfig::CfgModCount

Definition at line 214 of file DppConfig.h.

BOOL CDppConfig::CfgReadBack

Definition at line 60 of file DppConfig.h.

int CDppConfig::DAC

Definition at line 104 of file DppConfig.h.

unsigned char CDppConfig::DAC_Enable

Definition at line 103 of file DppConfig.h.

double CDppConfig::dblConfigHV

Definition at line 236 of file DppConfig.h.

double CDppConfig::DCal

Definition at line 195 of file DppConfig.h.

unsigned char CDppConfig::DetReset

Definition at line 98 of file DppConfig.h.

int CDppConfig::DeviceType

Definition at line 168 of file DppConfig.h.

BOOL CDppConfig::DisplayCfg

Definition at line 59 of file DppConfig.h.

BOOL CDppConfig::DisplaySca

Definition at line 62 of file DppConfig.h.

unsigned char CDppConfig::FastChThreshold

Definition at line 101 of file DppConfig.h.

double CDppConfig::FastCount

Definition at line 74 of file DppConfig.h.

unsigned char CDppConfig::Firmware

Definition at line 80 of file DppConfig.h.

int CDppConfig::FlatTop

Definition at line 96 of file DppConfig.h.

double CDppConfig::FlatTopUS

Definition at line 97 of file DppConfig.h.

unsigned char CDppConfig::FPGA

Definition at line 117 of file DppConfig.h.

int CDppConfig::Gain

Definition at line 113 of file DppConfig.h.

double CDppConfig::GainDelta

Definition at line 171 of file DppConfig.h.

unsigned char CDppConfig::Gate

Definition at line 118 of file DppConfig.h.

double CDppConfig::GPCount

Definition at line 73 of file DppConfig.h.

long CDppConfig::HV

Definition at line 138 of file DppConfig.h.

BOOL CDppConfig::HVEnabled

Definition at line 137 of file DppConfig.h.

double CDppConfig::HVMonitor

Definition at line 139 of file DppConfig.h.

CString CDppConfig::HVMonitorCStr

Definition at line 140 of file DppConfig.h.

int CDppConfig::HVRangeInd

Definition at line 176 of file DppConfig.h.

bool CDppConfig::HwCfgFromDLG

Definition at line 180 of file DppConfig.h.

BOOL CDppConfig::IndBuzzer

Definition at line 154 of file DppConfig.h.

BOOL CDppConfig::IndLED

Definition at line 153 of file DppConfig.h.

BOOL CDppConfig::InvertEn

Definition at line 150 of file DppConfig.h.

bool CDppConfig::isCfgChanged

Definition at line 58 of file DppConfig.h.

bool CDppConfig::isDeltaMode

Definition at line 169 of file DppConfig.h.

bool CDppConfig::isDPP5

Definition at line 82 of file DppConfig.h.

BOOL CDppConfig::isPresetAcq

Definition at line 126 of file DppConfig.h.

double CDppConfig::LiveTime

Definition at line 77 of file DppConfig.h.

BOOL CDppConfig::LoadRestartFastThresh

Definition at line 207 of file DppConfig.h.

BOOL CDppConfig::LoadRestartInProgress

Definition at line 203 of file DppConfig.h.

BOOL CDppConfig::LoadRestartInputOffset

Definition at line 205 of file DppConfig.h.

BOOL CDppConfig::LoadRestartInputOffsetSlow

Definition at line 206 of file DppConfig.h.

BOOL CDppConfig::LoadRestartSlowThresh

Definition at line 208 of file DppConfig.h.

CString CDppConfig::LoadRestartStatus

Definition at line 204 of file DppConfig.h.

int CDppConfig::MCA

Definition at line 105 of file DppConfig.h.

long CDppConfig::mcaCH

Definition at line 106 of file DppConfig.h.

BOOL CDppConfig::MCAEnable

Definition at line 107 of file DppConfig.h.

BOOL CDppConfig::MCSDone

Definition at line 123 of file DppConfig.h.

unsigned char CDppConfig::MCSEnable

Definition at line 121 of file DppConfig.h.

unsigned char CDppConfig::MCSTimebase

Definition at line 122 of file DppConfig.h.

bool CDppConfig::NavPanelUpdate

Definition at line 179 of file DppConfig.h.

BOOL CDppConfig::NeedsDP5ReBoot

Definition at line 228 of file DppConfig.h.

long CDppConfig::Offset

Definition at line 102 of file DppConfig.h.

long CDppConfig::PoleZero

Definition at line 145 of file DppConfig.h.

int CDppConfig::Port

Definition at line 67 of file DppConfig.h.

long CDppConfig::Preset

Definition at line 86 of file DppConfig.h.

double CDppConfig::PresetAcq

Definition at line 89 of file DppConfig.h.

unsigned long CDppConfig::PresetCount

Definition at line 158 of file DppConfig.h.

BOOL CDppConfig::PresetCountExpired

Definition at line 178 of file DppConfig.h.

double CDppConfig::PresetLt

Definition at line 88 of file DppConfig.h.

BOOL CDppConfig::PresetLtDone

Definition at line 125 of file DppConfig.h.

double CDppConfig::PresetRt

Definition at line 87 of file DppConfig.h.

BOOL CDppConfig::PresetRtDone

Definition at line 124 of file DppConfig.h.

BOOL CDppConfig::PrintCfg

Definition at line 66 of file DppConfig.h.

BOOL CDppConfig::PUREnable

Definition at line 108 of file DppConfig.h.

bool CDppConfig::PwrBtnConfig

Definition at line 164 of file DppConfig.h.

BOOL CDppConfig::PwrCtrl5VA

Definition at line 156 of file DppConfig.h.

BOOL CDppConfig::PwrCtrl9V

Definition at line 155 of file DppConfig.h.

long CDppConfig::PX4FineGain

Definition at line 149 of file DppConfig.h.

double CDppConfig::PX4Gain

Definition at line 172 of file DppConfig.h.

long CDppConfig::PX4InputOffset

Definition at line 146 of file DppConfig.h.

double CDppConfig::RealTime

Definition at line 76 of file DppConfig.h.

bool CDppConfig::RefreshDppGainPZ

Definition at line 191 of file DppConfig.h.

bool CDppConfig::RefreshDppGeneral

Definition at line 187 of file DppConfig.h.

bool CDppConfig::RefreshDppMCA

Definition at line 188 of file DppConfig.h.

bool CDppConfig::RefreshDppMisc

Definition at line 192 of file DppConfig.h.

bool CDppConfig::RefreshDppPower

Definition at line 190 of file DppConfig.h.

bool CDppConfig::RefreshDppShaping

Definition at line 189 of file DppConfig.h.

bool CDppConfig::RefreshDppTest

Definition at line 193 of file DppConfig.h.

int CDppConfig::Rise

Definition at line 109 of file DppConfig.h.

double CDppConfig::RiseUS

Definition at line 110 of file DppConfig.h.

unsigned char CDppConfig::RTDFast

Definition at line 115 of file DppConfig.h.

unsigned char CDppConfig::RTDOn

Definition at line 114 of file DppConfig.h.

unsigned char CDppConfig::RTDSlow

Definition at line 112 of file DppConfig.h.

BOOL CDppConfig::SaveCfg

Definition at line 65 of file DppConfig.h.

unsigned long CDppConfig::SCA[8]

Definition at line 159 of file DppConfig.h.

BOOL CDppConfig::ScaReadBack

Definition at line 63 of file DppConfig.h.

unsigned char CDppConfig::Scope[USB_SCOPE_SIZE]

Definition at line 200 of file DppConfig.h.

bool CDppConfig::ScopeTriggerFalling

Definition at line 197 of file DppConfig.h.

int CDppConfig::ScopeTriggerPosition

Definition at line 198 of file DppConfig.h.

BOOL CDppConfig::SEL8_5V

Definition at line 142 of file DppConfig.h.

unsigned long CDppConfig::SerialNumber

Definition at line 85 of file DppConfig.h.

BOOL CDppConfig::SetFastThreshDone

Definition at line 209 of file DppConfig.h.

BOOL CDppConfig::SetInputOffsetDone

Definition at line 210 of file DppConfig.h.

unsigned char CDppConfig::SlowChThreshold

Definition at line 99 of file DppConfig.h.

double CDppConfig::SlowCount

Definition at line 72 of file DppConfig.h.

double CDppConfig::SlowThresholdPct

Definition at line 100 of file DppConfig.h.

CString CDppConfig::StartTime

Definition at line 183 of file DppConfig.h.

int CDppConfig::StatDevInd

Definition at line 177 of file DppConfig.h.

BOOL CDppConfig::StatMcaEnabled

Definition at line 166 of file DppConfig.h.

CString CDppConfig::strAnalogOut

Definition at line 242 of file DppConfig.h.

CString CDppConfig::strGainDisplayValue

Definition at line 173 of file DppConfig.h.

CString CDppConfig::strInputOffset

Definition at line 244 of file DppConfig.h.

CString CDppConfig::strMcaMode

Definition at line 252 of file DppConfig.h.

CString CDppConfig::strOutputOffset

Definition at line 245 of file DppConfig.h.

CString CDppConfig::strPercentDeadTime

Definition at line 182 of file DppConfig.h.

CString CDppConfig::strPresetCmd

Definition at line 90 of file DppConfig.h.

CString CDppConfig::strPresetVal

Definition at line 91 of file DppConfig.h.

CString CDppConfig::strScopeGain

Definition at line 246 of file DppConfig.h.

CString CDppConfig::strTriggerPosition

Definition at line 249 of file DppConfig.h.

CString CDppConfig::strTriggerSlope

Definition at line 250 of file DppConfig.h.

CString CDppConfig::strTriggerSource

Definition at line 248 of file DppConfig.h.

BOOL CDppConfig::SwConfigRcvd

Definition at line 165 of file DppConfig.h.

long CDppConfig::TEC

Definition at line 134 of file DppConfig.h.

bool CDppConfig::TECEnabled

Definition at line 133 of file DppConfig.h.

double CDppConfig::TECMonitor

Definition at line 135 of file DppConfig.h.

CString CDppConfig::TECMonitorCStr

Definition at line 136 of file DppConfig.h.

BOOL CDppConfig::UpdateScopeCfg

Definition at line 201 of file DppConfig.h.

int CDppConfig::USBDataRefreshRate

Definition at line 184 of file DppConfig.h.

BOOL CDppConfig::XR100

Definition at line 141 of file DppConfig.h.

The documentation for this class was generated from the following files:
  • Config/DppConfig.h
  • Config/DppConfig.cpp
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppGain Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDppGain Class Reference

#include <DppGain.h>

List of all members.

Public Member Functions

CDppGain (void)
~CDppGain (void)
int | GetGainCount (DppAGainTable GainTable)
CString | GetTotalGainLimitsLabel (DppAGainTable GainTable)
double | GetTotalGainLimitsMin (DppAGainTable GainTable)
double | GetTotalGainLimitsMax (DppAGainTable GainTable)
BOOL | isInTotalGainRange (CString strTotalGain, DppAGainTable GainTable)
CString | FixTotalGainRange (CString strTotalGain, DppAGainTable GainTable)
double * | GetGainTablePtr (DppAGainTable GainTable)
void | LoadGainTableValues (CComboBox *m_CoarseGain, DppAGainTable GainTable)
void | LoadGainTableIndexes (CComboBox *m_CoarseGain, DppAGainTable GainTable)
double | FixTotalGainRangeDbl (double dblTotalGain, DppAGainTable GainTable)

Public Attributes

DppAGainTable GainTable
double * | ptrGainTable
double | MinGain
double | MaxGain
int | GainTableCount

Detailed Description

Definition at line 74 of file DppGain.h.

Constructor & Destructor Documentation

CDppGain::CDppGain ( void )

Definition at line 5 of file DppGain.cpp.

CDppGain::~CDppGain ( void )

Definition at line 10 of file DppGain.cpp.

Member Function Documentation

CString CDppGain::FixTotalGainRange | ( | CString | strTotalGain,
 |  | DppAGainTable | GainTable
 | ) |  |

Definition at line 115 of file DppGain.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

double CDppGain::FixTotalGainRangeDbl | ( | double | dblTotalGain,
 |  | DppAGainTable | GainTable
 | ) |  |

Definition at line 195 of file DppGain.cpp.

Here is the call graph for this function:

int CDppGain::GetGainCount ( DppAGainTable GainTable )

Definition at line 15 of file DppGain.cpp.

Here is the caller graph for this function:

double * CDppGain::GetGainTablePtr ( DppAGainTable GainTable )

Definition at line 139 of file DppGain.cpp.

Here is the caller graph for this function:

CString CDppGain::GetTotalGainLimitsLabel ( DppAGainTable GainTable )

Definition at line 36 of file DppGain.cpp.

Here is the caller graph for this function:

double CDppGain::GetTotalGainLimitsMax ( DppAGainTable GainTable )

Definition at line 78 of file DppGain.cpp.

Here is the caller graph for this function:

double CDppGain::GetTotalGainLimitsMin ( DppAGainTable GainTable )

Definition at line 57 of file DppGain.cpp.

Here is the caller graph for this function:

BOOL CDppGain::isInTotalGainRange | ( | CString | strTotalGain,
 |  | DppAGainTable | GainTable
 | ) |  |

Definition at line 99 of file DppGain.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppGain::LoadGainTableIndexes | ( | CComboBox * | m_CoarseGain,
 |  | DppAGainTable | GainTable
 | ) |  |

Definition at line 181 of file DppGain.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppGain::LoadGainTableValues | ( | CComboBox * | m_CoarseGain,
 |  | DppAGainTable | GainTable
 | ) |  |

Definition at line 160 of file DppGain.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

DppAGainTable CDppGain::GainTable

Definition at line 79 of file DppGain.h.

int CDppGain::GainTableCount

Definition at line 83 of file DppGain.h.

double CDppGain::MaxGain

Definition at line 82 of file DppGain.h.

double CDppGain::MinGain

Definition at line 81 of file DppGain.h.

double* CDppGain::ptrGainTable

Definition at line 80 of file DppGain.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/DppGain.h
  • DP5Cfg/DppGain.cpp
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppLibUsb Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDppLibUsb Class Reference

#include <DppLibUsb.h>

List of all members.

Public Member Functions

CDppLibUsb (void)
~CDppLibUsb (void)
int | InitializeLibusb ()
void | DeinitializeLibusb ()
libusb_device_handle * | FindUSBDevice (int idxAmptekDevice)
void | CloseUSBDevice (libusb_device_handle *devh)
int | SendPacketUSB (libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[])
bool | isAmptekDP5Device (libusb_device_descriptor desc)
int | CountDP5LibusbDevices ()
void | PrintDevices ()
const char * | libusb_strerror (enum libusb_error error_code)

Public Attributes

unsigned char | data_in [MAX_BULK_IN_TRANSFER_SIZE]
unsigned char | data_out [MAX_BULK_OUT_TRANSFER_SIZE]
libusb_device_handle * | DppLibusbHandle
int | NumDevices
int | CurrentDevice
bool | bLibusbReady
bool | bDeviceReady
char | LastLibUsbError [256]
bool | bDeviceConnected

Detailed Description

Definition at line 36 of file DppLibUsb.h.

Constructor & Destructor Documentation

CDppLibUsb::CDppLibUsb ( void )

Definition at line 3 of file DppLibUsb.cpp.

CDppLibUsb::~CDppLibUsb ( void )

Definition at line 7 of file DppLibUsb.cpp.

Member Function Documentation

void CDppLibUsb::CloseUSBDevice ( libusb_device_handle * devh )

Definition at line 91 of file DppLibUsb.cpp.

Here is the call graph for this function:

int CDppLibUsb::CountDP5LibusbDevices ( )

Definition at line 154 of file DppLibUsb.cpp.

Here is the call graph for this function:

void CDppLibUsb::DeinitializeLibusb ( )

Definition at line 25 of file DppLibUsb.cpp.

libusb_device_handle * CDppLibUsb::FindUSBDevice ( int idxAmptekDevice )

Definition at line 32 of file DppLibUsb.cpp.

Here is the call graph for this function:

int CDppLibUsb::InitializeLibusb ( )

Definition at line 13 of file DppLibUsb.cpp.

Here is the call graph for this function:

bool CDppLibUsb::isAmptekDP5Device ( libusb_device_descriptor desc )

Definition at line 142 of file DppLibUsb.cpp.

Here is the caller graph for this function:

const char * CDppLibUsb::libusb_strerror ( enum libusb_error error_code )

Definition at line 207 of file DppLibUsb.cpp.

Here is the caller graph for this function:

void CDppLibUsb::PrintDevices ( )

Definition at line 179 of file DppLibUsb.cpp.

Here is the call graph for this function:

int CDppLibUsb::SendPacketUSB | ( | libusb_device_handle * | devh,
 |  | unsigned char | data_out[],
 |  | unsigned char | data_in[]
 | ) |  |

Definition at line 103 of file DppLibUsb.cpp.

Member Data Documentation

bool CDppLibUsb::bDeviceConnected

Definition at line 51 of file DppLibUsb.h.

bool CDppLibUsb::bDeviceReady

Definition at line 49 of file DppLibUsb.h.

bool CDppLibUsb::bLibusbReady

Definition at line 48 of file DppLibUsb.h.

int CDppLibUsb::CurrentDevice

Definition at line 47 of file DppLibUsb.h.

unsigned char CDppLibUsb::data_in[MAX_BULK_IN_TRANSFER_SIZE]

Definition at line 42 of file DppLibUsb.h.

unsigned char CDppLibUsb::data_out[MAX_BULK_OUT_TRANSFER_SIZE]

Definition at line 43 of file DppLibUsb.h.

libusb_device_handle* CDppLibUsb::DppLibusbHandle

Definition at line 45 of file DppLibUsb.h.

char CDppLibUsb::LastLibUsbError[256]

Definition at line 50 of file DppLibUsb.h.

int CDppLibUsb::NumDevices

Definition at line 46 of file DppLibUsb.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DppLibUsb.h
  • DeviceIO/DppLibUsb.cpp
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppShaping Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDppShaping Class Reference

#include <DppShaping.h>

List of all members.

Public Member Functions

CDppShaping (void)
~CDppShaping (void)
void | Shaping_Setup (CComboBox *cboRiseObj, CComboBox *cboTopObj)
CString | GetRiseValueFromIndex (int RiseIndex, BOOL isRiseAveCalc)
CString | GetDefaultFlatTopFromRiseIndex (int RiseIndex, double dblFlatTop)
double | GetDblValFromComboText (CComboBox *m_ComboBoxCtrl)
void | SetRiseCombo ()
void | SetTopCombo ()
void | Set80MHzMode (BOOL is80Mhz)
CString | dbl_to_uS (double dblVal)

Public Attributes

double | dblPeakingMult
BOOL | b80MHzMode

Detailed Description

Definition at line 31 of file DppShaping.h.

Constructor & Destructor Documentation

CDppShaping::CDppShaping ( void )

Definition at line 6 of file DppShaping.cpp.

CDppShaping::~CDppShaping ( void )

Definition at line 12 of file DppShaping.cpp.

Member Function Documentation

CString CDppShaping::dbl_to_uS ( double dblVal )

Definition at line 261 of file DppShaping.cpp.

Here is the caller graph for this function:

double CDppShaping::GetDblValFromComboText ( CComboBox * m_ComboBoxCtrl )

Definition at line 199 of file DppShaping.cpp.

Here is the caller graph for this function:

CString CDppShaping::GetDefaultFlatTopFromRiseIndex | ( | int | RiseIndex,
 |  | double | dblFlatTop
 | ) |  |

Definition at line 126 of file DppShaping.cpp.

Here is the call graph for this function:

CString CDppShaping::GetRiseValueFromIndex | ( | int | RiseIndex,
 |  | BOOL | isRiseAveCalc = FALSE
 | ) |  |

Definition at line 68 of file DppShaping.cpp.

Here is the caller graph for this function:

void CDppShaping::Set80MHzMode ( BOOL is80Mhz )

Definition at line 16 of file DppShaping.cpp.

Here is the caller graph for this function:

void CDppShaping::SetRiseCombo ( )

Definition at line 214 of file DppShaping.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppShaping::SetTopCombo ( )

Definition at line 290 of file DppShaping.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppShaping::Shaping_Setup | ( | CComboBox * | cboRiseObj,
 |  | CComboBox * | cboTopObj
 | ) |  |

Definition at line 29 of file DppShaping.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

BOOL CDppShaping::b80MHzMode

Definition at line 51 of file DppShaping.h.

double CDppShaping::dblPeakingMult

Definition at line 50 of file DppShaping.h.

The documentation for this class was generated from the following files:
  • Config/DppShaping.h
  • Config/DppShaping.cpp
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppSlowThreshold Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CDppSlowThreshold Class Reference

#include <DppSlowThreshold.h>

List of all members.

Public Member Functions

CDppSlowThreshold (void)
~CDppSlowThreshold (void)
unsigned char | GetSlowChThreshold ()
void | SetSlowChThreshold (unsigned char SlowChThresholdVal)
void | Thresholds_Setup (CSpinButtonCtrl *udThresholdObj, CEdit *lblThresholdObj, CEdit *lblThresholdChannelsObj)
void | SetSlowChThresholdFromStr (CString strSlowThresh)
void | SetSlowChThresholdFromVal (int intSlowThresh)
void | SetSlowChThresholdConfigFromStr (CString strSlowThresh)
void | DPPThreshold (int SpinPos)
CString | GetSlowThreshPcntStr ()
CString | GetSlowChThresStrFromVal (unsigned char byteSlowThres)
void | txtSlowThreshold_Click ()
void | txtSlowThresholdChannels_Click ()
void | SetGain (long GainVal)
CString | GetSlowThreshChStr ()
CString | GetSlowThreshChStrFromVal (unsigned char byteSlowThres)
void | UpdateSlowThresChDisplay ()
unsigned char | GetSlowThresholdSettingFromChannels (double dblSlowThreshChannels)
unsigned char | GetSlowThresholdSettingFromPercent (double dblSlowThresh)

Detailed Description

Definition at line 3 of file DppSlowThreshold.h.

Constructor & Destructor Documentation

CDppSlowThreshold::CDppSlowThreshold ( void )

Definition at line 25 of file DppSlowThreshold.cpp.

CDppSlowThreshold::~CDppSlowThreshold ( void )

Definition at line 29 of file DppSlowThreshold.cpp.

Member Function Documentation

void CDppSlowThreshold::DPPThreshold ( int SpinPos )

Definition at line 116 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

unsigned char CDppSlowThreshold::GetSlowChThreshold ( )

Definition at line 34 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

CString CDppSlowThreshold::GetSlowChThresStrFromVal ( unsigned char byteSlowThres )

Definition at line 133 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

CString CDppSlowThreshold::GetSlowThreshChStr ( )

Definition at line 261 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

CString CDppSlowThreshold::GetSlowThreshChStrFromVal ( unsigned char byteSlowThres )

Definition at line 273 of file DppSlowThreshold.cpp.

unsigned char CDppSlowThreshold::GetSlowThresholdSettingFromChannels ( double dblSlowThreshChannels )

Definition at line 237 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

unsigned char CDppSlowThreshold::GetSlowThresholdSettingFromPercent ( double dblSlowThresh )

Definition at line 176 of file DppSlowThreshold.cpp.

CString CDppSlowThreshold::GetSlowThreshPcntStr ( )

Definition at line 124 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppSlowThreshold::SetGain ( long GainVal )

Definition at line 68 of file DppSlowThreshold.cpp.

Here is the caller graph for this function:

void CDppSlowThreshold::SetSlowChThreshold ( unsigned char SlowChThresholdVal )

Definition at line 38 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::SetSlowChThresholdConfigFromStr ( CString strSlowThresh )

Definition at line 102 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::SetSlowChThresholdFromStr ( CString strSlowThresh )

Definition at line 84 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::SetSlowChThresholdFromVal ( int intSlowThresh )

Definition at line 93 of file DppSlowThreshold.cpp.

void CDppSlowThreshold::Thresholds_Setup | ( | CSpinButtonCtrl * | udThresholdObj,
 |  | CEdit * | lblThresholdObj,
 |  | CEdit * | lblThresholdChannelsObj
 | ) |  |

Definition at line 46 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

void CDppSlowThreshold::txtSlowThreshold_Click ( )

Definition at line 149 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

void CDppSlowThreshold::txtSlowThresholdChannels_Click ( )

Definition at line 204 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

void CDppSlowThreshold::UpdateSlowThresChDisplay ( )

Definition at line 286 of file DppSlowThreshold.cpp.

Here is the call graph for this function:

The documentation for this class was generated from the following files:
  • Config/DppSlowThreshold.h
  • Config/DppSlowThreshold.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppSocket Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Attributes
CDppSocket Class Reference

#include <DppSocket.h>

List of all members.

Public Member Functions

CDppSocket ()
virtual | ~CDppSocket ()
BOOL | CreateSocket (CWnd *pEvtDlg)
void | CloseSocket ()
void | SetEventDlg (CWnd *pEvtDlg)
void | ResetEventDlg ()
BOOL | IsSocketOpen ()
bool | SendPacketInet (unsigned char Buffer[], CDppSocket *DppSock)
virtual void | OnReceive (int nErrorCode)

Public Attributes

SocketOwnerType m_Owner
u_short | DppPort
u_long | DppAddr
int | RcvCount
int | RcvTotal
BOOL | HaveHeader

Protected Attributes

CWnd * | m_pEvtDlg
BOOL | m_SocketOpen
BOOL | m_DataMode

Detailed Description

Definition at line 22 of file DppSocket.h.

Constructor & Destructor Documentation

CDppSocket::CDppSocket ( )

Definition at line 25 of file DppSocket.cpp.

CDppSocket::~CDppSocket ( ) [virtual]

Definition at line 35 of file DppSocket.cpp.

Member Function Documentation

void CDppSocket::CloseSocket ( )

Definition at line 74 of file DppSocket.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CDppSocket::CreateSocket ( CWnd * pEvtDlg )

Definition at line 52 of file DppSocket.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CDppSocket::IsSocketOpen ( )

Definition at line 79 of file DppSocket.cpp.

Here is the caller graph for this function:

void CDppSocket::OnReceive ( int nErrorCode ) [virtual]

Definition at line 84 of file DppSocket.cpp.

void CDppSocket::ResetEventDlg ( )

Definition at line 109 of file DppSocket.cpp.

Here is the caller graph for this function:

bool CDppSocket::SendPacketInet | ( | unsigned char | Buffer[],
 |  | CDppSocket * | DppSock
 | ) |  |

Definition at line 114 of file DppSocket.cpp.

Here is the caller graph for this function:

void CDppSocket::SetEventDlg ( CWnd * pEvtDlg )

Definition at line 104 of file DppSocket.cpp.

Here is the caller graph for this function:

Member Data Documentation

u_long CDppSocket::DppAddr

Definition at line 43 of file DppSocket.h.

u_short CDppSocket::DppPort

Definition at line 42 of file DppSocket.h.

BOOL CDppSocket::HaveHeader

Definition at line 48 of file DppSocket.h.

BOOL CDppSocket::m_DataMode [protected]

Definition at line 68 of file DppSocket.h.

SocketOwnerType CDppSocket::m_Owner

Definition at line 41 of file DppSocket.h.

CWnd* CDppSocket::m_pEvtDlg [protected]

Definition at line 66 of file DppSocket.h.

BOOL CDppSocket::m_SocketOpen [protected]

Definition at line 67 of file DppSocket.h.

int CDppSocket::RcvCount

Definition at line 46 of file DppSocket.h.

int CDppSocket::RcvTotal

Definition at line 47 of file DppSocket.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DppSocket.h
  • DeviceIO/DppSocket.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppUtilities Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CDppUtilities Class Reference

#include <DppUtilities.h>

List of all members.

Public Member Functions

CDppUtilities (void)
~CDppUtilities (void)
double | LongWordToDouble (int lwStart, unsigned char buffer[])
Covert a long word into a double.
double | BYTEVersionToDouble (unsigned char Version)
Convert a byte version value into a double.
string | BYTEVersionToString (unsigned char Version)
Convert a byte version value into a string.

Detailed Description

Definition at line 7 of file DppUtilities.h.

Constructor & Destructor Documentation

CDppUtilities::CDppUtilities ( void )

Definition at line 4 of file DppUtilities.cpp.

CDppUtilities::~CDppUtilities ( void )

Definition at line 8 of file DppUtilities.cpp.

Member Function Documentation

double CDppUtilities::BYTEVersionToDouble ( unsigned char Version )

Convert a byte version value into a double.

Definition at line 29 of file DppUtilities.cpp.

Here is the call graph for this function:

string CDppUtilities::BYTEVersionToString ( unsigned char Version )

Convert a byte version value into a string.

Definition at line 40 of file DppUtilities.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

double CDppUtilities::LongWordToDouble | ( | int | lwStart,
 |  | unsigned char | buffer[]
 | ) |  |

Covert a long word into a double.

Definition at line 15 of file DppUtilities.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • DeviceIO/DppUtilities.h
  • DeviceIO/DppUtilities.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CDppWinUSB Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CDppWinUSB Class Reference

#include <DppWinUSB.h>

Collaboration diagram for CDppWinUSB:
[legend]

List of all members.

Public Member Functions

CDppWinUSB (void)
~CDppWinUSB (void)
void | Disable_WinUsb ()
void | InitDeviceInfo ()
Initializes the DEVICE_INFO data.
void | CloseDeviceHandle ()
Closes the system device handle.
void | CloseWinUsbDevice ()
Closes the WinUSB device interface handle and frees the resources.
BOOL | GetDevicePath (LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex)
Returns the device path string for a selcted device.
HANDLE | OpenDevice (BOOL bSync, DWORD MemberIndex)
Opens a connection to a selected DPP device.
BOOL | Initialize_Device (DWORD MemberIndex)
Initializes the selected DPP device.
DPP_USB_STATUS | FindUSBDevice (DWORD MemberIndex)
Finds a USB DPP device and sets DEVICE_INFO status indicators. DPP_USB_STATUS is not supported for console applications.
int | CountDP5WinusbDevices (void)
Returns the number of USB devices found.
string | DisplayBufferArray (unsigned char buffer[], unsigned long bufSizeIn)
void | SaveStringDataToFile (string strData)
string | USBStatusString (DPP_USB_STATUS USBStatus)
bool | SendPacketUSB (unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[])
Sends a USB buffer and returns any data read back.

Public Attributes

bool | WinUsb_Disabled
DEVICE_INFO devInfo
Holds the current USB device information.
int | NumPipes
Number of endpoints.
HANDLE | PipeId [MAXPIPES]
Pipe ID array for the current pipes.
unsigned long | PipeTimeout [MAXPIPES]
Pipe timeout value array for the current pipes.
int | CurrentDevice
USB device index. CurrentDevice index starts at 1 for display purposes. WinUSB device indexes (MemberIndex) start at 0.
int | NumDevices
Number of devices found.
bool | isDppFound
Indicates a DPP device has been found.
bool | USB_Default_Timeout

Detailed Description

Definition at line 66 of file DppWinUSB.h.

Constructor & Destructor Documentation

CDppWinUSB::CDppWinUSB ( void )

Definition at line 4 of file DppWinUSB.cpp.

Here is the call graph for this function:

CDppWinUSB::~CDppWinUSB ( void )

Definition at line 14 of file DppWinUSB.cpp.

Member Function Documentation

void CDppWinUSB::CloseDeviceHandle ( )

Closes the system device handle.

Definition at line 30 of file DppWinUSB.cpp.

Here is the caller graph for this function:

void CDppWinUSB::CloseWinUsbDevice ( )

Closes the WinUSB device interface handle and frees the resources.

Definition at line 38 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CDppWinUSB::CountDP5WinusbDevices ( void )

Returns the number of USB devices found.

Definition at line 217 of file DppWinUSB.cpp.

Here is the caller graph for this function:

void CDppWinUSB::Disable_WinUsb ( )

Definition at line 18 of file DppWinUSB.cpp.

string CDppWinUSB::DisplayBufferArray | ( | unsigned char | buffer[],
 |  | unsigned long | bufSizeIn
 | ) |  |

Definition at line 276 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

DPP_USB_STATUS CDppWinUSB::FindUSBDevice ( DWORD MemberIndex )

Finds a USB DPP device and sets DEVICE_INFO status indicators. DPP_USB_STATUS is not supported for console applications.

Definition at line 183 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CDppWinUSB::GetDevicePath | ( | LPGUID | InterfaceGuid,
 |  | PCHAR | DevicePath,
 |  | size_t | BufLen,
 |  | DWORD | MemberIndex
 | ) |  |

Returns the device path string for a selcted device.

Definition at line 51 of file DppWinUSB.cpp.

Here is the caller graph for this function:

void CDppWinUSB::InitDeviceInfo ( )

Initializes the DEVICE_INFO data.

Definition at line 23 of file DppWinUSB.cpp.

Here is the caller graph for this function:

BOOL CDppWinUSB::Initialize_Device ( DWORD MemberIndex )

Initializes the selected DPP device.

Definition at line 117 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

HANDLE CDppWinUSB::OpenDevice | ( | BOOL | bSync,
 |  | DWORD | MemberIndex
 | ) |  |

Opens a connection to a selected DPP device.

Definition at line 97 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CDppWinUSB::SaveStringDataToFile ( string strData )

Definition at line 295 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CDppWinUSB::SendPacketUSB | ( | unsigned char | Buffer[],
 |  | DEVICE_INFO | TestDevInfo,
 |  | unsigned char | PacketIn[]
 | ) |  |

Sends a USB buffer and returns any data read back.

Definition at line 313 of file DppWinUSB.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CDppWinUSB::USBStatusString ( DPP_USB_STATUS USBStatus )

Definition at line 261 of file DppWinUSB.cpp.

Here is the caller graph for this function:

Member Data Documentation

int CDppWinUSB::CurrentDevice

USB device index. CurrentDevice index starts at 1 for display purposes. WinUSB device indexes (MemberIndex) start at 0.

Definition at line 104 of file DppWinUSB.h.

DEVICE_INFO CDppWinUSB::devInfo

Holds the current USB device information.

Definition at line 76 of file DppWinUSB.h.

bool CDppWinUSB::isDppFound

Indicates a DPP device has been found.

Definition at line 108 of file DppWinUSB.h.

int CDppWinUSB::NumDevices

Number of devices found.

Definition at line 106 of file DppWinUSB.h.

int CDppWinUSB::NumPipes

Number of endpoints.

Definition at line 78 of file DppWinUSB.h.

HANDLE CDppWinUSB::PipeId[MAXPIPES]

Pipe ID array for the current pipes.

Definition at line 81 of file DppWinUSB.h.

unsigned long CDppWinUSB::PipeTimeout[MAXPIPES]

Pipe timeout value array for the current pipes.

Definition at line 83 of file DppWinUSB.h.

bool CDppWinUSB::USB_Default_Timeout

Definition at line 117 of file DppWinUSB.h.

bool CDppWinUSB::WinUsb_Disabled

Definition at line 72 of file DppWinUSB.h.

The documentation for this class was generated from the following files:
  • DeviceIO/DppWinUSB.h
  • DeviceIO/DppWinUSB.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CFileBrowse Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes
CFileBrowse Class Reference

#include <FileBrowse.h>

List of all members.

Public Types

enum | DialogType { SAVE, OPEN }

Public Member Functions

CFileBrowse (void)
~CFileBrowse (void)
BOOL | DoModal (int DlgType, CString DlgTitle, CString FileFilter, CString DefaultExt, CString InitDir, CString *Filename)

Public Attributes

CString | CfgFileFilter
CString | TxtFileFilter
CString | ExeFileFilter
CString | BmpFileFilter
CString | McaFileFilter
CString | LibFileFilter
CString | AllFileFilter

Detailed Description

Definition at line 3 of file FileBrowse.h.

Member Enumeration Documentation

enum CFileBrowse::DialogType
Enumerator:
SAVE
OPEN

Definition at line 14 of file FileBrowse.h.

Constructor & Destructor Documentation

CFileBrowse::CFileBrowse ( void )

Definition at line 4 of file FileBrowse.cpp.

CFileBrowse::~CFileBrowse ( void )

Definition at line 16 of file FileBrowse.cpp.

Member Function Documentation

BOOL CFileBrowse::DoModal | ( | int | DlgType,
 |  | CString | DlgTitle,
 |  | CString | FileFilter,
 |  | CString | DefaultExt,
 |  | CString | InitDir,
 |  | CString * | Filename
 | ) |  |

Definition at line 20 of file FileBrowse.cpp.

Here is the caller graph for this function:

Member Data Documentation

CString CFileBrowse::AllFileFilter

Definition at line 25 of file FileBrowse.h.

CString CFileBrowse::BmpFileFilter

Definition at line 22 of file FileBrowse.h.

CString CFileBrowse::CfgFileFilter

Definition at line 19 of file FileBrowse.h.

CString CFileBrowse::ExeFileFilter

Definition at line 21 of file FileBrowse.h.

CString CFileBrowse::LibFileFilter

Definition at line 24 of file FileBrowse.h.

CString CFileBrowse::McaFileFilter

Definition at line 23 of file FileBrowse.h.

CString CFileBrowse::TxtFileFilter

Definition at line 20 of file FileBrowse.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/FileBrowse.h
  • DP5Cfg/FileBrowse.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CFilePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CFilePage Class Reference

#include <FilePage.h>

Inheritance diagram for CFilePage:
[legend]
Collaboration diagram for CFilePage:
[legend]

List of all members.

Public Member Functions

CFilePage ()
~CFilePage ()
virtual BOOL | OnSetActive ()
virtual BOOL | OnInitDialog ()
afx_msg void | OnBnClickedButtonReadConfig ()
void | ReadConfigFromAmptek_NP (CString strFilename, CString strKeyName)
void | ReadConfig ()
void | InitControls ()
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | CboUpdate (int nID_dci)
CString | GetAmptekDC_NP_Section ()
afx_msg void | OnCbnSelchangeReaddetectorconfigcombo ()
void | ReadAmptekDetectorConfigNames ()
afx_msg void | OnCbnSelchangeOptComboResc ()
afx_msg void | OnBnClickedButtonSaveConfig ()
CString | SaveConfigString ()
CString | GetCmdKeyData (CString strCmd, CString strCfgData)
afx_msg void | OnBnClickedButtonEditConfigFromHw ()
afx_msg void | OnBnClickedButtonSendToHardware ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | isCEditBox (int nID)
BOOL | isCComboBox (int nID)
afx_msg void | OnTimer (UINT nIDEvent)
virtual BOOL | OnApply ()
virtual void | OnCancel ()
void | EnableControls (BOOL bEnable)
afx_msg void | OnBnClickedButtonSendToHardwareNoEdit ()
afx_msg void | OnBnClickedRadioDppDeviceType1 ()
afx_msg void | OnBnClickedRadioDppDeviceType2 ()
afx_msg void | OnBnClickedRadioDppDeviceType3 ()
afx_msg void | OnBnClickedRadioDppDeviceType4 ()
afx_msg void | OnBnClickedRadioDppDeviceType5 ()
afx_msg void | OnBnClickedRadioDppDeviceType6 ()
void | SetDppDeviceType (int DeviceType)
void | SelectRadioDppDeviceType (int DeviceType)
void | EnableDeviceSelection (BOOL bEnable)
afx_msg void | OnCbnSelendokReaddetectorconfigcombo ()
afx_msg void | OnBnClickedCheckPc5Present ()
void | SetCheckPc5Present ()
afx_msg void | OnBnClickedCheckDP5DxGains ()
void | SetCheckDP5DxGains ()
afx_msg void | OnStnClickedStaticReadConfig ()
afx_msg void | OnStnClickedStaticSaveConfig ()
afx_msg void | OnBnClickedButtonSendCommand ()
afx_msg void | OnHelp ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)
afx_msg void | OnBnClickedButtonSendCommand2 ()

Public Attributes

CLabel m_FilePageLabel
CLabel m_FileAdvancedLabel
CLabel m_FileStandardLabel
CString | m_strConfigIn
CString | m_strConfigOut
CComboBox | m_ReadDetectorConfigCombo
UINT_PTR | m_nTmrConfigId
UINT_PTR | m_nTmrConfigEventId
UINT | m_nTmrConfigElapse
BOOL | isClosing

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 17 of file FilePage.h.

Constructor & Destructor Documentation

CFilePage::CFilePage ( )

Definition at line 35 of file FilePage.cpp.

CFilePage::~CFilePage ( )

Definition at line 49 of file FilePage.cpp.

Member Function Documentation

void CFilePage::CboUpdate ( int nID_dci )

Definition at line 242 of file FilePage.cpp.

Here is the caller graph for this function:

void CFilePage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 54 of file FilePage.cpp.

void CFilePage::EnableControls ( BOOL bEnable )

Definition at line 980 of file FilePage.cpp.

Here is the caller graph for this function:

void CFilePage::EnableDeviceSelection ( BOOL bEnable )

Definition at line 1117 of file FilePage.cpp.

Here is the caller graph for this function:

CString CFilePage::GetAmptekDC_NP_Section ( )

Definition at line 1128 of file FilePage.cpp.

Here is the caller graph for this function:

CString CFilePage::GetCmdKeyData | ( | CString | strCmd,
 |  | CString | strCfgData
 | ) |  |

Definition at line 629 of file FilePage.cpp.

Here is the caller graph for this function:

void CFilePage::InitControls ( )

Definition at line 197 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 221 of file FilePage.cpp.

Here is the call graph for this function:

BOOL CFilePage::isCComboBox ( int nID )

Definition at line 937 of file FilePage.cpp.

Here is the caller graph for this function:

BOOL CFilePage::isCEditBox ( int nID )

Definition at line 923 of file FilePage.cpp.

Here is the caller graph for this function:

BOOL CFilePage::OnApply ( ) [virtual]

Definition at line 963 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedButtonEditConfigFromHw ( )

Definition at line 649 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::OnBnClickedButtonReadConfig ( )

Definition at line 393 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::OnBnClickedButtonSaveConfig ( )

Definition at line 548 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::OnBnClickedButtonSendCommand ( )

Definition at line 1298 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::OnBnClickedButtonSendCommand2 ( )

Definition at line 1328 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedButtonSendToHardware ( )

use dp5 dx gains

holds eco indicator

Definition at line 790 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::OnBnClickedButtonSendToHardwareNoEdit ( )

Definition at line 999 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedCheckDP5DxGains ( )

Definition at line 1257 of file FilePage.cpp.

void CFilePage::OnBnClickedCheckPc5Present ( )

Definition at line 1220 of file FilePage.cpp.

void CFilePage::OnBnClickedRadioDppDeviceType1 ( )

Definition at line 1041 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedRadioDppDeviceType2 ( )

Definition at line 1048 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedRadioDppDeviceType3 ( )

Definition at line 1055 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedRadioDppDeviceType4 ( )

Definition at line 1062 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedRadioDppDeviceType5 ( )

Definition at line 1069 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnBnClickedRadioDppDeviceType6 ( )

Definition at line 1076 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnCancel ( ) [virtual]

Definition at line 973 of file FilePage.cpp.

void CFilePage::OnCbnSelchangeOptComboResc ( )

Definition at line 948 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnCbnSelchangeReaddetectorconfigcombo ( )

Definition at line 1157 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnCbnSelendokReaddetectorconfigcombo ( )

Definition at line 1213 of file FilePage.cpp.

void CFilePage::OnHelp ( )

Definition at line 1376 of file FilePage.cpp.

BOOL CFilePage::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 1363 of file FilePage.cpp.

BOOL CFilePage::OnInitDialog ( ) [virtual]

Definition at line 131 of file FilePage.cpp.

Here is the call graph for this function:

BOOL CFilePage::OnSetActive ( ) [virtual]

Definition at line 124 of file FilePage.cpp.

void CFilePage::OnStnClickedStaticReadConfig ( )

Definition at line 1288 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnStnClickedStaticSaveConfig ( )

Definition at line 1293 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::OnTimer ( UINT nIDEvent )

Definition at line 953 of file FilePage.cpp.

Here is the call graph for this function:

BOOL CFilePage::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 890 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::ReadAmptekDetectorConfigNames ( )

Definition at line 1176 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::ReadConfig ( )

Definition at line 328 of file FilePage.cpp.

Here is the call graph for this function:

void CFilePage::ReadConfigFromAmptek_NP | ( | CString | strFilename,
 |  | CString | strKeyName
 | ) |  |

Definition at line 470 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CFilePage::SaveConfigString ( )

Definition at line 602 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::SelectRadioDppDeviceType ( int DeviceType )

Definition at line 1091 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CFilePage::SetCheckDP5DxGains ( )

Definition at line 1269 of file FilePage.cpp.

Here is the caller graph for this function:

void CFilePage::SetCheckPc5Present ( )

Definition at line 1234 of file FilePage.cpp.

Here is the caller graph for this function:

void CFilePage::SetDppDeviceType ( int DeviceType )

Definition at line 1082 of file FilePage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

BOOL CFilePage::isClosing

Definition at line 95 of file FilePage.h.

CLabel CFilePage::m_FileAdvancedLabel

Definition at line 51 of file FilePage.h.

CLabel CFilePage::m_FilePageLabel

Definition at line 49 of file FilePage.h.

CLabel CFilePage::m_FileStandardLabel

Definition at line 53 of file FilePage.h.

UINT CFilePage::m_nTmrConfigElapse

Definition at line 91 of file FilePage.h.

UINT_PTR CFilePage::m_nTmrConfigEventId

Definition at line 90 of file FilePage.h.

UINT_PTR CFilePage::m_nTmrConfigId

Definition at line 89 of file FilePage.h.

CComboBox CFilePage::m_ReadDetectorConfigCombo

Definition at line 72 of file FilePage.h.

CString CFilePage::m_strConfigIn

Definition at line 56 of file FilePage.h.

CString CFilePage::m_strConfigOut

Definition at line 57 of file FilePage.h.

CToolTipCtrl CFilePage::m_ToolTip [protected]

Definition at line 45 of file FilePage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/FilePage.h
  • DP5Cfg/FilePage.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CGainPzPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CGainPzPage Class Reference

#include <GainPzPage.h>

Inheritance diagram for CGainPzPage:
[legend]
Collaboration diagram for CGainPzPage:
[legend]

List of all members.

Public Member Functions

CGainPzPage ()
~CGainPzPage ()
void | BuildToolTips ()
virtual BOOL | OnSetActive ()
virtual BOOL | OnInitDialog ()
void | InitControls ()
void | ShowMCA8000D_Controls (int iShowWin)
void | CheckMCA8000D_FineGain ()
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | CboUpdate (int nID_dci)
void | TextUpdate (int nID_dci)
afx_msg void | OnCbnSelchangeOptComboResl ()
afx_msg void | OnCbnSelchangeOptComboAinp ()
afx_msg void | OnCbnSelchangeOptComboInof ()
afx_msg void | OnCbnSelchangeOptComboPapz ()
afx_msg void | OnEnChangeOptTextPapz ()
afx_msg void | OnEnChangeOptTextResl ()
afx_msg void | OnEnChangeOptTextInof ()
afx_msg void | OnEnChangeOptTextGain ()
void | CboTextVis (int nIdCbox, int nIdEdit, BOOL isText)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | isCEditBox (int nID)
BOOL | isCComboBox (int nID)
afx_msg void | OnCbnSelchangeOptComboGaia ()
afx_msg void | OnEnChangeOptTextGaif ()
void | UpdateGainValue ()
afx_msg void | OnBnClickedButtonFineGainEnter ()
afx_msg void | OnCbnSelchangeOptComboGainSelect ()
afx_msg void | OnBnClickedButtonCoarseFineToTotal ()
afx_msg void | OnBnClickedButtonTotalToCoarseFine ()
afx_msg void | OnCbnSelchangeOptComboGaia2 ()
void | UpdateOptComboGAIA ()
void | SetDetResetValues (int nID, BOOL is80MHz)
afx_msg void | OnCbnSelchangeOptComboResl2 ()
void | InitCombo (HWND hDlg, DP5_CONFIGURATION cfg, int nID)
void | SetHvPowerWarning ()
afx_msg void | OnHelp ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)

Public Attributes

CLabel m_GainPzPageLabel
CLabel m_GainAdvancedLabel
CLabel m_GainStandardLabel
CLabel m_PowerHvWarning
BOOL | bEnableNewRESL
double | dblGAIF_Max
double | dblGAIF_Min
CComboBox | m_CoarseGain_GAIA_value
CComboBox | m_CoarseGain_GAIA_index
CDppGain DppGain

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 18 of file GainPzPage.h.

Constructor & Destructor Documentation

CGainPzPage::CGainPzPage ( )

Definition at line 25 of file GainPzPage.cpp.

CGainPzPage::~CGainPzPage ( )

Definition at line 32 of file GainPzPage.cpp.

Member Function Documentation

void CGainPzPage::BuildToolTips ( )

Definition at line 975 of file GainPzPage.cpp.

Here is the caller graph for this function:

void CGainPzPage::CboTextVis | ( | int | nIdCbox,
 |  | int | nIdEdit,
 |  | BOOL | isText
 | ) |  |

Definition at line 499 of file GainPzPage.cpp.

void CGainPzPage::CboUpdate ( int nID_dci )

Definition at line 441 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::CheckMCA8000D_FineGain ( )

Definition at line 300 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 37 of file GainPzPage.cpp.

void CGainPzPage::InitCombo | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg,
 |  | int | nID
 | ) |  |

Definition at line 869 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::InitControls ( )

Definition at line 146 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 371 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CGainPzPage::isCComboBox ( int nID )

Definition at line 714 of file GainPzPage.cpp.

Here is the caller graph for this function:

BOOL CGainPzPage::isCEditBox ( int nID )

Definition at line 691 of file GainPzPage.cpp.

Here is the caller graph for this function:

void CGainPzPage::OnBnClickedButtonCoarseFineToTotal ( )

Definition at line 763 of file GainPzPage.cpp.

void CGainPzPage::OnBnClickedButtonFineGainEnter ( )

Definition at line 737 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::OnBnClickedButtonTotalToCoarseFine ( )

Definition at line 779 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboAinp ( )

Definition at line 554 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboGaia ( )

Definition at line 569 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboGaia2 ( )

Definition at line 825 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboGainSelect ( )

Definition at line 757 of file GainPzPage.cpp.

void CGainPzPage::OnCbnSelchangeOptComboInof ( )

Definition at line 559 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboPapz ( )

Definition at line 564 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboResl ( )

Definition at line 549 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnCbnSelchangeOptComboResl2 ( )

Definition at line 894 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnEnChangeOptTextGaif ( )

Definition at line 648 of file GainPzPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CGainPzPage::OnEnChangeOptTextGain ( )

Definition at line 605 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnEnChangeOptTextInof ( )

Definition at line 600 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnEnChangeOptTextPapz ( )

Definition at line 590 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnEnChangeOptTextResl ( )

Definition at line 595 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::OnHelp ( )

Definition at line 968 of file GainPzPage.cpp.

BOOL CGainPzPage::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 955 of file GainPzPage.cpp.

BOOL CGainPzPage::OnInitDialog ( ) [virtual]

Definition at line 91 of file GainPzPage.cpp.

Here is the call graph for this function:

BOOL CGainPzPage::OnSetActive ( ) [virtual]

Definition at line 79 of file GainPzPage.cpp.

BOOL CGainPzPage::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 653 of file GainPzPage.cpp.

Here is the call graph for this function:

void CGainPzPage::SetDetResetValues | ( | int | nID,
 |  | BOOL | is80MHz
 | ) |  |

Definition at line 842 of file GainPzPage.cpp.

Here is the caller graph for this function:

void CGainPzPage::SetHvPowerWarning ( )

Definition at line 918 of file GainPzPage.cpp.

Here is the caller graph for this function:

void CGainPzPage::ShowMCA8000D_Controls ( int iShowWin )

Definition at line 320 of file GainPzPage.cpp.

void CGainPzPage::TextUpdate ( int nID_dci )

Definition at line 536 of file GainPzPage.cpp.

Here is the caller graph for this function:

void CGainPzPage::UpdateGainValue ( )

Definition at line 610 of file GainPzPage.cpp.

Here is the caller graph for this function:

void CGainPzPage::UpdateOptComboGAIA ( )

Definition at line 833 of file GainPzPage.cpp.

Here is the caller graph for this function:

Member Data Documentation

BOOL CGainPzPage::bEnableNewRESL

Definition at line 71 of file GainPzPage.h.

double CGainPzPage::dblGAIF_Max

Definition at line 91 of file GainPzPage.h.

double CGainPzPage::dblGAIF_Min

Definition at line 92 of file GainPzPage.h.

CDppGain CGainPzPage::DppGain

Definition at line 105 of file GainPzPage.h.

CComboBox CGainPzPage::m_CoarseGain_GAIA_index

Definition at line 104 of file GainPzPage.h.

CComboBox CGainPzPage::m_CoarseGain_GAIA_value

Definition at line 103 of file GainPzPage.h.

CLabel CGainPzPage::m_GainAdvancedLabel

Definition at line 53 of file GainPzPage.h.

CLabel CGainPzPage::m_GainPzPageLabel

Definition at line 51 of file GainPzPage.h.

CLabel CGainPzPage::m_GainStandardLabel

Definition at line 55 of file GainPzPage.h.

CLabel CGainPzPage::m_PowerHvWarning

Definition at line 57 of file GainPzPage.h.

CToolTipCtrl CGainPzPage::m_ToolTip [protected]

Definition at line 45 of file GainPzPage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/GainPzPage.h
  • DP5Cfg/GainPzPage.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CINI Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CINI Class Reference

#include <INI.h>

List of all members.

Public Member Functions

void | setINIFileName (CString strINIFile)
CStringList * | getSectionData (CString strSection)
CStringList * | getSectionNames ()
BOOL | sectionExists (CString strSection)
long | setKey (CString strValue, CString strKey, CString strSection)
long | DeleteKey (CString strKey, CString strSection)
long | DeleteSection (CString strSection)
CString | getKeyValue (CString strKey, CString strSection)
CINI (CString strFile)
CINI ()
virtual | ~CINI ()

Detailed Description

Definition at line 40 of file INI.h.

Constructor & Destructor Documentation

CINI::CINI ( CString strFile )

Definition at line 41 of file INI.cpp.

CINI::CINI ( ) [inline]

Definition at line 52 of file INI.h.

CINI::~CINI ( ) [virtual]

Definition at line 48 of file INI.cpp.

Member Function Documentation

long CINI::DeleteKey | ( | CString | strKey,
 |  | CString | strSection
 | ) |  |

Definition at line 77 of file INI.cpp.

Here is the caller graph for this function:

long CINI::DeleteSection ( CString strSection )

Definition at line 86 of file INI.cpp.

CString CINI::getKeyValue | ( | CString | strKey,
 |  | CString | strSection
 | ) |  |

Definition at line 55 of file INI.cpp.

Here is the caller graph for this function:

CStringList * CINI::getSectionData ( CString strSection )

Definition at line 133 of file INI.cpp.

Here is the caller graph for this function:

CStringList * CINI::getSectionNames ( )

Definition at line 109 of file INI.cpp.

BOOL CINI::sectionExists ( CString strSection )

Definition at line 95 of file INI.cpp.

Here is the caller graph for this function:

void CINI::setINIFileName ( CString strINIFile )

Definition at line 155 of file INI.cpp.

Here is the caller graph for this function:

long CINI::setKey | ( | CString | strValue,
 |  | CString | strKey,
 |  | CString | strSection
 | ) |  |

Definition at line 68 of file INI.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • CIni/INI.h
  • CIni/INI.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIniEx Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CIniEx Class Reference

#include <IniEx.h>

List of all members.

Public Member Functions

CIniEx (void)
~CIniEx (void)

Detailed Description

Definition at line 6 of file IniEx.h.

Constructor & Destructor Documentation

CIniEx::CIniEx ( void )

Definition at line 3 of file IniEx.cpp.

CIniEx::~CIniEx ( void )

Definition at line 7 of file IniEx.cpp.

The documentation for this class was generated from the following files:
  • CIni/IniEx.h
  • CIni/IniEx.cpp
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIniUtil Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CIniUtil Class Reference

#include <IniUtil.h>

Collaboration diagram for CIniUtil:
[legend]

List of all members.

Public Member Functions

CIniUtil (void)
~CIniUtil (void)
BOOL | GetDP5Data (CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comments)
BOOL | SaveDP5Data (CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comments)
BOOL | GetDP5Section (CString m_strINIFile, CString m_strSection, CStringList *m_strListDP5section)
CString | ConvertCmdListToCString (CStringList *strCmdList, BOOL AddNewLines, BOOL RemoveComments)
CString | GetMsIniItem (CString strCmdIn)
BOOL | DeleteDP5Key (CString m_strINIFile, CString m_strSection, CString cmdKey)

Public Attributes

CINI ini

Detailed Description

Definition at line 6 of file IniUtil.h.

Constructor & Destructor Documentation

CIniUtil::CIniUtil ( void )

Definition at line 4 of file IniUtil.cpp.

CIniUtil::~CIniUtil ( void )

Definition at line 9 of file IniUtil.cpp.

Member Function Documentation

CString CIniUtil::ConvertCmdListToCString | ( | CStringList * | strCmdList,
 |  | BOOL | AddNewLines,
 |  | BOOL | RemoveComments
 | ) |  |

Definition at line 111 of file IniUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CIniUtil::DeleteDP5Key | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CString | cmdKey
 | ) |  |

Definition at line 169 of file IniUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CIniUtil::GetDP5Data | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CString | cmdKey,
 |  | CString * | cmdData,
 |  | CString * | Comments
 | ) |  |

Definition at line 13 of file IniUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CIniUtil::GetDP5Section | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CStringList * | m_strListDP5section
 | ) |  |

Definition at line 62 of file IniUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CIniUtil::GetMsIniItem ( CString strCmdIn )

Definition at line 146 of file IniUtil.cpp.

Here is the caller graph for this function:

BOOL CIniUtil::SaveDP5Data | ( | CString | m_strINIFile,
 |  | CString | m_strSection,
 |  | CString | cmdKey,
 |  | CString | cmdData,
 |  | CString | Comments
 | ) |  |

Definition at line 44 of file IniUtil.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

CINI CIniUtil::ini

Definition at line 11 of file IniUtil.h.

The documentation for this class was generated from the following files:
  • CIni/IniUtil.h
  • CIni/IniUtil.cpp
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CLabel Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CLabel Class Reference

#include <Label.h>

List of all members.

Public Member Functions

CLabel ()
CLabel & | SetBkColor (COLORREF crBkgnd)
CLabel & | SetTextColor (COLORREF crText)
CLabel & | SetText (const CString &strText)
CLabel & | SetFontBold (BOOL bBold)
CLabel & | SetFontName (const CString &strFont)
CLabel & | SetFontUnderline (BOOL bSet)
CLabel & | SetFontItalic (BOOL bSet)
CLabel & | SetFontSize (int nSize)
CLabel & | SetSunken (BOOL bSet)
CLabel & | SetBorder (BOOL bSet)
CLabel & | FlashText (BOOL bActivate)
CLabel & | FlashBackground (BOOL bActivate)
CLabel & | SetLink (BOOL bLink)
CLabel & | SetLinkCursor (HCURSOR hCursor)
void | SetNullColor ()
void | SetLastColor ()
virtual | ~CLabel ()

Public Attributes

BOOL | NullSet
COLORREF | NullBkColor
COLORREF | NullTextColor
COLORREF | LastBkColor
COLORREF | LastTextColor

Protected Member Functions

void | ReconstructFont ()
afx_msg HBRUSH | CtlColor (CDC *pDC, UINT nCtlColor)
afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg BOOL | OnSetCursor (CWnd *pWnd, UINT nHitTest, UINT message)

Protected Attributes

COLORREF | m_crText
HBRUSH | m_hBrush
HBRUSH | m_hwndBrush
LOGFONT | m_lf
CFont | m_font
CString | m_strText
BOOL | m_bState
BOOL | m_bTimer
BOOL | m_bLink
FlashType m_Type
HCURSOR | m_hCursor

Detailed Description

Definition at line 15 of file Label.h.

Constructor & Destructor Documentation

CLabel::CLabel ( )

Definition at line 17 of file Label.cpp.

CLabel::~CLabel ( ) [virtual]

Definition at line 41 of file Label.cpp.

Member Function Documentation

HBRUSH CLabel::CtlColor | ( | CDC * | pDC,
 |  | UINT | nCtlColor
 | ) |  | [protected]

Definition at line 146 of file Label.cpp.

Here is the call graph for this function:

CLabel & CLabel::FlashBackground ( BOOL bActivate )

Definition at line 199 of file Label.cpp.

CLabel & CLabel::FlashText ( BOOL bActivate )

Definition at line 178 of file Label.cpp.

void CLabel::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  | [protected]

Definition at line 253 of file Label.cpp.

BOOL CLabel::OnSetCursor | ( | CWnd * | pWnd,
 |  | UINT | nHitTest,
 |  | UINT | message
 | ) |  | [protected]

Definition at line 263 of file Label.cpp.

void CLabel::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 219 of file Label.cpp.

void CLabel::ReconstructFont ( ) [protected]

Definition at line 169 of file Label.cpp.

Here is the caller graph for this function:

CLabel & CLabel::SetBkColor ( COLORREF crBkgnd )

Definition at line 115 of file Label.cpp.

Here is the caller graph for this function:

CLabel & CLabel::SetBorder ( BOOL bSet )

Definition at line 95 of file Label.cpp.

CLabel & CLabel::SetFontBold ( BOOL bBold )

Definition at line 61 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontItalic ( BOOL bSet )

Definition at line 77 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontName ( const CString & strFont )

Definition at line 125 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontSize ( int nSize )

Definition at line 105 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetFontUnderline ( BOOL bSet )

Definition at line 69 of file Label.cpp.

Here is the call graph for this function:

void CLabel::SetLastColor ( )

Definition at line 288 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetLink ( BOOL bLink )

Definition at line 241 of file Label.cpp.

CLabel & CLabel::SetLinkCursor ( HCURSOR hCursor )

Definition at line 274 of file Label.cpp.

void CLabel::SetNullColor ( )

Definition at line 280 of file Label.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CLabel & CLabel::SetSunken ( BOOL bSet )

Definition at line 85 of file Label.cpp.

CLabel & CLabel::SetText ( const CString & strText )

Definition at line 47 of file Label.cpp.

Here is the caller graph for this function:

CLabel & CLabel::SetTextColor ( COLORREF crText )

Definition at line 53 of file Label.cpp.

Here is the caller graph for this function:

Member Data Documentation

COLORREF CLabel::LastBkColor

Definition at line 40 of file Label.h.

COLORREF CLabel::LastTextColor

Definition at line 41 of file Label.h.

BOOL CLabel::m_bLink [protected]

Definition at line 55 of file Label.h.

BOOL CLabel::m_bState [protected]

Definition at line 53 of file Label.h.

BOOL CLabel::m_bTimer [protected]

Definition at line 54 of file Label.h.

COLORREF CLabel::m_crText [protected]

Definition at line 47 of file Label.h.

CFont CLabel::m_font [protected]

Definition at line 51 of file Label.h.

HBRUSH CLabel::m_hBrush [protected]

Definition at line 48 of file Label.h.

HCURSOR CLabel::m_hCursor [protected]

Definition at line 57 of file Label.h.

HBRUSH CLabel::m_hwndBrush [protected]

Definition at line 49 of file Label.h.

LOGFONT CLabel::m_lf [protected]

Definition at line 50 of file Label.h.

CString CLabel::m_strText [protected]

Definition at line 52 of file Label.h.

FlashType CLabel::m_Type [protected]

Definition at line 56 of file Label.h.

COLORREF CLabel::NullBkColor

Definition at line 38 of file Label.h.

BOOL CLabel::NullSet

Definition at line 37 of file Label.h.

COLORREF CLabel::NullTextColor

Definition at line 39 of file Label.h.

The documentation for this class was generated from the following files:
  • Controls/Label.h
  • Controls/Label.cpp
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CMcaPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CMcaPage Class Reference

#include <McaPage.h>

Inheritance diagram for CMcaPage:
[legend]
Collaboration diagram for CMcaPage:
[legend]

List of all members.

Public Member Functions

CMcaPage ()
~CMcaPage ()
void | BuildToolTips ()
virtual BOOL | OnSetActive ()
virtual BOOL | OnInitDialog ()
void | InitControls ()
void | InitDlgItemDMCA (HWND hDlg, DP5_CONFIGURATION cfg, int cboDP5CtrlID)
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | ShowMCA8000D_Controls (int iShowWin)
void | CboUpdateDMCA (int nID_dci, int nID)
void | CboUpdate (int nID_dci)
void | TextUpdate (int nID_dci)
afx_msg void | OnCbnSelchangeOptComboPret ()
afx_msg void | OnEnChangeOptTextThsl ()
afx_msg void | OnCbnSelchangeOptComboMcae ()
afx_msg void | OnCbnSelchangeOptComboMcac ()
afx_msg void | OnCbnSelchangeOptComboGate ()
afx_msg void | OnCbnSelchangeOptComboPrec ()
afx_msg void | OnCbnSelchangeOptComboSoff ()
afx_msg void | OnCbnSelchangeOptComboPdmd ()
afx_msg void | OnEnChangeOptTextPret ()
afx_msg void | OnEnChangeOptTextPrec ()
afx_msg void | OnEnChangeOptTextMcst ()
afx_msg void | OnEnChangeOptTextSoff ()
afx_msg void | OnCbnSelchangeOptComboMcas ()
void | CboTextVis (int nIdCbox, int nIdEdit, BOOL isText)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | isCEditBox (int nID)
BOOL | isCComboBox (int nID)
afx_msg void | OnEnChangeOptTextMcsl ()
afx_msg void | OnEnChangeOptTextMcsh ()
afx_msg void | OnEnChangeOptTextPrcl ()
afx_msg void | OnEnChangeOptTextPrch ()
afx_msg void | OnCbnSelchangeOptComboPrer ()
afx_msg void | OnEnChangeOptTextPrer ()
afx_msg void | OnCbnSelchangeOptComboPrel ()
afx_msg void | OnEnChangeOptTextPrel ()
afx_msg void | OnCbnSelchangeOptComboTlld ()
afx_msg void | OnEnChangeOptTextTlld ()
afx_msg void | OnBnClickedPresetcountcursorbutton ()
afx_msg void | OnBnClickedPresetcountroibutton ()
afx_msg void | OnHelp ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)
afx_msg void | OnCbnSelchangeOptComboDmcaGaia ()
afx_msg void | OnCbnSelchangeOptComboDmcaPure ()
void | MoveCtrl (int nID, long deltaX, long deltaY)
void | MoveCtrlEx (int nID, int nID_Left, int nID_Top)

Public Attributes

CLabel m_McaPageLabel
CLabel m_McaAdvancedLabel
CLabel m_McaStandardLabel
BOOL | isDMcaControls

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 18 of file McaPage.h.

Constructor & Destructor Documentation

CMcaPage::CMcaPage ( )

Definition at line 26 of file McaPage.cpp.

CMcaPage::~CMcaPage ( )

Definition at line 34 of file McaPage.cpp.

Member Function Documentation

void CMcaPage::BuildToolTips ( )

Definition at line 920 of file McaPage.cpp.

Here is the caller graph for this function:

void CMcaPage::CboTextVis | ( | int | nIdCbox,
 |  | int | nIdEdit,
 |  | BOOL | isText
 | ) |  |

Definition at line 564 of file McaPage.cpp.

void CMcaPage::CboUpdate ( int nID_dci )

Definition at line 508 of file McaPage.cpp.

Here is the caller graph for this function:

void CMcaPage::CboUpdateDMCA | ( | int | nID_dci,
 |  | int | nID
 | ) |  |

Definition at line 375 of file McaPage.cpp.

Here is the caller graph for this function:

void CMcaPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 39 of file McaPage.cpp.

void CMcaPage::InitControls ( )

Definition at line 180 of file McaPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMcaPage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 410 of file McaPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMcaPage::InitDlgItemDMCA | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg,
 |  | int | cboDP5CtrlID
 | ) |  |

Definition at line 342 of file McaPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CMcaPage::isCComboBox ( int nID )

Definition at line 810 of file McaPage.cpp.

Here is the caller graph for this function:

BOOL CMcaPage::isCEditBox ( int nID )

Definition at line 769 of file McaPage.cpp.

Here is the caller graph for this function:

void CMcaPage::MoveCtrl | ( | int | nID,
 |  | long | deltaX,
 |  | long | deltaY
 | ) |  |

Definition at line 1005 of file McaPage.cpp.

void CMcaPage::MoveCtrlEx | ( | int | nID,
 |  | int | nID_Left,
 |  | int | nID_Top
 | ) |  |

Definition at line 1023 of file McaPage.cpp.

Here is the caller graph for this function:

void CMcaPage::OnBnClickedPresetcountcursorbutton ( )

Definition at line 848 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnBnClickedPresetcountroibutton ( )

Definition at line 874 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboDmcaGaia ( )

Definition at line 400 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboDmcaPure ( )

Definition at line 405 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboGate ( )

Definition at line 628 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboMcac ( )

Definition at line 623 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboMcae ( )

Definition at line 618 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboMcas ( )

Definition at line 677 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboPdmd ( )

Definition at line 643 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboPrec ( )

Definition at line 633 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboPrel ( )

Definition at line 693 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboPrer ( )

Definition at line 683 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboPret ( )

Definition at line 613 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboSoff ( )

Definition at line 638 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnCbnSelchangeOptComboTlld ( )

Definition at line 728 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextMcsh ( )

Definition at line 708 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextMcsl ( )

Definition at line 703 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextMcst ( )

Definition at line 667 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextPrch ( )

Definition at line 718 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextPrcl ( )

Definition at line 713 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextPrec ( )

Definition at line 662 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextPrel ( )

Definition at line 698 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextPrer ( )

Definition at line 688 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextPret ( )

Definition at line 653 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextSoff ( )

Definition at line 672 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextThsl ( )

Definition at line 648 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnEnChangeOptTextTlld ( )

Definition at line 723 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::OnHelp ( )

Definition at line 913 of file McaPage.cpp.

BOOL CMcaPage::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 900 of file McaPage.cpp.

BOOL CMcaPage::OnInitDialog ( ) [virtual]

Definition at line 129 of file McaPage.cpp.

Here is the call graph for this function:

BOOL CMcaPage::OnSetActive ( ) [virtual]

Definition at line 94 of file McaPage.cpp.

BOOL CMcaPage::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 733 of file McaPage.cpp.

Here is the call graph for this function:

void CMcaPage::ShowMCA8000D_Controls ( int iShowWin )

Definition at line 285 of file McaPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMcaPage::TextUpdate ( int nID_dci )

Definition at line 600 of file McaPage.cpp.

Here is the caller graph for this function:

Member Data Documentation

BOOL CMcaPage::isDMcaControls

Definition at line 108 of file McaPage.h.

CLabel CMcaPage::m_McaAdvancedLabel

Definition at line 52 of file McaPage.h.

CLabel CMcaPage::m_McaPageLabel

Definition at line 50 of file McaPage.h.

CLabel CMcaPage::m_McaStandardLabel

Definition at line 54 of file McaPage.h.

CToolTipCtrl CMcaPage::m_ToolTip [protected]

Definition at line 45 of file McaPage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/McaPage.h
  • DP5Cfg/McaPage.cpp
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: cMemDC Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
cMemDC Class Reference

#include <memdc.h>

List of all members.

Public Member Functions

cMemDC (CDC *pDC, const CRect &rcBounds, long BackColor=RGB(255, 255, 255))
~cMemDC ()
cMemDC * operator-> ()

Detailed Description

Definition at line 20 of file memdc.h.

Constructor & Destructor Documentation

cMemDC::cMemDC | ( | CDC * | pDC,
 |  | const CRect & | rcBounds,
 |  | long | BackColor = RGB(255,255,255)
 | ) |  | [inline]

Definition at line 28 of file memdc.h.

cMemDC::~cMemDC ( ) [inline]

Definition at line 42 of file memdc.h.

Member Function Documentation

cMemDC* cMemDC::operator-> ( ) [inline]

Definition at line 48 of file memdc.h.

The documentation for this class was generated from the following file:
  • waitdlg/memdc.h
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CMiscPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CMiscPage Class Reference

#include <MiscPage.h>

Inheritance diagram for CMiscPage:
[legend]
Collaboration diagram for CMiscPage:
[legend]

List of all members.

Public Member Functions

CMiscPage ()
~CMiscPage ()
void | BuildToolTips ()
virtual BOOL | OnSetActive ()
afx_msg LONG | OnSetPageFocus (UINT wParam, LONG lParam)
virtual BOOL | OnInitDialog ()
afx_msg void | OnCbnSelchangeOptComboDaco ()
void | SetAuxList (int nAuxID, BOOL bNeedsNewAux)
void | InitAuxControls ()
void | InitControls ()
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | ShowMCA8000D_Controls (int iShowWin)
void | CboUpdate (int nID_dci)
void | TextUpdate (int nID_dci)
afx_msg void | OnCbnSelchangeOptComboScoe ()
afx_msg void | OnCbnSelchangeOptComboAuo1 ()
afx_msg void | OnCbnSelchangeOptComboScot ()
afx_msg void | OnCbnSelchangeOptComboGped ()
afx_msg void | OnCbnSelchangeOptComboGpin ()
afx_msg void | OnCbnSelchangeOptComboTpmo ()
afx_msg void | OnCbnSelchangeOptComboGpme ()
afx_msg void | OnCbnSelchangeOptComboGpga ()
afx_msg void | OnCbnSelchangeOptComboGpmc ()
afx_msg void | OnEnChangeOptTextDacf ()
afx_msg void | OnEnChangeOptTextDaco ()
afx_msg void | OnEnChangeOptTextAuo1 ()
afx_msg void | OnEnChangeOptTextGpin ()
void | CboTextVis (int nIdCbox, int nIdEdit, BOOL isText)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | isCEditBox (int nID)
BOOL | isCComboBox (int nID)
afx_msg void | OnEnChangeOptTextAuo2 ()
afx_msg void | OnCbnSelchangeOptComboScog ()
afx_msg void | OnCbnSelchangeOptComboAuo2 ()
afx_msg void | OnCbnSelchangeOptComboVolu ()
afx_msg void | OnCbnSelchangeOptComboCon1 ()
afx_msg void | OnCbnSelchangeOptComboCon2 ()
afx_msg void | OnBnClickedButtonOutputQuickset1 ()
afx_msg void | OnBnClickedButtonOutputQuickset2 ()
afx_msg void | OnBnClickedButtonOutputQuickset3 ()
void | SetCboItem (int nID, CString strVal)
void | OutputQuickset (CString strDAC, CString strOutputOffset, CString strAUX2, CString strAUX1, CString strCONN1, CString strCONN2)
afx_msg void | OnBnClickedCheckEnableSca ()
afx_msg void | OnCbnSelchangeComboScaIndex ()
afx_msg void | OnEnChangeEditLowThreshold ()
afx_msg void | OnEnChangeEditHighThreshold ()
afx_msg void | OnCbnSelchangeComboOutputLevel ()
afx_msg void | OnBnClickedButtonScaDefaults ()
afx_msg void | OnCbnSelchangeComboScaPulseWidth ()
afx_msg void | OnBnClickedButtonPreviewSca ()
BOOL | GetCheckBOOL (int nID)
void | SetCheckBOOL (int nID, BOOL isChecked)
void | EnableScaControls (BOOL Enable=TRUE, BOOL isVisible=TRUE)
void | EnableControl (int nID, BOOL Enable=TRUE, BOOL isVisible=TRUE)
void | UpdateSCAControls ()
void | SetSCAComboIndex (int nID, CString strValue)
int | GetComboIndex (int nID)
CString | GetComboValue (int nID)
afx_msg void | OnHelp ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)

Public Attributes

CLabel m_MiscPageLabel
CLabel m_MiscAdvancedLabel
CLabel m_MiscQuicksetLabel

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 18 of file MiscPage.h.

Constructor & Destructor Documentation

CMiscPage::CMiscPage ( )

Definition at line 26 of file MiscPage.cpp.

CMiscPage::~CMiscPage ( )

Definition at line 33 of file MiscPage.cpp.

Member Function Documentation

void CMiscPage::BuildToolTips ( )

Definition at line 808 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::CboTextVis | ( | int | nIdCbox,
 |  | int | nIdEdit,
 |  | BOOL | isText
 | ) |  |

Definition at line 470 of file MiscPage.cpp.

void CMiscPage::CboUpdate ( int nID_dci )

Definition at line 422 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 37 of file MiscPage.cpp.

void CMiscPage::EnableControl | ( | int | nID,
 |  | BOOL | Enable = TRUE,
 |  | BOOL | isVisible = TRUE
 | ) |  |

Definition at line 978 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::EnableScaControls | ( | BOOL | Enable = TRUE,
 |  | BOOL | isVisible = TRUE
 | ) |  |

Definition at line 950 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CMiscPage::GetCheckBOOL ( int nID )

Definition at line 934 of file MiscPage.cpp.

Here is the caller graph for this function:

int CMiscPage::GetComboIndex ( int nID )

Definition at line 1018 of file MiscPage.cpp.

Here is the caller graph for this function:

CString CMiscPage::GetComboValue ( int nID )

Definition at line 1031 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::InitAuxControls ( )

Definition at line 227 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::InitControls ( )

Definition at line 262 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 352 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CMiscPage::isCComboBox ( int nID )

Definition at line 681 of file MiscPage.cpp.

Here is the caller graph for this function:

BOOL CMiscPage::isCEditBox ( int nID )

Definition at line 658 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::OnBnClickedButtonOutputQuickset1 ( )

Definition at line 767 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnBnClickedButtonOutputQuickset2 ( )

Definition at line 773 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnBnClickedButtonOutputQuickset3 ( )

Definition at line 779 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnBnClickedButtonPreviewSca ( )

Definition at line 1039 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnBnClickedButtonScaDefaults ( )

Definition at line 920 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnBnClickedCheckEnableSca ( )

Definition at line 874 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeComboOutputLevel ( )

Definition at line 910 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeComboScaIndex ( )

Definition at line 881 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeComboScaPulseWidth ( )

Definition at line 929 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboAuo1 ( )

Definition at line 529 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::OnCbnSelchangeOptComboAuo2 ( )

Definition at line 535 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::OnCbnSelchangeOptComboCon1 ( )

Definition at line 585 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::OnCbnSelchangeOptComboCon2 ( )

Definition at line 590 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::OnCbnSelchangeOptComboDaco ( )

Definition at line 519 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::OnCbnSelchangeOptComboGped ( )

Definition at line 545 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboGpga ( )

Definition at line 565 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboGpin ( )

Definition at line 550 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboGpmc ( )

Definition at line 570 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboGpme ( )

Definition at line 560 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboScoe ( )

Definition at line 524 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboScog ( )

Definition at line 575 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboScot ( )

Definition at line 540 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboTpmo ( )

Definition at line 555 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnCbnSelchangeOptComboVolu ( )

Definition at line 580 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnEnChangeEditHighThreshold ( )

Definition at line 900 of file MiscPage.cpp.

void CMiscPage::OnEnChangeEditLowThreshold ( )

Definition at line 890 of file MiscPage.cpp.

void CMiscPage::OnEnChangeOptTextAuo1 ( )

Definition at line 605 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnEnChangeOptTextAuo2 ( )

Definition at line 610 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnEnChangeOptTextDacf ( )

Definition at line 595 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::OnEnChangeOptTextDaco ( )

Definition at line 600 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnEnChangeOptTextGpin ( )

Definition at line 615 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::OnHelp ( )

Definition at line 801 of file MiscPage.cpp.

BOOL CMiscPage::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 788 of file MiscPage.cpp.

BOOL CMiscPage::OnInitDialog ( ) [virtual]

Definition at line 112 of file MiscPage.cpp.

Here is the call graph for this function:

BOOL CMiscPage::OnSetActive ( ) [virtual]

Definition at line 93 of file MiscPage.cpp.

LONG CMiscPage::OnSetPageFocus | ( | UINT | wParam,
 |  | LONG | lParam
 | ) |  |

Definition at line 106 of file MiscPage.cpp.

void CMiscPage::OutputQuickset | ( | CString | strDAC,
 |  | CString | strOutputOffset,
 |  | CString | strAUX2,
 |  | CString | strAUX1,
 |  | CString | strCONN1,
 |  | CString | strCONN2
 | ) |  |

Definition at line 751 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CMiscPage::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 620 of file MiscPage.cpp.

Here is the call graph for this function:

void CMiscPage::SetAuxList | ( | int | nAuxID,
 |  | BOOL | bNeedsNewAux
 | ) |  |

Definition at line 165 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::SetCboItem | ( | int | nID,
 |  | CString | strVal
 | ) |  |

Definition at line 734 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::SetCheckBOOL | ( | int | nID,
 |  | BOOL | isChecked
 | ) |  |

Definition at line 943 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::SetSCAComboIndex | ( | int | nID,
 |  | CString | strValue
 | ) |  |

Definition at line 1003 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CMiscPage::ShowMCA8000D_Controls ( int iShowWin )

Definition at line 331 of file MiscPage.cpp.

void CMiscPage::TextUpdate ( int nID_dci )

Definition at line 506 of file MiscPage.cpp.

Here is the caller graph for this function:

void CMiscPage::UpdateSCAControls ( )

Definition at line 984 of file MiscPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

CLabel CMiscPage::m_MiscAdvancedLabel

Definition at line 53 of file MiscPage.h.

CLabel CMiscPage::m_MiscPageLabel

Definition at line 51 of file MiscPage.h.

CLabel CMiscPage::m_MiscQuicksetLabel

Definition at line 55 of file MiscPage.h.

CToolTipCtrl CMiscPage::m_ToolTip [protected]

Definition at line 45 of file MiscPage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/MiscPage.h
  • DP5Cfg/MiscPage.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CMSecTimer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CMSecTimer Class Reference

#include <MSecTimer.h>

List of all members.

Public Member Functions

CMSecTimer (void)
~CMSecTimer (void)
DWORD | msTimeDiff (DWORD msStartTime, DWORD msTestTime)
BOOL | msTimeExpired (DWORD msStartTime, DWORD msDelay)
BOOL | msTimer (DWORD msDelay)

Detailed Description

Definition at line 6 of file MSecTimer.h.

Constructor & Destructor Documentation

CMSecTimer::CMSecTimer ( void )

Definition at line 3 of file MSecTimer.cpp.

CMSecTimer::~CMSecTimer ( void )

Definition at line 7 of file MSecTimer.cpp.

Member Function Documentation

DWORD CMSecTimer::msTimeDiff | ( | DWORD | msStartTime,
 |  | DWORD | msTestTime
 | ) |  |

Definition at line 11 of file MSecTimer.cpp.

Here is the caller graph for this function:

BOOL CMSecTimer::msTimeExpired | ( | DWORD | msStartTime,
 |  | DWORD | msDelay
 | ) |  |

Definition at line 33 of file MSecTimer.cpp.

Here is the caller graph for this function:

BOOL CMSecTimer::msTimer ( DWORD msDelay )

Definition at line 60 of file MSecTimer.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • DeviceIO/MSecTimer.h
  • DeviceIO/MSecTimer.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CMsgBox Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions
CMsgBox Class Reference

#include <MsgBox.h>

List of all members.

Public Types

enum | { IDD = IDD_MESSAGE_BOX }

Public Member Functions

CMsgBox (CWnd *pParent=NULL)
virtual | ~CMsgBox ()
virtual BOOL | OnInitDialog ()
void | SetMessage (CString strMsg, CString m_strDelimiter)

Public Attributes

CString | m_strTitle
CString | m_strMessage
CString | m_strDelimiter

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Detailed Description

Definition at line 6 of file MsgBox.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 15 of file MsgBox.h.

Constructor & Destructor Documentation

CMsgBox::CMsgBox ( CWnd * pParent = NULL )

Definition at line 13 of file MsgBox.cpp.

CMsgBox::~CMsgBox ( ) [virtual]

Definition at line 18 of file MsgBox.cpp.

Member Function Documentation

void CMsgBox::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 22 of file MsgBox.cpp.

BOOL CMsgBox::OnInitDialog ( ) [virtual]

Definition at line 34 of file MsgBox.cpp.

void CMsgBox::SetMessage | ( | CString | strMsg,
 |  | CString | m_strDelimiter
 | ) |  |

Definition at line 47 of file MsgBox.cpp.

Member Data Documentation

CString CMsgBox::m_strDelimiter

Definition at line 25 of file MsgBox.h.

CString CMsgBox::m_strMessage

Definition at line 24 of file MsgBox.h.

CString CMsgBox::m_strTitle

Definition at line 23 of file MsgBox.h.

The documentation for this class was generated from the following files:
  • MsgBox.h
  • MsgBox.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CNetFinder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CNetFinder Class Reference

#include <NetFinder.h>

Collaboration diagram for CNetFinder:
[legend]

List of all members.

Public Member Functions

CNetFinder (void)
~CNetFinder (void)
CString | EntryToStr (NETDISPLAY_ENTRY *pEntry)
CString | EntryToStrRS232 (NETDISPLAY_ENTRY *pEntry, CString strPort)
CString | EntryToStrUSB (NETDISPLAY_ENTRY *pEntry, CString strPort)
COLORREF | AlertEntryToCOLORREF (NETDISPLAY_ENTRY *pEntry)
COLORREF | AlertByteToCOLORREF (unsigned char alert_level)
int | FindEntry (unsigned long SockAddr)
CString | SockAddr_DlgToStr (CDialog *dlg, int id1, int id2, int id3, int id4)
UINT | SockPort_DlgToUINT (CDialog *dlg, int id1)
in_addr | SockAddr_ByteToInAddr (unsigned char *ip)
unsigned long | SockAddr_ByteToULong (unsigned char *ip)
CString | SockAddr_ByteToStr (unsigned char *ip)
in_addr | SockAddr_StrToInAddr (CString strSockAddr)
unsigned long | SockAddr_StrToULong (CString strSockAddr)
in_addr | SockAddr_ULongToInAddr (unsigned long SockAddr)
CString | SockAddr_ULongToStr (unsigned long SockAddr)
CString | SockAddr_InAddrToStr (in_addr inSockAddr)
void | InitEntry (NETDISPLAY_ENTRY *pEntry)
void | InitAllEntries ()
void | AddEntry (NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort)

Public Attributes

int | m_rand
NETDISPLAY_ENTRY DppEntries [MAX_ENTRIES]
int | LastEntry
unsigned long | DppSockAddr
int | DppEntryIdx
BOOL | DppFound

Detailed Description

Definition at line 45 of file NetFinder.h.

Constructor & Destructor Documentation

CNetFinder::CNetFinder ( void )

Definition at line 6 of file NetFinder.cpp.

Here is the call graph for this function:

CNetFinder::~CNetFinder ( void )

Definition at line 13 of file NetFinder.cpp.

Member Function Documentation

void CNetFinder::AddEntry | ( | NETDISPLAY_ENTRY * | pEntry,
 |  | unsigned char * | buffer,
 |  | UINT | destPort
 | ) |  |

Definition at line 307 of file NetFinder.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

COLORREF CNetFinder::AlertByteToCOLORREF ( unsigned char alert_level )

Definition at line 25 of file NetFinder.cpp.

Here is the caller graph for this function:

COLORREF CNetFinder::AlertEntryToCOLORREF ( NETDISPLAY_ENTRY * pEntry )

Definition at line 18 of file NetFinder.cpp.

Here is the call graph for this function:

CString CNetFinder::EntryToStr ( NETDISPLAY_ENTRY * pEntry )

Definition at line 51 of file NetFinder.cpp.

Here is the caller graph for this function:

CString CNetFinder::EntryToStrRS232 | ( | NETDISPLAY_ENTRY * | pEntry,
 |  | CString | strPort
 | ) |  |

Definition at line 114 of file NetFinder.cpp.

Here is the caller graph for this function:

CString CNetFinder::EntryToStrUSB | ( | NETDISPLAY_ENTRY * | pEntry,
 |  | CString | strPort
 | ) |  |

Definition at line 178 of file NetFinder.cpp.

Here is the caller graph for this function:

int CNetFinder::FindEntry ( unsigned long SockAddr )

Definition at line 242 of file NetFinder.cpp.

Here is the caller graph for this function:

void CNetFinder::InitAllEntries ( )

Definition at line 298 of file NetFinder.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CNetFinder::InitEntry ( NETDISPLAY_ENTRY * pEntry )

Definition at line 256 of file NetFinder.cpp.

Here is the caller graph for this function:

in_addr CNetFinder::SockAddr_ByteToInAddr ( unsigned char * ip )

Definition at line 412 of file NetFinder.cpp.

Here is the caller graph for this function:

CString CNetFinder::SockAddr_ByteToStr ( unsigned char * ip )

Definition at line 429 of file NetFinder.cpp.

unsigned long CNetFinder::SockAddr_ByteToULong ( unsigned char * ip )

Definition at line 422 of file NetFinder.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CNetFinder::SockAddr_DlgToStr | ( | CDialog * | dlg,
 |  | int | id1,
 |  | int | id2,
 |  | int | id3,
 |  | int | id4
 | ) |  |

Definition at line 374 of file NetFinder.cpp.

Here is the caller graph for this function:

CString CNetFinder::SockAddr_InAddrToStr ( in_addr inSockAddr )

Definition at line 468 of file NetFinder.cpp.

in_addr CNetFinder::SockAddr_StrToInAddr ( CString strSockAddr )

Definition at line 436 of file NetFinder.cpp.

unsigned long CNetFinder::SockAddr_StrToULong ( CString strSockAddr )

Definition at line 445 of file NetFinder.cpp.

Here is the caller graph for this function:

in_addr CNetFinder::SockAddr_ULongToInAddr ( unsigned long SockAddr )

Definition at line 452 of file NetFinder.cpp.

CString CNetFinder::SockAddr_ULongToStr ( unsigned long SockAddr )

Definition at line 459 of file NetFinder.cpp.

Here is the caller graph for this function:

UINT CNetFinder::SockPort_DlgToUINT | ( | CDialog * | dlg,
 |  | int | id1
 | ) |  |

Definition at line 401 of file NetFinder.cpp.

Here is the caller graph for this function:

Member Data Documentation

NETDISPLAY_ENTRY CNetFinder::DppEntries[MAX_ENTRIES]

Definition at line 52 of file NetFinder.h.

int CNetFinder::DppEntryIdx

Definition at line 56 of file NetFinder.h.

BOOL CNetFinder::DppFound

Definition at line 57 of file NetFinder.h.

unsigned long CNetFinder::DppSockAddr

Definition at line 55 of file NetFinder.h.

int CNetFinder::LastEntry

Definition at line 53 of file NetFinder.h.

int CNetFinder::m_rand

Definition at line 51 of file NetFinder.h.

The documentation for this class was generated from the following files:
  • DeviceIO/NetFinder.h
  • DeviceIO/NetFinder.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CParsePacket Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CParsePacket Class Reference

#include <ParsePacket.h>

Collaboration diagram for CParsePacket:
[legend]

List of all members.

Public Member Functions

CParsePacket (void)
~CParsePacket (void)
void | ParsePacketStatus (unsigned char P[], Packet_In *PIN)
Parses DPP packet status, determines further processing.
string | PID2_TextToString (string strPacketSource, unsigned char PID2)
Processes DPP return ACKS, NAKS and errors.
long | ParsePacket (unsigned char P[], Packet_In *PIN)
Parses incoming DPP packet, tests packet, populates packet information, sets packet state.

Public Attributes

DppStateType DppState
DPP packet parser state indicator.

Detailed Description

Definition at line 42 of file ParsePacket.h.

Constructor & Destructor Documentation

CParsePacket::CParsePacket ( void )

Definition at line 3 of file ParsePacket.cpp.

CParsePacket::~CParsePacket ( void )

Definition at line 7 of file ParsePacket.cpp.

Member Function Documentation

long CParsePacket::ParsePacket | ( | unsigned char | P[],
 |  | Packet_In * | PIN
 | ) |  |

Parses incoming DPP packet, tests packet, populates packet information, sets packet state.

Definition at line 117 of file ParsePacket.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CParsePacket::ParsePacketStatus | ( | unsigned char | P[],
 |  | Packet_In * | PIN
 | ) |  |

Parses DPP packet status, determines further processing.

Definition at line 11 of file ParsePacket.cpp.

Here is the caller graph for this function:

string CParsePacket::PID2_TextToString | ( | string | strPacketSource,
 |  | unsigned char | PID2
 | ) |  |

Processes DPP return ACKS, NAKS and errors.

Definition at line 49 of file ParsePacket.cpp.

Here is the caller graph for this function:

Member Data Documentation

DppStateType CParsePacket::DppState

DPP packet parser state indicator.

Definition at line 48 of file ParsePacket.h.

The documentation for this class was generated from the following files:
  • DeviceIO/ParsePacket.h
  • DeviceIO/ParsePacket.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CPlot Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CPlot Class Reference

#include <Plot.h>

List of all members.

Public Member Functions

CPlot (void)
~CPlot (void)
int | PositionToPixel (double pos)
double | PixelToPosition (int pixel)
void | MovePlot (int xmin, int xmax, unsigned long ymin, unsigned long ymax)

Public Attributes

double | m_xCursorData
unsigned long | m_xMin
unsigned long | m_xMax
unsigned long | m_yMin
unsigned long | m_yMax
int | m_xPixels
int | m_yPixels
double | m_xCursorPos
double | m_yCursorPos

Detailed Description

Definition at line 5 of file Plot.h.

Constructor & Destructor Documentation

CPlot::CPlot ( void )

Definition at line 3 of file Plot.cpp.

CPlot::~CPlot ( void )

Definition at line 12 of file Plot.cpp.

Member Function Documentation

void CPlot::MovePlot | ( | int | xmin,
 |  | int | xmax,
 |  | unsigned long | ymin,
 |  | unsigned long | ymax
 | ) |  |

Definition at line 28 of file Plot.cpp.

double CPlot::PixelToPosition ( int pixel ) [inline]

Definition at line 23 of file Plot.cpp.

int CPlot::PositionToPixel ( double pos ) [inline]

Definition at line 18 of file Plot.cpp.

Member Data Documentation

double CPlot::m_xCursorData

Definition at line 11 of file Plot.h.

double CPlot::m_xCursorPos

Definition at line 21 of file Plot.h.

unsigned long CPlot::m_xMax

Definition at line 14 of file Plot.h.

unsigned long CPlot::m_xMin

Definition at line 13 of file Plot.h.

int CPlot::m_xPixels

Definition at line 18 of file Plot.h.

double CPlot::m_yCursorPos

Definition at line 22 of file Plot.h.

unsigned long CPlot::m_yMax

Definition at line 16 of file Plot.h.

unsigned long CPlot::m_yMin

Definition at line 15 of file Plot.h.

int CPlot::m_yPixels

Definition at line 19 of file Plot.h.

The documentation for this class was generated from the following files:
  • Plot.h
  • Plot.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CPlotCanvas Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions
CPlotCanvas Class Reference

#include <PlotCanvas.h>

Collaboration diagram for CPlotCanvas:
[legend]

List of all members.

Public Member Functions

CPlotCanvas ()
void | Invalidate ()
void | PlotTrace (long YPlotBufferIn[8192])
virtual | ~CPlotCanvas ()
void | ClearTrace ()
void | DrawCursor ()
void | OnRefreshBkgnd ()
void | SetPersistenceMode (bool Persistence)
void | SetCursorPosition (int CursorPos)
void | DrawCursor (CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
void | DataAcq (long DataBuffer[8192], int NumChan)

Public Attributes

COLORREF | m_crDisplayBGColor
COLORREF | m_crPlotColor
COLORREF | m_crCursorColor
COLORREF | m_crTextFGColor
COLORREF | m_crTextBGColor
bool | hasBackground
bool | PersistenceMode
int | CursorPosition
int | OldCursorPosition
COORD_LONG PlotCursor
COORD_LONG OldPlotCursor
long | YPlotBuffer [8192]
long | YPlotMAX
long | XPlotMAX
bool | OptScaleType
bool | OptPlotType

Protected Member Functions

afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg void | OnPaint ()

Detailed Description

Definition at line 46 of file PlotCanvas.h.

Constructor & Destructor Documentation

CPlotCanvas::CPlotCanvas ( )

Definition at line 9 of file PlotCanvas.cpp.

CPlotCanvas::~CPlotCanvas ( ) [virtual]

Definition at line 29 of file PlotCanvas.cpp.

Member Function Documentation

void CPlotCanvas::ClearTrace ( )

Definition at line 211 of file PlotCanvas.cpp.

Here is the caller graph for this function:

void CPlotCanvas::DataAcq | ( | long | DataBuffer[8192],
 |  | int | NumChan
 | ) |  |

Definition at line 265 of file PlotCanvas.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CPlotCanvas::DrawCursor ( )

Definition at line 226 of file PlotCanvas.cpp.

Here is the caller graph for this function:

void CPlotCanvas::DrawCursor | ( | CDC * | dcMem,
 |  | long | YPlotBufferIn[8192],
 |  | bool | EraseCursor = false
 | ) |  |

Definition at line 182 of file PlotCanvas.cpp.

void CPlotCanvas::Invalidate ( )
BOOL CPlotCanvas::OnEraseBkgnd ( CDC * pDC ) [protected]

Definition at line 46 of file PlotCanvas.cpp.

void CPlotCanvas::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  |

Definition at line 255 of file PlotCanvas.cpp.

Here is the call graph for this function:

void CPlotCanvas::OnPaint ( ) [protected]

Definition at line 60 of file PlotCanvas.cpp.

void CPlotCanvas::OnRefreshBkgnd ( )

Definition at line 53 of file PlotCanvas.cpp.

Here is the caller graph for this function:

void CPlotCanvas::PlotTrace ( long YPlotBufferIn[8192] )

Definition at line 197 of file PlotCanvas.cpp.

void CPlotCanvas::SetCursorPosition ( int CursorPos )

Definition at line 249 of file PlotCanvas.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CPlotCanvas::SetPersistenceMode ( bool Persistence )

Definition at line 240 of file PlotCanvas.cpp.

Here is the call graph for this function:

Member Data Documentation

int CPlotCanvas::CursorPosition

Definition at line 62 of file PlotCanvas.h.

bool CPlotCanvas::hasBackground

Definition at line 60 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crCursorColor

Definition at line 56 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crDisplayBGColor

Definition at line 54 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crPlotColor

Definition at line 55 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crTextBGColor

Definition at line 58 of file PlotCanvas.h.

COLORREF CPlotCanvas::m_crTextFGColor

Definition at line 57 of file PlotCanvas.h.

int CPlotCanvas::OldCursorPosition

Definition at line 63 of file PlotCanvas.h.

COORD_LONG CPlotCanvas::OldPlotCursor

Definition at line 66 of file PlotCanvas.h.

bool CPlotCanvas::OptPlotType

Definition at line 72 of file PlotCanvas.h.

bool CPlotCanvas::OptScaleType

Definition at line 71 of file PlotCanvas.h.

bool CPlotCanvas::PersistenceMode

Definition at line 61 of file PlotCanvas.h.

COORD_LONG CPlotCanvas::PlotCursor

Definition at line 65 of file PlotCanvas.h.

long CPlotCanvas::XPlotMAX

Definition at line 69 of file PlotCanvas.h.

long CPlotCanvas::YPlotBuffer[8192]

Definition at line 67 of file PlotCanvas.h.

long CPlotCanvas::YPlotMAX

Definition at line 68 of file PlotCanvas.h.

The documentation for this class was generated from the following files:
  • Controls/PlotCanvas.h
  • Controls/PlotCanvas.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CPowerPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CPowerPage Class Reference

#include <PowerPage.h>

Inheritance diagram for CPowerPage:
[legend]
Collaboration diagram for CPowerPage:
[legend]

List of all members.

Public Member Functions

CPowerPage ()
~CPowerPage ()
void | BuildToolTips ()
virtual BOOL | OnSetActive ()
virtual BOOL | OnInitDialog ()
void | InitControls ()
void | ShowMCA8000D_Controls (int iShowWin)
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | CboUpdate (int nID_dci)
void | TextUpdate (int nID_dci)
void | Init_PAPS_Controls ()
afx_msg void | OnCbnSelchangeOptComboPaps ()
afx_msg void | OnCbnSelchangeOptComboHvse ()
afx_msg void | OnCbnSelchangeOptComboTecs ()
afx_msg void | OnEnChangeOptTextHvse ()
afx_msg void | OnEnChangeOptTextTecs ()
void | CboTextVis (int nIdCbox, int nIdEdit, BOOL isText)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | isCEditBox (int nID)
BOOL | isCComboBox (int nID)
afx_msg void | OnCbnSelchangeOptComboBoot ()
void | SetHVSign (BOOL isPOS)
afx_msg void | OnBnClickedRadioHvSign1 ()
afx_msg void | OnBnClickedRadioHvSign2 ()
BOOL | isHVSignInString (CString strHV)
BOOL | isHVSignPositive (CString strHV)
void | SetHvPowerWarning ()
afx_msg void | OnHelp ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)

Public Attributes

CLabel m_PowerPageLabel
CLabel m_PowerAdvancedLabel
CLabel m_PowerStandardLabel
CLabel m_PowerHvSign1
CLabel m_PowerHvSign2
CLabel m_PowerHvWarning

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 17 of file PowerPage.h.

Constructor & Destructor Documentation

CPowerPage::CPowerPage ( )

Definition at line 24 of file PowerPage.cpp.

CPowerPage::~CPowerPage ( )

Definition at line 31 of file PowerPage.cpp.

Member Function Documentation

void CPowerPage::BuildToolTips ( )

Definition at line 630 of file PowerPage.cpp.

Here is the caller graph for this function:

void CPowerPage::CboTextVis | ( | int | nIdCbox,
 |  | int | nIdEdit,
 |  | BOOL | isText
 | ) |  |

Definition at line 365 of file PowerPage.cpp.

void CPowerPage::CboUpdate ( int nID_dci )

Definition at line 325 of file PowerPage.cpp.

Here is the caller graph for this function:

void CPowerPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 36 of file PowerPage.cpp.

void CPowerPage::Init_PAPS_Controls ( )

Definition at line 82 of file PowerPage.cpp.

Here is the caller graph for this function:

void CPowerPage::InitControls ( )

Definition at line 185 of file PowerPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CPowerPage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 267 of file PowerPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CPowerPage::isCComboBox ( int nID )

Definition at line 509 of file PowerPage.cpp.

Here is the caller graph for this function:

BOOL CPowerPage::isCEditBox ( int nID )

Definition at line 495 of file PowerPage.cpp.

Here is the caller graph for this function:

BOOL CPowerPage::isHVSignInString ( CString strHV )

Definition at line 541 of file PowerPage.cpp.

Here is the caller graph for this function:

BOOL CPowerPage::isHVSignPositive ( CString strHV )

Definition at line 548 of file PowerPage.cpp.

Here is the caller graph for this function:

void CPowerPage::OnBnClickedRadioHvSign1 ( )

Definition at line 555 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnBnClickedRadioHvSign2 ( )

Definition at line 561 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnCbnSelchangeOptComboBoot ( )

Definition at line 433 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnCbnSelchangeOptComboHvse ( )

Definition at line 438 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnCbnSelchangeOptComboPaps ( )

Definition at line 428 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnCbnSelchangeOptComboTecs ( )

Definition at line 443 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnEnChangeOptTextHvse ( )

Definition at line 448 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnEnChangeOptTextTecs ( )

Definition at line 453 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::OnHelp ( )

Definition at line 623 of file PowerPage.cpp.

BOOL CPowerPage::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 610 of file PowerPage.cpp.

BOOL CPowerPage::OnInitDialog ( ) [virtual]

Definition at line 110 of file PowerPage.cpp.

Here is the call graph for this function:

BOOL CPowerPage::OnSetActive ( ) [virtual]

Definition at line 70 of file PowerPage.cpp.

BOOL CPowerPage::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 458 of file PowerPage.cpp.

Here is the call graph for this function:

void CPowerPage::SetHvPowerWarning ( )

Definition at line 573 of file PowerPage.cpp.

Here is the caller graph for this function:

void CPowerPage::SetHVSign ( BOOL isPOS )

Definition at line 529 of file PowerPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CPowerPage::ShowMCA8000D_Controls ( int iShowWin )

Definition at line 241 of file PowerPage.cpp.

void CPowerPage::TextUpdate ( int nID_dci )

Definition at line 401 of file PowerPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

CLabel CPowerPage::m_PowerAdvancedLabel

Definition at line 53 of file PowerPage.h.

CLabel CPowerPage::m_PowerHvSign1

Definition at line 57 of file PowerPage.h.

CLabel CPowerPage::m_PowerHvSign2

Definition at line 59 of file PowerPage.h.

CLabel CPowerPage::m_PowerHvWarning

Definition at line 61 of file PowerPage.h.

CLabel CPowerPage::m_PowerPageLabel

Definition at line 51 of file PowerPage.h.

CLabel CPowerPage::m_PowerStandardLabel

Definition at line 55 of file PowerPage.h.

CToolTipCtrl CPowerPage::m_ToolTip [protected]

Definition at line 45 of file PowerPage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/PowerPage.h
  • DP5Cfg/PowerPage.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CRoi Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CRoi Class Reference

#include <roi.h>

List of all members.

Public Member Functions

CRoi ()
void | Insert (int i, int st, int en)
int | InsertSorted (int st, int en)
void | AddRoi (int st, int en)
void | Remove (int i)
void | Clear (void)
void | CopyRoi (CRoi &src)
int | AtChannel (int chan)
void | CalculateRoiInfo (double *buffer)

Public Attributes

int | m_count
int | m_selectIndex

Detailed Description

Definition at line 50 of file roi.h.

Constructor & Destructor Documentation

CRoi::CRoi ( ) [inline]

Definition at line 56 of file roi.h.

Member Function Documentation

void CRoi::AddRoi | ( | int | st,
 |  | int | en
 | ) |  | [inline]

Definition at line 59 of file roi.h.

Here is the call graph for this function:

int CRoi::AtChannel ( int chan )

Definition at line 65 of file Roi.cpp.

void CRoi::CalculateRoiInfo ( double * buffer )
void CRoi::Clear ( void )

Definition at line 58 of file Roi.cpp.

void CRoi::CopyRoi ( CRoi & src ) [inline]

Definition at line 62 of file roi.h.

void CRoi::Insert | ( | int | i,
 |  | int | st,
 |  | int | en
 | ) |  |

Definition at line 33 of file Roi.cpp.

Here is the caller graph for this function:

int CRoi::InsertSorted | ( | int | st,
 |  | int | en
 | ) |  |

Definition at line 41 of file Roi.cpp.

Here is the call graph for this function:

void CRoi::Remove ( int i )

Definition at line 23 of file Roi.cpp.

Member Data Documentation

int CRoi::m_count

Definition at line 53 of file roi.h.

int CRoi::m_selectIndex

Definition at line 54 of file roi.h.

The documentation for this class was generated from the following files:
  • roi.h
  • Roi.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CRoiEntry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CRoiEntry Class Reference

#include <roi.h>

List of all members.

Public Member Functions

CRoiEntry ()
CRoiEntry (int st, int en)

Public Attributes

int | m_start
int | m_end
double | m_total
double | m_net
double | m_centroid
double | m_uncertainty
double | m_fwhm
double | m_max
double | m_leftWidth
double | m_rightWidth
int | m_status

Detailed Description

Definition at line 20 of file roi.h.

Constructor & Destructor Documentation

CRoiEntry::CRoiEntry ( ) [inline]

Definition at line 41 of file roi.h.

CRoiEntry::CRoiEntry | ( | int | st,
 |  | int | en
 | ) |  | [inline]

Definition at line 42 of file roi.h.

Member Data Documentation

double CRoiEntry::m_centroid

Definition at line 28 of file roi.h.

int CRoiEntry::m_end

Definition at line 25 of file roi.h.

double CRoiEntry::m_fwhm

Definition at line 30 of file roi.h.

double CRoiEntry::m_leftWidth

Definition at line 32 of file roi.h.

double CRoiEntry::m_max

Definition at line 31 of file roi.h.

double CRoiEntry::m_net

Definition at line 27 of file roi.h.

double CRoiEntry::m_rightWidth

Definition at line 33 of file roi.h.

int CRoiEntry::m_start

Definition at line 24 of file roi.h.

int CRoiEntry::m_status

Definition at line 34 of file roi.h.

double CRoiEntry::m_total

Definition at line 26 of file roi.h.

double CRoiEntry::m_uncertainty

Definition at line 29 of file roi.h.

The documentation for this class was generated from the following file:
  • roi.h
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSca Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSca Class Reference

#include <Sca.h>

List of all members.

Public Member Functions

CSca (void)
~CSca (void)

Public Attributes

CString | strIniFilename
CString | CurIndex
BOOL | HaveCurIndex
CString | PulseWidth
CString | Index [MAX_SCA_REGISTER]
CString | Low [MAX_SCA_REGISTER]
CString | High [MAX_SCA_REGISTER]
CString | Output [MAX_SCA_REGISTER]
BOOL | HaveScaUpdate

Detailed Description

Definition at line 5 of file Sca.h.

Constructor & Destructor Documentation

CSca::CSca ( void )

Definition at line 4 of file Sca.cpp.

CSca::~CSca ( void )

Definition at line 10 of file Sca.cpp.

Member Data Documentation

CString CSca::CurIndex

Definition at line 12 of file Sca.h.

BOOL CSca::HaveCurIndex

Definition at line 13 of file Sca.h.

BOOL CSca::HaveScaUpdate

Definition at line 19 of file Sca.h.

CString CSca::High[MAX_SCA_REGISTER]

Definition at line 17 of file Sca.h.

CString CSca::Index[MAX_SCA_REGISTER]

Definition at line 15 of file Sca.h.

CString CSca::Low[MAX_SCA_REGISTER]

Definition at line 16 of file Sca.h.

CString CSca::Output[MAX_SCA_REGISTER]

Definition at line 18 of file Sca.h.

CString CSca::PulseWidth

Definition at line 14 of file Sca.h.

CString CSca::strIniFilename

Definition at line 11 of file Sca.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/Sca.h
  • DP5Cfg/Sca.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CScaFn Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CScaFn Class Reference

#include <ScaFn.h>

List of all members.

Public Member Functions

CScaFn (void)
~CScaFn (void)
BOOL | SplitData (CString strData, CString *varValue, CString strDefault)
long | varValueToIndex (CString varData)
void | SaveSCASetupINI (CSca sca)
void | DeleteIniSettingEx (CString strFilename, CString strSection, CString strKey)
void | SaveToIniEx (CString strFilename, CString strSection, CString strKey, CString strData)
void | SaveSCASettingsINI (CSca sca, long Index)
void | GetSCASetupINI (CSca *sca)
CString | GetFromIniEx (CString strFilename, CString strSection, CString strKey, CString strDefault)
void | GetSCASettingsINI (CSca *sca, long Index)
void | ReadSCASetting (CSca *sca, CString strSCAInfo)
CString | GetNextCMD (CString strCMDList)
void | SCACfgParser (CSca *sca, CString strSCASettings)
CString | SCAString (CString strCmd, CString strData, BOOL bDppMsg=TRUE)
CString | SCASetupString (CSca sca, BOOL bDppMsg=TRUE)
CString | SCASettingsString (CSca sca, long Index, BOOL bDppMsg=TRUE)
CString | SCAStringALL (CSca sca, BOOL bDppMsg=TRUE)
CString | SCAStringALLDisplay (CSca sca)
void | InitSCA (CSca *sca, long lChannels=8191, BOOL bTest=FALSE)

Public Attributes

CString | SCA_SECTION
CString | CFG_SECTION

Detailed Description

Definition at line 6 of file ScaFn.h.

Constructor & Destructor Documentation

CScaFn::CScaFn ( void )

Definition at line 5 of file ScaFn.cpp.

CScaFn::~CScaFn ( void )

Definition at line 11 of file ScaFn.cpp.

Member Function Documentation

void CScaFn::DeleteIniSettingEx | ( | CString | strFilename,
 |  | CString | strSection,
 |  | CString | strKey
 | ) |  |

Definition at line 107 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CScaFn::GetFromIniEx | ( | CString | strFilename,
 |  | CString | strSection,
 |  | CString | strKey,
 |  | CString | strDefault
 | ) |  |

Definition at line 166 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CScaFn::GetNextCMD ( CString strCMDList )

Definition at line 249 of file ScaFn.cpp.

Here is the caller graph for this function:

void CScaFn::GetSCASettingsINI | ( | CSca * | sca,
 |  | long | Index
 | ) |  |

Definition at line 181 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CScaFn::GetSCASetupINI ( CSca * sca )

Definition at line 138 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CScaFn::InitSCA | ( | CSca * | sca,
 |  | long | lChannels = 8191,
 |  | BOOL | bTest = FALSE
 | ) |  |

Definition at line 373 of file ScaFn.cpp.

Here is the caller graph for this function:

void CScaFn::ReadSCASetting | ( | CSca * | sca,
 |  | CString | strSCAInfo
 | ) |  |

Definition at line 208 of file ScaFn.cpp.

Here is the caller graph for this function:

void CScaFn::SaveSCASettingsINI | ( | CSca | sca,
 |  | long | Index
 | ) |  |

Definition at line 122 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CScaFn::SaveSCASetupINI ( CSca sca )

Definition at line 90 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CScaFn::SaveToIniEx | ( | CString | strFilename,
 |  | CString | strSection,
 |  | CString | strKey,
 |  | CString | strData
 | ) |  |

Definition at line 113 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CScaFn::SCACfgParser | ( | CSca * | sca,
 |  | CString | strSCASettings
 | ) |  |

Definition at line 262 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CScaFn::SCASettingsString | ( | CSca | sca,
 |  | long | Index,
 |  | BOOL | bDppMsg = TRUE
 | ) |  |

Definition at line 314 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CScaFn::SCASetupString | ( | CSca | sca,
 |  | BOOL | bDppMsg = TRUE
 | ) |  |

Definition at line 301 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CScaFn::SCAString | ( | CString | strCmd,
 |  | CString | strData,
 |  | BOOL | bDppMsg = TRUE
 | ) |  |

Definition at line 288 of file ScaFn.cpp.

Here is the caller graph for this function:

CString CScaFn::SCAStringALL | ( | CSca | sca,
 |  | BOOL | bDppMsg = TRUE
 | ) |  |

Definition at line 342 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CScaFn::SCAStringALLDisplay ( CSca sca )

Definition at line 356 of file ScaFn.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

BOOL CScaFn::SplitData | ( | CString | strData,
 |  | CString * | varValue,
 |  | CString | strDefault
 | ) |  |

Definition at line 15 of file ScaFn.cpp.

long CScaFn::varValueToIndex ( CString varData )

Definition at line 33 of file ScaFn.cpp.

Here is the caller graph for this function:

Member Data Documentation

CString CScaFn::CFG_SECTION

Definition at line 13 of file ScaFn.h.

CString CScaFn::SCA_SECTION

Definition at line 12 of file ScaFn.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/ScaFn.h
  • DP5Cfg/ScaFn.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSCommon Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSCommon Class Reference

#include <SCommon.h>

Collaboration diagram for CSCommon:
[legend]

List of all members.

Public Member Functions

CSCommon (void)
~CSCommon (void)
CString | GetDeviceNameFromVal (int DeviceTypeVal)
CString | Get (LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
int | Get (LPCTSTR profile, LPCTSTR entry, int def)
BOOL | Put (LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
BOOL | Put (LPCTSTR profile, LPCTSTR entry, int def)
void | LoadProfile ()
void | SaveProfile ()
void | CreateDP5Cfg ()
void | DP5CfgCmd (DP5_CMD_INDEX idxDP5Cfg, CString Command, int ListCtrlID, int TextCtrlID, DP5_CTRL_TYPE CtrlType, DP5_CTRL_GROUP CtrlGroup, CString Description, CString Units, CString Limits)

Public Attributes

CPlot m_plot
CPlot * plot
CSpectraList spectraList
CSpectrum m_Spectrum
CScaFn scafn
CSca sca
BOOL | SCAEnabled
CDppComm m_DppPort
CDppWinUSB DppWinUSB
CDppSocket m_DppSck
CWinusbNotify WinusbNotify
int | DppCommStatusInd
int | DppCommStatusIndOld
CDP5Status DP5Stat
CParsePacket ParsePkt
CDP5Protocol DP5Proto
CSendCommand SndCmd
CStringArray | Dp5CmdList
CString | HwCfgDP5
CString | HwCfgDP5Out
BOOL | HwCfgReady
BOOL | HwCfgExReady
unsigned char | CurrentInterface
BOOL | isDppFound [3]
BOOL | isDppConnected
UINT | ComPort
int | baud_rate
BOOL | NetfinderActive
unsigned long | SockAddr
CString | strSockAddr
CSProfile profileCls
CSProfile * profile
BOOL | ReloadCfg
BOOL | HaveConfig
BOOL | FindCommand
int | FindCtrlID
CDP5ControlUtil CtrlUtil
DP5_CONFIGURATION m_DP5Cfg [MAX_DP5_CONFIGURATIONS]
CDppConfig DppConfig
HWND | hWnd_Main
CString | strHelpFilePath
BOOL | isScaleLog
BOOL | isPlotLine

Detailed Description

Definition at line 63 of file SCommon.h.

Constructor & Destructor Documentation

CSCommon::CSCommon ( void )

Definition at line 13 of file SCommon.cpp.

CSCommon::~CSCommon ( void )

Definition at line 29 of file SCommon.cpp.

Member Function Documentation

void CSCommon::CreateDP5Cfg ( )

Definition at line 82 of file SCommon.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSCommon::DP5CfgCmd | ( | DP5_CMD_INDEX | idxDP5Cfg,
 |  | CString | Command,
 |  | int | ListCtrlID,
 |  | int | TextCtrlID,
 |  | DP5_CTRL_TYPE | CtrlType,
 |  | DP5_CTRL_GROUP | CtrlGroup,
 |  | CString | Description,
 |  | CString | Units,
 |  | CString | Limits
 | ) |  |

Definition at line 232 of file SCommon.cpp.

Here is the caller graph for this function:

CString CSCommon::Get | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | LPCTSTR | def
 | ) |  |

Definition at line 33 of file SCommon.cpp.

int CSCommon::Get | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | int | def
 | ) |  |

Definition at line 38 of file SCommon.cpp.

CString CSCommon::GetDeviceNameFromVal ( int DeviceTypeVal ) [inline]

Definition at line 69 of file SCommon.h.

Here is the caller graph for this function:

void CSCommon::LoadProfile ( )

Definition at line 53 of file SCommon.cpp.

Here is the caller graph for this function:

BOOL CSCommon::Put | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | LPCTSTR | def
 | ) |  |

Definition at line 43 of file SCommon.cpp.

BOOL CSCommon::Put | ( | LPCTSTR | profile,
 |  | LPCTSTR | entry,
 |  | int | def
 | ) |  |

Definition at line 48 of file SCommon.cpp.

void CSCommon::SaveProfile ( )

Definition at line 67 of file SCommon.cpp.

Here is the caller graph for this function:

Member Data Documentation

int CSCommon::baud_rate

Definition at line 142 of file SCommon.h.

UINT CSCommon::ComPort

Definition at line 141 of file SCommon.h.

CDP5ControlUtil CSCommon::CtrlUtil

Definition at line 160 of file SCommon.h.

unsigned char CSCommon::CurrentInterface

Definition at line 136 of file SCommon.h.

CStringArray CSCommon::Dp5CmdList

Definition at line 121 of file SCommon.h.

CDP5Protocol CSCommon::DP5Proto

Definition at line 118 of file SCommon.h.

CDP5Status CSCommon::DP5Stat

Definition at line 116 of file SCommon.h.

int CSCommon::DppCommStatusInd

Definition at line 112 of file SCommon.h.

int CSCommon::DppCommStatusIndOld

Definition at line 113 of file SCommon.h.

CDppConfig CSCommon::DppConfig

Definition at line 175 of file SCommon.h.

CDppWinUSB CSCommon::DppWinUSB

Definition at line 108 of file SCommon.h.

BOOL CSCommon::FindCommand

Definition at line 158 of file SCommon.h.

int CSCommon::FindCtrlID

Definition at line 159 of file SCommon.h.

BOOL CSCommon::HaveConfig

Definition at line 157 of file SCommon.h.

CString CSCommon::HwCfgDP5

Definition at line 122 of file SCommon.h.

CString CSCommon::HwCfgDP5Out

Definition at line 123 of file SCommon.h.

BOOL CSCommon::HwCfgExReady

Definition at line 125 of file SCommon.h.

BOOL CSCommon::HwCfgReady

Definition at line 124 of file SCommon.h.

HWND CSCommon::hWnd_Main

Definition at line 176 of file SCommon.h.

BOOL CSCommon::isDppConnected

Definition at line 138 of file SCommon.h.

BOOL CSCommon::isDppFound[3]

Definition at line 137 of file SCommon.h.

BOOL CSCommon::isPlotLine

Definition at line 190 of file SCommon.h.

BOOL CSCommon::isScaleLog

Definition at line 189 of file SCommon.h.

DP5_CONFIGURATION CSCommon::m_DP5Cfg[MAX_DP5_CONFIGURATIONS]

Definition at line 161 of file SCommon.h.

CDppComm CSCommon::m_DppPort

Definition at line 107 of file SCommon.h.

CDppSocket CSCommon::m_DppSck

Definition at line 109 of file SCommon.h.

CPlot CSCommon::m_plot

Definition at line 97 of file SCommon.h.

CSpectrum CSCommon::m_Spectrum

Definition at line 100 of file SCommon.h.

BOOL CSCommon::NetfinderActive

Definition at line 148 of file SCommon.h.

CParsePacket CSCommon::ParsePkt

Definition at line 117 of file SCommon.h.

CPlot* CSCommon::plot

Definition at line 98 of file SCommon.h.

CSProfile* CSCommon::profile

Definition at line 153 of file SCommon.h.

CSProfile CSCommon::profileCls

Definition at line 152 of file SCommon.h.

BOOL CSCommon::ReloadCfg

Definition at line 156 of file SCommon.h.

CSca CSCommon::sca

Definition at line 103 of file SCommon.h.

BOOL CSCommon::SCAEnabled

Definition at line 104 of file SCommon.h.

CScaFn CSCommon::scafn

Definition at line 102 of file SCommon.h.

CSendCommand CSCommon::SndCmd

Definition at line 119 of file SCommon.h.

unsigned long CSCommon::SockAddr

Definition at line 149 of file SCommon.h.

CSpectraList CSCommon::spectraList

Definition at line 99 of file SCommon.h.

CString CSCommon::strHelpFilePath

Definition at line 186 of file SCommon.h.

CString CSCommon::strSockAddr

Definition at line 150 of file SCommon.h.

CWinusbNotify CSCommon::WinusbNotify

Definition at line 110 of file SCommon.h.

The documentation for this class was generated from the following files:
  • SCommon.h
  • SCommon.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSelectDP5 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CSelectDP5 Class Reference

#include <SelectDP5.h>

Collaboration diagram for CSelectDP5:
[legend]

List of all members.

Public Member Functions

CSelectDP5 ()
virtual BOOL | OnInitDialog ()
void | ComPortEnum ()
int | GetComPortID ()
void | SetComPortID (int iComPort)
afx_msg void | OnCbnSelchangeComboComport ()
afx_msg void | OnBnClickedButtonClosePort ()
afx_msg void | OnBnClickedButtonOpenPort ()
afx_msg void | OnBnClickedButtonSerialReqData ()
void | SetDataRcvTimer (long Bytes)
void | ReqDataStatus ()
afx_msg void | OnTimer (UINT nIDEvent)
afx_msg LONG | OnCommunication (UINT, LONG)
void | OnComm ()
afx_msg void | OnBnClickedButtonFindUsbDevice ()
afx_msg void | OnBnClickedButtonFindDp5Ip ()
afx_msg LONG | OnReceive (UINT, LONG)
void | SendBroadcast (BOOL NewRand)
void | ReceivePacket ()
void | UpdateNetFinderStatus (CString strStatus, COLORREF rgbConnect, int idxEntry)
void | ClearNetFinderStatus (int idxEntry)
void | ClearNetFinderStatusAll ()
void | ReqDataStatusSock (unsigned long DppAddr)
virtual BOOL | DestroyWindow ()
void | EnableCommFunctions (int ControlGroup)
afx_msg void | OnBnClickedRadioCommtype1 ()
afx_msg void | OnBnClickedRadioCommtype2 ()
afx_msg void | OnBnClickedRadioCommtype3 ()
afx_msg void | OnBnClickedOk ()
void | UpdateNetfinderIpAddr (unsigned long IpAddr)
afx_msg void | OnBnClickedButtonIpSelect1 ()
afx_msg void | OnBnClickedButtonIpSelect2 ()
afx_msg void | OnBnClickedButtonIpSelect3 ()
afx_msg void | OnBnClickedButtonIpSelect4 ()
afx_msg void | OnStnClickedStaticNetfinder1 ()
afx_msg void | OnStnClickedStaticNetfinder2 ()
afx_msg void | OnStnClickedStaticNetfinder3 ()
afx_msg void | OnStnClickedStaticNetfinder4 ()
afx_msg void | OnBnClickedButtonCountDevices ()
afx_msg void | OnDeltaposSpinSelectDevice (NMHDR *pNMHDR, LRESULT *pResult)
afx_msg void | OnBnClickedButtonCloseDevice ()
afx_msg void | OnBnClickedCheckTypeIpAddress ()
afx_msg void | OnBnClickedConnectOK ()
virtual void | OnOK ()
void | CopyTextToClip (CString strTitle, CString strDesc)
afx_msg void | OnBnClickedButtonClipboardCopy ()
void | SetModified (BOOL bChanged)
afx_msg void | OnEnChangeSpectrumRefreshTime ()
afx_msg void | OnBnClickedButtonSpectrumRefreshDefault ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)

Public Attributes

CComboBox | cboComPort
UINT_PTR | m_nTmrRS232Id
UINT_PTR | m_nTmrRS232EventId
UINT | m_nTmrRS232Elapse
DP4_FORMAT_STATUS m_DP5_Status
unsigned char | DataIn [4096]
CLabel | lblNetFinder [4]
CNetFinder FindDpp
CNetFinder FindDppRS232
CNetFinder FindDppUSB
SocketOwnerType m_PrevOwner
CLabel | lblDppFound [3]
int | IpSelectBtn [4]
unsigned long | IpSelectAddr [4]
CSpinButtonCtrl | m_SpinSelectDevice
CButton | m_TypeInIPAddressCheck
BOOL | bTypeInIPAddress
BOOL | m_bModified
CEdit | m_SpectrumRefreshTimeCtrl

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 25 of file SelectDP5.h.

Constructor & Destructor Documentation

CSelectDP5::CSelectDP5 ( )

Definition at line 57 of file SelectDP5.cpp.

Member Function Documentation

void CSelectDP5::ClearNetFinderStatus ( int idxEntry )

Definition at line 413 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::ClearNetFinderStatusAll ( )

Definition at line 421 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::ComPortEnum ( )

Definition at line 488 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::CopyTextToClip | ( | CString | strTitle,
 |  | CString | strDesc
 | ) |  |

Definition at line 1064 of file SelectDP5.cpp.

Here is the caller graph for this function:

BOOL CSelectDP5::DestroyWindow ( ) [virtual]

Definition at line 476 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 66 of file SelectDP5.cpp.

void CSelectDP5::EnableCommFunctions ( int ControlGroup )

Definition at line 738 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CSelectDP5::GetComPortID ( )

Definition at line 514 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonClipboardCopy ( )

Definition at line 1078 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedButtonCloseDevice ( )

Definition at line 1026 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonClosePort ( )

Definition at line 537 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedButtonCountDevices ( )

Definition at line 962 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonFindDp5Ip ( )

Definition at line 201 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonFindUsbDevice ( )

Definition at line 680 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonIpSelect1 ( )

Definition at line 877 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonIpSelect2 ( )

Definition at line 887 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonIpSelect3 ( )

Definition at line 895 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonIpSelect4 ( )

Definition at line 903 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::OnBnClickedButtonOpenPort ( )

Definition at line 548 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedButtonSerialReqData ( )

Definition at line 652 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedButtonSpectrumRefreshDefault ( )

Definition at line 1105 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedCheckTypeIpAddress ( )

Definition at line 1036 of file SelectDP5.cpp.

void CSelectDP5::OnBnClickedConnectOK ( )

Definition at line 1041 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedOk ( )

Definition at line 871 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedRadioCommtype1 ( )

Definition at line 659 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedRadioCommtype2 ( )

Definition at line 665 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnBnClickedRadioCommtype3 ( )

Definition at line 673 of file SelectDP5.cpp.

Here is the call graph for this function:

afx_msg void CSelectDP5::OnCbnSelchangeComboComport ( )
void CSelectDP5::OnComm ( )

Definition at line 589 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

LONG CSelectDP5::OnCommunication | ( | UINT | ,
 |  | LONG |
 | ) |  |

Definition at line 569 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnDeltaposSpinSelectDevice | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  |

Definition at line 988 of file SelectDP5.cpp.

void CSelectDP5::OnEnChangeSpectrumRefreshTime ( )

Definition at line 1100 of file SelectDP5.cpp.

Here is the call graph for this function:

BOOL CSelectDP5::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 1112 of file SelectDP5.cpp.

BOOL CSelectDP5::OnInitDialog ( ) [virtual]

Definition at line 92 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnOK ( ) [virtual]

Definition at line 1059 of file SelectDP5.cpp.

Here is the caller graph for this function:

LONG CSelectDP5::OnReceive | ( | UINT | ,
 |  | LONG |
 | ) |  |

Definition at line 226 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnStnClickedStaticNetfinder1 ( )

Definition at line 911 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnStnClickedStaticNetfinder2 ( )

Definition at line 920 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnStnClickedStaticNetfinder3 ( )

Definition at line 929 of file SelectDP5.cpp.

Here is the call graph for this function:

void CSelectDP5::OnStnClickedStaticNetfinder4 ( )

Definition at line 938 of file SelectDP5.cpp.

Here is the call graph for this function:

afx_msg void CSelectDP5::OnTimer ( UINT nIDEvent )
void CSelectDP5::ReceivePacket ( )

Definition at line 239 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::ReqDataStatus ( )

Definition at line 636 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CSelectDP5::ReqDataStatusSock ( unsigned long DppAddr )

Definition at line 429 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::SendBroadcast ( BOOL NewRand )

Definition at line 457 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::SetComPortID ( int iComPort )

Definition at line 523 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::SetDataRcvTimer ( long Bytes )
void CSelectDP5::SetModified ( BOOL bChanged )

Definition at line 1095 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::UpdateNetfinderIpAddr ( unsigned long IpAddr )

Definition at line 947 of file SelectDP5.cpp.

Here is the caller graph for this function:

void CSelectDP5::UpdateNetFinderStatus | ( | CString | strStatus,
 |  | COLORREF | rgbConnect,
 |  | int | idxEntry
 | ) |  |

Definition at line 405 of file SelectDP5.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

Member Data Documentation

BOOL CSelectDP5::bTypeInIPAddress

Definition at line 132 of file SelectDP5.h.

CComboBox CSelectDP5::cboComPort

Definition at line 57 of file SelectDP5.h.

unsigned char CSelectDP5::DataIn[4096]

Definition at line 67 of file SelectDP5.h.

CNetFinder CSelectDP5::FindDpp

Definition at line 88 of file SelectDP5.h.

CNetFinder CSelectDP5::FindDppRS232

Definition at line 90 of file SelectDP5.h.

CNetFinder CSelectDP5::FindDppUSB

Definition at line 91 of file SelectDP5.h.

unsigned long CSelectDP5::IpSelectAddr[4]

Definition at line 109 of file SelectDP5.h.

int CSelectDP5::IpSelectBtn[4]

Definition at line 108 of file SelectDP5.h.

CLabel CSelectDP5::lblDppFound[3]

Definition at line 104 of file SelectDP5.h.

CLabel CSelectDP5::lblNetFinder[4]

Definition at line 87 of file SelectDP5.h.

BOOL CSelectDP5::m_bModified

Definition at line 136 of file SelectDP5.h.

DP4_FORMAT_STATUS CSelectDP5::m_DP5_Status

Definition at line 63 of file SelectDP5.h.

UINT CSelectDP5::m_nTmrRS232Elapse

Definition at line 61 of file SelectDP5.h.

UINT_PTR CSelectDP5::m_nTmrRS232EventId

Definition at line 60 of file SelectDP5.h.

UINT_PTR CSelectDP5::m_nTmrRS232Id

Definition at line 59 of file SelectDP5.h.

SocketOwnerType CSelectDP5::m_PrevOwner

Definition at line 93 of file SelectDP5.h.

CEdit CSelectDP5::m_SpectrumRefreshTimeCtrl

Definition at line 138 of file SelectDP5.h.

CSpinButtonCtrl CSelectDP5::m_SpinSelectDevice

Definition at line 122 of file SelectDP5.h.

CToolTipCtrl CSelectDP5::m_ToolTip [protected]

Definition at line 41 of file SelectDP5.h.

CButton CSelectDP5::m_TypeInIPAddressCheck

Definition at line 127 of file SelectDP5.h.

The documentation for this class was generated from the following files:
  • DeviceIO/SelectDP5.h
  • DeviceIO/SelectDP5.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSendCommand Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSendCommand Class Reference

#include <SendCommand.h>

Collaboration diagram for CSendCommand:
[legend]

List of all members.

Public Member Functions

CSendCommand (void)
~CSendCommand (void)
bool | TestPacketCkSumOK (unsigned char Data[])
Packet checksum test for commands with data.
bool | DP5_CMD (unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd)
Creates a DPP command that does not require additional processing.
bool | DP5_CMD_Config (unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions)
Creates a DPP command that requires configuration data options processing.
bool | DP5_CMD_Data (unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[])
Creates a DPP command that requires data.
bool | POUT_Buffer (Packet_Out POUT, unsigned char Buffer[])
Creates a packet output buffer from a command byte data array.

Public Attributes

CAsciiCmdUtilities AsciiCmdUtil

Detailed Description

CSendCommand prepares all command packets to be sent. Call CSendCommand::DP5_CMD, CSendCommand::DP5_CMD_Config or CSendCommand::DP5_CMD_Data along with the TRANSMIT_PACKET_TYPE and any additional data or options.

A command array of 8-bit bytes is generated.

Definition at line 23 of file SendCommand.h.

Constructor & Destructor Documentation

CSendCommand::CSendCommand ( void )

Definition at line 4 of file SendCommand.cpp.

CSendCommand::~CSendCommand ( void )

Definition at line 8 of file SendCommand.cpp.

Member Function Documentation

bool CSendCommand::DP5_CMD | ( | unsigned char | Buffer[],
 |  | TRANSMIT_PACKET_TYPE | XmtCmd
 | ) |  |

Creates a DPP command that does not require additional processing.

Definition at line 42 of file SendCommand.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CSendCommand::DP5_CMD_Config | ( | unsigned char | Buffer[],
 |  | TRANSMIT_PACKET_TYPE | XmtCmd,
 |  | CONFIG_OPTIONS | CfgOptions
 | ) |  |

Creates a DPP command that requires configuration data options processing.

Definition at line 273 of file SendCommand.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CSendCommand::DP5_CMD_Data | ( | unsigned char | Buffer[],
 |  | TRANSMIT_PACKET_TYPE | XmtCmd,
 |  | unsigned char | DataOut[]
 | ) |  |

Creates a DPP command that requires data.

Definition at line 404 of file SendCommand.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CSendCommand::POUT_Buffer | ( | Packet_Out | POUT,
 |  | unsigned char | Buffer[]
 | ) |  |

Creates a packet output buffer from a command byte data array.

Definition at line 446 of file SendCommand.cpp.

Here is the caller graph for this function:

bool CSendCommand::TestPacketCkSumOK ( unsigned char Data[] )

Packet checksum test for commands with data.

Definition at line 12 of file SendCommand.cpp.

Here is the caller graph for this function:

Member Data Documentation

CAsciiCmdUtilities CSendCommand::AsciiCmdUtil

Definition at line 28 of file SendCommand.h.

The documentation for this class was generated from the following files:
  • DeviceIO/SendCommand.h
  • DeviceIO/SendCommand.cpp
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CShapingPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CShapingPage Class Reference

#include <ShapingPage.h>

Inheritance diagram for CShapingPage:
[legend]
Collaboration diagram for CShapingPage:
[legend]

List of all members.

Public Member Functions

CShapingPage ()
~CShapingPage ()
void | BuildToolTips ()
virtual BOOL | OnSetActive ()
virtual BOOL | OnInitDialog ()
void | InitControls ()
void | ShowMCA8000D_Controls (int iShowWin)
void | InitDlgItem (HWND hDlg, DP5_CONFIGURATION cfg)
void | CboUpdate (int nID_dci)
void | TextUpdate (int nID_dci)
afx_msg void | OnCbnSelchangeOptComboPure ()
afx_msg void | OnCbnSelchangeOptComboSctc ()
afx_msg void | OnCbnSelchangeOptComboRtde ()
afx_msg void | OnCbnSelchangeOptComboBlrm ()
void | DisplayBlrMode ()
afx_msg void | OnCbnSelchangeOptComboCusp ()
afx_msg void | OnEnChangeOptTextTfla ()
afx_msg void | OnEnChangeOptTextThfa ()
afx_msg void | OnEnChangeOptTextTpea ()
afx_msg void | OnEnChangeOptTextRtds ()
afx_msg void | OnEnChangeOptTextRtdt ()
afx_msg void | OnEnChangeOptTextBlrd ()
afx_msg void | OnEnChangeOptTextBlru ()
afx_msg void | OnEnChangeOptTextCusp ()
afx_msg void | OnEnChangeOptTextPure ()
afx_msg void | OnEnChangeOptTextSctc ()
afx_msg void | OnCbnSelchangeOptComboClck ()
void | BLRQuickSet (CString strMode, CString strDown, CString strUp)
void | CboTextVis (int nIdCbox, int nIdEdit, BOOL isText)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | isCEditBox (int nID)
BOOL | isCComboBox (int nID)
void | InitFastPeakCombo ()
void | InitBlrMode ()
void | SetCboItem (int nID, CString strVal)
afx_msg void | OnCbnSelchangeRisecombo ()
afx_msg void | OnCbnSelchangeTopcombo ()
void | InitComboFromText (HWND hDlg, DP5_CONFIGURATION cfg, int nID)
afx_msg void | OnCbnSelchangeOptComboTpfa ()
afx_msg void | OnBnClickedBlrquickslowbutton2 ()
afx_msg void | OnHelp ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)

Public Attributes

CLabel m_ShapingPageLabel
CLabel m_ShapingAdvancedLabel
CLabel m_ShapingStandardLabel
CDppShaping RiseTop
CComboBox | m_RiseCombo
CComboBox | m_TopCombo
CComboBox | m_FastPeakCombo
CLabel | lblFPGAClk [3]
BOOL | b80MHzModeCfg_old

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)

Protected Attributes

CToolTipCtrl | m_ToolTip

Detailed Description

Definition at line 18 of file ShapingPage.h.

Constructor & Destructor Documentation

CShapingPage::CShapingPage ( )

Definition at line 24 of file ShapingPage.cpp.

CShapingPage::~CShapingPage ( )

Definition at line 31 of file ShapingPage.cpp.

Member Function Documentation

void CShapingPage::BLRQuickSet | ( | CString | strMode,
 |  | CString | strDown,
 |  | CString | strUp
 | ) |  |

Definition at line 718 of file ShapingPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CShapingPage::BuildToolTips ( )

Definition at line 943 of file ShapingPage.cpp.

Here is the caller graph for this function:

void CShapingPage::CboTextVis | ( | int | nIdCbox,
 |  | int | nIdEdit,
 |  | BOOL | isText
 | ) |  |

Definition at line 537 of file ShapingPage.cpp.

void CShapingPage::CboUpdate ( int nID_dci )

Definition at line 487 of file ShapingPage.cpp.

Here is the caller graph for this function:

void CShapingPage::DisplayBlrMode ( )

Definition at line 613 of file ShapingPage.cpp.

Here is the caller graph for this function:

void CShapingPage::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Reimplemented from CCfgPropPage.

Definition at line 36 of file ShapingPage.cpp.

void CShapingPage::InitBlrMode ( )

Definition at line 384 of file ShapingPage.cpp.

Here is the caller graph for this function:

void CShapingPage::InitComboFromText | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg,
 |  | int | nID
 | ) |  |

Definition at line 891 of file ShapingPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CShapingPage::InitControls ( )

Definition at line 170 of file ShapingPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CShapingPage::InitDlgItem | ( | HWND | hDlg,
 |  | DP5_CONFIGURATION | cfg
 | ) |  |

Definition at line 397 of file ShapingPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CShapingPage::InitFastPeakCombo ( )

Definition at line 365 of file ShapingPage.cpp.

Here is the caller graph for this function:

BOOL CShapingPage::isCComboBox ( int nID )

Definition at line 822 of file ShapingPage.cpp.

Here is the caller graph for this function:

BOOL CShapingPage::isCEditBox ( int nID )

Definition at line 781 of file ShapingPage.cpp.

Here is the caller graph for this function:

void CShapingPage::OnBnClickedBlrquickslowbutton2 ( )

Definition at line 915 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboBlrm ( )

Definition at line 607 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboClck ( )

Definition at line 691 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboCusp ( )

Definition at line 626 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboPure ( )

Definition at line 586 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboRtde ( )

Definition at line 602 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboSctc ( )

Definition at line 593 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeOptComboTpfa ( )

Definition at line 646 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeRisecombo ( )

Definition at line 871 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnCbnSelchangeTopcombo ( )

Definition at line 882 of file ShapingPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CShapingPage::OnEnChangeOptTextBlrd ( )

Definition at line 676 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextBlru ( )

Definition at line 681 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextCusp ( )

Definition at line 686 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextPure ( )

Definition at line 631 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextRtds ( )

Definition at line 666 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextRtdt ( )

Definition at line 671 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextSctc ( )

Definition at line 638 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextTfla ( )

Definition at line 651 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextThfa ( )

Definition at line 656 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnEnChangeOptTextTpea ( )

Definition at line 661 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::OnHelp ( )

Definition at line 936 of file ShapingPage.cpp.

BOOL CShapingPage::OnHelpInfo ( HELPINFO * pHelpInfo )

Definition at line 923 of file ShapingPage.cpp.

BOOL CShapingPage::OnInitDialog ( ) [virtual]

Definition at line 101 of file ShapingPage.cpp.

Here is the call graph for this function:

BOOL CShapingPage::OnSetActive ( ) [virtual]

Definition at line 94 of file ShapingPage.cpp.

BOOL CShapingPage::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 744 of file ShapingPage.cpp.

Here is the call graph for this function:

void CShapingPage::SetCboItem | ( | int | nID,
 |  | CString | strVal
 | ) |  |

Definition at line 854 of file ShapingPage.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CShapingPage::ShowMCA8000D_Controls ( int iShowWin )

Definition at line 291 of file ShapingPage.cpp.

void CShapingPage::TextUpdate ( int nID_dci )

Definition at line 573 of file ShapingPage.cpp.

Here is the caller graph for this function:

Member Data Documentation

BOOL CShapingPage::b80MHzModeCfg_old

Definition at line 105 of file ShapingPage.h.

CLabel CShapingPage::lblFPGAClk[3]

Definition at line 104 of file ShapingPage.h.

CComboBox CShapingPage::m_FastPeakCombo

Definition at line 95 of file ShapingPage.h.

CComboBox CShapingPage::m_RiseCombo

Definition at line 93 of file ShapingPage.h.

CLabel CShapingPage::m_ShapingAdvancedLabel

Definition at line 54 of file ShapingPage.h.

CLabel CShapingPage::m_ShapingPageLabel

Definition at line 52 of file ShapingPage.h.

CLabel CShapingPage::m_ShapingStandardLabel

Definition at line 56 of file ShapingPage.h.

CToolTipCtrl CShapingPage::m_ToolTip [protected]

Definition at line 46 of file ShapingPage.h.

CComboBox CShapingPage::m_TopCombo

Definition at line 94 of file ShapingPage.h.

CDppShaping CShapingPage::RiseTop

Definition at line 92 of file ShapingPage.h.

The documentation for this class was generated from the following files:
  • DP5Cfg/ShapingPage.h
  • DP5Cfg/ShapingPage.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSpectraList Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSpectraList Class Reference

#include <SpectraList.h>

Collaboration diagram for CSpectraList:
[legend]

List of all members.

Public Member Functions

CSpectraList (void)
~CSpectraList (void)

Public Attributes

CSpectrum * m_currentSpectrum

Detailed Description

Definition at line 5 of file SpectraList.h.

Constructor & Destructor Documentation

CSpectraList::CSpectraList ( void )

Definition at line 3 of file SpectraList.cpp.

CSpectraList::~CSpectraList ( void )

Definition at line 7 of file SpectraList.cpp.

Member Data Documentation

CSpectrum* CSpectraList::m_currentSpectrum

Definition at line 10 of file SpectraList.h.

The documentation for this class was generated from the following files:
  • SpectraList.h
  • SpectraList.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSpectrum Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSpectrum Class Reference

#include <Spectrum.h>

Collaboration diagram for CSpectrum:
[legend]

List of all members.

Public Member Functions

CSpectrum (void)
~CSpectrum (void)
int | PosToChannel (double pos)
int | PosToChannel (int pos)

Public Attributes

CSpectrumAttr m_attr
CRoi m_roi

Detailed Description

Definition at line 6 of file Spectrum.h.

Constructor & Destructor Documentation

CSpectrum::CSpectrum ( void )

Definition at line 4 of file Spectrum.cpp.

CSpectrum::~CSpectrum ( void )

Definition at line 8 of file Spectrum.cpp.

Member Function Documentation

int CSpectrum::PosToChannel ( double pos )

Definition at line 13 of file Spectrum.cpp.

Here is the caller graph for this function:

int CSpectrum::PosToChannel ( int pos )

Definition at line 19 of file Spectrum.cpp.

Member Data Documentation

CSpectrumAttr CSpectrum::m_attr

Definition at line 13 of file Spectrum.h.

CRoi CSpectrum::m_roi

Definition at line 14 of file Spectrum.h.

The documentation for this class was generated from the following files:
  • Spectrum.h
  • Spectrum.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSpectrumAttr Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSpectrumAttr Class Reference

#include <SpectrumAttr.h>

List of all members.

Public Member Functions

CSpectrumAttr (void)
~CSpectrumAttr (void)
void | SetDefaultAttr (void)
BOOL | ValidateTag (void)

Public Attributes

int | gainIndex
CString | file
CString | tag
CString | description
CString | generalNotes
CString | notesNotes
CString | systemNotes
CString | expressionText
int | contourWidth
COLORREF | contourColor
BOOL | isExpression
BOOL | printNotes

Detailed Description

Definition at line 5 of file SpectrumAttr.h.

Constructor & Destructor Documentation

CSpectrumAttr::CSpectrumAttr ( void )

Definition at line 5 of file SpectrumAttr.cpp.

CSpectrumAttr::~CSpectrumAttr ( void )

Definition at line 9 of file SpectrumAttr.cpp.

Member Function Documentation

void CSpectrumAttr::SetDefaultAttr ( void )
BOOL CSpectrumAttr::ValidateTag ( void )

Member Data Documentation

COLORREF CSpectrumAttr::contourColor

Definition at line 19 of file SpectrumAttr.h.

int CSpectrumAttr::contourWidth

Definition at line 18 of file SpectrumAttr.h.

CString CSpectrumAttr::description

Definition at line 13 of file SpectrumAttr.h.

CString CSpectrumAttr::expressionText

Definition at line 17 of file SpectrumAttr.h.

CString CSpectrumAttr::file

Definition at line 11 of file SpectrumAttr.h.

int CSpectrumAttr::gainIndex

Definition at line 10 of file SpectrumAttr.h.

CString CSpectrumAttr::generalNotes

Definition at line 14 of file SpectrumAttr.h.

BOOL CSpectrumAttr::isExpression

Definition at line 20 of file SpectrumAttr.h.

CString CSpectrumAttr::notesNotes

Definition at line 15 of file SpectrumAttr.h.

BOOL CSpectrumAttr::printNotes

Definition at line 21 of file SpectrumAttr.h.

CString CSpectrumAttr::systemNotes

Definition at line 16 of file SpectrumAttr.h.

CString CSpectrumAttr::tag

Definition at line 12 of file SpectrumAttr.h.

The documentation for this class was generated from the following files:
  • SpectrumAttr.h
  • SpectrumAttr.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CSProfile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CSProfile Class Reference

#include <SCommon.h>

Collaboration diagram for CSProfile:
[legend]

List of all members.

Public Member Functions

CSProfile ()
~CSProfile ()

Public Attributes

CString | profile
int | device_type
int | data_refresh
CString | strDevice
BOOL | SendCoarseFineGain
CScaFn scafn
CSca sca
BOOL | SCAEnabled
unsigned long | SockAddr
UINT | ComPort
int | baud_rate
unsigned char | CurrentInterface

Detailed Description

Definition at line 38 of file SCommon.h.

Constructor & Destructor Documentation

CSProfile::CSProfile ( ) [inline]

Definition at line 59 of file SCommon.h.

CSProfile::~CSProfile ( ) [inline]

Definition at line 60 of file SCommon.h.

Member Data Documentation

int CSProfile::baud_rate

Definition at line 55 of file SCommon.h.

UINT CSProfile::ComPort

Definition at line 54 of file SCommon.h.

unsigned char CSProfile::CurrentInterface

Definition at line 56 of file SCommon.h.

int CSProfile::data_refresh

Definition at line 43 of file SCommon.h.

int CSProfile::device_type

Definition at line 42 of file SCommon.h.

CString CSProfile::profile

Definition at line 41 of file SCommon.h.

CSca CSProfile::sca

Definition at line 50 of file SCommon.h.

BOOL CSProfile::SCAEnabled

Definition at line 51 of file SCommon.h.

CScaFn CSProfile::scafn

Definition at line 49 of file SCommon.h.

BOOL CSProfile::SendCoarseFineGain

Definition at line 47 of file SCommon.h.

unsigned long CSProfile::SockAddr

Definition at line 53 of file SCommon.h.

CString CSProfile::strDevice

Definition at line 44 of file SCommon.h.

The documentation for this class was generated from the following file:
  • SCommon.h
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CTrapKeyComboBox Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CTrapKeyComboBox Class Reference

#include <TrapKeyComboBox.h>

List of all members.

Public Member Functions

CTrapKeyComboBox (void)
virtual | ~CTrapKeyComboBox ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)

Public Attributes

bool | isEnterKey
bool | isLButton

Detailed Description

Definition at line 13 of file TrapKeyComboBox.h.

Constructor & Destructor Documentation

CTrapKeyComboBox::CTrapKeyComboBox ( void )

Definition at line 4 of file TrapKeyComboBox.cpp.

CTrapKeyComboBox::~CTrapKeyComboBox ( void ) [virtual]

Definition at line 10 of file TrapKeyComboBox.cpp.

Member Function Documentation

BOOL CTrapKeyComboBox::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 14 of file TrapKeyComboBox.cpp.

Member Data Documentation

bool CTrapKeyComboBox::isEnterKey

Definition at line 19 of file TrapKeyComboBox.h.

bool CTrapKeyComboBox::isLButton

Definition at line 20 of file TrapKeyComboBox.h.

The documentation for this class was generated from the following files:
  • Controls/TrapKeyComboBox.h
  • Controls/TrapKeyComboBox.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CTrapKeyEdit Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions
CTrapKeyEdit Class Reference

#include <TrapKeyEdit.h>

List of all members.

Public Member Functions

CTrapKeyEdit (void)
virtual | ~CTrapKeyEdit ()
void | DispatchEventEN_CHANGE ()

Public Attributes

bool | isEnterKey
bool | isLButton
bool | m_bFocusFlag

Protected Member Functions

afx_msg UINT | OnGetDlgCode ()
afx_msg void | OnKeyUp (UINT nChar, UINT nRepCnt, UINT nFlags)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnKillfocus ()

Detailed Description

Definition at line 13 of file TrapKeyEdit.h.

Constructor & Destructor Documentation

CTrapKeyEdit::CTrapKeyEdit ( void )

Definition at line 4 of file TrapKeyEdit.cpp.

CTrapKeyEdit::~CTrapKeyEdit ( void ) [virtual]

Definition at line 12 of file TrapKeyEdit.cpp.

Member Function Documentation

void CTrapKeyEdit::DispatchEventEN_CHANGE ( )

Definition at line 28 of file TrapKeyEdit.cpp.

Here is the caller graph for this function:

UINT CTrapKeyEdit::OnGetDlgCode ( ) [protected]

Definition at line 23 of file TrapKeyEdit.cpp.

void CTrapKeyEdit::OnKeyUp | ( | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags
 | ) |  | [protected]

Definition at line 39 of file TrapKeyEdit.cpp.

Here is the call graph for this function:

void CTrapKeyEdit::OnKillfocus ( ) [protected]

Definition at line 81 of file TrapKeyEdit.cpp.

void CTrapKeyEdit::OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  | [protected]

Definition at line 64 of file TrapKeyEdit.cpp.

Here is the call graph for this function:

Member Data Documentation

bool CTrapKeyEdit::isEnterKey

Definition at line 21 of file TrapKeyEdit.h.

bool CTrapKeyEdit::isLButton

Definition at line 22 of file TrapKeyEdit.h.

bool CTrapKeyEdit::m_bFocusFlag

Definition at line 24 of file TrapKeyEdit.h.

The documentation for this class was generated from the following files:
  • Controls/TrapKeyEdit.h
  • Controls/TrapKeyEdit.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CTuneSlowThreshold Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CTuneSlowThreshold Class Reference

#include <TuneSlowThreshold.h>

List of all members.

Public Member Functions

CTuneSlowThreshold (void)
~CTuneSlowThreshold (void)
void | SetSlowThreshToChPos (int ChPosIn, int mcaCH)
void | DelayTask (DWORD d)
int | GetSlowThreshCalStart (double *SpectrumBuffer, double UpperChMax, int mcaCH)
double | GetUpperChCounts (double *SpectrumBuffer, int mcaCH)
double | GetUpperChMax (double *SpectrumBuffer, int mcaCH)
void | GetSpectrumData (double *dblMCAData, long *lngMCAData, int mcaCH)
int | UpdatePlotCursorPosFromIntChPos (int CurCh, double dblPixPerChan)
void | DisplaySpecBuf25 (double *SpectrumBuffer)
int | GetSlowThreshChStrFromVal (unsigned char byteSlowThres, int mcaCH)

Detailed Description

Definition at line 9 of file TuneSlowThreshold.h.

Constructor & Destructor Documentation

CTuneSlowThreshold::CTuneSlowThreshold ( void )

Definition at line 9 of file TuneSlowThreshold.cpp.

CTuneSlowThreshold::~CTuneSlowThreshold ( void )

Definition at line 13 of file TuneSlowThreshold.cpp.

Member Function Documentation

void CTuneSlowThreshold::DelayTask ( DWORD d )

Definition at line 110 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

void CTuneSlowThreshold::DisplaySpecBuf25 ( double * SpectrumBuffer )

Definition at line 137 of file TuneSlowThreshold.cpp.

int CTuneSlowThreshold::GetSlowThreshCalStart | ( | double * | SpectrumBuffer,
 |  | double | UpperChMax,
 |  | int | mcaCH
 | ) |  |

Definition at line 44 of file TuneSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CTuneSlowThreshold::GetSlowThreshChStrFromVal | ( | unsigned char | byteSlowThres,
 |  | int | mcaCH
 | ) |  |

Definition at line 151 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

void CTuneSlowThreshold::GetSpectrumData | ( | double * | dblMCAData,
 |  | long * | lngMCAData,
 |  | int | mcaCH
 | ) |  |

Definition at line 17 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

double CTuneSlowThreshold::GetUpperChCounts | ( | double * | SpectrumBuffer,
 |  | int | mcaCH
 | ) |  |

Definition at line 84 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

double CTuneSlowThreshold::GetUpperChMax | ( | double * | SpectrumBuffer,
 |  | int | mcaCH
 | ) |  |

Definition at line 98 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

void CTuneSlowThreshold::SetSlowThreshToChPos | ( | int | ChPosIn,
 |  | int | mcaCH
 | ) |  |

Definition at line 23 of file TuneSlowThreshold.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

int CTuneSlowThreshold::UpdatePlotCursorPosFromIntChPos | ( | int | CurCh,
 |  | double | dblPixPerChan
 | ) |  |

Definition at line 124 of file TuneSlowThreshold.cpp.

Here is the caller graph for this function:

The documentation for this class was generated from the following files:
  • Config/TuneSlowThreshold.h
  • Config/TuneSlowThreshold.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CvcDP5App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
CvcDP5App Class Reference

#include <vcDP5.h>

List of all members.

Public Member Functions

CvcDP5App ()
virtual BOOL InitInstance ()

Detailed Description

Definition at line 17 of file vcDP5.h.

Constructor & Destructor Documentation

CvcDP5App::CvcDP5App ( )

Definition at line 23 of file vcDP5.cpp.

Member Function Documentation

BOOL CvcDP5App::InitInstance ( ) [virtual]

Definition at line 39 of file vcDP5.cpp.

Here is the call graph for this function:

The documentation for this class was generated from the following files:
  • vcDP5.h
  • vcDP5.cpp
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CvcDP5Dlg Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes
CvcDP5Dlg Class Reference

#include <vcDP5Dlg.h>

Collaboration diagram for CvcDP5Dlg:
[legend]

List of all members.

Public Types

enum | { IDD = IDD_vcDP5_DIALOG }

Public Member Functions

CvcDP5Dlg (CWnd *pParent=NULL)
~CvcDP5Dlg ()
bool | BOOL_TO_bool (BOOL bValue)
afx_msg void | OnBnClickedButtonFindDevice ()
afx_msg BOOL | OnDeviceChange (UINT nEventType, DWORD_PTR dwData)
afx_msg void | OnDestroy ()
unsigned long | DataTest ()
afx_msg void | OnTimer (UINT nIDEvent)
afx_msg void | OnBnClickedButtonArmTrigger ()
afx_msg void | OnBnClickedButtonSaveFile ()
afx_msg void | OnBnClickedButtonClearDataAndGraph ()
afx_msg void | OnBnClickedButtonSingleUpdate ()
afx_msg void | OnBnClickedButtonClearMiscData ()
afx_msg void | OnBnClickedButtonReadMiscData ()
afx_msg void | OnBnClickedButtonWriteMiscData ()
void | ShowStatus (CString strStatus)
void | ParsePacketEx (Packet_In PIN, DppStateType DppState)
void | ProcessDiagDataEx (Packet_In PIN, DppStateType DppState)
void | ProcessStatusEx (Packet_In PIN, DppStateType DppState)
void | ConvertStatusDP5ToDP4 (DP4_FORMAT_STATUS m_DP5_Status)
void | ProcessSpectrumEx (Packet_In PIN, DppStateType DppState)
void | ProcessScopeDataEx (Packet_In PIN, DppStateType DppState)
void | ProcessTextDataEx (Packet_In PIN, DppStateType DppState)
void | ProcessAck (unsigned char PID2)
void | DisplayError (Packet_In PIN, DppStateType DppState)
void | RequestScopeData (BOOL ScopeDataReady)
void | SendCommand (TRANSMIT_PACKET_TYPE XmtCmd)
void | SendCommandConfig (TRANSMIT_PACKET_TYPE XmtCmd)
string | CreateSpectrumConfig (string strRawCfgIn)
void | SendCommandData (TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[])
void | RemCallParsePacket (unsigned char PacketIn[])
void | PlotData (long DataBuffer[8192], int NumChan)
void | UpdatePlot ()
void | ScopeDisplay (unsigned char ScopeData[2048])
void | UpdateScope ()
void | EnableDPPFunctions (BOOL isEnabled)
afx_msg void | OnBnClickedButtonDiag ()
afx_msg LONG | OnReceive (UINT, LONG)
afx_msg void | OnBnClickedButtonSelectComm ()
afx_msg LONG | OnCommunication (UINT, LONG)
void | OnComm ()
void | OnResetCommunications ()
afx_msg void | OnBnClickedButtonGetSpectrum ()
afx_msg void | OnBnClickedButtonStartAcquisition ()
afx_msg void | OnBnClickedButtonStopAcquisition ()
afx_msg void | OnBnClickedButtonEditConfig ()
CString | GetDeviceNameFromVal (int DeviceTypeVal)
BOOL | isConnectedTest ()
afx_msg LRESULT | DppSendConfigToHw (WPARAM wParam, LPARAM lParam)
void | ProcessCfgReadEx (Packet_In PIN, DppStateType DppState)
string | GetCmdData (string strCmd, string strCfgData)
CString | GetCmdDataMS (CString strCmd, CString strCfgData)
string | GetCmdDesc (string strCmd)
CString | GetCmdDescMS (CString strCmd)
string | ReplaceCmdDesc (string strCmd, string strCfgData)
CString | ReplaceCmdDescMS (CString strCmd, CString strCfgData)
string | AppendCmdDesc (string strCmd, string strCfgData)
vector< string > | MakeDp5CmdList ()
void | CopyDp5CfgToClip (CString strCfg, CString strDesc)
afx_msg LRESULT | CallReadDppConfig (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | CallReadDppConfigEx (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | CallReadScaConfig (WPARAM wParam, LPARAM lParam)
afx_msg void | OnBnClickedButtonShowConfig ()
afx_msg void | OnBnClickedRadioPlotScaleLinear ()
afx_msg void | OnBnClickedRadioPlotScaleLog ()
afx_msg void | OnBnClickedRadioPlotTypeSolid ()
afx_msg void | OnBnClickedRadioPlotTypeLine ()
void | SaveMCAFile (string strFilename, string strMCA)
afx_msg void | OnBnClickedBtnSaveFile ()
string | CreateMCAData (long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst)
void | SetStartTime ()
afx_msg void | OnStnClickedPlotpicturecontrol ()
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
afx_msg void | OnBnClickedOk ()
afx_msg void | OnBnClickedCancel ()
void | SetPlotChannel ()
afx_msg void | OnBnClickedButtonClearRoi ()
afx_msg void | OnBnClickedButtonRoiEnd ()
afx_msg void | OnBnClickedButtonRoiStart ()
afx_msg BOOL | OnToolTipNotify (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
afx_msg void | TuneFastSlowThresh ()
afx_msg void | OnBnClickedButtonAutotune ()
double | GetPixPerChannel ()
string | CreateDTS (string strFormat)
CString | ParsePerformanceNotes (CString str)
CString | TextToBlockString (CString &str, char *prefix)
CString | CreateTextBlockTest ()
void | SendDppInfoTextBlock (CString strLowerTextBlock, CString strInfoTextBlock)
void | WriteTextBlock ()
void | ParseTextBlockNotes (CString strTextBlock)
BOOL | ExtractNote (CString &rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep)
void | CopyTextToClip (CString strTextIn)
void | OnBnClickedButtonWriteTextBlock ()
bool | SendManufacturingTextBlock (CString generalNotes)

Public Attributes

UINT_PTR | m_nTmrRS232Id
UINT_PTR | m_nTmrRS232EventId
UINT | m_nTmrRS232Elapse
UINT_PTR | m_nTmrSpectrumId
UINT_PTR | m_nTmrSpectrumEventId
UINT | m_nTmrSpectrumElapse
UINT_PTR | m_nTmrTimeoutId
UINT_PTR | m_nTmrTimeoutEventId
UINT | m_nTmrTimeoutElapse
BOOL | TimeoutFlag
CPlotCanvas m_PicturePlot
long | PlotBuffer [8192]
char | szSettings [3000]
long | XPlotMAX
long | YPlotMAX
BOOL | HavePlot
CStatic | m_PictureScope
unsigned char | ScopeBuffer [2048]
BOOL | HaveTrace
CLabel lblSelectCommunications
CLabel lblStatus
CLabel lblMiscStatus
vector< string > | Dp5CmdList
CPoint | CursorPosition
int | CurrentChannel
CString | strLowerMiscData
CString | strUpperMiscData

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | OnInitDialog ()
afx_msg void | OnSysCommand (UINT nID, LPARAM lParam)
afx_msg void | OnPaint ()
afx_msg HCURSOR | OnQueryDragIcon ()

Protected Attributes

HICON | m_hIcon

Detailed Description

Definition at line 30 of file vcDP5Dlg.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 38 of file vcDP5Dlg.h.

Constructor & Destructor Documentation

CvcDP5Dlg::CvcDP5Dlg ( CWnd * pParent = NULL )

Definition at line 55 of file vcDP5Dlg.cpp.

CvcDP5Dlg::~CvcDP5Dlg ( )

Definition at line 95 of file vcDP5Dlg.cpp.

Member Function Documentation

string CvcDP5Dlg::AppendCmdDesc | ( | string | strCmd,
 |  | string | strCfgData
 | ) |  |

Definition at line 1552 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CvcDP5Dlg::BOOL_TO_bool ( BOOL bValue )

Definition at line 229 of file vcDP5Dlg.cpp.

LRESULT CvcDP5Dlg::CallReadDppConfig | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 1273 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

LRESULT CvcDP5Dlg::CallReadDppConfigEx | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 1282 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

LRESULT CvcDP5Dlg::CallReadScaConfig | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 1291 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::ConvertStatusDP5ToDP4 ( DP4_FORMAT_STATUS m_DP5_Status )

Definition at line 487 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::CopyDp5CfgToClip | ( | CString | strCfg,
 |  | CString | strDesc
 | ) |  |

Definition at line 1913 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::CopyTextToClip ( CString strTextIn )

Definition at line 2549 of file vcDP5Dlg.cpp.

string CvcDP5Dlg::CreateDTS ( string strFormat )

Definition at line 2382 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

string CvcDP5Dlg::CreateMCAData | ( | long | m_larDataBuffer[],
 |  | SpectrumFileType | sfInfo,
 |  | DP4_FORMAT_STATUS | cfgStatusLst
 | ) |  |

Definition at line 2034 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CvcDP5Dlg::CreateSpectrumConfig ( string strRawCfgIn )

Definition at line 732 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CvcDP5Dlg::CreateTextBlockTest ( )

Definition at line 2566 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

unsigned long CvcDP5Dlg::DataTest ( )

Definition at line 353 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::DisplayError | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 457 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 100 of file vcDP5Dlg.cpp.

LRESULT CvcDP5Dlg::DppSendConfigToHw | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 1251 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::EnableDPPFunctions ( BOOL isEnabled )

Definition at line 925 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

BOOL CvcDP5Dlg::ExtractNote | ( | CString & | rString,
 |  | LPCTSTR | lpszFullString,
 |  | int | iSubString,
 |  | TCHAR | chSep
 | ) |  |

Definition at line 2521 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

string CvcDP5Dlg::GetCmdData | ( | string | strCmd,
 |  | string | strCfgData
 | ) |  |

Definition at line 1486 of file vcDP5Dlg.cpp.

CString CvcDP5Dlg::GetCmdDataMS | ( | CString | strCmd,
 |  | CString | strCfgData
 | ) |  |

Definition at line 1466 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

string CvcDP5Dlg::GetCmdDesc ( string strCmd )

Definition at line 1776 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

CString CvcDP5Dlg::GetCmdDescMS ( CString strCmd )

Definition at line 1639 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

CString CvcDP5Dlg::GetDeviceNameFromVal ( int DeviceTypeVal )

Definition at line 1027 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

double CvcDP5Dlg::GetPixPerChannel ( )

Definition at line 2196 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

BOOL CvcDP5Dlg::isConnectedTest ( )

Definition at line 1058 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

vector< string > CvcDP5Dlg::MakeDp5CmdList ( )

Definition at line 1574 of file vcDP5Dlg.cpp.

afx_msg void CvcDP5Dlg::OnBnClickedBtnSaveFile ( )
void CvcDP5Dlg::OnBnClickedButtonArmTrigger ( )

Definition at line 813 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonAutotune ( )

Definition at line 2372 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonClearDataAndGraph ( )

Definition at line 818 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::OnBnClickedButtonClearMiscData ( )

Definition at line 837 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedButtonClearRoi ( )

Definition at line 2217 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedButtonDiag ( )

Definition at line 954 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonEditConfig ( )

Definition at line 1234 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonFindDevice ( )

Definition at line 384 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

afx_msg void CvcDP5Dlg::OnBnClickedButtonGetSpectrum ( )
void CvcDP5Dlg::OnBnClickedButtonReadMiscData ( )

Definition at line 842 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonRoiEnd ( )

Definition at line 2222 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedButtonRoiStart ( )

Definition at line 2232 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedButtonSaveFile ( )

Definition at line 1980 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonSelectComm ( )

Definition at line 959 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonShowConfig ( )

Definition at line 1927 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonSingleUpdate ( )

Definition at line 824 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonStartAcquisition ( )

Definition at line 1223 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonStopAcquisition ( )

Definition at line 1229 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonWriteMiscData ( )

Definition at line 847 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnBnClickedButtonWriteTextBlock ( )
void CvcDP5Dlg::OnBnClickedCancel ( )

Definition at line 2212 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedOk ( )

Definition at line 2207 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotScaleLinear ( )

Definition at line 1939 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotScaleLog ( )

Definition at line 1950 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotTypeLine ( )

Definition at line 1972 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnBnClickedRadioPlotTypeSolid ( )

Definition at line 1961 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnComm ( )

Definition at line 1110 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

LONG CvcDP5Dlg::OnCommunication | ( | UINT | ,
 |  | LONG |
 | ) |  |

Definition at line 1089 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnDestroy ( )

Definition at line 339 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

BOOL CvcDP5Dlg::OnDeviceChange | ( | UINT | nEventType,
 |  | DWORD_PTR | dwData
 | ) |  |

Definition at line 288 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

BOOL CvcDP5Dlg::OnInitDialog ( ) [protected, virtual]

Definition at line 157 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint | point
 | ) |  |

Definition at line 2118 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnPaint ( ) [protected]

Definition at line 255 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

HCURSOR CvcDP5Dlg::OnQueryDragIcon ( ) [protected]

Definition at line 283 of file vcDP5Dlg.cpp.

LONG CvcDP5Dlg::OnReceive | ( | UINT | ,
 |  | LONG |
 | ) |  |

Definition at line 1141 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnResetCommunications ( )

Definition at line 324 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::OnStnClickedPlotpicturecontrol ( )

Definition at line 2105 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::OnSysCommand | ( | UINT | nID,
 |  | LPARAM | lParam
 | ) |  | [protected]

Definition at line 238 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::OnTimer ( UINT nIDEvent )

Definition at line 794 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

BOOL CvcDP5Dlg::OnToolTipNotify | ( | UINT | id,
 |  | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  |

Definition at line 2240 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::ParsePacketEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 404 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

CString CvcDP5Dlg::ParsePerformanceNotes ( CString str )

Definition at line 2402 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::ParseTextBlockNotes ( CString strTextBlock )

Definition at line 2470 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::PlotData | ( | long | DataBuffer[8192],
 |  | int | NumChan
 | ) |  |
BOOL CvcDP5Dlg::PreTranslateMessage ( MSG * pMsg ) [virtual]

Definition at line 2135 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

void CvcDP5Dlg::ProcessAck ( unsigned char PID2 )

Definition at line 468 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessCfgReadEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 1300 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessDiagDataEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 542 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessScopeDataEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 587 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessSpectrumEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 550 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessStatusEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 473 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::ProcessTextDataEx | ( | Packet_In | PIN,
 |  | DppStateType | DppState
 | ) |  |

Definition at line 595 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::RemCallParsePacket ( unsigned char PacketIn[] )

Definition at line 398 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

string CvcDP5Dlg::ReplaceCmdDesc | ( | string | strCmd,
 |  | string | strCfgData
 | ) |  |

Definition at line 1529 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

CString CvcDP5Dlg::ReplaceCmdDescMS | ( | CString | strCmd,
 |  | CString | strCfgData
 | ) |  |

Definition at line 1505 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::RequestScopeData ( BOOL ScopeDataReady )

Definition at line 609 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SaveMCAFile | ( | string | strFilename,
 |  | string | strMCA
 | ) |  |

Definition at line 2027 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::ScopeDisplay ( unsigned char ScopeData[2048] )

Definition at line 915 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendCommand ( TRANSMIT_PACKET_TYPE XmtCmd )

Definition at line 616 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendCommandConfig ( TRANSMIT_PACKET_TYPE XmtCmd )

Definition at line 673 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendCommandData | ( | TRANSMIT_PACKET_TYPE | XmtCmd,
 |  | unsigned char | DataOut[]
 | ) |  |

Definition at line 749 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SendDppInfoTextBlock | ( | CString | strLowerTextBlock,
 |  | CString | strInfoTextBlock
 | ) |  |

Definition at line 2582 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

bool CvcDP5Dlg::SendManufacturingTextBlock ( CString generalNotes )

Definition at line 2663 of file vcDP5Dlg.cpp.

void CvcDP5Dlg::SetPlotChannel ( )

Definition at line 2168 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::SetStartTime ( )
void CvcDP5Dlg::ShowStatus ( CString strStatus )

Definition at line 866 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

CString CvcDP5Dlg::TextToBlockString | ( | CString & | str,
 |  | char * | prefix
 | ) |  |

Definition at line 2442 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::TuneFastSlowThresh ( )

Definition at line 2274 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Here is the caller graph for this function:

void CvcDP5Dlg::UpdatePlot ( )
void CvcDP5Dlg::UpdateScope ( )

Definition at line 875 of file vcDP5Dlg.cpp.

Here is the caller graph for this function:

void CvcDP5Dlg::WriteTextBlock ( )

Definition at line 2608 of file vcDP5Dlg.cpp.

Here is the call graph for this function:

Member Data Documentation

int CvcDP5Dlg::CurrentChannel

Definition at line 179 of file vcDP5Dlg.h.

CPoint CvcDP5Dlg::CursorPosition

Definition at line 178 of file vcDP5Dlg.h.

vector<string> CvcDP5Dlg::Dp5CmdList

Definition at line 155 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::HavePlot

Definition at line 114 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::HaveTrace

Definition at line 120 of file vcDP5Dlg.h.

CLabel CvcDP5Dlg::lblMiscStatus

Definition at line 131 of file vcDP5Dlg.h.

CLabel CvcDP5Dlg::lblSelectCommunications

Definition at line 129 of file vcDP5Dlg.h.

CLabel CvcDP5Dlg::lblStatus

Definition at line 130 of file vcDP5Dlg.h.

HICON CvcDP5Dlg::m_hIcon [protected]

Definition at line 46 of file vcDP5Dlg.h.

UINT CvcDP5Dlg::m_nTmrRS232Elapse

Definition at line 91 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrRS232EventId

Definition at line 90 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrRS232Id

Definition at line 89 of file vcDP5Dlg.h.

UINT CvcDP5Dlg::m_nTmrSpectrumElapse

Definition at line 96 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrSpectrumEventId

Definition at line 95 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrSpectrumId

Definition at line 94 of file vcDP5Dlg.h.

UINT CvcDP5Dlg::m_nTmrTimeoutElapse

Definition at line 101 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrTimeoutEventId

Definition at line 100 of file vcDP5Dlg.h.

UINT_PTR CvcDP5Dlg::m_nTmrTimeoutId

Definition at line 99 of file vcDP5Dlg.h.

CPlotCanvas CvcDP5Dlg::m_PicturePlot

Definition at line 105 of file vcDP5Dlg.h.

CStatic CvcDP5Dlg::m_PictureScope

Definition at line 116 of file vcDP5Dlg.h.

long CvcDP5Dlg::PlotBuffer[8192]

Definition at line 109 of file vcDP5Dlg.h.

unsigned char CvcDP5Dlg::ScopeBuffer[2048]

Definition at line 119 of file vcDP5Dlg.h.

CString CvcDP5Dlg::strLowerMiscData

Definition at line 216 of file vcDP5Dlg.h.

CString CvcDP5Dlg::strUpperMiscData

Definition at line 217 of file vcDP5Dlg.h.

char CvcDP5Dlg::szSettings[3000]

Definition at line 110 of file vcDP5Dlg.h.

BOOL CvcDP5Dlg::TimeoutFlag

Definition at line 102 of file vcDP5Dlg.h.

long CvcDP5Dlg::XPlotMAX

Definition at line 111 of file vcDP5Dlg.h.

long CvcDP5Dlg::YPlotMAX

Definition at line 112 of file vcDP5Dlg.h.

The documentation for this class was generated from the following files:
  • vcDP5Dlg.h
  • vcDP5Dlg.cpp
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: cWaitDialog Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
cWaitDialog Class Reference

#include <CmdWaitDlg.h>

Collaboration diagram for cWaitDialog:
[legend]

List of all members.

Public Member Functions

void | Close ()
void | Show ()
virtual | ~cWaitDialog ()

Public Attributes

cWaitDlgThread * m_Thread
bool | m_bShowCancelButton
HANDLE | m_Event
CString | m_Text
CString | m_EventName

Detailed Description

Definition at line 25 of file CmdWaitDlg.h.

Constructor & Destructor Documentation

cWaitDialog::~cWaitDialog ( ) [virtual]

Definition at line 26 of file CmdWaitDlg.cpp.

Member Function Documentation

void cWaitDialog::Close ( )

Definition at line 51 of file CmdWaitDlg.cpp.

Here is the caller graph for this function:

void cWaitDialog::Show ( )

Definition at line 40 of file CmdWaitDlg.cpp.

Here is the caller graph for this function:

Member Data Documentation

bool cWaitDialog::m_bShowCancelButton

Definition at line 34 of file CmdWaitDlg.h.

HANDLE cWaitDialog::m_Event

Definition at line 35 of file CmdWaitDlg.h.

CString cWaitDialog::m_EventName

Definition at line 37 of file CmdWaitDlg.h.

CString cWaitDialog::m_Text

Definition at line 36 of file CmdWaitDlg.h.

cWaitDlgThread* cWaitDialog::m_Thread

Definition at line 33 of file CmdWaitDlg.h.

The documentation for this class was generated from the following files:
  • waitdlg/CmdWaitDlg.h
  • waitdlg/CmdWaitDlg.cpp
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: cWaitDlg Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions
cWaitDlg Class Reference

#include <WaitDlg.h>

Collaboration diagram for cWaitDlg:
[legend]

List of all members.

Public Types

enum | { IDD = IDD_BUSY_DLG }

Public Member Functions

cWaitDlg (CWnd *pParent=NULL)

Public Attributes

cWaitDlgThread * m_Thread
cAnimWnd m_Anim
CString | m_Text
bool | m_bShowCancelButton

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual void | OnCancel ()
virtual void | OnOK ()
virtual BOOL | OnInitDialog ()
afx_msg void | OnTimer (UINT nIDEvent)

Detailed Description

Definition at line 18 of file WaitDlg.h.

Member Enumeration Documentation

anonymous enum
Enumerator:
IDD

Definition at line 26 of file WaitDlg.h.

Constructor & Destructor Documentation

cWaitDlg::cWaitDlg ( CWnd * pParent = NULL )

Definition at line 19 of file WaitDlg.cpp.

Member Function Documentation

void cWaitDlg::DoDataExchange ( CDataExchange * pDX ) [protected, virtual]

Definition at line 30 of file WaitDlg.cpp.

void cWaitDlg::OnCancel ( ) [protected, virtual]

Definition at line 47 of file WaitDlg.cpp.

BOOL cWaitDlg::OnInitDialog ( ) [protected, virtual]

Definition at line 63 of file WaitDlg.cpp.

Here is the call graph for this function:

void cWaitDlg::OnOK ( ) [protected, virtual]

Definition at line 53 of file WaitDlg.cpp.

Here is the caller graph for this function:

void cWaitDlg::OnTimer ( UINT nIDEvent ) [protected]

Definition at line 86 of file WaitDlg.cpp.

Here is the call graph for this function:

Member Data Documentation

cAnimWnd cWaitDlg::m_Anim

Definition at line 30 of file WaitDlg.h.

bool cWaitDlg::m_bShowCancelButton

Definition at line 32 of file WaitDlg.h.

CString cWaitDlg::m_Text

Definition at line 31 of file WaitDlg.h.

cWaitDlgThread* cWaitDlg::m_Thread

Definition at line 29 of file WaitDlg.h.

The documentation for this class was generated from the following files:
  • waitdlg/WaitDlg.h
  • waitdlg/WaitDlg.cpp
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: cWaitDlgThread Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
cWaitDlgThread Class Reference

#include <WaitDlgThread.h>

List of all members.

Public Member Functions

cWaitDlgThread ()
virtual BOOL | InitInstance ()
virtual int | ExitInstance ()
virtual | ~cWaitDlgThread ()

Public Attributes

CString | m_Eventname
CEvent * | m_Event
bool | m_bShowCancelButton
CString | m_Text

Detailed Description

Definition at line 25 of file WaitDlgThread.h.

Constructor & Destructor Documentation

cWaitDlgThread::cWaitDlgThread ( )

Definition at line 21 of file WaitDlgThread.cpp.

cWaitDlgThread::~cWaitDlgThread ( ) [virtual]

Definition at line 27 of file WaitDlgThread.cpp.

Member Function Documentation

int cWaitDlgThread::ExitInstance ( ) [virtual]

Definition at line 47 of file WaitDlgThread.cpp.

BOOL cWaitDlgThread::InitInstance ( ) [virtual]

Definition at line 31 of file WaitDlgThread.cpp.

Member Data Documentation

bool cWaitDlgThread::m_bShowCancelButton

Definition at line 38 of file WaitDlgThread.h.

CEvent* cWaitDlgThread::m_Event

Definition at line 37 of file WaitDlgThread.h.

CString cWaitDlgThread::m_Eventname

Definition at line 36 of file WaitDlgThread.h.

CString cWaitDlgThread::m_Text

Definition at line 39 of file WaitDlgThread.h.

The documentation for this class was generated from the following files:
  • waitdlg/WaitDlgThread.h
  • waitdlg/WaitDlgThread.cpp
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CWinusbNotify Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes
CWinusbNotify Class Reference

#include <WinusbNotify.h>

List of all members.

Public Member Functions

CWinusbNotify (void)
~CWinusbNotify (void)
void | InitDeviceInfo ()
void | SetNotificationWindow (HWND m_hWnd)
void | RegDeviceNotification ()
BOOL | GetDevNotifyInfo (DWORD_PTR dwData, char devicePath[])
void | RemoveDeviceNotification ()
BOOL | UnregDeviceNotification (HDEVNOTIFY Handle)

Public Attributes

HDEVNOTIFY | DeviceNotificationHandle
HWND | m_hWndOwner

Detailed Description

CWinusbNotify CWinusbNotify

Definition at line 5 of file WinusbNotify.h.

Constructor & Destructor Documentation

CWinusbNotify::CWinusbNotify ( void )

Definition at line 4 of file WinusbNotify.cpp.

CWinusbNotify::~CWinusbNotify ( void )

Definition at line 10 of file WinusbNotify.cpp.

Member Function Documentation

BOOL CWinusbNotify::GetDevNotifyInfo | ( | DWORD_PTR | dwData,
 |  | char | devicePath[]
 | ) |  |

Definition at line 35 of file WinusbNotify.cpp.

Here is the caller graph for this function:

void CWinusbNotify::InitDeviceInfo ( )

Definition at line 19 of file WinusbNotify.cpp.

void CWinusbNotify::RegDeviceNotification ( )

Definition at line 24 of file WinusbNotify.cpp.

void CWinusbNotify::RemoveDeviceNotification ( )

Definition at line 56 of file WinusbNotify.cpp.

Here is the caller graph for this function:

void CWinusbNotify::SetNotificationWindow ( HWND m_hWnd )

Definition at line 14 of file WinusbNotify.cpp.

Here is the caller graph for this function:

BOOL CWinusbNotify::UnregDeviceNotification ( HDEVNOTIFY Handle )

Definition at line 63 of file WinusbNotify.cpp.

Member Data Documentation

HDEVNOTIFY CWinusbNotify::DeviceNotificationHandle

Definition at line 10 of file WinusbNotify.h.

HWND CWinusbNotify::m_hWndOwner

Definition at line 12 of file WinusbNotify.h.

The documentation for this class was generated from the following files:
  • DeviceIO/WinusbNotify.h
  • DeviceIO/WinusbNotify.cpp
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5_DP4_FORMAT_STATUS Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
DP5_DP4_FORMAT_STATUS Struct Reference

#include <DP5Status.h>

List of all members.

Public Attributes

unsigned char | RAW [64]
unsigned long | SerialNumber
double | FastCount
double | SlowCount
unsigned char | FPGA
unsigned char | Firmware
unsigned char | Build
double | AccumulationTime
double | RealTime
double | LiveTime
double | HV
double | DET_TEMP
double | DP5_TEMP
bool | PX4
bool | AFAST_LOCKED
bool | MCA_EN
bool | PRECNT_REACHED
bool | PresetRtDone
bool | PresetLtDone
bool | SUPPLIES_ON
bool | SCOPE_DR
bool | DP5_CONFIGURED
double | GP_COUNTER
bool | AOFFSET_LOCKED
bool | MCS_DONE
bool | RAM_TEST_RUN
bool | RAM_TEST_ERROR
double | DCAL
unsigned char | PZCORR
unsigned char | UC_TEMP_OFFSET
double | AN_IN
double | VREF_IN
unsigned long | PC5_SN
bool | PC5_PRESENT
bool | PC5_HV_POL
bool | PC5_8_5V
double | ADC_GAIN_CAL
unsigned char | ADC_OFFSET_CAL
long | SPECTRUM_OFFSET
bool | b80MHzMode
bool | bFPGAAutoClock
unsigned char | DEVICE_ID
bool | ReBootFlag
unsigned char | DPP_options
bool | HPGe_HV_INH
bool | HPGe_HV_INH_POL
double | TEC_Voltage
unsigned char | DPP_ECO
bool | AU34_2
bool | isAscInstalled
bool | isAscEnabled
bool | bScintHas80MHzOption
bool | isDP5_RevDxGains

Detailed Description

Definition at line 23 of file DP5Status.h.

Member Data Documentation

double DP5_DP4_FORMAT_STATUS::AccumulationTime

Definition at line 32 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::ADC_GAIN_CAL

Definition at line 61 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::ADC_OFFSET_CAL

Definition at line 62 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::AFAST_LOCKED

Definition at line 39 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::AN_IN

Definition at line 55 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::AOFFSET_LOCKED

Definition at line 48 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::AU34_2

Definition at line 73 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::b80MHzMode

Definition at line 64 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::bFPGAAutoClock

Definition at line 65 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::bScintHas80MHzOption

Definition at line 76 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::Build

Definition at line 31 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::DCAL

Definition at line 52 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::DET_TEMP

Definition at line 36 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::DEVICE_ID

Definition at line 66 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::DP5_CONFIGURED

Definition at line 46 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::DP5_TEMP

Definition at line 37 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::DPP_ECO

Definition at line 72 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::DPP_options

Definition at line 68 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::FastCount

Definition at line 27 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::Firmware

Definition at line 30 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::FPGA

Definition at line 29 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::GP_COUNTER

Definition at line 47 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::HPGe_HV_INH

Definition at line 69 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::HPGe_HV_INH_POL

Definition at line 70 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::HV

Definition at line 35 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::isAscEnabled

Definition at line 75 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::isAscInstalled

Definition at line 74 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::isDP5_RevDxGains

Definition at line 77 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::LiveTime

Definition at line 34 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::MCA_EN

Definition at line 40 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::MCS_DONE

Definition at line 49 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PC5_8_5V

Definition at line 60 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PC5_HV_POL

Definition at line 59 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PC5_PRESENT

Definition at line 58 of file DP5Status.h.

unsigned long DP5_DP4_FORMAT_STATUS::PC5_SN

Definition at line 57 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PRECNT_REACHED

Definition at line 41 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PresetLtDone

Definition at line 43 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PresetRtDone

Definition at line 42 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::PX4

Definition at line 38 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::PZCORR

Definition at line 53 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::RAM_TEST_ERROR

Definition at line 51 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::RAM_TEST_RUN

Definition at line 50 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::RAW[64]

Definition at line 25 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::RealTime

Definition at line 33 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::ReBootFlag

Definition at line 67 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::SCOPE_DR

Definition at line 45 of file DP5Status.h.

unsigned long DP5_DP4_FORMAT_STATUS::SerialNumber

Definition at line 26 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::SlowCount

Definition at line 28 of file DP5Status.h.

long DP5_DP4_FORMAT_STATUS::SPECTRUM_OFFSET

Definition at line 63 of file DP5Status.h.

bool DP5_DP4_FORMAT_STATUS::SUPPLIES_ON

Definition at line 44 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::TEC_Voltage

Definition at line 71 of file DP5Status.h.

unsigned char DP5_DP4_FORMAT_STATUS::UC_TEMP_OFFSET

Definition at line 54 of file DP5Status.h.

double DP5_DP4_FORMAT_STATUS::VREF_IN

Definition at line 56 of file DP5Status.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Status.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: NETDISPLAY_ENTRY Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
NETDISPLAY_ENTRY Struct Reference

#include <NetFinder.h>

List of all members.

Public Attributes

unsigned char | alert_level
UINT | event1_days
unsigned char | event1_hours
unsigned char | event1_minutes
UINT | event2_days
unsigned char | event2_hours
unsigned char | event2_minutes
unsigned char | event1_seconds
unsigned char | event2_seconds
unsigned char | mac [6]
unsigned char | ip [4]
USHORT | port
unsigned char | subnet [4]
unsigned char | gateway [4]
CString | str_type
CString | str_description
CString | str_ev1
CString | str_ev2
CString | str_display
COLORREF | ccConnectRGB
BOOL | HasData
unsigned long | SockAddr

Detailed Description

Definition at line 8 of file NetFinder.h.

Member Data Documentation

unsigned char NETDISPLAY_ENTRY::alert_level

Definition at line 9 of file NetFinder.h.

COLORREF NETDISPLAY_ENTRY::ccConnectRGB

Definition at line 34 of file NetFinder.h.

UINT NETDISPLAY_ENTRY::event1_days

Definition at line 11 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event1_hours

Definition at line 12 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event1_minutes

Definition at line 13 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event1_seconds

Definition at line 19 of file NetFinder.h.

UINT NETDISPLAY_ENTRY::event2_days

Definition at line 15 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event2_hours

Definition at line 16 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event2_minutes

Definition at line 17 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::event2_seconds

Definition at line 20 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::gateway[4]

Definition at line 26 of file NetFinder.h.

BOOL NETDISPLAY_ENTRY::HasData

Definition at line 36 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::ip[4]

Definition at line 23 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::mac[6]

Definition at line 22 of file NetFinder.h.

USHORT NETDISPLAY_ENTRY::port

Definition at line 24 of file NetFinder.h.

unsigned long NETDISPLAY_ENTRY::SockAddr

Definition at line 38 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_description

Definition at line 29 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_display

Definition at line 33 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_ev1

Definition at line 30 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_ev2

Definition at line 31 of file NetFinder.h.

CString NETDISPLAY_ENTRY::str_type

Definition at line 28 of file NetFinder.h.

unsigned char NETDISPLAY_ENTRY::subnet[4]

Definition at line 25 of file NetFinder.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/NetFinder.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Packet_Out Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
Packet_Out Struct Reference

#include <DP5Protocol.h>

List of all members.

Public Attributes

unsigned char | PID1
unsigned char | PID2
unsigned short | LEN
unsigned char | EXPECTEDRESPONSE
unsigned char | DATA [514]

Detailed Description

Definition at line 285 of file DP5Protocol.h.

Member Data Documentation

unsigned char Packet_Out::DATA[514]

Definition at line 290 of file DP5Protocol.h.

unsigned char Packet_Out::EXPECTEDRESPONSE

Definition at line 289 of file DP5Protocol.h.

unsigned short Packet_Out::LEN

Definition at line 288 of file DP5Protocol.h.

unsigned char Packet_Out::PID1

Definition at line 286 of file DP5Protocol.h.

unsigned char Packet_Out::PID2

Definition at line 287 of file DP5Protocol.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Spec Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
Spec Struct Reference

#include <DP5Protocol.h>

List of all members.

Public Attributes

long | DATA [MAX_BUFFER_DATA]
short | CHANNELS

Detailed Description

Definition at line 297 of file DP5Protocol.h.

Member Data Documentation

short Spec::CHANNELS

Definition at line 299 of file DP5Protocol.h.

long Spec::DATA[MAX_BUFFER_DATA]

Definition at line 298 of file DP5Protocol.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringex Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions
stringex Class Reference

#include <stringex.h>

List of all members.

Public Member Functions

stringex (void)
~stringex (void)
std::string | Format (const char *fmt,...)
std::string | MakeUpper (string StdString)
std::string | MakeLower (string StdString)

Detailed Description

Definition at line 16 of file stringex.h.

Constructor & Destructor Documentation

stringex::stringex ( void )

Definition at line 8 of file stringex.cpp.

stringex::~stringex ( void )

Definition at line 12 of file stringex.cpp.

Member Function Documentation

std::string stringex::Format | ( | const char * | fmt,
 |  |  | ...
 | ) |  |

Definition at line 33 of file stringex.cpp.

Here is the caller graph for this function:

std::string stringex::MakeLower ( string StdString )

Definition at line 52 of file stringex.cpp.

std::string stringex::MakeUpper ( string StdString )

Definition at line 42 of file stringex.cpp.

The documentation for this class was generated from the following files:
  • stringex.h
  • stringex.cpp
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: WINUSB_DEVICE_INFO Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes
WINUSB_DEVICE_INFO Struct Reference

Holds WinUSB device information. More...

#include <DppWinUSB.h>

List of all members.

Public Attributes

HANDLE | deviceHandle
System device handle opened with CreateFile using a device path.
WINUSB_INTERFACE_HANDLE winUSBHandle
WinUSB device interface handle opened with WinUsb_Initialize using a CreateFile device handle.
unsigned char | deviceSpeed
USB device speed indicator.
unsigned char | bulkInPipe
Bulk in pipe identifier.
unsigned char | bulkOutPipe
Bulk out pipe identifier.
unsigned char | interruptPipe
Interrupt pipe identifier.
char | devicePath [MAX_DEVPATH_LENGTH]
Device path identifier string used in opening a connection to a USB device.
BOOL | deviceConnected
True if a USB deevice is connected.

Detailed Description

Holds WinUSB device information.

Definition at line 46 of file DppWinUSB.h.

Member Data Documentation

unsigned char WINUSB_DEVICE_INFO::bulkInPipe

Bulk in pipe identifier.

Definition at line 55 of file DppWinUSB.h.

unsigned char WINUSB_DEVICE_INFO::bulkOutPipe

Bulk out pipe identifier.

Definition at line 57 of file DppWinUSB.h.

BOOL WINUSB_DEVICE_INFO::deviceConnected

True if a USB deevice is connected.

Definition at line 63 of file DppWinUSB.h.

HANDLE WINUSB_DEVICE_INFO::deviceHandle

System device handle opened with CreateFile using a device path.

Definition at line 49 of file DppWinUSB.h.

char WINUSB_DEVICE_INFO::devicePath[MAX_DEVPATH_LENGTH]

Device path identifier string used in opening a connection to a USB device.

Definition at line 61 of file DppWinUSB.h.

unsigned char WINUSB_DEVICE_INFO::deviceSpeed

USB device speed indicator.

Definition at line 53 of file DppWinUSB.h.

unsigned char WINUSB_DEVICE_INFO::interruptPipe

Interrupt pipe identifier.

Definition at line 59 of file DppWinUSB.h.

WINUSB_INTERFACE_HANDLE WINUSB_DEVICE_INFO::winUSBHandle

WinUSB device interface handle opened with WinUsb_Initialize using a CreateFile device handle.

Definition at line 51 of file DppWinUSB.h.

The documentation for this struct was generated from the following file:
  • DeviceIO/DppWinUSB.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • AccumulationTime : CDppConfig , DP5_DP4_FORMAT_STATUS
  • ACK_Received : CDP5Protocol
  • AcqMode : CDppConfig
  • ActivePage : CCfgPropSheet
  • ADC_GAIN_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_OFFSET_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_V : _DiagDataType
  • AddEntry() : CNetFinder
  • AddPage() : CCfgPropSheet
  • AddPages() : CDP5CfgWnd
  • AddRoi() : CRoi
  • AFAST_LOCKED : DP5_DP4_FORMAT_STATUS
  • alert_level : NETDISPLAY_ENTRY
  • AlertByteToCOLORREF() : CNetFinder
  • AlertEntryToCOLORREF() : CNetFinder
  • AllFileFilter : CFileBrowse
  • AN_IN : DP5_DP4_FORMAT_STATUS
  • AOFFSET_LOCKED : DP5_DP4_FORMAT_STATUS
  • AppendCmdDesc() : CvcDP5Dlg
  • AppendUnitsToSettingString() : CDP5ControlUtil
  • AppendUnitsToString() : CDP5ControlUtil
  • AsciiCmdUtil : CSendCommand
  • AtChannel() : CRoi
  • AU34_2 : DP5_DP4_FORMAT_STATUS
  • AuxOut : CDppConfig
  • Avg : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • b80MHzMode : CDppConfig , CDppShaping , DP5_DP4_FORMAT_STATUS
  • b80MHzModeCfg : CDppConfig
  • b80MHzModeCfg_old : CShapingPage
  • bAnalogPolarity : CDppConfig
  • bAppendUnits : _DP5_CONFIGURATION
  • BaselineOn : CDppConfig
  • baud_rate : CSProfile , CSCommon
  • bb_BootFlags : CDppConfig
  • bb_DeadTimeCounter : CDppConfig
  • bb_DiodeCalDACSet : CDppConfig
  • bb_HVDACSet : CDppConfig
  • bb_InputOffsetTuning : CDppConfig
  • bb_SpectrumOffset : CDppConfig
  • bb_TECCurrentLimit : CDppConfig
  • bb_TECDACSet : CDppConfig
  • bb_uCTempCal : CDppConfig
  • bBootHVPolarity : CDppConfig
  • bConfigHVPolarity : CDppConfig
  • bDeviceConnected : CDppLibUsb
  • bDeviceReady : CDppLibUsb
  • bEnableNewRESL : CGainPzPage
  • bFPGAAutoClock : CDppConfig , DP5_DP4_FORMAT_STATUS
  • bGammaRadHVMode : CDppConfig
  • bLibusbReady : CDppLibUsb
  • BLR : CDppConfig
  • BLRQuickSet() : CShapingPage
  • BmpFileFilter : CFileBrowse
  • BoardTemp : CDppConfig
  • BoardTempCStr : CDppConfig
  • BOOL_TO_bool() : CvcDP5Dlg
  • BootStatus : CDppConfig
  • bPC5Detected : CDppConfig
  • bScintHas80MHzOption : DP5_DP4_FORMAT_STATUS
  • bTypeInIPAddress : CSelectDP5
  • BufferOUT : CDP5Protocol
  • BufferSelect : CDppConfig
  • Build : DP5_DP4_FORMAT_STATUS , CDppConfig
  • BuildToolTips() : CMiscPage , CGainPzPage , CMcaPage , CPowerPage , CShapingPage
  • bulkInPipe : WINUSB_DEVICE_INFO
  • bulkOutPipe : WINUSB_DEVICE_INFO
  • BYTEVersionToDouble() : CDppUtilities
  • BYTEVersionToString() : CDppUtilities
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • CAboutDlg() : CAboutDlg
  • CalculateRoiInfo() : CRoi
  • CallReadDppConfig() : CvcDP5Dlg
  • CallReadDppConfigEx() : CvcDP5Dlg
  • CallReadScaConfig() : CvcDP5Dlg
  • cAnimWnd() : cAnimWnd
  • CAsciiCmdUtilities() : CAsciiCmdUtilities
  • cboComPort : CSelectDP5
  • CBootOptPage() : CBootOptPage
  • CboTextVis() : CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage
  • CboUpdate() : CFilePage , CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage , CBootOptPage
  • CboUpdateDMCA() : CMcaPage
  • ccConnectRGB : NETDISPLAY_ENTRY
  • CCfgPropPage : CCfgPropSheet , CCfgPropPage
  • CCfgPropSheet() : CCfgPropSheet
  • CDlgStatusBar() : CDlgStatusBar
  • CDlgToolBar() : CDlgToolBar
  • CDP5CfgWnd() : CDP5CfgWnd
  • CDP5ControlUtil() : CDP5ControlUtil
  • CDP5Protocol() : CDP5Protocol
  • CDP5Status() : CDP5Status
  • CDppComm() : CDppComm
  • CDppConfig() : CDppConfig
  • CDppGain() : CDppGain
  • CDppLibUsb() : CDppLibUsb
  • CDppShaping() : CDppShaping
  • CDppSlowThreshold() : CDppSlowThreshold
  • CDppSocket() : CDppSocket
  • CDppUtilities() : CDppUtilities
  • CDppWinUSB() : CDppWinUSB
  • CFG_SECTION : CScaFn
  • CfgFileFilter : CFileBrowse
  • CfgModCount : CDppConfig
  • CfgReadBack : CDppConfig
  • CFileBrowse() : CFileBrowse
  • CFilePage() : CFilePage
  • CGainPzPage() : CGainPzPage
  • CHANNELS : Spec
  • CheckMCA8000D_FineGain() : CGainPzPage
  • CheckSum : _Packet_In
  • CINI() : CINI
  • CIniEx() : CIniEx
  • CIniUtil() : CIniUtil
  • CLabel() : CLabel
  • Clear() : CRoi
  • ClearNetFinderStatus() : CSelectDP5
  • ClearNetFinderStatusAll() : CSelectDP5
  • ClearTrace() : CPlotCanvas
  • Close() : cWaitDialog
  • CloseDeviceHandle() : CDppWinUSB
  • ClosePort() : CDppComm
  • CloseSocket() : CDppSocket
  • CloseUSBDevice() : CDppLibUsb
  • CloseWinUsbDevice() : CDppWinUSB
  • CMcaPage() : CMcaPage
  • cMemDC() : cMemDC
  • CMiscPage() : CMiscPage
  • CMSecTimer() : CMSecTimer
  • CMsgBox() : CMsgBox
  • CNetFinder() : CNetFinder
  • ComboIndex : _DP5_CONFIGURATION
  • ComboValue : _DP5_CONFIGURATION
  • Command : _DP5_CONFIGURATION
  • Comments : _DP5_CONFIGURATION
  • CommError : CDP5Protocol
  • ComPort : CSProfile , CSCommon
  • ComPortEnum() : CSelectDP5
  • contourColor : CSpectrumAttr
  • contourWidth : CSpectrumAttr
  • ConvertCmdListToCString() : CIniUtil
  • ConvertStatusDP5ToDP4() : CvcDP5Dlg
  • CopyAsciiData() : CAsciiCmdUtilities
  • CopyDp5CfgToClip() : CvcDP5Dlg
  • CopyRoi() : CRoi
  • CopyTextToClip() : CSelectDP5 , CvcDP5Dlg
  • CountDP5LibusbDevices() : CDppLibUsb
  • CountDP5WinusbDevices() : CDppWinUSB
  • CParsePacket() : CParsePacket
  • CPlot() : CPlot
  • CPlotCanvas() : CPlotCanvas
  • CPowerPage() : CPowerPage
  • Create() : cAnimWnd
  • CreateDP5Cfg() : CSCommon
  • CreateDTS() : CvcDP5Dlg
  • CreateFullReadBackCmd() : CAsciiCmdUtilities
  • CreateFullReadBackCmdMCA8000D() : CAsciiCmdUtilities
  • CreateMCAData() : CvcDP5Dlg
  • CreateResTestReadBackCmd() : CAsciiCmdUtilities
  • CreateSocket() : CDppSocket
  • CreateSpectrumConfig() : CvcDP5Dlg
  • CreateTextBlockTest() : CvcDP5Dlg
  • CRoi() : CRoi
  • CRoiEntry() : CRoiEntry
  • CSca() : CSca
  • CScaFn() : CScaFn
  • CSCommon() : CSCommon
  • CSelectDP5() : CSelectDP5
  • CSendCommand() : CSendCommand
  • CShapingPage() : CShapingPage
  • CSpectraList() : CSpectraList
  • CSpectrum() : CSpectrum
  • CSpectrumAttr() : CSpectrumAttr
  • CSProfile() : CSProfile
  • CtlColor() : CLabel
  • CTrapKeyComboBox() : CTrapKeyComboBox
  • CTrapKeyEdit() : CTrapKeyEdit
  • CtrlGroup : _DP5_CONFIGURATION
  • CtrlType : _DP5_CONFIGURATION
  • CtrlUtil : CSCommon
  • CTuneSlowThreshold() : CTuneSlowThreshold
  • CurIndex : CSca
  • CurrentChannel : CvcDP5Dlg
  • CurrentDevice : CDppLibUsb , CDppWinUSB
  • CurrentInterface : CSProfile , CSCommon
  • CursorPosition : CPlotCanvas , CvcDP5Dlg
  • CvcDP5App() : CvcDP5App
  • CvcDP5Dlg() : CvcDP5Dlg
  • cWaitDlg() : cWaitDlg
  • cWaitDlgThread() : cWaitDlgThread
  • CWinusbNotify() : CWinusbNotify
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • DAC : CDppConfig
  • DAC_Enable : CDppConfig
  • DATA : Packet_Out , Spec , _Packet_In
  • data_in : CDppLibUsb
  • data_out : CDppLibUsb
  • data_refresh : CSProfile
  • DataAcq() : CPlotCanvas
  • DataIn : CSelectDP5
  • DataTest() : CvcDP5Dlg
  • dbl_to_uS() : CDppShaping
  • dblConfigHV : CDppConfig
  • dblGAIF_Max : CGainPzPage
  • dblGAIF_Min : CGainPzPage
  • dblPeakingMult : CDppShaping
  • DCAL : DP5_DP4_FORMAT_STATUS
  • DCal : CDppConfig
  • DeinitializeLibusb() : CDppLibUsb
  • DelayTask() : CTuneSlowThreshold
  • DeleteDP5Key() : CIniUtil
  • DeleteIniSettingEx() : CScaFn
  • DeleteKey() : CINI
  • DeleteSection() : CINI
  • description : CSpectrumAttr
  • Description : _DP5_CONFIGURATION
  • DestroyWindow() : CSelectDP5
  • DET_TEMP : DP5_DP4_FORMAT_STATUS
  • DetReset : CDppConfig
  • DEVICE_ID : DP5_DP4_FORMAT_STATUS
  • device_type : CSProfile
  • deviceConnected : WINUSB_DEVICE_INFO
  • deviceHandle : WINUSB_DEVICE_INFO
  • DeviceNotificationHandle : CWinusbNotify
  • devicePath : WINUSB_DEVICE_INFO
  • deviceSpeed : WINUSB_DEVICE_INFO
  • DeviceType : CDppConfig
  • devInfo : CDppWinUSB
  • DiagData : _DiagDataType , CDP5Status
  • DiagnosticsToString() : CDP5Status
  • DiagStrPX5Option() : CDP5Status
  • DialogType : CFileBrowse
  • Disable_WinUsb() : CDppWinUSB
  • DispatchEventEN_CHANGE() : CTrapKeyEdit
  • DisplayBlrMode() : CShapingPage
  • DisplayBufferArray() : CDP5Status , CDppWinUSB
  • DisplayCfg : CDppConfig
  • DisplayError() : CvcDP5Dlg
  • DisplaySca : CDppConfig
  • DisplaySpecBuf25() : CTuneSlowThreshold
  • DoDataExchange() : CvcDP5Dlg , cWaitDlg , CAboutDlg , CMiscPage , CCfgPropPage , CSelectDP5 , CBootOptPage , CFilePage , CGainPzPage , CMcaPage , CPowerPage , CShapingPage , CMsgBox
  • DoModal() : CCfgPropSheet , CFileBrowse , CDP5CfgWnd
  • DP5_CMD() : CSendCommand
  • DP5_CMD_Config() : CSendCommand
  • DP5_CMD_Data() : CSendCommand
  • DP5_CONFIGURED : DP5_DP4_FORMAT_STATUS
  • DP5_Dx_OptionFlags() : CDP5Status
  • DP5_TEMP : DP5_DP4_FORMAT_STATUS
  • DP5CfgCmd() : CSCommon
  • Dp5CmdList : CSCommon , CvcDP5Dlg
  • DP5Proto : CSCommon
  • DP5Stat : CSCommon
  • DPP_ECO : DP5_DP4_FORMAT_STATUS , _CONFIG_OPTIONS
  • DPP_options : DP5_DP4_FORMAT_STATUS
  • DppAddr : CDppSocket
  • DppCommStatusInd : CSCommon
  • DppCommStatusIndOld : CSCommon
  • DppCommThread() : CDppComm
  • DppConfig : CSCommon
  • DppEntries : CNetFinder
  • DppEntryIdx : CNetFinder
  • DppFound : CNetFinder
  • DppGain : CGainPzPage
  • DppLibusbHandle : CDppLibUsb
  • DppPort : CDppSocket
  • DppSendConfigToHw() : CvcDP5Dlg
  • DppSockAddr : CNetFinder
  • DppState : CParsePacket
  • DPPThreshold() : CDppSlowThreshold
  • DppType : _CONFIG_OPTIONS
  • DppUtil : CDP5Status
  • DppWinUSB : CSCommon
  • DrawCursor() : CPlotCanvas
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • EnableButton() : CDlgToolBar
  • EnableCommFunctions() : CSelectDP5
  • EnableControl() : CMiscPage
  • EnableControls() : CFilePage
  • EnableDeviceSelection() : CFilePage
  • EnableDPPFunctions() : CvcDP5Dlg
  • EnableScaControls() : CMiscPage
  • EntryToStr() : CNetFinder
  • EntryToStrRS232() : CNetFinder
  • EntryToStrUSB() : CNetFinder
  • event1_days : NETDISPLAY_ENTRY
  • event1_hours : NETDISPLAY_ENTRY
  • event1_minutes : NETDISPLAY_ENTRY
  • event1_seconds : NETDISPLAY_ENTRY
  • event2_days : NETDISPLAY_ENTRY
  • event2_hours : NETDISPLAY_ENTRY
  • event2_minutes : NETDISPLAY_ENTRY
  • event2_seconds : NETDISPLAY_ENTRY
  • ExeFileFilter : CFileBrowse
  • ExitInstance() : cWaitDlgThread
  • EXPECTEDRESPONSE : Packet_Out
  • expressionText : CSpectrumAttr
  • ExtractNote() : CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FastChThreshold : CDppConfig
  • FastCount : CDppConfig , DP5_DP4_FORMAT_STATUS
  • file : CSpectrumAttr
  • FindCboIdx() : CDP5ControlUtil
  • FindCboIdxExact() : CDP5ControlUtil
  • FindCommand : CSCommon
  • FindCtrlID : CSCommon
  • FindDpp : CSelectDP5
  • FindDppRS232 : CSelectDP5
  • FindDppUSB : CSelectDP5
  • FindEntry() : CNetFinder
  • FindUnitsInString() : CDP5ControlUtil
  • FindUSBDevice() : CDppLibUsb , CDppWinUSB
  • Firmware : CDppConfig , DP5_DP4_FORMAT_STATUS , _DiagDataType
  • FixTotalGainRange() : CDppGain
  • FixTotalGainRangeDbl() : CDppGain
  • FlashBackground() : CLabel
  • FlashText() : CLabel
  • FlatTop : CDppConfig
  • FlatTopUS : CDppConfig
  • FmtHex() : CDP5Status
  • FmtHvPwr() : CDP5Status
  • FmtLng() : CDP5Status
  • FmtPc5Pwr() : CDP5Status
  • FmtPc5Temp() : CDP5Status
  • Format() : stringex
  • FPGA : _DiagDataType , CDppConfig , DP5_DP4_FORMAT_STATUS
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • Gain : CDppConfig
  • GainDelta : CDppConfig
  • gainIndex : CSpectrumAttr
  • GainTable : CDppGain
  • GainTableCount : CDppGain
  • Gate : CDppConfig
  • gateway : NETDISPLAY_ENTRY
  • generalNotes : CSpectrumAttr
  • Get() : CSCommon
  • GetAmptekDC_NP_Section() : CFilePage
  • GetCheckBOOL() : CMiscPage
  • GetCmdChunk() : CAsciiCmdUtilities
  • GetCmdData() : CvcDP5Dlg
  • GetCmdDataMS() : CvcDP5Dlg
  • GetCmdDesc() : CvcDP5Dlg
  • GetCmdDescMS() : CvcDP5Dlg
  • GetCmdKeyData() : CFilePage
  • GetComboIndex() : CMiscPage
  • GetComboValue() : CMiscPage
  • GetCommErrStr() : CDppComm
  • GetComPortID() : CDppComm , CSelectDP5
  • GetCurrentButtonState() : CCfgPropSheet
  • GetDblValFromComboText() : CDppShaping
  • GetDefaultFlatTopFromRiseIndex() : CDppShaping
  • GetDeviceNameFromVal() : CDppConfig , CDP5Status , CSCommon , CvcDP5Dlg
  • GetDevicePath() : CDppWinUSB
  • GetDevNotifyInfo() : CWinusbNotify
  • GetDP5CfgStr() : CAsciiCmdUtilities
  • GetDP5Data() : CIniUtil
  • GetDP5ScaStr() : CAsciiCmdUtilities
  • GetDP5Section() : CIniUtil
  • GetFromIniEx() : CScaFn
  • GetGainCount() : CDppGain
  • GetGainTablePtr() : CDppGain
  • GetImageCount() : cAnimWnd
  • getKeyValue() : CINI
  • GetMsIniItem() : CIniUtil
  • GetNextCMD() : CScaFn
  • GetPixPerChannel() : CvcDP5Dlg
  • GetRiseValueFromIndex() : CDppShaping
  • GetSCASettingsINI() : CScaFn
  • GetSCASetupINI() : CScaFn
  • getSectionData() : CINI
  • getSectionNames() : CINI
  • GetSlowChThreshold() : CDppSlowThreshold
  • GetSlowChThresStrFromVal() : CDppSlowThreshold
  • GetSlowThreshCalStart() : CTuneSlowThreshold
  • GetSlowThreshChStr() : CDppSlowThreshold
  • GetSlowThreshChStrFromVal() : CTuneSlowThreshold , CDppSlowThreshold
  • GetSlowThresholdSettingFromChannels() : CDppSlowThreshold
  • GetSlowThresholdSettingFromPercent() : CDppSlowThreshold
  • GetSlowThreshPcntStr() : CDppSlowThreshold
  • GetSpectrumData() : CTuneSlowThreshold
  • GetStatusBar() : CCfgPropSheet
  • GetStatusValueStrings() : CDP5Status
  • GetToolBar() : CCfgPropSheet
  • GetTotalGainLimitsLabel() : CDppGain
  • GetTotalGainLimitsMax() : CDppGain
  • GetTotalGainLimitsMin() : CDppGain
  • GetUpperChCounts() : CTuneSlowThreshold
  • GetUpperChMax() : CTuneSlowThreshold
  • GetValueWithUnitsString() : CDP5ControlUtil
  • ghThreadExitEvent : CDppComm
  • GP_COUNTER : DP5_DP4_FORMAT_STATUS
  • GPCount : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • hasBackground : CPlotCanvas
  • HasData : NETDISPLAY_ENTRY
  • HaveConfig : CSCommon
  • HaveCurIndex : CSca
  • HaveHeader : CDppSocket
  • HavePlot : CvcDP5Dlg
  • HaveScaUpdate : CSca
  • HaveScopeData : _DppStateType
  • HaveTrace : CvcDP5Dlg
  • High : CSca
  • HPGe_HV_INH : DP5_DP4_FORMAT_STATUS
  • HPGe_HV_INH_POL : DP5_DP4_FORMAT_STATUS
  • HV : CDppConfig , DP5_DP4_FORMAT_STATUS
  • HVEnabled : CDppConfig
  • HVMonitor : CDppConfig
  • HVMonitorCStr : CDppConfig
  • HVOn : _DiagDataType
  • HVRangeInd : CDppConfig
  • HwCfgDP5 : CSCommon
  • HwCfgDP5Out : CSCommon , _CONFIG_OPTIONS
  • HwCfgExReady : CSCommon
  • HwCfgFromDLG : CDppConfig
  • HwCfgReady : CSCommon
  • hWnd_Main : CSCommon
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IDD : CBootOptPage , CMsgBox , CvcDP5Dlg , cWaitDlg , CAboutDlg
  • IndBuzzer : CDppConfig
  • Index : CSca , _WINUSB_SETUP_PACKET
  • IndLED : CDppConfig
  • ini : CIniUtil
  • Init_PAPS_Controls() : CPowerPage
  • InitAllEntries() : CNetFinder
  • InitAuxControls() : CMiscPage
  • InitBlrMode() : CShapingPage
  • InitCfgPropSheet() : CCfgPropSheet
  • InitCombo() : CGainPzPage
  • InitComboFromText() : CShapingPage
  • InitControls() : CBootOptPage , CFilePage , CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage
  • InitDeviceInfo() : CDppWinUSB , CWinusbNotify
  • InitDlgItem() : CPowerPage , CShapingPage , CBootOptPage , CFilePage , CGainPzPage , CMcaPage , CMiscPage
  • InitDlgItemDMCA() : CMcaPage
  • InitEntry() : CNetFinder
  • InitFastPeakCombo() : CShapingPage
  • Initialize_Device() : CDppWinUSB
  • InitializeLibusb() : CDppLibUsb
  • InitInstance() : CvcDP5App , cWaitDlgThread
  • InitSCA() : CScaFn
  • InPacketType : CDP5Protocol
  • Insert() : CRoi
  • InsertSorted() : CRoi
  • Interface : _DppStateType
  • interruptPipe : WINUSB_DEVICE_INFO
  • Interval : _WINUSB_PIPE_INFORMATION
  • Invalidate() : CPlotCanvas
  • InvertEn : CDppConfig
  • ip : NETDISPLAY_ENTRY
  • IpSelectAddr : CSelectDP5
  • IpSelectBtn : CSelectDP5
  • Is8_5VPreAmp : _DiagDataType
  • IsAllNumericString() : CDP5ControlUtil
  • isAmptekDP5Device() : CDppLibUsb
  • IsAorB() : CDP5Status
  • isAscEnabled : DP5_DP4_FORMAT_STATUS
  • isAscInstalled : DP5_DP4_FORMAT_STATUS
  • isCComboBox() : CFilePage , CShapingPage , CPowerPage , CGainPzPage , CMcaPage , CMiscPage
  • isCEditBox() : CFilePage , CGainPzPage , CMiscPage , CPowerPage , CMcaPage , CShapingPage
  • isCfgChanged : CDppConfig
  • isClosing : CFilePage
  • isConnectedTest() : CvcDP5Dlg
  • isDeltaMode : CDppConfig
  • isDMcaControls : CMcaPage
  • isDP5_RevDxGains : DP5_DP4_FORMAT_STATUS , _CONFIG_OPTIONS
  • isDPP5 : CDppConfig
  • isDppConnected : CSCommon
  • isDppFound : CSCommon , CDppWinUSB
  • isEnterKey : CTrapKeyEdit , CTrapKeyComboBox
  • isExpression : CSpectrumAttr
  • isHVSignInString() : CPowerPage
  • isHVSignPositive() : CPowerPage
  • isInTotalGainRange() : CDppGain
  • isLButton : CTrapKeyEdit , CTrapKeyComboBox
  • isPlotLine : CSCommon
  • IsPortOpen() : CDppComm
  • IsPosHV : _DiagDataType
  • isPresetAcq : CDppConfig
  • isScaleLog : CSCommon
  • IsSocketOpen() : CDppSocket
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LastBkColor : CLabel
  • LastEntry : CNetFinder
  • LastLibUsbError : CDppLibUsb
  • LastTextColor : CLabel
  • lblDppFound : CSelectDP5
  • lblFPGAClk : CShapingPage
  • lblMiscStatus : CvcDP5Dlg
  • lblNetFinder : CSelectDP5
  • lblSelectCommunications : CvcDP5Dlg
  • lblStatus : CvcDP5Dlg
  • LEN : _Packet_In , Packet_Out
  • Length : _WINUSB_SETUP_PACKET
  • LibFileFilter : CFileBrowse
  • libusb_strerror() : CDppLibUsb
  • Limits : _DP5_CONFIGURATION
  • ListCtrlID : _DP5_CONFIGURATION
  • LiveTime : CDppConfig , DP5_DP4_FORMAT_STATUS
  • LoadGainTableIndexes() : CDppGain
  • LoadGainTableValues() : CDppGain
  • LoadingCfg : CDP5ControlUtil
  • LoadProfile() : CSCommon
  • LoadRestartFastThresh : CDppConfig
  • LoadRestartInProgress : CDppConfig
  • LoadRestartInputOffset : CDppConfig
  • LoadRestartInputOffsetSlow : CDppConfig
  • LoadRestartSlowThresh : CDppConfig
  • LoadRestartStatus : CDppConfig
  • LongWordToDouble() : CDppUtilities
  • Low : CSca
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_Anim : cWaitDlg
  • m_attr : CSpectrum
  • m_bFocusFlag : CTrapKeyEdit
  • m_Bitmap : cAnimWnd
  • m_bKillItself : CCfgPropSheet
  • m_bLink : CLabel
  • m_bMenu : CCfgPropSheet
  • m_bModal : CCfgPropSheet , CDP5CfgWnd
  • m_bModified : CSelectDP5
  • m_BootOptPageLabel : CBootOptPage
  • m_bResetPrompt : CCfgPropSheet
  • m_bShowCancelButton : cWaitDialog , cWaitDlg , cWaitDlgThread
  • m_bState : CLabel
  • m_bStatusBar : CCfgPropSheet
  • m_bThreadRunning : CDppComm
  • m_bTimer : CLabel
  • m_bToolBar : CCfgPropSheet
  • m_bToolTips : CCfgPropSheet
  • m_centroid : CRoiEntry
  • m_CoarseGain_GAIA_index : CGainPzPage
  • m_CoarseGain_GAIA_value : CGainPzPage
  • m_CommTimeouts : CDppComm
  • m_count : CRoi
  • m_crCursorColor : CPlotCanvas
  • m_crDisplayBGColor : CPlotCanvas
  • m_crPlotColor : CPlotCanvas
  • m_crText : CLabel
  • m_crTextBGColor : CPlotCanvas
  • m_crTextFGColor : CPlotCanvas
  • m_CSBCtrlStatus : CCfgPropSheet
  • m_csCommunicationSync : CDppComm
  • m_CSToolBar : CCfgPropSheet
  • m_currentSpectrum : CSpectraList
  • m_DataMode : CDppSocket
  • m_dcb : CDppComm
  • m_DP5_Status : CDP5Status , CSelectDP5
  • m_DP5Cfg : CSCommon
  • m_DppPort : CSCommon
  • m_DppSck : CSCommon
  • m_dwCommEvents : CDppComm
  • m_end : CRoiEntry
  • m_Event : cWaitDialog , cWaitDlgThread
  • m_EventName : cWaitDialog
  • m_Eventname : cWaitDlgThread
  • m_FastPeakCombo : CShapingPage
  • m_FileAdvancedLabel : CFilePage
  • m_FilePage : CDP5CfgWnd
  • m_FilePageLabel : CFilePage
  • m_FileStandardLabel : CFilePage
  • m_font : CLabel
  • m_fwhm : CRoiEntry
  • m_GainAdvancedLabel : CGainPzPage
  • m_GainPzPage : CDP5CfgWnd
  • m_GainPzPageLabel : CGainPzPage
  • m_GainStandardLabel : CGainPzPage
  • m_hBrush : CLabel
  • m_hCursor : CLabel
  • m_hDppComm : CDppComm
  • m_Height : cAnimWnd
  • m_hEvents : CDppComm
  • m_hIcon : CvcDP5Dlg
  • m_hwndBrush : CLabel
  • m_hWndOwner : CWinusbNotify
  • m_hWriteEvent : CDppComm
  • m_ImageIndex : cAnimWnd
  • m_iNumChan : _SpectrumFileType
  • m_leftWidth : CRoiEntry
  • m_lf : CLabel
  • m_max : CRoiEntry
  • m_McaAdvancedLabel : CMcaPage
  • m_McaPage : CDP5CfgWnd
  • m_McaPageLabel : CMcaPage
  • m_McaStandardLabel : CMcaPage
  • m_MemDC : cAnimWnd
  • m_MiscAdvancedLabel : CMiscPage
  • m_MiscPage : CDP5CfgWnd
  • m_MiscPageLabel : CMiscPage
  • m_MiscQuicksetLabel : CMiscPage
  • m_net : CRoiEntry
  • m_nIDLastMessage : CCfgPropSheet
  • m_nIDTracking : CCfgPropSheet
  • m_nTmrConfigElapse : CFilePage
  • m_nTmrConfigEventId : CFilePage
  • m_nTmrConfigId : CFilePage
  • m_nTmrRS232Elapse : CSelectDP5 , CvcDP5Dlg
  • m_nTmrRS232EventId : CSelectDP5 , CvcDP5Dlg
  • m_nTmrRS232Id : CSelectDP5 , CvcDP5Dlg
  • m_nTmrSpectrumElapse : CvcDP5Dlg
  • m_nTmrSpectrumEventId : CvcDP5Dlg
  • m_nTmrSpectrumId : CvcDP5Dlg
  • m_nTmrTimeoutElapse : CvcDP5Dlg
  • m_nTmrTimeoutEventId : CvcDP5Dlg
  • m_nTmrTimeoutId : CvcDP5Dlg
  • m_nWriteBufferSize : CDppComm
  • m_Owner : CDppSocket
  • m_pEvtDlg : CDppSocket
  • m_PicturePlot : CvcDP5Dlg
  • m_PictureScope : CvcDP5Dlg
  • m_plot : CSCommon
  • m_PowerAdvancedLabel : CPowerPage
  • m_PowerHvSign1 : CPowerPage
  • m_PowerHvSign2 : CPowerPage
  • m_PowerHvWarning : CGainPzPage , CPowerPage
  • m_PowerPage : CDP5CfgWnd
  • m_PowerPageLabel : CPowerPage
  • m_PowerStandardLabel : CPowerPage
  • m_pOwner : CDppComm
  • m_PrevOwner : CSelectDP5
  • m_rand : CNetFinder
  • m_ReadDetectorConfigCombo : CFilePage
  • m_rightWidth : CRoiEntry
  • m_RiseCombo : CShapingPage
  • m_roi : CSpectrum
  • m_selectIndex : CRoi
  • m_ShapingAdvancedLabel : CShapingPage
  • m_ShapingPage : CDP5CfgWnd
  • m_ShapingPageLabel : CShapingPage
  • m_ShapingStandardLabel : CShapingPage
  • m_SocketOpen : CDppSocket
  • m_Spectrum : CSCommon
  • m_SpectrumRefreshTimeCtrl : CSelectDP5
  • m_SpinSelectDevice : CSelectDP5
  • m_start : CRoiEntry
  • m_status : CRoiEntry
  • m_strConfigIn : CFilePage
  • m_strConfigOut : CFilePage
  • m_strDelimiter : CMsgBox
  • m_strMessage : CMsgBox
  • m_strText : CLabel
  • m_strTitle : CMsgBox
  • m_szWriteBuffer : CDppComm
  • m_Text : cWaitDialog , cWaitDlg , cWaitDlgThread
  • m_Thread : cWaitDialog , cWaitDlg
  • m_Timer : CCfgPropSheet
  • m_ToolTip : CFilePage , CPowerPage , CMcaPage , CMiscPage , CShapingPage , CSelectDP5 , CGainPzPage
  • m_TopCombo : CShapingPage
  • m_total : CRoiEntry
  • m_TransparentColor : cAnimWnd
  • m_Type : CLabel
  • m_TypeInIPAddressCheck : CSelectDP5
  • m_uncertainty : CRoiEntry
  • m_Width : cAnimWnd
  • m_WinThread : CDppComm
  • m_xCursorData : CPlot
  • m_xCursorPos : CPlot
  • m_xMax : CPlot
  • m_xMin : CPlot
  • m_xPixels : CPlot
  • m_yCursorPos : CPlot
  • m_yMax : CPlot
  • m_yMin : CPlot
  • m_yPixels : CPlot
  • mac : NETDISPLAY_ENTRY
  • MakeDp5CmdList() : CvcDP5Dlg
  • MakeLower() : stringex
  • MakeUpper() : stringex , CAsciiCmdUtilities
  • MaxGain : CDppGain
  • MaximumPacketSize : _WINUSB_PIPE_INFORMATION
  • MCA : CDppConfig
  • MCA_EN : DP5_DP4_FORMAT_STATUS
  • mcaCH : CDppConfig
  • MCAEnable : CDppConfig
  • McaFileFilter : CFileBrowse
  • MCS_DONE : DP5_DP4_FORMAT_STATUS
  • MCSDone : CDppConfig
  • MCSEnable : CDppConfig
  • MCSTimebase : CDppConfig
  • MinGain : CDppGain
  • MiscData : CDP5Protocol
  • MoveCtrl() : CMcaPage
  • MoveCtrlEx() : CMcaPage
  • MovePlot() : CPlot
  • msTimeDiff() : CMSecTimer
  • msTimeExpired() : CMSecTimer
  • msTimer() : CMSecTimer
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • NavPanelUpdate : CDppConfig
  • NeedsDP5ReBoot : CDppConfig
  • Netfinder_active : CDP5Protocol
  • Netfinder_Seq : CDP5Protocol
  • NetfinderActive : CSCommon
  • notesNotes : CSpectrumAttr
  • NullBkColor : CLabel
  • NullSet : CLabel
  • NullTextColor : CLabel
  • NumDevices : CDppLibUsb , CDppWinUSB
  • NumPipes : CDppWinUSB
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • Offset : CDppConfig
  • OldCursorPosition : CPlotCanvas
  • OldPlotCursor : CPlotCanvas
  • OnApply() : CFilePage
  • OnBnClickedBlrquickslowbutton2() : CShapingPage
  • OnBnClickedBtnSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonArmTrigger() : CvcDP5Dlg
  • OnBnClickedButtonAutotune() : CvcDP5Dlg
  • OnBnClickedButtonClearDataAndGraph() : CvcDP5Dlg
  • OnBnClickedButtonClearMiscData() : CvcDP5Dlg
  • OnBnClickedButtonClearRoi() : CvcDP5Dlg
  • OnBnClickedButtonClipboardCopy() : CSelectDP5
  • OnBnClickedButtonCloseDevice() : CSelectDP5
  • OnBnClickedButtonClosePort() : CSelectDP5
  • OnBnClickedButtonCoarseFineToTotal() : CGainPzPage
  • OnBnClickedButtonCountDevices() : CSelectDP5
  • OnBnClickedButtonDiag() : CvcDP5Dlg
  • OnBnClickedButtonEditConfig() : CvcDP5Dlg
  • OnBnClickedButtonEditConfigFromHw() : CFilePage
  • OnBnClickedButtonFindDevice() : CvcDP5Dlg
  • OnBnClickedButtonFindDp5Ip() : CSelectDP5
  • OnBnClickedButtonFindUsbDevice() : CSelectDP5
  • OnBnClickedButtonFineGainEnter() : CGainPzPage
  • OnBnClickedButtonGetSpectrum() : CvcDP5Dlg
  • OnBnClickedButtonIpSelect1() : CSelectDP5
  • OnBnClickedButtonIpSelect2() : CSelectDP5
  • OnBnClickedButtonIpSelect3() : CSelectDP5
  • OnBnClickedButtonIpSelect4() : CSelectDP5
  • OnBnClickedButtonOpenPort() : CSelectDP5
  • OnBnClickedButtonOutputQuickset1() : CMiscPage
  • OnBnClickedButtonOutputQuickset2() : CMiscPage
  • OnBnClickedButtonOutputQuickset3() : CMiscPage
  • OnBnClickedButtonPreviewSca() : CMiscPage
  • OnBnClickedButtonReadConfig() : CFilePage
  • OnBnClickedButtonReadMiscData() : CvcDP5Dlg
  • OnBnClickedButtonRoiEnd() : CvcDP5Dlg
  • OnBnClickedButtonRoiStart() : CvcDP5Dlg
  • OnBnClickedButtonSaveConfig() : CFilePage
  • OnBnClickedButtonSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonScaDefaults() : CMiscPage
  • OnBnClickedButtonSelectComm() : CvcDP5Dlg
  • OnBnClickedButtonSendCommand() : CFilePage
  • OnBnClickedButtonSendCommand2() : CFilePage
  • OnBnClickedButtonSendToHardware() : CFilePage
  • OnBnClickedButtonSendToHardwareNoEdit() : CFilePage
  • OnBnClickedButtonSerialReqData() : CSelectDP5
  • OnBnClickedButtonShowConfig() : CvcDP5Dlg
  • OnBnClickedButtonSingleUpdate() : CvcDP5Dlg
  • OnBnClickedButtonSpectrumRefreshDefault() : CSelectDP5
  • OnBnClickedButtonStartAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonStopAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonTotalToCoarseFine() : CGainPzPage
  • OnBnClickedButtonWriteMiscData() : CvcDP5Dlg
  • OnBnClickedButtonWriteTextBlock() : CvcDP5Dlg
  • OnBnClickedCancel() : CvcDP5Dlg
  • OnBnClickedCheckDP5DxGains() : CFilePage
  • OnBnClickedCheckEnableSca() : CMiscPage
  • OnBnClickedCheckPc5Present() : CFilePage
  • OnBnClickedCheckTypeIpAddress() : CSelectDP5
  • OnBnClickedConnectOK() : CSelectDP5
  • OnBnClickedOk() : CSelectDP5 , CvcDP5Dlg
  • OnBnClickedPresetcountcursorbutton() : CMcaPage
  • OnBnClickedPresetcountroibutton() : CMcaPage
  • OnBnClickedRadioCommtype1() : CSelectDP5
  • OnBnClickedRadioCommtype2() : CSelectDP5
  • OnBnClickedRadioCommtype3() : CSelectDP5
  • OnBnClickedRadioDppDeviceType1() : CFilePage
  • OnBnClickedRadioDppDeviceType2() : CFilePage
  • OnBnClickedRadioDppDeviceType3() : CFilePage
  • OnBnClickedRadioDppDeviceType4() : CFilePage
  • OnBnClickedRadioDppDeviceType5() : CFilePage
  • OnBnClickedRadioDppDeviceType6() : CFilePage
  • OnBnClickedRadioHvSign1() : CPowerPage
  • OnBnClickedRadioHvSign2() : CPowerPage
  • OnBnClickedRadioPlotScaleLinear() : CvcDP5Dlg
  • OnBnClickedRadioPlotScaleLog() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeLine() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeSolid() : CvcDP5Dlg
  • OnCancel() : CCfgPropSheet , CFilePage , cWaitDlg
  • OnCbnSelchangeComboComport() : CSelectDP5
  • OnCbnSelchangeComboOutputLevel() : CMiscPage
  • OnCbnSelchangeComboScaIndex() : CMiscPage
  • OnCbnSelchangeComboScaPulseWidth() : CMiscPage
  • OnCbnSelchangeOptComboAinp() : CGainPzPage
  • OnCbnSelchangeOptComboAuo1() : CMiscPage
  • OnCbnSelchangeOptComboAuo2() : CMiscPage
  • OnCbnSelchangeOptComboBlrm() : CShapingPage
  • OnCbnSelchangeOptComboBoot() : CPowerPage
  • OnCbnSelchangeOptComboClck() : CShapingPage
  • OnCbnSelchangeOptComboCon1() : CMiscPage
  • OnCbnSelchangeOptComboCon2() : CMiscPage
  • OnCbnSelchangeOptComboCusp() : CShapingPage
  • OnCbnSelchangeOptComboDaco() : CMiscPage
  • OnCbnSelchangeOptComboDmcaGaia() : CMcaPage
  • OnCbnSelchangeOptComboDmcaPure() : CMcaPage
  • OnCbnSelchangeOptComboGaia() : CGainPzPage
  • OnCbnSelchangeOptComboGaia2() : CGainPzPage
  • OnCbnSelchangeOptComboGainSelect() : CGainPzPage
  • OnCbnSelchangeOptComboGate() : CMcaPage
  • OnCbnSelchangeOptComboGped() : CMiscPage
  • OnCbnSelchangeOptComboGpga() : CMiscPage
  • OnCbnSelchangeOptComboGpin() : CMiscPage
  • OnCbnSelchangeOptComboGpmc() : CMiscPage
  • OnCbnSelchangeOptComboGpme() : CMiscPage
  • OnCbnSelchangeOptComboHvse() : CPowerPage
  • OnCbnSelchangeOptComboInof() : CGainPzPage
  • OnCbnSelchangeOptComboMcac() : CMcaPage
  • OnCbnSelchangeOptComboMcae() : CMcaPage
  • OnCbnSelchangeOptComboMcas() : CMcaPage
  • OnCbnSelchangeOptComboPaps() : CPowerPage
  • OnCbnSelchangeOptComboPapz() : CGainPzPage
  • OnCbnSelchangeOptComboPdmd() : CMcaPage
  • OnCbnSelchangeOptComboPrec() : CMcaPage
  • OnCbnSelchangeOptComboPrel() : CMcaPage
  • OnCbnSelchangeOptComboPrer() : CMcaPage
  • OnCbnSelchangeOptComboPret() : CMcaPage
  • OnCbnSelchangeOptComboPure() : CShapingPage
  • OnCbnSelchangeOptComboResc() : CFilePage
  • OnCbnSelchangeOptComboResl() : CGainPzPage
  • OnCbnSelchangeOptComboResl2() : CGainPzPage
  • OnCbnSelchangeOptComboRtde() : CShapingPage
  • OnCbnSelchangeOptComboScoe() : CMiscPage
  • OnCbnSelchangeOptComboScog() : CMiscPage
  • OnCbnSelchangeOptComboScot() : CMiscPage
  • OnCbnSelchangeOptComboSctc() : CShapingPage
  • OnCbnSelchangeOptComboSoff() : CMcaPage
  • OnCbnSelchangeOptComboTecs() : CPowerPage
  • OnCbnSelchangeOptComboTlld() : CMcaPage
  • OnCbnSelchangeOptComboTpfa() : CShapingPage
  • OnCbnSelchangeOptComboTpmo() : CMiscPage
  • OnCbnSelchangeOptComboVolu() : CMiscPage
  • OnCbnSelchangeReaddetectorconfigcombo() : CFilePage
  • OnCbnSelchangeRisecombo() : CShapingPage
  • OnCbnSelchangeTopcombo() : CShapingPage
  • OnCbnSelendokReaddetectorconfigcombo() : CFilePage
  • OnComm() : CSelectDP5 , CvcDP5Dlg
  • OnCommunication() : CSelectDP5 , CvcDP5Dlg
  • OnDeltaposSpinSelectDevice() : CSelectDP5
  • OnDestroy() : CvcDP5Dlg
  • OnDeviceChange() : CvcDP5Dlg
  • OnEnChangeEditHighThreshold() : CMiscPage
  • OnEnChangeEditLowThreshold() : CMiscPage
  • OnEnChangeOptTextAuo1() : CMiscPage
  • OnEnChangeOptTextAuo2() : CMiscPage
  • OnEnChangeOptTextBlrd() : CShapingPage
  • OnEnChangeOptTextBlru() : CShapingPage
  • OnEnChangeOptTextCusp() : CShapingPage
  • OnEnChangeOptTextDacf() : CMiscPage
  • OnEnChangeOptTextDaco() : CMiscPage
  • OnEnChangeOptTextGaif() : CGainPzPage
  • OnEnChangeOptTextGain() : CGainPzPage
  • OnEnChangeOptTextGpin() : CMiscPage
  • OnEnChangeOptTextHvse() : CPowerPage
  • OnEnChangeOptTextInof() : CGainPzPage
  • OnEnChangeOptTextMcsh() : CMcaPage
  • OnEnChangeOptTextMcsl() : CMcaPage
  • OnEnChangeOptTextMcst() : CMcaPage
  • OnEnChangeOptTextPapz() : CGainPzPage
  • OnEnChangeOptTextPrch() : CMcaPage
  • OnEnChangeOptTextPrcl() : CMcaPage
  • OnEnChangeOptTextPrec() : CMcaPage
  • OnEnChangeOptTextPrel() : CMcaPage
  • OnEnChangeOptTextPrer() : CMcaPage
  • OnEnChangeOptTextPret() : CMcaPage
  • OnEnChangeOptTextPure() : CShapingPage
  • OnEnChangeOptTextResl() : CGainPzPage
  • OnEnChangeOptTextRtds() : CShapingPage
  • OnEnChangeOptTextRtdt() : CShapingPage
  • OnEnChangeOptTextSctc() : CShapingPage
  • OnEnChangeOptTextSoff() : CMcaPage
  • OnEnChangeOptTextTecs() : CPowerPage
  • OnEnChangeOptTextTfla() : CShapingPage
  • OnEnChangeOptTextThfa() : CShapingPage
  • OnEnChangeOptTextThsl() : CMcaPage
  • OnEnChangeOptTextTlld() : CMcaPage
  • OnEnChangeOptTextTpea() : CShapingPage
  • OnEnChangeSpectrumRefreshTime() : CSelectDP5
  • OnEnterIdle() : CCfgPropSheet
  • OnEraseBkgnd() : CPlotCanvas
  • OnFileTab() : CCfgPropSheet
  • OnFileTab2() : CCfgPropSheet
  • OnGainPzTab() : CCfgPropSheet
  • OnGainPzTab2() : CCfgPropSheet
  • OnGetDlgCode() : CTrapKeyEdit
  • OnHelp() : CFilePage , CMcaPage , CMiscPage , CPowerPage , CShapingPage , CGainPzPage
  • OnHelpInfo() : CPowerPage , CMcaPage , CSelectDP5 , CFilePage , CGainPzPage , CMiscPage , CShapingPage
  • OnIdleUpdateCmdUI() : CDlgToolBar , CDlgStatusBar
  • OnInitDialog() : CvcDP5Dlg , CMiscPage , CMcaPage , CDP5CfgWnd , CGainPzPage , CBootOptPage , CFilePage , CPowerPage , CSelectDP5 , cWaitDlg , CMsgBox , CShapingPage
  • OnInitMenuPopup() : CCfgPropSheet
  • OnKeyUp() : CTrapKeyEdit
  • OnKickIdle() : CCfgPropSheet
  • OnKillfocus() : CTrapKeyEdit
  • OnLButtonDown() : CLabel , CvcDP5Dlg , CPlotCanvas
  • OnLButtonUp() : CTrapKeyEdit
  • OnMcaTab() : CCfgPropSheet
  • OnMcaTab2() : CCfgPropSheet
  • OnMenuSelect() : CCfgPropSheet
  • OnMiscTab() : CCfgPropSheet
  • OnMiscTab2() : CCfgPropSheet
  • OnMouseMove() : CCfgPropSheet , CCfgPropPage
  • OnOffStr() : CDP5Status
  • OnOK() : CSelectDP5 , cWaitDlg
  • OnPaint() : CvcDP5Dlg , cAnimWnd , CPlotCanvas
  • OnPopMessageString() : CCfgPropSheet
  • OnPowerTab() : CCfgPropSheet
  • OnPowerTab2() : CCfgPropSheet
  • OnQueryDragIcon() : CvcDP5Dlg
  • OnReceive() : CSelectDP5 , CDppSocket , CvcDP5Dlg
  • OnRefreshBkgnd() : CPlotCanvas
  • OnResetCommunications() : CvcDP5Dlg
  • OnSelectTab() : CCfgPropSheet
  • OnSetActive() : CFilePage , CShapingPage , CGainPzPage , CMiscPage , CBootOptPage , CMcaPage , CPowerPage
  • OnSetCursor() : CLabel
  • OnSetMessageString() : CCfgPropSheet
  • OnSetPageFocus() : CMiscPage
  • OnShapingTab() : CCfgPropSheet
  • OnShapingTab2() : CCfgPropSheet
  • OnStatusBarCheck() : CCfgPropSheet
  • OnStnClickedPlotpicturecontrol() : CvcDP5Dlg
  • OnStnClickedStaticNetfinder1() : CSelectDP5
  • OnStnClickedStaticNetfinder2() : CSelectDP5
  • OnStnClickedStaticNetfinder3() : CSelectDP5
  • OnStnClickedStaticNetfinder4() : CSelectDP5
  • OnStnClickedStaticReadConfig() : CFilePage
  • OnStnClickedStaticSaveConfig() : CFilePage
  • OnSysCommand() : CvcDP5Dlg
  • OnTB1() : CCfgPropSheet
  • OnTimer() : CFilePage , cAnimWnd , cWaitDlg , CSelectDP5 , CvcDP5Dlg , CLabel , CCfgPropSheet
  • OnToolBarCheck() : CCfgPropSheet
  • OnToolTipNotify() : CvcDP5Dlg
  • OnToolTipText() : CCfgPropSheet , CCfgPropPage
  • OnUpdateKeyIndicator() : CCfgPropSheet
  • OnUpdateStatusBarMenu() : CCfgPropSheet
  • OnUpdateToolBarMenu() : CCfgPropSheet
  • OPEN : CFileBrowse
  • OpenDevice() : CDppWinUSB
  • OpenPort() : CDppComm
  • operator->() : cMemDC
  • OptPlotType : CPlotCanvas
  • OptScaleType : CPlotCanvas
  • OrderOut() : CDP5ControlUtil
  • osIO : CDppComm
  • Output : CSca
  • OutputQuickset() : CMiscPage
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Packet_Received : CDP5Protocol
  • PacketIn : CDP5Protocol
  • ParsePacket() : CParsePacket
  • ParsePacketEx() : CvcDP5Dlg
  • ParsePacketStatus() : CParsePacket
  • ParsePerformanceNotes() : CvcDP5Dlg
  • ParsePkt : CSCommon
  • ParseTextBlockNotes() : CvcDP5Dlg
  • PC5_8_5V : DP5_DP4_FORMAT_STATUS
  • PC5_HV_POL : DP5_DP4_FORMAT_STATUS
  • PC5_PRESENT : DP5_DP4_FORMAT_STATUS , _DiagDataType , _CONFIG_OPTIONS
  • PC5_SN : DP5_DP4_FORMAT_STATUS , _DiagDataType
  • PC5_V : _DiagDataType
  • PC5DCAL : _DiagDataType
  • PC5Initialized : _DiagDataType
  • PersistenceMode : CPlotCanvas
  • PID1 : _Packet_In , Packet_Out
  • PID2 : _Packet_In , Packet_Out
  • PID2_TextToString() : CParsePacket
  • PIN : CDP5Protocol
  • PipeId : CDppWinUSB , _WINUSB_PIPE_INFORMATION
  • PipeTimeout : CDppWinUSB
  • PipeType : _WINUSB_PIPE_INFORMATION
  • PixelToPosition() : CPlot
  • plot : CSCommon
  • PlotBuffer : CvcDP5Dlg
  • PlotCursor : CPlotCanvas
  • PlotData() : CvcDP5Dlg
  • PlotTrace() : CPlotCanvas
  • PoleZero : CDppConfig
  • Port : CDppConfig
  • port : NETDISPLAY_ENTRY
  • PortIDSetting : CDppComm
  • PortIsOpen : CDppComm
  • PositionToPixel() : CPlot
  • PostNcDestroy() : CCfgPropSheet
  • PosToChannel() : CSpectrum
  • POUT_Buffer() : CSendCommand
  • PreAmpON : _DiagDataType
  • PRECNT_REACHED : DP5_DP4_FORMAT_STATUS
  • Preset : CDppConfig
  • PresetAcq : CDppConfig
  • PresetCount : CDppConfig
  • PresetCountExpired : CDppConfig
  • PresetLt : CDppConfig
  • PresetLtDone : CDppConfig , DP5_DP4_FORMAT_STATUS
  • PresetRt : CDppConfig
  • PresetRtDone : CDppConfig , DP5_DP4_FORMAT_STATUS
  • PreTranslateMessage() : CFilePage , CShapingPage , CvcDP5Dlg , CPowerPage , CTrapKeyComboBox , CGainPzPage , CMcaPage , CMiscPage
  • PrintCfg : CDppConfig
  • PrintDevices() : CDppLibUsb
  • printNotes : CSpectrumAttr
  • Process_Diagnostics() : CDP5Status
  • Process_Status() : CDP5Status
  • ProcessAck() : CvcDP5Dlg
  • ProcessCfgReadEx() : CvcDP5Dlg
  • ProcessDiagDataEx() : CvcDP5Dlg
  • ProcessScopeDataEx() : CvcDP5Dlg
  • ProcessSpectrumEx() : CvcDP5Dlg
  • ProcessStatusEx() : CvcDP5Dlg
  • ProcessTextDataEx() : CvcDP5Dlg
  • ProcessUSBData() : CDppConfig
  • profile : CSProfile , CSCommon
  • profileCls : CSCommon
  • ptrGainTable : CDppGain
  • PulseWidth : CSca
  • PUREnable : CDppConfig
  • Put() : CSCommon
  • PwrBtnConfig : CDppConfig
  • PwrCtrl5VA : CDppConfig
  • PwrCtrl9V : CDppConfig
  • PX4 : DP5_DP4_FORMAT_STATUS
  • PX4FineGain : CDppConfig
  • PX4Gain : CDppConfig
  • PX4InputOffset : CDppConfig
  • PX5_OptionsString() : CDP5Status
  • PZCORR : DP5_DP4_FORMAT_STATUS
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RAM_TEST_ERROR : DP5_DP4_FORMAT_STATUS
  • RAM_TEST_RUN : DP5_DP4_FORMAT_STATUS
  • RAW : DP5_DP4_FORMAT_STATUS
  • RcvCount : CDppSocket
  • RcvTotal : CDppSocket
  • ReadAmptekDetectorConfigNames() : CFilePage
  • ReadConfig() : CFilePage
  • ReadConfigFromAmptek_NP() : CFilePage
  • ReadSCASetting() : CScaFn
  • RealTime : CDppConfig , DP5_DP4_FORMAT_STATUS
  • ReBootFlag : DP5_DP4_FORMAT_STATUS
  • ReceiveByte() : CDppComm
  • ReceivePacket() : CSelectDP5
  • ReconstructFont() : CLabel
  • RefreshDppGainPZ : CDppConfig
  • RefreshDppGeneral : CDppConfig
  • RefreshDppMCA : CDppConfig
  • RefreshDppMisc : CDppConfig
  • RefreshDppPower : CDppConfig
  • RefreshDppShaping : CDppConfig
  • RefreshDppTest : CDppConfig
  • RegDeviceNotification() : CWinusbNotify
  • ReloadCfg : CSCommon
  • RemCallParsePacket() : CvcDP5Dlg
  • Remove() : CRoi
  • Remove_MCA8000D_Cmds() : CAsciiCmdUtilities
  • RemoveCmd() : CAsciiCmdUtilities
  • RemoveCmdByDeviceType() : CAsciiCmdUtilities
  • RemoveCmdByDeviceTypeDP5DxK() : CAsciiCmdUtilities
  • RemoveDeviceNotification() : CWinusbNotify
  • RemoveUnitsFromDecString() : CDP5ControlUtil
  • RemWhitespace() : CAsciiCmdUtilities
  • ReplaceCmdDesc() : CvcDP5Dlg
  • ReplaceCmdDescMS() : CvcDP5Dlg
  • ReplaceCmdText() : CAsciiCmdUtilities
  • ReqDataStatus() : CSelectDP5
  • ReqDataStatusSock() : CSelectDP5
  • ReqProcess : _DppStateType
  • Request : _WINUSB_SETUP_PACKET
  • RequestScopeData() : CvcDP5Dlg
  • RequestType : _WINUSB_SETUP_PACKET
  • ResetEventDlg() : CDppSocket
  • Rise : CDppConfig
  • RiseTop : CShapingPage
  • RiseUS : CDppConfig
  • RS232_RThreshold : CDP5Protocol
  • RS232BytesInBuffer : CDP5Protocol
  • RS232HeaderReceived : CDP5Protocol
  • RS232PacketPtr : CDP5Protocol
  • RTDFast : CDppConfig
  • RTDOn : CDppConfig
  • RTDSlow : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SAVE : CFileBrowse
  • SaveCfg : CDppConfig
  • SaveConfigString() : CFilePage
  • SaveDP5Data() : CIniUtil
  • SaveMCAFile() : CvcDP5Dlg
  • SaveProfile() : CSCommon
  • SaveSCASettingsINI() : CScaFn
  • SaveSCASetupINI() : CScaFn
  • SaveStringDataToFile() : CDP5Status , CDppWinUSB
  • SaveToIniEx() : CScaFn
  • SCA : CDppConfig
  • sca : CSProfile , CSCommon
  • SCA_SECTION : CScaFn
  • SCACfgParser() : CScaFn
  • SCAEnabled : CSProfile , CSCommon
  • scafn : CSProfile , CSCommon
  • ScaleAuto : CDP5Protocol
  • ScaReadBack : CDppConfig
  • SCASettingsString() : CScaFn
  • SCASetupString() : CScaFn
  • SCAString() : CScaFn
  • SCAStringALL() : CScaFn
  • SCAStringALLDisplay() : CScaFn
  • Scope : CDppConfig , CDP5Protocol
  • SCOPE_DR : DP5_DP4_FORMAT_STATUS
  • ScopeAutoRearm : _DppStateType
  • ScopeBuffer : CvcDP5Dlg
  • ScopeDisplay() : CvcDP5Dlg
  • ScopeOverFlow : _DppStateType
  • ScopeTriggerFalling : CDppConfig
  • ScopeTriggerPosition : CDppConfig
  • sectionExists() : CINI
  • SEL8_5V : CDppConfig
  • SelectRadioDppDeviceType() : CFilePage
  • SendBroadcast() : CSelectDP5
  • SendCoarseFineGain : _CONFIG_OPTIONS , CSProfile
  • SendCommand() : CvcDP5Dlg
  • SendCommandConfig() : CvcDP5Dlg
  • SendCommandData() : CvcDP5Dlg
  • SendDppInfoTextBlock() : CvcDP5Dlg
  • SendManufacturingTextBlock() : CvcDP5Dlg
  • SendPacketInet() : CDppSocket
  • SendPacketRS232() : CDppComm
  • SendPacketUSB() : CDppLibUsb , CDppWinUSB
  • SerialNumber : CDppConfig , DP5_DP4_FORMAT_STATUS , _SpectrumFileType
  • Set80MHzMode() : CDppShaping
  • SetAuxList() : CMiscPage
  • SetBkColor() : CLabel
  • SetBorder() : CLabel
  • SetCboIdxByStr() : CDP5ControlUtil
  • SetCboItem() : CMiscPage , CShapingPage
  • SetCheckBOOL() : CMiscPage
  • SetCheckDP5DxGains() : CFilePage
  • SetCheckPc5Present() : CFilePage
  • SetComPortID() : CSelectDP5
  • SetCursorPosition() : CPlotCanvas
  • SetDataRcvTimer() : CSelectDP5
  • SetDefaultAttr() : CSpectrumAttr
  • SetDetResetValues() : CGainPzPage
  • SetDppDeviceType() : CFilePage
  • SetEventDlg() : CDppSocket
  • SetFastThreshDone : CDppConfig
  • SetFontBold() : CLabel
  • SetFontItalic() : CLabel
  • SetFontName() : CLabel
  • SetFontSize() : CLabel
  • SetFontUnderline() : CLabel
  • SetGain() : CDppSlowThreshold
  • SetHvPowerWarning() : CGainPzPage , CPowerPage
  • SetHVSign() : CPowerPage
  • SetImageList() : cAnimWnd
  • setINIFileName() : CINI
  • SetInputOffsetDone : CDppConfig
  • setKey() : CINI
  • SetLastColor() : CLabel
  • SetLink() : CLabel
  • SetLinkCursor() : CLabel
  • SetMessage() : CMsgBox
  • SetModified() : CSelectDP5
  • SetNotificationWindow() : CWinusbNotify
  • SetNullColor() : CLabel
  • SetPersistenceMode() : CPlotCanvas
  • SetPlotChannel() : CvcDP5Dlg
  • SetRiseCombo() : CDppShaping
  • SetSCAComboIndex() : CMiscPage
  • SetSlowChThreshold() : CDppSlowThreshold
  • SetSlowChThresholdConfigFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromVal() : CDppSlowThreshold
  • SetSlowThreshToChPos() : CTuneSlowThreshold
  • SetStartTime() : CvcDP5Dlg
  • SetSunken() : CLabel
  • SetText() : CLabel
  • SetTextColor() : CLabel
  • Setting : _DP5_CONFIGURATION
  • Settings() : CDppComm
  • SetTopCombo() : CDppShaping
  • Shaping_Setup() : CDppShaping
  • Show() : cWaitDialog
  • ShowMCA8000D_Controls() : CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage
  • ShowStatus() : CvcDP5Dlg
  • ShowStatusValueStrings() : CDP5Status
  • SlowChThreshold : CDppConfig
  • SlowCount : CDppConfig , DP5_DP4_FORMAT_STATUS
  • SlowThresholdPct : CDppConfig
  • SndCmd : CSCommon
  • SockAddr : NETDISPLAY_ENTRY , CSProfile , CSCommon
  • SockAddr_ByteToInAddr() : CNetFinder
  • SockAddr_ByteToStr() : CNetFinder
  • SockAddr_ByteToULong() : CNetFinder
  • SockAddr_DlgToStr() : CNetFinder
  • SockAddr_InAddrToStr() : CNetFinder
  • SockAddr_StrToInAddr() : CNetFinder
  • SockAddr_StrToULong() : CNetFinder
  • SockAddr_ULongToInAddr() : CNetFinder
  • SockAddr_ULongToStr() : CNetFinder
  • SockPort_DlgToUINT() : CNetFinder
  • spectraList : CSCommon
  • SPECTRUM : CDP5Protocol
  • SPECTRUM_OFFSET : DP5_DP4_FORMAT_STATUS
  • SplitData() : CScaFn
  • SRAMTestData : _DiagDataType
  • SRAMTestPass : _DiagDataType
  • StartAnim() : cAnimWnd
  • StartTime : CDppConfig
  • StatDevInd : CDppConfig
  • StatMcaEnabled : CDppConfig
  • STATUS : _Packet_In
  • StopAnim() : cAnimWnd
  • str_description : NETDISPLAY_ENTRY
  • str_display : NETDISPLAY_ENTRY
  • str_ev1 : NETDISPLAY_ENTRY
  • str_ev2 : NETDISPLAY_ENTRY
  • str_type : NETDISPLAY_ENTRY
  • strAnalogOut : CDppConfig
  • strDescription : _SpectrumFileType
  • strDevice : CSProfile
  • strFindCtrl : CDP5ControlUtil
  • strFindIdx : CDP5ControlUtil
  • strFindTab : CDP5ControlUtil
  • strGainDisplayValue : CDppConfig
  • strHelpFilePath : CSCommon
  • stringex() : stringex
  • strIniFilename : CSca
  • strInputOffset : CDppConfig
  • strLowerMiscData : CvcDP5Dlg
  • strMcaMode : CDppConfig
  • strOutputOffset : CDppConfig
  • strPercentDeadTime : CDppConfig
  • strPort : _DppStateType
  • strPresetCmd : CDppConfig
  • strPresetVal : CDppConfig
  • strScopeGain : CDppConfig
  • strSockAddr : CSCommon
  • strSpectrumConfig : _SpectrumFileType
  • strSpectrumStatus : _SpectrumFileType
  • strStartTime : _SpectrumFileType
  • strTag : _SpectrumFileType
  • strTempCal : _DiagDataType
  • strTempRaw : _DiagDataType
  • strTriggerPosition : CDppConfig
  • strTriggerSlope : CDppConfig
  • strTriggerSource : CDppConfig
  • strUpperMiscData : CvcDP5Dlg
  • subnet : NETDISPLAY_ENTRY
  • Sup9VOn : _DiagDataType
  • SUPPLIES_ON : DP5_DP4_FORMAT_STATUS
  • SwConfigRcvd : CDppConfig
  • systemNotes : CSpectrumAttr
  • szSettings : CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • tag : CSpectrumAttr
  • tbBtnMap : CDlgToolBar
  • TEC : CDppConfig
  • TEC_Voltage : DP5_DP4_FORMAT_STATUS
  • TECEnabled : CDppConfig
  • TECMonitor : CDppConfig
  • TECMonitorCStr : CDppConfig
  • TECOn : _DiagDataType
  • TempOffset : _DiagDataType
  • TestPacketCkSumOK() : CSendCommand
  • TextCtrlID : _DP5_CONFIGURATION
  • TextToBlockString() : CvcDP5Dlg
  • TextUpdate() : CPowerPage , CShapingPage , CMiscPage , CGainPzPage , CMcaPage
  • TextValue : _DP5_CONFIGURATION
  • Thresholds_Setup() : CDppSlowThreshold
  • Timeout_flag : CDP5Protocol
  • TimeoutFlag : CvcDP5Dlg
  • TuneFastSlowThresh() : CvcDP5Dlg
  • TxtFileFilter : CFileBrowse
  • txtSlowThreshold_Click() : CDppSlowThreshold
  • txtSlowThresholdChannels_Click() : CDppSlowThreshold
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UC_TEMP_OFFSET : DP5_DP4_FORMAT_STATUS
  • UCHARVersionToDouble() : CDppConfig
  • UDP_offset : CDP5Protocol
  • Units : _DP5_CONFIGURATION
  • UnregDeviceNotification() : CWinusbNotify
  • UpdateAll() : CCfgPropSheet
  • UpdateGainValue() : CGainPzPage
  • UpdateNetfinderIpAddr() : CSelectDP5
  • UpdateNetFinderStatus() : CSelectDP5
  • UpdateOptComboGAIA() : CGainPzPage
  • UpdatePlot() : CvcDP5Dlg
  • UpdatePlotCursorPosFromIntChPos() : CTuneSlowThreshold
  • UpdateSCAControls() : CMiscPage
  • UpdateScope() : CvcDP5Dlg
  • UpdateScopeCfg : CDppConfig
  • UpdateSetting() : CDP5ControlUtil
  • UpdateSettingOsc() : CDP5ControlUtil
  • UpdateSlowThresChDisplay() : CDppSlowThreshold
  • USB_Default_Timeout : CDP5Protocol , CDppWinUSB
  • USBDataRefreshRate : CDppConfig
  • USBStatusString() : CDppWinUSB
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • ValComments : _DP5_CONFIGURATION
  • ValidateTag() : CSpectrumAttr
  • Value : _WINUSB_SETUP_PACKET
  • varValueToIndex() : CScaFn
  • VersionToStr() : CDP5Status
  • VREF_IN : DP5_DP4_FORMAT_STATUS
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WinUsb_Disabled : CDppWinUSB
  • winUSBHandle : WINUSB_DEVICE_INFO
  • WinusbNotify : CSCommon
  • WriteByte() : CDppComm
  • WriteData() : CDppComm
  • WriteTextBlock() : CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • X : _COORD_LONG
  • XPlotMAX : CPlotCanvas , CvcDP5Dlg
  • XR100 : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- y -

  • Y : _COORD_LONG
  • YPlotBuffer : CPlotCanvas
  • YPlotMAX : CPlotCanvas , CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~cAnimWnd() : cAnimWnd
  • ~CAsciiCmdUtilities() : CAsciiCmdUtilities
  • ~CBootOptPage() : CBootOptPage
  • ~CCfgPropPage() : CCfgPropPage
  • ~CDlgStatusBar() : CDlgStatusBar
  • ~CDlgToolBar() : CDlgToolBar
  • ~CDP5CfgWnd() : CDP5CfgWnd
  • ~CDP5ControlUtil() : CDP5ControlUtil
  • ~CDP5Protocol() : CDP5Protocol
  • ~CDP5Status() : CDP5Status
  • ~CDppComm() : CDppComm
  • ~CDppConfig() : CDppConfig
  • ~CDppGain() : CDppGain
  • ~CDppLibUsb() : CDppLibUsb
  • ~CDppShaping() : CDppShaping
  • ~CDppSlowThreshold() : CDppSlowThreshold
  • ~CDppSocket() : CDppSocket
  • ~CDppUtilities() : CDppUtilities
  • ~CDppWinUSB() : CDppWinUSB
  • ~CFileBrowse() : CFileBrowse
  • ~CFilePage() : CFilePage
  • ~CGainPzPage() : CGainPzPage
  • ~CINI() : CINI
  • ~CIniEx() : CIniEx
  • ~CIniUtil() : CIniUtil
  • ~CLabel() : CLabel
  • ~CMcaPage() : CMcaPage
  • ~cMemDC() : cMemDC
  • ~CMiscPage() : CMiscPage
  • ~CMSecTimer() : CMSecTimer
  • ~CMsgBox() : CMsgBox
  • ~CNetFinder() : CNetFinder
  • ~CParsePacket() : CParsePacket
  • ~CPlot() : CPlot
  • ~CPlotCanvas() : CPlotCanvas
  • ~CPowerPage() : CPowerPage
  • ~CSca() : CSca
  • ~CScaFn() : CScaFn
  • ~CSCommon() : CSCommon
  • ~CSendCommand() : CSendCommand
  • ~CShapingPage() : CShapingPage
  • ~CSpectraList() : CSpectraList
  • ~CSpectrum() : CSpectrum
  • ~CSpectrumAttr() : CSpectrumAttr
  • ~CSProfile() : CSProfile
  • ~CTrapKeyComboBox() : CTrapKeyComboBox
  • ~CTrapKeyEdit() : CTrapKeyEdit
  • ~CTuneSlowThreshold() : CTuneSlowThreshold
  • ~CvcDP5Dlg() : CvcDP5Dlg
  • ~cWaitDialog() : cWaitDialog
  • ~cWaitDlgThread() : cWaitDlgThread
  • ~CWinusbNotify() : CWinusbNotify
  • ~stringex() : stringex
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AddEntry() : CNetFinder
  • AddPage() : CCfgPropSheet
  • AddPages() : CDP5CfgWnd
  • AddRoi() : CRoi
  • AlertByteToCOLORREF() : CNetFinder
  • AlertEntryToCOLORREF() : CNetFinder
  • AppendCmdDesc() : CvcDP5Dlg
  • AppendUnitsToSettingString() : CDP5ControlUtil
  • AppendUnitsToString() : CDP5ControlUtil
  • AtChannel() : CRoi
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • BLRQuickSet() : CShapingPage
  • BOOL_TO_bool() : CvcDP5Dlg
  • BuildToolTips() : CMcaPage , CShapingPage , CPowerPage , CMiscPage , CGainPzPage
  • BYTEVersionToDouble() : CDppUtilities
  • BYTEVersionToString() : CDppUtilities
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CAboutDlg() : CAboutDlg
  • CalculateRoiInfo() : CRoi
  • CallReadDppConfig() : CvcDP5Dlg
  • CallReadDppConfigEx() : CvcDP5Dlg
  • CallReadScaConfig() : CvcDP5Dlg
  • cAnimWnd() : cAnimWnd
  • CAsciiCmdUtilities() : CAsciiCmdUtilities
  • CBootOptPage() : CBootOptPage
  • CboTextVis() : CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage
  • CboUpdate() : CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage , CBootOptPage , CFilePage
  • CboUpdateDMCA() : CMcaPage
  • CCfgPropPage() : CCfgPropPage
  • CCfgPropSheet() : CCfgPropSheet
  • CDlgStatusBar() : CDlgStatusBar
  • CDlgToolBar() : CDlgToolBar
  • CDP5CfgWnd() : CDP5CfgWnd
  • CDP5ControlUtil() : CDP5ControlUtil
  • CDP5Protocol() : CDP5Protocol
  • CDP5Status() : CDP5Status
  • CDppComm() : CDppComm
  • CDppConfig() : CDppConfig
  • CDppGain() : CDppGain
  • CDppLibUsb() : CDppLibUsb
  • CDppShaping() : CDppShaping
  • CDppSlowThreshold() : CDppSlowThreshold
  • CDppSocket() : CDppSocket
  • CDppUtilities() : CDppUtilities
  • CDppWinUSB() : CDppWinUSB
  • CFileBrowse() : CFileBrowse
  • CFilePage() : CFilePage
  • CGainPzPage() : CGainPzPage
  • CheckMCA8000D_FineGain() : CGainPzPage
  • CINI() : CINI
  • CIniEx() : CIniEx
  • CIniUtil() : CIniUtil
  • CLabel() : CLabel
  • Clear() : CRoi
  • ClearNetFinderStatus() : CSelectDP5
  • ClearNetFinderStatusAll() : CSelectDP5
  • ClearTrace() : CPlotCanvas
  • Close() : cWaitDialog
  • CloseDeviceHandle() : CDppWinUSB
  • ClosePort() : CDppComm
  • CloseSocket() : CDppSocket
  • CloseUSBDevice() : CDppLibUsb
  • CloseWinUsbDevice() : CDppWinUSB
  • CMcaPage() : CMcaPage
  • cMemDC() : cMemDC
  • CMiscPage() : CMiscPage
  • CMSecTimer() : CMSecTimer
  • CMsgBox() : CMsgBox
  • CNetFinder() : CNetFinder
  • ComPortEnum() : CSelectDP5
  • ConvertCmdListToCString() : CIniUtil
  • ConvertStatusDP5ToDP4() : CvcDP5Dlg
  • CopyAsciiData() : CAsciiCmdUtilities
  • CopyDp5CfgToClip() : CvcDP5Dlg
  • CopyRoi() : CRoi
  • CopyTextToClip() : CSelectDP5 , CvcDP5Dlg
  • CountDP5LibusbDevices() : CDppLibUsb
  • CountDP5WinusbDevices() : CDppWinUSB
  • CParsePacket() : CParsePacket
  • CPlot() : CPlot
  • CPlotCanvas() : CPlotCanvas
  • CPowerPage() : CPowerPage
  • Create() : cAnimWnd
  • CreateDP5Cfg() : CSCommon
  • CreateDTS() : CvcDP5Dlg
  • CreateFullReadBackCmd() : CAsciiCmdUtilities
  • CreateFullReadBackCmdMCA8000D() : CAsciiCmdUtilities
  • CreateMCAData() : CvcDP5Dlg
  • CreateResTestReadBackCmd() : CAsciiCmdUtilities
  • CreateSocket() : CDppSocket
  • CreateSpectrumConfig() : CvcDP5Dlg
  • CreateTextBlockTest() : CvcDP5Dlg
  • CRoi() : CRoi
  • CRoiEntry() : CRoiEntry
  • CSca() : CSca
  • CScaFn() : CScaFn
  • CSCommon() : CSCommon
  • CSelectDP5() : CSelectDP5
  • CSendCommand() : CSendCommand
  • CShapingPage() : CShapingPage
  • CSpectraList() : CSpectraList
  • CSpectrum() : CSpectrum
  • CSpectrumAttr() : CSpectrumAttr
  • CSProfile() : CSProfile
  • CtlColor() : CLabel
  • CTrapKeyComboBox() : CTrapKeyComboBox
  • CTrapKeyEdit() : CTrapKeyEdit
  • CTuneSlowThreshold() : CTuneSlowThreshold
  • CvcDP5App() : CvcDP5App
  • CvcDP5Dlg() : CvcDP5Dlg
  • cWaitDlg() : cWaitDlg
  • cWaitDlgThread() : cWaitDlgThread
  • CWinusbNotify() : CWinusbNotify
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DataAcq() : CPlotCanvas
  • DataTest() : CvcDP5Dlg
  • dbl_to_uS() : CDppShaping
  • DeinitializeLibusb() : CDppLibUsb
  • DelayTask() : CTuneSlowThreshold
  • DeleteDP5Key() : CIniUtil
  • DeleteIniSettingEx() : CScaFn
  • DeleteKey() : CINI
  • DeleteSection() : CINI
  • DestroyWindow() : CSelectDP5
  • DiagnosticsToString() : CDP5Status
  • DiagStrPX5Option() : CDP5Status
  • Disable_WinUsb() : CDppWinUSB
  • DispatchEventEN_CHANGE() : CTrapKeyEdit
  • DisplayBlrMode() : CShapingPage
  • DisplayBufferArray() : CDP5Status , CDppWinUSB
  • DisplayError() : CvcDP5Dlg
  • DisplaySpecBuf25() : CTuneSlowThreshold
  • DoDataExchange() : CPowerPage , cWaitDlg , CvcDP5Dlg , CSelectDP5 , CBootOptPage , CCfgPropPage , CFilePage , CGainPzPage , CMcaPage , CMiscPage , CShapingPage , CMsgBox , CAboutDlg
  • DoModal() : CCfgPropSheet , CDP5CfgWnd , CFileBrowse
  • DP5_CMD() : CSendCommand
  • DP5_CMD_Config() : CSendCommand
  • DP5_CMD_Data() : CSendCommand
  • DP5_Dx_OptionFlags() : CDP5Status
  • DP5CfgCmd() : CSCommon
  • DppCommThread() : CDppComm
  • DppSendConfigToHw() : CvcDP5Dlg
  • DPPThreshold() : CDppSlowThreshold
  • DrawCursor() : CPlotCanvas
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EnableButton() : CDlgToolBar
  • EnableCommFunctions() : CSelectDP5
  • EnableControl() : CMiscPage
  • EnableControls() : CFilePage
  • EnableDeviceSelection() : CFilePage
  • EnableDPPFunctions() : CvcDP5Dlg
  • EnableScaControls() : CMiscPage
  • EntryToStr() : CNetFinder
  • EntryToStrRS232() : CNetFinder
  • EntryToStrUSB() : CNetFinder
  • ExitInstance() : cWaitDlgThread
  • ExtractNote() : CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • FindCboIdx() : CDP5ControlUtil
  • FindCboIdxExact() : CDP5ControlUtil
  • FindEntry() : CNetFinder
  • FindUnitsInString() : CDP5ControlUtil
  • FindUSBDevice() : CDppLibUsb , CDppWinUSB
  • FixTotalGainRange() : CDppGain
  • FixTotalGainRangeDbl() : CDppGain
  • FlashBackground() : CLabel
  • FlashText() : CLabel
  • FmtHex() : CDP5Status
  • FmtHvPwr() : CDP5Status
  • FmtLng() : CDP5Status
  • FmtPc5Pwr() : CDP5Status
  • FmtPc5Temp() : CDP5Status
  • Format() : stringex
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • Get() : CSCommon
  • GetAmptekDC_NP_Section() : CFilePage
  • GetCheckBOOL() : CMiscPage
  • GetCmdChunk() : CAsciiCmdUtilities
  • GetCmdData() : CvcDP5Dlg
  • GetCmdDataMS() : CvcDP5Dlg
  • GetCmdDesc() : CvcDP5Dlg
  • GetCmdDescMS() : CvcDP5Dlg
  • GetCmdKeyData() : CFilePage
  • GetComboIndex() : CMiscPage
  • GetComboValue() : CMiscPage
  • GetCommErrStr() : CDppComm
  • GetComPortID() : CDppComm , CSelectDP5
  • GetCurrentButtonState() : CCfgPropSheet
  • GetDblValFromComboText() : CDppShaping
  • GetDefaultFlatTopFromRiseIndex() : CDppShaping
  • GetDeviceNameFromVal() : CDppConfig , CDP5Status , CSCommon , CvcDP5Dlg
  • GetDevicePath() : CDppWinUSB
  • GetDevNotifyInfo() : CWinusbNotify
  • GetDP5CfgStr() : CAsciiCmdUtilities
  • GetDP5Data() : CIniUtil
  • GetDP5ScaStr() : CAsciiCmdUtilities
  • GetDP5Section() : CIniUtil
  • GetFromIniEx() : CScaFn
  • GetGainCount() : CDppGain
  • GetGainTablePtr() : CDppGain
  • GetImageCount() : cAnimWnd
  • getKeyValue() : CINI
  • GetMsIniItem() : CIniUtil
  • GetNextCMD() : CScaFn
  • GetPixPerChannel() : CvcDP5Dlg
  • GetRiseValueFromIndex() : CDppShaping
  • GetSCASettingsINI() : CScaFn
  • GetSCASetupINI() : CScaFn
  • getSectionData() : CINI
  • getSectionNames() : CINI
  • GetSlowChThreshold() : CDppSlowThreshold
  • GetSlowChThresStrFromVal() : CDppSlowThreshold
  • GetSlowThreshCalStart() : CTuneSlowThreshold
  • GetSlowThreshChStr() : CDppSlowThreshold
  • GetSlowThreshChStrFromVal() : CTuneSlowThreshold , CDppSlowThreshold
  • GetSlowThresholdSettingFromChannels() : CDppSlowThreshold
  • GetSlowThresholdSettingFromPercent() : CDppSlowThreshold
  • GetSlowThreshPcntStr() : CDppSlowThreshold
  • GetSpectrumData() : CTuneSlowThreshold
  • GetStatusBar() : CCfgPropSheet
  • GetStatusValueStrings() : CDP5Status
  • GetToolBar() : CCfgPropSheet
  • GetTotalGainLimitsLabel() : CDppGain
  • GetTotalGainLimitsMax() : CDppGain
  • GetTotalGainLimitsMin() : CDppGain
  • GetUpperChCounts() : CTuneSlowThreshold
  • GetUpperChMax() : CTuneSlowThreshold
  • GetValueWithUnitsString() : CDP5ControlUtil
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • Init_PAPS_Controls() : CPowerPage
  • InitAllEntries() : CNetFinder
  • InitAuxControls() : CMiscPage
  • InitBlrMode() : CShapingPage
  • InitCfgPropSheet() : CCfgPropSheet
  • InitCombo() : CGainPzPage
  • InitComboFromText() : CShapingPage
  • InitControls() : CBootOptPage , CFilePage , CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage
  • InitDeviceInfo() : CWinusbNotify , CDppWinUSB
  • InitDlgItem() : CBootOptPage , CFilePage , CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage
  • InitDlgItemDMCA() : CMcaPage
  • InitEntry() : CNetFinder
  • InitFastPeakCombo() : CShapingPage
  • Initialize_Device() : CDppWinUSB
  • InitializeLibusb() : CDppLibUsb
  • InitInstance() : CvcDP5App , cWaitDlgThread
  • InitSCA() : CScaFn
  • Insert() : CRoi
  • InsertSorted() : CRoi
  • Invalidate() : CPlotCanvas
  • IsAllNumericString() : CDP5ControlUtil
  • isAmptekDP5Device() : CDppLibUsb
  • IsAorB() : CDP5Status
  • isCComboBox() : CGainPzPage , CFilePage , CMcaPage , CPowerPage , CMiscPage , CShapingPage
  • isCEditBox() : CMcaPage , CShapingPage , CMiscPage , CFilePage , CPowerPage , CGainPzPage
  • isConnectedTest() : CvcDP5Dlg
  • isHVSignInString() : CPowerPage
  • isHVSignPositive() : CPowerPage
  • isInTotalGainRange() : CDppGain
  • IsPortOpen() : CDppComm
  • IsSocketOpen() : CDppSocket
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • libusb_strerror() : CDppLibUsb
  • LoadGainTableIndexes() : CDppGain
  • LoadGainTableValues() : CDppGain
  • LoadProfile() : CSCommon
  • LongWordToDouble() : CDppUtilities
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MakeDp5CmdList() : CvcDP5Dlg
  • MakeLower() : stringex
  • MakeUpper() : stringex , CAsciiCmdUtilities
  • MoveCtrl() : CMcaPage
  • MoveCtrlEx() : CMcaPage
  • MovePlot() : CPlot
  • msTimeDiff() : CMSecTimer
  • msTimeExpired() : CMSecTimer
  • msTimer() : CMSecTimer
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OnApply() : CFilePage
  • OnBnClickedBlrquickslowbutton2() : CShapingPage
  • OnBnClickedBtnSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonArmTrigger() : CvcDP5Dlg
  • OnBnClickedButtonAutotune() : CvcDP5Dlg
  • OnBnClickedButtonClearDataAndGraph() : CvcDP5Dlg
  • OnBnClickedButtonClearMiscData() : CvcDP5Dlg
  • OnBnClickedButtonClearRoi() : CvcDP5Dlg
  • OnBnClickedButtonClipboardCopy() : CSelectDP5
  • OnBnClickedButtonCloseDevice() : CSelectDP5
  • OnBnClickedButtonClosePort() : CSelectDP5
  • OnBnClickedButtonCoarseFineToTotal() : CGainPzPage
  • OnBnClickedButtonCountDevices() : CSelectDP5
  • OnBnClickedButtonDiag() : CvcDP5Dlg
  • OnBnClickedButtonEditConfig() : CvcDP5Dlg
  • OnBnClickedButtonEditConfigFromHw() : CFilePage
  • OnBnClickedButtonFindDevice() : CvcDP5Dlg
  • OnBnClickedButtonFindDp5Ip() : CSelectDP5
  • OnBnClickedButtonFindUsbDevice() : CSelectDP5
  • OnBnClickedButtonFineGainEnter() : CGainPzPage
  • OnBnClickedButtonGetSpectrum() : CvcDP5Dlg
  • OnBnClickedButtonIpSelect1() : CSelectDP5
  • OnBnClickedButtonIpSelect2() : CSelectDP5
  • OnBnClickedButtonIpSelect3() : CSelectDP5
  • OnBnClickedButtonIpSelect4() : CSelectDP5
  • OnBnClickedButtonOpenPort() : CSelectDP5
  • OnBnClickedButtonOutputQuickset1() : CMiscPage
  • OnBnClickedButtonOutputQuickset2() : CMiscPage
  • OnBnClickedButtonOutputQuickset3() : CMiscPage
  • OnBnClickedButtonPreviewSca() : CMiscPage
  • OnBnClickedButtonReadConfig() : CFilePage
  • OnBnClickedButtonReadMiscData() : CvcDP5Dlg
  • OnBnClickedButtonRoiEnd() : CvcDP5Dlg
  • OnBnClickedButtonRoiStart() : CvcDP5Dlg
  • OnBnClickedButtonSaveConfig() : CFilePage
  • OnBnClickedButtonSaveFile() : CvcDP5Dlg
  • OnBnClickedButtonScaDefaults() : CMiscPage
  • OnBnClickedButtonSelectComm() : CvcDP5Dlg
  • OnBnClickedButtonSendCommand() : CFilePage
  • OnBnClickedButtonSendCommand2() : CFilePage
  • OnBnClickedButtonSendToHardware() : CFilePage
  • OnBnClickedButtonSendToHardwareNoEdit() : CFilePage
  • OnBnClickedButtonSerialReqData() : CSelectDP5
  • OnBnClickedButtonShowConfig() : CvcDP5Dlg
  • OnBnClickedButtonSingleUpdate() : CvcDP5Dlg
  • OnBnClickedButtonSpectrumRefreshDefault() : CSelectDP5
  • OnBnClickedButtonStartAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonStopAcquisition() : CvcDP5Dlg
  • OnBnClickedButtonTotalToCoarseFine() : CGainPzPage
  • OnBnClickedButtonWriteMiscData() : CvcDP5Dlg
  • OnBnClickedButtonWriteTextBlock() : CvcDP5Dlg
  • OnBnClickedCancel() : CvcDP5Dlg
  • OnBnClickedCheckDP5DxGains() : CFilePage
  • OnBnClickedCheckEnableSca() : CMiscPage
  • OnBnClickedCheckPc5Present() : CFilePage
  • OnBnClickedCheckTypeIpAddress() : CSelectDP5
  • OnBnClickedConnectOK() : CSelectDP5
  • OnBnClickedOk() : CSelectDP5 , CvcDP5Dlg
  • OnBnClickedPresetcountcursorbutton() : CMcaPage
  • OnBnClickedPresetcountroibutton() : CMcaPage
  • OnBnClickedRadioCommtype1() : CSelectDP5
  • OnBnClickedRadioCommtype2() : CSelectDP5
  • OnBnClickedRadioCommtype3() : CSelectDP5
  • OnBnClickedRadioDppDeviceType1() : CFilePage
  • OnBnClickedRadioDppDeviceType2() : CFilePage
  • OnBnClickedRadioDppDeviceType3() : CFilePage
  • OnBnClickedRadioDppDeviceType4() : CFilePage
  • OnBnClickedRadioDppDeviceType5() : CFilePage
  • OnBnClickedRadioDppDeviceType6() : CFilePage
  • OnBnClickedRadioHvSign1() : CPowerPage
  • OnBnClickedRadioHvSign2() : CPowerPage
  • OnBnClickedRadioPlotScaleLinear() : CvcDP5Dlg
  • OnBnClickedRadioPlotScaleLog() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeLine() : CvcDP5Dlg
  • OnBnClickedRadioPlotTypeSolid() : CvcDP5Dlg
  • OnCancel() : CCfgPropSheet , CFilePage , cWaitDlg
  • OnCbnSelchangeComboComport() : CSelectDP5
  • OnCbnSelchangeComboOutputLevel() : CMiscPage
  • OnCbnSelchangeComboScaIndex() : CMiscPage
  • OnCbnSelchangeComboScaPulseWidth() : CMiscPage
  • OnCbnSelchangeOptComboAinp() : CGainPzPage
  • OnCbnSelchangeOptComboAuo1() : CMiscPage
  • OnCbnSelchangeOptComboAuo2() : CMiscPage
  • OnCbnSelchangeOptComboBlrm() : CShapingPage
  • OnCbnSelchangeOptComboBoot() : CPowerPage
  • OnCbnSelchangeOptComboClck() : CShapingPage
  • OnCbnSelchangeOptComboCon1() : CMiscPage
  • OnCbnSelchangeOptComboCon2() : CMiscPage
  • OnCbnSelchangeOptComboCusp() : CShapingPage
  • OnCbnSelchangeOptComboDaco() : CMiscPage
  • OnCbnSelchangeOptComboDmcaGaia() : CMcaPage
  • OnCbnSelchangeOptComboDmcaPure() : CMcaPage
  • OnCbnSelchangeOptComboGaia() : CGainPzPage
  • OnCbnSelchangeOptComboGaia2() : CGainPzPage
  • OnCbnSelchangeOptComboGainSelect() : CGainPzPage
  • OnCbnSelchangeOptComboGate() : CMcaPage
  • OnCbnSelchangeOptComboGped() : CMiscPage
  • OnCbnSelchangeOptComboGpga() : CMiscPage
  • OnCbnSelchangeOptComboGpin() : CMiscPage
  • OnCbnSelchangeOptComboGpmc() : CMiscPage
  • OnCbnSelchangeOptComboGpme() : CMiscPage
  • OnCbnSelchangeOptComboHvse() : CPowerPage
  • OnCbnSelchangeOptComboInof() : CGainPzPage
  • OnCbnSelchangeOptComboMcac() : CMcaPage
  • OnCbnSelchangeOptComboMcae() : CMcaPage
  • OnCbnSelchangeOptComboMcas() : CMcaPage
  • OnCbnSelchangeOptComboPaps() : CPowerPage
  • OnCbnSelchangeOptComboPapz() : CGainPzPage
  • OnCbnSelchangeOptComboPdmd() : CMcaPage
  • OnCbnSelchangeOptComboPrec() : CMcaPage
  • OnCbnSelchangeOptComboPrel() : CMcaPage
  • OnCbnSelchangeOptComboPrer() : CMcaPage
  • OnCbnSelchangeOptComboPret() : CMcaPage
  • OnCbnSelchangeOptComboPure() : CShapingPage
  • OnCbnSelchangeOptComboResc() : CFilePage
  • OnCbnSelchangeOptComboResl() : CGainPzPage
  • OnCbnSelchangeOptComboResl2() : CGainPzPage
  • OnCbnSelchangeOptComboRtde() : CShapingPage
  • OnCbnSelchangeOptComboScoe() : CMiscPage
  • OnCbnSelchangeOptComboScog() : CMiscPage
  • OnCbnSelchangeOptComboScot() : CMiscPage
  • OnCbnSelchangeOptComboSctc() : CShapingPage
  • OnCbnSelchangeOptComboSoff() : CMcaPage
  • OnCbnSelchangeOptComboTecs() : CPowerPage
  • OnCbnSelchangeOptComboTlld() : CMcaPage
  • OnCbnSelchangeOptComboTpfa() : CShapingPage
  • OnCbnSelchangeOptComboTpmo() : CMiscPage
  • OnCbnSelchangeOptComboVolu() : CMiscPage
  • OnCbnSelchangeReaddetectorconfigcombo() : CFilePage
  • OnCbnSelchangeRisecombo() : CShapingPage
  • OnCbnSelchangeTopcombo() : CShapingPage
  • OnCbnSelendokReaddetectorconfigcombo() : CFilePage
  • OnComm() : CSelectDP5 , CvcDP5Dlg
  • OnCommunication() : CSelectDP5 , CvcDP5Dlg
  • OnDeltaposSpinSelectDevice() : CSelectDP5
  • OnDestroy() : CvcDP5Dlg
  • OnDeviceChange() : CvcDP5Dlg
  • OnEnChangeEditHighThreshold() : CMiscPage
  • OnEnChangeEditLowThreshold() : CMiscPage
  • OnEnChangeOptTextAuo1() : CMiscPage
  • OnEnChangeOptTextAuo2() : CMiscPage
  • OnEnChangeOptTextBlrd() : CShapingPage
  • OnEnChangeOptTextBlru() : CShapingPage
  • OnEnChangeOptTextCusp() : CShapingPage
  • OnEnChangeOptTextDacf() : CMiscPage
  • OnEnChangeOptTextDaco() : CMiscPage
  • OnEnChangeOptTextGaif() : CGainPzPage
  • OnEnChangeOptTextGain() : CGainPzPage
  • OnEnChangeOptTextGpin() : CMiscPage
  • OnEnChangeOptTextHvse() : CPowerPage
  • OnEnChangeOptTextInof() : CGainPzPage
  • OnEnChangeOptTextMcsh() : CMcaPage
  • OnEnChangeOptTextMcsl() : CMcaPage
  • OnEnChangeOptTextMcst() : CMcaPage
  • OnEnChangeOptTextPapz() : CGainPzPage
  • OnEnChangeOptTextPrch() : CMcaPage
  • OnEnChangeOptTextPrcl() : CMcaPage
  • OnEnChangeOptTextPrec() : CMcaPage
  • OnEnChangeOptTextPrel() : CMcaPage
  • OnEnChangeOptTextPrer() : CMcaPage
  • OnEnChangeOptTextPret() : CMcaPage
  • OnEnChangeOptTextPure() : CShapingPage
  • OnEnChangeOptTextResl() : CGainPzPage
  • OnEnChangeOptTextRtds() : CShapingPage
  • OnEnChangeOptTextRtdt() : CShapingPage
  • OnEnChangeOptTextSctc() : CShapingPage
  • OnEnChangeOptTextSoff() : CMcaPage
  • OnEnChangeOptTextTecs() : CPowerPage
  • OnEnChangeOptTextTfla() : CShapingPage
  • OnEnChangeOptTextThfa() : CShapingPage
  • OnEnChangeOptTextThsl() : CMcaPage
  • OnEnChangeOptTextTlld() : CMcaPage
  • OnEnChangeOptTextTpea() : CShapingPage
  • OnEnChangeSpectrumRefreshTime() : CSelectDP5
  • OnEnterIdle() : CCfgPropSheet
  • OnEraseBkgnd() : CPlotCanvas
  • OnFileTab() : CCfgPropSheet
  • OnFileTab2() : CCfgPropSheet
  • OnGainPzTab() : CCfgPropSheet
  • OnGainPzTab2() : CCfgPropSheet
  • OnGetDlgCode() : CTrapKeyEdit
  • OnHelp() : CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage , CFilePage
  • OnHelpInfo() : CMiscPage , CPowerPage , CShapingPage , CGainPzPage , CSelectDP5 , CFilePage , CMcaPage
  • OnIdleUpdateCmdUI() : CDlgToolBar , CDlgStatusBar
  • OnInitDialog() : cWaitDlg , CMsgBox , CMcaPage , CBootOptPage , CShapingPage , CSelectDP5 , CDP5CfgWnd , CMiscPage , CPowerPage , CvcDP5Dlg , CFilePage , CGainPzPage
  • OnInitMenuPopup() : CCfgPropSheet
  • OnKeyUp() : CTrapKeyEdit
  • OnKickIdle() : CCfgPropSheet
  • OnKillfocus() : CTrapKeyEdit
  • OnLButtonDown() : CPlotCanvas , CLabel , CvcDP5Dlg
  • OnLButtonUp() : CTrapKeyEdit
  • OnMcaTab() : CCfgPropSheet
  • OnMcaTab2() : CCfgPropSheet
  • OnMenuSelect() : CCfgPropSheet
  • OnMiscTab() : CCfgPropSheet
  • OnMiscTab2() : CCfgPropSheet
  • OnMouseMove() : CCfgPropSheet , CCfgPropPage
  • OnOffStr() : CDP5Status
  • OnOK() : CSelectDP5 , cWaitDlg
  • OnPaint() : cAnimWnd , CvcDP5Dlg , CPlotCanvas
  • OnPopMessageString() : CCfgPropSheet
  • OnPowerTab() : CCfgPropSheet
  • OnPowerTab2() : CCfgPropSheet
  • OnQueryDragIcon() : CvcDP5Dlg
  • OnReceive() : CvcDP5Dlg , CSelectDP5 , CDppSocket
  • OnRefreshBkgnd() : CPlotCanvas
  • OnResetCommunications() : CvcDP5Dlg
  • OnSelectTab() : CCfgPropSheet
  • OnSetActive() : CMiscPage , CShapingPage , CPowerPage , CMcaPage , CGainPzPage , CFilePage , CBootOptPage
  • OnSetCursor() : CLabel
  • OnSetMessageString() : CCfgPropSheet
  • OnSetPageFocus() : CMiscPage
  • OnShapingTab() : CCfgPropSheet
  • OnShapingTab2() : CCfgPropSheet
  • OnStatusBarCheck() : CCfgPropSheet
  • OnStnClickedPlotpicturecontrol() : CvcDP5Dlg
  • OnStnClickedStaticNetfinder1() : CSelectDP5
  • OnStnClickedStaticNetfinder2() : CSelectDP5
  • OnStnClickedStaticNetfinder3() : CSelectDP5
  • OnStnClickedStaticNetfinder4() : CSelectDP5
  • OnStnClickedStaticReadConfig() : CFilePage
  • OnStnClickedStaticSaveConfig() : CFilePage
  • OnSysCommand() : CvcDP5Dlg
  • OnTB1() : CCfgPropSheet
  • OnTimer() : cAnimWnd , CSelectDP5 , CvcDP5Dlg , cWaitDlg , CCfgPropSheet , CLabel , CFilePage
  • OnToolBarCheck() : CCfgPropSheet
  • OnToolTipNotify() : CvcDP5Dlg
  • OnToolTipText() : CCfgPropPage , CCfgPropSheet
  • OnUpdateKeyIndicator() : CCfgPropSheet
  • OnUpdateStatusBarMenu() : CCfgPropSheet
  • OnUpdateToolBarMenu() : CCfgPropSheet
  • OpenDevice() : CDppWinUSB
  • OpenPort() : CDppComm
  • operator->() : cMemDC
  • OrderOut() : CDP5ControlUtil
  • OutputQuickset() : CMiscPage
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • ParsePacket() : CParsePacket
  • ParsePacketEx() : CvcDP5Dlg
  • ParsePacketStatus() : CParsePacket
  • ParsePerformanceNotes() : CvcDP5Dlg
  • ParseTextBlockNotes() : CvcDP5Dlg
  • PID2_TextToString() : CParsePacket
  • PixelToPosition() : CPlot
  • PlotData() : CvcDP5Dlg
  • PlotTrace() : CPlotCanvas
  • PositionToPixel() : CPlot
  • PostNcDestroy() : CCfgPropSheet
  • PosToChannel() : CSpectrum
  • POUT_Buffer() : CSendCommand
  • PreTranslateMessage() : CFilePage , CGainPzPage , CMcaPage , CMiscPage , CPowerPage , CShapingPage , CvcDP5Dlg , CTrapKeyComboBox
  • PrintDevices() : CDppLibUsb
  • Process_Diagnostics() : CDP5Status
  • Process_Status() : CDP5Status
  • ProcessAck() : CvcDP5Dlg
  • ProcessCfgReadEx() : CvcDP5Dlg
  • ProcessDiagDataEx() : CvcDP5Dlg
  • ProcessScopeDataEx() : CvcDP5Dlg
  • ProcessSpectrumEx() : CvcDP5Dlg
  • ProcessStatusEx() : CvcDP5Dlg
  • ProcessTextDataEx() : CvcDP5Dlg
  • ProcessUSBData() : CDppConfig
  • Put() : CSCommon
  • PX5_OptionsString() : CDP5Status
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • ReadAmptekDetectorConfigNames() : CFilePage
  • ReadConfig() : CFilePage
  • ReadConfigFromAmptek_NP() : CFilePage
  • ReadSCASetting() : CScaFn
  • ReceiveByte() : CDppComm
  • ReceivePacket() : CSelectDP5
  • ReconstructFont() : CLabel
  • RegDeviceNotification() : CWinusbNotify
  • RemCallParsePacket() : CvcDP5Dlg
  • Remove() : CRoi
  • Remove_MCA8000D_Cmds() : CAsciiCmdUtilities
  • RemoveCmd() : CAsciiCmdUtilities
  • RemoveCmdByDeviceType() : CAsciiCmdUtilities
  • RemoveCmdByDeviceTypeDP5DxK() : CAsciiCmdUtilities
  • RemoveDeviceNotification() : CWinusbNotify
  • RemoveUnitsFromDecString() : CDP5ControlUtil
  • RemWhitespace() : CAsciiCmdUtilities
  • ReplaceCmdDesc() : CvcDP5Dlg
  • ReplaceCmdDescMS() : CvcDP5Dlg
  • ReplaceCmdText() : CAsciiCmdUtilities
  • ReqDataStatus() : CSelectDP5
  • ReqDataStatusSock() : CSelectDP5
  • RequestScopeData() : CvcDP5Dlg
  • ResetEventDlg() : CDppSocket
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • SaveConfigString() : CFilePage
  • SaveDP5Data() : CIniUtil
  • SaveMCAFile() : CvcDP5Dlg
  • SaveProfile() : CSCommon
  • SaveSCASettingsINI() : CScaFn
  • SaveSCASetupINI() : CScaFn
  • SaveStringDataToFile() : CDppWinUSB , CDP5Status
  • SaveToIniEx() : CScaFn
  • SCACfgParser() : CScaFn
  • SCASettingsString() : CScaFn
  • SCASetupString() : CScaFn
  • SCAString() : CScaFn
  • SCAStringALL() : CScaFn
  • SCAStringALLDisplay() : CScaFn
  • ScopeDisplay() : CvcDP5Dlg
  • sectionExists() : CINI
  • SelectRadioDppDeviceType() : CFilePage
  • SendBroadcast() : CSelectDP5
  • SendCommand() : CvcDP5Dlg
  • SendCommandConfig() : CvcDP5Dlg
  • SendCommandData() : CvcDP5Dlg
  • SendDppInfoTextBlock() : CvcDP5Dlg
  • SendManufacturingTextBlock() : CvcDP5Dlg
  • SendPacketInet() : CDppSocket
  • SendPacketRS232() : CDppComm
  • SendPacketUSB() : CDppLibUsb , CDppWinUSB
  • Set80MHzMode() : CDppShaping
  • SetAuxList() : CMiscPage
  • SetBkColor() : CLabel
  • SetBorder() : CLabel
  • SetCboIdxByStr() : CDP5ControlUtil
  • SetCboItem() : CMiscPage , CShapingPage
  • SetCheckBOOL() : CMiscPage
  • SetCheckDP5DxGains() : CFilePage
  • SetCheckPc5Present() : CFilePage
  • SetComPortID() : CSelectDP5
  • SetCursorPosition() : CPlotCanvas
  • SetDataRcvTimer() : CSelectDP5
  • SetDefaultAttr() : CSpectrumAttr
  • SetDetResetValues() : CGainPzPage
  • SetDppDeviceType() : CFilePage
  • SetEventDlg() : CDppSocket
  • SetFontBold() : CLabel
  • SetFontItalic() : CLabel
  • SetFontName() : CLabel
  • SetFontSize() : CLabel
  • SetFontUnderline() : CLabel
  • SetGain() : CDppSlowThreshold
  • SetHvPowerWarning() : CGainPzPage , CPowerPage
  • SetHVSign() : CPowerPage
  • SetImageList() : cAnimWnd
  • setINIFileName() : CINI
  • setKey() : CINI
  • SetLastColor() : CLabel
  • SetLink() : CLabel
  • SetLinkCursor() : CLabel
  • SetMessage() : CMsgBox
  • SetModified() : CSelectDP5
  • SetNotificationWindow() : CWinusbNotify
  • SetNullColor() : CLabel
  • SetPersistenceMode() : CPlotCanvas
  • SetPlotChannel() : CvcDP5Dlg
  • SetRiseCombo() : CDppShaping
  • SetSCAComboIndex() : CMiscPage
  • SetSlowChThreshold() : CDppSlowThreshold
  • SetSlowChThresholdConfigFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromStr() : CDppSlowThreshold
  • SetSlowChThresholdFromVal() : CDppSlowThreshold
  • SetSlowThreshToChPos() : CTuneSlowThreshold
  • SetStartTime() : CvcDP5Dlg
  • SetSunken() : CLabel
  • SetText() : CLabel
  • SetTextColor() : CLabel
  • Settings() : CDppComm
  • SetTopCombo() : CDppShaping
  • Shaping_Setup() : CDppShaping
  • Show() : cWaitDialog
  • ShowMCA8000D_Controls() : CGainPzPage , CPowerPage , CMiscPage , CMcaPage , CShapingPage
  • ShowStatus() : CvcDP5Dlg
  • ShowStatusValueStrings() : CDP5Status
  • SockAddr_ByteToInAddr() : CNetFinder
  • SockAddr_ByteToStr() : CNetFinder
  • SockAddr_ByteToULong() : CNetFinder
  • SockAddr_DlgToStr() : CNetFinder
  • SockAddr_InAddrToStr() : CNetFinder
  • SockAddr_StrToInAddr() : CNetFinder
  • SockAddr_StrToULong() : CNetFinder
  • SockAddr_ULongToInAddr() : CNetFinder
  • SockAddr_ULongToStr() : CNetFinder
  • SockPort_DlgToUINT() : CNetFinder
  • SplitData() : CScaFn
  • StartAnim() : cAnimWnd
  • StopAnim() : cAnimWnd
  • stringex() : stringex
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • TestPacketCkSumOK() : CSendCommand
  • TextToBlockString() : CvcDP5Dlg
  • TextUpdate() : CMcaPage , CMiscPage , CGainPzPage , CShapingPage , CPowerPage
  • Thresholds_Setup() : CDppSlowThreshold
  • TuneFastSlowThresh() : CvcDP5Dlg
  • txtSlowThreshold_Click() : CDppSlowThreshold
  • txtSlowThresholdChannels_Click() : CDppSlowThreshold
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • UCHARVersionToDouble() : CDppConfig
  • UnregDeviceNotification() : CWinusbNotify
  • UpdateAll() : CCfgPropSheet
  • UpdateGainValue() : CGainPzPage
  • UpdateNetfinderIpAddr() : CSelectDP5
  • UpdateNetFinderStatus() : CSelectDP5
  • UpdateOptComboGAIA() : CGainPzPage
  • UpdatePlot() : CvcDP5Dlg
  • UpdatePlotCursorPosFromIntChPos() : CTuneSlowThreshold
  • UpdateSCAControls() : CMiscPage
  • UpdateScope() : CvcDP5Dlg
  • UpdateSetting() : CDP5ControlUtil
  • UpdateSettingOsc() : CDP5ControlUtil
  • UpdateSlowThresChDisplay() : CDppSlowThreshold
  • USBStatusString() : CDppWinUSB
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • ValidateTag() : CSpectrumAttr
  • varValueToIndex() : CScaFn
  • VersionToStr() : CDP5Status
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WriteByte() : CDppComm
  • WriteData() : CDppComm
  • WriteTextBlock() : CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~cAnimWnd() : cAnimWnd
  • ~CAsciiCmdUtilities() : CAsciiCmdUtilities
  • ~CBootOptPage() : CBootOptPage
  • ~CCfgPropPage() : CCfgPropPage
  • ~CDlgStatusBar() : CDlgStatusBar
  • ~CDlgToolBar() : CDlgToolBar
  • ~CDP5CfgWnd() : CDP5CfgWnd
  • ~CDP5ControlUtil() : CDP5ControlUtil
  • ~CDP5Protocol() : CDP5Protocol
  • ~CDP5Status() : CDP5Status
  • ~CDppComm() : CDppComm
  • ~CDppConfig() : CDppConfig
  • ~CDppGain() : CDppGain
  • ~CDppLibUsb() : CDppLibUsb
  • ~CDppShaping() : CDppShaping
  • ~CDppSlowThreshold() : CDppSlowThreshold
  • ~CDppSocket() : CDppSocket
  • ~CDppUtilities() : CDppUtilities
  • ~CDppWinUSB() : CDppWinUSB
  • ~CFileBrowse() : CFileBrowse
  • ~CFilePage() : CFilePage
  • ~CGainPzPage() : CGainPzPage
  • ~CINI() : CINI
  • ~CIniEx() : CIniEx
  • ~CIniUtil() : CIniUtil
  • ~CLabel() : CLabel
  • ~CMcaPage() : CMcaPage
  • ~cMemDC() : cMemDC
  • ~CMiscPage() : CMiscPage
  • ~CMSecTimer() : CMSecTimer
  • ~CMsgBox() : CMsgBox
  • ~CNetFinder() : CNetFinder
  • ~CParsePacket() : CParsePacket
  • ~CPlot() : CPlot
  • ~CPlotCanvas() : CPlotCanvas
  • ~CPowerPage() : CPowerPage
  • ~CSca() : CSca
  • ~CScaFn() : CScaFn
  • ~CSCommon() : CSCommon
  • ~CSendCommand() : CSendCommand
  • ~CShapingPage() : CShapingPage
  • ~CSpectraList() : CSpectraList
  • ~CSpectrum() : CSpectrum
  • ~CSpectrumAttr() : CSpectrumAttr
  • ~CSProfile() : CSProfile
  • ~CTrapKeyComboBox() : CTrapKeyComboBox
  • ~CTrapKeyEdit() : CTrapKeyEdit
  • ~CTuneSlowThreshold() : CTuneSlowThreshold
  • ~CvcDP5Dlg() : CvcDP5Dlg
  • ~cWaitDialog() : cWaitDialog
  • ~cWaitDlgThread() : cWaitDlgThread
  • ~CWinusbNotify() : CWinusbNotify
  • ~stringex() : stringex
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • AccumulationTime : CDppConfig , DP5_DP4_FORMAT_STATUS
  • ACK_Received : CDP5Protocol
  • AcqMode : CDppConfig
  • ActivePage : CCfgPropSheet
  • ADC_GAIN_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_OFFSET_CAL : DP5_DP4_FORMAT_STATUS
  • ADC_V : _DiagDataType
  • AFAST_LOCKED : DP5_DP4_FORMAT_STATUS
  • alert_level : NETDISPLAY_ENTRY
  • AllFileFilter : CFileBrowse
  • AN_IN : DP5_DP4_FORMAT_STATUS
  • AOFFSET_LOCKED : DP5_DP4_FORMAT_STATUS
  • AsciiCmdUtil : CSendCommand
  • AU34_2 : DP5_DP4_FORMAT_STATUS
  • AuxOut : CDppConfig
  • Avg : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • b80MHzMode : CDppConfig , CDppShaping , DP5_DP4_FORMAT_STATUS
  • b80MHzModeCfg : CDppConfig
  • b80MHzModeCfg_old : CShapingPage
  • bAnalogPolarity : CDppConfig
  • bAppendUnits : _DP5_CONFIGURATION
  • BaselineOn : CDppConfig
  • baud_rate : CSProfile , CSCommon
  • bb_BootFlags : CDppConfig
  • bb_DeadTimeCounter : CDppConfig
  • bb_DiodeCalDACSet : CDppConfig
  • bb_HVDACSet : CDppConfig
  • bb_InputOffsetTuning : CDppConfig
  • bb_SpectrumOffset : CDppConfig
  • bb_TECCurrentLimit : CDppConfig
  • bb_TECDACSet : CDppConfig
  • bb_uCTempCal : CDppConfig
  • bBootHVPolarity : CDppConfig
  • bConfigHVPolarity : CDppConfig
  • bDeviceConnected : CDppLibUsb
  • bDeviceReady : CDppLibUsb
  • bEnableNewRESL : CGainPzPage
  • bFPGAAutoClock : CDppConfig , DP5_DP4_FORMAT_STATUS
  • bGammaRadHVMode : CDppConfig
  • bLibusbReady : CDppLibUsb
  • BLR : CDppConfig
  • BmpFileFilter : CFileBrowse
  • BoardTemp : CDppConfig
  • BoardTempCStr : CDppConfig
  • BootStatus : CDppConfig
  • bPC5Detected : CDppConfig
  • bScintHas80MHzOption : DP5_DP4_FORMAT_STATUS
  • bTypeInIPAddress : CSelectDP5
  • BufferOUT : CDP5Protocol
  • BufferSelect : CDppConfig
  • Build : DP5_DP4_FORMAT_STATUS , CDppConfig
  • bulkInPipe : WINUSB_DEVICE_INFO
  • bulkOutPipe : WINUSB_DEVICE_INFO
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • cboComPort : CSelectDP5
  • ccConnectRGB : NETDISPLAY_ENTRY
  • CFG_SECTION : CScaFn
  • CfgFileFilter : CFileBrowse
  • CfgModCount : CDppConfig
  • CfgReadBack : CDppConfig
  • CHANNELS : Spec
  • CheckSum : _Packet_In
  • ComboIndex : _DP5_CONFIGURATION
  • ComboValue : _DP5_CONFIGURATION
  • Command : _DP5_CONFIGURATION
  • Comments : _DP5_CONFIGURATION
  • CommError : CDP5Protocol
  • ComPort : CSProfile , CSCommon
  • contourColor : CSpectrumAttr
  • contourWidth : CSpectrumAttr
  • CtrlGroup : _DP5_CONFIGURATION
  • CtrlType : _DP5_CONFIGURATION
  • CtrlUtil : CSCommon
  • CurIndex : CSca
  • CurrentChannel : CvcDP5Dlg
  • CurrentDevice : CDppLibUsb , CDppWinUSB
  • CurrentInterface : CSCommon , CSProfile
  • CursorPosition : CPlotCanvas , CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • DAC : CDppConfig
  • DAC_Enable : CDppConfig
  • DATA : Packet_Out , Spec , _Packet_In
  • data_in : CDppLibUsb
  • data_out : CDppLibUsb
  • data_refresh : CSProfile
  • DataIn : CSelectDP5
  • dblConfigHV : CDppConfig
  • dblGAIF_Max : CGainPzPage
  • dblGAIF_Min : CGainPzPage
  • dblPeakingMult : CDppShaping
  • DCAL : DP5_DP4_FORMAT_STATUS
  • DCal : CDppConfig
  • description : CSpectrumAttr
  • Description : _DP5_CONFIGURATION
  • DET_TEMP : DP5_DP4_FORMAT_STATUS
  • DetReset : CDppConfig
  • DEVICE_ID : DP5_DP4_FORMAT_STATUS
  • device_type : CSProfile
  • deviceConnected : WINUSB_DEVICE_INFO
  • deviceHandle : WINUSB_DEVICE_INFO
  • DeviceNotificationHandle : CWinusbNotify
  • devicePath : WINUSB_DEVICE_INFO
  • deviceSpeed : WINUSB_DEVICE_INFO
  • DeviceType : CDppConfig
  • devInfo : CDppWinUSB
  • DiagData : _DiagDataType , CDP5Status
  • DisplayCfg : CDppConfig
  • DisplaySca : CDppConfig
  • DP5_CONFIGURED : DP5_DP4_FORMAT_STATUS
  • DP5_TEMP : DP5_DP4_FORMAT_STATUS
  • Dp5CmdList : CSCommon , CvcDP5Dlg
  • DP5Proto : CSCommon
  • DP5Stat : CSCommon
  • DPP_ECO : DP5_DP4_FORMAT_STATUS , _CONFIG_OPTIONS
  • DPP_options : DP5_DP4_FORMAT_STATUS
  • DppAddr : CDppSocket
  • DppCommStatusInd : CSCommon
  • DppCommStatusIndOld : CSCommon
  • DppConfig : CSCommon
  • DppEntries : CNetFinder
  • DppEntryIdx : CNetFinder
  • DppFound : CNetFinder
  • DppGain : CGainPzPage
  • DppLibusbHandle : CDppLibUsb
  • DppPort : CDppSocket
  • DppSockAddr : CNetFinder
  • DppState : CParsePacket
  • DppType : _CONFIG_OPTIONS
  • DppUtil : CDP5Status
  • DppWinUSB : CSCommon
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • event1_days : NETDISPLAY_ENTRY
  • event1_hours : NETDISPLAY_ENTRY
  • event1_minutes : NETDISPLAY_ENTRY
  • event1_seconds : NETDISPLAY_ENTRY
  • event2_days : NETDISPLAY_ENTRY
  • event2_hours : NETDISPLAY_ENTRY
  • event2_minutes : NETDISPLAY_ENTRY
  • event2_seconds : NETDISPLAY_ENTRY
  • ExeFileFilter : CFileBrowse
  • EXPECTEDRESPONSE : Packet_Out
  • expressionText : CSpectrumAttr
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • FastChThreshold : CDppConfig
  • FastCount : CDppConfig , DP5_DP4_FORMAT_STATUS
  • file : CSpectrumAttr
  • FindCommand : CSCommon
  • FindCtrlID : CSCommon
  • FindDpp : CSelectDP5
  • FindDppRS232 : CSelectDP5
  • FindDppUSB : CSelectDP5
  • Firmware : DP5_DP4_FORMAT_STATUS , CDppConfig , _DiagDataType
  • FlatTop : CDppConfig
  • FlatTopUS : CDppConfig
  • FPGA : _DiagDataType , DP5_DP4_FORMAT_STATUS , CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • Gain : CDppConfig
  • GainDelta : CDppConfig
  • gainIndex : CSpectrumAttr
  • GainTable : CDppGain
  • GainTableCount : CDppGain
  • Gate : CDppConfig
  • gateway : NETDISPLAY_ENTRY
  • generalNotes : CSpectrumAttr
  • ghThreadExitEvent : CDppComm
  • GP_COUNTER : DP5_DP4_FORMAT_STATUS
  • GPCount : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • hasBackground : CPlotCanvas
  • HasData : NETDISPLAY_ENTRY
  • HaveConfig : CSCommon
  • HaveCurIndex : CSca
  • HaveHeader : CDppSocket
  • HavePlot : CvcDP5Dlg
  • HaveScaUpdate : CSca
  • HaveScopeData : _DppStateType
  • HaveTrace : CvcDP5Dlg
  • High : CSca
  • HPGe_HV_INH : DP5_DP4_FORMAT_STATUS
  • HPGe_HV_INH_POL : DP5_DP4_FORMAT_STATUS
  • HV : CDppConfig , DP5_DP4_FORMAT_STATUS
  • HVEnabled : CDppConfig
  • HVMonitor : CDppConfig
  • HVMonitorCStr : CDppConfig
  • HVOn : _DiagDataType
  • HVRangeInd : CDppConfig
  • HwCfgDP5 : CSCommon
  • HwCfgDP5Out : CSCommon , _CONFIG_OPTIONS
  • HwCfgExReady : CSCommon
  • HwCfgFromDLG : CDppConfig
  • HwCfgReady : CSCommon
  • hWnd_Main : CSCommon
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • IndBuzzer : CDppConfig
  • Index : _WINUSB_SETUP_PACKET , CSca
  • IndLED : CDppConfig
  • ini : CIniUtil
  • InPacketType : CDP5Protocol
  • Interface : _DppStateType
  • interruptPipe : WINUSB_DEVICE_INFO
  • Interval : _WINUSB_PIPE_INFORMATION
  • InvertEn : CDppConfig
  • ip : NETDISPLAY_ENTRY
  • IpSelectAddr : CSelectDP5
  • IpSelectBtn : CSelectDP5
  • Is8_5VPreAmp : _DiagDataType
  • isAscEnabled : DP5_DP4_FORMAT_STATUS
  • isAscInstalled : DP5_DP4_FORMAT_STATUS
  • isCfgChanged : CDppConfig
  • isClosing : CFilePage
  • isDeltaMode : CDppConfig
  • isDMcaControls : CMcaPage
  • isDP5_RevDxGains : DP5_DP4_FORMAT_STATUS , _CONFIG_OPTIONS
  • isDPP5 : CDppConfig
  • isDppConnected : CSCommon
  • isDppFound : CSCommon , CDppWinUSB
  • isEnterKey : CTrapKeyComboBox , CTrapKeyEdit
  • isExpression : CSpectrumAttr
  • isLButton : CTrapKeyComboBox , CTrapKeyEdit
  • isPlotLine : CSCommon
  • IsPosHV : _DiagDataType
  • isPresetAcq : CDppConfig
  • isScaleLog : CSCommon
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • LastBkColor : CLabel
  • LastEntry : CNetFinder
  • LastLibUsbError : CDppLibUsb
  • LastTextColor : CLabel
  • lblDppFound : CSelectDP5
  • lblFPGAClk : CShapingPage
  • lblMiscStatus : CvcDP5Dlg
  • lblNetFinder : CSelectDP5
  • lblSelectCommunications : CvcDP5Dlg
  • lblStatus : CvcDP5Dlg
  • LEN : _Packet_In , Packet_Out
  • Length : _WINUSB_SETUP_PACKET
  • LibFileFilter : CFileBrowse
  • Limits : _DP5_CONFIGURATION
  • ListCtrlID : _DP5_CONFIGURATION
  • LiveTime : CDppConfig , DP5_DP4_FORMAT_STATUS
  • LoadingCfg : CDP5ControlUtil
  • LoadRestartFastThresh : CDppConfig
  • LoadRestartInProgress : CDppConfig
  • LoadRestartInputOffset : CDppConfig
  • LoadRestartInputOffsetSlow : CDppConfig
  • LoadRestartSlowThresh : CDppConfig
  • LoadRestartStatus : CDppConfig
  • Low : CSca
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • m_Anim : cWaitDlg
  • m_attr : CSpectrum
  • m_bFocusFlag : CTrapKeyEdit
  • m_Bitmap : cAnimWnd
  • m_bKillItself : CCfgPropSheet
  • m_bLink : CLabel
  • m_bMenu : CCfgPropSheet
  • m_bModal : CCfgPropSheet , CDP5CfgWnd
  • m_bModified : CSelectDP5
  • m_BootOptPageLabel : CBootOptPage
  • m_bResetPrompt : CCfgPropSheet
  • m_bShowCancelButton : cWaitDialog , cWaitDlg , cWaitDlgThread
  • m_bState : CLabel
  • m_bStatusBar : CCfgPropSheet
  • m_bThreadRunning : CDppComm
  • m_bTimer : CLabel
  • m_bToolBar : CCfgPropSheet
  • m_bToolTips : CCfgPropSheet
  • m_centroid : CRoiEntry
  • m_CoarseGain_GAIA_index : CGainPzPage
  • m_CoarseGain_GAIA_value : CGainPzPage
  • m_CommTimeouts : CDppComm
  • m_count : CRoi
  • m_crCursorColor : CPlotCanvas
  • m_crDisplayBGColor : CPlotCanvas
  • m_crPlotColor : CPlotCanvas
  • m_crText : CLabel
  • m_crTextBGColor : CPlotCanvas
  • m_crTextFGColor : CPlotCanvas
  • m_CSBCtrlStatus : CCfgPropSheet
  • m_csCommunicationSync : CDppComm
  • m_CSToolBar : CCfgPropSheet
  • m_currentSpectrum : CSpectraList
  • m_DataMode : CDppSocket
  • m_dcb : CDppComm
  • m_DP5_Status : CDP5Status , CSelectDP5
  • m_DP5Cfg : CSCommon
  • m_DppPort : CSCommon
  • m_DppSck : CSCommon
  • m_dwCommEvents : CDppComm
  • m_end : CRoiEntry
  • m_Event : cWaitDialog , cWaitDlgThread
  • m_EventName : cWaitDialog
  • m_Eventname : cWaitDlgThread
  • m_FastPeakCombo : CShapingPage
  • m_FileAdvancedLabel : CFilePage
  • m_FilePage : CDP5CfgWnd
  • m_FilePageLabel : CFilePage
  • m_FileStandardLabel : CFilePage
  • m_font : CLabel
  • m_fwhm : CRoiEntry
  • m_GainAdvancedLabel : CGainPzPage
  • m_GainPzPage : CDP5CfgWnd
  • m_GainPzPageLabel : CGainPzPage
  • m_GainStandardLabel : CGainPzPage
  • m_hBrush : CLabel
  • m_hCursor : CLabel
  • m_hDppComm : CDppComm
  • m_Height : cAnimWnd
  • m_hEvents : CDppComm
  • m_hIcon : CvcDP5Dlg
  • m_hwndBrush : CLabel
  • m_hWndOwner : CWinusbNotify
  • m_hWriteEvent : CDppComm
  • m_ImageIndex : cAnimWnd
  • m_iNumChan : _SpectrumFileType
  • m_leftWidth : CRoiEntry
  • m_lf : CLabel
  • m_max : CRoiEntry
  • m_McaAdvancedLabel : CMcaPage
  • m_McaPage : CDP5CfgWnd
  • m_McaPageLabel : CMcaPage
  • m_McaStandardLabel : CMcaPage
  • m_MemDC : cAnimWnd
  • m_MiscAdvancedLabel : CMiscPage
  • m_MiscPage : CDP5CfgWnd
  • m_MiscPageLabel : CMiscPage
  • m_MiscQuicksetLabel : CMiscPage
  • m_net : CRoiEntry
  • m_nIDLastMessage : CCfgPropSheet
  • m_nIDTracking : CCfgPropSheet
  • m_nTmrConfigElapse : CFilePage
  • m_nTmrConfigEventId : CFilePage
  • m_nTmrConfigId : CFilePage
  • m_nTmrRS232Elapse : CSelectDP5 , CvcDP5Dlg
  • m_nTmrRS232EventId : CSelectDP5 , CvcDP5Dlg
  • m_nTmrRS232Id : CSelectDP5 , CvcDP5Dlg
  • m_nTmrSpectrumElapse : CvcDP5Dlg
  • m_nTmrSpectrumEventId : CvcDP5Dlg
  • m_nTmrSpectrumId : CvcDP5Dlg
  • m_nTmrTimeoutElapse : CvcDP5Dlg
  • m_nTmrTimeoutEventId : CvcDP5Dlg
  • m_nTmrTimeoutId : CvcDP5Dlg
  • m_nWriteBufferSize : CDppComm
  • m_Owner : CDppSocket
  • m_pEvtDlg : CDppSocket
  • m_PicturePlot : CvcDP5Dlg
  • m_PictureScope : CvcDP5Dlg
  • m_plot : CSCommon
  • m_PowerAdvancedLabel : CPowerPage
  • m_PowerHvSign1 : CPowerPage
  • m_PowerHvSign2 : CPowerPage
  • m_PowerHvWarning : CGainPzPage , CPowerPage
  • m_PowerPage : CDP5CfgWnd
  • m_PowerPageLabel : CPowerPage
  • m_PowerStandardLabel : CPowerPage
  • m_pOwner : CDppComm
  • m_PrevOwner : CSelectDP5
  • m_rand : CNetFinder
  • m_ReadDetectorConfigCombo : CFilePage
  • m_rightWidth : CRoiEntry
  • m_RiseCombo : CShapingPage
  • m_roi : CSpectrum
  • m_selectIndex : CRoi
  • m_ShapingAdvancedLabel : CShapingPage
  • m_ShapingPage : CDP5CfgWnd
  • m_ShapingPageLabel : CShapingPage
  • m_ShapingStandardLabel : CShapingPage
  • m_SocketOpen : CDppSocket
  • m_Spectrum : CSCommon
  • m_SpectrumRefreshTimeCtrl : CSelectDP5
  • m_SpinSelectDevice : CSelectDP5
  • m_start : CRoiEntry
  • m_status : CRoiEntry
  • m_strConfigIn : CFilePage
  • m_strConfigOut : CFilePage
  • m_strDelimiter : CMsgBox
  • m_strMessage : CMsgBox
  • m_strText : CLabel
  • m_strTitle : CMsgBox
  • m_szWriteBuffer : CDppComm
  • m_Text : cWaitDialog , cWaitDlg , cWaitDlgThread
  • m_Thread : cWaitDialog , cWaitDlg
  • m_Timer : CCfgPropSheet
  • m_ToolTip : CFilePage , CPowerPage , CMcaPage , CMiscPage , CGainPzPage , CSelectDP5 , CShapingPage
  • m_TopCombo : CShapingPage
  • m_total : CRoiEntry
  • m_TransparentColor : cAnimWnd
  • m_Type : CLabel
  • m_TypeInIPAddressCheck : CSelectDP5
  • m_uncertainty : CRoiEntry
  • m_Width : cAnimWnd
  • m_WinThread : CDppComm
  • m_xCursorData : CPlot
  • m_xCursorPos : CPlot
  • m_xMax : CPlot
  • m_xMin : CPlot
  • m_xPixels : CPlot
  • m_yCursorPos : CPlot
  • m_yMax : CPlot
  • m_yMin : CPlot
  • m_yPixels : CPlot
  • mac : NETDISPLAY_ENTRY
  • MaxGain : CDppGain
  • MaximumPacketSize : _WINUSB_PIPE_INFORMATION
  • MCA : CDppConfig
  • MCA_EN : DP5_DP4_FORMAT_STATUS
  • mcaCH : CDppConfig
  • MCAEnable : CDppConfig
  • McaFileFilter : CFileBrowse
  • MCS_DONE : DP5_DP4_FORMAT_STATUS
  • MCSDone : CDppConfig
  • MCSEnable : CDppConfig
  • MCSTimebase : CDppConfig
  • MinGain : CDppGain
  • MiscData : CDP5Protocol
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • NavPanelUpdate : CDppConfig
  • NeedsDP5ReBoot : CDppConfig
  • Netfinder_active : CDP5Protocol
  • Netfinder_Seq : CDP5Protocol
  • NetfinderActive : CSCommon
  • notesNotes : CSpectrumAttr
  • NullBkColor : CLabel
  • NullSet : CLabel
  • NullTextColor : CLabel
  • NumDevices : CDppLibUsb , CDppWinUSB
  • NumPipes : CDppWinUSB
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • Offset : CDppConfig
  • OldCursorPosition : CPlotCanvas
  • OldPlotCursor : CPlotCanvas
  • OptPlotType : CPlotCanvas
  • OptScaleType : CPlotCanvas
  • osIO : CDppComm
  • Output : CSca
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • Packet_Received : CDP5Protocol
  • PacketIn : CDP5Protocol
  • ParsePkt : CSCommon
  • PC5_8_5V : DP5_DP4_FORMAT_STATUS
  • PC5_HV_POL : DP5_DP4_FORMAT_STATUS
  • PC5_PRESENT : _CONFIG_OPTIONS , DP5_DP4_FORMAT_STATUS , _DiagDataType
  • PC5_SN : DP5_DP4_FORMAT_STATUS , _DiagDataType
  • PC5_V : _DiagDataType
  • PC5DCAL : _DiagDataType
  • PC5Initialized : _DiagDataType
  • PersistenceMode : CPlotCanvas
  • PID1 : Packet_Out , _Packet_In
  • PID2 : _Packet_In , Packet_Out
  • PIN : CDP5Protocol
  • PipeId : CDppWinUSB , _WINUSB_PIPE_INFORMATION
  • PipeTimeout : CDppWinUSB
  • PipeType : _WINUSB_PIPE_INFORMATION
  • plot : CSCommon
  • PlotBuffer : CvcDP5Dlg
  • PlotCursor : CPlotCanvas
  • PoleZero : CDppConfig
  • Port : CDppConfig
  • port : NETDISPLAY_ENTRY
  • PortIDSetting : CDppComm
  • PortIsOpen : CDppComm
  • PreAmpON : _DiagDataType
  • PRECNT_REACHED : DP5_DP4_FORMAT_STATUS
  • Preset : CDppConfig
  • PresetAcq : CDppConfig
  • PresetCount : CDppConfig
  • PresetCountExpired : CDppConfig
  • PresetLt : CDppConfig
  • PresetLtDone : CDppConfig , DP5_DP4_FORMAT_STATUS
  • PresetRt : CDppConfig
  • PresetRtDone : DP5_DP4_FORMAT_STATUS , CDppConfig
  • PrintCfg : CDppConfig
  • printNotes : CSpectrumAttr
  • profile : CSProfile , CSCommon
  • profileCls : CSCommon
  • ptrGainTable : CDppGain
  • PulseWidth : CSca
  • PUREnable : CDppConfig
  • PwrBtnConfig : CDppConfig
  • PwrCtrl5VA : CDppConfig
  • PwrCtrl9V : CDppConfig
  • PX4 : DP5_DP4_FORMAT_STATUS
  • PX4FineGain : CDppConfig
  • PX4Gain : CDppConfig
  • PX4InputOffset : CDppConfig
  • PZCORR : DP5_DP4_FORMAT_STATUS
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • RAM_TEST_ERROR : DP5_DP4_FORMAT_STATUS
  • RAM_TEST_RUN : DP5_DP4_FORMAT_STATUS
  • RAW : DP5_DP4_FORMAT_STATUS
  • RcvCount : CDppSocket
  • RcvTotal : CDppSocket
  • RealTime : CDppConfig , DP5_DP4_FORMAT_STATUS
  • ReBootFlag : DP5_DP4_FORMAT_STATUS
  • RefreshDppGainPZ : CDppConfig
  • RefreshDppGeneral : CDppConfig
  • RefreshDppMCA : CDppConfig
  • RefreshDppMisc : CDppConfig
  • RefreshDppPower : CDppConfig
  • RefreshDppShaping : CDppConfig
  • RefreshDppTest : CDppConfig
  • ReloadCfg : CSCommon
  • ReqProcess : _DppStateType
  • Request : _WINUSB_SETUP_PACKET
  • RequestType : _WINUSB_SETUP_PACKET
  • Rise : CDppConfig
  • RiseTop : CShapingPage
  • RiseUS : CDppConfig
  • RS232_RThreshold : CDP5Protocol
  • RS232BytesInBuffer : CDP5Protocol
  • RS232HeaderReceived : CDP5Protocol
  • RS232PacketPtr : CDP5Protocol
  • RTDFast : CDppConfig
  • RTDOn : CDppConfig
  • RTDSlow : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • SaveCfg : CDppConfig
  • SCA : CDppConfig
  • sca : CSCommon , CSProfile
  • SCA_SECTION : CScaFn
  • SCAEnabled : CSProfile , CSCommon
  • scafn : CSProfile , CSCommon
  • ScaleAuto : CDP5Protocol
  • ScaReadBack : CDppConfig
  • Scope : CDppConfig , CDP5Protocol
  • SCOPE_DR : DP5_DP4_FORMAT_STATUS
  • ScopeAutoRearm : _DppStateType
  • ScopeBuffer : CvcDP5Dlg
  • ScopeOverFlow : _DppStateType
  • ScopeTriggerFalling : CDppConfig
  • ScopeTriggerPosition : CDppConfig
  • SEL8_5V : CDppConfig
  • SendCoarseFineGain : _CONFIG_OPTIONS , CSProfile
  • SerialNumber : CDppConfig , DP5_DP4_FORMAT_STATUS , _SpectrumFileType
  • SetFastThreshDone : CDppConfig
  • SetInputOffsetDone : CDppConfig
  • Setting : _DP5_CONFIGURATION
  • SlowChThreshold : CDppConfig
  • SlowCount : CDppConfig , DP5_DP4_FORMAT_STATUS
  • SlowThresholdPct : CDppConfig
  • SndCmd : CSCommon
  • SockAddr : NETDISPLAY_ENTRY , CSProfile , CSCommon
  • spectraList : CSCommon
  • SPECTRUM : CDP5Protocol
  • SPECTRUM_OFFSET : DP5_DP4_FORMAT_STATUS
  • SRAMTestData : _DiagDataType
  • SRAMTestPass : _DiagDataType
  • StartTime : CDppConfig
  • StatDevInd : CDppConfig
  • StatMcaEnabled : CDppConfig
  • STATUS : _Packet_In
  • str_description : NETDISPLAY_ENTRY
  • str_display : NETDISPLAY_ENTRY
  • str_ev1 : NETDISPLAY_ENTRY
  • str_ev2 : NETDISPLAY_ENTRY
  • str_type : NETDISPLAY_ENTRY
  • strAnalogOut : CDppConfig
  • strDescription : _SpectrumFileType
  • strDevice : CSProfile
  • strFindCtrl : CDP5ControlUtil
  • strFindIdx : CDP5ControlUtil
  • strFindTab : CDP5ControlUtil
  • strGainDisplayValue : CDppConfig
  • strHelpFilePath : CSCommon
  • strIniFilename : CSca
  • strInputOffset : CDppConfig
  • strLowerMiscData : CvcDP5Dlg
  • strMcaMode : CDppConfig
  • strOutputOffset : CDppConfig
  • strPercentDeadTime : CDppConfig
  • strPort : _DppStateType
  • strPresetCmd : CDppConfig
  • strPresetVal : CDppConfig
  • strScopeGain : CDppConfig
  • strSockAddr : CSCommon
  • strSpectrumConfig : _SpectrumFileType
  • strSpectrumStatus : _SpectrumFileType
  • strStartTime : _SpectrumFileType
  • strTag : _SpectrumFileType
  • strTempCal : _DiagDataType
  • strTempRaw : _DiagDataType
  • strTriggerPosition : CDppConfig
  • strTriggerSlope : CDppConfig
  • strTriggerSource : CDppConfig
  • strUpperMiscData : CvcDP5Dlg
  • subnet : NETDISPLAY_ENTRY
  • Sup9VOn : _DiagDataType
  • SUPPLIES_ON : DP5_DP4_FORMAT_STATUS
  • SwConfigRcvd : CDppConfig
  • systemNotes : CSpectrumAttr
  • szSettings : CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • tag : CSpectrumAttr
  • tbBtnMap : CDlgToolBar
  • TEC : CDppConfig
  • TEC_Voltage : DP5_DP4_FORMAT_STATUS
  • TECEnabled : CDppConfig
  • TECMonitor : CDppConfig
  • TECMonitorCStr : CDppConfig
  • TECOn : _DiagDataType
  • TempOffset : _DiagDataType
  • TextCtrlID : _DP5_CONFIGURATION
  • TextValue : _DP5_CONFIGURATION
  • Timeout_flag : CDP5Protocol
  • TimeoutFlag : CvcDP5Dlg
  • TxtFileFilter : CFileBrowse
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • UC_TEMP_OFFSET : DP5_DP4_FORMAT_STATUS
  • UDP_offset : CDP5Protocol
  • Units : _DP5_CONFIGURATION
  • UpdateScopeCfg : CDppConfig
  • USB_Default_Timeout : CDP5Protocol , CDppWinUSB
  • USBDataRefreshRate : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • ValComments : _DP5_CONFIGURATION
  • Value : _WINUSB_SETUP_PACKET
  • VREF_IN : DP5_DP4_FORMAT_STATUS
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WinUsb_Disabled : CDppWinUSB
  • winUSBHandle : WINUSB_DEVICE_INFO
  • WinusbNotify : CSCommon
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • X : _COORD_LONG
  • XPlotMAX : CPlotCanvas , CvcDP5Dlg
  • XR100 : CDppConfig
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • Y : _COORD_LONG
  • YPlotBuffer : CPlotCanvas
  • YPlotMAX : CPlotCanvas , CvcDP5Dlg
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Enumerations

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • DialogType : CFileBrowse
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Enumerator

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • IDD : CBootOptPage , cWaitDlg , CvcDP5Dlg , CAboutDlg , CMsgBox
  • OPEN : CFileBrowse
  • SAVE : CFileBrowse
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Members - Related Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • CCfgPropPage : CCfgPropSheet
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: MsgBox.cpp File Reference

  • File List
  • File Members
MsgBox.cpp File Reference
#include "stdafx.h"
#include "resource.h"
#include "MsgBox.h"
Include dependency graph for MsgBox.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: MsgBox.h File Reference

Classes
MsgBox.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CMsgBox
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Plot.cpp File Reference

Plot.cpp File Reference
#include ".\plot.h"
Include dependency graph for Plot.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Plot.h File Reference

Classes
Plot.h File Reference
#include "stdafx.h"
#include "STypes.h"
Include dependency graph for Plot.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CPlot
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: resource.h File Reference

Defines
resource.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDM_ABOUTBOX 16
#define | IDD_ABOUTBOX 100
#define | IDS_ABOUTBOX 101
#define | IDC_BUSY_PIC 1029
#define | IDC_BUSY_TEXT 1030
#define | IDC_MESSAGE1 1105
#define | IDC_MESSAGE2 1106
#define | IDC_BUTTON_ADD_ROI 2304
#define | IDC_BUTTON_ARM_TRIGGER 2305
#define | IDC_BUTTON_CLEAR_DATA_AND_GRAPH 2306
#define | IDC_BUTTON_CLEAR_MISC_DATA 2307
#define | IDC_BUTTON_CLEAR_ROI 2308
#define | IDC_BUTTON_DIAG 2309
#define | IDC_BUTTON_EDIT_CONFIG 2310
#define | IDC_BUTTON_FIND_DEVICE 2311
#define | IDC_BUTTON_READ_MISC_DATA 2312
#define | IDC_BUTTON_ROI_END 2313
#define | IDC_BUTTON_ROI_START 2314
#define | IDC_BUTTON_SAVE_FILE 2315
#define | IDC_BUTTON_SELECT_COMM 2316
#define | IDC_BUTTON_SHOW_CONFIG 2317
#define | IDC_BUTTON_SINGLE_UPDATE 2318
#define | IDC_BUTTON_START_ACQUISITION 2319
#define | IDC_BUTTON_STOP_ACQUISITION 2320
#define | IDC_BUTTON_WRITE_MISC_DATA 2321
#define | IDC_CHECK_AUTO_REARM 2322
#define | IDC_CHECK_DELTA 2323
#define | IDC_EDIT_DESCRIPTION 2324
#define | IDC_EDIT_DIAG 2325
#define | IDC_EDIT_MISC_DATA 2326
#define | IDC_EDIT_START_TIME 2327
#define | IDC_EDIT_STATUS 2328
#define | IDC_EDIT_TAG 2329
#define | IDC_GROUP_PLOT_SCALE 2330
#define | IDC_PICTURE_PLOT 2331
#define | IDC_PICTURE_SCOPE 2332
#define | IDC_PLOTTYPEGROUP 2333
#define | IDC_RADIO_PLOT_SCALE_LINEAR 2334
#define | IDC_RADIO_PLOT_SCALE_LOG 2335
#define | IDC_RADIO_PLOT_TYPE_SOLID 2336
#define | IDC_RADIO_PLOT_TYPE_LINE 2337
#define | IDC_STATIC_ 2338
#define | IDC_STATIC_MISC_STATUS 2339
#define | IDC_STATIC_ROI_COUNT 2340
#define | IDC_STATIC_ROI_END 2341
#define | IDC_STATIC_ROI_INDEX 2342
#define | IDC_STATIC_ROI_START 2343
#define | IDC_STATIC_SELECT_COMMUNICATIONS 2344
#define | IDC_STATIC_SPECTRUM_STATUS 2345
#define | IDC_STATIC_STATUS 2346
#define | IDC_BUTTON_AUTOTUNE 2347
#define | IDB_BITMAP_DP5_DLG 4105
#define | IDB_SPECTRUM_ANIM 4144
#define | IDD_BUSY_DLG 4150
#define | IDD_MESSAGE_BOX 4159
#define | IDP_SOCKETS_INIT_FAILED 4186
#define | IDR_MAINFRAME 4188
#define | IDR_MENU 4189
#define | IDR_TOOLBAR 4196
#define | IDR_TOOLBAR_DP5_DLG 4197
#define | IDS_BTNSTRING_MODAL 4198
#define | IDS_BTNSTRING_MODELESS 4199
#define | IDS_CAPTION 4200
#define | IDD_vcDP5_DIALOG 7168
#define | ID_FILE_TAB 33064
#define | ID_GAINPZ_TAB 33073
#define | ID_MCA_TAB 33092
#define | ID_MISC_TAB 33095
#define | ID_POWER_TAB 33102
#define | ID_SHAPING_TAB 33120
#define | ID_HELP_ABOUT 40003

Define Documentation

#define ID_FILE_TAB 33064

Definition at line 69 of file resource.h.

#define ID_GAINPZ_TAB 33073

Definition at line 70 of file resource.h.

#define ID_HELP_ABOUT 40003

Definition at line 75 of file resource.h.

#define ID_MCA_TAB 33092

Definition at line 71 of file resource.h.

#define ID_MISC_TAB 33095

Definition at line 72 of file resource.h.

#define ID_POWER_TAB 33102

Definition at line 73 of file resource.h.

#define ID_SHAPING_TAB 33120

Definition at line 74 of file resource.h.

#define IDB_BITMAP_DP5_DLG 4105

Definition at line 56 of file resource.h.

#define IDB_SPECTRUM_ANIM 4144

Definition at line 57 of file resource.h.

#define IDC_BUSY_PIC 1029

Definition at line 8 of file resource.h.

#define IDC_BUSY_TEXT 1030

Definition at line 9 of file resource.h.

#define IDC_BUTTON_ADD_ROI 2304

Definition at line 12 of file resource.h.

#define IDC_BUTTON_ARM_TRIGGER 2305

Definition at line 13 of file resource.h.

#define IDC_BUTTON_AUTOTUNE 2347

Definition at line 55 of file resource.h.

#define IDC_BUTTON_CLEAR_DATA_AND_GRAPH 2306

Definition at line 14 of file resource.h.

#define IDC_BUTTON_CLEAR_MISC_DATA 2307

Definition at line 15 of file resource.h.

#define IDC_BUTTON_CLEAR_ROI 2308

Definition at line 16 of file resource.h.

#define IDC_BUTTON_DIAG 2309

Definition at line 17 of file resource.h.

#define IDC_BUTTON_EDIT_CONFIG 2310

Definition at line 18 of file resource.h.

#define IDC_BUTTON_FIND_DEVICE 2311

Definition at line 19 of file resource.h.

#define IDC_BUTTON_READ_MISC_DATA 2312

Definition at line 20 of file resource.h.

#define IDC_BUTTON_ROI_END 2313

Definition at line 21 of file resource.h.

#define IDC_BUTTON_ROI_START 2314

Definition at line 22 of file resource.h.

#define IDC_BUTTON_SAVE_FILE 2315

Definition at line 23 of file resource.h.

#define IDC_BUTTON_SELECT_COMM 2316

Definition at line 24 of file resource.h.

#define IDC_BUTTON_SHOW_CONFIG 2317

Definition at line 25 of file resource.h.

#define IDC_BUTTON_SINGLE_UPDATE 2318

Definition at line 26 of file resource.h.

#define IDC_BUTTON_START_ACQUISITION 2319

Definition at line 27 of file resource.h.

#define IDC_BUTTON_STOP_ACQUISITION 2320

Definition at line 28 of file resource.h.

#define IDC_BUTTON_WRITE_MISC_DATA 2321

Definition at line 29 of file resource.h.

#define IDC_CHECK_AUTO_REARM 2322

Definition at line 30 of file resource.h.

#define IDC_CHECK_DELTA 2323

Definition at line 31 of file resource.h.

#define IDC_EDIT_DESCRIPTION 2324

Definition at line 32 of file resource.h.

#define IDC_EDIT_DIAG 2325

Definition at line 33 of file resource.h.

#define IDC_EDIT_MISC_DATA 2326

Definition at line 34 of file resource.h.

#define IDC_EDIT_START_TIME 2327

Definition at line 35 of file resource.h.

#define IDC_EDIT_STATUS 2328

Definition at line 36 of file resource.h.

#define IDC_EDIT_TAG 2329

Definition at line 37 of file resource.h.

#define IDC_GROUP_PLOT_SCALE 2330

Definition at line 38 of file resource.h.

#define IDC_MESSAGE1 1105

Definition at line 10 of file resource.h.

#define IDC_MESSAGE2 1106

Definition at line 11 of file resource.h.

#define IDC_PICTURE_PLOT 2331

Definition at line 39 of file resource.h.

#define IDC_PICTURE_SCOPE 2332

Definition at line 40 of file resource.h.

#define IDC_PLOTTYPEGROUP 2333

Definition at line 41 of file resource.h.

#define IDC_RADIO_PLOT_SCALE_LINEAR 2334

Definition at line 42 of file resource.h.

#define IDC_RADIO_PLOT_SCALE_LOG 2335

Definition at line 43 of file resource.h.

#define IDC_RADIO_PLOT_TYPE_LINE 2337

Definition at line 45 of file resource.h.

#define IDC_RADIO_PLOT_TYPE_SOLID 2336

Definition at line 44 of file resource.h.

#define IDC_STATIC_ 2338

Definition at line 46 of file resource.h.

#define IDC_STATIC_MISC_STATUS 2339

Definition at line 47 of file resource.h.

#define IDC_STATIC_ROI_COUNT 2340

Definition at line 48 of file resource.h.

#define IDC_STATIC_ROI_END 2341

Definition at line 49 of file resource.h.

#define IDC_STATIC_ROI_INDEX 2342

Definition at line 50 of file resource.h.

#define IDC_STATIC_ROI_START 2343

Definition at line 51 of file resource.h.

#define IDC_STATIC_SELECT_COMMUNICATIONS 2344

Definition at line 52 of file resource.h.

#define IDC_STATIC_SPECTRUM_STATUS 2345

Definition at line 53 of file resource.h.

#define IDC_STATIC_STATUS 2346

Definition at line 54 of file resource.h.

#define IDD_ABOUTBOX 100

Definition at line 6 of file resource.h.

#define IDD_BUSY_DLG 4150

Definition at line 58 of file resource.h.

#define IDD_MESSAGE_BOX 4159

Definition at line 59 of file resource.h.

#define IDD_vcDP5_DIALOG 7168

Definition at line 68 of file resource.h.

#define IDM_ABOUTBOX 16

Definition at line 5 of file resource.h.

#define IDP_SOCKETS_INIT_FAILED 4186

Definition at line 60 of file resource.h.

#define IDR_MAINFRAME 4188

Definition at line 61 of file resource.h.

#define IDR_MENU 4189

Definition at line 62 of file resource.h.

#define IDR_TOOLBAR 4196

Definition at line 63 of file resource.h.

#define IDR_TOOLBAR_DP5_DLG 4197

Definition at line 64 of file resource.h.

#define IDS_ABOUTBOX 101

Definition at line 7 of file resource.h.

#define IDS_BTNSTRING_MODAL 4198

Definition at line 65 of file resource.h.

#define IDS_BTNSTRING_MODELESS 4199

Definition at line 66 of file resource.h.

#define IDS_CAPTION 4200

Definition at line 67 of file resource.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Roi.cpp File Reference

Roi.cpp File Reference
#include "stdafx.h"
#include "SCommon.h"
#include "Roi.h"
Include dependency graph for Roi.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: roi.h File Reference

Classes | Enumerations
roi.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CRoiEntry
class | CRoi

Enumerations

enum RoiDataKind {
ROI_DATA_INVALID, ROI_DATA_BAD,
ROI_DATA_MARGINAL, ROI_DATA_GOOD
}
enum RoiFocus {
ROI_DLG_FOCUS_NONE, ROI_DLG_FOCUS_START,
ROI_DLG_FOCUS_END
}

Enumeration Type Documentation

enum RoiDataKind
Enumerator:
ROI_DATA_INVALID
ROI_DATA_BAD
ROI_DATA_MARGINAL
ROI_DATA_GOOD

Definition at line 12 of file roi.h.

enum RoiFocus
Enumerator:
ROI_DLG_FOCUS_NONE
ROI_DLG_FOCUS_START
ROI_DLG_FOCUS_END

Definition at line 71 of file roi.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SCommon.cpp File Reference

SCommon.cpp File Reference
#include "StdAfx.h"
#include "SCommon.h"
#include <time.h>
#include <math.h>
#include "MiscPageRes.h"
#include "PowerPageRes.h"
#include "ShapingPageRes.h"
#include "FilePageRes.h"
#include "GainPzPageRes.h"
#include "McaPageRes.h"
Include dependency graph for SCommon.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SCommon.h File Reference

Classes | Defines | Variables
SCommon.h File Reference
#include "stdafx.h"
#include "DppConst.h"
#include "scafn.h"
#include "vcDP5_Shared_HIDD.h"
#include "vcDP5.h"
#include "DppSocket.h"
#include "DppWinUSB.h"
#include "DppComm.h"
#include "DP5Status.h"
#include "ParsePacket.h"
#include "DP5Protocol.h"
#include "SendCommand.h"
#include "DP5ControlUtil.h"
#include "DppConfig.h"
#include ".\plot.h"
#include ".\spectralist.h"
#include "WinusbNotify.h"
Include dependency graph for SCommon.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CSProfile
class | CSCommon

Defines

#define | WM_SETPAGEFOCUS WM_APP+2
#define | GETPD(p1, i1, data) str = Get(p1, #i1, data); i1 = atof(str)
#define | PUTPD(p1, i1) str.Format("%g", i1); Put(p1, #i1, str)
#define | GETP1(p1, i1, data) i1 = Get(p1, #i1, data)
#define | PUTP1(p1, i1) Put(p1, #i1, i1)

Variables

const CString | regDP5Comm = "DP5_Communication"
const CString | regDP5Device = "DP5_Device"
const CString | regDP5Config = "DP5_Configuration"
CSCommon s

Define Documentation

#define GETP1 | ( | p1,
 |  | i1,
 |  | data
 | ) | i1 = Get(p1, #i1, data)

Definition at line 31 of file SCommon.h.

#define GETPD | ( | p1,
 |  | i1,
 |  | data
 | ) | str = Get(p1, #i1, data); i1 = atof(str)

Definition at line 27 of file SCommon.h.

#define PUTP1 | ( | p1,
 |  | i1
 | ) | Put(p1, #i1, i1)

Definition at line 32 of file SCommon.h.

#define PUTPD | ( | p1,
 |  | i1
 | ) | str.Format("%g", i1); Put(p1, #i1, str)

Definition at line 28 of file SCommon.h.

#define WM_SETPAGEFOCUS WM_APP+2

Definition at line 8 of file SCommon.h.

Variable Documentation

const CString regDP5Comm = "DP5_Communication"

Definition at line 34 of file SCommon.h.

const CString regDP5Config = "DP5_Configuration"

Definition at line 36 of file SCommon.h.

const CString regDP5Device = "DP5_Device"

Definition at line 35 of file SCommon.h.

CSCommon s

Definition at line 35 of file vcDP5.cpp.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectraList.cpp File Reference

SpectraList.cpp File Reference
#include ".\spectralist.h"
Include dependency graph for SpectraList.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectraList.h File Reference

Classes
SpectraList.h File Reference
#include "StdAfx.h"
#include ".\spectrum.h"
Include dependency graph for SpectraList.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CSpectraList
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Spectrum.cpp File Reference

Spectrum.cpp File Reference
#include ".\spectrum.h"
Include dependency graph for Spectrum.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Spectrum.h File Reference

Classes
Spectrum.h File Reference
#include "stdafx.h"
#include ".\spectrumattr.h"
#include "Roi.h"
Include dependency graph for Spectrum.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CSpectrum
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectrumAttr.cpp File Reference

SpectrumAttr.cpp File Reference
#include ".\spectrumattr.h"
Include dependency graph for SpectrumAttr.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectrumAttr.h File Reference

Classes | Defines
SpectrumAttr.h File Reference
#include "StdAfx.h"
Include dependency graph for SpectrumAttr.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CSpectrumAttr

Defines

#define | MAX_GAIN_INDEX 6

Define Documentation

#define MAX_GAIN_INDEX 6

Definition at line 3 of file SpectrumAttr.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: StdAfx.cpp File Reference

StdAfx.cpp File Reference
#include "stdafx.h"
Include dependency graph for StdAfx.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: StdAfx.h File Reference

Defines
StdAfx.h File Reference
#include <afxwin.h>
#include <afxext.h>
#include <afxole.h>
#include <afxdisp.h>
#include <afxdtctl.h>
#include <vector>
#include <afxcmn.h>
#include <afxdlgs.h>
#include <afxtempl.h>
#include <afxsock.h>
Include dependency graph for StdAfx.h:

Go to the source code of this file.

Defines

#define | _CRT_SECURE_NO_DEPRECATE 1
#define | _SETUPAPI_VER 0x0501
#define | VC_EXTRALEAN

Define Documentation

#define _CRT_SECURE_NO_DEPRECATE 1

Definition at line 9 of file StdAfx.h.

#define _SETUPAPI_VER 0x0501

Definition at line 13 of file StdAfx.h.

#define VC_EXTRALEAN

Definition at line 39 of file StdAfx.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringex.cpp File Reference

stringex.cpp File Reference
#include "stringex.h"
Include dependency graph for stringex.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringex.h File Reference

Classes
stringex.h File Reference
#include <stdio.h>
#include <stdarg.h>
#include <cstdarg>
#include <vector>
#include <string>
#include <cctype>
Include dependency graph for stringex.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class stringex
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: STypes.cpp File Reference

STypes.cpp File Reference
#include "StdAfx.h"
#include "STypes.h"
Include dependency graph for STypes.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: STypes.h File Reference

Defines | Enumerations
STypes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | MIN_PLOT_X_PIXELS 100
#define | MIN_PLOT_Y_PIXELS 80
#define | MIN_FRAME_X_PIXELS 200
#define | MIN_FRAME_Y_PIXELS 160
#define | MAX_CHANNELS 0x4000ul
#define | MAX_COUNTS 0xFFFFFFFFul
#define | MIN_PLOT_CHANNELS 64
#define | MIN_PLOT_COUNTS 32
#define | MIN_GAIN 256
#define | MAX_GAIN_INDEX 6
#define | GAIN_FROM_INDEX(index) (MIN_GAIN << index)
#define | GETULONG(d) ((unsigned long) floor(d + 0.5))
#define | TOULONG(d)
#define | GETLONG(d) ((long) floor(d + 0.5))
#define | TOLONG(d)
#define | SCREEN_SCALE 10000
#define | MAX_SPECTRA 20

Enumerations

enum SCALE_TYPE {
LIN_SCALE, LOG_SCALE,
SQRT_SCALE
}
enum SMOOTH_TYPE {
INVALID_SMOOTH = -2, NO_SMOOTH,
THREE_SMOOTH, FIVE_SMOOTH
}
enum GAIN_TYPE {
GAIN_256, GAIN_512,
GAIN_1024, GAIN_2048,
GAIN_4096, GAIN_8192,
GAIN_16384
}

Define Documentation

#define GAIN_FROM_INDEX ( index ) (MIN_GAIN << index)

Definition at line 29 of file STypes.h.

#define GETLONG ( d ) ((long) floor(d + 0.5))

Definition at line 33 of file STypes.h.

#define GETULONG ( d ) ((unsigned long) floor(d + 0.5))

Definition at line 30 of file STypes.h.

#define MAX_CHANNELS 0x4000ul

Definition at line 20 of file STypes.h.

#define MAX_COUNTS 0xFFFFFFFFul

Definition at line 21 of file STypes.h.

#define MAX_GAIN_INDEX 6

Definition at line 27 of file STypes.h.

#define MAX_SPECTRA 20

Definition at line 39 of file STypes.h.

#define MIN_FRAME_X_PIXELS 200

Definition at line 17 of file STypes.h.

#define MIN_FRAME_Y_PIXELS 160

Definition at line 18 of file STypes.h.

#define MIN_GAIN 256

Definition at line 26 of file STypes.h.

#define MIN_PLOT_CHANNELS 64

Definition at line 23 of file STypes.h.

#define MIN_PLOT_COUNTS 32

Definition at line 24 of file STypes.h.

#define MIN_PLOT_X_PIXELS 100

Definition at line 14 of file STypes.h.

#define MIN_PLOT_Y_PIXELS 80

Definition at line 15 of file STypes.h.

#define SCREEN_SCALE 10000

Definition at line 37 of file STypes.h.

#define TOLONG ( d )
Value:
(d <= LONG_MIN ? LONG_MIN : \
        (d > LONG_MAX ? LONG_MAX : GETLONG(d)))

Definition at line 34 of file STypes.h.

#define TOULONG ( d )
Value:
(d <= 0.0 ? 0 : \
        (d > ULONG_MAX ? ULONG_MAX : GETULONG(d)))

Definition at line 31 of file STypes.h.

Enumeration Type Documentation

enum GAIN_TYPE
Enumerator:
GAIN_256
GAIN_512
GAIN_1024
GAIN_2048
GAIN_4096
GAIN_8192
GAIN_16384

Definition at line 57 of file STypes.h.

enum SCALE_TYPE
Enumerator:
LIN_SCALE
LOG_SCALE
SQRT_SCALE

Definition at line 42 of file STypes.h.

enum SMOOTH_TYPE
Enumerator:
INVALID_SMOOTH
NO_SMOOTH
THREE_SMOOTH
FIVE_SMOOTH

Definition at line 49 of file STypes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: UserMsgs.h File Reference

Defines
UserMsgs.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | WM_USER_PMCA_REQUEST_PARAMETER (WM_USER + 256)
#define | WM_USER_FPGUI_REQUEST_PARAMETER (WM_USER + 257)
#define | WM_USER_LOAD_FILE (WM_USER + 300)
#define | WM_USER_UPDATE_STATUS_BAR (WM_USER + 301)
#define | WM_USER_UPDATE_MENU (WM_USER + 302)
#define | WM_USER_SHOW_SPECTRA_LIST_DLG (WM_USER + 303)
#define | WM_USER_SEND_CONFIG_TO_HW (WM_USER + 305)
#define | WM_USER_REPEAT_MEASUREMENT (WM_USER + 306)
#define | WM_USER_READ_DPP_CONFIG (WM_USER + 307)
#define | WM_USER_SAVE_CONFIG_TO_FILE (WM_USER + 309)
#define | WM_USER_COARSE_AUTO_INPUT_OFFSET (WM_USER + 312)
#define | WM_USER_FINE_AUTO_INPUT_OFFSET (WM_USER + 313)
#define | WM_USER_DPP_AUTO_FAST_THESHOLD (WM_USER + 314)
#define | WM_USER_DPP_AUTO_SLOW_THESHOLD (WM_USER + 315)
#define | WM_USER_SHOW_CONNECT_DIALOG (WM_USER + 316)
#define | WM_USER_READ_SCA_CONFIG (WM_USER + 317)
#define | WM_USER_READ_DPP_CONFIG_EX (WM_USER + 319)

Define Documentation

#define WM_USER_COARSE_AUTO_INPUT_OFFSET (WM_USER + 312)

Definition at line 20 of file UserMsgs.h.

#define WM_USER_DPP_AUTO_FAST_THESHOLD (WM_USER + 314)

Definition at line 22 of file UserMsgs.h.

#define WM_USER_DPP_AUTO_SLOW_THESHOLD (WM_USER + 315)

Definition at line 23 of file UserMsgs.h.

#define WM_USER_FINE_AUTO_INPUT_OFFSET (WM_USER + 313)

Definition at line 21 of file UserMsgs.h.

#define WM_USER_FPGUI_REQUEST_PARAMETER (WM_USER + 257)

Definition at line 5 of file UserMsgs.h.

#define WM_USER_LOAD_FILE (WM_USER + 300)

Definition at line 7 of file UserMsgs.h.

#define WM_USER_PMCA_REQUEST_PARAMETER (WM_USER + 256)

Definition at line 4 of file UserMsgs.h.

#define WM_USER_READ_DPP_CONFIG (WM_USER + 307)

Definition at line 15 of file UserMsgs.h.

#define WM_USER_READ_DPP_CONFIG_EX (WM_USER + 319)

Definition at line 26 of file UserMsgs.h.

#define WM_USER_READ_SCA_CONFIG (WM_USER + 317)

Definition at line 25 of file UserMsgs.h.

#define WM_USER_REPEAT_MEASUREMENT (WM_USER + 306)

Definition at line 14 of file UserMsgs.h.

#define WM_USER_SAVE_CONFIG_TO_FILE (WM_USER + 309)

Definition at line 17 of file UserMsgs.h.

#define WM_USER_SEND_CONFIG_TO_HW (WM_USER + 305)

Definition at line 13 of file UserMsgs.h.

#define WM_USER_SHOW_CONNECT_DIALOG (WM_USER + 316)

Definition at line 24 of file UserMsgs.h.

#define WM_USER_SHOW_SPECTRA_LIST_DLG (WM_USER + 303)

Definition at line 10 of file UserMsgs.h.

#define WM_USER_UPDATE_MENU (WM_USER + 302)

Definition at line 9 of file UserMsgs.h.

#define WM_USER_UPDATE_STATUS_BAR (WM_USER + 301)

Definition at line 8 of file UserMsgs.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5.cpp File Reference

Variables
vcDP5.cpp File Reference
#include "stdafx.h"
#include "vcDP5.h"
#include "vcDP5Dlg.h"
#include "SCommon.h"
Include dependency graph for vcDP5.cpp:

Go to the source code of this file.

Variables

CvcDP5App theApp
CSCommon s

Variable Documentation

CSCommon s

Definition at line 35 of file vcDP5.cpp.

CvcDP5App theApp

Definition at line 34 of file vcDP5.cpp.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5.h File Reference

Classes | Variables
vcDP5.h File Reference
#include "resource.h"
#include <SetupAPI.h>
Include dependency graph for vcDP5.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CvcDP5App

Variables

CvcDP5App theApp

Variable Documentation

CvcDP5App theApp

Definition at line 34 of file vcDP5.cpp.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5_Shared_HIDD.h File Reference

Defines
vcDP5_Shared_HIDD.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | HIDD_DP5_CONNECT 0x20191
#define | HIDD_FILE_PAGE 0x20192
#define | HIDD_MCA_PAGE 0x20193
#define | HIDD_SHAPING_PAGE 0x20194
#define | HIDD_GAINPZ_PAGE 0x20195
#define | HIDD_POWER_PAGE 0x20196
#define | HIDD_MISC_PAGE 0x20197

Define Documentation

#define HIDD_DP5_CONNECT 0x20191

Definition at line 11 of file vcDP5_Shared_HIDD.h.

#define HIDD_FILE_PAGE 0x20192

Definition at line 12 of file vcDP5_Shared_HIDD.h.

#define HIDD_GAINPZ_PAGE 0x20195

Definition at line 15 of file vcDP5_Shared_HIDD.h.

#define HIDD_MCA_PAGE 0x20193

Definition at line 13 of file vcDP5_Shared_HIDD.h.

#define HIDD_MISC_PAGE 0x20197

Definition at line 17 of file vcDP5_Shared_HIDD.h.

#define HIDD_POWER_PAGE 0x20196

Definition at line 16 of file vcDP5_Shared_HIDD.h.

#define HIDD_SHAPING_PAGE 0x20194

Definition at line 14 of file vcDP5_Shared_HIDD.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5_Shared_IDD.h File Reference

Defines
vcDP5_Shared_IDD.h File Reference

Go to the source code of this file.

Defines

#define | IDD_DP5_CONNECT 401
#define | IDD_FILE_PAGE 402
#define | IDD_MCA_PAGE 403
#define | IDD_SHAPING_PAGE 404
#define | IDD_GAINPZ_PAGE 405
#define | IDD_POWER_PAGE 406
#define | IDD_MISC_PAGE 407

Define Documentation

#define IDD_DP5_CONNECT 401

Definition at line 1 of file vcDP5_Shared_IDD.h.

#define IDD_FILE_PAGE 402

Definition at line 2 of file vcDP5_Shared_IDD.h.

#define IDD_GAINPZ_PAGE 405

Definition at line 5 of file vcDP5_Shared_IDD.h.

#define IDD_MCA_PAGE 403

Definition at line 3 of file vcDP5_Shared_IDD.h.

#define IDD_MISC_PAGE 407

Definition at line 7 of file vcDP5_Shared_IDD.h.

#define IDD_POWER_PAGE 406

Definition at line 6 of file vcDP5_Shared_IDD.h.

#define IDD_SHAPING_PAGE 404

Definition at line 4 of file vcDP5_Shared_IDD.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5Dlg.cpp File Reference

Classes
vcDP5Dlg.cpp File Reference
#include "stdafx.h"
#include "vcDP5.h"
#include "vcDP5Dlg.h"
#include "SelectDP5.h"
#include ".\msectimer.h"
#include ".\waitdlg\CmdWaitDlg.h"
#include "UserMsgs.h"
#include "FileBrowse.h"
#include "DppGain.h"
#include "afxadv.h"
#include "TuneSlowThreshold.h"
#include "MsgBox.h"
Include dependency graph for vcDP5Dlg.cpp:

Go to the source code of this file.

Classes

class CAboutDlg
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5Dlg.h File Reference

Classes | Defines | Typedefs
vcDP5Dlg.h File Reference
#include "stdafx.h"
#include "afxwin.h"
#include "Resource.h"
#include "SCommon.h"
#include "ParsePacket.h"
#include "Label.h"
#include "PlotCanvas.h"
#include "DP5CfgWnd.h"
Include dependency graph for vcDP5Dlg.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _SpectrumFileType
class | CvcDP5Dlg

Defines

#define | LINEAR_PLOT_SCALE 0
#define | LOG_PLOT_SCALE 1
#define | SOLID_PLOT_TYPE 0
#define | LINE_PLOT_TYPE 1

Typedefs

typedef struct _SpectrumFileType | SpectrumFileType

Define Documentation

#define LINE_PLOT_TYPE 1

Definition at line 17 of file vcDP5Dlg.h.

#define LINEAR_PLOT_SCALE 0

Definition at line 14 of file vcDP5Dlg.h.

#define LOG_PLOT_SCALE 1

Definition at line 15 of file vcDP5Dlg.h.

#define SOLID_PLOT_TYPE 0

Definition at line 16 of file vcDP5Dlg.h.

Typedef Documentation

typedef struct _SpectrumFileType SpectrumFileType
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/DP5ControlUtil.cpp File Reference

CIni/DP5ControlUtil.cpp File Reference
#include "DP5ControlUtil.h"
Include dependency graph for DP5ControlUtil.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/DP5ControlUtil.h File Reference

Classes | Defines | Typedefs | Enumerations
CIni/DP5ControlUtil.h File Reference
#include "stdafx.h"
Include dependency graph for DP5ControlUtil.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _DP5_CONFIGURATION
class | CDP5ControlUtil

Defines

#define | TEXT_VIS(cmd, en) GetDlgItem(IDC_OPT_TEXT_##cmd)->ShowWindow(en)
#define | UNIT_VIS(cmd, en) GetDlgItem(IDC_OPT_UNITS_##cmd)->ShowWindow(en)
#define | LIMIT_VIS(cmd, en) GetDlgItem(IDC_OPT_LIMITS_##cmd)->ShowWindow(en)
#define | ALL_VIS(cmd, en) TEXT_VIS(cmd, en);UNIT_VIS(cmd, en);LIMIT_VIS(cmd, en)
#define | UNIT_INIT(cmd, en) GetDlgItem(IDC_OPT_UNITS_##cmd)->SetWindowText(en)
#define | LIMIT_INIT(cmd, en) GetDlgItem(IDC_OPT_LIMITS_##cmd)->SetWindowText(en)
#define | CBO_TEXT_VIS(cmd, en) CboTextVis(IDC_OPT_COMBO_##cmd,IDC_OPT_TEXT_##cmd,en);
#define | HasComboCtrl 0x1
#define | HasTextCtrl 0x2
#define | DP5_CMD_MIN dciRESC
#define | DP5_CMD_MAX dciBOOT
#define | MAX_DP5_CONFIGURATIONS 100

Typedefs

typedef enum _DP5_CMD_INDEX | DP5_CMD_INDEX
typedef enum _DP5_CTRL_TYPE | DP5_CTRL_TYPE
typedef enum _DP5_CTRL_GROUP | DP5_CTRL_GROUP
typedef enum _DP5_DATA_ID | DP5_DATA_ID
typedef struct _DP5_CONFIGURATION | DP5_CONFIGURATION

Enumerations

enum _DP5_CMD_INDEX {
dciRESC, dciCLCK,
dciTPEA, dciGAIF,
dciGAIN, dciRESL,
dciTFLA, dciTPFA,
dciPURE, dciSCTC,
dciRTDE, dciMCAS,
dciMCAC, dciSOFF,
dciAINP, dciINOF,
dciGAIA, dciCUSP,
dciPDMD, dciTHSL,
dciTLLD, dciTHFA,
dciDACO, dciDACF,
dciRTDS, dciRTDT,
dciBLRM, dciBLRD,
dciBLRU, dciGATE,
dciAUO1, dciPRET,
dciPRER, dciPREL,
dciPREC, dciPRCL,
dciPRCH, dciHVSE,
dciTECS, dciPAPZ,
dciPAPS, dciSCOE,
dciSCOT, dciSCOG,
dciMCSL, dciMCSH,
dciMCST, dciAUO2,
dciTPMO, dciGPED,
dciGPIN, dciGPME,
dciGPGA, dciGPMC,
dciMCAE, dciVOLU,
dciCON1, dciCON2,
dciBOOT
}
enum _DP5_CTRL_TYPE {
dctNone, dctCbo,
dctTxt, dctCboTxt
}
enum _DP5_CTRL_GROUP {
dcgFile, dcgMCA,
dcgShaping, dcgGainPZ,
dcgPower, dcgMisc,
dcgBootOpt
}
enum _DP5_DATA_ID {
ddiCommand, ddiListCtrlID,
ddiTextCtrlID, ddiCtrlType,
ddiCtrlGroup, ddiDescription,
ddiUnits, ddiTextValue,
ddiComboValue, ddiComboIndex,
ddiComments
}

Define Documentation

#define ALL_VIS | ( | cmd,
 |  | en
 | ) | TEXT_VIS(cmd, en);UNIT_VIS(cmd, en);LIMIT_VIS(cmd, en)

Definition at line 8 of file DP5ControlUtil.h.

#define CBO_TEXT_VIS | ( | cmd,
 |  | en
 | ) | CboTextVis(IDC_OPT_COMBO_##cmd,IDC_OPT_TEXT_##cmd,en);

Definition at line 12 of file DP5ControlUtil.h.

#define DP5_CMD_MAX dciBOOT

Definition at line 85 of file DP5ControlUtil.h.

#define DP5_CMD_MIN dciRESC

Definition at line 84 of file DP5ControlUtil.h.

#define HasComboCtrl 0x1

Definition at line 14 of file DP5ControlUtil.h.

#define HasTextCtrl 0x2

Definition at line 15 of file DP5ControlUtil.h.

#define LIMIT_INIT | ( | cmd,
 |  | en
 | ) | GetDlgItem(IDC_OPT_LIMITS_##cmd)->SetWindowText(en)

Definition at line 11 of file DP5ControlUtil.h.

#define LIMIT_VIS | ( | cmd,
 |  | en
 | ) | GetDlgItem(IDC_OPT_LIMITS_##cmd)->ShowWindow(en)

Definition at line 7 of file DP5ControlUtil.h.

#define MAX_DP5_CONFIGURATIONS 100

Definition at line 140 of file DP5ControlUtil.h.

#define TEXT_VIS | ( | cmd,
 |  | en
 | ) | GetDlgItem(IDC_OPT_TEXT_##cmd)->ShowWindow(en)

Definition at line 5 of file DP5ControlUtil.h.

#define UNIT_INIT | ( | cmd,
 |  | en
 | ) | GetDlgItem(IDC_OPT_UNITS_##cmd)->SetWindowText(en)

Definition at line 10 of file DP5ControlUtil.h.

#define UNIT_VIS | ( | cmd,
 |  | en
 | ) | GetDlgItem(IDC_OPT_UNITS_##cmd)->ShowWindow(en)

Definition at line 6 of file DP5ControlUtil.h.

Typedef Documentation

typedef enum _DP5_CMD_INDEX DP5_CMD_INDEX
typedef struct _DP5_CONFIGURATION DP5_CONFIGURATION
typedef enum _DP5_CTRL_GROUP DP5_CTRL_GROUP
typedef enum _DP5_CTRL_TYPE DP5_CTRL_TYPE
typedef enum _DP5_DATA_ID DP5_DATA_ID

Enumeration Type Documentation

enum _DP5_CMD_INDEX
Enumerator:
dciRESC
dciCLCK
dciTPEA
dciGAIF
dciGAIN
dciRESL
dciTFLA
dciTPFA
dciPURE
dciSCTC
dciRTDE
dciMCAS
dciMCAC
dciSOFF
dciAINP
dciINOF
dciGAIA
dciCUSP
dciPDMD
dciTHSL
dciTLLD
dciTHFA
dciDACO
dciDACF
dciRTDS
dciRTDT
dciBLRM
dciBLRD
dciBLRU
dciGATE
dciAUO1
dciPRET
dciPRER
dciPREL
dciPREC
dciPRCL
dciPRCH
dciHVSE
dciTECS
dciPAPZ
dciPAPS
dciSCOE
dciSCOT
dciSCOG
dciMCSL
dciMCSH
dciMCST
dciAUO2
dciTPMO
dciGPED
dciGPIN
dciGPME
dciGPGA
dciGPMC
dciMCAE
dciVOLU
dciCON1
dciCON2
dciBOOT

Definition at line 21 of file DP5ControlUtil.h.

enum _DP5_CTRL_GROUP
Enumerator:
dcgFile
dcgMCA
dcgShaping
dcgGainPZ
dcgPower
dcgMisc
dcgBootOpt

Definition at line 94 of file DP5ControlUtil.h.

enum _DP5_CTRL_TYPE
Enumerator:
dctNone
dctCbo
dctTxt
dctCboTxt

Definition at line 87 of file DP5ControlUtil.h.

enum _DP5_DATA_ID
Enumerator:
ddiCommand
ddiListCtrlID
ddiTextCtrlID
ddiCtrlType
ddiCtrlGroup
ddiDescription
ddiUnits
ddiTextValue
ddiComboValue
ddiComboIndex
ddiComments

Definition at line 104 of file DP5ControlUtil.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/INI.cpp File Reference

CIni/INI.cpp File Reference
#include "stdafx.h"
#include "INI.h"
#include <afxcoll.h>
Include dependency graph for INI.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/INI.h File Reference

Classes | Defines
CIni/INI.h File Reference
#include <afxcoll.h>
Include dependency graph for INI.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CINI

Defines

#define | MAX_SECTION_SIZE 0x7FFF
#define | MAX_KEY_DATA_SIZE 0xFF

Define Documentation

#define MAX_KEY_DATA_SIZE 0xFF

Definition at line 15 of file INI.h.

#define MAX_SECTION_SIZE 0x7FFF

Definition at line 14 of file INI.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniEx.cpp File Reference

CIni/IniEx.cpp File Reference
#include "IniEx.h"
Include dependency graph for IniEx.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniEx.h File Reference

Classes
CIni/IniEx.h File Reference
#include "stdafx.h"
Include dependency graph for IniEx.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CIniEx
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniUtil.cpp File Reference

CIni/IniUtil.cpp File Reference
#include "IniUtil.h"
Include dependency graph for IniUtil.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniUtil.h File Reference

Classes
CIni/IniUtil.h File Reference
#include "stdafx.h"
#include "INI.h"
Include dependency graph for IniUtil.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CIniUtil
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppConfig.cpp File Reference

Config/DppConfig.cpp File Reference
#include "stdafx.h"
#include "DppConfig.h"
#include <math.h>
Include dependency graph for DppConfig.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppConfig.h File Reference

Classes | Defines | Variables
Config/DppConfig.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppConfig

Defines

#define | COUNT_OFFSET 1
#define | USB_BUFFER_SIZE (64 + COUNT_OFFSET)
#define | USB_SCOPE_SIZE 2048
#define | USB_CFG_IN_SIZE (512 + COUNT_OFFSET)

Variables

const int | DP5_TO_PX4_CONTROL_INDEX [16] = {26,27,0,1,2,4,5,6,7,8,9,11,12,14,15,17}

Define Documentation

#define COUNT_OFFSET 1

Definition at line 34 of file DppConfig.h.

#define USB_BUFFER_SIZE (64 + COUNT_OFFSET)

Definition at line 36 of file DppConfig.h.

#define USB_CFG_IN_SIZE (512 + COUNT_OFFSET)

Definition at line 38 of file DppConfig.h.

#define USB_SCOPE_SIZE 2048

Definition at line 37 of file DppConfig.h.

Variable Documentation

const int DP5_TO_PX4_CONTROL_INDEX[16] = {26,27,0,1,2,4,5,6,7,8,9,11,12,14,15,17}

Definition at line 40 of file DppConfig.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppShaping.cpp File Reference

Config/DppShaping.cpp File Reference
#include "stdafx.h"
#include ".\dppshaping.h"
Include dependency graph for DppShaping.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppShaping.h File Reference

Classes | Defines
Config/DppShaping.h File Reference
#include <math.h>
Include dependency graph for DppShaping.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppShaping

Defines

#define | MAXPEAKINGTIMES 26
#define | MAXPEAKINGTIMES_20MHZ (MAXPEAKINGTIMES - 2)
#define | MAXPEAKINGTIMES_80MHZ MAXPEAKINGTIMES

Define Documentation

#define MAXPEAKINGTIMES 26

Definition at line 27 of file DppShaping.h.

#define MAXPEAKINGTIMES_20MHZ (MAXPEAKINGTIMES - 2)

Definition at line 28 of file DppShaping.h.

#define MAXPEAKINGTIMES_80MHZ MAXPEAKINGTIMES

Definition at line 29 of file DppShaping.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppSlowThreshold.cpp File Reference

Config/DppSlowThreshold.cpp File Reference
#include "stdafx.h"
#include ".\dppslowthreshold.h"
Include dependency graph for DppSlowThreshold.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppSlowThreshold.h File Reference

Classes
Config/DppSlowThreshold.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CDppSlowThreshold
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/TuneSlowThreshold.cpp File Reference

Config/TuneSlowThreshold.cpp File Reference
#include "stdafx.h"
#include ".\tuneslowthreshold.h"
#include "DppSlowThreshold.h"
#include "SCommon.h"
#include "UserMsgs.h"
Include dependency graph for TuneSlowThreshold.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/TuneSlowThreshold.h File Reference

Classes
Config/TuneSlowThreshold.h File Reference
#include "afxcmn.h"
#include "afxwin.h"
#include "resource.h"
Include dependency graph for TuneSlowThreshold.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CTuneSlowThreshold
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/Label.cpp File Reference

Controls/Label.cpp File Reference
#include "stdafx.h"
#include "Resource.h"
#include "Label.h"
Include dependency graph for Label.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/Label.h File Reference

Classes | Enumerations
Controls/Label.h File Reference
#include "X11Color.h"
Include dependency graph for Label.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CLabel

Enumerations

enum FlashType {
None, Text,
Background
}

Enumeration Type Documentation

enum FlashType
Enumerator:
None
Text
Background

Definition at line 13 of file Label.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/PlotCanvas.cpp File Reference

Controls/PlotCanvas.cpp File Reference
#include "stdafx.h"
#include <math.h>
#include "PlotCanvas.h"
Include dependency graph for PlotCanvas.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/PlotCanvas.h File Reference

Classes | Defines | Typedefs
Controls/PlotCanvas.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _COORD_LONG
class | CPlotCanvas

Defines

#define | CC_SYSCOLOR(ind) (0x80000000|((ind) & ~CLR_DEFAULT))
#define | ctrlColBlue RGB(0x00,0x00,0xFF)
#define | ctrlColSkyBlue RGB(0x32,0x99,0xCC)
#define | ctrlColLightBlue RGB(0xC0,0xD9,0xD9)
#define | ctrlColLightCyan RGB(0xE0,0xFF,0xFF)
#define | ctrlColYellow RGB(0x00,0xFF,0xFF)
#define | ctrlColGreen RGB(0x00,0xFF,0x00)
#define | ctrlDarkGreen RGB(0x2F,0x4F,0x2F)
#define | ctrlDarkGreenCopper RGB(0x4A,0x76,0x6E)
#define | ctrlDarkOliveGreen RGB(0x4F,0x4F,0x2F)
#define | ctrlColRed RGB(0xFF,0x00,0x00)
#define | ctrlColBlack RGB(0x00,0x00,0x00)
#define | ctrlColWhite RGB(0xFF,0xFF,0xFF)
#define | ctrlColDefault CLR_DEFAULT
#define | ctrlColWinBk GetSysColor(0x80000005L)
#define | ctrlColWinText CC_SYSCOLOR(COLOR_WINDOWTEXT)
#define | ctrlColBtnFace CC_SYSCOLOR(COLOR_BTNFACE)
#define | ctrlColInfoBk CC_SYSCOLOR(COLOR_INFOBK)
#define | ctrlColInfoText CC_SYSCOLOR(COLOR_INFOTEXT)
#define | ctrlColJavaGray RGB(0x64,0x64,0x64)
#define | ctrlColLightGray RGB(0xA8,0xA8,0xA8)
#define | ctrlColGray RGB(0xC0,0xC0,0xC0)

Typedefs

typedef struct _COORD_LONG | COORD_LONG

Define Documentation

#define CC_SYSCOLOR ( ind ) (0x80000000|((ind) & ~CLR_DEFAULT))

Definition at line 12 of file PlotCanvas.h.

#define ctrlColBlack RGB(0x00,0x00,0x00)

Definition at line 24 of file PlotCanvas.h.

#define ctrlColBlue RGB(0x00,0x00,0xFF)

Definition at line 14 of file PlotCanvas.h.

#define ctrlColBtnFace CC_SYSCOLOR(COLOR_BTNFACE)

Definition at line 30 of file PlotCanvas.h.

#define ctrlColDefault CLR_DEFAULT

Definition at line 26 of file PlotCanvas.h.

#define ctrlColGray RGB(0xC0,0xC0,0xC0)

Definition at line 36 of file PlotCanvas.h.

#define ctrlColGreen RGB(0x00,0xFF,0x00)

Definition at line 19 of file PlotCanvas.h.

#define ctrlColInfoBk CC_SYSCOLOR(COLOR_INFOBK)

Definition at line 31 of file PlotCanvas.h.

#define ctrlColInfoText CC_SYSCOLOR(COLOR_INFOTEXT)

Definition at line 32 of file PlotCanvas.h.

#define ctrlColJavaGray RGB(0x64,0x64,0x64)

Definition at line 34 of file PlotCanvas.h.

#define ctrlColLightBlue RGB(0xC0,0xD9,0xD9)

Definition at line 16 of file PlotCanvas.h.

#define ctrlColLightCyan RGB(0xE0,0xFF,0xFF)

Definition at line 17 of file PlotCanvas.h.

#define ctrlColLightGray RGB(0xA8,0xA8,0xA8)

Definition at line 35 of file PlotCanvas.h.

#define ctrlColRed RGB(0xFF,0x00,0x00)

Definition at line 23 of file PlotCanvas.h.

#define ctrlColSkyBlue RGB(0x32,0x99,0xCC)

Definition at line 15 of file PlotCanvas.h.

#define ctrlColWhite RGB(0xFF,0xFF,0xFF)

Definition at line 25 of file PlotCanvas.h.

#define ctrlColWinBk GetSysColor(0x80000005L)

Definition at line 28 of file PlotCanvas.h.

#define ctrlColWinText CC_SYSCOLOR(COLOR_WINDOWTEXT)

Definition at line 29 of file PlotCanvas.h.

#define ctrlColYellow RGB(0x00,0xFF,0xFF)

Definition at line 18 of file PlotCanvas.h.

#define ctrlDarkGreen RGB(0x2F,0x4F,0x2F)

Definition at line 20 of file PlotCanvas.h.

#define ctrlDarkGreenCopper RGB(0x4A,0x76,0x6E)

Definition at line 21 of file PlotCanvas.h.

#define ctrlDarkOliveGreen RGB(0x4F,0x4F,0x2F)

Definition at line 22 of file PlotCanvas.h.

Typedef Documentation

typedef struct _COORD_LONG COORD_LONG
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyComboBox.cpp File Reference

Controls/TrapKeyComboBox.cpp File Reference
#include "stdafx.h"
#include ".\trapkeyComboBox.h"
Include dependency graph for TrapKeyComboBox.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyComboBox.h File Reference

Classes
Controls/TrapKeyComboBox.h File Reference
#include "afxwin.h"
Include dependency graph for TrapKeyComboBox.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CTrapKeyComboBox
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyEdit.cpp File Reference

Controls/TrapKeyEdit.cpp File Reference
#include "stdafx.h"
#include ".\trapkeyedit.h"
Include dependency graph for TrapKeyEdit.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyEdit.h File Reference

Classes
Controls/TrapKeyEdit.h File Reference
#include "afxwin.h"
Include dependency graph for TrapKeyEdit.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CTrapKeyEdit
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/X11Color.h File Reference

Variables
Controls/X11Color.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Variables

const COLORREF | colorAliceBlue = RGB(0xF0,0xF8,0xFF)
const COLORREF | colorAmptekBlue = RGB(0x7A,0xCE,0xFC)
const COLORREF | colorAntiqueWhite = RGB(0xFA,0xEB,0xD7)
const COLORREF | colorAqua = RGB(0x00,0xFF,0xFF)
const COLORREF | colorAquamarine = RGB(0x7F,0xFF,0xD4)
const COLORREF | colorAzure = RGB(0xF0,0xFF,0xFF)
const COLORREF | colorBeige = RGB(0xF5,0xF5,0xDC)
const COLORREF | colorBisque = RGB(0xFF,0xE4,0xC4)
const COLORREF | colorBlack = RGB(0x00,0x00,0x00)
const COLORREF | colorBlanchedAlmond = RGB(0xFF,0xEB,0xCD)
const COLORREF | colorBlue = RGB(0x00,0x00,0xFF)
const COLORREF | colorBlueViolet = RGB(0x8A,0x2B,0xE2)
const COLORREF | colorBrown = RGB(0xA5,0x2A,0x2A)
const COLORREF | colorBurlyWood = RGB(0xDE,0xB8,0x87)
const COLORREF | colorCadetBlue = RGB(0x5F,0x9E,0xA0)
const COLORREF | colorChartreuse = RGB(0x7F,0xFF,0x00)
const COLORREF | colorChocolate = RGB(0xD2,0x69,0x1E)
const COLORREF | colorCoral = RGB(0xFF,0x7F,0x50)
const COLORREF | colorCornflowerBlue = RGB(0x64,0x95,0xED)
const COLORREF | colorCornsilk = RGB(0xFF,0xF8,0xDC)
const COLORREF | colorCrimson = RGB(0xDC,0x14,0x3C)
const COLORREF | colorCyan = RGB(0x00,0xFF,0xFF)
const COLORREF | colorDarkBlue = RGB(0x00,0x00,0x8B)
const COLORREF | colorDarkCyan = RGB(0x00,0x8B,0x8B)
const COLORREF | colorDarkGoldenrod = RGB(0xB8,0x86,0x0B)
const COLORREF | colorDarkGray = RGB(0xA9,0xA9,0xA9)
const COLORREF | colorDarkGreen = RGB(0x00,0x64,0x00)
const COLORREF | colorDarkKhaki = RGB(0xBD,0xB7,0x6B)
const COLORREF | colorDarkMagenta = RGB(0x8B,0x00,0x8B)
const COLORREF | colorDarkOliveGreen = RGB(0x55,0x6B,0x2F)
const COLORREF | colorDarkOrange = RGB(0xFF,0x8C,0x00)
const COLORREF | colorDarkOrchid = RGB(0x99,0x32,0xCC)
const COLORREF | colorDarkRed = RGB(0x8B,0x00,0x00)
const COLORREF | colorDarkSalmon = RGB(0xE9,0x96,0x7A)
const COLORREF | colorDarkSeaGreen = RGB(0x8F,0xBC,0x8F)
const COLORREF | colorDarkSlateBlue = RGB(0x48,0x3D,0x8B)
const COLORREF | colorDarkSlateGray = RGB(0x2F,0x4F,0x4F)
const COLORREF | colorDarkTurquoise = RGB(0x00,0xCE,0xD1)
const COLORREF | colorDarkViolet = RGB(0x94,0x00,0xD3)
const COLORREF | colorDeepPink = RGB(0xFF,0x14,0x93)
const COLORREF | colorDeepSkyBlue = RGB(0x00,0xBF,0xFF)
const COLORREF | colorDimGray = RGB(0x69,0x69,0x69)
const COLORREF | colorDodgerBlue = RGB(0x1E,0x90,0xFF)
const COLORREF | colorFireBrick = RGB(0xB2,0x22,0x22)
const COLORREF | colorFloralWhite = RGB(0xFF,0xFA,0xF0)
const COLORREF | colorForestGreen = RGB(0x22,0x8B,0x22)
const COLORREF | colorFuchsia = RGB(0xFF,0x00,0xFF)
const COLORREF | colorGainsboro = RGB(0xDC,0xDC,0xDC)
const COLORREF | colorGhostWhite = RGB(0xF8,0xF8,0xFF)
const COLORREF | colorGold = RGB(0xFF,0xD7,0x00)
const COLORREF | colorGoldenrod = RGB(0xDA,0xA5,0x20)
const COLORREF | colorGray = RGB(0x80,0x80,0x80)
const COLORREF | colorGreen = RGB(0x00,0x80,0x00)
const COLORREF | colorGreenYellow = RGB(0xAD,0xFF,0x2F)
const COLORREF | colorHoneydew = RGB(0xF0,0xFF,0xF0)
const COLORREF | colorHotPink = RGB(0xFF,0x69,0xB4)
const COLORREF | colorIndianRed = RGB(0xCD,0x5C,0x5C)
const COLORREF | colorIndigo = RGB(0x4B,0x00,0x82)
const COLORREF | colorIvory = RGB(0xFF,0xFF,0xF0)
const COLORREF | colorKhaki = RGB(0xF0,0xE6,0x8C)
const COLORREF | colorLavender = RGB(0xE6,0xE6,0xFA)
const COLORREF | colorLavenderBlush = RGB(0xFF,0xF0,0xF5)
const COLORREF | colorLawnGreen = RGB(0x7C,0xFC,0x00)
const COLORREF | colorLemonChiffon = RGB(0xFF,0xFA,0xCD)
const COLORREF | colorLightBlue = RGB(0xAD,0xD8,0xE6)
const COLORREF | colorLightCoral = RGB(0xF0,0x80,0x80)
const COLORREF | colorLightCyan = RGB(0xE0,0xFF,0xFF)
const COLORREF | colorLightGoldenrodYellow = RGB(0xFA,0xFA,0xD2)
const COLORREF | colorLightGray = RGB(0xD3,0xD3,0xD3)
const COLORREF | colorLightGreen = RGB(0x90,0xEE,0x90)
const COLORREF | colorLightGrey = RGB(0xD3,0xD3,0xD3)
const COLORREF | colorLightPink = RGB(0xFF,0xB6,0xC1)
const COLORREF | colorLightSalmon = RGB(0xFF,0xA0,0x7A)
const COLORREF | colorLightSeaGreen = RGB(0x20,0xB2,0xAA)
const COLORREF | colorLightSkyBlue = RGB(0x87,0xCE,0xFA)
const COLORREF | colorLightSlateGray = RGB(0x77,0x88,0x99)
const COLORREF | colorLightSteelBlue = RGB(0xB0,0xC4,0xDE)
const COLORREF | colorLightYellow = RGB(0xFF,0xFF,0xE0)
const COLORREF | colorLime = RGB(0x00,0xFF,0x00)
const COLORREF | colorLimeGreen = RGB(0x32,0xCD,0x32)
const COLORREF | colorLinen = RGB(0xFA,0xF0,0xE6)
const COLORREF | colorMagenta = RGB(0xFF,0x00,0xFF)
const COLORREF | colorMaroon = RGB(0x80,0x00,0x00)
const COLORREF | colorMediumAquamarine = RGB(0x66,0xCD,0xAA)
const COLORREF | colorMediumBlue = RGB(0x00,0x00,0xCD)
const COLORREF | colorMediumOrchid = RGB(0xBA,0x55,0xD3)
const COLORREF | colorMediumPurple = RGB(0x93,0x70,0xDB)
const COLORREF | colorMediumSeaGreen = RGB(0x3C,0xB3,0x71)
const COLORREF | colorMediumSlateBlue = RGB(0x7B,0x68,0xEE)
const COLORREF | colorMediumSpringGreen = RGB(0x00,0xFA,0x9A)
const COLORREF | colorMediumTurquoise = RGB(0x48,0xD1,0xCC)
const COLORREF | colorMediumVioletRed = RGB(0xC7,0x15,0x85)
const COLORREF | colorMidnightBlue = RGB(0x19,0x19,0x70)
const COLORREF | colorMintCream = RGB(0xF5,0xFF,0xFA)
const COLORREF | colorMistyRose = RGB(0xFF,0xE4,0xE1)
const COLORREF | colorMoccasin = RGB(0xFF,0xE4,0xB5)
const COLORREF | colorNavajoWhite = RGB(0xFF,0xDE,0xAD)
const COLORREF | colorNavy = RGB(0x00,0x00,0x80)
const COLORREF | colorOldLace = RGB(0xFD,0xF5,0xE6)
const COLORREF | colorOlive = RGB(0x80,0x80,0x00)
const COLORREF | colorOliveDrab = RGB(0x6B,0x8E,0x23)
const COLORREF | colorOrange = RGB(0xFF,0xA5,0x00)
const COLORREF | colorOrangeRed = RGB(0xFF,0x45,0x00)
const COLORREF | colorOrchid = RGB(0xDA,0x70,0xD6)
const COLORREF | colorPaleGoldenrod = RGB(0xEE,0xE8,0xAA)
const COLORREF | colorPaleGreen = RGB(0x98,0xFB,0x98)
const COLORREF | colorPaleTurquoise = RGB(0xAF,0xEE,0xEE)
const COLORREF | colorPaleVioletRed = RGB(0xDB,0x70,0x93)
const COLORREF | colorPapayaWhip = RGB(0xFF,0xEF,0xD5)
const COLORREF | colorPeachPuff = RGB(0xFF,0xDA,0xB9)
const COLORREF | colorPeru = RGB(0xCD,0x85,0x3F)
const COLORREF | colorPink = RGB(0xFF,0xC0,0xCB)
const COLORREF | colorPlum = RGB(0xDD,0xA0,0xDD)
const COLORREF | colorPowderBlue = RGB(0xB0,0xE0,0xE6)
const COLORREF | colorPurple = RGB(0x80,0x00,0x80)
const COLORREF | colorRed = RGB(0xFF,0x00,0x00)
const COLORREF | colorRosyBrown = RGB(0xBC,0x8F,0x8F)
const COLORREF | colorRoyalBlue = RGB(0x41,0x69,0xE1)
const COLORREF | colorSaddleBrown = RGB(0x8B,0x45,0x13)
const COLORREF | colorSalmon = RGB(0xFA,0x80,0x72)
const COLORREF | colorSandyBrown = RGB(0xF4,0xA4,0x60)
const COLORREF | colorSeaGreen = RGB(0x2E,0x8B,0x57)
const COLORREF | colorSeaShell = RGB(0xFF,0xF5,0xEE)
const COLORREF | colorSienna = RGB(0xA0,0x52,0x2D)
const COLORREF | colorSilver = RGB(0xC0,0xC0,0xC0)
const COLORREF | colorSkyBlue = RGB(0x87,0xCE,0xEB)
const COLORREF | colorSlateBlue = RGB(0x6A,0x5A,0xCD)
const COLORREF | colorSlateGray = RGB(0x70,0x80,0x90)
const COLORREF | colorSnow = RGB(0xFF,0xFA,0xFA)
const COLORREF | colorSpringGreen = RGB(0x00,0xFF,0x7F)
const COLORREF | colorSteelBlue = RGB(0x46,0x82,0xB4)
const COLORREF | colorTan = RGB(0xD2,0xB4,0x8C)
const COLORREF | colorTeal = RGB(0x00,0x80,0x80)
const COLORREF | colorThistle = RGB(0xD8,0xBF,0xD8)
const COLORREF | colorTomato = RGB(0xFF,0x63,0x47)
const COLORREF | colorTurquoise = RGB(0x40,0xE0,0xD0)
const COLORREF | colorViolet = RGB(0xEE,0x82,0xEE)
const COLORREF | colorWheat = RGB(0xF5,0xDE,0xB3)
const COLORREF | colorWhite = RGB(0xFF,0xFF,0xFF)
const COLORREF | colorWhiteSmoke = RGB(0xF5,0xF5,0xF5)
const COLORREF | colorYellow = RGB(0xFF,0xFF,0x00)
const COLORREF | colorYellowGreen = RGB(0x9A,0xCD,0x32)

Variable Documentation

const COLORREF colorAliceBlue = RGB(0xF0,0xF8,0xFF)

Definition at line 9 of file X11Color.h.

const COLORREF colorAmptekBlue = RGB(0x7A,0xCE,0xFC)

Definition at line 10 of file X11Color.h.

const COLORREF colorAntiqueWhite = RGB(0xFA,0xEB,0xD7)

Definition at line 11 of file X11Color.h.

const COLORREF colorAqua = RGB(0x00,0xFF,0xFF)

Definition at line 12 of file X11Color.h.

const COLORREF colorAquamarine = RGB(0x7F,0xFF,0xD4)

Definition at line 13 of file X11Color.h.

const COLORREF colorAzure = RGB(0xF0,0xFF,0xFF)

Definition at line 14 of file X11Color.h.

const COLORREF colorBeige = RGB(0xF5,0xF5,0xDC)

Definition at line 15 of file X11Color.h.

const COLORREF colorBisque = RGB(0xFF,0xE4,0xC4)

Definition at line 16 of file X11Color.h.

const COLORREF colorBlack = RGB(0x00,0x00,0x00)

Definition at line 17 of file X11Color.h.

const COLORREF colorBlanchedAlmond = RGB(0xFF,0xEB,0xCD)

Definition at line 18 of file X11Color.h.

const COLORREF colorBlue = RGB(0x00,0x00,0xFF)

Definition at line 19 of file X11Color.h.

const COLORREF colorBlueViolet = RGB(0x8A,0x2B,0xE2)

Definition at line 20 of file X11Color.h.

const COLORREF colorBrown = RGB(0xA5,0x2A,0x2A)

Definition at line 21 of file X11Color.h.

const COLORREF colorBurlyWood = RGB(0xDE,0xB8,0x87)

Definition at line 22 of file X11Color.h.

const COLORREF colorCadetBlue = RGB(0x5F,0x9E,0xA0)

Definition at line 23 of file X11Color.h.

const COLORREF colorChartreuse = RGB(0x7F,0xFF,0x00)

Definition at line 24 of file X11Color.h.

const COLORREF colorChocolate = RGB(0xD2,0x69,0x1E)

Definition at line 25 of file X11Color.h.

const COLORREF colorCoral = RGB(0xFF,0x7F,0x50)

Definition at line 26 of file X11Color.h.

const COLORREF colorCornflowerBlue = RGB(0x64,0x95,0xED)

Definition at line 27 of file X11Color.h.

const COLORREF colorCornsilk = RGB(0xFF,0xF8,0xDC)

Definition at line 28 of file X11Color.h.

const COLORREF colorCrimson = RGB(0xDC,0x14,0x3C)

Definition at line 29 of file X11Color.h.

const COLORREF colorCyan = RGB(0x00,0xFF,0xFF)

Definition at line 30 of file X11Color.h.

const COLORREF colorDarkBlue = RGB(0x00,0x00,0x8B)

Definition at line 31 of file X11Color.h.

const COLORREF colorDarkCyan = RGB(0x00,0x8B,0x8B)

Definition at line 32 of file X11Color.h.

const COLORREF colorDarkGoldenrod = RGB(0xB8,0x86,0x0B)

Definition at line 33 of file X11Color.h.

const COLORREF colorDarkGray = RGB(0xA9,0xA9,0xA9)

Definition at line 34 of file X11Color.h.

const COLORREF colorDarkGreen = RGB(0x00,0x64,0x00)

Definition at line 35 of file X11Color.h.

const COLORREF colorDarkKhaki = RGB(0xBD,0xB7,0x6B)

Definition at line 36 of file X11Color.h.

const COLORREF colorDarkMagenta = RGB(0x8B,0x00,0x8B)

Definition at line 37 of file X11Color.h.

const COLORREF colorDarkOliveGreen = RGB(0x55,0x6B,0x2F)

Definition at line 38 of file X11Color.h.

const COLORREF colorDarkOrange = RGB(0xFF,0x8C,0x00)

Definition at line 39 of file X11Color.h.

const COLORREF colorDarkOrchid = RGB(0x99,0x32,0xCC)

Definition at line 40 of file X11Color.h.

const COLORREF colorDarkRed = RGB(0x8B,0x00,0x00)

Definition at line 41 of file X11Color.h.

const COLORREF colorDarkSalmon = RGB(0xE9,0x96,0x7A)

Definition at line 42 of file X11Color.h.

const COLORREF colorDarkSeaGreen = RGB(0x8F,0xBC,0x8F)

Definition at line 43 of file X11Color.h.

const COLORREF colorDarkSlateBlue = RGB(0x48,0x3D,0x8B)

Definition at line 44 of file X11Color.h.

const COLORREF colorDarkSlateGray = RGB(0x2F,0x4F,0x4F)

Definition at line 45 of file X11Color.h.

const COLORREF colorDarkTurquoise = RGB(0x00,0xCE,0xD1)

Definition at line 46 of file X11Color.h.

const COLORREF colorDarkViolet = RGB(0x94,0x00,0xD3)

Definition at line 47 of file X11Color.h.

const COLORREF colorDeepPink = RGB(0xFF,0x14,0x93)

Definition at line 48 of file X11Color.h.

const COLORREF colorDeepSkyBlue = RGB(0x00,0xBF,0xFF)

Definition at line 49 of file X11Color.h.

const COLORREF colorDimGray = RGB(0x69,0x69,0x69)

Definition at line 50 of file X11Color.h.

const COLORREF colorDodgerBlue = RGB(0x1E,0x90,0xFF)

Definition at line 51 of file X11Color.h.

const COLORREF colorFireBrick = RGB(0xB2,0x22,0x22)

Definition at line 52 of file X11Color.h.

const COLORREF colorFloralWhite = RGB(0xFF,0xFA,0xF0)

Definition at line 53 of file X11Color.h.

const COLORREF colorForestGreen = RGB(0x22,0x8B,0x22)

Definition at line 54 of file X11Color.h.

const COLORREF colorFuchsia = RGB(0xFF,0x00,0xFF)

Definition at line 55 of file X11Color.h.

const COLORREF colorGainsboro = RGB(0xDC,0xDC,0xDC)

Definition at line 56 of file X11Color.h.

const COLORREF colorGhostWhite = RGB(0xF8,0xF8,0xFF)

Definition at line 57 of file X11Color.h.

const COLORREF colorGold = RGB(0xFF,0xD7,0x00)

Definition at line 58 of file X11Color.h.

const COLORREF colorGoldenrod = RGB(0xDA,0xA5,0x20)

Definition at line 59 of file X11Color.h.

const COLORREF colorGray = RGB(0x80,0x80,0x80)

Definition at line 60 of file X11Color.h.

const COLORREF colorGreen = RGB(0x00,0x80,0x00)

Definition at line 61 of file X11Color.h.

const COLORREF colorGreenYellow = RGB(0xAD,0xFF,0x2F)

Definition at line 62 of file X11Color.h.

const COLORREF colorHoneydew = RGB(0xF0,0xFF,0xF0)

Definition at line 63 of file X11Color.h.

const COLORREF colorHotPink = RGB(0xFF,0x69,0xB4)

Definition at line 64 of file X11Color.h.

const COLORREF colorIndianRed = RGB(0xCD,0x5C,0x5C)

Definition at line 65 of file X11Color.h.

const COLORREF colorIndigo = RGB(0x4B,0x00,0x82)

Definition at line 66 of file X11Color.h.

const COLORREF colorIvory = RGB(0xFF,0xFF,0xF0)

Definition at line 67 of file X11Color.h.

const COLORREF colorKhaki = RGB(0xF0,0xE6,0x8C)

Definition at line 68 of file X11Color.h.

const COLORREF colorLavender = RGB(0xE6,0xE6,0xFA)

Definition at line 69 of file X11Color.h.

const COLORREF colorLavenderBlush = RGB(0xFF,0xF0,0xF5)

Definition at line 70 of file X11Color.h.

const COLORREF colorLawnGreen = RGB(0x7C,0xFC,0x00)

Definition at line 71 of file X11Color.h.

const COLORREF colorLemonChiffon = RGB(0xFF,0xFA,0xCD)

Definition at line 72 of file X11Color.h.

const COLORREF colorLightBlue = RGB(0xAD,0xD8,0xE6)

Definition at line 73 of file X11Color.h.

const COLORREF colorLightCoral = RGB(0xF0,0x80,0x80)

Definition at line 74 of file X11Color.h.

const COLORREF colorLightCyan = RGB(0xE0,0xFF,0xFF)

Definition at line 75 of file X11Color.h.

const COLORREF colorLightGoldenrodYellow = RGB(0xFA,0xFA,0xD2)

Definition at line 76 of file X11Color.h.

const COLORREF colorLightGray = RGB(0xD3,0xD3,0xD3)

Definition at line 77 of file X11Color.h.

const COLORREF colorLightGreen = RGB(0x90,0xEE,0x90)

Definition at line 78 of file X11Color.h.

const COLORREF colorLightGrey = RGB(0xD3,0xD3,0xD3)

Definition at line 79 of file X11Color.h.

const COLORREF colorLightPink = RGB(0xFF,0xB6,0xC1)

Definition at line 80 of file X11Color.h.

const COLORREF colorLightSalmon = RGB(0xFF,0xA0,0x7A)

Definition at line 81 of file X11Color.h.

const COLORREF colorLightSeaGreen = RGB(0x20,0xB2,0xAA)

Definition at line 82 of file X11Color.h.

const COLORREF colorLightSkyBlue = RGB(0x87,0xCE,0xFA)

Definition at line 83 of file X11Color.h.

const COLORREF colorLightSlateGray = RGB(0x77,0x88,0x99)

Definition at line 84 of file X11Color.h.

const COLORREF colorLightSteelBlue = RGB(0xB0,0xC4,0xDE)

Definition at line 85 of file X11Color.h.

const COLORREF colorLightYellow = RGB(0xFF,0xFF,0xE0)

Definition at line 86 of file X11Color.h.

const COLORREF colorLime = RGB(0x00,0xFF,0x00)

Definition at line 87 of file X11Color.h.

const COLORREF colorLimeGreen = RGB(0x32,0xCD,0x32)

Definition at line 88 of file X11Color.h.

const COLORREF colorLinen = RGB(0xFA,0xF0,0xE6)

Definition at line 89 of file X11Color.h.

const COLORREF colorMagenta = RGB(0xFF,0x00,0xFF)

Definition at line 90 of file X11Color.h.

const COLORREF colorMaroon = RGB(0x80,0x00,0x00)

Definition at line 91 of file X11Color.h.

const COLORREF colorMediumAquamarine = RGB(0x66,0xCD,0xAA)

Definition at line 92 of file X11Color.h.

const COLORREF colorMediumBlue = RGB(0x00,0x00,0xCD)

Definition at line 93 of file X11Color.h.

const COLORREF colorMediumOrchid = RGB(0xBA,0x55,0xD3)

Definition at line 94 of file X11Color.h.

const COLORREF colorMediumPurple = RGB(0x93,0x70,0xDB)

Definition at line 95 of file X11Color.h.

const COLORREF colorMediumSeaGreen = RGB(0x3C,0xB3,0x71)

Definition at line 96 of file X11Color.h.

const COLORREF colorMediumSlateBlue = RGB(0x7B,0x68,0xEE)

Definition at line 97 of file X11Color.h.

const COLORREF colorMediumSpringGreen = RGB(0x00,0xFA,0x9A)

Definition at line 98 of file X11Color.h.

const COLORREF colorMediumTurquoise = RGB(0x48,0xD1,0xCC)

Definition at line 99 of file X11Color.h.

const COLORREF colorMediumVioletRed = RGB(0xC7,0x15,0x85)

Definition at line 100 of file X11Color.h.

const COLORREF colorMidnightBlue = RGB(0x19,0x19,0x70)

Definition at line 101 of file X11Color.h.

const COLORREF colorMintCream = RGB(0xF5,0xFF,0xFA)

Definition at line 102 of file X11Color.h.

const COLORREF colorMistyRose = RGB(0xFF,0xE4,0xE1)

Definition at line 103 of file X11Color.h.

const COLORREF colorMoccasin = RGB(0xFF,0xE4,0xB5)

Definition at line 104 of file X11Color.h.

const COLORREF colorNavajoWhite = RGB(0xFF,0xDE,0xAD)

Definition at line 105 of file X11Color.h.

const COLORREF colorNavy = RGB(0x00,0x00,0x80)

Definition at line 106 of file X11Color.h.

const COLORREF colorOldLace = RGB(0xFD,0xF5,0xE6)

Definition at line 107 of file X11Color.h.

const COLORREF colorOlive = RGB(0x80,0x80,0x00)

Definition at line 108 of file X11Color.h.

const COLORREF colorOliveDrab = RGB(0x6B,0x8E,0x23)

Definition at line 109 of file X11Color.h.

const COLORREF colorOrange = RGB(0xFF,0xA5,0x00)

Definition at line 110 of file X11Color.h.

const COLORREF colorOrangeRed = RGB(0xFF,0x45,0x00)

Definition at line 111 of file X11Color.h.

const COLORREF colorOrchid = RGB(0xDA,0x70,0xD6)

Definition at line 112 of file X11Color.h.

const COLORREF colorPaleGoldenrod = RGB(0xEE,0xE8,0xAA)

Definition at line 113 of file X11Color.h.

const COLORREF colorPaleGreen = RGB(0x98,0xFB,0x98)

Definition at line 114 of file X11Color.h.

const COLORREF colorPaleTurquoise = RGB(0xAF,0xEE,0xEE)

Definition at line 115 of file X11Color.h.

const COLORREF colorPaleVioletRed = RGB(0xDB,0x70,0x93)

Definition at line 116 of file X11Color.h.

const COLORREF colorPapayaWhip = RGB(0xFF,0xEF,0xD5)

Definition at line 117 of file X11Color.h.

const COLORREF colorPeachPuff = RGB(0xFF,0xDA,0xB9)

Definition at line 118 of file X11Color.h.

const COLORREF colorPeru = RGB(0xCD,0x85,0x3F)

Definition at line 119 of file X11Color.h.

const COLORREF colorPink = RGB(0xFF,0xC0,0xCB)

Definition at line 120 of file X11Color.h.

const COLORREF colorPlum = RGB(0xDD,0xA0,0xDD)

Definition at line 121 of file X11Color.h.

const COLORREF colorPowderBlue = RGB(0xB0,0xE0,0xE6)

Definition at line 122 of file X11Color.h.

const COLORREF colorPurple = RGB(0x80,0x00,0x80)

Definition at line 123 of file X11Color.h.

const COLORREF colorRed = RGB(0xFF,0x00,0x00)

Definition at line 124 of file X11Color.h.

const COLORREF colorRosyBrown = RGB(0xBC,0x8F,0x8F)

Definition at line 125 of file X11Color.h.

const COLORREF colorRoyalBlue = RGB(0x41,0x69,0xE1)

Definition at line 126 of file X11Color.h.

const COLORREF colorSaddleBrown = RGB(0x8B,0x45,0x13)

Definition at line 127 of file X11Color.h.

const COLORREF colorSalmon = RGB(0xFA,0x80,0x72)

Definition at line 128 of file X11Color.h.

const COLORREF colorSandyBrown = RGB(0xF4,0xA4,0x60)

Definition at line 129 of file X11Color.h.

const COLORREF colorSeaGreen = RGB(0x2E,0x8B,0x57)

Definition at line 130 of file X11Color.h.

const COLORREF colorSeaShell = RGB(0xFF,0xF5,0xEE)

Definition at line 131 of file X11Color.h.

const COLORREF colorSienna = RGB(0xA0,0x52,0x2D)

Definition at line 132 of file X11Color.h.

const COLORREF colorSilver = RGB(0xC0,0xC0,0xC0)

Definition at line 133 of file X11Color.h.

const COLORREF colorSkyBlue = RGB(0x87,0xCE,0xEB)

Definition at line 134 of file X11Color.h.

const COLORREF colorSlateBlue = RGB(0x6A,0x5A,0xCD)

Definition at line 135 of file X11Color.h.

const COLORREF colorSlateGray = RGB(0x70,0x80,0x90)

Definition at line 136 of file X11Color.h.

const COLORREF colorSnow = RGB(0xFF,0xFA,0xFA)

Definition at line 137 of file X11Color.h.

const COLORREF colorSpringGreen = RGB(0x00,0xFF,0x7F)

Definition at line 138 of file X11Color.h.

const COLORREF colorSteelBlue = RGB(0x46,0x82,0xB4)

Definition at line 139 of file X11Color.h.

const COLORREF colorTan = RGB(0xD2,0xB4,0x8C)

Definition at line 140 of file X11Color.h.

const COLORREF colorTeal = RGB(0x00,0x80,0x80)

Definition at line 141 of file X11Color.h.

const COLORREF colorThistle = RGB(0xD8,0xBF,0xD8)

Definition at line 142 of file X11Color.h.

const COLORREF colorTomato = RGB(0xFF,0x63,0x47)

Definition at line 143 of file X11Color.h.

const COLORREF colorTurquoise = RGB(0x40,0xE0,0xD0)

Definition at line 144 of file X11Color.h.

const COLORREF colorViolet = RGB(0xEE,0x82,0xEE)

Definition at line 145 of file X11Color.h.

const COLORREF colorWheat = RGB(0xF5,0xDE,0xB3)

Definition at line 146 of file X11Color.h.

const COLORREF colorWhite = RGB(0xFF,0xFF,0xFF)

Definition at line 147 of file X11Color.h.

const COLORREF colorWhiteSmoke = RGB(0xF5,0xF5,0xF5)

Definition at line 148 of file X11Color.h.

const COLORREF colorYellow = RGB(0xFF,0xFF,0x00)

Definition at line 149 of file X11Color.h.

const COLORREF colorYellowGreen = RGB(0x9A,0xCD,0x32)

Definition at line 150 of file X11Color.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/AsciiCmdUtilities.cpp File Reference

DeviceIO/AsciiCmdUtilities.cpp File Reference
#include "AsciiCmdUtilities.h"
Include dependency graph for AsciiCmdUtilities.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/AsciiCmdUtilities.h File Reference

Classes | Defines
DeviceIO/AsciiCmdUtilities.h File Reference
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <string>
#include <cctype>
#include "stringex.h"
#include "DppConst.h"
Include dependency graph for AsciiCmdUtilities.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CAsciiCmdUtilities

Defines

#define | DP4_PX4_OLD_CFG_SIZE 64
#define | DP5_MAX_CFG_SIZE 512
#define | Whitespace "\t\n\v\f\r\0x20"

Define Documentation

#define DP4_PX4_OLD_CFG_SIZE 64

Definition at line 14 of file AsciiCmdUtilities.h.

#define DP5_MAX_CFG_SIZE 512

Definition at line 15 of file AsciiCmdUtilities.h.

#define Whitespace "\t\n\v\f\r\0x20"

Definition at line 16 of file AsciiCmdUtilities.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Protocol.cpp File Reference

DeviceIO/DP5Protocol.cpp File Reference
#include "DP5Protocol.h"
Include dependency graph for DP5Protocol.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Protocol.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/DP5Protocol.h File Reference
#include <math.h>
Include dependency graph for DP5Protocol.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _Packet_In
struct | Packet_Out
struct | Spec
class | CDP5Protocol

Defines

#define | ACK 0
#define | SYNC1_ 0xF5
#define | SYNC2_ 0xFA
#define | RS232 0
#define | USB 1
#define | ETHERNET 2
#define | ETHERNET_TIMEOUT 1000
#define | RS232_TIMEOUT 2500
#define | USB_TIMEOUT 500
#define | Retries 2
#define | MAX_BUFFER_DATA 8192
#define | MAX_SCOPE_DATA 2048
#define | USB_DiagDataDelayMS 2500

Typedefs

typedef struct _Packet_In | Packet_In

Enumerations

enum TRANSMIT_PACKET_TYPE {
XMTPT_SEND_STATUS, XMTPT_SEND_SPECTRUM,
XMTPT_SEND_CLEAR_SPECTRUM, XMTPT_SEND_SPECTRUM_STATUS,
XMTPT_SEND_CLEAR_SPECTRUM_STATUS, XMTPT_BUFFER_SPECTRUM,
XMTPT_BUFFER_CLEAR_SPECTRUM, XMTPT_SEND_BUFFER,
XMTPT_SEND_DP4_STYLE_STATUS, XMTPT_SEND_PX4_CONFIG,
XMTPT_SEND_SCOPE_DATA, XMTPT_SEND_512_BYTE_MISC_DATA,
XMTPT_SEND_SCOPE_DATA_REARM, XMTPT_SEND_ETHERNET_SETTINGS,
XMTPT_SEND_DIAGNOSTIC_DATA, XMTPT_SEND_NETFINDER_PACKET,
XMTPT_SEND_HARDWARE_DESCRIPTION, XMTPT_SEND_SCA,
XMTPT_LATCH_SEND_SCA, XMTPT_LATCH_CLEAR_SEND_SCA,
XMTPT_SEND_ROI_OR_FIXED_BLOCK, XMTPT_PX4_STYLE_CONFIG_PACKET,
XMTPT_SEND_CONFIG_PACKET_EX, XMTPT_SEND_CONFIG_PACKET_TO_HW,
XMTPT_READ_CONFIG_PACKET, XMTPT_READ_CONFIG_PACKET_EX,
XMTPT_FULL_READ_CONFIG_PACKET, XMTPT_SCA_READ_CONFIG_PACKET,
XMTPT_ERASE_FPGA_IMAGE, XMTPT_UPLOAD_PACKET_FPGA,
XMTPT_REINITIALIZE_FPGA, XMTPT_ERASE_UC_IMAGE_0,
XMTPT_ERASE_UC_IMAGE_1, XMTPT_ERASE_UC_IMAGE_2,
XMTPT_UPLOAD_PACKET_UC, XMTPT_SWITCH_TO_UC_IMAGE_0,
XMTPT_SWITCH_TO_UC_IMAGE_1, XMTPT_SWITCH_TO_UC_IMAGE_2,
XMTPT_UC_FPGA_CHECKSUMS, XMTPT_CLEAR_SPECTRUM_BUFFER_A,
XMTPT_ENABLE_MCA_MCS, XMTPT_DISABLE_MCA_MCS,
XMTPT_ARM_DIGITAL_OSCILLOSCOPE, XMTPT_AUTOSET_INPUT_OFFSET,
XMTPT_AUTOSET_FAST_THRESHOLD, XMTPT_READ_IO3_0,
XMTPT_WRITE_IO3_0, XMTPT_WRITE_512_BYTE_MISC_DATA,
XMTPT_SET_DCAL, XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ,
XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC, XMTPT_SET_BOOT_FLAGS,
XMTPT_SET_HV_DP4_EMULATION, XMTPT_SET_TEC_DP4_EMULATION,
XMTPT_SET_INPUT_OFFSET_DP4_EMULATION, XMTPT_SET_ADC_CAL_GAIN_OFFSET,
XMTPT_SET_SPECTRUM_OFFSET, XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS,
XMTPT_SET_SERIAL_NUMBER, XMTPT_CLEAR_GP_COUNTER,
XMTPT_SWITCH_SUPPLIES, XMTPT_SEND_TEST_PACKET,
XMTPT_REQ_ACK_PACKET, XMTPT_FORCE_SCOPE_TRIGGER,
XMTPT_READ_MCA8000D_OPTION_PA_CAL, XMTPT_AU34_2_RESTART
}
enum PID1_TYPE {
PID1_REQ_STATUS = 0x01, PID1_REQ_SPECTRUM = 0x02,
PID1_REQ_SCOPE_MISC = 0x03, PID1_REQ_SCA = 0x04,
PID1_REQ_CONFIG = 0x20, PID1_REQ_FPGA_UC = 0x30,
PID1_RCV_STATUS = 0x80, PID1_RCV_SPECTRUM = 0x81,
PID1_RCV_SCOPE_MISC = 0x82, PID1_RCV_SCA = 0x83,
PID1_VENDOR_REQ = 0xF0, PID1_COMM_TEST = 0xF1,
PID1_ACK = 0xFF
}
enum | PID2_REQ_STATUS_TYPE { PID2_SEND_DP4_STYLE_STATUS = 0x01 }
enum PID2_REQ_SPECTRUM_TYPE {
PID2_SEND_SPECTRUM = 0x01, PID2_SEND_CLEAR_SPECTRUM = 0x02,
PID2_SEND_SPECTRUM_STATUS = 0x03, PID2_SEND_CLEAR_SPECTRUM_STATUS = 0x04
}
enum PID2_REQ_SCOPE_MISC_TYPE {
PID2_SEND_SCOPE_DATA = 0x01, PID2_SEND_512_BYTE_MISC_DATA = 0x02,
PID2_SEND_SCOPE_DATA_REARM = 0x03, PID2_SEND_ETHERNET_SETTINGS = 0x04,
PID2_SEND_DIAGNOSTIC_DATA = 0x05, PID2_SEND_HARDWARE_DESCRIPTION = 0x06,
PID2_SEND_NETFINDER_READBACK = 0x07, PID2_SEND_I2C_DATA = 0x08,
PID2_SEND_LIST_MODE_DATA = 0x09, PID2_SEND_OPTION_PA_CALIBRATION = 0x0A
}
enum PID2_REQ_SCA_TYPE {
PID2_SEND_SCA = 0x01, PID2_LATCH_SEND_SCA = 0x02,
PID2_LATCH_CLEAR_SEND_SCA = 0x03
}
enum PID2_REQ_CONFIG_TYPE {
PID2_PX4_STYLE_CONFIG_PACKET = 0x01, PID2_TEXT_CONFIG_PACKET = 0x02,
PID2_CONFIG_READBACK_PACKET = 0x03
}
enum PID2_REQ_FPGA_UC_TYPE {
PID2_ERASE_FPGA_IMAGE = 0x01, PID2_UPLOAD_PACKET_FPGA = 0x02,
PID2_REINITIALIZE_FPGA = 0x03, PID2_ERASE_UC_IMAGE_0 = 0x04,
PID2_ERASE_UC_IMAGE_1 = 0x05, PID2_ERASE_UC_IMAGE_2 = 0x06,
PID2_UPLOAD_PACKET_UC = 0x07, PID2_SWITCH_TO_UC_IMAGE_0 = 0x08,
PID2_SWITCH_TO_UC_IMAGE_1 = 0x09, PID2_SWITCH_TO_UC_IMAGE_2 = 0x0A
}
enum PID2_VENDOR_REQ_TYPE {
PID2_CLEAR_SPECTRUM_BUFFER_A = 0x01, PID2_ENABLE_MCA_MCS = 0x02,
PID2_DISABLE_MCA_MCS = 0x03, PID2_ARM_DIGITAL_OSCILLOSCOPE = 0x04,
PID2_AUTOSET_INPUT_OFFSET = 0x05, PID2_AUTOSET_FAST_THRESHOLD = 0x06,
PID2_READ_IO3_0 = 0x07, PID2_WRITE_IO3_0 = 0x08,
PID2_WRITE_512_BYTE_MISC_DATA = 0x09, PID2_SET_DCAL = 0x0A,
PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ = 0x0B, PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC = 0x0C,
PID2_SET_BOOT_FLAGS = 0x0D, PID2_SET_ADC_CAL_GAIN_OFFSET = 0x0E,
PID2_SET_SERIAL_NUMBER = 0x0F, PID2_CLEAR_GP_COUNTER = 0x10,
PID2_SET_ETHERNET_SETTINGS = 0x11, PID2_ETHERNET_ALLOW_SHAREING = 0x20,
PID2_ETHERNET_NO_SHARING = 0x21, PID2_ETHERNET_LOCK_IP = 0x22,
PID2_GENERIC_FPGA_WRITE = 0x89
}
enum | PID2_RCV_STATUS_TYPE { RCVPT_DP4_STYLE_STATUS = 0x01 }
enum PID2_RCV_SPECTRUM_TYPE {
RCVPT_256_CHANNEL_SPECTRUM = 0x01, RCVPT_256_CHANNEL_SPECTRUM_STATUS = 0x02,
RCVPT_512_CHANNEL_SPECTRUM = 0x03, RCVPT_512_CHANNEL_SPECTRUM_STATUS = 0x04,
RCVPT_1024_CHANNEL_SPECTRUM = 0x05, RCVPT_1024_CHANNEL_SPECTRUM_STATUS = 0x06,
RCVPT_2048_CHANNEL_SPECTRUM = 0x07, RCVPT_2048_CHANNEL_SPECTRUM_STATUS = 0x08,
RCVPT_4096_CHANNEL_SPECTRUM = 0x09, RCVPT_4096_CHANNEL_SPECTRUM_STATUS = 0x0A,
RCVPT_8192_CHANNEL_SPECTRUM = 0x0B, RCVPT_8192_CHANNEL_SPECTRUM_STATUS = 0x0C
}
enum PID2_RCV_SCOPE_MISC_TYPE {
RCVPT_SCOPE_DATA = 0x01, RCVPT_512_BYTE_MISC_DATA = 0x02,
RCVPT_SCOPE_DATA_WITH_OVERFLOW = 0x03, RCVPT_ETHERNET_SETTINGS = 0x04,
RCVPT_DIAGNOSTIC_DATA = 0x05, RCVPT_HARDWARE_DESCRIPTION = 0x06,
RCVPT_CONFIG_READBACK = 0x07, RCVPT_NETFINDER_READBACK = 0x08,
RCVPT_I2C_DATA = 0x09, RCVPT_LIST_MODE_DATA = 0x0A,
RCVPT_LIST_MODE_DATA_FIFO_FULL = 0x0B, RCVPT_OPTION_PA_CALIBRATION = 0x0C
}
enum | PID2_RCV_SCA_TYPE { RCVPT_SCA = 0x01 }
enum PID2_ACK_TYPE {
PID2_ACK_OK = 0x00, PID2_ACK_SYNC_ERROR = 0x01,
PID2_ACK_PID_ERROR = 0x02, PID2_ACK_LEN_ERROR = 0x03,
PID2_ACK_CHECKSUM_ERROR = 0x04, PID2_ACK_BAD_PARAM = 0x05,
PID2_ACK_BAD_HEX_REC = 0x06, PID2_ACK_UNRECOG = 0x07,
PID2_ACK_FPGA_ERROR = 0x08, PID2_ACK_CP2201_NOT_FOUND = 0x09,
PID2_ACK_SCOPE_DATA_NOT_AVAIL = 0x0A, PID2_ACK_PC5_NOT_PRESENT = 0x0B,
PID2_ACK_OK_ETHERNET_SHARE_REQ = 0x0C, PID2_ACK_ETHERNET_BUSY = 0x0D,
PID2_ACK_I2C_ERROR = 0x0E, PID2_ACK_OK_FPGA_UPLOAD_ADDR = 0x0F,
PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED = 0x10, PID2_ACK_CAL_DATA_NOT_PRESENT = 0x11
}

Define Documentation

#define ACK 0

Definition at line 260 of file DP5Protocol.h.

#define ETHERNET 2

Definition at line 268 of file DP5Protocol.h.

#define ETHERNET_TIMEOUT 1000

Definition at line 270 of file DP5Protocol.h.

#define MAX_BUFFER_DATA 8192

Definition at line 293 of file DP5Protocol.h.

#define MAX_SCOPE_DATA 2048

Definition at line 294 of file DP5Protocol.h.

#define Retries 2

Definition at line 274 of file DP5Protocol.h.

#define RS232 0

Definition at line 266 of file DP5Protocol.h.

#define RS232_TIMEOUT 2500

Definition at line 271 of file DP5Protocol.h.

#define SYNC1_ 0xF5

Definition at line 263 of file DP5Protocol.h.

#define SYNC2_ 0xFA

Definition at line 264 of file DP5Protocol.h.

#define USB 1

Definition at line 267 of file DP5Protocol.h.

#define USB_DiagDataDelayMS 2500

Definition at line 295 of file DP5Protocol.h.

#define USB_TIMEOUT 500

Definition at line 272 of file DP5Protocol.h.

Typedef Documentation

typedef struct _Packet_In Packet_In

Enumeration Type Documentation

enum PID1_TYPE
Enumerator:
PID1_REQ_STATUS
PID1_REQ_SPECTRUM
PID1_REQ_SCOPE_MISC
PID1_REQ_SCA
PID1_REQ_CONFIG
PID1_REQ_FPGA_UC
PID1_RCV_STATUS
PID1_RCV_SPECTRUM
PID1_RCV_SCOPE_MISC
PID1_RCV_SCA
PID1_VENDOR_REQ
PID1_COMM_TEST
PID1_ACK

Definition at line 98 of file DP5Protocol.h.

enum PID2_ACK_TYPE
Enumerator:
PID2_ACK_OK
PID2_ACK_SYNC_ERROR
PID2_ACK_PID_ERROR
PID2_ACK_LEN_ERROR
PID2_ACK_CHECKSUM_ERROR
PID2_ACK_BAD_PARAM
PID2_ACK_BAD_HEX_REC
PID2_ACK_UNRECOG
PID2_ACK_FPGA_ERROR
PID2_ACK_CP2201_NOT_FOUND
PID2_ACK_SCOPE_DATA_NOT_AVAIL
PID2_ACK_PC5_NOT_PRESENT
PID2_ACK_OK_ETHERNET_SHARE_REQ
PID2_ACK_ETHERNET_BUSY
PID2_ACK_I2C_ERROR
PID2_ACK_OK_FPGA_UPLOAD_ADDR
PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED
PID2_ACK_CAL_DATA_NOT_PRESENT

Definition at line 237 of file DP5Protocol.h.

enum PID2_RCV_SCA_TYPE
Enumerator:
RCVPT_SCA

Definition at line 233 of file DP5Protocol.h.

enum PID2_RCV_SCOPE_MISC_TYPE
Enumerator:
RCVPT_SCOPE_DATA
RCVPT_512_BYTE_MISC_DATA
RCVPT_SCOPE_DATA_WITH_OVERFLOW
RCVPT_ETHERNET_SETTINGS
RCVPT_DIAGNOSTIC_DATA
RCVPT_HARDWARE_DESCRIPTION
RCVPT_CONFIG_READBACK
RCVPT_NETFINDER_READBACK
RCVPT_I2C_DATA
RCVPT_LIST_MODE_DATA
RCVPT_LIST_MODE_DATA_FIFO_FULL
RCVPT_OPTION_PA_CALIBRATION

Definition at line 218 of file DP5Protocol.h.

enum PID2_RCV_SPECTRUM_TYPE
Enumerator:
RCVPT_256_CHANNEL_SPECTRUM
RCVPT_256_CHANNEL_SPECTRUM_STATUS
RCVPT_512_CHANNEL_SPECTRUM
RCVPT_512_CHANNEL_SPECTRUM_STATUS
RCVPT_1024_CHANNEL_SPECTRUM
RCVPT_1024_CHANNEL_SPECTRUM_STATUS
RCVPT_2048_CHANNEL_SPECTRUM
RCVPT_2048_CHANNEL_SPECTRUM_STATUS
RCVPT_4096_CHANNEL_SPECTRUM
RCVPT_4096_CHANNEL_SPECTRUM_STATUS
RCVPT_8192_CHANNEL_SPECTRUM
RCVPT_8192_CHANNEL_SPECTRUM_STATUS

Definition at line 203 of file DP5Protocol.h.

enum PID2_RCV_STATUS_TYPE
Enumerator:
RCVPT_DP4_STYLE_STATUS

Definition at line 199 of file DP5Protocol.h.

enum PID2_REQ_CONFIG_TYPE
Enumerator:
PID2_PX4_STYLE_CONFIG_PACKET
PID2_TEXT_CONFIG_PACKET
PID2_CONFIG_READBACK_PACKET

Definition at line 149 of file DP5Protocol.h.

enum PID2_REQ_FPGA_UC_TYPE
Enumerator:
PID2_ERASE_FPGA_IMAGE
PID2_UPLOAD_PACKET_FPGA
PID2_REINITIALIZE_FPGA
PID2_ERASE_UC_IMAGE_0
PID2_ERASE_UC_IMAGE_1
PID2_ERASE_UC_IMAGE_2
PID2_UPLOAD_PACKET_UC
PID2_SWITCH_TO_UC_IMAGE_0
PID2_SWITCH_TO_UC_IMAGE_1
PID2_SWITCH_TO_UC_IMAGE_2

Definition at line 155 of file DP5Protocol.h.

enum PID2_REQ_SCA_TYPE
Enumerator:
PID2_SEND_SCA
PID2_LATCH_SEND_SCA
PID2_LATCH_CLEAR_SEND_SCA

Definition at line 143 of file DP5Protocol.h.

enum PID2_REQ_SCOPE_MISC_TYPE
Enumerator:
PID2_SEND_SCOPE_DATA
PID2_SEND_512_BYTE_MISC_DATA
PID2_SEND_SCOPE_DATA_REARM
PID2_SEND_ETHERNET_SETTINGS
PID2_SEND_DIAGNOSTIC_DATA
PID2_SEND_HARDWARE_DESCRIPTION
PID2_SEND_NETFINDER_READBACK
PID2_SEND_I2C_DATA
PID2_SEND_LIST_MODE_DATA
PID2_SEND_OPTION_PA_CALIBRATION

Definition at line 130 of file DP5Protocol.h.

enum PID2_REQ_SPECTRUM_TYPE
Enumerator:
PID2_SEND_SPECTRUM
PID2_SEND_CLEAR_SPECTRUM
PID2_SEND_SPECTRUM_STATUS
PID2_SEND_CLEAR_SPECTRUM_STATUS

Definition at line 118 of file DP5Protocol.h.

enum PID2_REQ_STATUS_TYPE
Enumerator:
PID2_SEND_DP4_STYLE_STATUS

Definition at line 114 of file DP5Protocol.h.

enum PID2_VENDOR_REQ_TYPE
Enumerator:
PID2_CLEAR_SPECTRUM_BUFFER_A
PID2_ENABLE_MCA_MCS
PID2_DISABLE_MCA_MCS
PID2_ARM_DIGITAL_OSCILLOSCOPE
PID2_AUTOSET_INPUT_OFFSET
PID2_AUTOSET_FAST_THRESHOLD
PID2_READ_IO3_0
PID2_WRITE_IO3_0
PID2_WRITE_512_BYTE_MISC_DATA
PID2_SET_DCAL
PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ
PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC
PID2_SET_BOOT_FLAGS
PID2_SET_ADC_CAL_GAIN_OFFSET
PID2_SET_SERIAL_NUMBER
PID2_CLEAR_GP_COUNTER
PID2_SET_ETHERNET_SETTINGS
PID2_ETHERNET_ALLOW_SHAREING
PID2_ETHERNET_NO_SHARING
PID2_ETHERNET_LOCK_IP
PID2_GENERIC_FPGA_WRITE

Definition at line 169 of file DP5Protocol.h.

enum TRANSMIT_PACKET_TYPE

CDP5Protocol CDP5Protocol

Enumerator:
XMTPT_SEND_STATUS
XMTPT_SEND_SPECTRUM
XMTPT_SEND_CLEAR_SPECTRUM
XMTPT_SEND_SPECTRUM_STATUS
XMTPT_SEND_CLEAR_SPECTRUM_STATUS
XMTPT_BUFFER_SPECTRUM
XMTPT_BUFFER_CLEAR_SPECTRUM
XMTPT_SEND_BUFFER
XMTPT_SEND_DP4_STYLE_STATUS
XMTPT_SEND_PX4_CONFIG
XMTPT_SEND_SCOPE_DATA
XMTPT_SEND_512_BYTE_MISC_DATA
XMTPT_SEND_SCOPE_DATA_REARM
XMTPT_SEND_ETHERNET_SETTINGS
XMTPT_SEND_DIAGNOSTIC_DATA
XMTPT_SEND_NETFINDER_PACKET
XMTPT_SEND_HARDWARE_DESCRIPTION
XMTPT_SEND_SCA
XMTPT_LATCH_SEND_SCA
XMTPT_LATCH_CLEAR_SEND_SCA
XMTPT_SEND_ROI_OR_FIXED_BLOCK
XMTPT_PX4_STYLE_CONFIG_PACKET
XMTPT_SEND_CONFIG_PACKET_EX
XMTPT_SEND_CONFIG_PACKET_TO_HW
XMTPT_READ_CONFIG_PACKET
XMTPT_READ_CONFIG_PACKET_EX
XMTPT_FULL_READ_CONFIG_PACKET
XMTPT_SCA_READ_CONFIG_PACKET
XMTPT_ERASE_FPGA_IMAGE
XMTPT_UPLOAD_PACKET_FPGA
XMTPT_REINITIALIZE_FPGA
XMTPT_ERASE_UC_IMAGE_0
XMTPT_ERASE_UC_IMAGE_1
XMTPT_ERASE_UC_IMAGE_2
XMTPT_UPLOAD_PACKET_UC
XMTPT_SWITCH_TO_UC_IMAGE_0
XMTPT_SWITCH_TO_UC_IMAGE_1
XMTPT_SWITCH_TO_UC_IMAGE_2
XMTPT_UC_FPGA_CHECKSUMS
XMTPT_CLEAR_SPECTRUM_BUFFER_A
XMTPT_ENABLE_MCA_MCS
XMTPT_DISABLE_MCA_MCS
XMTPT_ARM_DIGITAL_OSCILLOSCOPE
XMTPT_AUTOSET_INPUT_OFFSET
XMTPT_AUTOSET_FAST_THRESHOLD
XMTPT_READ_IO3_0
XMTPT_WRITE_IO3_0
XMTPT_WRITE_512_BYTE_MISC_DATA
XMTPT_SET_DCAL
XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ
XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC
XMTPT_SET_BOOT_FLAGS
XMTPT_SET_HV_DP4_EMULATION
XMTPT_SET_TEC_DP4_EMULATION
XMTPT_SET_INPUT_OFFSET_DP4_EMULATION
XMTPT_SET_ADC_CAL_GAIN_OFFSET
XMTPT_SET_SPECTRUM_OFFSET
XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS
XMTPT_SET_SERIAL_NUMBER
XMTPT_CLEAR_GP_COUNTER
XMTPT_SWITCH_SUPPLIES
XMTPT_SEND_TEST_PACKET
XMTPT_REQ_ACK_PACKET
XMTPT_FORCE_SCOPE_TRIGGER
XMTPT_READ_MCA8000D_OPTION_PA_CAL
XMTPT_AU34_2_RESTART

Definition at line 5 of file DP5Protocol.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Status.cpp File Reference

DeviceIO/DP5Status.cpp File Reference
#include "DP5Status.h"
#include "stringex.h"
#include "DppConst.h"
Include dependency graph for DP5Status.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Status.h File Reference

Classes | Typedefs | Enumerations
DeviceIO/DP5Status.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include "DP5Protocol.h"
#include "DppUtilities.h"
Include dependency graph for DP5Status.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | DP5_DP4_FORMAT_STATUS
struct | _DiagDataType
class | CDP5Status

Typedefs

typedef enum _PX5_OPTIONS | PX5_OPTIONS
typedef struct
DP5_DP4_FORMAT_STATUS 		DP4_FORMAT_STATUS
typedef struct
DP5_DP4_FORMAT_STATUS * 		PDP4_FORMAT_STATUS
typedef struct _DiagDataType | DiagDataType
typedef struct _DiagDataType * | PDDiagDataType

Enumerations

enum _PX5_OPTIONS {
PX5_OPTION_NONE = 0, PX5_OPTION_HPGe_HVPS = 1,
PX5_OPTION_TEST_TEK = 4, PX5_OPTION_TEST_MOX = 5,
PX5_OPTION_TEST_AMP = 6, PX5_OPTION_TEST_MODE_1 = 8,
PX5_OPTION_TEST_MODE_2 = 9
}

Typedef Documentation

typedef struct _DiagDataType DiagDataType
typedef struct DP5_DP4_FORMAT_STATUS DP4_FORMAT_STATUS
typedef struct _DiagDataType * PDDiagDataType
typedef struct DP5_DP4_FORMAT_STATUS * PDP4_FORMAT_STATUS
typedef enum _PX5_OPTIONS PX5_OPTIONS

CDP5Status CDP5Status

Enumeration Type Documentation

enum _PX5_OPTIONS

CDP5Status CDP5Status

Enumerator:
PX5_OPTION_NONE
PX5_OPTION_HPGe_HVPS
PX5_OPTION_TEST_TEK
PX5_OPTION_TEST_MOX
PX5_OPTION_TEST_AMP
PX5_OPTION_TEST_MODE_1
PX5_OPTION_TEST_MODE_2

Definition at line 9 of file DP5Status.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppComm.cpp File Reference

DeviceIO/DppComm.cpp File Reference
#include "stdafx.h"
#include "DppComm.h"
#include <assert.h>
Include dependency graph for DppComm.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppComm.h File Reference

Classes | Defines
DeviceIO/DppComm.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppComm

Defines

#define | WM_DPPCOMM_RCV_CHAR (WM_USER + 400)
#define | EV_THREAD_EXIT_EVENT 0
#define | EV_READ_STATUS_EVENT 1
#define | EV_WRITE_DATA_EVENT 2

Define Documentation

#define EV_READ_STATUS_EVENT 1

Definition at line 5 of file DppComm.h.

#define EV_THREAD_EXIT_EVENT 0

Definition at line 4 of file DppComm.h.

#define EV_WRITE_DATA_EVENT 2

Definition at line 6 of file DppComm.h.

#define WM_DPPCOMM_RCV_CHAR (WM_USER + 400)

Definition at line 3 of file DppComm.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppConst.h File Reference

Defines | Typedefs | Enumerations
DeviceIO/DppConst.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | DP5_DPP_TYPES_FIRST dppDP5
#define | DP5_DPP_TYPES_LAST dppDP5X

Typedefs

typedef enum DP5_DPP_TYPES | dp5DppTypes

Enumerations

enum DP5_DPP_TYPES {
dppDP5, dppPX5,
dppDP5G, dppMCA8000D,
dppTB5, dppDP5X
}

Define Documentation

#define DP5_DPP_TYPES_FIRST dppDP5

Definition at line 20 of file DppConst.h.

#define DP5_DPP_TYPES_LAST dppDP5X

Definition at line 21 of file DppConst.h.

Typedef Documentation

typedef enum DP5_DPP_TYPES dp5DppTypes

Enumeration Type Documentation

enum DP5_DPP_TYPES
Enumerator:
dppDP5

DP5 uses DPP new (this) protocol is supported in this application ==0.

dppPX5

PX5 uses DPP new (this) protocol is supported in this application ==1.

dppDP5G

DP5G uses DPP new (this) protocol is supported in this application ==2.

dppMCA8000D

MCA8000D uses DPP new (this) protocol is supported in this application ==3.

dppTB5

TB5 uses DPP new (this) protocol is supported in this application ==4.

dppDP5X

DP5X uses DPP new (this) protocol is supported in this application ==5.

Definition at line 4 of file DppConst.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppLibUsb.cpp File Reference

DeviceIO/DppLibUsb.cpp File Reference
#include "DppLibUsb.h"
Include dependency graph for DppLibUsb.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppLibUsb.h File Reference

Classes | Defines
DeviceIO/DppLibUsb.h File Reference
#include <libusb.h>
#include <stdio.h>
#include <sys/types.h>
#include <string.h>
Include dependency graph for DppLibUsb.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppLibUsb

Defines

#define | AMPTEK_DP5_VENDOR_ID 0x10C4
#define | AMPTEK_DP5_PRODUCT_ID 0x842A
#define | INTERFACE_NUMBER 0
#define | TIMEOUT_MS 5000
#define | BULK_IN_ENDPOINT 0x81
#define | BULK_OUT_ENDPOINT 0x02
#define | MAX_BULK_IN_TRANSFER_SIZE 32768
#define | MAX_BULK_OUT_TRANSFER_SIZE 520
#define | STATUS_PACKET_SIZE 64
#define | DP5_USB_TIMEOUT 500
#define | DP5_DIAGDATA_TIMEOUT 2500
#define | PID1_REQ_SCOPE_MISC_TO 0x03
#define | PID2_SEND_DIAGNOSTIC_DATA_TO 0x05

Define Documentation

#define AMPTEK_DP5_PRODUCT_ID 0x842A

Definition at line 21 of file DppLibUsb.h.

#define AMPTEK_DP5_VENDOR_ID 0x10C4

Definition at line 20 of file DppLibUsb.h.

#define BULK_IN_ENDPOINT 0x81

Definition at line 25 of file DppLibUsb.h.

#define BULK_OUT_ENDPOINT 0x02

Definition at line 26 of file DppLibUsb.h.

#define DP5_DIAGDATA_TIMEOUT 2500

Definition at line 31 of file DppLibUsb.h.

#define DP5_USB_TIMEOUT 500

Definition at line 30 of file DppLibUsb.h.

#define INTERFACE_NUMBER 0

Definition at line 23 of file DppLibUsb.h.

#define MAX_BULK_IN_TRANSFER_SIZE 32768

Definition at line 27 of file DppLibUsb.h.

#define MAX_BULK_OUT_TRANSFER_SIZE 520

Definition at line 28 of file DppLibUsb.h.

#define PID1_REQ_SCOPE_MISC_TO 0x03

Definition at line 32 of file DppLibUsb.h.

#define PID2_SEND_DIAGNOSTIC_DATA_TO 0x05

Definition at line 33 of file DppLibUsb.h.

#define STATUS_PACKET_SIZE 64

Definition at line 29 of file DppLibUsb.h.

#define TIMEOUT_MS 5000

Definition at line 24 of file DppLibUsb.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppSocket.cpp File Reference

DeviceIO/DppSocket.cpp File Reference
#include "stdafx.h"
#include "DppSocket.h"
Include dependency graph for DppSocket.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppSocket.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/DppSocket.h File Reference
#include "stdafx.h"
Include dependency graph for DppSocket.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppSocket

Defines

#define | WM_DPPSOCKET_RCV_BUFFER (WM_USER + 401)

Typedefs

typedef enum _SocketOwnerType | SocketOwnerType

Enumerations

enum _SocketOwnerType {
sockownNone, sockownMainDlg,
sockownStartDlg
}

Define Documentation

#define WM_DPPSOCKET_RCV_BUFFER (WM_USER + 401)

Definition at line 8 of file DppSocket.h.

Typedef Documentation

typedef enum _SocketOwnerType SocketOwnerType

Enumeration Type Documentation

enum _SocketOwnerType
Enumerator:
sockownNone
sockownMainDlg
sockownStartDlg

Definition at line 12 of file DppSocket.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppUtilities.cpp File Reference

DeviceIO/DppUtilities.cpp File Reference
#include "DppUtilities.h"
#include "stringex.h"
Include dependency graph for DppUtilities.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppUtilities.h File Reference

Classes
DeviceIO/DppUtilities.h File Reference
#include <stdlib.h>
#include <math.h>
#include <string>
Include dependency graph for DppUtilities.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CDppUtilities
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppWinUSB.cpp File Reference

DeviceIO/DppWinUSB.cpp File Reference
#include "StdAfx.h"
#include "DppWinUSB.h"
Include dependency graph for DppWinUSB.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppWinUSB.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/DppWinUSB.h File Reference
#include <Windows.h>
#include <Strsafe.h>
#include "stringex.h"
#include <Winusb.h>
#include <Setupapi.h>
#include "guid.h"
#include <Dbt.h>
#include "DP5Protocol.h"
Include dependency graph for DppWinUSB.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | WINUSB_DEVICE_INFO
Holds WinUSB device information. More...
class | CDppWinUSB

Defines

#define | MAX_DEVPATH_LENGTH 256
#define | MAXDP5S 128
#define | MAXREGBUFFER 128
#define | WinUSBService "SYSTEM\\CurrentControlSet\\Services\\WinUSB\\Enum"
#define | WinUsbDP5 "USB\\Vid_10c4&Pid_842a"
#define | WinUsbDP5Size 21
#define | DRV_INFO_OPTION_NONE 0x00
#define | DRV_INFO_OPTION_MFG_NAME 0x01
#define | DRV_INFO_OPTION_PROV_NAME 0x02
#define | DRV_INFO_OPTION_DESC 0x04
#define | DRV_INFO_OPTION_DATE 0x08
#define | DRV_INFO_OPTION_VER 0x10
#define | DRV_INFO_OPTION_MS_TERM 0x20
#define | DRV_INFO_OPTION_UX_TERM 0x40
#define | DRV_INFO_OPTION_LABEL 0x80
#define | DRV_INFO_OPTION_ALL 0xFF
#define | MAXPIPES 10

Typedefs

typedef enum _DPP_USB_STATUS | DPP_USB_STATUS
typedef struct WINUSB_DEVICE_INFO | DEVICE_INFO
Holds WinUSB device information.
typedef struct WINUSB_DEVICE_INFO * | PDEVICE_INFO

Enumerations

enum _DPP_USB_STATUS {
dusbStatNoAction, dusbStatNewConnect,
dusbStatConnectFail
}

Define Documentation

#define DRV_INFO_OPTION_ALL 0xFF

Definition at line 35 of file DppWinUSB.h.

#define DRV_INFO_OPTION_DATE 0x08

Definition at line 30 of file DppWinUSB.h.

#define DRV_INFO_OPTION_DESC 0x04

Definition at line 29 of file DppWinUSB.h.

#define DRV_INFO_OPTION_LABEL 0x80

Definition at line 34 of file DppWinUSB.h.

#define DRV_INFO_OPTION_MFG_NAME 0x01

Definition at line 27 of file DppWinUSB.h.

#define DRV_INFO_OPTION_MS_TERM 0x20

Definition at line 32 of file DppWinUSB.h.

#define DRV_INFO_OPTION_NONE 0x00

Definition at line 26 of file DppWinUSB.h.

#define DRV_INFO_OPTION_PROV_NAME 0x02

Definition at line 28 of file DppWinUSB.h.

#define DRV_INFO_OPTION_UX_TERM 0x40

Definition at line 33 of file DppWinUSB.h.

#define DRV_INFO_OPTION_VER 0x10

Definition at line 31 of file DppWinUSB.h.

#define MAX_DEVPATH_LENGTH 256

CDppWinUSB CDppWinUSB

Definition at line 20 of file DppWinUSB.h.

#define MAXDP5S 128

Definition at line 21 of file DppWinUSB.h.

#define MAXPIPES 10

Definition at line 36 of file DppWinUSB.h.

#define MAXREGBUFFER 128

Definition at line 22 of file DppWinUSB.h.

#define WinUsbDP5 "USB\\Vid_10c4&Pid_842a"

Definition at line 24 of file DppWinUSB.h.

#define WinUsbDP5Size 21

Definition at line 25 of file DppWinUSB.h.

#define WinUSBService "SYSTEM\\CurrentControlSet\\Services\\WinUSB\\Enum"

Definition at line 23 of file DppWinUSB.h.

Typedef Documentation

typedef struct WINUSB_DEVICE_INFO DEVICE_INFO

Holds WinUSB device information.

typedef enum _DPP_USB_STATUS DPP_USB_STATUS
typedef struct WINUSB_DEVICE_INFO * PDEVICE_INFO

Enumeration Type Documentation

enum _DPP_USB_STATUS
Enumerator:
dusbStatNoAction
dusbStatNewConnect
dusbStatConnectFail

Definition at line 38 of file DppWinUSB.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/guid.h File Reference

Functions
DeviceIO/guid.h File Reference
#include <objbase.h>
#include <initguid.h>
Include dependency graph for guid.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Functions

DEFINE_GUID (GUID_DP5_INTERFACE_CLASS, 0x5a8ed6a1, 0x7fc3, 0x4b6a, 0xa5, 0x36, 0x95, 0xdf, 0x35, 0xd0, 0x34, 0x48)
Device Interface ID {5A8ED6A1-7FC3-4b6a-A536-95DF35D03448}.
DEFINE_GUID (GUID_DP5_SETUP_CLASS, 0x6a4e9a2d, 0x9368, 0x4f01, 0x8e, 0x60, 0xb3, 0xf9, 0xcd, 0xba, 0xb5, 0xe8)
Setup Class ID {6A4E9A2D-9368-4f01-8E60-B3F9CDBAB5E8}.

Function Documentation

DEFINE_GUID | ( | GUID_DP5_INTERFACE_CLASS | ,
 |  | 0x5a8ed6a1 | ,
 |  | 0x7fc3 | ,
 |  | 0x4b6a | ,
 |  | 0xa5 | ,
 |  | 0x36 | ,
 |  | 0x95 | ,
 |  | 0xdf | ,
 |  | 0x35 | ,
 |  | 0xd0 | ,
 |  | 0x34 | ,
 |  | 0x48 |
 | ) |  |

Device Interface ID {5A8ED6A1-7FC3-4b6a-A536-95DF35D03448}.

DEFINE_GUID | ( | GUID_DP5_SETUP_CLASS | ,
 |  | 0x6a4e9a2d | ,
 |  | 0x9368 | ,
 |  | 0x4f01 | ,
 |  | 0x8e | ,
 |  | 0x60 | ,
 |  | 0xb3 | ,
 |  | 0xf9 | ,
 |  | 0xcd | ,
 |  | 0xba | ,
 |  | 0xb5 | ,
 |  | 0xe8 |
 | ) |  |

Setup Class ID {6A4E9A2D-9368-4f01-8E60-B3F9CDBAB5E8}.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/MSecTimer.cpp File Reference

DeviceIO/MSecTimer.cpp File Reference
#include ".\msectimer.h"
Include dependency graph for MSecTimer.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/MSecTimer.h File Reference

Classes
DeviceIO/MSecTimer.h File Reference
#include "stdafx.h"
#include <math.h>
#include <Mmsystem.h>
Include dependency graph for MSecTimer.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CMSecTimer
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/NetFinder.cpp File Reference

DeviceIO/NetFinder.cpp File Reference
#include "StdAfx.h"
#include "NetFinder.h"
#include <time.h>
#include <math.h>
Include dependency graph for NetFinder.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/NetFinder.h File Reference

Classes | Typedefs | Variables
DeviceIO/NetFinder.h File Reference
#include "stdafx.h"
#include "X11Color.h"
Include dependency graph for NetFinder.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | NETDISPLAY_ENTRY
class | CNetFinder

Typedefs

typedef struct NETDISPLAY_ENTRY | NETDISPLAY_ENTRY

Variables

const int | NO_ENTRIES = -1
const int | MAX_ENTRIES = 10

Typedef Documentation

typedef struct NETDISPLAY_ENTRY NETDISPLAY_ENTRY

Variable Documentation

const int MAX_ENTRIES = 10

Definition at line 43 of file NetFinder.h.

const int NO_ENTRIES = -1

Definition at line 42 of file NetFinder.h.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/ParsePacket.cpp File Reference

DeviceIO/ParsePacket.cpp File Reference
#include "ParsePacket.h"
Include dependency graph for ParsePacket.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/ParsePacket.h File Reference

Classes | Defines | Typedefs | Enumerations
DeviceIO/ParsePacket.h File Reference
#include <string>
#include "DP5Protocol.h"
Include dependency graph for ParsePacket.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _DppStateType
class | CParsePacket

Defines

#define | preqProcessNone 0x0
#define | preqProcessStatus 0x1
#define | preqProcessSpectrum 0x2
#define | preqRequestScopeData 0x4
#define | preqProcessScopeData 0x8
#define | preqProcessTextData 0x10
#define | preqProcessScopeDataOverFlow 0x20
#define | preqProcessInetSettings 0x40
#define | preqProcessDiagData 0x80
#define | preqProcessHwDesc 0x100
#define | preqProcessCfgRead 0x200
#define | preqProcessNetFindRead 0x400
#define | preqProcessPaCal 0x800
#define | preqProcessSCAData 0x2000
#define | preqProcessAck 0x4000
#define | preqProcessError 0x8000

Typedefs

typedef enum _CommType | CommType
typedef struct _DppStateType | DppStateType

Enumerations

enum _CommType {
commNone = 0, commRS232 = 1,
commUSB = 2, commSockets = 3
}

Define Documentation

#define preqProcessAck 0x4000

Definition at line 30 of file ParsePacket.h.

#define preqProcessCfgRead 0x200

Definition at line 25 of file ParsePacket.h.

#define preqProcessDiagData 0x80

Definition at line 23 of file ParsePacket.h.

#define preqProcessError 0x8000

Definition at line 31 of file ParsePacket.h.

#define preqProcessHwDesc 0x100

Definition at line 24 of file ParsePacket.h.

#define preqProcessInetSettings 0x40

Definition at line 22 of file ParsePacket.h.

#define preqProcessNetFindRead 0x400

Definition at line 26 of file ParsePacket.h.

#define preqProcessNone 0x0

Definition at line 15 of file ParsePacket.h.

#define preqProcessPaCal 0x800

Definition at line 27 of file ParsePacket.h.

#define preqProcessSCAData 0x2000

Definition at line 29 of file ParsePacket.h.

#define preqProcessScopeData 0x8

Definition at line 19 of file ParsePacket.h.

#define preqProcessScopeDataOverFlow 0x20

Definition at line 21 of file ParsePacket.h.

#define preqProcessSpectrum 0x2

Definition at line 17 of file ParsePacket.h.

#define preqProcessStatus 0x1

Definition at line 16 of file ParsePacket.h.

#define preqProcessTextData 0x10

Definition at line 20 of file ParsePacket.h.

#define preqRequestScopeData 0x4

Definition at line 18 of file ParsePacket.h.

Typedef Documentation

typedef enum _CommType CommType
typedef struct _DppStateType DppStateType

Enumeration Type Documentation

enum _CommType
Enumerator:
commNone
commRS232
commUSB
commSockets

Definition at line 8 of file ParsePacket.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SelectDP5.cpp File Reference

DeviceIO/SelectDP5.cpp File Reference
#include "stdafx.h"
#include "SelectDP5.h"
#include "SelectDP5Res.h"
Include dependency graph for SelectDP5.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SelectDP5.h File Reference

Classes | Defines
DeviceIO/SelectDP5.h File Reference
#include "SCommon.h"
#include "Label.h"
#include "afxwin.h"
#include "NetFinder.h"
#include "afxadv.h"
Include dependency graph for SelectDP5.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CSelectDP5

Defines

#define | isDebug false

Define Documentation

#define isDebug false

Definition at line 15 of file SelectDP5.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SelectDP5Res.h File Reference

Defines
DeviceIO/SelectDP5Res.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_BUTTON_CLIPBOARD_COPY 2048
#define | IDC_BUTTON_CLOSE_DEVICE 2049
#define | IDC_BUTTON_CLOSE_PORT 2050
#define | IDC_BUTTON_COUNT_DEVICES 2051
#define | IDC_BUTTON_FIND_DP5_IP 2052
#define | IDC_BUTTON_FIND_USB_DEVICE 2053
#define | IDC_BUTTON_IP_SELECT1 2054
#define | IDC_BUTTON_IP_SELECT2 2055
#define | IDC_BUTTON_IP_SELECT3 2056
#define | IDC_BUTTON_IP_SELECT4 2057
#define | IDC_BUTTON_OPEN_PORT 2058
#define | IDC_BUTTON_SERIAL_REQ_DATA 2059
#define | IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT 2060
#define | IDC_CHECK_TYPE_IP_ADDRESS 2061
#define | IDC_COMBO_COMPORT 2062
#define | IDC_CONNECTOK 2063
#define | IDC_EDIT_DPPCOMM_STATUS 2064
#define | IDC_EDIT_IP_ADDR1 2065
#define | IDC_EDIT_IP_ADDR2 2066
#define | IDC_EDIT_IP_ADDR3 2067
#define | IDC_EDIT_IP_ADDR4 2068
#define | IDC_EDIT_IP_PORT 2069
#define | IDC_EDIT_STATUS2 2070
#define | IDC_RADIO_COMMTYPE1 2071
#define | IDC_RADIO_COMMTYPE2 2072
#define | IDC_RADIO_COMMTYPE3 2073
#define | IDC_SPECTRUM_REFRESH_TIME 2074
#define | IDC_SPIN_SELECT_DEVICE 2075
#define | IDC_STATIC_FOUND1 2076
#define | IDC_STATIC_FOUND2 2077
#define | IDC_STATIC_FOUND3 2078
#define | IDC_STATIC_IP_ADDRESS_LABEL 2079
#define | IDC_STATIC_IP_SERIAL_NUM 2080
#define | IDC_STATIC_LABEL_IP_1 2081
#define | IDC_STATIC_LABEL_IP_2 2082
#define | IDC_STATIC_LABEL_IP_3 2083
#define | IDC_STATIC_LABEL_IP_4 2084
#define | IDC_STATIC_NETFINDER1 2085
#define | IDC_STATIC_NETFINDER2 2086
#define | IDC_STATIC_NETFINDER3 2087
#define | IDC_STATIC_NETFINDER4 2088
#define | IDC_STATIC_NUM_DEVICES 2089
#define | IDC_STATIC_NUM_DEVICES2 2090
#define | IDC_STATIC_PORT_LABEL 2091
#define | IDC_STATIC_SELECT_USB_DEVICE_LABEL 2092

Define Documentation

#define IDC_BUTTON_CLIPBOARD_COPY 2048

Definition at line 5 of file SelectDP5Res.h.

#define IDC_BUTTON_CLOSE_DEVICE 2049

Definition at line 6 of file SelectDP5Res.h.

#define IDC_BUTTON_CLOSE_PORT 2050

Definition at line 7 of file SelectDP5Res.h.

#define IDC_BUTTON_COUNT_DEVICES 2051

Definition at line 8 of file SelectDP5Res.h.

#define IDC_BUTTON_FIND_DP5_IP 2052

Definition at line 9 of file SelectDP5Res.h.

#define IDC_BUTTON_FIND_USB_DEVICE 2053

Definition at line 10 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT1 2054

Definition at line 11 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT2 2055

Definition at line 12 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT3 2056

Definition at line 13 of file SelectDP5Res.h.

#define IDC_BUTTON_IP_SELECT4 2057

Definition at line 14 of file SelectDP5Res.h.

#define IDC_BUTTON_OPEN_PORT 2058

Definition at line 15 of file SelectDP5Res.h.

#define IDC_BUTTON_SERIAL_REQ_DATA 2059

Definition at line 16 of file SelectDP5Res.h.

#define IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT 2060

Definition at line 17 of file SelectDP5Res.h.

#define IDC_CHECK_TYPE_IP_ADDRESS 2061

Definition at line 18 of file SelectDP5Res.h.

#define IDC_COMBO_COMPORT 2062

Definition at line 19 of file SelectDP5Res.h.

#define IDC_CONNECTOK 2063

Definition at line 20 of file SelectDP5Res.h.

#define IDC_EDIT_DPPCOMM_STATUS 2064

Definition at line 21 of file SelectDP5Res.h.

#define IDC_EDIT_IP_ADDR1 2065

Definition at line 22 of file SelectDP5Res.h.

#define IDC_EDIT_IP_ADDR2 2066

Definition at line 23 of file SelectDP5Res.h.

#define IDC_EDIT_IP_ADDR3 2067

Definition at line 24 of file SelectDP5Res.h.

#define IDC_EDIT_IP_ADDR4 2068

Definition at line 25 of file SelectDP5Res.h.

#define IDC_EDIT_IP_PORT 2069

Definition at line 26 of file SelectDP5Res.h.

#define IDC_EDIT_STATUS2 2070

Definition at line 27 of file SelectDP5Res.h.

#define IDC_RADIO_COMMTYPE1 2071

Definition at line 28 of file SelectDP5Res.h.

#define IDC_RADIO_COMMTYPE2 2072

Definition at line 29 of file SelectDP5Res.h.

#define IDC_RADIO_COMMTYPE3 2073

Definition at line 30 of file SelectDP5Res.h.

#define IDC_SPECTRUM_REFRESH_TIME 2074

Definition at line 31 of file SelectDP5Res.h.

#define IDC_SPIN_SELECT_DEVICE 2075

Definition at line 32 of file SelectDP5Res.h.

#define IDC_STATIC_FOUND1 2076

Definition at line 33 of file SelectDP5Res.h.

#define IDC_STATIC_FOUND2 2077

Definition at line 34 of file SelectDP5Res.h.

#define IDC_STATIC_FOUND3 2078

Definition at line 35 of file SelectDP5Res.h.

#define IDC_STATIC_IP_ADDRESS_LABEL 2079

Definition at line 36 of file SelectDP5Res.h.

#define IDC_STATIC_IP_SERIAL_NUM 2080

Definition at line 37 of file SelectDP5Res.h.

#define IDC_STATIC_LABEL_IP_1 2081

Definition at line 38 of file SelectDP5Res.h.

#define IDC_STATIC_LABEL_IP_2 2082

Definition at line 39 of file SelectDP5Res.h.

#define IDC_STATIC_LABEL_IP_3 2083

Definition at line 40 of file SelectDP5Res.h.

#define IDC_STATIC_LABEL_IP_4 2084

Definition at line 41 of file SelectDP5Res.h.

#define IDC_STATIC_NETFINDER1 2085

Definition at line 42 of file SelectDP5Res.h.

#define IDC_STATIC_NETFINDER2 2086

Definition at line 43 of file SelectDP5Res.h.

#define IDC_STATIC_NETFINDER3 2087

Definition at line 44 of file SelectDP5Res.h.

#define IDC_STATIC_NETFINDER4 2088

Definition at line 45 of file SelectDP5Res.h.

#define IDC_STATIC_NUM_DEVICES 2089

Definition at line 46 of file SelectDP5Res.h.

#define IDC_STATIC_NUM_DEVICES2 2090

Definition at line 47 of file SelectDP5Res.h.

#define IDC_STATIC_PORT_LABEL 2091

Definition at line 48 of file SelectDP5Res.h.

#define IDC_STATIC_SELECT_USB_DEVICE_LABEL 2092

Definition at line 49 of file SelectDP5Res.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SendCommand.cpp File Reference

DeviceIO/SendCommand.cpp File Reference
#include "SendCommand.h"
#include "stringex.h"
Include dependency graph for SendCommand.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SendCommand.h File Reference

Classes | Typedefs
DeviceIO/SendCommand.h File Reference
#include "DppConst.h"
#include "DP5Protocol.h"
#include "AsciiCmdUtilities.h"
Include dependency graph for SendCommand.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _CONFIG_OPTIONS
class | CSendCommand

Typedefs

typedef struct _CONFIG_OPTIONS | CONFIG_OPTIONS

Typedef Documentation

typedef struct _CONFIG_OPTIONS CONFIG_OPTIONS
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WINUSB.H File Reference

Classes | Typedefs | Functions
DeviceIO/WINUSB.H File Reference
#include "winusbio.h"
Include dependency graph for WINUSB.H:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _WINUSB_SETUP_PACKET

Typedefs

typedef PVOID | WINUSB_INTERFACE_HANDLE
typedef PVOID * | PWINUSB_INTERFACE_HANDLE
typedef struct _WINUSB_SETUP_PACKET | WINUSB_SETUP_PACKET
typedef struct
_WINUSB_SETUP_PACKET * 		PWINUSB_SETUP_PACKET

Functions

BOOL __stdcall | WinUsb_Initialize (IN HANDLE DeviceHandle, OUT PWINUSB_INTERFACE_HANDLE InterfaceHandle)
BOOL __stdcall | WinUsb_Free (IN WINUSB_INTERFACE_HANDLE InterfaceHandle)
BOOL __stdcall | WinUsb_GetAssociatedInterface (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR AssociatedInterfaceIndex, OUT PWINUSB_INTERFACE_HANDLE AssociatedInterfaceHandle)
BOOL __stdcall | WinUsb_GetDescriptor (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR DescriptorType, IN UCHAR Index, IN USHORT LanguageID, OUT PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred)
BOOL __stdcall | WinUsb_QueryInterfaceSettings (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR AlternateInterfaceNumber, OUT PUSB_INTERFACE_DESCRIPTOR UsbAltInterfaceDescriptor)
BOOL __stdcall | WinUsb_QueryDeviceInformation (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN ULONG InformationType, IN OUT PULONG BufferLength, OUT PVOID Buffer)
BOOL __stdcall | WinUsb_SetCurrentAlternateSetting (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR SettingNumber)
BOOL __stdcall | WinUsb_GetCurrentAlternateSetting (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, OUT PUCHAR SettingNumber)
BOOL __stdcall | WinUsb_QueryPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR AlternateInterfaceNumber, IN UCHAR PipeIndex, OUT PWINUSB_PIPE_INFORMATION PipeInformation)
BOOL __stdcall | WinUsb_SetPipePolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN ULONG PolicyType, IN ULONG ValueLength, IN PVOID Value)
BOOL __stdcall | WinUsb_GetPipePolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN ULONG PolicyType, IN OUT PULONG ValueLength, OUT PVOID Value)
BOOL __stdcall | WinUsb_ReadPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred, IN LPOVERLAPPED Overlapped)
BOOL __stdcall | WinUsb_WritePipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID, IN PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred, IN LPOVERLAPPED Overlapped)
BOOL __stdcall | WinUsb_ControlTransfer (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN WINUSB_SETUP_PACKET SetupPacket, IN PUCHAR Buffer, IN ULONG BufferLength, OUT PULONG LengthTransferred, IN LPOVERLAPPED Overlapped)
BOOL __stdcall | WinUsb_ResetPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID)
BOOL __stdcall | WinUsb_AbortPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID)
BOOL __stdcall | WinUsb_FlushPipe (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN UCHAR PipeID)
BOOL __stdcall | WinUsb_SetPowerPolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN ULONG PolicyType, IN ULONG ValueLength, IN PVOID Value)
BOOL __stdcall | WinUsb_GetPowerPolicy (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN ULONG PolicyType, IN OUT PULONG ValueLength, OUT PVOID Value)
BOOL __stdcall | WinUsb_GetOverlappedResult (IN WINUSB_INTERFACE_HANDLE InterfaceHandle, IN LPOVERLAPPED lpOverlapped, OUT LPDWORD lpNumberOfBytesTransferred, BOOL bWait)
PUSB_INTERFACE_DESCRIPTOR __stdcall | WinUsb_ParseConfigurationDescriptor (IN PUSB_CONFIGURATION_DESCRIPTOR ConfigurationDescriptor, IN PVOID StartPosition, IN LONG InterfaceNumber, IN LONG AlternateSetting, IN LONG InterfaceClass, IN LONG InterfaceSubClass, IN LONG InterfaceProtocol)
PUSB_COMMON_DESCRIPTOR __stdcall | WinUsb_ParseDescriptors (IN PVOID DescriptorBuffer, IN ULONG TotalLength, IN PVOID StartPosition, IN LONG DescriptorType)

Typedef Documentation

typedef PVOID * PWINUSB_INTERFACE_HANDLE

Definition at line 45 of file WINUSB.H.

typedef struct _WINUSB_SETUP_PACKET * PWINUSB_SETUP_PACKET
typedef PVOID WINUSB_INTERFACE_HANDLE

Definition at line 45 of file WINUSB.H.

typedef struct _WINUSB_SETUP_PACKET WINUSB_SETUP_PACKET

Function Documentation

BOOL __stdcall WinUsb_AbortPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID
 | ) |  |
BOOL __stdcall WinUsb_ControlTransfer | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN WINUSB_SETUP_PACKET | SetupPacket,
 |  | IN PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred,
 |  | IN LPOVERLAPPED | Overlapped
 | ) |  |
BOOL __stdcall WinUsb_FlushPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID
 | ) |  |
BOOL __stdcall WinUsb_Free ( IN WINUSB_INTERFACE_HANDLE InterfaceHandle )

Here is the caller graph for this function:

BOOL __stdcall WinUsb_GetAssociatedInterface | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | AssociatedInterfaceIndex,
 |  | OUT PWINUSB_INTERFACE_HANDLE | AssociatedInterfaceHandle
 | ) |  |
BOOL __stdcall WinUsb_GetCurrentAlternateSetting | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | OUT PUCHAR | SettingNumber
 | ) |  |
BOOL __stdcall WinUsb_GetDescriptor | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | DescriptorType,
 |  | IN UCHAR | Index,
 |  | IN USHORT | LanguageID,
 |  | OUT PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred
 | ) |  |
BOOL __stdcall WinUsb_GetOverlappedResult | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN LPOVERLAPPED | lpOverlapped,
 |  | OUT LPDWORD | lpNumberOfBytesTransferred,
 |  | BOOL | bWait
 | ) |  |
BOOL __stdcall WinUsb_GetPipePolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN ULONG | PolicyType,
 |  | IN OUT PULONG | ValueLength,
 |  | OUT PVOID | Value
 | ) |  |
BOOL __stdcall WinUsb_GetPowerPolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN ULONG | PolicyType,
 |  | IN OUT PULONG | ValueLength,
 |  | OUT PVOID | Value
 | ) |  |
BOOL __stdcall WinUsb_Initialize | ( | IN HANDLE | DeviceHandle,
 |  | OUT PWINUSB_INTERFACE_HANDLE | InterfaceHandle
 | ) |  |

Here is the caller graph for this function:

PUSB_INTERFACE_DESCRIPTOR __stdcall WinUsb_ParseConfigurationDescriptor | ( | IN PUSB_CONFIGURATION_DESCRIPTOR | ConfigurationDescriptor,
 |  | IN PVOID | StartPosition,
 |  | IN LONG | InterfaceNumber,
 |  | IN LONG | AlternateSetting,
 |  | IN LONG | InterfaceClass,
 |  | IN LONG | InterfaceSubClass,
 |  | IN LONG | InterfaceProtocol
 | ) |  |
PUSB_COMMON_DESCRIPTOR __stdcall WinUsb_ParseDescriptors | ( | IN PVOID | DescriptorBuffer,
 |  | IN ULONG | TotalLength,
 |  | IN PVOID | StartPosition,
 |  | IN LONG | DescriptorType
 | ) |  |
BOOL __stdcall WinUsb_QueryDeviceInformation | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN ULONG | InformationType,
 |  | IN OUT PULONG | BufferLength,
 |  | OUT PVOID | Buffer
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_QueryInterfaceSettings | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | AlternateInterfaceNumber,
 |  | OUT PUSB_INTERFACE_DESCRIPTOR | UsbAltInterfaceDescriptor
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_QueryPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | AlternateInterfaceNumber,
 |  | IN UCHAR | PipeIndex,
 |  | OUT PWINUSB_PIPE_INFORMATION | PipeInformation
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_ReadPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred,
 |  | IN LPOVERLAPPED | Overlapped
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_ResetPipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID
 | ) |  |
BOOL __stdcall WinUsb_SetCurrentAlternateSetting | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | SettingNumber
 | ) |  |
BOOL __stdcall WinUsb_SetPipePolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN ULONG | PolicyType,
 |  | IN ULONG | ValueLength,
 |  | IN PVOID | Value
 | ) |  |

Here is the caller graph for this function:

BOOL __stdcall WinUsb_SetPowerPolicy | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN ULONG | PolicyType,
 |  | IN ULONG | ValueLength,
 |  | IN PVOID | Value
 | ) |  |
BOOL __stdcall WinUsb_WritePipe | ( | IN WINUSB_INTERFACE_HANDLE | InterfaceHandle,
 |  | IN UCHAR | PipeID,
 |  | IN PUCHAR | Buffer,
 |  | IN ULONG | BufferLength,
 |  | OUT PULONG | LengthTransferred,
 |  | IN LPOVERLAPPED | Overlapped
 | ) |  |

Here is the caller graph for this function:

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WINUSBIO.H File Reference

Classes | Defines | Typedefs | Functions
DeviceIO/WINUSBIO.H File Reference
#include "usb.h"
#include <initguid.h>
Include dependency graph for WINUSBIO.H:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

struct | _WINUSB_PIPE_INFORMATION

Defines

#define | SHORT_PACKET_TERMINATE 0x01
#define | AUTO_CLEAR_STALL 0x02
#define | PIPE_TRANSFER_TIMEOUT 0x03
#define | IGNORE_SHORT_PACKETS 0x04
#define | ALLOW_PARTIAL_READS 0x05
#define | AUTO_FLUSH 0x06
#define | RAW_IO 0x07
#define | MAXIMUM_TRANSFER_SIZE 0x08
#define | AUTO_SUSPEND 0x81
#define | SUSPEND_DELAY 0x83
#define | DEVICE_SPEED 0x01
#define | LowSpeed 0x01
#define | FullSpeed 0x02
#define | HighSpeed 0x03

Typedefs

typedef struct
_WINUSB_PIPE_INFORMATION 		WINUSB_PIPE_INFORMATION
typedef struct
_WINUSB_PIPE_INFORMATION * 		PWINUSB_PIPE_INFORMATION

Functions

DEFINE_GUID (WinUSB_TestGuid, 0xda812bff, 0x12c3, 0x46a2, 0x8e, 0x2b, 0xdb, 0xd3, 0xb7, 0x83, 0x4c, 0x43)

Define Documentation

#define ALLOW_PARTIAL_READS 0x05

Definition at line 44 of file WINUSBIO.H.

#define AUTO_CLEAR_STALL 0x02

Definition at line 41 of file WINUSBIO.H.

#define AUTO_FLUSH 0x06

Definition at line 45 of file WINUSBIO.H.

#define AUTO_SUSPEND 0x81

Definition at line 55 of file WINUSBIO.H.

#define DEVICE_SPEED 0x01

Definition at line 59 of file WINUSBIO.H.

#define FullSpeed 0x02

Definition at line 63 of file WINUSBIO.H.

#define HighSpeed 0x03

Definition at line 64 of file WINUSBIO.H.

#define IGNORE_SHORT_PACKETS 0x04

Definition at line 43 of file WINUSBIO.H.

#define LowSpeed 0x01

Definition at line 62 of file WINUSBIO.H.

#define MAXIMUM_TRANSFER_SIZE 0x08

Definition at line 47 of file WINUSBIO.H.

#define PIPE_TRANSFER_TIMEOUT 0x03

Definition at line 42 of file WINUSBIO.H.

#define RAW_IO 0x07

Definition at line 46 of file WINUSBIO.H.

#define SHORT_PACKET_TERMINATE 0x01

Definition at line 40 of file WINUSBIO.H.

#define SUSPEND_DELAY 0x83

Definition at line 56 of file WINUSBIO.H.

Typedef Documentation

typedef struct _WINUSB_PIPE_INFORMATION * PWINUSB_PIPE_INFORMATION
typedef struct _WINUSB_PIPE_INFORMATION WINUSB_PIPE_INFORMATION

Function Documentation

DEFINE_GUID | ( | WinUSB_TestGuid | ,
 |  | 0xda812bff | ,
 |  | 0x12c3 | ,
 |  | 0x46a2 | ,
 |  | 0x8e | ,
 |  | 0x2b | ,
 |  | 0xdb | ,
 |  | 0xd3 | ,
 |  | 0xb7 | ,
 |  | 0x83 | ,
 |  | 0x4c | ,
 |  | 0x43 |
 | ) |  |
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WinusbNotify.cpp File Reference

DeviceIO/WinusbNotify.cpp File Reference
#include "StdAfx.h"
#include "WinusbNotify.h"
Include dependency graph for WinusbNotify.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WinusbNotify.h File Reference

Classes
DeviceIO/WinusbNotify.h File Reference
#include "DppWinUSB.h"
Include dependency graph for WinusbNotify.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CWinusbNotify
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/BootOptPage.cpp File Reference

DP5Cfg/BootOptPage.cpp File Reference
#include "stdafx.h"
#include "resource.h"
#include "BootOptPage.h"
Include dependency graph for BootOptPage.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/BootOptPage.h File Reference

Classes
DP5Cfg/BootOptPage.h File Reference
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
Include dependency graph for BootOptPage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CBootOptPage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/CfgPropSheet.cpp File Reference

DP5Cfg/CfgPropSheet.cpp File Reference
#include "stdafx.h"
#include <afxpriv.h>
#include "CfgPropSheet.h"
Include dependency graph for CfgPropSheet.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/CfgPropSheet.h File Reference

Classes
DP5Cfg/CfgPropSheet.h File Reference
#include "resource.h"
#include "Dlgbars.h"
#include "scommon.h"
Include dependency graph for CfgPropSheet.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CCfgPropPage
class | CCfgPropSheet
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Dlgbars.cpp File Reference

DP5Cfg/Dlgbars.cpp File Reference
#include "stdafx.h"
#include <afxpriv.h>
#include "dlgbars.h"
Include dependency graph for Dlgbars.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Dlgbars.h File Reference

Classes
DP5Cfg/Dlgbars.h File Reference
#include "StdAfx.h"
Include dependency graph for Dlgbars.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDlgToolBar
class | CDlgStatusBar
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DP5CfgWnd.cpp File Reference

DP5Cfg/DP5CfgWnd.cpp File Reference
#include "stdafx.h"
#include "DP5CfgWnd.h"
#include "FilePage.h"
#include "resource.h"
Include dependency graph for DP5CfgWnd.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DP5CfgWnd.h File Reference

Classes
DP5Cfg/DP5CfgWnd.h File Reference
#include "CfgPropSheet.h"
#include "FilePage.h"
#include "McaPage.h"
#include "ShapingPage.h"
#include "GainPzPage.h"
#include "PowerPage.h"
#include "MiscPage.h"
Include dependency graph for DP5CfgWnd.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CDP5CfgWnd
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DppGain.cpp File Reference

DP5Cfg/DppGain.cpp File Reference
#include "StdAfx.h"
#include "DppGain.h"
Include dependency graph for DppGain.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DppGain.h File Reference

Classes | Defines | Typedefs | Enumerations
DP5Cfg/DppGain.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CDppGain

Defines

#define | SIZEOF_GAIN_ARRAY(gar) (sizeof(gar)/sizeof((gar)[0]))
#define | DP5_GAIN_COUNT 16
#define | PX5_GAIN_COUNT 28
#define | DP5G_GAIN_COUNT 4
#define | MCA8000D_GAIN_COUNT 2
#define | DP5_DX_GAIN_COUNT 24
#define | DP5X_GAIN_COUNT 6
#define | MinGainTable dagtDP5
#define | MaxGainTable dagtDP5Dx

Typedefs

typedef enum _DppAGainTable | DppAGainTable

Enumerations

enum _DppAGainTable {
dagtDP5, dagtPX5,
dagtDP5G, dagtMCA8000D,
dagtTB5, dagtDP5X,
dagtDP5Dx
}

Define Documentation

#define DP5_DX_GAIN_COUNT 24

Definition at line 16 of file DppGain.h.

#define DP5_GAIN_COUNT 16

Definition at line 12 of file DppGain.h.

#define DP5G_GAIN_COUNT 4

Definition at line 14 of file DppGain.h.

#define DP5X_GAIN_COUNT 6

Definition at line 17 of file DppGain.h.

#define MaxGainTable dagtDP5Dx

Definition at line 71 of file DppGain.h.

#define MCA8000D_GAIN_COUNT 2

Definition at line 15 of file DppGain.h.

#define MinGainTable dagtDP5

Definition at line 68 of file DppGain.h.

#define PX5_GAIN_COUNT 28

Definition at line 13 of file DppGain.h.

#define SIZEOF_GAIN_ARRAY ( gar ) (sizeof(gar)/sizeof((gar)[0]))

Definition at line 10 of file DppGain.h.

Typedef Documentation

typedef enum _DppAGainTable DppAGainTable

Enumeration Type Documentation

enum _DppAGainTable
Enumerator:
dagtDP5
dagtPX5
dagtDP5G
dagtMCA8000D
dagtTB5
dagtDP5X
dagtDP5Dx

Definition at line 57 of file DppGain.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FileBrowse.cpp File Reference

DP5Cfg/FileBrowse.cpp File Reference
#include "stdafx.h"
#include ".\filebrowse.h"
Include dependency graph for FileBrowse.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FileBrowse.h File Reference

Classes
DP5Cfg/FileBrowse.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CFileBrowse
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FilePage.cpp File Reference

Functions
DP5Cfg/FilePage.cpp File Reference
#include "stdafx.h"
#include "afxpriv.h"
#include "FilePageRes.h"
#include "FilePage.h"
#include "FileBrowse.h"
#include "IniUtil.h"
#include "scommon.h"
#include "UserMsgs.h"
#include "CmdWaitDlg.h"
#include "msectimer.h"
#include "AsciiCmdUtilities.h"
Include dependency graph for FilePage.cpp:

Go to the source code of this file.

Functions

BOOL CALLBACK EnumChildControls (HWND hWnd, LPARAM lParam)

Function Documentation

BOOL CALLBACK EnumChildControls | ( | HWND | hWnd,
 |  | LPARAM | lParam
 | ) |  |

Definition at line 261 of file FilePage.cpp.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FilePage.h File Reference

Classes
DP5Cfg/FilePage.h File Reference
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
Include dependency graph for FilePage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CFilePage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FilePageRes.h File Reference

Defines
DP5Cfg/FilePageRes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_BUTTON_EDIT_CONFIG_FROM_HW 1920
#define | IDC_BUTTON_READ_CONFIG 1921
#define | IDC_BUTTON_SAVE_CONFIG 1922
#define | IDC_BUTTON_SEND_COMMAND 1923
#define | IDC_BUTTON_SEND_TO_HARDWARE 1924
#define | IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT 1925
#define | IDC_CHECK_PC5_PRESENT 1926
#define | IDC_EDIT_HW_CFG_SECTION 1927
#define | IDC_EDIT_SEND_COMMAND 1928
#define | IDC_OPT_COMBO_RESC 1929
#define | IDC_OPT_FRAME_RESC 1930
#define | IDC_RADIO_DPP_DEVICE_TYPE1 1931
#define | IDC_RADIO_DPP_DEVICE_TYPE2 1932
#define | IDC_RADIO_DPP_DEVICE_TYPE3 1933
#define | IDC_READDETECTORCONFIGCOMBO 1934
#define | IDC_STATIC_CFG_LEN_LABEL 1935
#define | IDC_STATIC_CFG_LENGTH 1936
#define | IDC_STATIC_CONFIG_NAME 1937
#define | IDC_STATIC_CONFIG_NAME2 1938
#define | IDC_STATIC_DPP_DEVICE_TYPE 1939
#define | IDC_STATIC_FILE_ADVANCED 1940
#define | IDC_STATIC_FILE_BASIC 1941
#define | IDC_STATIC_FILE_PAGE 1942
#define | IDC_STATIC_FILE_STANDARD 1943
#define | IDC_STATIC_READ_CONFIG 1944
#define | IDC_STATIC_SAVE_CONFIG 1945
#define | IDC_STATIC_SEND_COMMAND_LABEL 1946
#define | IDC_EDIT_RCV_CFG 1947
#define | IDC_RADIO_DPP_DEVICE_TYPE4 1948
#define | IDC_BUTTON_SEND_COMMAND2 1949
#define | IDC_RADIO_DPP_DEVICE_TYPE5 1950
#define | IDC_CHECK_DP5_DX_GAIN 1951
#define | IDC_RADIO_DPP_DEVICE_TYPE6 1952
#define | IDI_DP5_CARD 6400
#define | IDI_OPEN_FOLDER 6401
#define | IDI_RIGHT_ARROW 6402

Define Documentation

#define IDC_BUTTON_EDIT_CONFIG_FROM_HW 1920

Definition at line 5 of file FilePageRes.h.

#define IDC_BUTTON_READ_CONFIG 1921

Definition at line 6 of file FilePageRes.h.

#define IDC_BUTTON_SAVE_CONFIG 1922

Definition at line 7 of file FilePageRes.h.

#define IDC_BUTTON_SEND_COMMAND 1923

Definition at line 8 of file FilePageRes.h.

#define IDC_BUTTON_SEND_COMMAND2 1949

Definition at line 34 of file FilePageRes.h.

#define IDC_BUTTON_SEND_TO_HARDWARE 1924

Definition at line 9 of file FilePageRes.h.

#define IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT 1925

Definition at line 10 of file FilePageRes.h.

#define IDC_CHECK_DP5_DX_GAIN 1951

Definition at line 36 of file FilePageRes.h.

#define IDC_CHECK_PC5_PRESENT 1926

Definition at line 11 of file FilePageRes.h.

#define IDC_EDIT_HW_CFG_SECTION 1927

Definition at line 12 of file FilePageRes.h.

#define IDC_EDIT_RCV_CFG 1947

Definition at line 32 of file FilePageRes.h.

#define IDC_EDIT_SEND_COMMAND 1928

Definition at line 13 of file FilePageRes.h.

#define IDC_OPT_COMBO_RESC 1929

Definition at line 14 of file FilePageRes.h.

#define IDC_OPT_FRAME_RESC 1930

Definition at line 15 of file FilePageRes.h.

#define IDC_RADIO_DPP_DEVICE_TYPE1 1931

Definition at line 16 of file FilePageRes.h.

#define IDC_RADIO_DPP_DEVICE_TYPE2 1932

Definition at line 17 of file FilePageRes.h.

#define IDC_RADIO_DPP_DEVICE_TYPE3 1933

Definition at line 18 of file FilePageRes.h.

#define IDC_RADIO_DPP_DEVICE_TYPE4 1948

Definition at line 33 of file FilePageRes.h.

#define IDC_RADIO_DPP_DEVICE_TYPE5 1950

Definition at line 35 of file FilePageRes.h.

#define IDC_RADIO_DPP_DEVICE_TYPE6 1952

Definition at line 37 of file FilePageRes.h.

#define IDC_READDETECTORCONFIGCOMBO 1934

Definition at line 19 of file FilePageRes.h.

#define IDC_STATIC_CFG_LEN_LABEL 1935

Definition at line 20 of file FilePageRes.h.

#define IDC_STATIC_CFG_LENGTH 1936

Definition at line 21 of file FilePageRes.h.

#define IDC_STATIC_CONFIG_NAME 1937

Definition at line 22 of file FilePageRes.h.

#define IDC_STATIC_CONFIG_NAME2 1938

Definition at line 23 of file FilePageRes.h.

#define IDC_STATIC_DPP_DEVICE_TYPE 1939

Definition at line 24 of file FilePageRes.h.

#define IDC_STATIC_FILE_ADVANCED 1940

Definition at line 25 of file FilePageRes.h.

#define IDC_STATIC_FILE_BASIC 1941

Definition at line 26 of file FilePageRes.h.

#define IDC_STATIC_FILE_PAGE 1942

Definition at line 27 of file FilePageRes.h.

#define IDC_STATIC_FILE_STANDARD 1943

Definition at line 28 of file FilePageRes.h.

#define IDC_STATIC_READ_CONFIG 1944

Definition at line 29 of file FilePageRes.h.

#define IDC_STATIC_SAVE_CONFIG 1945

Definition at line 30 of file FilePageRes.h.

#define IDC_STATIC_SEND_COMMAND_LABEL 1946

Definition at line 31 of file FilePageRes.h.

#define IDI_DP5_CARD 6400

Definition at line 38 of file FilePageRes.h.

#define IDI_OPEN_FOLDER 6401

Definition at line 39 of file FilePageRes.h.

#define IDI_RIGHT_ARROW 6402

Definition at line 40 of file FilePageRes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/GainPzPage.cpp File Reference

DP5Cfg/GainPzPage.cpp File Reference
#include "stdafx.h"
#include "afxpriv.h"
#include "GainPzPageRes.h"
#include "GainPzPage.h"
#include <math.h>
Include dependency graph for GainPzPage.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/GainPzPage.h File Reference

Classes
DP5Cfg/GainPzPage.h File Reference
#include "DppGain.h"
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
Include dependency graph for GainPzPage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CGainPzPage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/GainPzPageRes.h File Reference

Defines
DP5Cfg/GainPzPageRes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_OPT_UNITS_RESL2 1451
#define | IDC_OPT_COMBO_PAPZ 1539
#define | IDC_OPT_FRAME_PAPZ 1544
#define | IDC_OPT_LIMITS_PAPZ 1547
#define | IDC_OPT_TEXT_PAPZ 1550
#define | IDC_OPT_UNITS_PAPZ 1554
#define | IDC_STATIC_HV_WARNING 1560
#define | IDC_BUTTON_COARSE_FINE_TO_TOTAL 1664
#define | IDC_BUTTON_FINE_GAIN_ENTER 1665
#define | IDC_BUTTON_TOTAL_TO_COARSE_FINE 1666
#define | IDC_OPT_COMBO_AINP 1667
#define | IDC_OPT_COMBO_GAIA 1668
#define | IDC_OPT_COMBO_GAIA2 1669
#define | IDC_OPT_COMBO_GAIN_SELECT 1670
#define | IDC_OPT_COMBO_INOF 1671
#define | IDC_OPT_COMBO_RESL 1672
#define | IDC_OPT_COMBO_RESL2 1673
#define | IDC_OPT_FRAME_AINP 1674
#define | IDC_OPT_FRAME_GAIA 1675
#define | IDC_OPT_FRAME_GAIF 1676
#define | IDC_OPT_FRAME_GAIN 1677
#define | IDC_OPT_FRAME_INOF 1678
#define | IDC_OPT_FRAME_RESL 1679
#define | IDC_OPT_FRAME_RESL2 1680
#define | IDC_OPT_LIMITS_GAIF 1681
#define | IDC_OPT_LIMITS_GAIN 1682
#define | IDC_OPT_LIMITS_INOF 1683
#define | IDC_OPT_LIMITS_RESL 1684
#define | IDC_OPT_TEXT_GAIF 1685
#define | IDC_OPT_TEXT_GAIN 1686
#define | IDC_OPT_TEXT_INOF 1687
#define | IDC_OPT_TEXT_RESL 1688
#define | IDC_OPT_UNITS_GAIF 1689
#define | IDC_OPT_UNITS_GAIN 1690
#define | IDC_OPT_UNITS_INOF 1691
#define | IDC_OPT_UNITS_RESL 1692
#define | IDC_OPT_VALUE_GAIA 1693
#define | IDC_OPT_VALUE_GAIN 1694
#define | IDC_STATIC_AVANCED_GAIN_CONTROL 1695
#define | IDC_STATIC_GAIN_ADVANCED 1696
#define | IDC_STATIC_GAIN_BASIC 1697
#define | IDC_STATIC_GAIN_STANDARD 1698
#define | IDC_STATIC_GAINPZ_PAGE 1699
#define | IDC_STATIC_TOTAL_OR_BOTH_LABEL 1700
#define | IDS_TT_TOTAL_GAIN 5888
#define | IDS_TT_SEND_TOTAL_OR_COARSE_FINE_GAIN 5889
#define | IDS_TT_COARSE_GAIN 5890
#define | IDS_TT_FINE_GAIN 5891
#define | IDS_TT_ARROWS 5892
#define | IDS_TT_INPUT_OFFSET 5893
#define | IDS_TT_ANALOG_INPUT 5894
#define | IDS_TT_RESET_LOCKOUT 5895

Define Documentation

#define IDC_BUTTON_COARSE_FINE_TO_TOTAL 1664

Definition at line 12 of file GainPzPageRes.h.

#define IDC_BUTTON_FINE_GAIN_ENTER 1665

Definition at line 13 of file GainPzPageRes.h.

#define IDC_BUTTON_TOTAL_TO_COARSE_FINE 1666

Definition at line 14 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_AINP 1667

Definition at line 15 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_GAIA 1668

Definition at line 16 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_GAIA2 1669

Definition at line 17 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_GAIN_SELECT 1670

Definition at line 18 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_INOF 1671

Definition at line 19 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_PAPZ 1539

Definition at line 6 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_RESL 1672

Definition at line 20 of file GainPzPageRes.h.

#define IDC_OPT_COMBO_RESL2 1673

Definition at line 21 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_AINP 1674

Definition at line 22 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_GAIA 1675

Definition at line 23 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_GAIF 1676

Definition at line 24 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_GAIN 1677

Definition at line 25 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_INOF 1678

Definition at line 26 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_PAPZ 1544

Definition at line 7 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_RESL 1679

Definition at line 27 of file GainPzPageRes.h.

#define IDC_OPT_FRAME_RESL2 1680

Definition at line 28 of file GainPzPageRes.h.

#define IDC_OPT_LIMITS_GAIF 1681

Definition at line 29 of file GainPzPageRes.h.

#define IDC_OPT_LIMITS_GAIN 1682

Definition at line 30 of file GainPzPageRes.h.

#define IDC_OPT_LIMITS_INOF 1683

Definition at line 31 of file GainPzPageRes.h.

#define IDC_OPT_LIMITS_PAPZ 1547

Definition at line 8 of file GainPzPageRes.h.

#define IDC_OPT_LIMITS_RESL 1684

Definition at line 32 of file GainPzPageRes.h.

#define IDC_OPT_TEXT_GAIF 1685

Definition at line 33 of file GainPzPageRes.h.

#define IDC_OPT_TEXT_GAIN 1686

Definition at line 34 of file GainPzPageRes.h.

#define IDC_OPT_TEXT_INOF 1687

Definition at line 35 of file GainPzPageRes.h.

#define IDC_OPT_TEXT_PAPZ 1550

Definition at line 9 of file GainPzPageRes.h.

#define IDC_OPT_TEXT_RESL 1688

Definition at line 36 of file GainPzPageRes.h.

#define IDC_OPT_UNITS_GAIF 1689

Definition at line 37 of file GainPzPageRes.h.

#define IDC_OPT_UNITS_GAIN 1690

Definition at line 38 of file GainPzPageRes.h.

#define IDC_OPT_UNITS_INOF 1691

Definition at line 39 of file GainPzPageRes.h.

#define IDC_OPT_UNITS_PAPZ 1554

Definition at line 10 of file GainPzPageRes.h.

#define IDC_OPT_UNITS_RESL 1692

Definition at line 40 of file GainPzPageRes.h.

#define IDC_OPT_UNITS_RESL2 1451

Definition at line 5 of file GainPzPageRes.h.

#define IDC_OPT_VALUE_GAIA 1693

Definition at line 41 of file GainPzPageRes.h.

#define IDC_OPT_VALUE_GAIN 1694

Definition at line 42 of file GainPzPageRes.h.

#define IDC_STATIC_AVANCED_GAIN_CONTROL 1695

Definition at line 43 of file GainPzPageRes.h.

#define IDC_STATIC_GAIN_ADVANCED 1696

Definition at line 44 of file GainPzPageRes.h.

#define IDC_STATIC_GAIN_BASIC 1697

Definition at line 45 of file GainPzPageRes.h.

#define IDC_STATIC_GAIN_STANDARD 1698

Definition at line 46 of file GainPzPageRes.h.

#define IDC_STATIC_GAINPZ_PAGE 1699

Definition at line 47 of file GainPzPageRes.h.

#define IDC_STATIC_HV_WARNING 1560

Definition at line 11 of file GainPzPageRes.h.

#define IDC_STATIC_TOTAL_OR_BOTH_LABEL 1700

Definition at line 48 of file GainPzPageRes.h.

#define IDS_TT_ANALOG_INPUT 5894

Definition at line 55 of file GainPzPageRes.h.

#define IDS_TT_ARROWS 5892

Definition at line 53 of file GainPzPageRes.h.

#define IDS_TT_COARSE_GAIN 5890

Definition at line 51 of file GainPzPageRes.h.

#define IDS_TT_FINE_GAIN 5891

Definition at line 52 of file GainPzPageRes.h.

#define IDS_TT_INPUT_OFFSET 5893

Definition at line 54 of file GainPzPageRes.h.

#define IDS_TT_RESET_LOCKOUT 5895

Definition at line 56 of file GainPzPageRes.h.

#define IDS_TT_SEND_TOTAL_OR_COARSE_FINE_GAIN 5889

Definition at line 50 of file GainPzPageRes.h.

#define IDS_TT_TOTAL_GAIN 5888

Definition at line 49 of file GainPzPageRes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/McaPage.cpp File Reference

DP5Cfg/McaPage.cpp File Reference
#include "stdafx.h"
#include "afxpriv.h"
#include "McaPageRes.h"
#include "McaPage.h"
Include dependency graph for McaPage.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/McaPage.h File Reference

Classes
DP5Cfg/McaPage.h File Reference
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
#include "scommon.h"
Include dependency graph for McaPage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CMcaPage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/McaPageRes.h File Reference

Defines
DP5Cfg/McaPageRes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_OPT_COMBO_GATE 1280
#define | IDC_OPT_COMBO_MCAC 1281
#define | IDC_OPT_COMBO_MCAE 1282
#define | IDC_OPT_COMBO_MCAS 1283
#define | IDC_OPT_COMBO_PDMD 1284
#define | IDC_OPT_COMBO_PREC 1285
#define | IDC_OPT_COMBO_PRER 1286
#define | IDC_OPT_COMBO_PRET 1287
#define | IDC_OPT_COMBO_SOFF 1288
#define | IDC_OPT_COMBO_TLLD 1289
#define | IDC_OPT_FRAME_GATE 1290
#define | IDC_OPT_FRAME_MCAC 1291
#define | IDC_OPT_FRAME_MCAE 1292
#define | IDC_OPT_FRAME_MCAS 1293
#define | IDC_OPT_FRAME_MCSH 1294
#define | IDC_OPT_FRAME_MCSL 1295
#define | IDC_OPT_FRAME_MCST 1296
#define | IDC_OPT_FRAME_PDMD 1297
#define | IDC_OPT_FRAME_PRCH 1298
#define | IDC_OPT_FRAME_PRCL 1299
#define | IDC_OPT_FRAME_PREC 1300
#define | IDC_OPT_FRAME_PRER 1301
#define | IDC_OPT_FRAME_PRET 1302
#define | IDC_OPT_FRAME_SOFF 1303
#define | IDC_OPT_FRAME_THSL 1304
#define | IDC_OPT_FRAME_TLLD 1305
#define | IDC_OPT_LIMITS_MCSH 1306
#define | IDC_OPT_LIMITS_MCSL 1307
#define | IDC_OPT_LIMITS_MCST 1308
#define | IDC_OPT_LIMITS_PRCH 1309
#define | IDC_OPT_LIMITS_PRCL 1310
#define | IDC_OPT_LIMITS_PREC 1311
#define | IDC_OPT_LIMITS_PRER 1312
#define | IDC_OPT_LIMITS_PRET 1313
#define | IDC_OPT_LIMITS_SOFF 1314
#define | IDC_OPT_LIMITS_THSL 1315
#define | IDC_OPT_LIMITS_TLLD 1316
#define | IDC_OPT_TEXT_MCSH 1317
#define | IDC_OPT_TEXT_MCSL 1318
#define | IDC_OPT_TEXT_MCST 1319
#define | IDC_OPT_TEXT_PRCH 1320
#define | IDC_OPT_TEXT_PRCL 1321
#define | IDC_OPT_TEXT_PREC 1322
#define | IDC_OPT_TEXT_PRER 1323
#define | IDC_OPT_TEXT_PRET 1324
#define | IDC_OPT_TEXT_SOFF 1325
#define | IDC_OPT_TEXT_THSL 1326
#define | IDC_OPT_TEXT_TLLD 1327
#define | IDC_OPT_UNITS_MCSH 1328
#define | IDC_OPT_UNITS_MCSL 1329
#define | IDC_OPT_UNITS_MCST 1330
#define | IDC_OPT_UNITS_PRCH 1331
#define | IDC_OPT_UNITS_PRCL 1332
#define | IDC_OPT_UNITS_PREC 1333
#define | IDC_OPT_UNITS_PRER 1334
#define | IDC_OPT_UNITS_PRET 1335
#define | IDC_OPT_UNITS_SOFF 1336
#define | IDC_OPT_UNITS_THSL 1337
#define | IDC_OPT_UNITS_TLLD 1338
#define | IDC_PRESETCOUNTCURSORBUTTON 1339
#define | IDC_PRESETCOUNTROIBUTTON 1340
#define | IDC_STATIC_MCA_ADVANCED 1341
#define | IDC_STATIC_MCA_BASIC 1342
#define | IDC_STATIC_MCA_PAGE 1343
#define | IDC_STATIC_MCA_STANDARD 1344
#define | IDC_OPT_FRAME_DMCA_GAIA 1345
#define | IDC_OPT_COMBO_DMCA_GAIA 1346
#define | IDC_OPT_FRAME_DMCA_PURE 1347
#define | IDC_OPT_FRAME_PREL 1348
#define | IDC_OPT_COMBO_PREL 1349
#define | IDC_OPT_LIMITS_PREL 1350
#define | IDC_OPT_TEXT_PREL 1351
#define | IDC_OPT_UNITS_PREL 1352
#define | IDC_OPT_FRAME_SOFF2 1353
#define | IDC_OPT_COMBO_SOFF2 1354
#define | IDC_OPT_LIMITS_SOFF2 1355
#define | IDC_OPT_TEXT_SOFF2 1356
#define | IDC_OPT_UNITS_SOFF2 1357
#define | IDC_OPT_FRAME_SOFF3 1358
#define | IDC_OPT_COMBO_SOFF3 1359
#define | IDC_OPT_LIMITS_SOFF3 1360
#define | IDC_OPT_TEXT_SOFF3 1361
#define | IDC_OPT_UNITS_SOFF3 1362
#define | IDC_OPT_COMBO_DMCA_PURE 1416
#define | IDS_TT_MCA_MCS_CHANNELS 5120
#define | IDS_TT_SLOW_THRESHOLD 5121
#define | IDS_TT_LOW_LEVEL_DISCRIMINATOR 5122
#define | IDS_TT_SET_SPECTRUM_OFFSET 5123
#define | IDS_TT_PRESET_ACQUISITION_TIME 5124
#define | IDS_TT_PRESET_REAL_TIME 5125
#define | IDS_TT_PRESET_COUNT 5126
#define | IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL 5127
#define | IDS_TT_GATE_CONTROL 5128
#define | IDS_TT_MCS_TIMEBASE 5129
#define | IDS_TT_MCS_LOW_HIGH_CHANNEL 5130
#define | IDS_TT_MCA_SOURCE 5131
#define | IDS_TT_PEAK_DETECT_MODE 5132
#define | IDS_TT_PRESET_LIVE_TIME 5133

Define Documentation

#define IDC_OPT_COMBO_DMCA_GAIA 1346

Definition at line 71 of file McaPageRes.h.

#define IDC_OPT_COMBO_DMCA_PURE 1416

Definition at line 88 of file McaPageRes.h.

#define IDC_OPT_COMBO_GATE 1280

Definition at line 5 of file McaPageRes.h.

#define IDC_OPT_COMBO_MCAC 1281

Definition at line 6 of file McaPageRes.h.

#define IDC_OPT_COMBO_MCAE 1282

Definition at line 7 of file McaPageRes.h.

#define IDC_OPT_COMBO_MCAS 1283

Definition at line 8 of file McaPageRes.h.

#define IDC_OPT_COMBO_PDMD 1284

Definition at line 9 of file McaPageRes.h.

#define IDC_OPT_COMBO_PREC 1285

Definition at line 10 of file McaPageRes.h.

#define IDC_OPT_COMBO_PREL 1349

Definition at line 74 of file McaPageRes.h.

#define IDC_OPT_COMBO_PRER 1286

Definition at line 11 of file McaPageRes.h.

#define IDC_OPT_COMBO_PRET 1287

Definition at line 12 of file McaPageRes.h.

#define IDC_OPT_COMBO_SOFF 1288

Definition at line 13 of file McaPageRes.h.

#define IDC_OPT_COMBO_SOFF2 1354

Definition at line 79 of file McaPageRes.h.

#define IDC_OPT_COMBO_SOFF3 1359

Definition at line 84 of file McaPageRes.h.

#define IDC_OPT_COMBO_TLLD 1289

Definition at line 14 of file McaPageRes.h.

#define IDC_OPT_FRAME_DMCA_GAIA 1345

Definition at line 70 of file McaPageRes.h.

#define IDC_OPT_FRAME_DMCA_PURE 1347

Definition at line 72 of file McaPageRes.h.

#define IDC_OPT_FRAME_GATE 1290

Definition at line 15 of file McaPageRes.h.

#define IDC_OPT_FRAME_MCAC 1291

Definition at line 16 of file McaPageRes.h.

#define IDC_OPT_FRAME_MCAE 1292

Definition at line 17 of file McaPageRes.h.

#define IDC_OPT_FRAME_MCAS 1293

Definition at line 18 of file McaPageRes.h.

#define IDC_OPT_FRAME_MCSH 1294

Definition at line 19 of file McaPageRes.h.

#define IDC_OPT_FRAME_MCSL 1295

Definition at line 20 of file McaPageRes.h.

#define IDC_OPT_FRAME_MCST 1296

Definition at line 21 of file McaPageRes.h.

#define IDC_OPT_FRAME_PDMD 1297

Definition at line 22 of file McaPageRes.h.

#define IDC_OPT_FRAME_PRCH 1298

Definition at line 23 of file McaPageRes.h.

#define IDC_OPT_FRAME_PRCL 1299

Definition at line 24 of file McaPageRes.h.

#define IDC_OPT_FRAME_PREC 1300

Definition at line 25 of file McaPageRes.h.

#define IDC_OPT_FRAME_PREL 1348

Definition at line 73 of file McaPageRes.h.

#define IDC_OPT_FRAME_PRER 1301

Definition at line 26 of file McaPageRes.h.

#define IDC_OPT_FRAME_PRET 1302

Definition at line 27 of file McaPageRes.h.

#define IDC_OPT_FRAME_SOFF 1303

Definition at line 28 of file McaPageRes.h.

#define IDC_OPT_FRAME_SOFF2 1353

Definition at line 78 of file McaPageRes.h.

#define IDC_OPT_FRAME_SOFF3 1358

Definition at line 83 of file McaPageRes.h.

#define IDC_OPT_FRAME_THSL 1304

Definition at line 29 of file McaPageRes.h.

#define IDC_OPT_FRAME_TLLD 1305

Definition at line 30 of file McaPageRes.h.

#define IDC_OPT_LIMITS_MCSH 1306

Definition at line 31 of file McaPageRes.h.

#define IDC_OPT_LIMITS_MCSL 1307

Definition at line 32 of file McaPageRes.h.

#define IDC_OPT_LIMITS_MCST 1308

Definition at line 33 of file McaPageRes.h.

#define IDC_OPT_LIMITS_PRCH 1309

Definition at line 34 of file McaPageRes.h.

#define IDC_OPT_LIMITS_PRCL 1310

Definition at line 35 of file McaPageRes.h.

#define IDC_OPT_LIMITS_PREC 1311

Definition at line 36 of file McaPageRes.h.

#define IDC_OPT_LIMITS_PREL 1350

Definition at line 75 of file McaPageRes.h.

#define IDC_OPT_LIMITS_PRER 1312

Definition at line 37 of file McaPageRes.h.

#define IDC_OPT_LIMITS_PRET 1313

Definition at line 38 of file McaPageRes.h.

#define IDC_OPT_LIMITS_SOFF 1314

Definition at line 39 of file McaPageRes.h.

#define IDC_OPT_LIMITS_SOFF2 1355

Definition at line 80 of file McaPageRes.h.

#define IDC_OPT_LIMITS_SOFF3 1360

Definition at line 85 of file McaPageRes.h.

#define IDC_OPT_LIMITS_THSL 1315

Definition at line 40 of file McaPageRes.h.

#define IDC_OPT_LIMITS_TLLD 1316

Definition at line 41 of file McaPageRes.h.

#define IDC_OPT_TEXT_MCSH 1317

Definition at line 42 of file McaPageRes.h.

#define IDC_OPT_TEXT_MCSL 1318

Definition at line 43 of file McaPageRes.h.

#define IDC_OPT_TEXT_MCST 1319

Definition at line 44 of file McaPageRes.h.

#define IDC_OPT_TEXT_PRCH 1320

Definition at line 45 of file McaPageRes.h.

#define IDC_OPT_TEXT_PRCL 1321

Definition at line 46 of file McaPageRes.h.

#define IDC_OPT_TEXT_PREC 1322

Definition at line 47 of file McaPageRes.h.

#define IDC_OPT_TEXT_PREL 1351

Definition at line 76 of file McaPageRes.h.

#define IDC_OPT_TEXT_PRER 1323

Definition at line 48 of file McaPageRes.h.

#define IDC_OPT_TEXT_PRET 1324

Definition at line 49 of file McaPageRes.h.

#define IDC_OPT_TEXT_SOFF 1325

Definition at line 50 of file McaPageRes.h.

#define IDC_OPT_TEXT_SOFF2 1356

Definition at line 81 of file McaPageRes.h.

#define IDC_OPT_TEXT_SOFF3 1361

Definition at line 86 of file McaPageRes.h.

#define IDC_OPT_TEXT_THSL 1326

Definition at line 51 of file McaPageRes.h.

#define IDC_OPT_TEXT_TLLD 1327

Definition at line 52 of file McaPageRes.h.

#define IDC_OPT_UNITS_MCSH 1328

Definition at line 53 of file McaPageRes.h.

#define IDC_OPT_UNITS_MCSL 1329

Definition at line 54 of file McaPageRes.h.

#define IDC_OPT_UNITS_MCST 1330

Definition at line 55 of file McaPageRes.h.

#define IDC_OPT_UNITS_PRCH 1331

Definition at line 56 of file McaPageRes.h.

#define IDC_OPT_UNITS_PRCL 1332

Definition at line 57 of file McaPageRes.h.

#define IDC_OPT_UNITS_PREC 1333

Definition at line 58 of file McaPageRes.h.

#define IDC_OPT_UNITS_PREL 1352

Definition at line 77 of file McaPageRes.h.

#define IDC_OPT_UNITS_PRER 1334

Definition at line 59 of file McaPageRes.h.

#define IDC_OPT_UNITS_PRET 1335

Definition at line 60 of file McaPageRes.h.

#define IDC_OPT_UNITS_SOFF 1336

Definition at line 61 of file McaPageRes.h.

#define IDC_OPT_UNITS_SOFF2 1357

Definition at line 82 of file McaPageRes.h.

#define IDC_OPT_UNITS_SOFF3 1362

Definition at line 87 of file McaPageRes.h.

#define IDC_OPT_UNITS_THSL 1337

Definition at line 62 of file McaPageRes.h.

#define IDC_OPT_UNITS_TLLD 1338

Definition at line 63 of file McaPageRes.h.

#define IDC_PRESETCOUNTCURSORBUTTON 1339

Definition at line 64 of file McaPageRes.h.

#define IDC_PRESETCOUNTROIBUTTON 1340

Definition at line 65 of file McaPageRes.h.

#define IDC_STATIC_MCA_ADVANCED 1341

Definition at line 66 of file McaPageRes.h.

#define IDC_STATIC_MCA_BASIC 1342

Definition at line 67 of file McaPageRes.h.

#define IDC_STATIC_MCA_PAGE 1343

Definition at line 68 of file McaPageRes.h.

#define IDC_STATIC_MCA_STANDARD 1344

Definition at line 69 of file McaPageRes.h.

#define IDS_TT_GATE_CONTROL 5128

Definition at line 97 of file McaPageRes.h.

#define IDS_TT_LOW_LEVEL_DISCRIMINATOR 5122

Definition at line 91 of file McaPageRes.h.

#define IDS_TT_MCA_MCS_CHANNELS 5120

Definition at line 89 of file McaPageRes.h.

#define IDS_TT_MCA_SOURCE 5131

Definition at line 100 of file McaPageRes.h.

#define IDS_TT_MCS_LOW_HIGH_CHANNEL 5130

Definition at line 99 of file McaPageRes.h.

#define IDS_TT_MCS_TIMEBASE 5129

Definition at line 98 of file McaPageRes.h.

#define IDS_TT_PEAK_DETECT_MODE 5132

Definition at line 101 of file McaPageRes.h.

#define IDS_TT_PRESET_ACQUISITION_TIME 5124

Definition at line 93 of file McaPageRes.h.

#define IDS_TT_PRESET_COUNT 5126

Definition at line 95 of file McaPageRes.h.

#define IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL 5127

Definition at line 96 of file McaPageRes.h.

#define IDS_TT_PRESET_LIVE_TIME 5133

Definition at line 102 of file McaPageRes.h.

#define IDS_TT_PRESET_REAL_TIME 5125

Definition at line 94 of file McaPageRes.h.

#define IDS_TT_SET_SPECTRUM_OFFSET 5123

Definition at line 92 of file McaPageRes.h.

#define IDS_TT_SLOW_THRESHOLD 5121

Definition at line 90 of file McaPageRes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/MiscPage.cpp File Reference

DP5Cfg/MiscPage.cpp File Reference
#include "stdafx.h"
#include "afxpriv.h"
#include "MiscPageRes.h"
#include "MiscPage.h"
Include dependency graph for MiscPage.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/MiscPage.h File Reference

Classes
DP5Cfg/MiscPage.h File Reference
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
#include "scommon.h"
Include dependency graph for MiscPage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CMiscPage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/MiscPageRes.h File Reference

Defines
DP5Cfg/MiscPageRes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_BUTTON_OUTPUT_QUICKSET1 1792
#define | IDC_BUTTON_OUTPUT_QUICKSET2 1793
#define | IDC_BUTTON_OUTPUT_QUICKSET3 1794
#define | IDC_OPT_COMBO_AUO1 1795
#define | IDC_OPT_COMBO_AUO2 1796
#define | IDC_OPT_COMBO_CON1 1797
#define | IDC_OPT_COMBO_CON2 1798
#define | IDC_OPT_COMBO_DACO 1799
#define | IDC_OPT_COMBO_GPED 1800
#define | IDC_OPT_COMBO_GPGA 1801
#define | IDC_OPT_COMBO_GPIN 1802
#define | IDC_OPT_COMBO_GPMC 1803
#define | IDC_OPT_COMBO_GPME 1804
#define | IDC_OPT_COMBO_SCOE 1805
#define | IDC_OPT_COMBO_SCOG 1806
#define | IDC_OPT_COMBO_SCOT 1807
#define | IDC_OPT_COMBO_TPMO 1808
#define | IDC_OPT_COMBO_VOLU 1809
#define | IDC_OPT_FRAME_AUO1 1810
#define | IDC_OPT_FRAME_AUO2 1811
#define | IDC_OPT_FRAME_CON1 1812
#define | IDC_OPT_FRAME_CON2 1813
#define | IDC_OPT_FRAME_DACF 1814
#define | IDC_OPT_FRAME_DACO 1815
#define | IDC_OPT_FRAME_GPED 1816
#define | IDC_OPT_FRAME_GPGA 1817
#define | IDC_OPT_FRAME_GPIN 1818
#define | IDC_OPT_FRAME_GPMC 1819
#define | IDC_OPT_FRAME_GPME 1820
#define | IDC_OPT_FRAME_SCOE 1821
#define | IDC_OPT_FRAME_SCOG 1822
#define | IDC_OPT_FRAME_SCOT 1823
#define | IDC_OPT_FRAME_TPMO 1824
#define | IDC_OPT_FRAME_VOLU 1825
#define | IDC_OPT_LIMITS_AUO1 1826
#define | IDC_OPT_LIMITS_AUO2 1827
#define | IDC_OPT_LIMITS_DACF 1828
#define | IDC_OPT_LIMITS_DACO 1829
#define | IDC_OPT_LIMITS_GPIN 1830
#define | IDC_OPT_TEXT_AUO1 1831
#define | IDC_OPT_TEXT_AUO2 1832
#define | IDC_OPT_TEXT_DACF 1833
#define | IDC_OPT_TEXT_DACO 1834
#define | IDC_OPT_TEXT_GPIN 1835
#define | IDC_OPT_UNITS_AUO1 1836
#define | IDC_OPT_UNITS_AUO2 1837
#define | IDC_OPT_UNITS_DACF 1838
#define | IDC_OPT_UNITS_DACO 1839
#define | IDC_OPT_UNITS_GPIN 1840
#define | IDC_OPT_UNITS_SCOG 1841
#define | IDC_STATIC_MISC_ADVANCED 1842
#define | IDC_STATIC_MISC_BASIC 1843
#define | IDC_STATIC_MISC_PAGE 1844
#define | IDC_STATIC_MISC_QUICKSET 1845
#define | IDC_STATIC_MISC_STANDARD 1846
#define | IDC_CHECK_ENABLE_SCA 1847
#define | IDC_COMBO_SCA_INDEX 1848
#define | IDC_COMBO_OUTPUT_LEVEL 1849
#define | IDC_EDIT_LOW_THRESHOLD 1850
#define | IDC_EDIT_HIGH_THRESHOLD 1851
#define | IDC_BUTTON_SCA_DEFAULTS 1852
#define | IDC_COMBO_SCA_PULSE_WIDTH 1853
#define | IDC_BUTTON_PREVIEW_SCA 1854
#define | IDC_STATIC_CURRENT_SCA 1855
#define | IDC_STATIC_SCA_GROUP 1856
#define | IDC_STATIC_SCA_INDEX 1857
#define | IDC_STATIC_LOW_THRESHOLD 1858
#define | IDC_STATIC_HIGH_THRESHOLD 1859
#define | IDC_STATIC_OUTPUT_LEVEL 1860
#define | IDC_STATIC_SCA_PULSE_WIDTH 1861
#define | IDC_STATIC_DAC_FRAME 1862
#define | IDS_TT_ANALOG_OUT 6144
#define | IDS_TT_OUTPUT_OFFSET 6145
#define | IDS_TT_AUX_1 6146
#define | IDS_TT_AUX_2 6147
#define | IDS_TT_TEST_PULSER 6148
#define | IDS_TT_PX__SPEAKER 6149
#define | IDS_TT_CONNECTOR_1 6150
#define | IDS_TT_CONNECTOR_2 6151
#define | IDS_TT_SCOPE_COMMANDS 6152

Define Documentation

#define IDC_BUTTON_OUTPUT_QUICKSET1 1792

Definition at line 5 of file MiscPageRes.h.

#define IDC_BUTTON_OUTPUT_QUICKSET2 1793

Definition at line 6 of file MiscPageRes.h.

#define IDC_BUTTON_OUTPUT_QUICKSET3 1794

Definition at line 7 of file MiscPageRes.h.

#define IDC_BUTTON_PREVIEW_SCA 1854

Definition at line 67 of file MiscPageRes.h.

#define IDC_BUTTON_SCA_DEFAULTS 1852

Definition at line 65 of file MiscPageRes.h.

#define IDC_CHECK_ENABLE_SCA 1847

Definition at line 60 of file MiscPageRes.h.

#define IDC_COMBO_OUTPUT_LEVEL 1849

Definition at line 62 of file MiscPageRes.h.

#define IDC_COMBO_SCA_INDEX 1848

Definition at line 61 of file MiscPageRes.h.

#define IDC_COMBO_SCA_PULSE_WIDTH 1853

Definition at line 66 of file MiscPageRes.h.

#define IDC_EDIT_HIGH_THRESHOLD 1851

Definition at line 64 of file MiscPageRes.h.

#define IDC_EDIT_LOW_THRESHOLD 1850

Definition at line 63 of file MiscPageRes.h.

#define IDC_OPT_COMBO_AUO1 1795

Definition at line 8 of file MiscPageRes.h.

#define IDC_OPT_COMBO_AUO2 1796

Definition at line 9 of file MiscPageRes.h.

#define IDC_OPT_COMBO_CON1 1797

Definition at line 10 of file MiscPageRes.h.

#define IDC_OPT_COMBO_CON2 1798

Definition at line 11 of file MiscPageRes.h.

#define IDC_OPT_COMBO_DACO 1799

Definition at line 12 of file MiscPageRes.h.

#define IDC_OPT_COMBO_GPED 1800

Definition at line 13 of file MiscPageRes.h.

#define IDC_OPT_COMBO_GPGA 1801

Definition at line 14 of file MiscPageRes.h.

#define IDC_OPT_COMBO_GPIN 1802

Definition at line 15 of file MiscPageRes.h.

#define IDC_OPT_COMBO_GPMC 1803

Definition at line 16 of file MiscPageRes.h.

#define IDC_OPT_COMBO_GPME 1804

Definition at line 17 of file MiscPageRes.h.

#define IDC_OPT_COMBO_SCOE 1805

Definition at line 18 of file MiscPageRes.h.

#define IDC_OPT_COMBO_SCOG 1806

Definition at line 19 of file MiscPageRes.h.

#define IDC_OPT_COMBO_SCOT 1807

Definition at line 20 of file MiscPageRes.h.

#define IDC_OPT_COMBO_TPMO 1808

Definition at line 21 of file MiscPageRes.h.

#define IDC_OPT_COMBO_VOLU 1809

Definition at line 22 of file MiscPageRes.h.

#define IDC_OPT_FRAME_AUO1 1810

Definition at line 23 of file MiscPageRes.h.

#define IDC_OPT_FRAME_AUO2 1811

Definition at line 24 of file MiscPageRes.h.

#define IDC_OPT_FRAME_CON1 1812

Definition at line 25 of file MiscPageRes.h.

#define IDC_OPT_FRAME_CON2 1813

Definition at line 26 of file MiscPageRes.h.

#define IDC_OPT_FRAME_DACF 1814

Definition at line 27 of file MiscPageRes.h.

#define IDC_OPT_FRAME_DACO 1815

Definition at line 28 of file MiscPageRes.h.

#define IDC_OPT_FRAME_GPED 1816

Definition at line 29 of file MiscPageRes.h.

#define IDC_OPT_FRAME_GPGA 1817

Definition at line 30 of file MiscPageRes.h.

#define IDC_OPT_FRAME_GPIN 1818

Definition at line 31 of file MiscPageRes.h.

#define IDC_OPT_FRAME_GPMC 1819

Definition at line 32 of file MiscPageRes.h.

#define IDC_OPT_FRAME_GPME 1820

Definition at line 33 of file MiscPageRes.h.

#define IDC_OPT_FRAME_SCOE 1821

Definition at line 34 of file MiscPageRes.h.

#define IDC_OPT_FRAME_SCOG 1822

Definition at line 35 of file MiscPageRes.h.

#define IDC_OPT_FRAME_SCOT 1823

Definition at line 36 of file MiscPageRes.h.

#define IDC_OPT_FRAME_TPMO 1824

Definition at line 37 of file MiscPageRes.h.

#define IDC_OPT_FRAME_VOLU 1825

Definition at line 38 of file MiscPageRes.h.

#define IDC_OPT_LIMITS_AUO1 1826

Definition at line 39 of file MiscPageRes.h.

#define IDC_OPT_LIMITS_AUO2 1827

Definition at line 40 of file MiscPageRes.h.

#define IDC_OPT_LIMITS_DACF 1828

Definition at line 41 of file MiscPageRes.h.

#define IDC_OPT_LIMITS_DACO 1829

Definition at line 42 of file MiscPageRes.h.

#define IDC_OPT_LIMITS_GPIN 1830

Definition at line 43 of file MiscPageRes.h.

#define IDC_OPT_TEXT_AUO1 1831

Definition at line 44 of file MiscPageRes.h.

#define IDC_OPT_TEXT_AUO2 1832

Definition at line 45 of file MiscPageRes.h.

#define IDC_OPT_TEXT_DACF 1833

Definition at line 46 of file MiscPageRes.h.

#define IDC_OPT_TEXT_DACO 1834

Definition at line 47 of file MiscPageRes.h.

#define IDC_OPT_TEXT_GPIN 1835

Definition at line 48 of file MiscPageRes.h.

#define IDC_OPT_UNITS_AUO1 1836

Definition at line 49 of file MiscPageRes.h.

#define IDC_OPT_UNITS_AUO2 1837

Definition at line 50 of file MiscPageRes.h.

#define IDC_OPT_UNITS_DACF 1838

Definition at line 51 of file MiscPageRes.h.

#define IDC_OPT_UNITS_DACO 1839

Definition at line 52 of file MiscPageRes.h.

#define IDC_OPT_UNITS_GPIN 1840

Definition at line 53 of file MiscPageRes.h.

#define IDC_OPT_UNITS_SCOG 1841

Definition at line 54 of file MiscPageRes.h.

#define IDC_STATIC_CURRENT_SCA 1855

Definition at line 68 of file MiscPageRes.h.

#define IDC_STATIC_DAC_FRAME 1862

Definition at line 75 of file MiscPageRes.h.

#define IDC_STATIC_HIGH_THRESHOLD 1859

Definition at line 72 of file MiscPageRes.h.

#define IDC_STATIC_LOW_THRESHOLD 1858

Definition at line 71 of file MiscPageRes.h.

#define IDC_STATIC_MISC_ADVANCED 1842

Definition at line 55 of file MiscPageRes.h.

#define IDC_STATIC_MISC_BASIC 1843

Definition at line 56 of file MiscPageRes.h.

#define IDC_STATIC_MISC_PAGE 1844

Definition at line 57 of file MiscPageRes.h.

#define IDC_STATIC_MISC_QUICKSET 1845

Definition at line 58 of file MiscPageRes.h.

#define IDC_STATIC_MISC_STANDARD 1846

Definition at line 59 of file MiscPageRes.h.

#define IDC_STATIC_OUTPUT_LEVEL 1860

Definition at line 73 of file MiscPageRes.h.

#define IDC_STATIC_SCA_GROUP 1856

Definition at line 69 of file MiscPageRes.h.

#define IDC_STATIC_SCA_INDEX 1857

Definition at line 70 of file MiscPageRes.h.

#define IDC_STATIC_SCA_PULSE_WIDTH 1861

Definition at line 74 of file MiscPageRes.h.

#define IDS_TT_ANALOG_OUT 6144

Definition at line 76 of file MiscPageRes.h.

#define IDS_TT_AUX_1 6146

Definition at line 78 of file MiscPageRes.h.

#define IDS_TT_AUX_2 6147

Definition at line 79 of file MiscPageRes.h.

#define IDS_TT_CONNECTOR_1 6150

Definition at line 82 of file MiscPageRes.h.

#define IDS_TT_CONNECTOR_2 6151

Definition at line 83 of file MiscPageRes.h.

#define IDS_TT_OUTPUT_OFFSET 6145

Definition at line 77 of file MiscPageRes.h.

#define IDS_TT_PX__SPEAKER 6149

Definition at line 81 of file MiscPageRes.h.

#define IDS_TT_SCOPE_COMMANDS 6152

Definition at line 84 of file MiscPageRes.h.

#define IDS_TT_TEST_PULSER 6148

Definition at line 80 of file MiscPageRes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/PowerPage.cpp File Reference

DP5Cfg/PowerPage.cpp File Reference
#include "stdafx.h"
#include "afxpriv.h"
#include "PowerPageRes.h"
#include "PowerPage.h"
Include dependency graph for PowerPage.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/PowerPage.h File Reference

Classes
DP5Cfg/PowerPage.h File Reference
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
Include dependency graph for PowerPage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CPowerPage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/PowerPageRes.h File Reference

Defines
DP5Cfg/PowerPageRes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_OPT_COMBO_BOOT 1536
#define | IDC_OPT_COMBO_HVSE 1537
#define | IDC_OPT_COMBO_PAPS 1538
#define | IDC_OPT_COMBO_TECS 1540
#define | IDC_OPT_FRAME_BOOT 1541
#define | IDC_OPT_FRAME_HVSE 1542
#define | IDC_OPT_FRAME_PAPS 1543
#define | IDC_OPT_FRAME_TECS 1545
#define | IDC_OPT_LIMITS_HVSE 1546
#define | IDC_OPT_LIMITS_TECS 1548
#define | IDC_OPT_TEXT_HVSE 1549
#define | IDC_OPT_TEXT_TECS 1551
#define | IDC_OPT_UNITS_HVSE 1552
#define | IDC_OPT_UNITS_PAPS 1553
#define | IDC_OPT_UNITS_TECS 1555
#define | IDC_RADIO_HV_SIGN1 1556
#define | IDC_RADIO_HV_SIGN2 1557
#define | IDC_STATIC_HV_SIGN1 1558
#define | IDC_STATIC_HV_SIGN2 1559
#define | IDC_STATIC_HV_WARNING 1560
#define | IDC_STATIC_POWER_ADVANCED 1561
#define | IDC_STATIC_POWER_BASIC 1562
#define | IDC_STATIC_POWER_PAGE 1563
#define | IDC_STATIC_POWER_STANDARD 1564
#define | IDS_TT_COOLER_TEMPERATURE 5632
#define | IDS_TT_HIGH_VOLTAGE_BIAS 5633
#define | IDS_TT_HIGH_VOLTAGE_POLARITY 5634
#define | IDS_TT_PREAMP_VOLTAGE 5635
#define | IDS_TT_PC__ON_AT_STARTUP 5636

Define Documentation

#define IDC_OPT_COMBO_BOOT 1536

Definition at line 5 of file PowerPageRes.h.

#define IDC_OPT_COMBO_HVSE 1537

Definition at line 6 of file PowerPageRes.h.

#define IDC_OPT_COMBO_PAPS 1538

Definition at line 7 of file PowerPageRes.h.

#define IDC_OPT_COMBO_TECS 1540

Definition at line 8 of file PowerPageRes.h.

#define IDC_OPT_FRAME_BOOT 1541

Definition at line 9 of file PowerPageRes.h.

#define IDC_OPT_FRAME_HVSE 1542

Definition at line 10 of file PowerPageRes.h.

#define IDC_OPT_FRAME_PAPS 1543

Definition at line 11 of file PowerPageRes.h.

#define IDC_OPT_FRAME_TECS 1545

Definition at line 12 of file PowerPageRes.h.

#define IDC_OPT_LIMITS_HVSE 1546

Definition at line 13 of file PowerPageRes.h.

#define IDC_OPT_LIMITS_TECS 1548

Definition at line 14 of file PowerPageRes.h.

#define IDC_OPT_TEXT_HVSE 1549

Definition at line 15 of file PowerPageRes.h.

#define IDC_OPT_TEXT_TECS 1551

Definition at line 16 of file PowerPageRes.h.

#define IDC_OPT_UNITS_HVSE 1552

Definition at line 17 of file PowerPageRes.h.

#define IDC_OPT_UNITS_PAPS 1553

Definition at line 18 of file PowerPageRes.h.

#define IDC_OPT_UNITS_TECS 1555

Definition at line 19 of file PowerPageRes.h.

#define IDC_RADIO_HV_SIGN1 1556

Definition at line 20 of file PowerPageRes.h.

#define IDC_RADIO_HV_SIGN2 1557

Definition at line 21 of file PowerPageRes.h.

#define IDC_STATIC_HV_SIGN1 1558

Definition at line 22 of file PowerPageRes.h.

#define IDC_STATIC_HV_SIGN2 1559

Definition at line 23 of file PowerPageRes.h.

#define IDC_STATIC_HV_WARNING 1560

Definition at line 24 of file PowerPageRes.h.

#define IDC_STATIC_POWER_ADVANCED 1561

Definition at line 25 of file PowerPageRes.h.

#define IDC_STATIC_POWER_BASIC 1562

Definition at line 26 of file PowerPageRes.h.

#define IDC_STATIC_POWER_PAGE 1563

Definition at line 27 of file PowerPageRes.h.

#define IDC_STATIC_POWER_STANDARD 1564

Definition at line 28 of file PowerPageRes.h.

#define IDS_TT_COOLER_TEMPERATURE 5632

Definition at line 29 of file PowerPageRes.h.

#define IDS_TT_HIGH_VOLTAGE_BIAS 5633

Definition at line 30 of file PowerPageRes.h.

#define IDS_TT_HIGH_VOLTAGE_POLARITY 5634

Definition at line 31 of file PowerPageRes.h.

#define IDS_TT_PC__ON_AT_STARTUP 5636

Definition at line 33 of file PowerPageRes.h.

#define IDS_TT_PREAMP_VOLTAGE 5635

Definition at line 32 of file PowerPageRes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Sca.cpp File Reference

DP5Cfg/Sca.cpp File Reference
#include "StdAfx.h"
#include ".\sca.h"
Include dependency graph for Sca.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Sca.h File Reference

Classes | Defines
DP5Cfg/Sca.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | CSca

Defines

#define | MAX_SCA_REGISTER 8

Define Documentation

#define MAX_SCA_REGISTER 8

Definition at line 3 of file Sca.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ScaFn.cpp File Reference

DP5Cfg/ScaFn.cpp File Reference
#include "StdAfx.h"
#include ".\scafn.h"
#include "IniUtil.h"
Include dependency graph for ScaFn.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ScaFn.h File Reference

Classes
DP5Cfg/ScaFn.h File Reference
#include ".\sca.h"
Include dependency graph for ScaFn.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CScaFn
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ShapingPage.cpp File Reference

DP5Cfg/ShapingPage.cpp File Reference
#include "stdafx.h"
#include "afxpriv.h"
#include "ShapingPageRes.h"
#include "ShapingPage.h"
Include dependency graph for ShapingPage.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ShapingPage.h File Reference

Classes
DP5Cfg/ShapingPage.h File Reference
#include "CfgPropSheet.h"
#include "afxwin.h"
#include "label.h"
#include ".\dppshaping.h"
Include dependency graph for ShapingPage.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class CShapingPage
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ShapingPageRes.h File Reference

Defines
DP5Cfg/ShapingPageRes.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | IDC_OPT_COMBO_TLLD 1289
#define | IDC_OPT_FRAME_TLLD 1305
#define | IDC_OPT_LIMITS_TLLD 1316
#define | IDC_OPT_TEXT_TLLD 1327
#define | IDC_OPT_UNITS_TLLD 1338
#define | IDC_BLRQUICKSLOWBUTTON 1408
#define | IDC_FLATTOPSTATIC 1410
#define | IDC_LABEL_QUICK_PICK_SHAPING 1411
#define | IDC_LABEL_QUICK_PICK_SHAPING2 1412
#define | IDC_OPT_COMBO_BLRM 1413
#define | IDC_OPT_COMBO_CLCK 1414
#define | IDC_OPT_COMBO_CUSP 1415
#define | IDC_OPT_COMBO_PURE 1416
#define | IDC_OPT_COMBO_RTDE 1417
#define | IDC_OPT_COMBO_TPFA 1418
#define | IDC_OPT_FRAME_BLRD 1419
#define | IDC_OPT_FRAME_BLRM 1420
#define | IDC_OPT_FRAME_BLRU 1421
#define | IDC_OPT_FRAME_CLCK 1422
#define | IDC_OPT_FRAME_CUSP 1423
#define | IDC_OPT_FRAME_PURE 1424
#define | IDC_OPT_FRAME_RTDE 1425
#define | IDC_OPT_FRAME_RTDS 1426
#define | IDC_OPT_FRAME_RTDT 1427
#define | IDC_OPT_FRAME_TFLA 1428
#define | IDC_OPT_FRAME_THFA 1429
#define | IDC_OPT_FRAME_TPEA 1430
#define | IDC_OPT_FRAME_TPFA 1431
#define | IDC_OPT_LIMITS_BLRD 1432
#define | IDC_OPT_LIMITS_BLRU 1433
#define | IDC_OPT_LIMITS_CUSP 1434
#define | IDC_OPT_LIMITS_RTDS 1435
#define | IDC_OPT_LIMITS_RTDT 1436
#define | IDC_OPT_LIMITS_TFLA 1437
#define | IDC_OPT_LIMITS_THFA 1438
#define | IDC_OPT_LIMITS_TPEA 1439
#define | IDC_OPT_TEXT_BLRD 1440
#define | IDC_OPT_TEXT_BLRU 1441
#define | IDC_OPT_TEXT_CUSP 1442
#define | IDC_OPT_TEXT_RTDS 1443
#define | IDC_OPT_TEXT_RTDT 1444
#define | IDC_OPT_TEXT_TFLA 1445
#define | IDC_OPT_TEXT_THFA 1446
#define | IDC_OPT_TEXT_TPEA 1447
#define | IDC_OPT_UNITS_BLRD 1448
#define | IDC_OPT_UNITS_BLRU 1449
#define | IDC_OPT_UNITS_CUSP 1450
#define | IDC_OPT_UNITS_RESL2 1451
#define | IDC_OPT_UNITS_RESL3 1452
#define | IDC_OPT_UNITS_RTDS 1453
#define | IDC_OPT_UNITS_RTDT 1454
#define | IDC_OPT_UNITS_TFLA 1455
#define | IDC_OPT_UNITS_THFA 1456
#define | IDC_OPT_UNITS_TPEA 1457
#define | IDC_RISECOMBO 1458
#define | IDC_SHAPINGGROUP 1459
#define | IDC_STATIC_FPGACLK1 1460
#define | IDC_STATIC_FPGACLK2 1461
#define | IDC_STATIC_FPGACLK3 1462
#define | IDC_STATIC_PULSE_SHAPING 1463
#define | IDC_STATIC_SHAPING_ADVANCED 1464
#define | IDC_STATIC_SHAPING_BASIC 1465
#define | IDC_STATIC_SHAPING_PAGE 1466
#define | IDC_STATIC_SHAPING_STANDARD 1467
#define | IDC_TIMETOPEAKSTATIC 1468
#define | IDC_TOPCOMBO 1469
#define | IDC_LABEL_BLR_MODE_OFF_ON 1470
#define | IDC_STATIC_RTD_FRAME 1471
#define | IDC_STATIC_BLR_FRAME 1472
#define | IDC_STATIC_FAST_SHAPING_FRAME 1473
#define | IDC_OPT_LIMITS_PURE 1474
#define | IDC_OPT_TEXT_PURE 1475
#define | IDC_OPT_UNITS_PURE 1476
#define | IDC_OPT_FRAME_SCTC 1477
#define | IDC_OPT_COMBO_SCTC 1478
#define | IDC_OPT_LIMITS_SCTC 1479
#define | IDC_OPT_TEXT_SCTC 1480
#define | IDC_OPT_UNITS_SCTC 1481
#define | IDS_TT_PEAKING_TIME 5376
#define | IDS_TT_PEAKING_QPICK 5377
#define | IDS_TT_FLAT_TOP_WIDTH 5378
#define | IDS_TT_PUR_ON_OFF 5379
#define | IDS_TT_FAST_PEAKING_TIME 5380
#define | IDS_TT_FAST_THRESHOLD 5381
#define | IDS_TT_FPGA_CLOCK_SPEED 5382
#define | IDS_TT_NON_TRAPEZOIDAL_SHAPING 5383
#define | IDS_TT_BLR_QUICKSET 5384
#define | IDS_TT_RTD_ON_OFF 5385
#define | IDS_TT_RTD_THRESHOLD 5386
#define | IDS_TT_RTD_SENSITIVITY 5387
#define | IDS_TT_BLR_DOWN_CORRECTION 5388
#define | IDS_TT_BLR_UP_CORRECTION 5389
#define | IDS_TT_BLR_MODE 5390
#define | IDS_TT_SCTC 5391

Define Documentation

#define IDC_BLRQUICKSLOWBUTTON 1408

Definition at line 10 of file ShapingPageRes.h.

#define IDC_FLATTOPSTATIC 1410

Definition at line 11 of file ShapingPageRes.h.

#define IDC_LABEL_BLR_MODE_OFF_ON 1470

Definition at line 71 of file ShapingPageRes.h.

#define IDC_LABEL_QUICK_PICK_SHAPING 1411

Definition at line 12 of file ShapingPageRes.h.

#define IDC_LABEL_QUICK_PICK_SHAPING2 1412

Definition at line 13 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_BLRM 1413

Definition at line 14 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_CLCK 1414

Definition at line 15 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_CUSP 1415

Definition at line 16 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_PURE 1416

Definition at line 17 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_RTDE 1417

Definition at line 18 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_SCTC 1478

Definition at line 79 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_TLLD 1289

Definition at line 5 of file ShapingPageRes.h.

#define IDC_OPT_COMBO_TPFA 1418

Definition at line 19 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_BLRD 1419

Definition at line 20 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_BLRM 1420

Definition at line 21 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_BLRU 1421

Definition at line 22 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_CLCK 1422

Definition at line 23 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_CUSP 1423

Definition at line 24 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_PURE 1424

Definition at line 25 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_RTDE 1425

Definition at line 26 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_RTDS 1426

Definition at line 27 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_RTDT 1427

Definition at line 28 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_SCTC 1477

Definition at line 78 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_TFLA 1428

Definition at line 29 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_THFA 1429

Definition at line 30 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_TLLD 1305

Definition at line 6 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_TPEA 1430

Definition at line 31 of file ShapingPageRes.h.

#define IDC_OPT_FRAME_TPFA 1431

Definition at line 32 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_BLRD 1432

Definition at line 33 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_BLRU 1433

Definition at line 34 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_CUSP 1434

Definition at line 35 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_PURE 1474

Definition at line 75 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_RTDS 1435

Definition at line 36 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_RTDT 1436

Definition at line 37 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_SCTC 1479

Definition at line 80 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_TFLA 1437

Definition at line 38 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_THFA 1438

Definition at line 39 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_TLLD 1316

Definition at line 7 of file ShapingPageRes.h.

#define IDC_OPT_LIMITS_TPEA 1439

Definition at line 40 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_BLRD 1440

Definition at line 41 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_BLRU 1441

Definition at line 42 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_CUSP 1442

Definition at line 43 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_PURE 1475

Definition at line 76 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_RTDS 1443

Definition at line 44 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_RTDT 1444

Definition at line 45 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_SCTC 1480

Definition at line 81 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_TFLA 1445

Definition at line 46 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_THFA 1446

Definition at line 47 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_TLLD 1327

Definition at line 8 of file ShapingPageRes.h.

#define IDC_OPT_TEXT_TPEA 1447

Definition at line 48 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_BLRD 1448

Definition at line 49 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_BLRU 1449

Definition at line 50 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_CUSP 1450

Definition at line 51 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_PURE 1476

Definition at line 77 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_RESL2 1451

Definition at line 52 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_RESL3 1452

Definition at line 53 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_RTDS 1453

Definition at line 54 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_RTDT 1454

Definition at line 55 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_SCTC 1481

Definition at line 82 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_TFLA 1455

Definition at line 56 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_THFA 1456

Definition at line 57 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_TLLD 1338

Definition at line 9 of file ShapingPageRes.h.

#define IDC_OPT_UNITS_TPEA 1457

Definition at line 58 of file ShapingPageRes.h.

#define IDC_RISECOMBO 1458

Definition at line 59 of file ShapingPageRes.h.

#define IDC_SHAPINGGROUP 1459

Definition at line 60 of file ShapingPageRes.h.

#define IDC_STATIC_BLR_FRAME 1472

Definition at line 73 of file ShapingPageRes.h.

#define IDC_STATIC_FAST_SHAPING_FRAME 1473

Definition at line 74 of file ShapingPageRes.h.

#define IDC_STATIC_FPGACLK1 1460

Definition at line 61 of file ShapingPageRes.h.

#define IDC_STATIC_FPGACLK2 1461

Definition at line 62 of file ShapingPageRes.h.

#define IDC_STATIC_FPGACLK3 1462

Definition at line 63 of file ShapingPageRes.h.

#define IDC_STATIC_PULSE_SHAPING 1463

Definition at line 64 of file ShapingPageRes.h.

#define IDC_STATIC_RTD_FRAME 1471

Definition at line 72 of file ShapingPageRes.h.

#define IDC_STATIC_SHAPING_ADVANCED 1464

Definition at line 65 of file ShapingPageRes.h.

#define IDC_STATIC_SHAPING_BASIC 1465

Definition at line 66 of file ShapingPageRes.h.

#define IDC_STATIC_SHAPING_PAGE 1466

Definition at line 67 of file ShapingPageRes.h.

#define IDC_STATIC_SHAPING_STANDARD 1467

Definition at line 68 of file ShapingPageRes.h.

#define IDC_TIMETOPEAKSTATIC 1468

Definition at line 69 of file ShapingPageRes.h.

#define IDC_TOPCOMBO 1469

Definition at line 70 of file ShapingPageRes.h.

#define IDS_TT_BLR_DOWN_CORRECTION 5388

Definition at line 95 of file ShapingPageRes.h.

#define IDS_TT_BLR_MODE 5390

Definition at line 97 of file ShapingPageRes.h.

#define IDS_TT_BLR_QUICKSET 5384

Definition at line 91 of file ShapingPageRes.h.

#define IDS_TT_BLR_UP_CORRECTION 5389

Definition at line 96 of file ShapingPageRes.h.

#define IDS_TT_FAST_PEAKING_TIME 5380

Definition at line 87 of file ShapingPageRes.h.

#define IDS_TT_FAST_THRESHOLD 5381

Definition at line 88 of file ShapingPageRes.h.

#define IDS_TT_FLAT_TOP_WIDTH 5378

Definition at line 85 of file ShapingPageRes.h.

#define IDS_TT_FPGA_CLOCK_SPEED 5382

Definition at line 89 of file ShapingPageRes.h.

#define IDS_TT_NON_TRAPEZOIDAL_SHAPING 5383

Definition at line 90 of file ShapingPageRes.h.

#define IDS_TT_PEAKING_QPICK 5377

Definition at line 84 of file ShapingPageRes.h.

#define IDS_TT_PEAKING_TIME 5376

Definition at line 83 of file ShapingPageRes.h.

#define IDS_TT_PUR_ON_OFF 5379

Definition at line 86 of file ShapingPageRes.h.

#define IDS_TT_RTD_ON_OFF 5385

Definition at line 92 of file ShapingPageRes.h.

#define IDS_TT_RTD_SENSITIVITY 5387

Definition at line 94 of file ShapingPageRes.h.

#define IDS_TT_RTD_THRESHOLD 5386

Definition at line 93 of file ShapingPageRes.h.

#define IDS_TT_SCTC 5391

Definition at line 98 of file ShapingPageRes.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: hlp/HTMLDefines.h File Reference

Defines
hlp/HTMLDefines.h File Reference

Go to the source code of this file.

Defines

#define | HIDM_ABOUTBOX 0x10010
#define | HID_FILE_TAB 0x18128
#define | HID_GAINPZ_TAB 0x18131
#define | HID_MCA_TAB 0x18144
#define | HID_MISC_TAB 0x18147
#define | HID_POWER_TAB 0x1814E
#define | HID_SHAPING_TAB 0x18160
#define | HID_HELP_ABOUT 0x19C43
#define | HIDP_SOCKETS_INIT_FAILED 0x3105A
#define | HIDR_MAINFRAME 0x2105C
#define | HIDR_MENU 0x2105D
#define | HIDR_TOOLBAR 0x21064
#define | HIDR_TOOLBAR_DP5_DLG 0x21065
#define | HIDD_ABOUTBOX 0x20064
#define | HIDD_BUSY_DLG 0x21036
#define | HIDD_MESSAGE_BOX 0x2103F
#define | HIDD_vcDP5_DIALOG 0x21C00
#define | HID_HT_NOWHERE 0x40000
#define | HID_HT_CAPTION 0x40002
#define | HID_HT_SIZE 0x40004
#define | HID_HT_HSCROLL 0x40006
#define | HID_HT_VSCROLL 0x40007
#define | HID_HT_MINBUTTON 0x40008
#define | HID_HT_MAXBUTTON 0x40009
#define | HID_HT_SIZE 0x4000A
#define | HID_HT_SIZE 0x4000B
#define | HID_HT_SIZE 0x4000C
#define | HID_HT_SIZE 0x4000D
#define | HID_HT_SIZE 0x4000E
#define | HID_HT_SIZE 0x4000F
#define | HID_HT_SIZE 0x40010
#define | HID_HT_SIZE 0x40011
#define | HID_HT_SIZE 0x40012
#define | HID_HT_OBJECT 0x40013
#define | HID_HT_CLOSE 0x40014
#define | HID_HT_HELP 0x40015
#define | HID_SC_SIZE 0x1EF00
#define | HID_SC_MOVE 0x1EF01
#define | HID_SC_MINIMIZE 0x1EF02
#define | HID_SC_MAXIMIZE 0x1EF03
#define | HID_SC_NEXTWINDOW 0x1EF04
#define | HID_SC_PREVWINDOW 0x1EF05
#define | HID_SC_CLOSE 0x1EF06
#define | HID_SC_RESTORE 0x1EF12
#define | HID_SC_TASKLIST 0x1EF13
#define | HID_FILE_MRU_FILE1 0x1E110
#define | HID_FILE_MRU_FILE1 0x1E111
#define | HID_FILE_MRU_FILE1 0x1E112
#define | HID_FILE_MRU_FILE1 0x1E113
#define | HID_FILE_MRU_FILE1 0x1E114
#define | HID_FILE_MRU_FILE1 0x1E115
#define | HID_FILE_MRU_FILE1 0x1E116
#define | HID_FILE_MRU_FILE1 0x1E117
#define | HID_FILE_MRU_FILE1 0x1E118
#define | HID_FILE_MRU_FILE1 0x1E119
#define | HID_FILE_MRU_FILE1 0x1E11A
#define | HID_FILE_MRU_FILE1 0x1E11B
#define | HID_FILE_MRU_FILE1 0x1E11C
#define | HID_FILE_MRU_FILE1 0x1E11D
#define | HID_FILE_MRU_FILE1 0x1E11E
#define | HID_FILE_MRU_FILE1 0x1E11F
#define | HID_WINDOW_ALL 0x1EF1F
#define | HID_OLE_VERB_1 0x1E210
#define | HID_OLE_VERB_1 0x1E211
#define | HID_OLE_VERB_1 0x1E212
#define | HID_OLE_VERB_1 0x1E213
#define | HID_OLE_VERB_1 0x1E214
#define | HID_OLE_VERB_1 0x1E215
#define | HID_OLE_VERB_1 0x1E216
#define | HID_OLE_VERB_1 0x1E217
#define | HID_OLE_VERB_1 0x1E218
#define | HID_OLE_VERB_1 0x1E219
#define | HID_OLE_VERB_1 0x1E21A
#define | HID_OLE_VERB_1 0x1E21B
#define | HID_OLE_VERB_1 0x1E21C
#define | HID_OLE_VERB_1 0x1E21D
#define | HID_OLE_VERB_1 0x1E21E
#define | HID_OLE_VERB_1 0x1E21F
#define | HID_FILE_NEW 0x1E100
#define | HID_FILE_OPEN 0x1E101
#define | HID_FILE_CLOSE 0x1E102
#define | HID_FILE_SAVE 0x1E103
#define | HID_FILE_SAVE_AS 0x1E104
#define | HID_FILE_PAGE_SETUP 0x1E105
#define | HID_FILE_PRINT_SETUP 0x1E106
#define | HID_FILE_PRINT 0x1E107
#define | HID_FILE_PRINT_DIRECT 0x1E108
#define | HID_FILE_PRINT_PREVIEW 0x1E109
#define | HID_FILE_UPDATE 0x1E10A
#define | HID_FILE_SAVE_COPY_AS 0x1E10B
#define | HID_FILE_SEND_MAIL 0x1E10C
#define | HID_EDIT_CLEAR 0x1E120
#define | HID_EDIT_CLEAR_ALL 0x1E121
#define | HID_EDIT_COPY 0x1E122
#define | HID_EDIT_CUT 0x1E123
#define | HID_EDIT_FIND 0x1E124
#define | HID_EDIT_PASTE 0x1E125
#define | HID_EDIT_PASTE_LINK 0x1E126
#define | HID_EDIT_PASTE_SPECIAL 0x1E127
#define | HID_EDIT_REPEAT 0x1E128
#define | HID_EDIT_REPLACE 0x1E129
#define | HID_EDIT_SELECT_ALL 0x1E12A
#define | HID_EDIT_UNDO 0x1E12B
#define | HID_EDIT_REDO 0x1E12C
#define | HID_WINDOW_NEW 0x1E130
#define | HID_WINDOW_ARRANGE 0x1E131
#define | HID_WINDOW_CASCADE 0x1E132
#define | HID_WINDOW_TILE_HORZ 0x1E133
#define | HID_WINDOW_TILE_VERT 0x1E134
#define | HID_WINDOW_SPLIT 0x1E135
#define | HID_APP_ABOUT 0x1E140
#define | HID_APP_EXIT 0x1E141
#define | HID_HELP_INDEX 0x1E142
#define | HID_HELP_FINDER 0x1E143
#define | HID_HELP_USING 0x1E144
#define | HID_CONTEXT_HELP 0x1E145
#define | HID_NEXT_PANE 0x1E150
#define | HID_PREV_PANE 0x1E151
#define | HID_FORMAT_FONT 0x1E160
#define | HID_OLE_INSERT_NEW 0x1E200
#define | HID_OLE_EDIT_LINKS 0x1E201
#define | HID_OLE_EDIT_CONVERT 0x1E202
#define | HID_OLE_EDIT_CHANGE_ICON 0x1E203
#define | HID_OLE_EDIT_PROPERTIES 0x1E204
#define | HID_VIEW_TOOLBAR 0x1E800
#define | HID_VIEW_STATUS_BAR 0x1E801
#define | HID_RECORD_FIRST 0x1E900
#define | HID_RECORD_LAST 0x1E901
#define | HID_RECORD_NEXT 0x1E902
#define | HID_RECORD_PREV 0x1E903
#define | HID_WIZBACK 0x13023
#define | HID_WIZNEXT 0x13024
#define | HID_WIZFINISH 0x13025
#define | AFX_HIDD_FILEOPEN 0x27004
#define | AFX_HIDD_FILESAVE 0x27005
#define | AFX_HIDD_FONT 0x27006
#define | AFX_HIDD_COLOR 0x27007
#define | AFX_HIDD_PRINT 0x27008
#define | AFX_HIDD_PRINTSETUP 0x27009
#define | AFX_HIDD_FIND 0x2700A
#define | AFX_HIDD_REPLACE 0x2700B
#define | AFX_HIDD_NEWTYPEDLG 0x27801
#define | AFX_HIDD_PRINTDLG 0x27802
#define | AFX_HIDD_PREVIEW_TOOLBAR 0x27803
#define | AFX_HIDD_PREVIEW_SHORTTOOLBAR 0x2780B
#define | AFX_HIDD_INSERTOBJECT 0x27804
#define | AFX_HIDD_CHANGEICON 0x27805
#define | AFX_HIDD_CONVERT 0x27806
#define | AFX_HIDD_PASTESPECIAL 0x27807
#define | AFX_HIDD_EDITLINKS 0x27808
#define | AFX_HIDD_FILEBROWSE 0x27809
#define | AFX_HIDD_BUSY 0x2780A
#define | AFX_HIDD_OBJECTPROPERTIES 0x2780C
#define | AFX_HIDD_CHANGESOURCE 0x2780D
#define | AFX_HIDP_NO_ERROR_AVAILABLE 0x3F020
#define | AFX_HIDP_INVALID_FILENAME 0x3F100
#define | AFX_HIDP_FAILED_TO_OPEN_DOC 0x3F101
#define | AFX_HIDP_FAILED_TO_SAVE_DOC 0x3F102
#define | AFX_HIDP_ASK_TO_SAVE 0x3F103
#define | AFX_HIDP_FAILED_TO_CREATE_DOC 0x3F104
#define | AFX_HIDP_FILE_TOO_LARGE 0x3F105
#define | AFX_HIDP_FAILED_TO_START_PRINT 0x3F106
#define | AFX_HIDP_FAILED_TO_LAUNCH_HELP 0x3F107
#define | AFX_HIDP_INTERNAL_FAILURE 0x3F108
#define | AFX_HIDP_COMMAND_FAILURE 0x3F109
#define | AFX_HIDP_FAILED_MEMORY_ALLOC 0x3F10A
#define | AFX_HIDP_UNREG_DONE 0x3F10B
#define | AFX_HIDP_UNREG_FAILURE 0x3F10C
#define | AFX_HIDP_DLL_LOAD_FAILED 0x3F10D
#define | AFX_HIDP_DLL_BAD_VERSION 0x3F10E
#define | AFX_HIDP_PARSE_INT 0x3F110
#define | AFX_HIDP_PARSE_REAL 0x3F111
#define | AFX_HIDP_PARSE_INT_RANGE 0x3F112
#define | AFX_HIDP_PARSE_REAL_RANGE 0x3F113
#define | AFX_HIDP_PARSE_STRING_SIZE 0x3F114
#define | AFX_HIDP_PARSE_RADIO_BUTTON 0x3F115
#define | AFX_HIDP_PARSE_BYTE 0x3F116
#define | AFX_HIDP_PARSE_UINT 0x3F117
#define | AFX_HIDP_PARSE_DATETIME 0x3F118
#define | AFX_HIDP_PARSE_CURRENCY 0x3F119
#define | AFX_HIDP_FAILED_INVALID_FORMAT 0x3F120
#define | AFX_HIDP_FAILED_INVALID_PATH 0x3F121
#define | AFX_HIDP_FAILED_DISK_FULL 0x3F122
#define | AFX_HIDP_FAILED_ACCESS_READ 0x3F123
#define | AFX_HIDP_FAILED_ACCESS_WRITE 0x3F124
#define | AFX_HIDP_FAILED_IO_ERROR_READ 0x3F125
#define | AFX_HIDP_FAILED_IO_ERROR_WRITE 0x3F126
#define | AFX_HIDP_STATIC_OBJECT 0x3F180
#define | AFX_HIDP_FAILED_TO_CONNECT 0x3F181
#define | AFX_HIDP_SERVER_BUSY 0x3F182
#define | AFX_HIDP_BAD_VERB 0x3F183
#define | AFX_HIDP_FAILED_TO_NOTIFY 0x3F185
#define | AFX_HIDP_FAILED_TO_LAUNCH 0x3F186
#define | AFX_HIDP_ASK_TO_UPDATE 0x3F187
#define | AFX_HIDP_FAILED_TO_UPDATE 0x3F188
#define | AFX_HIDP_FAILED_TO_REGISTER 0x3F189
#define | AFX_HIDP_FAILED_TO_AUTO_REGISTER 0x3F18A
#define | AFX_HIDP_FAILED_TO_CONVERT 0x3F18B
#define | AFX_HIDP_GET_NOT_SUPPORTED 0x3F18C
#define | AFX_HIDP_SET_NOT_SUPPORTED 0x3F18D
#define | AFX_HIDP_ASK_TO_DISCARD 0x3F18E
#define | AFX_HIDP_FAILED_TO_CREATE 0x3F18F
#define | AFX_HIDP_FAILED_MAPI_LOAD 0x3F190
#define | AFX_HIDP_INVALID_MAPI_DLL 0x3F191
#define | AFX_HIDP_FAILED_MAPI_SEND 0x3F192
#define | AFX_HIDP_FILE_NONE 0x3F1A0
#define | AFX_HIDP_FILE_GENERIC 0x3F1A1
#define | AFX_HIDP_FILE_NOT_FOUND 0x3F1A2
#define | AFX_HIDP_FILE_BAD_PATH 0x3F1A3
#define | AFX_HIDP_FILE_TOO_MANY_OPEN 0x3F1A4
#define | AFX_HIDP_FILE_ACCESS_DENIED 0x3F1A5
#define | AFX_HIDP_FILE_INVALID_FILE 0x3F1A6
#define | AFX_HIDP_FILE_REMOVE_CURRENT 0x3F1A7
#define | AFX_HIDP_FILE_DIR_FULL 0x3F1A8
#define | AFX_HIDP_FILE_BAD_SEEK 0x3F1A9
#define | AFX_HIDP_FILE_HARD_IO 0x3F1AA
#define | AFX_HIDP_FILE_SHARING 0x3F1AB
#define | AFX_HIDP_FILE_LOCKING 0x3F1AC
#define | AFX_HIDP_FILE_DISKFULL 0x3F1AD
#define | AFX_HIDP_FILE_EOF 0x3F1AE
#define | AFX_HIDP_ARCH_NONE 0x3F1B0
#define | AFX_HIDP_ARCH_GENERIC 0x3F1B1
#define | AFX_HIDP_ARCH_READONLY 0x3F1B2
#define | AFX_HIDP_ARCH_ENDOFFILE 0x3F1B3
#define | AFX_HIDP_ARCH_WRITEONLY 0x3F1B4
#define | AFX_HIDP_ARCH_BADINDEX 0x3F1B5
#define | AFX_HIDP_ARCH_BADCLASS 0x3F1B6
#define | AFX_HIDP_ARCH_BADSCHEMA 0x3F1B7
#define | AFX_HIDP_SQL_CONNECT_FAIL 0x3F281
#define | AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY 0x3F282
#define | AFX_HIDP_SQL_EMPTY_COLUMN_LIST 0x3F283
#define | AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH 0x3F284
#define | AFX_HIDP_SQL_ILLEGAL_MODE 0x3F285
#define | AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED 0x3F286
#define | AFX_HIDP_SQL_NO_CURRENT_RECORD 0x3F287
#define | AFX_HIDP_SQL_NO_ROWS_AFFECTED 0x3F288
#define | AFX_HIDP_SQL_RECORDSET_READONLY 0x3F289
#define | AFX_HIDP_SQL_SQL_NO_TOTAL 0x3F28A
#define | AFX_HIDP_SQL_ODBC_LOAD_FAILED 0x3F28B
#define | AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED 0x3F28C
#define | AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED 0x3F28D
#define | AFX_HIDP_SQL_API_CONFORMANCE 0x3F28E
#define | AFX_HIDP_SQL_SQL_CONFORMANCE 0x3F28F
#define | AFX_HIDP_SQL_NO_DATA_FOUND 0x3F290
#define | AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED 0x3F291
#define | AFX_HIDP_SQL_ODBC_V2_REQUIRED 0x3F292
#define | AFX_HIDP_SQL_NO_POSITIONED_UPDATES 0x3F293
#define | AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED 0x3F294
#define | AFX_HIDP_SQL_DATA_TRUNCATED 0x3F295
#define | AFX_HIDP_SQL_ROW_FETCH 0x3F296
#define | AFX_HIDP_SQL_INCORRECT_ODBC 0x3F297
#define | AFX_HIDP_SQL_UPDATE_DELETE_FAILED 0x3F298
#define | AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED 0x3F299
#define | AFX_HIDP_SQL_FIELD_NOT_FOUND 0x3F29A
#define | AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED 0x3F29B
#define | AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED 0x3F29C
#define | AFX_HIDP_DAO_ENGINE_INITIALIZATION 0x3F2B0
#define | AFX_HIDP_DAO_DFX_BIND 0x3F2B1
#define | AFX_HIDP_DAO_OBJECT_NOT_OPEN 0x3F2B2
#define | AFX_HIDP_DAO_ROWTOOSHORT 0x3F2B3
#define | AFX_HIDP_DAO_BADBINDINFO 0x3F2B4
#define | AFX_HIDP_DAO_COLUMNUNAVAILABLE 0x3F2B5
#define | AFX_HIDW_TOOLBAR 0x5E800
#define | AFX_HIDW_STATUS_BAR 0x5E801
#define | AFX_HIDW_PREVIEW_BAR 0x5E802
#define | AFX_HIDW_RESIZE_BAR 0x5E803
#define | AFX_HIDW_DOCKBAR_TOP 0x5E81B
#define | AFX_HIDW_DOCKBAR_LEFT 0x5E81C
#define | AFX_HIDW_DOCKBAR_RIGHT 0x5E81D
#define | AFX_HIDW_DOCKBAR_BOTTOM 0x5E81E
#define | AFX_HIDW_DOCKBAR_FLOAT 0x5E81F

Define Documentation

#define AFX_HIDD_BUSY 0x2780A

Definition at line 185 of file HTMLDefines.h.

#define AFX_HIDD_CHANGEICON 0x27805

Definition at line 180 of file HTMLDefines.h.

#define AFX_HIDD_CHANGESOURCE 0x2780D

Definition at line 187 of file HTMLDefines.h.

#define AFX_HIDD_COLOR 0x27007

Definition at line 170 of file HTMLDefines.h.

#define AFX_HIDD_CONVERT 0x27806

Definition at line 181 of file HTMLDefines.h.

#define AFX_HIDD_EDITLINKS 0x27808

Definition at line 183 of file HTMLDefines.h.

#define AFX_HIDD_FILEBROWSE 0x27809

Definition at line 184 of file HTMLDefines.h.

#define AFX_HIDD_FILEOPEN 0x27004

Definition at line 167 of file HTMLDefines.h.

#define AFX_HIDD_FILESAVE 0x27005

Definition at line 168 of file HTMLDefines.h.

#define AFX_HIDD_FIND 0x2700A

Definition at line 173 of file HTMLDefines.h.

#define AFX_HIDD_FONT 0x27006

Definition at line 169 of file HTMLDefines.h.

#define AFX_HIDD_INSERTOBJECT 0x27804

Definition at line 179 of file HTMLDefines.h.

#define AFX_HIDD_NEWTYPEDLG 0x27801

Definition at line 175 of file HTMLDefines.h.

#define AFX_HIDD_OBJECTPROPERTIES 0x2780C

Definition at line 186 of file HTMLDefines.h.

#define AFX_HIDD_PASTESPECIAL 0x27807

Definition at line 182 of file HTMLDefines.h.

#define AFX_HIDD_PREVIEW_SHORTTOOLBAR 0x2780B

Definition at line 178 of file HTMLDefines.h.

#define AFX_HIDD_PREVIEW_TOOLBAR 0x27803

Definition at line 177 of file HTMLDefines.h.

#define AFX_HIDD_PRINT 0x27008

Definition at line 171 of file HTMLDefines.h.

#define AFX_HIDD_PRINTDLG 0x27802

Definition at line 176 of file HTMLDefines.h.

#define AFX_HIDD_PRINTSETUP 0x27009

Definition at line 172 of file HTMLDefines.h.

#define AFX_HIDD_REPLACE 0x2700B

Definition at line 174 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_BADCLASS 0x3F1B6

Definition at line 262 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_BADINDEX 0x3F1B5

Definition at line 261 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_BADSCHEMA 0x3F1B7

Definition at line 263 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_ENDOFFILE 0x3F1B3

Definition at line 259 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_GENERIC 0x3F1B1

Definition at line 257 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_NONE 0x3F1B0

Definition at line 256 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_READONLY 0x3F1B2

Definition at line 258 of file HTMLDefines.h.

#define AFX_HIDP_ARCH_WRITEONLY 0x3F1B4

Definition at line 260 of file HTMLDefines.h.

#define AFX_HIDP_ASK_TO_DISCARD 0x3F18E

Definition at line 236 of file HTMLDefines.h.

#define AFX_HIDP_ASK_TO_SAVE 0x3F103

Definition at line 194 of file HTMLDefines.h.

#define AFX_HIDP_ASK_TO_UPDATE 0x3F187

Definition at line 229 of file HTMLDefines.h.

#define AFX_HIDP_BAD_VERB 0x3F183

Definition at line 226 of file HTMLDefines.h.

#define AFX_HIDP_COMMAND_FAILURE 0x3F109

Definition at line 200 of file HTMLDefines.h.

#define AFX_HIDP_DAO_BADBINDINFO 0x3F2B4

Definition at line 296 of file HTMLDefines.h.

#define AFX_HIDP_DAO_COLUMNUNAVAILABLE 0x3F2B5

Definition at line 297 of file HTMLDefines.h.

#define AFX_HIDP_DAO_DFX_BIND 0x3F2B1

Definition at line 293 of file HTMLDefines.h.

#define AFX_HIDP_DAO_ENGINE_INITIALIZATION 0x3F2B0

Definition at line 292 of file HTMLDefines.h.

#define AFX_HIDP_DAO_OBJECT_NOT_OPEN 0x3F2B2

Definition at line 294 of file HTMLDefines.h.

#define AFX_HIDP_DAO_ROWTOOSHORT 0x3F2B3

Definition at line 295 of file HTMLDefines.h.

#define AFX_HIDP_DLL_BAD_VERSION 0x3F10E

Definition at line 205 of file HTMLDefines.h.

#define AFX_HIDP_DLL_LOAD_FAILED 0x3F10D

Definition at line 204 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_ACCESS_READ 0x3F123

Definition at line 219 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_ACCESS_WRITE 0x3F124

Definition at line 220 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_DISK_FULL 0x3F122

Definition at line 218 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_INVALID_FORMAT 0x3F120

Definition at line 216 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_INVALID_PATH 0x3F121

Definition at line 217 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_IO_ERROR_READ 0x3F125

Definition at line 221 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_IO_ERROR_WRITE 0x3F126

Definition at line 222 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_MAPI_LOAD 0x3F190

Definition at line 238 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_MAPI_SEND 0x3F192

Definition at line 240 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_MEMORY_ALLOC 0x3F10A

Definition at line 201 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_AUTO_REGISTER 0x3F18A

Definition at line 232 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CONNECT 0x3F181

Definition at line 224 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CONVERT 0x3F18B

Definition at line 233 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CREATE 0x3F18F

Definition at line 237 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_CREATE_DOC 0x3F104

Definition at line 195 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_LAUNCH 0x3F186

Definition at line 228 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_LAUNCH_HELP 0x3F107

Definition at line 198 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_NOTIFY 0x3F185

Definition at line 227 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_OPEN_DOC 0x3F101

Definition at line 192 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_REGISTER 0x3F189

Definition at line 231 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_SAVE_DOC 0x3F102

Definition at line 193 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_START_PRINT 0x3F106

Definition at line 197 of file HTMLDefines.h.

#define AFX_HIDP_FAILED_TO_UPDATE 0x3F188

Definition at line 230 of file HTMLDefines.h.

#define AFX_HIDP_FILE_ACCESS_DENIED 0x3F1A5

Definition at line 246 of file HTMLDefines.h.

#define AFX_HIDP_FILE_BAD_PATH 0x3F1A3

Definition at line 244 of file HTMLDefines.h.

#define AFX_HIDP_FILE_BAD_SEEK 0x3F1A9

Definition at line 250 of file HTMLDefines.h.

#define AFX_HIDP_FILE_DIR_FULL 0x3F1A8

Definition at line 249 of file HTMLDefines.h.

#define AFX_HIDP_FILE_DISKFULL 0x3F1AD

Definition at line 254 of file HTMLDefines.h.

#define AFX_HIDP_FILE_EOF 0x3F1AE

Definition at line 255 of file HTMLDefines.h.

#define AFX_HIDP_FILE_GENERIC 0x3F1A1

Definition at line 242 of file HTMLDefines.h.

#define AFX_HIDP_FILE_HARD_IO 0x3F1AA

Definition at line 251 of file HTMLDefines.h.

#define AFX_HIDP_FILE_INVALID_FILE 0x3F1A6

Definition at line 247 of file HTMLDefines.h.

#define AFX_HIDP_FILE_LOCKING 0x3F1AC

Definition at line 253 of file HTMLDefines.h.

#define AFX_HIDP_FILE_NONE 0x3F1A0

Definition at line 241 of file HTMLDefines.h.

#define AFX_HIDP_FILE_NOT_FOUND 0x3F1A2

Definition at line 243 of file HTMLDefines.h.

#define AFX_HIDP_FILE_REMOVE_CURRENT 0x3F1A7

Definition at line 248 of file HTMLDefines.h.

#define AFX_HIDP_FILE_SHARING 0x3F1AB

Definition at line 252 of file HTMLDefines.h.

#define AFX_HIDP_FILE_TOO_LARGE 0x3F105

Definition at line 196 of file HTMLDefines.h.

#define AFX_HIDP_FILE_TOO_MANY_OPEN 0x3F1A4

Definition at line 245 of file HTMLDefines.h.

#define AFX_HIDP_GET_NOT_SUPPORTED 0x3F18C

Definition at line 234 of file HTMLDefines.h.

#define AFX_HIDP_INTERNAL_FAILURE 0x3F108

Definition at line 199 of file HTMLDefines.h.

#define AFX_HIDP_INVALID_FILENAME 0x3F100

Definition at line 191 of file HTMLDefines.h.

#define AFX_HIDP_INVALID_MAPI_DLL 0x3F191

Definition at line 239 of file HTMLDefines.h.

#define AFX_HIDP_NO_ERROR_AVAILABLE 0x3F020

Definition at line 190 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_BYTE 0x3F116

Definition at line 212 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_CURRENCY 0x3F119

Definition at line 215 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_DATETIME 0x3F118

Definition at line 214 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_INT 0x3F110

Definition at line 206 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_INT_RANGE 0x3F112

Definition at line 208 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_RADIO_BUTTON 0x3F115

Definition at line 211 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_REAL 0x3F111

Definition at line 207 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_REAL_RANGE 0x3F113

Definition at line 209 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_STRING_SIZE 0x3F114

Definition at line 210 of file HTMLDefines.h.

#define AFX_HIDP_PARSE_UINT 0x3F117

Definition at line 213 of file HTMLDefines.h.

#define AFX_HIDP_SERVER_BUSY 0x3F182

Definition at line 225 of file HTMLDefines.h.

#define AFX_HIDP_SET_NOT_SUPPORTED 0x3F18D

Definition at line 235 of file HTMLDefines.h.

#define AFX_HIDP_SQL_API_CONFORMANCE 0x3F28E

Definition at line 277 of file HTMLDefines.h.

#define AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED 0x3F29C

Definition at line 291 of file HTMLDefines.h.

#define AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED 0x3F29B

Definition at line 290 of file HTMLDefines.h.

#define AFX_HIDP_SQL_CONNECT_FAIL 0x3F281

Definition at line 264 of file HTMLDefines.h.

#define AFX_HIDP_SQL_DATA_TRUNCATED 0x3F295

Definition at line 284 of file HTMLDefines.h.

#define AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED 0x3F299

Definition at line 288 of file HTMLDefines.h.

#define AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED 0x3F28C

Definition at line 275 of file HTMLDefines.h.

#define AFX_HIDP_SQL_EMPTY_COLUMN_LIST 0x3F283

Definition at line 266 of file HTMLDefines.h.

#define AFX_HIDP_SQL_FIELD_NOT_FOUND 0x3F29A

Definition at line 289 of file HTMLDefines.h.

#define AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH 0x3F284

Definition at line 267 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ILLEGAL_MODE 0x3F285

Definition at line 268 of file HTMLDefines.h.

#define AFX_HIDP_SQL_INCORRECT_ODBC 0x3F297

Definition at line 286 of file HTMLDefines.h.

#define AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED 0x3F294

Definition at line 283 of file HTMLDefines.h.

#define AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED 0x3F286

Definition at line 269 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_CURRENT_RECORD 0x3F287

Definition at line 270 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_DATA_FOUND 0x3F290

Definition at line 279 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_POSITIONED_UPDATES 0x3F293

Definition at line 282 of file HTMLDefines.h.

#define AFX_HIDP_SQL_NO_ROWS_AFFECTED 0x3F288

Definition at line 271 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ODBC_LOAD_FAILED 0x3F28B

Definition at line 274 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ODBC_V2_REQUIRED 0x3F292

Definition at line 281 of file HTMLDefines.h.

#define AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY 0x3F282

Definition at line 265 of file HTMLDefines.h.

#define AFX_HIDP_SQL_RECORDSET_READONLY 0x3F289

Definition at line 272 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ROW_FETCH 0x3F296

Definition at line 285 of file HTMLDefines.h.

#define AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED 0x3F291

Definition at line 280 of file HTMLDefines.h.

#define AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED 0x3F28D

Definition at line 276 of file HTMLDefines.h.

#define AFX_HIDP_SQL_SQL_CONFORMANCE 0x3F28F

Definition at line 278 of file HTMLDefines.h.

#define AFX_HIDP_SQL_SQL_NO_TOTAL 0x3F28A

Definition at line 273 of file HTMLDefines.h.

#define AFX_HIDP_SQL_UPDATE_DELETE_FAILED 0x3F298

Definition at line 287 of file HTMLDefines.h.

#define AFX_HIDP_STATIC_OBJECT 0x3F180

Definition at line 223 of file HTMLDefines.h.

#define AFX_HIDP_UNREG_DONE 0x3F10B

Definition at line 202 of file HTMLDefines.h.

#define AFX_HIDP_UNREG_FAILURE 0x3F10C

Definition at line 203 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_BOTTOM 0x5E81E

Definition at line 307 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_FLOAT 0x5E81F

Definition at line 308 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_LEFT 0x5E81C

Definition at line 305 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_RIGHT 0x5E81D

Definition at line 306 of file HTMLDefines.h.

#define AFX_HIDW_DOCKBAR_TOP 0x5E81B

Definition at line 304 of file HTMLDefines.h.

#define AFX_HIDW_PREVIEW_BAR 0x5E802

Definition at line 302 of file HTMLDefines.h.

#define AFX_HIDW_RESIZE_BAR 0x5E803

Definition at line 303 of file HTMLDefines.h.

#define AFX_HIDW_STATUS_BAR 0x5E801

Definition at line 301 of file HTMLDefines.h.

#define AFX_HIDW_TOOLBAR 0x5E800

Definition at line 300 of file HTMLDefines.h.

#define HID_APP_ABOUT 0x1E140

Definition at line 142 of file HTMLDefines.h.

#define HID_APP_EXIT 0x1E141

Definition at line 143 of file HTMLDefines.h.

#define HID_CONTEXT_HELP 0x1E145

Definition at line 147 of file HTMLDefines.h.

#define HID_EDIT_CLEAR 0x1E120

Definition at line 123 of file HTMLDefines.h.

#define HID_EDIT_CLEAR_ALL 0x1E121

Definition at line 124 of file HTMLDefines.h.

#define HID_EDIT_COPY 0x1E122

Definition at line 125 of file HTMLDefines.h.

#define HID_EDIT_CUT 0x1E123

Definition at line 126 of file HTMLDefines.h.

#define HID_EDIT_FIND 0x1E124

Definition at line 127 of file HTMLDefines.h.

#define HID_EDIT_PASTE 0x1E125

Definition at line 128 of file HTMLDefines.h.

#define HID_EDIT_PASTE_LINK 0x1E126

Definition at line 129 of file HTMLDefines.h.

#define HID_EDIT_PASTE_SPECIAL 0x1E127

Definition at line 130 of file HTMLDefines.h.

#define HID_EDIT_REDO 0x1E12C

Definition at line 135 of file HTMLDefines.h.

#define HID_EDIT_REPEAT 0x1E128

Definition at line 131 of file HTMLDefines.h.

#define HID_EDIT_REPLACE 0x1E129

Definition at line 132 of file HTMLDefines.h.

#define HID_EDIT_SELECT_ALL 0x1E12A

Definition at line 133 of file HTMLDefines.h.

#define HID_EDIT_UNDO 0x1E12B

Definition at line 134 of file HTMLDefines.h.

#define HID_FILE_CLOSE 0x1E102

Definition at line 112 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E110

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E111

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E112

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E113

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E114

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E115

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E116

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E117

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E118

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E119

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11A

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11B

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11C

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11D

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11E

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_MRU_FILE1 0x1E11F

Definition at line 86 of file HTMLDefines.h.

#define HID_FILE_NEW 0x1E100

Definition at line 110 of file HTMLDefines.h.

#define HID_FILE_OPEN 0x1E101

Definition at line 111 of file HTMLDefines.h.

#define HID_FILE_PAGE_SETUP 0x1E105

Definition at line 115 of file HTMLDefines.h.

#define HID_FILE_PRINT 0x1E107

Definition at line 117 of file HTMLDefines.h.

#define HID_FILE_PRINT_DIRECT 0x1E108

Definition at line 118 of file HTMLDefines.h.

#define HID_FILE_PRINT_PREVIEW 0x1E109

Definition at line 119 of file HTMLDefines.h.

#define HID_FILE_PRINT_SETUP 0x1E106

Definition at line 116 of file HTMLDefines.h.

#define HID_FILE_SAVE 0x1E103

Definition at line 113 of file HTMLDefines.h.

#define HID_FILE_SAVE_AS 0x1E104

Definition at line 114 of file HTMLDefines.h.

#define HID_FILE_SAVE_COPY_AS 0x1E10B

Definition at line 121 of file HTMLDefines.h.

#define HID_FILE_SEND_MAIL 0x1E10C

Definition at line 122 of file HTMLDefines.h.

#define HID_FILE_TAB 0x18128

Definition at line 4 of file HTMLDefines.h.

#define HID_FILE_UPDATE 0x1E10A

Definition at line 120 of file HTMLDefines.h.

#define HID_FORMAT_FONT 0x1E160

Definition at line 150 of file HTMLDefines.h.

#define HID_GAINPZ_TAB 0x18131

Definition at line 5 of file HTMLDefines.h.

#define HID_HELP_ABOUT 0x19C43

Definition at line 10 of file HTMLDefines.h.

#define HID_HELP_FINDER 0x1E143

Definition at line 145 of file HTMLDefines.h.

#define HID_HELP_INDEX 0x1E142

Definition at line 144 of file HTMLDefines.h.

#define HID_HELP_USING 0x1E144

Definition at line 146 of file HTMLDefines.h.

#define HID_HT_CAPTION 0x40002

Definition at line 40 of file HTMLDefines.h.

#define HID_HT_CLOSE 0x40014

Definition at line 56 of file HTMLDefines.h.

#define HID_HT_HELP 0x40015

Definition at line 57 of file HTMLDefines.h.

#define HID_HT_HSCROLL 0x40006

Definition at line 42 of file HTMLDefines.h.

#define HID_HT_MAXBUTTON 0x40009

Definition at line 45 of file HTMLDefines.h.

#define HID_HT_MINBUTTON 0x40008

Definition at line 44 of file HTMLDefines.h.

#define HID_HT_NOWHERE 0x40000

Definition at line 39 of file HTMLDefines.h.

#define HID_HT_OBJECT 0x40013

Definition at line 55 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40004

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000A

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000B

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000C

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000D

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000E

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x4000F

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40010

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40011

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_SIZE 0x40012

Definition at line 54 of file HTMLDefines.h.

#define HID_HT_VSCROLL 0x40007

Definition at line 43 of file HTMLDefines.h.

#define HID_MCA_TAB 0x18144

Definition at line 6 of file HTMLDefines.h.

#define HID_MISC_TAB 0x18147

Definition at line 7 of file HTMLDefines.h.

#define HID_NEXT_PANE 0x1E150

Definition at line 148 of file HTMLDefines.h.

#define HID_OLE_EDIT_CHANGE_ICON 0x1E203

Definition at line 154 of file HTMLDefines.h.

#define HID_OLE_EDIT_CONVERT 0x1E202

Definition at line 153 of file HTMLDefines.h.

#define HID_OLE_EDIT_LINKS 0x1E201

Definition at line 152 of file HTMLDefines.h.

#define HID_OLE_EDIT_PROPERTIES 0x1E204

Definition at line 155 of file HTMLDefines.h.

#define HID_OLE_INSERT_NEW 0x1E200

Definition at line 151 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E210

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E211

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E212

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E213

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E214

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E215

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E216

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E217

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E218

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E219

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21A

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21B

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21C

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21D

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21E

Definition at line 107 of file HTMLDefines.h.

#define HID_OLE_VERB_1 0x1E21F

Definition at line 107 of file HTMLDefines.h.

#define HID_POWER_TAB 0x1814E

Definition at line 8 of file HTMLDefines.h.

#define HID_PREV_PANE 0x1E151

Definition at line 149 of file HTMLDefines.h.

#define HID_RECORD_FIRST 0x1E900

Definition at line 158 of file HTMLDefines.h.

#define HID_RECORD_LAST 0x1E901

Definition at line 159 of file HTMLDefines.h.

#define HID_RECORD_NEXT 0x1E902

Definition at line 160 of file HTMLDefines.h.

#define HID_RECORD_PREV 0x1E903

Definition at line 161 of file HTMLDefines.h.

#define HID_SC_CLOSE 0x1EF06

Definition at line 66 of file HTMLDefines.h.

#define HID_SC_MAXIMIZE 0x1EF03

Definition at line 63 of file HTMLDefines.h.

#define HID_SC_MINIMIZE 0x1EF02

Definition at line 62 of file HTMLDefines.h.

#define HID_SC_MOVE 0x1EF01

Definition at line 61 of file HTMLDefines.h.

#define HID_SC_NEXTWINDOW 0x1EF04

Definition at line 64 of file HTMLDefines.h.

#define HID_SC_PREVWINDOW 0x1EF05

Definition at line 65 of file HTMLDefines.h.

#define HID_SC_RESTORE 0x1EF12

Definition at line 67 of file HTMLDefines.h.

#define HID_SC_SIZE 0x1EF00

Definition at line 60 of file HTMLDefines.h.

#define HID_SC_TASKLIST 0x1EF13

Definition at line 68 of file HTMLDefines.h.

#define HID_SHAPING_TAB 0x18160

Definition at line 9 of file HTMLDefines.h.

#define HID_VIEW_STATUS_BAR 0x1E801

Definition at line 157 of file HTMLDefines.h.

#define HID_VIEW_TOOLBAR 0x1E800

Definition at line 156 of file HTMLDefines.h.

#define HID_WINDOW_ALL 0x1EF1F

Definition at line 89 of file HTMLDefines.h.

#define HID_WINDOW_ARRANGE 0x1E131

Definition at line 137 of file HTMLDefines.h.

#define HID_WINDOW_CASCADE 0x1E132

Definition at line 138 of file HTMLDefines.h.

#define HID_WINDOW_NEW 0x1E130

Definition at line 136 of file HTMLDefines.h.

#define HID_WINDOW_SPLIT 0x1E135

Definition at line 141 of file HTMLDefines.h.

#define HID_WINDOW_TILE_HORZ 0x1E133

Definition at line 139 of file HTMLDefines.h.

#define HID_WINDOW_TILE_VERT 0x1E134

Definition at line 140 of file HTMLDefines.h.

#define HID_WIZBACK 0x13023

Definition at line 162 of file HTMLDefines.h.

#define HID_WIZFINISH 0x13025

Definition at line 164 of file HTMLDefines.h.

#define HID_WIZNEXT 0x13024

Definition at line 163 of file HTMLDefines.h.

#define HIDD_ABOUTBOX 0x20064

Definition at line 22 of file HTMLDefines.h.

#define HIDD_BUSY_DLG 0x21036

Definition at line 23 of file HTMLDefines.h.

#define HIDD_MESSAGE_BOX 0x2103F

Definition at line 24 of file HTMLDefines.h.

#define HIDD_vcDP5_DIALOG 0x21C00

Definition at line 25 of file HTMLDefines.h.

#define HIDM_ABOUTBOX 0x10010

Definition at line 3 of file HTMLDefines.h.

#define HIDP_SOCKETS_INIT_FAILED 0x3105A

Definition at line 13 of file HTMLDefines.h.

#define HIDR_MAINFRAME 0x2105C

Definition at line 16 of file HTMLDefines.h.

#define HIDR_MENU 0x2105D

Definition at line 17 of file HTMLDefines.h.

#define HIDR_TOOLBAR 0x21064

Definition at line 18 of file HTMLDefines.h.

#define HIDR_TOOLBAR_DP5_DLG 0x21065

Definition at line 19 of file HTMLDefines.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/AnimWnd.cpp File Reference

waitdlg/AnimWnd.cpp File Reference
#include "stdafx.h"
#include "AnimWnd.h"
Include dependency graph for AnimWnd.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/AnimWnd.h File Reference

Classes | Defines
waitdlg/AnimWnd.h File Reference
#include "memdc.h"
Include dependency graph for AnimWnd.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class | cAnimWnd

Defines

#define | TIMER_ID 13

Define Documentation

#define TIMER_ID 13

Definition at line 25 of file AnimWnd.h.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/CmdWaitDlg.cpp File Reference

waitdlg/CmdWaitDlg.cpp File Reference
#include "stdafx.h"
#include "CmdWaitDlg.h"
Include dependency graph for CmdWaitDlg.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/CmdWaitDlg.h File Reference

Classes
waitdlg/CmdWaitDlg.h File Reference
#include "WaitDlgThread.h"
Include dependency graph for CmdWaitDlg.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cWaitDialog
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/memdc.h File Reference

Classes
waitdlg/memdc.h File Reference
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cMemDC
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlg.cpp File Reference

waitdlg/WaitDlg.cpp File Reference
#include "stdafx.h"
#include "WaitDlg.h"
#include "resource.h"
Include dependency graph for WaitDlg.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlg.h File Reference

Classes
waitdlg/WaitDlg.h File Reference
#include <afxmt.h>
#include "WaitDlgThread.h"
#include "AnimWnd.h"
#include "resource.h"
Include dependency graph for WaitDlg.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cWaitDlg
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlgThread.cpp File Reference

waitdlg/WaitDlgThread.cpp File Reference
#include "stdafx.h"
#include "WaitDlgThread.h"
#include "WaitDlg.h"
Include dependency graph for WaitDlgThread.cpp:

Go to the source code of this file.

Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlgThread.h File Reference

Classes
waitdlg/WaitDlgThread.h File Reference
#include <afxmt.h>
Include dependency graph for WaitDlgThread.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Classes

class cWaitDlgThread
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- _ -

  • _CommType : ParsePacket.h
  • _CRT_SECURE_NO_DEPRECATE : StdAfx.h
  • _DP5_CMD_INDEX : DP5ControlUtil.h
  • _DP5_CTRL_GROUP : DP5ControlUtil.h
  • _DP5_CTRL_TYPE : DP5ControlUtil.h
  • _DP5_DATA_ID : DP5ControlUtil.h
  • _DPP_USB_STATUS : DppWinUSB.h
  • _DppAGainTable : DppGain.h
  • _PX5_OPTIONS : DP5Status.h
  • _SETUPAPI_VER : StdAfx.h
  • _SocketOwnerType : DppSocket.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- a -

  • ACK : DP5Protocol.h
  • AFX_HIDD_BUSY : HTMLDefines.h
  • AFX_HIDD_CHANGEICON : HTMLDefines.h
  • AFX_HIDD_CHANGESOURCE : HTMLDefines.h
  • AFX_HIDD_COLOR : HTMLDefines.h
  • AFX_HIDD_CONVERT : HTMLDefines.h
  • AFX_HIDD_EDITLINKS : HTMLDefines.h
  • AFX_HIDD_FILEBROWSE : HTMLDefines.h
  • AFX_HIDD_FILEOPEN : HTMLDefines.h
  • AFX_HIDD_FILESAVE : HTMLDefines.h
  • AFX_HIDD_FIND : HTMLDefines.h
  • AFX_HIDD_FONT : HTMLDefines.h
  • AFX_HIDD_INSERTOBJECT : HTMLDefines.h
  • AFX_HIDD_NEWTYPEDLG : HTMLDefines.h
  • AFX_HIDD_OBJECTPROPERTIES : HTMLDefines.h
  • AFX_HIDD_PASTESPECIAL : HTMLDefines.h
  • AFX_HIDD_PREVIEW_SHORTTOOLBAR : HTMLDefines.h
  • AFX_HIDD_PREVIEW_TOOLBAR : HTMLDefines.h
  • AFX_HIDD_PRINT : HTMLDefines.h
  • AFX_HIDD_PRINTDLG : HTMLDefines.h
  • AFX_HIDD_PRINTSETUP : HTMLDefines.h
  • AFX_HIDD_REPLACE : HTMLDefines.h
  • AFX_HIDP_ARCH_BADCLASS : HTMLDefines.h
  • AFX_HIDP_ARCH_BADINDEX : HTMLDefines.h
  • AFX_HIDP_ARCH_BADSCHEMA : HTMLDefines.h
  • AFX_HIDP_ARCH_ENDOFFILE : HTMLDefines.h
  • AFX_HIDP_ARCH_GENERIC : HTMLDefines.h
  • AFX_HIDP_ARCH_NONE : HTMLDefines.h
  • AFX_HIDP_ARCH_READONLY : HTMLDefines.h
  • AFX_HIDP_ARCH_WRITEONLY : HTMLDefines.h
  • AFX_HIDP_ASK_TO_DISCARD : HTMLDefines.h
  • AFX_HIDP_ASK_TO_SAVE : HTMLDefines.h
  • AFX_HIDP_ASK_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_BAD_VERB : HTMLDefines.h
  • AFX_HIDP_COMMAND_FAILURE : HTMLDefines.h
  • AFX_HIDP_DAO_BADBINDINFO : HTMLDefines.h
  • AFX_HIDP_DAO_COLUMNUNAVAILABLE : HTMLDefines.h
  • AFX_HIDP_DAO_DFX_BIND : HTMLDefines.h
  • AFX_HIDP_DAO_ENGINE_INITIALIZATION : HTMLDefines.h
  • AFX_HIDP_DAO_OBJECT_NOT_OPEN : HTMLDefines.h
  • AFX_HIDP_DAO_ROWTOOSHORT : HTMLDefines.h
  • AFX_HIDP_DLL_BAD_VERSION : HTMLDefines.h
  • AFX_HIDP_DLL_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_DISK_FULL : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_FORMAT : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_PATH : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_LOAD : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_SEND : HTMLDefines.h
  • AFX_HIDP_FAILED_MEMORY_ALLOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_AUTO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONNECT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONVERT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH_HELP : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_NOTIFY : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_OPEN_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_SAVE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_START_PRINT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_FILE_ACCESS_DENIED : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_PATH : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_SEEK : HTMLDefines.h
  • AFX_HIDP_FILE_DIR_FULL : HTMLDefines.h
  • AFX_HIDP_FILE_DISKFULL : HTMLDefines.h
  • AFX_HIDP_FILE_EOF : HTMLDefines.h
  • AFX_HIDP_FILE_GENERIC : HTMLDefines.h
  • AFX_HIDP_FILE_HARD_IO : HTMLDefines.h
  • AFX_HIDP_FILE_INVALID_FILE : HTMLDefines.h
  • AFX_HIDP_FILE_LOCKING : HTMLDefines.h
  • AFX_HIDP_FILE_NONE : HTMLDefines.h
  • AFX_HIDP_FILE_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_FILE_REMOVE_CURRENT : HTMLDefines.h
  • AFX_HIDP_FILE_SHARING : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_LARGE : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_MANY_OPEN : HTMLDefines.h
  • AFX_HIDP_GET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_INTERNAL_FAILURE : HTMLDefines.h
  • AFX_HIDP_INVALID_FILENAME : HTMLDefines.h
  • AFX_HIDP_INVALID_MAPI_DLL : HTMLDefines.h
  • AFX_HIDP_NO_ERROR_AVAILABLE : HTMLDefines.h
  • AFX_HIDP_PARSE_BYTE : HTMLDefines.h
  • AFX_HIDP_PARSE_CURRENCY : HTMLDefines.h
  • AFX_HIDP_PARSE_DATETIME : HTMLDefines.h
  • AFX_HIDP_PARSE_INT : HTMLDefines.h
  • AFX_HIDP_PARSE_INT_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_RADIO_BUTTON : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_STRING_SIZE : HTMLDefines.h
  • AFX_HIDP_PARSE_UINT : HTMLDefines.h
  • AFX_HIDP_SERVER_BUSY : HTMLDefines.h
  • AFX_HIDP_SET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_API_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_CONNECT_FAIL : HTMLDefines.h
  • AFX_HIDP_SQL_DATA_TRUNCATED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_EMPTY_COLUMN_LIST : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH : HTMLDefines.h
  • AFX_HIDP_SQL_ILLEGAL_MODE : HTMLDefines.h
  • AFX_HIDP_SQL_INCORRECT_ODBC : HTMLDefines.h
  • AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_NO_CURRENT_RECORD : HTMLDefines.h
  • AFX_HIDP_SQL_NO_DATA_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_NO_POSITIONED_UPDATES : HTMLDefines.h
  • AFX_HIDP_SQL_NO_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_V2_REQUIRED : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_READONLY : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_FETCH : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_NO_TOTAL : HTMLDefines.h
  • AFX_HIDP_SQL_UPDATE_DELETE_FAILED : HTMLDefines.h
  • AFX_HIDP_STATIC_OBJECT : HTMLDefines.h
  • AFX_HIDP_UNREG_DONE : HTMLDefines.h
  • AFX_HIDP_UNREG_FAILURE : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_BOTTOM : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_FLOAT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_LEFT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_RIGHT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_TOP : HTMLDefines.h
  • AFX_HIDW_PREVIEW_BAR : HTMLDefines.h
  • AFX_HIDW_RESIZE_BAR : HTMLDefines.h
  • AFX_HIDW_STATUS_BAR : HTMLDefines.h
  • AFX_HIDW_TOOLBAR : HTMLDefines.h
  • ALL_VIS : DP5ControlUtil.h
  • ALLOW_PARTIAL_READS : WINUSBIO.H
  • AMPTEK_DP5_PRODUCT_ID : DppLibUsb.h
  • AMPTEK_DP5_VENDOR_ID : DppLibUsb.h
  • AUTO_CLEAR_STALL : WINUSBIO.H
  • AUTO_FLUSH : WINUSBIO.H
  • AUTO_SUSPEND : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- b -

  • Background : Label.h
  • BULK_IN_ENDPOINT : DppLibUsb.h
  • BULK_OUT_ENDPOINT : DppLibUsb.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- c -

  • CBO_TEXT_VIS : DP5ControlUtil.h
  • CC_SYSCOLOR : PlotCanvas.h
  • colorAliceBlue : X11Color.h
  • colorAmptekBlue : X11Color.h
  • colorAntiqueWhite : X11Color.h
  • colorAqua : X11Color.h
  • colorAquamarine : X11Color.h
  • colorAzure : X11Color.h
  • colorBeige : X11Color.h
  • colorBisque : X11Color.h
  • colorBlack : X11Color.h
  • colorBlanchedAlmond : X11Color.h
  • colorBlue : X11Color.h
  • colorBlueViolet : X11Color.h
  • colorBrown : X11Color.h
  • colorBurlyWood : X11Color.h
  • colorCadetBlue : X11Color.h
  • colorChartreuse : X11Color.h
  • colorChocolate : X11Color.h
  • colorCoral : X11Color.h
  • colorCornflowerBlue : X11Color.h
  • colorCornsilk : X11Color.h
  • colorCrimson : X11Color.h
  • colorCyan : X11Color.h
  • colorDarkBlue : X11Color.h
  • colorDarkCyan : X11Color.h
  • colorDarkGoldenrod : X11Color.h
  • colorDarkGray : X11Color.h
  • colorDarkGreen : X11Color.h
  • colorDarkKhaki : X11Color.h
  • colorDarkMagenta : X11Color.h
  • colorDarkOliveGreen : X11Color.h
  • colorDarkOrange : X11Color.h
  • colorDarkOrchid : X11Color.h
  • colorDarkRed : X11Color.h
  • colorDarkSalmon : X11Color.h
  • colorDarkSeaGreen : X11Color.h
  • colorDarkSlateBlue : X11Color.h
  • colorDarkSlateGray : X11Color.h
  • colorDarkTurquoise : X11Color.h
  • colorDarkViolet : X11Color.h
  • colorDeepPink : X11Color.h
  • colorDeepSkyBlue : X11Color.h
  • colorDimGray : X11Color.h
  • colorDodgerBlue : X11Color.h
  • colorFireBrick : X11Color.h
  • colorFloralWhite : X11Color.h
  • colorForestGreen : X11Color.h
  • colorFuchsia : X11Color.h
  • colorGainsboro : X11Color.h
  • colorGhostWhite : X11Color.h
  • colorGold : X11Color.h
  • colorGoldenrod : X11Color.h
  • colorGray : X11Color.h
  • colorGreen : X11Color.h
  • colorGreenYellow : X11Color.h
  • colorHoneydew : X11Color.h
  • colorHotPink : X11Color.h
  • colorIndianRed : X11Color.h
  • colorIndigo : X11Color.h
  • colorIvory : X11Color.h
  • colorKhaki : X11Color.h
  • colorLavender : X11Color.h
  • colorLavenderBlush : X11Color.h
  • colorLawnGreen : X11Color.h
  • colorLemonChiffon : X11Color.h
  • colorLightBlue : X11Color.h
  • colorLightCoral : X11Color.h
  • colorLightCyan : X11Color.h
  • colorLightGoldenrodYellow : X11Color.h
  • colorLightGray : X11Color.h
  • colorLightGreen : X11Color.h
  • colorLightGrey : X11Color.h
  • colorLightPink : X11Color.h
  • colorLightSalmon : X11Color.h
  • colorLightSeaGreen : X11Color.h
  • colorLightSkyBlue : X11Color.h
  • colorLightSlateGray : X11Color.h
  • colorLightSteelBlue : X11Color.h
  • colorLightYellow : X11Color.h
  • colorLime : X11Color.h
  • colorLimeGreen : X11Color.h
  • colorLinen : X11Color.h
  • colorMagenta : X11Color.h
  • colorMaroon : X11Color.h
  • colorMediumAquamarine : X11Color.h
  • colorMediumBlue : X11Color.h
  • colorMediumOrchid : X11Color.h
  • colorMediumPurple : X11Color.h
  • colorMediumSeaGreen : X11Color.h
  • colorMediumSlateBlue : X11Color.h
  • colorMediumSpringGreen : X11Color.h
  • colorMediumTurquoise : X11Color.h
  • colorMediumVioletRed : X11Color.h
  • colorMidnightBlue : X11Color.h
  • colorMintCream : X11Color.h
  • colorMistyRose : X11Color.h
  • colorMoccasin : X11Color.h
  • colorNavajoWhite : X11Color.h
  • colorNavy : X11Color.h
  • colorOldLace : X11Color.h
  • colorOlive : X11Color.h
  • colorOliveDrab : X11Color.h
  • colorOrange : X11Color.h
  • colorOrangeRed : X11Color.h
  • colorOrchid : X11Color.h
  • colorPaleGoldenrod : X11Color.h
  • colorPaleGreen : X11Color.h
  • colorPaleTurquoise : X11Color.h
  • colorPaleVioletRed : X11Color.h
  • colorPapayaWhip : X11Color.h
  • colorPeachPuff : X11Color.h
  • colorPeru : X11Color.h
  • colorPink : X11Color.h
  • colorPlum : X11Color.h
  • colorPowderBlue : X11Color.h
  • colorPurple : X11Color.h
  • colorRed : X11Color.h
  • colorRosyBrown : X11Color.h
  • colorRoyalBlue : X11Color.h
  • colorSaddleBrown : X11Color.h
  • colorSalmon : X11Color.h
  • colorSandyBrown : X11Color.h
  • colorSeaGreen : X11Color.h
  • colorSeaShell : X11Color.h
  • colorSienna : X11Color.h
  • colorSilver : X11Color.h
  • colorSkyBlue : X11Color.h
  • colorSlateBlue : X11Color.h
  • colorSlateGray : X11Color.h
  • colorSnow : X11Color.h
  • colorSpringGreen : X11Color.h
  • colorSteelBlue : X11Color.h
  • colorTan : X11Color.h
  • colorTeal : X11Color.h
  • colorThistle : X11Color.h
  • colorTomato : X11Color.h
  • colorTurquoise : X11Color.h
  • colorViolet : X11Color.h
  • colorWheat : X11Color.h
  • colorWhite : X11Color.h
  • colorWhiteSmoke : X11Color.h
  • colorYellow : X11Color.h
  • colorYellowGreen : X11Color.h
  • commNone : ParsePacket.h
  • commRS232 : ParsePacket.h
  • commSockets : ParsePacket.h
  • CommType : ParsePacket.h
  • commUSB : ParsePacket.h
  • CONFIG_OPTIONS : SendCommand.h
  • COORD_LONG : PlotCanvas.h
  • COUNT_OFFSET : DppConfig.h
  • ctrlColBlack : PlotCanvas.h
  • ctrlColBlue : PlotCanvas.h
  • ctrlColBtnFace : PlotCanvas.h
  • ctrlColDefault : PlotCanvas.h
  • ctrlColGray : PlotCanvas.h
  • ctrlColGreen : PlotCanvas.h
  • ctrlColInfoBk : PlotCanvas.h
  • ctrlColInfoText : PlotCanvas.h
  • ctrlColJavaGray : PlotCanvas.h
  • ctrlColLightBlue : PlotCanvas.h
  • ctrlColLightCyan : PlotCanvas.h
  • ctrlColLightGray : PlotCanvas.h
  • ctrlColRed : PlotCanvas.h
  • ctrlColSkyBlue : PlotCanvas.h
  • ctrlColWhite : PlotCanvas.h
  • ctrlColWinBk : PlotCanvas.h
  • ctrlColWinText : PlotCanvas.h
  • ctrlColYellow : PlotCanvas.h
  • ctrlDarkGreen : PlotCanvas.h
  • ctrlDarkGreenCopper : PlotCanvas.h
  • ctrlDarkOliveGreen : PlotCanvas.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- d -

  • dagtDP5 : DppGain.h
  • dagtDP5Dx : DppGain.h
  • dagtDP5G : DppGain.h
  • dagtDP5X : DppGain.h
  • dagtMCA8000D : DppGain.h
  • dagtPX5 : DppGain.h
  • dagtTB5 : DppGain.h
  • dcgBootOpt : DP5ControlUtil.h
  • dcgFile : DP5ControlUtil.h
  • dcgGainPZ : DP5ControlUtil.h
  • dcgMCA : DP5ControlUtil.h
  • dcgMisc : DP5ControlUtil.h
  • dcgPower : DP5ControlUtil.h
  • dcgShaping : DP5ControlUtil.h
  • dciAINP : DP5ControlUtil.h
  • dciAUO1 : DP5ControlUtil.h
  • dciAUO2 : DP5ControlUtil.h
  • dciBLRD : DP5ControlUtil.h
  • dciBLRM : DP5ControlUtil.h
  • dciBLRU : DP5ControlUtil.h
  • dciBOOT : DP5ControlUtil.h
  • dciCLCK : DP5ControlUtil.h
  • dciCON1 : DP5ControlUtil.h
  • dciCON2 : DP5ControlUtil.h
  • dciCUSP : DP5ControlUtil.h
  • dciDACF : DP5ControlUtil.h
  • dciDACO : DP5ControlUtil.h
  • dciGAIA : DP5ControlUtil.h
  • dciGAIF : DP5ControlUtil.h
  • dciGAIN : DP5ControlUtil.h
  • dciGATE : DP5ControlUtil.h
  • dciGPED : DP5ControlUtil.h
  • dciGPGA : DP5ControlUtil.h
  • dciGPIN : DP5ControlUtil.h
  • dciGPMC : DP5ControlUtil.h
  • dciGPME : DP5ControlUtil.h
  • dciHVSE : DP5ControlUtil.h
  • dciINOF : DP5ControlUtil.h
  • dciMCAC : DP5ControlUtil.h
  • dciMCAE : DP5ControlUtil.h
  • dciMCAS : DP5ControlUtil.h
  • dciMCSH : DP5ControlUtil.h
  • dciMCSL : DP5ControlUtil.h
  • dciMCST : DP5ControlUtil.h
  • dciPAPS : DP5ControlUtil.h
  • dciPAPZ : DP5ControlUtil.h
  • dciPDMD : DP5ControlUtil.h
  • dciPRCH : DP5ControlUtil.h
  • dciPRCL : DP5ControlUtil.h
  • dciPREC : DP5ControlUtil.h
  • dciPREL : DP5ControlUtil.h
  • dciPRER : DP5ControlUtil.h
  • dciPRET : DP5ControlUtil.h
  • dciPURE : DP5ControlUtil.h
  • dciRESC : DP5ControlUtil.h
  • dciRESL : DP5ControlUtil.h
  • dciRTDE : DP5ControlUtil.h
  • dciRTDS : DP5ControlUtil.h
  • dciRTDT : DP5ControlUtil.h
  • dciSCOE : DP5ControlUtil.h
  • dciSCOG : DP5ControlUtil.h
  • dciSCOT : DP5ControlUtil.h
  • dciSCTC : DP5ControlUtil.h
  • dciSOFF : DP5ControlUtil.h
  • dciTECS : DP5ControlUtil.h
  • dciTFLA : DP5ControlUtil.h
  • dciTHFA : DP5ControlUtil.h
  • dciTHSL : DP5ControlUtil.h
  • dciTLLD : DP5ControlUtil.h
  • dciTPEA : DP5ControlUtil.h
  • dciTPFA : DP5ControlUtil.h
  • dciTPMO : DP5ControlUtil.h
  • dciVOLU : DP5ControlUtil.h
  • dctCbo : DP5ControlUtil.h
  • dctCboTxt : DP5ControlUtil.h
  • dctNone : DP5ControlUtil.h
  • dctTxt : DP5ControlUtil.h
  • ddiComboIndex : DP5ControlUtil.h
  • ddiComboValue : DP5ControlUtil.h
  • ddiCommand : DP5ControlUtil.h
  • ddiComments : DP5ControlUtil.h
  • ddiCtrlGroup : DP5ControlUtil.h
  • ddiCtrlType : DP5ControlUtil.h
  • ddiDescription : DP5ControlUtil.h
  • ddiListCtrlID : DP5ControlUtil.h
  • ddiTextCtrlID : DP5ControlUtil.h
  • ddiTextValue : DP5ControlUtil.h
  • ddiUnits : DP5ControlUtil.h
  • DEFINE_GUID() : guid.h , WINUSBIO.H
  • DEVICE_INFO : DppWinUSB.h
  • DEVICE_SPEED : WINUSBIO.H
  • DiagDataType : DP5Status.h
  • DP4_FORMAT_STATUS : DP5Status.h
  • DP4_PX4_OLD_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_CMD_INDEX : DP5ControlUtil.h
  • DP5_CMD_MAX : DP5ControlUtil.h
  • DP5_CMD_MIN : DP5ControlUtil.h
  • DP5_CONFIGURATION : DP5ControlUtil.h
  • DP5_CTRL_GROUP : DP5ControlUtil.h
  • DP5_CTRL_TYPE : DP5ControlUtil.h
  • DP5_DATA_ID : DP5ControlUtil.h
  • DP5_DIAGDATA_TIMEOUT : DppLibUsb.h
  • DP5_DPP_TYPES : DppConst.h
  • DP5_DPP_TYPES_FIRST : DppConst.h
  • DP5_DPP_TYPES_LAST : DppConst.h
  • DP5_DX_GAIN_COUNT : DppGain.h
  • DP5_GAIN_COUNT : DppGain.h
  • DP5_MAX_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_TO_PX4_CONTROL_INDEX : DppConfig.h
  • DP5_USB_TIMEOUT : DppLibUsb.h
  • dp5DppTypes : DppConst.h
  • DP5G_GAIN_COUNT : DppGain.h
  • DP5X_GAIN_COUNT : DppGain.h
  • DPP_USB_STATUS : DppWinUSB.h
  • DppAGainTable : DppGain.h
  • dppDP5 : DppConst.h
  • dppDP5G : DppConst.h
  • dppDP5X : DppConst.h
  • dppMCA8000D : DppConst.h
  • dppPX5 : DppConst.h
  • DppStateType : ParsePacket.h
  • dppTB5 : DppConst.h
  • DRV_INFO_OPTION_ALL : DppWinUSB.h
  • DRV_INFO_OPTION_DATE : DppWinUSB.h
  • DRV_INFO_OPTION_DESC : DppWinUSB.h
  • DRV_INFO_OPTION_LABEL : DppWinUSB.h
  • DRV_INFO_OPTION_MFG_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_MS_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_NONE : DppWinUSB.h
  • DRV_INFO_OPTION_PROV_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_UX_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_VER : DppWinUSB.h
  • dusbStatConnectFail : DppWinUSB.h
  • dusbStatNewConnect : DppWinUSB.h
  • dusbStatNoAction : DppWinUSB.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- e -

  • EnumChildControls() : FilePage.cpp
  • ETHERNET : DP5Protocol.h
  • ETHERNET_TIMEOUT : DP5Protocol.h
  • EV_READ_STATUS_EVENT : DppComm.h
  • EV_THREAD_EXIT_EVENT : DppComm.h
  • EV_WRITE_DATA_EVENT : DppComm.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- f -

  • FIVE_SMOOTH : STypes.h
  • FlashType : Label.h
  • FullSpeed : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- g -

  • GAIN_1024 : STypes.h
  • GAIN_16384 : STypes.h
  • GAIN_2048 : STypes.h
  • GAIN_256 : STypes.h
  • GAIN_4096 : STypes.h
  • GAIN_512 : STypes.h
  • GAIN_8192 : STypes.h
  • GAIN_FROM_INDEX : STypes.h
  • GAIN_TYPE : STypes.h
  • GETLONG : STypes.h
  • GETP1 : SCommon.h
  • GETPD : SCommon.h
  • GETULONG : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- h -

  • HasComboCtrl : DP5ControlUtil.h
  • HasTextCtrl : DP5ControlUtil.h
  • HID_APP_ABOUT : HTMLDefines.h
  • HID_APP_EXIT : HTMLDefines.h
  • HID_CONTEXT_HELP : HTMLDefines.h
  • HID_EDIT_CLEAR : HTMLDefines.h
  • HID_EDIT_CLEAR_ALL : HTMLDefines.h
  • HID_EDIT_COPY : HTMLDefines.h
  • HID_EDIT_CUT : HTMLDefines.h
  • HID_EDIT_FIND : HTMLDefines.h
  • HID_EDIT_PASTE : HTMLDefines.h
  • HID_EDIT_PASTE_LINK : HTMLDefines.h
  • HID_EDIT_PASTE_SPECIAL : HTMLDefines.h
  • HID_EDIT_REDO : HTMLDefines.h
  • HID_EDIT_REPEAT : HTMLDefines.h
  • HID_EDIT_REPLACE : HTMLDefines.h
  • HID_EDIT_SELECT_ALL : HTMLDefines.h
  • HID_EDIT_UNDO : HTMLDefines.h
  • HID_FILE_CLOSE : HTMLDefines.h
  • HID_FILE_MRU_FILE1 : HTMLDefines.h
  • HID_FILE_NEW : HTMLDefines.h
  • HID_FILE_OPEN : HTMLDefines.h
  • HID_FILE_PAGE_SETUP : HTMLDefines.h
  • HID_FILE_PRINT : HTMLDefines.h
  • HID_FILE_PRINT_DIRECT : HTMLDefines.h
  • HID_FILE_PRINT_PREVIEW : HTMLDefines.h
  • HID_FILE_PRINT_SETUP : HTMLDefines.h
  • HID_FILE_SAVE : HTMLDefines.h
  • HID_FILE_SAVE_AS : HTMLDefines.h
  • HID_FILE_SAVE_COPY_AS : HTMLDefines.h
  • HID_FILE_SEND_MAIL : HTMLDefines.h
  • HID_FILE_TAB : HTMLDefines.h
  • HID_FILE_UPDATE : HTMLDefines.h
  • HID_FORMAT_FONT : HTMLDefines.h
  • HID_GAINPZ_TAB : HTMLDefines.h
  • HID_HELP_ABOUT : HTMLDefines.h
  • HID_HELP_FINDER : HTMLDefines.h
  • HID_HELP_INDEX : HTMLDefines.h
  • HID_HELP_USING : HTMLDefines.h
  • HID_HT_CAPTION : HTMLDefines.h
  • HID_HT_CLOSE : HTMLDefines.h
  • HID_HT_HELP : HTMLDefines.h
  • HID_HT_HSCROLL : HTMLDefines.h
  • HID_HT_MAXBUTTON : HTMLDefines.h
  • HID_HT_MINBUTTON : HTMLDefines.h
  • HID_HT_NOWHERE : HTMLDefines.h
  • HID_HT_OBJECT : HTMLDefines.h
  • HID_HT_SIZE : HTMLDefines.h
  • HID_HT_VSCROLL : HTMLDefines.h
  • HID_MCA_TAB : HTMLDefines.h
  • HID_MISC_TAB : HTMLDefines.h
  • HID_NEXT_PANE : HTMLDefines.h
  • HID_OLE_EDIT_CHANGE_ICON : HTMLDefines.h
  • HID_OLE_EDIT_CONVERT : HTMLDefines.h
  • HID_OLE_EDIT_LINKS : HTMLDefines.h
  • HID_OLE_EDIT_PROPERTIES : HTMLDefines.h
  • HID_OLE_INSERT_NEW : HTMLDefines.h
  • HID_OLE_VERB_1 : HTMLDefines.h
  • HID_POWER_TAB : HTMLDefines.h
  • HID_PREV_PANE : HTMLDefines.h
  • HID_RECORD_FIRST : HTMLDefines.h
  • HID_RECORD_LAST : HTMLDefines.h
  • HID_RECORD_NEXT : HTMLDefines.h
  • HID_RECORD_PREV : HTMLDefines.h
  • HID_SC_CLOSE : HTMLDefines.h
  • HID_SC_MAXIMIZE : HTMLDefines.h
  • HID_SC_MINIMIZE : HTMLDefines.h
  • HID_SC_MOVE : HTMLDefines.h
  • HID_SC_NEXTWINDOW : HTMLDefines.h
  • HID_SC_PREVWINDOW : HTMLDefines.h
  • HID_SC_RESTORE : HTMLDefines.h
  • HID_SC_SIZE : HTMLDefines.h
  • HID_SC_TASKLIST : HTMLDefines.h
  • HID_SHAPING_TAB : HTMLDefines.h
  • HID_VIEW_STATUS_BAR : HTMLDefines.h
  • HID_VIEW_TOOLBAR : HTMLDefines.h
  • HID_WINDOW_ALL : HTMLDefines.h
  • HID_WINDOW_ARRANGE : HTMLDefines.h
  • HID_WINDOW_CASCADE : HTMLDefines.h
  • HID_WINDOW_NEW : HTMLDefines.h
  • HID_WINDOW_SPLIT : HTMLDefines.h
  • HID_WINDOW_TILE_HORZ : HTMLDefines.h
  • HID_WINDOW_TILE_VERT : HTMLDefines.h
  • HID_WIZBACK : HTMLDefines.h
  • HID_WIZFINISH : HTMLDefines.h
  • HID_WIZNEXT : HTMLDefines.h
  • HIDD_ABOUTBOX : HTMLDefines.h
  • HIDD_BUSY_DLG : HTMLDefines.h
  • HIDD_DP5_CONNECT : vcDP5_Shared_HIDD.h
  • HIDD_FILE_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_GAINPZ_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MCA_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MESSAGE_BOX : HTMLDefines.h
  • HIDD_MISC_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_POWER_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_SHAPING_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_vcDP5_DIALOG : HTMLDefines.h
  • HIDM_ABOUTBOX : HTMLDefines.h
  • HIDP_SOCKETS_INIT_FAILED : HTMLDefines.h
  • HIDR_MAINFRAME : HTMLDefines.h
  • HIDR_MENU : HTMLDefines.h
  • HIDR_TOOLBAR : HTMLDefines.h
  • HIDR_TOOLBAR_DP5_DLG : HTMLDefines.h
  • HighSpeed : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- i -

  • ID_FILE_TAB : resource.h
  • ID_GAINPZ_TAB : resource.h
  • ID_HELP_ABOUT : resource.h
  • ID_MCA_TAB : resource.h
  • ID_MISC_TAB : resource.h
  • ID_POWER_TAB : resource.h
  • ID_SHAPING_TAB : resource.h
  • IDB_BITMAP_DP5_DLG : resource.h
  • IDB_SPECTRUM_ANIM : resource.h
  • IDC_BLRQUICKSLOWBUTTON : ShapingPageRes.h
  • IDC_BUSY_PIC : resource.h
  • IDC_BUSY_TEXT : resource.h
  • IDC_BUTTON_ADD_ROI : resource.h
  • IDC_BUTTON_ARM_TRIGGER : resource.h
  • IDC_BUTTON_AUTOTUNE : resource.h
  • IDC_BUTTON_CLEAR_DATA_AND_GRAPH : resource.h
  • IDC_BUTTON_CLEAR_MISC_DATA : resource.h
  • IDC_BUTTON_CLEAR_ROI : resource.h
  • IDC_BUTTON_CLIPBOARD_COPY : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_PORT : SelectDP5Res.h
  • IDC_BUTTON_COARSE_FINE_TO_TOTAL : GainPzPageRes.h
  • IDC_BUTTON_COUNT_DEVICES : SelectDP5Res.h
  • IDC_BUTTON_DIAG : resource.h
  • IDC_BUTTON_EDIT_CONFIG : resource.h
  • IDC_BUTTON_EDIT_CONFIG_FROM_HW : FilePageRes.h
  • IDC_BUTTON_FIND_DEVICE : resource.h
  • IDC_BUTTON_FIND_DP5_IP : SelectDP5Res.h
  • IDC_BUTTON_FIND_USB_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_FINE_GAIN_ENTER : GainPzPageRes.h
  • IDC_BUTTON_IP_SELECT1 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT2 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT3 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT4 : SelectDP5Res.h
  • IDC_BUTTON_OPEN_PORT : SelectDP5Res.h
  • IDC_BUTTON_OUTPUT_QUICKSET1 : MiscPageRes.h
  • IDC_BUTTON_OUTPUT_QUICKSET2 : MiscPageRes.h
  • IDC_BUTTON_OUTPUT_QUICKSET3 : MiscPageRes.h
  • IDC_BUTTON_PREVIEW_SCA : MiscPageRes.h
  • IDC_BUTTON_READ_CONFIG : FilePageRes.h
  • IDC_BUTTON_READ_MISC_DATA : resource.h
  • IDC_BUTTON_ROI_END : resource.h
  • IDC_BUTTON_ROI_START : resource.h
  • IDC_BUTTON_SAVE_CONFIG : FilePageRes.h
  • IDC_BUTTON_SAVE_FILE : resource.h
  • IDC_BUTTON_SCA_DEFAULTS : MiscPageRes.h
  • IDC_BUTTON_SELECT_COMM : resource.h
  • IDC_BUTTON_SEND_COMMAND : FilePageRes.h
  • IDC_BUTTON_SEND_COMMAND2 : FilePageRes.h
  • IDC_BUTTON_SEND_TO_HARDWARE : FilePageRes.h
  • IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT : FilePageRes.h
  • IDC_BUTTON_SERIAL_REQ_DATA : SelectDP5Res.h
  • IDC_BUTTON_SHOW_CONFIG : resource.h
  • IDC_BUTTON_SINGLE_UPDATE : resource.h
  • IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT : SelectDP5Res.h
  • IDC_BUTTON_START_ACQUISITION : resource.h
  • IDC_BUTTON_STOP_ACQUISITION : resource.h
  • IDC_BUTTON_TOTAL_TO_COARSE_FINE : GainPzPageRes.h
  • IDC_BUTTON_WRITE_MISC_DATA : resource.h
  • IDC_CHECK_AUTO_REARM : resource.h
  • IDC_CHECK_DELTA : resource.h
  • IDC_CHECK_DP5_DX_GAIN : FilePageRes.h
  • IDC_CHECK_ENABLE_SCA : MiscPageRes.h
  • IDC_CHECK_PC5_PRESENT : FilePageRes.h
  • IDC_CHECK_TYPE_IP_ADDRESS : SelectDP5Res.h
  • IDC_COMBO_COMPORT : SelectDP5Res.h
  • IDC_COMBO_OUTPUT_LEVEL : MiscPageRes.h
  • IDC_COMBO_SCA_INDEX : MiscPageRes.h
  • IDC_COMBO_SCA_PULSE_WIDTH : MiscPageRes.h
  • IDC_CONNECTOK : SelectDP5Res.h
  • IDC_EDIT_DESCRIPTION : resource.h
  • IDC_EDIT_DIAG : resource.h
  • IDC_EDIT_DPPCOMM_STATUS : SelectDP5Res.h
  • IDC_EDIT_HIGH_THRESHOLD : MiscPageRes.h
  • IDC_EDIT_HW_CFG_SECTION : FilePageRes.h
  • IDC_EDIT_IP_ADDR1 : SelectDP5Res.h
  • IDC_EDIT_IP_ADDR2 : SelectDP5Res.h
  • IDC_EDIT_IP_ADDR3 : SelectDP5Res.h
  • IDC_EDIT_IP_ADDR4 : SelectDP5Res.h
  • IDC_EDIT_IP_PORT : SelectDP5Res.h
  • IDC_EDIT_LOW_THRESHOLD : MiscPageRes.h
  • IDC_EDIT_MISC_DATA : resource.h
  • IDC_EDIT_RCV_CFG : FilePageRes.h
  • IDC_EDIT_SEND_COMMAND : FilePageRes.h
  • IDC_EDIT_START_TIME : resource.h
  • IDC_EDIT_STATUS : resource.h
  • IDC_EDIT_STATUS2 : SelectDP5Res.h
  • IDC_EDIT_TAG : resource.h
  • IDC_FLATTOPSTATIC : ShapingPageRes.h
  • IDC_GROUP_PLOT_SCALE : resource.h
  • IDC_LABEL_BLR_MODE_OFF_ON : ShapingPageRes.h
  • IDC_LABEL_QUICK_PICK_SHAPING : ShapingPageRes.h
  • IDC_LABEL_QUICK_PICK_SHAPING2 : ShapingPageRes.h
  • IDC_MESSAGE1 : resource.h
  • IDC_MESSAGE2 : resource.h
  • IDC_OPT_COMBO_AINP : GainPzPageRes.h
  • IDC_OPT_COMBO_AUO1 : MiscPageRes.h
  • IDC_OPT_COMBO_AUO2 : MiscPageRes.h
  • IDC_OPT_COMBO_BLRM : ShapingPageRes.h
  • IDC_OPT_COMBO_BOOT : PowerPageRes.h
  • IDC_OPT_COMBO_CLCK : ShapingPageRes.h
  • IDC_OPT_COMBO_CON1 : MiscPageRes.h
  • IDC_OPT_COMBO_CON2 : MiscPageRes.h
  • IDC_OPT_COMBO_CUSP : ShapingPageRes.h
  • IDC_OPT_COMBO_DACO : MiscPageRes.h
  • IDC_OPT_COMBO_DMCA_GAIA : McaPageRes.h
  • IDC_OPT_COMBO_DMCA_PURE : McaPageRes.h
  • IDC_OPT_COMBO_GAIA : GainPzPageRes.h
  • IDC_OPT_COMBO_GAIA2 : GainPzPageRes.h
  • IDC_OPT_COMBO_GAIN_SELECT : GainPzPageRes.h
  • IDC_OPT_COMBO_GATE : McaPageRes.h
  • IDC_OPT_COMBO_GPED : MiscPageRes.h
  • IDC_OPT_COMBO_GPGA : MiscPageRes.h
  • IDC_OPT_COMBO_GPIN : MiscPageRes.h
  • IDC_OPT_COMBO_GPMC : MiscPageRes.h
  • IDC_OPT_COMBO_GPME : MiscPageRes.h
  • IDC_OPT_COMBO_HVSE : PowerPageRes.h
  • IDC_OPT_COMBO_INOF : GainPzPageRes.h
  • IDC_OPT_COMBO_MCAC : McaPageRes.h
  • IDC_OPT_COMBO_MCAE : McaPageRes.h
  • IDC_OPT_COMBO_MCAS : McaPageRes.h
  • IDC_OPT_COMBO_PAPS : PowerPageRes.h
  • IDC_OPT_COMBO_PAPZ : GainPzPageRes.h
  • IDC_OPT_COMBO_PDMD : McaPageRes.h
  • IDC_OPT_COMBO_PREC : McaPageRes.h
  • IDC_OPT_COMBO_PREL : McaPageRes.h
  • IDC_OPT_COMBO_PRER : McaPageRes.h
  • IDC_OPT_COMBO_PRET : McaPageRes.h
  • IDC_OPT_COMBO_PURE : ShapingPageRes.h
  • IDC_OPT_COMBO_RESC : FilePageRes.h
  • IDC_OPT_COMBO_RESL : GainPzPageRes.h
  • IDC_OPT_COMBO_RESL2 : GainPzPageRes.h
  • IDC_OPT_COMBO_RTDE : ShapingPageRes.h
  • IDC_OPT_COMBO_SCOE : MiscPageRes.h
  • IDC_OPT_COMBO_SCOG : MiscPageRes.h
  • IDC_OPT_COMBO_SCOT : MiscPageRes.h
  • IDC_OPT_COMBO_SCTC : ShapingPageRes.h
  • IDC_OPT_COMBO_SOFF : McaPageRes.h
  • IDC_OPT_COMBO_SOFF2 : McaPageRes.h
  • IDC_OPT_COMBO_SOFF3 : McaPageRes.h
  • IDC_OPT_COMBO_TECS : PowerPageRes.h
  • IDC_OPT_COMBO_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_COMBO_TPFA : ShapingPageRes.h
  • IDC_OPT_COMBO_TPMO : MiscPageRes.h
  • IDC_OPT_COMBO_VOLU : MiscPageRes.h
  • IDC_OPT_FRAME_AINP : GainPzPageRes.h
  • IDC_OPT_FRAME_AUO1 : MiscPageRes.h
  • IDC_OPT_FRAME_AUO2 : MiscPageRes.h
  • IDC_OPT_FRAME_BLRD : ShapingPageRes.h
  • IDC_OPT_FRAME_BLRM : ShapingPageRes.h
  • IDC_OPT_FRAME_BLRU : ShapingPageRes.h
  • IDC_OPT_FRAME_BOOT : PowerPageRes.h
  • IDC_OPT_FRAME_CLCK : ShapingPageRes.h
  • IDC_OPT_FRAME_CON1 : MiscPageRes.h
  • IDC_OPT_FRAME_CON2 : MiscPageRes.h
  • IDC_OPT_FRAME_CUSP : ShapingPageRes.h
  • IDC_OPT_FRAME_DACF : MiscPageRes.h
  • IDC_OPT_FRAME_DACO : MiscPageRes.h
  • IDC_OPT_FRAME_DMCA_GAIA : McaPageRes.h
  • IDC_OPT_FRAME_DMCA_PURE : McaPageRes.h
  • IDC_OPT_FRAME_GAIA : GainPzPageRes.h
  • IDC_OPT_FRAME_GAIF : GainPzPageRes.h
  • IDC_OPT_FRAME_GAIN : GainPzPageRes.h
  • IDC_OPT_FRAME_GATE : McaPageRes.h
  • IDC_OPT_FRAME_GPED : MiscPageRes.h
  • IDC_OPT_FRAME_GPGA : MiscPageRes.h
  • IDC_OPT_FRAME_GPIN : MiscPageRes.h
  • IDC_OPT_FRAME_GPMC : MiscPageRes.h
  • IDC_OPT_FRAME_GPME : MiscPageRes.h
  • IDC_OPT_FRAME_HVSE : PowerPageRes.h
  • IDC_OPT_FRAME_INOF : GainPzPageRes.h
  • IDC_OPT_FRAME_MCAC : McaPageRes.h
  • IDC_OPT_FRAME_MCAE : McaPageRes.h
  • IDC_OPT_FRAME_MCAS : McaPageRes.h
  • IDC_OPT_FRAME_MCSH : McaPageRes.h
  • IDC_OPT_FRAME_MCSL : McaPageRes.h
  • IDC_OPT_FRAME_MCST : McaPageRes.h
  • IDC_OPT_FRAME_PAPS : PowerPageRes.h
  • IDC_OPT_FRAME_PAPZ : GainPzPageRes.h
  • IDC_OPT_FRAME_PDMD : McaPageRes.h
  • IDC_OPT_FRAME_PRCH : McaPageRes.h
  • IDC_OPT_FRAME_PRCL : McaPageRes.h
  • IDC_OPT_FRAME_PREC : McaPageRes.h
  • IDC_OPT_FRAME_PREL : McaPageRes.h
  • IDC_OPT_FRAME_PRER : McaPageRes.h
  • IDC_OPT_FRAME_PRET : McaPageRes.h
  • IDC_OPT_FRAME_PURE : ShapingPageRes.h
  • IDC_OPT_FRAME_RESC : FilePageRes.h
  • IDC_OPT_FRAME_RESL : GainPzPageRes.h
  • IDC_OPT_FRAME_RESL2 : GainPzPageRes.h
  • IDC_OPT_FRAME_RTDE : ShapingPageRes.h
  • IDC_OPT_FRAME_RTDS : ShapingPageRes.h
  • IDC_OPT_FRAME_RTDT : ShapingPageRes.h
  • IDC_OPT_FRAME_SCOE : MiscPageRes.h
  • IDC_OPT_FRAME_SCOG : MiscPageRes.h
  • IDC_OPT_FRAME_SCOT : MiscPageRes.h
  • IDC_OPT_FRAME_SCTC : ShapingPageRes.h
  • IDC_OPT_FRAME_SOFF : McaPageRes.h
  • IDC_OPT_FRAME_SOFF2 : McaPageRes.h
  • IDC_OPT_FRAME_SOFF3 : McaPageRes.h
  • IDC_OPT_FRAME_TECS : PowerPageRes.h
  • IDC_OPT_FRAME_TFLA : ShapingPageRes.h
  • IDC_OPT_FRAME_THFA : ShapingPageRes.h
  • IDC_OPT_FRAME_THSL : McaPageRes.h
  • IDC_OPT_FRAME_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_FRAME_TPEA : ShapingPageRes.h
  • IDC_OPT_FRAME_TPFA : ShapingPageRes.h
  • IDC_OPT_FRAME_TPMO : MiscPageRes.h
  • IDC_OPT_FRAME_VOLU : MiscPageRes.h
  • IDC_OPT_LIMITS_AUO1 : MiscPageRes.h
  • IDC_OPT_LIMITS_AUO2 : MiscPageRes.h
  • IDC_OPT_LIMITS_BLRD : ShapingPageRes.h
  • IDC_OPT_LIMITS_BLRU : ShapingPageRes.h
  • IDC_OPT_LIMITS_CUSP : ShapingPageRes.h
  • IDC_OPT_LIMITS_DACF : MiscPageRes.h
  • IDC_OPT_LIMITS_DACO : MiscPageRes.h
  • IDC_OPT_LIMITS_GAIF : GainPzPageRes.h
  • IDC_OPT_LIMITS_GAIN : GainPzPageRes.h
  • IDC_OPT_LIMITS_GPIN : MiscPageRes.h
  • IDC_OPT_LIMITS_HVSE : PowerPageRes.h
  • IDC_OPT_LIMITS_INOF : GainPzPageRes.h
  • IDC_OPT_LIMITS_MCSH : McaPageRes.h
  • IDC_OPT_LIMITS_MCSL : McaPageRes.h
  • IDC_OPT_LIMITS_MCST : McaPageRes.h
  • IDC_OPT_LIMITS_PAPZ : GainPzPageRes.h
  • IDC_OPT_LIMITS_PRCH : McaPageRes.h
  • IDC_OPT_LIMITS_PRCL : McaPageRes.h
  • IDC_OPT_LIMITS_PREC : McaPageRes.h
  • IDC_OPT_LIMITS_PREL : McaPageRes.h
  • IDC_OPT_LIMITS_PRER : McaPageRes.h
  • IDC_OPT_LIMITS_PRET : McaPageRes.h
  • IDC_OPT_LIMITS_PURE : ShapingPageRes.h
  • IDC_OPT_LIMITS_RESL : GainPzPageRes.h
  • IDC_OPT_LIMITS_RTDS : ShapingPageRes.h
  • IDC_OPT_LIMITS_RTDT : ShapingPageRes.h
  • IDC_OPT_LIMITS_SCTC : ShapingPageRes.h
  • IDC_OPT_LIMITS_SOFF : McaPageRes.h
  • IDC_OPT_LIMITS_SOFF2 : McaPageRes.h
  • IDC_OPT_LIMITS_SOFF3 : McaPageRes.h
  • IDC_OPT_LIMITS_TECS : PowerPageRes.h
  • IDC_OPT_LIMITS_TFLA : ShapingPageRes.h
  • IDC_OPT_LIMITS_THFA : ShapingPageRes.h
  • IDC_OPT_LIMITS_THSL : McaPageRes.h
  • IDC_OPT_LIMITS_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_LIMITS_TPEA : ShapingPageRes.h
  • IDC_OPT_TEXT_AUO1 : MiscPageRes.h
  • IDC_OPT_TEXT_AUO2 : MiscPageRes.h
  • IDC_OPT_TEXT_BLRD : ShapingPageRes.h
  • IDC_OPT_TEXT_BLRU : ShapingPageRes.h
  • IDC_OPT_TEXT_CUSP : ShapingPageRes.h
  • IDC_OPT_TEXT_DACF : MiscPageRes.h
  • IDC_OPT_TEXT_DACO : MiscPageRes.h
  • IDC_OPT_TEXT_GAIF : GainPzPageRes.h
  • IDC_OPT_TEXT_GAIN : GainPzPageRes.h
  • IDC_OPT_TEXT_GPIN : MiscPageRes.h
  • IDC_OPT_TEXT_HVSE : PowerPageRes.h
  • IDC_OPT_TEXT_INOF : GainPzPageRes.h
  • IDC_OPT_TEXT_MCSH : McaPageRes.h
  • IDC_OPT_TEXT_MCSL : McaPageRes.h
  • IDC_OPT_TEXT_MCST : McaPageRes.h
  • IDC_OPT_TEXT_PAPZ : GainPzPageRes.h
  • IDC_OPT_TEXT_PRCH : McaPageRes.h
  • IDC_OPT_TEXT_PRCL : McaPageRes.h
  • IDC_OPT_TEXT_PREC : McaPageRes.h
  • IDC_OPT_TEXT_PREL : McaPageRes.h
  • IDC_OPT_TEXT_PRER : McaPageRes.h
  • IDC_OPT_TEXT_PRET : McaPageRes.h
  • IDC_OPT_TEXT_PURE : ShapingPageRes.h
  • IDC_OPT_TEXT_RESL : GainPzPageRes.h
  • IDC_OPT_TEXT_RTDS : ShapingPageRes.h
  • IDC_OPT_TEXT_RTDT : ShapingPageRes.h
  • IDC_OPT_TEXT_SCTC : ShapingPageRes.h
  • IDC_OPT_TEXT_SOFF : McaPageRes.h
  • IDC_OPT_TEXT_SOFF2 : McaPageRes.h
  • IDC_OPT_TEXT_SOFF3 : McaPageRes.h
  • IDC_OPT_TEXT_TECS : PowerPageRes.h
  • IDC_OPT_TEXT_TFLA : ShapingPageRes.h
  • IDC_OPT_TEXT_THFA : ShapingPageRes.h
  • IDC_OPT_TEXT_THSL : McaPageRes.h
  • IDC_OPT_TEXT_TLLD : ShapingPageRes.h , McaPageRes.h
  • IDC_OPT_TEXT_TPEA : ShapingPageRes.h
  • IDC_OPT_UNITS_AUO1 : MiscPageRes.h
  • IDC_OPT_UNITS_AUO2 : MiscPageRes.h
  • IDC_OPT_UNITS_BLRD : ShapingPageRes.h
  • IDC_OPT_UNITS_BLRU : ShapingPageRes.h
  • IDC_OPT_UNITS_CUSP : ShapingPageRes.h
  • IDC_OPT_UNITS_DACF : MiscPageRes.h
  • IDC_OPT_UNITS_DACO : MiscPageRes.h
  • IDC_OPT_UNITS_GAIF : GainPzPageRes.h
  • IDC_OPT_UNITS_GAIN : GainPzPageRes.h
  • IDC_OPT_UNITS_GPIN : MiscPageRes.h
  • IDC_OPT_UNITS_HVSE : PowerPageRes.h
  • IDC_OPT_UNITS_INOF : GainPzPageRes.h
  • IDC_OPT_UNITS_MCSH : McaPageRes.h
  • IDC_OPT_UNITS_MCSL : McaPageRes.h
  • IDC_OPT_UNITS_MCST : McaPageRes.h
  • IDC_OPT_UNITS_PAPS : PowerPageRes.h
  • IDC_OPT_UNITS_PAPZ : GainPzPageRes.h
  • IDC_OPT_UNITS_PRCH : McaPageRes.h
  • IDC_OPT_UNITS_PRCL : McaPageRes.h
  • IDC_OPT_UNITS_PREC : McaPageRes.h
  • IDC_OPT_UNITS_PREL : McaPageRes.h
  • IDC_OPT_UNITS_PRER : McaPageRes.h
  • IDC_OPT_UNITS_PRET : McaPageRes.h
  • IDC_OPT_UNITS_PURE : ShapingPageRes.h
  • IDC_OPT_UNITS_RESL : GainPzPageRes.h
  • IDC_OPT_UNITS_RESL2 : ShapingPageRes.h , GainPzPageRes.h
  • IDC_OPT_UNITS_RESL3 : ShapingPageRes.h
  • IDC_OPT_UNITS_RTDS : ShapingPageRes.h
  • IDC_OPT_UNITS_RTDT : ShapingPageRes.h
  • IDC_OPT_UNITS_SCOG : MiscPageRes.h
  • IDC_OPT_UNITS_SCTC : ShapingPageRes.h
  • IDC_OPT_UNITS_SOFF : McaPageRes.h
  • IDC_OPT_UNITS_SOFF2 : McaPageRes.h
  • IDC_OPT_UNITS_SOFF3 : McaPageRes.h
  • IDC_OPT_UNITS_TECS : PowerPageRes.h
  • IDC_OPT_UNITS_TFLA : ShapingPageRes.h
  • IDC_OPT_UNITS_THFA : ShapingPageRes.h
  • IDC_OPT_UNITS_THSL : McaPageRes.h
  • IDC_OPT_UNITS_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_UNITS_TPEA : ShapingPageRes.h
  • IDC_OPT_VALUE_GAIA : GainPzPageRes.h
  • IDC_OPT_VALUE_GAIN : GainPzPageRes.h
  • IDC_PICTURE_PLOT : resource.h
  • IDC_PICTURE_SCOPE : resource.h
  • IDC_PLOTTYPEGROUP : resource.h
  • IDC_PRESETCOUNTCURSORBUTTON : McaPageRes.h
  • IDC_PRESETCOUNTROIBUTTON : McaPageRes.h
  • IDC_RADIO_COMMTYPE1 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE2 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE3 : SelectDP5Res.h
  • IDC_RADIO_DPP_DEVICE_TYPE1 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE2 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE3 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE4 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE5 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE6 : FilePageRes.h
  • IDC_RADIO_HV_SIGN1 : PowerPageRes.h
  • IDC_RADIO_HV_SIGN2 : PowerPageRes.h
  • IDC_RADIO_PLOT_SCALE_LINEAR : resource.h
  • IDC_RADIO_PLOT_SCALE_LOG : resource.h
  • IDC_RADIO_PLOT_TYPE_LINE : resource.h
  • IDC_RADIO_PLOT_TYPE_SOLID : resource.h
  • IDC_READDETECTORCONFIGCOMBO : FilePageRes.h
  • IDC_RISECOMBO : ShapingPageRes.h
  • IDC_SHAPINGGROUP : ShapingPageRes.h
  • IDC_SPECTRUM_REFRESH_TIME : SelectDP5Res.h
  • IDC_SPIN_SELECT_DEVICE : SelectDP5Res.h
  • IDC_STATIC_ : resource.h
  • IDC_STATIC_AVANCED_GAIN_CONTROL : GainPzPageRes.h
  • IDC_STATIC_BLR_FRAME : ShapingPageRes.h
  • IDC_STATIC_CFG_LEN_LABEL : FilePageRes.h
  • IDC_STATIC_CFG_LENGTH : FilePageRes.h
  • IDC_STATIC_CONFIG_NAME : FilePageRes.h
  • IDC_STATIC_CONFIG_NAME2 : FilePageRes.h
  • IDC_STATIC_CURRENT_SCA : MiscPageRes.h
  • IDC_STATIC_DAC_FRAME : MiscPageRes.h
  • IDC_STATIC_DPP_DEVICE_TYPE : FilePageRes.h
  • IDC_STATIC_FAST_SHAPING_FRAME : ShapingPageRes.h
  • IDC_STATIC_FILE_ADVANCED : FilePageRes.h
  • IDC_STATIC_FILE_BASIC : FilePageRes.h
  • IDC_STATIC_FILE_PAGE : FilePageRes.h
  • IDC_STATIC_FILE_STANDARD : FilePageRes.h
  • IDC_STATIC_FOUND1 : SelectDP5Res.h
  • IDC_STATIC_FOUND2 : SelectDP5Res.h
  • IDC_STATIC_FOUND3 : SelectDP5Res.h
  • IDC_STATIC_FPGACLK1 : ShapingPageRes.h
  • IDC_STATIC_FPGACLK2 : ShapingPageRes.h
  • IDC_STATIC_FPGACLK3 : ShapingPageRes.h
  • IDC_STATIC_GAIN_ADVANCED : GainPzPageRes.h
  • IDC_STATIC_GAIN_BASIC : GainPzPageRes.h
  • IDC_STATIC_GAIN_STANDARD : GainPzPageRes.h
  • IDC_STATIC_GAINPZ_PAGE : GainPzPageRes.h
  • IDC_STATIC_HIGH_THRESHOLD : MiscPageRes.h
  • IDC_STATIC_HV_SIGN1 : PowerPageRes.h
  • IDC_STATIC_HV_SIGN2 : PowerPageRes.h
  • IDC_STATIC_HV_WARNING : GainPzPageRes.h , PowerPageRes.h
  • IDC_STATIC_IP_ADDRESS_LABEL : SelectDP5Res.h
  • IDC_STATIC_IP_SERIAL_NUM : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_1 : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_2 : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_3 : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_4 : SelectDP5Res.h
  • IDC_STATIC_LOW_THRESHOLD : MiscPageRes.h
  • IDC_STATIC_MCA_ADVANCED : McaPageRes.h
  • IDC_STATIC_MCA_BASIC : McaPageRes.h
  • IDC_STATIC_MCA_PAGE : McaPageRes.h
  • IDC_STATIC_MCA_STANDARD : McaPageRes.h
  • IDC_STATIC_MISC_ADVANCED : MiscPageRes.h
  • IDC_STATIC_MISC_BASIC : MiscPageRes.h
  • IDC_STATIC_MISC_PAGE : MiscPageRes.h
  • IDC_STATIC_MISC_QUICKSET : MiscPageRes.h
  • IDC_STATIC_MISC_STANDARD : MiscPageRes.h
  • IDC_STATIC_MISC_STATUS : resource.h
  • IDC_STATIC_NETFINDER1 : SelectDP5Res.h
  • IDC_STATIC_NETFINDER2 : SelectDP5Res.h
  • IDC_STATIC_NETFINDER3 : SelectDP5Res.h
  • IDC_STATIC_NETFINDER4 : SelectDP5Res.h
  • IDC_STATIC_NUM_DEVICES : SelectDP5Res.h
  • IDC_STATIC_NUM_DEVICES2 : SelectDP5Res.h
  • IDC_STATIC_OUTPUT_LEVEL : MiscPageRes.h
  • IDC_STATIC_PORT_LABEL : SelectDP5Res.h
  • IDC_STATIC_POWER_ADVANCED : PowerPageRes.h
  • IDC_STATIC_POWER_BASIC : PowerPageRes.h
  • IDC_STATIC_POWER_PAGE : PowerPageRes.h
  • IDC_STATIC_POWER_STANDARD : PowerPageRes.h
  • IDC_STATIC_PULSE_SHAPING : ShapingPageRes.h
  • IDC_STATIC_READ_CONFIG : FilePageRes.h
  • IDC_STATIC_ROI_COUNT : resource.h
  • IDC_STATIC_ROI_END : resource.h
  • IDC_STATIC_ROI_INDEX : resource.h
  • IDC_STATIC_ROI_START : resource.h
  • IDC_STATIC_RTD_FRAME : ShapingPageRes.h
  • IDC_STATIC_SAVE_CONFIG : FilePageRes.h
  • IDC_STATIC_SCA_GROUP : MiscPageRes.h
  • IDC_STATIC_SCA_INDEX : MiscPageRes.h
  • IDC_STATIC_SCA_PULSE_WIDTH : MiscPageRes.h
  • IDC_STATIC_SELECT_COMMUNICATIONS : resource.h
  • IDC_STATIC_SELECT_USB_DEVICE_LABEL : SelectDP5Res.h
  • IDC_STATIC_SEND_COMMAND_LABEL : FilePageRes.h
  • IDC_STATIC_SHAPING_ADVANCED : ShapingPageRes.h
  • IDC_STATIC_SHAPING_BASIC : ShapingPageRes.h
  • IDC_STATIC_SHAPING_PAGE : ShapingPageRes.h
  • IDC_STATIC_SHAPING_STANDARD : ShapingPageRes.h
  • IDC_STATIC_SPECTRUM_STATUS : resource.h
  • IDC_STATIC_STATUS : resource.h
  • IDC_STATIC_TOTAL_OR_BOTH_LABEL : GainPzPageRes.h
  • IDC_TIMETOPEAKSTATIC : ShapingPageRes.h
  • IDC_TOPCOMBO : ShapingPageRes.h
  • IDD_ABOUTBOX : resource.h
  • IDD_BUSY_DLG : resource.h
  • IDD_DP5_CONNECT : vcDP5_Shared_IDD.h
  • IDD_FILE_PAGE : vcDP5_Shared_IDD.h
  • IDD_GAINPZ_PAGE : vcDP5_Shared_IDD.h
  • IDD_MCA_PAGE : vcDP5_Shared_IDD.h
  • IDD_MESSAGE_BOX : resource.h
  • IDD_MISC_PAGE : vcDP5_Shared_IDD.h
  • IDD_POWER_PAGE : vcDP5_Shared_IDD.h
  • IDD_SHAPING_PAGE : vcDP5_Shared_IDD.h
  • IDD_vcDP5_DIALOG : resource.h
  • IDI_DP5_CARD : FilePageRes.h
  • IDI_OPEN_FOLDER : FilePageRes.h
  • IDI_RIGHT_ARROW : FilePageRes.h
  • IDM_ABOUTBOX : resource.h
  • IDP_SOCKETS_INIT_FAILED : resource.h
  • IDR_MAINFRAME : resource.h
  • IDR_MENU : resource.h
  • IDR_TOOLBAR : resource.h
  • IDR_TOOLBAR_DP5_DLG : resource.h
  • IDS_ABOUTBOX : resource.h
  • IDS_BTNSTRING_MODAL : resource.h
  • IDS_BTNSTRING_MODELESS : resource.h
  • IDS_CAPTION : resource.h
  • IDS_TT_ANALOG_INPUT : GainPzPageRes.h
  • IDS_TT_ANALOG_OUT : MiscPageRes.h
  • IDS_TT_ARROWS : GainPzPageRes.h
  • IDS_TT_AUX_1 : MiscPageRes.h
  • IDS_TT_AUX_2 : MiscPageRes.h
  • IDS_TT_BLR_DOWN_CORRECTION : ShapingPageRes.h
  • IDS_TT_BLR_MODE : ShapingPageRes.h
  • IDS_TT_BLR_QUICKSET : ShapingPageRes.h
  • IDS_TT_BLR_UP_CORRECTION : ShapingPageRes.h
  • IDS_TT_COARSE_GAIN : GainPzPageRes.h
  • IDS_TT_CONNECTOR_1 : MiscPageRes.h
  • IDS_TT_CONNECTOR_2 : MiscPageRes.h
  • IDS_TT_COOLER_TEMPERATURE : PowerPageRes.h
  • IDS_TT_FAST_PEAKING_TIME : ShapingPageRes.h
  • IDS_TT_FAST_THRESHOLD : ShapingPageRes.h
  • IDS_TT_FINE_GAIN : GainPzPageRes.h
  • IDS_TT_FLAT_TOP_WIDTH : ShapingPageRes.h
  • IDS_TT_FPGA_CLOCK_SPEED : ShapingPageRes.h
  • IDS_TT_GATE_CONTROL : McaPageRes.h
  • IDS_TT_HIGH_VOLTAGE_BIAS : PowerPageRes.h
  • IDS_TT_HIGH_VOLTAGE_POLARITY : PowerPageRes.h
  • IDS_TT_INPUT_OFFSET : GainPzPageRes.h
  • IDS_TT_LOW_LEVEL_DISCRIMINATOR : McaPageRes.h
  • IDS_TT_MCA_MCS_CHANNELS : McaPageRes.h
  • IDS_TT_MCA_SOURCE : McaPageRes.h
  • IDS_TT_MCS_LOW_HIGH_CHANNEL : McaPageRes.h
  • IDS_TT_MCS_TIMEBASE : McaPageRes.h
  • IDS_TT_NON_TRAPEZOIDAL_SHAPING : ShapingPageRes.h
  • IDS_TT_OUTPUT_OFFSET : MiscPageRes.h
  • IDS_TT_PC__ON_AT_STARTUP : PowerPageRes.h
  • IDS_TT_PEAK_DETECT_MODE : McaPageRes.h
  • IDS_TT_PEAKING_QPICK : ShapingPageRes.h
  • IDS_TT_PEAKING_TIME : ShapingPageRes.h
  • IDS_TT_PREAMP_VOLTAGE : PowerPageRes.h
  • IDS_TT_PRESET_ACQUISITION_TIME : McaPageRes.h
  • IDS_TT_PRESET_COUNT : McaPageRes.h
  • IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL : McaPageRes.h
  • IDS_TT_PRESET_LIVE_TIME : McaPageRes.h
  • IDS_TT_PRESET_REAL_TIME : McaPageRes.h
  • IDS_TT_PUR_ON_OFF : ShapingPageRes.h
  • IDS_TT_PX__SPEAKER : MiscPageRes.h
  • IDS_TT_RESET_LOCKOUT : GainPzPageRes.h
  • IDS_TT_RTD_ON_OFF : ShapingPageRes.h
  • IDS_TT_RTD_SENSITIVITY : ShapingPageRes.h
  • IDS_TT_RTD_THRESHOLD : ShapingPageRes.h
  • IDS_TT_SCOPE_COMMANDS : MiscPageRes.h
  • IDS_TT_SCTC : ShapingPageRes.h
  • IDS_TT_SEND_TOTAL_OR_COARSE_FINE_GAIN : GainPzPageRes.h
  • IDS_TT_SET_SPECTRUM_OFFSET : McaPageRes.h
  • IDS_TT_SLOW_THRESHOLD : McaPageRes.h
  • IDS_TT_TEST_PULSER : MiscPageRes.h
  • IDS_TT_TOTAL_GAIN : GainPzPageRes.h
  • IGNORE_SHORT_PACKETS : WINUSBIO.H
  • INTERFACE_NUMBER : DppLibUsb.h
  • INVALID_SMOOTH : STypes.h
  • isDebug : SelectDP5.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- l -

  • LIMIT_INIT : DP5ControlUtil.h
  • LIMIT_VIS : DP5ControlUtil.h
  • LIN_SCALE : STypes.h
  • LINE_PLOT_TYPE : vcDP5Dlg.h
  • LINEAR_PLOT_SCALE : vcDP5Dlg.h
  • LOG_PLOT_SCALE : vcDP5Dlg.h
  • LOG_SCALE : STypes.h
  • LowSpeed : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- m -

  • MAX_BUFFER_DATA : DP5Protocol.h
  • MAX_BULK_IN_TRANSFER_SIZE : DppLibUsb.h
  • MAX_BULK_OUT_TRANSFER_SIZE : DppLibUsb.h
  • MAX_CHANNELS : STypes.h
  • MAX_COUNTS : STypes.h
  • MAX_DEVPATH_LENGTH : DppWinUSB.h
  • MAX_DP5_CONFIGURATIONS : DP5ControlUtil.h
  • MAX_ENTRIES : NetFinder.h
  • MAX_GAIN_INDEX : SpectrumAttr.h , STypes.h
  • MAX_KEY_DATA_SIZE : INI.h
  • MAX_SCA_REGISTER : Sca.h
  • MAX_SCOPE_DATA : DP5Protocol.h
  • MAX_SECTION_SIZE : INI.h
  • MAX_SPECTRA : STypes.h
  • MAXDP5S : DppWinUSB.h
  • MaxGainTable : DppGain.h
  • MAXIMUM_TRANSFER_SIZE : WINUSBIO.H
  • MAXPEAKINGTIMES : DppShaping.h
  • MAXPEAKINGTIMES_20MHZ : DppShaping.h
  • MAXPEAKINGTIMES_80MHZ : DppShaping.h
  • MAXPIPES : DppWinUSB.h
  • MAXREGBUFFER : DppWinUSB.h
  • MCA8000D_GAIN_COUNT : DppGain.h
  • MIN_FRAME_X_PIXELS : STypes.h
  • MIN_FRAME_Y_PIXELS : STypes.h
  • MIN_GAIN : STypes.h
  • MIN_PLOT_CHANNELS : STypes.h
  • MIN_PLOT_COUNTS : STypes.h
  • MIN_PLOT_X_PIXELS : STypes.h
  • MIN_PLOT_Y_PIXELS : STypes.h
  • MinGainTable : DppGain.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- n -

  • NETDISPLAY_ENTRY : NetFinder.h
  • NO_ENTRIES : NetFinder.h
  • NO_SMOOTH : STypes.h
  • None : Label.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- p -

  • Packet_In : DP5Protocol.h
  • PDDiagDataType : DP5Status.h
  • PDEVICE_INFO : DppWinUSB.h
  • PDP4_FORMAT_STATUS : DP5Status.h
  • PID1_ACK : DP5Protocol.h
  • PID1_COMM_TEST : DP5Protocol.h
  • PID1_RCV_SCA : DP5Protocol.h
  • PID1_RCV_SCOPE_MISC : DP5Protocol.h
  • PID1_RCV_SPECTRUM : DP5Protocol.h
  • PID1_RCV_STATUS : DP5Protocol.h
  • PID1_REQ_CONFIG : DP5Protocol.h
  • PID1_REQ_FPGA_UC : DP5Protocol.h
  • PID1_REQ_SCA : DP5Protocol.h
  • PID1_REQ_SCOPE_MISC : DP5Protocol.h
  • PID1_REQ_SCOPE_MISC_TO : DppLibUsb.h
  • PID1_REQ_SPECTRUM : DP5Protocol.h
  • PID1_REQ_STATUS : DP5Protocol.h
  • PID1_TYPE : DP5Protocol.h
  • PID1_VENDOR_REQ : DP5Protocol.h
  • PID2_ACK_BAD_HEX_REC : DP5Protocol.h
  • PID2_ACK_BAD_PARAM : DP5Protocol.h
  • PID2_ACK_CAL_DATA_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_CHECKSUM_ERROR : DP5Protocol.h
  • PID2_ACK_CP2201_NOT_FOUND : DP5Protocol.h
  • PID2_ACK_ETHERNET_BUSY : DP5Protocol.h
  • PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED : DP5Protocol.h
  • PID2_ACK_FPGA_ERROR : DP5Protocol.h
  • PID2_ACK_I2C_ERROR : DP5Protocol.h
  • PID2_ACK_LEN_ERROR : DP5Protocol.h
  • PID2_ACK_OK : DP5Protocol.h
  • PID2_ACK_OK_ETHERNET_SHARE_REQ : DP5Protocol.h
  • PID2_ACK_OK_FPGA_UPLOAD_ADDR : DP5Protocol.h
  • PID2_ACK_PC5_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_PID_ERROR : DP5Protocol.h
  • PID2_ACK_SCOPE_DATA_NOT_AVAIL : DP5Protocol.h
  • PID2_ACK_SYNC_ERROR : DP5Protocol.h
  • PID2_ACK_TYPE : DP5Protocol.h
  • PID2_ACK_UNRECOG : DP5Protocol.h
  • PID2_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • PID2_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • PID2_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • PID2_CLEAR_GP_COUNTER : DP5Protocol.h
  • PID2_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • PID2_CONFIG_READBACK_PACKET : DP5Protocol.h
  • PID2_DISABLE_MCA_MCS : DP5Protocol.h
  • PID2_ENABLE_MCA_MCS : DP5Protocol.h
  • PID2_ERASE_FPGA_IMAGE : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • PID2_ETHERNET_ALLOW_SHAREING : DP5Protocol.h
  • PID2_ETHERNET_LOCK_IP : DP5Protocol.h
  • PID2_ETHERNET_NO_SHARING : DP5Protocol.h
  • PID2_GENERIC_FPGA_WRITE : DP5Protocol.h
  • PID2_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • PID2_LATCH_SEND_SCA : DP5Protocol.h
  • PID2_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • PID2_RCV_SCA_TYPE : DP5Protocol.h
  • PID2_RCV_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_RCV_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_RCV_STATUS_TYPE : DP5Protocol.h
  • PID2_READ_IO3_0 : DP5Protocol.h
  • PID2_REINITIALIZE_FPGA : DP5Protocol.h
  • PID2_REQ_CONFIG_TYPE : DP5Protocol.h
  • PID2_REQ_FPGA_UC_TYPE : DP5Protocol.h
  • PID2_REQ_SCA_TYPE : DP5Protocol.h
  • PID2_REQ_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_REQ_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_REQ_STATUS_TYPE : DP5Protocol.h
  • PID2_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • PID2_SEND_DIAGNOSTIC_DATA_TO : DppLibUsb.h
  • PID2_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • PID2_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • PID2_SEND_I2C_DATA : DP5Protocol.h
  • PID2_SEND_LIST_MODE_DATA : DP5Protocol.h
  • PID2_SEND_NETFINDER_READBACK : DP5Protocol.h
  • PID2_SEND_OPTION_PA_CALIBRATION : DP5Protocol.h
  • PID2_SEND_SCA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • PID2_SEND_SPECTRUM : DP5Protocol.h
  • PID2_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • PID2_SET_BOOT_FLAGS : DP5Protocol.h
  • PID2_SET_DCAL : DP5Protocol.h
  • PID2_SET_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • PID2_SET_SERIAL_NUMBER : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • PID2_TEXT_CONFIG_PACKET : DP5Protocol.h
  • PID2_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • PID2_UPLOAD_PACKET_UC : DP5Protocol.h
  • PID2_VENDOR_REQ_TYPE : DP5Protocol.h
  • PID2_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_WRITE_IO3_0 : DP5Protocol.h
  • PIPE_TRANSFER_TIMEOUT : WINUSBIO.H
  • preqProcessAck : ParsePacket.h
  • preqProcessCfgRead : ParsePacket.h
  • preqProcessDiagData : ParsePacket.h
  • preqProcessError : ParsePacket.h
  • preqProcessHwDesc : ParsePacket.h
  • preqProcessInetSettings : ParsePacket.h
  • preqProcessNetFindRead : ParsePacket.h
  • preqProcessNone : ParsePacket.h
  • preqProcessPaCal : ParsePacket.h
  • preqProcessSCAData : ParsePacket.h
  • preqProcessScopeData : ParsePacket.h
  • preqProcessScopeDataOverFlow : ParsePacket.h
  • preqProcessSpectrum : ParsePacket.h
  • preqProcessStatus : ParsePacket.h
  • preqProcessTextData : ParsePacket.h
  • preqRequestScopeData : ParsePacket.h
  • PUTP1 : SCommon.h
  • PUTPD : SCommon.h
  • PWINUSB_INTERFACE_HANDLE : WINUSB.H
  • PWINUSB_PIPE_INFORMATION : WINUSBIO.H
  • PWINUSB_SETUP_PACKET : WINUSB.H
  • PX5_GAIN_COUNT : DppGain.h
  • PX5_OPTION_HPGe_HVPS : DP5Status.h
  • PX5_OPTION_NONE : DP5Status.h
  • PX5_OPTION_TEST_AMP : DP5Status.h
  • PX5_OPTION_TEST_MODE_1 : DP5Status.h
  • PX5_OPTION_TEST_MODE_2 : DP5Status.h
  • PX5_OPTION_TEST_MOX : DP5Status.h
  • PX5_OPTION_TEST_TEK : DP5Status.h
  • PX5_OPTIONS : DP5Status.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- r -

  • RAW_IO : WINUSBIO.H
  • RCVPT_1024_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_1024_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_512_BYTE_MISC_DATA : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_CONFIG_READBACK : DP5Protocol.h
  • RCVPT_DIAGNOSTIC_DATA : DP5Protocol.h
  • RCVPT_DP4_STYLE_STATUS : DP5Protocol.h
  • RCVPT_ETHERNET_SETTINGS : DP5Protocol.h
  • RCVPT_HARDWARE_DESCRIPTION : DP5Protocol.h
  • RCVPT_I2C_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA_FIFO_FULL : DP5Protocol.h
  • RCVPT_NETFINDER_READBACK : DP5Protocol.h
  • RCVPT_OPTION_PA_CALIBRATION : DP5Protocol.h
  • RCVPT_SCA : DP5Protocol.h
  • RCVPT_SCOPE_DATA : DP5Protocol.h
  • RCVPT_SCOPE_DATA_WITH_OVERFLOW : DP5Protocol.h
  • regDP5Comm : SCommon.h
  • regDP5Config : SCommon.h
  • regDP5Device : SCommon.h
  • Retries : DP5Protocol.h
  • ROI_DATA_BAD : roi.h
  • ROI_DATA_GOOD : roi.h
  • ROI_DATA_INVALID : roi.h
  • ROI_DATA_MARGINAL : roi.h
  • ROI_DLG_FOCUS_END : roi.h
  • ROI_DLG_FOCUS_NONE : roi.h
  • ROI_DLG_FOCUS_START : roi.h
  • RoiDataKind : roi.h
  • RoiFocus : roi.h
  • RS232 : DP5Protocol.h
  • RS232_TIMEOUT : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- s -

  • s : SCommon.h , vcDP5.cpp
  • SCALE_TYPE : STypes.h
  • SCREEN_SCALE : STypes.h
  • SHORT_PACKET_TERMINATE : WINUSBIO.H
  • SIZEOF_GAIN_ARRAY : DppGain.h
  • SMOOTH_TYPE : STypes.h
  • SocketOwnerType : DppSocket.h
  • sockownMainDlg : DppSocket.h
  • sockownNone : DppSocket.h
  • sockownStartDlg : DppSocket.h
  • SOLID_PLOT_TYPE : vcDP5Dlg.h
  • SpectrumFileType : vcDP5Dlg.h
  • SQRT_SCALE : STypes.h
  • STATUS_PACKET_SIZE : DppLibUsb.h
  • SUSPEND_DELAY : WINUSBIO.H
  • SYNC1_ : DP5Protocol.h
  • SYNC2_ : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- t -

  • Text : Label.h
  • TEXT_VIS : DP5ControlUtil.h
  • theApp : vcDP5.h , vcDP5.cpp
  • THREE_SMOOTH : STypes.h
  • TIMEOUT_MS : DppLibUsb.h
  • TIMER_ID : AnimWnd.h
  • TOLONG : STypes.h
  • TOULONG : STypes.h
  • TRANSMIT_PACKET_TYPE : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- u -

  • UNIT_INIT : DP5ControlUtil.h
  • UNIT_VIS : DP5ControlUtil.h
  • USB : DP5Protocol.h
  • USB_BUFFER_SIZE : DppConfig.h
  • USB_CFG_IN_SIZE : DppConfig.h
  • USB_DiagDataDelayMS : DP5Protocol.h
  • USB_SCOPE_SIZE : DppConfig.h
  • USB_TIMEOUT : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- v -

  • VC_EXTRALEAN : StdAfx.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- w -

  • Whitespace : AsciiCmdUtilities.h
  • WinUsb_AbortPipe() : WINUSB.H
  • WinUsb_ControlTransfer() : WINUSB.H
  • WinUsb_FlushPipe() : WINUSB.H
  • WinUsb_Free() : WINUSB.H
  • WinUsb_GetAssociatedInterface() : WINUSB.H
  • WinUsb_GetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_GetDescriptor() : WINUSB.H
  • WinUsb_GetOverlappedResult() : WINUSB.H
  • WinUsb_GetPipePolicy() : WINUSB.H
  • WinUsb_GetPowerPolicy() : WINUSB.H
  • WinUsb_Initialize() : WINUSB.H
  • WINUSB_INTERFACE_HANDLE : WINUSB.H
  • WinUsb_ParseConfigurationDescriptor() : WINUSB.H
  • WinUsb_ParseDescriptors() : WINUSB.H
  • WINUSB_PIPE_INFORMATION : WINUSBIO.H
  • WinUsb_QueryDeviceInformation() : WINUSB.H
  • WinUsb_QueryInterfaceSettings() : WINUSB.H
  • WinUsb_QueryPipe() : WINUSB.H
  • WinUsb_ReadPipe() : WINUSB.H
  • WinUsb_ResetPipe() : WINUSB.H
  • WinUsb_SetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_SetPipePolicy() : WINUSB.H
  • WinUsb_SetPowerPolicy() : WINUSB.H
  • WINUSB_SETUP_PACKET : WINUSB.H
  • WinUsb_WritePipe() : WINUSB.H
  • WinUsbDP5 : DppWinUSB.h
  • WinUsbDP5Size : DppWinUSB.h
  • WinUSBService : DppWinUSB.h
  • WM_DPPCOMM_RCV_CHAR : DppComm.h
  • WM_DPPSOCKET_RCV_BUFFER : DppSocket.h
  • WM_SETPAGEFOCUS : SCommon.h
  • WM_USER_COARSE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_DPP_AUTO_FAST_THESHOLD : UserMsgs.h
  • WM_USER_DPP_AUTO_SLOW_THESHOLD : UserMsgs.h
  • WM_USER_FINE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_FPGUI_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_LOAD_FILE : UserMsgs.h
  • WM_USER_PMCA_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG_EX : UserMsgs.h
  • WM_USER_READ_SCA_CONFIG : UserMsgs.h
  • WM_USER_REPEAT_MEASUREMENT : UserMsgs.h
  • WM_USER_SAVE_CONFIG_TO_FILE : UserMsgs.h
  • WM_USER_SEND_CONFIG_TO_HW : UserMsgs.h
  • WM_USER_SHOW_CONNECT_DIALOG : UserMsgs.h
  • WM_USER_SHOW_SPECTRA_LIST_DLG : UserMsgs.h
  • WM_USER_UPDATE_MENU : UserMsgs.h
  • WM_USER_UPDATE_STATUS_BAR : UserMsgs.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- x -

  • XMTPT_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • XMTPT_AU34_2_RESTART : DP5Protocol.h
  • XMTPT_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • XMTPT_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • XMTPT_BUFFER_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_BUFFER_SPECTRUM : DP5Protocol.h
  • XMTPT_CLEAR_GP_COUNTER : DP5Protocol.h
  • XMTPT_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • XMTPT_DISABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ENABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ERASE_FPGA_IMAGE : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_FORCE_SCOPE_TRIGGER : DP5Protocol.h
  • XMTPT_FULL_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • XMTPT_LATCH_SEND_SCA : DP5Protocol.h
  • XMTPT_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_READ_IO3_0 : DP5Protocol.h
  • XMTPT_READ_MCA8000D_OPTION_PA_CAL : DP5Protocol.h
  • XMTPT_REINITIALIZE_FPGA : DP5Protocol.h
  • XMTPT_REQ_ACK_PACKET : DP5Protocol.h
  • XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS : DP5Protocol.h
  • XMTPT_SCA_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_SEND_BUFFER : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_TO_HW : DP5Protocol.h
  • XMTPT_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • XMTPT_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • XMTPT_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • XMTPT_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • XMTPT_SEND_NETFINDER_PACKET : DP5Protocol.h
  • XMTPT_SEND_PX4_CONFIG : DP5Protocol.h
  • XMTPT_SEND_ROI_OR_FIXED_BLOCK : DP5Protocol.h
  • XMTPT_SEND_SCA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_STATUS : DP5Protocol.h
  • XMTPT_SEND_TEST_PACKET : DP5Protocol.h
  • XMTPT_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • XMTPT_SET_BOOT_FLAGS : DP5Protocol.h
  • XMTPT_SET_DCAL : DP5Protocol.h
  • XMTPT_SET_HV_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_INPUT_OFFSET_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • XMTPT_SET_SERIAL_NUMBER : DP5Protocol.h
  • XMTPT_SET_SPECTRUM_OFFSET : DP5Protocol.h
  • XMTPT_SET_TEC_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SWITCH_SUPPLIES : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_UC_FPGA_CHECKSUMS : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_UC : DP5Protocol.h
  • XMTPT_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_WRITE_IO3_0 : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • DEFINE_GUID() : guid.h , WINUSBIO.H , guid.h
  • EnumChildControls() : FilePage.cpp
  • WinUsb_AbortPipe() : WINUSB.H
  • WinUsb_ControlTransfer() : WINUSB.H
  • WinUsb_FlushPipe() : WINUSB.H
  • WinUsb_Free() : WINUSB.H
  • WinUsb_GetAssociatedInterface() : WINUSB.H
  • WinUsb_GetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_GetDescriptor() : WINUSB.H
  • WinUsb_GetOverlappedResult() : WINUSB.H
  • WinUsb_GetPipePolicy() : WINUSB.H
  • WinUsb_GetPowerPolicy() : WINUSB.H
  • WinUsb_Initialize() : WINUSB.H
  • WinUsb_ParseConfigurationDescriptor() : WINUSB.H
  • WinUsb_ParseDescriptors() : WINUSB.H
  • WinUsb_QueryDeviceInformation() : WINUSB.H
  • WinUsb_QueryInterfaceSettings() : WINUSB.H
  • WinUsb_QueryPipe() : WINUSB.H
  • WinUsb_ReadPipe() : WINUSB.H
  • WinUsb_ResetPipe() : WINUSB.H
  • WinUsb_SetCurrentAlternateSetting() : WINUSB.H
  • WinUsb_SetPipePolicy() : WINUSB.H
  • WinUsb_SetPowerPolicy() : WINUSB.H
  • WinUsb_WritePipe() : WINUSB.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • c
  • d
  • m
  • n
  • r
  • s
  • t

- c -

  • colorAliceBlue : X11Color.h
  • colorAmptekBlue : X11Color.h
  • colorAntiqueWhite : X11Color.h
  • colorAqua : X11Color.h
  • colorAquamarine : X11Color.h
  • colorAzure : X11Color.h
  • colorBeige : X11Color.h
  • colorBisque : X11Color.h
  • colorBlack : X11Color.h
  • colorBlanchedAlmond : X11Color.h
  • colorBlue : X11Color.h
  • colorBlueViolet : X11Color.h
  • colorBrown : X11Color.h
  • colorBurlyWood : X11Color.h
  • colorCadetBlue : X11Color.h
  • colorChartreuse : X11Color.h
  • colorChocolate : X11Color.h
  • colorCoral : X11Color.h
  • colorCornflowerBlue : X11Color.h
  • colorCornsilk : X11Color.h
  • colorCrimson : X11Color.h
  • colorCyan : X11Color.h
  • colorDarkBlue : X11Color.h
  • colorDarkCyan : X11Color.h
  • colorDarkGoldenrod : X11Color.h
  • colorDarkGray : X11Color.h
  • colorDarkGreen : X11Color.h
  • colorDarkKhaki : X11Color.h
  • colorDarkMagenta : X11Color.h
  • colorDarkOliveGreen : X11Color.h
  • colorDarkOrange : X11Color.h
  • colorDarkOrchid : X11Color.h
  • colorDarkRed : X11Color.h
  • colorDarkSalmon : X11Color.h
  • colorDarkSeaGreen : X11Color.h
  • colorDarkSlateBlue : X11Color.h
  • colorDarkSlateGray : X11Color.h
  • colorDarkTurquoise : X11Color.h
  • colorDarkViolet : X11Color.h
  • colorDeepPink : X11Color.h
  • colorDeepSkyBlue : X11Color.h
  • colorDimGray : X11Color.h
  • colorDodgerBlue : X11Color.h
  • colorFireBrick : X11Color.h
  • colorFloralWhite : X11Color.h
  • colorForestGreen : X11Color.h
  • colorFuchsia : X11Color.h
  • colorGainsboro : X11Color.h
  • colorGhostWhite : X11Color.h
  • colorGold : X11Color.h
  • colorGoldenrod : X11Color.h
  • colorGray : X11Color.h
  • colorGreen : X11Color.h
  • colorGreenYellow : X11Color.h
  • colorHoneydew : X11Color.h
  • colorHotPink : X11Color.h
  • colorIndianRed : X11Color.h
  • colorIndigo : X11Color.h
  • colorIvory : X11Color.h
  • colorKhaki : X11Color.h
  • colorLavender : X11Color.h
  • colorLavenderBlush : X11Color.h
  • colorLawnGreen : X11Color.h
  • colorLemonChiffon : X11Color.h
  • colorLightBlue : X11Color.h
  • colorLightCoral : X11Color.h
  • colorLightCyan : X11Color.h
  • colorLightGoldenrodYellow : X11Color.h
  • colorLightGray : X11Color.h
  • colorLightGreen : X11Color.h
  • colorLightGrey : X11Color.h
  • colorLightPink : X11Color.h
  • colorLightSalmon : X11Color.h
  • colorLightSeaGreen : X11Color.h
  • colorLightSkyBlue : X11Color.h
  • colorLightSlateGray : X11Color.h
  • colorLightSteelBlue : X11Color.h
  • colorLightYellow : X11Color.h
  • colorLime : X11Color.h
  • colorLimeGreen : X11Color.h
  • colorLinen : X11Color.h
  • colorMagenta : X11Color.h
  • colorMaroon : X11Color.h
  • colorMediumAquamarine : X11Color.h
  • colorMediumBlue : X11Color.h
  • colorMediumOrchid : X11Color.h
  • colorMediumPurple : X11Color.h
  • colorMediumSeaGreen : X11Color.h
  • colorMediumSlateBlue : X11Color.h
  • colorMediumSpringGreen : X11Color.h
  • colorMediumTurquoise : X11Color.h
  • colorMediumVioletRed : X11Color.h
  • colorMidnightBlue : X11Color.h
  • colorMintCream : X11Color.h
  • colorMistyRose : X11Color.h
  • colorMoccasin : X11Color.h
  • colorNavajoWhite : X11Color.h
  • colorNavy : X11Color.h
  • colorOldLace : X11Color.h
  • colorOlive : X11Color.h
  • colorOliveDrab : X11Color.h
  • colorOrange : X11Color.h
  • colorOrangeRed : X11Color.h
  • colorOrchid : X11Color.h
  • colorPaleGoldenrod : X11Color.h
  • colorPaleGreen : X11Color.h
  • colorPaleTurquoise : X11Color.h
  • colorPaleVioletRed : X11Color.h
  • colorPapayaWhip : X11Color.h
  • colorPeachPuff : X11Color.h
  • colorPeru : X11Color.h
  • colorPink : X11Color.h
  • colorPlum : X11Color.h
  • colorPowderBlue : X11Color.h
  • colorPurple : X11Color.h
  • colorRed : X11Color.h
  • colorRosyBrown : X11Color.h
  • colorRoyalBlue : X11Color.h
  • colorSaddleBrown : X11Color.h
  • colorSalmon : X11Color.h
  • colorSandyBrown : X11Color.h
  • colorSeaGreen : X11Color.h
  • colorSeaShell : X11Color.h
  • colorSienna : X11Color.h
  • colorSilver : X11Color.h
  • colorSkyBlue : X11Color.h
  • colorSlateBlue : X11Color.h
  • colorSlateGray : X11Color.h
  • colorSnow : X11Color.h
  • colorSpringGreen : X11Color.h
  • colorSteelBlue : X11Color.h
  • colorTan : X11Color.h
  • colorTeal : X11Color.h
  • colorThistle : X11Color.h
  • colorTomato : X11Color.h
  • colorTurquoise : X11Color.h
  • colorViolet : X11Color.h
  • colorWheat : X11Color.h
  • colorWhite : X11Color.h
  • colorWhiteSmoke : X11Color.h
  • colorYellow : X11Color.h
  • colorYellowGreen : X11Color.h

- d -

  • DP5_TO_PX4_CONTROL_INDEX : DppConfig.h

- m -

  • MAX_ENTRIES : NetFinder.h

- n -

  • NO_ENTRIES : NetFinder.h

- r -

  • regDP5Comm : SCommon.h
  • regDP5Config : SCommon.h
  • regDP5Device : SCommon.h

- s -

  • s : SCommon.h , vcDP5.cpp

- t -

  • theApp : vcDP5.cpp , vcDP5.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • CommType : ParsePacket.h
  • CONFIG_OPTIONS : SendCommand.h
  • COORD_LONG : PlotCanvas.h
  • DEVICE_INFO : DppWinUSB.h
  • DiagDataType : DP5Status.h
  • DP4_FORMAT_STATUS : DP5Status.h
  • DP5_CMD_INDEX : DP5ControlUtil.h
  • DP5_CONFIGURATION : DP5ControlUtil.h
  • DP5_CTRL_GROUP : DP5ControlUtil.h
  • DP5_CTRL_TYPE : DP5ControlUtil.h
  • DP5_DATA_ID : DP5ControlUtil.h
  • dp5DppTypes : DppConst.h
  • DPP_USB_STATUS : DppWinUSB.h
  • DppAGainTable : DppGain.h
  • DppStateType : ParsePacket.h
  • NETDISPLAY_ENTRY : NetFinder.h
  • Packet_In : DP5Protocol.h
  • PDDiagDataType : DP5Status.h
  • PDEVICE_INFO : DppWinUSB.h
  • PDP4_FORMAT_STATUS : DP5Status.h
  • PWINUSB_INTERFACE_HANDLE : WINUSB.H
  • PWINUSB_PIPE_INFORMATION : WINUSBIO.H
  • PWINUSB_SETUP_PACKET : WINUSB.H
  • PX5_OPTIONS : DP5Status.h
  • SocketOwnerType : DppSocket.h
  • SpectrumFileType : vcDP5Dlg.h
  • WINUSB_INTERFACE_HANDLE : WINUSB.H
  • WINUSB_PIPE_INFORMATION : WINUSBIO.H
  • WINUSB_SETUP_PACKET : WINUSB.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _CommType : ParsePacket.h
  • _DP5_CMD_INDEX : DP5ControlUtil.h
  • _DP5_CTRL_GROUP : DP5ControlUtil.h
  • _DP5_CTRL_TYPE : DP5ControlUtil.h
  • _DP5_DATA_ID : DP5ControlUtil.h
  • _DPP_USB_STATUS : DppWinUSB.h
  • _DppAGainTable : DppGain.h
  • _PX5_OPTIONS : DP5Status.h
  • _SocketOwnerType : DppSocket.h
  • DP5_DPP_TYPES : DppConst.h
  • FlashType : Label.h
  • GAIN_TYPE : STypes.h
  • PID1_TYPE : DP5Protocol.h
  • PID2_ACK_TYPE : DP5Protocol.h
  • PID2_RCV_SCA_TYPE : DP5Protocol.h
  • PID2_RCV_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_RCV_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_RCV_STATUS_TYPE : DP5Protocol.h
  • PID2_REQ_CONFIG_TYPE : DP5Protocol.h
  • PID2_REQ_FPGA_UC_TYPE : DP5Protocol.h
  • PID2_REQ_SCA_TYPE : DP5Protocol.h
  • PID2_REQ_SCOPE_MISC_TYPE : DP5Protocol.h
  • PID2_REQ_SPECTRUM_TYPE : DP5Protocol.h
  • PID2_REQ_STATUS_TYPE : DP5Protocol.h
  • PID2_VENDOR_REQ_TYPE : DP5Protocol.h
  • RoiDataKind : roi.h
  • RoiFocus : roi.h
  • SCALE_TYPE : STypes.h
  • SMOOTH_TYPE : STypes.h
  • TRANSMIT_PACKET_TYPE : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- b -

  • Background : Label.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- c -

  • commNone : ParsePacket.h
  • commRS232 : ParsePacket.h
  • commSockets : ParsePacket.h
  • commUSB : ParsePacket.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- d -

  • dagtDP5 : DppGain.h
  • dagtDP5Dx : DppGain.h
  • dagtDP5G : DppGain.h
  • dagtDP5X : DppGain.h
  • dagtMCA8000D : DppGain.h
  • dagtPX5 : DppGain.h
  • dagtTB5 : DppGain.h
  • dcgBootOpt : DP5ControlUtil.h
  • dcgFile : DP5ControlUtil.h
  • dcgGainPZ : DP5ControlUtil.h
  • dcgMCA : DP5ControlUtil.h
  • dcgMisc : DP5ControlUtil.h
  • dcgPower : DP5ControlUtil.h
  • dcgShaping : DP5ControlUtil.h
  • dciAINP : DP5ControlUtil.h
  • dciAUO1 : DP5ControlUtil.h
  • dciAUO2 : DP5ControlUtil.h
  • dciBLRD : DP5ControlUtil.h
  • dciBLRM : DP5ControlUtil.h
  • dciBLRU : DP5ControlUtil.h
  • dciBOOT : DP5ControlUtil.h
  • dciCLCK : DP5ControlUtil.h
  • dciCON1 : DP5ControlUtil.h
  • dciCON2 : DP5ControlUtil.h
  • dciCUSP : DP5ControlUtil.h
  • dciDACF : DP5ControlUtil.h
  • dciDACO : DP5ControlUtil.h
  • dciGAIA : DP5ControlUtil.h
  • dciGAIF : DP5ControlUtil.h
  • dciGAIN : DP5ControlUtil.h
  • dciGATE : DP5ControlUtil.h
  • dciGPED : DP5ControlUtil.h
  • dciGPGA : DP5ControlUtil.h
  • dciGPIN : DP5ControlUtil.h
  • dciGPMC : DP5ControlUtil.h
  • dciGPME : DP5ControlUtil.h
  • dciHVSE : DP5ControlUtil.h
  • dciINOF : DP5ControlUtil.h
  • dciMCAC : DP5ControlUtil.h
  • dciMCAE : DP5ControlUtil.h
  • dciMCAS : DP5ControlUtil.h
  • dciMCSH : DP5ControlUtil.h
  • dciMCSL : DP5ControlUtil.h
  • dciMCST : DP5ControlUtil.h
  • dciPAPS : DP5ControlUtil.h
  • dciPAPZ : DP5ControlUtil.h
  • dciPDMD : DP5ControlUtil.h
  • dciPRCH : DP5ControlUtil.h
  • dciPRCL : DP5ControlUtil.h
  • dciPREC : DP5ControlUtil.h
  • dciPREL : DP5ControlUtil.h
  • dciPRER : DP5ControlUtil.h
  • dciPRET : DP5ControlUtil.h
  • dciPURE : DP5ControlUtil.h
  • dciRESC : DP5ControlUtil.h
  • dciRESL : DP5ControlUtil.h
  • dciRTDE : DP5ControlUtil.h
  • dciRTDS : DP5ControlUtil.h
  • dciRTDT : DP5ControlUtil.h
  • dciSCOE : DP5ControlUtil.h
  • dciSCOG : DP5ControlUtil.h
  • dciSCOT : DP5ControlUtil.h
  • dciSCTC : DP5ControlUtil.h
  • dciSOFF : DP5ControlUtil.h
  • dciTECS : DP5ControlUtil.h
  • dciTFLA : DP5ControlUtil.h
  • dciTHFA : DP5ControlUtil.h
  • dciTHSL : DP5ControlUtil.h
  • dciTLLD : DP5ControlUtil.h
  • dciTPEA : DP5ControlUtil.h
  • dciTPFA : DP5ControlUtil.h
  • dciTPMO : DP5ControlUtil.h
  • dciVOLU : DP5ControlUtil.h
  • dctCbo : DP5ControlUtil.h
  • dctCboTxt : DP5ControlUtil.h
  • dctNone : DP5ControlUtil.h
  • dctTxt : DP5ControlUtil.h
  • ddiComboIndex : DP5ControlUtil.h
  • ddiComboValue : DP5ControlUtil.h
  • ddiCommand : DP5ControlUtil.h
  • ddiComments : DP5ControlUtil.h
  • ddiCtrlGroup : DP5ControlUtil.h
  • ddiCtrlType : DP5ControlUtil.h
  • ddiDescription : DP5ControlUtil.h
  • ddiListCtrlID : DP5ControlUtil.h
  • ddiTextCtrlID : DP5ControlUtil.h
  • ddiTextValue : DP5ControlUtil.h
  • ddiUnits : DP5ControlUtil.h
  • dppDP5 : DppConst.h
  • dppDP5G : DppConst.h
  • dppDP5X : DppConst.h
  • dppMCA8000D : DppConst.h
  • dppPX5 : DppConst.h
  • dppTB5 : DppConst.h
  • dusbStatConnectFail : DppWinUSB.h
  • dusbStatNewConnect : DppWinUSB.h
  • dusbStatNoAction : DppWinUSB.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- f -

  • FIVE_SMOOTH : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- g -

  • GAIN_1024 : STypes.h
  • GAIN_16384 : STypes.h
  • GAIN_2048 : STypes.h
  • GAIN_256 : STypes.h
  • GAIN_4096 : STypes.h
  • GAIN_512 : STypes.h
  • GAIN_8192 : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- i -

  • INVALID_SMOOTH : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- l -

  • LIN_SCALE : STypes.h
  • LOG_SCALE : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- n -

  • NO_SMOOTH : STypes.h
  • None : Label.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- p -

  • PID1_ACK : DP5Protocol.h
  • PID1_COMM_TEST : DP5Protocol.h
  • PID1_RCV_SCA : DP5Protocol.h
  • PID1_RCV_SCOPE_MISC : DP5Protocol.h
  • PID1_RCV_SPECTRUM : DP5Protocol.h
  • PID1_RCV_STATUS : DP5Protocol.h
  • PID1_REQ_CONFIG : DP5Protocol.h
  • PID1_REQ_FPGA_UC : DP5Protocol.h
  • PID1_REQ_SCA : DP5Protocol.h
  • PID1_REQ_SCOPE_MISC : DP5Protocol.h
  • PID1_REQ_SPECTRUM : DP5Protocol.h
  • PID1_REQ_STATUS : DP5Protocol.h
  • PID1_VENDOR_REQ : DP5Protocol.h
  • PID2_ACK_BAD_HEX_REC : DP5Protocol.h
  • PID2_ACK_BAD_PARAM : DP5Protocol.h
  • PID2_ACK_CAL_DATA_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_CHECKSUM_ERROR : DP5Protocol.h
  • PID2_ACK_CP2201_NOT_FOUND : DP5Protocol.h
  • PID2_ACK_ETHERNET_BUSY : DP5Protocol.h
  • PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED : DP5Protocol.h
  • PID2_ACK_FPGA_ERROR : DP5Protocol.h
  • PID2_ACK_I2C_ERROR : DP5Protocol.h
  • PID2_ACK_LEN_ERROR : DP5Protocol.h
  • PID2_ACK_OK : DP5Protocol.h
  • PID2_ACK_OK_ETHERNET_SHARE_REQ : DP5Protocol.h
  • PID2_ACK_OK_FPGA_UPLOAD_ADDR : DP5Protocol.h
  • PID2_ACK_PC5_NOT_PRESENT : DP5Protocol.h
  • PID2_ACK_PID_ERROR : DP5Protocol.h
  • PID2_ACK_SCOPE_DATA_NOT_AVAIL : DP5Protocol.h
  • PID2_ACK_SYNC_ERROR : DP5Protocol.h
  • PID2_ACK_UNRECOG : DP5Protocol.h
  • PID2_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • PID2_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • PID2_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • PID2_CLEAR_GP_COUNTER : DP5Protocol.h
  • PID2_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • PID2_CONFIG_READBACK_PACKET : DP5Protocol.h
  • PID2_DISABLE_MCA_MCS : DP5Protocol.h
  • PID2_ENABLE_MCA_MCS : DP5Protocol.h
  • PID2_ERASE_FPGA_IMAGE : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • PID2_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • PID2_ETHERNET_ALLOW_SHAREING : DP5Protocol.h
  • PID2_ETHERNET_LOCK_IP : DP5Protocol.h
  • PID2_ETHERNET_NO_SHARING : DP5Protocol.h
  • PID2_GENERIC_FPGA_WRITE : DP5Protocol.h
  • PID2_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • PID2_LATCH_SEND_SCA : DP5Protocol.h
  • PID2_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • PID2_READ_IO3_0 : DP5Protocol.h
  • PID2_REINITIALIZE_FPGA : DP5Protocol.h
  • PID2_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • PID2_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • PID2_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • PID2_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • PID2_SEND_I2C_DATA : DP5Protocol.h
  • PID2_SEND_LIST_MODE_DATA : DP5Protocol.h
  • PID2_SEND_NETFINDER_READBACK : DP5Protocol.h
  • PID2_SEND_OPTION_PA_CALIBRATION : DP5Protocol.h
  • PID2_SEND_SCA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA : DP5Protocol.h
  • PID2_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • PID2_SEND_SPECTRUM : DP5Protocol.h
  • PID2_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • PID2_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • PID2_SET_BOOT_FLAGS : DP5Protocol.h
  • PID2_SET_DCAL : DP5Protocol.h
  • PID2_SET_ETHERNET_SETTINGS : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • PID2_SET_SERIAL_NUMBER : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • PID2_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • PID2_TEXT_CONFIG_PACKET : DP5Protocol.h
  • PID2_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • PID2_UPLOAD_PACKET_UC : DP5Protocol.h
  • PID2_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • PID2_WRITE_IO3_0 : DP5Protocol.h
  • PX5_OPTION_HPGe_HVPS : DP5Status.h
  • PX5_OPTION_NONE : DP5Status.h
  • PX5_OPTION_TEST_AMP : DP5Status.h
  • PX5_OPTION_TEST_MODE_1 : DP5Status.h
  • PX5_OPTION_TEST_MODE_2 : DP5Status.h
  • PX5_OPTION_TEST_MOX : DP5Status.h
  • PX5_OPTION_TEST_TEK : DP5Status.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- r -

  • RCVPT_1024_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_1024_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_2048_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_256_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_4096_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_512_BYTE_MISC_DATA : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_512_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM : DP5Protocol.h
  • RCVPT_8192_CHANNEL_SPECTRUM_STATUS : DP5Protocol.h
  • RCVPT_CONFIG_READBACK : DP5Protocol.h
  • RCVPT_DIAGNOSTIC_DATA : DP5Protocol.h
  • RCVPT_DP4_STYLE_STATUS : DP5Protocol.h
  • RCVPT_ETHERNET_SETTINGS : DP5Protocol.h
  • RCVPT_HARDWARE_DESCRIPTION : DP5Protocol.h
  • RCVPT_I2C_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA : DP5Protocol.h
  • RCVPT_LIST_MODE_DATA_FIFO_FULL : DP5Protocol.h
  • RCVPT_NETFINDER_READBACK : DP5Protocol.h
  • RCVPT_OPTION_PA_CALIBRATION : DP5Protocol.h
  • RCVPT_SCA : DP5Protocol.h
  • RCVPT_SCOPE_DATA : DP5Protocol.h
  • RCVPT_SCOPE_DATA_WITH_OVERFLOW : DP5Protocol.h
  • ROI_DATA_BAD : roi.h
  • ROI_DATA_GOOD : roi.h
  • ROI_DATA_INVALID : roi.h
  • ROI_DATA_MARGINAL : roi.h
  • ROI_DLG_FOCUS_END : roi.h
  • ROI_DLG_FOCUS_NONE : roi.h
  • ROI_DLG_FOCUS_START : roi.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- s -

  • sockownMainDlg : DppSocket.h
  • sockownNone : DppSocket.h
  • sockownStartDlg : DppSocket.h
  • SQRT_SCALE : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- t -

  • Text : Label.h
  • THREE_SMOOTH : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • n
  • p
  • r
  • s
  • t
  • x

- x -

  • XMTPT_ARM_DIGITAL_OSCILLOSCOPE : DP5Protocol.h
  • XMTPT_AU34_2_RESTART : DP5Protocol.h
  • XMTPT_AUTOSET_FAST_THRESHOLD : DP5Protocol.h
  • XMTPT_AUTOSET_INPUT_OFFSET : DP5Protocol.h
  • XMTPT_BUFFER_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_BUFFER_SPECTRUM : DP5Protocol.h
  • XMTPT_CLEAR_GP_COUNTER : DP5Protocol.h
  • XMTPT_CLEAR_SPECTRUM_BUFFER_A : DP5Protocol.h
  • XMTPT_DISABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ENABLE_MCA_MCS : DP5Protocol.h
  • XMTPT_ERASE_FPGA_IMAGE : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_ERASE_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_FORCE_SCOPE_TRIGGER : DP5Protocol.h
  • XMTPT_FULL_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_LATCH_CLEAR_SEND_SCA : DP5Protocol.h
  • XMTPT_LATCH_SEND_SCA : DP5Protocol.h
  • XMTPT_PX4_STYLE_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_READ_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_READ_IO3_0 : DP5Protocol.h
  • XMTPT_READ_MCA8000D_OPTION_PA_CAL : DP5Protocol.h
  • XMTPT_REINITIALIZE_FPGA : DP5Protocol.h
  • XMTPT_REQ_ACK_PACKET : DP5Protocol.h
  • XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS : DP5Protocol.h
  • XMTPT_SCA_READ_CONFIG_PACKET : DP5Protocol.h
  • XMTPT_SEND_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_SEND_BUFFER : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_CLEAR_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_EX : DP5Protocol.h
  • XMTPT_SEND_CONFIG_PACKET_TO_HW : DP5Protocol.h
  • XMTPT_SEND_DIAGNOSTIC_DATA : DP5Protocol.h
  • XMTPT_SEND_DP4_STYLE_STATUS : DP5Protocol.h
  • XMTPT_SEND_ETHERNET_SETTINGS : DP5Protocol.h
  • XMTPT_SEND_HARDWARE_DESCRIPTION : DP5Protocol.h
  • XMTPT_SEND_NETFINDER_PACKET : DP5Protocol.h
  • XMTPT_SEND_PX4_CONFIG : DP5Protocol.h
  • XMTPT_SEND_ROI_OR_FIXED_BLOCK : DP5Protocol.h
  • XMTPT_SEND_SCA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA : DP5Protocol.h
  • XMTPT_SEND_SCOPE_DATA_REARM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM : DP5Protocol.h
  • XMTPT_SEND_SPECTRUM_STATUS : DP5Protocol.h
  • XMTPT_SEND_STATUS : DP5Protocol.h
  • XMTPT_SEND_TEST_PACKET : DP5Protocol.h
  • XMTPT_SET_ADC_CAL_GAIN_OFFSET : DP5Protocol.h
  • XMTPT_SET_BOOT_FLAGS : DP5Protocol.h
  • XMTPT_SET_DCAL : DP5Protocol.h
  • XMTPT_SET_HV_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_INPUT_OFFSET_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ : DP5Protocol.h
  • XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC : DP5Protocol.h
  • XMTPT_SET_SERIAL_NUMBER : DP5Protocol.h
  • XMTPT_SET_SPECTRUM_OFFSET : DP5Protocol.h
  • XMTPT_SET_TEC_DP4_EMULATION : DP5Protocol.h
  • XMTPT_SWITCH_SUPPLIES : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_0 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_1 : DP5Protocol.h
  • XMTPT_SWITCH_TO_UC_IMAGE_2 : DP5Protocol.h
  • XMTPT_UC_FPGA_CHECKSUMS : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_FPGA : DP5Protocol.h
  • XMTPT_UPLOAD_PACKET_UC : DP5Protocol.h
  • XMTPT_WRITE_512_BYTE_MISC_DATA : DP5Protocol.h
  • XMTPT_WRITE_IO3_0 : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- _ -

  • _CRT_SECURE_NO_DEPRECATE : StdAfx.h
  • _SETUPAPI_VER : StdAfx.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ACK : DP5Protocol.h
  • AFX_HIDD_BUSY : HTMLDefines.h
  • AFX_HIDD_CHANGEICON : HTMLDefines.h
  • AFX_HIDD_CHANGESOURCE : HTMLDefines.h
  • AFX_HIDD_COLOR : HTMLDefines.h
  • AFX_HIDD_CONVERT : HTMLDefines.h
  • AFX_HIDD_EDITLINKS : HTMLDefines.h
  • AFX_HIDD_FILEBROWSE : HTMLDefines.h
  • AFX_HIDD_FILEOPEN : HTMLDefines.h
  • AFX_HIDD_FILESAVE : HTMLDefines.h
  • AFX_HIDD_FIND : HTMLDefines.h
  • AFX_HIDD_FONT : HTMLDefines.h
  • AFX_HIDD_INSERTOBJECT : HTMLDefines.h
  • AFX_HIDD_NEWTYPEDLG : HTMLDefines.h
  • AFX_HIDD_OBJECTPROPERTIES : HTMLDefines.h
  • AFX_HIDD_PASTESPECIAL : HTMLDefines.h
  • AFX_HIDD_PREVIEW_SHORTTOOLBAR : HTMLDefines.h
  • AFX_HIDD_PREVIEW_TOOLBAR : HTMLDefines.h
  • AFX_HIDD_PRINT : HTMLDefines.h
  • AFX_HIDD_PRINTDLG : HTMLDefines.h
  • AFX_HIDD_PRINTSETUP : HTMLDefines.h
  • AFX_HIDD_REPLACE : HTMLDefines.h
  • AFX_HIDP_ARCH_BADCLASS : HTMLDefines.h
  • AFX_HIDP_ARCH_BADINDEX : HTMLDefines.h
  • AFX_HIDP_ARCH_BADSCHEMA : HTMLDefines.h
  • AFX_HIDP_ARCH_ENDOFFILE : HTMLDefines.h
  • AFX_HIDP_ARCH_GENERIC : HTMLDefines.h
  • AFX_HIDP_ARCH_NONE : HTMLDefines.h
  • AFX_HIDP_ARCH_READONLY : HTMLDefines.h
  • AFX_HIDP_ARCH_WRITEONLY : HTMLDefines.h
  • AFX_HIDP_ASK_TO_DISCARD : HTMLDefines.h
  • AFX_HIDP_ASK_TO_SAVE : HTMLDefines.h
  • AFX_HIDP_ASK_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_BAD_VERB : HTMLDefines.h
  • AFX_HIDP_COMMAND_FAILURE : HTMLDefines.h
  • AFX_HIDP_DAO_BADBINDINFO : HTMLDefines.h
  • AFX_HIDP_DAO_COLUMNUNAVAILABLE : HTMLDefines.h
  • AFX_HIDP_DAO_DFX_BIND : HTMLDefines.h
  • AFX_HIDP_DAO_ENGINE_INITIALIZATION : HTMLDefines.h
  • AFX_HIDP_DAO_OBJECT_NOT_OPEN : HTMLDefines.h
  • AFX_HIDP_DAO_ROWTOOSHORT : HTMLDefines.h
  • AFX_HIDP_DLL_BAD_VERSION : HTMLDefines.h
  • AFX_HIDP_DLL_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_ACCESS_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_DISK_FULL : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_FORMAT : HTMLDefines.h
  • AFX_HIDP_FAILED_INVALID_PATH : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_READ : HTMLDefines.h
  • AFX_HIDP_FAILED_IO_ERROR_WRITE : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_LOAD : HTMLDefines.h
  • AFX_HIDP_FAILED_MAPI_SEND : HTMLDefines.h
  • AFX_HIDP_FAILED_MEMORY_ALLOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_AUTO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONNECT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CONVERT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_CREATE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_LAUNCH_HELP : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_NOTIFY : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_OPEN_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_REGISTER : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_SAVE_DOC : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_START_PRINT : HTMLDefines.h
  • AFX_HIDP_FAILED_TO_UPDATE : HTMLDefines.h
  • AFX_HIDP_FILE_ACCESS_DENIED : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_PATH : HTMLDefines.h
  • AFX_HIDP_FILE_BAD_SEEK : HTMLDefines.h
  • AFX_HIDP_FILE_DIR_FULL : HTMLDefines.h
  • AFX_HIDP_FILE_DISKFULL : HTMLDefines.h
  • AFX_HIDP_FILE_EOF : HTMLDefines.h
  • AFX_HIDP_FILE_GENERIC : HTMLDefines.h
  • AFX_HIDP_FILE_HARD_IO : HTMLDefines.h
  • AFX_HIDP_FILE_INVALID_FILE : HTMLDefines.h
  • AFX_HIDP_FILE_LOCKING : HTMLDefines.h
  • AFX_HIDP_FILE_NONE : HTMLDefines.h
  • AFX_HIDP_FILE_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_FILE_REMOVE_CURRENT : HTMLDefines.h
  • AFX_HIDP_FILE_SHARING : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_LARGE : HTMLDefines.h
  • AFX_HIDP_FILE_TOO_MANY_OPEN : HTMLDefines.h
  • AFX_HIDP_GET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_INTERNAL_FAILURE : HTMLDefines.h
  • AFX_HIDP_INVALID_FILENAME : HTMLDefines.h
  • AFX_HIDP_INVALID_MAPI_DLL : HTMLDefines.h
  • AFX_HIDP_NO_ERROR_AVAILABLE : HTMLDefines.h
  • AFX_HIDP_PARSE_BYTE : HTMLDefines.h
  • AFX_HIDP_PARSE_CURRENCY : HTMLDefines.h
  • AFX_HIDP_PARSE_DATETIME : HTMLDefines.h
  • AFX_HIDP_PARSE_INT : HTMLDefines.h
  • AFX_HIDP_PARSE_INT_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_RADIO_BUTTON : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL : HTMLDefines.h
  • AFX_HIDP_PARSE_REAL_RANGE : HTMLDefines.h
  • AFX_HIDP_PARSE_STRING_SIZE : HTMLDefines.h
  • AFX_HIDP_PARSE_UINT : HTMLDefines.h
  • AFX_HIDP_SERVER_BUSY : HTMLDefines.h
  • AFX_HIDP_SET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_API_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED : HTMLDefines.h
  • AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_CONNECT_FAIL : HTMLDefines.h
  • AFX_HIDP_SQL_DATA_TRUNCATED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_EMPTY_COLUMN_LIST : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_NOT_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH : HTMLDefines.h
  • AFX_HIDP_SQL_ILLEGAL_MODE : HTMLDefines.h
  • AFX_HIDP_SQL_INCORRECT_ODBC : HTMLDefines.h
  • AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_NO_CURRENT_RECORD : HTMLDefines.h
  • AFX_HIDP_SQL_NO_DATA_FOUND : HTMLDefines.h
  • AFX_HIDP_SQL_NO_POSITIONED_UPDATES : HTMLDefines.h
  • AFX_HIDP_SQL_NO_ROWS_AFFECTED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_LOAD_FAILED : HTMLDefines.h
  • AFX_HIDP_SQL_ODBC_V2_REQUIRED : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY : HTMLDefines.h
  • AFX_HIDP_SQL_RECORDSET_READONLY : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_FETCH : HTMLDefines.h
  • AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_CONFORMANCE : HTMLDefines.h
  • AFX_HIDP_SQL_SQL_NO_TOTAL : HTMLDefines.h
  • AFX_HIDP_SQL_UPDATE_DELETE_FAILED : HTMLDefines.h
  • AFX_HIDP_STATIC_OBJECT : HTMLDefines.h
  • AFX_HIDP_UNREG_DONE : HTMLDefines.h
  • AFX_HIDP_UNREG_FAILURE : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_BOTTOM : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_FLOAT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_LEFT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_RIGHT : HTMLDefines.h
  • AFX_HIDW_DOCKBAR_TOP : HTMLDefines.h
  • AFX_HIDW_PREVIEW_BAR : HTMLDefines.h
  • AFX_HIDW_RESIZE_BAR : HTMLDefines.h
  • AFX_HIDW_STATUS_BAR : HTMLDefines.h
  • AFX_HIDW_TOOLBAR : HTMLDefines.h
  • ALL_VIS : DP5ControlUtil.h
  • ALLOW_PARTIAL_READS : WINUSBIO.H
  • AMPTEK_DP5_PRODUCT_ID : DppLibUsb.h
  • AMPTEK_DP5_VENDOR_ID : DppLibUsb.h
  • AUTO_CLEAR_STALL : WINUSBIO.H
  • AUTO_FLUSH : WINUSBIO.H
  • AUTO_SUSPEND : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BULK_IN_ENDPOINT : DppLibUsb.h
  • BULK_OUT_ENDPOINT : DppLibUsb.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CBO_TEXT_VIS : DP5ControlUtil.h
  • CC_SYSCOLOR : PlotCanvas.h
  • COUNT_OFFSET : DppConfig.h
  • ctrlColBlack : PlotCanvas.h
  • ctrlColBlue : PlotCanvas.h
  • ctrlColBtnFace : PlotCanvas.h
  • ctrlColDefault : PlotCanvas.h
  • ctrlColGray : PlotCanvas.h
  • ctrlColGreen : PlotCanvas.h
  • ctrlColInfoBk : PlotCanvas.h
  • ctrlColInfoText : PlotCanvas.h
  • ctrlColJavaGray : PlotCanvas.h
  • ctrlColLightBlue : PlotCanvas.h
  • ctrlColLightCyan : PlotCanvas.h
  • ctrlColLightGray : PlotCanvas.h
  • ctrlColRed : PlotCanvas.h
  • ctrlColSkyBlue : PlotCanvas.h
  • ctrlColWhite : PlotCanvas.h
  • ctrlColWinBk : PlotCanvas.h
  • ctrlColWinText : PlotCanvas.h
  • ctrlColYellow : PlotCanvas.h
  • ctrlDarkGreen : PlotCanvas.h
  • ctrlDarkGreenCopper : PlotCanvas.h
  • ctrlDarkOliveGreen : PlotCanvas.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • DEVICE_SPEED : WINUSBIO.H
  • DP4_PX4_OLD_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_CMD_MAX : DP5ControlUtil.h
  • DP5_CMD_MIN : DP5ControlUtil.h
  • DP5_DIAGDATA_TIMEOUT : DppLibUsb.h
  • DP5_DPP_TYPES_FIRST : DppConst.h
  • DP5_DPP_TYPES_LAST : DppConst.h
  • DP5_DX_GAIN_COUNT : DppGain.h
  • DP5_GAIN_COUNT : DppGain.h
  • DP5_MAX_CFG_SIZE : AsciiCmdUtilities.h
  • DP5_USB_TIMEOUT : DppLibUsb.h
  • DP5G_GAIN_COUNT : DppGain.h
  • DP5X_GAIN_COUNT : DppGain.h
  • DRV_INFO_OPTION_ALL : DppWinUSB.h
  • DRV_INFO_OPTION_DATE : DppWinUSB.h
  • DRV_INFO_OPTION_DESC : DppWinUSB.h
  • DRV_INFO_OPTION_LABEL : DppWinUSB.h
  • DRV_INFO_OPTION_MFG_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_MS_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_NONE : DppWinUSB.h
  • DRV_INFO_OPTION_PROV_NAME : DppWinUSB.h
  • DRV_INFO_OPTION_UX_TERM : DppWinUSB.h
  • DRV_INFO_OPTION_VER : DppWinUSB.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • ETHERNET : DP5Protocol.h
  • ETHERNET_TIMEOUT : DP5Protocol.h
  • EV_READ_STATUS_EVENT : DppComm.h
  • EV_THREAD_EXIT_EVENT : DppComm.h
  • EV_WRITE_DATA_EVENT : DppComm.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FullSpeed : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GAIN_FROM_INDEX : STypes.h
  • GETLONG : STypes.h
  • GETP1 : SCommon.h
  • GETPD : SCommon.h
  • GETULONG : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HasComboCtrl : DP5ControlUtil.h
  • HasTextCtrl : DP5ControlUtil.h
  • HID_APP_ABOUT : HTMLDefines.h
  • HID_APP_EXIT : HTMLDefines.h
  • HID_CONTEXT_HELP : HTMLDefines.h
  • HID_EDIT_CLEAR : HTMLDefines.h
  • HID_EDIT_CLEAR_ALL : HTMLDefines.h
  • HID_EDIT_COPY : HTMLDefines.h
  • HID_EDIT_CUT : HTMLDefines.h
  • HID_EDIT_FIND : HTMLDefines.h
  • HID_EDIT_PASTE : HTMLDefines.h
  • HID_EDIT_PASTE_LINK : HTMLDefines.h
  • HID_EDIT_PASTE_SPECIAL : HTMLDefines.h
  • HID_EDIT_REDO : HTMLDefines.h
  • HID_EDIT_REPEAT : HTMLDefines.h
  • HID_EDIT_REPLACE : HTMLDefines.h
  • HID_EDIT_SELECT_ALL : HTMLDefines.h
  • HID_EDIT_UNDO : HTMLDefines.h
  • HID_FILE_CLOSE : HTMLDefines.h
  • HID_FILE_MRU_FILE1 : HTMLDefines.h
  • HID_FILE_NEW : HTMLDefines.h
  • HID_FILE_OPEN : HTMLDefines.h
  • HID_FILE_PAGE_SETUP : HTMLDefines.h
  • HID_FILE_PRINT : HTMLDefines.h
  • HID_FILE_PRINT_DIRECT : HTMLDefines.h
  • HID_FILE_PRINT_PREVIEW : HTMLDefines.h
  • HID_FILE_PRINT_SETUP : HTMLDefines.h
  • HID_FILE_SAVE : HTMLDefines.h
  • HID_FILE_SAVE_AS : HTMLDefines.h
  • HID_FILE_SAVE_COPY_AS : HTMLDefines.h
  • HID_FILE_SEND_MAIL : HTMLDefines.h
  • HID_FILE_TAB : HTMLDefines.h
  • HID_FILE_UPDATE : HTMLDefines.h
  • HID_FORMAT_FONT : HTMLDefines.h
  • HID_GAINPZ_TAB : HTMLDefines.h
  • HID_HELP_ABOUT : HTMLDefines.h
  • HID_HELP_FINDER : HTMLDefines.h
  • HID_HELP_INDEX : HTMLDefines.h
  • HID_HELP_USING : HTMLDefines.h
  • HID_HT_CAPTION : HTMLDefines.h
  • HID_HT_CLOSE : HTMLDefines.h
  • HID_HT_HELP : HTMLDefines.h
  • HID_HT_HSCROLL : HTMLDefines.h
  • HID_HT_MAXBUTTON : HTMLDefines.h
  • HID_HT_MINBUTTON : HTMLDefines.h
  • HID_HT_NOWHERE : HTMLDefines.h
  • HID_HT_OBJECT : HTMLDefines.h
  • HID_HT_SIZE : HTMLDefines.h
  • HID_HT_VSCROLL : HTMLDefines.h
  • HID_MCA_TAB : HTMLDefines.h
  • HID_MISC_TAB : HTMLDefines.h
  • HID_NEXT_PANE : HTMLDefines.h
  • HID_OLE_EDIT_CHANGE_ICON : HTMLDefines.h
  • HID_OLE_EDIT_CONVERT : HTMLDefines.h
  • HID_OLE_EDIT_LINKS : HTMLDefines.h
  • HID_OLE_EDIT_PROPERTIES : HTMLDefines.h
  • HID_OLE_INSERT_NEW : HTMLDefines.h
  • HID_OLE_VERB_1 : HTMLDefines.h
  • HID_POWER_TAB : HTMLDefines.h
  • HID_PREV_PANE : HTMLDefines.h
  • HID_RECORD_FIRST : HTMLDefines.h
  • HID_RECORD_LAST : HTMLDefines.h
  • HID_RECORD_NEXT : HTMLDefines.h
  • HID_RECORD_PREV : HTMLDefines.h
  • HID_SC_CLOSE : HTMLDefines.h
  • HID_SC_MAXIMIZE : HTMLDefines.h
  • HID_SC_MINIMIZE : HTMLDefines.h
  • HID_SC_MOVE : HTMLDefines.h
  • HID_SC_NEXTWINDOW : HTMLDefines.h
  • HID_SC_PREVWINDOW : HTMLDefines.h
  • HID_SC_RESTORE : HTMLDefines.h
  • HID_SC_SIZE : HTMLDefines.h
  • HID_SC_TASKLIST : HTMLDefines.h
  • HID_SHAPING_TAB : HTMLDefines.h
  • HID_VIEW_STATUS_BAR : HTMLDefines.h
  • HID_VIEW_TOOLBAR : HTMLDefines.h
  • HID_WINDOW_ALL : HTMLDefines.h
  • HID_WINDOW_ARRANGE : HTMLDefines.h
  • HID_WINDOW_CASCADE : HTMLDefines.h
  • HID_WINDOW_NEW : HTMLDefines.h
  • HID_WINDOW_SPLIT : HTMLDefines.h
  • HID_WINDOW_TILE_HORZ : HTMLDefines.h
  • HID_WINDOW_TILE_VERT : HTMLDefines.h
  • HID_WIZBACK : HTMLDefines.h
  • HID_WIZFINISH : HTMLDefines.h
  • HID_WIZNEXT : HTMLDefines.h
  • HIDD_ABOUTBOX : HTMLDefines.h
  • HIDD_BUSY_DLG : HTMLDefines.h
  • HIDD_DP5_CONNECT : vcDP5_Shared_HIDD.h
  • HIDD_FILE_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_GAINPZ_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MCA_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_MESSAGE_BOX : HTMLDefines.h
  • HIDD_MISC_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_POWER_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_SHAPING_PAGE : vcDP5_Shared_HIDD.h
  • HIDD_vcDP5_DIALOG : HTMLDefines.h
  • HIDM_ABOUTBOX : HTMLDefines.h
  • HIDP_SOCKETS_INIT_FAILED : HTMLDefines.h
  • HIDR_MAINFRAME : HTMLDefines.h
  • HIDR_MENU : HTMLDefines.h
  • HIDR_TOOLBAR : HTMLDefines.h
  • HIDR_TOOLBAR_DP5_DLG : HTMLDefines.h
  • HighSpeed : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • ID_FILE_TAB : resource.h
  • ID_GAINPZ_TAB : resource.h
  • ID_HELP_ABOUT : resource.h
  • ID_MCA_TAB : resource.h
  • ID_MISC_TAB : resource.h
  • ID_POWER_TAB : resource.h
  • ID_SHAPING_TAB : resource.h
  • IDB_BITMAP_DP5_DLG : resource.h
  • IDB_SPECTRUM_ANIM : resource.h
  • IDC_BLRQUICKSLOWBUTTON : ShapingPageRes.h
  • IDC_BUSY_PIC : resource.h
  • IDC_BUSY_TEXT : resource.h
  • IDC_BUTTON_ADD_ROI : resource.h
  • IDC_BUTTON_ARM_TRIGGER : resource.h
  • IDC_BUTTON_AUTOTUNE : resource.h
  • IDC_BUTTON_CLEAR_DATA_AND_GRAPH : resource.h
  • IDC_BUTTON_CLEAR_MISC_DATA : resource.h
  • IDC_BUTTON_CLEAR_ROI : resource.h
  • IDC_BUTTON_CLIPBOARD_COPY : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_CLOSE_PORT : SelectDP5Res.h
  • IDC_BUTTON_COARSE_FINE_TO_TOTAL : GainPzPageRes.h
  • IDC_BUTTON_COUNT_DEVICES : SelectDP5Res.h
  • IDC_BUTTON_DIAG : resource.h
  • IDC_BUTTON_EDIT_CONFIG : resource.h
  • IDC_BUTTON_EDIT_CONFIG_FROM_HW : FilePageRes.h
  • IDC_BUTTON_FIND_DEVICE : resource.h
  • IDC_BUTTON_FIND_DP5_IP : SelectDP5Res.h
  • IDC_BUTTON_FIND_USB_DEVICE : SelectDP5Res.h
  • IDC_BUTTON_FINE_GAIN_ENTER : GainPzPageRes.h
  • IDC_BUTTON_IP_SELECT1 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT2 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT3 : SelectDP5Res.h
  • IDC_BUTTON_IP_SELECT4 : SelectDP5Res.h
  • IDC_BUTTON_OPEN_PORT : SelectDP5Res.h
  • IDC_BUTTON_OUTPUT_QUICKSET1 : MiscPageRes.h
  • IDC_BUTTON_OUTPUT_QUICKSET2 : MiscPageRes.h
  • IDC_BUTTON_OUTPUT_QUICKSET3 : MiscPageRes.h
  • IDC_BUTTON_PREVIEW_SCA : MiscPageRes.h
  • IDC_BUTTON_READ_CONFIG : FilePageRes.h
  • IDC_BUTTON_READ_MISC_DATA : resource.h
  • IDC_BUTTON_ROI_END : resource.h
  • IDC_BUTTON_ROI_START : resource.h
  • IDC_BUTTON_SAVE_CONFIG : FilePageRes.h
  • IDC_BUTTON_SAVE_FILE : resource.h
  • IDC_BUTTON_SCA_DEFAULTS : MiscPageRes.h
  • IDC_BUTTON_SELECT_COMM : resource.h
  • IDC_BUTTON_SEND_COMMAND : FilePageRes.h
  • IDC_BUTTON_SEND_COMMAND2 : FilePageRes.h
  • IDC_BUTTON_SEND_TO_HARDWARE : FilePageRes.h
  • IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT : FilePageRes.h
  • IDC_BUTTON_SERIAL_REQ_DATA : SelectDP5Res.h
  • IDC_BUTTON_SHOW_CONFIG : resource.h
  • IDC_BUTTON_SINGLE_UPDATE : resource.h
  • IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT : SelectDP5Res.h
  • IDC_BUTTON_START_ACQUISITION : resource.h
  • IDC_BUTTON_STOP_ACQUISITION : resource.h
  • IDC_BUTTON_TOTAL_TO_COARSE_FINE : GainPzPageRes.h
  • IDC_BUTTON_WRITE_MISC_DATA : resource.h
  • IDC_CHECK_AUTO_REARM : resource.h
  • IDC_CHECK_DELTA : resource.h
  • IDC_CHECK_DP5_DX_GAIN : FilePageRes.h
  • IDC_CHECK_ENABLE_SCA : MiscPageRes.h
  • IDC_CHECK_PC5_PRESENT : FilePageRes.h
  • IDC_CHECK_TYPE_IP_ADDRESS : SelectDP5Res.h
  • IDC_COMBO_COMPORT : SelectDP5Res.h
  • IDC_COMBO_OUTPUT_LEVEL : MiscPageRes.h
  • IDC_COMBO_SCA_INDEX : MiscPageRes.h
  • IDC_COMBO_SCA_PULSE_WIDTH : MiscPageRes.h
  • IDC_CONNECTOK : SelectDP5Res.h
  • IDC_EDIT_DESCRIPTION : resource.h
  • IDC_EDIT_DIAG : resource.h
  • IDC_EDIT_DPPCOMM_STATUS : SelectDP5Res.h
  • IDC_EDIT_HIGH_THRESHOLD : MiscPageRes.h
  • IDC_EDIT_HW_CFG_SECTION : FilePageRes.h
  • IDC_EDIT_IP_ADDR1 : SelectDP5Res.h
  • IDC_EDIT_IP_ADDR2 : SelectDP5Res.h
  • IDC_EDIT_IP_ADDR3 : SelectDP5Res.h
  • IDC_EDIT_IP_ADDR4 : SelectDP5Res.h
  • IDC_EDIT_IP_PORT : SelectDP5Res.h
  • IDC_EDIT_LOW_THRESHOLD : MiscPageRes.h
  • IDC_EDIT_MISC_DATA : resource.h
  • IDC_EDIT_RCV_CFG : FilePageRes.h
  • IDC_EDIT_SEND_COMMAND : FilePageRes.h
  • IDC_EDIT_START_TIME : resource.h
  • IDC_EDIT_STATUS : resource.h
  • IDC_EDIT_STATUS2 : SelectDP5Res.h
  • IDC_EDIT_TAG : resource.h
  • IDC_FLATTOPSTATIC : ShapingPageRes.h
  • IDC_GROUP_PLOT_SCALE : resource.h
  • IDC_LABEL_BLR_MODE_OFF_ON : ShapingPageRes.h
  • IDC_LABEL_QUICK_PICK_SHAPING : ShapingPageRes.h
  • IDC_LABEL_QUICK_PICK_SHAPING2 : ShapingPageRes.h
  • IDC_MESSAGE1 : resource.h
  • IDC_MESSAGE2 : resource.h
  • IDC_OPT_COMBO_AINP : GainPzPageRes.h
  • IDC_OPT_COMBO_AUO1 : MiscPageRes.h
  • IDC_OPT_COMBO_AUO2 : MiscPageRes.h
  • IDC_OPT_COMBO_BLRM : ShapingPageRes.h
  • IDC_OPT_COMBO_BOOT : PowerPageRes.h
  • IDC_OPT_COMBO_CLCK : ShapingPageRes.h
  • IDC_OPT_COMBO_CON1 : MiscPageRes.h
  • IDC_OPT_COMBO_CON2 : MiscPageRes.h
  • IDC_OPT_COMBO_CUSP : ShapingPageRes.h
  • IDC_OPT_COMBO_DACO : MiscPageRes.h
  • IDC_OPT_COMBO_DMCA_GAIA : McaPageRes.h
  • IDC_OPT_COMBO_DMCA_PURE : McaPageRes.h
  • IDC_OPT_COMBO_GAIA : GainPzPageRes.h
  • IDC_OPT_COMBO_GAIA2 : GainPzPageRes.h
  • IDC_OPT_COMBO_GAIN_SELECT : GainPzPageRes.h
  • IDC_OPT_COMBO_GATE : McaPageRes.h
  • IDC_OPT_COMBO_GPED : MiscPageRes.h
  • IDC_OPT_COMBO_GPGA : MiscPageRes.h
  • IDC_OPT_COMBO_GPIN : MiscPageRes.h
  • IDC_OPT_COMBO_GPMC : MiscPageRes.h
  • IDC_OPT_COMBO_GPME : MiscPageRes.h
  • IDC_OPT_COMBO_HVSE : PowerPageRes.h
  • IDC_OPT_COMBO_INOF : GainPzPageRes.h
  • IDC_OPT_COMBO_MCAC : McaPageRes.h
  • IDC_OPT_COMBO_MCAE : McaPageRes.h
  • IDC_OPT_COMBO_MCAS : McaPageRes.h
  • IDC_OPT_COMBO_PAPS : PowerPageRes.h
  • IDC_OPT_COMBO_PAPZ : GainPzPageRes.h
  • IDC_OPT_COMBO_PDMD : McaPageRes.h
  • IDC_OPT_COMBO_PREC : McaPageRes.h
  • IDC_OPT_COMBO_PREL : McaPageRes.h
  • IDC_OPT_COMBO_PRER : McaPageRes.h
  • IDC_OPT_COMBO_PRET : McaPageRes.h
  • IDC_OPT_COMBO_PURE : ShapingPageRes.h
  • IDC_OPT_COMBO_RESC : FilePageRes.h
  • IDC_OPT_COMBO_RESL : GainPzPageRes.h
  • IDC_OPT_COMBO_RESL2 : GainPzPageRes.h
  • IDC_OPT_COMBO_RTDE : ShapingPageRes.h
  • IDC_OPT_COMBO_SCOE : MiscPageRes.h
  • IDC_OPT_COMBO_SCOG : MiscPageRes.h
  • IDC_OPT_COMBO_SCOT : MiscPageRes.h
  • IDC_OPT_COMBO_SCTC : ShapingPageRes.h
  • IDC_OPT_COMBO_SOFF : McaPageRes.h
  • IDC_OPT_COMBO_SOFF2 : McaPageRes.h
  • IDC_OPT_COMBO_SOFF3 : McaPageRes.h
  • IDC_OPT_COMBO_TECS : PowerPageRes.h
  • IDC_OPT_COMBO_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_COMBO_TPFA : ShapingPageRes.h
  • IDC_OPT_COMBO_TPMO : MiscPageRes.h
  • IDC_OPT_COMBO_VOLU : MiscPageRes.h
  • IDC_OPT_FRAME_AINP : GainPzPageRes.h
  • IDC_OPT_FRAME_AUO1 : MiscPageRes.h
  • IDC_OPT_FRAME_AUO2 : MiscPageRes.h
  • IDC_OPT_FRAME_BLRD : ShapingPageRes.h
  • IDC_OPT_FRAME_BLRM : ShapingPageRes.h
  • IDC_OPT_FRAME_BLRU : ShapingPageRes.h
  • IDC_OPT_FRAME_BOOT : PowerPageRes.h
  • IDC_OPT_FRAME_CLCK : ShapingPageRes.h
  • IDC_OPT_FRAME_CON1 : MiscPageRes.h
  • IDC_OPT_FRAME_CON2 : MiscPageRes.h
  • IDC_OPT_FRAME_CUSP : ShapingPageRes.h
  • IDC_OPT_FRAME_DACF : MiscPageRes.h
  • IDC_OPT_FRAME_DACO : MiscPageRes.h
  • IDC_OPT_FRAME_DMCA_GAIA : McaPageRes.h
  • IDC_OPT_FRAME_DMCA_PURE : McaPageRes.h
  • IDC_OPT_FRAME_GAIA : GainPzPageRes.h
  • IDC_OPT_FRAME_GAIF : GainPzPageRes.h
  • IDC_OPT_FRAME_GAIN : GainPzPageRes.h
  • IDC_OPT_FRAME_GATE : McaPageRes.h
  • IDC_OPT_FRAME_GPED : MiscPageRes.h
  • IDC_OPT_FRAME_GPGA : MiscPageRes.h
  • IDC_OPT_FRAME_GPIN : MiscPageRes.h
  • IDC_OPT_FRAME_GPMC : MiscPageRes.h
  • IDC_OPT_FRAME_GPME : MiscPageRes.h
  • IDC_OPT_FRAME_HVSE : PowerPageRes.h
  • IDC_OPT_FRAME_INOF : GainPzPageRes.h
  • IDC_OPT_FRAME_MCAC : McaPageRes.h
  • IDC_OPT_FRAME_MCAE : McaPageRes.h
  • IDC_OPT_FRAME_MCAS : McaPageRes.h
  • IDC_OPT_FRAME_MCSH : McaPageRes.h
  • IDC_OPT_FRAME_MCSL : McaPageRes.h
  • IDC_OPT_FRAME_MCST : McaPageRes.h
  • IDC_OPT_FRAME_PAPS : PowerPageRes.h
  • IDC_OPT_FRAME_PAPZ : GainPzPageRes.h
  • IDC_OPT_FRAME_PDMD : McaPageRes.h
  • IDC_OPT_FRAME_PRCH : McaPageRes.h
  • IDC_OPT_FRAME_PRCL : McaPageRes.h
  • IDC_OPT_FRAME_PREC : McaPageRes.h
  • IDC_OPT_FRAME_PREL : McaPageRes.h
  • IDC_OPT_FRAME_PRER : McaPageRes.h
  • IDC_OPT_FRAME_PRET : McaPageRes.h
  • IDC_OPT_FRAME_PURE : ShapingPageRes.h
  • IDC_OPT_FRAME_RESC : FilePageRes.h
  • IDC_OPT_FRAME_RESL : GainPzPageRes.h
  • IDC_OPT_FRAME_RESL2 : GainPzPageRes.h
  • IDC_OPT_FRAME_RTDE : ShapingPageRes.h
  • IDC_OPT_FRAME_RTDS : ShapingPageRes.h
  • IDC_OPT_FRAME_RTDT : ShapingPageRes.h
  • IDC_OPT_FRAME_SCOE : MiscPageRes.h
  • IDC_OPT_FRAME_SCOG : MiscPageRes.h
  • IDC_OPT_FRAME_SCOT : MiscPageRes.h
  • IDC_OPT_FRAME_SCTC : ShapingPageRes.h
  • IDC_OPT_FRAME_SOFF : McaPageRes.h
  • IDC_OPT_FRAME_SOFF2 : McaPageRes.h
  • IDC_OPT_FRAME_SOFF3 : McaPageRes.h
  • IDC_OPT_FRAME_TECS : PowerPageRes.h
  • IDC_OPT_FRAME_TFLA : ShapingPageRes.h
  • IDC_OPT_FRAME_THFA : ShapingPageRes.h
  • IDC_OPT_FRAME_THSL : McaPageRes.h
  • IDC_OPT_FRAME_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_FRAME_TPEA : ShapingPageRes.h
  • IDC_OPT_FRAME_TPFA : ShapingPageRes.h
  • IDC_OPT_FRAME_TPMO : MiscPageRes.h
  • IDC_OPT_FRAME_VOLU : MiscPageRes.h
  • IDC_OPT_LIMITS_AUO1 : MiscPageRes.h
  • IDC_OPT_LIMITS_AUO2 : MiscPageRes.h
  • IDC_OPT_LIMITS_BLRD : ShapingPageRes.h
  • IDC_OPT_LIMITS_BLRU : ShapingPageRes.h
  • IDC_OPT_LIMITS_CUSP : ShapingPageRes.h
  • IDC_OPT_LIMITS_DACF : MiscPageRes.h
  • IDC_OPT_LIMITS_DACO : MiscPageRes.h
  • IDC_OPT_LIMITS_GAIF : GainPzPageRes.h
  • IDC_OPT_LIMITS_GAIN : GainPzPageRes.h
  • IDC_OPT_LIMITS_GPIN : MiscPageRes.h
  • IDC_OPT_LIMITS_HVSE : PowerPageRes.h
  • IDC_OPT_LIMITS_INOF : GainPzPageRes.h
  • IDC_OPT_LIMITS_MCSH : McaPageRes.h
  • IDC_OPT_LIMITS_MCSL : McaPageRes.h
  • IDC_OPT_LIMITS_MCST : McaPageRes.h
  • IDC_OPT_LIMITS_PAPZ : GainPzPageRes.h
  • IDC_OPT_LIMITS_PRCH : McaPageRes.h
  • IDC_OPT_LIMITS_PRCL : McaPageRes.h
  • IDC_OPT_LIMITS_PREC : McaPageRes.h
  • IDC_OPT_LIMITS_PREL : McaPageRes.h
  • IDC_OPT_LIMITS_PRER : McaPageRes.h
  • IDC_OPT_LIMITS_PRET : McaPageRes.h
  • IDC_OPT_LIMITS_PURE : ShapingPageRes.h
  • IDC_OPT_LIMITS_RESL : GainPzPageRes.h
  • IDC_OPT_LIMITS_RTDS : ShapingPageRes.h
  • IDC_OPT_LIMITS_RTDT : ShapingPageRes.h
  • IDC_OPT_LIMITS_SCTC : ShapingPageRes.h
  • IDC_OPT_LIMITS_SOFF : McaPageRes.h
  • IDC_OPT_LIMITS_SOFF2 : McaPageRes.h
  • IDC_OPT_LIMITS_SOFF3 : McaPageRes.h
  • IDC_OPT_LIMITS_TECS : PowerPageRes.h
  • IDC_OPT_LIMITS_TFLA : ShapingPageRes.h
  • IDC_OPT_LIMITS_THFA : ShapingPageRes.h
  • IDC_OPT_LIMITS_THSL : McaPageRes.h
  • IDC_OPT_LIMITS_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_LIMITS_TPEA : ShapingPageRes.h
  • IDC_OPT_TEXT_AUO1 : MiscPageRes.h
  • IDC_OPT_TEXT_AUO2 : MiscPageRes.h
  • IDC_OPT_TEXT_BLRD : ShapingPageRes.h
  • IDC_OPT_TEXT_BLRU : ShapingPageRes.h
  • IDC_OPT_TEXT_CUSP : ShapingPageRes.h
  • IDC_OPT_TEXT_DACF : MiscPageRes.h
  • IDC_OPT_TEXT_DACO : MiscPageRes.h
  • IDC_OPT_TEXT_GAIF : GainPzPageRes.h
  • IDC_OPT_TEXT_GAIN : GainPzPageRes.h
  • IDC_OPT_TEXT_GPIN : MiscPageRes.h
  • IDC_OPT_TEXT_HVSE : PowerPageRes.h
  • IDC_OPT_TEXT_INOF : GainPzPageRes.h
  • IDC_OPT_TEXT_MCSH : McaPageRes.h
  • IDC_OPT_TEXT_MCSL : McaPageRes.h
  • IDC_OPT_TEXT_MCST : McaPageRes.h
  • IDC_OPT_TEXT_PAPZ : GainPzPageRes.h
  • IDC_OPT_TEXT_PRCH : McaPageRes.h
  • IDC_OPT_TEXT_PRCL : McaPageRes.h
  • IDC_OPT_TEXT_PREC : McaPageRes.h
  • IDC_OPT_TEXT_PREL : McaPageRes.h
  • IDC_OPT_TEXT_PRER : McaPageRes.h
  • IDC_OPT_TEXT_PRET : McaPageRes.h
  • IDC_OPT_TEXT_PURE : ShapingPageRes.h
  • IDC_OPT_TEXT_RESL : GainPzPageRes.h
  • IDC_OPT_TEXT_RTDS : ShapingPageRes.h
  • IDC_OPT_TEXT_RTDT : ShapingPageRes.h
  • IDC_OPT_TEXT_SCTC : ShapingPageRes.h
  • IDC_OPT_TEXT_SOFF : McaPageRes.h
  • IDC_OPT_TEXT_SOFF2 : McaPageRes.h
  • IDC_OPT_TEXT_SOFF3 : McaPageRes.h
  • IDC_OPT_TEXT_TECS : PowerPageRes.h
  • IDC_OPT_TEXT_TFLA : ShapingPageRes.h
  • IDC_OPT_TEXT_THFA : ShapingPageRes.h
  • IDC_OPT_TEXT_THSL : McaPageRes.h
  • IDC_OPT_TEXT_TLLD : ShapingPageRes.h , McaPageRes.h
  • IDC_OPT_TEXT_TPEA : ShapingPageRes.h
  • IDC_OPT_UNITS_AUO1 : MiscPageRes.h
  • IDC_OPT_UNITS_AUO2 : MiscPageRes.h
  • IDC_OPT_UNITS_BLRD : ShapingPageRes.h
  • IDC_OPT_UNITS_BLRU : ShapingPageRes.h
  • IDC_OPT_UNITS_CUSP : ShapingPageRes.h
  • IDC_OPT_UNITS_DACF : MiscPageRes.h
  • IDC_OPT_UNITS_DACO : MiscPageRes.h
  • IDC_OPT_UNITS_GAIF : GainPzPageRes.h
  • IDC_OPT_UNITS_GAIN : GainPzPageRes.h
  • IDC_OPT_UNITS_GPIN : MiscPageRes.h
  • IDC_OPT_UNITS_HVSE : PowerPageRes.h
  • IDC_OPT_UNITS_INOF : GainPzPageRes.h
  • IDC_OPT_UNITS_MCSH : McaPageRes.h
  • IDC_OPT_UNITS_MCSL : McaPageRes.h
  • IDC_OPT_UNITS_MCST : McaPageRes.h
  • IDC_OPT_UNITS_PAPS : PowerPageRes.h
  • IDC_OPT_UNITS_PAPZ : GainPzPageRes.h
  • IDC_OPT_UNITS_PRCH : McaPageRes.h
  • IDC_OPT_UNITS_PRCL : McaPageRes.h
  • IDC_OPT_UNITS_PREC : McaPageRes.h
  • IDC_OPT_UNITS_PREL : McaPageRes.h
  • IDC_OPT_UNITS_PRER : McaPageRes.h
  • IDC_OPT_UNITS_PRET : McaPageRes.h
  • IDC_OPT_UNITS_PURE : ShapingPageRes.h
  • IDC_OPT_UNITS_RESL : GainPzPageRes.h
  • IDC_OPT_UNITS_RESL2 : ShapingPageRes.h , GainPzPageRes.h
  • IDC_OPT_UNITS_RESL3 : ShapingPageRes.h
  • IDC_OPT_UNITS_RTDS : ShapingPageRes.h
  • IDC_OPT_UNITS_RTDT : ShapingPageRes.h
  • IDC_OPT_UNITS_SCOG : MiscPageRes.h
  • IDC_OPT_UNITS_SCTC : ShapingPageRes.h
  • IDC_OPT_UNITS_SOFF : McaPageRes.h
  • IDC_OPT_UNITS_SOFF2 : McaPageRes.h
  • IDC_OPT_UNITS_SOFF3 : McaPageRes.h
  • IDC_OPT_UNITS_TECS : PowerPageRes.h
  • IDC_OPT_UNITS_TFLA : ShapingPageRes.h
  • IDC_OPT_UNITS_THFA : ShapingPageRes.h
  • IDC_OPT_UNITS_THSL : McaPageRes.h
  • IDC_OPT_UNITS_TLLD : McaPageRes.h , ShapingPageRes.h
  • IDC_OPT_UNITS_TPEA : ShapingPageRes.h
  • IDC_OPT_VALUE_GAIA : GainPzPageRes.h
  • IDC_OPT_VALUE_GAIN : GainPzPageRes.h
  • IDC_PICTURE_PLOT : resource.h
  • IDC_PICTURE_SCOPE : resource.h
  • IDC_PLOTTYPEGROUP : resource.h
  • IDC_PRESETCOUNTCURSORBUTTON : McaPageRes.h
  • IDC_PRESETCOUNTROIBUTTON : McaPageRes.h
  • IDC_RADIO_COMMTYPE1 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE2 : SelectDP5Res.h
  • IDC_RADIO_COMMTYPE3 : SelectDP5Res.h
  • IDC_RADIO_DPP_DEVICE_TYPE1 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE2 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE3 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE4 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE5 : FilePageRes.h
  • IDC_RADIO_DPP_DEVICE_TYPE6 : FilePageRes.h
  • IDC_RADIO_HV_SIGN1 : PowerPageRes.h
  • IDC_RADIO_HV_SIGN2 : PowerPageRes.h
  • IDC_RADIO_PLOT_SCALE_LINEAR : resource.h
  • IDC_RADIO_PLOT_SCALE_LOG : resource.h
  • IDC_RADIO_PLOT_TYPE_LINE : resource.h
  • IDC_RADIO_PLOT_TYPE_SOLID : resource.h
  • IDC_READDETECTORCONFIGCOMBO : FilePageRes.h
  • IDC_RISECOMBO : ShapingPageRes.h
  • IDC_SHAPINGGROUP : ShapingPageRes.h
  • IDC_SPECTRUM_REFRESH_TIME : SelectDP5Res.h
  • IDC_SPIN_SELECT_DEVICE : SelectDP5Res.h
  • IDC_STATIC_ : resource.h
  • IDC_STATIC_AVANCED_GAIN_CONTROL : GainPzPageRes.h
  • IDC_STATIC_BLR_FRAME : ShapingPageRes.h
  • IDC_STATIC_CFG_LEN_LABEL : FilePageRes.h
  • IDC_STATIC_CFG_LENGTH : FilePageRes.h
  • IDC_STATIC_CONFIG_NAME : FilePageRes.h
  • IDC_STATIC_CONFIG_NAME2 : FilePageRes.h
  • IDC_STATIC_CURRENT_SCA : MiscPageRes.h
  • IDC_STATIC_DAC_FRAME : MiscPageRes.h
  • IDC_STATIC_DPP_DEVICE_TYPE : FilePageRes.h
  • IDC_STATIC_FAST_SHAPING_FRAME : ShapingPageRes.h
  • IDC_STATIC_FILE_ADVANCED : FilePageRes.h
  • IDC_STATIC_FILE_BASIC : FilePageRes.h
  • IDC_STATIC_FILE_PAGE : FilePageRes.h
  • IDC_STATIC_FILE_STANDARD : FilePageRes.h
  • IDC_STATIC_FOUND1 : SelectDP5Res.h
  • IDC_STATIC_FOUND2 : SelectDP5Res.h
  • IDC_STATIC_FOUND3 : SelectDP5Res.h
  • IDC_STATIC_FPGACLK1 : ShapingPageRes.h
  • IDC_STATIC_FPGACLK2 : ShapingPageRes.h
  • IDC_STATIC_FPGACLK3 : ShapingPageRes.h
  • IDC_STATIC_GAIN_ADVANCED : GainPzPageRes.h
  • IDC_STATIC_GAIN_BASIC : GainPzPageRes.h
  • IDC_STATIC_GAIN_STANDARD : GainPzPageRes.h
  • IDC_STATIC_GAINPZ_PAGE : GainPzPageRes.h
  • IDC_STATIC_HIGH_THRESHOLD : MiscPageRes.h
  • IDC_STATIC_HV_SIGN1 : PowerPageRes.h
  • IDC_STATIC_HV_SIGN2 : PowerPageRes.h
  • IDC_STATIC_HV_WARNING : PowerPageRes.h , GainPzPageRes.h
  • IDC_STATIC_IP_ADDRESS_LABEL : SelectDP5Res.h
  • IDC_STATIC_IP_SERIAL_NUM : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_1 : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_2 : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_3 : SelectDP5Res.h
  • IDC_STATIC_LABEL_IP_4 : SelectDP5Res.h
  • IDC_STATIC_LOW_THRESHOLD : MiscPageRes.h
  • IDC_STATIC_MCA_ADVANCED : McaPageRes.h
  • IDC_STATIC_MCA_BASIC : McaPageRes.h
  • IDC_STATIC_MCA_PAGE : McaPageRes.h
  • IDC_STATIC_MCA_STANDARD : McaPageRes.h
  • IDC_STATIC_MISC_ADVANCED : MiscPageRes.h
  • IDC_STATIC_MISC_BASIC : MiscPageRes.h
  • IDC_STATIC_MISC_PAGE : MiscPageRes.h
  • IDC_STATIC_MISC_QUICKSET : MiscPageRes.h
  • IDC_STATIC_MISC_STANDARD : MiscPageRes.h
  • IDC_STATIC_MISC_STATUS : resource.h
  • IDC_STATIC_NETFINDER1 : SelectDP5Res.h
  • IDC_STATIC_NETFINDER2 : SelectDP5Res.h
  • IDC_STATIC_NETFINDER3 : SelectDP5Res.h
  • IDC_STATIC_NETFINDER4 : SelectDP5Res.h
  • IDC_STATIC_NUM_DEVICES : SelectDP5Res.h
  • IDC_STATIC_NUM_DEVICES2 : SelectDP5Res.h
  • IDC_STATIC_OUTPUT_LEVEL : MiscPageRes.h
  • IDC_STATIC_PORT_LABEL : SelectDP5Res.h
  • IDC_STATIC_POWER_ADVANCED : PowerPageRes.h
  • IDC_STATIC_POWER_BASIC : PowerPageRes.h
  • IDC_STATIC_POWER_PAGE : PowerPageRes.h
  • IDC_STATIC_POWER_STANDARD : PowerPageRes.h
  • IDC_STATIC_PULSE_SHAPING : ShapingPageRes.h
  • IDC_STATIC_READ_CONFIG : FilePageRes.h
  • IDC_STATIC_ROI_COUNT : resource.h
  • IDC_STATIC_ROI_END : resource.h
  • IDC_STATIC_ROI_INDEX : resource.h
  • IDC_STATIC_ROI_START : resource.h
  • IDC_STATIC_RTD_FRAME : ShapingPageRes.h
  • IDC_STATIC_SAVE_CONFIG : FilePageRes.h
  • IDC_STATIC_SCA_GROUP : MiscPageRes.h
  • IDC_STATIC_SCA_INDEX : MiscPageRes.h
  • IDC_STATIC_SCA_PULSE_WIDTH : MiscPageRes.h
  • IDC_STATIC_SELECT_COMMUNICATIONS : resource.h
  • IDC_STATIC_SELECT_USB_DEVICE_LABEL : SelectDP5Res.h
  • IDC_STATIC_SEND_COMMAND_LABEL : FilePageRes.h
  • IDC_STATIC_SHAPING_ADVANCED : ShapingPageRes.h
  • IDC_STATIC_SHAPING_BASIC : ShapingPageRes.h
  • IDC_STATIC_SHAPING_PAGE : ShapingPageRes.h
  • IDC_STATIC_SHAPING_STANDARD : ShapingPageRes.h
  • IDC_STATIC_SPECTRUM_STATUS : resource.h
  • IDC_STATIC_STATUS : resource.h
  • IDC_STATIC_TOTAL_OR_BOTH_LABEL : GainPzPageRes.h
  • IDC_TIMETOPEAKSTATIC : ShapingPageRes.h
  • IDC_TOPCOMBO : ShapingPageRes.h
  • IDD_ABOUTBOX : resource.h
  • IDD_BUSY_DLG : resource.h
  • IDD_DP5_CONNECT : vcDP5_Shared_IDD.h
  • IDD_FILE_PAGE : vcDP5_Shared_IDD.h
  • IDD_GAINPZ_PAGE : vcDP5_Shared_IDD.h
  • IDD_MCA_PAGE : vcDP5_Shared_IDD.h
  • IDD_MESSAGE_BOX : resource.h
  • IDD_MISC_PAGE : vcDP5_Shared_IDD.h
  • IDD_POWER_PAGE : vcDP5_Shared_IDD.h
  • IDD_SHAPING_PAGE : vcDP5_Shared_IDD.h
  • IDD_vcDP5_DIALOG : resource.h
  • IDI_DP5_CARD : FilePageRes.h
  • IDI_OPEN_FOLDER : FilePageRes.h
  • IDI_RIGHT_ARROW : FilePageRes.h
  • IDM_ABOUTBOX : resource.h
  • IDP_SOCKETS_INIT_FAILED : resource.h
  • IDR_MAINFRAME : resource.h
  • IDR_MENU : resource.h
  • IDR_TOOLBAR : resource.h
  • IDR_TOOLBAR_DP5_DLG : resource.h
  • IDS_ABOUTBOX : resource.h
  • IDS_BTNSTRING_MODAL : resource.h
  • IDS_BTNSTRING_MODELESS : resource.h
  • IDS_CAPTION : resource.h
  • IDS_TT_ANALOG_INPUT : GainPzPageRes.h
  • IDS_TT_ANALOG_OUT : MiscPageRes.h
  • IDS_TT_ARROWS : GainPzPageRes.h
  • IDS_TT_AUX_1 : MiscPageRes.h
  • IDS_TT_AUX_2 : MiscPageRes.h
  • IDS_TT_BLR_DOWN_CORRECTION : ShapingPageRes.h
  • IDS_TT_BLR_MODE : ShapingPageRes.h
  • IDS_TT_BLR_QUICKSET : ShapingPageRes.h
  • IDS_TT_BLR_UP_CORRECTION : ShapingPageRes.h
  • IDS_TT_COARSE_GAIN : GainPzPageRes.h
  • IDS_TT_CONNECTOR_1 : MiscPageRes.h
  • IDS_TT_CONNECTOR_2 : MiscPageRes.h
  • IDS_TT_COOLER_TEMPERATURE : PowerPageRes.h
  • IDS_TT_FAST_PEAKING_TIME : ShapingPageRes.h
  • IDS_TT_FAST_THRESHOLD : ShapingPageRes.h
  • IDS_TT_FINE_GAIN : GainPzPageRes.h
  • IDS_TT_FLAT_TOP_WIDTH : ShapingPageRes.h
  • IDS_TT_FPGA_CLOCK_SPEED : ShapingPageRes.h
  • IDS_TT_GATE_CONTROL : McaPageRes.h
  • IDS_TT_HIGH_VOLTAGE_BIAS : PowerPageRes.h
  • IDS_TT_HIGH_VOLTAGE_POLARITY : PowerPageRes.h
  • IDS_TT_INPUT_OFFSET : GainPzPageRes.h
  • IDS_TT_LOW_LEVEL_DISCRIMINATOR : McaPageRes.h
  • IDS_TT_MCA_MCS_CHANNELS : McaPageRes.h
  • IDS_TT_MCA_SOURCE : McaPageRes.h
  • IDS_TT_MCS_LOW_HIGH_CHANNEL : McaPageRes.h
  • IDS_TT_MCS_TIMEBASE : McaPageRes.h
  • IDS_TT_NON_TRAPEZOIDAL_SHAPING : ShapingPageRes.h
  • IDS_TT_OUTPUT_OFFSET : MiscPageRes.h
  • IDS_TT_PC__ON_AT_STARTUP : PowerPageRes.h
  • IDS_TT_PEAK_DETECT_MODE : McaPageRes.h
  • IDS_TT_PEAKING_QPICK : ShapingPageRes.h
  • IDS_TT_PEAKING_TIME : ShapingPageRes.h
  • IDS_TT_PREAMP_VOLTAGE : PowerPageRes.h
  • IDS_TT_PRESET_ACQUISITION_TIME : McaPageRes.h
  • IDS_TT_PRESET_COUNT : McaPageRes.h
  • IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL : McaPageRes.h
  • IDS_TT_PRESET_LIVE_TIME : McaPageRes.h
  • IDS_TT_PRESET_REAL_TIME : McaPageRes.h
  • IDS_TT_PUR_ON_OFF : ShapingPageRes.h
  • IDS_TT_PX__SPEAKER : MiscPageRes.h
  • IDS_TT_RESET_LOCKOUT : GainPzPageRes.h
  • IDS_TT_RTD_ON_OFF : ShapingPageRes.h
  • IDS_TT_RTD_SENSITIVITY : ShapingPageRes.h
  • IDS_TT_RTD_THRESHOLD : ShapingPageRes.h
  • IDS_TT_SCOPE_COMMANDS : MiscPageRes.h
  • IDS_TT_SCTC : ShapingPageRes.h
  • IDS_TT_SEND_TOTAL_OR_COARSE_FINE_GAIN : GainPzPageRes.h
  • IDS_TT_SET_SPECTRUM_OFFSET : McaPageRes.h
  • IDS_TT_SLOW_THRESHOLD : McaPageRes.h
  • IDS_TT_TEST_PULSER : MiscPageRes.h
  • IDS_TT_TOTAL_GAIN : GainPzPageRes.h
  • IGNORE_SHORT_PACKETS : WINUSBIO.H
  • INTERFACE_NUMBER : DppLibUsb.h
  • isDebug : SelectDP5.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • LIMIT_INIT : DP5ControlUtil.h
  • LIMIT_VIS : DP5ControlUtil.h
  • LINE_PLOT_TYPE : vcDP5Dlg.h
  • LINEAR_PLOT_SCALE : vcDP5Dlg.h
  • LOG_PLOT_SCALE : vcDP5Dlg.h
  • LowSpeed : WINUSBIO.H
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MAX_BUFFER_DATA : DP5Protocol.h
  • MAX_BULK_IN_TRANSFER_SIZE : DppLibUsb.h
  • MAX_BULK_OUT_TRANSFER_SIZE : DppLibUsb.h
  • MAX_CHANNELS : STypes.h
  • MAX_COUNTS : STypes.h
  • MAX_DEVPATH_LENGTH : DppWinUSB.h
  • MAX_DP5_CONFIGURATIONS : DP5ControlUtil.h
  • MAX_GAIN_INDEX : SpectrumAttr.h , STypes.h
  • MAX_KEY_DATA_SIZE : INI.h
  • MAX_SCA_REGISTER : Sca.h
  • MAX_SCOPE_DATA : DP5Protocol.h
  • MAX_SECTION_SIZE : INI.h
  • MAX_SPECTRA : STypes.h
  • MAXDP5S : DppWinUSB.h
  • MaxGainTable : DppGain.h
  • MAXIMUM_TRANSFER_SIZE : WINUSBIO.H
  • MAXPEAKINGTIMES : DppShaping.h
  • MAXPEAKINGTIMES_20MHZ : DppShaping.h
  • MAXPEAKINGTIMES_80MHZ : DppShaping.h
  • MAXPIPES : DppWinUSB.h
  • MAXREGBUFFER : DppWinUSB.h
  • MCA8000D_GAIN_COUNT : DppGain.h
  • MIN_FRAME_X_PIXELS : STypes.h
  • MIN_FRAME_Y_PIXELS : STypes.h
  • MIN_GAIN : STypes.h
  • MIN_PLOT_CHANNELS : STypes.h
  • MIN_PLOT_COUNTS : STypes.h
  • MIN_PLOT_X_PIXELS : STypes.h
  • MIN_PLOT_Y_PIXELS : STypes.h
  • MinGainTable : DppGain.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PID1_REQ_SCOPE_MISC_TO : DppLibUsb.h
  • PID2_SEND_DIAGNOSTIC_DATA_TO : DppLibUsb.h
  • PIPE_TRANSFER_TIMEOUT : WINUSBIO.H
  • preqProcessAck : ParsePacket.h
  • preqProcessCfgRead : ParsePacket.h
  • preqProcessDiagData : ParsePacket.h
  • preqProcessError : ParsePacket.h
  • preqProcessHwDesc : ParsePacket.h
  • preqProcessInetSettings : ParsePacket.h
  • preqProcessNetFindRead : ParsePacket.h
  • preqProcessNone : ParsePacket.h
  • preqProcessPaCal : ParsePacket.h
  • preqProcessSCAData : ParsePacket.h
  • preqProcessScopeData : ParsePacket.h
  • preqProcessScopeDataOverFlow : ParsePacket.h
  • preqProcessSpectrum : ParsePacket.h
  • preqProcessStatus : ParsePacket.h
  • preqProcessTextData : ParsePacket.h
  • preqRequestScopeData : ParsePacket.h
  • PUTP1 : SCommon.h
  • PUTPD : SCommon.h
  • PX5_GAIN_COUNT : DppGain.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • RAW_IO : WINUSBIO.H
  • Retries : DP5Protocol.h
  • RS232 : DP5Protocol.h
  • RS232_TIMEOUT : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • SCREEN_SCALE : STypes.h
  • SHORT_PACKET_TERMINATE : WINUSBIO.H
  • SIZEOF_GAIN_ARRAY : DppGain.h
  • SOLID_PLOT_TYPE : vcDP5Dlg.h
  • STATUS_PACKET_SIZE : DppLibUsb.h
  • SUSPEND_DELAY : WINUSBIO.H
  • SYNC1_ : DP5Protocol.h
  • SYNC2_ : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TEXT_VIS : DP5ControlUtil.h
  • TIMEOUT_MS : DppLibUsb.h
  • TIMER_ID : AnimWnd.h
  • TOLONG : STypes.h
  • TOULONG : STypes.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UNIT_INIT : DP5ControlUtil.h
  • UNIT_VIS : DP5ControlUtil.h
  • USB : DP5Protocol.h
  • USB_BUFFER_SIZE : DppConfig.h
  • USB_CFG_IN_SIZE : DppConfig.h
  • USB_DiagDataDelayMS : DP5Protocol.h
  • USB_SCOPE_SIZE : DppConfig.h
  • USB_TIMEOUT : DP5Protocol.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • VC_EXTRALEAN : StdAfx.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • Whitespace : AsciiCmdUtilities.h
  • WinUsbDP5 : DppWinUSB.h
  • WinUsbDP5Size : DppWinUSB.h
  • WinUSBService : DppWinUSB.h
  • WM_DPPCOMM_RCV_CHAR : DppComm.h
  • WM_DPPSOCKET_RCV_BUFFER : DppSocket.h
  • WM_SETPAGEFOCUS : SCommon.h
  • WM_USER_COARSE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_DPP_AUTO_FAST_THESHOLD : UserMsgs.h
  • WM_USER_DPP_AUTO_SLOW_THESHOLD : UserMsgs.h
  • WM_USER_FINE_AUTO_INPUT_OFFSET : UserMsgs.h
  • WM_USER_FPGUI_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_LOAD_FILE : UserMsgs.h
  • WM_USER_PMCA_REQUEST_PARAMETER : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG : UserMsgs.h
  • WM_USER_READ_DPP_CONFIG_EX : UserMsgs.h
  • WM_USER_READ_SCA_CONFIG : UserMsgs.h
  • WM_USER_REPEAT_MEASUREMENT : UserMsgs.h
  • WM_USER_SAVE_CONFIG_TO_FILE : UserMsgs.h
  • WM_USER_SEND_CONFIG_TO_HW : UserMsgs.h
  • WM_USER_SHOW_CONNECT_DIALOG : UserMsgs.h
  • WM_USER_SHOW_SPECTRA_LIST_DLG : UserMsgs.h
  • WM_USER_UPDATE_MENU : UserMsgs.h
  • WM_USER_UPDATE_STATUS_BAR : UserMsgs.h
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/AnimWnd.cpp Source File

waitdlg/AnimWnd.cpp
Go to the documentation of this file.
00001 // cAnimWnd.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "AnimWnd.h"
00006
00008 // cAnimWnd
00009
00010 cAnimWnd::cAnimWnd()
00011 {
00012    m_ImageIndex = -1;
00013    m_MemDC = NULL;
00014 }
00015
00016 cAnimWnd::~cAnimWnd()
00017 {
00018    if (m_MemDC)
00019       delete m_MemDC;
00020
00021    m_Bitmap.Detach();
00022    m_Bitmap.DeleteObject();
00023 }
00024
00025
00026 BEGIN_MESSAGE_MAP(cAnimWnd, CWnd)
00027         //{{AFX_MSG_MAP(cAnimWnd)
00028         ON_WM_TIMER()
00029         ON_WM_PAINT()
00030         //}}AFX_MSG_MAP
00031 END_MESSAGE_MAP()
00032
00033
00035 // cAnimWnd message handlers
00036
00037 void cAnimWnd::SetImageList(UINT BitmapID, short Sizex, short Sizey, COLORREF TransparentColor)
00038 {
00039    m_TransparentColor = TransparentColor;
00040
00041    m_Bitmap.LoadBitmap(BitmapID);
00042    m_Width = Sizex;
00043    m_Height = Sizey;
00044
00045    CPoint ptSize;
00046    BITMAP bm_info;
00047    m_Bitmap.GetBitmap(&bm_info);
00048    ptSize.x = bm_info.bmWidth;
00049         ptSize.y = bm_info.bmHeight;
00050
00051    m_MemDC = new cMemDC(this->GetDC(), CRect(0,0,ptSize.x, ptSize.y));
00052    m_MemDC->SelectObject(&m_Bitmap);
00053 }
00054
00055 void cAnimWnd::OnPaint()
00056 {
00057         CPaintDC dc(this); // device context for painting
00058
00059         // TODO: Add your message handler code here
00060    if (m_MemDC)
00061       {
00062       // paint current image
00063       dc.BitBlt(0,0,m_Width, m_Height, m_MemDC, ((m_ImageIndex) * m_Width),0,SRCCOPY);
00064       }
00065    else
00066       {
00067            CWnd::DefWindowProc(WM_PAINT, (WPARAM)dc.m_hDC, 0);
00068       return;
00069       }
00070
00071         // Do not call CWnd::OnPaint() for painting messages
00072 }
00073
00074 void cAnimWnd::OnTimer(UINT nIDEvent)
00075 {
00076         // TODO: Add your message handler code here and/or call default
00077         switch (nIDEvent)
00078       {
00079       case TIMER_ID:
00080          {
00081          if (m_MemDC)
00082             {
00083             if (m_ImageIndex++ >= GetImageCount() - 1)
00084                m_ImageIndex = 0;
00085             Invalidate(TRUE);
00086             }
00087          }
00088       }
00089
00090         CWnd::OnTimer(nIDEvent);
00091 }
00092
00093 INT_PTR cAnimWnd::StartAnim(short Delay)
00094 {
00095    INT_PTR ret = SetTimer(TIMER_ID, Delay, NULL);
00096    return ret;
00097 }
00098
00099 BOOL cAnimWnd::StopAnim()
00100 {
00101    if (!KillTimer(TIMER_ID))
00102       return FALSE;
00103
00104    return TRUE;
00105 }
00106
00107 BOOL cAnimWnd::Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID, CCreateContext* pContext)
00108 {
00109         // TODO: Add your specialized code here and/or call the base class
00110    CString wndclass = ::AfxRegisterWndClass(CS_DBLCLKS,
00111      ::LoadCursor(NULL, IDC_ARROW),
00112      ::GetSysColorBrush(COLOR_BTNFACE), 0);
00113
00114         BOOL ret = CWnd::CreateEx(0L, wndclass, NULL, dwStyle, rect, pParentWnd, nID, pContext);
00115
00116    return ret;
00117 }
00118
00119
00120 int cAnimWnd::GetImageCount()
00121 {
00122    BITMAP bm_info;
00123    m_Bitmap.GetBitmap(&bm_info);
00124    int x = bm_info.bmWidth;
00125
00126    return (int)(x / m_Width);
00127 }
00128
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/AnimWnd.h Source File

waitdlg/AnimWnd.h
Go to the documentation of this file.
00001 #if !defined(AFX_cANIMWND_H__7F9C97E1_F7F4_11D2_837C_00500406DAEB__INCLUDED_)
00002 #define AFX_cANIMWND_H__7F9C97E1_F7F4_11D2_837C_00500406DAEB__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // cAnimWnd.h : header file
00008 //
00010 // Author: Todd Andrews
00011 // Email:  tmandrews@mindspring.com
00012 // Copyright 1999, Todd Andrews
00013 //
00014 // You may freely use or modify this code provided this
00015 // Copyright is included in all derived versions.
00016 //
00017 //
00018 // This class implements an animated bitmap
00019
00020 #include "memdc.h"
00021
00023 // cAnimWnd window
00024
00025 #define TIMER_ID 13
00026 class cAnimWnd : public CWnd
00027 {
00028 // Construction
00029 public:
00030         cAnimWnd();
00031
00032 // Attributes
00033 public:
00034
00035 protected:
00036    int            m_ImageIndex;
00037    COLORREF       m_TransparentColor;
00038    short          m_Width;
00039    short          m_Height;
00040    CBitmap        m_Bitmap;
00041    cMemDC         *m_MemDC;
00042
00043 // Operations
00044 public:
00045    void SetImageList(UINT BitmapID, short Size, short Sizey, COLORREF TransparentColor = -1);
00046
00047 // Overrides
00048         // ClassWizard generated virtual function overrides
00049         //{{AFX_VIRTUAL(cAnimWnd)
00050         public:
00051         virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
00052         //}}AFX_VIRTUAL
00053
00054 // Implementation
00055 public:
00056         int GetImageCount();
00057         BOOL StopAnim();
00058         INT_PTR StartAnim(short Delay = 50);
00059         virtual ~cAnimWnd();
00060
00061         // Generated message map functions
00062 protected:
00063         //{{AFX_MSG(cAnimWnd)
00064         afx_msg void OnTimer(UINT nIDEvent);
00065         afx_msg void OnPaint();
00066         //}}AFX_MSG
00067         DECLARE_MESSAGE_MAP()
00068 };
00069
00071
00072 //{{AFX_INSERT_LOCATION}}
00073 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00074
00075 #endif // !defined(AFX_cANIMWND_H__7F9C97E1_F7F4_11D2_837C_00500406DAEB__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/AsciiCmdUtilities.cpp Source File

DeviceIO/AsciiCmdUtilities.cpp
Go to the documentation of this file.
00001 #include "AsciiCmdUtilities.h"
00002
00003 CAsciiCmdUtilities::CAsciiCmdUtilities(void)
00004 {
00005 }
00006
00007 CAsciiCmdUtilities::~CAsciiCmdUtilities(void)
00008 {
00009 }
00010
00011 string CAsciiCmdUtilities::MakeUpper(string StdString)
00012 {
00013   const int length = (int)StdString.length();
00014   for(int i=0; i<length ; ++i)
00015   {
00016     StdString[i] = std::toupper(StdString[i]);
00017   }
00018   return StdString;
00019 }
00020
00021 string CAsciiCmdUtilities::RemWhitespace(string strLine)
00022 {
00023         unsigned int idxCh;
00024         string strCh;
00025         string strNoWSp;
00026
00027         strNoWSp = "";
00028         if (strLine.find_first_of(Whitespace, 0) == std::string::npos) {                // string has no whitespace
00029                 return strLine;
00030         } else {                        // remove whitespace
00031                 for (idxCh=0;idxCh<strLine.length();idxCh++) {
00032                         strCh = strLine.substr(idxCh,1);
00033                         if (strCh.find_first_of(Whitespace, 0) == std::string::npos) {          // char is not whitespace
00034                                 strNoWSp += strCh;
00035                         }
00036                 }
00037                 return strNoWSp;
00038         }
00039 }
00040
00041 //read and format [DP5 Configuration File]
00042 string CAsciiCmdUtilities::GetDP5CfgStr(string strFilename)
00043 {
00044         FILE *txtFile;
00045         char chLine[LINE_MAX];
00046         string strCfg;
00047         string strLine;
00048         long lPos;
00049         char ch;
00050         bool bCfgSection;
00051         int iCmpCfg;
00052         long lPosCfg;
00053         stringex strfn;
00054
00055         bCfgSection = false;
00056         iCmpCfg = 1;
00057         if (( txtFile = fopen(strFilename.c_str(), "r")) == NULL) {  // Can't open input file
00058                 return "";
00059         }
00060         strCfg = "";
00061         while((fgets(chLine, LINE_MAX, txtFile)) != NULL) {
00062                 strLine = strfn.Format("%s",chLine);
00063                 lPosCfg = (long)strLine.find('[');                              // find a section (-1=not found,0=section found,>0=undefined)
00064                 if (lPosCfg == 0) {                                                             // Locate DP5 Configuration Section
00065                         iCmpCfg = (long)strLine.find("[DP5 Configuration File]");
00066                         if (iCmpCfg == 0) {                                                     // Configuration Section Found
00067                                 bCfgSection = true;
00068                         } else {                                                                        // Non-Configuration Section Found
00069                                 bCfgSection = false;
00070                         }
00071                 }
00072                 if (bCfgSection) {                                                              // Save Configuration Section Only
00073                         strLine = MakeUpper(strLine);                           // make all uppercase
00074                         lPos = (long)strLine.find(';');                         // find the delimiter (-1=not found,0=commented line)
00075                         if (lPos > 0) {                                                         // if has delimiter that is not first char
00076                                 strLine = strLine.substr(0,lPos + 1);   // remove string right of delimiter
00077                                 ch = strLine.at(0);
00078                                 if ((ch >= 'A') && (ch <= 'Z')) {               // if is valid value
00079                                         strLine = RemWhitespace(strLine);       // remove whitespace in command sequence
00080                                         if (strLine.length() > 1) {                     // check if command w/delimiter left
00081                                                 strCfg += strLine;                              // add to command string
00082                                         }
00083                                 }
00084                         }
00085                 }
00086                 strLine = "";
00087         }
00088         fclose(txtFile);
00089         if (strCfg.length() > 0) {
00090                 return strCfg;
00091         } else {
00092                 return "";
00093         }
00094 }
00095
00096 //read and format [DP5 SCA Configuration]
00097 string CAsciiCmdUtilities::GetDP5ScaStr(string strFilename)
00098 {
00099         FILE *txtFile;
00100         char chLine[LINE_MAX];
00101         string strCfg;
00102         string strLine;
00103         long lPos;
00104         char ch;
00105         bool bCfgSection;
00106         int iCmpCfg;
00107         long lPosCfg;
00108         stringex strfn;
00109         char chScaOld;
00110         char chSCA;
00111         int iScaBytes;
00112         string strScaIdx;
00113         string strScaCmd = "";
00114
00115         bCfgSection = false;
00116         iCmpCfg = 1;
00117         if (( txtFile = fopen(strFilename.c_str(), "r")) == NULL) {  // Can't open input file
00118                 return "";
00119         }
00120         chScaOld = '0';
00121         chSCA = '9';
00122         strCfg = "";
00123         while((fgets(chLine, LINE_MAX, txtFile)) != NULL) {
00124                 strLine = strfn.Format("%s",chLine);
00125                 lPosCfg = (long)strLine.find('[');                              // find a section (-1=not found,0=section found,>0=undefined)
00126                 if (lPosCfg == 0) {                                                             // Locate DP5 Configuration Section
00127                         iCmpCfg = (long)strLine.find("[DP5 SCA Configuration]");
00128                         if (iCmpCfg == 0) {                                                     // Configuration Section Found
00129                                 bCfgSection = true;
00130                         } else {                                                                        // Non-Configuration Section Found
00131                                 bCfgSection = false;
00132                         }
00133                 }
00134                 if (bCfgSection) {                                                              // Save Configuration Section Only
00135                         strLine = MakeUpper(strLine);                           // make all uppercase
00136                         lPos = (long)strLine.find(';');                         // find the delimiter (-1=not found,0=commented line)
00137                         if (lPos > 0) {                                                         // if has delimiter that is not first char
00138                                 strLine = strLine.substr(0,lPos + 1);   // remove string right of delimiter
00139                                 ch = strLine.at(0);
00140                                 if ((ch >= 'A') && (ch <= 'Z')) {               // if is valid value
00141                                         strLine = RemWhitespace(strLine);       // remove whitespace in command sequence
00142                                         if (strLine.length() > 1) {                     // check if command w/delimiter left
00143                                                 //strCfg += strLine;                            // add to command string
00144                                                 //strcat(strCfg,chLine);                                // add to command string
00145                                                 chSCA = strLine.at(4);                          // determine SCA Index
00146                                                 // remove index from SCA Command to create DPP ASCII Command format
00147                                                 if ((chSCA > '0') && (chSCA < '9')) {
00148                                                         if (chSCA != chScaOld) {                // Is same as current index?
00149                                                                 chScaOld = chSCA;                       // if no, save current index
00150                                                                 // insert index command into string (SCAI=%c;)
00151                                                                 strScaIdx = strfn.Format("SCAI=%c;",chSCA);
00152                                                                 strCfg += strScaIdx;                            // add sca index command to string
00153                                                                 strScaIdx = "";
00154                                                         }
00155                                                         strScaCmd = strLine.substr(0,4);
00156                                                         for (iScaBytes=5;iScaBytes<=lPos;iScaBytes++) {
00157                                                                 strScaCmd += strLine.at(iScaBytes);
00158                                                         }
00159                                                         strCfg += strScaCmd;                            // add to command string
00160                                                 } else {        // no index to remove, cmd was saved with SCAI command
00161                                                         strCfg += strLine;                                      // add to command string
00162                                                 }
00163                                         }
00164                                 }
00165                         }
00166                 }
00167                 strLine = "";
00168         }
00169         fclose(txtFile);
00170         if (strCfg.length() > 0) {
00171                 return strCfg;
00172         } else {
00173                 return "";
00174         }
00175 }
00176
00177 string CAsciiCmdUtilities::CreateResTestReadBackCmd(bool bSendCoarseFineGain, int DppType)
00178 {
00179         string strCfg("");
00180     bool isINOF;
00181
00182     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00183         strCfg = "";
00184         strCfg += "CLCK=?;";
00185         strCfg += "TPEA=?;";
00186         if (bSendCoarseFineGain) { strCfg += "GAIF=?;"; }
00187         if (!bSendCoarseFineGain) { strCfg += "GAIN=?;"; }
00188         strCfg += "RESL=?;";
00189         strCfg += "TFLA=?;";
00190         strCfg += "TPFA=?;";
00191         strCfg += "PURE=?;";
00192         strCfg += "RTDE=?;";
00193         strCfg += "MCAS=?;";
00194         strCfg += "MCAC=?;";
00195         strCfg += "SOFF=?;";
00196         strCfg += "AINP=?;";
00197         if (isINOF) { strCfg += "INOF=?;"; }
00198         if (bSendCoarseFineGain) { strCfg += "GAIA=?;"; }
00199         return strCfg;
00200 }
00201
00202 string CAsciiCmdUtilities::CreateFullReadBackCmd(bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
00203 {
00204         string strCfg("");
00205     bool isHVSE;
00206     bool isPAPS;
00207     bool isTECS;
00208     bool isVOLU;
00209         bool isCON1;
00210         bool isCON2;
00211     bool isINOF;
00212     bool isBOOT;
00213         bool isGATE;
00214     bool isPAPZ;
00215         bool isSCTC;
00216         bool isDP5_DxK=false;
00217         bool isDP5_DxL=false;
00218
00219         if (DppType == dppMCA8000D) {
00220                 strCfg = CreateFullReadBackCmdMCA8000D(DppType);
00221                 return strCfg;
00222         }
00223
00224         // DP5 Rev Dx K,L needs PAPZ
00225         if ((DppType == dppDP5) && isDP5_RevDxGains) {
00226                 if ((DPP_ECO & 0x0F) == 0x0A) {
00227                         isDP5_DxK = true;
00228                 }
00229                 if ((DPP_ECO & 0x0F) == 0x0B) {
00230                         isDP5_DxL = true;
00231                 }
00232         }
00233
00234     isHVSE = (((DppType != dppPX5) && PC5_PRESENT) || DppType == dppPX5);
00235     isPAPS = (DppType != dppDP5G) && (DppType != dppTB5);
00236     isTECS = (((DppType == dppDP5) && PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00237     isVOLU = (DppType == dppPX5);
00238     isCON1 = ((DppType != dppDP5) && (DppType != dppDP5X));
00239     isCON2 = ((DppType != dppDP5) && (DppType != dppDP5X));
00240     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00241     isSCTC = (DppType == dppDP5G) || (DppType == dppTB5);
00242     isBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00243         isGATE = ((DppType == dppDP5) || (DppType == dppDP5X));
00244         isPAPZ = (DppType == dppPX5) || isDP5_DxK || isDP5_DxL;
00245
00246         strCfg = "";
00247         strCfg += "RESC=?;";
00248         strCfg += "CLCK=?;";
00249         strCfg += "TPEA=?;";
00250         strCfg += "GAIF=?;";
00251         strCfg += "GAIN=?;";
00252         strCfg += "RESL=?;";
00253         strCfg += "TFLA=?;";
00254         strCfg += "TPFA=?;";
00255         strCfg += "PURE=?;";
00256         if (isSCTC) { strCfg += "SCTC=?;"; }
00257         strCfg += "RTDE=?;";
00258         strCfg += "MCAS=?;";
00259         strCfg += "MCAC=?;";
00260         strCfg += "SOFF=?;";
00261         strCfg += "AINP=?;";
00262         if (isINOF) { strCfg += "INOF=?;"; }
00263         strCfg += "GAIA=?;";
00264         strCfg += "CUSP=?;";
00265         strCfg += "PDMD=?;";
00266         strCfg += "THSL=?;";
00267         strCfg += "TLLD=?;";
00268         strCfg += "THFA=?;";
00269         strCfg += "DACO=?;";
00270         strCfg += "DACF=?;";
00271         strCfg += "RTDS=?;";
00272         strCfg += "RTDT=?;";
00273         strCfg += "BLRM=?;";
00274         strCfg += "BLRD=?;";
00275         strCfg += "BLRU=?;";
00276         if (isGATE) { strCfg += "GATE=?;"; }
00277         strCfg += "AUO1=?;";
00278         strCfg += "PRET=?;";
00279         strCfg += "PRER=?;";
00280         strCfg += "PREC=?;";
00281         strCfg += "PRCL=?;";
00282         strCfg += "PRCH=?;";
00283         if (isHVSE) { strCfg += "HVSE=?;"; }
00284         if (isTECS) { strCfg += "TECS=?;"; }
00285         if (isPAPZ) { strCfg += "PAPZ=?;"; }
00286         if (isPAPS) { strCfg += "PAPS=?;"; }
00287         strCfg += "SCOE=?;";
00288         strCfg += "SCOT=?;";
00289         strCfg += "SCOG=?;";
00290         strCfg += "MCSL=?;";
00291         strCfg += "MCSH=?;";
00292         strCfg += "MCST=?;";
00293         strCfg += "AUO2=?;";
00294         strCfg += "TPMO=?;";
00295         strCfg += "GPED=?;";
00296         strCfg += "GPIN=?;";
00297         strCfg += "GPME=?;";
00298         strCfg += "GPGA=?;";
00299         strCfg += "GPMC=?;";
00300         strCfg += "MCAE=?;";
00301         if (isVOLU) { strCfg += "VOLU=?;"; }
00302         if (isCON1) { strCfg += "CON1=?;"; }
00303         if (isCON2) { strCfg += "CON2=?;"; }
00304         if (isBOOT) { strCfg += "BOOT=?;"; }
00305         return strCfg;
00306 }
00307
00308 string CAsciiCmdUtilities::CreateFullReadBackCmdMCA8000D(int DppType)
00309 {
00310         string strCfg("");
00311
00312         if (DppType == dppMCA8000D) {
00313                 strCfg += "RESC=?;";
00314                 strCfg += "PURE=?;";
00315                 strCfg += "MCAS=?;";
00316                 strCfg += "MCAC=?;";
00317                 strCfg += "SOFF=?;";
00318                 strCfg += "GAIA=?;";
00319                 strCfg += "PDMD=?;";
00320                 strCfg += "THSL=?;";
00321                 strCfg += "TLLD=?;";
00322                 strCfg += "GATE=?;";
00323                 strCfg += "AUO1=?;";
00324                 //strCfg += "PRET=?;";
00325                 strCfg += "PRER=?;";
00326                 strCfg += "PREL=?;";
00327                 strCfg += "PREC=?;";
00328                 strCfg += "PRCL=?;";
00329                 strCfg += "PRCH=?;";
00330                 strCfg += "SCOE=?;";
00331                 strCfg += "SCOT=?;";
00332                 strCfg += "SCOG=?;";
00333                 strCfg += "MCSL=?;";
00334                 strCfg += "MCSH=?;";
00335                 strCfg += "MCST=?;";
00336                 strCfg += "AUO2=?;";
00337                 strCfg += "GPED=?;";
00338                 strCfg += "GPIN=?;";
00339                 strCfg += "GPME=?;";
00340                 strCfg += "GPGA=?;";
00341                 strCfg += "GPMC=?;";
00342                 strCfg += "MCAE=?;";
00343                 //strCfg += "VOLU=?;";
00344                 //strCfg += "CON1=?;";
00345                 //strCfg += "CON2=?;";
00346                 strCfg += "PDMD=?;";
00347         }
00348         return strCfg;
00349 }
00350
00351 string CAsciiCmdUtilities::RemoveCmd(string strCmd, string strCfgData)
00352 {
00353         int iStart,iEnd,iCmd;
00354         string strNew;
00355
00356         strNew = "";
00357         if (strCfgData.length() < 7) { return strCfgData; }     // no data
00358         if (strCmd.length() != 4) {     return strCfgData; }            // bad command
00359         iCmd = (int)strCfgData.find(strCmd+"=",0);
00360         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
00361         iStart = iCmd;
00362         iEnd = (int)strCfgData.find(";",iCmd);
00363         if (iEnd == -1) { return strCfgData; }                                          // end not found
00364         if (iEnd <= iStart) { return strCfgData; }                                      // unknown error
00365         strNew = strCfgData.substr(0,iStart) + strCfgData.substr(iEnd+1);
00366         return strNew;
00367 }
00368
00370 string CAsciiCmdUtilities::RemoveCmdByDeviceType(string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO)
00371 {
00372         string strCfgData;
00373     bool isHVSE;
00374     bool isPAPS;
00375     bool isTECS;
00376     bool isVOLU;
00377         bool isCON1;
00378         bool isCON2;
00379     bool isINOF;
00380     bool isBOOT;
00381         bool isGATE;
00382         bool isPAPZ;
00383         bool isSCTC;
00384         bool isPREL;
00385         bool isDP5_DxK=false;
00386         bool isDP5_DxL=false;
00387
00388         strCfgData = strCfgDataIn;
00389         if (DppType == dppMCA8000D) {
00390                 strCfgData = Remove_MCA8000D_Cmds(strCfgData,DppType);
00391                 return strCfgData;
00392         }
00393
00394         // DP5 Rev Dx K,L needs PAPZ
00395         if ((DppType == dppDP5) && isDP5_RevDxGains) {
00396                 if ((DPP_ECO & 0x0F) == 0x0A) {
00397                         isDP5_DxK = true;
00398                 }
00399                 if ((DPP_ECO & 0x0F) == 0x0B) {
00400                         isDP5_DxL = true;
00401                 }
00402         }
00403
00404     isHVSE = (((DppType != dppPX5) && PC5_PRESENT) || DppType == dppPX5);
00405     isPAPS = (DppType != dppDP5G) && (DppType != dppTB5);
00406     isTECS = (((DppType == dppDP5) && PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00407     isVOLU = (DppType == dppPX5);
00408     isCON1 = ((DppType != dppDP5) && (DppType != dppDP5X));
00409     isCON2 = ((DppType != dppDP5) && (DppType != dppDP5X));
00410     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00411         isSCTC = (DppType == dppDP5G) || (DppType == dppTB5);
00412     isBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00413         isGATE = ((DppType == dppDP5) || (DppType == dppDP5X));
00414         isPAPZ = (DppType == dppPX5) || isDP5_DxK || isDP5_DxL;
00415         isPREL = (DppType == dppMCA8000D);
00416         if (!isHVSE) { strCfgData = RemoveCmd("HVSE", strCfgData); }  //High Voltage Bias
00417         if (!isPAPS) { strCfgData = RemoveCmd("PAPS", strCfgData); }  //Preamp Voltage
00418         if (!isTECS) { strCfgData = RemoveCmd("TECS", strCfgData); }  //Cooler Temperature
00419         if (!isVOLU) { strCfgData = RemoveCmd("VOLU", strCfgData); }  //px5 speaker
00420         if (!isCON1) { strCfgData = RemoveCmd("CON1", strCfgData); }  //connector 1
00421         if (!isCON2) { strCfgData = RemoveCmd("CON2", strCfgData); }  //connector 2
00422         if (!isINOF) { strCfgData = RemoveCmd("INOF", strCfgData); }  //input offset
00423         if (!isBOOT) { strCfgData = RemoveCmd("BOOT", strCfgData); }  //PC5 On At StartUp
00424         if (!isGATE) { strCfgData = RemoveCmd("GATE", strCfgData); }  //Gate input
00425         if (!isPAPZ) { strCfgData = RemoveCmd("PAPZ", strCfgData); }  //Pole-Zero
00426         if (!isSCTC) { strCfgData = RemoveCmd("SCTC", strCfgData); }  //Scintillator Time Constant
00427         if (!isPREL) { strCfgData = RemoveCmd("PREL", strCfgData); }  //Preset Live Time
00428         return strCfgData;
00429 }
00430
00432 string CAsciiCmdUtilities::RemoveCmdByDeviceTypeDP5DxK(string strCfgDataIn, bool PC5_PRESENT, int DppType)
00433 {
00434         string strCfgData;
00435     bool isHVSE;
00436     bool isPAPS;
00437     bool isTECS;
00438     bool isVOLU;
00439         bool isCON1;
00440         bool isCON2;
00441     bool isINOF;
00442     bool isBOOT;
00443         bool isGATE;
00444         bool isPAPZ;
00445         bool isSCTC;
00446         bool isPREL;
00447
00448         strCfgData = strCfgDataIn;
00449         //if (DppType == dppMCA8000D) {
00450         //      strCfgData = Remove_MCA8000D_Cmds(strCfgData,DppType);
00451         //      return strCfgData;
00452         //}
00453     isHVSE = (((DppType != dppPX5) && PC5_PRESENT) || DppType == dppPX5);
00454     isPAPS = (DppType != dppDP5G) && (DppType != dppTB5);
00455     isTECS = (((DppType == dppDP5) && PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00456     isVOLU = (DppType == dppPX5);
00457     isCON1 = ((DppType != dppDP5) && (DppType != dppDP5X));
00458     isCON2 = ((DppType != dppDP5) && (DppType != dppDP5X));
00459     isINOF = (DppType != dppDP5G) && (DppType != dppTB5);
00460         isSCTC = (DppType == dppDP5G) || (DppType == dppTB5);
00461     isBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00462         isGATE = ((DppType == dppDP5) || (DppType == dppDP5X));
00463         //isPAPZ = (DppType == dppPX5);         // DP5 Rev Dx K,L needs PAPZ
00464         isPAPZ = true;                                                  // DP5 Rev Dx K,L needs PAPZ
00465         isPREL = (DppType == dppMCA8000D);
00466         if (!isHVSE) { strCfgData = RemoveCmd("HVSE", strCfgData); }  //High Voltage Bias
00467         if (!isPAPS) { strCfgData = RemoveCmd("PAPS", strCfgData); }  //Preamp Voltage
00468         if (!isTECS) { strCfgData = RemoveCmd("TECS", strCfgData); }  //Cooler Temperature
00469         if (!isVOLU) { strCfgData = RemoveCmd("VOLU", strCfgData); }  //px5 speaker
00470         if (!isCON1) { strCfgData = RemoveCmd("CON1", strCfgData); }  //connector 1
00471         if (!isCON2) { strCfgData = RemoveCmd("CON2", strCfgData); }  //connector 2
00472         if (!isINOF) { strCfgData = RemoveCmd("INOF", strCfgData); }  //input offset
00473         if (!isBOOT) { strCfgData = RemoveCmd("BOOT", strCfgData); }  //PC5 On At StartUp
00474         if (!isGATE) { strCfgData = RemoveCmd("GATE", strCfgData); }  //Gate input
00475         if (!isPAPZ) { strCfgData = RemoveCmd("PAPZ", strCfgData); }  //Pole-Zero
00476         if (!isSCTC) { strCfgData = RemoveCmd("SCTC", strCfgData); }  //Scintillator Time Constant
00477         if (!isPREL) { strCfgData = RemoveCmd("PREL", strCfgData); }  //Preset Live Time
00478         return strCfgData;
00479 }
00480
00482 string CAsciiCmdUtilities::Remove_MCA8000D_Cmds(string strCfgDataIn, int DppType)
00483 {
00484         string strCfgData;
00485
00486         strCfgData = strCfgDataIn;
00487         if (DppType == dppMCA8000D) {
00488                 strCfgData = RemoveCmd("CLCK", strCfgData);
00489                 strCfgData = RemoveCmd("TPEA", strCfgData);
00490                 strCfgData = RemoveCmd("GAIF", strCfgData);
00491                 strCfgData = RemoveCmd("GAIN", strCfgData);
00492                 strCfgData = RemoveCmd("RESL", strCfgData);
00493                 strCfgData = RemoveCmd("TFLA", strCfgData);
00494                 strCfgData = RemoveCmd("TPFA", strCfgData);
00495                 //strCfgData = RemoveCmd("PURE", strCfgData);
00496                 strCfgData = RemoveCmd("RTDE", strCfgData);
00497                 strCfgData = RemoveCmd("AINP", strCfgData);
00498                 strCfgData = RemoveCmd("INOF", strCfgData);
00499                 strCfgData = RemoveCmd("CUSP", strCfgData);
00500                 strCfgData = RemoveCmd("THFA", strCfgData);
00501                 strCfgData = RemoveCmd("DACO", strCfgData);
00502                 strCfgData = RemoveCmd("DACF", strCfgData);
00503                 strCfgData = RemoveCmd("RTDS", strCfgData);
00504                 strCfgData = RemoveCmd("RTDT", strCfgData);
00505                 strCfgData = RemoveCmd("BLRM", strCfgData);
00506                 strCfgData = RemoveCmd("BLRD", strCfgData);
00507                 strCfgData = RemoveCmd("BLRU", strCfgData);
00508                 strCfgData = RemoveCmd("PRET", strCfgData);
00509                 strCfgData = RemoveCmd("HVSE", strCfgData);
00510                 strCfgData = RemoveCmd("TECS", strCfgData);
00511                 strCfgData = RemoveCmd("PAPZ", strCfgData);
00512                 strCfgData = RemoveCmd("PAPS", strCfgData);
00513                 strCfgData = RemoveCmd("TPMO", strCfgData);
00514                 strCfgData = RemoveCmd("SCAH", strCfgData);
00515                 strCfgData = RemoveCmd("SCAI", strCfgData);
00516                 strCfgData = RemoveCmd("SCAL", strCfgData);
00517                 strCfgData = RemoveCmd("SCAO", strCfgData);
00518                 strCfgData = RemoveCmd("SCAW", strCfgData);
00519                 strCfgData = RemoveCmd("BOOT", strCfgData);
00520
00521                 // added to list late, recheck at later date 20120817
00522                 strCfgData = RemoveCmd("CON1", strCfgData);
00523                 strCfgData = RemoveCmd("CON2", strCfgData);
00524
00525                 // not implemented as of 20120817, will be implemented at some time
00526                 strCfgData = RemoveCmd("VOLU", strCfgData);
00527         }
00528         return strCfgData;
00529 }
00530
00531 // replaces all occurrences of substring in string
00532 std::string CAsciiCmdUtilities::ReplaceCmdText(std::string strInTextIn, std::string strFrom, std::string strTo)
00533 {
00534         std::string strReplaceText;
00535         std::string strInText;
00536         std::string strOutText;
00537         int lFromLen;
00538         int lMatchPos;
00539
00540         strInText = strInTextIn;
00541         strOutText = "";
00542         lFromLen = (int)strFrom.length();
00543         while (strInText.length()>0) {
00544                 lMatchPos = (1+(int)strInText.find(strFrom));
00545                 if (lMatchPos==0) {
00546                         strOutText = strOutText+strInText;
00547                         strInText = "";
00548                 } else {
00549                         strOutText = strOutText+strInText.substr(0,lMatchPos-1)+strTo;
00550                         strInText = std::string(strInText).substr(lMatchPos+lFromLen-1);
00551                 }
00552         }
00553         strReplaceText = strOutText;
00554         return strReplaceText;
00555 }
00556
00557 // breaks ASCII Command string into two chuncks, returns split position
00558 int CAsciiCmdUtilities::GetCmdChunk(std::string strCmd)
00559 {
00560         int GetCmdChunk = 0;
00561         int idxCfg;
00562         int lChunk;
00563         int lEnd;
00564         GetCmdChunk = 0;
00565         lChunk = 0;
00566         lEnd = 0;
00567         for(idxCfg=1; idxCfg<=(int)strCmd.length();idxCfg++) {
00568                 lChunk = (int)(1+strCmd.find(";", lEnd));
00569                 if ((lChunk==0) || (lChunk>512)) {
00570                         break;
00571                 }
00572                 lEnd = lChunk;
00573         }
00574         GetCmdChunk = lEnd;
00575         return GetCmdChunk;
00576 }
00577
00578 bool CAsciiCmdUtilities::CopyAsciiData(unsigned char Data[], string strCfg, long lLen)
00579 {
00580         long idxData;
00581         const char *c_str1 = strCfg.c_str();
00582
00583         if (lLen > 0) {
00584                 for(idxData=0;idxData<lLen;idxData++) {
00585                         Data[idxData] = c_str1[idxData];
00586                 }
00587                 return true;
00588         } else {
00589                 return false;
00590         }
00591         return false;
00592 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/AsciiCmdUtilities.h Source File

DeviceIO/AsciiCmdUtilities.h
Go to the documentation of this file.
00001 #pragma once
00002 #include <stdlib.h>
00003 #include <stdio.h>
00004 #include <math.h>
00005 #include <string>
00006 #include <cctype> // std::toupper, std::tolower
00007 using namespace std;
00008 #include "stringex.h"
00009 #include "DppConst.h"
00010
00011 #ifndef LINE_MAX
00012         #define LINE_MAX 256
00013 #endif
00014 #define DP4_PX4_OLD_CFG_SIZE 64
00015 #define DP5_MAX_CFG_SIZE 512            /// 512 + 8 Bytes (2 SYNC,2 PID,2 LEN,2 CHKSUM)
00016 #define Whitespace "\t\n\v\f\r\0x20"    /// $ = Chr$(0) + Chr$(9) + Chr$(10) + Chr$(11) + Chr$(12) + Chr$(13) + Chr$(32)
00017
00018 class CAsciiCmdUtilities
00019 {
00020 public:
00021         CAsciiCmdUtilities(void);
00022         ~CAsciiCmdUtilities(void);
00024         std::string MakeUpper(std::string myString);
00026         std::string RemWhitespace(std::string strLine);
00028         std::string GetDP5CfgStr(std::string strFilename);
00030         std::string GetDP5ScaStr(std::string strFilename);
00031         std::string CreateResTestReadBackCmd(bool bSendCoarseFineGain, int DppType);
00033         std::string CreateFullReadBackCmd(bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO);
00035         std::string CreateFullReadBackCmdMCA8000D(int DppType);
00037         std::string RemoveCmd(std::string strCmd, std::string strCfgData);
00039         std::string RemoveCmdByDeviceType(std::string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO);
00041         std::string RemoveCmdByDeviceTypeDP5DxK(std::string strCfgDataIn, bool PC5_PRESENT, int DppType);
00043         std::string Remove_MCA8000D_Cmds(std::string strCfgDataIn, int DppType);
00044         // replaces all occurrences of substring in string
00045         std::string ReplaceCmdText(std::string strInTextIn, std::string strFrom, std::string strTo);
00046         // breaks ASCII Command string into two chuncks, returns split position
00047         int GetCmdChunk(std::string strCmd);
00049         bool CopyAsciiData(unsigned char Data[], string strCfg, long lLen);
00050 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/BootOptPage.cpp Source File

DP5Cfg/BootOptPage.cpp
Go to the documentation of this file.
00001 // BootOptPage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "resource.h"
00006 #include "BootOptPage.h"
00007 #include ".\BootOptPage.h"
00008
00009 #ifdef _DEBUG
00010 #define new DEBUG_NEW
00011 #undef THIS_FILE
00012 static char THIS_FILE[] = __FILE__;
00013 #endif
00014
00016 // CBootOptPage property page
00017
00018 IMPLEMENT_DYNCREATE(CBootOptPage, CCfgPropPage)
00019
00020 CBootOptPage::CBootOptPage() : CCfgPropPage(CBootOptPage::IDD)
00021 {
00022         //{{AFX_DATA_INIT(CBootOptPage)
00023                 // NOTE: the ClassWizard will add member initialization here
00024         //}}AFX_DATA_INIT
00025 }
00026
00027 CBootOptPage::~CBootOptPage()
00028 {
00029
00030 }
00031
00032 void CBootOptPage::DoDataExchange(CDataExchange* pDX)
00033 {
00034         CCfgPropPage::DoDataExchange(pDX);
00035         //{{AFX_DATA_MAP(CBootOptPage)
00036         //}}AFX_DATA_MAP
00037         DDX_Control(pDX, IDC_STATIC_BOOTOPT_PAGE, m_BootOptPageLabel);
00038 }
00039
00040 BEGIN_MESSAGE_MAP(CBootOptPage, CCfgPropPage)
00041         //{{AFX_MSG_MAP(CBootOptPage)
00042         //}}AFX_MSG_MAP
00043 END_MESSAGE_MAP()
00044
00046 // CBootOptPage message handlers
00047
00048 BOOL CBootOptPage::OnSetActive()
00049 {
00050         // TODO: Add your specialized code here and/or call the base class
00051         if (s.ReloadCfg) { InitControls(); }
00052         return CCfgPropPage::OnSetActive();
00053 }
00054
00055 BOOL CBootOptPage::OnInitDialog()
00056 {
00057         CCfgPropPage::OnInitDialog();
00058
00059         m_BootOptPageLabel
00060                 .SetFontName("Arial")
00061                 .SetFontSize(24)
00062                 .SetTextColor(RGB(0,0,255))
00063                 .SetBkColor(RGB(244, 243, 238))
00064                 .SetFontItalic(TRUE)
00065                 .SetFontBold(TRUE);
00066
00067         InitControls();
00068
00069         // TODO:  Add extra initialization here
00070
00071         return TRUE;  // return TRUE unless you set the focus to a control
00072         // EXCEPTION: OCX Property Pages should return FALSE
00073 }
00074
00075
00076 void CBootOptPage::InitControls()
00077 {
00078         HWND hPage = this->GetSafeHwnd();
00079
00080 }
00081
00082 void CBootOptPage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00083 {
00084         int cboDP5CtrlID = cfg.ListCtrlID;
00085         int txtDP5CtrlID = cfg.TextCtrlID;
00086         CString cstrVal = cfg.Setting;
00087         int idxList;
00088         CString cstrUnits;
00089         CString cstrLimits;
00090
00091         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00092                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00093                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,cstrVal);
00094                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00095                         if ((cfg.CtrlType & dctTxt) > 0) {      // if cbotxt must find mask, else set to 0
00096                                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"#");
00097                                 if (idxList == LB_ERR) { // mask begins with +
00098                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"+");
00099                                 }
00100                                 if (idxList == LB_ERR) { // mask begins with -
00101                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"-");
00102                                 }
00103                                 if (idxList == LB_ERR) { // not found default to 0
00104                                         idxList = 0;
00105                                 }
00106                         } else {
00107                                 idxList = 0;            // set to first item
00108                         }
00109                 }
00110                 cb.SetCurSel(idxList);
00111         }
00112 }
00113
00114 // pass dci id to update combo control and display edit controls if any
00115 void CBootOptPage::CboUpdate(int nID_dci)
00116 {
00117         CString cstrCboText;
00118         int nID;
00119
00120         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00121         if (nID == NULL) { return; }
00122         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00123         int idx = cb.GetCurSel();
00124         if (idx > LB_ERR) {
00125                 cb.GetLBText(idx,cstrCboText);
00126                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00127                 s.m_DP5Cfg[nID_dci].ComboValue = cstrCboText;
00128         } else {
00129                 return;
00130         }
00131 }
00132
00133
00134
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/BootOptPage.h Source File

DP5Cfg/BootOptPage.h
Go to the documentation of this file.
00001 #if !defined(AFX_BootOptPage_H__INCLUDED_)
00002 #define AFX_BootOptPage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // BootOptPage.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "afxwin.h"
00012 #include "label.h"
00013
00015 // CBootOptPage dialog
00016
00017 class CBootOptPage : public CCfgPropPage
00018 {
00019         DECLARE_DYNCREATE(CBootOptPage)
00020
00021 // Construction
00022 public:
00023         CBootOptPage();
00024         ~CBootOptPage();
00025
00026 // Dialog Data
00027         //{{AFX_DATA(CBootOptPage)
00028         enum { IDD = IDD_BOOTOPT_PAGE };
00029         //}}AFX_DATA
00030
00031 // Overrides
00032         // ClassWizard generate virtual function overrides
00033         //{{AFX_VIRTUAL(CBootOptPage)
00034         protected:
00035         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00036         //}}AFX_VIRTUAL
00037
00038 // Implementation
00039 protected:
00040         // Generated message map functions
00041         //{{AFX_MSG(CBootOptPage)
00042         //}}AFX_MSG
00043         DECLARE_MESSAGE_MAP()
00044
00045 public:
00046         //CStatic m_BootOptPageLabel;
00047         CLabel m_BootOptPageLabel;
00048         virtual BOOL OnSetActive();
00049         virtual BOOL OnInitDialog();
00050
00051         void InitControls();
00052         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00053         void CboUpdate(int nID_dci);
00054
00055 };
00056
00057 //{{AFX_INSERT_LOCATION}}
00058 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00059
00060 #endif // !defined(AFX_BootOptPage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/CfgPropSheet.cpp Source File

DP5Cfg/CfgPropSheet.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include <afxpriv.h>
00003 #include "CfgPropSheet.h"
00004 #include ".\cfgpropsheet.h"
00005
00006 #ifdef _DEBUG
00007 #define new DEBUG_NEW
00008 #undef THIS_FILE
00009 static char THIS_FILE[] = __FILE__;
00010 #endif
00011
00012 static UINT BASED_CODE DP5Buttons[] =
00013 {
00014         ID_FILE_TAB,
00015         ID_MCA_TAB,
00016         ID_SHAPING_TAB,
00017         ID_GAINPZ_TAB,
00018         ID_POWER_TAB,
00019         ID_MISC_TAB
00020 };
00021
00022
00024 // CCfgPropSheet
00025
00026 IMPLEMENT_DYNAMIC(CCfgPropSheet, CPropertySheet)
00027
00028 CCfgPropSheet::CCfgPropSheet(UINT nIDCaption, CWnd* pParentWnd, UINT iSelectPage, HBITMAP hbmWatermark, HPALETTE hpalWatermark, HBITMAP hbmHeader)
00029         :CPropertySheet(nIDCaption,pParentWnd,iSelectPage,hbmWatermark,hpalWatermark,hbmHeader)
00030 {
00031         m_bResetPrompt = FALSE;
00032
00033         m_bToolTips = FALSE;
00034         m_bStatusBar = FALSE;
00035         m_bToolBar = FALSE;
00036
00037         m_bKillItself = TRUE;
00038
00039         m_bModal = TRUE;
00040
00041         m_Timer = 0;
00042
00043         ActivePage = ID_FILE_TAB;
00044 }
00045
00046 CCfgPropSheet::CCfgPropSheet(LPCTSTR pszCaption, CWnd* pParentWnd, UINT iSelectPage, HBITMAP hbmWatermark, HPALETTE hpalWatermark, HBITMAP hbmHeader)
00047         :CPropertySheet(pszCaption,pParentWnd,iSelectPage,hbmWatermark,hpalWatermark,hbmHeader)
00048 {
00049         m_bResetPrompt = FALSE;
00050
00051         m_bToolTips = FALSE;
00052         m_bStatusBar = FALSE;
00053         m_bToolBar = FALSE;
00054
00055         m_bKillItself = TRUE;
00056
00057         m_bModal = FALSE;
00058
00059         m_Timer = 0;
00060         ActivePage = ID_FILE_TAB;
00061
00062 }
00063
00064 BOOL CCfgPropSheet::InitCfgPropSheet(BOOL bToolTips, BOOL bStatusBar, UINT *pIndicators, UINT nIndicators, UINT uiMenu, UINT uiToolBar, DWORD dwToolBarStyle)
00065 {
00066         if (bToolTips) {
00067                 EnableToolTips(TRUE);
00068
00069                 m_bToolTips = TRUE;
00070
00071                 for (int i = 0; i < GetPageCount(); i++) {
00072                         GetPage(i)->EnableToolTips(TRUE);
00073                 }
00074         }
00075
00076         if (bStatusBar) {
00077                 if (pIndicators) {
00078                         if (!m_CSBCtrlStatus.Create(this) ||
00079                                 !m_CSBCtrlStatus.SetIndicators(pIndicators,nIndicators )) {
00080                                 TRACE(_T("Failed to create status bar\n"));
00081                                 return FALSE;      // fail to create
00082                         }
00083                 } else {
00084                         UINT indicators[] = {
00085                                                                         ID_SEPARATOR,
00086                                                                         ID_INDICATOR_CAPS,
00087                                                                         ID_INDICATOR_NUM,
00088                                                                         ID_INDICATOR_SCRL,
00089                                                                 };
00090                         if (!m_CSBCtrlStatus.Create(this) ||
00091                                 !m_CSBCtrlStatus.SetIndicators(indicators,4)) {
00092                                 TRACE(_T("Failed to create status bar\n"));
00093                                 return FALSE;      // fail to create
00094                         }
00095                 }
00096                 OnSetMessageString(AFX_IDS_IDLEMESSAGE);
00097                 m_CSBCtrlStatus.SetPaneInfo(0, m_CSBCtrlStatus.GetItemID(0),SBPS_STRETCH, NULL );
00098                 m_bStatusBar = TRUE;
00099         }
00100
00101         if (uiToolBar) {
00102                 if (m_CSToolBar.CreateEx(this,dwToolBarStyle)) {
00103
00104                         m_CSToolBar.LoadToolBar(uiToolBar);
00105                         m_CSToolBar.SetButtons(DP5Buttons,7);
00106                         m_CSToolBar.SetSizes(CSize(60,60),CSize(24,23));
00107                         m_CSToolBar.SetButtonText(0,_T("&General"));
00108                         m_CSToolBar.SetButtonText(1,_T("&MCA"));
00109                         m_CSToolBar.SetButtonText(2,_T("&Shaping"));
00110                         m_CSToolBar.SetButtonText(3,_T("&Gain"));
00111                         m_CSToolBar.SetButtonText(4,_T("&Power"));
00112                         m_CSToolBar.SetButtonText(5,_T("M&isc"));
00113                         //m_CSToolBar.SetButtonText(6,_T("&BootOpt"));
00114
00115                         //,RGB(255, 255, 255
00116                         if (m_bToolTips) m_CSToolBar.EnableToolTips();
00117
00118                         m_bToolBar = TRUE;
00119
00120                 } else {
00121                         TRACE(_T("Failed to create toolbar bar\n"));
00122                         return FALSE;
00123                 }
00124         }
00125
00126         if (bStatusBar || uiToolBar || uiMenu) {
00127                 CRect rcClientStart;
00128                 CRect rcClientNow;
00129                 GetClientRect(rcClientStart);
00130                 RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, 0, reposQuery, rcClientNow);
00131
00132                 CPoint ptOffset(rcClientNow.left - rcClientStart.left,(rcClientNow.top - rcClientStart.top) / 4);
00133
00134                 CRect  rcChild;
00135                 CWnd* pwndChild = GetWindow(GW_CHILD);
00136                 while (pwndChild) {
00137                         pwndChild->GetWindowRect(rcChild);
00138                         ScreenToClient(rcChild);
00139                         rcChild.OffsetRect(ptOffset);
00140                         pwndChild->MoveWindow(rcChild, FALSE);
00141                         pwndChild = pwndChild->GetNextWindow();
00142                 }
00143
00144                 CRect rcWindow;
00145                 GetWindowRect(rcWindow);
00146                 rcWindow.right += rcClientStart.Width() - rcClientNow.Width();
00147                 if (bStatusBar) {
00148                         WINDOWPLACEMENT plc;
00149                         m_CSBCtrlStatus.GetWindowPlacement(&plc);
00150                         rcWindow.bottom += (rcClientStart.Height() - rcClientNow.Height()) - (plc.rcNormalPosition.top * 3);
00151                 } else {
00152                         rcWindow.bottom += rcClientStart.Height() - rcClientNow.Height() - 7;
00153                 }
00154                 MoveWindow(rcWindow, FALSE);
00155                 RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, 0);
00156         }
00157         GetTabControl()->ShowWindow(SW_HIDE);   // hide the tab control
00158         if (!m_bModal) {
00159                 m_Timer = (UINT)SetTimer(666, 100, NULL);
00160         }
00161         return TRUE;
00162 }
00163
00164 void CCfgPropSheet::AddPage( CCfgPropPage* pPage )
00165 {
00166         CPropertySheet::AddPage((CPropertyPage *)pPage);
00167 }
00168
00169 BEGIN_MESSAGE_MAP(CCfgPropSheet, CPropertySheet)
00170         //{{AFX_MSG_MAP(CCfgPropSheet)
00171         ON_COMMAND(ID_APP_EXIT, OnTB1)
00172         // Begin Tab Controls
00173         ON_COMMAND(ID_FILE_TAB, OnFileTab)
00174         ON_COMMAND(ID_MCA_TAB, OnMcaTab)
00175         ON_COMMAND(ID_SHAPING_TAB, OnShapingTab)
00176         ON_COMMAND(ID_GAINPZ_TAB, OnGainPzTab)
00177         ON_COMMAND(ID_POWER_TAB, OnPowerTab)
00178         ON_COMMAND(ID_MISC_TAB, OnMiscTab)
00179
00180         ON_UPDATE_COMMAND_UI(ID_FILE_TAB, OnFileTab2)
00181         ON_UPDATE_COMMAND_UI(ID_MCA_TAB, OnMcaTab2)
00182         ON_UPDATE_COMMAND_UI(ID_SHAPING_TAB, OnShapingTab2)
00183         ON_UPDATE_COMMAND_UI(ID_GAINPZ_TAB, OnGainPzTab2)
00184         ON_UPDATE_COMMAND_UI(ID_POWER_TAB, OnPowerTab2)
00185         ON_UPDATE_COMMAND_UI(ID_MISC_TAB, OnMiscTab2)
00186
00187         // End Tab Controls
00188         ON_WM_ENTERIDLE()
00189     ON_MESSAGE(WM_POPMESSAGESTRING, OnPopMessageString)
00190         ON_MESSAGE(WM_SETMESSAGESTRING, OnSetMessageString)
00191         ON_WM_MENUSELECT()
00192         ON_UPDATE_COMMAND_UI(ID_INDICATOR_NUM, OnUpdateKeyIndicator)
00193         ON_UPDATE_COMMAND_UI(ID_VIEW_STATUS_BAR, OnUpdateStatusBarMenu)
00194         ON_COMMAND(ID_VIEW_STATUS_BAR, OnStatusBarCheck)
00195         ON_COMMAND(ID_VIEW_TOOLBAR, OnToolBarCheck)
00196         ON_UPDATE_COMMAND_UI(ID_VIEW_TOOLBAR, OnUpdateToolBarMenu)
00197         ON_WM_MOUSEMOVE()
00198         ON_WM_INITMENUPOPUP()
00199         ON_MESSAGE(WM_KICKIDLE, OnKickIdle)
00200         ON_UPDATE_COMMAND_UI(ID_INDICATOR_CAPS, OnUpdateKeyIndicator)
00201         ON_UPDATE_COMMAND_UI(ID_INDICATOR_SCRL, OnUpdateKeyIndicator)
00202         //ON_COMMAND(IDOK, OnOK)
00203         ON_COMMAND(IDCANCEL, OnCancel)
00204         ON_WM_TIMER()
00205         //}}AFX_MSG_MAP
00206         ON_NOTIFY_EX_RANGE(TTN_NEEDTEXTW, 0, 0xFFFF, OnToolTipText)
00207         ON_NOTIFY_EX_RANGE(TTN_NEEDTEXTA, 0, 0xFFFF, OnToolTipText)
00208 END_MESSAGE_MAP()
00209
00211 // CCfgPropSheet message handlers
00212
00213 void CCfgPropSheet::GetCurrentButtonState()
00214 {
00215
00216
00217       UINT iButtonID;
00218       UINT iButtonStyle;
00219       int iButtonImage;
00220           CString strState;
00221
00222       // If the Toolbar is not based upon the default "AFX_IDW_TOOLBAR"
00223       // constant, then replace its use with the valid Toolbar constant.
00224
00225       // If the following line is used from the Frame Window remove
00226       //"GetParentFrame()->":
00227       //CToolBar* pBar = &m_bToolBar;
00228       //(CToolBar*)GetParentFrame()->GetDescendantWindow(AFX_IDW_TOOLBAR);
00229
00230       // If this code sample is called from an AppWizard generated,
00231       // Frame Window member function in Visual C++ 4.0, replace the above
00232       // statement with the following. Recall that the CMDIFrameWnd-derived
00233       // Frame Window generated by AppWizard has a CToolBar m_wndToolBar
00234       // member.
00235       //CToolBar* pBar = &m_wndToolBar;
00236           //CToolBar* pBar = &m_bToolBar;
00237           CToolBar* pBar = &m_CSToolBar;
00238
00239       if (pBar != NULL) {
00240
00241            // Use the relevant Button ID for the following line:
00242            int iButtonIndex = pBar->CommandToIndex(ID_FILE_TAB);
00243
00244            pBar->GetButtonInfo(iButtonIndex, iButtonID, iButtonStyle, iButtonImage);
00245
00246            // The following code checks for all possible states.
00247            // In practice, check only for those states that you need.
00248
00249            if (iButtonStyle & TBBS_PRESSED)
00250                 strState = "Button Down";
00251            else
00252                 if (iButtonStyle & (TBBS_CHECKED & TBBS_DISABLED))
00253                      strState = "Button Down & Unavailable";
00254                 else
00255                      if (iButtonStyle & TBBS_DISABLED)
00256                           strState = "Button Disabled";
00257                      else
00258                           if (iButtonStyle & TBBS_INDETERMINATE)
00259                                strState = "Button State Indeterminate";
00260                           else
00261                                if (iButtonStyle & TBBS_CHECKED)
00262                                     strState = "Button Checked";
00263                                else
00264                                     strState = "Button Up & Enabled";
00265                    AfxMessageBox(strState);
00266           }
00267 }
00268
00269 void CCfgPropSheet::OnFileTab()
00270 {
00271
00272         ActivePage = ID_FILE_TAB;
00273         SetActivePage(0);
00274
00275         if (m_bToolBar) {
00276                 //GetCurrentButtonState();
00277         }
00278 }
00279
00280 void CCfgPropSheet::OnMcaTab()
00281 {
00282         ActivePage = ID_MCA_TAB;
00283         SetActivePage(1);
00284 }
00285 void CCfgPropSheet::OnShapingTab()
00286 {
00287         ActivePage = ID_SHAPING_TAB;
00288         SetActivePage(2);
00289 }
00290 void CCfgPropSheet::OnGainPzTab()
00291 {
00292         ActivePage = ID_GAINPZ_TAB;
00293         SetActivePage(3);
00294 }
00295 void CCfgPropSheet::OnPowerTab()
00296 {
00297         ActivePage = ID_POWER_TAB;
00298         SetActivePage(4);
00299 }
00300 void CCfgPropSheet::OnMiscTab()
00301 {
00302         ActivePage = ID_MISC_TAB;
00303         SetActivePage(5);
00304 }
00305
00306 void CCfgPropSheet::OnSelectTab(UINT NewActivePage, int nPage)
00307 {
00308         ActivePage = NewActivePage;
00309         SetActivePage(nPage);
00310 }
00311
00312 void CCfgPropSheet::UpdateAll()
00313 {
00314         ActivePage = ID_FILE_TAB;
00315         SetActivePage(0);
00316
00317         ActivePage = ID_MCA_TAB;
00318         SetActivePage(1);
00319
00320         ActivePage = ID_SHAPING_TAB;
00321         SetActivePage(2);
00322
00323         ActivePage = ID_GAINPZ_TAB;
00324         SetActivePage(3);
00325
00326         ActivePage = ID_POWER_TAB;
00327         SetActivePage(4);
00328
00329         ActivePage = ID_MISC_TAB;
00330         SetActivePage(5);
00331
00332         //ActivePage = ID_BOOTOPT_TAB;
00333         //SetActivePage(6);
00334
00335         ActivePage = ID_FILE_TAB;
00336         SetActivePage(0);
00337
00338         GetPage(0)->SetModified(FALSE);
00339         GetPage(1)->SetModified(FALSE);
00340         GetPage(2)->SetModified(FALSE);
00341         GetPage(3)->SetModified(FALSE);
00342         GetPage(4)->SetModified(FALSE);
00343         GetPage(5)->SetModified(FALSE);
00344 }
00345
00346 // ====================================
00347
00348 void CCfgPropSheet::OnFileTab2(CCmdUI* pCmdUI)
00349 {
00350         pCmdUI->Enable(s.HaveConfig);
00351         pCmdUI->SetCheck(ActivePage == ID_FILE_TAB);
00352 }
00353
00354 void CCfgPropSheet::OnMcaTab2(CCmdUI* pCmdUI)
00355 {
00356         pCmdUI->Enable(s.HaveConfig);
00357         pCmdUI->SetCheck(ActivePage == ID_MCA_TAB);
00358 }
00359 void CCfgPropSheet::OnShapingTab2(CCmdUI* pCmdUI)
00360 {
00361         if (s.profile->device_type == dppMCA8000D) {
00362                 pCmdUI->Enable(false);
00363         } else {
00364                 pCmdUI->Enable(s.HaveConfig);
00365         }
00366         pCmdUI->SetCheck(ActivePage == ID_SHAPING_TAB);
00367 }
00368 void CCfgPropSheet::OnGainPzTab2(CCmdUI* pCmdUI)
00369 {
00370         if (s.profile->device_type == dppMCA8000D) {
00371                 pCmdUI->Enable(false);
00372         } else {
00373                 pCmdUI->Enable(s.HaveConfig);
00374         }
00375         pCmdUI->SetCheck(ActivePage == ID_GAINPZ_TAB);
00376 }
00377 void CCfgPropSheet::OnPowerTab2(CCmdUI* pCmdUI)
00378 {
00379         if (s.profile->device_type == dppMCA8000D) {
00380                 pCmdUI->Enable(false);
00381         } else {
00382                 pCmdUI->Enable(s.HaveConfig);
00383         }
00384         pCmdUI->SetCheck(ActivePage == ID_POWER_TAB);
00385 }
00386 void CCfgPropSheet::OnMiscTab2(CCmdUI* pCmdUI)
00387 {
00388         if (s.profile->device_type == dppMCA8000D) {
00389                 pCmdUI->Enable(false);
00390         } else {
00391                 pCmdUI->Enable(s.HaveConfig);
00392         }
00393         pCmdUI->SetCheck(ActivePage == ID_MISC_TAB);
00394 }
00395
00396 void CCfgPropSheet::OnTB1()
00397 {
00398         AfxMessageBox("TB1");
00399 }
00400
00401 INT_PTR CCfgPropSheet::DoModal()
00402 {
00403         m_bKillItself = FALSE;
00404         m_bModal = TRUE;
00405         return CPropertySheet::DoModal();
00406 }
00407
00408 void CCfgPropSheet::PostNcDestroy()
00409 {
00410         if (!m_bKillItself) {
00411                 CPropertySheet::PostNcDestroy();
00412         }
00413 }
00414
00415 void CCfgPropSheet::OnCancel()
00416 {
00417         if (m_bKillItself) {
00418                 DestroyWindow();
00419         } else {
00420                 CCfgPropSheet::EndDialog(IDCANCEL);
00421         }
00422 }
00423
00424 void CCfgPropSheet::OnEnterIdle(UINT nWhy, CWnd* pWho)
00425 {
00426         CPropertySheet::OnEnterIdle(nWhy, pWho);
00427
00428         if (AfxGetApp()->m_pMainWnd != this) {
00429                 if (m_bStatusBar) m_CSBCtrlStatus.SendMessage(WM_IDLEUPDATECMDUI);
00430                 if (m_bToolBar) m_CSToolBar.SendMessage(WM_IDLEUPDATECMDUI,TRUE);
00431         }
00432
00433         if (nWhy != MSGF_MENU || m_nIDTracking == m_nIDLastMessage) {
00434                 return;
00435         }
00436
00437         OnSetMessageString(m_nIDTracking);
00438         ASSERT(m_nIDTracking == m_nIDLastMessage);
00439 }
00440
00441 void CCfgPropSheet::OnInitMenuPopup(CMenu* pPopupMenu, UINT nIndex, BOOL bSysMenu)
00442 {
00443         CPropertySheet::OnInitMenuPopup(pPopupMenu, nIndex, bSysMenu);
00444
00445         if (!bSysMenu) {
00446                 ASSERT(pPopupMenu != NULL);
00447
00448                 CCmdUI state;
00449                 state.m_pMenu = pPopupMenu;
00450                 ASSERT(state.m_pOther == NULL);
00451
00452                 state.m_nIndexMax = pPopupMenu->GetMenuItemCount();
00453                 for (state.m_nIndex = 0; state.m_nIndex < state.m_nIndexMax; state.m_nIndex++) {
00454                         state.m_nID = pPopupMenu->GetMenuItemID(state.m_nIndex);
00455                         if (state.m_nID == 0)
00456                                 continue;
00457
00458                         ASSERT(state.m_pOther == NULL);
00459                         ASSERT(state.m_pMenu != NULL);
00460                         if (state.m_nID == (UINT)-1) {
00461                                 state.m_pSubMenu = pPopupMenu->GetSubMenu(state.m_nIndex);
00462                                 if (state.m_pSubMenu == NULL ||
00463                                     (state.m_nID = state.m_pSubMenu->GetMenuItemID(0)) == 0 ||
00464                                     state.m_nID == (UINT)-1) {
00465                                 continue;
00466                             }
00467                             state.DoUpdate(this, FALSE);
00468                         } else {
00469                                 state.m_pSubMenu = NULL;
00470                                 state.DoUpdate(this, state.m_nID < 0xF000);
00471                         }
00472                 }
00473         }
00474 }
00475
00476 void CCfgPropSheet::OnMenuSelect(UINT nItemID, UINT nFlags, HMENU hSysMenu)
00477 {
00478         CPropertySheet::OnMenuSelect(nItemID, nFlags, hSysMenu);
00479
00480         if (nFlags == 0xFFFF) {
00481                 m_nIDTracking = AFX_IDS_IDLEMESSAGE;
00482                 OnSetMessageString(m_nIDTracking);
00483                 ASSERT(m_nIDTracking == m_nIDLastMessage);
00484         } else if (nItemID == 0 || nFlags & (MF_SEPARATOR|MF_POPUP|MF_MENUBREAK|MF_MENUBARBREAK)) {
00485                 m_nIDTracking = 0;
00486         } else if (nItemID >= 0xF000 && nItemID < 0xF1F0) {
00487                 m_nIDTracking = ID_COMMAND_FROM_SC(nItemID);
00488                 ASSERT(m_nIDTracking >= AFX_IDS_SCFIRST && m_nIDTracking < AFX_IDS_SCFIRST + 31);
00489         } else {
00490                 m_nIDTracking = nItemID;
00491         }
00492 }
00493
00494 void CCfgPropSheet::OnMouseMove(UINT nFlags, CPoint point)
00495 {
00496         if (m_bResetPrompt) {
00497                 OnSetMessageString(AFX_IDS_IDLEMESSAGE);
00498                 m_bResetPrompt = FALSE;
00499         }
00500
00501         CPropertySheet::OnMouseMove(nFlags, point);
00502 }
00503
00504 BOOL CCfgPropSheet::OnToolTipText(UINT, NMHDR* pNMHDR, LRESULT* pResult)
00505 {
00506         ASSERT(pNMHDR->code == TTN_NEEDTEXTA || pNMHDR->code == TTN_NEEDTEXTW);
00507
00508         if (GetRoutingFrame() != NULL) {
00509                 return FALSE;
00510         }
00511
00512         TOOLTIPTEXTA* pTTTA = (TOOLTIPTEXTA*)pNMHDR;
00513         TOOLTIPTEXTW* pTTTW = (TOOLTIPTEXTW*)pNMHDR;
00514         TCHAR szFullText[256];
00515         CString strTipText;
00516         CString strPromtpText;
00517         INT_PTR nID = pNMHDR->idFrom;
00518
00519         if (pNMHDR->code == TTN_NEEDTEXTA && (pTTTA->uFlags & TTF_IDISHWND) ||
00520                 pNMHDR->code == TTN_NEEDTEXTW && (pTTTW->uFlags & TTF_IDISHWND)) {
00521                 nID = ((INT_PTR)(WORD)::GetDlgCtrlID((HWND)nID));
00522         }
00523
00524         if ((nID != 0) && (nID != ID_VIEW_STATUS_BAR)) {
00525                 AfxLoadString((UINT)nID, szFullText);
00526                 AfxExtractSubString(strTipText, szFullText, 1, '\n');
00527                 AfxExtractSubString(strPromtpText, szFullText, 0, '\n');
00528
00529                 if (!strPromtpText.IsEmpty()) {
00530                         if (::IsWindow(m_CSBCtrlStatus.m_hWnd)) m_CSBCtrlStatus.SetWindowText(strPromtpText);
00531                         m_bResetPrompt = TRUE;
00532                 }
00533         }
00534 #ifndef _UNICODE
00535         if (pNMHDR->code == TTN_NEEDTEXTA)
00536                 lstrcpyn(pTTTA->szText, strTipText,(sizeof(pTTTA->szText)/sizeof(pTTTA->szText[0])));
00537         else
00538                 _mbstowcsz(pTTTW->szText, strTipText,(sizeof(pTTTW->szText)/sizeof(pTTTW->szText[0])));
00539 #else
00540         if (pNMHDR->code == TTN_NEEDTEXTA)
00541                 _wcstombsz(pTTTA->szText, strTipText,(sizeof(pTTTA->szText)/sizeof(pTTTA->szText[0])));
00542         else
00543                 lstrcpyn(pTTTW->szText, strTipText,(sizeof(pTTTW->szText)/sizeof(pTTTW->szText[0])));
00544 #endif
00545         *pResult = 0;
00546
00547         ::SetWindowPos(pNMHDR->hwndFrom, HWND_TOP, 0, 0, 0, 0,SWP_NOACTIVATE|SWP_NOSIZE|SWP_NOMOVE);
00548
00549         return TRUE;
00550 }
00551
00552 void CCfgPropSheet::OnUpdateToolBarMenu(CCmdUI* pCmdUI)
00553 {
00554         ASSERT(pCmdUI->m_nID == ID_VIEW_TOOLBAR);
00555         pCmdUI->SetCheck(m_CSToolBar.IsWindowVisible());
00556 }
00557
00558 void CCfgPropSheet::OnToolBarCheck()
00559 {
00560         m_CSToolBar.ShowWindow(m_CSToolBar.IsWindowVisible() ? SW_HIDE : SW_SHOWNA);
00561
00562         if (m_bToolBar) {
00563                 CRect crToolBar;
00564                 CRect rcClientStart;
00565                 CRect rcClientNow;
00566                 CRect rcWindow;
00567
00568                 GetWindowRect(rcWindow);
00569                 m_CSToolBar.GetWindowRect(crToolBar);
00570                 ScreenToClient(crToolBar);
00571                 GetClientRect(rcClientStart);
00572
00573                 RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, 0, reposQuery, rcClientNow);
00574
00575                 CPoint ptOffset(
00576                         rcClientNow.left - rcClientStart.left,
00577                         rcClientNow.top - rcClientStart.top +
00578                         m_CSToolBar.IsWindowVisible() ? crToolBar.Height() : -1 * crToolBar.Height());
00579
00580                 CRect  rcChild;
00581                 CWnd* pwndChild = GetWindow(GW_CHILD);
00582                 while (pwndChild) {
00583                         pwndChild->GetWindowRect(rcChild);
00584                         ScreenToClient(rcChild);
00585                         rcChild.OffsetRect(ptOffset);
00586                         pwndChild->MoveWindow(rcChild, TRUE);
00587                         if (pwndChild->GetStyle() & WS_VISIBLE) {
00588                                 pwndChild->ShowWindow(SW_HIDE);
00589                                 pwndChild->ShowWindow(SW_SHOW);
00590                         }
00591                         pwndChild = pwndChild->GetNextWindow();
00592                 }
00593
00594                 if (m_CSToolBar.IsWindowVisible()) {
00595                         rcWindow.right += rcClientStart.Width() - rcClientNow.Width();
00596                         rcWindow.bottom += crToolBar.Height();
00597                 } else {
00598                         rcWindow.right += rcClientStart.Width() - rcClientNow.Width();
00599                         rcWindow.bottom -= crToolBar.Height();
00600                 }
00601                 MoveWindow(rcWindow, TRUE);
00602
00603                 RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, 0);
00604         }
00605 }
00606
00607 void CCfgPropSheet::OnUpdateStatusBarMenu(CCmdUI* pCmdUI)
00608 {
00609         ASSERT(pCmdUI->m_nID == ID_VIEW_STATUS_BAR);
00610         pCmdUI->SetCheck(m_CSBCtrlStatus.IsWindowVisible());
00611 }
00612
00613 void CCfgPropSheet::OnStatusBarCheck()
00614 {
00615         m_CSBCtrlStatus.ShowWindow(m_CSBCtrlStatus.IsWindowVisible() ? SW_HIDE : SW_SHOWNA);
00616
00617         if (m_bStatusBar) {
00618                 CRect crStatusBar;
00619                 CRect rcClientStart;
00620                 CRect rcClientNow;
00621                 CRect rcWindow;
00622
00623                 GetWindowRect(rcWindow);
00624                 m_CSBCtrlStatus.GetWindowRect(crStatusBar);
00625                 ScreenToClient(crStatusBar);
00626                 GetClientRect(rcClientStart);
00627
00628                 RepositionBars(AFX_IDW_CONTROLBAR_FIRST, AFX_IDW_CONTROLBAR_LAST, 0, reposQuery, rcClientNow);
00629
00630                 if (m_CSBCtrlStatus.IsWindowVisible()) {
00631                         rcWindow.right += rcClientStart.Width() - rcClientNow.Width();
00632                         rcWindow.bottom += crStatusBar.Height();
00633                 } else {
00634                         rcWindow.right += rcClientStart.Width() - rcClientNow.Width();
00635                         rcWindow.bottom -= crStatusBar.Height();
00636                 }
00637                 MoveWindow(rcWindow, TRUE);
00638         }
00639 }
00640
00641 void CCfgPropSheet::OnUpdateKeyIndicator(CCmdUI* pCmdUI)
00642 {
00643         UINT nVK;
00644
00645         switch (pCmdUI->m_nID) {
00646         case ID_INDICATOR_CAPS:
00647                 nVK = VK_CAPITAL;
00648                 break;
00649         case ID_INDICATOR_NUM:
00650                 nVK = VK_NUMLOCK;
00651                 break;
00652         case ID_INDICATOR_SCRL:
00653                 nVK = VK_SCROLL;
00654                 break;
00655         default:
00656                 TRACE(_T("Warning: OnUpdateKeyIndicator - unknown indicator 0x%04X\n"), pCmdUI->m_nID);
00657                 pCmdUI->ContinueRouting();
00658                 return;
00659         }
00660
00661         pCmdUI->Enable(::GetKeyState(nVK) & 1);
00662
00663         ASSERT(pCmdUI->m_bEnableChanged);
00664 }
00665
00666 LRESULT CCfgPropSheet::OnSetMessageString(WPARAM wParam, LPARAM lParam)
00667 {
00668         UINT    nIDMsg = (UINT)wParam;
00669         CString strMsg;
00670         TCHAR szFullText[256];
00671
00672         if (nIDMsg) {
00673                 if (nIDMsg == AFX_IDS_IDLEMESSAGE) {
00674                         strMsg.LoadString(AFX_IDS_IDLEMESSAGE);
00675                         if (m_CSBCtrlStatus.m_hWnd) m_CSBCtrlStatus.SetWindowText(strMsg);
00676                 } else {
00677                         if (strMsg.LoadString(nIDMsg) != 0) {
00678                                 CString strTipText;
00679                                 AfxLoadString(nIDMsg, szFullText);
00680                                 UINT i = 0;
00681                                 while (i++ < _tcslen(szFullText)) {
00682                                         if (szFullText[i] == (TCHAR)'\n') {
00683                                                 strTipText = CString(szFullText).Left(i);
00684                                                 break;
00685                                         }
00686                                 }
00687                                 if (m_CSBCtrlStatus.m_hWnd) m_CSBCtrlStatus.SetWindowText(strTipText);
00688                         } else {
00689                                 TRACE(_T("Warning: no message line prompt for ID %x%04X\n"), nIDMsg);
00690                         }
00691                 }
00692         } else {
00693                 if (m_CSBCtrlStatus.m_hWnd) m_CSBCtrlStatus.SetWindowText(strMsg);
00694         }
00695
00696         UINT nIDLast     = m_nIDLastMessage;
00697         m_nIDLastMessage = nIDMsg;
00698         m_nIDTracking    = nIDMsg;
00699         return nIDLast;
00700
00701 }
00702
00703 LRESULT CCfgPropSheet::OnPopMessageString(WPARAM wParam, LPARAM lParam)
00704 {
00705         if (m_nFlags & WF_NOPOPMSG) {
00706                 return 0;
00707         }
00708
00709         return SendMessage(WM_SETMESSAGESTRING, wParam, lParam);
00710 }
00711
00712 LRESULT CCfgPropSheet::OnKickIdle(WPARAM, LPARAM lCount)
00713 {
00714         if (m_bStatusBar) m_CSBCtrlStatus.SendMessage(WM_IDLEUPDATECMDUI);
00715         if (m_bToolBar) m_CSToolBar.SendMessage(WM_IDLEUPDATECMDUI,TRUE);
00716
00717         return (lCount <= 2);
00718 }
00719
00720 void CCfgPropSheet::OnTimer(UINT nIDEvent)
00721 {
00722         if ((AfxGetMainWnd() == this) && (m_Timer != 0) && (!m_bModal)) {
00723                 KillTimer(666);
00724                 m_Timer = 0;
00725         } else {
00726                 if (nIDEvent == 666) OnKickIdle(0,0);
00727         }
00728
00729         CPropertySheet::OnTimer(nIDEvent);
00730 }
00731
00733 // CCfgPropPage property page
00734
00735 IMPLEMENT_DYNCREATE(CCfgPropPage, CPropertyPage)
00736
00737 CCfgPropPage::CCfgPropPage() : CPropertyPage()
00738 {
00739 }
00740
00741 CCfgPropPage::CCfgPropPage(UINT nIDTemplate, UINT nIDCaption, UINT nIDHeaderTitle, UINT nIDHeaderSubTitle)
00742         : CPropertyPage(nIDTemplate,nIDCaption,nIDHeaderTitle,nIDHeaderSubTitle)
00743 {
00744 }
00745
00746 CCfgPropPage::CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption, UINT nIDHeaderTitle, UINT nIDHeaderSubTitle)
00747         : CPropertyPage(lpszTemplateName,nIDCaption,nIDHeaderTitle,nIDHeaderSubTitle)
00748 {
00749 }
00750
00751 CCfgPropPage::~CCfgPropPage()
00752 {
00753 }
00754
00755 void CCfgPropPage::DoDataExchange(CDataExchange* pDX)
00756 {
00757         CPropertyPage::DoDataExchange(pDX);
00758         //{{AFX_DATA_MAP(CCfgPropPage)
00759                 // NOTE: the ClassWizard will add DDX and DDV calls here
00760         //}}AFX_DATA_MAP
00761 }
00762
00763
00764 BEGIN_MESSAGE_MAP(CCfgPropPage, CPropertyPage)
00765         //{{AFX_MSG_MAP(CCfgPropPage)
00766         ON_WM_MOUSEMOVE()
00767         //}}AFX_MSG_MAP
00768         ON_NOTIFY_EX_RANGE(TTN_NEEDTEXTW, 0, 0xFFFF, OnToolTipText)
00769         ON_NOTIFY_EX_RANGE(TTN_NEEDTEXTA, 0, 0xFFFF, OnToolTipText)
00770 END_MESSAGE_MAP()
00771
00772 BOOL CCfgPropPage::OnToolTipText(UINT i, NMHDR* pNMHDR, LRESULT* pResult)
00773 {
00774         ASSERT(GetParent()->IsKindOf(RUNTIME_CLASS(CCfgPropSheet)));
00775
00776         CCfgPropSheet *pParent = (CCfgPropSheet *)GetParent();
00777
00778         return pParent->OnToolTipText(i,pNMHDR,pResult);
00779 }
00780
00781 void CCfgPropPage::OnMouseMove(UINT nFlags, CPoint point)
00782 {
00783         ASSERT(GetParent()->IsKindOf(RUNTIME_CLASS(CCfgPropSheet)));
00784
00785         CCfgPropSheet *pParent = (CCfgPropSheet *)GetParent();
00786         pParent->OnMouseMove(nFlags, point);
00787
00788         CPropertyPage::OnMouseMove(nFlags, point);
00789 }
00790
00791
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/CfgPropSheet.h Source File

DP5Cfg/CfgPropSheet.h
Go to the documentation of this file.
00001 #if !defined(AFX_CFGPROPSHEET_H__INCLUDED_)
00002 #define AFX_CFGPROPSHEET_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // CfgPropSheet.h : header file
00008 //
00009
00010 #include "resource.h"
00011 #include "Dlgbars.h"
00012 #include "scommon.h"
00013
00015 // CCfgPropPage
00016
00017 class CCfgPropPage : public CPropertyPage
00018 {
00019         DECLARE_DYNCREATE(CCfgPropPage)
00020
00021 // Construction
00022 public:
00023         CCfgPropPage();
00024         CCfgPropPage(UINT nIDTemplate, UINT nIDCaption = 0, UINT nIDHeaderTitle = 0, UINT nIDHeaderSubTitle = 0);
00025         CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption = 0, UINT nIDHeaderTitle = 0, UINT nIDHeaderSubTitle = 0);
00026
00027         ~CCfgPropPage();
00028
00029 // Dialog Data
00030         //{{AFX_DATA(CCfgPropPage)
00031                 // NOTE - ClassWizard will add data members here.
00032                 //    DO NOT EDIT what you see in these blocks of generated code !
00033         //}}AFX_DATA
00034
00035
00036 // Overrides
00037         // ClassWizard generate virtual function overrides
00038         //{{AFX_VIRTUAL(CCfgPropPage)
00039         protected:
00040         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00041         //}}AFX_VIRTUAL
00042
00043 // Implementation
00044 protected:
00045         // Generated message map functions
00046         //{{AFX_MSG(CCfgPropPage)
00047         afx_msg void OnMouseMove(UINT nFlags, CPoint point);
00048         //}}AFX_MSG
00049         BOOL OnToolTipText(UINT, NMHDR* pNMHDR, LRESULT* pResult);
00050         DECLARE_MESSAGE_MAP()
00051
00052 };
00053
00055 // CCfgPropSheet
00056
00057 class CCfgPropSheet : public CPropertySheet
00058 {
00059         DECLARE_DYNAMIC(CCfgPropSheet)
00060
00061 // Construction
00062 public:
00063         CCfgPropSheet(UINT nIDCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0, HBITMAP hbmWatermark = NULL, HPALETTE hpalWatermark = NULL, HBITMAP hbmHeader = NULL );
00064         CCfgPropSheet(LPCTSTR pszCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0, HBITMAP hbmWatermark = NULL, HPALETTE hpalWatermark = NULL, HBITMAP hbmHeader = NULL );
00065         //TBSTYLE_CHECKGROUP |
00066         BOOL InitCfgPropSheet(BOOL bToolTips = FALSE, BOOL bStatusBar = FALSE, UINT *pIndicators = NULL, UINT nIndicators = 0, UINT uiMenu = 0,UINT uiToolBar = 0, DWORD dwToolBarStyle = TBSTYLE_FLAT | WS_CHILD | WS_VISIBLE | CBRS_TOP | CBRS_GRIPPER | CBRS_TOOLTIPS | CBRS_FLYBY | CBRS_SIZE_DYNAMIC);
00067
00068         void AddPage( CCfgPropPage* pPage );
00069
00070 // Attributes
00071 public:
00072         CStatusBar* GetStatusBar() { return &m_CSBCtrlStatus; }
00073         CToolBar*   GetToolBar()   { return &m_CSToolBar; }
00074
00075 protected:
00076         CDlgStatusBar   m_CSBCtrlStatus;
00077         CDlgToolBar             m_CSToolBar;
00078         UINT                    m_nIDTracking;
00079         UINT                    m_nIDLastMessage;
00080         BOOL                    m_bResetPrompt;
00081
00082         BOOL                    m_bToolTips;
00083         BOOL                    m_bStatusBar;
00084         BOOL                    m_bToolBar;
00085         BOOL                    m_bMenu;
00086
00087         BOOL                    m_bKillItself;
00088
00089         BOOL                    m_bModal;
00090         UINT                    m_Timer;
00091
00092 // Operations
00093 public:
00094
00095 // Overrides
00096         // ClassWizard generated virtual function overrides
00097         //{{AFX_VIRTUAL(CCfgPropSheet)
00098         public:
00099         virtual void OnCancel();
00100         //virtual void OnOK();
00101         //afx_msg void OnOK();
00102         virtual INT_PTR DoModal();
00103
00104         afx_msg void OnFileTab();
00105         afx_msg void OnMcaTab();
00106         afx_msg void OnShapingTab();
00107         afx_msg void OnGainPzTab();
00108         afx_msg void OnPowerTab();
00109         afx_msg void OnMiscTab();
00110         void OnSelectTab(UINT NewActivePage, int nPage);
00111         void UpdateAll();
00112         UINT ActivePage;
00113
00114
00115         afx_msg void OnFileTab2(CCmdUI* pCmdUI);
00116         afx_msg void OnMcaTab2(CCmdUI* pCmdUI);
00117         afx_msg void OnShapingTab2(CCmdUI* pCmdUI);
00118         afx_msg void OnGainPzTab2(CCmdUI* pCmdUI);
00119         afx_msg void OnPowerTab2(CCmdUI* pCmdUI);
00120         afx_msg void OnMiscTab2(CCmdUI* pCmdUI);
00121
00122
00123
00124
00125         void GetCurrentButtonState();
00126
00127         void OnTB1();
00128         protected:
00129         virtual void PostNcDestroy();
00130         //}}AFX_VIRTUAL
00131
00132 // Implementation
00133 public:
00134
00135         // Generated message map functions
00136 protected:
00137         //{{AFX_MSG(CCfgPropSheet)
00138         afx_msg void OnEnterIdle(UINT nWhy, CWnd* pWho);
00139         afx_msg LRESULT OnPopMessageString(WPARAM wParam, LPARAM lParam);
00140         afx_msg LRESULT OnSetMessageString(WPARAM wParam, LPARAM lParam = 0L);
00141         afx_msg void OnMenuSelect(UINT nItemID, UINT nFlags, HMENU hSysMenu);
00142         afx_msg void OnUpdateKeyIndicator(CCmdUI* pCmdUI);
00143         afx_msg void OnUpdateStatusBarMenu(CCmdUI* pCmdUI);
00144         afx_msg void OnStatusBarCheck();
00145         afx_msg void OnToolBarCheck();
00146         afx_msg void OnUpdateToolBarMenu(CCmdUI* pCmdUI);
00147         afx_msg void OnMouseMove(UINT nFlags, CPoint point);
00148         afx_msg void OnInitMenuPopup(CMenu* pPopupMenu, UINT nIndex, BOOL bSysMenu);
00149         afx_msg LRESULT OnKickIdle(WPARAM, LPARAM lCount);
00150         afx_msg void OnTimer(UINT nIDEvent);
00151         //}}AFX_MSG
00152         BOOL OnToolTipText(UINT, NMHDR* pNMHDR, LRESULT* pResult);
00153         DECLARE_MESSAGE_MAP()
00154
00155         friend class CCfgPropPage;
00156
00157 };
00158
00160
00161 //{{AFX_INSERT_LOCATION}}
00162 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00163
00164 #endif // !defined(AFX_CFGPROPSHEET_H__INCLUDED_)
00165
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/CmdWaitDlg.cpp Source File

waitdlg/CmdWaitDlg.cpp
Go to the documentation of this file.
00001 // cWaitDialog.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "WaitDialog.h"
00006 #include "CmdWaitDlg.h"
00007
00008 //#ifdef _DEBUG
00009 //#define new DEBUG_NEW
00010 //#undef THIS_FILE
00011 //static char THIS_FILE[] = __FILE__;
00012 //#endif
00013
00015 // cWaitDialog
00016
00017 IMPLEMENT_DYNCREATE(cWaitDialog, CCmdTarget)
00018
00019 cWaitDialog::cWaitDialog()
00020 {
00021    m_bShowCancelButton = false;
00022    m_Text = "";
00023    m_EventName = "";
00024 }
00025
00026 cWaitDialog::~cWaitDialog()
00027 {
00028 }
00029
00030
00031 BEGIN_MESSAGE_MAP(cWaitDialog, CCmdTarget)
00032         //{{AFX_MSG_MAP(cWaitDialog)
00033                 // NOTE - the ClassWizard will add and remove mapping macros here.
00034         //}}AFX_MSG_MAP
00035 END_MESSAGE_MAP()
00036
00038 // cWaitDialog message handlers
00039
00040 void cWaitDialog::Show()
00041 {
00042    m_Event = CreateEvent(NULL, TRUE, FALSE, m_EventName);
00043    m_Thread = (cWaitDlgThread *)AfxBeginThread(RUNTIME_CLASS(cWaitDlgThread), THREAD_PRIORITY_NORMAL, 0, CREATE_SUSPENDED);
00044    m_Thread->m_Eventname = m_EventName;
00045    m_Thread->m_Text = m_Text;
00046    m_Thread->m_bShowCancelButton = m_bShowCancelButton;
00047    m_Thread->ResumeThread();
00048
00049 }
00050
00051 void cWaitDialog::Close()
00052 {
00053    m_Thread->m_Event->SetEvent();
00054    CloseHandle(m_Event);
00055 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/CmdWaitDlg.h Source File

waitdlg/CmdWaitDlg.h
Go to the documentation of this file.
00001 #if !defined(AFX_cWAITDIALOG_H__25FAD201_F98F_11D2_8127_F91DB0F31875__INCLUDED_)
00002 #define AFX_cWAITDIALOG_H__25FAD201_F98F_11D2_8127_F91DB0F31875__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // cWaitDialog.h : header file
00008 //
00010 // Author: Todd Andrews
00011 // Email:  tmandrews@mindspring.com
00012 // Copyright 1999, Todd Andrews
00013 //
00014 // You may freely use or modify this code provided this
00015 // Copyright is included in all derived versions.
00016 //
00017 //
00018 // This class implements a wrapper for a worker thread and dialog
00019
00020 #include "WaitDlgThread.h"
00021
00023 // cWaitDialog command target
00024
00025 class cWaitDialog : public CCmdTarget
00026 {
00027         DECLARE_DYNCREATE(cWaitDialog)
00028
00029         cWaitDialog();           // protected constructor used by dynamic creation
00030
00031 // Attributes
00032 public:
00033         cWaitDlgThread     *m_Thread;
00034         bool                          m_bShowCancelButton;
00035    HANDLE            m_Event;
00036    CString           m_Text;
00037    CString           m_EventName;
00038
00039 // Operations
00040 public:
00041         void Close();
00042         void Show();
00043
00044 // Overrides
00045         // ClassWizard generated virtual function overrides
00046         //{{AFX_VIRTUAL(cWaitDialog)
00047         //}}AFX_VIRTUAL
00048
00049 // Implementation
00050 public:
00051    virtual ~cWaitDialog();
00052 protected:
00053
00054         // Generated message map functions
00055         //{{AFX_MSG(cWaitDialog)
00056                 // NOTE - the ClassWizard will add and remove member functions here.
00057         //}}AFX_MSG
00058
00059         DECLARE_MESSAGE_MAP()
00060 };
00061
00063
00064 //{{AFX_INSERT_LOCATION}}
00065 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00066
00067 #endif // !defined(AFX_cWAITDIALOG_H__25FAD201_F98F_11D2_8127_F91DB0F31875__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DP5CfgWnd.cpp Source File

DP5Cfg/DP5CfgWnd.cpp
Go to the documentation of this file.
00001 // DP5CfgWnd.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "CDP5Cfg.h"
00006 #include "DP5CfgWnd.h"
00007 #include "FilePage.h"
00008 #include "resource.h"
00009
00010 #ifdef _DEBUG
00011 #define new DEBUG_NEW
00012 #undef THIS_FILE
00013 static char THIS_FILE[] = __FILE__;
00014 #endif
00015
00017 // CDP5CfgWnd
00018
00019 IMPLEMENT_DYNAMIC(CDP5CfgWnd, CCfgPropSheet)
00020
00021 CDP5CfgWnd::CDP5CfgWnd(UINT nIDCaption, CWnd* pParentWnd, UINT iSelectPage)
00022         :CCfgPropSheet(nIDCaption, pParentWnd, iSelectPage)
00023 {
00024         m_bModal = FALSE;
00025
00026         AddPages();
00027 }
00028
00029 CDP5CfgWnd::CDP5CfgWnd(LPCTSTR pszCaption, CWnd* pParentWnd, UINT iSelectPage)
00030         :CCfgPropSheet(pszCaption, pParentWnd, iSelectPage)
00031 {
00032         m_bModal = FALSE;
00033
00034         AddPages();
00035 }
00036
00037 CDP5CfgWnd::~CDP5CfgWnd()
00038 {
00039
00040 }
00041
00042 void CDP5CfgWnd::AddPages(void)
00043 {
00044         AddPage(&m_FilePage);
00045         AddPage(&m_McaPage);
00046         AddPage(&m_ShapingPage);
00047         AddPage(&m_GainPzPage);
00048         AddPage(&m_PowerPage);
00049         AddPage(&m_MiscPage);
00050         //AddPage(&m_BootOptPage);
00051 }
00052
00053 BEGIN_MESSAGE_MAP(CDP5CfgWnd, CCfgPropSheet)
00054         //{{AFX_MSG_MAP(CDP5CfgWnd)
00055         //}}AFX_MSG_MAP
00056 END_MESSAGE_MAP()
00057
00059 // CDP5CfgWnd message handlers
00060
00061 BOOL CDP5CfgWnd::OnInitDialog()
00062 {
00063
00064         BOOL bResult = CCfgPropSheet::OnInitDialog();
00065
00066         InitCfgPropSheet(TRUE,TRUE,NULL,0,IDR_MENU,IDR_TOOLBAR);
00067
00068         CString CsBtnText;
00069         if (m_bModal) {
00070                 CsBtnText.LoadString(IDS_BTNSTRING_MODELESS);
00071         } else {
00072                 CsBtnText.LoadString(IDS_BTNSTRING_MODAL);
00073         }
00074         return bResult;
00075 }
00076
00077 INT_PTR CDP5CfgWnd::DoModal()
00078 {
00079         m_bModal = TRUE;
00080         return CCfgPropSheet::DoModal();
00081 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DP5CfgWnd.h Source File

DP5Cfg/DP5CfgWnd.h
Go to the documentation of this file.
00001 #if !defined(AFX_DP5CfgWnd_H__INCLUDED_)
00002 #define AFX_DP5CfgWnd_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // DP5CfgWnd.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "FilePage.h"
00012 #include "McaPage.h"
00013 #include "ShapingPage.h"
00014 #include "GainPzPage.h"
00015 #include "PowerPage.h"
00016 #include "MiscPage.h"
00017 //#include "BootOptPage.h"
00018
00020 // CDP5CfgWnd
00021
00022 class CDP5CfgWnd : public CCfgPropSheet
00023 {
00024         DECLARE_DYNAMIC(CDP5CfgWnd)
00025
00026 // Construction
00027 public:
00028         CDP5CfgWnd(UINT nIDCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0);
00029         CDP5CfgWnd(LPCTSTR pszCaption, CWnd* pParentWnd = NULL, UINT iSelectPage = 0);
00030
00031 // Attributes
00032 public:
00033         CFilePage m_FilePage;
00034         CMcaPage m_McaPage;
00035         CShapingPage m_ShapingPage;
00036         CGainPzPage m_GainPzPage;
00037         CPowerPage m_PowerPage;
00038         CMiscPage m_MiscPage;
00039         //CBootOptPage m_BootOptPage;
00040
00041         BOOL m_bModal;
00042
00043 // Operations
00044 public:
00045
00046 // Overrides
00047         // ClassWizard generated virtual function overrides
00048         //{{AFX_VIRTUAL(CDP5CfgWnd)
00049         public:
00050         virtual BOOL OnInitDialog();
00051         virtual INT_PTR DoModal();
00052         //}}AFX_VIRTUAL
00053
00054 // Implementation
00055 public:
00056         virtual ~CDP5CfgWnd();
00057
00058         // Generated message map functions
00059 protected:
00060
00061         void AddPages(void);
00062         //{{AFX_MSG(CDP5CfgWnd)
00063         //}}AFX_MSG
00064         DECLARE_MESSAGE_MAP()
00065 };
00066
00068
00069 //{{AFX_INSERT_LOCATION}}
00070 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00071
00072 #endif // !defined(AFX_DP5CfgWnd_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/DP5ControlUtil.cpp Source File

CIni/DP5ControlUtil.cpp
Go to the documentation of this file.
00001 #include "DP5ControlUtil.h"
00002
00003 CDP5ControlUtil::CDP5ControlUtil(void)
00004 {
00005 }
00006
00007 CDP5ControlUtil::~CDP5ControlUtil(void)
00008 {
00009 }
00010
00011 int CDP5ControlUtil::OrderOut(int IndexIn)
00012 {
00013         if ((IndexIn >= DP5_CMD_MIN) && (IndexIn <= DP5_CMD_MAX)) {
00014                 return IndexIn;
00015         } else {
00016                 return -1;
00017         }
00018 }
00019
00020 int CDP5ControlUtil::FindCboIdxExact(HWND hDlg, int cboDP5CtrlID, CString strVal)
00021 {
00022     int lRet;
00023         HWND m_cbo_hWnd;
00024         m_cbo_hWnd = GetDlgItem(hDlg,cboDP5CtrlID);
00025         if (m_cbo_hWnd == NULL) { return LB_ERR; }
00026         lRet = (int)SendMessage(m_cbo_hWnd, CB_FINDSTRINGEXACT, 0, (LPARAM)strVal.GetString());
00027     return lRet;
00028 }
00029
00030 int CDP5ControlUtil::FindCboIdx(HWND hDlg, int cboDP5CtrlID, CString strVal)
00031 {
00032     int lRet;
00033         HWND m_cbo_hWnd;
00034         m_cbo_hWnd = GetDlgItem(hDlg,cboDP5CtrlID);
00035         if (m_cbo_hWnd == NULL) { return LB_ERR; }
00036         lRet = (int)SendMessage(m_cbo_hWnd, CB_FINDSTRING, 0, (LPARAM)strVal.GetString());
00037     return lRet;
00038 }
00039
00040 void CDP5ControlUtil::SetCboIdxByStr(HWND hDlg, DP5_CONFIGURATION cfg)
00041 {
00042         int cboDP5CtrlID = cfg.ListCtrlID;
00043         CString strVal = cfg.Setting;
00044         int idx = FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00045         HWND dlgItm = GetDlgItem(hDlg, cboDP5CtrlID);
00046         if (dlgItm != NULL) {
00047                 CComboBox &cb = *(CComboBox *) dlgItm;
00048                 cb.SetCurSel(idx);
00049         }
00050 }
00051
00052 // test for the units in the value string
00053 int CDP5ControlUtil::FindUnitsInString(CString strValue, CString strUnits)
00054 {
00055         CString strValueUC;
00056         CString strUnitsUC;
00057         int iPos;
00058         strValueUC = strValue.MakeUpper();
00059         strUnitsUC = strUnits.MakeUpper();
00060         iPos = strValueUC.Find(strUnitsUC);
00061         return iPos;
00062 }
00063
00064 // test if have units if so remove from text value string
00065 void CDP5ControlUtil::RemoveUnitsFromDecString(DP5_CONFIGURATION *cfg)
00066 {
00067         int iUnit;                                                                              // unit position found, -1 if units not found
00068         CString strValue;
00069         if (cfg->Units.GetLength() > 0) {                               // has units, need to test
00070                 iUnit = FindUnitsInString(cfg->Setting, cfg->Units);
00071                 if (iUnit > -1) {
00072                         cfg->bAppendUnits = TRUE;                               // append the usnits on save
00073                         strValue = cfg->Setting.Left(iUnit);    // remove the units
00074                         cfg->Setting = strValue;
00075                 }
00076                 if ((cfg->CtrlType & dctCbo) > 0) {             //has cbo val with possible units, must clear units to find cbo value
00077                         iUnit = FindUnitsInString(cfg->ComboValue, cfg->Units);
00078                         if (iUnit > -1) {
00079                                 cfg->bAppendUnits = TRUE;                               // append the usnits on save
00080                                 strValue = cfg->ComboValue.Left(iUnit); // remove the units
00081                                 cfg->ComboValue = strValue;
00082                         }
00083                 }
00084                 if ((cfg->CtrlType & dctTxt) > 0) {             // has text value
00085                         iUnit = FindUnitsInString(cfg->TextValue, cfg->Units);
00086                         if (iUnit > -1) {
00087                                 cfg->bAppendUnits = TRUE;                               // append the usnits on save
00088                                 strValue = cfg->TextValue.Left(iUnit);  // remove the units
00089                                 cfg->TextValue = strValue;
00090                         }
00091                 }
00092         }
00093 }
00094
00095 // test for the units in the value string
00096 CString CDP5ControlUtil::AppendUnitsToString(CString strValue, CString strUnits)
00097 {
00098         CString strValUnitsUC;
00099         strValUnitsUC = strValue.MakeUpper() + strUnits.MakeUpper();
00100         if (strValUnitsUC.GetLength() > 10) {
00101                 return strValue;
00102         } else {
00103                 return strValUnitsUC;
00104         }
00105         return strValue;
00106 }
00107
00108 // test if have units if so append
00109 void CDP5ControlUtil::AppendUnitsToSettingString(DP5_CONFIGURATION *cfg)
00110 {
00111         CString strValue;
00112         if (cfg->Units.GetLength() > 0) {       // has units, need to test
00113                 if (cfg->bAppendUnits) {                        // only append units if requested
00114                         if (cfg->CtrlType == dctTxt) {  // is text value only, can always append value
00115                                 cfg->Setting = AppendUnitsToString(cfg->Setting, cfg->Units);
00116                         } else { // test cbo, if the value is numeric then append units
00117                                 if (IsAllNumericString(cfg->Setting)) {
00118                                         cfg->Setting = AppendUnitsToString(cfg->Setting, cfg->Units);
00119                                 }
00120                         }
00121                 }
00122         }
00123 }
00124
00125 // test if have units if so append
00126 CString CDP5ControlUtil::GetValueWithUnitsString(DP5_CONFIGURATION cfg)
00127 {
00128         CString strValue;
00129         if (cfg.Units.GetLength() > 0) {        // has units, need to test
00130                 if (cfg.bAppendUnits) {                 // only append units if requested
00131                         if ((cfg.CtrlType & dctTxt) > 0) {      // is text value only, can always append value
00132                                 return AppendUnitsToString(cfg.TextValue, cfg.Units);
00133                         }
00134                 }
00135         }
00136         return cfg.TextValue;
00137 }
00138
00139 void CDP5ControlUtil::UpdateSetting(DP5_CONFIGURATION *cfg)
00140 {
00141         if (cfg->CtrlType == dctCbo) {                  // is combo value only
00142                 cfg->Setting = cfg->ComboValue;
00143         } else
00144         if (cfg->CtrlType == dctTxt) {                  // is text value only
00145                 cfg->Setting = cfg->TextValue;
00146         } else
00147         if (cfg->CtrlType == dctCboTxt) {               // is combo and text value
00148                 if (cfg->ComboValue.Find('#') >= 0) {   // this is the mask, use text
00149                         cfg->Setting = cfg->TextValue;
00150                 } else {                                                        // use combo value
00151                         cfg->Setting = cfg->ComboValue;
00152                 }
00153         }
00154         AppendUnitsToSettingString(cfg);                // append units if any
00155 }
00156
00157 void CDP5ControlUtil::UpdateSettingOsc(DP5_CONFIGURATION *cfg)
00158 {
00159         if (cfg->CtrlType == dctCbo) {                  // is combo value only
00160                 cfg->Setting = cfg->ComboValue;
00161         } else
00162         if (cfg->CtrlType == dctTxt) {                  // is text value only
00163                 cfg->Setting = cfg->TextValue;
00164         } else
00165         if (cfg->CtrlType == dctCboTxt) {               // is combo and text value
00166                 if (cfg->ComboValue.Find('#') >= 0) {   // this is the mask, use text
00167                         cfg->Setting = cfg->TextValue;
00168                 } else {                                                        // use combo value
00169                         cfg->Setting = cfg->ComboValue;
00170                 }
00171         }
00172 }
00173
00174 // test if have units if so remove from text value string
00175 BOOL CDP5ControlUtil::IsAllNumericString(CString strValue)
00176 {
00177         int iPos;                               // position Numeric Char Found
00178         int iPosCh;                             // position of character being tested
00179         CString strCh;                          // holds char to test
00180         for (iPosCh = 0; iPosCh<strValue.GetLength();iPosCh++) {
00181                 strCh = strValue.Mid(iPosCh,1);
00182                 iPos = strCh.FindOneOf(_T("+-.0123456789"));
00183                 if (iPos == -1) break;  // quit if not found
00184         }
00185         if (iPos > -1) {                                // has all numeric characters
00186                 return TRUE;
00187         } else {
00188                 return FALSE;
00189         }
00190 }
00191
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/DP5ControlUtil.h Source File

CIni/DP5ControlUtil.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003
00004 // DP5 Dialog Helper Macros
00005 #define TEXT_VIS(cmd, en) GetDlgItem(IDC_OPT_TEXT_##cmd)->ShowWindow(en)
00006 #define UNIT_VIS(cmd, en) GetDlgItem(IDC_OPT_UNITS_##cmd)->ShowWindow(en)
00007 #define LIMIT_VIS(cmd, en) GetDlgItem(IDC_OPT_LIMITS_##cmd)->ShowWindow(en)
00008 #define ALL_VIS(cmd, en) TEXT_VIS(cmd, en);UNIT_VIS(cmd, en);LIMIT_VIS(cmd, en)
00009
00010 #define UNIT_INIT(cmd, en) GetDlgItem(IDC_OPT_UNITS_##cmd)->SetWindowText(en)
00011 #define LIMIT_INIT(cmd, en) GetDlgItem(IDC_OPT_LIMITS_##cmd)->SetWindowText(en)
00012 #define CBO_TEXT_VIS(cmd, en) CboTextVis(IDC_OPT_COMBO_##cmd,IDC_OPT_TEXT_##cmd,en);
00013
00014 #define HasComboCtrl 0x1
00015 #define HasTextCtrl 0x2
00016
00017 // DP5_CMD_INDEX is the Master Index for ASCII commands.
00018 // DP5_CMD_INDEX orders the list of DP5 FW6 device commands in the correct order
00019 // For configuration commands to register properly order based on dependencies
00020 // must be maintained.
00021 typedef enum _DP5_CMD_INDEX {
00022         dciRESC,
00023         dciCLCK,
00024         dciTPEA,
00025         dciGAIF,
00026         dciGAIN,
00027         dciRESL,
00028         dciTFLA,
00029         dciTPFA,
00030         dciPURE,
00031         dciSCTC,
00032         dciRTDE,
00033         dciMCAS,
00034         dciMCAC,
00035         dciSOFF,
00036         dciAINP,
00037         dciINOF,
00038         dciGAIA,
00039         dciCUSP,
00040         dciPDMD,
00041         dciTHSL,
00042         dciTLLD,
00043         dciTHFA,
00044         dciDACO,
00045         dciDACF,
00046         dciRTDS,
00047         dciRTDT,
00048         dciBLRM,
00049         dciBLRD,
00050         dciBLRU,
00051         dciGATE,
00052         dciAUO1,
00053         dciPRET,
00054         dciPRER,
00055         dciPREL,
00056         dciPREC,
00057         dciPRCL,
00058         dciPRCH,
00059         dciHVSE,
00060         dciTECS,
00061         dciPAPZ,
00062         dciPAPS,
00063         dciSCOE,
00064         dciSCOT,
00065         dciSCOG,
00066         dciMCSL,
00067         dciMCSH,
00068         dciMCST,
00069         dciAUO2,
00070         dciTPMO,
00071         dciGPED,
00072         dciGPIN,
00073         dciGPME,
00074         dciGPGA,
00075         dciGPMC,
00076         dciMCAE,
00077         dciVOLU,
00078         dciCON1,
00079         dciCON2,
00080         dciBOOT
00081         //dciLAST                       // this does not exist
00082 } DP5_CMD_INDEX;
00083
00084 #define DP5_CMD_MIN dciRESC
00085 #define DP5_CMD_MAX dciBOOT
00086
00087 typedef enum _DP5_CTRL_TYPE {   // dp5 command control type
00088     dctNone,                                            // no controls
00089     dctCbo,                                                     // combobox only
00090     dctTxt,                                                     // text edit only
00091     dctCboTxt                                           // combobox with text edit
00092 } DP5_CTRL_TYPE;
00093
00094 typedef enum _DP5_CTRL_GROUP {  // dp5 control group
00095     dcgFile,                                            // file
00096     dcgMCA,                                                     // mca
00097     dcgShaping,                                         // Shaping
00098     dcgGainPZ,                                          // GainPZ
00099     dcgPower,                                           // Power
00100     dcgMisc,                                            // Misc
00101     dcgBootOpt                                          // BootOpt
00102 } DP5_CTRL_GROUP;
00103
00104 typedef enum _DP5_DATA_ID {             // dp5 data id, index to dp5 config data
00105         ddiCommand,                                     // 4-char COMMAND mnemonic
00106         ddiListCtrlID,                          // combobox control ID if any
00107         ddiTextCtrlID,                          // text control ID if any
00108         ddiCtrlType,                            // control type
00109         ddiCtrlGroup,                           // control group (page)
00110         ddiDescription,                         // COMMAND Description
00111         ddiUnits,                                       // COMMAND units
00112         ddiTextValue,                           // typed-in text value
00113         ddiComboValue,                          // selected combo value text
00114         ddiComboIndex,                          // selected combo index
00115         ddiComments                             // to append to command on save
00116 } DP5_DATA_ID;
00117
00118 typedef struct _DP5_CONFIGURATION {
00119         // these values are constant
00120         CString Command;                        // 4-char COMMAND mnemonic
00121         int ListCtrlID;                         // combobox control ID if any
00122         int TextCtrlID;                         // text control ID if any
00123         DP5_CTRL_TYPE CtrlType;         // control type
00124         DP5_CTRL_GROUP CtrlGroup;       // control group (page)
00125         CString Description;            // COMMAND Description
00126         CString Units;                          // COMMAND units
00127         CString Limits;                         // COMMAND limits
00128         // these values are read in
00129         CString Setting;                        // raw setting before parsing for controls
00130         CString TextValue;                      // typed-in text value
00131         CString ComboValue;                     // selected combo value text
00132         int ComboIndex;                         // selected combo index
00133         CString Comments;                       // to append to command on save
00134         CString ValComments;            // to append to values on save
00135         BOOL bAppendUnits;                      // append optional units for typed-in values
00136         //BOOL bSendCommand;                    // command selected to be sent from dialog
00137         //int ControlOrder;
00138 } DP5_CONFIGURATION;
00139
00140 #define MAX_DP5_CONFIGURATIONS 100
00141
00142 class CDP5ControlUtil
00143 {
00144 public:
00145         CDP5ControlUtil(void);
00146         ~CDP5ControlUtil(void);
00147         BOOL LoadingCfg;
00148         CString strFindTab;
00149         CString strFindCtrl;
00150         CString strFindIdx;
00151         int FindCboIdxExact(HWND hDlg, int cboDP5CtrlID, CString strVal);
00152         int FindCboIdx(HWND hDlg, int cboDP5CtrlID, CString strVal);
00153         //void SetCboIdxByStr(HWND hDlg, int cboDP5CtrlID, CString strVal);
00154         void SetCboIdxByStr(HWND hDlg, DP5_CONFIGURATION cfg);
00155         int FindUnitsInString(CString strValue, CString strUnits);
00156         void RemoveUnitsFromDecString(DP5_CONFIGURATION *cfg);
00157         CString AppendUnitsToString(CString strValue, CString strUnits);
00158         void AppendUnitsToSettingString(DP5_CONFIGURATION *cfg);
00159         void UpdateSetting(DP5_CONFIGURATION *cfg);
00160         void UpdateSettingOsc(DP5_CONFIGURATION *cfg);
00161         int OrderOut(int IndexIn);
00162         BOOL IsAllNumericString(CString strValue);
00163         CString GetValueWithUnitsString(DP5_CONFIGURATION cfg);
00164 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Protocol.cpp Source File

DeviceIO/DP5Protocol.cpp
Go to the documentation of this file.
00001 #include "DP5Protocol.h"
00002
00003 CDP5Protocol::CDP5Protocol(void)
00004 {
00005 }
00006
00007 CDP5Protocol::~CDP5Protocol(void)
00008 {
00009 }
00010
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Protocol.h Source File

DeviceIO/DP5Protocol.h
Go to the documentation of this file.
00001
00002 #pragma once
00003 #include <math.h>
00004
00005 enum TRANSMIT_PACKET_TYPE {
00006      //REQUEST_PACKETS_TO_DP5
00007         XMTPT_SEND_STATUS,
00008     XMTPT_SEND_SPECTRUM,
00009     XMTPT_SEND_CLEAR_SPECTRUM,
00010     XMTPT_SEND_SPECTRUM_STATUS,
00011     XMTPT_SEND_CLEAR_SPECTRUM_STATUS,
00012     XMTPT_BUFFER_SPECTRUM,
00013     XMTPT_BUFFER_CLEAR_SPECTRUM,
00014     XMTPT_SEND_BUFFER,
00015     XMTPT_SEND_DP4_STYLE_STATUS,
00016     XMTPT_SEND_PX4_CONFIG,
00017     XMTPT_SEND_SCOPE_DATA,
00018     XMTPT_SEND_512_BYTE_MISC_DATA,
00019     XMTPT_SEND_SCOPE_DATA_REARM,
00020     XMTPT_SEND_ETHERNET_SETTINGS,
00021     XMTPT_SEND_DIAGNOSTIC_DATA,
00022         XMTPT_SEND_NETFINDER_PACKET,
00023     XMTPT_SEND_HARDWARE_DESCRIPTION,
00024     XMTPT_SEND_SCA,
00025     XMTPT_LATCH_SEND_SCA,
00026     XMTPT_LATCH_CLEAR_SEND_SCA,
00027     XMTPT_SEND_ROI_OR_FIXED_BLOCK,
00028     XMTPT_PX4_STYLE_CONFIG_PACKET,
00029     XMTPT_SEND_CONFIG_PACKET_EX,
00030         XMTPT_SEND_CONFIG_PACKET_TO_HW,
00031     XMTPT_READ_CONFIG_PACKET,
00032     XMTPT_READ_CONFIG_PACKET_EX,
00033     XMTPT_FULL_READ_CONFIG_PACKET,
00034     XMTPT_SCA_READ_CONFIG_PACKET,
00035     XMTPT_ERASE_FPGA_IMAGE,
00036     XMTPT_UPLOAD_PACKET_FPGA,
00037     XMTPT_REINITIALIZE_FPGA,
00038     XMTPT_ERASE_UC_IMAGE_0,
00039     XMTPT_ERASE_UC_IMAGE_1,
00040     XMTPT_ERASE_UC_IMAGE_2,
00041     XMTPT_UPLOAD_PACKET_UC,
00042     XMTPT_SWITCH_TO_UC_IMAGE_0,
00043     XMTPT_SWITCH_TO_UC_IMAGE_1,
00044     XMTPT_SWITCH_TO_UC_IMAGE_2,
00045     XMTPT_UC_FPGA_CHECKSUMS,
00046
00047     //VENDOR_REQUESTS_TO_DP5
00048     XMTPT_CLEAR_SPECTRUM_BUFFER_A,
00049     XMTPT_ENABLE_MCA_MCS,
00050     XMTPT_DISABLE_MCA_MCS,
00051     XMTPT_ARM_DIGITAL_OSCILLOSCOPE,
00052     XMTPT_AUTOSET_INPUT_OFFSET,
00053     XMTPT_AUTOSET_FAST_THRESHOLD,
00054     XMTPT_READ_IO3_0,
00055     XMTPT_WRITE_IO3_0,
00056     XMTPT_WRITE_512_BYTE_MISC_DATA,
00057     XMTPT_SET_DCAL,
00058     XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ,
00059     XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL_UC,
00060     XMTPT_SET_BOOT_FLAGS,
00061     XMTPT_SET_HV_DP4_EMULATION,
00062     XMTPT_SET_TEC_DP4_EMULATION,
00063     XMTPT_SET_INPUT_OFFSET_DP4_EMULATION,
00064     XMTPT_SET_ADC_CAL_GAIN_OFFSET,
00065     XMTPT_SET_SPECTRUM_OFFSET,
00066     XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS,
00067     XMTPT_SET_SERIAL_NUMBER,
00068     XMTPT_CLEAR_GP_COUNTER,
00069     XMTPT_SWITCH_SUPPLIES,
00070
00071     XMTPT_SEND_TEST_PACKET,
00072         XMTPT_REQ_ACK_PACKET,
00073         XMTPT_FORCE_SCOPE_TRIGGER,
00074         XMTPT_READ_MCA8000D_OPTION_PA_CAL,
00075         XMTPT_AU34_2_RESTART
00076 };  //TRANSMIT_PACKET_TYPE
00077
00078 //enum RECEIVE_PACKET_TYPE {
00079 //     //RESPONSE_PACKETS_FROM_DP5
00080 //    RCVPT_DP4_STYLE_STATUS,
00081 //    RCVPT_256_CHANNEL_SPECTRUM,
00082 //    RCVPT_256_CHANNEL_SPECTRUM_STATUS,
00083 //    RCVPT_512_CHANNEL_SPECTRUM,
00084 //    RCVPT_512_CHANNEL_SPECTRUM_STATUS,
00085 //    RCVPT_1024_CHANNEL_SPECTRUM,
00086 //    RCVPT_1024_CHANNEL_SPECTRUM_STATUS,
00087 //    RCVPT_2048_CHANNEL_SPECTRUM,
00088 //    RCVPT_2048_CHANNEL_SPECTRUM_STATUS,
00089 //    RCVPT_4096_CHANNEL_SPECTRUM,
00090 //    RCVPT_4096_CHANNEL_SPECTRUM_STATUS,
00091 //    RCVPT_8192_CHANNEL_SPECTRUM,
00092 //    RCVPT_8192_CHANNEL_SPECTRUM_STATUS,
00093 //    RCVPT_SCOPE_DATA,
00094 //    RCVPT_512_BYTE_MISC_DATA,
00095 //    RCVPT_IO3_0_STATE
00096 //};  //RECEIVE_PACKET_TYPE
00097
00098 enum PID1_TYPE {
00099     PID1_REQ_STATUS = 0x01,
00100     PID1_REQ_SPECTRUM = 0x02,
00101     PID1_REQ_SCOPE_MISC = 0x03,
00102     PID1_REQ_SCA = 0x04,
00103     PID1_REQ_CONFIG = 0x20,
00104     PID1_REQ_FPGA_UC = 0x30,
00105     PID1_RCV_STATUS = 0x80,
00106     PID1_RCV_SPECTRUM = 0x81,
00107     PID1_RCV_SCOPE_MISC = 0x82,
00108     PID1_RCV_SCA = 0x83,
00109     PID1_VENDOR_REQ = 0xF0,
00110         PID1_COMM_TEST = 0xF1,
00111     PID1_ACK = 0xFF
00112 };  //PID1_TYPE
00113
00114 enum PID2_REQ_STATUS_TYPE {
00115     PID2_SEND_DP4_STYLE_STATUS = 0x01
00116 };  //PID2_REQ_STATUS_TYPE
00117
00118 enum PID2_REQ_SPECTRUM_TYPE {
00119     // REQUEST_PACKETS_TO_DP5
00120     PID2_SEND_SPECTRUM = 0x01,
00121     PID2_SEND_CLEAR_SPECTRUM = 0x02,
00122     PID2_SEND_SPECTRUM_STATUS = 0x03,
00123     PID2_SEND_CLEAR_SPECTRUM_STATUS = 0x04
00124     //PID2_BUFFER_SPECTRUM,
00125     //PID2_BUFFER_CLEAR_SPECTRUM,
00126     //PID2_SEND_BUFFER,
00127     //PID2_SEND_CONFIG
00128 };  //PID2_REQ_SPECTRUM_TYPE
00129
00130 enum PID2_REQ_SCOPE_MISC_TYPE {
00131     PID2_SEND_SCOPE_DATA = 0x01,
00132     PID2_SEND_512_BYTE_MISC_DATA = 0x02,
00133     PID2_SEND_SCOPE_DATA_REARM = 0x03,
00134     PID2_SEND_ETHERNET_SETTINGS = 0x04,
00135     PID2_SEND_DIAGNOSTIC_DATA = 0x05,
00136     PID2_SEND_HARDWARE_DESCRIPTION = 0x06,
00137         PID2_SEND_NETFINDER_READBACK = 0x07,
00138         PID2_SEND_I2C_DATA = 0x08,
00139         PID2_SEND_LIST_MODE_DATA = 0x09,
00140         PID2_SEND_OPTION_PA_CALIBRATION = 0x0A
00141 };  //PID2_REQ_SCOPE_MISC_TYPE
00142
00143 enum PID2_REQ_SCA_TYPE {
00144     PID2_SEND_SCA = 0x01,
00145     PID2_LATCH_SEND_SCA = 0x02,
00146     PID2_LATCH_CLEAR_SEND_SCA = 0x03
00147 };  //PID2_REQ_SCA_TYPE
00148
00149 enum PID2_REQ_CONFIG_TYPE {
00150     PID2_PX4_STYLE_CONFIG_PACKET = 0x01,
00151     PID2_TEXT_CONFIG_PACKET = 0x02,
00152     PID2_CONFIG_READBACK_PACKET = 0x03
00153 };  //PID2_SEND_CONFIG_TYPE
00154
00155 enum PID2_REQ_FPGA_UC_TYPE {
00156     PID2_ERASE_FPGA_IMAGE = 0x01,
00157     PID2_UPLOAD_PACKET_FPGA = 0x02,
00158     PID2_REINITIALIZE_FPGA = 0x03,
00159     PID2_ERASE_UC_IMAGE_0 = 0x04,
00160     PID2_ERASE_UC_IMAGE_1 = 0x05,
00161     PID2_ERASE_UC_IMAGE_2 = 0x06,
00162     PID2_UPLOAD_PACKET_UC = 0x07,
00163     PID2_SWITCH_TO_UC_IMAGE_0 = 0x08,
00164     PID2_SWITCH_TO_UC_IMAGE_1 = 0x09,
00165     PID2_SWITCH_TO_UC_IMAGE_2 = 0x0A
00166     //PID2_UC_FPGA_CHECKSUMS
00167 };  //PID2_REQ_FPGA_UC_TYPE
00168
00169 enum PID2_VENDOR_REQ_TYPE {
00170     PID2_CLEAR_SPECTRUM_BUFFER_A = 0x01,
00171     PID2_ENABLE_MCA_MCS = 0x02,
00172     PID2_DISABLE_MCA_MCS = 0x03,
00173     PID2_ARM_DIGITAL_OSCILLOSCOPE = 0x04,
00174     PID2_AUTOSET_INPUT_OFFSET = 0x05,
00175     PID2_AUTOSET_FAST_THRESHOLD = 0x06,
00176     PID2_READ_IO3_0 = 0x07,
00177     PID2_WRITE_IO3_0 = 0x08,
00178     PID2_WRITE_512_BYTE_MISC_DATA = 0x09,
00179     PID2_SET_DCAL = 0x0A,
00180     PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_PZ = 0x0B,
00181     PID2_SET_PZ_CORRECTION_UC_TEMP_CAL_UC = 0x0C,
00182     PID2_SET_BOOT_FLAGS = 0x0D,
00183     //PID2_SET_HV_DP4_EMULATION
00184     //PID2_SET_TEC_DP4_EMULATION
00185     //PID2_SET_INPUT_OFFSET_DP4_EMULATION
00186     PID2_SET_ADC_CAL_GAIN_OFFSET = 0x0E,
00187     //PID2_SET_SPECTRUM_OFFSET
00188     //PID2_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS
00189     PID2_SET_SERIAL_NUMBER = 0x0F,
00190     PID2_CLEAR_GP_COUNTER = 0x10,
00191     PID2_SET_ETHERNET_SETTINGS = 0x11,
00192     //PID2_SWITCH_SUPPLIES
00193     PID2_ETHERNET_ALLOW_SHAREING = 0x20,
00194     PID2_ETHERNET_NO_SHARING = 0x21,
00195     PID2_ETHERNET_LOCK_IP = 0x22,
00196         PID2_GENERIC_FPGA_WRITE = 0x89
00197 };  //PID2_VENDOR_REQ_TYPE
00198
00199 enum PID2_RCV_STATUS_TYPE {
00200     RCVPT_DP4_STYLE_STATUS = 0x01
00201 };  //PID2_RCV_STATUS_TYPE
00202
00203 enum PID2_RCV_SPECTRUM_TYPE {
00204     RCVPT_256_CHANNEL_SPECTRUM = 0x01,
00205     RCVPT_256_CHANNEL_SPECTRUM_STATUS = 0x02,
00206     RCVPT_512_CHANNEL_SPECTRUM = 0x03,
00207     RCVPT_512_CHANNEL_SPECTRUM_STATUS = 0x04,
00208     RCVPT_1024_CHANNEL_SPECTRUM = 0x05,
00209     RCVPT_1024_CHANNEL_SPECTRUM_STATUS = 0x06,
00210     RCVPT_2048_CHANNEL_SPECTRUM = 0x07,
00211     RCVPT_2048_CHANNEL_SPECTRUM_STATUS = 0x08,
00212     RCVPT_4096_CHANNEL_SPECTRUM = 0x09,
00213     RCVPT_4096_CHANNEL_SPECTRUM_STATUS = 0x0A,
00214     RCVPT_8192_CHANNEL_SPECTRUM = 0x0B,
00215     RCVPT_8192_CHANNEL_SPECTRUM_STATUS = 0x0C
00216 };  //PID2_RCV_SPECTRUM_TYPE
00217
00218 enum PID2_RCV_SCOPE_MISC_TYPE {
00219     RCVPT_SCOPE_DATA = 0x01,
00220     RCVPT_512_BYTE_MISC_DATA = 0x02,
00221     RCVPT_SCOPE_DATA_WITH_OVERFLOW = 0x03,
00222     RCVPT_ETHERNET_SETTINGS = 0x04,
00223     RCVPT_DIAGNOSTIC_DATA = 0x05,
00224     RCVPT_HARDWARE_DESCRIPTION = 0x06,
00225         RCVPT_CONFIG_READBACK = 0x07,
00226         RCVPT_NETFINDER_READBACK = 0x08,
00227         RCVPT_I2C_DATA = 0x09,
00228         RCVPT_LIST_MODE_DATA = 0x0A,
00229         RCVPT_LIST_MODE_DATA_FIFO_FULL = 0x0B,
00230         RCVPT_OPTION_PA_CALIBRATION = 0x0C
00231 };  //PID2_REQ_SCOPE_MISC_TYPE
00232
00233 enum PID2_RCV_SCA_TYPE {
00234     RCVPT_SCA = 0x01
00235 };  //PID2_REQ_SCA_TYPE
00236
00237 enum PID2_ACK_TYPE {  //PID1_ACK, PID2_ACK_TYPE)
00238     PID2_ACK_OK = 0x00,
00239     PID2_ACK_SYNC_ERROR = 0x01,
00240     PID2_ACK_PID_ERROR = 0x02,
00241     PID2_ACK_LEN_ERROR = 0x03,
00242     PID2_ACK_CHECKSUM_ERROR = 0x04,
00243     PID2_ACK_BAD_PARAM = 0x05,
00244     PID2_ACK_BAD_HEX_REC = 0x06,
00245     PID2_ACK_UNRECOG = 0x07,
00246     PID2_ACK_FPGA_ERROR = 0x08,
00247     PID2_ACK_CP2201_NOT_FOUND = 0x09,
00248     PID2_ACK_SCOPE_DATA_NOT_AVAIL = 0x0A,
00249     PID2_ACK_PC5_NOT_PRESENT = 0x0B,
00250     PID2_ACK_OK_ETHERNET_SHARE_REQ = 0x0C,
00251         PID2_ACK_ETHERNET_BUSY = 0x0D,
00252         PID2_ACK_I2C_ERROR = 0x0E,
00253         PID2_ACK_OK_FPGA_UPLOAD_ADDR = 0x0F,
00254         PID2_ACK_FEATURE_NOT_FPGA_SUPPORTED = 0x10,
00255         PID2_ACK_CAL_DATA_NOT_PRESENT = 0x11
00256 };  //PID2_ACK_TYPE
00257
00258 //#define PID1_ACK 0xFF
00259
00260 #define ACK 0
00261 //#define STATUS 1
00262 //#define SPECTRUM 2
00263 #define SYNC1_ 0xF5
00264 #define SYNC2_ 0xFA
00265
00266 #define RS232 0
00267 #define USB 1
00268 #define ETHERNET 2
00269
00270 #define ETHERNET_TIMEOUT 1000   // default timeout of 1000mS
00271 #define RS232_TIMEOUT 2500      // default timeout of 2500mS (8K spectrum ~2.2s)
00272 #define USB_TIMEOUT 500         // default timeout of 500mS
00273
00274 #define Retries 2   // total of 3 attempts
00275
00276 typedef struct _Packet_In {
00277     unsigned char PID1;
00278     unsigned char PID2;
00279     unsigned short LEN;  // signed, but data payload always less than 32768
00280     unsigned char STATUS;
00281     unsigned char DATA[32768];
00282     long CheckSum;
00283 } Packet_In;
00284
00285 struct Packet_Out {
00286     unsigned char PID1;
00287     unsigned char PID2;
00288     unsigned short LEN;  // signed, but data payload always less than 32768
00289     unsigned char EXPECTEDRESPONSE;
00290     unsigned char DATA[514];
00291 };
00292
00293 #define MAX_BUFFER_DATA         8192
00294 #define MAX_SCOPE_DATA          2048
00295 #define USB_DiagDataDelayMS 2500
00296
00297 struct Spec {
00298         long DATA[MAX_BUFFER_DATA];   // this keeps total of static data under 64K VB limit
00299         short CHANNELS;
00300 };
00301
00302 class CDP5Protocol
00303 {
00304 public:
00305         CDP5Protocol(void);
00306         ~CDP5Protocol(void);
00307
00309         short InPacketType;
00310         // Incoming packet buffer. (24648==largest possible IN packet.)
00311         unsigned char PacketIn[24648];
00312
00314         long RS232BytesInBuffer;
00316         long RS232_RThreshold;
00318         bool RS232HeaderReceived;
00320         short RS232PacketPtr;
00321
00323         bool ScaleAuto;
00325         unsigned char Scope[2048];
00327         unsigned char MiscData[512];
00329         bool CommError;
00331         unsigned char BufferOUT[520];
00333         Spec SPECTRUM;
00335         Packet_In PIN;
00336
00338         bool ACK_Received;
00340         bool Packet_Received;
00342         bool Timeout_flag;
00343
00344         int UDP_offset;
00345         bool Netfinder_active;
00346         int Netfinder_Seq;
00347
00349         bool USB_Default_Timeout;
00350 };
00351
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Status.cpp Source File

DeviceIO/DP5Status.cpp
Go to the documentation of this file.
00001
00002 #include "DP5Status.h"
00003 #include "stringex.h"
00004 #include "DppConst.h"
00005 #ifdef _MSC_VER
00006     #pragma warning(disable:4996)
00007 #endif
00008
00009 CDP5Status::CDP5Status(void)
00010 {
00011 }
00012
00013 CDP5Status::~CDP5Status(void)
00014 {
00015 }
00016
00017 void CDP5Status::Process_Status(DP4_FORMAT_STATUS *m_DP5_Status)
00018 {
00019         bool bDMCA_LiveTime = false;
00020         unsigned int uiFwBuild = 0;
00021
00022         m_DP5_Status->DEVICE_ID = m_DP5_Status->RAW[39];
00023     m_DP5_Status->FastCount = DppUtil.LongWordToDouble(0, m_DP5_Status->RAW);
00024     m_DP5_Status->SlowCount = DppUtil.LongWordToDouble(4, m_DP5_Status->RAW);
00025     m_DP5_Status->GP_COUNTER = DppUtil.LongWordToDouble(8, m_DP5_Status->RAW);
00026     m_DP5_Status->AccumulationTime = (float)m_DP5_Status->RAW[12] * 0.001 + (float)(m_DP5_Status->RAW[13] + (float)m_DP5_Status->RAW[14] * 256.0 + (float)m_DP5_Status->RAW[15] * 65536.0) * 0.1;
00027         m_DP5_Status->RealTime = ((double)m_DP5_Status->RAW[20] + ((double)m_DP5_Status->RAW[21] * 256.0) + ((double)m_DP5_Status->RAW[22] * 65536.0) + ((double)m_DP5_Status->RAW[23] * 16777216.0)) * 0.001;
00028
00029         m_DP5_Status->Firmware = m_DP5_Status->RAW[24];
00030     m_DP5_Status->FPGA = m_DP5_Status->RAW[25];
00031
00032         if (m_DP5_Status->Firmware > 0x65) {
00033                 m_DP5_Status->Build = m_DP5_Status->RAW[37] & 0xF;              //Build # added in FW6.06
00034         } else {
00035                 m_DP5_Status->Build = 0;
00036         }
00037
00038         //Firmware Version:  6.07  Build:  0 has LiveTime and PREL
00039         //DEVICE_ID 0=DP5,1=PX5,2=DP5G,3=MCA8000D,4=TB5
00040         if (m_DP5_Status->DEVICE_ID == dppMCA8000D) {
00041                 if (m_DP5_Status->Firmware >= 0x67) {
00042                         bDMCA_LiveTime = true;
00043                 }
00044         }
00045
00046         if (bDMCA_LiveTime) {
00047                 m_DP5_Status->LiveTime = ((double)m_DP5_Status->RAW[16] + ((double)m_DP5_Status->RAW[17] * 256.0) + ((double)m_DP5_Status->RAW[18] * 65536.0) + ((double)m_DP5_Status->RAW[19] * 16777216.0)) * 0.001;
00048         } else {
00049                 m_DP5_Status->LiveTime = 0;
00050         }
00051
00052     if (m_DP5_Status->RAW[29] < 128) {
00053         m_DP5_Status->SerialNumber = (unsigned long)DppUtil.LongWordToDouble(26, m_DP5_Status->RAW);
00054     } else {
00055         m_DP5_Status->SerialNumber = -1;
00056     }
00057
00058         // m_DP5_Status->HV = (double)(m_DP5_Status->RAW[31] + (m_DP5_Status->RAW[30] & 15) * 256) * 0.5;                                       // 0.5V/count
00059
00060         if (m_DP5_Status->RAW[30] < 128)  {    // not negative
00061         m_DP5_Status->HV = ((double)m_DP5_Status->RAW[31] + ((double)m_DP5_Status->RAW[30] * 256.0)) * 0.5;  // 0.5V/count
00062         } else {
00063                 m_DP5_Status->HV = (((double)m_DP5_Status->RAW[31] + ((double)m_DP5_Status->RAW[30] * 256)) - 65536.0) * 0.5; // 0.5V/count
00064         }
00065
00066         m_DP5_Status->DET_TEMP = (double)((m_DP5_Status->RAW[33]) + (m_DP5_Status->RAW[32] & 15) * 256) * 0.1; // - 273.16;             // 0.1K/count
00067     m_DP5_Status->DP5_TEMP = m_DP5_Status->RAW[34] - ((m_DP5_Status->RAW[34] & 128) * 2);
00068
00069     m_DP5_Status->PresetRtDone = ((m_DP5_Status->RAW[35] & 128) == 128);
00070
00071         //unsigned char:35 BIT:D6
00072         // == Preset LiveTime Done for MCA8000D
00073         // == FAST Thresh locked for other dpp devices
00074         m_DP5_Status->PresetLtDone = false;
00075         m_DP5_Status->AFAST_LOCKED = false;
00076         if (bDMCA_LiveTime) {           // test for MCA8000D
00077                 m_DP5_Status->PresetLtDone = ((m_DP5_Status->RAW[35] & 64) == 64);
00078         } else {
00079                 m_DP5_Status->AFAST_LOCKED = ((m_DP5_Status->RAW[35] & 64) == 64);
00080         }
00081     m_DP5_Status->MCA_EN = ((m_DP5_Status->RAW[35] & 32) == 32);
00082     m_DP5_Status->PRECNT_REACHED = ((m_DP5_Status->RAW[35] & 16) == 16);
00083     m_DP5_Status->SCOPE_DR = ((m_DP5_Status->RAW[35] & 4) == 4);
00084     m_DP5_Status->DP5_CONFIGURED = ((m_DP5_Status->RAW[35] & 2) == 2);
00085
00086     m_DP5_Status->AOFFSET_LOCKED = ((m_DP5_Status->RAW[36] & 128) == 0);  // 0=locked, 1=searching
00087     m_DP5_Status->MCS_DONE = ((m_DP5_Status->RAW[36] & 64) == 64);
00088
00089     m_DP5_Status->b80MHzMode = ((m_DP5_Status->RAW[36] & 2) == 2);
00090     m_DP5_Status->bFPGAAutoClock = ((m_DP5_Status->RAW[36] & 1) == 1);
00091
00092     m_DP5_Status->PC5_PRESENT = ((m_DP5_Status->RAW[38] & 128) == 128);
00093     if  (m_DP5_Status->PC5_PRESENT) {
00094         m_DP5_Status->PC5_HV_POL = ((m_DP5_Status->RAW[38] & 64) == 64);
00095         m_DP5_Status->PC5_8_5V = ((m_DP5_Status->RAW[38] & 32) == 32);
00096     } else {
00097         m_DP5_Status->PC5_HV_POL = false;
00098         m_DP5_Status->PC5_8_5V = false;
00099     }
00100
00101         if (m_DP5_Status->Firmware >= 0x65) {           // reboot flag added FW6.05
00102                 if ((m_DP5_Status->RAW[36] & 32) == 32) {
00103             m_DP5_Status->ReBootFlag = true;
00104                 } else {
00105                         m_DP5_Status->ReBootFlag = false;
00106                 }
00107         } else {
00108         m_DP5_Status->ReBootFlag = false;
00109         }
00110
00111         m_DP5_Status->TEC_Voltage = (((double)(m_DP5_Status->RAW[40] & 15) * 256.0) + (double)(m_DP5_Status->RAW[41])) / 758.5;
00112         m_DP5_Status->DPP_ECO = m_DP5_Status->RAW[49];
00113         m_DP5_Status->bScintHas80MHzOption = false;
00114         m_DP5_Status->DPP_options = (m_DP5_Status->RAW[42] & 15);
00115         m_DP5_Status->HPGe_HV_INH = false;
00116         m_DP5_Status->HPGe_HV_INH_POL = false;
00117         m_DP5_Status->AU34_2 = false;
00118         m_DP5_Status->isAscInstalled = false;
00119         m_DP5_Status->isDP5_RevDxGains = false;
00120         if (m_DP5_Status->DEVICE_ID == dppPX5) {
00121                 if (m_DP5_Status->DPP_options == PX5_OPTION_HPGe_HVPS) {
00122                         m_DP5_Status->HPGe_HV_INH = ((m_DP5_Status->RAW[42] & 32) == 32);
00123                         m_DP5_Status->HPGe_HV_INH_POL = ((m_DP5_Status->RAW[42] & 16) == 16);
00124                         if (m_DP5_Status->DPP_ECO == 1) {
00125                                 m_DP5_Status->isAscInstalled = true;
00126                                 m_DP5_Status->AU34_2 = ((m_DP5_Status->RAW[42] & 64) == 64);
00127                         }
00128                 }
00129         } else if ((m_DP5_Status->DEVICE_ID == dppDP5G) || (m_DP5_Status->DEVICE_ID == dppTB5)) {
00130                 if ((m_DP5_Status->DPP_ECO == 1) || (m_DP5_Status->DPP_ECO == 2)) {
00131                         // DPP_ECO == 2 80MHz option added 20150409
00132                         m_DP5_Status->bScintHas80MHzOption = true;
00133                 }
00134         } else if (m_DP5_Status->DEVICE_ID == dppDP5) {
00135                 uiFwBuild = m_DP5_Status->Firmware;
00136                 uiFwBuild = uiFwBuild << 8;
00137                 uiFwBuild = uiFwBuild + m_DP5_Status->Build;
00138                 // uiFwBuild - firmware with build for comparison
00139                 if (uiFwBuild >= 0x686) {
00140                         // 0xFF Value indicates old Analog Gain Count of 16
00141                         // Values < 0xFF indicate new gain count of 24 and new board rev
00142                         // "DP5 G3 Configuration P" will not be used (==0xFF)
00143                         if (m_DP5_Status->DPP_ECO < 0xFF) {
00144                                 m_DP5_Status->isDP5_RevDxGains = true;
00145                         }
00146
00147                 }
00148
00149         }
00150 }
00151
00152 string CDP5Status::DP5_Dx_OptionFlags(unsigned char DP5_Dx_Options) {
00153         unsigned char D7D6;
00154         unsigned char D5D4;
00155         unsigned char D3D0;
00156         string strRev("");
00157         stringex strfn;
00158
00159         //D7-D6: 0 = DP5 Rev D
00160         //       1 = DP5 Rev E (future)
00161         //       2 = DP5 Rev F (future)
00162         //       3 = DP5 Rev G (future)
00163         D7D6 = ((DP5_Dx_Options >> 6) & 0x03) + 'D';
00164         //D5-D4: minor rev, 0-3 (i.e. Rev D0, D1 etc.)
00165         D5D4 = ((DP5_Dx_Options >> 4) & 0x03);
00166         //D3-D0: Configuration 0 = A, 1=B, 2=C... 15=P.
00167         D3D0 = (DP5_Dx_Options & 0x0F) + 'A';
00168
00169         strRev = strfn.Format("DP5 Rev %c%d Configuration %c",D7D6,D5D4,D3D0);
00170         return(strRev);
00171
00172 }
00173
00174 string CDP5Status::ShowStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status)
00175 {
00176     string strConfig("");
00177     string strTemp;
00178         string strIntPart;
00179         string strFracPart;
00180         stringex strfn;
00181
00182         strTemp = GetDeviceNameFromVal(m_DP5_Status.DEVICE_ID);
00183         strConfig = "Device Type: " + strTemp + "\r\n";
00184         strTemp = strfn.Format("Serial Number: %lu\r\n",m_DP5_Status.SerialNumber);     //SerialNumber
00185         strConfig += strTemp;
00186         strTemp = "Firmware: " + DppUtil.BYTEVersionToString(m_DP5_Status.Firmware);
00187         strConfig += strTemp;
00188         if (m_DP5_Status.Firmware > 0x65) {
00189                 strTemp = strfn.Format("  Build:  %d\r\n", m_DP5_Status.Build);
00190                 strConfig += strTemp;
00191         } else {
00192                 strConfig += "\r\n";
00193         }
00194         strTemp = "FPGA: " + DppUtil.BYTEVersionToString(m_DP5_Status.FPGA) + "\r\n";
00195         strConfig += strTemp;
00196         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00197                 strTemp = strfn.Format("Fast Count: %.0f\r\n",m_DP5_Status.FastCount);          //FastCount
00198                 strConfig += strTemp;
00199         }
00200         strTemp = strfn.Format("Slow Count: %.0f\r\n",m_DP5_Status.SlowCount);          //SlowCount
00201         strConfig += strTemp;
00202         strTemp = strfn.Format("GP Count: %.0f\r\n",m_DP5_Status.GP_COUNTER);           //GP Count
00203         strConfig += strTemp;
00204
00205         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00206                 strTemp = strfn.Format("Accumulation Time: %.0f\r\n",m_DP5_Status.AccumulationTime);        //AccumulationTime
00207                 strConfig += strTemp;
00208         }
00209
00210         strTemp = strfn.Format("Real Time: %.0f\r\n",m_DP5_Status.RealTime);        //RealTime
00211         strConfig += strTemp;
00212
00213         if (m_DP5_Status.DEVICE_ID == dppMCA8000D) {
00214                 strTemp = strfn.Format("Live Time: %.0f\r\n",m_DP5_Status.LiveTime);        //RealTime
00215                 strConfig += strTemp;
00216         }
00217
00218         return strConfig;
00219 }
00220
00221 string CDP5Status::PX5_OptionsString(DP4_FORMAT_STATUS m_DP5_Status)
00222 {
00223         string strOptions("");
00224         string strValue("");
00225
00226         if (m_DP5_Status.DEVICE_ID == dppPX5) {
00227         //m_DP5_Status.DPP_options = 1;
00228         //m_DP5_Status.HPGe_HV_INH = true;
00229         //m_DP5_Status.HPGe_HV_INH_POL = true;
00230         if (m_DP5_Status.DPP_options > 0) {
00231             //===============PX5 Options==================
00232             strOptions += "PX5 Options: ";
00233             if ((m_DP5_Status.DPP_options & 1) == 1) {
00234                 strOptions += "HPGe HVPS\r\n";
00235             } else {
00236                 strOptions += "Unknown\r\n";
00237             }
00238             //===============HPGe HVPS HV Status==================
00239             strOptions += "HPGe HV: ";
00240             if (m_DP5_Status.HPGe_HV_INH) {
00241                 strOptions += "not inhibited\r\n";
00242             } else {
00243                 strOptions += "inhibited\r\n";
00244             }
00245             //===============HPGe HVPS Inhibit Status==================
00246             strOptions += "INH Polarity: ";
00247             if (m_DP5_Status.HPGe_HV_INH_POL) {
00248                 strOptions += "high\r\n";
00249             } else {
00250                 strOptions += "low\r\n";
00251             }
00252         } else {
00253             strOptions += "PX5 Options: None\r\n";  //           strOptions += "No Options Installed"
00254         }
00255     }
00256         return strOptions;
00257 }
00258
00259 string CDP5Status::GetStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status)
00260 {
00261     string strConfig("");
00262     string strTemp;
00263         string strIntPart;
00264         string strFracPart;
00265         stringex strfn;
00266
00267         strTemp = GetDeviceNameFromVal(m_DP5_Status.DEVICE_ID);
00268         strConfig = "Device Type: " + strTemp + "\r\n";
00269         strTemp = strfn.Format("Serial Number: %lu\r\n",m_DP5_Status.SerialNumber);     //SerialNumber
00270         strConfig += strTemp;
00271         strTemp = "Firmware: " + DppUtil.BYTEVersionToString(m_DP5_Status.Firmware);
00272         strConfig += strTemp;
00273         if (m_DP5_Status.Firmware > 0x65) {
00274                 strTemp = strfn.Format("  Build:  %d\r\n", m_DP5_Status.Build);
00275                 strConfig += strTemp;
00276         } else {
00277                 strConfig += "\r\n";
00278         }
00279         strTemp = "FPGA: " + DppUtil.BYTEVersionToString(m_DP5_Status.FPGA) + "\r\n";
00280         strConfig += strTemp;
00281         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00282                 strTemp = strfn.Format("Fast Count: %.0f\r\n",m_DP5_Status.FastCount);          //FastCount
00283                 strConfig += strTemp;
00284         }
00285         strTemp = strfn.Format("Slow Count: %.0f\r\n",m_DP5_Status.SlowCount);          //SlowCount
00286         strConfig += strTemp;
00287         strTemp = strfn.Format("GP Count: %.0f\r\n",m_DP5_Status.GP_COUNTER);           //GP Count
00288         strConfig += strTemp;
00289
00290         if (m_DP5_Status.DEVICE_ID != dppMCA8000D) {
00291                 strTemp = strfn.Format("Accumulation Time: %.0f\r\n",m_DP5_Status.AccumulationTime);        //AccumulationTime
00292                 strConfig += strTemp;
00293         }
00294
00295         strTemp = strfn.Format("Real Time: %.0f\r\n",m_DP5_Status.RealTime);        //RealTime
00296         strConfig += strTemp;
00297
00298         if (m_DP5_Status.DEVICE_ID == dppMCA8000D) {
00299                 strTemp = strfn.Format("Live Time: %.0f\r\n",m_DP5_Status.LiveTime);        //RealTime
00300                 strConfig += strTemp;
00301         }
00302
00303    if ((m_DP5_Status.DEVICE_ID != dppDP5G) && (m_DP5_Status.DEVICE_ID != dppTB5) && (m_DP5_Status.DEVICE_ID != dppMCA8000D)) {
00304         strTemp = strfn.Format("Detector Temp: %.0fK\r\n",m_DP5_Status.DET_TEMP);               //"##0°C") ' round to nearest degree
00305                 strConfig += strTemp;
00306                 strTemp = strfn.Format("Detector HV: %.0fV\r\n",m_DP5_Status.HV);
00307                 strConfig += strTemp;
00308                 strTemp = strfn.Format("Board Temp: %d°C\r\n",(int)m_DP5_Status.DP5_TEMP);
00309                 strConfig += strTemp;
00310         } else if ((m_DP5_Status.DEVICE_ID == dppDP5G) || (m_DP5_Status.DEVICE_ID == dppTB5)) {         // GAMMARAD5,TB5
00311                 if (m_DP5_Status.DET_TEMP > 0) {
00312                         strTemp = strfn.Format("Detector Temp: %.1fK\r\n",m_DP5_Status.DET_TEMP);
00313                         strConfig += strTemp;
00314                 } else {
00315                         strConfig += "";
00316                 }
00317                 strTemp = strfn.Format("HV Set: %.0fV\r\n",m_DP5_Status.HV);
00318                 strConfig += strTemp;
00319         } else if (m_DP5_Status.DEVICE_ID == dppMCA8000D) {             // Digital MCA
00320                 strTemp = strfn.Format("Board Temp: %d°C\r\n",(int)m_DP5_Status.DP5_TEMP);
00321                 strConfig += strTemp;
00322         }
00323         if (m_DP5_Status.DEVICE_ID == dppPX5) {
00324                 strTemp = PX5_OptionsString(m_DP5_Status);
00325                 strConfig += strTemp;
00326                 strTemp = strfn.Format("TEC V: %.3fV\r\n",m_DP5_Status.TEC_Voltage);
00327                 strConfig += strTemp;
00328         }
00329         return strConfig;
00330 }
00331
00332 void CDP5Status::Process_Diagnostics(Packet_In PIN, DiagDataType *dd, int device_type)
00333 {
00334     long idxVal;
00335     string strVal;
00336         double DP5_ADC_Gain[10];  // convert each ADC count to engineering units - values calculated in FORM.LOAD
00337         double PC5_ADC_Gain[3];
00338         double PX5_ADC_Gain[12];
00339     stringex strfn;
00340
00341     DP5_ADC_Gain[0] = 1.0 / 0.00286;                // 2.86mV/C
00342     DP5_ADC_Gain[1] = 1.0;                          // Vdd mon (out-of-scale)
00343     DP5_ADC_Gain[2] = (30.1 + 20.0) / 20.0;           // PWR
00344     DP5_ADC_Gain[3] = (13.0 + 20.0) / 20.0;            // 3.3V
00345     DP5_ADC_Gain[4] = (4.99 + 20.0) / 20.0;         // 2.5V
00346     DP5_ADC_Gain[5] = 1.0;                          // 1.2V
00347     DP5_ADC_Gain[6] = (35.7 + 20.0) / 20.0;          // 5.5V
00348     DP5_ADC_Gain[7] = (35.7 + 75.0) / 35.7;        // -5.5V (this one is tricky)
00349     DP5_ADC_Gain[8] = 1.0;                          // AN_IN
00350     DP5_ADC_Gain[9] = 1.0;                          // VREF_IN
00351
00352     PC5_ADC_Gain[0] = 500.0;                        // HV: 1500V/3V
00353     PC5_ADC_Gain[1] = 100.0;                        // TEC: 300K/3V
00354     PC5_ADC_Gain[2] = (20.0 + 10.0) / 10.0;            // +8.5/5V
00355
00356         //PX5_ADC_Gain[0] = (30.1 + 20.0) / 20.0;          // PWR
00357         PX5_ADC_Gain[0] = (69.8 + 20.0) / 20.0;          // 9V (was originally PWR)
00358     PX5_ADC_Gain[1] = (13.0 + 20.0) / 20.0;            // 3.3V
00359     PX5_ADC_Gain[2] = (4.99 + 20.0) / 20.0;          // 2.5V
00360     PX5_ADC_Gain[3] = 1.0;                         // 1.2V
00361     PX5_ADC_Gain[4] = (30.1 + 20.0) / 20.0;          // 5V
00362     PX5_ADC_Gain[5] = (10.7 + 75.0) / 10.7;         // -5V (this one is tricky)
00363     PX5_ADC_Gain[6] = (64.9 + 20.0) / 20.0;          // +PA
00364     PX5_ADC_Gain[7] = (10.7 + 75) / 10.7;        // -PA
00365     PX5_ADC_Gain[8] = (16.0 + 20.0) / 20.0;            // +TEC
00366     PX5_ADC_Gain[9] = 500.0;                       // HV: 1500V/3V
00367     PX5_ADC_Gain[10] = 100.0;                       // TEC: 300K/3V
00368     PX5_ADC_Gain[11] = 1.0 / 0.00286;               // 2.86mV/C
00369
00370     dd->Firmware = PIN.DATA[0];
00371     dd->FPGA = PIN.DATA[1];
00372     strVal = "0x0" + FmtHex(PIN.DATA[2], 2) + FmtHex(PIN.DATA[3], 2) + FmtHex(PIN.DATA[4], 2);
00373     dd->SRAMTestData = strtol(strVal.c_str(),NULL,0);
00374     dd->SRAMTestPass = (dd->SRAMTestData == 0xFFFFFF);
00375     dd->TempOffset = PIN.DATA[180] + 256 * (PIN.DATA[180] > 127);  // 8-bit signed value
00376
00377         if ((device_type == dppDP5) || (device_type == dppDP5X)) {
00378                 for(idxVal=0;idxVal<10;idxVal++){
00379                         dd->ADC_V[idxVal] = (float)((((PIN.DATA[5 + idxVal * 2] & 3) * 256) + PIN.DATA[6 + idxVal * 2]) * 2.44 / 1024.0 * DP5_ADC_Gain[idxVal]); // convert counts to engineering units (C or V)
00380                 }
00381                 dd->ADC_V[7] = dd->ADC_V[7] + dd->ADC_V[6] * (float)(1.0 - DP5_ADC_Gain[7]);  // -5.5V is a function of +5.5V
00382                 dd->strTempRaw = strfn.Format("%   #.0f0C", dd->ADC_V[0] - 271.3);
00383                 dd->strTempCal = strfn.Format("%   #.0f0C", (dd->ADC_V[0] - 280.0 + dd->TempOffset));
00384         } else if (device_type == dppPX5) {
00385         for(idxVal=0;idxVal<11;idxVal++){
00386             dd->ADC_V[idxVal] = (float)((((PIN.DATA[5 + idxVal * 2] & 15) * 256) + PIN.DATA[6 + idxVal * 2]) * 3.0 / 4096.0 * PX5_ADC_Gain[idxVal]);   // convert counts to engineering units (C or V)
00387                 }
00388         dd->ADC_V[11] = (float)((((PIN.DATA[5 + 11 * 2] & 3) * 256) + PIN.DATA[6 + 11 * 2]) * 3.0 / 1024.0 * PX5_ADC_Gain[11]);  // convert counts to engineering units (C or V)
00389         dd->ADC_V[5] = (float)(dd->ADC_V[5] - (3.0 * PX5_ADC_Gain[5]) + 3.0); // -5V uses +3VR
00390         dd->ADC_V[7] = (float)(dd->ADC_V[7] - (3.0 * PX5_ADC_Gain[7]) + 3.0); // -PA uses +3VR
00391                 dd->strTempRaw = strfn.Format("%#.1fC", dd->ADC_V[11] - 271.3);
00392                 dd->strTempCal = strfn.Format("%#.1fC", (dd->ADC_V[11] - 280.0 + dd->TempOffset));
00393         }
00394
00395     dd->PC5_PRESENT = false;  // assume no PC5, then check to see if there are any non-zero bytes
00396         for(idxVal=25;idxVal<=38;idxVal++) {
00397                 if (PIN.DATA[idxVal] > 0) {
00398             dd->PC5_PRESENT = true;
00399             break;
00400         }
00401     }
00402
00403     if (dd->PC5_PRESENT) {
00404                 for(idxVal=0;idxVal<=2;idxVal++) {
00405                         dd->PC5_V[idxVal] = (float)((((PIN.DATA[25 + idxVal * 2] & 15) * 256) + PIN.DATA[26 + idxVal * 2]) * 3.0 / 4096.0 * PC5_ADC_Gain[idxVal]); // convert counts to engineering units (C or V)
00406                 }
00407                 if (PIN.DATA[34] < 128) {
00408                         dd->PC5_SN = (unsigned long)DppUtil.LongWordToDouble(31, PIN.DATA);
00409                 } else {
00410                         dd->PC5_SN = -1; // no PC5 S/N
00411                 }
00412                 if ((PIN.DATA[35] == 255) && (PIN.DATA[36] == 255)) {
00413                         dd->PC5Initialized = false;
00414                         dd->PC5DCAL = 0;
00415                 } else {
00416                         dd->PC5Initialized = true;
00417                         dd->PC5DCAL = (float)(((float)(PIN.DATA[35]) * 256.0 + (float)(PIN.DATA[36])) * 3.0 / 4096.0);
00418                 }
00419                 dd->IsPosHV = ((PIN.DATA[37] & 128) == 128);
00420                 dd->Is8_5VPreAmp = ((PIN.DATA[37] & 64) == 64);
00421                 dd->Sup9VOn = ((PIN.DATA[38] & 8) == 8);
00422                 dd->PreAmpON = ((PIN.DATA[38] & 4) == 4);
00423                 dd->HVOn = ((PIN.DATA[38] & 2) == 2);
00424                 dd->TECOn = ((PIN.DATA[38] & 1) == 1);
00425         } else {
00426         for(idxVal=0;idxVal<=2;idxVal++) {
00427             dd->PC5_V[idxVal] = 0;
00428                 }
00429         dd->PC5_SN = -1; // no PC5 S/N
00430         dd->PC5Initialized = false;
00431         dd->PC5DCAL = 0;
00432         dd->IsPosHV = false;
00433         dd->Is8_5VPreAmp = false;
00434         dd->Sup9VOn = false;
00435         dd->PreAmpON = false;
00436         dd->HVOn = false;
00437         dd->TECOn = false;
00438     }
00439         for(idxVal=0;idxVal<=191;idxVal++) {
00440         dd->DiagData[idxVal] = PIN.DATA[idxVal + 39];
00441     }
00442         //string strData;
00443         //strData = DisplayBufferArray(PIN.DATA, 256);
00444         //SaveStringDataToFile(strData);
00445 }
00446
00447 string CDP5Status::DiagnosticsToString(DiagDataType dd, int device_type)
00448 {
00449     long idxVal;
00450         string strVal;
00451     string strDiag;
00452         stringex strfn;
00453
00454     strDiag = "Firmware: " + VersionToStr(dd.Firmware) + "\r\n";
00455     strDiag += "FPGA: " + VersionToStr(dd.FPGA) + "\r\n";
00456     strDiag += "SRAM Test: ";
00457     if (dd.SRAMTestPass) {
00458         strDiag += "PASS\r\n";
00459     } else {
00460         strDiag += "ERROR @ 0x" + FmtHex(dd.SRAMTestData, 6) + "\r\n";
00461     }
00462
00463         if ((device_type == dppDP5) || (device_type == dppDP5X)) {
00464                 strDiag += "DP5 Temp (raw): " + dd.strTempRaw + "\r\n";
00465                 strDiag += "DP5 Temp (cal'd): " + dd.strTempCal + "\r\n";
00466                 strDiag += "PWR: " + FmtPc5Pwr(dd.ADC_V[2]) + "\r\n";
00467                 strDiag += "3.3V: " + FmtPc5Pwr(dd.ADC_V[3]) + "\r\n";
00468                 strDiag += "2.5V: " + FmtPc5Pwr(dd.ADC_V[4]) + "\r\n";
00469                 strDiag += "1.2V: " + FmtPc5Pwr(dd.ADC_V[5]) + "\r\n";
00470                 strDiag += "+5.5V: " + FmtPc5Pwr(dd.ADC_V[6]) + "\r\n";
00471                 strDiag += "-5.5V: " + FmtPc5Pwr(dd.ADC_V[7]) + "\r\n";
00472                 strDiag += "AN_IN: " + FmtPc5Pwr(dd.ADC_V[8]) + "\r\n";
00473                 strDiag += "VREF_IN: " + FmtPc5Pwr(dd.ADC_V[9]) + "\r\n";
00474
00475                 strDiag += "\r\n";
00476                 if (dd.PC5_PRESENT) {
00477                         strDiag += "PC5: Present\r\n";
00478                         strVal = strfn.Format("%dV",(int)(dd.PC5_V[0]));
00479                         strDiag += "HV: " + strVal + "\r\n";
00480                         strVal = strfn.Format("%#.1fK",dd.PC5_V[1]);
00481                         strDiag += "Detector Temp: " + strVal + "\r\n";
00482                         strDiag += "+8.5/5V: " + FmtPc5Pwr(dd.PC5_V[2]) + "\r\n";
00483                         if (dd.PC5_SN > -1) {
00484                                 strDiag += "PC5 S/N: " + FmtLng(dd.PC5_SN) + "\r\n";
00485                         } else {
00486                                 strDiag += "PC5 S/N: none\r\n";
00487                         }
00488                         if (dd.PC5Initialized) {
00489                                 strDiag += "PC5 DCAL: " + FmtPc5Pwr(dd.PC5DCAL) + "\r\n";
00490                         } else {
00491                                 strDiag += "PC5 DCAL: Uninitialized\r\n";
00492                         }
00493                         strDiag += "PC5 Flavor: ";
00494                         strDiag += IsAorB(dd.IsPosHV, "+HV, ", "-HV, ");
00495                         strDiag += IsAorB(dd.Is8_5VPreAmp, "8.5V preamp", "5V preamp") + "\r\n";
00496                         strDiag += "PC5 Supplies:\r\n";
00497                         strDiag += "9V: " + OnOffStr(dd.Sup9VOn) + "\r\n";
00498                         strDiag += "Preamp: " + OnOffStr(dd.PreAmpON) + "\r\n";
00499                         strDiag += "HV: " + OnOffStr(dd.HVOn) + "\r\n";
00500                         strDiag += "TEC: " + OnOffStr(dd.TECOn) + "\r\n";
00501                 } else {
00502                         strDiag += "PC5: Not Present\r\n";
00503                 }
00504         } else if (device_type == dppPX5) {
00505                 strDiag += "PX5 Temp (raw): " + dd.strTempRaw + "\r\n";
00506                 strDiag += "PX5 Temp (cal'd): " + dd.strTempCal + "\r\n";
00507                 //strDiag += "PWR: " + FmtPc5Pwr(dd.ADC_V[0]) + "\r\n";
00508                 strDiag += "9V: " + FmtPc5Pwr(dd.ADC_V[0]) + "\r\n";
00509                 strDiag += "3.3V: " + FmtPc5Pwr(dd.ADC_V[1]) + "\r\n";
00510                 strDiag += "2.5V: " + FmtPc5Pwr(dd.ADC_V[2]) + "\r\n";
00511                 strDiag += "1.2V: " + FmtPc5Pwr(dd.ADC_V[3]) + "\r\n";
00512                 strDiag += "+5V: " + FmtPc5Pwr(dd.ADC_V[4]) + "\r\n";
00513                 strDiag += "-5V: " + FmtPc5Pwr(dd.ADC_V[5]) + "\r\n";
00514                 strDiag += "+PA: " + FmtPc5Pwr(dd.ADC_V[6]) + "\r\n";
00515                 strDiag += "-PA: " + FmtPc5Pwr(dd.ADC_V[7]) + "\r\n";
00516                 strDiag += "TEC: " + FmtPc5Pwr(dd.ADC_V[8]) + "\r\n";
00517                 strDiag += "ABS(HV): " + FmtHvPwr(dd.ADC_V[9]) + "\r\n";
00518                 strDiag += "DET_TEMP: " + FmtPc5Temp(dd.ADC_V[10]) + "\r\n";
00519         }
00520
00521     strDiag += "\r\nDiagnostic Data\r\n";
00522     strDiag += "---------------\r\n";
00523         for(idxVal=0;idxVal<=191;idxVal++) {
00524         if ((idxVal % 8) == 0) {
00525                         strDiag += FmtHex(idxVal, 2) + ":";
00526                 }
00527         strDiag += FmtHex(dd.DiagData[idxVal], 2) + " ";
00528         if ((idxVal % 8) == 7) {
00529                         strDiag += "\r\n";
00530                 }
00531     }
00532     return (strDiag);
00533 }
00534
00535 string CDP5Status::DiagStrPX5Option(DiagDataType dd, int device_type)
00536 {
00537     long idxVal;
00538         string strVal;
00539     string strDiag;
00540         stringex strfn;
00541
00542     strDiag = "Firmware: " + VersionToStr(dd.Firmware) + "\r\n";
00543     strDiag += "FPGA: " + VersionToStr(dd.FPGA) + "\r\n";
00544     strDiag += "SRAM Test: ";
00545     if (dd.SRAMTestPass) {
00546         strDiag += "PASS\r\n";
00547     } else {
00548         strDiag += "ERROR @ 0x" + FmtHex(dd.SRAMTestData, 6) + "\r\n";
00549     }
00550
00551         if (device_type == dppPX5) {
00552                 strDiag += "PX5 Temp (raw): " + dd.strTempRaw + "\r\n";
00553                 strDiag += "PX5 Temp (cal'd): " + dd.strTempCal + "\r\n";
00554                 strDiag += "9V: " + FmtPc5Pwr(dd.ADC_V[0]) + "\r\n";
00555                 strDiag += "3.3V: " + FmtPc5Pwr(dd.ADC_V[1]) + "\r\n";
00556                 strDiag += "2.5V: " + FmtPc5Pwr(dd.ADC_V[2]) + "\r\n";
00557                 strDiag += "TDET: " + FmtPc5Pwr(dd.ADC_V[3]) + "\r\n";
00558                 strDiag += "+5V: " + FmtPc5Pwr(dd.ADC_V[4]) + "\r\n";
00559                 strDiag += "-5V: " + FmtPc5Pwr(dd.ADC_V[5]) + "\r\n";
00560                 strDiag += "+PA: " + FmtPc5Pwr(dd.ADC_V[6]) + "\r\n";
00561                 strDiag += "-PA: " + FmtPc5Pwr(dd.ADC_V[7]) + "\r\n";
00562                 strDiag += "TEC: " + FmtPc5Pwr(dd.ADC_V[8]) + "\r\n";
00563                 strDiag += "ABS(HV): " + FmtHvPwr(dd.ADC_V[9]) + "\r\n";
00564                 strDiag += "DET_TEMP: " + FmtPc5Temp(dd.ADC_V[10]) + "\r\n";
00565         }
00566
00567     strDiag += "\r\nDiagnostic Data\r\n";
00568     strDiag += "---------------\r\n";
00569         for(idxVal=0;idxVal<=191;idxVal++) {
00570         if ((idxVal % 8) == 0) {
00571                         strDiag += FmtHex(idxVal, 2) + ":";
00572                 }
00573         strDiag += FmtHex(dd.DiagData[idxVal], 2) + " ";
00574         if ((idxVal % 8) == 7) {
00575                         strDiag += "\r\n";
00576                 }
00577     }
00578     return (strDiag);
00579 }
00580
00581 string CDP5Status::FmtHvPwr(float fVal)
00582 {
00583         string strVal;
00584         stringex strfn;
00585         strVal = strfn.Format("%#.1fV", fVal);  // "#.##0V"
00586         return strVal;
00587 }
00588
00589 string CDP5Status::FmtPc5Pwr(float fVal)
00590 {
00591         string strVal;
00592         stringex strfn;
00593         strVal = strfn.Format("%#.3fV", fVal);  // "#.##0V"
00594         return strVal;
00595 }
00596
00597 string CDP5Status::FmtPc5Temp(float fVal)
00598 {
00599         string strVal;
00600         stringex strfn;
00601         strVal = strfn.Format("%#.1fK", fVal);  // "#.##0V"
00602         return strVal;
00603 }
00604
00605 string CDP5Status::FmtHex(long FmtHex, long HexDig)
00606 {
00607         string strHex;
00608         string strFmt;
00609         stringex strfn;
00610         strFmt = strfn.Format("%d",HexDig);             // max size of 0 pad
00611         strFmt = "%0" + strFmt + "X";           // string format specifier
00612         strHex = strfn.Format(strFmt.c_str(), FmtHex);  // create padded string
00613         return strHex;
00614 }
00615
00616 string CDP5Status::FmtLng(long lVal)
00617 {
00618         string strVal;
00619         stringex strfn;
00620         strVal = strfn.Format("%d", lVal);
00621         return strVal;
00622 }
00623
00624 string CDP5Status::VersionToStr(unsigned char bVersion)
00625 {
00626         string strVerMajor;
00627         string strVerMinor;
00628         string strVer;
00629         stringex strfn;
00630         strVerMajor = strfn.Format("%d",((bVersion & 0xF0) / 16));
00631         strVerMinor = strfn.Format("%02d",(bVersion & 0x0F));
00632         strVer = strVerMajor + "." + strVerMinor;
00633         return (strVer);
00634 }
00635
00636 string CDP5Status::OnOffStr(bool bOn)
00637 {
00638     if (bOn) {
00639         return("ON");
00640     } else {
00641         return("OFF");
00642     }
00643 }
00644
00645 string CDP5Status::IsAorB(bool bIsA, string strA, string strB)
00646 {
00647     if (bIsA) {
00648         return(strA);
00649     } else {
00650         return(strB);
00651     }
00652 }
00653
00654 string CDP5Status::GetDeviceNameFromVal(int DeviceTypeVal)
00655 {
00656     string strDeviceType;
00657         switch(DeviceTypeVal) {
00658                 case 0:
00659             strDeviceType = "DP5";
00660                         break;
00661                 case 1:
00662             strDeviceType = "PX5";
00663                         break;
00664                 case 2:
00665             strDeviceType = "DP5G";
00666                         break;
00667                 case 3:
00668             strDeviceType = "MCA8000D";
00669                         break;
00670                 case 4:
00671             strDeviceType = "TB5";
00672                         break;
00673                 case 5:
00674             strDeviceType = "DP5-X";
00675                         break;
00676                 default:           //if unknown set to DP5
00677             strDeviceType = "DP5";
00678                         break;
00679         }
00680     return strDeviceType;
00681 }
00682
00683 string CDP5Status::DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn)
00684 {
00685     unsigned long i;
00686         string strVal("");
00687         string strMsg("");
00688         stringex strfn;
00689         for(i=0;i<bufSizeIn;i++) {
00690                 strVal = strfn.Format("%.2X ",buffer[i]);
00691                 strMsg += strVal;
00692                 //if (((i+1) % 16) == 0 ) {
00693                 //      strMsg += "\r\n";
00694                 //} else
00695                 if (((i+1) % 8) == 0 ) {
00696                 //      strMsg += "   ";
00697                         //strMsg += "\r\n";
00698                         strMsg += "\n";
00699                 }
00700         }
00701         //strMsg += "\n";
00702         return strMsg;
00703 }
00704
00705 void CDP5Status::SaveStringDataToFile(string strData)
00706 {
00707         FILE  *out;
00708         string strFilename;
00709         string strError;
00710         stringex strfn;
00711
00712         strFilename = "vcDP5_Data.txt";
00713
00714         if ( (out = fopen(strFilename.c_str(),"w")) == (FILE *) NULL)
00715                 strError = strfn.Format("Couldn't open %s for writing.\n", strFilename.c_str());
00716         else
00717         {
00718                 fprintf(out,"%s\n",strData.c_str());
00719         }
00720         fclose(out);
00721 }
00722
00723
00724
00725
00726
00727
00728
00729
00730
00731
00732
00733
00734
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DP5Status.h Source File

DeviceIO/DP5Status.h
Go to the documentation of this file.
00001
00003 #pragma once
00004 #include <stdio.h>
00005 #include <stdlib.h>
00006 #include "DP5Protocol.h"
00007 #include "DppUtilities.h"
00008
00009 typedef enum _PX5_OPTIONS
00010 {
00011         PX5_OPTION_NONE=0,
00012         PX5_OPTION_HPGe_HVPS=1,
00013         PX5_OPTION_TEST_TEK=4,
00014         PX5_OPTION_TEST_MOX=5,
00015         PX5_OPTION_TEST_AMP=6,
00016         PX5_OPTION_TEST_MODE_1=8,
00017         PX5_OPTION_TEST_MODE_2=9
00018 } PX5_OPTIONS;
00019
00020 //PX5_OPTION_TEST_MODE_1 reserved for future use
00021 //PX5_OPTION_TEST_MODE_2 reserved for future use
00022
00023 typedef struct DP5_DP4_FORMAT_STATUS
00024 {
00025     unsigned char RAW[64];
00026     unsigned long SerialNumber;
00027     double FastCount;
00028     double SlowCount;
00029     unsigned char FPGA;
00030     unsigned char Firmware;
00031         unsigned char Build;
00032     double AccumulationTime;
00033     double RealTime;
00034     double LiveTime;
00035     double HV;
00036     double DET_TEMP;
00037     double DP5_TEMP;
00038     bool PX4;
00039     bool AFAST_LOCKED;
00040     bool MCA_EN;
00041     bool PRECNT_REACHED;
00042         bool PresetRtDone;
00043         bool PresetLtDone;
00044     bool SUPPLIES_ON;
00045     bool SCOPE_DR;
00046     bool DP5_CONFIGURED;
00047     double GP_COUNTER;
00048     bool AOFFSET_LOCKED;
00049     bool MCS_DONE;
00050     bool RAM_TEST_RUN;
00051     bool RAM_TEST_ERROR;
00052     double DCAL;
00053     unsigned char PZCORR;                               // or single?
00054     unsigned char UC_TEMP_OFFSET;
00055     double AN_IN;
00056     double VREF_IN;
00057     unsigned long PC5_SN;
00058     bool PC5_PRESENT;
00059     bool PC5_HV_POL;
00060     bool PC5_8_5V;
00061     double ADC_GAIN_CAL;
00062     unsigned char ADC_OFFSET_CAL;
00063     long SPECTRUM_OFFSET;     // or single?
00064         bool b80MHzMode;
00065         bool bFPGAAutoClock;
00066         unsigned char DEVICE_ID;
00067         bool ReBootFlag;
00068         unsigned char DPP_options;
00069         bool HPGe_HV_INH;
00070         bool HPGe_HV_INH_POL;
00071         double TEC_Voltage;
00072         unsigned char DPP_ECO;
00073         bool AU34_2;
00074         bool isAscInstalled;
00075         bool isAscEnabled;
00076         bool bScintHas80MHzOption;
00077         bool isDP5_RevDxGains;
00078 } DP4_FORMAT_STATUS, *PDP4_FORMAT_STATUS;
00079
00080 typedef struct _DiagDataType
00081 {
00082     float ADC_V[12];
00083     float PC5_V[4];
00084     bool PC5_PRESENT;
00085     long PC5_SN;
00086     unsigned char Firmware;
00087     unsigned char FPGA;
00088     bool SRAMTestPass;
00089     long SRAMTestData;
00090     int TempOffset;
00091     string strTempRaw;
00092     string strTempCal;
00093     bool PC5Initialized;
00094     float PC5DCAL;
00095     bool IsPosHV;
00096     bool Is8_5VPreAmp;
00097     bool Sup9VOn;
00098     bool PreAmpON;
00099     bool HVOn;
00100     bool TECOn;
00101     unsigned char DiagData[192];
00102 } DiagDataType, *PDDiagDataType;
00103
00104 class CDP5Status
00105 {
00106 public:
00107         CDP5Status(void);
00108         ~CDP5Status(void);
00109
00111         CDppUtilities DppUtil;
00112
00114         DP4_FORMAT_STATUS m_DP5_Status;
00116         DiagDataType DiagData;
00118         void Process_Status(DP4_FORMAT_STATUS *m_DP5_Status);
00119         string DP5_Dx_OptionFlags(unsigned char DP5_Dx_Options);
00121         string ShowStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status);
00122         string PX5_OptionsString(DP4_FORMAT_STATUS m_DP5_Status);
00123         string GetStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status);
00124
00126         void Process_Diagnostics(Packet_In PIN, DiagDataType *dd, int device_type);
00128         string DiagnosticsToString(DiagDataType dd, int device_type);
00130         string DiagStrPX5Option(DiagDataType dd, int device_type);
00131
00133         string FmtHvPwr(float fVal);
00135         string FmtPc5Pwr(float fVal);
00137         string FmtPc5Temp(float fVal) ;
00139         string FmtHex(long FmtHex, long HexDig);
00141         string FmtLng(long lVal);
00143         string VersionToStr(unsigned char bVersion);
00145         string OnOffStr(bool bOn);
00147         string IsAorB(bool bIsA, string strA, string strB);
00149         string GetDeviceNameFromVal(int DeviceTypeVal) ;
00151         string DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn);
00153         void SaveStringDataToFile(string strData);
00154
00155 };
00156
00157
00158
00159
00160
00161
00162
00163
00164
00165
00166
00167
00168
00169
00170
00171
00172
00173
00174
00175
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Dlgbars.cpp Source File

DP5Cfg/Dlgbars.cpp
Go to the documentation of this file.
00001 // DLGBARS.cpp : Defines the class behaviors for the dialog tool bar
00002 //               and status bar.
00003 //
00004 // This is a part of the Microsoft Foundation Classes C++ library.
00005 // Copyright (c) Microsoft Corporation.  All rights reserved.
00006 //
00007 // This source code is only intended as a supplement to the
00008 // Microsoft Foundation Classes Reference and related
00009 // electronic documentation provided with the library.
00010 // See these sources for detailed information regarding the
00011 // Microsoft Foundation Classes product.
00012
00013 #include "stdafx.h"
00014 #include <afxpriv.h>
00015 #include "dlgbars.h"
00016
00017 #ifdef _DEBUG
00018 #define new DEBUG_NEW
00019 #undef THIS_FILE
00020 static char THIS_FILE[] = __FILE__;
00021 #endif
00022
00024 // CDlgToolBar
00025
00026 BEGIN_MESSAGE_MAP(CDlgToolBar, CToolBar)
00027         //{{AFX_MSG_MAP(CDlgToolBar)
00028         ON_MESSAGE(WM_IDLEUPDATECMDUI, OnIdleUpdateCmdUI)
00029                 // NOTE - the ClassWizard will add and remove mapping macros here.
00030                 //    DO NOT EDIT what you see in these blocks of generated code!
00031         //}}AFX_MSG_MAP
00032 END_MESSAGE_MAP()
00033
00035 // CDlgToolBar Construction/Destruction
00036
00037 CDlgToolBar::CDlgToolBar()
00038 {
00039 }
00040
00041 CDlgToolBar::~CDlgToolBar()
00042 {
00043 }
00044
00046 // CDlgToolBar::OnIdleUpdateCmdUI
00047 //      OnIdleUpdateCmdUI handles the WM_IDLEUPDATECMDUI message, which is
00048 //      used to update the status of user-interface elements within the MFC
00049 //      framework.
00050 //
00051 //      We have to get a little tricky here: CToolBar::OnUpdateCmdUI
00052 //      expects a CFrameWnd pointer as its first parameter.  However, it
00053 //      doesn't do anything but pass the parameter on to another function
00054 //      which only requires a CCmdTarget pointer.  We can get a CWnd pointer
00055 //      to the parent window, which is a CCmdTarget, but may not be a
00056 //      CFrameWnd.  So, to make CToolBar::OnUpdateCmdUI happy, we will call
00057 //      our CWnd pointer a CFrameWnd pointer temporarily.
00058
00059 LRESULT CDlgToolBar::OnIdleUpdateCmdUI(WPARAM wParam, LPARAM)
00060 {
00061         int nID;
00062         BOOL bEnable;
00063         POSITION rNextPosition;
00064
00065         if (!tbBtnMap.GetCount())
00066         {
00067         if (IsWindowVisible())
00068         {
00069                 CFrameWnd *pParent = (CFrameWnd *)GetParent();
00070                 if (pParent)
00071                         OnUpdateCmdUI(pParent, (BOOL)wParam);
00072         }
00073         }
00074
00075         if (IsWindowVisible())
00076         {
00077                 rNextPosition = tbBtnMap.GetStartPosition();
00078                 while (rNextPosition != NULL) {
00079                         tbBtnMap.GetNextAssoc(rNextPosition, nID, bEnable);
00080                         GetToolBarCtrl().EnableButton(nID, bEnable);
00081                 }
00082         }
00083         return 0L;
00084 }
00085
00086 void CDlgToolBar::EnableButton(int nID, BOOL bEnable)
00087 {
00088         GetToolBarCtrl().EnableButton(nID, bEnable);
00089         if (bEnable)
00090                 tbBtnMap.RemoveKey(nID);
00091         else
00092                 tbBtnMap.SetAt(nID, bEnable);
00093 }
00094
00096 // CDlgStatusBar
00097
00098 BEGIN_MESSAGE_MAP(CDlgStatusBar, CStatusBar)
00099         //{{AFX_MSG_MAP(CDlgStatusBar)
00100         ON_MESSAGE(WM_IDLEUPDATECMDUI, OnIdleUpdateCmdUI)
00101         //}}AFX_MSG_MAP
00102 END_MESSAGE_MAP()
00103
00105 // CDlgStatusBar Construction/Destruction
00106
00107 CDlgStatusBar::CDlgStatusBar()
00108 {
00109 }
00110
00111 CDlgStatusBar::~CDlgStatusBar()
00112 {
00113 }
00114
00116 // CDlgStatusBar::OnIdleUpdateCmdUI
00117 //      OnIdleUpdateCmdUI handles the WM_IDLEUPDATECMDUI message, which is
00118 //      used to update the status of user-interface elements within the MFC
00119 //      framework.
00120 //
00121 //      We have to get a little tricky here: CStatusBar::OnUpdateCmdUI
00122 //      expects a CFrameWnd pointer as its first parameter.  However, it
00123 //      doesn't do anything but pass the parameter on to another function
00124 //      which only requires a CCmdTarget pointer.  We can get a CWnd pointer
00125 //      to the parent window, which is a CCmdTarget, but may not be a
00126 //      CFrameWnd.  So, to make CStatusBar::OnUpdateCmdUI happy, we will call
00127 //      our CWnd pointer a CFrameWnd pointer temporarily.
00128
00129 LRESULT CDlgStatusBar::OnIdleUpdateCmdUI(WPARAM wParam, LPARAM)
00130 {
00131         if (IsWindowVisible())
00132         {
00133                 CFrameWnd *pParent = (CFrameWnd *)GetParent();
00134                 if (pParent)
00135                         OnUpdateCmdUI(pParent, (BOOL)wParam);
00136         }
00137         return 0L;
00138 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Dlgbars.h Source File

DP5Cfg/Dlgbars.h
Go to the documentation of this file.
00001 // DlgBars.h : header file
00002 //
00003
00004 // This is a part of the Microsoft Foundation Classes C++ library.
00005 // Copyright (c) Microsoft Corporation.  All rights reserved.
00006 //
00007 // This source code is only intended as a supplement to the
00008 // Microsoft Foundation Classes Reference and related
00009 // electronic documentation provided with the library.
00010 // See these sources for detailed information regarding the
00011 // Microsoft Foundation Classes product.
00012
00013 /*****************************************************************************
00014
00015   Purpose:
00016         Interface for CDlgToolBar, a special type of CToolBar which does not
00017         expect a parent frame window to be available, and CDlgStatusBar, which
00018         does the same for CStatusBars.  This allows the control bars
00019         to be used in applications where the main window is a dialog bar.
00020
00021   Functions:
00022         CDlgToolBar::CDlgToolBar()          -- constructor
00023         CDlgToolBar::~CDlgToolBar()         -- destructor
00024         CDlgToolBar::OnIdleUpdateCmdUI()    -- WM_IDLEUPDATECMDUI handler
00025
00026         CDlgStatusBar::CDlgStatusBar()      -- constructor
00027         CDlgStatusBar::~CDlgStatusBar()     -- destructor
00028         CDlgStatusBar::OnIdleUpdateCmdUI()  -- WM_IDLEUPDATECMDUI handler
00029
00030   Development Team:
00031         Mary Kirtland
00032   Ported to 32-bit by:
00033         Mike Hedley
00034   Created by Microsoft Product Support Services, Premier ISV Support
00035   Copyright (c) 2000 Microsoft Corporation. All rights reserved.
00036 \****************************************************************************/
00037
00038 #ifndef __DLGBARS_H__
00039 #define __DLGBARS_H__
00040
00041 #pragma once
00042
00043 #include "StdAfx.h"
00044
00045 class CDlgToolBar : public CToolBar
00046 {
00047 // Construction
00048 public:
00049         CDlgToolBar();
00050
00051 // Implementation
00052 public:
00053         virtual ~CDlgToolBar();
00054         void EnableButton(int nId, BOOL bEnable);
00055
00056 protected:
00057         CMap <int,int&,BOOL,BOOL&> tbBtnMap;
00058         // Generated message map functions
00059         //{{AFX_MSG(CDlgToolBar)
00060         afx_msg LRESULT OnIdleUpdateCmdUI(WPARAM wParam, LPARAM);
00061         //}}AFX_MSG
00062         DECLARE_MESSAGE_MAP()
00063 };
00064
00065 class CDlgStatusBar : public CStatusBar
00066 {
00067 // Construction
00068 public:
00069         CDlgStatusBar();
00070
00071 // Implementation
00072 public:
00073         virtual ~CDlgStatusBar();
00074
00075 protected:
00076         // Generated message map functions
00077         //{{AFX_MSG(CDlgStatusBar)
00078         afx_msg LRESULT OnIdleUpdateCmdUI(WPARAM wParam, LPARAM);
00079         //}}AFX_MSG
00080         DECLARE_MESSAGE_MAP()
00081 };
00082
00083 #endif //__DLGBARS_H__
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppComm.cpp Source File

DeviceIO/DppComm.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include "DppComm.h"
00003 #include <assert.h>
00004
00005 CDppComm::CDppComm()
00006 {
00007         PortIDSetting = 0;
00008         PortIsOpen = FALSE;
00009         m_hDppComm = NULL;
00010         m_hWriteEvent = NULL;
00011         ghThreadExitEvent = NULL;
00012         m_szWriteBuffer = NULL;
00013         m_bThreadRunning = FALSE;
00014         osIO.Offset = 0;
00015         osIO.OffsetHigh = 0;
00016         osIO.hEvent = NULL;
00017         ExitEvent = FALSE;
00018 }
00019
00020
00021 // Delete dynamic memory
00022
00023 CDppComm::~CDppComm()
00024 {
00025         if (PortIsOpen) {
00026                 ExitEvent = TRUE;
00027                 do {
00028                         SetEvent(ghThreadExitEvent);
00029                 } while (m_bThreadRunning);
00030
00031                 CloseHandle(ghThreadExitEvent);  // close event handles
00032                 CloseHandle(osIO.hEvent);
00033                 CloseHandle(m_hWriteEvent);
00034                 if (m_hDppComm != NULL)
00035                 {
00036                         CloseHandle(m_hDppComm);
00037                         m_hDppComm = NULL;
00038                 }
00039         }
00040         delete [] m_szWriteBuffer;
00041         PortIsOpen = FALSE;
00042         ExitEvent = FALSE;
00043 }
00044
00045 BOOL CDppComm::Settings(CWnd* hPortWnd, UINT PortID, UINT BaudRate, char Parity, UINT DataBits,
00046                                                    UINT StopBits, DWORD dwCommEvents, UINT WriteBuffSize)
00047 {
00048
00049         if (m_bThreadRunning)
00050         {
00051                 ExitEvent = TRUE;
00052                 do
00053                 {
00054                         SetEvent(ghThreadExitEvent);
00055                 } while (m_bThreadRunning);
00056         }
00057         ExitEvent = FALSE;
00058
00059         // create events
00060         if (osIO.hEvent != NULL)
00061                 ResetEvent(osIO.hEvent);
00062         osIO.hEvent = CreateEvent(NULL, TRUE, FALSE, NULL);
00063
00064         if (m_hWriteEvent != NULL)
00065                 ResetEvent(m_hWriteEvent);
00066         m_hWriteEvent = CreateEvent(NULL, TRUE, FALSE, NULL);
00067
00068         if (ghThreadExitEvent != NULL)
00069                 ResetEvent(ghThreadExitEvent);
00070         ghThreadExitEvent = CreateEvent(NULL, TRUE, FALSE, NULL);
00071
00072         // initialize the event objects
00073         m_hEvents[0] = ghThreadExitEvent;       // highest priority
00074         m_hEvents[1] = osIO.hEvent;
00075         m_hEvents[2] = m_hWriteEvent;
00076
00077         // initialize critical section
00078         InitializeCriticalSection(&m_csCommunicationSync);
00079
00080         // set buffersize for writing and save the owner
00081         m_pOwner = hPortWnd;
00082
00083         if (m_szWriteBuffer != NULL)
00084                 delete [] m_szWriteBuffer;
00085         m_szWriteBuffer = new unsigned char[WriteBuffSize];
00086
00087         m_nWriteBufferSize = WriteBuffSize;
00088         m_dwCommEvents = dwCommEvents;
00089
00090         BOOL bResult = FALSE;
00091         char *szComPort = new char[50];
00092         char *szSettings = new char[50];
00093
00094         EnterCriticalSection(&m_csCommunicationSync);
00095         if (m_hDppComm != NULL)
00096         {
00097                 CloseHandle(m_hDppComm);
00098                 m_hDppComm = NULL;
00099         }
00100         sprintf(szComPort, "\\\\.\\COM%d", PortID);
00101         sprintf(szSettings, "baud=%d parity=%c data=%d stop=%d", BaudRate, Parity, DataBits, StopBits);
00102         m_hDppComm = CreateFile(szComPort,GENERIC_READ | GENERIC_WRITE,0,NULL,OPEN_EXISTING,FILE_FLAG_OVERLAPPED,0);
00103         if (m_hDppComm == INVALID_HANDLE_VALUE) {
00104                 delete [] szComPort;
00105                 delete [] szSettings;
00106                 PortIDSetting = 0;
00107                 return FALSE;
00108         } else {
00109                 PortIDSetting = PortID;
00110         }
00111         m_CommTimeouts.ReadIntervalTimeout = 1000;
00112         m_CommTimeouts.ReadTotalTimeoutMultiplier = 1000;
00113         m_CommTimeouts.ReadTotalTimeoutConstant = 1000;
00114         m_CommTimeouts.WriteTotalTimeoutMultiplier = 1000;
00115         m_CommTimeouts.WriteTotalTimeoutConstant = 1000;
00116         if (SetCommTimeouts(m_hDppComm, &m_CommTimeouts)) {
00117                 if (SetCommMask(m_hDppComm, dwCommEvents)) {
00118                         if (GetCommState(m_hDppComm, &m_dcb)) {
00119                                 m_dcb.fRtsControl = RTS_CONTROL_ENABLE;         // set RTS bit high!
00120                                 if (BuildCommDCB(szSettings, &m_dcb)) {
00121                                         if (SetCommState(m_hDppComm, &m_dcb)) {
00122                                                 // running
00123                                         } else {
00124                                                 GetCommErrStr("SetCommState()");
00125                                         }
00126                                 } else {
00127                                         GetCommErrStr("BuildCommDCB()");
00128                                 }
00129                         } else {
00130                                 GetCommErrStr("GetCommState()");
00131                         }
00132                 } else {
00133                         GetCommErrStr("SetCommMask()");
00134                 }
00135         } else {
00136                 GetCommErrStr("SetCommTimeouts()");
00137         }
00138         delete [] szComPort;
00139         delete [] szSettings;
00140         PurgeComm(m_hDppComm, PURGE_RXCLEAR | PURGE_TXCLEAR | PURGE_RXABORT | PURGE_TXABORT);
00141         LeaveCriticalSection(&m_csCommunicationSync);
00142         return TRUE;
00143 }
00144
00145 UINT CDppComm::DppCommThread(LPVOID pParam)
00146 {
00147         CDppComm *port = (CDppComm*)pParam;
00148         port->m_bThreadRunning = TRUE;
00149         DWORD BytesTransfered = 0;
00150         DWORD Event = 0;
00151         DWORD CommEvent = 0;
00152         DWORD dwError = 0;
00153         COMSTAT comStat;
00154         BOOL  bResult = TRUE;
00155         comStat.cbInQue = 0;
00156         comStat.cbOutQue = 0;
00157         if (port->m_hDppComm){
00158                 PurgeComm(port->m_hDppComm, PURGE_RXCLEAR | PURGE_TXCLEAR | PURGE_RXABORT | PURGE_TXABORT);
00159         }
00160         for (;;)
00161         {
00162                 //if (ExitEvent) TRACE("CDppComm::DppCommThread WaitCommEvent\n");
00163                 bResult = WaitCommEvent(port->m_hDppComm, &Event, &port->osIO);
00164                 if (!bResult) {
00165                         switch (dwError = GetLastError()) {
00166                                 case ERROR_IO_PENDING:
00167                                 {
00168                                         break;
00169                                 }
00170                                 case ERROR_INVALID_PARAMETER:
00171                                 {
00172                                         break;
00173                                 }
00174                                 default:
00175                                 {
00176                                         port->GetCommErrStr("WaitCommEvent()");
00177                                         break;
00178                                 }
00179                         }
00180                 } else {
00181                         bResult = ClearCommError(port->m_hDppComm, &dwError, &comStat);
00182                         if (comStat.cbInQue == 0) continue;
00183                 }
00184                 //if (ExitEvent) TRACE("CDppComm::DppCommThread WaitForMultipleObjects\n");
00185                 Event = WaitForMultipleObjects(3, port->m_hEvents, FALSE, INFINITE);
00186                 //if (ExitEvent) TRACE("CDppComm::DppCommThread Event %d\n",Event);
00187                 switch (Event) {
00188                         case EV_THREAD_EXIT_EVENT:                      // exit thread
00189                         {
00190                                 if (port->m_hDppComm){
00191                                         PurgeComm(port->m_hDppComm, PURGE_RXCLEAR | PURGE_TXCLEAR | PURGE_RXABORT | PURGE_TXABORT);
00192                                         SetCommMask(port->m_hDppComm, 0);
00193                                 }
00194                                 port->m_bThreadRunning = FALSE;
00195                                 AfxEndThread(100);
00196                                 break;
00197                         }
00198                         case EV_READ_STATUS_EVENT:                      // read byte data
00199                         {
00200                                 GetCommMask(port->m_hDppComm, &CommEvent);
00201                                 if (CommEvent & EV_RXCHAR) {
00202                                         ReceiveByte(port, comStat);
00203                                 }
00204                                 break;
00205                         }
00206                         case EV_WRITE_DATA_EVENT:                       //write byte data
00207                         {
00208                                 WriteByte(port);
00209                                 break;
00210                         }
00211                 }
00212                 //if (ExitEvent) TRACE("CDppComm::DppCommThread Next\n");
00213         }
00217         return 0;
00218 }
00219
00220 BOOL CDppComm::OpenPort()
00221 {
00222         if (!(m_WinThread = AfxBeginThread(DppCommThread, this))) {
00223                 PortIsOpen = FALSE;
00224                 return FALSE;
00225         } else {
00226                 PortIsOpen = TRUE;
00227                 return TRUE;
00228         }
00229 }
00230
00231 BOOL CDppComm::ClosePort()
00232 {
00233         UINT64 SetCount;
00234         SetCount=0;
00235         //TRACE("CDppComm::ClosePort\n");
00236         ExitEvent = TRUE;
00237         do {
00238                 SetEvent(ghThreadExitEvent);
00239                 SetCount++;
00240                 //TRACE("SetEvent(ghThreadExitEvent) %d\n",SetCount);
00241                 if ((SetCount == 12) || (SetCount == 100)) {
00242                         if (m_bThreadRunning) m_WinThread->PumpMessage();
00243                         //TRACE("CDppComm::ClosePort PumpMessage\n");
00244                 }
00245         } while (m_bThreadRunning);
00246     CloseHandle(ghThreadExitEvent);      // close event handles
00247     CloseHandle(osIO.hEvent);
00248     CloseHandle(m_hWriteEvent);
00249         if (m_hDppComm != NULL)
00250         {
00251                 CloseHandle(m_hDppComm);
00252                 m_hDppComm = NULL;
00253         }
00254         PortIsOpen = FALSE;
00255         ExitEvent = FALSE;
00256         return TRUE;
00257 }
00258
00259 void CDppComm::GetCommErrStr(char* ErrorText)
00260 {
00261         char *Temp = new char[200];
00262         LPVOID lpMsgBuf;
00263
00264         //if (ExitEvent) TRACE("CDppComm::GetCommErrStr\n");
00265
00266         FormatMessage(
00267                 FORMAT_MESSAGE_ALLOCATE_BUFFER | FORMAT_MESSAGE_FROM_SYSTEM,
00268                 NULL,
00269                 GetLastError(),
00270                 MAKELANGID(LANG_NEUTRAL, SUBLANG_DEFAULT), // Default language
00271                 (LPTSTR) &lpMsgBuf,
00272                 0,
00273                 NULL
00274         );
00275         sprintf(Temp, "DppComm %s Error: \n%s\n", (char*)ErrorText, lpMsgBuf);
00276         MessageBox(NULL, Temp, "DppComm Error", MB_ICONSTOP);
00277         LocalFree(lpMsgBuf);
00278         delete[] Temp;
00279 }
00280
00281 void CDppComm::WriteByte(CDppComm* port)
00282 {
00283         BOOL bWrite = TRUE;
00284         BOOL bResult = TRUE;
00285         DWORD BytesSent = 0;
00286
00287         //if (ExitEvent) TRACE("CDppComm::WriteByte\n");
00288
00289         ResetEvent(port->m_hWriteEvent);
00290
00291         if (ExitEvent) {        // quit if exiting thread
00292                 return;
00293         }
00294         EnterCriticalSection(&port->m_csCommunicationSync);
00295         if (bWrite)
00296         {
00297                 port->osIO.Offset = 0;
00298                 port->osIO.OffsetHigh = 0;
00299                 PurgeComm(port->m_hDppComm, PURGE_RXCLEAR | PURGE_TXCLEAR | PURGE_RXABORT | PURGE_TXABORT);
00300                 bResult = WriteFile(port->m_hDppComm,port->m_szWriteBuffer,(DWORD)m_SendBytes,&BytesSent,&port->osIO);
00301                 if (!bResult) {
00302                         DWORD dwError = GetLastError();
00303                         switch (dwError) {
00304                                 case ERROR_IO_PENDING:
00305                                 {
00306                                         BytesSent = 0;
00307                                         bWrite = FALSE;
00308                                         break;
00309                                 }
00310                                 default:
00311                                 {
00312                                         port->GetCommErrStr("WriteFile()");
00313                                 }
00314                         }
00315                 } else {
00316                         LeaveCriticalSection(&port->m_csCommunicationSync);
00317                 }
00318         }
00319         if (!bWrite) {
00320                 bWrite = TRUE;
00321                 bResult = GetOverlappedResult(port->m_hDppComm,&port->osIO,&BytesSent,TRUE);
00322                 LeaveCriticalSection(&port->m_csCommunicationSync);
00323                 if (!bResult) {
00324                         port->GetCommErrStr("GetOverlappedResults() in WriteFile()");
00325                 }
00326         }
00327         if (BytesSent != m_SendBytes)
00328         {
00329                 //AfxMessageBox("DppComm WriteByte Bytes Sent != Buffer Length %d != %d\n", BytesSent, m_SendBytes);
00330         }
00331 }
00332
00333 void CDppComm::ReceiveByte(CDppComm* port, COMSTAT comStat)
00334 {
00335         BOOL  bRead = TRUE;
00336         BOOL  bResult = TRUE;
00337         DWORD dwError = 0;
00338         DWORD BytesRead = 0;
00339         unsigned char RXBuff;
00340
00341         //if (ExitEvent) TRACE("CDppComm::ReceiveByte\n");
00342
00343         if (ExitEvent) {        // quit if exiting thread
00344                 return;
00345         }
00346
00347         for (;;) {
00348                 if (ExitEvent) {        // quit if exiting thread
00349                         break;
00350                 }
00351                 EnterCriticalSection(&port->m_csCommunicationSync);
00352                 bResult = ClearCommError(port->m_hDppComm, &dwError, &comStat);
00353                 LeaveCriticalSection(&port->m_csCommunicationSync);
00354                 if (comStat.cbInQue == 0) {     // que empty
00355                         break;
00356                 }
00357                 EnterCriticalSection(&port->m_csCommunicationSync);
00358                 if (bRead) {
00359                         bResult = ReadFile(port->m_hDppComm,&RXBuff,1,&BytesRead,&port->osIO);
00360                         if (!bResult) {         // error
00361                                 switch (dwError = GetLastError()) {
00362                                         case ERROR_IO_PENDING:
00363                                         {
00364                                                 bRead = FALSE;
00365                                                 break;
00366                                         }
00367                                         default:
00368                                         {
00369                                                 port->GetCommErrStr("ReadFile()");
00370                                                 break;
00371                                         }
00372                                 }
00373                         }
00374                         else
00375                         {
00376                                 bRead = TRUE;
00377                         }
00378                 }
00379                 if (!bRead) {
00380                         bRead = TRUE;
00381                         bResult = GetOverlappedResult(port->m_hDppComm,&port->osIO,&BytesRead,TRUE);
00382                         if (!bResult) {         // error
00383                                 port->GetCommErrStr("GetOverlappedResults() in ReadFile()");
00384                         }
00385                 }
00386                 LeaveCriticalSection(&port->m_csCommunicationSync);
00387                 if (ExitEvent) {        // quit if exiting thread
00388                         break;
00389                 }
00390                 ::SendMessage((port->m_pOwner)->m_hWnd, WM_DPPCOMM_RCV_CHAR, (WPARAM) RXBuff, (LPARAM) BytesRead);      // rcv byte
00391                 if (ExitEvent) {        // quit if exiting thread
00392                         break;
00393                 }
00394         }
00395 }
00396
00397 void CDppComm::WriteData(unsigned char* string, size_t NumBytes) {
00398         //if (ExitEvent) TRACE("CDppComm::WriteData\n");
00399         if (ExitEvent) {        // quit if exiting thread
00400                 return;
00401         }
00402         assert(m_hDppComm != 0);
00403         m_SendBytes = NumBytes;
00404         memset(m_szWriteBuffer, 0, m_SendBytes);
00405         for (size_t i=0; i<m_SendBytes; i++) m_szWriteBuffer[i]=string[i];
00406         SetEvent(m_hWriteEvent);
00407 }
00408
00409 UINT CDppComm::GetComPortID()
00410 {
00411         return PortIDSetting;
00412 }
00413
00414 BOOL CDppComm::IsPortOpen()
00415 {
00416         return PortIsOpen;
00417 }
00418
00419 bool CDppComm::SendPacketRS232(unsigned char Buffer[], CDppComm *CommPort)
00420 {
00421     long PLen;
00422     PLen = (Buffer[4] * 256) + Buffer[5] + 8;
00423         CommPort->WriteData(Buffer, PLen);
00424         return true;
00425 }
00426
00427
00428
00429
00430
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppComm.h Source File

DeviceIO/DppComm.h
Go to the documentation of this file.
00001 #ifndef __DppComm_H__INCLUDED_
00002 #define __DppComm_H__INCLUDED_
00003 #define WM_DPPCOMM_RCV_CHAR (WM_USER + 400)
00004 #define EV_THREAD_EXIT_EVENT 0
00005 #define EV_READ_STATUS_EVENT 1
00006 #define EV_WRITE_DATA_EVENT 2
00007
00008 static size_t m_SendBytes;
00009 static BOOL ExitEvent;
00010
00011 class CDppComm
00012 {
00013 public:
00014         CDppComm();
00015         virtual ~CDppComm();
00016         BOOL Settings(CWnd* hPortWnd, UINT PortID = 1, UINT BaudRate = 115200, char Parity = 'N', UINT DataBits = 8, UINT StopBits = 1, DWORD dwCommEvents = EV_RXCHAR, UINT nBufferSize = 1024);
00017         BOOL OpenPort();
00018         BOOL ClosePort();
00019         BOOL IsPortOpen();
00020         UINT GetComPortID();
00021         void WriteData(unsigned char* string, size_t NumBytes);
00022         bool SendPacketRS232(unsigned char Buffer[], CDppComm *CommPort);
00023
00024 protected:
00025         void GetCommErrStr(char* ErrorText);
00026         static UINT     DppCommThread(LPVOID pParam);
00027         static void     ReceiveByte(CDppComm* port, COMSTAT comStat);
00028         static void     WriteByte(CDppComm* port);
00029         CWinThread* m_WinThread;
00030         CRITICAL_SECTION m_csCommunicationSync;
00031         BOOL m_bThreadRunning;
00032         HANDLE ghThreadExitEvent;
00033         HANDLE m_hDppComm;
00034         HANDLE m_hWriteEvent;
00035         HANDLE m_hEvents[3];
00036         OVERLAPPED osIO;                        // overlapped structure for asynchronous IO
00037         COMMTIMEOUTS m_CommTimeouts;
00038         DCB m_dcb;
00039         CWnd* m_pOwner;
00040         unsigned char* m_szWriteBuffer;
00041         DWORD m_dwCommEvents;
00042         DWORD m_nWriteBufferSize;
00043         UINT PortIDSetting;
00044         BOOL PortIsOpen;
00045
00046 };
00047
00048 #endif __DppComm_H__INCLUDED_
00049
00050
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppConfig.cpp Source File

Config/DppConfig.cpp
Go to the documentation of this file.
00001 // CDppConfig.cpp : Defines the DPP Configuration Storage class.
00002 //
00003
00004 #include "stdafx.h"
00005 #include "DppConfig.h"
00006 #include <math.h>
00007
00008 #ifdef _DEBUG
00009 #define new DEBUG_NEW
00010 #endif
00011
00012 //@doc CDppConfig
00013
00014 CDppConfig::CDppConfig(void)
00015 {
00016         GainDelta = 1.0;
00017         strGainDisplayValue = "";
00018         isCfgChanged = false;
00019         isDeltaMode = false;
00020         PresetCountExpired = false;
00021         NavPanelUpdate = false;
00022         // HVRangeInd = 0;
00023         HVRangeInd = 1;  // HVRangeInd not longer used, always set to 1500v 20050606
00024         ScopeTriggerFalling = false;
00025         ScopeTriggerPosition = 2;
00026         MCSEnable = 1;
00027         isDPP5 = false;                                         // DPP5 20070926 initialize dpp5 indicator flag
00028         bGammaRadHVMode = false;
00029         b80MHzMode = false;
00030         b80MHzModeCfg = false;
00031         bConfigHVPolarity = true;
00032         bPC5Detected = false;
00033         bBootHVPolarity = false;
00034         DisplayCfg = FALSE;
00035         CfgReadBack = FALSE;
00036
00037         DisplaySca = FALSE;
00038         ScaReadBack = FALSE;
00039
00040         SaveCfg = FALSE;
00041         PrintCfg = FALSE;
00042
00043         // DP5 oscilloscope support
00044         strAnalogOut = "";
00045
00046         strInputOffset = "";
00047         strOutputOffset = "";
00048         strScopeGain = "";
00049
00050         strTriggerSource = "";
00051         strTriggerPosition = "";
00052         strTriggerSlope = "";
00053
00054         UpdateScopeCfg = FALSE;
00055
00056         isPresetAcq = FALSE;
00057
00058
00059 }
00060
00061 CDppConfig::~CDppConfig(void)
00062 {
00063 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppConfig.h Source File

Config/DppConfig.h
Go to the documentation of this file.
00001 // CDppConfig.h : header file
00002 //
00003 //--------------------------------------------------------------------------------------
00004 //@doc CDppConfig
00005 //
00006 //@module DppConfig.h | DPP (DP4, PX4) Device Configuration Functions
00007 //
00008 //This class has software functionality for DPP (DP4, PX4) Device
00009 //Configuration management. The CDppConfig Class is the main repository
00010 //for DPP device configuration data. The CDppConfig Class can store and copy
00011 //a DPP device configuration. The current DPP device configuration can
00012 //also be saved to a string for display.
00013 //
00014 //The CDppConfig Class does processing of configuration data
00015 //for transmission to a DPP device. The processed configuration buffer can be
00016 //transmitted to the DPP by serial communications port or by USB.
00017 //
00018 //The CDppConfig Class also stores and processes status messages and
00019 //live spectral data requested from a DPP device.
00020 //
00021 // Copyright (c)2004 Amptek, All Rights Reserved
00022 //
00023 //@devnote
00024 //
00025 //@devnote Version: 20040709_0927
00026 //
00027 //@head3 CDppConfig Members |
00028 //@index | CDppConfig
00029 //
00030 //--------------------------------------------------------------------------------------
00031
00032 #pragma once
00033
00034 #define COUNT_OFFSET 1  // new dp4/px4 with fix
00035 //#define USB_DATA_SIZE (24576 + COUNT_OFFSET)
00036 #define USB_BUFFER_SIZE (64 + COUNT_OFFSET)
00037 #define USB_SCOPE_SIZE 2048
00038 #define USB_CFG_IN_SIZE (512 + COUNT_OFFSET)
00039
00040 const int DP5_TO_PX4_CONTROL_INDEX[16] = {26,27,0,1,2,4,5,6,7,8,9,11,12,14,15,17};
00041
00042 //@class DPP (DP4, PX4) Device Configuration Functions
00043 class CDppConfig
00044 {
00045
00046 private:
00047         //---SetDPPConfigBuffer Buffer------------------------------------------------------
00048         unsigned char Config[USB_BUFFER_SIZE];                  //@cmember config data buffer
00049
00050         //---gen config vars----------------------------------------------------------------
00051         long MCAData[8192];                     //@cmember holds the live spectra data
00052         unsigned char MCARaw[24576];            //@cmember holds pre-processed spectra data
00053
00054
00055 public:
00056         CDppConfig(void);                       //@cmember constructor
00057         ~CDppConfig(void);                      //@cmember destructor
00058         bool isCfgChanged;                      //@cmember indicates the data in this class has been changed
00059         BOOL DisplayCfg;
00060         BOOL CfgReadBack;
00061
00062         BOOL DisplaySca;
00063         BOOL ScaReadBack;
00064
00065         BOOL SaveCfg;
00066         BOOL PrintCfg;
00067         int Port;                                       //@cmember current com port, -1=none,0=usb,1=com1,2=com2,...
00068
00069         //---Process Status Vars------------------------------------------------------------------
00070         //long SlowCount;                       //@cmember slow channel count (from status)
00071         //long FastCount;                       //@cmember fast channel count (from status)
00072         double SlowCount;                       //@cmember slow channel count (from status)
00073         double GPCount;                     //@cmember slow channel count (from status)
00074         double FastCount;                       //@cmember fast channel count (from status)
00075         double AccumulationTime;        //@cmember real time duration of present data acquisition interval
00076         double RealTime;        //@cmember real time duration of present data acquisition interval
00077         double LiveTime;                        //@cmember live time
00078
00079         //---ConfigureDPP Vars--------------------------------------------------------------------
00080         unsigned char Firmware;                         //@cmember firmware revision
00081         unsigned char Build;
00082         bool isDPP5;                            //@cmember DPP5 indicator               // DPP5 20070926
00083
00084         //long SerialNumber;            //@cmember unit serial number
00085         unsigned long SerialNumber;                     //@cmember unit serial number
00086         long Preset;                            //@cmember var holds preset time, used in usb
00087         double PresetRt;                                //@cmember var holds preset time, used in usb
00088         double PresetLt;                                //@cmember var holds preset time, used in usb
00089         double PresetAcq;                               //@cmember var holds preset time, used in usb
00090         CString strPresetCmd;
00091         CString strPresetVal;
00092
00093
00094         //---SetDPPConfigBuffer Vars-----------------------------------------------------------------------
00095         int Avg;                                        //@cmember holds decimation setting for pulse shaping
00096         int FlatTop;                            //@cmember flatop register setting
00097         double FlatTopUS;
00098         unsigned char DetReset;                         //@cmember detector reset lockout period
00099         unsigned char SlowChThreshold;          //@cmember Slow ch threshold, Events w/amp lower not added to spectrum
00100         double SlowThresholdPct;
00101         unsigned char FastChThreshold;          //@cmember Fast Ch Threshold, events w/fch amp below this are rejected
00102         long Offset;                            //@cmember Output DAC offset, -64…+63,(signed) (-500mV to +492mV)
00103         unsigned char DAC_Enable;                       //@cmember dac enabled
00104         int DAC;                                        //@cmember DAC output type,(stobed peak,shaped pulse,dec inp,fast ch)
00105         int MCA;                                        //@cmember number of channels 4=256,3=512,2=1024,1=2048,0=4096,5=8192
00106         long mcaCH;                                     //@cmember actual number of channels 0,256,512,1024,2048,4096,8192
00107         BOOL MCAEnable;                         //@cmember mca enabled setting
00108         BOOL PUREnable;                         //@cmember pile-up rejection enabled
00109         int Rise;                                       //@cmember risetime register setting
00110         double RiseUS;
00111         BOOL BaselineOn;                        //@cmember use autobaseline during detector reset
00112         unsigned char RTDSlow;                          //@cmember Risetime Discrimination slow threshold
00113         int Gain;                                       //@cmember analog gain setting (0=10,1=20,2=50,3=100)
00114         unsigned char RTDOn;                            //@cmember Turns RTD on, and sets the amplitude and timing thresholds
00115         unsigned char RTDFast;                          //@cmember RTD Time Threshold,Events w/HWHM wider than this are rejected
00116         unsigned char BLR;                                      //@cmember Baseline Restoration, see udBLR.Value notes for values
00117         unsigned char FPGA;                                     //@cmember fpga revision
00118         unsigned char Gate;                                     //@cmember gate input settings, determines events included/excluded from spectrum, see DPPGate
00119         unsigned char BufferSelect;                     //@cmember Holds Buffer Sel A&B,Buffer Sel Hardware,see DPPBufferSelect
00120         unsigned char AcqMode;                          //@cmember acquisition mode 0=MCA,1=MCS
00121         unsigned char MCSEnable;                        //@cmember MCS Enable (Always ON, Gate Signal-if low prevents counts to current mcs channel)
00122         unsigned char MCSTimebase;                      //@cmember MCS timebase value (0-15) see CAcqMode
00123         BOOL MCSDone;                           //@cmember MCS done flag 1=finished, 0=not finished
00124         BOOL PresetRtDone;
00125         BOOL PresetLtDone;
00126         BOOL isPresetAcq;                       // need to test if MCAEnabled==FALSE is Preset Acq Expired
00127         // NOTE: current mcs processing channel stored in slow counts
00128         //Status packet offset 28, bit 6 is the 'MCS Done' flag. 1=finished, 0=not finished.
00129         //(D7 of this byte is the 'Auto Input Offset Searching/locked' flag.)
00130
00131         //---PX4 Vars-----------------------------------------------------------------------------
00132         // power prop page vars
00133         bool TECEnabled;                        //@cmember Enable TEC
00134         long TEC;                                       //@cmember TEC temperature setting (displayed in Kelvin)
00135         double TECMonitor;                      //@cmember TEC temperature monitor value
00136         CString TECMonitorCStr;         //@cmember TEC temperature monitor display CString
00137         BOOL HVEnabled;                         //@cmember high voltage setting enable
00138         long HV;                                        //@cmember high voltage setting value
00139         double HVMonitor;                       //@cmember high voltage monitor value
00140         CString HVMonitorCStr;          //@cmember high voltage monitor display CString
00141         BOOL XR100;                                     //@cmember XR100 control value (obsolete)
00142         BOOL SEL8_5V;                           //@cmember preamp power select value (5v or 8.5v)
00143
00144         // gainpz prop page vars -----------------------------------------------------
00145         long PoleZero;                          //@cmember pole zero adjust value
00146         long PX4InputOffset;            //@cmember input offset
00147
00148         //long PX4CoarseGain;
00149         long PX4FineGain;                       //@cmember fine gain
00150         BOOL InvertEn;                          //@cmember use InvertEnable during detector reset
00151
00152         // misc prop page vars ---------------------------------------------------------
00153         BOOL IndLED;                            //@cmember *changed to audio1 volume setting
00154         BOOL IndBuzzer;                         //@cmember *changed to audio0 volume setting
00155         BOOL PwrCtrl9V;                         //@cmember 9V power enable, always set to ON
00156         BOOL PwrCtrl5VA;                        //@cmember 5VA power enable, no longer used, always set to false
00157         int AuxOut;                                     //@cmember Aux output type
00158         unsigned long PresetCount;      //@cmember preset count in selected channels, ch are set in SCA8
00159         unsigned long SCA[8];           //@cmember SCA values, LL, UL, and Enable are stored together
00160
00161         int BoardTemp;                          //@cmember board temperature monitor value
00162         CString BoardTempCStr;          //@cmember board temperature monitor display CString
00163         unsigned char BootStatus;                       //@cmember boot status byte (PwrBtnConfig,SwConfigRcvd,McaEnabled)
00164         bool PwrBtnConfig;                      //@cmember dpp has loaded config from power button
00165         BOOL SwConfigRcvd;                      //@cmember software has sent valid config to unit since startup
00166         BOOL StatMcaEnabled;            //@cmember mca en, high during acq, preset time resets flag
00167
00168         int DeviceType;                         //@cmember device type 0=mca8ka,1=dp4,2=px4,3=DP5(DP4 emul),4=DP5 (PX4 Emulation)
00169         bool isDeltaMode;                       //@cmember false=MCA mode, true=Delta mode
00170
00171         double GainDelta;                       //@cmember increment/decrement value for px4 toolbar/menu gain change function
00172         double PX4Gain;                         //@cmember stores current gain value for px4 toolbar/menu gain change function
00173         CString strGainDisplayValue;    //@cmember stores display CString for px4 toolbar/menu gain change function
00174
00175         // added to px4 --------------------------------------------------------------
00176         int HVRangeInd;                                 //@cmember HV range indicator from status block (0=750V,1=1500V)
00177         int StatDevInd;                                 //@cmember device indicator from status block (0=dp4,1=px4)
00178         BOOL PresetCountExpired;                //@cmember indicates presets counts have been reached
00179         bool NavPanelUpdate;                    //@cmember indicates NavPanel Needs update
00180         bool HwCfgFromDLG;                              //@cmember hardware configuration from dialog settings
00181
00182         CString strPercentDeadTime;             //@cmember holds Percent Dead Time display value for info panel
00183         CString StartTime;                              //@cmember px4 data acquisition start time in CString format
00184         int USBDataRefreshRate;                 //@cmember usb data read timer interval
00185
00186         // refresh flags for dialog boxes, eliminates unwanted overwrites due to new data refreshes
00187         bool RefreshDppGeneral;                                                                 //@cmember refresh general property page
00188         bool RefreshDppMCA;                                                                         //@cmember refresh MCA property page
00189         bool RefreshDppShaping;                                                                 //@cmember refresh shaping property page
00190         bool RefreshDppPower;                                                                   //@cmember refresh power property page
00191         bool RefreshDppGainPZ;                                                                  //@cmember refresh gainpz property page
00192         bool RefreshDppMisc;                                                                    //@cmember refresh misc property page
00193         bool RefreshDppTest;                                                                    //@cmember refresh dpptest property page
00194
00195         double DCal;  //DCal
00196
00197         bool ScopeTriggerFalling;                       //@cmember scope trigger
00198         int ScopeTriggerPosition;                       //@cmember scope position
00199         //unsigned char Scope[512];                                     //@cmember scope display
00200         unsigned char Scope[USB_SCOPE_SIZE];            //@cmember scope display
00201         BOOL UpdateScopeCfg;                            //@cmember scope indicates scope cfg needs update
00202
00203         BOOL LoadRestartInProgress;                     //@cmember the config dialog is restart with a cfg dlg loaded config
00204         CString LoadRestartStatus;                      //@cmember the config dialog restart status message
00205         BOOL LoadRestartInputOffset;            //@cmember the config dialog is restart with a cfg dlg loaded config
00206         BOOL LoadRestartInputOffsetSlow;        //@cmember the config dialog is restart with a cfg dlg loaded config
00207         BOOL LoadRestartFastThresh;                     //@cmember the config dialog is restart with a cfg dlg loaded config
00208         BOOL LoadRestartSlowThresh;                     //@cmember the config dialog is restart with a cfg dlg loaded config
00209         BOOL SetFastThreshDone;                         //@cmember DPP tune fast thresh has successfully done
00210         BOOL SetInputOffsetDone;                        //@cmember DPP tune input offset has successfully done
00211
00212         long ProcessUSBData();
00213
00214         int CfgModCount;                                                                        // configuration modified count for CPropertySheet
00215         CString GetDeviceNameFromVal(int DeviceTypeVal);        // DPP5 20071018
00216         double UCHARVersionToDouble(unsigned char Version);                     // DPP5 20071015
00217
00218         //Status packet BootBlock                       //DPP5 20071105
00219         double bb_DeadTimeCounter;                      //0x2F-0x2C deadtime counter 50nS/count
00220         USHORT bb_DiodeCalDACSet;                       //0x30-31 Diode Cal DAC setting
00221         USHORT bb_TECCurrentLimit;                      //0x32-33 TEC current limit DAC setting (not used in DP5)
00222         USHORT bb_BootFlags;                            //0x34-35 Boot flags (MSB currently unused)
00223         USHORT bb_HVDACSet;                                     //0x36-37 HV DAC setting (not used in PX4 mode)
00224         USHORT bb_TECDACSet;                            //0x38-39 TEC DAC setting (not used in PX4 mode)
00225         USHORT bb_InputOffsetTuning;            //0x3A-3B Input offset DAC setting (not used in PX4 mode) (not currently used - testing to see if constant value works)
00226         USHORT bb_uCTempCal;                            //0x3C-3D uC temp cal, or something like that (not used yet)
00227         USHORT bb_SpectrumOffset;                       //0x3E-3F Spectrum offset (not used yet, added a boot flag bit (D1) to indicate whether to use this)
00228         BOOL NeedsDP5ReBoot;
00229         BOOL b80MHzMode;
00230         BOOL b80MHzModeCfg;
00231         BOOL bFPGAAutoClock;
00232
00233         // configuration indicator support
00234         BOOL bGammaRadHVMode;           // GammaRad HV
00235         BOOL bConfigHVPolarity;         // Detector HV Polarity, for setup warnings
00236         double dblConfigHV;             // Detector HV, for test dialog data
00237         BOOL bPC5Detected;                      // PC5 connected,PX5 HV Pwr Error
00238         BOOL bBootHVPolarity;           // HV Polarity from status packet
00239         BOOL bAnalogPolarity;           // Analog Input Polarity, for setup warnings
00240
00241         // DP5 oscilloscope support
00242         CString strAnalogOut;
00243
00244         CString strInputOffset;
00245         CString strOutputOffset;
00246         CString strScopeGain;
00247
00248         CString strTriggerSource;
00249         CString strTriggerPosition;
00250         CString strTriggerSlope;
00251
00252         CString strMcaMode;
00253
00254
00255 };
00256
00257
00258
00259
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppConst.h Source File

DeviceIO/DppConst.h
Go to the documentation of this file.
00001
00002 #pragma once
00003
00004 typedef enum DP5_DPP_TYPES
00005 {
00007         dppDP5,
00009         dppPX5,
00011         dppDP5G,
00013         dppMCA8000D,
00015         dppTB5,
00017         dppDP5X
00018 } dp5DppTypes;
00019
00020 #define DP5_DPP_TYPES_FIRST dppDP5
00021 #define DP5_DPP_TYPES_LAST dppDP5X
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DppGain.cpp Source File

DP5Cfg/DppGain.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "DppGain.h"
00003 // DP5/PX5/DP5G Analog Gain
00004
00005 CDppGain::CDppGain(void)
00006 {
00007         GainTable = dagtDP5;
00008 }
00009
00010 CDppGain::~CDppGain(void)
00011 {
00012         //
00013 }
00014
00015 int CDppGain::GetGainCount(DppAGainTable GainTable)
00016 {
00017         int GainCount = 0;
00018         if (GainTable == dagtDP5) {
00019                 GainCount = DP5_GAIN_COUNT;
00020         } else if (GainTable == dagtPX5) {
00021                 GainCount = PX5_GAIN_COUNT;
00022         } else if (GainTable == dagtDP5G) {
00023                 GainCount = DP5G_GAIN_COUNT;
00024         } else if (GainTable == dagtMCA8000D) {
00025                 GainCount = MCA8000D_GAIN_COUNT;
00026         } else if (GainTable == dagtTB5) {
00027                 GainCount = DP5G_GAIN_COUNT;
00028         } else if (GainTable == dagtDP5Dx) {
00029                 GainCount = DP5_DX_GAIN_COUNT;
00030         } else if (GainTable == dagtDP5X) {
00031                 GainCount = DP5X_GAIN_COUNT;
00032         }
00033         return GainCount;
00034 }
00035
00036 CString CDppGain::GetTotalGainLimitsLabel(DppAGainTable GainTable)
00037 {
00038         CString GainLabel("");
00039         if (GainTable == dagtDP5) {
00040                 GainLabel = "0.75 to 150";
00041         } else if (GainTable == dagtPX5) {
00042                 GainLabel = "0.75 to 500";
00043         } else if (GainTable == dagtDP5G) {
00044                 GainLabel = "1.0 to 10.0";
00045         } else if (GainTable == dagtMCA8000D) {
00046                 GainLabel = "1x OR 10x";
00047         } else if (GainTable == dagtTB5) {
00048                 GainLabel = "1.0 to 10.0";
00049         } else if (GainTable == dagtDP5Dx) {
00050                 GainLabel = "0.75 to 250";
00051         } else if (GainTable == dagtDP5X) {
00052                 GainLabel = "3.00 to 150";
00053         }
00054         return GainLabel;
00055 }
00056
00057 double CDppGain::GetTotalGainLimitsMin(DppAGainTable GainTable)
00058 {
00059         double GainMin = 0.75;
00060         if (GainTable == dagtDP5) {
00061                 GainMin = 0.75;
00062         } else if (GainTable == dagtPX5) {
00063                 GainMin = 0.75;
00064         } else if (GainTable == dagtDP5G) {
00065                 GainMin = 1.0;
00066         } else if (GainTable == dagtMCA8000D) {
00067                 GainMin = 1;
00068         } else if (GainTable == dagtTB5) {
00069                 GainMin = 1.0;
00070         } else if (GainTable == dagtDP5Dx) {
00071                 GainMin = 0.75;
00072         } else if (GainTable == dagtDP5X) {
00073                 GainMin = 3.0;
00074         }
00075         return GainMin;
00076 }
00077
00078 double CDppGain::GetTotalGainLimitsMax(DppAGainTable GainTable)
00079 {
00080         double GainMax = 150;
00081         if (GainTable == dagtDP5) {
00082                 GainMax = 150;
00083         } else if (GainTable == dagtPX5) {
00084                 GainMax = 500;
00085         } else if (GainTable == dagtDP5G) {
00086                 GainMax = 10.0;
00087         } else if (GainTable == dagtMCA8000D) {
00088                 GainMax = 10;
00089         } else if (GainTable == dagtTB5) {
00090                 GainMax = 10.0;
00091         } else if (GainTable == dagtDP5Dx) {
00092                 GainMax = 250;
00093         } else if (GainTable == dagtDP5X) {
00094                 GainMax = 150;
00095         }
00096         return GainMax;
00097 }
00098
00099 BOOL CDppGain::isInTotalGainRange(CString strTotalGain, DppAGainTable GainTable)
00100 {
00101         double GainMin = 0.75;
00102         double GainMax = 150;
00103         BOOL inRange = FALSE;
00104         double dblGain = 0.75;
00105
00106         dblGain = atof(strTotalGain);
00107         GainMin = GetTotalGainLimitsMin(GainTable);
00108         GainMax = GetTotalGainLimitsMax(GainTable);
00109         if ((dblGain >= GainMin) && (dblGain <= GainMax)) {
00110                 inRange = TRUE;
00111         }
00112         return inRange;
00113 }
00114
00115 CString CDppGain::FixTotalGainRange(CString strTotalGain, DppAGainTable GainTable)
00116 {
00117         double GainMin = 0.75;
00118         double GainMax = 150;
00119         BOOL inRange = FALSE;
00120         double dblGain = 0.75;
00121         CString strGain;
00122
00123         dblGain = atof(strTotalGain);
00124         strGain = strTotalGain;
00125         GainMin = GetTotalGainLimitsMin(GainTable);
00126         GainMax = GetTotalGainLimitsMax(GainTable);
00127         if ((dblGain >= GainMin) && (dblGain <= GainMax)) {
00128                 strGain.Format("%.1f",dblGain); // value in range return value
00129         } else if (dblGain < GainMin) {
00130                 dblGain = GainMin;
00131                 strGain.Format("%.2f",dblGain);
00132         } else if (dblGain > GainMax) {
00133                 dblGain = GainMax;
00134                 strGain.Format("%.1f",dblGain);
00135         }
00136         return strGain;
00137 }
00138
00139 double * CDppGain::GetGainTablePtr(DppAGainTable GainTable)
00140 {
00141         double * ptrGainTable;
00142         if (GainTable == dagtDP5) {
00143                 ptrGainTable = &DP5_Gain[0];
00144         } else if (GainTable == dagtPX5) {
00145                 ptrGainTable = &PX5_Gain[0];
00146         } else if (GainTable == dagtDP5G) {
00147                 ptrGainTable = &DP5G_Gain[0];
00148         } else if (GainTable == dagtMCA8000D) {
00149                 ptrGainTable = &MCA8000D_Gain[0];
00150         } else if (GainTable == dagtTB5) {
00151                 ptrGainTable = &DP5G_Gain[0];
00152         } else if (GainTable == dagtDP5Dx) {
00153                 ptrGainTable = &DP5_DX_Gain[0];
00154         } else if (GainTable == dagtDP5X) {
00155                 ptrGainTable = &DP5X_Gain[0];
00156         }
00157         return ptrGainTable;
00158 }
00159
00160 void CDppGain::LoadGainTableValues(CComboBox *m_CoarseGain, DppAGainTable GainTable)
00161 {
00162         int GainCount = GetGainCount(GainTable);
00163         double * ptrGainTable = GetGainTablePtr(GainTable);
00164         CString strGain;
00165         int idxGain;
00166         double dblGain;
00167
00168         m_CoarseGain->ResetContent();
00169         for (idxGain=0;idxGain<GainCount;idxGain++){
00170                 dblGain = ptrGainTable[idxGain];
00171                 if (GainTable == dagtMCA8000D) {
00172                         strGain.Format("%.0fV",dblGain);
00173                 } else {
00174                         strGain.Format("%.3f",dblGain);
00175                 }
00176                 m_CoarseGain->AddString(strGain);
00177         }
00178         m_CoarseGain->SetCurSel(0);
00179 }
00180
00181 void CDppGain::LoadGainTableIndexes(CComboBox *m_CoarseGain, DppAGainTable GainTable)
00182 {
00183         int GainCount = GetGainCount(GainTable);
00184         CString strGain;
00185         int idxGain;
00186
00187         m_CoarseGain->ResetContent();
00188         for (idxGain=1;idxGain<=GainCount;idxGain++){
00189                 strGain.Format("%d",idxGain);
00190                 m_CoarseGain->AddString(strGain);
00191         }
00192         m_CoarseGain->SetCurSel(0);
00193 }
00194
00195 double CDppGain::FixTotalGainRangeDbl(double dblTotalGain, DppAGainTable GainTable)
00196 {
00197         double GainMin = 0.75;
00198         double GainMax = 150;
00199         BOOL inRange = FALSE;
00200         double dblGain = 0.75;
00201
00202         dblGain = dblTotalGain;
00203         GainMin = GetTotalGainLimitsMin(GainTable);
00204         GainMax = GetTotalGainLimitsMax(GainTable);
00205         if ((dblGain >= GainMin) && (dblGain <= GainMax)) {
00206                 // value in range return value
00207         } else if (dblGain < GainMin) {
00208                 dblGain = GainMin;
00209         } else if (dblGain > GainMax) {
00210                 dblGain = GainMax;
00211         }
00212         return dblGain;
00213 }
00214
00215
00216
00217
00218
00219
00220
00221
00222
00223
00224
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/DppGain.h Source File

DP5Cfg/DppGain.h
Go to the documentation of this file.
00001 #if !defined(AFX_DPPGAIN_H__INCLUDED_)
00002 #define AFX_DPPGAIN_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // DppGain.h : header file
00008 // DP5/PX5/DP5G/MCA8000D/TB5 Analog Gain Tables
00009
00010 #define SIZEOF_GAIN_ARRAY(gar)  (sizeof(gar)/sizeof((gar)[0]))
00011
00012 #define DP5_GAIN_COUNT 16
00013 #define PX5_GAIN_COUNT 28
00014 #define DP5G_GAIN_COUNT 4
00015 #define MCA8000D_GAIN_COUNT 2
00016 #define DP5_DX_GAIN_COUNT 24
00017 #define DP5X_GAIN_COUNT 6
00018
00019 // Option in FW6.08.06 and above, also has option flag in status
00020
00021 static double DP5X_Gain[DP5X_GAIN_COUNT] = {
00022         4.008, 8.016, 13.987, 27.974,
00023     55.948, 111.896};
00024
00025 static double DP5_DX_Gain[DP5_DX_GAIN_COUNT] = {
00026         1.000, 1.250, 1.563, 1.952,
00027         2.433, 3.040, 3.801, 4.749,
00028         5.975, 7.466, 9.337, 11.666,
00029         14.605, 18.250, 22.822, 28.515,
00030         35.530, 44.395, 55.518, 69.368,
00031         87.269, 109.043, 136.364, 170.383};
00032
00033 static double DP5_Gain[DP5_GAIN_COUNT] = {
00034         1.122, 2.491, 3.778, 5.278,
00035         6.556, 8.387, 10.091, 11.322,
00036         14.554, 17.772, 22.402, 30.839,
00037         38.124, 47.468, 66.157, 101.828};
00038
00039 static double PX5_Gain[PX5_GAIN_COUNT] = {
00040         1.000, 1.250, 1.560, 1.950,     // approx 1.25^n
00041         2.433, 3.041, 3.797, 4.746,
00042         5.975, 7.472, 9.340, 11.656,
00043         14.570, 18.179, 22.724, 28.371,
00044         35.464, 44.645, 55.831, 69.788,
00045         87.096, 108.622, 135.836, 169.795,
00046         211.989, 264.987, 330.704, 413.379};
00047
00048 static double DP5G_Gain[DP5G_GAIN_COUNT] = {
00049         1.571, 2.556, 4.091, 6.769};    // approx 1.6^n
00050
00051 static double MCA8000D_Gain[MCA8000D_GAIN_COUNT] = {
00052         1, 10};
00053
00054 // DP5s have two gain tables all gain tables are
00055 // selected by the device type except dagtDP5Dx (the new DP5 gains)
00056 // this selection should always be LAST in this ENUM
00057 typedef enum _DppAGainTable
00058 {
00059         dagtDP5,
00060         dagtPX5,
00061         dagtDP5G,
00062         dagtMCA8000D,
00063     dagtTB5,
00064         dagtDP5X,
00065         dagtDP5Dx
00066 } DppAGainTable;
00067
00068 #define MinGainTable dagtDP5
00069 //#define MaxGainTable dagtMCA8000D
00070 //#define MaxGainTable dagtTB5
00071 #define MaxGainTable dagtDP5Dx
00072 //#define MaxGainTable dagtDP5X
00073
00074 class CDppGain
00075 {
00076 public:
00077         CDppGain(void);
00078         ~CDppGain(void);
00079         DppAGainTable GainTable;
00080         double * ptrGainTable;
00081         double MinGain;
00082         double MaxGain;
00083         int GainTableCount;
00084         int GetGainCount(DppAGainTable GainTable);
00085         CString GetTotalGainLimitsLabel(DppAGainTable GainTable);
00086         double GetTotalGainLimitsMin(DppAGainTable GainTable);
00087         double GetTotalGainLimitsMax(DppAGainTable GainTable);
00088         BOOL isInTotalGainRange(CString strTotalGain, DppAGainTable GainTable);
00089         CString FixTotalGainRange(CString strTotalGain, DppAGainTable GainTable);
00090
00091         double * GetGainTablePtr(DppAGainTable GainTable);
00092         void LoadGainTableValues(CComboBox *m_CoarseGain, DppAGainTable GainTable);
00093         void LoadGainTableIndexes(CComboBox *m_CoarseGain, DppAGainTable GainTable);
00094
00095         double FixTotalGainRangeDbl(double dblTotalGain, DppAGainTable GainTable);
00096
00097 };
00098
00100 // CDPPGAIN definitions
00101
00102
00103 //{{AFX_INSERT_LOCATION}}
00104 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00105
00106 #endif // !defined(AFX_DPPGAIN_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppLibUsb.cpp Source File

DeviceIO/DppLibUsb.cpp
Go to the documentation of this file.
00001 #include "DppLibUsb.h"
00002
00003 CDppLibUsb::CDppLibUsb(void)
00004 {
00005
00006 }
00007 CDppLibUsb::~CDppLibUsb(void)
00008 {
00009
00010 }
00011
00012 // InitializeLibusb must be call before any other libusb operations
00013 int CDppLibUsb::InitializeLibusb()
00014 {
00015         int iStatus=0;
00016         iStatus = libusb_init(NULL);
00017         if (iStatus != 0) {
00018                 fprintf(stderr, "Unable to initialize libusb. %s\n", libusb_strerror((libusb_error)iStatus));
00019         }
00020         return iStatus;
00021 }
00022
00023 // DeinitializeLibusb must be called after all libusb operations
00024 // have been completed and all devices/lists are closed
00025 void CDppLibUsb::DeinitializeLibusb()
00026 {
00027         libusb_exit(NULL);
00028 }
00029
00030 // devices start at 1
00031 // Do only when no devices are connected
00032 libusb_device_handle * CDppLibUsb::FindUSBDevice(int idxAmptekDevice)
00033 {
00034         struct libusb_device **devs;
00035         struct libusb_device *found = NULL;
00036         struct libusb_device_handle *handle = NULL;
00037         struct libusb_device_descriptor desc;
00038         struct libusb_device *device = NULL;
00039         ssize_t devcnt = 0;
00040         ssize_t iDev = 0;
00041         int r;
00042         int idxDev=1;
00043
00044         bDeviceConnected = false;
00045         devcnt = libusb_get_device_list(NULL, &devs);
00046         if (devcnt < 0) {
00047                 fprintf(stderr, "failed to get device list");
00048                 return NULL;
00049         }
00050         for (iDev = 0; iDev < devcnt; iDev++) {
00051                 device = devs[iDev];
00052                 int r = libusb_get_device_descriptor (device, &desc);
00053                 if (r < 0) {
00054                         fprintf(stderr, libusb_strerror((libusb_error)r));
00055                         goto out;
00056                         //continue;
00057                 }
00058                 if (isAmptekDP5Device(desc)) {
00059                         if (idxAmptekDevice==idxDev) {
00060                                 found = device;
00061                                 break;
00062                         } else {        // inc counter to next device
00063                                 idxDev++;
00064                         }
00065                 }
00066         }
00067         if (found) {
00068                 r = libusb_open(found, &handle);
00069                 if (r < 0) {
00070                         fprintf(stderr, libusb_strerror((libusb_error)r));
00071                         handle = NULL;
00072                 } else {
00073                         if (handle != NULL) {
00074                                 r = libusb_claim_interface(handle, INTERFACE_NUMBER);
00075                                 if (r >= 0) {
00076                                         bDeviceConnected = true; // have interface
00077                                 } else {
00078                                         fprintf(stderr, "libusb_claim_interface error %s\n", libusb_strerror((libusb_error)r));
00079                                 }
00080                         } else {
00081                                 fprintf(stderr, "Unable to find a dpp device.\n");
00082                         }
00083                 }
00084         }
00085
00086 out:
00087         libusb_free_device_list(devs, 1);
00088         return handle;
00089 }
00090
00091 void CDppLibUsb::CloseUSBDevice(libusb_device_handle * devh)
00092 {
00093         int r;
00094         if (devh != NULL) {
00095                 r = libusb_release_interface(devh, INTERFACE_NUMBER);
00096                 if (r < 0) {
00097                         fprintf(stderr, "libusb_release_interface error %s\n", libusb_strerror((libusb_error)r));
00098                 }
00099                 libusb_close(devh);
00100         }
00101 }
00102
00103 int CDppLibUsb::SendPacketUSB(libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[])
00104 {
00105         int bytes_transferred;
00106         unsigned int timeout = 5000;
00107         int result = 0;
00108         int length = 0;
00109
00110         if ((data_out[2] == PID1_REQ_SCOPE_MISC_TO) && data_out[3] == PID2_SEND_DIAGNOSTIC_DATA_TO) {
00111                 timeout = DP5_DIAGDATA_TIMEOUT;
00112         } else {
00113                 timeout = DP5_USB_TIMEOUT;
00114         }
00115
00116         length = data_out[4];
00117         length *= 256;
00118         length += data_out[5];
00119         length += 8;
00120
00121         result = libusb_bulk_transfer(devh, BULK_OUT_ENDPOINT, data_out, length, &bytes_transferred, timeout);
00122         if (result >= 0) {
00123                 result = libusb_bulk_transfer(devh, BULK_IN_ENDPOINT, data_in, MAX_BULK_IN_TRANSFER_SIZE, &bytes_transferred, timeout);
00124                 if (result >= 0) {
00125                         if (bytes_transferred > 0) {
00126                                 return bytes_transferred;
00127                         } else {
00128                                 fprintf(stderr, "No data received in bulk transfer (%d)\n", result);
00129                                 return -1;
00130                         }
00131                 } else {
00132                         fprintf(stderr, "Error receiving data via bulk transfer %d\n", result);
00133                         return result;
00134                 }
00135         } else {
00136                 fprintf(stderr, "Error sending data via bulk transfer %d\n", result);
00137                 return result;
00138         }
00139         return 0;
00140  }
00141
00142 bool CDppLibUsb::isAmptekDP5Device(libusb_device_descriptor desc)
00143 {
00144         bool isDevice=false;
00145         if ((desc.idVendor == AMPTEK_DP5_VENDOR_ID) && (desc.idProduct == AMPTEK_DP5_PRODUCT_ID))
00146         {
00147                 isDevice=true;
00148         }
00149         return isDevice;
00150 }
00151
00152 // Counts number of dpp devices
00153 // Do only when no devices are connected
00154 int CDppLibUsb::CountDP5LibusbDevices()
00155 {
00156         libusb_device **devs;
00157         int iDppCount=0;
00158
00159         ssize_t cnt = libusb_get_device_list (NULL, &devs);
00160         if (cnt < 0)
00161                 return (-1);
00162         int nr = 0, i = 0;
00163         struct libusb_device_descriptor desc;
00164         for (i = 0; i < cnt; ++i)
00165         {
00166                 int r = libusb_get_device_descriptor (devs[i], &desc);
00167                 if (r != 0) {
00168                         fprintf(stderr, libusb_strerror((libusb_error)r));
00169                         continue;
00170                 }
00171                 if (isAmptekDP5Device(desc)) { nr++; }
00172         }
00173         libusb_free_device_list (devs, 1);
00174         iDppCount = (int)nr;
00175         return iDppCount;
00176 }
00177
00178 // Do only when no devices are connected
00179 void CDppLibUsb::PrintDevices()
00180 {
00181         struct libusb_device **devs;
00182         struct libusb_device *dev = NULL;
00183         int i = 0;
00184         ssize_t cnt = 0;
00185
00186         cnt = libusb_get_device_list(NULL, &devs);
00187         if (cnt < 0) {
00188                 fprintf(stderr, "failed to get device list");
00189                 return;
00190         }
00191
00192         while ((dev = devs[i++]) != NULL) {
00193                 struct libusb_device_descriptor desc;
00194                 int r = libusb_get_device_descriptor(dev, &desc);
00195                 if (r < 0) {
00196                         fprintf(stderr, "device descriptor error: %s", libusb_strerror((libusb_error)r));
00197                         return;
00198                 }
00199                 if (isAmptekDP5Device(desc)) {
00200                         printf("%04x:%04x (bus %d, device %d)\n", desc.idVendor, desc.idProduct, libusb_get_bus_number(dev), libusb_get_device_address(dev));
00201                 }
00202         }
00203         libusb_free_device_list(devs, 1);
00204 }
00205
00206 #ifndef LIBUSB_WINUSB_BACKEND
00207 const char * CDppLibUsb::libusb_strerror(enum libusb_error error_code)
00208 {
00209         switch (error_code) {
00210         case LIBUSB_SUCCESS:
00211                 return "Success";
00212         case LIBUSB_ERROR_IO:
00213                 return "Input/output error";
00214         case LIBUSB_ERROR_INVALID_PARAM:
00215                 return "Invalid parameter";
00216         case LIBUSB_ERROR_ACCESS:
00217                 return "Access denied (insufficient permissions)";
00218         case LIBUSB_ERROR_NO_DEVICE:
00219                 return "No such device (it may have been disconnected)";
00220         case LIBUSB_ERROR_NOT_FOUND:
00221                 return "Entity not found";
00222         case LIBUSB_ERROR_BUSY:
00223                 return "Resource busy";
00224         case LIBUSB_ERROR_TIMEOUT:
00225                 return "Operation timed out";
00226         case LIBUSB_ERROR_OVERFLOW:
00227                 return "Overflow";
00228         case LIBUSB_ERROR_PIPE:
00229                 return "Pipe error";
00230         case LIBUSB_ERROR_INTERRUPTED:
00231                 return "System call interrupted (perhaps due to signal)";
00232         case LIBUSB_ERROR_NO_MEM:
00233                 return "Insufficient memory";
00234         case LIBUSB_ERROR_NOT_SUPPORTED:
00235                 return "Operation not supported or unimplemented on this platform";
00236         case LIBUSB_ERROR_OTHER:
00237                 return "Other error";
00238         }
00239         return "Unknown error";
00240 }
00241 #endif
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppLibUsb.h Source File

DeviceIO/DppLibUsb.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 #ifdef _WIN32
00004         #define LIBUSB_WINUSB_BACKEND 1
00005 #endif
00006
00007 #ifdef LIBUSB_WINUSB_BACKEND
00008         #include "libusb.h"
00009         #ifdef _MSC_VER
00010                 #pragma comment(lib, ".\\DeviceIO\\libusb.lib")
00011         #endif
00012 #else
00013         #include <libusb.h>
00014 #endif
00015
00016 #include <stdio.h>
00017 #include <sys/types.h>
00018 #include <string.h>
00019
00020 #define AMPTEK_DP5_VENDOR_ID 0x10C4
00021 #define AMPTEK_DP5_PRODUCT_ID 0x842A
00022
00023 #define INTERFACE_NUMBER 0
00024 #define TIMEOUT_MS 5000
00025 #define BULK_IN_ENDPOINT 0x81
00026 #define BULK_OUT_ENDPOINT 0x02
00027 #define MAX_BULK_IN_TRANSFER_SIZE 32768
00028 #define MAX_BULK_OUT_TRANSFER_SIZE 520
00029 #define STATUS_PACKET_SIZE 64
00030 #define DP5_USB_TIMEOUT 500         // default timeout (500mS)
00031 #define DP5_DIAGDATA_TIMEOUT 2500       // diag data timeout
00032 #define PID1_REQ_SCOPE_MISC_TO 0x03
00033 #define PID2_SEND_DIAGNOSTIC_DATA_TO 0x05
00034
00035
00036 class CDppLibUsb
00037 {
00038 public:
00039         CDppLibUsb(void);
00040         ~CDppLibUsb(void);
00041
00042         unsigned char data_in[MAX_BULK_IN_TRANSFER_SIZE];               // data bytes in
00043         unsigned char data_out[MAX_BULK_OUT_TRANSFER_SIZE];             // data bytes out
00044
00045         libusb_device_handle *DppLibusbHandle;
00046         int NumDevices;
00047         int CurrentDevice;
00048         bool bLibusbReady;
00049         bool bDeviceReady;
00050         char LastLibUsbError[256];
00051         bool bDeviceConnected;
00052
00053         int InitializeLibusb();
00054         void DeinitializeLibusb();
00055         libusb_device_handle * FindUSBDevice(int idxAmptekDevice);
00056         void CloseUSBDevice(libusb_device_handle * devh);
00057         int SendPacketUSB(libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[]);
00058         bool isAmptekDP5Device(libusb_device_descriptor desc);
00059         int CountDP5LibusbDevices();
00060         void PrintDevices();
00061
00062 #ifndef LIBUSB_WINUSB_BACKEND
00063         const char * libusb_strerror(enum libusb_error error_code);
00064 #endif
00065
00066 };
00067
00068
00069
00070
00071
00072
00073
00074
00075
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppShaping.cpp Source File

Config/DppShaping.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\dppshaping.h"
00003
00004 //@doc CDppShaping
00005
00006 CDppShaping::CDppShaping(void)
00007 {
00008         dblPeakingMult = 1.0;
00009         b80MHzMode = false;
00010 }
00011
00012 CDppShaping::~CDppShaping(void)
00013 {
00014 }
00015
00016 void CDppShaping::Set80MHzMode(BOOL is80Mhz) {
00017         if (is80Mhz) {
00018                 dblPeakingMult = 0.25;
00019                 b80MHzMode = true;
00020         } else {
00021                 dblPeakingMult = 1.0;
00022                 b80MHzMode = false;
00023         }
00024 }
00025
00026 //@mfunc <c CDppShaping> Pulse Shaping Control Setup and Initialization.
00027 //@parm Rise Option Control
00028 //@parm FlatTop Option Control
00029 void CDppShaping::Shaping_Setup(CComboBox *cboRiseObj, CComboBox *cboTopObj) {
00030     int i;
00031     int intAvg;
00032     cboRise = cboRiseObj;            //set pointers to ctrl objects
00033     cboTop = cboTopObj;
00034
00035     cboRise->ResetContent();
00036     mAvg = 1;            //default avg val
00037
00038     // Changed peaking time/decimation combinations 5/6/02
00039     //For i = 1 To 15
00040         CString strTemp;
00041         if (b80MHzMode) {       // 50/100 shaping update
00042                 strTemp.Format("%.3f",(1.0 * 0.2) * dblPeakingMult);
00043                 cboRise->AddString(strTemp);
00044                 strTemp.Format("%.3f",(2.0 * 0.2) * dblPeakingMult);
00045                 cboRise->AddString(strTemp);
00046         }                                       // 50/100 shaping update
00047         for (i=1; i<=8; i++) {
00048                 strTemp.Format("%.3f",(i * 0.8) * dblPeakingMult);
00049                 cboRise->AddString(strTemp);
00050                 //MessageBox(NULL,strTemp," ",MB_OK);
00051     }
00052
00053         for (intAvg=1; intAvg<=4; intAvg++) {
00054                 for (i=5; i<=8; i++) {
00055                         strTemp.Format("%.3f",(i * 0.8 * pow(2.0,intAvg)) * dblPeakingMult);
00056                         cboRise->AddString(strTemp);
00057         }
00058     } //clsConfig.Avg
00059         cboRise->SetCurSel(0);
00060         cboTop->SetCurSel(0);
00061         mFlatTop = 0;
00062     SetRiseCombo();
00063 }
00064
00065 //@mfunc <c CDppShaping> Calculate Rise display text from a Rise combobox control index.
00066 //@parm Rise combobox control index
00067 //@rdesc Rise display text value string
00068 CString CDppShaping::GetRiseValueFromIndex(int RiseIndex, BOOL isRiseAveCalc = FALSE) {
00069     long idxRiseText;
00070     long idxAve;
00071     long idxX;
00072     CString RiseTextArray[MAXPEAKINGTIMES];
00073     CString strMsg;
00074     double dblPeakingMult;
00075
00076     if (isRiseAveCalc) {
00077         dblPeakingMult = 1.0;     //always use 20mhz values for riseave calcs
00078         } else if (b80MHzMode) {
00079         dblPeakingMult = 0.25;
00080         } else {
00081         dblPeakingMult = 1.0;
00082         }
00083
00084     strMsg = "";
00085     if ((RiseIndex < 0) || (RiseIndex >= MAXPEAKINGTIMES)) {
00086                 return strMsg;
00087         }
00088     idxRiseText = -1;
00089     if (b80MHzMode) {
00090                 for(idxX=1;idxX<=2;idxX++) {
00091             idxRiseText++;
00092             if (isRiseAveCalc) {     //create valid 20mhz values for 80mhz rise ave'
00093                                 RiseTextArray[idxRiseText].Format("%.3f",(1.0 * 0.8 * dblPeakingMult));
00094                         } else {                       //create real 80mhz values
00095                                 RiseTextArray[idxRiseText].Format("%.3f",((double)(idxX) * 0.2 * dblPeakingMult));
00096             }
00097             strMsg += RiseTextArray[idxRiseText] + "\r\n";
00098                 }
00099         }
00100     for(idxX=1;idxX<=8;idxX++) {
00101         idxRiseText++;
00102                 RiseTextArray[idxRiseText].Format("%.3f",((double)(idxX) * 0.8 * dblPeakingMult));
00103         strMsg += RiseTextArray[idxRiseText] + "\r\n";
00104     }
00105         for(idxAve=1;idxAve<=4;idxAve++) {
00106                 for(idxX=5;idxX<=8;idxX++) {
00107             idxRiseText++;
00108                         RiseTextArray[idxRiseText].Format("%.3f",((double)(idxX) * 0.8 * pow(2.0,idxAve)) * dblPeakingMult);
00109             strMsg += RiseTextArray[idxRiseText] + "\r\n";
00110         }
00111     }
00112     if (! b80MHzMode) {       //fill rest of array with valid (largest) value
00113         for(idxX=1;idxX<=2;idxX++) {
00114             idxRiseText++;
00115                         RiseTextArray[idxRiseText].Format("%.3f",((double)(8) * 0.8 * pow(2.0,4)) * dblPeakingMult);
00116             strMsg += RiseTextArray[idxRiseText] + "\r\n";
00117         }
00118     }
00119         if (RiseIndex > idxRiseText) {
00120                 return RiseTextArray[idxRiseText];
00121         }
00122         return RiseTextArray[RiseIndex];
00123 }
00124
00125 // get the closest value less than or equal to the selected flattop
00126 CString CDppShaping::GetDefaultFlatTopFromRiseIndex(int RiseIndex, double dblFlatTop)
00127 {
00128     int i;
00129         CString strTop("");
00130         CString strTemp("");
00131         // local copies used in calculating flattops for resolution tests
00132         int mRise;           //risetime register setting
00133     int mAvg;            //holds decimation setting for pulse shaping
00134         bool bDone=false;
00135         CString strLowest("");
00136         double dblRiseVal;
00137
00138         dblRiseVal = atof(GetRiseValueFromIndex(RiseIndex, TRUE));
00139         if ((dblRiseVal >= 0) && (dblRiseVal <= 6.4001)) {                              //    Case 0 To 6.4
00140                 mRise = (int)((dblRiseVal+0.0001) / 0.8);
00141                 mAvg = 1;
00142         } else if ((dblRiseVal >= 8) && (dblRiseVal <= 12.8001)) {              //    Case 8 To 12.8
00143         mRise = (int)((dblRiseVal+0.0001) / 1.6);
00144         mAvg = 2;
00145         } else if ((dblRiseVal >= 16) && (dblRiseVal <= 25.6001)) {     //    Case 16 To 25.6;
00146         mRise = (int)((dblRiseVal+0.0001) / 3.2);
00147         mAvg = 3;
00148         } else if ((dblRiseVal >= 32) && (dblRiseVal <= 51.2001)) {     //    Case 32 To 51.2
00149         mRise = (int)((dblRiseVal+0.0001) / 6.4);
00150         mAvg = 4;
00151         } else if ((dblRiseVal >= 64) && (dblRiseVal <= 102.4001)) {    //    Case 64 To 102.4
00152         mRise = (int)((dblRiseVal+0.0001) / 12.8);
00153         mAvg = 5;
00154     }
00155
00156         strLowest = dbl_to_uS(((0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00157         if (atof(strLowest) >= dblFlatTop) {
00158                 strTop = strLowest;
00159                 bDone = true;
00160         }
00161         if (!bDone) {   // skip any more calcs if have results
00162                 for(i=1;i<=8;i++) {     // create new list
00163                         if (bDone) { break; };
00164                         strTemp = dbl_to_uS((((double)i * 0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00165                         if (atof(strTemp) <= dblFlatTop) {
00166                                 strTop = strTemp;
00167                         } else {
00168                                 bDone = true;
00169                         }
00170                 }
00171         }
00172         if (!bDone) {   // skip any more calcs if have results
00173                 for(i=9;i<=62;i++) {    // create new list
00174                         if (bDone) { break; };
00175                         if ((i % 4) == 0) {
00176                                 strTemp = dbl_to_uS((((double)i * 0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00177                                 if (atof(strTemp) <= dblFlatTop) {
00178                                         strTop = strTemp;
00179                                 } else {
00180                                         bDone = true;
00181                                 }
00182                         }
00183                 }
00184         }
00185         if (!bDone) {   // skip any more calcs if have results
00186                 strTop = dbl_to_uS(((63.0 * 0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00187                 if (atof(strTemp) <= dblFlatTop) {
00188                         strTop = strTemp;
00189                 } else {
00190                         bDone = true;
00191                 }
00192         }
00193         if (strTop.GetLength() == 0) {  // value wasn't found, assign lowest value available
00194                 strTop = strLowest;             // this should never happen
00195         }
00196         return strTop;
00197 }
00198
00199 double CDppShaping::GetDblValFromComboText(CComboBox *m_ComboBoxCtrl) {
00200         int int_strlen;
00201         double dblVal;
00202         CString strText("");
00203
00204         m_ComboBoxCtrl->GetLBText(m_ComboBoxCtrl->GetCurSel(),strText); // get cbo text at the current position
00205         strText.TrimLeft();
00206         strText.TrimRight();
00207         strText = strText;                                                      // remove whitespace bebore checking size
00208         int_strlen = strText.GetLength();                                       // get the len to determine substring
00209         char *stopch;
00210         dblVal = strtod(strText.Mid(0,int_strlen-2),&stopch);
00211         return dblVal;
00212 }
00213
00214 void CDppShaping::SetRiseCombo() {
00215     int i;
00216         float dblRiseVal;
00217         CString strTop("");
00218         int RiseIdx;
00219         CString strTopFMT;
00220         CString temp;
00221         CString strFtAll;
00222
00223         strFtAll = "";
00224         RiseIdx = cboRise->GetCurSel();
00225         dblRiseVal = (float)atof(GetRiseValueFromIndex(RiseIdx,TRUE));
00226         if ((dblRiseVal >= 0) && (dblRiseVal <= 6.4001)) {                              //    Case 0 To 6.4
00227                 mRise = (int)((dblRiseVal+0.0001) / 0.8);
00228                 mAvg = 1;
00229         } else if ((dblRiseVal >= 8) && (dblRiseVal <= 12.8001)) {              //    Case 8 To 12.8
00230         mRise = (int)((dblRiseVal+0.0001) / 1.6);
00231         mAvg = 2;
00232         } else if ((dblRiseVal >= 16) && (dblRiseVal <= 25.6001)) {     //    Case 16 To 25.6;
00233         mRise = (int)((dblRiseVal+0.0001) / 3.2);
00234         mAvg = 3;
00235         } else if ((dblRiseVal >= 32) && (dblRiseVal <= 51.2001)) {     //    Case 32 To 51.2
00236         mRise = (int)((dblRiseVal+0.0001) / 6.4);
00237         mAvg = 4;
00238         } else if ((dblRiseVal >= 64) && (dblRiseVal <= 102.4001)) {    //    Case 64 To 102.4
00239         mRise = (int)((dblRiseVal+0.0001) / 12.8);
00240         mAvg = 5;
00241     }
00242     cboTop->ResetContent();
00243         cboTop->ResetContent();
00244         for(i=1;i<=8;i++) {     // create new list
00245                 strTop = dbl_to_uS((((double)i * 0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00246                 cboTop->AddString(strTop);
00247     }
00248
00249         for(i=9;i<=62;i++) {    // create new list
00250                 if ((i % 4) == 0) {
00251                         strTop = dbl_to_uS((((double)i * 0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00252                         cboTop->AddString(strTop);
00253                 }
00254     }
00255         strTop = dbl_to_uS(((63.0 * 0.05 * pow(2.0,(mAvg-1))) * dblPeakingMult));
00256         cboTop->AddString(strTop);
00257         cboTop->SetCurSel(0);
00258         mFlatTop = 0;
00259 }
00260
00261 CString CDppShaping::dbl_to_uS(double dblVal)
00262 {
00263         //unsigned char t;
00264         unsigned long l;
00265                 unsigned long ul;
00266                 CString strInt;
00267                 CString strDec;
00268                 CString strVal;
00269
00270                 ul = (unsigned long)(dblVal * 1000.0);
00271         l = ul / 1000;  // convert to integer uS
00272                 strInt.Format("%lu", l); // output integer portion in uS
00273                 strDec.Format(".%03lu", ul - (l * 1000));       // output 3 chars right of decimal point
00274                 strVal = strInt + strDec;
00275                 return strVal;
00276 }
00277
00278 //clsDialogs.DPPTop calls SetTopCombo (the ctrl calls DPPTop)
00279 //if top selection is made assign value to top var
00280 //@mfunc <c CDppShaping> Sets FlatTop value from the FlatTop combobox selection.
00281 //
00282 //@comm This sub is used with the cboTop control click event.
00283 //
00284 //@ex Calling SetTopCombo from a control |
00285 //
00286 //Private Sub cboTop_click()
00287 //    clsRise.SetTopCombo
00288 //    dlgDPPCONFIG.FlatTop = clsRise.FlatTop
00289 //}
00290 void CDppShaping::SetTopCombo() {
00291         CString strTop("");
00292         double dblTopVal;
00293         dblTopVal = GetDblValFromComboText(cboTop);
00294         mFlatTop = cboTop->GetCurSel();
00295         if (mFlatTop < 0) { mFlatTop = 0; }
00296 }
00297
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppShaping.h Source File

Config/DppShaping.h
Go to the documentation of this file.
00001 #pragma once
00002 #include <math.h>
00003
00004 //--------------------------------------------------------------------------------------
00005 //@doc CDppShaping
00006 //
00007 //@module clsShaping_Ctrl Class | Pulse Shaping Control Functions
00008 //
00009 //This class has the software functionality for Pulse Shaping
00010 //control.
00011 //
00012 // Copyright (c)2004,2010 Amptek, All Rights Reserved
00013 //
00014 //@devnote The Version Selection Control Functions are for test purposes
00015 //only.
00016 //
00017 //@devnote Version: v20100813_140923
00018 //
00019 //@iex
00020 //=================================================
00021 //
00022 //@head3 CDppShaping Members |
00023 //@index | CDppShaping
00024 //
00025 //--------------------------------------------------------------------------------------
00026
00027 #define MAXPEAKINGTIMES 26
00028 #define MAXPEAKINGTIMES_20MHZ (MAXPEAKINGTIMES - 2)
00029 #define MAXPEAKINGTIMES_80MHZ MAXPEAKINGTIMES
00030
00031 class CDppShaping
00032 {
00033
00034 private:
00035     CComboBox *cboRise;
00036     CComboBox *cboTop;
00037     int mRise;           //risetime register setting
00038     int mAvg;            //holds decimation setting for pulse shaping
00039     int mFlatTop;        //flatop register setting
00040
00041 public:
00042         CDppShaping(void);
00043         ~CDppShaping(void);
00044         void Shaping_Setup(CComboBox *cboRiseObj, CComboBox *cboTopObj);
00045         CString GetRiseValueFromIndex(int RiseIndex, BOOL isRiseAveCalc);
00046         CString GetDefaultFlatTopFromRiseIndex(int RiseIndex, double dblFlatTop);
00047         double GetDblValFromComboText(CComboBox *m_ComboBoxCtrl);
00048         void SetRiseCombo();
00049         void SetTopCombo();
00050         double dblPeakingMult;
00051         BOOL b80MHzMode;
00052         void Set80MHzMode(BOOL is80Mhz);
00053         CString dbl_to_uS(double dblVal);
00054 };
00055
00056
00057
00058
00059
00060
00061
00062
00063
00064
00065
00066
00067
00068
00069
00070
00071
00072
00073
00074
00075
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppSlowThreshold.cpp Source File

Config/DppSlowThreshold.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\dppslowthreshold.h"
00003
00004 //--------------------------------------------------------------------------------------
00005 //@doc CDppSlowThreshold
00006 //
00007 //@module DppSlowThreshold.cpp | Threshold Control Functions
00008 //
00009 //This class has the software functionality for Threshold
00010 //controls.
00011 //
00012 // Copyright (c)2004 Amptek, All Rights Reserved
00013 //
00014 //@devnote The Threshold Control Functions run independantly
00015 //from the clsDPPConfig class. Anytime a function is called that updates a
00016 //value, the corresponding clsDPPConfig variable must updated as well.
00017 //
00018 //@devnote Version: v20040629_1613
00019 //
00020 //@head3 CDppSlowThreshold Members |
00021 //@index | CDppSlowThreshold
00022 //
00023 //--------------------------------------------------------------------------------------
00024
00025 CDppSlowThreshold::CDppSlowThreshold(void)
00026 {
00027 }
00028
00029 CDppSlowThreshold::~CDppSlowThreshold(void)
00030 {
00031 }
00032
00033 //@bfield SlowChThreshold | Byte | Slow channel threshold, Events with amplitude lower not added to spectrum
00034 unsigned char CDppSlowThreshold::GetSlowChThreshold() {
00035     return mSlowChThreshold;
00036 }
00037
00038 void CDppSlowThreshold::SetSlowChThreshold(unsigned char SlowChThresholdVal) {
00039     mSlowChThreshold = SlowChThresholdVal;
00040 }
00041
00042 //@mfunc <c CDppSlowThreshold> Threshold Control Setup and Initialization.
00043 //@parm Slow Threshold UpDown Control
00044 //@parm Slow Threshold label
00045 //@parm Slow Threshold label
00046 void CDppSlowThreshold::Thresholds_Setup(CSpinButtonCtrl *udThresholdObj,  CEdit *lblThresholdObj,  CEdit *lblThresholdChannelsObj) {
00047     udThreshold = udThresholdObj;
00048     lblThreshold = lblThresholdObj;
00049     lblThresholdChannels = lblThresholdChannelsObj;
00050         GainChannels = 1024;
00051     //udThreshold.ToolTipText = "Shaped threshold"
00052         udThreshold->SetRange32(0,250);         // set control min,max
00053     //udThreshold.Wrap = True
00054     //udThreshold.Enabled = True
00055     //lblSlowThreshold.Caption = "Slow Threshold"
00056     //lblThreshold.Caption = "lblThreshold"
00057     //lblThreshold.ToolTipText = "Slow Channel Threshold excludes events that should not be added to the stored spectrum"
00058     //udThreshold.Value = 4       // default threhold=4
00059         udThreshold->SetPos(4);                 // default fast threshold=100 // udFThreshold.Value = 100
00060         DPPThreshold(4);
00061 }
00062
00063 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00064 //from a slow threshold value string
00065 //@parm slow threshold value string
00066 //@devnote Used by clsDPPFile.SetDPPControlsFromStr, must set
00067 //clsDPPConfig.SlowChThreshold variable after running.
00068 void CDppSlowThreshold::SetGain(long GainVal)
00069 {
00070         if (GainVal > 8192) {
00071                 GainChannels = 8192;
00072         } else if (GainVal < 256) {
00073                 GainChannels = 256;
00074         } else {
00075                 GainChannels = GainVal;
00076         }
00077 }
00078
00079 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00080 //from a slow threshold value string
00081 //@parm slow threshold value string
00082 //@devnote Used by clsDPPFile.SetDPPControlsFromStr, must set
00083 //clsDPPConfig.SlowChThreshold variable after running.
00084 void CDppSlowThreshold::SetSlowChThresholdFromStr(CString strSlowThresh) {
00085         udThreshold->SetPos(atoi(strSlowThresh));
00086 }
00087
00088 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00089 //from a slow threshold value
00090 //@parm slow threshold value
00091 //@devnote Used by clsDPPFile.SetDPPControlsFromVal, must set
00092 //clsDPPConfig.SlowChThreshold variable after running.
00093 void CDppSlowThreshold::SetSlowChThresholdFromVal(int intSlowThresh) {
00094         udThreshold->SetPos(intSlowThresh);     //udThreshold.Value = intSlowThresh
00095 }
00096
00097 //@mfunc <c CDppSlowThreshold> Set Slow threshold value from a Slow threshold value string
00098 //@parm Slow threshold value string
00099 //@devnote Must set clsDPPConfig.SlowChThreshold variable after running,
00100 //does not update the controls, used for direct
00101 //initialization of the clsDPPConfig class.
00102 void CDppSlowThreshold::SetSlowChThresholdConfigFromStr(CString strSlowThresh) {
00103     mSlowChThreshold = atoi(strSlowThresh);
00104 }
00105
00106 //@mfunc <c CDppSlowThreshold> Slow Threshold Selection Control function.
00107 //
00108 //@comm This sub is used with the udFThreshold control change event.
00109 //
00110 //@ex Calling DPPFThreshold from a control |
00111 //
00112 //Private Sub udFThreshold_Change()
00113 //    clsThreshold.DPPFThreshold
00114 //    dlgDPPCONFIG.SlowChThreshold = clsThreshold.SlowChThreshold
00115 //}
00116 void CDppSlowThreshold::DPPThreshold(int SpinPos) {
00117     //mSlowChThreshold = udThreshold->GetPos();
00118     mSlowChThreshold = SpinPos;
00119     lblThreshold->SetWindowText(GetSlowThreshPcntStr());
00120         lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00121 }
00122
00123 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from current Slow Threshold.
00124 CString CDppSlowThreshold::GetSlowThreshPcntStr() {
00125         CString strSlowThresh;
00126         strSlowThresh = GetSlowChThresStrFromVal(mSlowChThreshold);
00127         return strSlowThresh;
00128 }
00129
00130 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from Slow Threshold value.
00131 //@parm Slow Threshold value
00132 //@rdesc Slow Threshold display text string
00133 CString CDppSlowThreshold::GetSlowChThresStrFromVal(unsigned char byteSlowThres) {
00134         CString strSlowThresh;
00135         strSlowThresh.Format("%.2f%% FS",((byteSlowThres * 100.0 * 4.0 / 4096 * 100) / 100));
00136         return strSlowThresh;
00137 }
00138
00139 //@mfunc <c CDppSlowThreshold> Slow Threshold Selection Control function.
00140 //
00141 //@comm This sub is used with the udFThreshold control change event.
00142 //
00143 //@ex Calling DPPFThreshold from a control |
00144 //
00145 //Private Sub udFThreshold_Change()
00146 //    clsThreshold.DPPFThreshold
00147 //    dlgDPPCONFIG.SlowChThreshold = clsThreshold.SlowChThreshold
00148 //}
00149 void CDppSlowThreshold::txtSlowThreshold_Click()
00150 {
00151         CString strSlowThresh;
00152         double dblSlowThresh;
00153         double FSReal;
00154         int FSCFG;
00155     // get value, cast to double, convert to real percent
00156         lblThreshold->GetWindowText(strSlowThresh);
00157         dblSlowThresh = atof(strSlowThresh);
00158         FSReal = dblSlowThresh / 100.0;
00159         if (FSReal < 0.0) {
00160                 FSReal = 0.0;
00161         } else if (FSReal > 0.2441) {
00162                 FSReal = 0.2441;                                // max is 24.41 percent
00163         }
00164         // convert FSReal to FSCFG to get closest actual setting
00165         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00166         // xtra check
00167         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00168         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00169         // set controls to value, textbox, ud, (when added,) channels textbox
00170     mSlowChThreshold = FSCFG;
00171         udThreshold->SetPos(FSCFG);
00172     lblThreshold->SetWindowText(GetSlowThreshPcntStr());
00173         lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00174 }
00175
00176 unsigned char CDppSlowThreshold::GetSlowThresholdSettingFromPercent(double dblSlowThresh)
00177 {
00178         double FSReal;
00179         int FSCFG;
00180         FSReal = dblSlowThresh / 100.0;
00181         if (FSReal < 0.0) {
00182                 FSReal = 0.0;
00183         } else if (FSReal > 0.2441) {
00184                 FSReal = 0.2441;                                // max is 24.41 percent
00185         }
00186         // convert FSReal to FSCFG to get closest actual setting
00187         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00188         // xtra check
00189         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00190         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00191         return FSCFG;
00192 }
00193
00194 //@mfunc <c CDppSlowThreshold> Slow Threshold Selection Control function.
00195 //
00196 //@comm This sub is used with the udFThreshold control change event.
00197 //
00198 //@ex Calling DPPFThreshold from a control |
00199 //
00200 //Private Sub udFThreshold_Change()
00201 //    clsThreshold.DPPFThreshold
00202 //    dlgDPPCONFIG.SlowChThreshold = clsThreshold.SlowChThreshold
00203 //}
00204 void CDppSlowThreshold::txtSlowThresholdChannels_Click()
00205 {
00206         CString strSlowThresh;
00207         double dblSlowThresh;
00208         double FSReal;
00209         int FSCFG;
00210     // get value, cast to double, convert to real percent
00211         lblThresholdChannels->GetWindowText(strSlowThresh);
00212         dblSlowThresh = atof(strSlowThresh);
00213         FSReal = dblSlowThresh / (double)GainChannels;
00214         if (FSReal < 0.0) {
00215                 FSReal = 0.0;
00216         } else if (FSReal > 0.2441) {
00217                 FSReal = 0.2441;                                // max is 24.41 percent
00218         }
00219         // convert FSReal to FSCFG to get closest actual setting
00220         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00221         // xtra check
00222         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00223         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00224         // set controls to value, textbox, ud, (when added,) channels textbox
00225     mSlowChThreshold = FSCFG;
00226         udThreshold->SetPos(FSCFG);
00227     lblThreshold->SetWindowText(GetSlowThreshPcntStr());
00228         if (!(strSlowThresh == GetSlowThreshChStr())) {
00229                 lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00230         }
00231 }
00232
00233 //@mfunc <c SetSlowThresholdFromChannels> Set Slow Threshold from channels value.
00234 //
00235 //@comm This sub is used with auto threshold scaling.
00236 //
00237 unsigned char CDppSlowThreshold::GetSlowThresholdSettingFromChannels(double dblSlowThreshChannels)
00238 {
00239         double FSReal;
00240         int FSCFG;
00241     // get value, cast to double, convert to real percent
00242         FSReal = dblSlowThreshChannels / (double)GainChannels;
00243         if (FSReal < 0.0) {
00244                 FSReal = 0.0;
00245         } else if (FSReal > 0.2441) {
00246                 FSReal = 0.2441;                                // max is 24.41 percent
00247         }
00248         // convert FSReal to FSCFG to get closest actual setting
00249         FSCFG = (int)((FSReal * 4.0 * 256.0) + 0.5);    //%FS CFG = %FS Real * 4 * 256;
00250         // xtra check
00251         if (FSCFG > 250) { FSCFG = 250; }               //%FS 0-24.41%, 0-250
00252         if (FSCFG < 0) { FSCFG = 0; }           //%FS 0-24.41%, 0-250
00253         // set controls to value, textbox, ud, (when added,) channels textbox
00254     mSlowChThreshold = FSCFG;
00255         return mSlowChThreshold;
00256 }
00257
00258 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from Slow Threshold value.
00259 //@parm Slow Threshold value
00260 //@rdesc Slow Threshold display text string
00261 CString CDppSlowThreshold::GetSlowThreshChStr()
00262 {
00263         long lngSlowThresh;
00264         CString strSlowThresh;
00265         lngSlowThresh = (long)(((double)mSlowChThreshold * (double)GainChannels / 1024.0) + 0.5);
00266         strSlowThresh.Format("%d",lngSlowThresh);
00267         return strSlowThresh;
00268 }
00269
00270 //@mfunc <c CDppSlowThreshold> Get Slow Threshold display text string from Slow Threshold value.
00271 //@parm Slow Threshold value
00272 //@rdesc Slow Threshold display text string
00273 CString CDppSlowThreshold::GetSlowThreshChStrFromVal(unsigned char byteSlowThres)
00274 {
00275         long lngSlowThresh;
00276         CString strSlowThresh;
00277         lngSlowThresh = (long)(((double)byteSlowThres * (double)GainChannels / 1024.0) + 0.5);
00278         strSlowThresh.Format("%d",lngSlowThresh);
00279         return strSlowThresh;
00280 }
00281
00282 //@mfunc <c CDppSlowThreshold> Set Slow Threshold UpDown control and slow threshold value
00283 //from a slow threshold value string
00284 //@devnote Used by clsDPPFile.SetDPPControlsFromStr, must set
00285 //clsDPPConfig.SlowChThreshold variable after running.
00286 void CDppSlowThreshold::UpdateSlowThresChDisplay()
00287 {
00288         lblThresholdChannels->SetWindowText(GetSlowThreshChStr());
00289 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/DppSlowThreshold.h Source File

Config/DppSlowThreshold.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 class CDppSlowThreshold
00004 {
00005
00006 private:
00007         unsigned char mSlowChThreshold;  //Slow ch threshold, Events w/amp lower not added to spectrum
00008         CSpinButtonCtrl *udThreshold;
00009         CEdit *lblThreshold;
00010         CEdit *lblThresholdChannels;
00011         long GainChannels;
00012
00013 public:
00014         CDppSlowThreshold(void);
00015         ~CDppSlowThreshold(void);
00016         unsigned char GetSlowChThreshold();
00017         void SetSlowChThreshold(unsigned char SlowChThresholdVal);
00018         void Thresholds_Setup(CSpinButtonCtrl *udThresholdObj,  CEdit *lblThresholdObj,  CEdit *lblThresholdChannelsObj);
00019         void SetSlowChThresholdFromStr(CString strSlowThresh);
00020         void SetSlowChThresholdFromVal(int intSlowThresh);
00021         void SetSlowChThresholdConfigFromStr(CString strSlowThresh);
00022         void DPPThreshold(int SpinPos);
00023         CString GetSlowThreshPcntStr();
00024         CString GetSlowChThresStrFromVal(unsigned char byteSlowThres);
00025         void txtSlowThreshold_Click();
00026         void txtSlowThresholdChannels_Click();
00027         void SetGain(long GainVal);
00028         CString GetSlowThreshChStr();
00029         CString GetSlowThreshChStrFromVal(unsigned char byteSlowThres);
00030         void UpdateSlowThresChDisplay();
00031         unsigned char GetSlowThresholdSettingFromChannels(double dblSlowThreshChannels);
00032         unsigned char GetSlowThresholdSettingFromPercent(double dblSlowThresh);
00033
00034 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppSocket.cpp Source File

DeviceIO/DppSocket.cpp
Go to the documentation of this file.
00001 // DppSocket.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "DppSocket.h"
00006
00007
00009 // Include dialog headers here for direct OnReceive calls
00011 //#include "vcDP5Dlg.h"                     // example sockownMainDlg
00012 //#include "SelectDP5.h"                        // example sockownStartDlg
00014
00015 //#ifdef _DEBUG
00016 //#define new DEBUG_NEW
00017 //#undef THIS_FILE
00018 //static char THIS_FILE[] = __FILE__;
00019 //#endif
00020
00021
00023 // CDppSocket
00024
00025 CDppSocket::CDppSocket()
00026 {
00027         m_pEvtDlg = NULL;
00028         m_SocketOpen = FALSE;
00029         m_DataMode = FALSE;
00030         m_Owner = sockownNone;
00031         DppPort = 10001;
00032         DppAddr = inet_addr("192.168.0.28");
00033 }
00034
00035 CDppSocket::~CDppSocket()
00036 {
00037         m_pEvtDlg = NULL;
00038 }
00039
00040 // Do not edit the following lines, which are needed by ClassWizard.
00041 #if 0
00042 BEGIN_MESSAGE_MAP(CDppSocket, CSocket)
00043         //{{AFX_MSG_MAP(CDppSocket)
00044         //}}AFX_MSG_MAP
00045 END_MESSAGE_MAP()
00046 #endif  // 0
00047
00049 // CDppSocket member functions
00050
00051 //BOOL CDppSocket::CreateSocket(CDialog *pEvtDlg)
00052 BOOL CDppSocket::CreateSocket(CWnd *pEvtDlg)
00053 {
00054         bool broadcast = TRUE;
00055
00056         if (m_SocketOpen) {
00057                 Close();
00058                 ResetEventDlg();
00059         }
00060
00061         if(!Create(0, SOCK_DGRAM)){
00062                 AfxMessageBox("Cannot Open Socket");
00063         } else {
00064                 m_SocketOpen = TRUE;
00065         }
00066
00067         if (m_SocketOpen) {
00068                 SetSockOpt(SO_BROADCAST, &broadcast, sizeof(BOOL));
00069                 SetEventDlg(pEvtDlg);
00070         }
00071         return m_SocketOpen;
00072 }
00073
00074 void CDppSocket::CloseSocket()
00075 {
00076         ResetEventDlg();
00077 }
00078
00079 BOOL CDppSocket::IsSocketOpen()
00080 {
00081         return (m_SocketOpen);
00082 }
00083
00084 void CDppSocket::OnReceive(int nErrorCode)
00085 {
00086         // TODO: Add your specialized code here and/or call the base class
00087         if ((nErrorCode == 0) && (m_pEvtDlg != NULL)) {
00088                 ::SendMessage(m_pEvtDlg->GetSafeHwnd(), WM_DPPSOCKET_RCV_BUFFER, (WPARAM) NULL, (LPARAM) nErrorCode);   // rcv byte
00089
00090                 //m_pEvtDlg->m_hWnd
00091                 //switch (m_Owner) {
00092                 //      case sockownMainDlg:
00093                 //              //((CvcDP5Dlg*)m_pEvtDlg)->OnReceive(nErrorCode);
00094                 //              break;
00095                 //      case sockownStartDlg:
00096                 //              //((CSelectDP5*)m_pEvtDlg)->OnReceive(nErrorCode);
00097                 //              break;
00098                 //}
00099         }
00100         CAsyncSocket::OnReceive(nErrorCode);
00101 }
00102
00103 //void CDppSocket::SetEventDlg(CDialog *pEvtDlg)
00104 void CDppSocket::SetEventDlg(CWnd *pEvtDlg)
00105 {
00106         m_pEvtDlg = pEvtDlg;
00107 }
00108
00109 void CDppSocket::ResetEventDlg()
00110 {
00111         m_pEvtDlg = NULL;
00112 }
00113
00114 bool CDppSocket::SendPacketInet(unsigned char Buffer[], CDppSocket *DppSock)
00115 {
00116     int PLen;                                   // socket uses int value
00117         SOCKADDR_IN RemoteAddr;
00118         int dwBytes;
00119
00120     PLen = (Buffer[4] * 256) + Buffer[5] + 8;
00121         RemoteAddr.sin_family = AF_INET;
00122         RemoteAddr.sin_port = htons(DppSock->DppPort);
00123         RemoteAddr.sin_addr.s_addr = DppSock->DppAddr;
00124         dwBytes = DppSock->SendTo(Buffer, PLen, (const SOCKADDR* )&RemoteAddr, sizeof(RemoteAddr));
00125         if(SOCKET_ERROR == dwBytes){
00126                 //CString str;
00127                 //str.Format("Error Code: %i.", GetLastError());
00128                 //AfxMessageBox(str + " Unable To Send Packet. Please Check Network Connection.");
00129         }
00130         return true;
00131 }
00132
00133
00134
00135
00136
00137
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppSocket.h Source File

DeviceIO/DppSocket.h
Go to the documentation of this file.
00001 #if !defined(AFX_DppSocket_H__INCLUDED_)
00002 #define AFX_DppSocket_H__INCLUDED_
00003
00004 #pragma once
00005 #include "stdafx.h"
00006 //#include "NetFinder.h"
00007
00008 #define WM_DPPSOCKET_RCV_BUFFER (WM_USER + 401)
00009
00010 // DppSocket.h : header file
00011
00012 typedef enum _SocketOwnerType
00013 {
00014         sockownNone,
00015         sockownMainDlg,
00016         sockownStartDlg
00017 } SocketOwnerType;
00018
00020 // CDppSocket command target
00021
00022 class CDppSocket : public CSocket
00023 {
00024 // Attributes
00025 public:
00026
00027 // Operations
00028 public:
00029         CDppSocket();
00030         virtual ~CDppSocket();
00031
00032 // Overrides
00033 public:
00034         //BOOL CreateSocket(CDialog *pEvtDlg);
00035         BOOL CreateSocket(CWnd *pEvtDlg);
00036         void CloseSocket();
00037         //void SetEventDlg(CDialog *pEvtDlg);
00038         void SetEventDlg(CWnd *pEvtDlg);
00039         void ResetEventDlg();
00040
00041         SocketOwnerType m_Owner;                // who's talking now
00042         u_short DppPort;                                // dpp port for remote port (bsd type)
00043         u_long DppAddr;                             // dpp addr for remote addr (bsd type)
00044
00045         // Receive helper vars
00046         int RcvCount;                                   // byte count/offset for Packet buffer save
00047         int RcvTotal;                                   // total bytes expected
00048         BOOL HaveHeader;                                // header found, get packet bytes
00049         BOOL IsSocketOpen();
00050         bool SendPacketInet(unsigned char Buffer[], CDppSocket *DppSock);
00051
00052         // ClassWizard generated virtual function overrides
00053         //{{AFX_VIRTUAL(CDppSocket)
00054 public:
00055         virtual void OnReceive(int nErrorCode);
00056         //}}AFX_VIRTUAL
00057
00058         // Generated message map functions
00059         //{{AFX_MSG(CDppSocket)
00060                 // NOTE - the ClassWizard will add and remove member functions here.
00061         //}}AFX_MSG
00062
00063 // Implementation
00064 protected:
00065         //CDialog *m_pEvtDlg;
00066         CWnd *m_pEvtDlg;
00067         BOOL m_SocketOpen;
00068         BOOL m_DataMode;
00069 };
00070
00072
00073 //{{AFX_INSERT_LOCATION}}
00074 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00075
00076 #endif // !defined(AFX_DppSocket_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppUtilities.cpp Source File

DeviceIO/DppUtilities.cpp
Go to the documentation of this file.
00001 #include "DppUtilities.h"
00002 #include "stringex.h"
00003
00004 CDppUtilities::CDppUtilities(void)
00005 {
00006 }
00007
00008 CDppUtilities::~CDppUtilities(void)
00009 {
00010 }
00011
00012 // convert a 4 byte long word to a double
00013 // lwStart - starting index of longword
00014 // buffer - byte buffer
00015 double CDppUtilities::LongWordToDouble(int lwStart, unsigned char buffer[])
00016 {
00017         double dblVal;
00018         int idx;
00019         double ByteMask;
00020         dblVal = 0;
00021         for(idx=0;idx<4;idx++) {                // build 4 bytes (lwStart-lwStart+3) into double
00022                 ByteMask = pow(2.0,(8 * idx));
00023                 dblVal = dblVal + (buffer[(lwStart + idx)] * ByteMask);
00024         }
00025         return dblVal;
00026 }
00027
00028 // calculate major.minor version from unsigned char, convert/save to double
00029 double CDppUtilities::BYTEVersionToDouble(unsigned char Version)
00030 {
00031         double dblVersion = 0.0;
00032         stringex strfn;
00033         string strTemp;
00034         strTemp = strfn.Format("%d.%02d",((Version & 240) / 16),(Version & 15));
00035         dblVersion = atof(strTemp.c_str());
00036         return dblVersion;
00037 }
00038
00039 // calculate major.minor version from unsigned char, convert/save to string
00040 string CDppUtilities::BYTEVersionToString(unsigned char Version)
00041 {
00042         string strTemp;
00043         stringex strfn;
00044         strTemp = strfn.Format("%d.%02d",((Version & 240) / 16),(Version & 15));
00045         return strTemp;
00046 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppUtilities.h Source File

DeviceIO/DppUtilities.h
Go to the documentation of this file.
00001 #pragma once
00002 #include <stdlib.h>
00003 #include <math.h>
00004 #include <string>
00005 using namespace std;
00006
00007 class CDppUtilities
00008 {
00009 public:
00010         CDppUtilities(void);
00011         ~CDppUtilities(void);
00013         double LongWordToDouble(int lwStart, unsigned char buffer[]);
00015         double BYTEVersionToDouble(unsigned char Version);
00017         string BYTEVersionToString(unsigned char Version);
00018 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppWinUSB.cpp Source File

DeviceIO/DppWinUSB.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "DppWinUSB.h"
00003
00004 CDppWinUSB::CDppWinUSB(void)
00005 {
00006         WinUsb_Disabled = false;
00007         InitDeviceInfo();
00008         NumPipes = -1;
00009         CurrentDevice = 1;
00010         NumDevices = 0;
00011         USB_Default_Timeout = FALSE;     // flag that non-default timeout is in use
00012 }
00013
00014 CDppWinUSB::~CDppWinUSB(void)
00015 {
00016 }
00017
00018 void CDppWinUSB::Disable_WinUsb()
00019 {
00020         WinUsb_Disabled = true;
00021 }
00022
00023 void CDppWinUSB::InitDeviceInfo()
00024 {
00025         devInfo.deviceHandle = INVALID_HANDLE_VALUE;
00026         devInfo.winUSBHandle = NULL;
00027         devInfo.deviceConnected = FALSE;
00028 }
00029
00030 void CDppWinUSB::CloseDeviceHandle()
00031 {
00032         if ((devInfo.deviceHandle != NULL) && (devInfo.deviceHandle != INVALID_HANDLE_VALUE)) {
00033                 CloseHandle(devInfo.deviceHandle);
00034                 devInfo.deviceHandle = NULL;
00035         }
00036 }
00037
00038 void CDppWinUSB::CloseWinUsbDevice()
00039 {
00040         if (WinUsb_Disabled) return;
00041     if (devInfo.winUSBHandle) {
00042         if (!WinUsb_Free(devInfo.winUSBHandle)) {
00043                         //DSYSERR("-WinUsb_Free failed");
00044                         //MessageBox(NULL,"WinUsb_Free failed","Closing WinUSB",MB_OK);
00045         }
00046         devInfo.winUSBHandle = NULL;
00047     }
00048         CloseDeviceHandle();
00049 }
00050
00051 BOOL CDppWinUSB::GetDevicePath(LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex)
00052 {
00053         BOOL bResult = FALSE;
00054         HDEVINFO deviceInfo;
00055         SP_DEVICE_INTERFACE_DATA interfaceData;
00056         PSP_DEVICE_INTERFACE_DETAIL_DATA detailData = NULL;
00057         unsigned long length;
00058         unsigned long requiredLength=0;
00059         HRESULT hr;
00060
00061         if (WinUsb_Disabled) return FALSE;
00062
00063         // get device information handle
00064         deviceInfo = SetupDiGetClassDevs(InterfaceGuid, NULL, NULL, DIGCF_PRESENT | DIGCF_DEVICEINTERFACE);
00065
00066         // ===== Loop here to find multiple devices ====================
00067         // get interface data for device enumeration (first
00068         interfaceData.cbSize = sizeof(SP_DEVICE_INTERFACE_DATA);
00069         bResult = SetupDiEnumDeviceInterfaces(deviceInfo, NULL, InterfaceGuid, MemberIndex, &interfaceData);
00070         //bResult = SetupDiEnumDeviceInterfaces(deviceInfo, NULL, InterfaceGuid, 0, &interfaceData);
00071         if(FALSE == bResult)  { return FALSE; }
00072
00073         // get the details for the current device interface
00074         bResult = SetupDiGetDeviceInterfaceDetail(deviceInfo, &interfaceData, NULL, 0, &requiredLength, NULL);
00075         detailData = (PSP_DEVICE_INTERFACE_DETAIL_DATA)LocalAlloc(LMEM_FIXED, requiredLength);
00076         if(NULL == detailData) {
00077                 SetupDiDestroyDeviceInfoList(deviceInfo);
00078                 return FALSE;
00079         }
00080         detailData->cbSize = sizeof(SP_DEVICE_INTERFACE_DETAIL_DATA);
00081         length = requiredLength;
00082         bResult = SetupDiGetDeviceInterfaceDetail(deviceInfo, &interfaceData, detailData, length, &requiredLength, NULL);
00083         if(FALSE == bResult)   {
00084                 LocalFree(detailData);
00085                 return FALSE;
00086         }
00087         // copy the device path
00088         hr = StringCchCopy(DevicePath, BufLen, detailData->DevicePath);
00089         if(FAILED(hr)) {
00090                 SetupDiDestroyDeviceInfoList(deviceInfo);
00091                 LocalFree(detailData);
00092         }
00093         LocalFree(detailData);
00094         return bResult;
00095 }
00096
00097 HANDLE CDppWinUSB::OpenDevice(BOOL bSync, DWORD MemberIndex)
00098 {
00099         HANDLE hDev = NULL;
00100         char devicePath[MAX_DEVPATH_LENGTH];
00101         BOOL retVal;
00102
00103         if (WinUsb_Disabled) return INVALID_HANDLE_VALUE;
00104
00105         retVal = GetDevicePath((LPGUID) &GUID_DP5_INTERFACE_CLASS, devicePath, sizeof(devicePath), MemberIndex);
00106         //Error-handling code omitted.
00107         if (retVal) {
00108                 HRESULT hr;
00109                 hr = StringCchCopy(devInfo.devicePath, sizeof(devicePath), devicePath);
00110         }
00111         hDev = CreateFile(devicePath, GENERIC_WRITE | GENERIC_READ, FILE_SHARE_WRITE | FILE_SHARE_READ,
00112                                                 NULL, OPEN_EXISTING, FILE_ATTRIBUTE_NORMAL | FILE_FLAG_OVERLAPPED, NULL);
00113         //Error-handling code omitted.
00114         return hDev;
00115 }
00116
00117 BOOL CDppWinUSB::Initialize_Device(DWORD MemberIndex)
00118 {
00119         BOOL bResult;
00120         WINUSB_INTERFACE_HANDLE usbHandle;
00121         USB_INTERFACE_DESCRIPTOR ifaceDescriptor;
00122         WINUSB_PIPE_INFORMATION pipeInfo;
00123         unsigned char speed;
00124         unsigned long length;
00125         unsigned char bFalse = 0;
00126         unsigned char bTrue = 1;
00127         unsigned long pipeTimeout;
00128
00129         if (WinUsb_Disabled) return false;
00130
00131         pipeTimeout = 500;   // 2/4/10 - seems like 500mS should be plenty?
00132         //Change timeout for Erase FPGA (4 Sec), and Diagnostic Data (2.5 Sec) commands
00133
00134         InitDeviceInfo();
00135         devInfo.deviceHandle = OpenDevice(TRUE, MemberIndex);
00136         bResult = WinUsb_Initialize(devInfo.deviceHandle, &usbHandle);
00137         //[1]
00138         if(bResult) {
00139                 devInfo.winUSBHandle = usbHandle;
00140                 length = sizeof(unsigned char);
00141                 bResult = WinUsb_QueryDeviceInformation(devInfo.winUSBHandle, DEVICE_SPEED, &length, &speed);
00142         }
00143         //[2]
00144         if(bResult)
00145         {
00146                 devInfo.deviceSpeed = speed;
00147                 bResult = WinUsb_QueryInterfaceSettings(devInfo.winUSBHandle, 0, &ifaceDescriptor);
00148         }
00149         if(bResult) {
00150                 NumPipes = ifaceDescriptor.bNumEndpoints;
00151                 for(int i=0;i<ifaceDescriptor.bNumEndpoints;i++) {
00152                         PipeId[i] = INVALID_HANDLE_VALUE;
00153                         PipeTimeout[i] = 500;
00154                         //[3]
00155                         bResult = WinUsb_QueryPipe(devInfo.winUSBHandle, 0, (unsigned char) i, &pipeInfo);
00156                         PipeId[i] = (HANDLE)pipeInfo.PipeId;
00157                         PipeTimeout[i] = pipeTimeout;
00158                         //[4]
00159                         if(pipeInfo.PipeType == UsbdPipeTypeBulk && USB_ENDPOINT_DIRECTION_IN(pipeInfo.PipeId)) {
00160                                 devInfo.bulkInPipe = pipeInfo.PipeId;
00161                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, IGNORE_SHORT_PACKETS, sizeof(unsigned char), &bFalse);
00162                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, AUTO_CLEAR_STALL, sizeof(unsigned char), &bTrue);
00163                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, ALLOW_PARTIAL_READS, sizeof(unsigned char), &bFalse);
00164                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00165                         } else if(pipeInfo.PipeType == UsbdPipeTypeBulk && USB_ENDPOINT_DIRECTION_OUT(pipeInfo.PipeId)) {
00166                                 devInfo.bulkOutPipe = pipeInfo.PipeId;
00167                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkInPipe, IGNORE_SHORT_PACKETS, sizeof(unsigned char), &bFalse);
00168                                 //WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, SHORT_PACKET_TERMINATE, sizeof(unsigned char), &bTrue);
00169                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, SHORT_PACKET_TERMINATE, sizeof(unsigned char), &bFalse);
00170                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, AUTO_CLEAR_STALL, sizeof(unsigned char), &bTrue);
00171                                 WinUsb_SetPipePolicy(devInfo.winUSBHandle, devInfo.bulkOutPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00172                         } else if(pipeInfo.PipeType == UsbdPipeTypeInterrupt) {
00173                                 devInfo.interruptPipe = pipeInfo.PipeId;
00174                         } else {
00175                                 bResult = FALSE;
00176                                 break;
00177                         }
00178                 }
00179         }
00180         return bResult;
00181 }
00182
00183 DPP_USB_STATUS CDppWinUSB::FindUSBDevice(DWORD MemberIndex)
00184 {
00185         BOOL bResult;
00186         DPP_USB_STATUS USBStatus;       //0=do nothing, 1=new connect, 2=cannot connect
00187
00188         if (WinUsb_Disabled) return dusbStatConnectFail;
00189
00190         USBStatus = dusbStatNoAction;
00191         if (devInfo.deviceConnected) {          // already connected,do nothing
00192                 return (USBStatus);
00193         }
00194         USBStatus = dusbStatConnectFail;
00195         bResult = Initialize_Device(MemberIndex);               // begin connect sequence
00196         if (! bResult) {                                                                // failed to initialize
00197                 devInfo.deviceConnected = FALSE;
00198                 return (USBStatus);                                                     // return ConnectFail
00199         }
00200         if (devInfo.deviceHandle == NULL) {     // NULL device handle,do nothing
00201                 USBStatus = dusbStatNoAction;
00202                 return (USBStatus);
00203         }
00204         if (devInfo.deviceHandle != INVALID_HANDLE_VALUE) {
00205                 devInfo.deviceConnected = true;
00206                 USBStatus = dusbStatNewConnect;                         // return NewConnect
00207         } else {                                                                                // return ConnectFail
00208                 devInfo.deviceConnected = false;
00209                 CloseWinUsbDevice();
00210         }
00211         //if (devInfo.deviceConnected) {
00212         //      RegDeviceNotification();
00213         //}
00214         return (USBStatus);
00215 }
00216
00217 int CDppWinUSB::CountDP5WinusbDevices(void)
00218 {
00219         int NumDevices = 0;
00220     HKEY hKey;
00221     DWORD retCode;
00222         unsigned char DevicePath[MAXREGBUFFER];
00223     DWORD cbDevicePath;
00224     char KeyName[MAX_PATH];
00225         DWORD cbKeyName;
00226         char ErrMsg[MAXREGBUFFER];
00227         DWORD cbErrMsg;
00228
00229         char* lpDevicePath;
00230
00231         retCode = RegOpenKeyEx(HKEY_LOCAL_MACHINE, WinUSBService, 0, KEY_QUERY_VALUE, &hKey);
00232     if (retCode != ERROR_SUCCESS) {
00233         return 0;
00234     }
00235         // Test ALL Keys (0,1,... are device paths, Count,NextInstance,(Default) have other info)
00236         for (DWORD idxDP5 = 0; idxDP5 < MAXDP5S + 3; idxDP5++) {        //devs + 3 other keys
00237                 cbKeyName = MAX_PATH;
00238                 cbDevicePath = MAXREGBUFFER;
00239                 retCode = RegEnumValue(hKey, idxDP5, KeyName, &cbKeyName, NULL, NULL, &DevicePath[0], &cbDevicePath);
00240                 if (retCode == ERROR_SUCCESS) {
00241                         lpDevicePath = (char*)DevicePath;
00242                         if (!_strnicmp(KeyName, "Count", 5)) {
00243                                 continue;
00244                         } else if (!_strnicmp(lpDevicePath, WinUsbDP5, WinUsbDP5Size)) {        // DP5 device path found
00245                                 //TRACE("DP5 device [%d]: %s=%s\r\n", (NumDevices + 1), KeyName, DevicePath);
00246                                 NumDevices++;
00247                                 continue;
00248                         }
00249                 } else if (retCode == ERROR_NO_MORE_ITEMS) {    // no more values to read
00250                         break;
00251                 } else {                                                                                // error reading values
00252                         cbErrMsg = MAXREGBUFFER;
00253                         FormatMessage(FORMAT_MESSAGE_FROM_SYSTEM, NULL, retCode, MAKELANGID(LANG_NEUTRAL, SUBLANG_DEFAULT), ErrMsg, cbErrMsg, NULL);
00254                         break;
00255                 }
00256         }
00257         RegCloseKey(hKey);
00258     return NumDevices;          /* return number of devices */
00259 }
00260
00261 string CDppWinUSB::USBStatusString(DPP_USB_STATUS USBStatus)
00262 {
00263         string strStatus;
00264         strStatus = "";
00265         switch (USBStatus) {
00266                 case dusbStatNewConnect:
00267                         strStatus = "USB DPP device connected.";
00268                         break;
00269                 case dusbStatConnectFail:
00270                         strStatus = "Cannot connect to USB DPP device.";
00271                         break;
00272         }
00273         return (strStatus);
00274 }
00275
00276 string CDppWinUSB::DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn)
00277 {
00278     unsigned long i;
00279         string strVal("");
00280         string strMsg("");
00281         stringex strfn;
00282         for(i=0;i<bufSizeIn;i++) {
00283                 strVal = strfn.Format("%.2X ",buffer[i]);
00284                 strMsg += strVal;
00285                 if (((i+1) % 16) == 0 ) {
00286                         strMsg += "\r\n";
00287                 } else if (((i+1) % 8) == 0 ) {
00288                         strMsg += "   ";
00289                 }
00290         }
00291         strMsg += "\r\n";
00292         return strMsg;
00293 }
00294
00295 void CDppWinUSB::SaveStringDataToFile(string strData)
00296 {
00297    FILE  *out;
00298    string strFilename;
00299    string strError;
00300    stringex strfn;
00301
00302    strFilename = "CfgHex.txt";
00303
00304    if ( (out = fopen(strFilename.c_str(),"w")) == (FILE *) NULL)
00305       strError = strfn.Format("Couldn't open %s for writing.\n", strFilename.c_str());
00306    else
00307    {
00308       fprintf(out,"%s\n",strData.c_str());
00309    }
00310    fclose(out);
00311 }
00312
00313 bool CDppWinUSB::SendPacketUSB(unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[])
00314 {
00315     unsigned long bytesWritten;
00316         unsigned long bytesRead;
00317     int success;
00318     long PLen;
00319         unsigned long pipeTimeout;
00320
00321     if ((Buffer[2] == PID1_REQ_SCOPE_MISC) && Buffer[3] == PID2_SEND_DIAGNOSTIC_DATA) {
00322                 // Request Diagnostic Packet delay 'USB_DiagDataDelayMS
00323                 pipeTimeout = USB_DiagDataDelayMS;
00324                 success = WinUsb_SetPipePolicy(TestDevInfo.winUSBHandle, TestDevInfo.bulkInPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00325         USB_Default_Timeout = false;     // flag that non-default timeout is in use
00326         } else {
00327         if (USB_Default_Timeout == false) {  // change pipetimeout to default if it isn't already set that way
00328                         pipeTimeout = USB_TIMEOUT;
00329                         success = WinUsb_SetPipePolicy(TestDevInfo.winUSBHandle, TestDevInfo.bulkInPipe, PIPE_TRANSFER_TIMEOUT, sizeof(unsigned long), &pipeTimeout);
00330             USB_Default_Timeout = true;      // flag that default timeout is in use
00331         }
00332         }
00333
00334         bytesWritten = NULL;
00335         bytesRead = NULL;
00336         PLen = (Buffer[4] * 256) + Buffer[5] + 8;
00337         success = WinUsb_WritePipe(TestDevInfo.winUSBHandle, TestDevInfo.bulkOutPipe, Buffer, PLen, &bytesWritten, NULL);
00338         Sleep(50);                              // 20110907 Added to improve usb communications while running other processes
00339         if (success) {
00340                 success = WinUsb_ReadPipe(TestDevInfo.winUSBHandle, TestDevInfo.bulkInPipe, PacketIn, 32767, &bytesRead, NULL);
00341                 if (success) {
00342                         return true;
00343                 } else {
00344                         return false;
00345                 }
00346         } else {
00347                 return false;
00348         }
00349 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/DppWinUSB.h Source File

DeviceIO/DppWinUSB.h
Go to the documentation of this file.
00001
00002 #pragma once
00003
00004 // MS var redef bug fix
00005 #ifdef _MP
00006         #undef _MP
00007 #endif
00008 // ====================
00009 // Include Windows headers
00010 #include <Windows.h>
00011 #include <Strsafe.h>
00012 #include "stringex.h"
00013 // Include WinUSB headers
00014 #include <Winusb.h>
00015 #include <Setupapi.h>
00016 #include "guid.h"
00017 #include <Dbt.h>
00018 #include "DP5Protocol.h"
00019
00020 #define MAX_DEVPATH_LENGTH 256
00021 #define MAXDP5S 128                             // max number of devices
00022 #define MAXREGBUFFER 128
00023 #define WinUSBService "SYSTEM\\CurrentControlSet\\Services\\WinUSB\\Enum"
00024 #define WinUsbDP5 "USB\\Vid_10c4&Pid_842a"
00025 #define WinUsbDP5Size 21
00026 #define DRV_INFO_OPTION_NONE 0x00
00027 #define DRV_INFO_OPTION_MFG_NAME 0x01
00028 #define DRV_INFO_OPTION_PROV_NAME 0x02
00029 #define DRV_INFO_OPTION_DESC 0x04
00030 #define DRV_INFO_OPTION_DATE 0x08
00031 #define DRV_INFO_OPTION_VER 0x10
00032 #define DRV_INFO_OPTION_MS_TERM 0x20
00033 #define DRV_INFO_OPTION_UX_TERM 0x40
00034 #define DRV_INFO_OPTION_LABEL 0x80
00035 #define DRV_INFO_OPTION_ALL 0xFF
00036 #define MAXPIPES 10
00037
00038 typedef enum _DPP_USB_STATUS
00039 {
00040         dusbStatNoAction,
00041         dusbStatNewConnect,
00042         dusbStatConnectFail
00043 } DPP_USB_STATUS;
00044
00046 typedef struct WINUSB_DEVICE_INFO
00047 {
00049         HANDLE deviceHandle;
00051         WINUSB_INTERFACE_HANDLE winUSBHandle;
00053         unsigned char deviceSpeed;
00055         unsigned char bulkInPipe;
00057         unsigned char bulkOutPipe;
00059         unsigned char interruptPipe;
00061         char devicePath[MAX_DEVPATH_LENGTH];
00063         BOOL deviceConnected;
00064 } DEVICE_INFO, *PDEVICE_INFO;
00065
00066 class CDppWinUSB
00067 {
00068 public:
00069         CDppWinUSB(void);
00070         ~CDppWinUSB(void);
00071
00072         bool WinUsb_Disabled;
00073         void Disable_WinUsb();
00074
00076         DEVICE_INFO devInfo;
00078         int NumPipes;
00079
00081         HANDLE PipeId[MAXPIPES];
00083         unsigned long PipeTimeout[MAXPIPES];
00085         void InitDeviceInfo();
00087         void CloseDeviceHandle();
00089         void CloseWinUsbDevice();
00091         BOOL GetDevicePath(LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex);
00093         HANDLE OpenDevice(BOOL bSync, DWORD MemberIndex);
00095         BOOL Initialize_Device(DWORD MemberIndex);
00096
00097         // dialog helper functions
00098
00100         DPP_USB_STATUS FindUSBDevice(DWORD MemberIndex);
00102         int CountDP5WinusbDevices(void);
00104         int CurrentDevice;
00106         int NumDevices;
00108         bool isDppFound;
00109
00110         string DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn);
00111         void SaveStringDataToFile(string strData);
00112
00113         string USBStatusString(DPP_USB_STATUS USBStatus);
00114
00116         bool SendPacketUSB(unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[]);
00117         bool USB_Default_Timeout;
00118
00119 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FileBrowse.cpp Source File

DP5Cfg/FileBrowse.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\filebrowse.h"
00003
00004 CFileBrowse::CFileBrowse(void)
00005 {
00006         CfgFileFilter = _T("Configuration Files (*.txt)|*.txt|Text Files (*.txt)|*.txt|All Files (*.*)|*.*||");
00007         TxtFileFilter = _T("Text Files (*.txt)|*.txt|All Files (*.*)|*.*||");
00008         ExeFileFilter = _T("Programs (*.exe)|*.exe|All Files (*.*)|*.*||");
00009         BmpFileFilter = _T("Windows Bitmap (*.bmp)|*.bmp|All Files (*.*)|*.*||");
00010
00011         McaFileFilter = _T("Spectra Data Files (*.mca)|*.mca|All Files (*.*)|*.*||");
00012         LibFileFilter = _T("Library Files (*.lib)|*.lib|All Files (*.*)|*.*||");
00013         AllFileFilter = _T("All Files (*.*)|*.*||");
00014 }
00015
00016 CFileBrowse::~CFileBrowse(void)
00017 {
00018 }
00019
00020 BOOL CFileBrowse::DoModal(int DlgType,
00021                                                 CString DlgTitle,
00022                                                 CString FileFilter,
00023                                                 CString DefaultExt,
00024                                                 CString InitDir,
00025                                                 CString* Filename)
00026 {
00027         BOOL bResult = FALSE;
00028         CString strFilter("");
00029         CString strExtension("");
00030         DWORD dwFlags = 0;
00031
00032         if (FileFilter.GetLength() > 1) {
00033                 strFilter = FileFilter;
00034         }
00035         if (DefaultExt.GetLength() > 1) {
00036                 strExtension = DefaultExt;
00037         }
00038         dwFlags = (DlgType) ? OFN_FILEMUSTEXIST : OFN_OVERWRITEPROMPT;
00039         dwFlags |= OFN_HIDEREADONLY;
00040         dwFlags |= OFN_ENABLESIZING;
00041         dwFlags &= ~OFN_CREATEPROMPT; //prevent forced file creation on open
00042
00043         CFileDialog FileDlg(DlgType, strExtension, (*Filename), dwFlags, strFilter);
00044         FileDlg.m_ofn.lpstrTitle = DlgTitle;
00045         if (InitDir.GetLength() > 1) {
00046                 FileDlg.m_ofn.lpstrInitialDir = InitDir;
00047         }
00048         if (FileDlg.DoModal() == IDOK) {
00049                 bResult = TRUE;
00050                 *Filename = FileDlg.GetPathName();
00051         }
00052         return bResult;
00053 }
00054
00055
00056
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FileBrowse.h Source File

DP5Cfg/FileBrowse.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 class CFileBrowse {
00004
00005 public:
00006         CFileBrowse(void);
00007         ~CFileBrowse(void);
00008         BOOL DoModal(int DlgType,
00009                                         CString DlgTitle,
00010                                         CString FileFilter,
00011                                         CString DefaultExt,
00012                                         CString InitDir,
00013                                         CString* Filename);
00014         enum DialogType {
00015                 SAVE,
00016                 OPEN
00017         };
00018         // Filter strings
00019         CString CfgFileFilter;
00020         CString TxtFileFilter;
00021         CString ExeFileFilter;
00022         CString BmpFileFilter;
00023         CString McaFileFilter;
00024         CString LibFileFilter;
00025         CString AllFileFilter;
00026 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FilePage.cpp Source File

DP5Cfg/FilePage.cpp
Go to the documentation of this file.
00001 // FilePage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "afxpriv.h"    // afxpriv.h has WM_COMMANDHELP id
00006
00007 #include "FilePageRes.h"
00008 #include "FilePage.h"
00009 #include "FileBrowse.h"
00010 #include "IniUtil.h"
00011 #include "scommon.h"
00012 #include ".\filepage.h"
00013 #include "UserMsgs.h"
00014 #include "CmdWaitDlg.h"
00015 #include "msectimer.h"
00016 #include "AsciiCmdUtilities.h"
00017
00018 #ifdef _DEBUG
00019 #define new DEBUG_NEW
00020 #undef THIS_FILE
00021 static char THIS_FILE[] = __FILE__;
00022 #endif
00023
00025 // CFilePage property page
00026
00027 IMPLEMENT_DYNCREATE(CFilePage, CCfgPropPage)
00028 // #define IDD_FILE_PAGE                   104
00029
00030 //CFilePage::CFilePage() : CCfgPropPage(CFilePage::IDD)
00031 //, m_strConfigIn(_T(""))
00032 //, m_strConfigOut(_T(""))
00033
00034
00035 CFilePage::CFilePage() : CCfgPropPage("IDD_FILE_PAGE")
00036 , m_strConfigIn(_T(""))
00037 , m_strConfigOut(_T(""))
00038 {
00039         //{{AFX_DATA_INIT(CFilePage)
00040                 // NOTE: the ClassWizard will add member initialization here
00041         //}}AFX_DATA_INIT
00042
00043         // auto load hw config if connected, timer calls function
00044         m_nTmrConfigId = 0;                             // return SetTimer Return Value (0=false,TimerID if OK)
00045         m_nTmrConfigEventId = 4;        // Timer Event Identifier
00046         m_nTmrConfigElapse = 500;       // Timeout value in milliseconds
00047 }
00048
00049 CFilePage::~CFilePage()
00050 {
00051
00052 }
00053
00054 void CFilePage::DoDataExchange(CDataExchange* pDX)
00055 {
00056         CCfgPropPage::DoDataExchange(pDX);
00057         //{{AFX_DATA_MAP(CFilePage)
00058         //}}AFX_DATA_MAP
00059         DDX_Control(pDX, IDC_STATIC_FILE_PAGE, m_FilePageLabel);
00060     DDX_Control(pDX, IDC_READDETECTORCONFIGCOMBO, m_ReadDetectorConfigCombo);
00061         DDX_Control(pDX, IDC_STATIC_FILE_ADVANCED, m_FileAdvancedLabel);
00062         DDX_Control(pDX, IDC_STATIC_FILE_STANDARD, m_FileStandardLabel);
00063
00064 }
00065
00066 BEGIN_MESSAGE_MAP(CFilePage, CCfgPropPage)
00067         //{{AFX_MSG_MAP(CFilePage)
00068         //}}AFX_MSG_MAP
00069
00070         // Read/Save ini format config file
00071         ON_BN_CLICKED(IDC_BUTTON_READ_CONFIG, OnBnClickedButtonReadConfig)
00072         ON_BN_CLICKED(IDC_BUTTON_SAVE_CONFIG, OnBnClickedButtonSaveConfig)
00073
00074         // reset configuration to defaults (this command is now hidden, default->RESC=YES;)
00075         ON_CBN_SELCHANGE(IDC_OPT_COMBO_RESC, OnCbnSelchangeOptComboResc)
00076         //ON_BN_CLICKED(IDC_BUTTON_FIND_COMMAND, OnBnClickedButtonFindCommand)
00077
00078         // read current configuration from hardware (active DPP)
00079         // reads config to configuration dialog for editing
00080         // if a dpp device is present, this is done when the dialog is opened
00081         ON_BN_CLICKED(IDC_BUTTON_EDIT_CONFIG_FROM_HW, OnBnClickedButtonEditConfigFromHw)
00082
00083         // send current configuration to hardware (active DPP)
00084         // if a dpp device is present, this is done when apply or OK buttons are pressed
00085         ON_BN_CLICKED(IDC_BUTTON_SEND_TO_HARDWARE, OnBnClickedButtonSendToHardware)
00086         ON_WM_TIMER()
00087
00088         // reads cfg file and directly sends commands to hardware
00089         // this function can send new and unsupported commands
00090         ON_BN_CLICKED(IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT, OnBnClickedButtonSendToHardwareNoEdit)
00091
00092         // Select device type and pc5 option when creating config and DPP is not connected
00093         // TYPE1=DP5, TYPE2=PX5, TYPE3=DP5G, TYPE4=MCA8000D, TYPE5=TB5
00094         ON_BN_CLICKED(IDC_RADIO_DPP_DEVICE_TYPE1, OnBnClickedRadioDppDeviceType1)
00095         ON_BN_CLICKED(IDC_RADIO_DPP_DEVICE_TYPE2, OnBnClickedRadioDppDeviceType2)
00096         ON_BN_CLICKED(IDC_RADIO_DPP_DEVICE_TYPE3, OnBnClickedRadioDppDeviceType3)
00097         ON_BN_CLICKED(IDC_RADIO_DPP_DEVICE_TYPE4, OnBnClickedRadioDppDeviceType4)
00098         ON_BN_CLICKED(IDC_RADIO_DPP_DEVICE_TYPE5, OnBnClickedRadioDppDeviceType5)
00099         ON_BN_CLICKED(IDC_RADIO_DPP_DEVICE_TYPE6, OnBnClickedRadioDppDeviceType6)
00100         ON_BN_CLICKED(IDC_CHECK_PC5_PRESENT, OnBnClickedCheckPc5Present)
00101         ON_BN_CLICKED(IDC_CHECK_DP5_DX_GAIN, OnBnClickedCheckDP5DxGains)
00102
00103         // read predefined configurations
00104         // defined in AmptekDC_NP.ini (Amptek Detector Configurations, New (FW6) Protocol)
00105         ON_CBN_SELENDOK(IDC_READDETECTORCONFIGCOMBO, OnCbnSelendokReaddetectorconfigcombo)
00106         ON_CBN_SELCHANGE(IDC_READDETECTORCONFIGCOMBO, OnCbnSelchangeReaddetectorconfigcombo)
00107
00108         // respond to the read/save config folder icon next to the command button
00109         ON_STN_CLICKED(IDC_STATIC_READ_CONFIG, OnStnClickedStaticReadConfig)
00110         ON_STN_CLICKED(IDC_STATIC_SAVE_CONFIG, OnStnClickedStaticSaveConfig)
00111
00112         // send typed in text command string
00113         ON_BN_CLICKED(IDC_BUTTON_SEND_COMMAND, OnBnClickedButtonSendCommand)
00114
00115         ON_COMMAND(ID_HELP, OnHelp)
00116         ON_WM_HELPINFO()
00117
00118         ON_BN_CLICKED(IDC_BUTTON_SEND_COMMAND2, OnBnClickedButtonSendCommand2)
00119 END_MESSAGE_MAP()
00120
00122 // CFilePage message handlers
00123
00124 BOOL CFilePage::OnSetActive()
00125 {
00126         // TODO: Add your specialized code here and/or call the base class
00127         if (s.ReloadCfg) { InitControls(); }
00128         return CCfgPropPage::OnSetActive();
00129 }
00130
00131 BOOL CFilePage::OnInitDialog()
00132 {
00133         CCfgPropPage::OnInitDialog();
00134
00135         SelectRadioDppDeviceType(s.profile->device_type);
00136         isClosing = FALSE;
00137         m_FilePageLabel
00138                 .SetFontName("Arial")
00139                 .SetFontSize(24)
00140                 .SetTextColor(RGB(0,0,255))
00141                 .SetBkColor(RGB(244, 243, 238))
00142                 .SetFontItalic(TRUE)
00143                 .SetFontBold(TRUE);
00144
00145         m_FileAdvancedLabel
00146                 .SetFontName("Arial")
00147                 .SetFontSize(18)
00148                 .SetTextColor(RGB(0, 70, 213))
00149                 .SetBkColor(RGB(245, 245, 242))
00150                 .SetFontItalic(TRUE)
00151                 .SetFontBold(FALSE);
00152
00153         m_FileStandardLabel
00154                 .SetFontName("Arial")
00155                 .SetFontSize(18)
00156                 .SetTextColor(RGB(0, 70, 213))
00157                 .SetBkColor(RGB(252, 252, 254))
00158                 .SetFontItalic(TRUE)
00159                 .SetFontBold(FALSE);
00160
00161         //GetDlgItem(IDC_READDETECTORCONFIGCOMBO)->EnableWindow(FALSE);
00162         InitControls();
00163         if (s.isDppConnected) {
00164                 s.HaveConfig = FALSE;
00165                 EnableControls(FALSE);
00166                 EnableDeviceSelection(FALSE);
00167                 SelectRadioDppDeviceType(s.profile->device_type);
00168                 m_nTmrConfigId = SetTimer(m_nTmrConfigEventId, m_nTmrConfigElapse, NULL);
00169
00170                 GetDlgItem(IDC_STATIC_SEND_COMMAND_LABEL)->ShowWindow(SW_SHOW);
00171                 GetDlgItem(IDC_BUTTON_SEND_COMMAND)->ShowWindow(SW_SHOW);
00172                 GetDlgItem(IDC_BUTTON_SEND_COMMAND2)->ShowWindow(SW_SHOW);
00173                 GetDlgItem(IDC_EDIT_SEND_COMMAND)->ShowWindow(SW_SHOW);
00174
00175         } else {
00176                 EnableDeviceSelection(TRUE);    // must select dpp device type to enable controls
00177                 //--------------------------------------------------------------
00178                 //s.DP5Stat.m_DP5_Status.DPP_options = PX5_OPTION_HPGe_HVPS;
00179                 s.DP5Stat.m_DP5_Status.DPP_options = PX5_OPTION_NONE;
00180                 //DPP_options == NONE unless PX5 and has options
00181                 //--------------------------------------------------------------
00182                 GetDlgItem(IDC_STATIC_SEND_COMMAND_LABEL)->ShowWindow(SW_HIDE);
00183                 GetDlgItem(IDC_BUTTON_SEND_COMMAND)->ShowWindow(SW_HIDE);
00184                 GetDlgItem(IDC_BUTTON_SEND_COMMAND2)->ShowWindow(SW_HIDE);
00185                 GetDlgItem(IDC_EDIT_SEND_COMMAND)->ShowWindow(SW_HIDE);
00186                 GetDlgItem(IDC_EDIT_RCV_CFG)->ShowWindow(SW_HIDE);
00187         }
00188
00189         // TODO:  Add extra initialization here
00190
00191         return TRUE;  // return TRUE unless you set the focus to a control
00192         // EXCEPTION: OCX Property Pages should return FALSE
00193 }
00194
00195 //dciRESC       RESC    IDC_OPT_COMBO_RESC                                      0       dctCbo          dcgFile Reset Configuration
00196
00197 void CFilePage::InitControls()
00198 {
00199         HWND hPage = this->GetSafeHwnd();\
00200         InitDlgItem(hPage,s.m_DP5Cfg[dciRESC]);
00201         CboUpdate(dciRESC);
00202
00203         GetDlgItem(IDC_STATIC_CFG_LEN_LABEL)->ShowWindow(SW_HIDE);
00204         GetDlgItem(IDC_STATIC_CFG_LENGTH)->ShowWindow(SW_HIDE);
00205         GetDlgItem(IDC_STATIC_CFG_LENGTH)->SetWindowText("");
00206
00207         if (!s.isDppConnected) {
00208                 GetDlgItem(IDC_BUTTON_EDIT_CONFIG_FROM_HW)->EnableWindow(FALSE);
00209                 GetDlgItem(IDC_BUTTON_SEND_TO_HARDWARE)->EnableWindow(FALSE);
00210                 GetDlgItem(IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT)->EnableWindow(FALSE);
00211         }
00212     ReadAmptekDetectorConfigNames();
00213
00214         //if (s.profile->device_type == dppMCA8000D) {
00215         //      ShowMCA8000D_Controls(SW_HIDE);
00216         //} else {
00217         //      ShowMCA8000D_Controls(SW_SHOW);
00218         //}
00219 }
00220
00221 void CFilePage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00222 {
00223         int cboDP5CtrlID = cfg.ListCtrlID;
00224         CString strVal = cfg.Setting;
00225         int idxList;
00226
00227         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00228                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00229                 //idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00230                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00231                 if (idxList == LB_ERR) {
00232                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00233                 }
00234                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00235                         idxList = 0;                    // set to first item
00236                 }
00237                 cb.SetCurSel(idxList);
00238         }
00239 }
00240
00241 // pass dci id to update combo control and display edit controls if any
00242 void CFilePage::CboUpdate(int nID_dci)
00243 {
00244         CString strCboText;
00245         int nID;
00246
00247         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00248         if (nID == NULL) { return; }
00249         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00250         int idx = cb.GetCurSel();
00251         if (idx > LB_ERR) {
00252                 cb.GetLBText(idx,strCboText);
00253                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00254                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00255         } else {
00256                 return;
00257         }
00258         SetModified(TRUE);
00259 }
00260
00261 BOOL CALLBACK EnumChildControls(HWND hWnd, LPARAM lParam)
00262 {
00263      // Make sure window is valid
00264      if (hWnd && IsWindow(hWnd))
00265      {
00266           CWnd* pWnd = CWnd::FromHandle(hWnd);
00267           ASSERT_VALID(pWnd);
00268
00269           // Get the class name for the window
00270           TCHAR szClassName[100];
00271           GetClassName(hWnd, szClassName, 100);
00272                   int iStyle = GetWindowLong(hWnd, GWL_STYLE);
00273                   iStyle &= 0xF;
00274                   CString strControl;
00275           //TRACE(_T("Class Name: %s\n"), szClassName);
00276                   if (_tcscmp(_T("ComboBox"), szClassName) == 0) {
00277                                 CComboBox* pComboBox = (CComboBox*)pWnd;
00278                                 pComboBox->GetWindowText(strControl);
00279                                 //TRACE(_T("ComboBox: %s\n"), strControl);
00280                   } else
00281                   if (_tcscmp(_T("Edit"), szClassName) == 0) {
00282                                 CEdit* pEdit = (CEdit*)pWnd;
00283                                 pEdit->GetWindowText(strControl);
00284                                 //TRACE(_T("Edit: %s\n"), strControl);
00285                   } else
00286                   if (_tcscmp(_T("Static"), szClassName) == 0) {
00287                                 CStatic* pStatic = (CStatic*)pWnd;
00288                                 pStatic->GetWindowText(strControl);
00289                                 //TRACE(_T("Static: %s\n"), strControl);
00290                   } else
00291                   //if (_tcscmp(_T("ListBox"), szClassName) == 0) {
00292                   //    // don't use ListBox for options
00293                   //} else
00294                   if (_tcscmp(_T("Button"), szClassName) == 0) { // check button type controls
00295                           CButton* pButton = (CButton*)pWnd;
00296                         switch (iStyle) {
00297                                 case BS_CHECKBOX:
00298                                 case BS_AUTOCHECKBOX:
00299                                 case BS_3STATE:
00300                                 case BS_AUTO3STATE:
00301                                         //CHECKBOX
00302                                         break;
00303                                 case BS_RADIOBUTTON:
00304                                 case BS_AUTORADIOBUTTON:
00305                                         //RADIO
00306                                         break;
00307                                 case BS_GROUPBOX:
00308                                         //FRAME
00309                                         pButton->GetWindowText(strControl);
00310                                         //TRACE(_T("Frame: %s\n"), strControl);
00311                                         break;
00312                                 case BS_PUSHBUTTON:
00313                                 case BS_OWNERDRAW:
00314                                 case BS_DEFPUSHBUTTON:
00315                                         //BUTTON
00316                                         //pButton->GetWindowText(strButton);
00317                                         //TRACE(_T("Push Button: %s\n"), strButton);
00318                                         break;
00319                                 default:
00320                                         // not defined here
00321                                         break;
00322                         }
00323           }
00324      }
00325      return TRUE;
00326 }
00327
00328 void CFilePage::ReadConfig()
00329 {
00330         UpdateData(TRUE);
00331         CFileBrowse BR;
00332         CString strDfltExt;
00333         CIniUtil ciu;
00334         CString csData;
00335         CString csCmts;
00336
00337         CString sCurrentDir;
00338         CString strFilename;
00339         bool isTestApp;
00340
00341         s.CreateDP5Cfg();
00342         sCurrentDir = s.strHelpFilePath;
00343         sCurrentDir = sCurrentDir.Left(sCurrentDir.ReverseFind('\\'));
00344         strFilename = sCurrentDir + "\\DP5 Config.txt";
00345         DWORD dwAttr = GetFileAttributes((LPCTSTR)strFilename);
00346         if (dwAttr == 0xffffffff)               // test if test ini file exists
00347                 isTestApp = false;
00348         else
00349                 isTestApp = true;
00350         if (isTestApp)  {                               // read test profile path
00351                 m_strConfigIn = strFilename;
00352         } else {
00353                 strDfltExt = "txt";
00354                 if (BR.DoModal(BR.OPEN,
00355                                 "Open Configuration",
00356                                 BR.CfgFileFilter,
00357                                 strDfltExt,
00358                                 _T(""),
00359                                 &m_strConfigIn)) {
00360                 } else {
00361                         return;
00362                 }
00363         }
00364
00365                 //m_strConfigIn = "C:\\Projects\\DP5_PROTOCOL\\DppMCA\\DP5CfgTest.txt";
00366                 UpdateData(FALSE);
00367                 for (int idxCmd = DP5_CMD_MIN;idxCmd<=DP5_CMD_MAX;idxCmd++) {
00368                         csData = "";
00369                         csCmts = "";
00370                         if (ciu.GetDP5Data(m_strConfigIn,_T("DP5 Configuration File"),s.m_DP5Cfg[idxCmd].Command,&csData,&csCmts)) {
00371                                 s.m_DP5Cfg[idxCmd].Setting = csData;
00372                                 s.m_DP5Cfg[idxCmd].Comments = csCmts;
00373                         }
00374                         if ((s.m_DP5Cfg[idxCmd].CtrlType & HasTextCtrl) > 0) {
00375                                 csData = "";
00376                                 csCmts = "";
00377                                 if (ciu.GetDP5Data(m_strConfigIn,_T("DP5 Configuration Values"),s.m_DP5Cfg[idxCmd].Command,&csData,&csCmts)) {
00378                                         s.m_DP5Cfg[idxCmd].TextValue = csData;
00379                                         s.m_DP5Cfg[idxCmd].ValComments = csCmts;
00380                                 }
00381                         }
00382                         s.CtrlUtil.RemoveUnitsFromDecString(&s.m_DP5Cfg[idxCmd]);
00383                 }
00384                 s.HaveConfig = TRUE;
00385                 //GetDlgItem(IDC_BUTTON_FIND_COMMAND)->EnableWindow(TRUE);
00386                 s.ReloadCfg = TRUE;
00387                 CCfgPropSheet &pp = *(CCfgPropSheet *) this->GetSafeOwner();
00388                 pp.UpdateAll();
00389                 s.ReloadCfg = FALSE;
00390         //}
00391 }
00392
00393 void CFilePage::OnBnClickedButtonReadConfig()
00394 {
00395         UpdateData(TRUE);
00396         CFileBrowse BR;
00397         CString strDfltExt;
00398         CIniUtil ciu;
00399         CString csData;
00400         CString csCmts;
00401
00402         CString csDataVal;
00403         CString csCmtsVal;
00404
00405         CString strConfigName;
00406         strConfigName = "Configuration File";
00407
00408         strDfltExt = "txt";
00409         s.CreateDP5Cfg();
00410
00411         if (BR.DoModal(BR.OPEN,
00412                         "Open Configuration",
00413                         BR.CfgFileFilter,
00414                         strDfltExt,
00415                         _T(""),
00416                         &m_strConfigIn)) {
00417                 UpdateData(FALSE);
00418                 for (int idxCmd = DP5_CMD_MIN;idxCmd<=DP5_CMD_MAX;idxCmd++) {
00419                         //csData = "";
00420                         //csCmts = "";
00421                         if (ciu.GetDP5Data(m_strConfigIn,_T("DP5 Configuration File"),s.m_DP5Cfg[idxCmd].Command,&csData,&csCmts)) {
00422                                 if (csData.Find(";",0) >= 0) {
00423                                         csData = "";
00424                                 }
00425                                 s.m_DP5Cfg[idxCmd].Setting = csData;
00426                                 s.m_DP5Cfg[idxCmd].Comments = csCmts;
00427                         }
00428                         if (s.m_DP5Cfg[idxCmd].Command == "CLCK") {
00429                                 s.DppConfig.b80MHzModeCfg = FALSE;
00430                                 if (csData.Find("80",0) >= 0) {
00431                                         s.DppConfig.b80MHzModeCfg = TRUE;
00432                                 }
00433                         }
00434                         if ((s.m_DP5Cfg[idxCmd].CtrlType & HasTextCtrl) > 0) {
00435                                 csData = "";
00436                                 csCmts = "";
00437                                 if (ciu.GetDP5Data(m_strConfigIn,_T("DP5 Configuration Values"),s.m_DP5Cfg[idxCmd].Command,&csData,&csCmts)) {
00438                                         if (csData.Find(";",0) >= 0) {
00439                                                 csData = "";
00440                                         }
00441                                         s.m_DP5Cfg[idxCmd].TextValue = csData;
00442                                         s.m_DP5Cfg[idxCmd].ValComments = csCmts;
00443                                 }
00444                         }
00445                         s.CtrlUtil.RemoveUnitsFromDecString(&s.m_DP5Cfg[idxCmd]);
00446                 }
00447
00448                 if (s.SCAEnabled) {
00449                         s.sca.strIniFilename = m_strConfigIn;
00450                         s.scafn.GetSCASetupINI(&s.sca);
00451                         for(int iIndex=1; iIndex<=MAX_SCA_REGISTER; iIndex++) {
00452                                 s.scafn.GetSCASettingsINI(&s.sca, iIndex);
00453                         }
00454                 }
00455
00456                 s.HaveConfig = TRUE;
00457                 //GetDlgItem(IDC_BUTTON_FIND_COMMAND)->EnableWindow(TRUE);
00458                 s.ReloadCfg = TRUE;
00459                 CCfgPropSheet &pp = *(CCfgPropSheet *) this->GetSafeOwner();
00460                 pp.UpdateAll();
00461                 s.ReloadCfg = FALSE;
00462                 EnableControls(TRUE);
00463                 SetModified(TRUE);
00464
00465                 strConfigName = m_strConfigIn.Mid(m_strConfigIn.ReverseFind('\\'));
00466                 GetDlgItem(IDC_STATIC_CONFIG_NAME)->SetWindowText(strConfigName);
00467         }
00468 }
00469
00470 void CFilePage::ReadConfigFromAmptek_NP(CString strFilename, CString strKeyName)
00471 {
00472         UpdateData(TRUE);
00473         CString strFilter;
00474         CString strDfltExt;
00475         CIniUtil ciu;
00476         CString csData;
00477         CString csCmts;
00478
00479         CString csDataVal;
00480         CString csCmtsVal;
00481
00482         strFilter = "Text Files (*.txt)|*.txt|DP5 Setup Files (*.dp5)|*.dp5|All Files (*.*)|*.*||";
00483         strDfltExt = "txt";
00484         s.CreateDP5Cfg();
00485
00486         ciu.ini.setINIFileName(strFilename);
00487         BOOL bExists = ciu.ini.sectionExists("DP5 Configuration File");
00488         if(!bExists) {  // no configuration file or configuratiion section is missing
00489                 return;
00490         } else {
00491                 m_strConfigIn = strFilename;
00492                 UpdateData(FALSE);
00493                 for (int idxCmd = DP5_CMD_MIN;idxCmd<=DP5_CMD_MAX;idxCmd++) {
00494                         //csData = "";
00495                         //csCmts = "";
00496                         if (ciu.GetDP5Data(m_strConfigIn,_T("DP5 Configuration File"),s.m_DP5Cfg[idxCmd].Command,&csData,&csCmts)) {
00497                                 if (csData.Find(";",0) >= 0) {
00498                                         csData = "";
00499                                 }
00500                                 s.m_DP5Cfg[idxCmd].Setting = csData;
00501                                 s.m_DP5Cfg[idxCmd].Comments = csCmts;
00502                         }
00503                         if (s.m_DP5Cfg[idxCmd].Command == "CLCK") {
00504                                 s.DppConfig.b80MHzModeCfg = FALSE;
00505                                 if (csData.Find("80",0) >= 0) {
00506                                         s.DppConfig.b80MHzModeCfg = TRUE;
00507                                 }
00508                         }
00509
00510                         if ((s.m_DP5Cfg[idxCmd].CtrlType & HasTextCtrl) > 0) {
00511                                 csData = "";
00512                                 csCmts = "";
00513                                 if (ciu.GetDP5Data(m_strConfigIn,_T("DP5 Configuration Values"),s.m_DP5Cfg[idxCmd].Command,&csData,&csCmts)) {
00514                                         if (csData.Find(";",0) >= 0) {
00515                                                 csData = "";
00516                                         }
00517                                         s.m_DP5Cfg[idxCmd].TextValue = csData;
00518                                         s.m_DP5Cfg[idxCmd].ValComments = csCmts;
00519                                 }
00520                         }
00521                         s.CtrlUtil.RemoveUnitsFromDecString(&s.m_DP5Cfg[idxCmd]);
00522                 }
00523                 s.HaveConfig = TRUE;
00524                 //GetDlgItem(IDC_BUTTON_FIND_COMMAND)->EnableWindow(TRUE);
00525                 s.ReloadCfg = TRUE;
00526                 CCfgPropSheet &pp = *(CCfgPropSheet *) this->GetSafeOwner();
00527                 pp.UpdateAll();
00528                 s.ReloadCfg = FALSE;
00529                 EnableControls(TRUE);
00530                 SetModified(TRUE);
00531                 GetDlgItem(IDC_STATIC_CONFIG_NAME)->SetWindowText(strKeyName);
00532         }
00533 }
00534
00535 //void CFilePage::OnBnClickedButtonFindCommand()
00536 //{
00537 //      UINT NewActivePage;
00538 //      int nPage;
00539 //      s.FindCommand = TRUE;
00540 //      s.FindCtrlID = IDC_OPT_COMBO_DACO;
00541 //      NewActivePage = ID_MISC_TAB;
00542 //      nPage = 5;
00543 //      CCfgPropSheet &pp = *(CCfgPropSheet *) this->GetSafeOwner();
00544 //      pp.OnSelectTab(NewActivePage, nPage);
00545 //}
00546
00547
00548 void CFilePage::OnBnClickedButtonSaveConfig()
00549 {
00550         UpdateData(TRUE);
00551         CFileBrowse BR;
00552         CString strDfltExt;
00553         CIniUtil ciu;
00554         CString csData;
00555         CString csCmts;
00556         int idxReOrderCmd;
00557         int idxCmd;
00558
00559         strDfltExt = "txt";
00560         if (BR.DoModal(BR.SAVE,
00561                         "Save Configuration",
00562                         BR.CfgFileFilter,
00563                         strDfltExt,
00564                         _T(""),
00565                         &m_strConfigOut)) {
00566                 UpdateData(FALSE);
00567                 for (idxCmd = DP5_CMD_MIN;idxCmd<=DP5_CMD_MAX;idxCmd++) {
00568                         idxReOrderCmd = s.CtrlUtil.OrderOut(idxCmd);
00569                         s.CtrlUtil.UpdateSetting(&s.m_DP5Cfg[idxReOrderCmd]);                   // process setting
00570                         csData = s.m_DP5Cfg[idxReOrderCmd].Setting;
00571                         csCmts = s.m_DP5Cfg[idxReOrderCmd].Comments;
00572                         if (csData.Find(";",0) >= 0) {
00573                                 csData = "";
00574                         }
00575                         //if (s.m_DP5Cfg[idxReOrderCmd].Command.GetLength() > 0) {
00576                                 if (ciu.SaveDP5Data(m_strConfigOut,_T("DP5 Configuration File"),s.m_DP5Cfg[idxReOrderCmd].Command,csData,csCmts)) {
00577                                         // get last error here
00578                                 }
00579                                 if ((s.m_DP5Cfg[idxReOrderCmd].CtrlType & dctTxt) > 0) {                // has text value
00580                                         csData = s.CtrlUtil.GetValueWithUnitsString(s.m_DP5Cfg[idxReOrderCmd]);
00581                                         csCmts = s.m_DP5Cfg[idxReOrderCmd].ValComments;
00582                                         if (csData.Find(";",0) >= 0) {
00583                                                 csData = "";
00584                                         }
00585                                         if (ciu.SaveDP5Data(m_strConfigOut,_T("DP5 Configuration Values"),s.m_DP5Cfg[idxReOrderCmd].Command,csData,csCmts)) {
00586                                                 // get last error here
00587                                         }
00588                                 }
00589                         //}
00590                 }
00591                 if (s.SCAEnabled) {
00592                         s.sca.strIniFilename = m_strConfigOut;
00593                         s.scafn.SaveSCASetupINI(s.sca);
00594                         for(int iIndex=1; iIndex<=MAX_SCA_REGISTER; iIndex++) {
00595                                 s.scafn.SaveSCASettingsINI(s.sca, iIndex);
00596                         }
00597                 }
00598         }
00599 }
00600
00601 //============================================================
00602 CString CFilePage::SaveConfigString()
00603 {
00604         UpdateData(TRUE);
00605         CString csCmd;
00606         CString csData;
00607         int idxReOrderCmd;
00608         int idxCmd;
00609         CString strDP5Cfg;
00610
00611         strDP5Cfg = "";
00612         UpdateData(FALSE);
00613         for (idxCmd = DP5_CMD_MIN;idxCmd<=DP5_CMD_MAX;idxCmd++) {
00614                 idxReOrderCmd = s.CtrlUtil.OrderOut(idxCmd);
00615                 s.CtrlUtil.UpdateSetting(&s.m_DP5Cfg[idxReOrderCmd]);                   // process setting
00616                 csCmd = s.m_DP5Cfg[idxReOrderCmd].Command;
00617                 csData = s.m_DP5Cfg[idxReOrderCmd].Setting;
00618                 if ((csData.GetLength()>0) && (csData != ";")) {
00619                         strDP5Cfg += csCmd;
00620                         strDP5Cfg += "=";
00621                         strDP5Cfg += csData;
00622                         strDP5Cfg += ";";
00623                 }
00624         }
00625         return strDP5Cfg;
00626 }
00627 //============================================================
00628
00629 CString CFilePage::GetCmdKeyData(CString strCmd, CString strCfgData)
00630 {
00631         int iStart,iEnd,iCmd;
00632         CString strCmdData;
00633
00634         strCmdData = "";
00635         if (strCfgData.GetLength() < 7) { return strCmdData; }  // no data
00636         if (strCmd.GetLength() != 4) {  return strCmdData; }            // bad command
00637         iCmd = strCfgData.Find(strCmd+"=",0);
00638         if (iCmd == -1) { return strCmdData; }                  // cmd not found
00639         iStart = strCfgData.Find("=",iCmd);
00640         if (iStart == -1) { return strCmdData; }                // data start not found
00641         iEnd = strCfgData.Find(";",iCmd);
00642         if (iEnd == -1) {return strCmdData; }                   // data end found
00643         if (iStart >= iEnd) { return strCmdData; }              // data error
00644         strCmdData = strCfgData.Mid(iStart+1,(iEnd - (iStart+1)));
00645         //AfxMessageBox(strCmdData);
00646         return strCmdData;
00647 }
00648
00649 void CFilePage::OnBnClickedButtonEditConfigFromHw()
00650 {
00651         cWaitDialog dlg;
00652         CString strWait;
00653         CString strReady;
00654         CStringArray cChar;
00655         CMSecTimer tmr;
00656         int numTries = 7;
00657
00658         s.HwCfgReady = FALSE;
00659         s.HwCfgExReady = FALSE;
00660         ::SendMessage(s.hWnd_Main,WM_USER_READ_DPP_CONFIG,0L,0L);
00661
00662         tmr.msTimer(500);
00663
00664         cChar.Add("-");
00665         cChar.Add("\\");
00666         cChar.Add("|");
00667         cChar.Add("/");
00668         cChar.Add("-");
00669         cChar.Add("\\");
00670         cChar.Add("|");
00671         cChar.Add("/");
00672
00673         cChar.Add("-");
00674         cChar.Add("\\");
00675         cChar.Add("|");
00676         cChar.Add("/");
00677         cChar.Add("-");
00678         cChar.Add("\\");
00679         cChar.Add("|");
00680         cChar.Add("/");
00681
00682         cChar.Add("-");
00683         cChar.Add("\\");
00684         cChar.Add("|");
00685         cChar.Add("/");
00686         cChar.Add("-");
00687         cChar.Add("\\");
00688         cChar.Add("|");
00689         cChar.Add("/");
00690
00691         cChar.Add("-");
00692         cChar.Add("\\");
00693         cChar.Add("|");
00694         cChar.Add("/");
00695         cChar.Add("-");
00696         cChar.Add("\\");
00697         cChar.Add("|");
00698         cChar.Add("/");
00699
00700         for (int idxWait=0;idxWait<numTries;idxWait++) {
00701                 strWait.Format(" %d ",idxWait);
00702                 strReady.Format(" %d ",s.HwCfgReady);
00703                 dlg.m_Text = "Reading...please wait" + strWait + cChar[idxWait];  + " " + strReady;
00704                 if (isClosing) {
00705                         idxWait = numTries;
00706                         EnableControls(TRUE);
00707                         return;
00708                 }
00709                 dlg.Show();
00710                 tmr.msTimer(500);
00711                 dlg.Close();
00712                 UpdateData(FALSE);
00713                 if (isClosing) {
00714                         idxWait = numTries;
00715                         EnableControls(TRUE);
00716                         return;
00717                 }
00718                 if (s.HwCfgReady) {
00719                         idxWait = numTries;
00720                 } else if (((idxWait + 1)%3) == 0) {
00721                         ::SendMessage(s.hWnd_Main,WM_USER_READ_DPP_CONFIG,0L,0L);
00722                         tmr.msTimer(500);
00723                 }
00724                 if (isClosing) {
00725                         idxWait = numTries;
00726                         EnableControls(TRUE);
00727                         return;
00728                 }
00729         }
00730         if (!s.HwCfgReady) {
00731                 //AfxMessageBox("Hardware configuration not read. Please try again.");
00732                 EnableControls(TRUE);
00733                 return;
00734         }
00735
00736         CString csData;
00737         s.CreateDP5Cfg();
00738         UpdateData(FALSE);
00739         for (int idxCmd = DP5_CMD_MIN;idxCmd<=DP5_CMD_MAX;idxCmd++) {
00740                 csData = "";
00741                 csData = GetCmdKeyData(s.m_DP5Cfg[idxCmd].Command, s.HwCfgDP5);
00742                 if (csData.GetLength() > 0) {
00743                         s.m_DP5Cfg[idxCmd].Setting = csData;
00744                         s.m_DP5Cfg[idxCmd].Comments = "";
00745                 }
00746
00747                 if (s.m_DP5Cfg[idxCmd].Command == "CLCK") {
00748                         s.DppConfig.b80MHzModeCfg = FALSE;
00749                         if (csData.Find("80",0) >= 0) {
00750                                 s.DppConfig.b80MHzModeCfg = TRUE;
00751                         }
00752                 }
00753                 s.CtrlUtil.RemoveUnitsFromDecString(&s.m_DP5Cfg[idxCmd]);
00754         }
00755
00756         // have config update from hardware, if using scas, update sca data structure too
00757         if (s.SCAEnabled) {
00758                 s.sca.HaveScaUpdate = FALSE;
00759                 s.HwCfgReady = FALSE;
00760                 ::SendMessage(s.hWnd_Main,WM_USER_READ_SCA_CONFIG,0L,0L);
00761                 tmr.msTimer(500);
00762                 if (s.HwCfgReady == TRUE) {
00763                         s.sca.HaveScaUpdate = TRUE;
00764                         //AfxMessageBox(s.scafn.SCAStringALLDisplay(s.sca));
00765                 } else { // try one more time
00766                         s.HwCfgReady = FALSE;
00767                         ::SendMessage(s.hWnd_Main,WM_USER_READ_SCA_CONFIG,0L,0L);
00768                         tmr.msTimer(500);
00769                         if (s.HwCfgReady == TRUE) {
00770                                 s.sca.HaveScaUpdate = TRUE;
00771                         }
00772                 }
00773                 if (!s.sca.HaveScaUpdate) {
00774                         EnableControls(TRUE);
00775                         return;
00776                 }
00777         }
00778
00779         s.HaveConfig = TRUE;
00780         //GetDlgItem(IDC_BUTTON_FIND_COMMAND)->EnableWindow(TRUE);
00781         s.ReloadCfg = TRUE;
00782         CCfgPropSheet &pp = *(CCfgPropSheet *) this->GetSafeOwner();
00783         pp.UpdateAll();
00784         s.ReloadCfg = FALSE;
00785         EnableControls(TRUE);
00786         SetModified(FALSE);
00787         GetDlgItem(IDC_STATIC_CONFIG_NAME)->SetWindowText("Hardware Configuration");
00788 }
00789
00790 void CFilePage::OnBnClickedButtonSendToHardware()
00791 {
00792         CMSecTimer tmr;
00793         CString strCfgMFC("");
00794         std::string strCfg("");
00795         bool isPC5Present=false;                        //Needed to remove pc5 commands
00796         int DppType=0;                                          //Needed to remove
00797         CAsciiCmdUtilities AsciiCmdUtil;        //ASCII command utility library
00798         long lCfgLen=0;                                         //ASCII Configuration Command String Length
00799         int idxSplitCfg=0;                                      //Configuration split position, only if necessary
00800         bool bSplitCfg=false;                           //Configuration split flag
00801         std::string strSplitCfg("");            //Configuration split string second buffer
00802         bool isDP5_RevDxGains;
00803         unsigned char DPP_ECO;
00804         BOOL isDP5_DxK=false;                           //DP5 Rev Dx config K needs PAPZ (not removed, *special case)
00805         BOOL isDP5_DxL=false;                           //DP5 Rev Dx config L needs PAPZ (not removed, *special case)
00806
00807         DppType = s.profile->device_type;
00808         isPC5Present = (bool)(!(s.DP5Stat.m_DP5_Status.PC5_PRESENT == 0));
00809         isDP5_RevDxGains = s.DP5Stat.m_DP5_Status.isDP5_RevDxGains;
00810         DPP_ECO = s.DP5Stat.m_DP5_Status.DPP_ECO;
00811
00812         s.HwCfgReady = FALSE;
00813         s.HwCfgExReady = FALSE;
00814         s.HwCfgDP5Out = "";
00815         strCfgMFC = SaveConfigString();
00816         strCfg = strCfgMFC;
00817
00818         // Configuration Oversize Fix 20141224
00819         // The hardware cannot handle ASCII Configurations Larger than 512 Bytes
00820         // The original solution was to separately send the SCA Commands
00821         // Now the number of command excluding SCA command may exceed 512 Bytes
00822         // New methods of controlling the size of the cfg string are needed
00823
00824         //      1. Run the RemoveCmdByDeviceType here (is also in CSendCommand::WM_USER_SEND_CONFIG_TO_HW)
00825         //              --> RemoveCmdByDeviceType is done here to accurately measure size.
00826         //      2. Measure final ASCII cfg string size
00827
00828         if ((DppType == dppDP5) && s.DP5Stat.m_DP5_Status.isDP5_RevDxGains) {
00829                 if ((s.DP5Stat.m_DP5_Status.DPP_ECO & 0x0F) == 0x0A) {
00830                         isDP5_DxK = true;
00831                 }
00832                 if ((s.DP5Stat.m_DP5_Status.DPP_ECO & 0x0F) == 0x0B) {
00833                         isDP5_DxL = true;
00834                 }
00835         }
00836         if (isDP5_DxK || isDP5_DxL) {           // keeps PAPZ for DP5 DxK/DxL
00837                 strCfg = AsciiCmdUtil.RemoveCmdByDeviceTypeDP5DxK(strCfg, isPC5Present, DppType);
00838         } else {
00839                 strCfg = AsciiCmdUtil.RemoveCmdByDeviceType(strCfg, isPC5Present, DppType, isDP5_RevDxGains, DPP_ECO);
00840         }
00841         lCfgLen = (long)strCfg.length();        //Test configuration size
00842
00843         //      3. If needed shorten cmds, ReMeasure final ASCII cfg string size
00844         if (lCfgLen > 512) {            //configuration is too large, try to reduce
00845         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "US;", ";");
00846         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "OFF;", "OF;");
00847         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "RISING;", "RI;");
00848         strCfg = AsciiCmdUtil.ReplaceCmdText(strCfg, "FALLING;", "FA;");
00849         lCfgLen = (long)strCfg.length();        //Test configuration size
00850                 //      4. If needed split cmd string, send cfg in two blocks
00851                 if (lCfgLen > 512) {    //configuration is still too large, split cfg
00852             bSplitCfg = true;
00853             idxSplitCfg = AsciiCmdUtil.GetCmdChunk(strCfg);
00854             strSplitCfg = strCfg.substr(idxSplitCfg);
00855                         strCfg = strCfg.substr(0, idxSplitCfg);
00856                 }
00857         }
00858
00859         strCfgMFC = strCfg.c_str();
00860         s.HwCfgDP5Out = strCfgMFC;
00861         if (s.HwCfgDP5Out.GetLength() >0 ) {
00862                 s.HwCfgReady = TRUE;                    // filter out messages by device, gain, and option types
00863                 ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
00864         }
00865
00866         if (bSplitCfg) {
00867                 tmr.msTimer(500);
00868                 s.HwCfgReady = FALSE;
00869                 s.HwCfgExReady = FALSE;
00870                 strCfgMFC = strSplitCfg.c_str();
00871                 s.HwCfgDP5Out = strCfgMFC;
00872                 if (s.HwCfgDP5Out.GetLength() >0 ) {
00873                         s.HwCfgReady = TRUE;                    // filter out messages by device, gain, and option types
00874                         ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
00875                 }
00876         }
00877
00878         if (s.SCAEnabled) {
00879                 tmr.msTimer(500);
00880                 s.HwCfgReady = FALSE;
00881                 s.HwCfgExReady = FALSE;
00882                 s.HwCfgDP5Out = s.scafn.SCAStringALL(s.sca, TRUE);
00883                 if (s.HwCfgDP5Out.GetLength() >0 ) {
00884                         s.HwCfgExReady = TRUE;          // bypass command filters for scas
00885                         ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
00886                 }
00887         }
00888 }
00889
00890 BOOL CFilePage::PreTranslateMessage(MSG* pMsg)
00891 {
00892         // TODO: Add your specialized code here and/or call the base class
00893
00894         //==================================================================
00895         if ( pMsg->message == WM_KEYDOWN && pMsg->wParam == VK_RETURN ) {
00896                 CWnd* pCurrent= GetFocus();
00897                 int ctrl = pCurrent->GetDlgCtrlID();
00898                 //if (ctrl == IDC_OPT_TEXT_MCST) {
00899                 if (isCEditBox(ctrl)) {
00900                         if (ctrl==IDC_EDIT_SEND_COMMAND) {
00901                                 OnBnClickedButtonSendCommand();
00902                         } else {
00903                                 ::SendMessage(this->m_hWnd, WM_COMMAND, MAKEWPARAM(ctrl, EN_CHANGE), (LPARAM) m_hWnd);
00904                                 CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00905                                 pMsg->wParam = VK_TAB;
00906                                 //if ( pNext != NULL ) {
00907                                 //      if (pNext->GetDlgCtrlID() != IDOK ) {
00908                                 //              pNext->SetFocus();
00909                                 //              return TRUE;
00910                                 //      }
00911                                 //}
00912                         }
00913                 } else if (isCComboBox(ctrl)) {
00914                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00915                         pMsg->wParam = VK_TAB;
00916                 }
00917         }
00918
00919         //==================================================================
00920         return CCfgPropPage::PreTranslateMessage(pMsg);
00921 }
00922
00923 BOOL CFilePage::isCEditBox(int nID)
00924 {
00925         BOOL isEdit = FALSE;
00926         switch (nID) {
00927                 case IDC_EDIT_SEND_COMMAND:
00928                         isEdit = TRUE;
00929                         break;
00930                 default:
00931                         isEdit = FALSE;
00932                         break;
00933         }
00934         return isEdit;
00935 }
00936
00937 BOOL CFilePage::isCComboBox(int nID)
00938 {
00939         BOOL isCombo = FALSE;
00940         switch (nID) {
00941                 case IDC_OPT_COMBO_RESC:
00942                         isCombo = TRUE;
00943                         break;
00944         }
00945         return isCombo;
00946 }
00947
00948 void CFilePage::OnCbnSelchangeOptComboResc()
00949 {
00950         CboUpdate(dciRESC);
00951 }
00952
00953 void CFilePage::OnTimer(UINT nIDEvent)
00954 {
00955         // TODO: Add your message handler code here and/or call default
00956         KillTimer(m_nTmrConfigId);
00957         if (s.isDppConnected) {
00958                 OnBnClickedButtonEditConfigFromHw();
00959         }
00960         CCfgPropPage::OnTimer(nIDEvent);
00961 }
00962
00963 BOOL CFilePage::OnApply()
00964 {
00965         // TODO: Add your specialized code here and/or call the base class
00966         isClosing = TRUE;
00967         if (s.isDppConnected) {
00968                 OnBnClickedButtonSendToHardware();
00969         }
00970         return CCfgPropPage::OnApply();
00971 }
00972
00973 void CFilePage::OnCancel()
00974 {
00975         // TODO: Add your specialized code here and/or call the base class
00976         isClosing = TRUE;
00977         CCfgPropPage::OnCancel();
00978 }
00979
00980 void CFilePage::EnableControls(BOOL bEnable)
00981 {
00982         GetDlgItem(IDC_STATIC_FILE_PAGE)->EnableWindow(bEnable);
00983         GetDlgItem(IDC_OPT_FRAME_RESC)->EnableWindow(bEnable);
00984         GetDlgItem(IDC_OPT_COMBO_RESC)->EnableWindow(bEnable);
00985         GetDlgItem(IDC_BUTTON_READ_CONFIG)->EnableWindow(bEnable);
00986         GetDlgItem(IDC_BUTTON_SAVE_CONFIG)->EnableWindow(bEnable);
00987         GetDlgItem(IDC_BUTTON_EDIT_CONFIG_FROM_HW)->EnableWindow(bEnable);
00988         GetDlgItem(IDC_BUTTON_SEND_TO_HARDWARE)->EnableWindow(bEnable);
00989         GetDlgItem(IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT)->EnableWindow(bEnable);
00990         //GetDlgItem(IDC_READDETECTORCONFIGCOMBO)->EnableWindow(bEnable);
00991
00992         if (!s.isDppConnected) {
00993                 GetDlgItem(IDC_BUTTON_EDIT_CONFIG_FROM_HW)->EnableWindow(FALSE);
00994                 GetDlgItem(IDC_BUTTON_SEND_TO_HARDWARE)->EnableWindow(FALSE);
00995                 GetDlgItem(IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT)->EnableWindow(FALSE);
00996         }
00997 }
00998
00999 void CFilePage::OnBnClickedButtonSendToHardwareNoEdit()
01000 {
01001         CFileBrowse BR;
01002         CString strDfltExt;
01003         CIniUtil ciu;
01004         CString cstCfg;
01005         CString m_strConfigInNoEdit;
01006         CStringList m_strListDP5section;
01007         CString strCmdLen;
01008
01009         strDfltExt = "txt";
01010
01011         s.HwCfgReady = FALSE;
01012         s.HwCfgExReady = FALSE;
01013         s.HwCfgDP5Out = "";
01014         if (BR.DoModal(BR.OPEN,
01015                         "Open Configuration",
01016                         BR.CfgFileFilter,
01017                         strDfltExt,
01018                         _T(""),
01019                         &m_strConfigInNoEdit)) {
01020                 if (ciu.GetDP5Section(m_strConfigInNoEdit, _T("DP5 Configuration File"), &m_strListDP5section)) {
01021                         cstCfg = ciu.ConvertCmdListToCString(&m_strListDP5section,FALSE,TRUE);
01022                         if (cstCfg != "") {
01023                                 s.HwCfgDP5Out = cstCfg;
01024                                 strCmdLen.Format("%d",cstCfg.GetLength());
01025                                 s.HaveConfig = TRUE;
01026                                 if (s.HwCfgDP5Out.GetLength() >0 ) {
01027                                         s.HwCfgReady = TRUE;
01028                                         ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
01029                                 }
01030                                 cstCfg = ciu.ConvertCmdListToCString(&m_strListDP5section,TRUE,TRUE);
01031                                 GetDlgItem(IDC_EDIT_HW_CFG_SECTION)->SetWindowText(cstCfg);
01032                                 GetDlgItem(IDC_STATIC_CFG_LEN_LABEL)->ShowWindow(SW_SHOW);
01033                                 GetDlgItem(IDC_STATIC_CFG_LENGTH)->ShowWindow(SW_SHOW);
01034                                 GetDlgItem(IDC_STATIC_CFG_LENGTH)->SetWindowText(strCmdLen);
01035                         }
01036                 }
01037         }
01038 }
01039
01040 // dp5
01041 void CFilePage::OnBnClickedRadioDppDeviceType1()
01042 {
01043         SelectRadioDppDeviceType(dppDP5);
01044         ReadAmptekDetectorConfigNames();                // load amptek configurations from AmptekDC_NP.ini
01045 }
01046
01047 //px5
01048 void CFilePage::OnBnClickedRadioDppDeviceType2()
01049 {
01050         SelectRadioDppDeviceType(dppPX5);
01051         ReadAmptekDetectorConfigNames();                // load amptek configurations from AmptekDC_NP.ini
01052 }
01053
01054 //dp5g
01055 void CFilePage::OnBnClickedRadioDppDeviceType3()
01056 {
01057         SelectRadioDppDeviceType(dppDP5G);
01058         ReadAmptekDetectorConfigNames();                // load amptek configurations from AmptekDC_NP.ini
01059 }
01060
01061 //mca8000d
01062 void CFilePage::OnBnClickedRadioDppDeviceType4()
01063 {
01064         SelectRadioDppDeviceType(dppMCA8000D);
01065         ReadAmptekDetectorConfigNames();                // load amptek configurations from AmptekDC_NP.ini
01066 }
01067
01068 //tb5
01069 void CFilePage::OnBnClickedRadioDppDeviceType5()
01070 {
01071         SelectRadioDppDeviceType(dppTB5);
01072         ReadAmptekDetectorConfigNames();                // load amptek configurations from AmptekDC_NP.ini
01073 }
01074
01075 // dp5x
01076 void CFilePage::OnBnClickedRadioDppDeviceType6()
01077 {
01078         SelectRadioDppDeviceType(dppDP5X);
01079         ReadAmptekDetectorConfigNames();                // load amptek configurations from AmptekDC_NP.ini
01080 }
01081
01082 void CFilePage::SetDppDeviceType(int DeviceType)
01083 {
01084         s.profile->device_type = DeviceType;
01085         s.DppConfig.DeviceType = DeviceType;
01086         s.profile->strDevice = s.GetDeviceNameFromVal(DeviceType);
01087         SetCheckPc5Present();
01088         SetCheckDP5DxGains();
01089 }
01090
01091 void CFilePage::SelectRadioDppDeviceType(int DeviceType)
01092 {
01093         if (DeviceType == dppDP5) {
01094                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE1);
01095                 SetDppDeviceType(dppDP5);
01096         } else if (DeviceType == dppPX5) {
01097                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE2);
01098                 SetDppDeviceType(dppPX5);
01099         } else if (DeviceType == dppDP5G) {
01100                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE3);
01101                 SetDppDeviceType(dppDP5G);
01102         } else if (DeviceType == dppMCA8000D) {
01103                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE4);
01104                 SetDppDeviceType(dppMCA8000D);
01105         } else if (DeviceType == dppTB5) {
01106                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE5);
01107                 SetDppDeviceType(dppTB5);
01108         } else if (DeviceType == dppDP5X) {
01109                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE6);
01110                 SetDppDeviceType(dppDP5X);
01111         } else {
01112                 CheckRadioButton(IDC_RADIO_DPP_DEVICE_TYPE1, IDC_RADIO_DPP_DEVICE_TYPE6, IDC_RADIO_DPP_DEVICE_TYPE1);
01113                 SetDppDeviceType(dppDP5);
01114         }
01115 }
01116
01117 void CFilePage::EnableDeviceSelection(BOOL bEnable)
01118 {
01119         GetDlgItem(IDC_RADIO_DPP_DEVICE_TYPE1)->EnableWindow(bEnable);
01120         GetDlgItem(IDC_RADIO_DPP_DEVICE_TYPE2)->EnableWindow(bEnable);
01121         GetDlgItem(IDC_RADIO_DPP_DEVICE_TYPE3)->EnableWindow(bEnable);
01122         GetDlgItem(IDC_RADIO_DPP_DEVICE_TYPE4)->EnableWindow(bEnable);
01123         GetDlgItem(IDC_RADIO_DPP_DEVICE_TYPE5)->EnableWindow(bEnable);
01124         GetDlgItem(IDC_RADIO_DPP_DEVICE_TYPE6)->EnableWindow(bEnable);
01125         GetDlgItem(IDC_STATIC_DPP_DEVICE_TYPE)->EnableWindow(bEnable);
01126 }
01127
01128 CString CFilePage::GetAmptekDC_NP_Section()
01129 {
01130         CString strDeviceType("");
01131         //strDeviceType = "Amptek Detector Configurations";
01132         switch (s.profile->device_type) {
01133                 case dppDP5:
01134                         strDeviceType = "Amptek Detector Configurations DP5";
01135                         break;
01136                 case dppPX5:
01137                         strDeviceType = "Amptek Detector Configurations PX5";
01138                         break;
01139                 case dppDP5G:
01140                         strDeviceType = "Amptek Detector Configurations DP5G";
01141                         break;
01142                 case dppMCA8000D:
01143                         strDeviceType = "Amptek Detector Configurations MCA8000D";
01144                         break;
01145                 case dppTB5:
01146                         strDeviceType = "Amptek Detector Configurations TB5";
01147                         break;
01148                 case dppDP5X:
01149                         strDeviceType = "Amptek Detector Configurations DP5-X";
01150                         break;
01151                 default:
01152                         strDeviceType = "Amptek Detector Configurations";
01153                         break;
01154         }
01155         return strDeviceType;
01156 }
01157 void CFilePage::OnCbnSelchangeReaddetectorconfigcombo()
01158 {
01159         CString strSection;
01160         CString strKeyName;
01161         CString strKeyValue;
01162
01163     CIniUtil ciu;
01164         CString filename;
01165         CString sCurrentDir = theApp.m_pszHelpFilePath;
01166         sCurrentDir = sCurrentDir.Left(sCurrentDir.ReverseFind('\\'));
01167         filename = sCurrentDir + "\\AmptekDC_NP.ini";
01168         ciu.ini.setINIFileName(filename);
01169         m_ReadDetectorConfigCombo.GetWindowText(strKeyName);
01170         strSection = GetAmptekDC_NP_Section();
01171         strKeyValue = ciu.ini.getKeyValue(strKeyName,strSection);
01172         filename = sCurrentDir + "\\" + strKeyValue;
01173         ReadConfigFromAmptek_NP(filename,strKeyName);
01174 }
01175
01176 void CFilePage::ReadAmptekDetectorConfigNames()
01177 {
01178         CString strSection;
01179     CIniUtil ciu;
01180         CString filename;
01181         CString sCurrentDir = theApp.m_pszHelpFilePath;
01182         sCurrentDir = sCurrentDir.Left(sCurrentDir.ReverseFind('\\'));
01183         filename = sCurrentDir + "\\AmptekDC_NP.ini";
01184         ciu.ini.setINIFileName(filename);
01185     m_ReadDetectorConfigCombo.ResetContent();
01186         strSection = GetAmptekDC_NP_Section();
01187         BOOL bExists = ciu.ini.sectionExists(strSection);
01188
01189         if(!bExists)
01190         {
01191                 //AfxMessageBox("Amptek Configuration By Detector Data Load Error");
01192                 GetDlgItem(IDC_READDETECTORCONFIGCOMBO)->ShowWindow(SW_HIDE);
01193                 return;
01194         }
01195
01196         //load listbox from collection returned from getSectionData(sectionname)
01197         CStringList* DetCfgFileList = ciu.ini.getSectionData(strSection);
01198
01199         POSITION position;
01200
01201         CString strKey;
01202         int EqPos;
01203         for(position = DetCfgFileList->GetHeadPosition(); position != NULL; )
01204         {
01205                 strKey = DetCfgFileList->GetNext(position);
01206                 EqPos = strKey.Find("=",0);
01207                 strKey = strKey.Left(EqPos);
01208                 m_ReadDetectorConfigCombo.AddString(strKey);
01209         }
01210
01211 }
01212
01213 void CFilePage::OnCbnSelendokReaddetectorconfigcombo()
01214 {
01215         CString CfgName;
01216         m_ReadDetectorConfigCombo.GetWindowText(CfgName);
01217         //AfxMessageBox(CfgName);
01218 }
01219
01220 void CFilePage::OnBnClickedCheckPc5Present()
01221 {
01222         CButton *chkPresent;
01223         if ((!s.isDppConnected) && (s.profile->device_type == dppDP5)) {
01224                 chkPresent = (CButton *)GetDlgItem(IDC_CHECK_PC5_PRESENT);
01225                 // this assignment is for bool PC5_PRESENT (standard C++ vars)
01226                 s.DP5Stat.m_DP5_Status.PC5_PRESENT = (chkPresent->GetCheck() == BST_CHECKED);
01227                 // this assignment is for BOOL PC5_PRESENT (MFC vars)
01228                 //s.DP5Stat.m_DP5_Status.PC5_PRESENT = (BOOL)chkPresent->GetCheck();
01229         } else {
01230                 GetDlgItem(IDC_CHECK_PC5_PRESENT)->ShowWindow(SW_HIDE);
01231         }
01232 }
01233
01234 void CFilePage::SetCheckPc5Present()
01235 {
01236         CButton *chkPresent;
01237         BOOL isPC5Present;
01238         if ((!s.isDppConnected) && (s.profile->device_type == dppDP5)) {
01239                 GetDlgItem(IDC_CHECK_PC5_PRESENT)->ShowWindow(SW_SHOW);
01240                 chkPresent = (CButton *)GetDlgItem(IDC_CHECK_PC5_PRESENT);
01241                 isPC5Present = s.DP5Stat.m_DP5_Status.PC5_PRESENT;
01242                 chkPresent->SetCheck(isPC5Present);
01243         } else {
01244                 // PC5_PRESENT should always be set for DP5X
01245                 if ((!s.isDppConnected) && (s.profile->device_type == dppDP5X)) {
01246                         s.DP5Stat.m_DP5_Status.PC5_PRESENT = true;
01247                 }
01248                 GetDlgItem(IDC_CHECK_PC5_PRESENT)->ShowWindow(SW_HIDE);
01249         }
01250 }
01251
01253 //if ((s.profile->device_type == dppDP5) && (s.DP5Stat.m_DP5_Status.isDP5_RevDxGains)) {
01254 //      GainTable = dagtDP5Dx;
01255 //}
01256
01257 void CFilePage::OnBnClickedCheckDP5DxGains()
01258 {
01259         CButton *chkDP5DxGains;
01260         if ((!s.isDppConnected) && (s.profile->device_type == dppDP5)) {        // DP5 Dx Configuration K,L Only Settings
01261                 chkDP5DxGains = (CButton *)GetDlgItem(IDC_CHECK_DP5_DX_GAIN);
01262                 // 0==unchecked,1==checked,2==indeterminate, getCheck-->int, isDP5_RevDxGains->bool
01263                 s.DP5Stat.m_DP5_Status.isDP5_RevDxGains = (bool)(chkDP5DxGains->GetCheck() == 1);
01264         } else {
01265                 GetDlgItem(IDC_CHECK_DP5_DX_GAIN)->ShowWindow(SW_HIDE);
01266         }
01267 }
01268
01269 void CFilePage::SetCheckDP5DxGains()
01270 {
01271         CButton *chkDP5DxGains;
01272         BOOL isDP5DxGains;
01273         if ((!s.isDppConnected) && (s.profile->device_type == dppDP5)) {
01274                 GetDlgItem(IDC_CHECK_DP5_DX_GAIN)->ShowWindow(SW_SHOW);
01275                 chkDP5DxGains = (CButton *)GetDlgItem(IDC_CHECK_DP5_DX_GAIN);   // DP5 Dx Configuration K,L Only Settings
01276                 isDP5DxGains = s.DP5Stat.m_DP5_Status.isDP5_RevDxGains;
01277                 chkDP5DxGains->SetCheck(isDP5DxGains);
01278         } else {
01279                 GetDlgItem(IDC_CHECK_DP5_DX_GAIN)->ShowWindow(SW_HIDE);
01280         }
01281 }
01282
01283 //=================================
01284 //=================================
01285 //=================================
01286 //=================================
01287
01288 void CFilePage::OnStnClickedStaticReadConfig()
01289 {
01290         OnBnClickedButtonReadConfig();
01291 }
01292
01293 void CFilePage::OnStnClickedStaticSaveConfig()
01294 {
01295         OnBnClickedButtonSaveConfig();
01296 }
01297
01298 void CFilePage::OnBnClickedButtonSendCommand()
01299 {
01300         CString cstCfg;
01301         CMSecTimer tmr;
01302
01303         //IDC_STATIC_SEND_COMMAND_LABEL
01304         GetDlgItem(IDC_BUTTON_SEND_COMMAND)->EnableWindow(FALSE);
01305         GetDlgItem(IDC_EDIT_SEND_COMMAND)->EnableWindow(FALSE);
01306         s.HwCfgReady = FALSE;
01307         s.HwCfgExReady = FALSE;
01308         s.HwCfgDP5Out = "";
01309         GetDlgItem(IDC_EDIT_SEND_COMMAND)->GetWindowText(cstCfg);
01310         cstCfg.Trim();
01311         cstCfg.MakeUpper();
01312         GetDlgItem(IDC_EDIT_SEND_COMMAND)->SetWindowText(cstCfg);
01313                 if (cstCfg != "") {
01314                         s.HwCfgDP5Out = cstCfg;
01315                         s.HaveConfig = TRUE;
01316                         if (s.HwCfgDP5Out.GetLength() >0 ) {
01317                                 s.HwCfgReady = TRUE;
01318                                 ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
01319                         }
01320                 }
01321         tmr.msTimer(500);
01322         OnBnClickedButtonEditConfigFromHw();
01323         GetDlgItem(IDC_BUTTON_SEND_COMMAND)->EnableWindow(TRUE);
01324         GetDlgItem(IDC_EDIT_SEND_COMMAND)->EnableWindow(TRUE);
01325
01326 }
01327
01328 void CFilePage::OnBnClickedButtonSendCommand2()
01329 {
01330         CString cstCfg;
01331         CMSecTimer tmr;
01332
01333         //IDC_STATIC_SEND_COMMAND_LABEL
01334         GetDlgItem(IDC_BUTTON_SEND_COMMAND2)->EnableWindow(FALSE);
01335         GetDlgItem(IDC_EDIT_SEND_COMMAND)->EnableWindow(FALSE);
01336         s.HwCfgReady = FALSE;
01337         s.HwCfgExReady = FALSE;
01338         s.HwCfgDP5Out = "";
01339         GetDlgItem(IDC_EDIT_SEND_COMMAND)->GetWindowText(cstCfg);
01340         cstCfg.Trim();
01341         cstCfg.MakeUpper();
01342         GetDlgItem(IDC_EDIT_SEND_COMMAND)->SetWindowText(cstCfg);
01343         if (cstCfg != "") {
01344                 s.HwCfgDP5Out = cstCfg;
01345                 if (s.HwCfgDP5Out.GetLength() >0 ) {
01346                         ::PostMessage(s.hWnd_Main,WM_USER_READ_DPP_CONFIG_EX,0L,0L);
01347                 }
01348                 tmr.msTimer(500);
01349                 if (s.HwCfgReady) {
01350                         GetDlgItem(IDC_EDIT_RCV_CFG)->ShowWindow(SW_SHOW);
01351                         GetDlgItem(IDC_EDIT_RCV_CFG)->SetWindowText(s.HwCfgDP5);
01352                 }
01353         }
01354         GetDlgItem(IDC_BUTTON_SEND_COMMAND2)->EnableWindow(TRUE);
01355         GetDlgItem(IDC_EDIT_SEND_COMMAND)->EnableWindow(TRUE);
01356
01357 }
01358
01359
01361 // HtmlHelp for shared dialog
01362 // NOTE: shared dialogs use string type IDD, not global IDD
01363 BOOL CFilePage::OnHelpInfo(HELPINFO* pHelpInfo)
01364 {
01365         CString strHelp;
01366         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
01367                 if (pHelpInfo->dwContextId == 0) {
01368                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_FILE_PAGE);
01369                 } else {
01370                         //
01371                 }
01372         }
01373         return true;
01374 }
01375
01376 void CFilePage::OnHelp()                                // enable property sheet help button help
01377 {
01378         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_FILE_PAGE);
01379     //SendMessage(WM_COMMANDHELP);      //
01380 }
01382
01383
01384
01385
01386
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FilePage.h Source File

DP5Cfg/FilePage.h
Go to the documentation of this file.
00001 #if !defined(AFX_FilePage_H__INCLUDED_)
00002 #define AFX_FilePage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // FilePage.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "afxwin.h"
00012 #include "label.h"
00013
00015 // CFilePage dialog
00016
00017 class CFilePage : public CCfgPropPage
00018 {
00019         DECLARE_DYNCREATE(CFilePage)
00020
00021 // Construction
00022 public:
00023         CFilePage();
00024         ~CFilePage();
00025
00026 // Dialog Data
00027         //{{AFX_DATA(CFilePage)
00028         //enum { IDD = IDD_FILE_PAGE };
00029         //}}AFX_DATA
00030
00031
00032 // Overrides
00033         // ClassWizard generate virtual function overrides
00034         //{{AFX_VIRTUAL(CFilePage)
00035         protected:
00036         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00037         //}}AFX_VIRTUAL
00038
00039 // Implementation
00040 protected:
00041         // Generated message map functions
00042         //{{AFX_MSG(CFilePage)
00043         //}}AFX_MSG
00044         DECLARE_MESSAGE_MAP()
00045         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00046
00047 public:
00048         //CStatic m_FilePageLabel;
00049         CLabel m_FilePageLabel;
00050         //CStatic m_FileAdvancedLabel;
00051         CLabel m_FileAdvancedLabel;
00052         //CStatic m_FileStandardLabel;
00053         CLabel m_FileStandardLabel;
00054         virtual BOOL OnSetActive();
00055         virtual BOOL OnInitDialog();
00056         CString m_strConfigIn;
00057         CString m_strConfigOut;
00058
00059         afx_msg void OnBnClickedButtonReadConfig();
00060         void ReadConfigFromAmptek_NP(CString strFilename, CString strKeyName);
00061         void ReadConfig();
00062
00063         void InitControls();
00064         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00065         void CFilePage::CboUpdate(int nID_dci);
00066
00067         // Get Amptek Detector Configuration (New Protocol{FW6+}) Section Name
00068         CString GetAmptekDC_NP_Section();
00069         // -------------------------------------------------------------------
00070
00071     afx_msg void OnCbnSelchangeReaddetectorconfigcombo();
00072         CComboBox m_ReadDetectorConfigCombo;
00073         void ReadAmptekDetectorConfigNames();
00074
00075         afx_msg void OnCbnSelchangeOptComboResc();
00076         //afx_msg void OnBnClickedButtonFindCommand();  // find cfg cmd controls on another page
00077         afx_msg void OnBnClickedButtonSaveConfig();
00078         CString SaveConfigString();
00079         CString GetCmdKeyData(CString strCmd, CString strCfgData);
00080         afx_msg void OnBnClickedButtonEditConfigFromHw();
00081         afx_msg void OnBnClickedButtonSendToHardware();
00082
00083         virtual BOOL PreTranslateMessage(MSG* pMsg);
00084         BOOL isCEditBox(int nID);
00085         BOOL isCComboBox(int nID);
00086
00087         afx_msg void OnTimer(UINT nIDEvent);
00088         // AutoReadHwConfig 100ms Timer
00089         UINT_PTR m_nTmrConfigId;                // return SetTimer Return Value (0=false,TimerID if OK)
00090         UINT_PTR m_nTmrConfigEventId;   // Timer Event Identifier
00091         UINT m_nTmrConfigElapse;                // Timeout value in milliseconds
00092
00093         virtual BOOL OnApply();
00094         virtual void OnCancel();
00095         BOOL isClosing;
00096
00097         void EnableControls(BOOL bEnable);
00098
00099         afx_msg void OnBnClickedButtonSendToHardwareNoEdit();
00100         afx_msg void OnBnClickedRadioDppDeviceType1();
00101         afx_msg void OnBnClickedRadioDppDeviceType2();
00102         afx_msg void OnBnClickedRadioDppDeviceType3();
00103         afx_msg void OnBnClickedRadioDppDeviceType4();
00104         afx_msg void OnBnClickedRadioDppDeviceType5();
00105         afx_msg void OnBnClickedRadioDppDeviceType6();
00106         void SetDppDeviceType(int DeviceType);
00107         void SelectRadioDppDeviceType(int DeviceType);
00108         void EnableDeviceSelection(BOOL bEnable);
00109
00110         afx_msg void OnCbnSelendokReaddetectorconfigcombo();
00111         afx_msg void OnBnClickedCheckPc5Present();
00112         void SetCheckPc5Present();
00113
00114         // DP5 Rev Dx (Rev D0 and above) extended gain range control
00115         // enables configuration selections when no dp5 device is attached
00116         afx_msg void OnBnClickedCheckDP5DxGains();
00117         void SetCheckDP5DxGains();
00118
00119         afx_msg void OnStnClickedStaticReadConfig();
00120         afx_msg void OnStnClickedStaticSaveConfig();
00121         afx_msg void OnBnClickedButtonSendCommand();
00122
00123         afx_msg void OnHelp();
00124         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00125
00126         afx_msg void OnBnClickedButtonSendCommand2();
00127 };
00128
00129 //{{AFX_INSERT_LOCATION}}
00130 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00131
00132 #endif // !defined(AFX_FilePage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/FilePageRes.h Source File

DP5Cfg/FilePageRes.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by FilePage.rc
00004 //
00005 #define IDC_BUTTON_EDIT_CONFIG_FROM_HW  1920
00006 #define IDC_BUTTON_READ_CONFIG          1921
00007 #define IDC_BUTTON_SAVE_CONFIG          1922
00008 #define IDC_BUTTON_SEND_COMMAND         1923
00009 #define IDC_BUTTON_SEND_TO_HARDWARE     1924
00010 #define IDC_BUTTON_SEND_TO_HARDWARE_NO_EDIT 1925
00011 #define IDC_CHECK_PC5_PRESENT           1926
00012 #define IDC_EDIT_HW_CFG_SECTION         1927
00013 #define IDC_EDIT_SEND_COMMAND           1928
00014 #define IDC_OPT_COMBO_RESC              1929
00015 #define IDC_OPT_FRAME_RESC              1930
00016 #define IDC_RADIO_DPP_DEVICE_TYPE1      1931
00017 #define IDC_RADIO_DPP_DEVICE_TYPE2      1932
00018 #define IDC_RADIO_DPP_DEVICE_TYPE3      1933
00019 #define IDC_READDETECTORCONFIGCOMBO     1934
00020 #define IDC_STATIC_CFG_LEN_LABEL        1935
00021 #define IDC_STATIC_CFG_LENGTH           1936
00022 #define IDC_STATIC_CONFIG_NAME          1937
00023 #define IDC_STATIC_CONFIG_NAME2         1938
00024 #define IDC_STATIC_DPP_DEVICE_TYPE      1939
00025 #define IDC_STATIC_FILE_ADVANCED        1940
00026 #define IDC_STATIC_FILE_BASIC           1941
00027 #define IDC_STATIC_FILE_PAGE            1942
00028 #define IDC_STATIC_FILE_STANDARD        1943
00029 #define IDC_STATIC_READ_CONFIG          1944
00030 #define IDC_STATIC_SAVE_CONFIG          1945
00031 #define IDC_STATIC_SEND_COMMAND_LABEL   1946
00032 #define IDC_EDIT_RCV_CFG                1947
00033 #define IDC_RADIO_DPP_DEVICE_TYPE4      1948
00034 #define IDC_BUTTON_SEND_COMMAND2        1949
00035 #define IDC_RADIO_DPP_DEVICE_TYPE5      1950
00036 #define IDC_CHECK_DP5_DX_GAIN           1951
00037 #define IDC_RADIO_DPP_DEVICE_TYPE6      1952
00038 #define IDI_DP5_CARD                    6400
00039 #define IDI_OPEN_FOLDER                 6401
00040 #define IDI_RIGHT_ARROW                 6402
00041
00042 // Next default values for new objects
00043 //
00044 #ifdef APSTUDIO_INVOKED
00045 #ifndef APSTUDIO_READONLY_SYMBOLS
00046 #define _APS_NEXT_RESOURCE_VALUE        6403
00047 #define _APS_NEXT_COMMAND_VALUE         33408
00048 #define _APS_NEXT_CONTROL_VALUE         1953
00049 #define _APS_NEXT_SYMED_VALUE           6403
00050 #endif
00051 #endif
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/GainPzPage.cpp Source File

DP5Cfg/GainPzPage.cpp
Go to the documentation of this file.
00001 // GainPzPage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005  #include "afxpriv.h"   // afxpriv.h has WM_COMMANDHELP id
00006 #include "GainPzPageRes.h"
00007 #include "GainPzPage.h"
00008 #include ".\GainPzPage.h"
00009 #include <math.h>
00010
00011 #ifdef _DEBUG
00012 #define new DEBUG_NEW
00013 #undef THIS_FILE
00014 static char THIS_FILE[] = __FILE__;
00015 #endif
00016
00018 // CGainPzPage property page
00019
00020 IMPLEMENT_DYNCREATE(CGainPzPage, CCfgPropPage)
00021 //#define IDD_GAINPZ_PAGE                 108
00022
00023
00024 //CGainPzPage::CGainPzPage() : CCfgPropPage(CGainPzPage::IDD)
00025 CGainPzPage::CGainPzPage() : CCfgPropPage("IDD_GAINPZ_PAGE")
00026 {
00027         //{{AFX_DATA_INIT(CGainPzPage)
00028                 // NOTE: the ClassWizard will add member initialization here
00029         //}}AFX_DATA_INIT
00030 }
00031
00032 CGainPzPage::~CGainPzPage()
00033 {
00034
00035 }
00036
00037 void CGainPzPage::DoDataExchange(CDataExchange* pDX)
00038 {
00039         CCfgPropPage::DoDataExchange(pDX);
00040         //{{AFX_DATA_MAP(CGainPzPage)
00041         //}}AFX_DATA_MAP
00042         DDX_Control(pDX, IDC_STATIC_GAINPZ_PAGE, m_GainPzPageLabel);
00043         DDX_Control(pDX, IDC_OPT_COMBO_GAIA, m_CoarseGain_GAIA_index);
00044         DDX_Control(pDX, IDC_OPT_COMBO_GAIA2, m_CoarseGain_GAIA_value);
00045         DDX_Control(pDX, IDC_STATIC_GAIN_ADVANCED, m_GainAdvancedLabel);
00046         DDX_Control(pDX, IDC_STATIC_GAIN_STANDARD, m_GainStandardLabel);
00047         DDX_Control(pDX, IDC_STATIC_HV_WARNING, m_PowerHvWarning);
00048
00049 }
00050
00051 BEGIN_MESSAGE_MAP(CGainPzPage, CCfgPropPage)
00052         //{{AFX_MSG_MAP(CGainPzPage)
00053         //}}AFX_MSG_MAP
00054         ON_CBN_SELCHANGE(IDC_OPT_COMBO_RESL, OnCbnSelchangeOptComboResl)
00055         ON_CBN_SELCHANGE(IDC_OPT_COMBO_AINP, OnCbnSelchangeOptComboAinp)
00056         ON_CBN_SELCHANGE(IDC_OPT_COMBO_INOF, OnCbnSelchangeOptComboInof)
00057         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PAPZ, OnCbnSelchangeOptComboPapz)
00058         ON_EN_CHANGE(IDC_OPT_TEXT_PAPZ, OnEnChangeOptTextPapz)
00059         ON_EN_CHANGE(IDC_OPT_TEXT_RESL, OnEnChangeOptTextResl)
00060         ON_EN_CHANGE(IDC_OPT_TEXT_INOF, OnEnChangeOptTextInof)
00061         ON_EN_CHANGE(IDC_OPT_TEXT_GAIN, OnEnChangeOptTextGain)
00062         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GAIA, OnCbnSelchangeOptComboGaia)
00063         ON_EN_CHANGE(IDC_OPT_TEXT_GAIF, OnEnChangeOptTextGaif)
00064         ON_BN_CLICKED(IDC_BUTTON_FINE_GAIN_ENTER, OnBnClickedButtonFineGainEnter)
00065         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GAIN_SELECT, OnCbnSelchangeOptComboGainSelect)
00066         ON_BN_CLICKED(IDC_BUTTON_COARSE_FINE_TO_TOTAL, OnBnClickedButtonCoarseFineToTotal)
00067         ON_BN_CLICKED(IDC_BUTTON_TOTAL_TO_COARSE_FINE, OnBnClickedButtonTotalToCoarseFine)
00068         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GAIA2, OnCbnSelchangeOptComboGaia2)
00069         ON_CBN_SELCHANGE(IDC_OPT_COMBO_RESL2, OnCbnSelchangeOptComboResl2)
00070
00071         ON_COMMAND(ID_HELP, OnHelp)
00072         ON_WM_HELPINFO()
00073
00074 END_MESSAGE_MAP()
00075
00077 // CGainPzPage message handlers
00078
00079 BOOL CGainPzPage::OnSetActive()
00080 {
00081         // TODO: Add your specialized code here and/or call the base class
00082         if (s.ReloadCfg) {
00083                 InitControls();
00084         } else {
00085                 SetHvPowerWarning();
00086         }
00087
00088         return CCfgPropPage::OnSetActive();
00089 }
00090
00091 BOOL CGainPzPage::OnInitDialog()
00092 {
00093         CCfgPropPage::OnInitDialog();
00094
00095         BuildToolTips();
00096
00097         m_GainPzPageLabel
00098                 .SetFontName("Arial")
00099                 .SetFontSize(24)
00100                 .SetTextColor(RGB(0,0,255))
00101                 .SetBkColor(RGB(244, 243, 238))
00102                 .SetFontItalic(TRUE)
00103                 .SetFontBold(TRUE);
00104
00105         m_GainAdvancedLabel
00106                 .SetFontName("Arial")
00107                 .SetFontSize(18)
00108                 .SetTextColor(RGB(0, 70, 213))
00109                 .SetBkColor(RGB(249, 248, 247))
00110                 .SetFontItalic(TRUE)
00111                 .SetFontBold(FALSE);
00112
00113         m_GainStandardLabel
00114                 .SetFontName("Arial")
00115                 .SetFontSize(18)
00116                 .SetTextColor(RGB(0, 70, 213))
00117                 .SetBkColor(RGB(252, 252, 253))
00118                 .SetFontItalic(TRUE);
00119
00120         m_PowerHvWarning
00121                 .SetFontName("Arial")
00122                 .SetFontSize(12)
00123                 .SetTextColor(RGB(255, 0, 0))
00124                 .SetBkColor(RGB(247, 246, 243))
00125                 .SetFontItalic(FALSE)
00126                 .SetFontBold(TRUE);
00127
00128         InitControls();
00129
00130         // TODO:  Add extra initialization here
00131
00132         return TRUE;  // return TRUE unless you set the focus to a control
00133         // EXCEPTION: OCX Property Pages should return FALSE
00134 }
00135
00136 //dciRESL       RESL    IDC_OPT_COMBO_RESL      IDC_OPT_TEXT_RESL       dctCboTxt       dcgGainPZ       Reset Lockout   uS
00137 //dciAINP       AINP    IDC_OPT_COMBO_AINP      0                                       dctCbo          dcgGainPZ       Analog Input Pos/Neg
00138 //dciINOF       INOF    IDC_OPT_COMBO_INOF      IDC_OPT_TEXT_INOF       dctCboTxt       dcgGainPZ       Input Offset    mV
00139 //dciGAIN       GAIN    0                                       IDC_OPT_TEXT_GAIN       dctTxt          dcgGainPZ       Total Gain (Analog * Fine)      x
00140 //dciPAPZ       PAPZ    IDC_OPT_COMBO_PAPZ      IDC_OPT_TEXT_PAPZ       dctCboTxt       dcgPower        Pole-Zero       "uS",   "34.5uS to 8773uS");
00141 // PX5 HPGe and DP5 Dx Configuration K
00142 //dciPAPZ       PAPZ    IDC_OPT_COMBO_PAPZ      IDC_OPT_TEXT_PAPZ       dctCboTxt       dcgPower        Pole-Zero       "uS",   "34.5 to 103.5uS");
00143 // DP5 Dx Configuration L
00144 //dciPAPZ       PAPZ    IDC_OPT_COMBO_PAPZ      IDC_OPT_TEXT_PAPZ       dctCboTxt       dcgPower        Pole-Zero       "uS",   "91.6uS to 1203uS");
00145
00146 void CGainPzPage::InitControls()
00147 {
00148         BOOL bEnablePAPZ=FALSE;
00149         int iShowNewRESL=SW_HIDE;
00150         int iShowOldRESL=SW_SHOW;
00151         int DppType;
00152
00153         BOOL bHPGePAPZ=FALSE;
00154         bool isDP5_DxK=false;
00155         bool isDP5_DxL=false;
00156
00157         DppType = s.profile->device_type;
00158         bEnableNewRESL=FALSE;           // start as old RESL, test for new RESL
00159
00160         HWND hPage = this->GetSafeHwnd();
00161
00162         // Select gain table for analog gain values
00163         int GainTable = s.profile->device_type - dppDP5;
00164         bEnablePAPZ = (DppType == dppPX5);
00165
00167         //0.750-1.250 All devices except DP5X
00168         //0.600-1.400 DP5X
00169         dblGAIF_Max = 1.250;
00170         dblGAIF_Min = 0.750;
00171         GetDlgItem(IDC_OPT_LIMITS_GAIF)->SetWindowText("0.750-1.250");
00172         // SEE END OF CGainPzPage::InitControls for more details
00174
00175         // DP5 Rev Dx Have 24 Analog Gains and a wider gain range
00176         if ((s.profile->device_type == dppDP5) && (s.DP5Stat.m_DP5_Status.isDP5_RevDxGains)) {
00177                 GainTable = dagtDP5Dx;
00178                 //A==0x00,K==0x0A,  PAPZ Enabled for DP5 Dx Configuration K
00179                 if ((s.DP5Stat.m_DP5_Status.DPP_ECO & 0x0F) == 0x0A) { // DP5 Dx Configuration K
00180                         isDP5_DxK = true;
00181                         bEnablePAPZ = true;
00182                 }
00183                 if ((s.DP5Stat.m_DP5_Status.DPP_ECO & 0x0F) == 0x0B) {  // DP5 Dx Configuration L
00184                         isDP5_DxL = true;
00185                         bEnablePAPZ = true;
00186                 }
00187         }
00188
00189         if (s.DP5Stat.m_DP5_Status.DPP_options == PX5_OPTION_HPGe_HVPS) {
00190                 bHPGePAPZ = true;
00191         }
00192
00193         if (bEnablePAPZ && (s.profile->device_type == dppDP5)) {        // DP5 Dx Configuration K,L Only
00194                 bHPGePAPZ = true;                                                                                       // Remove or update logic
00195         }
00196
00197         if (((s.DppConfig.Firmware == 0x67) && (s.DppConfig.Build >= 4)) || (s.DppConfig.Firmware > 0x67))
00198         {
00199                 bEnableNewRESL=TRUE;    // Needs new RESL controls
00200                 iShowNewRESL=SW_SHOW;
00201                 iShowOldRESL=SW_HIDE;
00202         }
00203
00204         GetDlgItem(IDC_OPT_FRAME_RESL)->ShowWindow(iShowNewRESL);
00205         GetDlgItem(IDC_OPT_COMBO_RESL)->ShowWindow(iShowNewRESL);
00206         GetDlgItem(IDC_OPT_LIMITS_RESL)->ShowWindow(iShowNewRESL);
00207         GetDlgItem(IDC_OPT_TEXT_RESL)->ShowWindow(iShowNewRESL);
00208         GetDlgItem(IDC_OPT_UNITS_RESL)->ShowWindow(iShowNewRESL);
00209
00210         GetDlgItem(IDC_OPT_FRAME_RESL2)->ShowWindow(iShowOldRESL);
00211         GetDlgItem(IDC_OPT_COMBO_RESL2)->ShowWindow(iShowOldRESL);
00212         GetDlgItem(IDC_OPT_UNITS_RESL2)->ShowWindow(iShowOldRESL);
00213
00214         GetDlgItem(IDC_OPT_FRAME_PAPZ)->EnableWindow(bEnablePAPZ);
00215         GetDlgItem(IDC_OPT_COMBO_PAPZ)->EnableWindow(bEnablePAPZ);
00216         GetDlgItem(IDC_OPT_TEXT_PAPZ)->EnableWindow(bEnablePAPZ);
00217         GetDlgItem(IDC_OPT_LIMITS_PAPZ)->EnableWindow(bEnablePAPZ);
00218         GetDlgItem(IDC_OPT_UNITS_PAPZ)->EnableWindow(bEnablePAPZ);
00219
00220         // Select gain table for analog gain values
00221         //int GainTable = s.profile->device_type - dppDP5;
00222         if (GainTable < MinGainTable) { GainTable = MinGainTable; }
00223         if (GainTable > MaxGainTable) { GainTable = MaxGainTable; }
00224         DppGain.GainTable = (DppAGainTable)GainTable;
00225         DppGain.ptrGainTable = DppGain.GetGainTablePtr(DppGain.GainTable);
00226         DppGain.GainTableCount = DppGain.GetGainCount(DppGain.GainTable);
00227         DppGain.MinGain = DppGain.GetTotalGainLimitsMin(DppGain.GainTable);
00228         DppGain.MaxGain = DppGain.GetTotalGainLimitsMax(DppGain.GainTable);
00229
00230         DppGain.LoadGainTableValues(&m_CoarseGain_GAIA_value, DppGain.GainTable);
00231         DppGain.LoadGainTableIndexes(&m_CoarseGain_GAIA_index, DppGain.GainTable);
00232
00233         SetDetResetValues(IDC_OPT_COMBO_RESL2,s.DppConfig.b80MHzModeCfg);
00234
00235         InitDlgItem(hPage,s.m_DP5Cfg[dciRESL]);
00236         InitDlgItem(hPage,s.m_DP5Cfg[dciAINP]);
00237         InitDlgItem(hPage,s.m_DP5Cfg[dciINOF]);
00238         InitDlgItem(hPage,s.m_DP5Cfg[dciGAIN]);
00239         InitDlgItem(hPage,s.m_DP5Cfg[dciGAIA]);
00240         InitDlgItem(hPage,s.m_DP5Cfg[dciGAIF]);
00241         InitDlgItem(hPage,s.m_DP5Cfg[dciPAPZ]);
00242         CboUpdate(dciPAPZ);
00243
00244         if (bHPGePAPZ && !(isDP5_DxK || isDP5_DxL)) {   // PX5 HPGe
00245                 GetDlgItem(IDC_OPT_LIMITS_PAPZ)->SetWindowText("34.5uS to 103.5uS");
00246         } else if (bHPGePAPZ && isDP5_DxK) {                    // DP5 Dx Configuration K
00247                 GetDlgItem(IDC_OPT_LIMITS_PAPZ)->SetWindowText("34.5uS to 103.5uS");
00248         } else if (bHPGePAPZ && isDP5_DxL) {                    // DP5 Dx Configuration L
00249                 GetDlgItem(IDC_OPT_LIMITS_PAPZ)->SetWindowText("91.6uS to 1203uS");
00250         } else {
00251                 GetDlgItem(IDC_OPT_LIMITS_PAPZ)->SetWindowText("34.5uS to 8773uS");
00252         }
00253
00254         CboUpdate(dciRESL);
00255         CboUpdate(dciAINP);
00256         CboUpdate(dciINOF);
00257         //CboUpdate(dciGAIA);
00258         OnEnChangeOptTextGaif();                // update fine gain value
00259         OnCbnSelchangeOptComboGaia();   // update coarse gain text display also
00260         OnBnClickedButtonFineGainEnter();
00261
00262         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIN_SELECT);
00263         pCombo->SetCurSel(s.profile->SendCoarseFineGain);
00264         UpdateOptComboGAIA();
00265
00266         InitCombo(hPage,s.m_DP5Cfg[dciRESL],IDC_OPT_COMBO_RESL2);
00267
00268         // reset the Total Gain Range To Current Gain Table Values
00269         CString strTotalGainRange;
00270         strTotalGainRange = DppGain.GetTotalGainLimitsLabel(DppGain.GainTable);
00271         GetDlgItem(IDC_OPT_LIMITS_GAIN)->SetWindowText(strTotalGainRange);
00272
00273         // correct the total gain value if out of range
00274         CString strTotalGain;
00275         GetDlgItem(IDC_OPT_TEXT_GAIN)->GetWindowText(strTotalGain);
00276         if (! DppGain.isInTotalGainRange(strTotalGain, DppGain.GainTable)) {
00277                 strTotalGain = DppGain.FixTotalGainRange(strTotalGain, DppGain.GainTable);
00278                 GetDlgItem(IDC_OPT_TEXT_GAIN)->SetWindowText(strTotalGain);
00279         }
00280
00281         //if (s.profile->device_type == dppMCA8000D) {
00282         //      ShowMCA8000D_Controls(SW_HIDE);
00283         //      CheckMCA8000D_FineGain();       // verify the fine gain is at 1 if not, set it to 1
00284         //      GetDlgItem(IDC_OPT_FRAME_GAIA)->SetWindowText("Input Range");
00285         //} else {
00286         //      ShowMCA8000D_Controls(SW_SHOW);
00287         //      GetDlgItem(IDC_OPT_FRAME_GAIA)->SetWindowText("Coarse Gain");
00288         //}
00289         if (DppType == dppDP5X) {
00290                 dblGAIF_Max = 1.400;
00291                 dblGAIF_Min = 0.600;
00292                 GetDlgItem(IDC_OPT_LIMITS_GAIF)->SetWindowText("0.600-1.400");
00293         } else {
00294                 dblGAIF_Max = 1.250;
00295                 dblGAIF_Min = 0.750;
00296                 GetDlgItem(IDC_OPT_LIMITS_GAIF)->SetWindowText("0.750-1.250");
00297         }
00298 }
00299
00300 void CGainPzPage::CheckMCA8000D_FineGain()
00301 {
00302         CString strGAIF;
00303         double dblGAIF;
00304         GetDlgItem(IDC_OPT_TEXT_GAIF)->GetWindowText(strGAIF);
00305         if (strGAIF.GetLength() > 0) {
00306                 dblGAIF = atof(strGAIF);
00307                 if (dblGAIF != 1) {
00308                         strGAIF = "1";
00309                         dblGAIF = 1;
00310                         GetDlgItem(IDC_OPT_TEXT_GAIF)->SetWindowText(strGAIF);
00311                 }
00312         } else {
00313                 strGAIF = "1";
00314                 dblGAIF = 1;
00315                 GetDlgItem(IDC_OPT_TEXT_GAIF)->SetWindowText(strGAIF);
00316         }
00317         UpdateGainValue();                              // update gain value display
00318 }
00319
00320 void CGainPzPage::ShowMCA8000D_Controls(int iShowWin)
00321 {
00322         GetDlgItem(IDC_BUTTON_FINE_GAIN_ENTER)->ShowWindow(iShowWin);
00323         GetDlgItem(IDC_OPT_COMBO_AINP)->ShowWindow(iShowWin);
00324         GetDlgItem(IDC_OPT_COMBO_GAIN_SELECT)->ShowWindow(iShowWin);
00325         GetDlgItem(IDC_OPT_COMBO_INOF)->ShowWindow(iShowWin);
00326         GetDlgItem(IDC_OPT_COMBO_RESL)->ShowWindow(iShowWin);
00327         GetDlgItem(IDC_OPT_COMBO_RESL2)->ShowWindow(iShowWin);
00328         GetDlgItem(IDC_OPT_FRAME_AINP)->ShowWindow(iShowWin);
00329         GetDlgItem(IDC_OPT_FRAME_GAIF)->ShowWindow(iShowWin);
00330         GetDlgItem(IDC_OPT_FRAME_GAIN)->ShowWindow(iShowWin);
00331         GetDlgItem(IDC_OPT_FRAME_INOF)->ShowWindow(iShowWin);
00332         GetDlgItem(IDC_OPT_FRAME_RESL)->ShowWindow(iShowWin);
00333         GetDlgItem(IDC_OPT_FRAME_RESL2)->ShowWindow(iShowWin);
00334         GetDlgItem(IDC_OPT_LIMITS_GAIF)->ShowWindow(iShowWin);
00335         GetDlgItem(IDC_OPT_LIMITS_GAIN)->ShowWindow(iShowWin);
00336         GetDlgItem(IDC_OPT_LIMITS_INOF)->ShowWindow(iShowWin);
00337         GetDlgItem(IDC_OPT_LIMITS_RESL)->ShowWindow(iShowWin);
00338         GetDlgItem(IDC_OPT_TEXT_GAIF)->ShowWindow(iShowWin);
00339         GetDlgItem(IDC_OPT_TEXT_GAIN)->ShowWindow(iShowWin);
00340         GetDlgItem(IDC_OPT_TEXT_INOF)->ShowWindow(iShowWin);
00341         GetDlgItem(IDC_OPT_TEXT_RESL)->ShowWindow(iShowWin);
00342         GetDlgItem(IDC_OPT_UNITS_GAIF)->ShowWindow(iShowWin);
00343         GetDlgItem(IDC_OPT_UNITS_GAIN)->ShowWindow(iShowWin);
00344         GetDlgItem(IDC_OPT_UNITS_INOF)->ShowWindow(iShowWin);
00345         GetDlgItem(IDC_OPT_UNITS_RESL)->ShowWindow(iShowWin);
00346         GetDlgItem(IDC_OPT_UNITS_RESL2)->ShowWindow(iShowWin);
00347         GetDlgItem(IDC_OPT_VALUE_GAIN)->ShowWindow(iShowWin);
00348         GetDlgItem(IDC_STATIC_AVANCED_GAIN_CONTROL)->ShowWindow(iShowWin);
00349         GetDlgItem(IDC_STATIC_GAINPZ_PAGE)->ShowWindow(iShowWin);
00350         GetDlgItem(IDC_STATIC_GAIN_ADVANCED)->ShowWindow(iShowWin);
00351         GetDlgItem(IDC_STATIC_GAIN_BASIC)->ShowWindow(iShowWin);
00352         GetDlgItem(IDC_STATIC_GAIN_STANDARD)->ShowWindow(iShowWin);
00353
00354         GetDlgItem(IDC_STATIC_TOTAL_OR_BOTH_LABEL)->ShowWindow(iShowWin);
00355         GetDlgItem(IDC_BUTTON_TOTAL_TO_COARSE_FINE)->ShowWindow(iShowWin);
00356         GetDlgItem(IDC_BUTTON_COARSE_FINE_TO_TOTAL)->ShowWindow(iShowWin);
00357
00358         GetDlgItem(IDC_OPT_COMBO_PAPZ)->ShowWindow(iShowWin);
00359         GetDlgItem(IDC_OPT_FRAME_PAPZ)->ShowWindow(iShowWin);
00360         GetDlgItem(IDC_OPT_LIMITS_PAPZ)->ShowWindow(iShowWin);
00361         GetDlgItem(IDC_OPT_TEXT_PAPZ)->ShowWindow(iShowWin);
00362         GetDlgItem(IDC_OPT_UNITS_PAPZ)->ShowWindow(iShowWin);
00363
00364
00365         //GetDlgItem(IDC_OPT_FRAME_GAIA)->ShowWindow(iShowWin);
00366         //GetDlgItem(IDC_OPT_COMBO_GAIA2)->ShowWindow(iShowWin);
00367         //GetDlgItem(IDC_OPT_VALUE_GAIA)->ShowWindow(iShowWin);
00368
00369 }
00370
00371 void CGainPzPage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00372 {
00373         int cboDP5CtrlID = cfg.ListCtrlID;
00374         int txtDP5CtrlID = cfg.TextCtrlID;
00375         CString strVal = cfg.Setting;
00376         int idxList;
00377         CString strUnits;
00378         CString strLimits;
00379
00380         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00381                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00382                 //idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00383                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00384                 if (idxList == LB_ERR) {
00385                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00386                 }
00387                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00388                         if ((cfg.CtrlType & dctTxt) > 0) {      // if cbotxt must find mask, else set to 0
00389                                 cfg.TextValue = cfg.Setting;            // overwrite if currently editing
00390                                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"#");
00391                                 if (idxList == LB_ERR) { // mask begins with +
00392                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"+");
00393                                 }
00394                                 if (idxList == LB_ERR) { // mask begins with -
00395                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"-");
00396                                 }
00397                                 if (idxList == LB_ERR) { // not found default to 0
00398                                         idxList = 0;
00399                                 }
00400                         } else {
00401                                 idxList = 0;            // set to first item
00402                         }
00403                 }
00404                 cb.SetCurSel(idxList);
00405         }
00406         if ((cfg.CtrlType & dctTxt) > 0) {
00407                 if ((cfg.CtrlType & dctCbo) == 0) {             // cbo update above
00408                         if (cfg.Setting.GetLength() > 0) {
00409                                 cfg.TextValue = cfg.Setting;
00410                         }
00411                 }
00412                 GetDlgItem(txtDP5CtrlID)->SetWindowText(cfg.TextValue);
00413                 strUnits = cfg.Units;
00414                 strLimits = cfg.Limits;
00415                 switch (txtDP5CtrlID) {
00416                         case IDC_OPT_TEXT_RESL:
00417                                 UNIT_INIT(RESL, strUnits);
00418                                 LIMIT_INIT(RESL, strLimits);
00419                                 break;
00420                         case IDC_OPT_TEXT_INOF:
00421                                 UNIT_INIT(INOF, strUnits);
00422                                 LIMIT_INIT(INOF, strLimits);
00423                                 break;
00424                         case IDC_OPT_TEXT_GAIN:
00425                                 UNIT_INIT(GAIN, strUnits);
00426                                 LIMIT_INIT(GAIN, strLimits);
00427                                 break;
00428                         case IDC_OPT_TEXT_GAIF:
00429                                 UNIT_INIT(GAIF, strUnits);
00430                                 LIMIT_INIT(GAIF, strLimits);
00431                                 break;
00432                         case IDC_OPT_TEXT_PAPZ:
00433                                 UNIT_INIT(PAPZ, strUnits);
00434                                 LIMIT_INIT(PAPZ, strLimits);
00435                                 break;
00436                 }
00437         }
00438 }
00439
00440 // pass dci id to update combo control and display edit controls if any
00441 void CGainPzPage::CboUpdate(int nID_dci)
00442 {
00443         CString strCboText;
00444         int nID;
00445         int CmdShow;
00446         //BOOL isText;
00447
00448         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00449         if (nID == NULL) { return; }
00450         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00451         int idx = cb.GetCurSel();
00452         if (idx > LB_ERR) {
00453                 cb.GetLBText(idx,strCboText);
00454                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00455                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00456                 if (nID_dci == dciAINP) {
00457                         if (strCboText.GetLength() > 0) {
00458                                 s.DppConfig.bAnalogPolarity = FALSE;
00459                                 if (strCboText.Find("PO") > -1) {
00460                                         s.DppConfig.bAnalogPolarity = TRUE;
00461                                 }
00462                                 SetHvPowerWarning();
00463                         }
00464                 }
00465         } else {
00466                 return;
00467         }
00468         if (s.m_DP5Cfg[nID_dci].CtrlType == dctCboTxt) {
00469                 if (strCboText.Find('#') >= 0) {
00470                         CmdShow = SW_SHOW;
00471                 } else {
00472                         CmdShow = SW_HIDE;
00473                 }
00474                 switch (nID) {
00475                         case IDC_OPT_COMBO_RESL:
00476                                 if (bEnableNewRESL) {
00477                                         ALL_VIS(RESL, CmdShow);
00478                                         CBO_TEXT_VIS(RESL, (CmdShow!=0));
00479                                 }
00480                                 //CboTextVis(IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,(CmdShow!=0));
00481                                 break;
00482                         case IDC_OPT_COMBO_INOF:
00483                                 ALL_VIS(INOF, CmdShow);
00484                                 CBO_TEXT_VIS(INOF, (CmdShow!=0));
00485                                 //CboTextVis(IDC_OPT_COMBO_INOF,IDC_OPT_TEXT_INOF,(CmdShow!=0));
00486                                 break;
00487                         case IDC_OPT_COMBO_PAPZ:
00488                                 ALL_VIS(PAPZ, CmdShow);
00489                                 CBO_TEXT_VIS(PAPZ, (CmdShow!=0));
00490                                 break;
00491                 }
00492         }
00493         SetModified(TRUE);
00494 }
00495
00496 //CBO_TEXT_VIS(RESL, (CmdShow!=0));
00497 //CboTextVis(IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,(CmdShow!=0));
00498 //void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00499 void CGainPzPage::CboTextVis(int nIdCbox, int nIdEdit, BOOL isText)
00500 {
00501         UINT ddSize;
00502         RECT lpRect;
00503         CEdit* pEdit;
00504         CComboBox* pCombo;
00505         int btnSize = 20;
00506
00507         pEdit = (CEdit*)GetDlgItem(nIdEdit);            // cast to edit for rect
00508         pEdit->GetRect(&lpRect);                                        // get rect
00509         ddSize = lpRect.right - lpRect.left;            // save width
00510         if (isText) {
00511                 GetDlgItem(nIdEdit)->ShowWindow(SW_SHOW);
00512                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);
00513                 pCombo->GetWindowRect(&lpRect);
00514                 ScreenToClient(&lpRect);
00515                 //int ddSize1 = lpRect.right - lpRect.left;             // save width
00516                 //TRACE("Combo Edit %d\r\n",ddSize1);
00517                 lpRect.right = lpRect.left + btnSize;
00518                 pCombo->MoveWindow(&lpRect,TRUE);
00519                 pCombo->SetDroppedWidth(ddSize + btnSize);
00520         } else {
00521                 GetDlgItem(nIdEdit)->ShowWindow(SW_HIDE);       // hide edit
00522                 //TRACE("Edit %d\r\n",ddSize);
00523                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);       // cast to combo
00524                 pCombo->GetWindowRect(&lpRect);                         // get win size
00525                 ScreenToClient(&lpRect);                                        // adjust to screen
00526                 //int ddSize2 = lpRect.right - lpRect.left;             // save width
00527                 //TRACE("Combo %d\r\n",ddSize2);
00528                 lpRect.right = lpRect.left + ddSize + btnSize;  // get restored combo size
00529                 pCombo->MoveWindow(&lpRect,TRUE);                       // restore combo
00530                 pCombo->SetDroppedWidth(ddSize);                        // restore combo
00531         }
00532
00533 }
00534
00535 // pass dci id to update combo control and display edit controls if any
00536 void CGainPzPage::TextUpdate(int nID_dci)
00537 {
00538         CString strText;
00539         int nID;
00540
00541         nID = s.m_DP5Cfg[nID_dci].TextCtrlID;
00542         if (nID == NULL) { return; }
00543
00544         GetDlgItem(nID)->GetWindowText(strText);
00545         s.m_DP5Cfg[nID_dci].TextValue = strText;
00546         SetModified(TRUE);
00547 }
00548
00549 void CGainPzPage::OnCbnSelchangeOptComboResl()
00550 {
00551         CboUpdate(dciRESL);
00552 }
00553
00554 void CGainPzPage::OnCbnSelchangeOptComboAinp()
00555 {
00556         CboUpdate(dciAINP);
00557 }
00558
00559 void CGainPzPage::OnCbnSelchangeOptComboInof()
00560 {
00561         CboUpdate(dciINOF);
00562 }
00563
00564 void CGainPzPage::OnCbnSelchangeOptComboPapz()
00565 {
00566         CboUpdate(dciPAPZ);
00567 }
00568
00569 void CGainPzPage::OnCbnSelchangeOptComboGaia()
00570 {
00571         CboUpdate(dciGAIA);
00572
00573         // Update the Visual Display
00574         CString strAnalogGain;
00575         CString strFormat="%.3fx";
00576         if (s.profile->device_type == dppMCA8000D) {
00577                 strFormat="%.0fx";
00578         }
00579         strAnalogGain = "";
00580         CComboBox &cb = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_GAIA);
00581         int idx = cb.GetCurSel();
00582         if ((idx > LB_ERR) && (idx < DppGain.GainTableCount)) {
00583                 strAnalogGain.Format(strFormat, DppGain.ptrGainTable[idx]);
00584         }
00585         GetDlgItem(IDC_OPT_VALUE_GAIA)->SetWindowText(strAnalogGain);
00586         UpdateGainValue();                              // update gain value display
00587
00588 }
00589
00590 void CGainPzPage::OnEnChangeOptTextPapz()
00591 {
00592         TextUpdate(dciPAPZ);
00593 }
00594
00595 void CGainPzPage::OnEnChangeOptTextResl()
00596 {
00597         TextUpdate(dciRESL);
00598 }
00599
00600 void CGainPzPage::OnEnChangeOptTextInof()
00601 {
00602         TextUpdate(dciINOF);
00603 }
00604
00605 void CGainPzPage::OnEnChangeOptTextGain()
00606 {
00607         TextUpdate(dciGAIN);
00608 }
00609
00610 void CGainPzPage::UpdateGainValue()
00611 {
00612         // get coarse gain
00613         CString strAnalogGain;
00614         double dblCoarseGain;
00615         strAnalogGain = "";
00616         CComboBox &cb = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_GAIA);
00617         int idx = cb.GetCurSel();
00618         if ((idx > LB_ERR) && (idx < DppGain.GainTableCount)) {
00619                 dblCoarseGain = DppGain.ptrGainTable[idx];
00620         } else {
00621                 dblCoarseGain = DppGain.ptrGainTable[DppGain.GainTableCount - 1];
00622         }
00623         // get fine gain
00624         CString strGAIF;
00625         double dblFineGain;
00626         GetDlgItem(IDC_OPT_TEXT_GAIF)->GetWindowText(strGAIF);
00627         if (strGAIF.GetLength() > 0) {
00628                 dblFineGain = atof(strGAIF);
00629                 if ((dblFineGain > 1.250) || (dblFineGain < 0.750)) {
00630                         dblFineGain = 1.000;
00631                 }
00632         } else {
00633                 dblFineGain = 1.000;
00634         }
00635         double dblTotalGain;
00636         // calculate total gain
00637         dblTotalGain = dblCoarseGain * dblFineGain;
00638         // check for errors
00639         if (dblTotalGain < DppGain.MinGain) {
00640                 dblTotalGain = DppGain.MinGain;
00641         } else if (dblTotalGain > DppGain.MaxGain) {
00642                 dblTotalGain = DppGain.MaxGain;
00643         }
00644         strAnalogGain.Format("%.3fx",dblTotalGain);
00645         GetDlgItem(IDC_OPT_VALUE_GAIN)->SetWindowText(strAnalogGain);
00646 }
00647
00648 void CGainPzPage::OnEnChangeOptTextGaif()
00649 {
00650         TextUpdate(dciGAIF);
00651 }
00652
00653 BOOL CGainPzPage::PreTranslateMessage(MSG* pMsg)
00654 {
00655         // TODO: Add your specialized code here and/or call the base class
00656         //==================================================================
00657         MSG msg = *pMsg;
00658         if (msg.message == WM_MOUSEMOVE) {      // Relay events to the tooltip control
00659                 msg.hwnd = (HWND)m_ToolTip.SendMessage(TTM_WINDOWFROMPOINT, 0, (LPARAM)&msg.pt);
00660                 CPoint pt = pMsg->pt;
00661                 ::ScreenToClient(msg.hwnd, &pt);
00662                 msg.lParam = MAKELONG(pt.x, pt.y);
00663                 m_ToolTip.Activate(TRUE);   // make sure tooltip is active
00664                 m_ToolTip.RelayEvent(&msg); // Let the ToolTip process this message.
00665         } else if ( pMsg->message == WM_KEYDOWN && pMsg->wParam == VK_RETURN ) {
00666                 CWnd* pCurrent= GetFocus();
00667                 int ctrl = pCurrent->GetDlgCtrlID();
00668                 //if (ctrl == IDC_OPT_TEXT_GAIF) {
00669
00670                 //} else
00671                 if (isCEditBox(ctrl)) {
00672                         ::SendMessage(this->m_hWnd, WM_COMMAND, MAKEWPARAM(ctrl, EN_CHANGE), (LPARAM) m_hWnd);
00673                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00674                         pMsg->wParam = VK_TAB;
00675                         //if ( pNext != NULL ) {
00676                         //      if (pNext->GetDlgCtrlID() != IDOK ) {
00677                         //              pNext->SetFocus();
00678                         //              return TRUE;
00679                         //      }
00680                         //}
00681                 } else if (isCComboBox(ctrl)) {
00682                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00683                         pMsg->wParam = VK_TAB;
00684                 }
00685         }
00686
00687         //==================================================================
00688         return CCfgPropPage::PreTranslateMessage(pMsg);
00689 }
00690
00691 BOOL CGainPzPage::isCEditBox(int nID)
00692 {
00693         BOOL isEdit = FALSE;
00694         switch (nID) {
00695                 case IDC_OPT_TEXT_RESL:
00696                         isEdit = TRUE;
00697                         break;
00698                 case IDC_OPT_TEXT_INOF:
00699                         isEdit = TRUE;
00700                         break;
00701                 case IDC_OPT_TEXT_GAIN:
00702                         isEdit = TRUE;
00703                         break;
00704                 case IDC_OPT_TEXT_GAIF:
00705                         isEdit = TRUE;
00706                         break;
00707                 case IDC_OPT_TEXT_PAPZ:
00708                         isEdit = TRUE;
00709                         break;
00710         }
00711         return isEdit;
00712 }
00713
00714 BOOL CGainPzPage::isCComboBox(int nID)
00715 {
00716         BOOL isCombo = FALSE;
00717         switch (nID) {
00718                 case IDC_OPT_COMBO_RESL:
00719                         isCombo = TRUE;
00720                         break;
00721                 case IDC_OPT_COMBO_AINP:
00722                         isCombo = TRUE;
00723                         break;
00724                 case IDC_OPT_COMBO_INOF:
00725                         isCombo = TRUE;
00726                         break;
00727                 case IDC_OPT_COMBO_GAIA:
00728                         isCombo = TRUE;
00729                         break;
00730                 case IDC_OPT_COMBO_PAPZ:
00731                         isCombo = TRUE;
00732                         break;
00733         }
00734         return isCombo;
00735 }
00736
00737 void CGainPzPage::OnBnClickedButtonFineGainEnter()
00738 {
00739         CString strGAIF;
00740         double dblGAIF;
00741         GetDlgItem(IDC_OPT_TEXT_GAIF)->GetWindowText(strGAIF);
00742         if (strGAIF.GetLength() > 0) {
00743                 dblGAIF = atof(strGAIF);
00744                 if ((dblGAIF > dblGAIF_Max) || (dblGAIF < dblGAIF_Min)) {
00745                         strGAIF = "1.000";
00746                         dblGAIF = 1.000;
00747                         GetDlgItem(IDC_OPT_TEXT_GAIF)->SetWindowText(strGAIF);
00748                 }
00749         } else {
00750                 strGAIF = "1.000";
00751                 dblGAIF = 1.000;
00752                 GetDlgItem(IDC_OPT_TEXT_GAIF)->SetWindowText(strGAIF);
00753         }
00754         UpdateGainValue();                              // update gain value display
00755 }
00756
00757 void CGainPzPage::OnCbnSelchangeOptComboGainSelect()
00758 {
00759         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIN_SELECT);
00760         s.profile->SendCoarseFineGain = pCombo->GetCurSel();
00761 }
00762
00763 void CGainPzPage::OnBnClickedButtonCoarseFineToTotal()
00764 {
00765         CString strGain;
00766         double dblGain;
00767
00768                                                                 // get coarse (analog) * fine gain from display label
00769         GetDlgItem(IDC_OPT_VALUE_GAIN)->GetWindowText(strGain);
00770         dblGain = atof(strGain);        // test for total gain errors
00771         if (dblGain < DppGain.MinGain) {
00772                 strGain.Format("%.2f",DppGain.MinGain);
00773         } else if (dblGain > DppGain.MaxGain) {
00774                 strGain.Format("%.1f",DppGain.MaxGain);
00775         }
00776         GetDlgItem(IDC_OPT_TEXT_GAIN)->SetWindowText(strGain);
00777 }
00778
00779 void CGainPzPage::OnBnClickedButtonTotalToCoarseFine()
00780 {
00781         CString strGain;
00782         CString strFine;
00783         CString strCoarse;
00784         CString strTotal;
00785
00786         double dblGain;
00787         double prevGain, curGain;
00788         int idxGain;
00789
00790         GetDlgItem(IDC_OPT_TEXT_GAIN)->GetWindowText(strGain);  // get total gain
00791         // use dp5 algrorithm to split into coarse (analog) and fine gains
00792         dblGain = atof(strGain);
00793         if (dblGain < DppGain.MinGain) {
00794                 dblGain = DppGain.MinGain;
00795         } else if (dblGain > DppGain.MaxGain) {
00796                 dblGain = DppGain.MaxGain;
00797         }
00798
00799         idxGain = 0;
00800         prevGain = fabs(dblGain - DppGain.ptrGainTable[0]);
00801         curGain = fabs(dblGain - DppGain.ptrGainTable[1]);
00802         while((prevGain > curGain) && (idxGain < (DppGain.GainTableCount - 1)))
00803         {
00804                 idxGain++;
00805                 prevGain = curGain;
00806                 curGain = fabs(dblGain - DppGain.ptrGainTable[idxGain+1]);
00807         }
00808         curGain = dblGain / DppGain.ptrGainTable[idxGain];         // f = required fine gain, 1.15 fixed point
00809
00810         //strGain.Format("Total In: %.3fx ",dblGain);
00811         //strCoarse.Format("Coarse: %.3fx ",DP5_Gain[idxGain]);
00812         //strFine.Format("Fine: %.4fx ",curGain);
00813         //strTotal.Format("Total Out: %.3fx ",(DP5_Gain[idxGain] * curGain));
00814         //AfxMessageBox(strGain + strCoarse + strFine + strTotal);
00815
00816         strFine.Format("%.3f",curGain);
00817         GetDlgItem(IDC_OPT_TEXT_GAIF)->SetWindowText(strFine);          // set fine gain
00818         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIA);
00819         pCombo->SetCurSel(idxGain);
00820         OnBnClickedButtonFineGainEnter();
00821         UpdateOptComboGAIA();                           // update display control
00822         OnCbnSelchangeOptComboGaia2();          // update text value
00823 }
00824
00825 void CGainPzPage::OnCbnSelchangeOptComboGaia2()
00826 {
00827         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIA);
00828         CComboBox* pCombo2 = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIA2);
00829         pCombo->SetCurSel(pCombo2->GetCurSel());
00830         OnCbnSelchangeOptComboGaia();
00831 }
00832
00833 void CGainPzPage::UpdateOptComboGAIA()
00834 {
00835         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIA);
00836         CComboBox* pCombo2 = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_GAIA2);
00837         pCombo2->SetCurSel(pCombo->GetCurSel());
00838 }
00839
00840 // 25.6uS, 51.2uS, 102.4uS, 204.8uS, 409.6uS, 819.2uS, 1638.4uS, 3276.8uS
00841 // 102.4uS, 204.8uS, 409.6uS, 819.2uS, 1638.4uS, 3276.8uS, 6553.6uS, 13107.2uS
00842 void CGainPzPage::SetDetResetValues(int nID, BOOL is80MHz)
00843 {
00844         CComboBox* pCombo = (CComboBox*)GetDlgItem(nID);
00845         pCombo->ResetContent();
00846         if (is80MHz) {  //FPGA clock=80MHz
00847                 pCombo->AddString("OFF");
00848                 pCombo->AddString("25.6");
00849                 pCombo->AddString("51.2");
00850                 pCombo->AddString("102.4");
00851                 pCombo->AddString("204.8");
00852                 pCombo->AddString("409.6");
00853                 pCombo->AddString("819.2");
00854                 pCombo->AddString("1638.4");
00855                 pCombo->AddString("3276.8");
00856         } else {                //FPGA clock=20MHz
00857                 pCombo->AddString("OFF");
00858                 pCombo->AddString("102.4");
00859                 pCombo->AddString("204.8");
00860                 pCombo->AddString("409.6");
00861                 pCombo->AddString("819.2");
00862                 pCombo->AddString("1638.4");
00863                 pCombo->AddString("3276.8");
00864                 pCombo->AddString("6553.6");
00865                 pCombo->AddString("13107.2");
00866         }
00867 }
00868
00869 void CGainPzPage::InitCombo(HWND hDlg, DP5_CONFIGURATION cfg, int nID)
00870 {
00871         CString strVal = cfg.Setting;
00872         int idxList;
00873
00874         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00875         //idxList = s.CtrlUtil.FindCboIdx(hDlg,nID,strVal);
00876         idxList = s.CtrlUtil.FindCboIdxExact(hDlg,nID,strVal);  // try exact first
00877         if (idxList == LB_ERR) {
00878                 idxList = s.CtrlUtil.FindCboIdx(hDlg,nID,strVal);
00879         }
00880         if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00881                 strVal = cfg.TextValue;
00882                 if (strVal.Find('#') >= 0) {    // try the text
00883                         idxList = s.CtrlUtil.FindCboIdx(hDlg,nID,strVal);
00884                         if (idxList == LB_ERR) { // not found default to 0
00885                                 idxList = 0;
00886                         }
00887                 } else {
00888                         idxList = 0;            // set to first item
00889                 }
00890         }
00891         cb.SetCurSel(idxList);
00892 }
00893
00894 void CGainPzPage::OnCbnSelchangeOptComboResl2()
00895 {
00896         CString strRESL;
00897         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_RESL);
00898         CComboBox* pCombo2 = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_RESL2);
00899         int iRESL = pCombo2->GetCurSel();
00900         if (iRESL > 0) {        //have value
00901                 pCombo->SetCurSel(0);
00902                 CboUpdate(dciRESL);
00903                 pCombo2->GetWindowText(strRESL);
00904                 TextUpdate(dciRESL);
00905                 GetDlgItem(IDC_OPT_TEXT_RESL)->SetWindowText(strRESL);
00906         } else {                        // off
00907                 pCombo->SetCurSel(1);
00908                 CboUpdate(dciRESL);
00909         }
00910 }
00911
00912 //s.DppConfig.bGammaRadHVMode;          // GammaRad HV
00913 //s.DppConfig.bConfigHVPolarity;        // Detector HV Polarity, for setup warnings
00914 //s.DppConfig.bPC5Detected;                     // PC5 connected,PX5 HV Pwr Error
00915 //s.DppConfig.bBootHVPolarity;          // HV Polarity from status packet
00916 //s.DppConfig.bAnalogPolarity;          // Analog Input Polarity, for setup warnings
00917 //m_PowerHvWarning==IDC_STATIC_HV_WARNING
00918 void CGainPzPage::SetHvPowerWarning()
00919 {
00920         CString strPolarity;
00921         CString strWarning;
00922         m_PowerHvWarning.ShowWindow(SW_HIDE);
00923         if (s.isDppConnected) {
00924                 // disable warnings for px5 with HPGe option
00925                 if ((s.profile->device_type == dppPX5) && (s.DP5Stat.m_DP5_Status.DPP_options == PX5_OPTION_HPGe_HVPS)) {
00926                         return;
00927                 }
00928                 if (s.DppConfig.bPC5Detected) {
00929                         if (s.DppConfig.bConfigHVPolarity == s.DppConfig.bAnalogPolarity) {
00930                                 m_PowerHvWarning.ShowWindow(SW_SHOW);
00931                                 strWarning = " Input and HV polarity \r incorrect for Amptek detectors";
00932                                 if (s.DppConfig.bAnalogPolarity) {
00933                                         strPolarity = " \r BOTH + (POS)";
00934                                 } else {
00935                                         strPolarity = " \r BOTH - (NEG)";
00936                                 }
00937                                 m_PowerHvWarning.SetWindowText(strWarning + strPolarity);
00938                         } else {
00939                                 m_PowerHvWarning.SetWindowText("");
00940                         }
00941                 } else if (s.profile->device_type == dppPX5) {
00942                         m_PowerHvWarning.ShowWindow(SW_SHOW);
00943                         m_PowerHvWarning.SetWindowText("PX5 HV Power Error");
00944                 } else {        // no pc5 or hv detected
00945                         m_PowerHvWarning.SetWindowText("");
00946                 }
00947         } else {                // not connected
00948                 m_PowerHvWarning.SetWindowText("");
00949         }
00950 }
00951
00953 // HtmlHelp for shared dialog
00954 // NOTE: shared dialogs use string type IDD, not global IDD
00955 BOOL CGainPzPage::OnHelpInfo(HELPINFO* pHelpInfo)
00956 {
00957         CString strHelp;
00958         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
00959                 if (pHelpInfo->dwContextId == 0) {
00960                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_GAINPZ_PAGE);
00961                 } else {
00962                         //
00963                 }
00964         }
00965         return true;
00966 }
00967
00968 void CGainPzPage::OnHelp()                              // enable property sheet help button help
00969 {
00970         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_GAINPZ_PAGE);
00971     //SendMessage(WM_COMMANDHELP);      //
00972 }
00974
00975 void CGainPzPage::BuildToolTips()
00976 {
00977         if (!m_ToolTip.Create(this)) {
00978                 TRACE0("Unable to create ToolTip control\n");
00979         } else {
00980         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_AINP), IDS_TT_ANALOG_INPUT);
00981         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_AINP), IDS_TT_ANALOG_INPUT);
00982         m_ToolTip.AddTool(GetDlgItem(IDC_BUTTON_TOTAL_TO_COARSE_FINE), IDS_TT_ARROWS);
00983         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_VALUE_GAIA), IDS_TT_COARSE_GAIN);
00984         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GAIA), IDS_TT_COARSE_GAIN);
00985         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GAIA), IDS_TT_COARSE_GAIN);
00986         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_GAIF), IDS_TT_FINE_GAIN);
00987         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_GAIF), IDS_TT_FINE_GAIN);
00988         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GAIF), IDS_TT_FINE_GAIN);
00989         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_GAIF), IDS_TT_FINE_GAIN);
00990         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_GAIN), IDS_TT_TOTAL_GAIN);
00991         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_VALUE_GAIN), IDS_TT_TOTAL_GAIN);
00992         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_GAIN), IDS_TT_TOTAL_GAIN);
00993         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_GAIN), IDS_TT_TOTAL_GAIN);
00994         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GAIN), IDS_TT_TOTAL_GAIN);
00995         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_INOF), IDS_TT_INPUT_OFFSET);
00996         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_INOF), IDS_TT_INPUT_OFFSET);
00997         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_INOF), IDS_TT_INPUT_OFFSET);
00998         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_INOF), IDS_TT_INPUT_OFFSET);
00999         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_INOF), IDS_TT_INPUT_OFFSET);
01000         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_GAINPZ_PAGE), IDS_TT);
01001         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_RESL), IDS_TT_RESET_LOCKOUT);
01002         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_RESL), IDS_TT_RESET_LOCKOUT);
01003         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_RESL), IDS_TT_RESET_LOCKOUT);
01004         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_RESL), IDS_TT_RESET_LOCKOUT);
01005         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_RESL), IDS_TT_RESET_LOCKOUT);
01006         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_GAIN_ADVANCED), IDS_TT);
01007         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_GAIN_BASIC), IDS_TT);
01008         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GAIN_SELECT), IDS_TT_SEND_TOTAL_OR_COARSE_FINE_GAIN);
01009         m_ToolTip.AddTool(GetDlgItem(IDC_BUTTON_FINE_GAIN_ENTER), IDS_TT_FINE_GAIN);
01010         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GAIA2), IDS_TT_COARSE_GAIN);
01011         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_GAIN_STANDARD), IDS_TT);
01012         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_AVANCED_GAIN_CONTROL), IDS_TT);
01013         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_RESL2), IDS_TT);
01014         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_RESL2), IDS_TT);
01015         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_RESL2), IDS_TT);
01016         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_HV_WARNING), IDS_TT);
01017         m_ToolTip.AddTool(GetDlgItem(IDC_BUTTON_COARSE_FINE_TO_TOTAL), IDS_TT_ARROWS);
01018
01019                 m_ToolTip.Activate(TRUE);
01020                 m_ToolTip.SetMaxTipWidth(200);
01021         }
01022 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/GainPzPage.h Source File

DP5Cfg/GainPzPage.h
Go to the documentation of this file.
00001 #if !defined(AFX_GainPzPage_H__INCLUDED_)
00002 #define AFX_GainPzPage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // GainPzPage.h : header file
00008 //
00009
00010 #include "DppGain.h"                            // dp5/px5/dp5g/mca8000d/tb5 analog gain tables
00011 #include "CfgPropSheet.h"
00012 #include "afxwin.h"
00013 #include "label.h"
00014
00016 // CGainPzPage dialog
00017
00018 class CGainPzPage : public CCfgPropPage
00019 {
00020         DECLARE_DYNCREATE(CGainPzPage)
00021
00022 // Construction
00023 public:
00024         CGainPzPage();
00025         ~CGainPzPage();
00026
00027 // Dialog Data
00028         //{{AFX_DATA(CGainPzPage)
00029         //enum { IDD = IDD_GAINPZ_PAGE };
00030         //}}AFX_DATA
00031
00032 // Overrides
00033         // ClassWizard generate virtual function overrides
00034         //{{AFX_VIRTUAL(CGainPzPage)
00035         protected:
00036         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00037         //}}AFX_VIRTUAL
00038
00039 // Implementation
00040 protected:
00041         // Generated message map functions
00042         //{{AFX_MSG(CGainPzPage)
00043         //}}AFX_MSG
00044         DECLARE_MESSAGE_MAP()
00045         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00046
00047 public:
00048         void BuildToolTips();                                                           // Tooltip control
00049
00050         //CStatic m_GainPzPageLabel;
00051         CLabel m_GainPzPageLabel;
00052         //CStatic m_GainAdvancedLabel;
00053         CLabel m_GainAdvancedLabel;
00054         //CStatic m_GainStandardLabel;
00055         CLabel m_GainStandardLabel;
00056         //CStatic m_PowerHvWarning;
00057         CLabel m_PowerHvWarning;
00058
00059         virtual BOOL OnSetActive();
00060         virtual BOOL OnInitDialog();
00061
00062         void InitControls();
00063         void ShowMCA8000D_Controls(int iShowWin);
00064         void CheckMCA8000D_FineGain();
00065
00066         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00067         void CboUpdate(int nID_dci);
00068         void TextUpdate(int nID_dci);
00069
00070         //FW6.07.04 and later: The reset lockout interval can be set with 1uS precision
00071         BOOL bEnableNewRESL;    // controls viewing of RESL textbox
00072         afx_msg void OnCbnSelchangeOptComboResl();
00073         afx_msg void OnCbnSelchangeOptComboAinp();
00074         afx_msg void OnCbnSelchangeOptComboInof();
00075         afx_msg void OnCbnSelchangeOptComboPapz();
00076         afx_msg void OnEnChangeOptTextPapz();
00077         afx_msg void OnEnChangeOptTextResl();
00078         afx_msg void OnEnChangeOptTextInof();
00079         afx_msg void OnEnChangeOptTextGain();
00080
00081         void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00082
00083         virtual BOOL PreTranslateMessage(MSG* pMsg);
00084         BOOL isCEditBox(int nID);
00085         BOOL isCComboBox(int nID);
00086
00087         afx_msg void OnCbnSelchangeOptComboGaia();
00088         afx_msg void OnEnChangeOptTextGaif();
00089
00090         void UpdateGainValue();
00091         double dblGAIF_Max;
00092         double dblGAIF_Min;
00093
00094         afx_msg void OnBnClickedButtonFineGainEnter();
00095         afx_msg void OnCbnSelchangeOptComboGainSelect();
00096         afx_msg void OnBnClickedButtonCoarseFineToTotal();
00097         afx_msg void OnBnClickedButtonTotalToCoarseFine();
00098         afx_msg void OnCbnSelchangeOptComboGaia2();
00099         void UpdateOptComboGAIA();
00100         void SetDetResetValues(int nID, BOOL is80MHz);
00101         afx_msg void OnCbnSelchangeOptComboResl2();
00102         void InitCombo(HWND hDlg, DP5_CONFIGURATION cfg, int nID);
00103         CComboBox m_CoarseGain_GAIA_value;
00104         CComboBox m_CoarseGain_GAIA_index;
00105         CDppGain DppGain;
00106         void SetHvPowerWarning();
00107         afx_msg void OnHelp();
00108         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00109 };
00110
00111 //{{AFX_INSERT_LOCATION}}
00112 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00113
00114 #endif // !defined(AFX_GainPzPage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/GainPzPageRes.h Source File

DP5Cfg/GainPzPageRes.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by GainPzPage.rc
00004 //
00005 #define IDC_OPT_UNITS_RESL2             1451
00006 #define IDC_OPT_COMBO_PAPZ              1539
00007 #define IDC_OPT_FRAME_PAPZ              1544
00008 #define IDC_OPT_LIMITS_PAPZ             1547
00009 #define IDC_OPT_TEXT_PAPZ               1550
00010 #define IDC_OPT_UNITS_PAPZ              1554
00011 #define IDC_STATIC_HV_WARNING           1560
00012 #define IDC_BUTTON_COARSE_FINE_TO_TOTAL 1664
00013 #define IDC_BUTTON_FINE_GAIN_ENTER      1665
00014 #define IDC_BUTTON_TOTAL_TO_COARSE_FINE 1666
00015 #define IDC_OPT_COMBO_AINP              1667
00016 #define IDC_OPT_COMBO_GAIA              1668
00017 #define IDC_OPT_COMBO_GAIA2             1669
00018 #define IDC_OPT_COMBO_GAIN_SELECT       1670
00019 #define IDC_OPT_COMBO_INOF              1671
00020 #define IDC_OPT_COMBO_RESL              1672
00021 #define IDC_OPT_COMBO_RESL2             1673
00022 #define IDC_OPT_FRAME_AINP              1674
00023 #define IDC_OPT_FRAME_GAIA              1675
00024 #define IDC_OPT_FRAME_GAIF              1676
00025 #define IDC_OPT_FRAME_GAIN              1677
00026 #define IDC_OPT_FRAME_INOF              1678
00027 #define IDC_OPT_FRAME_RESL              1679
00028 #define IDC_OPT_FRAME_RESL2             1680
00029 #define IDC_OPT_LIMITS_GAIF             1681
00030 #define IDC_OPT_LIMITS_GAIN             1682
00031 #define IDC_OPT_LIMITS_INOF             1683
00032 #define IDC_OPT_LIMITS_RESL             1684
00033 #define IDC_OPT_TEXT_GAIF               1685
00034 #define IDC_OPT_TEXT_GAIN               1686
00035 #define IDC_OPT_TEXT_INOF               1687
00036 #define IDC_OPT_TEXT_RESL               1688
00037 #define IDC_OPT_UNITS_GAIF              1689
00038 #define IDC_OPT_UNITS_GAIN              1690
00039 #define IDC_OPT_UNITS_INOF              1691
00040 #define IDC_OPT_UNITS_RESL              1692
00041 #define IDC_OPT_VALUE_GAIA              1693
00042 #define IDC_OPT_VALUE_GAIN              1694
00043 #define IDC_STATIC_AVANCED_GAIN_CONTROL 1695
00044 #define IDC_STATIC_GAIN_ADVANCED        1696
00045 #define IDC_STATIC_GAIN_BASIC           1697
00046 #define IDC_STATIC_GAIN_STANDARD        1698
00047 #define IDC_STATIC_GAINPZ_PAGE          1699
00048 #define IDC_STATIC_TOTAL_OR_BOTH_LABEL  1700
00049 #define IDS_TT_TOTAL_GAIN               5888
00050 #define IDS_TT_SEND_TOTAL_OR_COARSE_FINE_GAIN 5889
00051 #define IDS_TT_COARSE_GAIN              5890
00052 #define IDS_TT_FINE_GAIN                5891
00053 #define IDS_TT_ARROWS                   5892
00054 #define IDS_TT_INPUT_OFFSET             5893
00055 #define IDS_TT_ANALOG_INPUT             5894
00056 #define IDS_TT_RESET_LOCKOUT            5895
00057
00058 // Next default values for new objects
00059 //
00060 #ifdef APSTUDIO_INVOKED
00061 #ifndef APSTUDIO_READONLY_SYMBOLS
00062 #define _APS_NEXT_RESOURCE_VALUE        5896
00063 #define _APS_NEXT_COMMAND_VALUE         33376
00064 #define _APS_NEXT_CONTROL_VALUE         1701
00065 #define _APS_NEXT_SYMED_VALUE           5896
00066 #endif
00067 #endif
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: hlp/HTMLDefines.h Source File

hlp/HTMLDefines.h
Go to the documentation of this file.
00001
00002 // Commands (ID_* and IDM_*)
00003 #define HIDM_ABOUTBOX                           0x10010
00004 #define HID_FILE_TAB                            0x18128
00005 #define HID_GAINPZ_TAB                          0x18131
00006 #define HID_MCA_TAB                             0x18144
00007 #define HID_MISC_TAB                            0x18147
00008 #define HID_POWER_TAB                           0x1814E
00009 #define HID_SHAPING_TAB                         0x18160
00010 #define HID_HELP_ABOUT                          0x19C43
00011
00012 // Prompts (IDP_*)
00013 #define HIDP_SOCKETS_INIT_FAILED                0x3105A
00014
00015 // Resources (IDR_*)
00016 #define HIDR_MAINFRAME                          0x2105C
00017 #define HIDR_MENU                               0x2105D
00018 #define HIDR_TOOLBAR                            0x21064
00019 #define HIDR_TOOLBAR_DP5_DLG                    0x21065
00020
00021 // Dialogs (IDD_*)
00022 #define HIDD_ABOUTBOX                           0x20064
00023 #define HIDD_BUSY_DLG                           0x21036
00024 #define HIDD_MESSAGE_BOX                        0x2103F
00025 #define HIDD_vcDP5_DIALOG                       0x21C00
00026
00027 // Frame Controls (IDW_*)
00028 // This is a part of the Microsoft Foundation Classes C++ library.
00029 // Copyright (C) Microsoft Corporation
00030 // All rights reserved.
00031 //
00032 // This source code is only intended as a supplement to the
00033 // Microsoft Foundation Classes Reference and related
00034 // electronic documentation provided with the library.
00035 // See these sources for detailed information regarding the
00036 // Microsoft Foundation Classes product.
00037
00038 // Non-Client HitTest help IDs
00039 #define HID_HT_NOWHERE                          0x40000
00040 #define HID_HT_CAPTION                          0x40002
00041 #define HID_HT_SIZE                             0x40004
00042 #define HID_HT_HSCROLL                          0x40006
00043 #define HID_HT_VSCROLL                          0x40007
00044 #define HID_HT_MINBUTTON                        0x40008
00045 #define HID_HT_MAXBUTTON                        0x40009
00046 #define HID_HT_SIZE                             0x4000A // alias: ID_HT_LEFT
00047 #define HID_HT_SIZE                             0x4000B // alias: ID_HT_RIGHT
00048 #define HID_HT_SIZE                             0x4000C // alias: ID_HT_TOP
00049 #define HID_HT_SIZE                             0x4000D // alias: ID_HT_TOPLEFT
00050 #define HID_HT_SIZE                             0x4000E // alias: ID_HT_TOPRIGHT
00051 #define HID_HT_SIZE                             0x4000F // alias: ID_HT_BOTTOM
00052 #define HID_HT_SIZE                             0x40010 // alias: ID_HT_BOTTOMLEFT
00053 #define HID_HT_SIZE                             0x40011 // alias: ID_HT_BOTTOMRIGHT
00054 #define HID_HT_SIZE                             0x40012 // alias: ID_HT_BORDER
00055 #define HID_HT_OBJECT                                                   0x40013
00056 #define HID_HT_CLOSE                                                    0x40014
00057 #define HID_HT_HELP                                                             0x40015
00058
00059 // WM_SYSCOMMAND help IDs
00060 #define HID_SC_SIZE                             0x1EF00
00061 #define HID_SC_MOVE                             0x1EF01
00062 #define HID_SC_MINIMIZE                         0x1EF02
00063 #define HID_SC_MAXIMIZE                         0x1EF03
00064 #define HID_SC_NEXTWINDOW                       0x1EF04
00065 #define HID_SC_PREVWINDOW                       0x1EF05
00066 #define HID_SC_CLOSE                            0x1EF06
00067 #define HID_SC_RESTORE                          0x1EF12
00068 #define HID_SC_TASKLIST                         0x1EF13
00069
00070 // File MRU and aliases
00071 #define HID_FILE_MRU_FILE1                      0x1E110
00072 #define HID_FILE_MRU_FILE1                      0x1E111 // aliases: MRU_2 - MRU_16
00073 #define HID_FILE_MRU_FILE1                      0x1E112
00074 #define HID_FILE_MRU_FILE1                      0x1E113
00075 #define HID_FILE_MRU_FILE1                      0x1E114
00076 #define HID_FILE_MRU_FILE1                      0x1E115
00077 #define HID_FILE_MRU_FILE1                      0x1E116
00078 #define HID_FILE_MRU_FILE1                      0x1E117
00079 #define HID_FILE_MRU_FILE1                      0x1E118
00080 #define HID_FILE_MRU_FILE1                      0x1E119
00081 #define HID_FILE_MRU_FILE1                      0x1E11A
00082 #define HID_FILE_MRU_FILE1                      0x1E11B
00083 #define HID_FILE_MRU_FILE1                      0x1E11C
00084 #define HID_FILE_MRU_FILE1                      0x1E11D
00085 #define HID_FILE_MRU_FILE1                      0x1E11E
00086 #define HID_FILE_MRU_FILE1                      0x1E11F
00087
00088 // Window menu list
00089 #define HID_WINDOW_ALL                          0x1EF1F
00090
00091 // OLE menu and aliases
00092 #define HID_OLE_VERB_1                          0x1E210
00093 #define HID_OLE_VERB_1                          0x1E211 // aliases: VERB_2 -> VERB_16
00094 #define HID_OLE_VERB_1                          0x1E212
00095 #define HID_OLE_VERB_1                          0x1E213
00096 #define HID_OLE_VERB_1                          0x1E214
00097 #define HID_OLE_VERB_1                          0x1E215
00098 #define HID_OLE_VERB_1                          0x1E216
00099 #define HID_OLE_VERB_1                          0x1E217
00100 #define HID_OLE_VERB_1                          0x1E218
00101 #define HID_OLE_VERB_1                          0x1E219
00102 #define HID_OLE_VERB_1                          0x1E21A
00103 #define HID_OLE_VERB_1                          0x1E21B
00104 #define HID_OLE_VERB_1                          0x1E21C
00105 #define HID_OLE_VERB_1                          0x1E21D
00106 #define HID_OLE_VERB_1                          0x1E21E
00107 #define HID_OLE_VERB_1                          0x1E21F
00108
00109 // Commands (HID_*)
00110 #define HID_FILE_NEW                            0x1E100
00111 #define HID_FILE_OPEN                           0x1E101
00112 #define HID_FILE_CLOSE                          0x1E102
00113 #define HID_FILE_SAVE                           0x1E103
00114 #define HID_FILE_SAVE_AS                        0x1E104
00115 #define HID_FILE_PAGE_SETUP                     0x1E105
00116 #define HID_FILE_PRINT_SETUP                    0x1E106
00117 #define HID_FILE_PRINT                          0x1E107
00118 #define HID_FILE_PRINT_DIRECT                   0x1E108
00119 #define HID_FILE_PRINT_PREVIEW                  0x1E109
00120 #define HID_FILE_UPDATE                         0x1E10A
00121 #define HID_FILE_SAVE_COPY_AS                   0x1E10B
00122 #define HID_FILE_SEND_MAIL                      0x1E10C
00123 #define HID_EDIT_CLEAR                          0x1E120
00124 #define HID_EDIT_CLEAR_ALL                      0x1E121
00125 #define HID_EDIT_COPY                           0x1E122
00126 #define HID_EDIT_CUT                            0x1E123
00127 #define HID_EDIT_FIND                           0x1E124
00128 #define HID_EDIT_PASTE                          0x1E125
00129 #define HID_EDIT_PASTE_LINK                     0x1E126
00130 #define HID_EDIT_PASTE_SPECIAL                  0x1E127
00131 #define HID_EDIT_REPEAT                         0x1E128
00132 #define HID_EDIT_REPLACE                        0x1E129
00133 #define HID_EDIT_SELECT_ALL                     0x1E12A
00134 #define HID_EDIT_UNDO                           0x1E12B
00135 #define HID_EDIT_REDO                           0x1E12C
00136 #define HID_WINDOW_NEW                          0x1E130
00137 #define HID_WINDOW_ARRANGE                      0x1E131
00138 #define HID_WINDOW_CASCADE                      0x1E132
00139 #define HID_WINDOW_TILE_HORZ                    0x1E133
00140 #define HID_WINDOW_TILE_VERT                    0x1E134
00141 #define HID_WINDOW_SPLIT                        0x1E135
00142 #define HID_APP_ABOUT                           0x1E140
00143 #define HID_APP_EXIT                            0x1E141
00144 #define HID_HELP_INDEX                          0x1E142
00145 #define HID_HELP_FINDER                         0x1E143
00146 #define HID_HELP_USING                          0x1E144
00147 #define HID_CONTEXT_HELP                        0x1E145
00148 #define HID_NEXT_PANE                           0x1E150
00149 #define HID_PREV_PANE                           0x1E151
00150 #define HID_FORMAT_FONT                         0x1E160
00151 #define HID_OLE_INSERT_NEW                      0x1E200
00152 #define HID_OLE_EDIT_LINKS                      0x1E201
00153 #define HID_OLE_EDIT_CONVERT                    0x1E202
00154 #define HID_OLE_EDIT_CHANGE_ICON                0x1E203
00155 #define HID_OLE_EDIT_PROPERTIES                 0x1E204
00156 #define HID_VIEW_TOOLBAR                        0x1E800
00157 #define HID_VIEW_STATUS_BAR                     0x1E801
00158 #define HID_RECORD_FIRST                        0x1E900
00159 #define HID_RECORD_LAST                         0x1E901
00160 #define HID_RECORD_NEXT                         0x1E902
00161 #define HID_RECORD_PREV                         0x1E903
00162 #define HID_WIZBACK                             0x13023
00163 #define HID_WIZNEXT                             0x13024
00164 #define HID_WIZFINISH                           0x13025
00165
00166 // Dialogs (AFX_HIDD_*)
00167 #define AFX_HIDD_FILEOPEN                       0x27004
00168 #define AFX_HIDD_FILESAVE                       0x27005
00169 #define AFX_HIDD_FONT                           0x27006
00170 #define AFX_HIDD_COLOR                          0x27007
00171 #define AFX_HIDD_PRINT                          0x27008
00172 #define AFX_HIDD_PRINTSETUP                     0x27009
00173 #define AFX_HIDD_FIND                           0x2700A
00174 #define AFX_HIDD_REPLACE                        0x2700B
00175 #define AFX_HIDD_NEWTYPEDLG                     0x27801
00176 #define AFX_HIDD_PRINTDLG                       0x27802
00177 #define AFX_HIDD_PREVIEW_TOOLBAR                0x27803
00178 #define AFX_HIDD_PREVIEW_SHORTTOOLBAR           0x2780B
00179 #define AFX_HIDD_INSERTOBJECT                   0x27804
00180 #define AFX_HIDD_CHANGEICON                     0x27805
00181 #define AFX_HIDD_CONVERT                        0x27806
00182 #define AFX_HIDD_PASTESPECIAL                   0x27807
00183 #define AFX_HIDD_EDITLINKS                      0x27808
00184 #define AFX_HIDD_FILEBROWSE                     0x27809
00185 #define AFX_HIDD_BUSY                           0x2780A
00186 #define AFX_HIDD_OBJECTPROPERTIES               0x2780C
00187 #define AFX_HIDD_CHANGESOURCE                   0x2780D
00188
00189 // Prompts/Errors (AFX_HIDP_*)
00190 #define AFX_HIDP_NO_ERROR_AVAILABLE             0x3F020
00191 #define AFX_HIDP_INVALID_FILENAME               0x3F100
00192 #define AFX_HIDP_FAILED_TO_OPEN_DOC             0x3F101
00193 #define AFX_HIDP_FAILED_TO_SAVE_DOC             0x3F102
00194 #define AFX_HIDP_ASK_TO_SAVE                    0x3F103
00195 #define AFX_HIDP_FAILED_TO_CREATE_DOC           0x3F104
00196 #define AFX_HIDP_FILE_TOO_LARGE                 0x3F105
00197 #define AFX_HIDP_FAILED_TO_START_PRINT          0x3F106
00198 #define AFX_HIDP_FAILED_TO_LAUNCH_HELP          0x3F107
00199 #define AFX_HIDP_INTERNAL_FAILURE               0x3F108
00200 #define AFX_HIDP_COMMAND_FAILURE                0x3F109
00201 #define AFX_HIDP_FAILED_MEMORY_ALLOC            0x3F10A
00202 #define AFX_HIDP_UNREG_DONE                     0x3F10B
00203 #define AFX_HIDP_UNREG_FAILURE                  0x3F10C
00204 #define AFX_HIDP_DLL_LOAD_FAILED                0x3F10D
00205 #define AFX_HIDP_DLL_BAD_VERSION                0x3F10E
00206 #define AFX_HIDP_PARSE_INT                      0x3F110
00207 #define AFX_HIDP_PARSE_REAL                     0x3F111
00208 #define AFX_HIDP_PARSE_INT_RANGE                0x3F112
00209 #define AFX_HIDP_PARSE_REAL_RANGE               0x3F113
00210 #define AFX_HIDP_PARSE_STRING_SIZE              0x3F114
00211 #define AFX_HIDP_PARSE_RADIO_BUTTON             0x3F115
00212 #define AFX_HIDP_PARSE_BYTE                     0x3F116
00213 #define AFX_HIDP_PARSE_UINT                     0x3F117
00214 #define AFX_HIDP_PARSE_DATETIME                 0x3F118
00215 #define AFX_HIDP_PARSE_CURRENCY                 0x3F119
00216 #define AFX_HIDP_FAILED_INVALID_FORMAT          0x3F120
00217 #define AFX_HIDP_FAILED_INVALID_PATH            0x3F121
00218 #define AFX_HIDP_FAILED_DISK_FULL               0x3F122
00219 #define AFX_HIDP_FAILED_ACCESS_READ             0x3F123
00220 #define AFX_HIDP_FAILED_ACCESS_WRITE            0x3F124
00221 #define AFX_HIDP_FAILED_IO_ERROR_READ           0x3F125
00222 #define AFX_HIDP_FAILED_IO_ERROR_WRITE          0x3F126
00223 #define AFX_HIDP_STATIC_OBJECT                  0x3F180
00224 #define AFX_HIDP_FAILED_TO_CONNECT              0x3F181
00225 #define AFX_HIDP_SERVER_BUSY                    0x3F182
00226 #define AFX_HIDP_BAD_VERB                       0x3F183
00227 #define AFX_HIDP_FAILED_TO_NOTIFY               0x3F185
00228 #define AFX_HIDP_FAILED_TO_LAUNCH               0x3F186
00229 #define AFX_HIDP_ASK_TO_UPDATE                  0x3F187
00230 #define AFX_HIDP_FAILED_TO_UPDATE               0x3F188
00231 #define AFX_HIDP_FAILED_TO_REGISTER             0x3F189
00232 #define AFX_HIDP_FAILED_TO_AUTO_REGISTER        0x3F18A
00233 #define AFX_HIDP_FAILED_TO_CONVERT              0x3F18B
00234 #define AFX_HIDP_GET_NOT_SUPPORTED              0x3F18C
00235 #define AFX_HIDP_SET_NOT_SUPPORTED              0x3F18D
00236 #define AFX_HIDP_ASK_TO_DISCARD                 0x3F18E
00237 #define AFX_HIDP_FAILED_TO_CREATE               0x3F18F
00238 #define AFX_HIDP_FAILED_MAPI_LOAD               0x3F190
00239 #define AFX_HIDP_INVALID_MAPI_DLL               0x3F191
00240 #define AFX_HIDP_FAILED_MAPI_SEND               0x3F192
00241 #define AFX_HIDP_FILE_NONE                      0x3F1A0
00242 #define AFX_HIDP_FILE_GENERIC                   0x3F1A1
00243 #define AFX_HIDP_FILE_NOT_FOUND                 0x3F1A2
00244 #define AFX_HIDP_FILE_BAD_PATH                  0x3F1A3
00245 #define AFX_HIDP_FILE_TOO_MANY_OPEN             0x3F1A4
00246 #define AFX_HIDP_FILE_ACCESS_DENIED             0x3F1A5
00247 #define AFX_HIDP_FILE_INVALID_FILE              0x3F1A6
00248 #define AFX_HIDP_FILE_REMOVE_CURRENT            0x3F1A7
00249 #define AFX_HIDP_FILE_DIR_FULL                  0x3F1A8
00250 #define AFX_HIDP_FILE_BAD_SEEK                  0x3F1A9
00251 #define AFX_HIDP_FILE_HARD_IO                   0x3F1AA
00252 #define AFX_HIDP_FILE_SHARING                   0x3F1AB
00253 #define AFX_HIDP_FILE_LOCKING                   0x3F1AC
00254 #define AFX_HIDP_FILE_DISKFULL                  0x3F1AD
00255 #define AFX_HIDP_FILE_EOF                       0x3F1AE
00256 #define AFX_HIDP_ARCH_NONE                      0x3F1B0
00257 #define AFX_HIDP_ARCH_GENERIC                   0x3F1B1
00258 #define AFX_HIDP_ARCH_READONLY                  0x3F1B2
00259 #define AFX_HIDP_ARCH_ENDOFFILE                 0x3F1B3
00260 #define AFX_HIDP_ARCH_WRITEONLY                 0x3F1B4
00261 #define AFX_HIDP_ARCH_BADINDEX                  0x3F1B5
00262 #define AFX_HIDP_ARCH_BADCLASS                  0x3F1B6
00263 #define AFX_HIDP_ARCH_BADSCHEMA                 0x3F1B7
00264 #define AFX_HIDP_SQL_CONNECT_FAIL               0x3F281
00265 #define AFX_HIDP_SQL_RECORDSET_FORWARD_ONLY     0x3F282
00266 #define AFX_HIDP_SQL_EMPTY_COLUMN_LIST          0x3F283
00267 #define AFX_HIDP_SQL_FIELD_SCHEMA_MISMATCH      0x3F284
00268 #define AFX_HIDP_SQL_ILLEGAL_MODE               0x3F285
00269 #define AFX_HIDP_SQL_MULTIPLE_ROWS_AFFECTED     0x3F286
00270 #define AFX_HIDP_SQL_NO_CURRENT_RECORD          0x3F287
00271 #define AFX_HIDP_SQL_NO_ROWS_AFFECTED           0x3F288
00272 #define AFX_HIDP_SQL_RECORDSET_READONLY         0x3F289
00273 #define AFX_HIDP_SQL_SQL_NO_TOTAL               0x3F28A
00274 #define AFX_HIDP_SQL_ODBC_LOAD_FAILED           0x3F28B
00275 #define AFX_HIDP_SQL_DYNASET_NOT_SUPPORTED      0x3F28C
00276 #define AFX_HIDP_SQL_SNAPSHOT_NOT_SUPPORTED     0x3F28D
00277 #define AFX_HIDP_SQL_API_CONFORMANCE            0x3F28E
00278 #define AFX_HIDP_SQL_SQL_CONFORMANCE            0x3F28F
00279 #define AFX_HIDP_SQL_NO_DATA_FOUND              0x3F290
00280 #define AFX_HIDP_SQL_ROW_UPDATE_NOT_SUPPORTED   0x3F291
00281 #define AFX_HIDP_SQL_ODBC_V2_REQUIRED           0x3F292
00282 #define AFX_HIDP_SQL_NO_POSITIONED_UPDATES      0x3F293
00283 #define AFX_HIDP_SQL_LOCK_MODE_NOT_SUPPORTED    0x3F294
00284 #define AFX_HIDP_SQL_DATA_TRUNCATED             0x3F295
00285 #define AFX_HIDP_SQL_ROW_FETCH                  0x3F296
00286 #define AFX_HIDP_SQL_INCORRECT_ODBC             0x3F297
00287 #define AFX_HIDP_SQL_UPDATE_DELETE_FAILED       0x3F298
00288 #define AFX_HIDP_SQL_DYNAMIC_CURSOR_NOT_SUPPORTED       0x3F299
00289 #define AFX_HIDP_SQL_FIELD_NOT_FOUND            0x3F29A
00290 #define AFX_HIDP_SQL_BOOKMARKS_NOT_SUPPORTED    0x3F29B
00291 #define AFX_HIDP_SQL_BOOKMARKS_NOT_ENABLED      0x3F29C
00292 #define AFX_HIDP_DAO_ENGINE_INITIALIZATION      0x3F2B0
00293 #define AFX_HIDP_DAO_DFX_BIND                   0x3F2B1
00294 #define AFX_HIDP_DAO_OBJECT_NOT_OPEN            0x3F2B2
00295 #define AFX_HIDP_DAO_ROWTOOSHORT                0x3F2B3
00296 #define AFX_HIDP_DAO_BADBINDINFO                0x3F2B4
00297 #define AFX_HIDP_DAO_COLUMNUNAVAILABLE          0x3F2B5
00298
00299 // Frame Controls (AFX_HIDW_*)
00300 #define AFX_HIDW_TOOLBAR                        0x5E800
00301 #define AFX_HIDW_STATUS_BAR                     0x5E801
00302 #define AFX_HIDW_PREVIEW_BAR                    0x5E802
00303 #define AFX_HIDW_RESIZE_BAR                     0x5E803
00304 #define AFX_HIDW_DOCKBAR_TOP                    0x5E81B
00305 #define AFX_HIDW_DOCKBAR_LEFT                   0x5E81C
00306 #define AFX_HIDW_DOCKBAR_RIGHT                  0x5E81D
00307 #define AFX_HIDW_DOCKBAR_BOTTOM                 0x5E81E
00308 #define AFX_HIDW_DOCKBAR_FLOAT                  0x5E81F
00309
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/INI.cpp Source File

CIni/INI.cpp
Go to the documentation of this file.
00001 // IniFile.cpp: implementation of the CINI class.
00002 //
00004
00005 #include "stdafx.h"
00006 //#include "Readini.h"
00007 #include "INI.h"
00008 #include <afxcoll.h>
00009
00010 #ifdef _DEBUG
00011 #undef THIS_FILE
00012 static char THIS_FILE[]=__FILE__;
00013 #define new DEBUG_NEW
00014 #endif
00015
00016 //
00017 //setINIFileName
00018 // Sets the INI File name to read and write.
00019 //
00020 //getKeyValue
00021 // Used to retrieve a key value given the section and key name.
00022 //
00023 //getSectionData
00024 // Used to retrieve all key/value pairs of a given section.
00025 //
00026 //getSectionNames
00027 // Used to retrieve all the sections in an ini file
00028 //
00029 //sectionExists
00030 // Used to find out if a given section exists.
00031 //
00032 //setKey
00033 // Used to modify the key value or to create a key value pair for the specified section.
00034 //
00035
00036
00038 // Construction/Destruction
00040
00041 CINI::CINI(CString strFile)
00042 {
00043         m_strFileName = strFile;
00044         m_sectionList = new CStringList();
00045         m_sectionDataList = new CStringList();
00046 }
00047
00048 CINI::~CINI()
00049 {
00050         delete m_sectionList;
00051         delete m_sectionDataList;
00052 }
00053
00054 // Used to retrieve a value give the section and key
00055 CString CINI::getKeyValue(CString strKey,CString strSection)
00056 {
00057         char ac_Result[MAX_KEY_DATA_SIZE];
00058
00059         // Get the info from the .ini file
00060         m_lRetValue = GetPrivateProfileString((LPCTSTR)strSection,(LPCTSTR)strKey,
00061                 "",ac_Result, MAX_KEY_DATA_SIZE, (LPCTSTR)m_strFileName);
00062
00063         CString strResult(ac_Result);
00064         return strResult;
00065 }
00066
00067 // Used to add or set a key value pair to a section
00068 long CINI::setKey(CString strValue, CString strKey, CString strSection)
00069 {
00070         m_lRetValue = WritePrivateProfileString (strSection, strKey,
00071                              strValue, m_strFileName);
00072
00073         return m_lRetValue;
00074 }
00075
00076 // Used to delete a key value pair to a section
00077 long CINI::DeleteKey(CString strKey, CString strSection)
00078 {
00079         m_lRetValue = WritePrivateProfileString (strSection, strKey,
00080                              NULL, m_strFileName);
00081
00082         return m_lRetValue;
00083 }
00084
00085 // Used to delete a key value pair to a section
00086 long CINI::DeleteSection(CString strSection)
00087 {
00088         m_lRetValue = WritePrivateProfileString (strSection, NULL,
00089                              NULL, m_strFileName);
00090
00091         return m_lRetValue;
00092 }
00093
00094 // Used to find out if a given section exists
00095 BOOL CINI::sectionExists(CString strSection)
00096 {
00097         char ac_Result[MAX_KEY_DATA_SIZE];
00098         CString csAux;
00099         // Get the info from the .ini file
00100         m_lRetValue = GetPrivateProfileString((LPCTSTR)strSection,NULL,
00101                 "",ac_Result, MAX_KEY_DATA_SIZE, (LPCTSTR)m_strFileName);
00102         // Return if we could retrieve any info from that section
00103         //csAux.Format("%d",m_lRetValue);
00104         //MessageBox(NULL,csAux,"",MB_OK);
00105         return (m_lRetValue > 0);
00106 }
00107
00108 // Used to retrieve all of the  section names in the ini file
00109 CStringList* CINI::getSectionNames()  //returns collection of section names
00110 {
00111         char ac_Result[MAX_SECTION_SIZE];
00112         m_sectionList->RemoveAll();
00113
00114         m_lRetValue = GetPrivateProfileSectionNames(ac_Result,MAX_SECTION_SIZE,(LPCTSTR)m_strFileName);
00115
00116         CString strSectionName;
00117         for(int i=0; i<m_lRetValue; i++)
00118         {
00119                 if(ac_Result[i] != '\0') {
00120                         strSectionName = strSectionName + ac_Result[i];
00121                 } else {
00122                         if(strSectionName != "") {
00123                                 m_sectionList->InsertAfter(m_sectionList->GetTailPosition(),strSectionName);
00124                         }
00125                         strSectionName = "";
00126                 }
00127         }
00128
00129         return m_sectionList;
00130 }
00131
00132 // Used to retrieve all key/value pairs of a given section.
00133 CStringList* CINI::getSectionData(CString strSection)
00134 {
00135         char ac_Result[MAX_SECTION_SIZE];  //change size depending on needs
00136         m_sectionDataList->RemoveAll();
00137         m_lRetValue = GetPrivateProfileSection((LPCTSTR)strSection, ac_Result, MAX_SECTION_SIZE, (LPCTSTR)m_strFileName);
00138
00139         CString strSectionData;
00140         for(int i=0; i<m_lRetValue; i++)
00141         {
00142                 if(ac_Result[i] != '\0') {
00143                         strSectionData = strSectionData + ac_Result[i];
00144                 } else {
00145                         if(strSectionData != "") {
00146                                 m_sectionDataList->InsertAfter(m_sectionDataList->GetTailPosition(),strSectionData);
00147                         }
00148                         strSectionData = "";
00149                 }
00150         }
00151
00152         return m_sectionDataList;
00153 }
00154
00155 void CINI::setINIFileName(CString strINIFile)
00156 {
00157         m_strFileName = strINIFile;
00158 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/INI.h Source File

CIni/INI.h
Go to the documentation of this file.
00001 // IniFile.h: interface for the CINI class.
00002 //
00004
00005 #if !defined(AFX_INIFILE_H__99976B4B_DBA1_4D1E_AA14_CBEB63042FD1__INCLUDED_)
00006 #define AFX_INIFILE_H__99976B4B_DBA1_4D1E_AA14_CBEB63042FD1__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include <afxcoll.h>
00013
00014 #define MAX_SECTION_SIZE 0x7FFF
00015 #define MAX_KEY_DATA_SIZE 0xFF
00016
00017
00018 //
00019 //setINIFileName
00020 // Sets the INI File name to read and write.
00021 //
00022 //getKeyValue
00023 // Used to retrieve a key value given the section and key name.
00024 //
00025 //getSectionData
00026 // Used to retrieve all key/value pairs of a given section.
00027 //
00028 //getSectionNames
00029 // Used to retrieve all the sections in an ini file
00030 //
00031 //sectionExists
00032 // Used to find out if a given section exists.
00033 //
00034 //setKey
00035 // Used to modify the key value or to create a key value pair for the specified section.
00036 //
00037
00038
00039
00040 class CINI
00041 {
00042 public:
00043         void setINIFileName(CString strINIFile);
00044         CStringList* getSectionData(CString strSection);
00045         CStringList* getSectionNames();
00046         BOOL sectionExists(CString strSection);
00047         long setKey(CString strValue, CString strKey, CString strSection);
00048         long DeleteKey(CString strKey, CString strSection);
00049         long CINI::DeleteSection(CString strSection);
00050         CString getKeyValue(CString strKey,CString strSection);
00051         CINI(CString strFile);
00052         CINI()
00053         {
00054                 m_sectionList = new CStringList();
00055                 m_sectionDataList = new CStringList();
00056         }
00057         virtual ~CINI();
00058
00059 private:
00060         CStringList *m_sectionDataList;
00061         CStringList *m_sectionList;
00062         CString m_strSection;
00063         long m_lRetValue;
00064         CString m_strFileName;
00065 };
00066
00067 #endif // !defined(AFX_INIFILE_H__99976B4B_DBA1_4D1E_AA14_CBEB63042FD1__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniEx.cpp Source File

CIni/IniEx.cpp
Go to the documentation of this file.
00001 #include "IniEx.h"
00002
00003 CIniEx::CIniEx(void)
00004 {
00005 }
00006
00007 CIniEx::~CIniEx(void)
00008 {
00009 }
00010
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniEx.h Source File

CIni/IniEx.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 //IniEx.h
00004
00005
00006 class CIniEx
00007 {
00008 public:
00009         CIniEx(void);
00010         ~CIniEx(void);
00011 };
00012
00013
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniUtil.cpp Source File

CIni/IniUtil.cpp
Go to the documentation of this file.
00001
00002 #include "IniUtil.h"
00003
00004 CIniUtil::CIniUtil(void)
00005 {
00006         //m_ValSection = _T("DP5 Configuration Values");
00007 }
00008
00009 CIniUtil::~CIniUtil(void)
00010 {
00011 }
00012
00013 BOOL CIniUtil::GetDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comment)
00014 {
00015         CString m_strSectionName;
00016         CString m_strKeyValue;
00017         int ScPos;
00018         CString strData;
00019         CString strComment;
00020
00021         m_strSectionName = m_strSection;
00022         if(m_strINIFile.IsEmpty()) { return FALSE; }            //Specify INI File name
00023         if(m_strSectionName.IsEmpty()) { return FALSE; }        //Specify section name
00024         ini.setINIFileName(m_strINIFile);
00025         BOOL bExists = ini.sectionExists(m_strSectionName);
00026         if(!bExists) { return FALSE; }                                          //Section doesn't exist
00027         strData.Empty();
00028         m_strKeyValue = ini.getKeyValue(cmdKey,m_strSectionName);
00029         m_strKeyValue.Trim();
00030         if (m_strKeyValue.GetLength() == 0) { return FALSE; }
00031         strComment = "";
00032         ScPos = m_strKeyValue.Find(";",0);
00033         if (ScPos > 0) {                                                                        // save the value if comment
00034                 strData = m_strKeyValue.Left(ScPos);
00035                 strComment = m_strKeyValue.Mid(ScPos + 1);
00036         } else {
00037                 strData = m_strKeyValue;
00038         }
00039         *cmdData = strData;
00040         *Comment = strComment;
00041         return TRUE;
00042 }
00043
00044 BOOL CIniUtil::SaveDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comment)
00045 {
00046         CString m_strSectionName;
00047         CString m_strKeyValue;
00048         CString strData;
00049         BOOL m_lRetValue;
00050
00051         m_strSectionName = m_strSection;
00052         //if(m_strINIFile.IsEmpty()) { return FALSE; }          //Specify INI File name
00053         //if(m_strSectionName.IsEmpty()) { return FALSE; }      //Specify section name
00054         ini.setINIFileName(m_strINIFile);
00055         //BOOL bExists = ini.sectionExists(m_strSectionName);
00056         //if(!bExists) { return FALSE; }                                                //Section doesn't exist
00057         strData = cmdData + ";" + Comment;
00058         m_lRetValue = ini.setKey(strData,cmdKey,m_strSection);
00059         return m_lRetValue;
00060 }
00061
00062 BOOL CIniUtil::GetDP5Section(CString m_strINIFile, CString m_strSection, CStringList* m_strListDP5section)
00063 {
00064         if(m_strINIFile.IsEmpty())
00065         {
00066                 //AfxMessageBox("INI File name error");
00067                 return FALSE;
00068         }
00069         if(m_strSection.IsEmpty())
00070         {
00071                 //AfxMessageBox("Section name error");
00072                 return FALSE;
00073         }
00074
00075         ini.setINIFileName(m_strINIFile);
00076         BOOL bExists = ini.sectionExists(m_strSection);
00077
00078         if(!bExists)
00079         {
00080                 //AfxMessageBox("Section doesn't exist error");
00081                 return FALSE;
00082         }
00083         CStringList* strlstSection = ini.getSectionData(m_strSection);
00084
00085         POSITION posCmd;
00086         //BOOL isComment;
00087         //CString strKey;
00088         //int EqPos;
00089         m_strListDP5section->RemoveAll();
00090         CString strCMD;
00091         for(posCmd = strlstSection->GetHeadPosition(); posCmd != NULL; )
00092         {
00093                 strCMD = strlstSection->GetNext(posCmd);
00094                 //if (isComment) {
00095                 //      strKey = myOtherList->GetNext(position);
00096                 //      EqPos = strKey.Find("=",0);
00097                 //      strKey = strKey.Left(EqPos);
00098                 //      m_ListSectionData.AddString(strKey);
00099                 //} else {
00100
00101                 if(strCMD != "") {
00102                         m_strListDP5section->InsertAfter(m_strListDP5section->GetTailPosition(),strCMD);
00103                 }
00104                 strCMD = "";
00105                 //}
00106         }
00107
00108         return TRUE;
00109 }
00110
00111 CString CIniUtil::ConvertCmdListToCString(CStringList* strCmdList, BOOL AddNewLines, BOOL RemoveComments)
00112 {
00113         CString strCmdCStr;
00114         POSITION posCmd;
00115         int ComPos;
00116         CString strCMD;
00117         strCmdCStr = "";
00118         strCMD = "";
00119         for(posCmd = strCmdList->GetHeadPosition(); posCmd != NULL; )
00120         {
00121                 strCMD = strCmdList->GetNext(posCmd);
00122                 strCMD = strCMD.Trim();
00123                 if (RemoveComments && (strCMD != "")) {
00124                         ComPos = strCMD.Find(";",0);
00125                         //CMDV=*;
00126                         //0123456
00127                         if (ComPos > 5) {                                       // remove the comments
00128                                 strCMD = strCMD.Left(ComPos);
00129                                 strCMD = strCMD.Trim() + ";";
00130                         } else if (ComPos >= 0) {                               // error
00131                                 strCMD = "";
00132                         } else {                                                // check for MS style ini entry
00133                                 strCMD = GetMsIniItem(strCMD);
00134                         }
00135                 }
00136                 if(strCMD != "") {
00137                         if (AddNewLines) { strCMD += "\r\n"; }
00138                         strCmdCStr += strCMD;
00139                 }
00140                 strCMD = "";
00141         }
00142
00143         return strCmdCStr;
00144 }
00145
00146 CString CIniUtil::GetMsIniItem(CString strCmdIn)
00147 {
00148         CString strMsCmd;
00149         int iStart,iEnd;
00150         CString strKey;
00151         CString strData;
00152         CString strCMD;
00153
00154         strCMD = strCmdIn.Trim();
00155         // test for valid command parameters
00156         if (strCMD.GetLength() < 6) { return ""; }      // no data possible
00157         iStart = strCMD.Find("=",0);
00158         if (iStart != 4) { return ""; }                         // data start not found
00159         iEnd = strCMD.Find(";",0);
00160         if (iEnd != -1) {       // terminator found, just strip comments
00161                 strMsCmd = strCMD.Left(iEnd+1);
00162                 return strMsCmd;
00163         }
00164         // appear to have ms ini key data pair, terminate cmd, ret
00165         strMsCmd = strCMD + ";";
00166         return strMsCmd;
00167 }
00168
00169 BOOL CIniUtil::DeleteDP5Key(CString m_strINIFile, CString m_strSection, CString cmdKey)
00170 {
00171         CString m_strSectionName;
00172         CString m_strKeyValue;
00173
00174         m_strSectionName = m_strSection;
00175         if(m_strINIFile.IsEmpty()) { return FALSE; }            //Specify INI File name
00176         if(m_strSectionName.IsEmpty()) { return FALSE; }        //Specify section name
00177         ini.setINIFileName(m_strINIFile);
00178         BOOL bExists = ini.sectionExists(m_strSectionName);
00179         if(!bExists) { return FALSE; }                                          //Section doesn't exist
00180         BOOL isDeleted = ini.DeleteKey(cmdKey,m_strSection);
00181         return TRUE;
00182 }
00183
00184
00185
00186 //void CIniUtil::ListSections()
00187 //{
00188 //      if(m_strINIFile.IsEmpty())
00189 //      {
00190 //              AfxMessageBox("Specify INI File name");
00191 //              return;
00192 //      }
00193 //
00194 //      ini.setINIFileName(m_strINIFile);
00195 //      m_ListSections.ResetContent();
00196 //      m_ListSectionData.ResetContent();
00197 //
00198 //      m_strKeyValue.Empty();
00199 //      UpdateData(FALSE);
00200 //
00201 //      //load listbox from collection returned from getSectionNames();
00202 //      CStringList* strSectionList = ini.getSectionNames();
00203 //      POSITION pos;
00204 //      for(pos = myStringList->GetHeadPosition(); pos != NULL; ) {
00205 //              m_ListSections.AddString(myStringList->GetNext(pos));
00206 //      }
00207 //}
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: CIni/IniUtil.h Source File

CIni/IniUtil.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "INI.h"
00004
00005
00006 class CIniUtil
00007 {
00008 public:
00009         CIniUtil(void);
00010         ~CIniUtil(void);
00011         CINI ini;
00012
00013         BOOL GetDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comments);
00014         BOOL SaveDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comments);
00015         BOOL GetDP5Section(CString m_strINIFile, CString m_strSection, CStringList* m_strListDP5section);
00016         CString ConvertCmdListToCString(CStringList* strCmdList, BOOL AddNewLines, BOOL RemoveComments);
00017         CString GetMsIniItem(CString strCmdIn);
00018         BOOL DeleteDP5Key(CString m_strINIFile, CString m_strSection, CString cmdKey);
00019 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/Label.cpp Source File

Controls/Label.cpp
Go to the documentation of this file.
00001 // Label.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "Resource.h"
00006 #include "Label.h"
00007
00008 #ifdef _DEBUG
00009 #define new DEBUG_NEW
00010 #undef THIS_FILE
00011 static char THIS_FILE[] = __FILE__;
00012 #endif
00013
00015 // CLabel
00016
00017 CLabel::CLabel()
00018 {
00019         NullSet = FALSE;
00020         NullBkColor = GetSysColor(COLOR_3DFACE);
00021         NullTextColor = GetSysColor(COLOR_GRAYTEXT);
00022         LastBkColor = GetSysColor(COLOR_3DFACE);
00023         LastTextColor = GetSysColor(COLOR_WINDOWTEXT);
00024
00025         m_crText = GetSysColor(COLOR_WINDOWTEXT);
00026         m_hBrush = ::CreateSolidBrush(GetSysColor(COLOR_3DFACE));
00027
00028         ::GetObject((HFONT)GetStockObject(DEFAULT_GUI_FONT),sizeof(m_lf),&m_lf);
00029
00030         m_font.CreateFontIndirect(&m_lf);
00031         m_bTimer = FALSE;
00032         m_bState = FALSE;
00033         m_bLink = TRUE;
00034         m_hCursor = NULL;
00035         m_Type = None;
00036
00037         m_hwndBrush = ::CreateSolidBrush(GetSysColor(COLOR_3DFACE));
00038 }
00039
00040
00041 CLabel::~CLabel()
00042 {
00043         m_font.DeleteObject();
00044         ::DeleteObject(m_hBrush);
00045 }
00046
00047 CLabel& CLabel::SetText(const CString& strText)
00048 {
00049         SetWindowText(strText);
00050         return *this;
00051 }
00052
00053 CLabel& CLabel::SetTextColor(COLORREF crText)
00054 {
00055         if (!NullSet) LastTextColor = crText;
00056         m_crText = crText;
00057         RedrawWindow();
00058         return *this;
00059 }
00060
00061 CLabel& CLabel::SetFontBold(BOOL bBold)
00062 {
00063         m_lf.lfWeight = bBold ? FW_BOLD : FW_NORMAL;
00064         ReconstructFont();
00065         RedrawWindow();
00066         return *this;
00067 }
00068
00069 CLabel& CLabel::SetFontUnderline(BOOL bSet)
00070 {
00071         m_lf.lfUnderline = bSet;
00072         ReconstructFont();
00073         RedrawWindow();
00074         return *this;
00075 }
00076
00077 CLabel& CLabel::SetFontItalic(BOOL bSet)
00078 {
00079         m_lf.lfItalic = bSet;
00080         ReconstructFont();
00081         RedrawWindow();
00082         return *this;
00083 }
00084
00085 CLabel& CLabel::SetSunken(BOOL bSet)
00086 {
00087         if (!bSet)
00088                 ModifyStyleEx(WS_EX_STATICEDGE,0,SWP_DRAWFRAME);
00089         else
00090                 ModifyStyleEx(0,WS_EX_STATICEDGE,SWP_DRAWFRAME);
00091
00092         return *this;
00093 }
00094
00095 CLabel& CLabel::SetBorder(BOOL bSet)
00096 {
00097         if (!bSet)
00098                 ModifyStyle(WS_BORDER,0,SWP_DRAWFRAME);
00099         else
00100                 ModifyStyle(0,WS_BORDER,SWP_DRAWFRAME);
00101
00102         return *this;
00103 }
00104
00105 CLabel& CLabel::SetFontSize(int nSize)
00106 {
00107         nSize*=-1;
00108         m_lf.lfHeight = nSize;
00109         ReconstructFont();
00110         RedrawWindow();
00111         return *this;
00112 }
00113
00114
00115 CLabel& CLabel::SetBkColor(COLORREF crBkgnd)
00116 {
00117         if (!NullSet) LastBkColor = crBkgnd;
00118         if (m_hBrush)
00119                 ::DeleteObject(m_hBrush);
00120
00121         m_hBrush = ::CreateSolidBrush(crBkgnd);
00122         return *this;
00123 }
00124
00125 CLabel& CLabel::SetFontName(const CString& strFont)
00126 {
00127         strcpy(m_lf.lfFaceName,strFont);
00128         ReconstructFont();
00129         RedrawWindow();
00130         return *this;
00131 }
00132
00133
00134 BEGIN_MESSAGE_MAP(CLabel, CStatic)
00135         //{{AFX_MSG_MAP(CLabel)
00136         ON_WM_CTLCOLOR_REFLECT()
00137         ON_WM_TIMER()
00138         ON_WM_LBUTTONDOWN()
00139         ON_WM_SETCURSOR()
00140         //}}AFX_MSG_MAP
00141 END_MESSAGE_MAP()
00142
00144 // CLabel message handlers
00145
00146 HBRUSH CLabel::CtlColor(CDC* pDC, UINT nCtlColor)
00147 {
00148         // TODO: Change any attributes of the DC here
00149
00150         // TODO: Return a non-NULL brush if the parent's handler should not be called
00151
00152         if (CTLCOLOR_STATIC == nCtlColor)
00153         {
00154                 pDC->SelectObject(&m_font);
00155                 pDC->SetTextColor(m_crText);
00156                 pDC->SetBkMode(TRANSPARENT);
00157         }
00158
00159
00160         if (m_Type == Background)
00161         {
00162                 if (!m_bState)
00163                         return m_hwndBrush;
00164         }
00165
00166         return m_hBrush;
00167 }
00168
00169 void CLabel::ReconstructFont()
00170 {
00171         m_font.DeleteObject();
00172         BOOL bCreated = m_font.CreateFontIndirect(&m_lf);
00173
00174         ASSERT(bCreated);
00175 }
00176
00177
00178 CLabel& CLabel::FlashText(BOOL bActivate)
00179 {
00180         if (m_bTimer)
00181         {
00182                 SetWindowText(m_strText);
00183                 KillTimer(1);
00184         }
00185
00186         if (bActivate)
00187         {
00188                 GetWindowText(m_strText);
00189                 m_bState = FALSE;
00190
00191                 m_bTimer = TRUE;
00192                 SetTimer(1,500,NULL);
00193                 m_Type = Text;
00194         }
00195
00196         return *this;
00197 }
00198
00199 CLabel& CLabel::FlashBackground(BOOL bActivate)
00200 {
00201
00202         if (m_bTimer)
00203                 KillTimer(1);
00204
00205         if (bActivate)
00206         {
00207                 m_bState = FALSE;
00208
00209                 m_bTimer = TRUE;
00210                 SetTimer(1,500,NULL);
00211
00212                 m_Type = Background;
00213         }
00214
00215         return *this;
00216 }
00217
00218
00219 void CLabel::OnTimer(UINT nIDEvent)
00220 {
00221         m_bState = !m_bState;
00222
00223         switch (m_Type)
00224         {
00225                 case Text:
00226                         if (m_bState)
00227                                 SetWindowText("");
00228                         else
00229                                 SetWindowText(m_strText);
00230                 break;
00231
00232                 case Background:
00233                         InvalidateRect(NULL,FALSE);
00234                         UpdateWindow();
00235                 break;
00236         }
00237
00238         CStatic::OnTimer(nIDEvent);
00239 }
00240
00241 CLabel& CLabel::SetLink(BOOL bLink)
00242 {
00243         m_bLink = bLink;
00244
00245         if (bLink)
00246                 ModifyStyle(0,SS_NOTIFY);
00247         else
00248                 ModifyStyle(SS_NOTIFY,0);
00249
00250         return *this;
00251 }
00252
00253 void CLabel::OnLButtonDown(UINT nFlags, CPoint point)
00254 {
00255         CString strLink;
00256
00257         GetWindowText(strLink);
00258         ShellExecute(NULL,"open",strLink,NULL,NULL,SW_SHOWNORMAL);
00259
00260         CStatic::OnLButtonDown(nFlags, point);
00261 }
00262
00263 BOOL CLabel::OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message)
00264 {
00265         if (m_hCursor)
00266         {
00267                 ::SetCursor(m_hCursor);
00268                 return TRUE;
00269         }
00270
00271         return CStatic::OnSetCursor(pWnd, nHitTest, message);
00272 }
00273
00274 CLabel& CLabel::SetLinkCursor(HCURSOR hCursor)
00275 {
00276         m_hCursor = hCursor;
00277         return *this;
00278 }
00279
00280 void CLabel::SetNullColor()
00281 {
00282         NullSet = TRUE;
00283         SetBkColor(NullBkColor);
00284         SetTextColor(NullTextColor);
00285         NullSet = FALSE;
00286 }
00287
00288 void CLabel::SetLastColor()
00289 {
00290         NullSet = TRUE;
00291         SetBkColor(LastBkColor);
00292         SetTextColor(LastTextColor);
00293         NullSet = FALSE;
00294 }
00295
00296
00297
00298
00299
00300
00301
00302
00303
00304
00305
00306
00307
00308
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/Label.h Source File

Controls/Label.h
Go to the documentation of this file.
00001 #if !defined(AFX_LABEL_H__INCLUDED_)
00002 #define AFX_LABEL_H__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // Label.h : header file
00008 //
00009 #include "X11Color.h"
00010
00012 // CLabel window
00013 enum FlashType {None, Text, Background };
00014
00015 class CLabel : public CStatic
00016 {
00017 // Construction
00018 public:
00019         CLabel();
00020         CLabel& SetBkColor(COLORREF crBkgnd);
00021         CLabel& SetTextColor(COLORREF crText);
00022         CLabel& SetText(const CString& strText);
00023         CLabel& SetFontBold(BOOL bBold);
00024         CLabel& SetFontName(const CString& strFont);
00025         CLabel& SetFontUnderline(BOOL bSet);
00026         CLabel& SetFontItalic(BOOL bSet);
00027         CLabel& SetFontSize(int nSize);
00028         CLabel& SetSunken(BOOL bSet);
00029         CLabel& SetBorder(BOOL bSet);
00030         CLabel& FlashText(BOOL bActivate);
00031         CLabel& FlashBackground(BOOL bActivate);
00032         CLabel& SetLink(BOOL bLink);
00033         CLabel& SetLinkCursor(HCURSOR hCursor);
00034
00035 // Attributes
00036 public:
00037         BOOL NullSet;
00038         COLORREF NullBkColor;
00039         COLORREF NullTextColor;
00040         COLORREF LastBkColor;
00041         COLORREF LastTextColor;
00042         void SetNullColor();
00043         void SetLastColor();
00044
00045 protected:
00046         void ReconstructFont();
00047         COLORREF        m_crText;
00048         HBRUSH          m_hBrush;
00049         HBRUSH          m_hwndBrush;
00050         LOGFONT         m_lf;
00051         CFont           m_font;
00052         CString         m_strText;
00053         BOOL            m_bState;
00054         BOOL            m_bTimer;
00055         BOOL            m_bLink;
00056         FlashType       m_Type;
00057         HCURSOR         m_hCursor;
00058                         // Operations
00059 public:
00060 // Overrides
00061         // ClassWizard generated virtual function overrides
00062         //{{AFX_VIRTUAL(CLabel)
00063         //}}AFX_VIRTUAL
00064
00065 // Implementation
00066 public:
00067         virtual ~CLabel();
00068
00069         // Generated message map functions
00070 protected:
00071         //{{AFX_MSG(CLabel)
00072         afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
00073         afx_msg void OnTimer(UINT nIDEvent);
00074         afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
00075         afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
00076         //}}AFX_MSG
00077
00078         DECLARE_MESSAGE_MAP()
00079 };
00080
00082
00083 //{{AFX_INSERT_LOCATION}}
00084 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00085
00086 #endif // !defined(AFX_LABEL_H__INCLUDED_)
00087
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/MSecTimer.cpp Source File

DeviceIO/MSecTimer.cpp
Go to the documentation of this file.
00001 #include ".\msectimer.h"
00002
00003 CMSecTimer::CMSecTimer(void)
00004 {
00005 }
00006
00007 CMSecTimer::~CMSecTimer(void)
00008 {
00009 }
00010
00011 DWORD CMSecTimer::msTimeDiff(DWORD msStartTime, DWORD msTestTime)
00012 {
00013         DWORD64 RollOver = (DWORD)pow(2.0,32);
00014         DWORD64 msStartTime64;
00015         DWORD64 msTestTime64;
00016         DWORD64 msTimeDiff64;
00017         DWORD msTimeDiff32;
00018         if (msStartTime > msTestTime) { // rollover
00019                 msTestTime64 = (DWORD64)msTestTime + RollOver;
00020                 msStartTime64 = (DWORD64)msStartTime;
00021                 msTimeDiff64 = msTestTime64 - msTestTime64;
00022                 if (msTimeDiff64 < RollOver) {
00023                         msTimeDiff32 = (DWORD)(msTimeDiff64);
00024                 } else {
00025                         msTimeDiff32 = 0;
00026                 }
00027         } else {
00028                 msTimeDiff32 = msTestTime - msStartTime;
00029         }
00030         return (msTimeDiff32);
00031 }
00032
00033 BOOL CMSecTimer::msTimeExpired(DWORD msStartTime, DWORD msDelay)
00034 {
00035         BOOL isExpired;
00036         DWORD msTestTime;
00037         DWORD64 RollOver = (DWORD)pow(2.0,32);
00038         DWORD64 msStartTime64;
00039         DWORD64 msTestTime64;
00040         DWORD64 msTimeDiff64;
00041         DWORD msTimeDiff32;
00042
00043         msTestTime = timeGetTime();
00044         if (msStartTime > msTestTime) { // rollover
00045                 msTestTime64 = (DWORD64)msTestTime + RollOver;
00046                 msStartTime64 = (DWORD64)msStartTime;
00047                 msTimeDiff64 = msTestTime64 - msTestTime64;
00048                 if (msTimeDiff64 < RollOver) {
00049                         msTimeDiff32 = (DWORD)(msTimeDiff64);
00050                 } else {
00051                         msTimeDiff32 = 0;
00052                 }
00053         } else {
00054                 msTimeDiff32 = msTestTime - msStartTime;
00055         }
00056         isExpired = (msTimeDiff32 >= msDelay);
00057         return (isExpired);
00058 }
00059
00060 BOOL CMSecTimer::msTimer(DWORD msDelay)
00061 {
00062         MSG msg;
00063         DWORD msStartTime;
00064         DWORD msTestTime;
00065         BOOL isExpired = FALSE;
00066         DWORD msTimeDiff32 = 0;
00067         msStartTime = timeGetTime();
00068         msTestTime = timeGetTime();
00069         do {
00070                 isExpired = msTimeExpired(msStartTime, msDelay);
00071                 msTimeDiff32 = msTimeDiff(msStartTime, msTestTime);
00072                 if (PeekMessage(&msg, NULL, NULL, NULL, PM_REMOVE))
00073                 {
00074                 TranslateMessage(&msg);
00075                 DispatchMessage(&msg);
00076                 }
00077         } while (!isExpired && (msTimeDiff32 <= msDelay));
00078         return (TRUE);
00079 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/MSecTimer.h Source File

DeviceIO/MSecTimer.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include <math.h>
00004 #include <Mmsystem.h>
00005
00006 class CMSecTimer
00007 {
00008 public:
00009         CMSecTimer(void);
00010         ~CMSecTimer(void);
00011         DWORD msTimeDiff(DWORD msStartTime, DWORD msTestTime);
00012         BOOL msTimeExpired(DWORD msStartTime, DWORD msDelay);
00013         BOOL msTimer(DWORD msDelay);
00014 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/McaPage.cpp Source File

DP5Cfg/McaPage.cpp
Go to the documentation of this file.
00001 // McaPage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "afxpriv.h"    // afxpriv.h has WM_COMMANDHELP id
00006 #include "McaPageRes.h"
00007 #include "McaPage.h"
00008 #include ".\McaPage.h"
00009
00010 #ifdef _DEBUG
00011 #define new DEBUG_NEW
00012 #undef THIS_FILE
00013 static char THIS_FILE[] = __FILE__;
00014 #endif
00015
00017 // CMcaPage property page
00018
00019 IMPLEMENT_DYNCREATE(CMcaPage, CCfgPropPage)
00020 //IDD_MCA_PAGE
00021 //#define IDD_MCA_PAGE                    106
00022
00023
00024 //CMcaPage::CMcaPage() : CCfgPropPage(IDD_MCA_PAGE)
00025 //CMcaPage::CMcaPage() : CCfgPropPage(CMcaPage::IDD)
00026 CMcaPage::CMcaPage() : CCfgPropPage("IDD_MCA_PAGE")
00027 {
00028         //{{AFX_DATA_INIT(CMcaPage)
00029                 // NOTE: the ClassWizard will add member initialization here
00030         isDMcaControls = FALSE;
00031         //}}AFX_DATA_INIT
00032 }
00033
00034 CMcaPage::~CMcaPage()
00035 {
00036
00037 }
00038
00039 void CMcaPage::DoDataExchange(CDataExchange* pDX)
00040 {
00041         CCfgPropPage::DoDataExchange(pDX);
00042         //{{AFX_DATA_MAP(CMcaPage)
00043         //}}AFX_DATA_MAP
00044         DDX_Control(pDX, IDC_STATIC_MCA_PAGE, m_McaPageLabel);
00045         DDX_Control(pDX, IDC_STATIC_MCA_ADVANCED, m_McaAdvancedLabel);
00046         DDX_Control(pDX, IDC_STATIC_MCA_STANDARD, m_McaStandardLabel);
00047 }
00048
00049 BEGIN_MESSAGE_MAP(CMcaPage, CCfgPropPage)
00050         //{{AFX_MSG_MAP(CMcaPage)
00051         //}}AFX_MSG_MAP
00052         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PRET, OnCbnSelchangeOptComboPret)
00053         ON_EN_CHANGE(IDC_OPT_TEXT_THSL, OnEnChangeOptTextThsl)
00054         ON_CBN_SELCHANGE(IDC_OPT_COMBO_MCAE, OnCbnSelchangeOptComboMcae)
00055         ON_CBN_SELCHANGE(IDC_OPT_COMBO_MCAC, OnCbnSelchangeOptComboMcac)
00056         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GATE, OnCbnSelchangeOptComboGate)
00057         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PREC, OnCbnSelchangeOptComboPrec)
00058         ON_CBN_SELCHANGE(IDC_OPT_COMBO_SOFF, OnCbnSelchangeOptComboSoff)
00059         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PDMD, OnCbnSelchangeOptComboPdmd)
00060
00061         ON_EN_CHANGE(IDC_OPT_TEXT_PRET, OnEnChangeOptTextPret)
00062         ON_EN_CHANGE(IDC_OPT_TEXT_PREC, OnEnChangeOptTextPrec)
00063         ON_EN_CHANGE(IDC_OPT_TEXT_MCST, OnEnChangeOptTextMcst)
00064         ON_EN_CHANGE(IDC_OPT_TEXT_SOFF, OnEnChangeOptTextSoff)
00065
00066         ON_CBN_SELCHANGE(IDC_OPT_COMBO_MCAS, OnCbnSelchangeOptComboMcas)
00067         ON_EN_CHANGE(IDC_OPT_TEXT_MCSL, OnEnChangeOptTextMcsl)
00068         ON_EN_CHANGE(IDC_OPT_TEXT_MCSH, OnEnChangeOptTextMcsh)
00069         ON_EN_CHANGE(IDC_OPT_TEXT_PRCL, OnEnChangeOptTextPrcl)
00070         ON_EN_CHANGE(IDC_OPT_TEXT_PRCH, OnEnChangeOptTextPrch)
00071
00072         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PRER, OnCbnSelchangeOptComboPrer)
00073         ON_EN_CHANGE(IDC_OPT_TEXT_PRER, OnEnChangeOptTextPrer)
00074
00075         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PREL, OnCbnSelchangeOptComboPrel)
00076         ON_EN_CHANGE(IDC_OPT_TEXT_PREL, OnEnChangeOptTextPrel)
00077
00078         ON_CBN_SELCHANGE(IDC_OPT_COMBO_TLLD, OnCbnSelchangeOptComboTlld)
00079         ON_EN_CHANGE(IDC_OPT_TEXT_TLLD, OnEnChangeOptTextTlld)
00080
00081         ON_BN_CLICKED(IDC_PRESETCOUNTCURSORBUTTON, OnBnClickedPresetcountcursorbutton)
00082         ON_BN_CLICKED(IDC_PRESETCOUNTROIBUTTON, OnBnClickedPresetcountroibutton)
00083
00084         ON_COMMAND(ID_HELP, OnHelp)
00085         ON_WM_HELPINFO()
00086
00087         ON_CBN_SELCHANGE(IDC_OPT_COMBO_DMCA_GAIA, OnCbnSelchangeOptComboDmcaGaia)
00088         ON_CBN_SELCHANGE(IDC_OPT_COMBO_DMCA_PURE, OnCbnSelchangeOptComboDmcaPure)
00089 END_MESSAGE_MAP()
00090
00092 // CMcaPage message handlers
00093
00094 BOOL CMcaPage::OnSetActive()
00095 {
00096         BOOL bIsDMCA_Ctrls = FALSE;
00097         BOOL bIsDMCA_Dev = FALSE;
00098         int DppType;
00099         //CString strDPP("");
00100         //CString strDPP2("");
00101
00102         if (s.ReloadCfg) {
00103                 InitControls();
00104         } else {                        // reset DMCA controls if not matching device type
00105                 DppType = s.profile->device_type;
00106                 //strDPP.Format("DppType %d  <->  Profile device_type %d\r\n",DppType,s.profile->device_type);
00107                 //strDPP2 += strDPP;
00108                 //AfxMessageBox(strDPP);
00109                 bIsDMCA_Dev = FALSE;
00110                 if (DppType == dppMCA8000D) {
00111                         bIsDMCA_Dev = TRUE;
00112                 }
00113                 //bIsDMCA_Ctrls = GetDlgItem(IDC_OPT_FRAME_DMCA_GAIA)->IsWindowVisible();
00114                 bIsDMCA_Ctrls = isDMcaControls;
00115                 //strDPP.Format("bIsDMCA_Dev %d <-> bIsDMCA_Ctrls %d\r\n",bIsDMCA_Dev,bIsDMCA_Ctrls);
00116                 //strDPP2 += strDPP;
00117                 //AfxMessageBox(strDPP2);
00118                 if (bIsDMCA_Dev != bIsDMCA_Ctrls) {
00119                         //strDPP = "InitControls\r\n";
00120                         //strDPP2 += strDPP;
00121                         //AfxMessageBox("InitControls");
00122                         InitControls();
00123                 }
00124                 //AfxMessageBox(strDPP2);
00125         }
00126         return CCfgPropPage::OnSetActive();
00127 }
00128
00129 BOOL CMcaPage::OnInitDialog()
00130 {
00131         CCfgPropPage::OnInitDialog();
00132
00133         BuildToolTips();
00134
00135         m_McaPageLabel
00136                 .SetFontName("Arial")
00137                 .SetFontSize(24)
00138                 .SetTextColor(RGB(0,0,255))
00139                 .SetBkColor(RGB(244, 243, 238))
00140                 .SetFontItalic(TRUE)
00141                 .SetFontBold(TRUE);
00142
00143         m_McaAdvancedLabel
00144                 .SetFontName("Arial")
00145                 .SetFontSize(18)
00146                 .SetTextColor(RGB(0, 70, 213))
00147                 .SetBkColor(RGB(248, 248, 246))
00148                 .SetFontItalic(TRUE)
00149                 .SetFontBold(FALSE);
00150
00151         m_McaStandardLabel
00152                 .SetFontName("Arial")
00153                 .SetFontSize(18)
00154                 .SetTextColor(RGB(0, 70, 213))
00155                 .SetBkColor(RGB(252, 252, 253))
00156                 .SetFontItalic(TRUE)
00157                 .SetFontBold(FALSE);
00158
00159         InitControls();
00160
00161         // TODO:  Add extra initialization here
00162
00163         return TRUE;  // return TRUE unless you set the focus to a control
00164         // EXCEPTION: OCX Property Pages should return FALSE
00165 }
00166
00167 //dciTHSL       THSL    0                                       IDC_OPT_TEXT_THSL       dctTxt          dcgMCA  Slow Threshhold %
00168 //dciMCAE       MCAE    IDC_OPT_COMBO_MCAE      0                                       dctCbo          dcgMCA  MCA Enable
00169 //dciMCAC       MCAC    IDC_OPT_COMBO_MCAC      0                                       dctCbo          dcgMCA  MCA/MCS Channels
00170 //dciGATE       GATE    IDC_OPT_COMBO_GATE      0                                       dctCbo          dcgMCA  Gate Control
00171
00172 //dciPRET       PRET    IDC_OPT_COMBO_PRET      IDC_OPT_TEXT_PRET       dctCboTxt       dcgMCA  Preset Time     S
00173 //dciPREC       PREC    IDC_OPT_COMBO_PREC      IDC_OPT_TEXT_PREC       dctCboTxt       dcgMCA  Preset Counts   cnts
00174 //dciMCST       MCST    0                                       IDC_OPT_TEXT_MCST       dctTxt          dcgMCA  MCS Timebase    S
00175 //dciSOFF       SOFF    IDC_OPT_COMBO_SOFF      IDC_OPT_TEXT_SOFF       dctCboTxt       dcgMCA  Set Spectrum Offset     CH
00176
00177 //dciMCAS       MCAS    IDC_OPT_COMBO_MCAS                                      0       dctCbo          dcgBootOpt      MCA Source
00178 //dciPDMD       PDMD    IDC_OPT_COMBO_PDMD      0                                       dctCbo          dcgShaping      Peak Detect Mode (Min/Max)
00179
00180 void CMcaPage::InitControls()
00181 {
00182         HWND hPage = this->GetSafeHwnd();
00183         BOOL bEnableGATE;
00184         int DppType;
00185
00186         DppType = s.profile->device_type;
00187         bEnableGATE =((DppType == dppDP5) || (DppType == dppDP5X) || (DppType == dppMCA8000D));
00188
00189         CComboBox &cbMCAS = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_MCAS);
00190         CComboBox &cbPDMD = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_PDMD);
00191
00192         // MCAS and PDMD have different values for MCA8000D
00193         if (DppType == dppMCA8000D) {
00194                 GetDlgItem(IDC_OPT_FRAME_GATE)->SetWindowText("Gate 1");
00195                 if (cbMCAS.GetCount() != 2) {   //NORM;MCS;
00196                         cbMCAS.ResetContent();
00197                         cbMCAS.AddString("NORM");
00198                         cbMCAS.AddString("MCS");
00199                         cbMCAS.Clear();
00200                 }
00201                 if (cbPDMD.GetCount() != 5) {   //NORM;MIN;ABS;CLK;INT;
00202                         cbPDMD.ResetContent();
00203                         cbPDMD.AddString("NORM");
00204                         cbPDMD.AddString("MIN");
00205                         cbPDMD.AddString("ABS");
00206                         cbPDMD.AddString("CLK");
00207                         cbPDMD.AddString("INT");
00208                         cbPDMD.Clear();
00209                 }
00210         } else {
00211                 GetDlgItem(IDC_OPT_FRAME_GATE)->SetWindowText("Gate Control");
00212                 if (cbMCAS.GetCount() != 5) {   // NORM;MCS;FAST;PUR;RTD;
00213                         cbMCAS.ResetContent();
00214                         cbMCAS.AddString("NORM");
00215                         cbMCAS.AddString("MCS");
00216                         cbMCAS.AddString("FAST");
00217                         cbMCAS.AddString("PUR");
00218                         cbMCAS.AddString("RTD");
00219                         cbMCAS.Clear();
00220                 }
00221                 if (cbPDMD.GetCount() != 2) {   //NORM;MCS;
00222                         cbPDMD.ResetContent();
00223                         cbPDMD.AddString("NORM");
00224                         cbPDMD.AddString("MIN");
00225                         cbPDMD.Clear();
00226                 }
00227         }
00228
00229         GetDlgItem(IDC_OPT_FRAME_GATE)->EnableWindow(bEnableGATE);
00230         GetDlgItem(IDC_OPT_COMBO_GATE)->EnableWindow(bEnableGATE);
00231
00232         InitDlgItem(hPage,s.m_DP5Cfg[dciTHSL]);
00233         InitDlgItem(hPage,s.m_DP5Cfg[dciMCAE]);
00234         InitDlgItem(hPage,s.m_DP5Cfg[dciMCAC]);
00235         InitDlgItem(hPage,s.m_DP5Cfg[dciGATE]);
00236
00237         InitDlgItem(hPage,s.m_DP5Cfg[dciPRET]);
00238         InitDlgItem(hPage,s.m_DP5Cfg[dciPREC]);
00239         InitDlgItem(hPage,s.m_DP5Cfg[dciMCST]);
00240         InitDlgItem(hPage,s.m_DP5Cfg[dciSOFF]);
00241
00242         InitDlgItem(hPage,s.m_DP5Cfg[dciMCAS]);
00243
00244         InitDlgItem(hPage,s.m_DP5Cfg[dciMCSL]);
00245         InitDlgItem(hPage,s.m_DP5Cfg[dciMCSH]);
00246
00247         InitDlgItem(hPage,s.m_DP5Cfg[dciPRCL]);
00248         InitDlgItem(hPage,s.m_DP5Cfg[dciPRCH]);
00249
00250         InitDlgItem(hPage,s.m_DP5Cfg[dciPRER]);
00251
00252         InitDlgItem(hPage,s.m_DP5Cfg[dciPDMD]);
00253         InitDlgItem(hPage,s.m_DP5Cfg[dciTLLD]);
00254
00255         CboUpdate(dciPRET);
00256         CboUpdate(dciMCAE);
00257         CboUpdate(dciMCAC);
00258         CboUpdate(dciGATE);
00259         CboUpdate(dciPREC);
00260         CboUpdate(dciSOFF);
00261         CboUpdate(dciMCAS);
00262         CboUpdate(dciPRER);
00263         CboUpdate(dciPDMD);
00264         CboUpdate(dciTLLD);
00265
00266         if (s.profile->device_type == dppMCA8000D) {
00267                 ShowMCA8000D_Controls(SW_SHOW);
00268                 InitDlgItemDMCA(hPage,s.m_DP5Cfg[dciGAIA],IDC_OPT_COMBO_DMCA_GAIA);
00269                 InitDlgItemDMCA(hPage,s.m_DP5Cfg[dciPURE],IDC_OPT_COMBO_DMCA_PURE);
00270                 CboUpdateDMCA(dciGAIA,IDC_OPT_COMBO_DMCA_GAIA);
00271                 CboUpdateDMCA(dciPURE,IDC_OPT_COMBO_DMCA_PURE);
00272                 InitDlgItem(hPage,s.m_DP5Cfg[dciSOFF]);
00273                 CboUpdate(dciSOFF);
00274                 InitDlgItem(hPage,s.m_DP5Cfg[dciPREL]);
00275                 CboUpdate(dciPREL);
00276         } else {
00277                 ShowMCA8000D_Controls(SW_HIDE);
00278                 InitDlgItem(hPage,s.m_DP5Cfg[dciSOFF]);
00279                 CboUpdate(dciSOFF);
00280                 InitDlgItem(hPage,s.m_DP5Cfg[dciPRET]);
00281                 CboUpdate(dciPRET);
00282         }
00283 }
00284
00285 void CMcaPage::ShowMCA8000D_Controls(int iShowWin)
00286 {
00287         int iNotShowWin;
00288
00289         if (iShowWin == SW_HIDE) {
00290                 isDMcaControls = FALSE;
00291                 iNotShowWin = SW_SHOW;
00292         } else {
00293                 isDMcaControls = TRUE;;
00294                 iNotShowWin = SW_HIDE;
00295         }
00296
00297         GetDlgItem(IDC_OPT_FRAME_DMCA_GAIA)->ShowWindow(iShowWin);
00298         GetDlgItem(IDC_OPT_COMBO_DMCA_GAIA)->ShowWindow(iShowWin);
00299         GetDlgItem(IDC_OPT_FRAME_DMCA_PURE)->ShowWindow(iShowWin);
00300         GetDlgItem(IDC_OPT_COMBO_DMCA_PURE)->ShowWindow(iShowWin);
00301
00302         GetDlgItem(IDC_OPT_FRAME_PREL)->ShowWindow(iShowWin);
00303         GetDlgItem(IDC_OPT_COMBO_PREL)->ShowWindow(iShowWin);
00304         GetDlgItem(IDC_OPT_TEXT_PREL)->ShowWindow(iShowWin);
00305         GetDlgItem(IDC_OPT_UNITS_PREL)->ShowWindow(iShowWin);
00306         GetDlgItem(IDC_OPT_LIMITS_PREL)->ShowWindow(iShowWin);
00307
00308         GetDlgItem(IDC_OPT_FRAME_PRET)->ShowWindow(iNotShowWin);
00309         GetDlgItem(IDC_OPT_COMBO_PRET)->ShowWindow(iNotShowWin);
00310         GetDlgItem(IDC_OPT_TEXT_PRET)->ShowWindow(iNotShowWin);
00311         GetDlgItem(IDC_OPT_UNITS_PRET)->ShowWindow(iNotShowWin);
00312         GetDlgItem(IDC_OPT_LIMITS_PRET)->ShowWindow(iNotShowWin);
00313
00314                 //CString strIsSOFF_Move("");
00315                 //strIsSOFF_Move.Format("%d",iShowWin);
00316                 //AfxMessageBox(strIsSOFF_Move);
00317
00318         if (iShowWin) {
00319                 //MoveCtrl(IDC_OPT_FRAME_SOFF, 0, -90);
00320                 //MoveCtrl(IDC_OPT_COMBO_SOFF, 0, -90);
00321                 //MoveCtrl(IDC_OPT_TEXT_SOFF, 0, -90);
00322                 //MoveCtrl(IDC_OPT_UNITS_SOFF, 0, -90);
00323                 //MoveCtrl(IDC_OPT_LIMITS_SOFF, 0, -90);
00324
00325
00326                 MoveCtrlEx(IDC_OPT_FRAME_SOFF, IDC_OPT_FRAME_SOFF2, IDC_OPT_FRAME_SOFF2);
00327                 MoveCtrlEx(IDC_OPT_COMBO_SOFF, IDC_OPT_COMBO_SOFF2, IDC_OPT_COMBO_SOFF2);
00328                 MoveCtrlEx(IDC_OPT_TEXT_SOFF, IDC_OPT_TEXT_SOFF2, IDC_OPT_TEXT_SOFF2);
00329                 MoveCtrlEx(IDC_OPT_UNITS_SOFF, IDC_OPT_UNITS_SOFF2, IDC_OPT_UNITS_SOFF2);
00330                 MoveCtrlEx(IDC_OPT_LIMITS_SOFF, IDC_OPT_LIMITS_SOFF2, IDC_OPT_LIMITS_SOFF2);
00331
00332         } else {
00333                 MoveCtrlEx(IDC_OPT_FRAME_SOFF, IDC_OPT_FRAME_SOFF3, IDC_OPT_FRAME_SOFF3);
00334                 MoveCtrlEx(IDC_OPT_COMBO_SOFF, IDC_OPT_COMBO_SOFF3, IDC_OPT_COMBO_SOFF3);
00335                 MoveCtrlEx(IDC_OPT_TEXT_SOFF, IDC_OPT_TEXT_SOFF3, IDC_OPT_TEXT_SOFF3);
00336                 MoveCtrlEx(IDC_OPT_UNITS_SOFF, IDC_OPT_UNITS_SOFF3, IDC_OPT_UNITS_SOFF3);
00337                 MoveCtrlEx(IDC_OPT_LIMITS_SOFF, IDC_OPT_LIMITS_SOFF3, IDC_OPT_LIMITS_SOFF3);
00338
00339         }
00340 }
00341
00342 void CMcaPage::InitDlgItemDMCA(HWND hDlg, DP5_CONFIGURATION cfg, int cboDP5CtrlID)
00343 {
00344         CString strVal = cfg.Setting;
00345         int idxList;
00346         CString strUnits;
00347         CString strLimits;
00348
00349         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00350                 switch (cboDP5CtrlID) {
00351                         case IDC_OPT_COMBO_DMCA_GAIA:   // one plus the combobox index (1=1V,2=10V)
00352                                 idxList = atoi(strVal);
00353                                 idxList--;
00354                                 if ((idxList < 0) || (idxList > 1)) { idxList=0; }
00355                                 break;
00356                         case IDC_OPT_COMBO_DMCA_PURE:   //ON;OFF;
00357                                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00358                                 if (idxList == LB_ERR) {
00359                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00360                                 }
00361                                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00362                                         idxList = 0;            // set to first item
00363                                 }
00364                                 break;
00365                 }
00366                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00367                 cb.SetCurSel(idxList);
00368         }
00369 }
00370
00371 // MCA8000D special controls are not listed in the main control data structure
00372 // The DMCA controls moved to this page are combo boxes only
00373 // The "standard controls" for the moved DMCA commands are on other pages
00374 // The dialog item id must be passed in to get the data
00375 void CMcaPage::CboUpdateDMCA(int nID_dci, int nID)
00376 {
00377         CString strCboText;
00378
00379         if (nID == NULL) { return; }
00380         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00381         int idx = cb.GetCurSel();
00382         if (idx > LB_ERR) {
00383                 switch (nID_dci) {
00384                         case dciGAIA:   // one plus the combobox index (1=1V,2=10V)
00385                                 if ((idx < 0) || (idx > 1)) { idx=0; }
00386                                 strCboText.Format("%d",(idx+1));
00387                                 break;
00388                         case dciPURE:   //ON;OFF;
00389                                 cb.GetLBText(idx,strCboText);
00390                                 break;
00391                 }
00392                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00393                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00394                 SetModified(TRUE);
00395         } else {
00396                 return;
00397         }
00398 }
00399
00400 void CMcaPage::OnCbnSelchangeOptComboDmcaGaia()
00401 {
00402         CboUpdateDMCA(dciGAIA,IDC_OPT_COMBO_DMCA_GAIA);
00403 }
00404
00405 void CMcaPage::OnCbnSelchangeOptComboDmcaPure()
00406 {
00407         CboUpdateDMCA(dciPURE,IDC_OPT_COMBO_DMCA_PURE);
00408 }
00409
00410 void CMcaPage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00411 {
00412         int cboDP5CtrlID = cfg.ListCtrlID;
00413         int txtDP5CtrlID = cfg.TextCtrlID;
00414         CString strVal = cfg.Setting;
00415         int idxList;
00416         CString strUnits;
00417         CString strLimits;
00418
00419         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00420                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00421                 //idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00422                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00423                 if (idxList == LB_ERR) {
00424                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00425                 }
00426                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00427                         if ((cfg.CtrlType & dctTxt) > 0) {      // if cbotxt must find mask, else set to 0
00428                                 cfg.TextValue = cfg.Setting;            // overwrite if currently editing
00429                                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"#");
00430                                 if (idxList == LB_ERR) { // mask begins with +
00431                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"+");
00432                                 }
00433                                 if (idxList == LB_ERR) { // mask begins with -
00434                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"-");
00435                                 }
00436                                 if (idxList == LB_ERR) { // not found default to 0
00437                                         idxList = 0;
00438                                 }
00439                         } else {
00440                                 idxList = 0;            // set to first item
00441                         }
00442                 }
00443                 cb.SetCurSel(idxList);
00444         }
00445         if ((cfg.CtrlType & dctTxt) > 0) {
00446                 if ((cfg.CtrlType & dctCbo) == 0) {             // cbo update above
00447                         if (cfg.Setting.GetLength() > 0) {
00448                                 cfg.TextValue = cfg.Setting;
00449                         }
00450                 }
00451                 GetDlgItem(txtDP5CtrlID)->SetWindowText(cfg.TextValue);
00452                 strUnits = cfg.Units;
00453                 strLimits = cfg.Limits;
00454                 switch (txtDP5CtrlID) {
00455                         case IDC_OPT_TEXT_THSL:
00456                                 UNIT_INIT(THSL, strUnits);
00457                                 LIMIT_INIT(THSL, strLimits);
00458                                 break;
00459                         case IDC_OPT_TEXT_PRET:
00460                                 UNIT_INIT(PRET, strUnits);
00461                                 LIMIT_INIT(PRET, strLimits);
00462                                 break;
00463                         case IDC_OPT_TEXT_PREC:
00464                                 UNIT_INIT(PREC, strUnits);
00465                                 LIMIT_INIT(PREC, strLimits);
00466                                 break;
00467                         case IDC_OPT_TEXT_MCST:
00468                                 UNIT_INIT(MCST, strUnits);
00469                                 LIMIT_INIT(MCST, strLimits);
00470                                 break;
00471                         case IDC_OPT_TEXT_MCSL:
00472                                 UNIT_INIT(MCSL, strUnits);
00473                                 LIMIT_INIT(MCSL, strLimits);
00474                                 break;
00475                         case IDC_OPT_TEXT_MCSH:
00476                                 UNIT_INIT(MCSH, strUnits);
00477                                 LIMIT_INIT(MCSH, strLimits);
00478                                 break;
00479                         case IDC_OPT_TEXT_PRCL:
00480                                 UNIT_INIT(PRCL, strUnits);
00481                                 LIMIT_INIT(PRCL, strLimits);
00482                                 break;
00483                         case IDC_OPT_TEXT_PRCH:
00484                                 UNIT_INIT(PRCH, strUnits);
00485                                 LIMIT_INIT(PRCH, strLimits);
00486                                 break;
00487                         case IDC_OPT_TEXT_PRER:
00488                                 UNIT_INIT(PRER, strUnits);
00489                                 LIMIT_INIT(PRER, strLimits);
00490                                 break;
00491                         case IDC_OPT_TEXT_PREL:
00492                                 UNIT_INIT(PREL, strUnits);
00493                                 LIMIT_INIT(PREL, strLimits);
00494                                 break;
00495                         case IDC_OPT_TEXT_SOFF:
00496                                 UNIT_INIT(SOFF, strUnits);
00497                                 LIMIT_INIT(SOFF, strLimits);
00498                                 break;
00499                         case IDC_OPT_TEXT_TLLD:
00500                                 UNIT_INIT(TLLD, strUnits);
00501                                 LIMIT_INIT(TLLD, strLimits);
00502                                 break;
00503                 }
00504         }
00505 }
00506
00507 // pass dci id to update combo control and display edit controls if any
00508 void CMcaPage::CboUpdate(int nID_dci)
00509 {
00510         CString strCboText;
00511         int nID;
00512         int CmdShow;
00513
00514         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00515         if (nID == NULL) { return; }
00516         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00517         int idx = cb.GetCurSel();
00518         if (idx > LB_ERR) {
00519                 cb.GetLBText(idx,strCboText);
00520                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00521                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00522         } else {
00523                 return;
00524         }
00525         if (s.m_DP5Cfg[nID_dci].CtrlType == dctCboTxt) {
00526                 if (strCboText.Find('#') >= 0) {
00527                         CmdShow = SW_SHOW;
00528                 } else {
00529                         CmdShow = SW_HIDE;
00530                 }
00531                 switch (nID) {
00532                         case IDC_OPT_COMBO_PRET:
00533                                 ALL_VIS(PRET, CmdShow);
00534                                 CBO_TEXT_VIS(PRET, (CmdShow!=0));
00535                                 break;
00536                         case IDC_OPT_COMBO_PREC:
00537                                 ALL_VIS(PREC, CmdShow);
00538                                 CBO_TEXT_VIS(PREC, (CmdShow!=0));
00539                                 break;
00540                         case IDC_OPT_COMBO_PRER:
00541                                 ALL_VIS(PRER, CmdShow);
00542                                 CBO_TEXT_VIS(PRER, (CmdShow!=0));
00543                                 break;
00544                         case IDC_OPT_COMBO_PREL:
00545                                 ALL_VIS(PREL, CmdShow);
00546                                 CBO_TEXT_VIS(PREL, (CmdShow!=0));
00547                                 break;
00548                         case IDC_OPT_COMBO_SOFF:
00549                                 ALL_VIS(SOFF, CmdShow);
00550                                 CBO_TEXT_VIS(SOFF, (CmdShow!=0));
00551                                 break;
00552                         case IDC_OPT_COMBO_TLLD:
00553                                 ALL_VIS(TLLD, CmdShow);
00554                                 CBO_TEXT_VIS(TLLD, (CmdShow!=0));
00555                                 break;
00556                 }
00557         }
00558         SetModified(TRUE);
00559 }
00560
00561 //CBO_TEXT_VIS(RESL, (CmdShow!=0));
00562 //CboTextVis(IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,(CmdShow!=0));
00563 //void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00564 void CMcaPage::CboTextVis(int nIdCbox, int nIdEdit, BOOL isText)
00565 {
00566         UINT ddSize;
00567         RECT lpRect;
00568         CEdit* pEdit;
00569         CComboBox* pCombo;
00570         int btnSize = 20;
00571
00572         pEdit = (CEdit*)GetDlgItem(nIdEdit);            // cast to edit for rect
00573         pEdit->GetRect(&lpRect);                                        // get rect
00574         ddSize = lpRect.right - lpRect.left;            // save width
00575         if (isText) {
00576                 GetDlgItem(nIdEdit)->ShowWindow(SW_SHOW);
00577                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);
00578                 pCombo->GetWindowRect(&lpRect);
00579                 ScreenToClient(&lpRect);
00580                 //int ddSize1 = lpRect.right - lpRect.left;             // save width
00581                 //TRACE("Combo Edit %d\r\n",ddSize1);
00582                 lpRect.right = lpRect.left + btnSize;
00583                 pCombo->MoveWindow(&lpRect,TRUE);
00584                 pCombo->SetDroppedWidth(ddSize + btnSize);
00585         } else {
00586                 GetDlgItem(nIdEdit)->ShowWindow(SW_HIDE);       // hide edit
00587                 //TRACE("Edit %d\r\n",ddSize);
00588                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);       // cast to combo
00589                 pCombo->GetWindowRect(&lpRect);                         // get win size
00590                 ScreenToClient(&lpRect);                                        // adjust to screen
00591                 //int ddSize2 = lpRect.right - lpRect.left;             // save width
00592                 //TRACE("Combo %d\r\n",ddSize2);
00593                 lpRect.right = lpRect.left + ddSize + btnSize;  // get restored combo size
00594                 pCombo->MoveWindow(&lpRect,TRUE);                       // restore combo
00595                 pCombo->SetDroppedWidth(ddSize);                        // restore combo
00596         }
00597 }
00598
00599 // pass dci id to update combo control and display edit controls if any
00600 void CMcaPage::TextUpdate(int nID_dci)
00601 {
00602         CString strText;
00603         int nID;
00604
00605         nID = s.m_DP5Cfg[nID_dci].TextCtrlID;
00606         if (nID == NULL) { return; }
00607
00608         GetDlgItem(nID)->GetWindowText(strText);
00609         s.m_DP5Cfg[nID_dci].TextValue = strText;
00610         SetModified(TRUE);
00611 }
00612
00613 void CMcaPage::OnCbnSelchangeOptComboPret()
00614 {
00615         CboUpdate(dciPRET);
00616 }
00617
00618 void CMcaPage::OnCbnSelchangeOptComboMcae()
00619 {
00620         CboUpdate(dciMCAE);
00621 }
00622
00623 void CMcaPage::OnCbnSelchangeOptComboMcac()
00624 {
00625         CboUpdate(dciMCAC);
00626 }
00627
00628 void CMcaPage::OnCbnSelchangeOptComboGate()
00629 {
00630         CboUpdate(dciGATE);
00631 }
00632
00633 void CMcaPage::OnCbnSelchangeOptComboPrec()
00634 {
00635         CboUpdate(dciPREC);
00636 }
00637
00638 void CMcaPage::OnCbnSelchangeOptComboSoff()
00639 {
00640         CboUpdate(dciSOFF);
00641 }
00642
00643 void CMcaPage::OnCbnSelchangeOptComboPdmd()
00644 {
00645         CboUpdate(dciPDMD);
00646 }
00647
00648 void CMcaPage::OnEnChangeOptTextThsl()
00649 {
00650         TextUpdate(dciTHSL);
00651 }
00652
00653 void CMcaPage::OnEnChangeOptTextPret()
00654 {
00655         TextUpdate(dciPRET);
00656         //CString strText;
00657         //GetDlgItem(IDC_OPT_TEXT_PRET)->GetWindowText(strText);
00658         //AfxMessageBox(s.m_DP5Cfg[dciPRET].TextValue);
00659         //AfxMessageBox(strText);
00660 }
00661
00662 void CMcaPage::OnEnChangeOptTextPrec()
00663 {
00664         TextUpdate(dciPREC);
00665 }
00666
00667 void CMcaPage::OnEnChangeOptTextMcst()
00668 {
00669         TextUpdate(dciMCST);
00670 }
00671
00672 void CMcaPage::OnEnChangeOptTextSoff()
00673 {
00674         TextUpdate(dciSOFF);
00675 }
00676
00677 void CMcaPage::OnCbnSelchangeOptComboMcas()
00678 {
00679         CboUpdate(dciMCAS);
00680 }
00681
00682
00683 void CMcaPage::OnCbnSelchangeOptComboPrer()
00684 {
00685         CboUpdate(dciPRER);
00686 }
00687
00688 void CMcaPage::OnEnChangeOptTextPrer()
00689 {
00690         TextUpdate(dciPRER);
00691 }
00692
00693 void CMcaPage::OnCbnSelchangeOptComboPrel()
00694 {
00695         CboUpdate(dciPREL);
00696 }
00697
00698 void CMcaPage::OnEnChangeOptTextPrel()
00699 {
00700         TextUpdate(dciPREL);
00701 }
00702
00703 void CMcaPage::OnEnChangeOptTextMcsl()
00704 {
00705         TextUpdate(dciMCSL);
00706 }
00707
00708 void CMcaPage::OnEnChangeOptTextMcsh()
00709 {
00710         TextUpdate(dciMCSH);
00711 }
00712
00713 void CMcaPage::OnEnChangeOptTextPrcl()
00714 {
00715         TextUpdate(dciPRCL);
00716 }
00717
00718 void CMcaPage::OnEnChangeOptTextPrch()
00719 {
00720         TextUpdate(dciPRCH);
00721 }
00722
00723 void CMcaPage::OnEnChangeOptTextTlld()
00724 {
00725         TextUpdate(dciTLLD);
00726 }
00727
00728 void CMcaPage::OnCbnSelchangeOptComboTlld()
00729 {
00730         CboUpdate(dciTLLD);
00731 }
00732
00733 BOOL CMcaPage::PreTranslateMessage(MSG* pMsg)
00734 {
00735         int ctrl;
00736         CWnd* pCurrent;
00737         MSG msg = *pMsg;
00738         if (msg.message == WM_MOUSEMOVE) {      // Relay events to the tooltip control
00739                 msg.hwnd = (HWND)m_ToolTip.SendMessage(TTM_WINDOWFROMPOINT, 0, (LPARAM)&msg.pt);
00740                 CPoint pt = pMsg->pt;
00741                 ::ScreenToClient(msg.hwnd, &pt);
00742                 msg.lParam = MAKELONG(pt.x, pt.y);
00743                 m_ToolTip.Activate(TRUE);   // make sure tooltip is active
00744                 m_ToolTip.RelayEvent(&msg); // Let the ToolTip process this message.
00745         } else if ( pMsg->message == WM_KEYDOWN && pMsg->wParam == VK_RETURN ) {
00746                 pCurrent = GetFocus();
00747                 ctrl = pCurrent->GetDlgCtrlID();
00748                 //if (ctrl == IDC_OPT_TEXT_MCST) {
00749                 if (isCEditBox(ctrl)) {
00750                         ::SendMessage(this->m_hWnd, WM_COMMAND, MAKEWPARAM(ctrl, EN_CHANGE), (LPARAM) m_hWnd);
00751                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00752                         pMsg->wParam = VK_TAB;
00753                         //if ( pNext != NULL ) {
00754                         //      if (pNext->GetDlgCtrlID() != IDOK ) {
00755                         //              pNext->SetFocus();
00756                         //              return TRUE;
00757                         //      }
00758                         //}
00759                 } else if (isCComboBox(ctrl)) {
00760                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00761                         pMsg->wParam = VK_TAB;
00762                 }
00763         }
00764
00765         //==================================================================
00766         return CCfgPropPage::PreTranslateMessage(pMsg);
00767 }
00768
00769 BOOL CMcaPage::isCEditBox(int nID)
00770 {
00771         BOOL isEdit = FALSE;
00772         switch (nID) {
00773                 case IDC_OPT_TEXT_THSL:
00774                         isEdit = TRUE;
00775                         break;
00776                 case IDC_OPT_TEXT_PRET:
00777                         isEdit = TRUE;
00778                         break;
00779                 case IDC_OPT_TEXT_PREC:
00780                         isEdit = TRUE;
00781                         break;
00782                 case IDC_OPT_TEXT_PRER:
00783                         isEdit = TRUE;
00784                         break;
00785                 case IDC_OPT_TEXT_PREL:
00786                         isEdit = TRUE;
00787                         break;
00788                 case IDC_OPT_TEXT_MCST:
00789                         isEdit = TRUE;
00790                         break;
00791                 case IDC_OPT_TEXT_MCSL:
00792                         isEdit = TRUE;
00793                         break;
00794                 case IDC_OPT_TEXT_MCSH:
00795                         isEdit = TRUE;
00796                         break;
00797                 case IDC_OPT_TEXT_PRCL:
00798                         isEdit = TRUE;
00799                         break;
00800                 case IDC_OPT_TEXT_PRCH:
00801                         isEdit = TRUE;
00802                         break;
00803                 case IDC_OPT_TEXT_SOFF:
00804                         isEdit = TRUE;
00805                         break;
00806         }
00807         return isEdit;
00808 }
00809
00810 BOOL CMcaPage::isCComboBox(int nID)
00811 {
00812         BOOL isCombo = FALSE;
00813         switch (nID) {
00814                 case IDC_OPT_COMBO_MCAS:
00815                         isCombo = TRUE;
00816                         break;
00817                 case IDC_OPT_COMBO_MCAE:
00818                         isCombo = TRUE;
00819                         break;
00820                 case IDC_OPT_COMBO_MCAC:
00821                         isCombo = TRUE;
00822                         break;
00823                 case IDC_OPT_COMBO_GATE:
00824                         isCombo = TRUE;
00825                         break;
00826                 case IDC_OPT_COMBO_PRET:
00827                         isCombo = TRUE;
00828                         break;
00829                 case IDC_OPT_COMBO_PREC:
00830                         isCombo = TRUE;
00831                         break;
00832                 case IDC_OPT_COMBO_PRER:
00833                         isCombo = TRUE;
00834                         break;
00835                 case IDC_OPT_COMBO_PREL:
00836                         isCombo = TRUE;
00837                         break;
00838                 case IDC_OPT_COMBO_SOFF:
00839                         isCombo = TRUE;
00840                         break;
00841                 case IDC_OPT_COMBO_PDMD:
00842                         isCombo = TRUE;
00843                         break;
00844         }
00845         return isCombo;
00846 }
00847
00848 void CMcaPage::OnBnClickedPresetcountcursorbutton()
00849 {
00850
00851         int ChPos;
00852         CString strChPos;
00853
00854         ChPos = 0;
00855         ChPos = s.spectraList.m_currentSpectrum->PosToChannel(s.plot->m_xCursorData);
00856         if (ChPos == 0) ChPos = 1;
00857         //ChPos++;              //20110503
00858
00859         strChPos.Format("%d",ChPos - 1);
00860         GetDlgItem(IDC_OPT_TEXT_PRCL)->SetWindowText(strChPos);
00861         TextUpdate(dciPRCL);
00862
00863         strChPos.Format("%d",ChPos + 1);
00864         GetDlgItem(IDC_OPT_TEXT_PRCH)->SetWindowText(strChPos);
00865         TextUpdate(dciPRCH);
00866
00867 }
00868
00869 // This will change when dpp channels=dpppmca channels
00870 // NOTE: the dp5 spectrum 1-max chan
00871 //       DppMCA 0-(max chan-1)
00872 // Preset Chan Low = (roi start channel) + 1 //offset chan
00873 // Preset Chan High = (roi end channel) + 1  //offset chan
00874 void CMcaPage::OnBnClickedPresetcountroibutton()
00875 {
00876         int ChPosL;
00877         int ChPosH;
00878         CString strChPos;
00879         CSpectrum &sp = *s.spectraList.m_currentSpectrum;       // get handle to current spectrum
00880         int i = sp.m_roi.m_selectIndex;                                         // get the index of the current ROI
00881         if (i >= 0 && i < sp.m_roi.m_count)                                     // test if ROI is valid and in list
00882         {
00883                 ChPosL = sp.m_roi[i].m_start; // + 1;  //20110503                       // roi start channel
00884                 if (ChPosL < 0) ChPosL = 0;
00885                 strChPos.Format("%d",ChPosL);
00886                 GetDlgItem(IDC_OPT_TEXT_PRCL)->SetWindowText(strChPos);
00887                 TextUpdate(dciPRCL);
00888
00889                 ChPosH = sp.m_roi[i].m_end; // + 1;  //20110503                                 // roi end channel
00890                 if (ChPosH <= ChPosL + 2) ChPosH = ChPosL + 2;
00891                 strChPos.Format("%d",ChPosH);
00892                 GetDlgItem(IDC_OPT_TEXT_PRCH)->SetWindowText(strChPos);
00893                 TextUpdate(dciPRCH);
00894         }
00895 }
00896
00898 // HtmlHelp for shared dialog
00899 // NOTE: shared dialogs use string type IDD, not global IDD
00900 BOOL CMcaPage::OnHelpInfo(HELPINFO* pHelpInfo)
00901 {
00902         CString strHelp;
00903         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
00904                 if (pHelpInfo->dwContextId == 0) {
00905                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_MCA_PAGE);
00906                 } else {
00907                         //
00908                 }
00909         }
00910         return true;
00911 }
00912
00913 void CMcaPage::OnHelp()                         // enable property sheet help button help
00914 {
00915         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_MCA_PAGE);
00916     //SendMessage(WM_COMMANDHELP);      //
00917 }
00919
00920 void CMcaPage::BuildToolTips()
00921 {
00922         if (!m_ToolTip.Create(this)) {
00923                 TRACE0("Unable to create ToolTip control\n");
00924         } else {
00925                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GATE), IDS_TT_GATE_CONTROL);
00926                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GATE), IDS_TT_GATE_CONTROL);
00927                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_MCAC), IDS_TT_MCA_MCS_CHANNELS);
00928                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_MCAC), IDS_TT_MCA_MCS_CHANNELS);
00929                 //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_MCAE), IDS_TT_ANA_LOAD_LIB);
00930                 //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_MCAE), IDS_TT_ANA_LOAD_LIB);
00931                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_MCAS), IDS_TT_MCA_SOURCE);
00932                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_MCAS), IDS_TT_MCA_SOURCE);
00933                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_MCSH), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00934                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_MCSH), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00935                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_MCSH), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00936                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_MCSH), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00937                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_MCSL), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00938                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_MCSL), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00939                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_MCSL), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00940                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_MCSL), IDS_TT_MCS_LOW_HIGH_CHANNEL);
00941                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_MCST), IDS_TT_MCS_TIMEBASE);
00942                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_MCST), IDS_TT_MCS_TIMEBASE);
00943                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_MCST), IDS_TT_MCS_TIMEBASE);
00944                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_MCST), IDS_TT_MCS_TIMEBASE);
00945                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PDMD), IDS_TT_PEAK_DETECT_MODE);
00946                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PDMD), IDS_TT_PEAK_DETECT_MODE);
00947                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PRCH), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00948                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PRCH), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00949                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PRCH), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00950                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PRCH), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00951                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PRCL), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00952                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PRCL), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00953                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PRCL), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00954                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PRCL), IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL);
00955                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PREC), IDS_TT_PRESET_COUNT);
00956                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PREC), IDS_TT_PRESET_COUNT);
00957                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PREC), IDS_TT_PRESET_COUNT);
00958                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PREC), IDS_TT_PRESET_COUNT);
00959                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PREC), IDS_TT_PRESET_COUNT);
00960
00961                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PRER), IDS_TT_PRESET_REAL_TIME);
00962                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PRER), IDS_TT_PRESET_REAL_TIME);
00963                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PRER), IDS_TT_PRESET_REAL_TIME);
00964                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PRER), IDS_TT_PRESET_REAL_TIME);
00965                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PRER), IDS_TT_PRESET_REAL_TIME);
00966
00967                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PREL), IDS_TT_PRESET_LIVE_TIME);
00968                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PREL), IDS_TT_PRESET_LIVE_TIME);
00969                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PREL), IDS_TT_PRESET_LIVE_TIME);
00970                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PREL), IDS_TT_PRESET_LIVE_TIME);
00971                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PREL), IDS_TT_PRESET_LIVE_TIME);
00972
00973                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PRET), IDS_TT_PRESET_ACQUISITION_TIME);
00974                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PRET), IDS_TT_PRESET_ACQUISITION_TIME);
00975                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PRET), IDS_TT_PRESET_ACQUISITION_TIME);
00976                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PRET), IDS_TT_PRESET_ACQUISITION_TIME);
00977                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PRET), IDS_TT_PRESET_ACQUISITION_TIME);
00978                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_SOFF), IDS_TT_SET_SPECTRUM_OFFSET);
00979                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_SOFF), IDS_TT_SET_SPECTRUM_OFFSET);
00980                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_SOFF), IDS_TT_SET_SPECTRUM_OFFSET);
00981                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_SOFF), IDS_TT_SET_SPECTRUM_OFFSET);
00982                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_SOFF), IDS_TT_SET_SPECTRUM_OFFSET);
00983                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_THSL), IDS_TT_SLOW_THRESHOLD);
00984                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_THSL), IDS_TT_SLOW_THRESHOLD);
00985                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_THSL), IDS_TT_SLOW_THRESHOLD);
00986                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_THSL), IDS_TT_SLOW_THRESHOLD);
00987                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_TLLD), IDS_TT_LOW_LEVEL_DISCRIMINATOR);
00988                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TLLD), IDS_TT_LOW_LEVEL_DISCRIMINATOR);
00989                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_TLLD), IDS_TT_LOW_LEVEL_DISCRIMINATOR);
00990                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_TLLD), IDS_TT_LOW_LEVEL_DISCRIMINATOR);
00991                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_TLLD), IDS_TT_LOW_LEVEL_DISCRIMINATOR);
00992                 m_ToolTip.AddTool(GetDlgItem(IDC_PRESETCOUNTCURSORBUTTON), IDS_TT_PRESET_COUNT);
00993                 m_ToolTip.AddTool(GetDlgItem(IDC_PRESETCOUNTROIBUTTON), IDS_TT_PRESET_COUNT);
00994
00995                 //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MCA_ADVANCED), _T("Advanced controls for experienced users."));
00996                 //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MCA_BASIC), _T("Basic controls for most users."));
00997                 //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MCA_PAGE), _T("MCA Controls Page"));
00998                 //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MCA_STANDARD), _T("Basic controls for most users."));
00999
01000                 m_ToolTip.Activate(TRUE);
01001                 m_ToolTip.SetMaxTipWidth(200);
01002         }
01003 }
01004
01005 void CMcaPage::MoveCtrl(int nID, long deltaX, long deltaY)
01006 {
01007     CRect m_Rect; // CRect representing tab control's position.
01008         //CString strRect("");
01009         //CString strAll("");
01010         GetDlgItem(nID)->GetWindowRect(&m_Rect);
01011         //strRect.Format("Rect: %d %d %d %d \r\n", m_Rect.left, m_Rect.top, m_Rect.Width(), m_Rect.Height());
01012         //strAll += strRect;
01013         ScreenToClient(m_Rect);
01014         GetDlgItem(nID)->MoveWindow(m_Rect.left + deltaX, m_Rect.top + deltaY, m_Rect.Width(), m_Rect.Height(), 1);
01015         //strRect.Format("Rect: %d %d %d %d \r\n", m_Rect.left, m_Rect.top, m_Rect.Width(), m_Rect.Height());
01016         //strAll += strRect;
01017         //ScreenToClient(m_Rect);
01018         //AfxMessageBox(strRect);
01019         //AfxMessageBox(strAll);
01020         GetDlgItem(nID)->ShowWindow(SW_SHOW);
01021 }
01022
01023 void CMcaPage::MoveCtrlEx(int nID, int nID_Left, int nID_Top)
01024 {
01025     CRect m_Rect; // CRect representing tab control's position.
01026         CRect m_Rect_Left; // CRect representing tab control's position.
01027         CRect m_Rect_Top; // CRect representing tab control's position.
01028         //CString strRect("");
01029         //CString strAll("");
01030         GetDlgItem(nID)->GetWindowRect(&m_Rect);
01031         GetDlgItem(nID_Left)->GetWindowRect(&m_Rect_Left);
01032         GetDlgItem(nID_Top)->GetWindowRect(&m_Rect_Top);
01033         //strRect.Format("Rect: %d %d %d %d \r\n", m_Rect.left, m_Rect.top, m_Rect.Width(), m_Rect.Height());
01034         //strAll += strRect;
01035         ScreenToClient(m_Rect);
01036         ScreenToClient(m_Rect_Left);
01037         ScreenToClient(m_Rect_Top);
01038         GetDlgItem(nID)->MoveWindow(m_Rect_Left.left, m_Rect_Top.top, m_Rect.Width(), m_Rect.Height(), 1);
01039         //strRect.Format("Rect: %d %d %d %d \r\n", m_Rect.left, m_Rect.top, m_Rect.Width(), m_Rect.Height());
01040         //strAll += strRect;
01041         //ScreenToClient(m_Rect);
01042         //AfxMessageBox(strRect);
01043         //AfxMessageBox(strAll);
01044         GetDlgItem(nID)->ShowWindow(SW_SHOW);
01045 }
01046
01047
01048
01049
01050
01051
01052
01053
01054
01055
01056
01057
01058
01059
01060
01061
01062
01063
01064
01065
01066
01067
01068
01069
01070
01071
01072
01073
01074
01075
01076
01077
01078
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/McaPage.h Source File

DP5Cfg/McaPage.h
Go to the documentation of this file.
00001 #if !defined(AFX_McaPage_H__INCLUDED_)
00002 #define AFX_McaPage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // McaPage.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "afxwin.h"
00012 #include "label.h"
00013 #include "scommon.h"
00014
00016 // CMcaPage dialog
00017
00018 class CMcaPage : public CCfgPropPage
00019 {
00020         DECLARE_DYNCREATE(CMcaPage)
00021
00022 // Construction
00023 public:
00024         CMcaPage();
00025         ~CMcaPage();
00026
00027 // Dialog Data
00028         //{{AFX_DATA(CMcaPage)
00029         //enum { IDD = IDD_MCA_PAGE };
00030         //}}AFX_DATA
00031
00032 // Overrides
00033         // ClassWizard generate virtual function overrides
00034         //{{AFX_VIRTUAL(CMcaPage)
00035         protected:
00036         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00037         //}}AFX_VIRTUAL
00038
00039 // Implementation
00040 protected:
00041         // Generated message map functions
00042         //{{AFX_MSG(CMcaPage)
00043         //}}AFX_MSG
00044         DECLARE_MESSAGE_MAP()
00045         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00046
00047 public:
00048         void BuildToolTips();                                                           // Tooltip control
00049         //CStatic m_McaPageLabel;
00050         CLabel m_McaPageLabel;
00051         //CStatic m_McaAdvancedLabel;
00052         CLabel m_McaAdvancedLabel;
00053         //CStatic m_McaStandardLabel;
00054         CLabel m_McaStandardLabel;
00055         virtual BOOL OnSetActive();
00056         virtual BOOL OnInitDialog();
00057
00058         void InitControls();
00059         void InitDlgItemDMCA(HWND hDlg, DP5_CONFIGURATION cfg, int cboDP5CtrlID);
00060         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00061         void ShowMCA8000D_Controls(int iShowWin);
00062
00063         void CboUpdateDMCA(int nID_dci, int nID);
00064         void CboUpdate(int nID_dci);
00065         void TextUpdate(int nID_dci);
00066
00067         afx_msg void OnCbnSelchangeOptComboPret();
00068
00069         afx_msg void OnEnChangeOptTextThsl();
00070         afx_msg void OnCbnSelchangeOptComboMcae();
00071         afx_msg void OnCbnSelchangeOptComboMcac();
00072         afx_msg void OnCbnSelchangeOptComboGate();
00073         afx_msg void OnCbnSelchangeOptComboPrec();
00074         afx_msg void OnCbnSelchangeOptComboSoff();
00075         afx_msg void OnCbnSelchangeOptComboPdmd();
00076         afx_msg void OnEnChangeOptTextPret();
00077         afx_msg void OnEnChangeOptTextPrec();
00078         afx_msg void OnEnChangeOptTextMcst();
00079         afx_msg void OnEnChangeOptTextSoff();
00080
00081         afx_msg void OnCbnSelchangeOptComboMcas();
00082         void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00083
00084         virtual BOOL PreTranslateMessage(MSG* pMsg);
00085         BOOL isCEditBox(int nID);
00086         BOOL isCComboBox(int nID);
00087         afx_msg void OnEnChangeOptTextMcsl();
00088         afx_msg void OnEnChangeOptTextMcsh();
00089         afx_msg void OnEnChangeOptTextPrcl();
00090         afx_msg void OnEnChangeOptTextPrch();
00091         afx_msg void OnCbnSelchangeOptComboPrer();
00092         afx_msg void OnEnChangeOptTextPrer();
00093         afx_msg void OnCbnSelchangeOptComboPrel();
00094         afx_msg void OnEnChangeOptTextPrel();
00095         afx_msg void OnCbnSelchangeOptComboTlld();
00096         afx_msg void OnEnChangeOptTextTlld();
00097         afx_msg void OnBnClickedPresetcountcursorbutton();
00098         afx_msg void OnBnClickedPresetcountroibutton();
00099
00100         afx_msg void OnHelp();
00101         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00102
00103         afx_msg void OnCbnSelchangeOptComboDmcaGaia();
00104         afx_msg void OnCbnSelchangeOptComboDmcaPure();
00105
00106         void MoveCtrl(int nID, long deltaX, long deltaY);
00107         void MoveCtrlEx(int nID, int nID_Left, int nID_Top);
00108         BOOL isDMcaControls;
00109
00110 };
00111
00112 //{{AFX_INSERT_LOCATION}}
00113 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00114
00115 #endif // !defined(AFX_McaPage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/McaPageRes.h Source File

DP5Cfg/McaPageRes.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by McaPage.rc
00004 //
00005 #define IDC_OPT_COMBO_GATE              1280
00006 #define IDC_OPT_COMBO_MCAC              1281
00007 #define IDC_OPT_COMBO_MCAE              1282
00008 #define IDC_OPT_COMBO_MCAS              1283
00009 #define IDC_OPT_COMBO_PDMD              1284
00010 #define IDC_OPT_COMBO_PREC              1285
00011 #define IDC_OPT_COMBO_PRER              1286
00012 #define IDC_OPT_COMBO_PRET              1287
00013 #define IDC_OPT_COMBO_SOFF              1288
00014 #define IDC_OPT_COMBO_TLLD              1289
00015 #define IDC_OPT_FRAME_GATE              1290
00016 #define IDC_OPT_FRAME_MCAC              1291
00017 #define IDC_OPT_FRAME_MCAE              1292
00018 #define IDC_OPT_FRAME_MCAS              1293
00019 #define IDC_OPT_FRAME_MCSH              1294
00020 #define IDC_OPT_FRAME_MCSL              1295
00021 #define IDC_OPT_FRAME_MCST              1296
00022 #define IDC_OPT_FRAME_PDMD              1297
00023 #define IDC_OPT_FRAME_PRCH              1298
00024 #define IDC_OPT_FRAME_PRCL              1299
00025 #define IDC_OPT_FRAME_PREC              1300
00026 #define IDC_OPT_FRAME_PRER              1301
00027 #define IDC_OPT_FRAME_PRET              1302
00028 #define IDC_OPT_FRAME_SOFF              1303
00029 #define IDC_OPT_FRAME_THSL              1304
00030 #define IDC_OPT_FRAME_TLLD              1305
00031 #define IDC_OPT_LIMITS_MCSH             1306
00032 #define IDC_OPT_LIMITS_MCSL             1307
00033 #define IDC_OPT_LIMITS_MCST             1308
00034 #define IDC_OPT_LIMITS_PRCH             1309
00035 #define IDC_OPT_LIMITS_PRCL             1310
00036 #define IDC_OPT_LIMITS_PREC             1311
00037 #define IDC_OPT_LIMITS_PRER             1312
00038 #define IDC_OPT_LIMITS_PRET             1313
00039 #define IDC_OPT_LIMITS_SOFF             1314
00040 #define IDC_OPT_LIMITS_THSL             1315
00041 #define IDC_OPT_LIMITS_TLLD             1316
00042 #define IDC_OPT_TEXT_MCSH               1317
00043 #define IDC_OPT_TEXT_MCSL               1318
00044 #define IDC_OPT_TEXT_MCST               1319
00045 #define IDC_OPT_TEXT_PRCH               1320
00046 #define IDC_OPT_TEXT_PRCL               1321
00047 #define IDC_OPT_TEXT_PREC               1322
00048 #define IDC_OPT_TEXT_PRER               1323
00049 #define IDC_OPT_TEXT_PRET               1324
00050 #define IDC_OPT_TEXT_SOFF               1325
00051 #define IDC_OPT_TEXT_THSL               1326
00052 #define IDC_OPT_TEXT_TLLD               1327
00053 #define IDC_OPT_UNITS_MCSH              1328
00054 #define IDC_OPT_UNITS_MCSL              1329
00055 #define IDC_OPT_UNITS_MCST              1330
00056 #define IDC_OPT_UNITS_PRCH              1331
00057 #define IDC_OPT_UNITS_PRCL              1332
00058 #define IDC_OPT_UNITS_PREC              1333
00059 #define IDC_OPT_UNITS_PRER              1334
00060 #define IDC_OPT_UNITS_PRET              1335
00061 #define IDC_OPT_UNITS_SOFF              1336
00062 #define IDC_OPT_UNITS_THSL              1337
00063 #define IDC_OPT_UNITS_TLLD              1338
00064 #define IDC_PRESETCOUNTCURSORBUTTON     1339
00065 #define IDC_PRESETCOUNTROIBUTTON        1340
00066 #define IDC_STATIC_MCA_ADVANCED         1341
00067 #define IDC_STATIC_MCA_BASIC            1342
00068 #define IDC_STATIC_MCA_PAGE             1343
00069 #define IDC_STATIC_MCA_STANDARD         1344
00070 #define IDC_OPT_FRAME_DMCA_GAIA         1345
00071 #define IDC_OPT_COMBO_DMCA_GAIA         1346
00072 #define IDC_OPT_FRAME_DMCA_PURE         1347
00073 #define IDC_OPT_FRAME_PREL              1348
00074 #define IDC_OPT_COMBO_PREL              1349
00075 #define IDC_OPT_LIMITS_PREL             1350
00076 #define IDC_OPT_TEXT_PREL               1351
00077 #define IDC_OPT_UNITS_PREL              1352
00078 #define IDC_OPT_FRAME_SOFF2             1353
00079 #define IDC_OPT_COMBO_SOFF2             1354
00080 #define IDC_OPT_LIMITS_SOFF2            1355
00081 #define IDC_OPT_TEXT_SOFF2              1356
00082 #define IDC_OPT_UNITS_SOFF2             1357
00083 #define IDC_OPT_FRAME_SOFF3             1358
00084 #define IDC_OPT_COMBO_SOFF3             1359
00085 #define IDC_OPT_LIMITS_SOFF3            1360
00086 #define IDC_OPT_TEXT_SOFF3              1361
00087 #define IDC_OPT_UNITS_SOFF3             1362
00088 #define IDC_OPT_COMBO_DMCA_PURE         1416
00089 #define IDS_TT_MCA_MCS_CHANNELS         5120
00090 #define IDS_TT_SLOW_THRESHOLD           5121
00091 #define IDS_TT_LOW_LEVEL_DISCRIMINATOR  5122
00092 #define IDS_TT_SET_SPECTRUM_OFFSET      5123
00093 #define IDS_TT_PRESET_ACQUISITION_TIME  5124
00094 #define IDS_TT_PRESET_REAL_TIME         5125
00095 #define IDS_TT_PRESET_COUNT             5126
00096 #define IDS_TT_PRESET_COUNT_LOW_HIGH_CHANNEL 5127
00097 #define IDS_TT_GATE_CONTROL             5128
00098 #define IDS_TT_MCS_TIMEBASE             5129
00099 #define IDS_TT_MCS_LOW_HIGH_CHANNEL     5130
00100 #define IDS_TT_MCA_SOURCE               5131
00101 #define IDS_TT_PEAK_DETECT_MODE         5132
00102 #define IDS_TT_PRESET_LIVE_TIME         5133
00103
00104 // Next default values for new objects
00105 //
00106 #ifdef APSTUDIO_INVOKED
00107 #ifndef APSTUDIO_READONLY_SYMBOLS
00108 #define _APS_NEXT_RESOURCE_VALUE        5133
00109 #define _APS_NEXT_COMMAND_VALUE         33280
00110 #define _APS_NEXT_CONTROL_VALUE         1345
00111 #define _APS_NEXT_SYMED_VALUE           5134
00112 #endif
00113 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/MiscPage.cpp Source File

DP5Cfg/MiscPage.cpp
Go to the documentation of this file.
00001 // MiscPage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005  #include "afxpriv.h"   // afxpriv.h has WM_COMMANDHELP id
00006 //#include "CDP5Cfg.h"
00007 #include "MiscPageRes.h"
00008 #include "MiscPage.h"
00009 #include ".\MiscPage.h"
00010
00011
00012 #ifdef _DEBUG
00013 #define new DEBUG_NEW
00014 #undef THIS_FILE
00015 static char THIS_FILE[] = __FILE__;
00016 #endif
00017
00019 // CMiscPage property page
00020
00021 IMPLEMENT_DYNCREATE(CMiscPage, CCfgPropPage)
00022 //#define IDD_MISC_PAGE                   110
00023
00024
00025 //CMiscPage::CMiscPage() : CCfgPropPage(CMiscPage::IDD)
00026 CMiscPage::CMiscPage() : CCfgPropPage("IDD_MISC_PAGE")
00027 {
00028         //{{AFX_DATA_INIT(CMiscPage)
00029                 // NOTE: the ClassWizard will add member initialization here
00030         //}}AFX_DATA_INIT
00031 }
00032
00033 CMiscPage::~CMiscPage()
00034 {
00035 }
00036
00037 void CMiscPage::DoDataExchange(CDataExchange* pDX)
00038 {
00039         CCfgPropPage::DoDataExchange(pDX);
00040         //{{AFX_DATA_MAP(CMiscPage)
00041         //}}AFX_DATA_MAP
00042         DDX_Control(pDX, IDC_STATIC_MISC_PAGE, m_MiscPageLabel);
00043         DDX_Control(pDX, IDC_STATIC_MISC_ADVANCED, m_MiscAdvancedLabel);
00044         DDX_Control(pDX, IDC_STATIC_MISC_QUICKSET, m_MiscQuicksetLabel);
00045 }
00046
00047 BEGIN_MESSAGE_MAP(CMiscPage, CCfgPropPage)
00048         //{{AFX_MSG_MAP(CMiscPage)
00049         //}}AFX_MSG_MAP
00050         ON_CBN_SELCHANGE(IDC_OPT_COMBO_DACO, OnCbnSelchangeOptComboDaco)
00051         ON_EN_CHANGE(IDC_OPT_TEXT_DACF, OnEnChangeOptTextDacf)
00052         ON_CBN_SELCHANGE(IDC_OPT_COMBO_SCOE, OnCbnSelchangeOptComboScoe)
00053         ON_CBN_SELCHANGE(IDC_OPT_COMBO_AUO1, OnCbnSelchangeOptComboAuo1)
00054         ON_CBN_SELCHANGE(IDC_OPT_COMBO_AUO2, OnCbnSelchangeOptComboAuo2)
00055         ON_CBN_SELCHANGE(IDC_OPT_COMBO_SCOT, OnCbnSelchangeOptComboScot)
00056         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GPED, OnCbnSelchangeOptComboGped)
00057         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GPIN, OnCbnSelchangeOptComboGpin)
00058         ON_CBN_SELCHANGE(IDC_OPT_COMBO_TPMO, OnCbnSelchangeOptComboTpmo)
00059         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GPME, OnCbnSelchangeOptComboGpme)
00060         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GPGA, OnCbnSelchangeOptComboGpga)
00061         ON_CBN_SELCHANGE(IDC_OPT_COMBO_GPMC, OnCbnSelchangeOptComboGpmc)
00062         ON_EN_CHANGE(IDC_OPT_TEXT_DACO, OnEnChangeOptTextDaco)
00063         ON_EN_CHANGE(IDC_OPT_TEXT_AUO1, OnEnChangeOptTextAuo1)
00064         ON_EN_CHANGE(IDC_OPT_TEXT_GPIN, OnEnChangeOptTextGpin)
00065         ON_MESSAGE(WM_SETPAGEFOCUS, OnSetPageFocus)
00066         ON_EN_CHANGE(IDC_OPT_TEXT_AUO2, OnEnChangeOptTextAuo2)
00067         ON_CBN_SELCHANGE(IDC_OPT_COMBO_SCOG, OnCbnSelchangeOptComboScog)
00068         ON_CBN_SELCHANGE(IDC_OPT_COMBO_VOLU, OnCbnSelchangeOptComboVolu)
00069         ON_CBN_SELCHANGE(IDC_OPT_COMBO_CON1, OnCbnSelchangeOptComboCon1)
00070         ON_CBN_SELCHANGE(IDC_OPT_COMBO_CON2, OnCbnSelchangeOptComboCon2)
00071         ON_BN_CLICKED(IDC_BUTTON_OUTPUT_QUICKSET1, OnBnClickedButtonOutputQuickset1)
00072         ON_BN_CLICKED(IDC_BUTTON_OUTPUT_QUICKSET2, OnBnClickedButtonOutputQuickset2)
00073         ON_BN_CLICKED(IDC_BUTTON_OUTPUT_QUICKSET3, OnBnClickedButtonOutputQuickset3)
00074
00075         // SCA Editor
00076         ON_BN_CLICKED(IDC_CHECK_ENABLE_SCA, OnBnClickedCheckEnableSca)
00077         ON_CBN_SELCHANGE(IDC_COMBO_SCA_INDEX, OnCbnSelchangeComboScaIndex)
00078         ON_EN_CHANGE(IDC_EDIT_LOW_THRESHOLD, OnEnChangeEditLowThreshold)
00079         ON_EN_CHANGE(IDC_EDIT_HIGH_THRESHOLD, OnEnChangeEditHighThreshold)
00080         ON_CBN_SELCHANGE(IDC_COMBO_OUTPUT_LEVEL, OnCbnSelchangeComboOutputLevel)
00081         ON_BN_CLICKED(IDC_BUTTON_SCA_DEFAULTS, OnBnClickedButtonScaDefaults)
00082         ON_CBN_SELCHANGE(IDC_COMBO_SCA_PULSE_WIDTH, OnCbnSelchangeComboScaPulseWidth)
00083         ON_BN_CLICKED(IDC_BUTTON_PREVIEW_SCA, OnBnClickedButtonPreviewSca)
00084
00085         ON_COMMAND(ID_HELP, OnHelp)
00086         ON_WM_HELPINFO()
00087
00088 END_MESSAGE_MAP()
00089
00091 // CMiscPage message handlers
00092
00093 BOOL CMiscPage::OnSetActive()
00094 {
00095         // TODO: Add your specialized code here and/or call the base class
00096         if (s.ReloadCfg) {
00097                 InitControls();
00098         }
00099         if (s.FindCommand) {
00100                 PostMessage(WM_SETPAGEFOCUS, 0, 0L);
00101                 s.FindCommand = FALSE;
00102         }
00103         return CCfgPropPage::OnSetActive();
00104 }
00105
00106 LONG CMiscPage::OnSetPageFocus(UINT wParam, LONG lParam)
00107 {
00108         GetDlgItem(s.FindCtrlID)->SetFocus();
00109         return 0;
00110 }
00111
00112 BOOL CMiscPage::OnInitDialog()
00113 {
00114         CCfgPropPage::OnInitDialog();
00115
00116         BuildToolTips();
00117
00118         m_MiscPageLabel
00119                 .SetFontName("Arial")
00120                 .SetFontSize(24)
00121                 .SetTextColor(RGB(0,0,255))
00122                 .SetBkColor(RGB(244, 243, 238))
00123                 .SetFontItalic(TRUE)
00124                 .SetFontBold(TRUE);
00125
00126         m_MiscAdvancedLabel
00127                 .SetFontName("Arial")
00128                 .SetFontSize(18)
00129                 .SetTextColor(RGB(0, 70, 213))
00130                 .SetBkColor(RGB(250, 251, 251))
00131                 .SetFontItalic(TRUE)
00132                 .SetFontBold(FALSE);
00133
00134         m_MiscQuicksetLabel
00135                 .SetFontName("Arial")
00136                 .SetFontSize(18)
00137                 .SetTextColor(RGB(0, 70, 213))
00138                 .SetBkColor(RGB(252, 252, 253))
00139                 .SetFontItalic(TRUE)
00140                 .SetFontBold(FALSE);
00141
00142         InitControls();
00143
00144         // TODO:  Add extra initialization here
00145
00146         return TRUE;  // return TRUE unless you set the focus to a control
00147         // EXCEPTION: OCX Property Pages should return FALSE
00148 }
00149
00150 //dciDACF       DACF    0                                       IDC_OPT_TEXT_DACF       dctTxt          dcgMisc DAC Offset      mV
00151 //dciDACO       DACO    IDC_OPT_COMBO_DACO      IDC_OPT_TEXT_DACO       dctCboTxt       dcgMisc DAC Output
00152 //dciSCOE       SCOE    IDC_OPT_COMBO_SCOE      0                                       dctCbo          dcgMisc Scope Trigger Edge
00153 //dciAUO1       AUO1    IDC_OPT_COMBO_AUO1      IDC_OPT_TEXT_AUO1       dctCboTxt       dcgMisc AUX_OUT Selection
00154 //dciSCOT       SCOT    IDC_OPT_COMBO_SCOT      0                                       dctCbo          dcgMisc Scope Trigger Position
00155 //dciGPED       GPED    IDC_OPT_COMBO_GPED      0                                       dctCbo          dcgMisc G.P. Counter Edge
00156 //dciGPIN       GPIN    IDC_OPT_COMBO_GPIN      IDC_OPT_TEXT_GPIN       dctCboTxt       dcgMisc G.P. Counter Input
00157 //dciTPMO       TPMO    IDC_OPT_COMBO_TPMO      0                                       dctCbo          dcgMisc Test Pulser On/Off
00158 //dciGPME       GPME    IDC_OPT_COMBO_GPME      0                                       dctCbo          dcgMisc G.P. Counter Uses MCA_EN?
00159 //dciGPGA       GPGA    IDC_OPT_COMBO_GPGA      0                                       dctCbo          dcgMisc G.P. Counter Uses GATE?
00160 //dciGPMC       GPMC    IDC_OPT_COMBO_GPMC      0                                       dctCbo          dcgMisc G.P. counter Cleared With MCA Counters?
00161 //dciAUO2       AUO2    IDC_OPT_COMBO_AUO2      IDC_OPT_TEXT_AUO2       dctCboTxt       dcgMisc AUX_2 Selection
00162 //dciVOLU,      VOLU    IDC_OPT_COMBO_VOLU      0                                       dctCbo          dcgMisc Speaker On/Off
00163
00164
00165 void CMiscPage::SetAuxList(int nAuxID, BOOL bNeedsNewAux)
00166 {
00167         CComboBox &cbAUOX = *(CComboBox *) GetDlgItem(nAuxID);
00168         // Test if the controls are already set
00169         // OLD Parameters
00170         //AUX1 #;ICR;PILEUP;MCSTB;ONESH;DETRES;MCAEN;PEAKH;SCA8;
00171         //AUX2 #;ICR;DIAG;PEAKH;ONESH;RTDOS;RTDREJ;LIVE;VETO;
00172
00173         // NEW Parameters
00174         //AUX1 ICR;PILEUP;MCSTB;ONESH;DETRES;MCAEN;PEAKH;SCA8;RTDOS;RTDREJ;VETO;LIVE;
00175         //AUX2 ICR;PILEUP;MCSTB;ONESH;DETRES;MCAEN;PEAKH;SCA8;RTDOS;RTDREJ;VETO;LIVE;STREAM;
00176         if (bNeedsNewAux) {             // AUX1 and AUX2 new controls
00177                 cbAUOX.ResetContent();
00178                 cbAUOX.AddString("ICR");
00179                 cbAUOX.AddString("PILEUP");
00180                 cbAUOX.AddString("MCSTB");
00181                 cbAUOX.AddString("ONESH");
00182                 cbAUOX.AddString("DETRES");
00183                 cbAUOX.AddString("MCAEN");
00184                 cbAUOX.AddString("PEAKH");
00185                 cbAUOX.AddString("SCA8");
00186                 cbAUOX.AddString("RTDOS");
00187                 cbAUOX.AddString("RTDREJ");
00188                 cbAUOX.AddString("VETO");
00189                 cbAUOX.AddString("LIVE");
00190                 if (nAuxID == IDC_OPT_COMBO_AUO2) {
00191                         cbAUOX.AddString("STREAM");
00192                 }
00193                 cbAUOX.Clear();
00194         } else {
00195                 if (nAuxID == IDC_OPT_COMBO_AUO2) {     //AUX2 old controls
00196                         cbAUOX.ResetContent();
00197                         cbAUOX.AddString("#");
00198                         cbAUOX.AddString("ICR");
00199                         cbAUOX.AddString("DIAG");
00200                         cbAUOX.AddString("PEAKH");
00201                         cbAUOX.AddString("ONESH");
00202                         cbAUOX.AddString("RTDOS");
00203                         cbAUOX.AddString("RTDREJ");
00204                         cbAUOX.AddString("LIVE");
00205                         cbAUOX.AddString("VETO");
00206                         if (((s.DppConfig.Firmware == 0x66) && (s.DppConfig.Build >= 6)) || (s.DppConfig.Firmware > 0x66))
00207                         {
00208                                 cbAUOX.AddString("STREAM");     // STREAM for 6.06.06 and later
00209                         }
00210                         cbAUOX.Clear();
00211                 } else {                                                //AUX1 old controls
00212                         cbAUOX.ResetContent();
00213                         cbAUOX.AddString("#");
00214                         cbAUOX.AddString("ICR");
00215                         cbAUOX.AddString("PILEUP");
00216                         cbAUOX.AddString("MCSTB");
00217                         cbAUOX.AddString("ONESH");
00218                         cbAUOX.AddString("DETRES");
00219                         cbAUOX.AddString("MCAEN");
00220                         cbAUOX.AddString("PEAKH");
00221                         cbAUOX.AddString("SCA8");
00222                         cbAUOX.Clear();
00223                 }
00224         }
00225 }
00226
00227 void CMiscPage::InitAuxControls()
00228 {
00229         BOOL bNeedsNewAux=FALSE;
00230         BOOL bHasNewAux=FALSE;
00231         BOOL bNeedsUpdate=FALSE;
00232         CString strRTDOS("RTDOS");
00233         int nIndex=0;
00234         CComboBox &cbAUO1 = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_AUO1);
00235         //CComboBox &cbAUO2 = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_AUO2);
00236         if (((s.DppConfig.Firmware == 0x68) && (s.DppConfig.Build >= 2)) || (s.DppConfig.Firmware > 0x68))
00237         {
00238                 bNeedsNewAux=TRUE;      // Needs new AUX controls
00239         }
00240
00241         // Test if the controls are already set
00242         // OLD Parameters
00243         //AUX1 #;ICR;PILEUP;MCSTB;ONESH;DETRES;MCAEN;PEAKH;SCA8;
00244         //AUX2 #;ICR;DIAG;PEAKH;ONESH;RTDOS;RTDREJ;LIVE;VETO;
00245
00246         // NEW Parameters
00247         //AUX1 ICR;PILEUP;MCSTB;ONESH;DETRES;MCAEN;PEAKH;SCA8;RTDOS;RTDREJ;VETO;LIVE;
00248         //AUX2 ICR;PILEUP;MCSTB;ONESH;DETRES;MCAEN;PEAKH;SCA8;RTDOS;RTDREJ;VETO;LIVE;STREAM;
00249
00250         nIndex = cbAUO1.FindStringExact(nIndex, strRTDOS);
00251         if (nIndex != CB_ERR) { bHasNewAux=TRUE; }
00252         if (bNeedsNewAux != bHasNewAux) {
00253                 bNeedsUpdate=TRUE;
00254         }
00255
00256         if (bNeedsUpdate) {
00257                 SetAuxList(IDC_OPT_COMBO_AUO1, bNeedsNewAux);
00258                 SetAuxList(IDC_OPT_COMBO_AUO2, bNeedsNewAux);
00259         }
00260 }
00261
00262 void CMiscPage::InitControls()
00263 {
00264         HWND hPage = this->GetSafeHwnd();
00265         BOOL bEnableVOLU;
00266         BOOL bEnableCON1;
00267         BOOL bEnableCON2;
00268
00269         InitAuxControls();
00270
00271         bEnableVOLU = (s.profile->device_type == dppPX5);
00272         GetDlgItem(IDC_OPT_COMBO_VOLU)->EnableWindow(bEnableVOLU);
00273         GetDlgItem(IDC_OPT_FRAME_VOLU)->EnableWindow(bEnableVOLU);
00274
00275         bEnableCON1 = ((s.profile->device_type != dppDP5) && (s.profile->device_type != dppDP5X));
00276         GetDlgItem(IDC_OPT_COMBO_CON1)->EnableWindow(bEnableCON1);
00277         GetDlgItem(IDC_OPT_FRAME_CON1)->EnableWindow(bEnableCON1);
00278
00279         bEnableCON2 = ((s.profile->device_type != dppDP5) && (s.profile->device_type != dppDP5X));
00280         GetDlgItem(IDC_OPT_COMBO_CON2)->EnableWindow(bEnableCON2);
00281         GetDlgItem(IDC_OPT_FRAME_CON2)->EnableWindow(bEnableCON2);
00282
00283         InitDlgItem(hPage,s.m_DP5Cfg[dciDACF]);
00284         InitDlgItem(hPage,s.m_DP5Cfg[dciDACO]);
00285         InitDlgItem(hPage,s.m_DP5Cfg[dciSCOE]);
00286         InitDlgItem(hPage,s.m_DP5Cfg[dciAUO1]);
00287         InitDlgItem(hPage,s.m_DP5Cfg[dciAUO2]);
00288         InitDlgItem(hPage,s.m_DP5Cfg[dciSCOT]);
00289         InitDlgItem(hPage,s.m_DP5Cfg[dciGPED]);
00290         InitDlgItem(hPage,s.m_DP5Cfg[dciGPIN]);
00291         InitDlgItem(hPage,s.m_DP5Cfg[dciTPMO]);
00292         InitDlgItem(hPage,s.m_DP5Cfg[dciGPME]);
00293         InitDlgItem(hPage,s.m_DP5Cfg[dciGPGA]);
00294         InitDlgItem(hPage,s.m_DP5Cfg[dciGPMC]);
00295         InitDlgItem(hPage,s.m_DP5Cfg[dciSCOG]);
00296         InitDlgItem(hPage,s.m_DP5Cfg[dciVOLU]);
00297         InitDlgItem(hPage,s.m_DP5Cfg[dciCON1]);
00298         InitDlgItem(hPage,s.m_DP5Cfg[dciCON2]);
00299
00300         CboUpdate(dciDACO);
00301         CboUpdate(dciSCOE);
00302         CboUpdate(dciAUO1);
00303         CboUpdate(dciAUO2);
00304         CboUpdate(dciSCOT);
00305         CboUpdate(dciGPED);
00306         CboUpdate(dciGPIN);
00307         CboUpdate(dciTPMO);
00308         CboUpdate(dciGPME);
00309         CboUpdate(dciGPGA);
00310         CboUpdate(dciGPMC);
00311         CboUpdate(dciSCOG);
00312         CboUpdate(dciVOLU);
00313         CboUpdate(dciCON1);
00314         CboUpdate(dciCON2);
00315
00316         if (!s.SCAEnabled) {
00317                 s.scafn.InitSCA(&s.sca, 8192);
00318         }
00319         SetCheckBOOL(IDC_CHECK_ENABLE_SCA, s.SCAEnabled);
00320         EnableScaControls(s.SCAEnabled);
00321         s.sca.CurIndex.Format("%d",1);  // set to sca 1 on init 20110908
00322         UpdateSCAControls();
00323
00324         //if (s.profile->device_type == dppMCA8000D) {
00325         //      ShowMCA8000D_Controls(SW_HIDE);
00326         //} else {
00327         //      ShowMCA8000D_Controls(SW_SHOW);
00328         //}
00329 }
00330
00331 void CMiscPage::ShowMCA8000D_Controls(int iShowWin)
00332 {
00333         GetDlgItem(IDC_OPT_COMBO_DACO)->ShowWindow(iShowWin);
00334         GetDlgItem(IDC_OPT_COMBO_TPMO)->ShowWindow(iShowWin);
00335         GetDlgItem(IDC_OPT_FRAME_DACF)->ShowWindow(iShowWin);
00336         GetDlgItem(IDC_OPT_FRAME_DACO)->ShowWindow(iShowWin);
00337         GetDlgItem(IDC_OPT_FRAME_TPMO)->ShowWindow(iShowWin);
00338         GetDlgItem(IDC_OPT_LIMITS_DACF)->ShowWindow(iShowWin);
00339         GetDlgItem(IDC_OPT_LIMITS_DACO)->ShowWindow(iShowWin);
00340         GetDlgItem(IDC_OPT_TEXT_DACF)->ShowWindow(iShowWin);
00341         GetDlgItem(IDC_OPT_TEXT_DACO)->ShowWindow(iShowWin);
00342         GetDlgItem(IDC_OPT_UNITS_DACF)->ShowWindow(iShowWin);
00343         GetDlgItem(IDC_OPT_UNITS_DACO)->ShowWindow(iShowWin);
00344         GetDlgItem(IDC_STATIC_DAC_FRAME)->ShowWindow(iShowWin);
00345
00346         GetDlgItem(IDC_BUTTON_OUTPUT_QUICKSET1)->ShowWindow(iShowWin);
00347         GetDlgItem(IDC_BUTTON_OUTPUT_QUICKSET2)->ShowWindow(iShowWin);
00348         GetDlgItem(IDC_BUTTON_OUTPUT_QUICKSET3)->ShowWindow(iShowWin);
00349
00350 }
00351
00352 void CMiscPage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00353 {
00354         int cboDP5CtrlID = cfg.ListCtrlID;
00355         int txtDP5CtrlID = cfg.TextCtrlID;
00356         CString strVal = cfg.Setting;
00357         int idxList;
00358         CString strUnits;
00359         CString strLimits;
00360
00361         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00362                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00363                 //idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00364                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00365                 if (idxList == LB_ERR) {
00366                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00367                 }
00368                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00369                         if ((cfg.CtrlType & dctTxt) > 0) {      // if cbotxt must find mask, else set to 0
00370                                 cfg.TextValue = cfg.Setting;            // overwrite if currently editing
00371                                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"#");
00372                                 if (idxList == LB_ERR) { // mask begins with +
00373                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"+");
00374                                 }
00375                                 if (idxList == LB_ERR) { // mask begins with -
00376                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"-");
00377                                 }
00378                                 if (idxList == LB_ERR) { // not found default to 0
00379                                         idxList = 0;
00380                                 }
00381                         } else {
00382                                 idxList = 0;            // set to first item
00383                         }
00384                 }
00385                 cb.SetCurSel(idxList);
00386         }
00387         if ((cfg.CtrlType & dctTxt) > 0) {
00388                 if ((cfg.CtrlType & dctCbo) == 0) {             // cbo update above
00389                         if (cfg.Setting.GetLength() > 0) {
00390                                 cfg.TextValue = cfg.Setting;
00391                         }
00392                 }
00393                 GetDlgItem(txtDP5CtrlID)->SetWindowText(cfg.TextValue);
00394                 strUnits = cfg.Units;
00395                 strLimits = cfg.Limits;
00396                 switch (txtDP5CtrlID) {
00397                         case IDC_OPT_TEXT_DACF:
00398                                 UNIT_INIT(DACF, strUnits);
00399                                 LIMIT_INIT(DACF, strLimits);
00400                                 break;
00401                         case IDC_OPT_TEXT_DACO:
00402                                 UNIT_INIT(DACO, strUnits);
00403                                 LIMIT_INIT(DACO, strLimits);
00404                                 break;
00405                         case IDC_OPT_TEXT_AUO1:
00406                                 UNIT_INIT(AUO1, strUnits);
00407                                 LIMIT_INIT(AUO1, strLimits);
00408                                 break;
00409                         case IDC_OPT_TEXT_AUO2:
00410                                 UNIT_INIT(AUO2, strUnits);
00411                                 LIMIT_INIT(AUO2, strLimits);
00412                                 break;
00413                         case IDC_OPT_TEXT_GPIN:
00414                                 UNIT_INIT(GPIN, strUnits);
00415                                 LIMIT_INIT(GPIN, strLimits);
00416                                 break;
00417                 }
00418         }
00419 }
00420
00421 // pass dci id to update combo control and display edit controls if any
00422 void CMiscPage::CboUpdate(int nID_dci)
00423 {
00424         CString strCboText;
00425         int nID;
00426         int CmdShow;
00427
00428         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00429         if (nID == NULL) { return; }
00430         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00431         int idx = cb.GetCurSel();
00432         if (idx > LB_ERR) {
00433                 cb.GetLBText(idx,strCboText);
00434                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00435                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00436         } else {
00437                 return;
00438         }
00439         if (s.m_DP5Cfg[nID_dci].CtrlType == dctCboTxt) {
00440                 if (strCboText.Find('#') >= 0) {
00441                         CmdShow = SW_SHOW;
00442                 } else {
00443                         CmdShow = SW_HIDE;
00444                 }
00445                 switch (nID) {
00446                         case IDC_OPT_COMBO_DACO:
00447                                 ALL_VIS(DACO, CmdShow);
00448                                 CBO_TEXT_VIS(DACO, (CmdShow!=0));
00449                                 break;
00450                         case IDC_OPT_COMBO_AUO1:
00451                                 ALL_VIS(AUO1, CmdShow);
00452                                 CBO_TEXT_VIS(AUO1, (CmdShow!=0));
00453                                 break;
00454                         case IDC_OPT_COMBO_AUO2:
00455                                 ALL_VIS(AUO2, CmdShow);
00456                                 CBO_TEXT_VIS(AUO2, (CmdShow!=0));
00457                                 break;
00458                         case IDC_OPT_COMBO_GPIN:
00459                                 ALL_VIS(GPIN, CmdShow);
00460                                 CBO_TEXT_VIS(GPIN, (CmdShow!=0));
00461                                 break;
00462                 }
00463         }
00464         SetModified(TRUE);
00465 }
00466
00467 //CBO_TEXT_VIS(RESL, (CmdShow!=0));
00468 //CboTextVis(IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,(CmdShow!=0));
00469 //void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00470 void CMiscPage::CboTextVis(int nIdCbox, int nIdEdit, BOOL isText)
00471 {
00472         UINT ddSize;
00473         RECT lpRect;
00474         CEdit* pEdit;
00475         CComboBox* pCombo;
00476         int btnSize = 20;
00477
00478         pEdit = (CEdit*)GetDlgItem(nIdEdit);            // cast to edit for rect
00479         pEdit->GetRect(&lpRect);                                        // get rect
00480         ddSize = lpRect.right - lpRect.left;            // save width
00481         if (isText) {
00482                 GetDlgItem(nIdEdit)->ShowWindow(SW_SHOW);
00483                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);
00484                 pCombo->GetWindowRect(&lpRect);
00485                 ScreenToClient(&lpRect);
00486                 //int ddSize1 = lpRect.right - lpRect.left;             // save width
00487                 //TRACE("Combo Edit %d\r\n",ddSize1);
00488                 lpRect.right = lpRect.left + btnSize;
00489                 pCombo->MoveWindow(&lpRect,TRUE);
00490                 pCombo->SetDroppedWidth(ddSize + btnSize);
00491         } else {
00492                 GetDlgItem(nIdEdit)->ShowWindow(SW_HIDE);       // hide edit
00493                 //TRACE("Edit %d\r\n",ddSize);
00494                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);       // cast to combo
00495                 pCombo->GetWindowRect(&lpRect);                         // get win size
00496                 ScreenToClient(&lpRect);                                        // adjust to screen
00497                 //int ddSize2 = lpRect.right - lpRect.left;             // save width
00498                 //TRACE("Combo %d\r\n",ddSize2);
00499                 lpRect.right = lpRect.left + ddSize + btnSize;  // get restored combo size
00500                 pCombo->MoveWindow(&lpRect,TRUE);                       // restore combo
00501                 pCombo->SetDroppedWidth(ddSize);                        // restore combo
00502         }
00503 }
00504
00505 // pass dci id to update combo control and display edit controls if any
00506 void CMiscPage::TextUpdate(int nID_dci)
00507 {
00508         CString strText;
00509         int nID;
00510
00511         nID = s.m_DP5Cfg[nID_dci].TextCtrlID;
00512         if (nID == NULL) { return; }
00513
00514         GetDlgItem(nID)->GetWindowText(strText);
00515         s.m_DP5Cfg[nID_dci].TextValue = strText;
00516         SetModified(TRUE);
00517 }
00518
00519 void CMiscPage::OnCbnSelchangeOptComboDaco()
00520 {
00521         CboUpdate(dciDACO);
00522 }
00523
00524 void CMiscPage::OnCbnSelchangeOptComboScoe()
00525 {
00526         CboUpdate(dciSCOE);
00527 }
00528
00529 void CMiscPage::OnCbnSelchangeOptComboAuo1()
00530 {
00531         CboUpdate(dciAUO1);
00532 }
00533
00534
00535 void CMiscPage::OnCbnSelchangeOptComboAuo2()
00536 {
00537         CboUpdate(dciAUO2);
00538 }
00539
00540 void CMiscPage::OnCbnSelchangeOptComboScot()
00541 {
00542         CboUpdate(dciSCOT);
00543 }
00544
00545 void CMiscPage::OnCbnSelchangeOptComboGped()
00546 {
00547         CboUpdate(dciGPED);
00548 }
00549
00550 void CMiscPage::OnCbnSelchangeOptComboGpin()
00551 {
00552         CboUpdate(dciGPIN);
00553 }
00554
00555 void CMiscPage::OnCbnSelchangeOptComboTpmo()
00556 {
00557         CboUpdate(dciTPMO);
00558 }
00559
00560 void CMiscPage::OnCbnSelchangeOptComboGpme()
00561 {
00562         CboUpdate(dciGPME);
00563 }
00564
00565 void CMiscPage::OnCbnSelchangeOptComboGpga()
00566 {
00567         CboUpdate(dciGPGA);
00568 }
00569
00570 void CMiscPage::OnCbnSelchangeOptComboGpmc()
00571 {
00572         CboUpdate(dciGPMC);
00573 }
00574
00575 void CMiscPage::OnCbnSelchangeOptComboScog()
00576 {
00577         CboUpdate(dciSCOG);
00578 }
00579
00580 void CMiscPage::OnCbnSelchangeOptComboVolu()
00581 {
00582         CboUpdate(dciVOLU);
00583 }
00584
00585 void CMiscPage::OnCbnSelchangeOptComboCon1()
00586 {
00587         CboUpdate(dciCON1);
00588 }
00589
00590 void CMiscPage::OnCbnSelchangeOptComboCon2()
00591 {
00592         CboUpdate(dciCON2);
00593 }
00594
00595 void CMiscPage::OnEnChangeOptTextDacf()
00596 {
00597         TextUpdate(dciDACF);
00598 }
00599
00600 void CMiscPage::OnEnChangeOptTextDaco()
00601 {
00602         TextUpdate(dciDACO);
00603 }
00604
00605 void CMiscPage::OnEnChangeOptTextAuo1()
00606 {
00607         TextUpdate(dciAUO1);
00608 }
00609
00610 void CMiscPage::OnEnChangeOptTextAuo2()
00611 {
00612         TextUpdate(dciAUO2);
00613 }
00614
00615 void CMiscPage::OnEnChangeOptTextGpin()
00616 {
00617         TextUpdate(dciGPIN);
00618 }
00619
00620 BOOL CMiscPage::PreTranslateMessage(MSG* pMsg)
00621 {
00622         // TODO: Add your specialized code here and/or call the base class
00623
00624         //==================================================================
00625         MSG msg = *pMsg;
00626         if (msg.message == WM_MOUSEMOVE) {      // Relay events to the tooltip control
00627                 msg.hwnd = (HWND)m_ToolTip.SendMessage(TTM_WINDOWFROMPOINT, 0, (LPARAM)&msg.pt);
00628                 CPoint pt = pMsg->pt;
00629                 ::ScreenToClient(msg.hwnd, &pt);
00630                 msg.lParam = MAKELONG(pt.x, pt.y);
00631                 m_ToolTip.Activate(TRUE);   // make sure tooltip is active
00632                 m_ToolTip.RelayEvent(&msg); // Let the ToolTip process this message.
00633         } else if ( pMsg->message == WM_KEYDOWN && pMsg->wParam == VK_RETURN ) {
00634                 CWnd* pCurrent= GetFocus();
00635                 int ctrl = pCurrent->GetDlgCtrlID();
00636                 //if (ctrl == IDC_OPT_TEXT_MCST) {
00637                 if (isCEditBox(ctrl)) {
00638                         ::SendMessage(this->m_hWnd, WM_COMMAND, MAKEWPARAM(ctrl, EN_CHANGE), (LPARAM) m_hWnd);
00639                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00640                         pMsg->wParam = VK_TAB;
00641                         //if ( pNext != NULL ) {
00642                         //      if (pNext->GetDlgCtrlID() != IDOK ) {
00643                         //              pNext->SetFocus();
00644                         //              return TRUE;
00645                         //      }
00646                         //}
00647                 } else if (isCComboBox(ctrl)) {
00648                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00649                         pMsg->wParam = VK_TAB;
00650                 }
00651         }
00652
00653         //==================================================================
00654         return CCfgPropPage::PreTranslateMessage(pMsg);
00655 }
00656
00657 //AUO2
00658 BOOL CMiscPage::isCEditBox(int nID)
00659 {
00660         BOOL isEdit = FALSE;
00661         switch (nID) {
00662                 case IDC_OPT_TEXT_DACF:
00663                         isEdit = TRUE;
00664                         break;
00665                 case IDC_OPT_TEXT_DACO:
00666                         isEdit = TRUE;
00667                         break;
00668                 case IDC_OPT_TEXT_AUO1:
00669                         isEdit = TRUE;
00670                         break;
00671                 case IDC_OPT_TEXT_AUO2:
00672                         isEdit = TRUE;
00673                         break;
00674                 case IDC_OPT_TEXT_GPIN:
00675                         isEdit = TRUE;
00676                         break;
00677         }
00678         return isEdit;
00679 }
00680
00681 BOOL CMiscPage::isCComboBox(int nID)
00682 {
00683         BOOL isCombo = FALSE;
00684         switch (nID) {
00685                 case IDC_OPT_COMBO_DACO:
00686                         isCombo = TRUE;
00687                         break;
00688                 case IDC_OPT_COMBO_SCOE:
00689                         isCombo = TRUE;
00690                         break;
00691                 case IDC_OPT_COMBO_AUO1:
00692                         isCombo = TRUE;
00693                         break;
00694                 case IDC_OPT_COMBO_AUO2:
00695                         isCombo = TRUE;
00696                         break;
00697                 case IDC_OPT_COMBO_SCOT:
00698                         isCombo = TRUE;
00699                         break;
00700                 case IDC_OPT_COMBO_GPED:
00701                         isCombo = TRUE;
00702                         break;
00703                 case IDC_OPT_COMBO_GPIN:
00704                         isCombo = TRUE;
00705                         break;
00706                 case IDC_OPT_COMBO_TPMO:
00707                         isCombo = TRUE;
00708                         break;
00709                 case IDC_OPT_COMBO_GPME:
00710                         isCombo = TRUE;
00711                         break;
00712                 case IDC_OPT_COMBO_GPGA:
00713                         isCombo = TRUE;
00714                         break;
00715                 case IDC_OPT_COMBO_GPMC:
00716                         isCombo = TRUE;
00717                         break;
00718                 case IDC_OPT_COMBO_SCOG:
00719                         isCombo = TRUE;
00720                         break;
00721                 case IDC_OPT_COMBO_VOLU:
00722                         isCombo = TRUE;
00723                         break;
00724                 case IDC_OPT_COMBO_CON1:
00725                         isCombo = TRUE;
00726                         break;
00727                 case IDC_OPT_COMBO_CON2:
00728                         isCombo = TRUE;
00729                         break;
00730         }
00731         return isCombo;
00732 }
00733
00734 void CMiscPage::SetCboItem(int nID, CString strVal)
00735 {
00736         HWND hPage = this->GetSafeHwnd();
00737         int cboDP5CtrlID = nID;
00738         int idxList;
00739
00740         CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00741         idxList = s.CtrlUtil.FindCboIdxExact(hPage,cboDP5CtrlID,strVal);        // try exact first
00742         if (idxList == LB_ERR) {
00743                 idxList = s.CtrlUtil.FindCboIdx(hPage,cboDP5CtrlID,strVal);
00744         }
00745         if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00746                 idxList = 0;            // set to first item
00747         }
00748         cb.SetCurSel(idxList);
00749 }
00750
00751 void CMiscPage::OutputQuickset(CString strDAC, CString strOutputOffset, CString strAUX2, CString strAUX1, CString strCONN1, CString strCONN2)
00752 {
00753         SetCboItem(IDC_OPT_COMBO_DACO, strDAC);
00754         OnCbnSelchangeOptComboDaco();
00755         GetDlgItem(IDC_OPT_TEXT_DACF)->SetWindowText(strOutputOffset);
00756         OnEnChangeOptTextDacf();
00757         SetCboItem(IDC_OPT_COMBO_AUO2, strAUX2);
00758         OnCbnSelchangeOptComboAuo2();
00759         SetCboItem(IDC_OPT_COMBO_AUO1, strAUX1);
00760         OnCbnSelchangeOptComboAuo1();
00761         SetCboItem(IDC_OPT_COMBO_CON1, strCONN1);
00762         OnCbnSelchangeOptComboCon1();
00763         SetCboItem(IDC_OPT_COMBO_CON2, strCONN2);
00764         OnCbnSelchangeOptComboCon2();
00765 }
00766
00767 void CMiscPage::OnBnClickedButtonOutputQuickset1()
00768 {
00769         //1. Shaped Output:  DAC=SHAPED, output offset=50 mV, AUX2 = ICR, AUX1 = SCA8, CONN1 = DAC, CONN2 = AUXOUT2
00770         OutputQuickset("SHAPED", "50 mV", "ICR", "SCA8", "DAC", "AUXOUT2");
00771 }
00772
00773 void CMiscPage::OnBnClickedButtonOutputQuickset2()
00774 {
00775         //2. ADC Input:  DAC=INPUT, output offset=0 mV, AUX2 = ICR, AUX1 = SCA8, CONN1 = DAC, CONN2 = AUXOUT2
00776         OutputQuickset("INPUT", "0 mV", "ICR", "SCA8", "DAC", "AUXOUT2");
00777 }
00778
00779 void CMiscPage::OnBnClickedButtonOutputQuickset3()
00780 {
00781         //3. Pile-Up:  DAC=FAST, output offset=50 mV, AUX2 = ICR, AUX1 = PILEUP, CONN1 = DAC, CONN2 = AUXOUT2
00782         OutputQuickset("FAST", "50mV", "ICR", "PILEUP", "DAC", "AUXOUT2");
00783 }
00784
00786 // HtmlHelp for shared dialog
00787 // NOTE: shared dialogs use string type IDD, not global IDD
00788 BOOL CMiscPage::OnHelpInfo(HELPINFO* pHelpInfo)
00789 {
00790         CString strHelp;
00791         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
00792                 if (pHelpInfo->dwContextId == 0) {
00793                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_MISC_PAGE);
00794                 } else {
00795                         //
00796                 }
00797         }
00798         return true;
00799 }
00800
00801 void CMiscPage::OnHelp()                                // enable property sheet help button help
00802 {
00803         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_MISC_PAGE);
00804     //SendMessage(WM_COMMANDHELP);      //
00805 }
00807
00808 void CMiscPage::BuildToolTips()
00809 {
00810         if (!m_ToolTip.Create(this)) {
00811                 TRACE0("Unable to create ToolTip control\n");
00812         } else {
00813         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_AUO1), IDS_TT_AUX_1);
00814         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_AUO1), IDS_TT_AUX_1);
00815         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_AUO1), IDS_TT_AUX_1);
00816         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_AUO1), IDS_TT_AUX_1);
00817         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_AUO1), IDS_TT_AUX_1);
00818         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_AUO2), IDS_TT_AUX_2);
00819         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_AUO2), IDS_TT_AUX_2);
00820         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_AUO2), IDS_TT_AUX_2);
00821         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_AUO2), IDS_TT_AUX_2);
00822         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_AUO2), IDS_TT_AUX_2);
00823         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_CON1), IDS_TT_CONNECTOR_1);
00824         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_CON1), IDS_TT_CONNECTOR_1);
00825         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_CON2), IDS_TT_CONNECTOR_2);
00826         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_CON2), IDS_TT_CONNECTOR_2);
00827         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_DACF), IDS_TT_OUTPUT_OFFSET);
00828         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_DACF), IDS_TT_OUTPUT_OFFSET);
00829         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_DACF), IDS_TT_OUTPUT_OFFSET);
00830         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_DACF), IDS_TT_OUTPUT_OFFSET);
00831         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_DACO), IDS_TT_ANALOG_OUT);
00832         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_DACO), IDS_TT_ANALOG_OUT);
00833         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_DACO), IDS_TT_ANALOG_OUT);
00834         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_DACO), IDS_TT_ANALOG_OUT);
00835         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_DACO), IDS_TT_ANALOG_OUT);
00836         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GPED), IDS_TT);
00837         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GPED), IDS_TT);
00838         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GPGA), IDS_TT);
00839         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GPGA), IDS_TT);
00840         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_GPIN), IDS_TT);
00841         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_GPIN), IDS_TT);
00842         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GPIN), IDS_TT);
00843         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_GPIN), IDS_TT);
00844         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GPIN), IDS_TT);
00845         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GPMC), IDS_TT);
00846         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GPMC), IDS_TT);
00847         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_GPME), IDS_TT);
00848         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_GPME), IDS_TT);
00849         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MISC_PAGE), IDS_TT);
00850         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_SCOE), IDS_TT_SCOPE_COMMANDS);
00851         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_SCOE), IDS_TT_SCOPE_COMMANDS);
00852         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_SCOG), IDS_TT_SCOPE_COMMANDS);
00853         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_SCOG), IDS_TT_SCOPE_COMMANDS);
00854         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_SCOG), IDS_TT_SCOPE_COMMANDS);
00855         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_SCOT), IDS_TT_SCOPE_COMMANDS);
00856         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_SCOT), IDS_TT_SCOPE_COMMANDS);
00857         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_TPMO), IDS_TT_TEST_PULSER);
00858         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TPMO), IDS_TT_TEST_PULSER);
00859         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_VOLU), IDS_TT_PX__SPEAKER);
00860         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_VOLU), IDS_TT_PX__SPEAKER);
00861         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MISC_ADVANCED), IDS_TT);
00862         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MISC_BASIC), IDS_TT);
00863         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MISC_QUICKSET), IDS_TT);
00864         //m_ToolTip.AddTool(GetDlgItem(IDC_BUTTON_OUTPUT_QUICKSET1), IDS_TT);
00865         //m_ToolTip.AddTool(GetDlgItem(IDC_BUTTON_OUTPUT_QUICKSET2), IDS_TT);
00866         //m_ToolTip.AddTool(GetDlgItem(IDC_BUTTON_OUTPUT_QUICKSET3), IDS_TT);
00867         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_MISC_STANDARD), IDS_TT);
00868
00869                 m_ToolTip.Activate(TRUE);
00870                 m_ToolTip.SetMaxTipWidth(200);
00871         }
00872 }
00873
00874 void CMiscPage::OnBnClickedCheckEnableSca()
00875 {
00876          s.SCAEnabled = GetCheckBOOL(IDC_CHECK_ENABLE_SCA);
00877          s.profile->SCAEnabled = s.SCAEnabled;                          // 20110810 sca support
00878          EnableScaControls(s.SCAEnabled);
00879 }
00880
00881 void CMiscPage::OnCbnSelchangeComboScaIndex()
00882 {
00883         int iIndex;
00884         iIndex = GetComboIndex(IDC_COMBO_SCA_INDEX);
00885         iIndex++;
00886         s.sca.CurIndex.Format("%d",iIndex);
00887         UpdateSCAControls();
00888 }
00889
00890 void CMiscPage::OnEnChangeEditLowThreshold()
00891 {
00892         int iIndex;
00893         iIndex = atoi(s.sca.CurIndex);
00894         if ((iIndex < 1) || (iIndex > MAX_SCA_REGISTER)) {
00895                 s.sca.CurIndex.Format("%d",1);
00896         }
00897         GetDlgItem(IDC_EDIT_LOW_THRESHOLD)->GetWindowText(s.sca.Low[iIndex - 1]);
00898 }
00899
00900 void CMiscPage::OnEnChangeEditHighThreshold()
00901 {
00902         int iIndex;
00903         iIndex = atoi(s.sca.CurIndex);
00904         if ((iIndex < 1) || (iIndex > MAX_SCA_REGISTER)) {
00905                 s.sca.CurIndex.Format("%d",1);
00906         }
00907         GetDlgItem(IDC_EDIT_HIGH_THRESHOLD)->GetWindowText(s.sca.High[iIndex - 1]);
00908 }
00909
00910 void CMiscPage::OnCbnSelchangeComboOutputLevel()
00911 {
00912         int iIndex;
00913         iIndex = atoi(s.sca.CurIndex);
00914         if ((iIndex < 1) || (iIndex > MAX_SCA_REGISTER)) {
00915                 s.sca.CurIndex.Format("%d",1);
00916         }
00917         s.sca.Output[iIndex - 1] = GetComboValue(IDC_COMBO_OUTPUT_LEVEL);
00918 }
00919
00920 void CMiscPage::OnBnClickedButtonScaDefaults()
00921 {
00922         s.scafn.InitSCA(&s.sca, 8192);
00923         s.SCAEnabled = FALSE;
00924         SetCheckBOOL(IDC_CHECK_ENABLE_SCA, s.SCAEnabled);
00925         UpdateSCAControls();
00926         EnableScaControls(s.SCAEnabled);
00927 }
00928
00929 void CMiscPage::OnCbnSelchangeComboScaPulseWidth()
00930 {
00931         s.sca.PulseWidth = GetComboValue(IDC_COMBO_SCA_PULSE_WIDTH);
00932 }
00933
00934 BOOL CMiscPage::GetCheckBOOL(int nID)
00935 {
00936         CButton *chkBox;
00937         BOOL isChecked;
00938         chkBox = (CButton *)GetDlgItem(nID);
00939         isChecked = (BOOL)chkBox->GetCheck();
00940         return isChecked;
00941 }
00942
00943 void CMiscPage::SetCheckBOOL(int nID, BOOL isChecked)
00944 {
00945         CButton *chkBox;
00946         chkBox = (CButton *)GetDlgItem(nID);
00947         chkBox->SetCheck(isChecked);
00948 }
00949
00950 void CMiscPage::EnableScaControls(BOOL Enable, BOOL isVisible)
00951 {
00952         //SCA Enable CheckBox (DO NOT DISABLE)
00953         //EnableControl(IDC_CHECK_ENABLE_SCA, Enable, isVisible);
00954
00955         //SCA Control Buttons
00956         EnableControl(IDC_BUTTON_SCA_DEFAULTS, Enable, isVisible);
00957         EnableControl(IDC_BUTTON_PREVIEW_SCA, Enable, isVisible);
00958
00959         //SCA ComboBox Controls
00960         EnableControl(IDC_COMBO_OUTPUT_LEVEL, Enable, isVisible);
00961         EnableControl(IDC_COMBO_SCA_INDEX, Enable, isVisible);
00962         EnableControl(IDC_COMBO_SCA_PULSE_WIDTH, Enable, isVisible);
00963
00964         //SCA Edit Controls
00965         EnableControl(IDC_EDIT_HIGH_THRESHOLD, Enable, isVisible);
00966         EnableControl(IDC_EDIT_LOW_THRESHOLD, Enable, isVisible);
00967
00968         //SCA Static Controls
00969         EnableControl(IDC_STATIC_SCA_GROUP, Enable, isVisible);
00970         EnableControl(IDC_STATIC_SCA_INDEX, Enable, isVisible);
00971         EnableControl(IDC_STATIC_LOW_THRESHOLD, Enable, isVisible);
00972         EnableControl(IDC_STATIC_HIGH_THRESHOLD, Enable, isVisible);
00973         EnableControl(IDC_STATIC_OUTPUT_LEVEL, Enable, isVisible);
00974         EnableControl(IDC_STATIC_SCA_PULSE_WIDTH, Enable, isVisible);
00975         EnableControl(IDC_STATIC_CURRENT_SCA, Enable, isVisible);
00976 }
00977
00978 void CMiscPage::EnableControl(int nID, BOOL Enable, BOOL isVisible)
00979 {
00980         GetDlgItem(nID)->EnableWindow(Enable);
00981         GetDlgItem(nID)->ShowWindow(isVisible);
00982 }
00983
00984 void CMiscPage::UpdateSCAControls()
00985 {
00986         int iIndex;
00987         iIndex = atoi(s.sca.CurIndex);
00988         if (iIndex < 1) {
00989                 s.sca.CurIndex.Format("%d",1);
00990         }
00991         GetDlgItem(IDC_STATIC_CURRENT_SCA)->SetWindowText("SCA " + s.sca.CurIndex);     // display sca number
00992
00993         //Set SCA ComboBox Controls
00994         SetSCAComboIndex(IDC_COMBO_OUTPUT_LEVEL, s.sca.Output[iIndex - 1]);
00995         SetSCAComboIndex(IDC_COMBO_SCA_INDEX, s.sca.CurIndex);
00996         SetSCAComboIndex(IDC_COMBO_SCA_PULSE_WIDTH, s.sca.PulseWidth);
00997
00999         GetDlgItem(IDC_EDIT_LOW_THRESHOLD)->SetWindowText(s.sca.Low[iIndex - 1]);
01000         GetDlgItem(IDC_EDIT_HIGH_THRESHOLD)->SetWindowText(s.sca.High[iIndex - 1]);
01001 }
01002
01003 void CMiscPage::SetSCAComboIndex(int nID, CString strValue)
01004 {
01005         CComboBox* pCombo;
01006         int CurSel;
01007         int Count;
01008
01009         pCombo = (CComboBox*)GetDlgItem(nID);
01010         CurSel = s.scafn.varValueToIndex(strValue);
01011         Count = pCombo->GetCount();
01012         if ((CurSel < 0) || (CurSel >= Count)) {
01013                 CurSel = 0;
01014         }
01015         pCombo->SetCurSel(CurSel);
01016 }
01017
01018 int CMiscPage::GetComboIndex(int nID)
01019 {
01020         CComboBox* pCombo;
01021         int CurSel;
01022
01023         pCombo = (CComboBox*)GetDlgItem(nID);
01024         CurSel = pCombo->GetCurSel();
01025         if (CurSel == LB_ERR){
01026                 CurSel = 0;
01027         }
01028         return CurSel;
01029 }
01030
01031 CString CMiscPage::GetComboValue(int nID)
01032 {
01033         CString strValue;
01034         CComboBox* pCombo = (CComboBox*)GetDlgItem(nID);
01035         pCombo->GetLBText(pCombo->GetCurSel(),strValue);
01036         return strValue;
01037 }
01038
01039 void CMiscPage::OnBnClickedButtonPreviewSca()
01040 {
01041         CString strSCA;
01042
01043         //strSCA = s.scafn.SCAStringALL(s.sca, TRUE);
01044         strSCA = s.scafn.SCAStringALLDisplay(s.sca);
01045         AfxMessageBox(strSCA);
01046 }
01047
01048
01049
01050
01051
01052
01053
01054
01055
01056
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/MiscPage.h Source File

DP5Cfg/MiscPage.h
Go to the documentation of this file.
00001 #if !defined(AFX_MiscPage_H__INCLUDED_)
00002 #define AFX_MiscPage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // MiscPage.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "afxwin.h"
00012 #include "label.h"
00013 #include "scommon.h"
00014
00016 // CMiscPage dialog
00017
00018 class CMiscPage : public CCfgPropPage
00019 {
00020         DECLARE_DYNCREATE(CMiscPage)
00021
00022 // Construction
00023 public:
00024         CMiscPage();
00025         ~CMiscPage();
00026
00027 // Dialog Data
00028         //{{AFX_DATA(CMiscPage)
00029         //enum { IDD = IDD_MISC_PAGE };
00030         //}}AFX_DATA
00031
00032 // Overrides
00033         // ClassWizard generate virtual function overrides
00034         //{{AFX_VIRTUAL(CMiscPage)
00035         protected:
00036         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00037         //}}AFX_VIRTUAL
00038
00039 // Implementation
00040 protected:
00041         // Generated message map functions
00042         //{{AFX_MSG(CMiscPage)
00043         //}}AFX_MSG
00044         DECLARE_MESSAGE_MAP()
00045         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00046
00047 public:
00048         void BuildToolTips();                                                           // Tooltip control
00049
00050         //CStatic m_MiscPageLabel;
00051         CLabel m_MiscPageLabel;
00052         //CStatic m_MiscAdvancedLabel;
00053         CLabel m_MiscAdvancedLabel;
00054         //CStatic m_MiscQuicksetLabel;
00055         CLabel m_MiscQuicksetLabel;
00056
00057         virtual BOOL OnSetActive();
00058         afx_msg LONG CMiscPage::OnSetPageFocus(UINT wParam, LONG lParam);
00059         virtual BOOL OnInitDialog();
00060         afx_msg void OnCbnSelchangeOptComboDaco();
00061
00062         void SetAuxList(int nAuxID, BOOL bNeedsNewAux);
00063         void InitAuxControls();
00064         void InitControls();
00065         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00066         void ShowMCA8000D_Controls(int iShowWin);
00067
00068         void CboUpdate(int nID_dci);
00069         void TextUpdate(int nID_dci);
00070
00071         afx_msg void OnCbnSelchangeOptComboScoe();
00072         afx_msg void OnCbnSelchangeOptComboAuo1();
00073         afx_msg void OnCbnSelchangeOptComboScot();
00074         afx_msg void OnCbnSelchangeOptComboGped();
00075         afx_msg void OnCbnSelchangeOptComboGpin();
00076         afx_msg void OnCbnSelchangeOptComboTpmo();
00077         afx_msg void OnCbnSelchangeOptComboGpme();
00078         afx_msg void OnCbnSelchangeOptComboGpga();
00079         afx_msg void OnCbnSelchangeOptComboGpmc();
00080
00081         afx_msg void OnEnChangeOptTextDacf();
00082         afx_msg void OnEnChangeOptTextDaco();
00083         afx_msg void OnEnChangeOptTextAuo1();
00084         afx_msg void OnEnChangeOptTextGpin();
00085
00086         void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00087
00088         virtual BOOL PreTranslateMessage(MSG* pMsg);
00089         BOOL isCEditBox(int nID);
00090         BOOL isCComboBox(int nID);
00091         afx_msg void OnEnChangeOptTextAuo2();
00092         afx_msg void OnCbnSelchangeOptComboScog();
00093         afx_msg void OnCbnSelchangeOptComboAuo2();
00094         afx_msg void OnCbnSelchangeOptComboVolu();
00095         afx_msg void OnCbnSelchangeOptComboCon1();
00096         afx_msg void OnCbnSelchangeOptComboCon2();
00097         afx_msg void OnBnClickedButtonOutputQuickset1();
00098         afx_msg void OnBnClickedButtonOutputQuickset2();
00099         afx_msg void OnBnClickedButtonOutputQuickset3();
00100         void SetCboItem(int nID, CString strVal);
00101         void OutputQuickset(CString strDAC, CString strOutputOffset, CString strAUX2, CString strAUX1, CString strCONN1, CString strCONN2);
00102
00103         // SCA Editor
00104         afx_msg void OnBnClickedCheckEnableSca();
00105         afx_msg void OnCbnSelchangeComboScaIndex();
00106         afx_msg void OnEnChangeEditLowThreshold();
00107         afx_msg void OnEnChangeEditHighThreshold();
00108         afx_msg void OnCbnSelchangeComboOutputLevel();
00109         afx_msg void OnBnClickedButtonScaDefaults();
00110         afx_msg void OnCbnSelchangeComboScaPulseWidth();
00111         afx_msg void OnBnClickedButtonPreviewSca();
00112
00113         // SCA Editor Support
00114         BOOL GetCheckBOOL(int nID);
00115         void SetCheckBOOL(int nID, BOOL isChecked);
00116         void EnableScaControls(BOOL Enable = TRUE, BOOL isVisible = TRUE);
00117         void EnableControl(int nID, BOOL Enable = TRUE, BOOL isVisible = TRUE);
00118         void UpdateSCAControls();
00119         void SetSCAComboIndex(int nID, CString strValue);
00120         int GetComboIndex(int nID);
00121         CString GetComboValue(int nID);
00122
00123         afx_msg void OnHelp();
00124         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00125
00126 };
00127
00128 //{{AFX_INSERT_LOCATION}}
00129 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00130
00131 #endif // !defined(AFX_MiscPage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/MiscPageRes.h Source File

DP5Cfg/MiscPageRes.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by MiscPage.rc
00004 //
00005 #define IDC_BUTTON_OUTPUT_QUICKSET1     1792
00006 #define IDC_BUTTON_OUTPUT_QUICKSET2     1793
00007 #define IDC_BUTTON_OUTPUT_QUICKSET3     1794
00008 #define IDC_OPT_COMBO_AUO1              1795
00009 #define IDC_OPT_COMBO_AUO2              1796
00010 #define IDC_OPT_COMBO_CON1              1797
00011 #define IDC_OPT_COMBO_CON2              1798
00012 #define IDC_OPT_COMBO_DACO              1799
00013 #define IDC_OPT_COMBO_GPED              1800
00014 #define IDC_OPT_COMBO_GPGA              1801
00015 #define IDC_OPT_COMBO_GPIN              1802
00016 #define IDC_OPT_COMBO_GPMC              1803
00017 #define IDC_OPT_COMBO_GPME              1804
00018 #define IDC_OPT_COMBO_SCOE              1805
00019 #define IDC_OPT_COMBO_SCOG              1806
00020 #define IDC_OPT_COMBO_SCOT              1807
00021 #define IDC_OPT_COMBO_TPMO              1808
00022 #define IDC_OPT_COMBO_VOLU              1809
00023 #define IDC_OPT_FRAME_AUO1              1810
00024 #define IDC_OPT_FRAME_AUO2              1811
00025 #define IDC_OPT_FRAME_CON1              1812
00026 #define IDC_OPT_FRAME_CON2              1813
00027 #define IDC_OPT_FRAME_DACF              1814
00028 #define IDC_OPT_FRAME_DACO              1815
00029 #define IDC_OPT_FRAME_GPED              1816
00030 #define IDC_OPT_FRAME_GPGA              1817
00031 #define IDC_OPT_FRAME_GPIN              1818
00032 #define IDC_OPT_FRAME_GPMC              1819
00033 #define IDC_OPT_FRAME_GPME              1820
00034 #define IDC_OPT_FRAME_SCOE              1821
00035 #define IDC_OPT_FRAME_SCOG              1822
00036 #define IDC_OPT_FRAME_SCOT              1823
00037 #define IDC_OPT_FRAME_TPMO              1824
00038 #define IDC_OPT_FRAME_VOLU              1825
00039 #define IDC_OPT_LIMITS_AUO1             1826
00040 #define IDC_OPT_LIMITS_AUO2             1827
00041 #define IDC_OPT_LIMITS_DACF             1828
00042 #define IDC_OPT_LIMITS_DACO             1829
00043 #define IDC_OPT_LIMITS_GPIN             1830
00044 #define IDC_OPT_TEXT_AUO1               1831
00045 #define IDC_OPT_TEXT_AUO2               1832
00046 #define IDC_OPT_TEXT_DACF               1833
00047 #define IDC_OPT_TEXT_DACO               1834
00048 #define IDC_OPT_TEXT_GPIN               1835
00049 #define IDC_OPT_UNITS_AUO1              1836
00050 #define IDC_OPT_UNITS_AUO2              1837
00051 #define IDC_OPT_UNITS_DACF              1838
00052 #define IDC_OPT_UNITS_DACO              1839
00053 #define IDC_OPT_UNITS_GPIN              1840
00054 #define IDC_OPT_UNITS_SCOG              1841
00055 #define IDC_STATIC_MISC_ADVANCED        1842
00056 #define IDC_STATIC_MISC_BASIC           1843
00057 #define IDC_STATIC_MISC_PAGE            1844
00058 #define IDC_STATIC_MISC_QUICKSET        1845
00059 #define IDC_STATIC_MISC_STANDARD        1846
00060 #define IDC_CHECK_ENABLE_SCA            1847
00061 #define IDC_COMBO_SCA_INDEX             1848
00062 #define IDC_COMBO_OUTPUT_LEVEL          1849
00063 #define IDC_EDIT_LOW_THRESHOLD          1850
00064 #define IDC_EDIT_HIGH_THRESHOLD         1851
00065 #define IDC_BUTTON_SCA_DEFAULTS         1852
00066 #define IDC_COMBO_SCA_PULSE_WIDTH       1853
00067 #define IDC_BUTTON_PREVIEW_SCA          1854
00068 #define IDC_STATIC_CURRENT_SCA          1855
00069 #define IDC_STATIC_SCA_GROUP            1856
00070 #define IDC_STATIC_SCA_INDEX            1857
00071 #define IDC_STATIC_LOW_THRESHOLD        1858
00072 #define IDC_STATIC_HIGH_THRESHOLD       1859
00073 #define IDC_STATIC_OUTPUT_LEVEL         1860
00074 #define IDC_STATIC_SCA_PULSE_WIDTH      1861
00075 #define IDC_STATIC_DAC_FRAME            1862
00076 #define IDS_TT_ANALOG_OUT               6144
00077 #define IDS_TT_OUTPUT_OFFSET            6145
00078 #define IDS_TT_AUX_1                    6146
00079 #define IDS_TT_AUX_2                    6147
00080 #define IDS_TT_TEST_PULSER              6148
00081 #define IDS_TT_PX__SPEAKER              6149
00082 #define IDS_TT_CONNECTOR_1              6150
00083 #define IDS_TT_CONNECTOR_2              6151
00084 #define IDS_TT_SCOPE_COMMANDS           6152
00085
00086 // Next default values for new objects
00087 //
00088 #ifdef APSTUDIO_INVOKED
00089 #ifndef APSTUDIO_READONLY_SYMBOLS
00090 #define _APS_NEXT_RESOURCE_VALUE        6153
00091 #define _APS_NEXT_COMMAND_VALUE         33392
00092 #define _APS_NEXT_CONTROL_VALUE         1863
00093 #define _APS_NEXT_SYMED_VALUE           6153
00094 #endif
00095 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: MsgBox.cpp Source File

MsgBox.cpp
Go to the documentation of this file.
00001 // MsgBox.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "resource.h"
00006 #include "MsgBox.h"
00007 #include ".\msgbox.h"
00008
00009
00010 // CMsgBox dialog
00011
00012 IMPLEMENT_DYNAMIC(CMsgBox, CDialog)
00013 CMsgBox::CMsgBox(CWnd* pParent /*=NULL*/)
00014         : CDialog(CMsgBox::IDD, pParent)
00015 {
00016 }
00017
00018 CMsgBox::~CMsgBox()
00019 {
00020 }
00021
00022 void CMsgBox::DoDataExchange(CDataExchange* pDX)
00023 {
00024         CDialog::DoDataExchange(pDX);
00025 }
00026
00027
00028 BEGIN_MESSAGE_MAP(CMsgBox, CDialog)
00029 END_MESSAGE_MAP()
00030
00031
00032 // CMsgBox message handlers
00033
00034 BOOL CMsgBox::OnInitDialog()
00035 {
00036         CDialog::OnInitDialog();
00037
00038         SetWindowText(m_strTitle);
00039         SetMessage(m_strMessage, m_strDelimiter);
00040
00041         // TODO:  Add extra initialization here
00042
00043         return TRUE;  // return TRUE unless you set the focus to a control
00044         // EXCEPTION: OCX Property Pages should return FALSE
00045 }
00046
00047 void CMsgBox::SetMessage(CString strMsg, CString strDelimiter)
00048 {
00049         int iHalf;
00050         int iDelimiter; // \r\n ms win
00051         if (strMsg.GetLength() == 0) { return; }
00052         if (strMsg.GetLength() < 100) {
00053                 GetDlgItem(IDC_MESSAGE1)->SetWindowText(strMsg);
00054                 GetDlgItem(IDC_MESSAGE2)->SetWindowText("");
00055         } else {
00056                 iHalf = (int)(strMsg.GetLength() / 2);
00057                 iDelimiter = strMsg.Find(strDelimiter,iHalf);
00058                 if (iDelimiter >= iHalf) {                      // try to find next \r\n
00059                         GetDlgItem(IDC_MESSAGE1)->SetWindowText(strMsg.Left(iDelimiter+1));
00060                         GetDlgItem(IDC_MESSAGE2)->SetWindowText(strMsg.Mid(iDelimiter+2));
00061                 }
00062         }
00063 }
00064
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: MsgBox.h Source File

MsgBox.h
Go to the documentation of this file.
00001 #pragma once
00002
00003
00004 // CMsgBox dialog
00005
00006 class CMsgBox : public CDialog
00007 {
00008         DECLARE_DYNAMIC(CMsgBox)
00009
00010 public:
00011         CMsgBox(CWnd* pParent = NULL);   // standard constructor
00012         virtual ~CMsgBox();
00013
00014 // Dialog Data
00015         enum { IDD = IDD_MESSAGE_BOX };
00016
00017 protected:
00018         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00019
00020         DECLARE_MESSAGE_MAP()
00021 public:
00022         virtual BOOL OnInitDialog();
00023         CString m_strTitle;
00024         CString m_strMessage;
00025         CString m_strDelimiter;
00026         void SetMessage(CString strMsg, CString m_strDelimiter);
00027
00028
00029 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/NetFinder.cpp Source File

DeviceIO/NetFinder.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "NetFinder.h"
00003 #include <time.h>
00004 #include <math.h>
00005
00006 CNetFinder::CNetFinder(void)
00007 {
00008         InitAllEntries();
00009         m_rand = 0;
00010         LastEntry = NO_ENTRIES;
00011 }
00012
00013 CNetFinder::~CNetFinder(void)
00014 {
00015
00016 }
00017
00018 COLORREF CNetFinder::AlertEntryToCOLORREF(NETDISPLAY_ENTRY *pEntry)
00019 {
00020         COLORREF DppConnectionColor;
00021         DppConnectionColor = AlertByteToCOLORREF(pEntry->alert_level);
00022         return (DppConnectionColor);
00023 }
00024
00025 COLORREF CNetFinder::AlertByteToCOLORREF(unsigned char alert_level)
00026 {
00027         COLORREF DppConnectionColor;
00028         switch(alert_level){                    // Alert Level
00029                 case 0x00:      //0 = Interface is open (unconnected);
00030                         DppConnectionColor = colorGreen;
00031                         break;
00032                 case 0x01:      //1 = Interface is connected (sharing is allowed);
00033                         DppConnectionColor = colorYellow;
00034                         break;
00035                 case 0x02:      //2 = Interface is connected (sharing is not allowed);
00036                         DppConnectionColor = colorRed;
00037                         break;
00038                 case 0x03:      //3 = Interface is locked
00039                         DppConnectionColor = colorRed;
00040                         break;
00041                 case 0x04:      //4 = Interface is unavailable because USB is connected
00042                         DppConnectionColor = colorSilver;
00043                         break;
00044                 default:        //Interface configuration unknown
00045                         DppConnectionColor = colorWhite;
00046                         break;
00047         }
00048         return (DppConnectionColor);
00049 }
00050
00051 CString CNetFinder::EntryToStr(NETDISPLAY_ENTRY *pEntry)
00052 {
00053         CString strAlertLevel;
00054         CString strDeviceType;
00055         CString strIpAddress;
00056         CString strEvent1, strEvent2;
00057         CString strAdditionalDesc;
00058         CString strMacAddress;
00059         CString strEntry;
00060         CString temp_str, temp_str2;
00061
00062         strAlertLevel = "Connection: ";
00063         switch(pEntry->alert_level){                    // Alert Level
00064                 case 0x00:      //0 = Interface is open (unconnected);
00065                         strAlertLevel += "Interface is open (unconnected)";
00066                         break;
00067                 case 0x01:      //1 = Interface is connected (sharing is allowed);
00068                         strAlertLevel += "Interface is connected (sharing is allowed)";
00069                         break;
00070                 case 0x02:      //2 = Interface is connected (sharing is not allowed);
00071                         strAlertLevel += "Interface is connected (sharing is not allowed)";
00072                         break;
00073                 case 0x03:      //3 = Interface is locked
00074                         strAlertLevel += "Interface is locked";
00075                         break;
00076                 case 0x04:      //4 = Interface is unavailable because USB is connected
00077                         strAlertLevel += "Interface is unavailable because USB is connected";
00078                         break;
00079                 default:
00080                         strAlertLevel += "Interface configuration unknown";
00081                         break;
00082         }
00083         strDeviceType = pEntry->str_type;               // Device Name/Type
00084         // IP Address String
00085         strIpAddress.Format("IP Address: %u.%u.%u.%u", (unsigned short) pEntry->ip[0], (unsigned short) pEntry->ip[1],(unsigned short) pEntry->ip[2],(unsigned short) pEntry->ip[3]);
00086         strAdditionalDesc = pEntry->str_description;    // Additional Description
00087         // MacAddress
00088         strMacAddress.Format("MAC Address: %02x-%02x-%02x-%02x-%02x-%02x", (unsigned short) pEntry->mac[0], (unsigned short) pEntry->mac[1],(unsigned short) pEntry->mac[2],(unsigned short) pEntry->mac[3],(unsigned short) pEntry->mac[4],(unsigned short) pEntry->mac[5]);
00089         // Event1 Time
00090         temp_str = pEntry->str_ev1 + " ";
00091         if(pEntry->event1_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event1_days,pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00092         else if(pEntry->event1_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00093         else if(pEntry->event1_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event1_minutes, pEntry->event1_seconds );
00094         else temp_str2.Format("%i seconds", pEntry->event1_seconds );
00095         strEvent1 = temp_str + temp_str2;
00096         // Event2 Time
00097         temp_str = pEntry->str_ev2 + " ";
00098         if(pEntry->event2_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event2_days,pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00099         else if(pEntry->event2_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00100         else if(pEntry->event2_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event2_minutes, pEntry->event2_seconds );
00101         else temp_str2.Format("%i seconds", pEntry->event2_seconds );
00102         strEvent2 = temp_str + temp_str2;
00103
00104         strEntry = strDeviceType + "\r\n";
00105         strEntry += strAlertLevel + "\r\n";
00106         strEntry += strIpAddress + "\r\n";
00107         strEntry += strAdditionalDesc + "\r\n";
00108         strEntry += strMacAddress + "\r\n";
00109         strEntry += strEvent1 + "\r\n";
00110         strEntry += strEvent2 + "\r\n";
00111         return strEntry;
00112 }
00113
00114 CString CNetFinder::EntryToStrRS232(NETDISPLAY_ENTRY *pEntry, CString strPort)
00115 {
00116         CString strAlertLevel;
00117         CString strDeviceType;
00118         CString strIpAddress;
00119         CString strEvent1, strEvent2;
00120         CString strAdditionalDesc;
00121         CString strMacAddress;
00122         CString strEntry;
00123         CString temp_str, temp_str2;
00124
00125         strAlertLevel = "Connection: ";
00126         strAlertLevel += strPort;
00127         //switch(pEntry->alert_level){                  // Alert Level
00128         //      case 0x00:      //0 = Interface is open (unconnected);
00129         //              strAlertLevel += "Interface is open (unconnected)";
00130         //              break;
00131         //      case 0x01:      //1 = Interface is connected (sharing is allowed);
00132         //              strAlertLevel += "Interface is connected (sharing is allowed)";
00133         //              break;
00134         //      case 0x02:      //2 = Interface is connected (sharing is not allowed);
00135         //              strAlertLevel += "Interface is connected (sharing is not allowed)";
00136         //              break;
00137         //      case 0x03:      //3 = Interface is locked
00138         //              strAlertLevel += "Interface is locked";
00139         //              break;
00140         //      case 0x04:      //4 = Interface is unavailable because USB is connected
00141         //              strAlertLevel += "Interface is unavailable because USB is connected";
00142         //              break;
00143         //      default:
00144         //              strAlertLevel += "Interface configuration unknown";
00145         //              break;
00146         //}
00147         strDeviceType = pEntry->str_type;               // Device Name/Type
00148         // IP Address String
00149         strIpAddress.Format("IP Address: %u.%u.%u.%u", (unsigned short) pEntry->ip[0], (unsigned short) pEntry->ip[1],(unsigned short) pEntry->ip[2],(unsigned short) pEntry->ip[3]);
00150         strAdditionalDesc = pEntry->str_description;    // Additional Description
00151         // MacAddress
00152         strMacAddress.Format("MAC Address: %02x-%02x-%02x-%02x-%02x-%02x", (unsigned short) pEntry->mac[0], (unsigned short) pEntry->mac[1],(unsigned short) pEntry->mac[2],(unsigned short) pEntry->mac[3],(unsigned short) pEntry->mac[4],(unsigned short) pEntry->mac[5]);
00153         // Event1 Time
00154         temp_str = pEntry->str_ev1 + " ";
00155         if(pEntry->event1_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event1_days,pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00156         else if(pEntry->event1_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00157         else if(pEntry->event1_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event1_minutes, pEntry->event1_seconds );
00158         else temp_str2.Format("%i seconds", pEntry->event1_seconds );
00159         strEvent1 = temp_str + temp_str2;
00160         // Event2 Time
00161         temp_str = pEntry->str_ev2 + " ";
00162         if(pEntry->event2_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event2_days,pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00163         else if(pEntry->event2_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00164         else if(pEntry->event2_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event2_minutes, pEntry->event2_seconds );
00165         else temp_str2.Format("%i seconds", pEntry->event2_seconds );
00166         strEvent2 = temp_str + temp_str2;
00167
00168         strEntry = strDeviceType + "\r\n";
00169         strEntry += strAlertLevel + "\r\n";
00170         //strEntry += strIpAddress + "\r\n";
00171         strEntry += strAdditionalDesc + "\r\n";
00172         strEntry += strMacAddress + "\r\n";
00173         strEntry += strEvent1 + "\r\n";
00174         //strEntry += strEvent2 + "\r\n";
00175         return strEntry;
00176 }
00177
00178 CString CNetFinder::EntryToStrUSB(NETDISPLAY_ENTRY *pEntry, CString strPort)
00179 {
00180         CString strAlertLevel;
00181         CString strDeviceType;
00182         CString strIpAddress;
00183         CString strEvent1, strEvent2;
00184         CString strAdditionalDesc;
00185         CString strMacAddress;
00186         CString strEntry;
00187         CString temp_str, temp_str2;
00188
00189         strAlertLevel = "Connection: ";
00190         strAlertLevel += strPort;
00191         //switch(pEntry->alert_level){                  // Alert Level
00192         //      case 0x00:      //0 = Interface is open (unconnected);
00193         //              strAlertLevel += "Interface is open (unconnected)";
00194         //              break;
00195         //      case 0x01:      //1 = Interface is connected (sharing is allowed);
00196         //              strAlertLevel += "Interface is connected (sharing is allowed)";
00197         //              break;
00198         //      case 0x02:      //2 = Interface is connected (sharing is not allowed);
00199         //              strAlertLevel += "Interface is connected (sharing is not allowed)";
00200         //              break;
00201         //      case 0x03:      //3 = Interface is locked
00202         //              strAlertLevel += "Interface is locked";
00203         //              break;
00204         //      case 0x04:      //4 = Interface is unavailable because USB is connected
00205         //              strAlertLevel += "Interface is unavailable because USB is connected";
00206         //              break;
00207         //      default:
00208         //              strAlertLevel += "Interface configuration unknown";
00209         //              break;
00210         //}
00211         strDeviceType = pEntry->str_type;               // Device Name/Type
00212         // IP Address String
00213         strIpAddress.Format("IP Address: %u.%u.%u.%u", (unsigned short) pEntry->ip[0], (unsigned short) pEntry->ip[1],(unsigned short) pEntry->ip[2],(unsigned short) pEntry->ip[3]);
00214         strAdditionalDesc = pEntry->str_description;    // Additional Description
00215         // MacAddress
00216         strMacAddress.Format("MAC Address: %02x-%02x-%02x-%02x-%02x-%02x", (unsigned short) pEntry->mac[0], (unsigned short) pEntry->mac[1],(unsigned short) pEntry->mac[2],(unsigned short) pEntry->mac[3],(unsigned short) pEntry->mac[4],(unsigned short) pEntry->mac[5]);
00217         // Event1 Time
00218         temp_str = pEntry->str_ev1 + " ";
00219         if(pEntry->event1_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event1_days,pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00220         else if(pEntry->event1_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event1_hours,pEntry->event1_minutes, pEntry->event1_seconds );
00221         else if(pEntry->event1_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event1_minutes, pEntry->event1_seconds );
00222         else temp_str2.Format("%i seconds", pEntry->event1_seconds );
00223         strEvent1 = temp_str + temp_str2;
00224         // Event2 Time
00225         temp_str = pEntry->str_ev2 + " ";
00226         if(pEntry->event2_days) temp_str2.Format("%i days, %i hours, %i minutes, %i seconds", pEntry->event2_days,pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00227         else if(pEntry->event2_hours) temp_str2.Format("%i hours, %i minutes, %i seconds", pEntry->event2_hours,pEntry->event2_minutes, pEntry->event2_seconds );
00228         else if(pEntry->event2_minutes) temp_str2.Format("%i minutes, %i seconds", pEntry->event2_minutes, pEntry->event2_seconds );
00229         else temp_str2.Format("%i seconds", pEntry->event2_seconds );
00230         strEvent2 = temp_str + temp_str2;
00231
00232         strEntry = strDeviceType + "\r\n";
00233         strEntry += strAlertLevel + "\r\n";
00234         //strEntry += strIpAddress + "\r\n";
00235         strEntry += strAdditionalDesc + "\r\n";
00236         strEntry += strMacAddress + "\r\n";
00237         strEntry += strEvent1 + "\r\n";
00238         //strEntry += strEvent2 + "\r\n";
00239         return strEntry;
00240 }
00241
00242 int CNetFinder::FindEntry(unsigned long SockAddr)
00243 {
00244         int idxEntry;
00245         int EntryFound;
00246         EntryFound = NO_ENTRIES;
00247         for (idxEntry=0;idxEntry<=LastEntry;idxEntry++){
00248                 if (SockAddr == DppEntries[idxEntry].SockAddr) {
00249                         EntryFound = idxEntry;
00250                         break;
00251                 }
00252         }
00253         return (EntryFound);
00254 }
00255
00256 void CNetFinder::InitEntry(NETDISPLAY_ENTRY *pEntry)
00257 {
00258         int idxInit;
00259         pEntry->alert_level = 0;
00260
00261         pEntry->event1_days = 0;
00262         pEntry->event1_hours = 0;
00263         pEntry->event1_minutes = 0;
00264
00265         pEntry->event2_days = 0;
00266         pEntry->event2_hours = 0;
00267         pEntry->event2_minutes = 0;
00268
00269         pEntry->event1_seconds = 0;
00270         pEntry->event2_seconds = 0;
00271
00272         pEntry->port = 0; // Get port from UDP header
00273
00274         for (idxInit=0;idxInit<4;idxInit++){
00275                 pEntry->mac[idxInit] = 0;
00276                 pEntry->ip[idxInit] = 0;
00277                 pEntry->subnet[idxInit] = 0;
00278                 pEntry->gateway[idxInit] = 0;
00279         }
00280
00281         pEntry->mac[4] = 0;
00282         pEntry->mac[5] = 0;
00283
00284         pEntry->str_type = "";
00285         pEntry->str_description = "";
00286         pEntry->str_ev1 = "";
00287         pEntry->str_ev2 = "";
00288
00289         pEntry->str_display = "";
00290         pEntry->ccConnectRGB = colorWhite;
00291
00292         pEntry->HasData = FALSE;
00293
00294         pEntry->SockAddr = 0;
00295
00296 }
00297
00298 void CNetFinder::InitAllEntries()
00299 {
00300         for (int idxEntry=0;idxEntry<MAX_ENTRIES;idxEntry++){
00301                 InitEntry(&DppEntries[idxEntry]);
00302         }
00303         LastEntry = NO_ENTRIES;
00304         m_rand = 0;
00305 }
00306
00307 void CNetFinder::AddEntry(NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort)
00308 {
00309         pEntry->alert_level = buffer[1];
00310         pEntry->port = destPort;
00311
00312         int i = 4; // Start buffer index at 4
00313
00314         pEntry->event1_days = ( (int) buffer[i++]<<8 );
00315         pEntry->event1_days |= buffer[i++];
00316
00317         pEntry->event1_hours = buffer[i++];
00318         pEntry->event1_minutes = buffer[i++];
00319
00320         pEntry->event2_days = ( (int) buffer[i++]<<8 );
00321         pEntry->event2_days |= buffer[i++];
00322
00323         pEntry->event2_hours = buffer[i++];
00324         pEntry->event2_minutes = buffer[i++];
00325
00326         pEntry->event1_seconds = buffer[i++];
00327         pEntry->event2_seconds = buffer[i++];
00328
00329         pEntry->mac[0] = buffer[i++];
00330         pEntry->mac[1] = buffer[i++];
00331         pEntry->mac[2] = buffer[i++];
00332         pEntry->mac[3] = buffer[i++];
00333         pEntry->mac[4] = buffer[i++];
00334         pEntry->mac[5] = buffer[i++];
00335
00336         pEntry->ip[0] = buffer[i++];
00337         pEntry->ip[1] = buffer[i++];
00338         pEntry->ip[2] = buffer[i++];
00339         pEntry->ip[3] = buffer[i++];
00340
00341         pEntry->subnet[0] = buffer[i++];
00342         pEntry->subnet[1] = buffer[i++];
00343         pEntry->subnet[2] = buffer[i++];
00344         pEntry->subnet[3] = buffer[i++];
00345
00346         pEntry->gateway[0] = buffer[i++];
00347         pEntry->gateway[1] = buffer[i++];
00348         pEntry->gateway[2] = buffer[i++];
00349         pEntry->gateway[3] = buffer[i++];
00350
00351         pEntry->str_type = &buffer[i];
00352         i += (pEntry->str_type.GetLength()+1);
00353
00354         pEntry->str_description = &buffer[i];
00355         i += (pEntry->str_description.GetLength()+1);
00356
00357         // Copy the Event1+2 text descripion without the ": "
00358         pEntry->str_ev1 = &buffer[i];
00359         i += (pEntry->str_ev1.GetLength()+1);
00360
00361         pEntry->str_ev2 = &buffer[i];
00362         i += (pEntry->str_ev2.GetLength()+1);
00363
00364         // Add ": " to str_ev1 and str_ev2
00365         pEntry->str_ev1 += ": ";
00366         pEntry->str_ev2 += ": ";
00367
00368         pEntry->ccConnectRGB = AlertByteToCOLORREF(pEntry->alert_level);
00369         pEntry->HasData = TRUE;
00370         pEntry->SockAddr = SockAddr_ByteToULong(&buffer[20]);
00371         pEntry->str_display = EntryToStr(pEntry);       // Convert Entry infor to string
00372 }
00373
00374 CString CNetFinder::SockAddr_DlgToStr(CDialog *dlg, int id1, int id2, int id3, int id4)
00375 {
00376         char szAddr[10];
00377         CString strAddr;
00378         CString strID;
00379
00380         memset(&szAddr, 0, sizeof(szAddr));
00381         ::GetDlgItemText(dlg->GetSafeHwnd(), id1, szAddr, sizeof(szAddr));
00382         strID.Format("%s",szAddr);
00383         strAddr = strID.Trim();
00384         memset(&szAddr, 0, sizeof(szAddr));
00385         ::GetDlgItemText(dlg->GetSafeHwnd(), id2, szAddr, sizeof(szAddr));
00386         strID.Format(".%s",szAddr);
00387         strAddr += strID.Trim();
00388         memset(&szAddr, 0, sizeof(szAddr));
00389         ::GetDlgItemText(dlg->GetSafeHwnd(), id3, szAddr, sizeof(szAddr));
00390         strID.Format(".%s",szAddr);
00391         strAddr += strID.Trim();
00392         memset(&szAddr, 0, sizeof(szAddr));
00393         ::GetDlgItemText(dlg->GetSafeHwnd(), id4, szAddr, sizeof(szAddr));
00394         strID.Format(".%s",szAddr);
00395         strAddr += strID.Trim();
00396         return(strAddr);
00397
00398 }
00399
00400
00401 UINT CNetFinder::SockPort_DlgToUINT(CDialog *dlg, int id1)
00402 {
00403         char szPort[10];
00404         UINT Port;
00405         CString strPort;
00406         memset(&szPort, 0, sizeof(szPort));
00407         ::GetDlgItemText(dlg->GetSafeHwnd(), id1, szPort, sizeof(szPort));
00408         Port = atoi(szPort);
00409         return(Port);
00410 }
00411
00412 in_addr CNetFinder::SockAddr_ByteToInAddr(unsigned char *ip)
00413 {
00414         in_addr inSockAddr;
00415         inSockAddr.S_un.S_un_b.s_b1 = ip[0];
00416         inSockAddr.S_un.S_un_b.s_b2 = ip[1];
00417         inSockAddr.S_un.S_un_b.s_b3 = ip[2];
00418         inSockAddr.S_un.S_un_b.s_b4 = ip[3];
00419         return (inSockAddr);
00420 }
00421
00422 unsigned long CNetFinder::SockAddr_ByteToULong(unsigned char *ip)
00423 {
00424         in_addr inSockAddr;
00425         inSockAddr = SockAddr_ByteToInAddr(ip);
00426         return (inSockAddr.S_un.S_addr);
00427 }
00428
00429 CString CNetFinder::SockAddr_ByteToStr(unsigned char *ip)
00430 {
00431         CString strSockAddr;
00432         strSockAddr.Format("%d.%d.%d.%d",ip[0],ip[1],ip[2],ip[3]);
00433         return (strSockAddr);
00434 }
00435
00436 in_addr CNetFinder::SockAddr_StrToInAddr(CString strSockAddr)
00437 {
00438         unsigned long SockAddr;
00439         in_addr inSockAddr;
00440         SockAddr = inet_addr(strSockAddr);
00441         inSockAddr.S_un.S_addr = SockAddr;
00442         return (inSockAddr);
00443 }
00444
00445 unsigned long CNetFinder::SockAddr_StrToULong(CString strSockAddr)
00446 {
00447         unsigned long SockAddr;
00448         SockAddr = inet_addr(strSockAddr);
00449         return (SockAddr);
00450 }
00451
00452 in_addr CNetFinder::SockAddr_ULongToInAddr(unsigned long SockAddr)
00453 {
00454         in_addr inSockAddr;
00455         inSockAddr.S_un.S_addr = SockAddr;
00456         return (inSockAddr);
00457 }
00458
00459 CString CNetFinder::SockAddr_ULongToStr(unsigned long SockAddr)
00460 {
00461         CString strSockAddr;
00462         in_addr inSockAddr;
00463         inSockAddr.S_un.S_addr = SockAddr;
00464         strSockAddr.Format("%s",_T(inet_ntoa(inSockAddr)));
00465         return (strSockAddr);
00466 }
00467
00468 CString CNetFinder::SockAddr_InAddrToStr(in_addr inSockAddr)
00469 {
00470         CString strSockAddr;
00471         strSockAddr.Format("%s",_T(inet_ntoa(inSockAddr)));
00472         return (strSockAddr);
00473 }
00474
00475
00476
00477
00478
00479
00480
00481
00482
00483
00484
00485
00486
00487
00488
00489
00490
00491
00492
00493
00494
00495
00496
00497
00498
00499
00500
00501
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/NetFinder.h Source File

DeviceIO/NetFinder.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "X11Color.h"
00004
00006 // NetFinder Data
00007
00008 typedef struct NETDISPLAY_ENTRY {
00009         unsigned char alert_level;
00010
00011         UINT event1_days;
00012         unsigned char event1_hours;
00013         unsigned char event1_minutes;
00014
00015         UINT event2_days;
00016         unsigned char event2_hours;
00017         unsigned char event2_minutes;
00018
00019         unsigned char event1_seconds;
00020         unsigned char event2_seconds;
00021
00022         unsigned char mac[6];
00023         unsigned char ip[4];
00024         USHORT port; // Get port from UDP header
00025         unsigned char subnet[4];
00026         unsigned char gateway[4];
00027
00028         CString str_type;
00029         CString str_description;
00030         CString str_ev1;
00031         CString str_ev2;
00032
00033         CString str_display;
00034         COLORREF ccConnectRGB;
00035
00036         BOOL HasData;
00037
00038         unsigned long SockAddr;
00039
00040 } NETDISPLAY_ENTRY;
00041
00042 const int NO_ENTRIES = -1;
00043 const int MAX_ENTRIES = 10;
00044
00045 class CNetFinder
00046 {
00047 public:
00048         CNetFinder(void);
00049         ~CNetFinder(void);
00050
00051         int m_rand;
00052         NETDISPLAY_ENTRY DppEntries[MAX_ENTRIES];       // 20140430 changed hardcode to const var
00053         int LastEntry;
00054
00055         unsigned long DppSockAddr;                                      // socket address of selected DPP
00056         int DppEntryIdx;                                        // entry index of selected DPP
00057         BOOL DppFound;                                          // selected DPP found
00058
00059         CString EntryToStr(NETDISPLAY_ENTRY *pEntry);
00060         CString EntryToStrRS232(NETDISPLAY_ENTRY *pEntry, CString strPort);
00061         CString EntryToStrUSB(NETDISPLAY_ENTRY *pEntry, CString strPort);
00062         COLORREF AlertEntryToCOLORREF(NETDISPLAY_ENTRY *pEntry);
00063         COLORREF AlertByteToCOLORREF(unsigned char alert_level);
00064
00065         int FindEntry(unsigned long SockAddr);
00066
00067         CString SockAddr_DlgToStr(CDialog *dlg, int id1, int id2, int id3, int id4);
00068         UINT SockPort_DlgToUINT(CDialog *dlg, int id1);
00069
00070         in_addr SockAddr_ByteToInAddr(unsigned char *ip);
00071         unsigned long SockAddr_ByteToULong(unsigned char *ip);
00072         CString SockAddr_ByteToStr(unsigned char *ip);
00073
00074         in_addr SockAddr_StrToInAddr(CString strSockAddr);      // BYTES in_addr.S_un.S_un_b.s_b*
00075         unsigned long SockAddr_StrToULong(CString strSockAddr);
00076
00077         in_addr SockAddr_ULongToInAddr(unsigned long SockAddr);
00078         CString SockAddr_ULongToStr(unsigned long SockAddr);
00079
00080         CString SockAddr_InAddrToStr(in_addr inSockAddr);
00081
00082         void InitEntry(NETDISPLAY_ENTRY *pEntry);
00083         void InitAllEntries();
00084         void AddEntry(NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort);
00085
00086 };
00087
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/ParsePacket.cpp Source File

DeviceIO/ParsePacket.cpp
Go to the documentation of this file.
00001 #include "ParsePacket.h"
00002
00003 CParsePacket::CParsePacket(void)
00004 {
00005 }
00006
00007 CParsePacket::~CParsePacket(void)
00008 {
00009 }
00010
00011 void CParsePacket::ParsePacketStatus(unsigned char P[], Packet_In *PIN)
00012 {
00013     short X;
00014     long CSum;
00015
00016     CSum = 0;
00017     if (P[0] == SYNC1_) {
00018         if (P[1] == SYNC2_) {
00019             if (P[4] < 128) {  // LEN MSB < 128, i.e. LEN < 32768
00020                 PIN->LEN = (P[4] * 256) + P[5];
00021                 PIN->PID1 = P[2];
00022                 PIN->PID2 = P[3];
00023                                 for (X=0;X <=(PIN->LEN+5);X++) {        // add up all the bytes except checksum
00024                     CSum = CSum + P[X];
00025                 }
00026                 CSum = CSum + 256 * (long)(P[PIN->LEN + 6]) + (long)(P[PIN->LEN + 7]);
00027                 PIN->CheckSum = CSum;
00028                 if ((CSum & 0xFFFF) == 0) {
00029                     PIN->STATUS = 0;      // packet is OK
00030                     if (PIN->LEN > 0) {
00031                                                 for (X=6;X <=(PIN->LEN+5);X++) {
00032                             PIN->DATA[X - 6] = P[X];
00033                                                 }
00034                     }
00035                 } else {
00036                     PIN->STATUS = PID2_ACK_CHECKSUM_ERROR;    // checksum error
00037                 }
00038             } else {
00039                 PIN->STATUS = PID2_ACK_LEN_ERROR;        // length error
00040             }
00041         } else {
00042             PIN->STATUS = PID2_ACK_SYNC_ERROR;            // sync error
00043         }
00044     } else {
00045         PIN->STATUS = PID2_ACK_SYNC_ERROR ;               // sync error
00046     }
00047 }
00048
00049 string CParsePacket::PID2_TextToString(string strPacketSource, unsigned char PID2)
00050 {
00051         string strPID2;
00052         strPID2 = "";
00053         switch (PID2) {
00054                 case PID2_ACK_OK:    // ACK OK
00055             //PID2_TextToString = strPacketSource + ": OK\t";
00056             //strPID2 = "ACK_OK";
00057                         strPID2 = "";
00058             //ACK_Received = True
00059                         break;
00060         case PID2_ACK_SYNC_ERROR:
00061             strPID2 = strPacketSource + ": Sync Error\t";
00062                         break;
00063         case PID2_ACK_PID_ERROR:
00064             strPID2 = strPacketSource + ": PID Error\t";
00065                         break;
00066         case PID2_ACK_LEN_ERROR:
00067             strPID2 = strPacketSource + ": Length Error\t";
00068                         break;
00069         case PID2_ACK_CHECKSUM_ERROR:
00070             strPID2 = strPacketSource + ": Checksum Error\t";
00071                         break;
00072         case PID2_ACK_BAD_PARAM:        // now msg includes bad parameter
00073                         // put the error extractor in a new function
00074                 //[] If PIN.LEN > 0 Then ' BAD CMD (PID2=7), BAD PARAM (PID2=5), NO PC5 (PID2=11) errors return offending command string
00075       //        [] T$ = ""
00076       //        [] For X = 0 To PIN.LEN - 1
00077       //                [] T$ = T$ + Chr(PIN.DATA(X))
00078       //        [] Next X
00079       //        [] End If
00080             strPID2 = strPacketSource + ": Bad Parameter\t";
00081                         break;
00082         case PID2_ACK_BAD_HEX_REC:
00083             strPID2 = strPacketSource + ": Bad HEX Record\t";
00084                         break;
00085         case PID2_ACK_FPGA_ERROR:
00086             strPID2 = strPacketSource + ": FPGA not initialized\t";
00087                         break;
00088         case PID2_ACK_CP2201_NOT_FOUND:
00089             strPID2 = strPacketSource + ": CP2201 not found\t";
00090                         break;
00091         case PID2_ACK_SCOPE_DATA_NOT_AVAIL:
00092             strPID2 = strPacketSource + ": No scope data\t";
00093                         break;
00094         case PID2_ACK_PC5_NOT_PRESENT:
00095             strPID2 = strPacketSource + ": PC5 not present\t";
00096                         break;
00097         case PID2_ACK_OK_ETHERNET_SHARE_REQ:
00098             strPID2 = strPacketSource + ": Ethernet sharing request\t";
00099                         break;
00100         case PID2_ACK_ETHERNET_BUSY:
00101             strPID2 = strPacketSource + ": Ethernet sharing request\t";
00102                         break;
00103                 //[] Case :TextLog "ACK: PC5 NOT DETECTED '" + T$ + "'" + vbCrLf
00104         case PID2_ACK_CAL_DATA_NOT_PRESENT:
00105             strPID2 = strPacketSource + ": Calibration data not present\t";
00106                         break;
00107         case PID2_ACK_UNRECOG:
00108             strPID2 = strPacketSource + ": Unrecognized Command\t";
00109                         break;
00110                 default:
00111                         strPID2 = strPacketSource + ": Unrecognized Error\t";
00112                         break;
00113         }
00114         return strPID2;
00115 }
00116
00117 long CParsePacket::ParsePacket(unsigned char P[], Packet_In *PIN)
00118 {
00119         long ParsePkt;
00120     ParsePkt = preqProcessNone;
00121     ParsePacketStatus (P, PIN);
00122     if (PIN->STATUS == PID2_ACK_OK) { // no errors
00123         if ((PIN->PID1 == PID1_RCV_STATUS) && (PIN->PID2 == PID2_SEND_DP4_STYLE_STATUS)) { // DP4-style status
00124             ParsePkt = preqProcessStatus;
00125         } else if ((PIN->PID1 == PID1_RCV_SPECTRUM) && ((PIN->PID2 >= RCVPT_256_CHANNEL_SPECTRUM) && (PIN->PID2 <= RCVPT_8192_CHANNEL_SPECTRUM_STATUS))) { // spectrum / spectrum+status
00126             ParsePkt = preqProcessSpectrum;
00127         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == PID2_SEND_SCOPE_DATA)) { //scope data packet
00128         //    ParsePkt = preqProcessScopeData;
00129         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == PID2_SEND_512_BYTE_MISC_DATA)) { //text data packet
00130         //    ParsePkt = preqProcessTextData;
00131         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_SCOPE_DATA)) { //scope data packet
00132             //ScopeOverFlow = false;
00133             ParsePkt = preqProcessScopeData;
00134         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_512_BYTE_MISC_DATA)) { //text data packet
00135             ParsePkt = preqProcessTextData;
00136         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_SCOPE_DATA_WITH_OVERFLOW)) { //scope data with overflow packet
00137             //ScopeOverFlow = true;
00138             //ParsePkt = preqProcessScopeData;
00139             ParsePkt = preqProcessScopeDataOverFlow;
00140         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_ETHERNET_SETTINGS)) { //ethernet settings packet
00141             //ParsePkt = preqProcessInetSettings;
00142         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_DIAGNOSTIC_DATA)) { //diagnostic data  packet
00143             ParsePkt = preqProcessDiagData;
00144         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_HARDWARE_DESCRIPTION)) { //hardware description packet
00145             //ParsePkt = preqProcessHwDesc;
00146         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_CONFIG_READBACK)) {
00147             ParsePkt = preqProcessCfgRead;
00148         //} else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_NETFINDER_READBACK)) {
00149             //ParsePkt = preqProcessNetFindRead;
00150         } else if ((PIN->PID1 == PID1_RCV_SCOPE_MISC) && (PIN->PID2 == RCVPT_OPTION_PA_CALIBRATION)) {
00151             ParsePkt = preqProcessPaCal;
00152         } else if (PIN->PID1 == PID1_ACK) {
00153             ParsePkt = preqProcessAck;
00154         } else {
00155             PIN->STATUS = PID2_ACK_PID_ERROR;  // unknown PID
00156             ParsePkt = preqProcessError;
00157         }
00158     } else {
00159         ParsePkt = preqProcessError;
00160     }
00161
00162     //PIN->PID1 = 0;    // overwrite the PIDs so packet can't be erroneously processed again
00163     //PIN->PID2 = 0;
00164
00165         return ParsePkt;
00166 }
00167
00168 //ElseIf PIN.PID2 = 7 Then ' Config readback response packet
00169 //    txtConfig.Text = ""
00170 //    For X = 0 To PIN.LEN - 1
00171 //        txtConfig.Text = txtConfig.Text + Chr(PIN.DATA(X))
00172 //        If Chr(PIN.DATA(X)) = ";" Then
00173 //            txtConfig.Text = txtConfig.Text + vbCrLf
00174 //        End If
00175 //    Next X
00176
00177
00178
00179
00180
00181
00182
00183
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/ParsePacket.h Source File

DeviceIO/ParsePacket.h
Go to the documentation of this file.
00001
00002 #pragma once
00003
00004 #include <string>
00005 #include "DP5Protocol.h"
00006 using namespace std;
00007
00008 typedef enum _CommType {
00009     commNone = 0,
00010     commRS232 = 1,
00011     commUSB = 2,
00012     commSockets = 3
00013 } CommType;
00014
00015 #define preqProcessNone 0x0
00016 #define preqProcessStatus 0x1
00017 #define preqProcessSpectrum 0x2
00018 #define preqRequestScopeData 0x4
00019 #define preqProcessScopeData 0x8
00020 #define preqProcessTextData 0x10
00021 #define preqProcessScopeDataOverFlow 0x20
00022 #define preqProcessInetSettings 0x40
00023 #define preqProcessDiagData 0x80
00024 #define preqProcessHwDesc 0x100
00025 #define preqProcessCfgRead 0x200
00026 #define preqProcessNetFindRead 0x400
00027 #define preqProcessPaCal 0x800
00028 //...
00029 #define preqProcessSCAData 0x2000
00030 #define preqProcessAck 0x4000
00031 #define preqProcessError 0x8000
00032
00033 typedef struct _DppStateType {
00034     CommType Interface;
00035     string strPort;
00036     unsigned long ReqProcess;
00037     bool HaveScopeData;
00038     bool ScopeAutoRearm;
00039         bool ScopeOverFlow;
00040 } DppStateType;
00041
00042 class CParsePacket
00043 {
00044 public:
00045         CParsePacket(void);
00046         ~CParsePacket(void);
00048         DppStateType DppState;
00050         void ParsePacketStatus(unsigned char P[], Packet_In *PIN);
00052         string PID2_TextToString(string strPacketSource, unsigned char PID2);
00054         long ParsePacket(unsigned char P[], Packet_In *PIN);
00055 };
00056
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Plot.cpp Source File

Plot.cpp
Go to the documentation of this file.
00001 #include ".\plot.h"
00002
00003 CPlot::CPlot(void)
00004 {
00005         m_yMin = 0;
00006     m_yMax = 127;
00007     m_xMin = 0;
00008     m_xMax = 1023;
00009     m_xPixels = m_yPixels = 1000000;
00010 }
00011
00012 CPlot::~CPlot(void)
00013 {
00014 }
00015
00016 // Translate position (0 .. MAX_CHANNELS) to pixel
00017
00018 inline int CPlot::PositionToPixel(double pos)
00019 {
00020     return((int)(m_xPixels * double(pos - (m_xMin + 0.5f)) / double(m_xMax - m_xMin) + 0.5f));
00021 }
00022
00023 inline double CPlot::PixelToPosition(int pixel)
00024 {
00025     return(m_xMin + double(pixel) * double(m_xMax - m_xMin) / m_xPixels);
00026 }
00027
00028 void CPlot::MovePlot(int xmin, int xmax, unsigned long ymin, unsigned long ymax)
00029 {
00030     int xmi = xmin;
00031     int xma = xmax;
00032     int dx = xmax - xmin;
00033     if (dx < MIN_PLOT_CHANNELS - 1)
00034         dx = MIN_PLOT_CHANNELS - 1;
00035     else if (dx >= MAX_CHANNELS)
00036         dx = MAX_CHANNELS - 1;
00037     if (xmi < 0)
00038         xmi = 0;
00039     xma = xmi + dx;
00040     if (xma >= MAX_CHANNELS)
00041     {
00042         xma = MAX_CHANNELS - 1;
00043         xmi = xma - dx;
00044     }
00045     if (int(m_xMin) != xmi || int(m_xMax) != xma)
00046     {
00047         m_xMin = xmi;
00048         m_xMax = xma;
00049     }
00050 }
00051
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Plot.h Source File

Plot.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "STypes.h"
00004
00005 class CPlot
00006 {
00007 public:
00008         CPlot(void);
00009         ~CPlot(void);
00010
00011     double m_xCursorData;   // Cursor position (channels)
00012
00013         unsigned long m_xMin;
00014     unsigned long m_xMax;
00015     unsigned long m_yMin;
00016     unsigned long m_yMax;
00017
00018         int m_xPixels;  // Number of x-pixels
00019     int m_yPixels;  // Number of y-pixels
00020
00021         double m_xCursorPos;    // Cursor position (pixels)
00022     double m_yCursorPos;
00023
00024         inline int PositionToPixel(double pos);
00025         inline double PixelToPosition(int pixel);
00026         void MovePlot(int xmin, int xmax, unsigned long ymin, unsigned long ymax);
00027 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/PlotCanvas.cpp Source File

Controls/PlotCanvas.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include <math.h>
00003 #include "PlotCanvas.h"
00004 #include ".\PlotCanvas.h"
00005
00007 // CPlotCanvas
00008
00009 CPlotCanvas::CPlotCanvas()
00010 {
00011         m_crDisplayBGColor = ctrlColWhite;
00012         m_crPlotColor = ctrlColRed;
00013         m_crCursorColor = ctrlColBlack;
00014         m_crTextFGColor = ctrlColBlack;
00015         m_crTextBGColor = ctrlColWhite;
00016
00017         hasBackground = false;
00018         PersistenceMode = false;
00019         CursorPosition = -1;    // don't plot if not set
00020         XPlotMAX = 0;
00021         YPlotMAX = 0;
00022         for(int i=0; i<8192;i++) {
00023                 YPlotBuffer[i] = 0;
00024         }
00025         OptScaleType = false;   //true = log,false=linear
00026         OptPlotType = false;    //true = line,false=solid
00027 }
00028
00029 CPlotCanvas::~CPlotCanvas()
00030 {
00031 }
00032
00033 BEGIN_MESSAGE_MAP(CPlotCanvas, CStatic)
00034         //{{AFX_MSG_MAP(CPlotCanvas)
00035         ON_WM_ERASEBKGND()
00036         ON_WM_PAINT()
00037         ON_WM_LBUTTONDOWN()
00038         //}}AFX_MSG_MAP
00039 END_MESSAGE_MAP()
00040
00042 // CPlotCanvas message handlers
00043
00046 BOOL CPlotCanvas::OnEraseBkgnd(CDC* pDC)
00047 {
00048         return TRUE;    // do not erase background
00049 }
00050
00053 void CPlotCanvas::OnRefreshBkgnd()
00054 {
00055         hasBackground = false;  // redraw background
00056 }
00057
00060 void CPlotCanvas::OnPaint()
00061 {
00062         CPaintDC dc(this); // device context for painting
00063         CRect rect;
00064         GetClientRect(&rect);
00065         DrawPlotCanvas(&rect,&dc);
00066 }
00067
00069 // DrawPlotCanvas
00070 // The DrawPlotCanvas method will draw a compas with the heading centered.
00072 void CPlotCanvas::DrawPlotCanvas(CRect *pRect, CDC *pDCa)
00073 {
00074         BOOL isPlotPen = TRUE;
00075         BOOL CurrentPen = TRUE;         //true=plot pen, false =roi pen
00076         CDC *pDC = pDCa;                                        // Get DC if no DC is passed
00077         if(pDCa == NULL) pDC = GetDC();
00078         CDC dcMem;                                                      // Create temporary work DC (memory DC) and bitmap
00079         CBitmap bmTemp;
00080         dcMem.CreateCompatibleDC(pDC);
00081         bmTemp.CreateCompatibleBitmap( pDC,pRect->Width(),pRect->Height() );
00082         CBitmap *pbmOld = dcMem.SelectObject(&bmTemp);
00083         CRect rect = *pRect;
00084         dcMem.BitBlt(0, 0, rect.Width(), rect.Height(), pDC, 0, 0, SRCCOPY) ;
00085         CString strRectInfo;
00086         strRectInfo.Format("Width: %d  Height: %d", rect.Width(), rect.Height());
00087
00088         // Draw background rectangle
00089         CBrush WorkSpaceBrush( m_crDisplayBGColor );
00090         CBrush *pOldBrush = dcMem.SelectObject(&WorkSpaceBrush);
00091         CPen *pOldPen = (CPen *)dcMem.SelectStockObject( NULL_PEN );
00092         if (!hasBackground || !PersistenceMode) {
00093                 dcMem.Rectangle(&rect);
00094                 dcMem.Draw3dRect(&rect, (COLORREF)GetSysColor(COLOR_3DSHADOW), (COLORREF)GetSysColor(COLOR_3DHILIGHT));
00095                 hasBackground = true;
00096         }
00097         //dcMem.SelectStockObject( BLACK_PEN);
00098         dcMem.SelectStockObject(WHITE_PEN);
00099         CRgn rgnRect;                           // Create rgn
00100         rgnRect.CreateRectRgn(rect.left,rect.top,rect.right,rect.bottom);
00101         dcMem.SelectClipRgn(&rgnRect);
00102         rect = *pRect;
00103
00104         // Create a font and set color
00105         CFont cFont,*cpOldFont;
00106         cFont.CreatePointFont(70,_T("Arial"));
00107         cpOldFont = (CFont *)dcMem.SelectObject(&cFont);
00108         COLORREF crOldBkColor = dcMem.SetBkColor( m_crDisplayBGColor );
00109         TEXTMETRIC tm;
00110         dcMem.GetTextMetrics(&tm);
00111         // change color of plotting pen
00112         CPen PlottingPen( PS_SOLID, 1, RGB(255,0,0) );
00113         CPen RoiPen( PS_SOLID, 1, RGB(0,0,255) );
00114         dcMem.SelectObject( &PlottingPen );
00115         dcMem.MoveTo(0, rect.bottom - YPlotBuffer[0]);
00116         double XScaleFactor;
00117         if (XPlotMAX > 0) {
00118                 XScaleFactor = (double) rect.Width();
00119                 XScaleFactor /= (double)(XPlotMAX + 1);
00120         } else {
00121                 XScaleFactor = (double) rect.Width();
00122         }
00123         double YScaleFactor;
00124         if (YPlotMAX > 0) {
00125                 YScaleFactor = (double) rect.Height();
00126                 YScaleFactor /= (double)(YPlotMAX + 1);
00127         } else {
00128                 YScaleFactor = (double) rect.Height();
00129         }
00130         for(int X=0; X<=XPlotMAX; X++) {
00136
00141
00142                 if (OptPlotType) {
00143                         dcMem.LineTo((int)(X * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X]* YScaleFactor)));
00144                         dcMem.LineTo((int)((X + 1) * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X + 1]* YScaleFactor)));
00145                 } else {
00146                         dcMem.LineTo((int)(X * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X]* YScaleFactor)));
00147                         dcMem.LineTo((int)((X + 1) * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X + 1]* YScaleFactor)));
00148                         dcMem.MoveTo((int)(X * XScaleFactor),rect.bottom);
00149                         dcMem.LineTo((int)(X * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X]* YScaleFactor)));
00150                         dcMem.MoveTo((int)((X + 1) * XScaleFactor), rect.bottom);
00151                         dcMem.LineTo((int)((X + 1) * XScaleFactor), (int)(rect.bottom - (YPlotBuffer[X + 1]* YScaleFactor)));
00152                 }
00153     }
00154         CPen MarkerPen( PS_SOLID, 1, RGB(0,0,255) );
00155         dcMem.SelectObject( &MarkerPen );
00156         DrawCursor( &dcMem, YPlotBuffer, false);
00157         dcMem.SelectObject( &MarkerPen );
00158
00159         //
00160         // finally draw to screen from temperary dc
00161         //
00162         pDC->BitBlt(0,0,rect.Width(),rect.Height(),&dcMem,0,0,SRCCOPY);
00163
00165         pDC->SelectClipRgn(NULL);
00166         rgnRect.DeleteObject();
00167         dcMem.SelectObject(pOldBrush);
00168         WorkSpaceBrush.DeleteObject();
00169         dcMem.SetBkColor( crOldBkColor );
00170         dcMem.SelectObject(pbmOld);
00171         bmTemp.DeleteObject();
00172         dcMem.SelectObject(cpOldFont);
00173         cFont.DeleteObject();
00174         dcMem.SelectObject(pOldPen);
00175
00176         dcMem.SelectObject(cpOldFont);
00177
00179         if(pDCa == NULL) ReleaseDC(pDC);
00180 }
00181
00182 void CPlotCanvas::DrawCursor(CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor = false)
00183 {
00184         CPen TriggerFGPen( PS_SOLID, 1, m_crCursorColor );
00185         CPen TriggerBGPen( PS_SOLID, 1, m_crDisplayBGColor );
00186         dcMem->SelectObject( &TriggerFGPen );
00187         CRect rect;
00188         GetClientRect(&rect);
00189         dcMem->MoveTo(CursorPosition, 0);
00190         dcMem->LineTo(CursorPosition, rect.Height());
00191 }
00192
00194 // Name:                PlotTrace
00195 // Description: Plots trace from dpp scope data.
00197 void CPlotCanvas::PlotTrace(long YPlotBufferIn[8192])
00198 {
00199         CRect rect;
00200         GetClientRect(&rect);
00201         for(int i=0; i<8192;i++) {
00202                 YPlotBuffer[i] = YPlotBufferIn[i];
00203         }
00204         DrawPlotCanvas(&rect);
00205 }
00206
00208 // Name:                PlotTrace
00209 // Description: Plots trace from dpp scope data.
00211 void CPlotCanvas::ClearTrace()
00212 {
00213         CRect rect;
00214         GetClientRect(&rect);
00215         hasBackground = false;  // redraw background
00216         for(int i=0; i<8192;i++) {
00217                 YPlotBuffer[i] = 0;
00218         }
00219         DrawPlotCanvas(&rect);
00220 }
00221
00223 // Name:                PlotTrace
00224 // Description: Plots trace from dpp scope data.
00226 void CPlotCanvas::DrawCursor()
00227 {
00228         CRect rect;
00229         GetClientRect(&rect);
00230         hasBackground = false;  // redraw background
00231         //for(int i=0; i<8192;i++) {
00232         //      YPlotBuffer[i] = 0;
00233         //}
00234         DrawPlotCanvas(&rect);
00235 }
00236
00239
00240 void CPlotCanvas::SetPersistenceMode(bool Persistence)
00241 {
00242         PersistenceMode = Persistence;
00243         OnRefreshBkgnd();
00244 }
00245
00248
00249 void CPlotCanvas::SetCursorPosition(int CursorPos)
00250 {
00251         CursorPosition = CursorPos;
00252         OnRefreshBkgnd();
00253 }
00254
00255 void CPlotCanvas::OnLButtonDown(UINT nFlags, CPoint point)
00256 {
00257         //AfxMessageBox("CPlotCanvas::OnLButtonDown");
00258         SetCursorPosition(point.x);
00259         CRect rect;
00260         GetClientRect(&rect);
00261         DrawPlotCanvas(&rect);
00262         CStatic::OnLButtonDown(nFlags, point);
00263 }
00264
00265 void CPlotCanvas::DataAcq(long DataBuffer[8192], int NumChan)
00266 {
00267     int i;
00268         long YMAX;
00269     double y1;
00270
00271     XPlotMAX = NumChan - 1;
00272         if (NumChan > 0) {                      //plot data
00273         YMAX = 0;
00274         for(i = 0; i < NumChan; i++) { //get the largest value to be displayed
00275             if (OptScaleType) {
00276                                 if (log(1.0 + DataBuffer[i]) > YMAX) { YMAX = (long)(log(1.0 + DataBuffer[i])); }
00277             } else {
00278                 if (DataBuffer[i] > YMAX) { YMAX = DataBuffer[i]; }
00279             }
00280         }
00281         if (YMAX < 1) {
00282                         ClearTrace();
00283                         return;
00284                 }         //if no y scale exit sub
00285         if (OptScaleType) {     //adjust plot to include entire high peak
00286             YMAX = (YMAX * 10) + 10;
00287         } else {
00288             if (YMAX < 20) {
00289                 YMAX = YMAX + 2;
00290             } else {
00291                 YMAX = YMAX + 10;
00292             }
00293         }
00294         for (i = 0; i < NumChan;i++ ) { //get the largest value to be displayed
00295             if (OptScaleType) {
00296                 y1 = log(1.0 + DataBuffer[i]) * 10;
00297             } else {
00298                                 y1 = DataBuffer[i];
00299             }
00300             YPlotBuffer[i] = (long)(y1);
00301         }
00302         YPlotMAX = YMAX;
00303                 CRect rect;
00304                 GetClientRect(&rect);
00305                 hasBackground = false;  // redraw background
00306                 DrawPlotCanvas(&rect);
00307         }
00308 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/PlotCanvas.h Source File

Controls/PlotCanvas.h
Go to the documentation of this file.
00001 #if !defined(AFX_PlotCanvas_H__INCLUDED_)
00002 #define AFX_PlotCanvas_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007
00008
00009
00010
00011 // PlotCanvas.h : header file
00012 #define CC_SYSCOLOR(ind) (0x80000000|((ind) & ~CLR_DEFAULT))
00013
00014 #define ctrlColBlue RGB(0x00,0x00,0xFF)
00015 #define ctrlColSkyBlue RGB(0x32,0x99,0xCC)
00016 #define ctrlColLightBlue RGB(0xC0,0xD9,0xD9)
00017 #define ctrlColLightCyan RGB(0xE0,0xFF,0xFF)
00018 #define ctrlColYellow RGB(0x00,0xFF,0xFF)
00019 #define ctrlColGreen RGB(0x00,0xFF,0x00)
00020 #define ctrlDarkGreen RGB(0x2F,0x4F,0x2F)
00021 #define ctrlDarkGreenCopper RGB(0x4A,0x76,0x6E)
00022 #define ctrlDarkOliveGreen RGB(0x4F,0x4F,0x2F)
00023 #define ctrlColRed RGB(0xFF,0x00,0x00)
00024 #define ctrlColBlack RGB(0x00,0x00,0x00)
00025 #define ctrlColWhite RGB(0xFF,0xFF,0xFF)
00026 #define ctrlColDefault CLR_DEFAULT
00027 //#define ctrlColWinBk CC_SYSCOLOR(COLOR_WINDOW)
00028 #define ctrlColWinBk GetSysColor(0x80000005L)
00029 #define ctrlColWinText CC_SYSCOLOR(COLOR_WINDOWTEXT)
00030 #define ctrlColBtnFace CC_SYSCOLOR(COLOR_BTNFACE)
00031 #define ctrlColInfoBk CC_SYSCOLOR(COLOR_INFOBK)
00032 #define ctrlColInfoText CC_SYSCOLOR(COLOR_INFOTEXT)
00033
00034 #define ctrlColJavaGray RGB(0x64,0x64,0x64)
00035 #define ctrlColLightGray RGB(0xA8,0xA8,0xA8)
00036 #define ctrlColGray RGB(0xC0,0xC0,0xC0)
00037
00038 typedef struct _COORD_LONG { // coord.
00039     long X;      // horizontal coordinate
00040     long Y;      // vertical coordinate
00041 } COORD_LONG;
00042
00044 // CPlotCanvas window
00045
00046 class CPlotCanvas : public CStatic
00047 {
00048 // Construction
00049 public:
00050         CPlotCanvas();
00051
00052 // Attributes
00053 public:
00054         COLORREF m_crDisplayBGColor;
00055         COLORREF m_crPlotColor;
00056         COLORREF m_crCursorColor;
00057         COLORREF m_crTextFGColor;
00058         COLORREF m_crTextBGColor;
00059         //COLORREF m_crGridColor;
00060         bool hasBackground;
00061         bool PersistenceMode;
00062         int CursorPosition;
00063         int OldCursorPosition;
00064
00065         COORD_LONG PlotCursor;
00066         COORD_LONG OldPlotCursor;
00067         long YPlotBuffer[8192];    //holds y position data for cursor updates
00068         long YPlotMAX;
00069         long XPlotMAX;
00070
00071         bool OptScaleType;
00072         bool OptPlotType;
00073
00074 // Operations
00075 public:
00076
00077 // Overrides
00078         // ClassWizard generated virtual function overrides
00079         //{{AFX_VIRTUAL(CPlotCanvas)
00080         //}}AFX_VIRTUAL
00081
00082 // Implementation
00083 public:
00084         void Invalidate();
00085         void PlotTrace(long YPlotBufferIn[8192]);
00086         virtual ~CPlotCanvas();
00087
00088         // Generated message map functions
00089 protected:
00090         //{{AFX_MSG(CPlotCanvas)
00091         afx_msg BOOL OnEraseBkgnd(CDC* pDC);
00092         afx_msg void OnPaint();
00093         //}}AFX_MSG
00094
00095         DECLARE_MESSAGE_MAP()
00096 private:
00097         void DrawPlotCanvas(CRect *pRect, CDC *pDCa = NULL);
00098 public:
00099         //void MakePlot(long YPlotBufferIn[8192]);
00100         void ClearTrace();
00101         void DrawCursor();
00102         void OnRefreshBkgnd();
00103         void SetPersistenceMode(bool Persistence);
00104         void SetCursorPosition(int CursorPos);
00105         void DrawCursor(CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor);
00106
00107         afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
00108         void DataAcq(long DataBuffer[8192], int NumChan);
00109
00110 };
00111
00112 //{{AFX_INSERT_LOCATION}}
00113 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00114
00115 #endif // !defined(AFX_PlotCanvas_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/PowerPage.cpp Source File

DP5Cfg/PowerPage.cpp
Go to the documentation of this file.
00001 // PowerPage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "afxpriv.h"    // afxpriv.h has WM_COMMANDHELP id
00006 //#include "CDP5Cfg.h"
00007 #include "PowerPageRes.h"
00008 #include "PowerPage.h"
00009 #include ".\PowerPage.h"
00010
00011 #ifdef _DEBUG
00012 #define new DEBUG_NEW
00013 #undef THIS_FILE
00014 static char THIS_FILE[] = __FILE__;
00015 #endif
00016
00018 // CPowerPage property page
00019
00020 IMPLEMENT_DYNCREATE(CPowerPage, CCfgPropPage)
00021 //#define IDD_POWER_PAGE                  109
00022
00023 //CPowerPage::CPowerPage() : CCfgPropPage(CPowerPage::IDD)
00024 CPowerPage::CPowerPage() : CCfgPropPage("IDD_POWER_PAGE")
00025 {
00026         //{{AFX_DATA_INIT(CPowerPage)
00027                 // NOTE: the ClassWizard will add member initialization here
00028         //}}AFX_DATA_INIT
00029 }
00030
00031 CPowerPage::~CPowerPage()
00032 {
00033
00034 }
00035
00036 void CPowerPage::DoDataExchange(CDataExchange* pDX)
00037 {
00038         CCfgPropPage::DoDataExchange(pDX);
00039         //{{AFX_DATA_MAP(CPowerPage)
00040         //}}AFX_DATA_MAP
00041         DDX_Control(pDX, IDC_STATIC_POWER_PAGE, m_PowerPageLabel);
00042         DDX_Control(pDX, IDC_STATIC_POWER_ADVANCED, m_PowerAdvancedLabel);
00043         DDX_Control(pDX, IDC_STATIC_POWER_STANDARD, m_PowerStandardLabel);
00044         DDX_Control(pDX, IDC_STATIC_HV_SIGN1, m_PowerHvSign1);
00045         DDX_Control(pDX, IDC_STATIC_HV_SIGN2, m_PowerHvSign2);
00046         DDX_Control(pDX, IDC_STATIC_HV_WARNING, m_PowerHvWarning);
00047
00048 }
00049
00050 BEGIN_MESSAGE_MAP(CPowerPage, CCfgPropPage)
00051         //{{AFX_MSG_MAP(CPowerPage)
00052         //}}AFX_MSG_MAP
00053         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PAPS, OnCbnSelchangeOptComboPaps)
00054         ON_CBN_SELCHANGE(IDC_OPT_COMBO_HVSE, OnCbnSelchangeOptComboHvse)
00055         ON_CBN_SELCHANGE(IDC_OPT_COMBO_TECS, OnCbnSelchangeOptComboTecs)
00056         ON_EN_CHANGE(IDC_OPT_TEXT_HVSE, OnEnChangeOptTextHvse)
00057         ON_EN_CHANGE(IDC_OPT_TEXT_TECS, OnEnChangeOptTextTecs)
00058         ON_CBN_SELCHANGE(IDC_OPT_COMBO_BOOT, OnCbnSelchangeOptComboBoot)
00059         ON_BN_CLICKED(IDC_RADIO_HV_SIGN1, OnBnClickedRadioHvSign1)
00060         ON_BN_CLICKED(IDC_RADIO_HV_SIGN2, OnBnClickedRadioHvSign2)
00061
00062         ON_COMMAND(ID_HELP, OnHelp)
00063         ON_WM_HELPINFO()
00064
00065 END_MESSAGE_MAP()
00066
00068 // CPowerPage message handlers
00069
00070 BOOL CPowerPage::OnSetActive()
00071 {
00072         // TODO: Add your specialized code here and/or call the base class
00073         if (s.ReloadCfg) {
00074                 InitControls();
00075         } else {
00076                 SetHvPowerWarning();
00077         }
00078
00079         return CCfgPropPage::OnSetActive();
00080 }
00081
00082 void CPowerPage::Init_PAPS_Controls()
00083 {
00084         CComboBox* pCombo;
00085         if ((s.profile->device_type == dppDP5G) || (s.profile->device_type == dppTB5)) {
00086                 GetDlgItem(IDC_OPT_FRAME_PAPS)->ShowWindow(SW_HIDE);
00087                 GetDlgItem(IDC_OPT_COMBO_PAPS)->ShowWindow(SW_HIDE);
00088                 GetDlgItem(IDC_OPT_UNITS_PAPS)->ShowWindow(SW_HIDE);
00089         } else if ((s.profile->device_type == dppDP5) || (s.profile->device_type == dppDP5X)) {
00090                 pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_PAPS);
00091                 pCombo->ResetContent();
00092                 pCombo->AddString("8.5");
00093                 pCombo->AddString("5");
00094                 pCombo->AddString("OFF");
00095                 pCombo->AddString("ON");
00096         } else if ((s.profile->device_type == dppPX5) && (s.DP5Stat.m_DP5_Status.DPP_options == PX5_OPTION_HPGe_HVPS)) {
00097                 pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_PAPS);
00098                 pCombo->ResetContent();
00099                 pCombo->AddString("OFF");
00100                 pCombo->AddString("ON");
00101         } else if (s.profile->device_type == dppPX5) {
00102                 pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_PAPS);
00103                 pCombo->ResetContent();
00104                 pCombo->AddString("8.5");
00105                 pCombo->AddString("5");
00106                 pCombo->AddString("OFF");
00107         }
00108 }
00109
00110 BOOL CPowerPage::OnInitDialog()
00111 {
00112         CCfgPropPage::OnInitDialog();
00113
00114         BuildToolTips();
00115
00116         Init_PAPS_Controls();
00117
00118         CComboBox* pComboHV;
00119         pComboHV = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_HVSE);
00120         pComboHV->SetCurSel(0);
00121         GetDlgItem(IDC_OPT_TEXT_HVSE)->SetWindowText("0");
00122
00123         SetHVSign(TRUE);        // TRUE == + (pos)
00124
00125         m_PowerPageLabel
00126                 .SetFontName("Arial")
00127                 .SetFontSize(24)
00128                 .SetTextColor(RGB(0,0,255))
00129                 .SetBkColor(RGB(244, 243, 238))
00130                 .SetFontItalic(TRUE)
00131                 .SetFontBold(TRUE);
00132
00133         m_PowerAdvancedLabel
00134                 .SetFontName("Arial")
00135                 .SetFontSize(18)
00136                 .SetTextColor(RGB(0, 70, 213))
00137                 .SetBkColor(RGB(246, 245, 241))
00138                 .SetFontItalic(TRUE)
00139                 .SetFontBold(FALSE);
00140
00141         m_PowerStandardLabel
00142                 .SetFontName("Arial")
00143                 .SetFontSize(18)
00144                 .SetTextColor(RGB(0, 70, 213))
00145                 .SetBkColor(RGB(252, 252, 253))
00146                 .SetFontItalic(TRUE)
00147                 .SetFontBold(FALSE);
00148
00149         m_PowerHvSign1
00150                 .SetFontName("Arial")
00151                 .SetFontSize(24)
00152                 .SetTextColor(RGB(0, 0, 255))
00153                 .SetBkColor(RGB(252, 252, 253))
00154                 .SetFontItalic(FALSE)
00155                 .SetFontBold(TRUE);
00156
00157         m_PowerHvSign2
00158                 .SetFontName("Arial")
00159                 .SetFontSize(24)
00160                 .SetTextColor(RGB(255, 0, 0))
00161                 .SetBkColor(RGB(252, 252, 253))
00162                 .SetFontItalic(FALSE)
00163                 .SetFontBold(TRUE);
00164
00165         m_PowerHvWarning
00166                 .SetFontName("Arial")
00167                 .SetFontSize(12)
00168                 .SetTextColor(RGB(255, 0, 0))
00169                 .SetBkColor(RGB(247, 246, 243))
00170                 .SetFontItalic(FALSE)
00171                 .SetFontBold(TRUE);
00172
00173         InitControls();
00174
00175         // TODO:  Add extra initialization here
00176
00177         return TRUE;  // return TRUE unless you set the focus to a control
00178         // EXCEPTION: OCX Property Pages should return FALSE
00179 }
00180
00181 //dciPAPS       PAPS    IDC_OPT_COMBO_PAPS      0                                       dctCbo          dcgPower        PreAmp 8.5/5 (N/A)      V
00182 //dciHVSE       HVSE    IDC_OPT_COMBO_HVSE      IDC_OPT_TEXT_HVSE       dctCboTxt       dcgPower        HV Set  V
00183 //dciTECS       TECS    IDC_OPT_COMBO_TECS      IDC_OPT_TEXT_TECS       dctCboTxt       dcgPower        TEC Set K
00184
00185 void CPowerPage::InitControls()
00186 {
00187         HWND hPage = this->GetSafeHwnd();
00188         BOOL bEnableTECS;
00189         BOOL bEnableHVSE;
00190         BOOL bEnableBOOT;
00191         int DppType;
00192
00193         DppType = s.profile->device_type;
00194     bEnableTECS = (((DppType == dppDP5) && s.DP5Stat.m_DP5_Status.PC5_PRESENT) || (DppType == dppPX5) || (DppType == dppDP5X));
00195     bEnableHVSE = (((DppType != dppPX5) && s.DP5Stat.m_DP5_Status.PC5_PRESENT) || (DppType == dppPX5));
00196         bEnableBOOT = ((DppType == dppDP5) || (DppType == dppDP5X));
00197
00198         GetDlgItem(IDC_OPT_FRAME_TECS)->EnableWindow(bEnableTECS);
00199         GetDlgItem(IDC_OPT_COMBO_TECS)->EnableWindow(bEnableTECS);
00200         GetDlgItem(IDC_OPT_TEXT_TECS)->EnableWindow(bEnableTECS);
00201         GetDlgItem(IDC_OPT_LIMITS_TECS)->EnableWindow(bEnableTECS);
00202         GetDlgItem(IDC_OPT_UNITS_TECS)->EnableWindow(bEnableTECS);
00203
00204         GetDlgItem(IDC_OPT_FRAME_HVSE)->EnableWindow(bEnableHVSE);
00205         GetDlgItem(IDC_OPT_COMBO_HVSE)->EnableWindow(bEnableHVSE);
00206         GetDlgItem(IDC_OPT_TEXT_HVSE)->EnableWindow(bEnableHVSE);
00207         GetDlgItem(IDC_OPT_LIMITS_HVSE)->EnableWindow(bEnableHVSE);
00208         GetDlgItem(IDC_OPT_UNITS_HVSE)->EnableWindow(bEnableHVSE);
00209
00210         // Enable/Disable HV Polarity Controls
00211         GetDlgItem(IDC_RADIO_HV_SIGN1)->EnableWindow(bEnableHVSE);
00212         GetDlgItem(IDC_RADIO_HV_SIGN2)->EnableWindow(bEnableHVSE);
00213         GetDlgItem(IDC_STATIC_HV_SIGN1)->EnableWindow(bEnableHVSE);
00214         GetDlgItem(IDC_STATIC_HV_SIGN2)->EnableWindow(bEnableHVSE);
00215
00216         GetDlgItem(IDC_OPT_FRAME_BOOT)->EnableWindow(bEnableBOOT);
00217         GetDlgItem(IDC_OPT_COMBO_BOOT)->EnableWindow(bEnableBOOT);
00218
00219         InitDlgItem(hPage,s.m_DP5Cfg[dciPAPS]);
00220         InitDlgItem(hPage,s.m_DP5Cfg[dciHVSE]);
00221
00222         // HPGe option +/-5000V
00223         if ((s.profile->device_type == dppPX5) && (s.DP5Stat.m_DP5_Status.DPP_options == PX5_OPTION_HPGe_HVPS)) {
00224                 GetDlgItem(IDC_OPT_LIMITS_HVSE)->SetWindowText(_T("0 to 5000V (+HV) or 0 to -5000V (-HV)"));
00225         }
00226
00227         InitDlgItem(hPage,s.m_DP5Cfg[dciTECS]);
00228         InitDlgItem(hPage,s.m_DP5Cfg[dciBOOT]);
00229         CboUpdate(dciPAPS);
00230         CboUpdate(dciHVSE);
00231         CboUpdate(dciTECS);
00232         CboUpdate(dciBOOT);
00233
00234         //if (s.profile->device_type == dppMCA8000D) {
00235         //      ShowMCA8000D_Controls(SW_HIDE);
00236         //} else {
00237         //      ShowMCA8000D_Controls(SW_SHOW);
00238         //}
00239 }
00240
00241 void CPowerPage::ShowMCA8000D_Controls(int iShowWin)
00242 {
00243         GetDlgItem(IDC_OPT_COMBO_BOOT)->ShowWindow(iShowWin);
00244         GetDlgItem(IDC_OPT_COMBO_HVSE)->ShowWindow(iShowWin);
00245         GetDlgItem(IDC_OPT_COMBO_PAPS)->ShowWindow(iShowWin);
00246
00247         GetDlgItem(IDC_OPT_COMBO_TECS)->ShowWindow(iShowWin);
00248         GetDlgItem(IDC_OPT_FRAME_BOOT)->ShowWindow(iShowWin);
00249         GetDlgItem(IDC_OPT_FRAME_HVSE)->ShowWindow(iShowWin);
00250         GetDlgItem(IDC_OPT_FRAME_PAPS)->ShowWindow(iShowWin);
00251         GetDlgItem(IDC_OPT_FRAME_TECS)->ShowWindow(iShowWin);
00252         GetDlgItem(IDC_OPT_LIMITS_HVSE)->ShowWindow(iShowWin);
00253         GetDlgItem(IDC_OPT_LIMITS_TECS)->ShowWindow(iShowWin);
00254         GetDlgItem(IDC_OPT_TEXT_HVSE)->ShowWindow(iShowWin);
00255         GetDlgItem(IDC_OPT_TEXT_TECS)->ShowWindow(iShowWin);
00256         GetDlgItem(IDC_OPT_UNITS_HVSE)->ShowWindow(iShowWin);
00257         GetDlgItem(IDC_OPT_UNITS_PAPS)->ShowWindow(iShowWin);
00258         GetDlgItem(IDC_OPT_UNITS_TECS)->ShowWindow(iShowWin);
00259
00260         GetDlgItem(IDC_STATIC_HV_SIGN1)->ShowWindow(iShowWin);
00261         GetDlgItem(IDC_STATIC_HV_SIGN2)->ShowWindow(iShowWin);
00262         GetDlgItem(IDC_RADIO_HV_SIGN1)->ShowWindow(iShowWin);
00263         GetDlgItem(IDC_RADIO_HV_SIGN2)->ShowWindow(iShowWin);
00264
00265 }
00266
00267 void CPowerPage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00268 {
00269         int cboDP5CtrlID = cfg.ListCtrlID;
00270         int txtDP5CtrlID = cfg.TextCtrlID;
00271         CString strVal = cfg.Setting;
00272         int idxList;
00273         CString strUnits;
00274         CString strLimits;
00275
00276         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00277                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00278                 //idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00279                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00280                 if (idxList == LB_ERR) {
00281                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00282                 }
00283                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00284                         if ((cfg.CtrlType & dctTxt) > 0) {      // if cbotxt must find mask, else set to 0
00285                                 cfg.TextValue = cfg.Setting;            // overwrite if currently editing
00286                                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"#");
00287                                 if (idxList == LB_ERR) { // mask begins with +
00288                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"+");
00289                                 }
00290                                 if (idxList == LB_ERR) { // mask begins with -
00291                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"-");
00292                                 }
00293                                 if (idxList == LB_ERR) { // not found default to 0
00294                                         idxList = 0;
00295                                 }
00296                         } else {
00297                                 idxList = 0;            // set to first item
00298                         }
00299                 }
00300                 cb.SetCurSel(idxList);
00301         }
00302         if ((cfg.CtrlType & dctTxt) > 0) {
00303                 if ((cfg.CtrlType & dctCbo) == 0) {             // cbo update above
00304                         if (cfg.Setting.GetLength() > 0) {
00305                                 cfg.TextValue = cfg.Setting;
00306                         }
00307                 }
00308                 GetDlgItem(txtDP5CtrlID)->SetWindowText(cfg.TextValue);
00309                 strUnits = cfg.Units;
00310                 strLimits = cfg.Limits;
00311                 switch (txtDP5CtrlID) {
00312                         case IDC_OPT_TEXT_HVSE:
00313                                 UNIT_INIT(HVSE, strUnits);
00314                                 LIMIT_INIT(HVSE, strLimits);
00315                                 break;
00316                         case IDC_OPT_TEXT_TECS:
00317                                 UNIT_INIT(TECS, strUnits);
00318                                 LIMIT_INIT(TECS, strLimits);
00319                                 break;
00320                 }
00321         }
00322 }
00323
00324 // pass dci id to update combo control and display edit controls if any
00325 void CPowerPage::CboUpdate(int nID_dci)
00326 {
00327         CString strCboText;
00328         int nID;
00329         int CmdShow;
00330
00331         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00332         if (nID == NULL) { return; }
00333         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00334         int idx = cb.GetCurSel();
00335         if (idx > LB_ERR) {
00336                 cb.GetLBText(idx,strCboText);
00337                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00338                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00339         } else {
00340                 return;
00341         }
00342         if (s.m_DP5Cfg[nID_dci].CtrlType == dctCboTxt) {
00343                 if (strCboText.Find('#') >= 0) {
00344                         CmdShow = SW_SHOW;
00345                 } else {
00346                         CmdShow = SW_HIDE;
00347                 }
00348                 switch (nID) {
00349                         case IDC_OPT_COMBO_HVSE:
00350                                 ALL_VIS(HVSE, CmdShow);
00351                                 CBO_TEXT_VIS(HVSE, (CmdShow!=0));
00352                                 break;
00353                         case IDC_OPT_COMBO_TECS:
00354                                 ALL_VIS(TECS, CmdShow);
00355                                 CBO_TEXT_VIS(TECS, (CmdShow!=0));
00356                                 break;
00357                 }
00358         }
00359         SetModified(TRUE);
00360 }
00361
00362 //CBO_TEXT_VIS(RESL, (CmdShow!=0));
00363 //CboTextVis(IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,(CmdShow!=0));
00364 //void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00365 void CPowerPage::CboTextVis(int nIdCbox, int nIdEdit, BOOL isText)
00366 {
00367         UINT ddSize;
00368         RECT lpRect;
00369         CEdit* pEdit;
00370         CComboBox* pCombo;
00371         int btnSize = 20;
00372
00373         pEdit = (CEdit*)GetDlgItem(nIdEdit);            // cast to edit for rect
00374         pEdit->GetRect(&lpRect);                                        // get rect
00375         ddSize = lpRect.right - lpRect.left;            // save width
00376         if (isText) {
00377                 GetDlgItem(nIdEdit)->ShowWindow(SW_SHOW);
00378                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);
00379                 pCombo->GetWindowRect(&lpRect);
00380                 ScreenToClient(&lpRect);
00381                 //int ddSize1 = lpRect.right - lpRect.left;             // save width
00382                 //TRACE("Combo Edit %d\r\n",ddSize1);
00383                 lpRect.right = lpRect.left + btnSize;
00384                 pCombo->MoveWindow(&lpRect,TRUE);
00385                 pCombo->SetDroppedWidth(ddSize + btnSize);
00386         } else {
00387                 GetDlgItem(nIdEdit)->ShowWindow(SW_HIDE);       // hide edit
00388                 //TRACE("Edit %d\r\n",ddSize);
00389                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);       // cast to combo
00390                 pCombo->GetWindowRect(&lpRect);                         // get win size
00391                 ScreenToClient(&lpRect);                                        // adjust to screen
00392                 //int ddSize2 = lpRect.right - lpRect.left;             // save width
00393                 //TRACE("Combo %d\r\n",ddSize2);
00394                 lpRect.right = lpRect.left + ddSize + btnSize;  // get restored combo size
00395                 pCombo->MoveWindow(&lpRect,TRUE);                       // restore combo
00396                 pCombo->SetDroppedWidth(ddSize);                        // restore combo
00397         }
00398 }
00399
00400 // pass dci id to update combo control and display edit controls if any
00401 void CPowerPage::TextUpdate(int nID_dci)
00402 {
00403         CString strText;
00404         int nID;
00405         int iHV;
00406
00407         nID = s.m_DP5Cfg[nID_dci].TextCtrlID;
00408         if (nID == NULL) { return; }
00409
00410         GetDlgItem(nID)->GetWindowText(strText);
00411         if (nID == IDC_OPT_TEXT_HVSE)
00412         {
00413                 if (isHVSignInString(strText)) {                // test/remove the sign in the string
00414                         if (s.DppConfig.bConfigHVPolarity != isHVSignPositive(strText)) {       // test for sign change
00415                                 SetHVSign(isHVSignPositive(strText));           // if so change sign
00416                         }
00417                         iHV = abs(atoi(strText));                                       // save abs value in text
00418                         strText.Format("%d",iHV);                                       // prep for save
00419                         GetDlgItem(nID)->SetWindowText(strText);        // save abs to control
00420                 }
00421                 if (!s.DppConfig.bConfigHVPolarity) { strText = "-" + strText; }                // fix sign for data save
00422                 //AfxMessageBox(strText);
00423         }
00424         s.m_DP5Cfg[nID_dci].TextValue = strText;
00425         SetModified(TRUE);
00426 }
00427
00428 void CPowerPage::OnCbnSelchangeOptComboPaps()
00429 {
00430         CboUpdate(dciPAPS);
00431 }
00432
00433 void CPowerPage::OnCbnSelchangeOptComboBoot()
00434 {
00435         CboUpdate(dciBOOT);
00436 }
00437
00438 void CPowerPage::OnCbnSelchangeOptComboHvse()
00439 {
00440         CboUpdate(dciHVSE);
00441 }
00442
00443 void CPowerPage::OnCbnSelchangeOptComboTecs()
00444 {
00445         CboUpdate(dciTECS);
00446 }
00447
00448 void CPowerPage::OnEnChangeOptTextHvse()
00449 {
00450         TextUpdate(dciHVSE);
00451 }
00452
00453 void CPowerPage::OnEnChangeOptTextTecs()
00454 {
00455         TextUpdate(dciTECS);
00456 }
00457
00458 BOOL CPowerPage::PreTranslateMessage(MSG* pMsg)
00459 {
00460         // TODO: Add your specialized code here and/or call the base class
00461
00462         //==================================================================
00463         MSG msg = *pMsg;
00464         if (msg.message == WM_MOUSEMOVE) {      // Relay events to the tooltip control
00465                 msg.hwnd = (HWND)m_ToolTip.SendMessage(TTM_WINDOWFROMPOINT, 0, (LPARAM)&msg.pt);
00466                 CPoint pt = pMsg->pt;
00467                 ::ScreenToClient(msg.hwnd, &pt);
00468                 msg.lParam = MAKELONG(pt.x, pt.y);
00469                 m_ToolTip.Activate(TRUE);   // make sure tooltip is active
00470                 m_ToolTip.RelayEvent(&msg); // Let the ToolTip process this message.
00471         } else if ( pMsg->message == WM_KEYDOWN && pMsg->wParam == VK_RETURN ) {
00472                 CWnd* pCurrent= GetFocus();
00473                 int ctrl = pCurrent->GetDlgCtrlID();
00474                 //if (ctrl == IDC_OPT_TEXT_MCST) {
00475                 if (isCEditBox(ctrl)) {
00476                         ::SendMessage(this->m_hWnd, WM_COMMAND, MAKEWPARAM(ctrl, EN_CHANGE), (LPARAM) m_hWnd);
00477                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00478                         pMsg->wParam = VK_TAB;
00479                         //if ( pNext != NULL ) {
00480                         //      if (pNext->GetDlgCtrlID() != IDOK ) {
00481                         //              pNext->SetFocus();
00482                         //              return TRUE;
00483                         //      }
00484                         //}
00485                 } else if (isCComboBox(ctrl)) {
00486                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00487                         pMsg->wParam = VK_TAB;
00488                 }
00489         }
00490
00491         //==================================================================
00492         return CCfgPropPage::PreTranslateMessage(pMsg);
00493 }
00494
00495 BOOL CPowerPage::isCEditBox(int nID)
00496 {
00497         BOOL isEdit = FALSE;
00498         switch (nID) {
00499                 case IDC_OPT_TEXT_HVSE:
00500                         isEdit = TRUE;
00501                         break;
00502                 case IDC_OPT_TEXT_TECS:
00503                         isEdit = TRUE;
00504                         break;
00505         }
00506         return isEdit;
00507 }
00508
00509 BOOL CPowerPage::isCComboBox(int nID)
00510 {
00511         BOOL isCombo = FALSE;
00512         switch (nID) {
00513                 case IDC_OPT_COMBO_PAPS:
00514                         isCombo = TRUE;
00515                         break;
00516                 case IDC_OPT_COMBO_BOOT:
00517                         isCombo = TRUE;
00518                         break;
00519                 case IDC_OPT_COMBO_HVSE:
00520                         isCombo = TRUE;
00521                         break;
00522                 case IDC_OPT_COMBO_TECS:
00523                         isCombo = TRUE;
00524                         break;
00525         }
00526         return isCombo;
00527 }
00528
00529 void CPowerPage::SetHVSign(BOOL isPOS)
00530 {
00531         CButton *chkEnable;
00532         chkEnable = (CButton *)GetDlgItem(IDC_RADIO_HV_SIGN1);   //+ (pos)
00533         chkEnable->SetCheck(isPOS);
00534         s.DppConfig.bConfigHVPolarity = isPOS;
00535         CButton *chkDisable;
00536         chkDisable = (CButton *)GetDlgItem(IDC_RADIO_HV_SIGN2);  //- (neg)
00537         chkDisable->SetCheck(!isPOS);
00538         SetHvPowerWarning();
00539 }
00540
00541 BOOL CPowerPage::isHVSignInString(CString strHV)
00542 {
00543         int iFound;
00544         iFound = strHV.FindOneOf("+-");
00545         return (iFound > -1);
00546 }
00547
00548 BOOL CPowerPage::isHVSignPositive(CString strHV)
00549 {
00550         int iFound;
00551         iFound = strHV.Find('-');
00552         return (iFound == -1);
00553 }
00554
00555 void CPowerPage::OnBnClickedRadioHvSign1()
00556 {
00557         SetHVSign(TRUE);        // TRUE == + (pos)
00558         TextUpdate(dciHVSE);
00559 }
00560
00561 void CPowerPage::OnBnClickedRadioHvSign2()
00562 {
00563         SetHVSign(FALSE);       // FALSE == - (neg)
00564         TextUpdate(dciHVSE);
00565 }
00566
00567 //s.DppConfig.bGammaRadHVMode;          // GammaRad HV
00568 //s.DppConfig.bConfigHVPolarity;        // Detector HV Polarity, for setup warnings
00569 //s.DppConfig.bPC5Detected;                     // PC5 connected,PX5 HV Pwr Error
00570 //s.DppConfig.bBootHVPolarity;          // HV Polarity from status packet
00571 //s.DppConfig.bAnalogPolarity;          // Analog Input Polarity, for setup warnings
00572 //m_PowerHvWarning==IDC_STATIC_HV_WARNING
00573 void CPowerPage::SetHvPowerWarning()
00574 {
00575         CString strPolarity;
00576         CString strWarning;
00577         m_PowerHvWarning.ShowWindow(SW_HIDE);
00578         if (s.isDppConnected) {
00579                 // disable warnings for px5 with HPGe option
00580                 if ((s.profile->device_type == dppPX5) && (s.DP5Stat.m_DP5_Status.DPP_options == PX5_OPTION_HPGe_HVPS)) {
00581                         return;
00582                 }
00583                 if (s.DppConfig.bPC5Detected) {
00584                         if (s.DppConfig.bAnalogPolarity == s.DppConfig.bConfigHVPolarity) {
00585                                 m_PowerHvWarning.ShowWindow(SW_SHOW);
00586                                 strWarning = " Input and HV polarity \r incorrect for Amptek detectors";
00587                                 if (s.DppConfig.bConfigHVPolarity) {
00588                                         strPolarity = " \r BOTH + (POS)";
00589                                 } else {
00590                                         strPolarity = " \r BOTH - (NEG)";
00591                                 }
00592                                 m_PowerHvWarning.SetWindowText(strWarning + strPolarity);
00593                         } else {
00594                                 m_PowerHvWarning.SetWindowText("");
00595                         }
00596                 } else if (s.profile->device_type == dppPX5) {
00597                         m_PowerHvWarning.ShowWindow(SW_SHOW);
00598                         m_PowerHvWarning.SetWindowText("PX5 HV Power Error");
00599                 } else {        // no pc5 or hv detected
00600                         m_PowerHvWarning.SetWindowText("");
00601                 }
00602         } else {                // not connected
00603                 m_PowerHvWarning.SetWindowText("");
00604         }
00605 }
00606
00608 // HtmlHelp for shared dialog
00609 // NOTE: shared dialogs use string type IDD, not global IDD
00610 BOOL CPowerPage::OnHelpInfo(HELPINFO* pHelpInfo)
00611 {
00612         CString strHelp;
00613         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
00614                 if (pHelpInfo->dwContextId == 0) {
00615                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_POWER_PAGE);
00616                 } else {
00617                         //
00618                 }
00619         }
00620         return true;
00621 }
00622
00623 void CPowerPage::OnHelp()                               // enable property sheet help button help
00624 {
00625         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_POWER_PAGE);
00626     //SendMessage(WM_COMMANDHELP);      //
00627 }
00629
00630 void CPowerPage::BuildToolTips()
00631 {
00632         if (!m_ToolTip.Create(this)) {
00633                 TRACE0("Unable to create ToolTip control\n");
00634         } else {
00635         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_BOOT), IDS_TT_PC__ON_AT_STARTUP);
00636         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_BOOT), IDS_TT_PC__ON_AT_STARTUP);
00637
00638         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_HVSE), IDS_TT_HIGH_VOLTAGE_BIAS);
00639         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_HVSE), IDS_TT_HIGH_VOLTAGE_BIAS);
00640         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_HVSE), IDS_TT_HIGH_VOLTAGE_BIAS);
00641         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_HVSE), IDS_TT_HIGH_VOLTAGE_BIAS);
00642         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_HVSE), IDS_TT_HIGH_VOLTAGE_BIAS);
00643
00644         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PAPS), IDS_TT_PREAMP_VOLTAGE);
00645         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PAPS), IDS_TT_PREAMP_VOLTAGE);
00646                 m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PAPS), IDS_TT_PREAMP_VOLTAGE);
00647
00648         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TECS), IDS_TT_COOLER_TEMPERATURE);
00649         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_TECS), IDS_TT_COOLER_TEMPERATURE);
00650         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_TECS), IDS_TT_COOLER_TEMPERATURE);
00651         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_TECS), IDS_TT_COOLER_TEMPERATURE);
00652         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_TECS), IDS_TT_COOLER_TEMPERATURE);
00653
00654         m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_HV_SIGN1), IDS_TT_HIGH_VOLTAGE_POLARITY);
00655         m_ToolTip.AddTool(GetDlgItem(IDC_RADIO_HV_SIGN1), IDS_TT_HIGH_VOLTAGE_POLARITY);
00656         m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_HV_SIGN2), IDS_TT_HIGH_VOLTAGE_POLARITY);
00657         m_ToolTip.AddTool(GetDlgItem(IDC_RADIO_HV_SIGN2), IDS_TT_HIGH_VOLTAGE_POLARITY);
00658
00659                 m_ToolTip.Activate(TRUE);
00660                 m_ToolTip.SetMaxTipWidth(200);
00661         }
00662 }
00663
00664
00665
00666
00667
00668
00669
00670
00671
00672
00673
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/PowerPage.h Source File

DP5Cfg/PowerPage.h
Go to the documentation of this file.
00001 #if !defined(AFX_PowerPage_H__INCLUDED_)
00002 #define AFX_PowerPage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // PowerPage.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "afxwin.h"
00012 #include "label.h"
00013
00015 // CPowerPage dialog
00016
00017 class CPowerPage : public CCfgPropPage
00018 {
00019         DECLARE_DYNCREATE(CPowerPage)
00020
00021 // Construction
00022 public:
00023         CPowerPage();
00024         ~CPowerPage();
00025
00026 // Dialog Data
00027         //{{AFX_DATA(CPowerPage)
00028         //enum { IDD = IDD_POWER_PAGE };
00029         //}}AFX_DATA
00030
00031
00032 // Overrides
00033         // ClassWizard generate virtual function overrides
00034         //{{AFX_VIRTUAL(CPowerPage)
00035         protected:
00036         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00037         //}}AFX_VIRTUAL
00038
00039 // Implementation
00040 protected:
00041         // Generated message map functions
00042         //{{AFX_MSG(CPowerPage)
00043         //}}AFX_MSG
00044         DECLARE_MESSAGE_MAP()
00045         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00046
00047 public:
00048         void BuildToolTips();                                                           // Tooltip control
00049
00050         //CStatic m_PowerPageLabel;
00051         CLabel m_PowerPageLabel;
00052         //CStatic m_PowerAdvancedLabel;
00053         CLabel m_PowerAdvancedLabel;
00054         //CStatic m_PowerStandardLabel;
00055         CLabel m_PowerStandardLabel;
00056         //CStatic m_PowerHvSign1;
00057         CLabel m_PowerHvSign1;
00058         //CStatic m_PowerHvSign2;
00059         CLabel m_PowerHvSign2;
00060         //CStatic m_PowerHvWarning;
00061         CLabel m_PowerHvWarning;
00062
00063         virtual BOOL OnSetActive();
00064         virtual BOOL OnInitDialog();
00065
00066         void InitControls();
00067         void ShowMCA8000D_Controls(int iShowWin);
00068
00069         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00070         void CboUpdate(int nID_dci);
00071         void TextUpdate(int nID_dci);
00072         void Init_PAPS_Controls();
00073
00074         afx_msg void OnCbnSelchangeOptComboPaps();
00075         afx_msg void OnCbnSelchangeOptComboHvse();
00076         afx_msg void OnCbnSelchangeOptComboTecs();
00077         afx_msg void OnEnChangeOptTextHvse();
00078         afx_msg void OnEnChangeOptTextTecs();
00079
00080         void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00081
00082         virtual BOOL PreTranslateMessage(MSG* pMsg);
00083         BOOL isCEditBox(int nID);
00084         BOOL isCComboBox(int nID);
00085         afx_msg void OnCbnSelchangeOptComboBoot();
00086         void SetHVSign(BOOL isPOS);
00087         afx_msg void OnBnClickedRadioHvSign1();
00088         afx_msg void OnBnClickedRadioHvSign2();
00089         BOOL isHVSignInString(CString strHV);
00090         BOOL isHVSignPositive(CString strHV);
00091         void SetHvPowerWarning();
00092
00093         afx_msg void OnHelp();
00094         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00095
00096 };
00097
00098 //{{AFX_INSERT_LOCATION}}
00099 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00100
00101 #endif // !defined(AFX_PowerPage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/PowerPageRes.h Source File

DP5Cfg/PowerPageRes.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by PowerPage.rc
00004 //
00005 #define IDC_OPT_COMBO_BOOT              1536
00006 #define IDC_OPT_COMBO_HVSE              1537
00007 #define IDC_OPT_COMBO_PAPS              1538
00008 #define IDC_OPT_COMBO_TECS              1540
00009 #define IDC_OPT_FRAME_BOOT              1541
00010 #define IDC_OPT_FRAME_HVSE              1542
00011 #define IDC_OPT_FRAME_PAPS              1543
00012 #define IDC_OPT_FRAME_TECS              1545
00013 #define IDC_OPT_LIMITS_HVSE             1546
00014 #define IDC_OPT_LIMITS_TECS             1548
00015 #define IDC_OPT_TEXT_HVSE               1549
00016 #define IDC_OPT_TEXT_TECS               1551
00017 #define IDC_OPT_UNITS_HVSE              1552
00018 #define IDC_OPT_UNITS_PAPS              1553
00019 #define IDC_OPT_UNITS_TECS              1555
00020 #define IDC_RADIO_HV_SIGN1              1556
00021 #define IDC_RADIO_HV_SIGN2              1557
00022 #define IDC_STATIC_HV_SIGN1             1558
00023 #define IDC_STATIC_HV_SIGN2             1559
00024 #define IDC_STATIC_HV_WARNING           1560
00025 #define IDC_STATIC_POWER_ADVANCED       1561
00026 #define IDC_STATIC_POWER_BASIC          1562
00027 #define IDC_STATIC_POWER_PAGE           1563
00028 #define IDC_STATIC_POWER_STANDARD       1564
00029 #define IDS_TT_COOLER_TEMPERATURE       5632
00030 #define IDS_TT_HIGH_VOLTAGE_BIAS        5633
00031 #define IDS_TT_HIGH_VOLTAGE_POLARITY    5634
00032 #define IDS_TT_PREAMP_VOLTAGE           5635
00033 #define IDS_TT_PC__ON_AT_STARTUP        5636
00034
00035 // Next default values for new objects
00036 //
00037 #ifdef APSTUDIO_INVOKED
00038 #ifndef APSTUDIO_READONLY_SYMBOLS
00039 #define _APS_NEXT_RESOURCE_VALUE        5637
00040 #define _APS_NEXT_COMMAND_VALUE         33360
00041 #define _APS_NEXT_CONTROL_VALUE         1565
00042 #define _APS_NEXT_SYMED_VALUE           5637
00043 #endif
00044 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Roi.cpp Source File

Roi.cpp
Go to the documentation of this file.
00001
00002 // Module Roi
00003 //
00004 // Roi manipulation and definition functions
00005 //
00006 // Rev. 1.0     February 22, 1999
00008
00009 #include "stdafx.h"
00010 #include "SCommon.h"
00011 #include "Roi.h"
00012 #include ".\roi.h"
00013
00014 #ifdef _DEBUG
00015 #undef THIS_FILE
00016 static char THIS_FILE[]=__FILE__;
00017 #define new DEBUG_NEW
00018 #endif
00019
00020 static const char *roi_stat[] =
00021         {"INVALID", "BAD", "MARGINAL", "GOOD"};
00022
00023 void CRoi::Remove(int i)
00024 {
00025     RemoveAt(i);
00026     if (m_selectIndex == i)
00027         m_selectIndex = -1;
00028     else if (m_selectIndex > i)
00029         m_selectIndex--;
00030     m_count--;
00031 }
00032
00033 void CRoi::Insert(int i, int st, int en)
00034 {
00035     InsertAt(i, CRoiEntry(st, en));
00036     m_count++;
00037     if (m_selectIndex >= i)
00038         m_selectIndex++;
00039 }
00040
00041 int CRoi::InsertSorted(int st, int en)
00042 {
00043     int i;
00044     if (st < en)
00045     {
00046         for (i = 0; i < m_count; i++)
00047         {
00048             if (st < ElementAt(i).m_start)
00049                 break;
00050         }
00051         Insert(i, st, en);
00052     }
00053     else
00054         i = -1;
00055     return i;
00056 }
00057
00058 void CRoi::Clear(void)
00059 {
00060     RemoveAll();
00061     m_count = 0;
00062     m_selectIndex = -1;
00063 }
00064
00065 int CRoi::AtChannel(int chan)
00066 {
00067     int i;
00068     for (i = 0; i < m_count; i++)
00069     {
00070         if (ElementAt(i).m_start <= chan &&
00071                 ElementAt(i).m_end >= chan)
00072             break;
00073     }
00074     if (i == m_count)
00075         i = -1;
00076     return i;
00077 }
00078
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SCommon.cpp Source File

SCommon.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "SCommon.h"
00003 #include <time.h>
00004 #include <math.h>
00005
00006 #include "MiscPageRes.h"
00007 #include "PowerPageRes.h"
00008 #include "ShapingPageRes.h"
00009 #include "FilePageRes.h"
00010 #include "GainPzPageRes.h"
00011 #include "McaPageRes.h"
00012
00013 CSCommon::CSCommon(void)
00014 {
00015         profile = &profileCls;
00016
00017         HaveConfig = FALSE;
00018         ReloadCfg = FALSE;
00019         FindCommand = FALSE;
00020         FindCtrlID = 0;
00021
00022         plot = &m_plot;                                                                 // point to CPlot class to operate like DppMCA
00023         spectraList.m_currentSpectrum = &m_Spectrum;    // point to CSpectrum class to operate like DppMCA
00024
00025         // seed random number generator
00026         srand((unsigned)time(NULL));    //Seed the random-number generator with current time
00027 }
00028
00029 CSCommon::~CSCommon(void)
00030 {
00031 }
00032
00033 CString CSCommon::Get(LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
00034 {
00035         return(theApp.GetProfileString(profile, entry, def));
00036 }
00037
00038 int CSCommon::Get(LPCTSTR profile, LPCTSTR entry, int def)
00039 {
00040         return(theApp.GetProfileInt(profile, entry, def));
00041 }
00042
00043 BOOL CSCommon::Put(LPCTSTR profile, LPCTSTR entry, LPCTSTR def)
00044 {
00045         return(theApp.WriteProfileString(profile, entry, def));
00046 }
00047
00048 BOOL CSCommon::Put(LPCTSTR profile, LPCTSTR entry, int def)
00049 {
00050         return(theApp.WriteProfileInt(profile, entry, def));
00051 }
00052
00053 void CSCommon::LoadProfile()
00054 {
00055         GETP1(regDP5Comm, SCAEnabled, 0x00);
00056
00057         GETP1(regDP5Comm, SockAddr, 0xFF00A8C0);
00058         GETP1(regDP5Comm, CurrentInterface, 0x01);
00059         GETP1(regDP5Comm, ComPort, 0x01);
00060         GETP1(regDP5Comm, baud_rate, 115200);
00061         // plot type
00062         GETP1(regDP5Comm, isScaleLog, FALSE);   //TRUE=log, FALSE=linear, default=FALSE
00063         GETP1(regDP5Comm, isPlotLine, FALSE);   //TRUE=line, FALSE=solid, default=FALSE
00064
00065 }
00066
00067 void CSCommon::SaveProfile()
00068 {
00069         CString regDP5Comm1 = regDP5Comm;               // convert const to CString
00070
00071         PUTP1(regDP5Comm1, SCAEnabled);
00072
00073         PUTP1(regDP5Comm1, SockAddr);
00074         PUTP1(regDP5Comm1, CurrentInterface);
00075         PUTP1(regDP5Comm1, ComPort);
00076         PUTP1(regDP5Comm1, baud_rate);
00077         // plot type
00078         PUTP1(regDP5Comm1, isScaleLog);
00079         PUTP1(regDP5Comm1, isPlotLine);
00080 }
00081
00082 void CSCommon::CreateDP5Cfg() {
00083
00084 //DP5CfgCmd(DP5_CMD_INDEX idxDP5Cfg,            // dp5 command index
00085 //                                                      CString Command,                        // 4-char COMMAND mnemonic
00086 //                                                      int ListCtrlID,                         // combobox control ID if any
00087 //                                                      int TextCtrlID,                         // text control ID if any
00088 //                                                      DP5_CTRL_TYPE CtrlType,         // control type
00089 //                                                      DP5_CTRL_GROUP CtrlGroup,       // control group (page)
00090 //                                                      CString Description,            // COMMAND Description
00091 //                                                      CString Units)                          // COMMAND units
00092
00093
00094         DP5CfgCmd(dciRESC,"RESC",IDC_OPT_COMBO_RESC,0,                                  dctCbo,         dcgFile,        "Reset Configuration",                                          "",             "");
00095
00096         DP5CfgCmd(dciRESL,"RESL",IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,  dctCboTxt,      dcgGainPZ,      "Reset Lockout",                                                        "uS",   "0 to 65535uS");
00097         DP5CfgCmd(dciAINP,"AINP",IDC_OPT_COMBO_AINP,0,                                  dctCbo,         dcgGainPZ,      "Analog Input Pos/Neg",                                         "",             "");
00098         DP5CfgCmd(dciINOF,"INOF",IDC_OPT_COMBO_INOF,IDC_OPT_TEXT_INOF,  dctCboTxt,      dcgGainPZ,      "Input Offset",                                                         "mV",   "-2047 to +2047mV");
00099         DP5CfgCmd(dciGAIN,"GAIN",0,                                     IDC_OPT_TEXT_GAIN,      dctTxt,         dcgGainPZ,      "Total Gain (Analog * Fine)",                           "x",    "0.75 to 150");
00100
00101
00102         DP5CfgCmd(dciMCAS,"MCAS",IDC_OPT_COMBO_MCAS,0,                                  dctCbo,         dcgMCA,         "MCA Source",                                                           "",             "");
00103         DP5CfgCmd(dciTHSL,"THSL",0,                                     IDC_OPT_TEXT_THSL,      dctTxt,         dcgMCA,         "Slow Threshhold",                                                      "%",    "0 to 24.9% with 8 to bit precision (256 => 25%)");
00104         DP5CfgCmd(dciMCAE,"MCAE",IDC_OPT_COMBO_MCAE,0,                                  dctCbo,         dcgMCA,         "MCA Enable",                                                           "",             "");
00105         DP5CfgCmd(dciMCAC,"MCAC",IDC_OPT_COMBO_MCAC,0,                                  dctCbo,         dcgMCA,         "MCA/MCS Channels",                                                     "",             "");
00106         DP5CfgCmd(dciGATE,"GATE",IDC_OPT_COMBO_GATE,0,                                  dctCbo,         dcgMCA,         "Gate Control",                                                         "",             "");
00107         DP5CfgCmd(dciPRET,"PRET",IDC_OPT_COMBO_PRET,IDC_OPT_TEXT_PRET,  dctCboTxt,      dcgMCA,         "Preset Acquisition Time",                                                              "S",    "0-1677721.5 S");
00108         DP5CfgCmd(dciPREC,"PREC",IDC_OPT_COMBO_PREC,IDC_OPT_TEXT_PREC,  dctCboTxt,      dcgMCA,         "Preset Counts",                                                        "cnts", "0-4294967295");
00109         DP5CfgCmd(dciMCST,"MCST",0,                                     IDC_OPT_TEXT_MCST,      dctTxt,         dcgMCA,         "MCS Timebase",                                                         "S",    "multiples of 10mS; up to 655.35S");
00110         DP5CfgCmd(dciSOFF,"SOFF",IDC_OPT_COMBO_SOFF,IDC_OPT_TEXT_SOFF,  dctCboTxt,      dcgMCA,         "Set Spectrum Offset",                                          "CH",   "+/- Channels. +0.25=+1/4 channel (higher energy)");
00111
00112         DP5CfgCmd(dciDACF,"DACF",0,                                     IDC_OPT_TEXT_DACF,      dctTxt,         dcgMisc,        "DAC Offset",                                                           "mV",   "-500 to +499mV");
00113         DP5CfgCmd(dciDACO,"DACO",IDC_OPT_COMBO_DACO,IDC_OPT_TEXT_DACO,  dctCboTxt,      dcgMisc,        "DAC Output",                                                           "",             "1 to 8");
00114         DP5CfgCmd(dciSCOE,"SCOE",IDC_OPT_COMBO_SCOE,0,                                  dctCbo,         dcgMisc,        "Scope Trigger Edge",                                           "",             "");
00115         DP5CfgCmd(dciAUO1,"AUO1",IDC_OPT_COMBO_AUO1,IDC_OPT_TEXT_AUO1,  dctCboTxt,      dcgMisc,        "AUX_OUT Selection",                                            "",             "1 to 8");
00116         DP5CfgCmd(dciSCOT,"SCOT",IDC_OPT_COMBO_SCOT,0,                                  dctCbo,         dcgMisc,        "Scope Trigger Position",                                       "%",            "");
00117         DP5CfgCmd(dciGPED,"GPED",IDC_OPT_COMBO_GPED,0,                                  dctCbo,         dcgMisc,        "G.P. Counter Edge",                                            "",             "");
00118         DP5CfgCmd(dciGPIN,"GPIN",IDC_OPT_COMBO_GPIN,IDC_OPT_TEXT_GPIN,  dctCboTxt,      dcgMisc,        "G.P. Counter Input",                                           "",             "1 to 8");
00119         DP5CfgCmd(dciTPMO,"TPMO",IDC_OPT_COMBO_TPMO,0,                                  dctCbo,         dcgMisc,        "Test Pulser On/Off",                                           "",             "");
00120         DP5CfgCmd(dciGPME,"GPME",IDC_OPT_COMBO_GPME,0,                                  dctCbo,         dcgMisc,        "G.P. Counter Uses MCA_EN?",                            "",             "");
00121         DP5CfgCmd(dciGPGA,"GPGA",IDC_OPT_COMBO_GPGA,0,                                  dctCbo,         dcgMisc,        "G.P. Counter Uses GATE?",                                      "",             "");
00122         DP5CfgCmd(dciGPMC,"GPMC",IDC_OPT_COMBO_GPMC,0,                                  dctCbo,         dcgMisc,        "G.P. counter Cleared With MCA Counters?",      "",             "");
00123
00124         DP5CfgCmd(dciPAPS,"PAPS",IDC_OPT_COMBO_PAPS,0,                                  dctCbo,         dcgPower,       "PreAmp 8.5/5 (N/A)",                                           "V",    "");
00125         DP5CfgCmd(dciHVSE,"HVSE",IDC_OPT_COMBO_HVSE,IDC_OPT_TEXT_HVSE,  dctCboTxt,      dcgPower,       "HV Set",                                                                       "V",    "0 to 1500V (+HV) or 0 to -1500V (-HV)");
00126         DP5CfgCmd(dciTECS,"TECS",IDC_OPT_COMBO_TECS,IDC_OPT_TEXT_TECS,  dctCboTxt,      dcgPower,       "TEC Set",                                                                      "K",    "0 to 299K");
00127         DP5CfgCmd(dciPAPZ,"PAPZ",IDC_OPT_COMBO_PAPZ,IDC_OPT_TEXT_PAPZ,  dctCboTxt,      dcgPower,       "Pole-Zero",                                                            "uS",   "34.5uS to 8773uS");
00128
00129         DP5CfgCmd(dciCLCK,"CLCK",IDC_OPT_COMBO_CLCK,0,                                  dctCbo,         dcgShaping,     "20MHz/80MHz",                                                          "",             "");
00130         DP5CfgCmd(dciTFLA,"TFLA",0,                                     IDC_OPT_TEXT_TFLA,      dctTxt,         dcgShaping,     "Flat Top",                                                                     "uS",   "0 to 51.2uS");
00131         DP5CfgCmd(dciTHFA,"THFA",0,                                     IDC_OPT_TEXT_THFA,      dctTxt,         dcgShaping,     "Fast Threshold",                                                       "",             "0 to 255.93");
00132
00133         DP5CfgCmd(dciPURE,"PURE",IDC_OPT_COMBO_PURE,IDC_OPT_TEXT_PURE,  dctCboTxt,      dcgShaping,     "PUR Interval On/Off",                                          "uS",   "");
00134         DP5CfgCmd(dciSCTC,"SCTC",IDC_OPT_COMBO_SCTC,IDC_OPT_TEXT_SCTC,  dctCboTxt,      dcgShaping,     "Scintillator Time Constant",                           "nS",   "");
00135
00136         DP5CfgCmd(dciTPEA,"TPEA",0,                                     IDC_OPT_TEXT_TPEA,      dctTxt,         dcgShaping,     "Peaking Time",                                                         "uS",   "0.8-102.4uS (CLK=20MHz); 0.2-25.6uS (80MHz); 0.2-102.4uS (AUTO)");
00137         DP5CfgCmd(dciRTDS,"RTDS",0,                                     IDC_OPT_TEXT_RTDS,      dctTxt,         dcgShaping,     "RTD Sensitivity",                                                      "%",    "0 to 398");
00138         DP5CfgCmd(dciRTDE,"RTDE",IDC_OPT_COMBO_RTDE,0,                                  dctCbo,         dcgShaping,     "RTD On/Off",                                                           "",             "");
00139         DP5CfgCmd(dciRTDT,"RTDT",0,                                     IDC_OPT_TEXT_RTDT,      dctTxt,         dcgShaping,     "RTD Threshold",                                                        "%",    "0 to 49.9");
00140         DP5CfgCmd(dciBLRD,"BLRD",0,                                     IDC_OPT_TEXT_BLRD,      dctTxt,         dcgShaping,     "BLR Down Correction",                                          "",             "0 to 3");
00141         DP5CfgCmd(dciBLRU,"BLRU",0,                                     IDC_OPT_TEXT_BLRU,      dctTxt,         dcgShaping,     "BLR Up Correction",                                            "",             "0 to 3");
00142         DP5CfgCmd(dciBLRM,"BLRM",IDC_OPT_COMBO_BLRM,0,                                  dctCbo,         dcgShaping,     "BLR Mode",                                                                     "",             "");
00143         DP5CfgCmd(dciPDMD,"PDMD",IDC_OPT_COMBO_PDMD,0,                                  dctCbo,         dcgMCA, "Peak Detect Mode (Min/Max)",                           "",             "");
00144         DP5CfgCmd(dciCUSP,"CUSP",IDC_OPT_COMBO_CUSP,IDC_OPT_TEXT_CUSP,  dctCboTxt,      dcgShaping,     "Non-Trapezoidal Shaping",                                      "%",    "-99 to +99%");
00145
00146         //========================================================================================================================
00147         DP5CfgCmd(dciAUO2,"AUO2",IDC_OPT_COMBO_AUO2,IDC_OPT_TEXT_AUO2,  dctCboTxt,              dcgMisc,"AUX_OUT2 Selection",                                           "",             "1-8");
00148         DP5CfgCmd(dciBOOT,"BOOT",IDC_OPT_COMBO_BOOT,0,                                  dctCbo,         dcgPower,       "PC5 On At StartUp",                                            "",             "");
00149
00150         //========================================================================================================================
00151         DP5CfgCmd(dciGAIA,"GAIA",IDC_OPT_COMBO_GAIA,0,                                  dctCbo,         dcgGainPZ,      "Coarse Gain",                                                          "",             "");
00152         DP5CfgCmd(dciGAIF,"GAIF",0,                                     IDC_OPT_TEXT_GAIF,      dctTxt,         dcgGainPZ,      "Fine Gain",                                                            "x",            "0.750-1.250");
00153
00154         //========================================================================================================================
00155         //========================================================================================================================
00156         //========================================================================================================================
00157
00158         DP5CfgCmd(dciMCSL,"MCSL",0,                                     IDC_OPT_TEXT_MCSL,      dctTxt,         dcgMCA,         "MCS Low Channel",                                                      "",             "1-8192");
00159         DP5CfgCmd(dciMCSH,"MCSH",0,                                     IDC_OPT_TEXT_MCSH,      dctTxt,         dcgMCA,         "MCS High Channel",                                                     "",             "1-8192");
00160
00161         DP5CfgCmd(dciPRCL,"PRCL",0,                                     IDC_OPT_TEXT_PRCL,      dctTxt,         dcgMCA,         "Preset Count Low Channel",                                     "",             "1-8192");
00162         DP5CfgCmd(dciPRCH,"PRCH",0,                                     IDC_OPT_TEXT_PRCH,      dctTxt,         dcgMCA,         "Preset Count High Channel",                            "",             "1-8192");
00163
00164         DP5CfgCmd(dciPRER,"PRER",IDC_OPT_COMBO_PRER,IDC_OPT_TEXT_PRER,  dctCboTxt,      dcgMCA,         "Preset Real Time",                                                     "S",    "0-4294967.29");
00165         DP5CfgCmd(dciTLLD,"TLLD",IDC_OPT_COMBO_TLLD,IDC_OPT_TEXT_TLLD,  dctCboTxt,      dcgMCA, "Low Level Discriminator",                                      "CH",   "1-8192");
00166         DP5CfgCmd(dciSCOG,"SCOG",IDC_OPT_COMBO_SCOG,0,                                  dctCbo,         dcgMisc,        "Gain",                                                                         "",             "");
00167
00168         DP5CfgCmd(dciTPFA,"TPFA",IDC_OPT_COMBO_TPFA,0,                                  dctCbo,         dcgShaping,     "Fast Peaking Time",                                            "",             "");
00169         DP5CfgCmd(dciVOLU,"VOLU",IDC_OPT_COMBO_VOLU,0,                                  dctCbo,         dcgMisc,        "Speaker On/Off",                                               "",             "");
00170
00171         DP5CfgCmd(dciCON1,"CON1",IDC_OPT_COMBO_CON1,0,                                  dctCbo,         dcgMisc,        "Connector 1",                                          "",             "");
00172         DP5CfgCmd(dciCON2,"CON2",IDC_OPT_COMBO_CON2,0,                                  dctCbo,         dcgMisc,        "Connector 1",                                          "",             "");
00173
00174 }
00175
00176 // Configuration Dialog Update Notes:
00177 // 1. Control Resources
00178 //              [] For ComboText Group Add cbo,txt,units,limits,frame controls
00179 //              [] For Combo Only Add cbo, frame
00180 //      [] For Text Only, Add txt,units,limits,frame
00181 //              [] For All Combo Add data resource string (item1;item2;...)
00182 //              [] For ALL Add name of control to frame
00183 // 2. Initialization
00184 //              [] For ALL Controls Add InitDlgItem at InitControls
00185 //              [] For Text Add Entry in InitDlgItem
00186 //              [] For ALL Combo Add CboUpdate at InitControls
00187 //              [] For ComboText Group Add Text Update Entry in CboUpdate
00188 // 3. Control Command Handlers
00189 //              [] Text TextUpdate Command Handler
00190 //              [] Cbo CboUpdate Command Handler
00191 //      [] ComboText Group, TextUpdate and CboUpdate
00192 // 4. ComboText Group Text Edit Function
00193 //              [] CboTextVis bonds Combo with Text for CboTxt Single Control Function
00194 //              [] Add CboTextVis to Text Update Entry in CboUpdate
00195 // 5. CDialog Trap Key Updates
00196 //              [] VK_RETURN is trapped to prevent dialog closing during edits (MS Defaults Bug)
00197 //              [] PreTranslateMessage traps Combo/Text control VK_RETURN, tabs to next stop
00198 //              [] For Text Add nID to isCEditBox
00199 //              [] For Combo Add nID to isCComboBox
00200
00201 // ==== Text Only Summary ====
00202 // [] Add txt,units,limits,frame
00203 // [] Add name of control to frame
00204 // [] Add InitDlgItem at InitControls
00205 // [] Add Text Update Entry in InitDlgItem
00206 // [] TextUpdate Command Handler
00207 // [] Add nID to isCEditBox
00208
00209 // ==== Combo Only Summary ====
00210 // [] Add cbo, frame
00211 // [] Add name of control to frame
00212 // [] Add data resource string
00213 // [] Add InitDlgItem at InitControls
00214 // [] Add CboUpdate at InitControls
00215 // [] CboUpdate Command Handler
00216 // [] Add nID to isCComboBox
00217
00218 // ==== ComboText Group Summary ====
00219 // [] Add cbo,txt,units,limits,frame controls
00220 // [] Add name of control to frame
00221 // [] Add data resource string
00222 // [] Add InitDlgItem at InitControls
00223 // [] Add CboUpdate at InitControls
00224 // [] Add Text Update Entry in InitDlgItem
00225 // [] Add Text Update Entry in CboUpdate
00226 // [] Add CboTextVis to Text Update Entry in CboUpdate
00227 // [] TextUpdate Command Handler
00228 // [] CboUpdate Command Handler
00229 // [] Add nID Txt to isCEditBox
00230 // [] Add nID Cbo to isCComboBox
00231
00232 void CSCommon::DP5CfgCmd(DP5_CMD_INDEX idxDP5Cfg,               // dp5 command index
00233                                                         CString Command,                        // 4-char COMMAND mnemonic
00234                                                         int ListCtrlID,                         // combobox control ID if any
00235                                                         int TextCtrlID,                         // text control ID if any
00236                                                         DP5_CTRL_TYPE CtrlType,         // control type
00237                                                         DP5_CTRL_GROUP CtrlGroup,       // control group (page)
00238                                                         CString Description,            // COMMAND Description
00239                                                         CString Units,                          // COMMAND units
00240                                                         CString Limits)
00241 {
00242         // set constant values
00243         m_DP5Cfg[idxDP5Cfg].Command = Command;
00244         m_DP5Cfg[idxDP5Cfg].ListCtrlID = ListCtrlID;
00245         m_DP5Cfg[idxDP5Cfg].TextCtrlID = TextCtrlID;
00246         m_DP5Cfg[idxDP5Cfg].CtrlType = CtrlType;
00247         m_DP5Cfg[idxDP5Cfg].CtrlGroup = CtrlGroup;
00248         m_DP5Cfg[idxDP5Cfg].Description = Description;
00249         m_DP5Cfg[idxDP5Cfg].Units = Units;
00250         m_DP5Cfg[idxDP5Cfg].Limits = Limits;
00251
00252         // initialize dynamic values
00253         m_DP5Cfg[idxDP5Cfg].Setting = "";
00254         m_DP5Cfg[idxDP5Cfg].TextValue = "";
00255         m_DP5Cfg[idxDP5Cfg].ComboValue = "";
00256         m_DP5Cfg[idxDP5Cfg].ComboIndex = -1;
00257         m_DP5Cfg[idxDP5Cfg].Comments = "";
00258         m_DP5Cfg[idxDP5Cfg].ValComments = "";
00259         m_DP5Cfg[idxDP5Cfg].bAppendUnits = FALSE;
00260
00261 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SCommon.h Source File

SCommon.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include "DppConst.h"
00004 #include "scafn.h"
00005 #include "vcDP5_Shared_HIDD.h"
00006 #include "vcDP5.h"
00007 //#include "SProfile.h"
00008 #define WM_SETPAGEFOCUS WM_APP+2
00009
00010 //Communications
00011 #include "DppSocket.h"
00012 #include "DppWinUSB.h"
00013 #include "DppComm.h"
00014
00015 #include "DP5Status.h"
00016 #include "ParsePacket.h"
00017 #include "DP5Protocol.h"
00018 #include "SendCommand.h"
00019
00020 #include "DP5ControlUtil.h"
00021 #include "DppConfig.h"
00022 #include ".\plot.h"
00023 #include ".\spectralist.h"
00024 #include "WinusbNotify.h"
00025
00026 // Get/Save a double format value
00027 #define GETPD(p1, i1, data) str = Get(p1, #i1, data); i1 = atof(str)
00028 #define PUTPD(p1, i1) str.Format("%g", i1); Put(p1, #i1, str)
00029
00030 // Get/Save a parameter value
00031 #define GETP1(p1, i1, data) i1 = Get(p1, #i1, data)
00032 #define PUTP1(p1, i1) Put(p1, #i1, i1)
00033
00034 const CString regDP5Comm = "DP5_Communication";
00035 const CString regDP5Device = "DP5_Device";
00036 const CString regDP5Config = "DP5_Configuration";
00037
00038 class CSProfile
00039 {
00040 public:
00041     CString profile;
00042         int device_type;        // DPP Device Type
00043         int data_refresh;       // usb data refresh rate in milli seconds
00044         CString strDevice; // Holds the live device type name for display // DPP5 20071010_1245
00045
00046         //DP5 Settings
00047         BOOL SendCoarseFineGain;        // FALSE=Send GAIN, TRUE=Send GAIA,GAIF
00048
00049         CScaFn scafn;
00050         CSca sca;
00051         BOOL SCAEnabled;
00052
00053         unsigned long SockAddr;                         // Current Ip Address
00054         UINT ComPort;                           // current com port
00055     int baud_rate;                              // current baud rate
00056         unsigned char CurrentInterface;         // interface in use (RS232/USB/ETHERNET)
00057
00058 public:
00059         CSProfile(){};
00060         ~CSProfile(){};
00061 };
00062
00063 class CSCommon
00064 {
00065 public:
00066         CSCommon(void);
00067         ~CSCommon(void);
00068
00069         CString GetDeviceNameFromVal(int DeviceTypeVal) {
00070                 CString strDeviceType;
00071                 switch(DeviceTypeVal) {
00072                         case dppDP5:
00073                                 strDeviceType = "DP5";
00074                                 break;
00075                         case dppPX5:
00076                                 strDeviceType = "PX5";
00077                                 break;
00078                         case dppDP5G:
00079                                 strDeviceType = "DP5G";
00080                                 break;
00081                         case dppMCA8000D:
00082                                 strDeviceType = "MCA8000D";
00083                                 break;
00084                         case dppTB5:
00085                                 strDeviceType = "TB5";
00086                                 break;
00087                         case dppDP5X:
00088                                 strDeviceType = "DP5-X";
00089                                 break;
00090                         default:           //if unknown set to DP5
00091                                 strDeviceType = "DP5";
00092                                 break;
00093                 }
00094                 return strDeviceType;
00095         }
00096
00097         CPlot m_plot;                           //  = new CPlot;
00098         CPlot *plot;
00099         CSpectraList spectraList;
00100         CSpectrum m_Spectrum;           // we only have one spectrum
00101
00102         CScaFn scafn;
00103         CSca sca;
00104         BOOL SCAEnabled;
00105
00106         //Communications
00107         CDppComm m_DppPort;                     // RS232 Serial Port
00108         CDppWinUSB DppWinUSB;           // WinUSB
00109         CDppSocket m_DppSck;            // Ethernet/Sockets
00110         CWinusbNotify WinusbNotify;
00111
00112         int DppCommStatusInd;           // dpp communications status indicator
00113         int DppCommStatusIndOld;    //
00114
00115         //DP5 Protocol Support
00116         CDP5Status DP5Stat;
00117         CParsePacket ParsePkt;
00118         CDP5Protocol DP5Proto;
00119         CSendCommand SndCmd;
00120         //CDppConfig DppConfig;
00121         CStringArray Dp5CmdList;
00122         CString HwCfgDP5;
00123         CString HwCfgDP5Out;
00124         BOOL HwCfgReady;
00125         BOOL HwCfgExReady;
00126
00127         // Save/Load Registry Settings Support functions
00128     CString Get(LPCTSTR profile, LPCTSTR entry, LPCTSTR def);
00129     int Get(LPCTSTR profile, LPCTSTR entry, int def);
00130     BOOL Put(LPCTSTR profile, LPCTSTR entry, LPCTSTR def);
00131     BOOL Put(LPCTSTR profile, LPCTSTR entry, int def);
00132         void LoadProfile();
00133         void SaveProfile();
00134
00135         // Shared Communications Interface Settings
00136         unsigned char CurrentInterface;         // interface in use (RS232/USB/ETHERNET)
00137         BOOL isDppFound[3];     // device found on interface=TRUE ([0]=RS232/[1]=USB/[2]=ETHERNET)
00138         BOOL isDppConnected; // CurrentInterface selected and device found
00139
00140         // Serial Port Settings
00141         UINT ComPort;
00142         int baud_rate;
00143
00144         // WinUSB Settings
00145         // Serial Number
00146
00147         // Ethernet Settings
00148         BOOL NetfinderActive;
00149         unsigned long SockAddr;
00150         CString strSockAddr;
00151
00152         CSProfile profileCls;
00153         CSProfile *profile;
00154
00155         // DP5 Configuration Helper Functions
00156         BOOL ReloadCfg;
00157         BOOL HaveConfig;
00158         BOOL FindCommand;
00159         int FindCtrlID;
00160         CDP5ControlUtil CtrlUtil;
00161         DP5_CONFIGURATION m_DP5Cfg[MAX_DP5_CONFIGURATIONS];
00162         void CreateDP5Cfg();
00163         void DP5CfgCmd(DP5_CMD_INDEX idxDP5Cfg,         // dp5 command index
00164                                                         CString Command,                        // 4-char COMMAND mnemonic
00165                                                         int ListCtrlID,                         // combobox control ID if any
00166                                                         int TextCtrlID,                         // text control ID if any
00167                                                         DP5_CTRL_TYPE CtrlType,         // control type
00168                                                         DP5_CTRL_GROUP CtrlGroup,       // control group (page)
00169                                                         CString Description,            // COMMAND Description
00170                                                         CString Units,                          // COMMAND units
00171                                                         CString Limits);                        // COMMAND limits
00172
00173
00174
00175         CDppConfig DppConfig;
00176         HWND hWnd_Main;
00177
00178         //CString HwCfgDP5;
00179         //CString HwCfgDP5Out;
00180         //BOOL HwCfgReady;
00181         //BOOL HwCfgExReady;
00182
00183         //CSProfile profileCls;
00184         //CSProfile *profile;
00185
00186         CString strHelpFilePath;
00187
00188         // save plot type
00189         BOOL isScaleLog;        //TRUE=log, FALSE=linear, default=FALSE
00190         BOOL isPlotLine;        //TRUE=line, FALSE=solid, default=FALSE
00191
00192
00193
00194 };
00195
00196 extern CSCommon s;
00197
00198
00199
00200
00201
00202
00203
00204
00205
00206
00207
00208
00209
00210
00211
00212
00213
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: STypes.cpp Source File

STypes.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "STypes.h"
00003
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: STypes.h Source File

STypes.h
Go to the documentation of this file.
00001 // STypes.h: s.
00002 //
00004
00005 // This file defines types that can be used in other header files
00006
00007 #if !defined(AFX_GLBTYPES_H__3724B201_2C60_11D2_9A26_00403354E42C__INCLUDED_)
00008 #define AFX_GLBTYPES_H__3724B201_2C60_11D2_9A26_00403354E42C__INCLUDED_
00009
00010 #if _MSC_VER >= 1000
00011 #pragma once
00012 #endif // _MSC_VER >= 1000
00013
00014 #define MIN_PLOT_X_PIXELS 100
00015 #define MIN_PLOT_Y_PIXELS 80
00016
00017 #define MIN_FRAME_X_PIXELS 200
00018 #define MIN_FRAME_Y_PIXELS 160
00019
00020 #define MAX_CHANNELS 0x4000ul
00021 #define MAX_COUNTS 0xFFFFFFFFul
00022
00023 #define MIN_PLOT_CHANNELS 64
00024 #define MIN_PLOT_COUNTS 32
00025
00026 #define MIN_GAIN 256
00027 #define MAX_GAIN_INDEX 6
00028
00029 #define GAIN_FROM_INDEX(index) (MIN_GAIN << index)
00030 #define GETULONG(d) ((unsigned long) floor(d + 0.5))
00031 #define TOULONG(d) (d <= 0.0 ? 0 : \
00032         (d > ULONG_MAX ? ULONG_MAX : GETULONG(d)))
00033 #define GETLONG(d) ((long) floor(d + 0.5))
00034 #define TOLONG(d) (d <= LONG_MIN ? LONG_MIN : \
00035         (d > LONG_MAX ? LONG_MAX : GETLONG(d)))
00036
00037 #define SCREEN_SCALE 10000
00038
00039 #define MAX_SPECTRA 20
00040
00041
00042 typedef enum
00043 {
00044     LIN_SCALE,
00045     LOG_SCALE,
00046     SQRT_SCALE
00047 } SCALE_TYPE;
00048
00049 typedef enum
00050 {
00051     INVALID_SMOOTH = -2,
00052     NO_SMOOTH,
00053     THREE_SMOOTH,
00054     FIVE_SMOOTH
00055 } SMOOTH_TYPE;
00056
00057 typedef enum
00058 {
00059     GAIN_256,
00060     GAIN_512,
00061     GAIN_1024,
00062     GAIN_2048,
00063     GAIN_4096,
00064     GAIN_8192,
00065     GAIN_16384
00066 } GAIN_TYPE;
00067
00068 #endif // !defined(AFX_GLBTYPES_H__3724B201_2C60_11D2_9A26_00403354E42C__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Sca.cpp Source File

DP5Cfg/Sca.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include ".\sca.h"
00003
00004 CSca::CSca(void)
00005 {
00006         HaveCurIndex = FALSE;
00007         HaveScaUpdate = FALSE;
00008 }
00009
00010 CSca::~CSca(void)
00011 {
00012 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/Sca.h Source File

DP5Cfg/Sca.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 #define MAX_SCA_REGISTER 8
00004
00005 class CSca
00006 {
00007 public:
00008         CSca(void);
00009         ~CSca(void);
00010
00011     CString strIniFilename;
00012     CString CurIndex;
00013     BOOL HaveCurIndex;
00014     CString PulseWidth;
00015     CString Index[MAX_SCA_REGISTER];
00016     CString Low[MAX_SCA_REGISTER];
00017     CString High[MAX_SCA_REGISTER];
00018     CString Output[MAX_SCA_REGISTER];
00019         BOOL HaveScaUpdate;                                     // sca has been updated by hardware
00020
00021 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ScaFn.cpp Source File

DP5Cfg/ScaFn.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include ".\scafn.h"
00003 #include "IniUtil.h"
00004
00005 CScaFn::CScaFn(void)
00006 {
00007         SCA_SECTION = "DP5 SCA Configuration";
00008         CFG_SECTION = "DP5 Configuration File";
00009 }
00010
00011 CScaFn::~CScaFn(void)
00012 {
00013 }
00014
00015 BOOL CScaFn::SplitData(CString strData, CString *varValue, CString strDefault)
00016 {
00017     long lSep;
00018     CString strChan;
00019         BOOL bSplitData;
00020
00021         bSplitData = FALSE;
00022     lSep = strData.Find(";");
00023     if (lSep > 0) {      //file has setting, separate comments from data, if any
00024         *varValue = strData.Left(lSep - 1).Trim();
00025         bSplitData = TRUE;
00026     } else {
00027         *varValue = strDefault;
00028         bSplitData = FALSE;
00029     }
00030         return bSplitData;
00031 }
00032
00033 long CScaFn::varValueToIndex(CString strData)
00034 {
00035         CString strCase;
00036         long lValueToIndex;
00037
00038     strCase = strData.MakeUpper();
00039     if (strCase == "OFF") {
00040         lValueToIndex = 0;
00041     } else if (strCase == "HI") {
00042         lValueToIndex = 1;
00043     } else if (strCase == "LOW") {
00044         lValueToIndex = 2;
00045     } else if (strCase == "256") {
00046         lValueToIndex = 0;
00047     } else if (strCase == "512") {
00048         lValueToIndex = 1;
00049     } else if (strCase == "1024") {
00050         lValueToIndex = 2;
00051     } else if (strCase == "2048") {
00052         lValueToIndex = 3;
00053     } else if (strCase == "4096") {
00054         lValueToIndex = 4;
00055     } else if (strCase == "8192") {
00056         lValueToIndex = 5;
00057     } else if (strCase == "100") {
00058         lValueToIndex = 0;
00059     } else if (strCase == "1000") {
00060         lValueToIndex = 1;
00061     } else if (strCase == "1") {
00062         lValueToIndex = 0;
00063     } else if (strCase == "2") {
00064         lValueToIndex = 1;
00065     } else if (strCase == "3") {
00066         lValueToIndex = 2;
00067     } else if (strCase == "4") {
00068         lValueToIndex = 3;
00069     } else if (strCase == "5") {
00070         lValueToIndex = 4;
00071     } else if (strCase == "6") {
00072         lValueToIndex = 5;
00073     } else if (strCase == "7") {
00074         lValueToIndex = 6;
00075     } else if (strCase == "8") {
00076         lValueToIndex = 7;
00077     } else if (strCase == "HIGH") {
00078         lValueToIndex = 1;
00079     } else if (strCase == "HIG") {
00080         lValueToIndex = 1;
00081     } else if (strCase == "LO") {
00082         lValueToIndex = 2;
00083         } else {
00084         lValueToIndex = 0;
00085         }
00086         return lValueToIndex;
00087 }
00088
00089 //these must be in the correct order, old sca settings will be deleted and new appended to end
00090 void CScaFn::SaveSCASetupINI(CSca sca)
00091 {
00092     CString strData;
00093     long Index;
00094
00095     Index = atol(sca.CurIndex);
00096
00097     DeleteIniSettingEx(sca.strIniFilename, CFG_SECTION, "SCAI");
00098     DeleteIniSettingEx(sca.strIniFilename, CFG_SECTION, "SCAO");
00099     DeleteIniSettingEx(sca.strIniFilename, CFG_SECTION, "SCAL");
00100     DeleteIniSettingEx(sca.strIniFilename, CFG_SECTION, "SCAH");
00101     DeleteIniSettingEx(sca.strIniFilename, CFG_SECTION, "SCAW");
00102
00103     strData = sca.PulseWidth; // + ";";
00104     SaveToIniEx(sca.strIniFilename, CFG_SECTION, "SCAW", strData);
00105 }
00106
00107 void CScaFn::DeleteIniSettingEx(CString strFilename, CString strSection, CString strKey)
00108 {
00109         CIniUtil ciu;
00110         ciu.DeleteDP5Key(strFilename,strSection,strKey);
00111 }
00112
00113 void CScaFn::SaveToIniEx(CString strFilename, CString strSection, CString strKey, CString strData)
00114 {
00115         CIniUtil ciu;
00116         CString csCmts;
00117
00118         csCmts = "";
00119         ciu.SaveDP5Data(strFilename,strSection,strKey,strData,csCmts);
00120 }
00121
00122 void CScaFn::SaveSCASettingsINI(CSca sca, long Index)
00123 {
00124     CString strIdx;
00125     CString strData;
00126     strIdx.Format("%d",Index);
00127
00128     strData = sca.Output[Index - 1]; // + ";";
00129     SaveToIniEx(sca.strIniFilename, SCA_SECTION, "SCAO" + strIdx, strData);
00130
00131     strData = sca.Low[Index - 1]; // + ";";
00132     SaveToIniEx(sca.strIniFilename, SCA_SECTION, "SCAL" + strIdx, strData);
00133
00134     strData = sca.High[Index - 1]; // + ";";
00135     SaveToIniEx(sca.strIniFilename, SCA_SECTION, "SCAH" + strIdx, strData);
00136 }
00137
00138 void CScaFn::GetSCASetupINI(CSca *sca)
00139 {
00140     CString strValue;
00141     CString strComment;
00142     CString strData;
00143     long lIndex;
00144
00145     strData = GetFromIniEx(sca->strIniFilename, CFG_SECTION, "SCAW", "100");
00146         sca->PulseWidth = strData;
00147
00148     strData = GetFromIniEx(sca->strIniFilename, CFG_SECTION, "SCAI", "1");
00149         sca->CurIndex = strData;
00150     sca->HaveCurIndex = (BOOL)(strData.GetLength() > 0);
00151
00152     if (sca->HaveCurIndex) {     //update sca from latest config data
00153         lIndex = atol(sca->CurIndex);
00154
00155         strData = GetFromIniEx(sca->strIniFilename, CFG_SECTION, "SCAO", "OFF");
00156                 sca->Output[lIndex - 1] = strData;
00157
00158         strData = GetFromIniEx(sca->strIniFilename, CFG_SECTION, "SCAL", "0");
00159         sca->Low[lIndex - 1] = strData;
00160
00161         strData = GetFromIniEx(sca->strIniFilename, CFG_SECTION, "SCAH", "1023");
00162                 sca->High[lIndex - 1] = strData;
00163     }
00164 }
00165
00166 CString CScaFn::GetFromIniEx(CString strFilename, CString strSection, CString strKey, CString strDefault)
00167 {
00168         CString strData;
00169         CIniUtil ciu;
00170         CString csData;
00171         CString csCmts;
00172
00173         if (ciu.GetDP5Data(strFilename,strSection,strKey,&csData,&csCmts)) {
00174                 strData = csData;
00175         } else {
00176                 strData = strDefault;
00177         }
00178         return strData;
00179 }
00180
00181 void CScaFn::GetSCASettingsINI(CSca *sca, long lIndexIn)
00182 {
00183     CString strValue;
00184     CString strComment;
00185     CString strIdx;
00186     CString strData;
00187         long lIndex;
00188
00189     strIdx.Format("%d",lIndexIn);
00190     sca->Index[lIndexIn - 1] = strIdx;       //for future use
00191         lIndex = atol(sca->CurIndex);
00192
00193     //skip updating data that was updated from the configuration settings
00194         //if (sca->HaveCurIndex && (lIndex == Index)) { return; }
00195
00196     strData = GetFromIniEx(sca->strIniFilename, SCA_SECTION, "SCAO" + strIdx, "OFF");
00197     sca->Output[lIndexIn - 1] = strData;
00198
00199     strData = GetFromIniEx(sca->strIniFilename, SCA_SECTION, "SCAL" + strIdx, "0");
00200     sca->Low[lIndexIn - 1] = strData;
00201
00202     strData = GetFromIniEx(sca->strIniFilename, SCA_SECTION, "SCAH" + strIdx, "1023");
00203     sca->High[lIndexIn - 1] = strData;
00204 }
00205
00206 //                                       1234567
00207 //expecting data format strCMD=strData; (CMD1=?;)
00208 void CScaFn::ReadSCASetting(CSca *sca, CString strSCAInfo)
00209 {
00210     CString strCmd;
00211     CString strData;
00212     long lSep;
00213     long lTerm;
00214         long lIndex;
00215
00216         lIndex = atol(sca->CurIndex);
00217     lSep = strSCAInfo.Find("=");
00218     lTerm = strSCAInfo.Find(";");
00219     if (lSep != 4) { return; }
00220     if (lTerm < 6) { return; }
00221     strCmd = strSCAInfo.Left(4).MakeUpper();
00222     strData = strSCAInfo.Mid(5, lTerm - 5).MakeUpper();
00223         if (strCmd == "SCAW") {
00224         sca->PulseWidth = strData;
00225     } else if (strCmd == "SCAI") {
00226         sca->CurIndex = strData;
00227         sca->HaveCurIndex = TRUE;
00228                 lIndex = atol(sca->CurIndex);
00229         sca->Index[lIndex - 1] = strData;
00230     } else if (strCmd == "SCAL") {
00231                 if (lIndex > 0) {
00232                         sca->Low[lIndex - 1] = strData;
00233                 }
00234     } else if (strCmd == "SCAH") {
00235                 if (lIndex > 0) {
00236                         sca->High[lIndex - 1] = strData;
00237                 }
00238     } else if (strCmd == "SCAO") {
00239                 if (lIndex > 0) {
00240                         sca->Output[lIndex - 1] = strData;
00241                 }
00242     } else {
00243         //unknown data error
00244     }
00245 }
00246
00247 //reads dpp command string removes and returns byref next dpp config command
00248 //functions returns true if command found, false otherwise
00249 CString CScaFn::GetNextCMD(CString strCMDList)
00250 {
00251     CString strCmd;
00252     long lNextCmd;
00253
00254     strCmd = "";
00255     if (strCMDList.GetLength() < 7) { return strCmd; }    //1234=6;8
00256         lNextCmd = strCMDList.Find(";");
00257     if (lNextCmd < 6) { return strCmd; }                                        //0123=5;7
00258         strCmd = strCMDList.Left(lNextCmd+1).MakeUpper();
00259         return strCmd;
00260 }
00261
00262 void CScaFn::SCACfgParser(CSca *sca, CString strSCASettings)
00263 {
00264     CString strCMDList;
00265     CString strCmd;
00266     long idxCMDs;
00267     long CMDMax;
00268         long lCmdLen;
00269
00270         if (strSCASettings.GetLength() < 7) { return; }
00271     strCMDList = strSCASettings;
00272     strCmd = "";
00273         CMDMax = strSCASettings.GetLength();
00274         CMDMax /= 7;
00275         CMDMax++;                               //loop the max number of times
00276     for (idxCMDs=0;idxCMDs<=CMDMax;idxCMDs++) {
00277         strCmd = GetNextCMD(strCMDList);
00278                 lCmdLen = strCmd.GetLength();
00279         if (lCmdLen > 0) {
00280             ReadSCASetting(sca, strCmd);
00281                         strCMDList = strCMDList.Mid(lCmdLen);
00282         } else {
00283             break;
00284         }
00285     }
00286 }
00287
00288 CString CScaFn::SCAString(CString strCmd, CString strData, BOOL bDppMsg)
00289 {
00290     CString str;
00291     str = strCmd.MakeUpper();
00292     str = str + "=";
00293     str = str + strData.MakeUpper() + ";";
00294         if (! bDppMsg) {
00295         str = str + "\r\n";
00296         }
00297     return str;
00298 }
00299
00300 //these must be in the correct order, old sca settings will be delected and new appended to end
00301 CString CScaFn::SCASetupString(CSca sca, BOOL bDppMsg)
00302 {
00303     CString strData;
00304     CString strSCAsus;
00305     CString str;
00306
00307     strSCAsus = "";
00308     strData = sca.PulseWidth;
00309     str = SCAString("SCAW", strData, bDppMsg);
00310     strSCAsus = strSCAsus + str;
00311     return strSCAsus;
00312 }
00313
00314 CString CScaFn::SCASettingsString(CSca sca, long Index, BOOL bDppMsg)
00315 {
00316     CString strIdx;
00317     CString strData;
00318     CString strSCAsets;
00319     CString str;
00320
00321         strIdx.Format("%d",Index);
00322
00323     strData = sca.Index[Index];
00324     str = SCAString("SCAI", strData, bDppMsg);
00325     strSCAsets = strSCAsets + str;
00326
00327     strData = sca.Output[Index];
00328     str = SCAString("SCAO", strData, bDppMsg);
00329     strSCAsets = strSCAsets + str;
00330
00331     strData = sca.Low[Index];
00332     str = SCAString("SCAL", strData, bDppMsg);
00333     strSCAsets = strSCAsets + str;
00334
00335     strData = sca.High[Index];
00336     str = SCAString("SCAH", strData, bDppMsg);
00337     strSCAsets = strSCAsets + str;
00338
00339     return strSCAsets;
00340 }
00341
00342 CString CScaFn::SCAStringALL(CSca sca, BOOL bDppMsg)
00343 {
00344     long idxSCA;
00345     CString strSCA;
00346         CString strSetting;
00347
00348     strSCA = SCASetupString(sca, bDppMsg);
00349     for (idxSCA=0;idxSCA<MAX_SCA_REGISTER;idxSCA++) {
00350                 strSetting = SCASettingsString(sca, idxSCA, bDppMsg);
00351         strSCA = strSCA + strSetting;
00352     }
00353     return strSCA;
00354 }
00355
00356 CString CScaFn::SCAStringALLDisplay(CSca sca)
00357 {
00358     long idxSCA;
00359     CString strSCA;
00360     BOOL bDppMsg;
00361         CString strSetting;
00362
00363     bDppMsg = TRUE;
00364     strSCA = SCASetupString(sca, bDppMsg);
00365     for (idxSCA=0;idxSCA<MAX_SCA_REGISTER;idxSCA++) {
00366         strSCA = strSCA + "\r\n";
00367                 strSetting = SCASettingsString(sca, idxSCA, bDppMsg);
00368         strSCA = strSCA + strSetting;
00369     }
00370     return strSCA;
00371 }
00372
00373 void CScaFn::InitSCA(CSca *sca, long lChannels, BOOL bTest)
00374 {
00375     long idxSCA;
00376         CString strHigh;
00377         CString strIndex;
00378     sca->strIniFilename = "";
00379         strHigh.Format("%d", lChannels - 1);
00380     sca->CurIndex = "1";
00381     sca->PulseWidth = "100";
00382         for (idxSCA=0;idxSCA<MAX_SCA_REGISTER;idxSCA++) {
00383                 strIndex.Format("%d",idxSCA + 1);
00384                 sca->Index[idxSCA] = strIndex;
00385                 if (bTest) {
00386                         sca->Low[idxSCA].Format("%d", ((idxSCA+1) * 1));
00387                         sca->High[idxSCA].Format("%d", ((idxSCA+1) * 100));
00388                 } else {
00389                     sca->Low[idxSCA] = "0";
00390                         sca->High[idxSCA] = strHigh;
00391                 }
00392         if (idxSCA < 8) {
00393             sca->Output[idxSCA] = "OFF";
00394         }
00395     }
00396 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ScaFn.h Source File

DP5Cfg/ScaFn.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 #include ".\sca.h"
00004
00005
00006 class CScaFn
00007 {
00008 public:
00009         CScaFn(void);
00010         ~CScaFn(void);
00011
00012         CString SCA_SECTION;
00013         CString CFG_SECTION;
00014
00015         BOOL SplitData(CString strData, CString *varValue, CString strDefault);
00016
00017         long varValueToIndex(CString varData);
00018
00019         void SaveSCASetupINI(CSca sca);
00020         void DeleteIniSettingEx(CString strFilename, CString strSection, CString strKey);
00021         void SaveToIniEx(CString strFilename, CString strSection, CString strKey, CString strData);
00022         void SaveSCASettingsINI(CSca sca, long Index);
00023         void GetSCASetupINI(CSca *sca);
00024         CString GetFromIniEx(CString strFilename, CString strSection, CString strKey, CString strDefault);
00025         void GetSCASettingsINI(CSca *sca, long Index);
00026         void ReadSCASetting(CSca *sca, CString strSCAInfo);
00027         CString GetNextCMD(CString strCMDList);
00028         void SCACfgParser(CSca *sca, CString strSCASettings);
00029         CString SCAString(CString strCmd, CString strData, BOOL bDppMsg = TRUE);
00030         CString SCASetupString(CSca sca, BOOL bDppMsg = TRUE);
00031         CString SCASettingsString(CSca sca, long Index, BOOL bDppMsg = TRUE);
00032         CString SCAStringALL(CSca sca, BOOL bDppMsg = TRUE);
00033         CString SCAStringALLDisplay(CSca sca);
00034         void InitSCA(CSca *sca, long lChannels=8191, BOOL bTest = FALSE);
00035 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SelectDP5.cpp Source File

DeviceIO/SelectDP5.cpp
Go to the documentation of this file.
00001 // SelectDP5.cpp : implementation file
00002 //
00003 #include "stdafx.h"
00004 #include "SelectDP5.h"
00005 #include "SelectDP5Res.h"
00006 #include ".\selectdp5.h"
00007
00008 BEGIN_MESSAGE_MAP(CSelectDP5, CDialog)
00009         ON_MESSAGE(WM_DPPCOMM_RCV_CHAR, OnCommunication)
00010         ON_MESSAGE(WM_DPPSOCKET_RCV_BUFFER, OnReceive)
00011         ON_WM_DESTROY()
00012         ON_BN_CLICKED(IDC_BUTTON_FIND_DP5_IP, OnBnClickedButtonFindDp5Ip)
00013         ON_BN_CLICKED(IDC_BUTTON_CLOSE_PORT, OnBnClickedButtonClosePort)
00014         ON_BN_CLICKED(IDC_BUTTON_OPEN_PORT, OnBnClickedButtonOpenPort)
00015         ON_BN_CLICKED(IDC_BUTTON_SERIAL_REQ_DATA, OnBnClickedButtonSerialReqData)
00016         ON_BN_CLICKED(IDC_RADIO_COMMTYPE1, OnBnClickedRadioCommtype1)
00017         ON_BN_CLICKED(IDC_RADIO_COMMTYPE2, OnBnClickedRadioCommtype2)
00018         ON_BN_CLICKED(IDC_RADIO_COMMTYPE3, OnBnClickedRadioCommtype3)
00019         ON_BN_CLICKED(IDC_BUTTON_FIND_USB_DEVICE, OnBnClickedButtonFindUsbDevice)
00020         ON_BN_CLICKED(IDC_CONNECTOK, OnBnClickedConnectOK)
00021         ON_BN_CLICKED(IDOK, OnOK)
00022         ON_BN_CLICKED(IDC_BUTTON_IP_SELECT1, OnBnClickedButtonIpSelect1)
00023         ON_BN_CLICKED(IDC_BUTTON_IP_SELECT2, OnBnClickedButtonIpSelect2)
00024         ON_BN_CLICKED(IDC_BUTTON_IP_SELECT3, OnBnClickedButtonIpSelect3)
00025         ON_BN_CLICKED(IDC_BUTTON_IP_SELECT4, OnBnClickedButtonIpSelect4)
00026         ON_STN_CLICKED(IDC_STATIC_NETFINDER1, OnStnClickedStaticNetfinder1)
00027         ON_STN_CLICKED(IDC_STATIC_NETFINDER2, OnStnClickedStaticNetfinder2)
00028         ON_STN_CLICKED(IDC_STATIC_NETFINDER3, OnStnClickedStaticNetfinder3)
00029         ON_STN_CLICKED(IDC_STATIC_NETFINDER4, OnStnClickedStaticNetfinder4)
00030
00031         ON_BN_CLICKED(IDC_BUTTON_COUNT_DEVICES, OnBnClickedButtonCountDevices)
00032         ON_NOTIFY(UDN_DELTAPOS, IDC_SPIN_SELECT_DEVICE, OnDeltaposSpinSelectDevice)
00033         ON_BN_CLICKED(IDC_BUTTON_CLOSE_DEVICE, OnBnClickedButtonCloseDevice)
00034
00035         ON_BN_CLICKED(IDC_CHECK_TYPE_IP_ADDRESS, OnBnClickedCheckTypeIpAddress)
00036         ON_BN_CLICKED(IDC_BUTTON_CLIPBOARD_COPY, OnBnClickedButtonClipboardCopy)
00037         ON_EN_CHANGE(IDC_SPECTRUM_REFRESH_TIME, OnEnChangeSpectrumRefreshTime)
00038         ON_BN_CLICKED(IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT, OnBnClickedButtonSpectrumRefreshDefault)
00039
00040         ON_WM_HELPINFO()
00041
00042 END_MESSAGE_MAP()
00043
00044 // CSelectDP5 dialog
00045
00046 //IDD_DP5_CONNECT
00047
00048 //IMPLEMENT_DYNAMIC(CSelectDP5, CDialog)
00049 //CSelectDP5::CSelectDP5(CWnd* pParent /*=NULL*/)
00050 //      : CDialog(CSelectDP5::IDD, pParent)
00051
00052 //CSelectDP5::CSelectDP5(CWnd* pParent /*=NULL*/)
00053 //      : CDialog(_T("IDD_DP5_CONNECT"), pParent)
00054 //CSelectDP5::CSelectDP5(CWnd* pParent /*=NULL*/)
00055 //      : CDialog("IDD_DP5_CONNECT")
00056
00057 CSelectDP5::CSelectDP5() : CDialog(_T("IDD_DP5_CONNECT"))
00058 {
00059         bTypeInIPAddress = FALSE;
00060 }
00061
00062 //CSelectDP5::~CSelectDP5()
00063 //{
00064 //}
00065
00066 void CSelectDP5::DoDataExchange(CDataExchange* pDX)
00067 {
00068         CDialog::DoDataExchange(pDX);
00069         //{{AFX_DATA_MAP(CSpectrumDlg)
00070         // netfinder display
00071         DDX_Control(pDX, IDC_STATIC_NETFINDER1, lblNetFinder[0]);
00072         DDX_Control(pDX, IDC_STATIC_NETFINDER2, lblNetFinder[1]);
00073         DDX_Control(pDX, IDC_STATIC_NETFINDER3, lblNetFinder[2]);
00074         DDX_Control(pDX, IDC_STATIC_NETFINDER4, lblNetFinder[3]);
00075
00076         DDX_Control(pDX, IDC_STATIC_FOUND1, lblDppFound[0]);
00077         DDX_Control(pDX, IDC_STATIC_FOUND2, lblDppFound[1]);
00078         DDX_Control(pDX, IDC_STATIC_FOUND3, lblDppFound[2]);
00079
00080         DDX_Control(pDX, IDC_COMBO_COMPORT, cboComPort);
00081
00082         DDX_Control(pDX, IDC_SPIN_SELECT_DEVICE, m_SpinSelectDevice);
00083
00084         DDX_Control(pDX, IDC_CHECK_TYPE_IP_ADDRESS, m_TypeInIPAddressCheck);
00085
00086         DDX_Control(pDX, IDC_SPECTRUM_REFRESH_TIME, m_SpectrumRefreshTimeCtrl);
00087         //}}AFX_DATA_MAP
00088 }
00089
00090
00091
00092 BOOL CSelectDP5::OnInitDialog()
00093 {
00094         CDialog::OnInitDialog();
00095
00096         m_bModified = FALSE;
00097
00098         CString strDataRefresh;
00099         long lDataRefresh;
00100         ComPortEnum();
00101         lDataRefresh = s.profile->data_refresh;
00102         if ((lDataRefresh < 500) || (lDataRefresh > 20000)) { // 500-20,000 milli seconds
00103                 lDataRefresh = 1000;
00104                 s.profile->data_refresh = 1000;
00105         }
00106         strDataRefresh.Format("%d",s.profile->data_refresh);
00107         m_SpectrumRefreshTimeCtrl.SetWindowText(strDataRefresh);
00108
00109         m_TypeInIPAddressCheck.SetCheck(bTypeInIPAddress);
00110
00111         s.DppWinUSB.NumDevices = 0;
00112         GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText("0");
00113         s.DppWinUSB.CurrentDevice = 1;
00114         m_SpinSelectDevice.SetRange(1,1);
00115         m_SpinSelectDevice.SetPos(1);
00116         GetDlgItem(IDC_STATIC_NUM_DEVICES2)->SetWindowText("1");
00117
00118         IpSelectBtn[0] = IDC_BUTTON_IP_SELECT1;
00119         IpSelectBtn[1] = IDC_BUTTON_IP_SELECT2;
00120         IpSelectBtn[2] = IDC_BUTTON_IP_SELECT3;
00121         IpSelectBtn[3] = IDC_BUTTON_IP_SELECT4;
00122
00123         // TODO: Add extra initialization here
00124         GetDlgItem(IDC_EDIT_IP_ADDR1)->SetWindowText("192");
00125         GetDlgItem(IDC_EDIT_IP_ADDR2)->SetWindowText("168");
00126         GetDlgItem(IDC_EDIT_IP_ADDR3)->SetWindowText("0");
00127         GetDlgItem(IDC_EDIT_IP_ADDR4)->SetWindowText("230");
00128         GetDlgItem(IDC_EDIT_IP_PORT)->SetWindowText("10001");
00129         //UpdateNetfinderIpAddr(s.SockAddr);
00130
00131         UpdateNetfinderIpAddr(s.profile->SockAddr);
00132         s.NetfinderActive = FALSE;
00133         m_PrevOwner = s.m_DppSck.m_Owner;
00134         s.m_DppSck.m_Owner = sockownStartDlg;
00135         s.m_DppSck.CreateSocket(this);
00136
00137         GetDlgItem(IDC_BUTTON_SERIAL_REQ_DATA)->EnableWindow(FALSE);
00138         GetDlgItem(IDC_COMBO_COMPORT)->EnableWindow(TRUE);
00139         cboComPort.SetCurSel(0);
00140         if ((s.profile->ComPort > 0) && (s.profile->ComPort <= 17)) {
00141                 SetComPortID(s.profile->ComPort);
00142                 //cboComPort.SetCurSel(s.profile->ComPort - 1);
00143         }
00144
00145         lblDppFound[RS232]
00146                 .SetFontName("Arial")
00147                 .SetFontSize(14)
00148                 .SetTextColor(colorLightSlateGray)
00149                 .SetBkColor(colorLightSteelBlue)
00150                 .SetFontBold(TRUE);
00151         lblDppFound[RS232].ShowWindow(SW_HIDE);
00152         s.isDppFound[RS232] = FALSE;
00153
00154         lblDppFound[USB]
00155                 .SetFontName("Arial")
00156                 .SetFontSize(14)
00157                 .SetTextColor(colorLightSlateGray)
00158                 .SetBkColor(colorLightSteelBlue)
00159                 .SetFontBold(TRUE);
00160
00161         if (s.DppWinUSB.devInfo.deviceConnected) {
00162                 lblDppFound[USB].ShowWindow(SW_SHOW);
00163         } else {
00164                 lblDppFound[USB].ShowWindow(SW_HIDE);
00165         }
00166
00167         lblDppFound[ETHERNET]
00168                 .SetFontName("Arial")
00169                 .SetFontSize(14)
00170                 .SetTextColor(colorLightSlateGray)
00171                 .SetBkColor(colorLightSteelBlue)
00172                 .SetFontBold(TRUE);
00173
00174         if (s.CurrentInterface < RS232) {
00175                 s.CurrentInterface = RS232;
00176         } else if (s.CurrentInterface > ETHERNET) {
00177                 s.CurrentInterface = ETHERNET;
00178         }
00179         if (s.CurrentInterface == RS232) {
00180                 CheckRadioButton(IDC_RADIO_COMMTYPE1, IDC_RADIO_COMMTYPE3, IDC_RADIO_COMMTYPE1);
00181         } else if (s.CurrentInterface == USB) {
00182                 CheckRadioButton(IDC_RADIO_COMMTYPE1, IDC_RADIO_COMMTYPE3, IDC_RADIO_COMMTYPE2);
00183         } else if (s.CurrentInterface == ETHERNET) {
00184                 CheckRadioButton(IDC_RADIO_COMMTYPE1, IDC_RADIO_COMMTYPE3, IDC_RADIO_COMMTYPE3);
00185         }
00186         EnableCommFunctions(s.CurrentInterface);        // initialize interface selection
00187
00188         if (s.CurrentInterface == USB) {
00189                 OnBnClickedButtonCountDevices();
00190                 OnBnClickedButtonFindUsbDevice();
00191         }
00192         CenterWindow();
00193         return TRUE;  // return TRUE unless you set the focus to a control
00194         // EXCEPTION: OCX Property Pages should return FALSE
00195 }
00196
00197
00198 // CSelectDP5 message handlers
00199
00200
00201 void CSelectDP5::OnBnClickedButtonFindDp5Ip()
00202 {
00203         CString strSockAddr;
00204         unsigned long SockAddr;
00205
00206         for(int idxIP=0;idxIP<4;idxIP++){
00207                 GetDlgItem(IpSelectBtn[idxIP])->ShowWindow(SW_HIDE);
00208                 IpSelectAddr[idxIP] = 0;
00209         }
00210         lblDppFound[2].ShowWindow(SW_HIDE);
00211         GetDlgItem(IDC_STATIC_IP_SERIAL_NUM)->ShowWindow(SW_HIDE);
00212         FindDpp.InitAllEntries();
00213         ClearNetFinderStatusAll();
00214         if (bTypeInIPAddress) {
00215                 strSockAddr = FindDpp.SockAddr_DlgToStr(this,IDC_EDIT_IP_ADDR1,IDC_EDIT_IP_ADDR2,IDC_EDIT_IP_ADDR3,IDC_EDIT_IP_ADDR4);
00216                 SockAddr = FindDpp.SockAddr_StrToULong(strSockAddr);    // Test IP Address
00217                 ReqDataStatusSock(SockAddr);
00218                 s.NetfinderActive = FALSE;
00219         } else {
00220                 SendBroadcast(TRUE);
00221                 s.NetfinderActive = TRUE;
00222         }
00223 }
00224
00225 //void CSelectDP5::OnReceive(int nErrorCode)
00226 LONG CSelectDP5::OnReceive(WPARAM ch, LPARAM Bytes)
00227 {
00228         //if (s.NetfinderActive) {
00229         //      ReceivePacket();
00230         //} else {
00231         //      ReceivePacket();
00232         //      // get data
00233         //}
00234         ReceivePacket();
00235         return 0;
00236 }
00237
00238
00239 void CSelectDP5::ReceivePacket()
00240 {
00241
00242         unsigned char buffer[4096] = {0};
00243         int num_bytes;
00244
00245         //---------------------------------------------------------------
00246         // Receive Packet from Buffer
00247         //---------------------------------------------------------------
00248
00249         // IP and Port of sender.
00250         CString destIP;
00251         UINT destPort;
00252         BOOL IpAddrFound;
00253         CString strSockAddr;
00254         unsigned long SockAddr;
00255         unsigned long SockAddrNew;
00256         int EntryFound;
00257         //int TestEntry;
00258         //CString strPort;
00259         BOOL bHaveNetFinderPacket;
00260         BOOL bDiscardPacket;
00261         int iBufferSize;
00262         int idxBuff;
00263         unsigned long TypeInSockAddr;
00264
00265         num_bytes = s.m_DppSck.ReceiveFrom(buffer, 4096, destIP, destPort);
00266         //strPort.Format(" Port: %d",destPort);
00267
00268         //AfxMessageBox(destIP + strPort);
00269
00270         // Check for errors
00271         if(num_bytes >= 10000){
00272
00273                 // Handle Error
00274                 AfxMessageBox("Error receiving data");
00275                 return;
00276
00277         }
00278         //AfxMessageBox("Received Packet");
00279         //---------------------------------------------------------------
00280         // Verify NetFinder Packet
00281         //---------------------------------------------------------------
00282         bHaveNetFinderPacket = FALSE;
00283         bDiscardPacket = FALSE;
00284         if (!s.NetfinderActive) {
00285                 // check for Amptek protocol Netfinder packet
00286                 if ((buffer[0] == 0xF5) &&
00287                         (buffer[1] == 0xFA) &&
00288                         (buffer[2] == 0x82) &&
00289                         (buffer[3] == 0x08)) {
00290                         iBufferSize = (int)(buffer[4] << 8) + (int)buffer[5];
00291                         if (iBufferSize < num_bytes) {  // fix the buffer for NetFinder class
00292                                 for(idxBuff=0;idxBuff<iBufferSize;idxBuff++){
00293                                         buffer[idxBuff] = buffer[idxBuff+6];
00294                                 }
00295                                 for(idxBuff=iBufferSize;idxBuff<iBufferSize+6;idxBuff++){
00296                                         buffer[idxBuff] = NULL;
00297                                 }
00298                                 strSockAddr = FindDpp.SockAddr_DlgToStr(this,IDC_EDIT_IP_ADDR1,IDC_EDIT_IP_ADDR2,IDC_EDIT_IP_ADDR3,IDC_EDIT_IP_ADDR4);
00299                                 TypeInSockAddr = FindDpp.SockAddr_StrToULong(strSockAddr);      // Test IP Address
00300                                 bHaveNetFinderPacket = TRUE;    // have Amptek protocol Netfinder packet
00301                         }
00302                 }
00303         } else {        //netfinder is active check for response
00304                 //      check for Silicon Labs Netfinder protocol
00305                 //      Check minimum packet size
00306                 //  Check packet type field (must be 0x01)
00307                 //      Verify random number
00308                 if ((num_bytes >= 32) &&
00309                         (buffer[0] == 0x01) &&
00310                         (buffer[2] == (FindDpp.m_rand >> 8)) &&
00311                         (buffer[3] == (FindDpp.m_rand & 0x00FF))) {
00312                         bHaveNetFinderPacket = TRUE;    // have Silicon Labs Netfinder packet
00313                 }  else if((buffer[0] == 0x00) &&
00314                         (buffer[2] == (FindDpp.m_rand >> 8)) &&
00315                         (buffer[3] == (FindDpp.m_rand & 0x00FF))) {
00316                         bDiscardPacket = TRUE;
00317                 }
00318                 // Discard Packet
00319                 // We have received an identity request from another host.
00320                 // This is a very rare case in which the PC randomly chooses port 3040
00321                 // for the netfinder app and the same random number is chosen.
00322         }
00323
00324         if (bHaveNetFinderPacket) {
00325                 EntryFound = NO_ENTRIES;
00326                 //TestEntry = NO_ENTRIES;
00327                 if (FindDpp.LastEntry == NO_ENTRIES) {  // Add entry
00328                         FindDpp.LastEntry = 0;
00329                         FindDpp.AddEntry(&FindDpp.DppEntries[FindDpp.LastEntry], buffer, destPort);
00330                         //TestEntry = FindDpp.LastEntry;
00331                 } else {
00332                         SockAddr = FindDpp.SockAddr_ByteToULong(&buffer[20]);
00333                         EntryFound = FindDpp.FindEntry(SockAddr);
00334                         if (EntryFound > NO_ENTRIES) {          // update an existing entry
00335                                 FindDpp.InitEntry(&FindDpp.DppEntries[EntryFound]);
00336                                 FindDpp.AddEntry(&FindDpp.DppEntries[EntryFound], buffer, destPort);
00337                                 //TestEntry = EntryFound;
00338                         } else {                                                        // Add entry
00339                                 // 20140430 Limit number of devices that can be added to Ethernet device list
00340                                 // LastEntry must be less than MAX_ENTRIES
00341                                 // any number of devices can be scanned
00342                                 // only MAX_ENTRIES number of devices can be stored
00343                                 // only 4 devices can be displayed at a time
00344                                 if (FindDpp.LastEntry < (MAX_ENTRIES - 1)) {
00345                                         FindDpp.LastEntry++;
00346                                         FindDpp.AddEntry(&FindDpp.DppEntries[FindDpp.LastEntry], buffer, destPort);
00347                                         //TestEntry = FindDpp.LastEntry;
00348                                 }
00349                         }
00350                 }
00351
00352                 ClearNetFinderStatusAll();
00353                 CString strStatus;
00354                 COLORREF rgbConnect;
00355                 IpAddrFound = FALSE;
00356                 lblDppFound[ETHERNET].ShowWindow(SW_HIDE);
00357                 s.isDppFound[ETHERNET] = FALSE;
00358                 strSockAddr = FindDpp.SockAddr_DlgToStr(this,IDC_EDIT_IP_ADDR1,IDC_EDIT_IP_ADDR2,IDC_EDIT_IP_ADDR3,IDC_EDIT_IP_ADDR4);
00359                 SockAddr = FindDpp.SockAddr_StrToULong(strSockAddr);    // Test IP Address
00360                 if (FindDpp.LastEntry > NO_ENTRIES) {
00361                         for (int idxEntry=0;idxEntry<=FindDpp.LastEntry;idxEntry++) {
00362                                 if (idxEntry < 4) {             // only 4 displays
00363                                         strStatus = FindDpp.DppEntries[idxEntry].str_display;
00364                                         rgbConnect = FindDpp.DppEntries[idxEntry].ccConnectRGB;
00365                                         if (bTypeInIPAddress) {
00366                                                 // a amptek protocol netfinder packet has been received
00367                                                 // the netfinder packet will have the devices local address
00368                                                 // the local address may not equal the inet ip address
00369                                                 // this not an error, use type in address as test place holder
00370                                                 // the socket data source address can be used
00371                                                 // in place of this value
00372                                                 SockAddrNew = TypeInSockAddr;
00373                                         } else {
00374                                                 SockAddrNew = FindDpp.DppEntries[idxEntry].SockAddr;
00375                                         }
00376                                         GetDlgItem(IpSelectBtn[idxEntry])->ShowWindow(SW_SHOW);
00377                                         IpSelectAddr[idxEntry] = SockAddrNew;
00378                                         if (SockAddr == SockAddrNew) {
00379                                                 IpAddrFound = TRUE;
00380                                                 //AfxMessageBox("Found");
00381                                                 lblDppFound[2].ShowWindow(SW_SHOW);
00382
00383                                                 s.isDppFound[ETHERNET] = TRUE;
00384                                                 //s.SockAddr = SockAddr;                // 20110502 rem dups use profile only
00385                                                 s.profile->SockAddr = SockAddr;
00386
00387                                                 //s.strSockAddr = FindDpp.SockAddr_ULongToStr(s.SockAddr);      // 20110502
00388                                                 s.strSockAddr = FindDpp.SockAddr_ULongToStr(s.profile->SockAddr);       // 20110502
00389                                                 GetDlgItem(IDC_STATIC_IP_SERIAL_NUM)->SetWindowText(s.strSockAddr);
00390                                                 GetDlgItem(IDC_STATIC_IP_SERIAL_NUM)->ShowWindow(SW_SHOW);
00391                                                 s.m_DppSck.DppPort = FindDpp.SockPort_DlgToUINT(this,IDC_EDIT_IP_PORT);
00392                                                 // s.m_DppSck.DppAddr = s.SockAddr;     s.profile->SockAdd
00393                                                 s.m_DppSck.DppAddr = s.profile->SockAddr;
00394                                         }
00395                                         UpdateNetFinderStatus(strStatus, rgbConnect, idxEntry);
00396                                 }
00397                         }
00398                 }
00399         }
00403 }
00404
00405 void CSelectDP5::UpdateNetFinderStatus(CString strStatus, COLORREF rgbConnect, int idxEntry)
00406 {
00407         lblNetFinder[idxEntry].SetBkColor(rgbConnect);  // set the color first
00408         UpdateData(FALSE);
00409         lblNetFinder[idxEntry].SetText(strStatus);
00410         UpdateData(FALSE);
00411 }
00412
00413 void CSelectDP5::ClearNetFinderStatus(int idxEntry)
00414 {
00415         lblNetFinder[idxEntry].SetBkColor(colorWhite);
00416         UpdateData(FALSE);
00417         lblNetFinder[idxEntry].SetWindowText("");
00418         UpdateData(FALSE);
00419 }
00420
00421 void CSelectDP5::ClearNetFinderStatusAll()
00422 {
00423         int idxEntry;
00424         for (idxEntry=0;idxEntry<4;idxEntry++){
00425                 ClearNetFinderStatus(idxEntry);
00426         }
00427 }
00428
00429 void CSelectDP5::ReqDataStatusSock(unsigned long DppAddr)
00430 {
00431         //-----------------------------------------------------------------
00432         // Send Broadcast Identity Request Packets
00433         //-----------------------------------------------------------------
00434         // Note: This section may be moved to a function to allow
00435         // multiple re-tries.
00436         //
00437         //unsigned char buff[8] = { 0xF5, 0xFA, 0x02, 0x03, 0x00, 0x00, 0xFE, 0x0C };
00438         unsigned char buff[8] = { 0xF5, 0xFA, 0x03, 0x07, 0x00, 0x00, 0xFE, 0x07 };
00439
00440         int dwBytes;
00441
00442         SOCKADDR_IN remoteAddr;
00443         remoteAddr.sin_family = AF_INET;
00444         remoteAddr.sin_port = htons(10001);
00445         //DppAddr = inet_addr("192.168.0.230");
00446         remoteAddr.sin_addr.s_addr = DppAddr;
00447         dwBytes =s.m_DppSck.SendTo(buff, 8, (const SOCKADDR* )&remoteAddr, sizeof(remoteAddr));
00448         if(SOCKET_ERROR == dwBytes){
00449                 CString str;
00450                 str.Format("Error Code: %i.", GetLastError());
00451                 AfxMessageBox(str + " Unable To Send Packet. Please Check Network Connection.");
00452         }
00453 }
00454
00455
00456 // Send Dpp Style NetFinder Broadcast Identity Request Packets
00457 void CSelectDP5::SendBroadcast(BOOL NewRand)
00458 {
00459         int m_rand;
00460         unsigned char buff[6] = { 0,0,0,0,0xF4,0xFA };
00461         if (NewRand) {
00462                 do{
00463                         m_rand = (rand()); // rand returns a number between 0 and 0x7FFF
00464                 } while(m_rand == 0);    // make sure m_rand is not zero
00465         }
00466         buff[2] = (m_rand >> 8);
00467         buff[3] = (m_rand & 0x00FF);
00468         FindDpp.m_rand = m_rand;                // save to netfinder for dpp response detection
00469         if(SOCKET_ERROR == s.m_DppSck.SendTo(buff, 6, 3040, NULL)){
00470                 CString str;
00471                 str.Format("Error Code: %i.", GetLastError());
00472                 AfxMessageBox(str + " Unable To Send Packet. Please Check Network Connection.");
00473         }
00474 }
00475
00476 BOOL CSelectDP5::DestroyWindow()
00477 {
00478         // TODO: Add your specialized code here and/or call the base class
00479
00480         // inet and rs232 need setup for data redirection to main dialog
00481         if (s.m_DppPort.IsPortOpen()) {         // close the port, if selected will be reopened
00482                 s.m_DppPort.ClosePort();
00483         }
00484         s.m_DppSck.m_Owner = m_PrevOwner;       // reassign previous owner
00485         return CDialog::DestroyWindow();
00486 }
00487
00488 void CSelectDP5::ComPortEnum()
00489 {
00490         cboComPort.ResetContent();
00491
00492         for (int i = 1; i < 255; i++) {
00493                 char szComPortName[32];
00494                 char szComboName[32];
00495                 sprintf (szComPortName, "\\\\.\\COM%d", i);
00496                 sprintf (szComboName, "COM%d", i);
00497                 HANDLE hPort = CreateFile(
00498                         szComPortName,
00499                         GENERIC_READ,
00500                         FILE_SHARE_READ | FILE_SHARE_WRITE,
00501                         NULL,
00502                         OPEN_EXISTING,
00503                         FILE_ATTRIBUTE_NORMAL,
00504                         NULL
00505                 );
00506                 if (hPort != INVALID_HANDLE_VALUE){
00507                         CloseHandle(hPort);
00508                         hPort = NULL;
00509                         cboComPort.AddString(szComboName);
00510                 }
00511         }
00512 }
00513
00514 int CSelectDP5::GetComPortID()
00515 {
00516         int iComPort=0;
00517         CString strCom("");
00518         cboComPort.GetWindowText(strCom);
00519         iComPort = atoi(strCom.Mid(3));
00520         return iComPort;
00521 }
00522
00523 void CSelectDP5::SetComPortID(int iComPort)
00524 {
00525         CString strComPort;
00526         int iComPortIndex=0;
00527         strComPort.Format("COM%d",iComPort);
00528         iComPortIndex = cboComPort.FindStringExact(0,strComPort);
00529         if (iComPortIndex == -1) {
00530                 if (cboComPort.GetCount() > 0) {
00531                         iComPortIndex = 0;
00532                 }
00533         }
00534         cboComPort.SetCurSel(iComPortIndex);
00535 }
00536
00537 void CSelectDP5::OnBnClickedButtonClosePort()
00538 {
00539         if (s.m_DppPort.IsPortOpen()) {
00540                 GetDlgItem(IDC_BUTTON_SERIAL_REQ_DATA)->EnableWindow(FALSE);
00541                 s.m_DppPort.ClosePort();
00542                 GetDlgItem(IDC_COMBO_COMPORT)->EnableWindow(TRUE);
00543                 lblDppFound[RS232].ShowWindow(SW_HIDE);
00544                 s.isDppFound[RS232] = FALSE;
00545         }
00546 }
00547
00548 void CSelectDP5::OnBnClickedButtonOpenPort()
00549 {
00550         UINT ComPort;
00551         if (!s.m_DppPort.IsPortOpen()) {
00552                 // init the port
00553                 ComPort = GetComPortID();
00554                 //ComPort = (UINT)(cboComPort.GetCurSel()+1);
00555                 //if (m_DppPort.Settings(this, 1, 115200, 'N', 8, 1, EV_RXCHAR, 1024)) {
00556
00557                 //20120725 VARIABLE_BAUD_RATE s.profile->baud_rate
00558                 if (s.m_DppPort.Settings(this, ComPort, s.profile->baud_rate, 'N', 8, 1, EV_RXCHAR, 1024)) {
00559                 //if (s.m_DppPort.Settings(this, ComPort, 115200, 'N', 8, 1, EV_RXCHAR, 1024)) {
00560                         GetDlgItem(IDC_COMBO_COMPORT)->EnableWindow(FALSE);
00561                         s.m_DppPort.OpenPort();
00562                         GetDlgItem(IDC_BUTTON_SERIAL_REQ_DATA)->EnableWindow(TRUE);
00563                         s.profile->ComPort = ComPort;
00564                         //s.ComPort = ComPort;
00565                 }
00566         }
00567 }
00568
00569 LONG CSelectDP5::OnCommunication(WPARAM ch, LPARAM Bytes)
00570 {
00571
00572         DWORD BytesRead;
00573         BytesRead = (DWORD)Bytes;
00574         if (BytesRead == 0)
00575                 return -1;
00576
00577         DataIn[s.DP5Proto.RS232BytesInBuffer]=(unsigned char)ch;
00578         s.DP5Proto.RS232BytesInBuffer+=BytesRead;
00579
00580         // this calls OnComm for RxChar Events
00581         if (s.DP5Proto.RS232_RThreshold == 0) { // always call if thresh == 0
00582                 OnComm();
00583         } else if (s.DP5Proto.RS232BytesInBuffer >= s.DP5Proto.RS232_RThreshold) {
00584                 OnComm();
00585         }
00586         return 0;
00587 }
00588
00589 void CSelectDP5::OnComm()
00590 {
00591         long pktLen;
00592         unsigned char buffer[4096] = {0};
00593         CString strPort;
00594
00595         if (s.DP5Proto.RS232HeaderReceived) {
00596                 s.DP5Proto.RS232HeaderReceived = FALSE;
00597                 FindDppRS232.InitAllEntries();
00598                 pktLen = (long)((DataIn[4] * 256) + DataIn[5] + 8);   // temporarily save the length field
00599                 if (s.DP5Proto.RS232BytesInBuffer == s.DP5Proto.RS232_RThreshold) {
00600                         //for (int i=0; i< 64;i++) {
00601                         //      m_DP5_Status.RAW[i] = DataIn[i+3078];
00602                         //}
00603                         //s.DP5Stat.Process_Status(&m_DP5_Status);
00604
00605
00606                         for (int i=0; i< pktLen;i++) {
00607                                 buffer[i] = DataIn[i+6];
00608                         }
00609                         FindDppRS232.AddEntry(&FindDppRS232.DppEntries[0], buffer, 0);
00610                         CString strStatus;
00611                         cboComPort.GetWindowText(strPort);
00612                         strStatus = FindDppRS232.EntryToStrRS232(&FindDppRS232.DppEntries[0], ("RS232 - " + strPort));
00613                         GetDlgItem(IDC_EDIT_DPPCOMM_STATUS)->SetWindowText(strStatus);
00614                         lblDppFound[RS232].ShowWindow(SW_SHOW);
00615                         s.isDppFound[RS232] = TRUE;
00616                 }
00617                 s.DP5Proto.RS232_RThreshold = 8;
00618         } else {
00619                 if (s.DP5Proto.RS232BytesInBuffer >= s.DP5Proto.RS232_RThreshold) {
00620                         if ((DataIn[0] == 0xF5) && (DataIn[1] == 0xFA)) {
00621                                 pktLen = (long)((DataIn[4] * 256) + DataIn[5] + 8);   // temporarily save the length field
00622                 if (pktLen > 0) {
00623                     s.DP5Proto.RS232_RThreshold = pktLen;   // additional bytes to read = data length
00624                                         //SetDataRcvTimer(RS232_RThreshold);
00625                     s.DP5Proto.RS232HeaderReceived = TRUE;
00626                 } else {
00627                     //ParsePacket(DataIn[]);
00628                 }
00629             } else {
00630                 memset(&DataIn, 0, sizeof(DataIn));  // flush the buffer by emptying it
00631                         }
00632                 }
00633         }
00634 }
00635
00636 void CSelectDP5::ReqDataStatus()
00637 {
00638         //-----------------------------------------------------------------
00639         // request data and status
00640         //-----------------------------------------------------------------
00641
00642         //unsigned char buff[8] = { 0xF5, 0xFA, 0x02, 0x03, 0x00, 0x00, 0xFE, 0x0C };
00643         // NetFinder Packet
00644         unsigned char buff[8] = { 0xF5, 0xFA, 0x03, 0x07, 0x00, 0x00, 0xFE, 0x07 };
00645         memset(&DataIn, 0, sizeof(DataIn));
00646         s.DP5Proto.RS232BytesInBuffer = 0;
00647         s.DP5Proto.RS232HeaderReceived = FALSE;
00648         s.DP5Proto.RS232_RThreshold = 8;
00649         s.m_DppPort.WriteData(buff, sizeof(buff));
00650 }
00651
00652 void CSelectDP5::OnBnClickedButtonSerialReqData()
00653 {
00654         lblDppFound[RS232].ShowWindow(SW_HIDE);
00655         s.isDppFound[RS232] = FALSE;
00656         ReqDataStatus();
00657 }
00658
00659 void CSelectDP5::OnBnClickedRadioCommtype1()
00660 {
00661         s.CurrentInterface = RS232;
00662         EnableCommFunctions(RS232);
00663 }
00664
00665 void CSelectDP5::OnBnClickedRadioCommtype2()
00666 {
00667         s.CurrentInterface = USB;
00668         EnableCommFunctions(USB);
00669         OnBnClickedButtonCountDevices();
00670         OnBnClickedButtonFindUsbDevice();
00671 }
00672
00673 void CSelectDP5::OnBnClickedRadioCommtype3()
00674 {
00675         s.CurrentInterface = ETHERNET;
00676         EnableCommFunctions(ETHERNET);
00677         OnBnClickedButtonFindDp5Ip();
00678 }
00679
00680 void CSelectDP5::OnBnClickedButtonFindUsbDevice()
00681 {
00682         TRANSMIT_PACKET_TYPE XmtCmd;
00683     BOOL HaveBuffer;
00684     BOOL SentPkt;
00685
00686         string strUSBStatus;
00687         DPP_USB_STATUS USBStatus;       //0=do nothing, 1=new connect, 2=cannot connect
00688
00689         long pktLen;
00690         unsigned char buffer[4096] = {0};
00691         //CONFIG_OPTIONS CfgOptions;
00692
00693         //CfgOptions.DppType = s.DP5Stat.m_DP5_Status.DEVICE_ID;
00694         //CfgOptions.HwCfgDP5Out = s.HwCfgDP5Out;
00695         //CfgOptions.PC5_PRESENT = s.DP5Stat.m_DP5_Status.PC5_PRESENT;
00696         //CfgOptions.SendCoarseFineGain = FALSE;
00697
00698         OnBnClickedButtonCloseDevice();
00699
00700         USBStatus = s.DppWinUSB.FindUSBDevice(s.DppWinUSB.CurrentDevice - 1);
00701         if (USBStatus != dusbStatNoAction) {
00702                 strUSBStatus = s.DppWinUSB.USBStatusString(USBStatus);
00703                 GetDlgItem(IDC_EDIT_STATUS2)->SetWindowText(strUSBStatus.c_str());
00704                 if (USBStatus == dusbStatNewConnect) {
00705                         s.CurrentInterface = USB;
00706                 }
00707         }
00708         if (s.DppWinUSB.devInfo.deviceConnected) {
00709                 lblDppFound[USB].ShowWindow(SW_SHOW);
00710                 s.isDppFound[USB] = TRUE;
00711                 XmtCmd = XMTPT_SEND_NETFINDER_PACKET;
00712                 HaveBuffer = s.SndCmd.DP5_CMD(s.DP5Proto.BufferOUT, XmtCmd);
00713                 if (HaveBuffer) {
00714                         s.DP5Proto.ACK_Received = false;
00715                         s.DP5Proto.Packet_Received = false; // a response packet is always expected
00716                         s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00717                         SentPkt = s.DppWinUSB.SendPacketUSB(s.DP5Proto.BufferOUT, s.DppWinUSB.devInfo, s.DP5Proto.PacketIn);
00718                 }
00719                 if (SentPkt) {
00720                         FindDppUSB.InitAllEntries();
00721                         pktLen = (long)((s.DP5Proto.PacketIn[4] * 256) + s.DP5Proto.PacketIn[5] + 8);   // temporarily save the length field
00722                         for (int i=0; i< pktLen;i++) {
00723                                 buffer[i] = s.DP5Proto.PacketIn[i+6];
00724                         }
00725                         FindDppUSB.AddEntry(&FindDppUSB.DppEntries[0], buffer, 0);
00726                         CString strStatus;
00727                         CString strDeviceInfo;
00728                         strDeviceInfo.Format("USB Device %d of %d", s.DppWinUSB.CurrentDevice, s.DppWinUSB.NumDevices);
00729                         strStatus = FindDppUSB.EntryToStrUSB(&FindDppUSB.DppEntries[0], strDeviceInfo);
00730                         GetDlgItem(IDC_EDIT_STATUS2)->SetWindowText(strStatus);
00731                 }
00732         } else {
00733                 lblDppFound[USB].ShowWindow(SW_HIDE);
00734                 s.isDppFound[USB] = FALSE;
00735         }
00736 }
00737
00738 void CSelectDP5::EnableCommFunctions(int ControlGroup)
00739 {
00740         BOOL isSComEnabled;
00741         BOOL isDUSBEnabled;
00742         BOOL isINETEnabled;
00743
00744         int ShowSComEnabled;
00745         int ShowDUSBEnabled;
00746         int ShowINETEnabled;
00747
00748         isSComEnabled = FALSE;
00749         isDUSBEnabled = FALSE;
00750         isINETEnabled = FALSE;
00751         ShowSComEnabled = SW_HIDE;
00752         ShowDUSBEnabled = SW_HIDE;
00753         ShowINETEnabled = SW_HIDE;
00754
00755         switch (ControlGroup) {
00756                 case RS232:
00757                         isSComEnabled = TRUE;
00758                         ShowSComEnabled = isSComEnabled * SW_SHOW;
00759                         break;
00760                 case USB:
00761                         isDUSBEnabled = TRUE;
00762                         ShowDUSBEnabled = isDUSBEnabled * SW_SHOW;
00763                         break;
00764                 case ETHERNET:
00765                         isINETEnabled = TRUE;
00766                         ShowINETEnabled = isINETEnabled * SW_SHOW;
00767                         break;
00768         }
00769
00770         // Serial Comm
00771         GetDlgItem(IDC_BUTTON_OPEN_PORT)->EnableWindow(isSComEnabled);
00772         GetDlgItem(IDC_BUTTON_CLOSE_PORT)->EnableWindow(isSComEnabled);
00773         GetDlgItem(IDC_BUTTON_SERIAL_REQ_DATA)->EnableWindow(isSComEnabled);
00774         GetDlgItem(IDC_COMBO_COMPORT)->EnableWindow(isSComEnabled);
00775         GetDlgItem(IDC_EDIT_DPPCOMM_STATUS)->EnableWindow(isSComEnabled);
00776         GetDlgItem(IDC_EDIT_DPPCOMM_STATUS)->ShowWindow(ShowSComEnabled);
00777
00778         if (ControlGroup == RS232) {
00779                 if (s.m_DppPort.IsPortOpen()) {
00780                         GetDlgItem(IDC_BUTTON_SERIAL_REQ_DATA)->EnableWindow(TRUE);
00781                         GetDlgItem(IDC_COMBO_COMPORT)->EnableWindow(FALSE);
00782                 } else {
00783                         GetDlgItem(IDC_BUTTON_SERIAL_REQ_DATA)->EnableWindow(FALSE);
00784                         GetDlgItem(IDC_COMBO_COMPORT)->EnableWindow(TRUE);
00785                 }
00786         }
00787
00788         if (ControlGroup != RS232) {
00789                 lblDppFound[RS232].SetNullColor();
00790         } else {
00791                 lblDppFound[RS232].SetLastColor();
00792         }
00793
00794         // WinUsb
00795         GetDlgItem(IDC_BUTTON_FIND_USB_DEVICE)->EnableWindow(isDUSBEnabled);
00796         GetDlgItem(IDC_EDIT_STATUS2)->EnableWindow(isDUSBEnabled);
00797
00798         GetDlgItem(IDC_BUTTON_COUNT_DEVICES)->EnableWindow(isDUSBEnabled);
00799         GetDlgItem(IDC_STATIC_NUM_DEVICES)->EnableWindow(isDUSBEnabled);
00800         GetDlgItem(IDC_STATIC_SELECT_USB_DEVICE_LABEL)->EnableWindow(isDUSBEnabled);
00801         GetDlgItem(IDC_SPIN_SELECT_DEVICE)->EnableWindow(isDUSBEnabled);
00802         GetDlgItem(IDC_STATIC_NUM_DEVICES2)->EnableWindow(isDUSBEnabled);
00803         GetDlgItem(IDC_BUTTON_CLOSE_DEVICE)->EnableWindow(isDUSBEnabled);
00804
00805         GetDlgItem(IDC_EDIT_STATUS2)->ShowWindow(ShowDUSBEnabled);
00806
00807         if (ControlGroup != USB) {
00808                 lblDppFound[USB].SetNullColor();
00809         } else {
00810                 lblDppFound[USB].SetLastColor();
00811         }
00812
00813         // Sockets
00814         GetDlgItem(IDC_BUTTON_FIND_DP5_IP)->EnableWindow(isINETEnabled);
00815
00816         GetDlgItem(IDC_EDIT_IP_ADDR1)->EnableWindow(isINETEnabled);
00817         GetDlgItem(IDC_EDIT_IP_ADDR2)->EnableWindow(isINETEnabled);
00818         GetDlgItem(IDC_EDIT_IP_ADDR3)->EnableWindow(isINETEnabled);
00819         GetDlgItem(IDC_EDIT_IP_ADDR4)->EnableWindow(isINETEnabled);
00820         GetDlgItem(IDC_EDIT_IP_PORT)->EnableWindow(isINETEnabled);
00821
00822         GetDlgItem(IDC_STATIC_IP_ADDRESS_LABEL)->EnableWindow(isINETEnabled);
00823         GetDlgItem(IDC_STATIC_PORT_LABEL)->EnableWindow(isINETEnabled);
00824
00825         GetDlgItem(IDC_STATIC_NETFINDER1)->EnableWindow(isINETEnabled);
00826         GetDlgItem(IDC_STATIC_NETFINDER2)->EnableWindow(isINETEnabled);
00827         GetDlgItem(IDC_STATIC_NETFINDER3)->EnableWindow(isINETEnabled);
00828         GetDlgItem(IDC_STATIC_NETFINDER4)->EnableWindow(isINETEnabled);
00829
00830         GetDlgItem(IDC_STATIC_LABEL_IP_1)->EnableWindow(isINETEnabled);
00831         GetDlgItem(IDC_STATIC_LABEL_IP_2)->EnableWindow(isINETEnabled);
00832         GetDlgItem(IDC_STATIC_LABEL_IP_3)->EnableWindow(isINETEnabled);
00833         GetDlgItem(IDC_STATIC_LABEL_IP_4)->EnableWindow(isINETEnabled);
00834
00835         GetDlgItem(IDC_STATIC_NETFINDER1)->ShowWindow(ShowINETEnabled);
00836         GetDlgItem(IDC_STATIC_NETFINDER2)->ShowWindow(ShowINETEnabled);
00837         GetDlgItem(IDC_STATIC_NETFINDER3)->ShowWindow(ShowINETEnabled);
00838         GetDlgItem(IDC_STATIC_NETFINDER4)->ShowWindow(ShowINETEnabled);
00839
00840         GetDlgItem(IDC_STATIC_LABEL_IP_1)->ShowWindow(ShowINETEnabled);
00841         GetDlgItem(IDC_STATIC_LABEL_IP_2)->ShowWindow(ShowINETEnabled);
00842         GetDlgItem(IDC_STATIC_LABEL_IP_3)->ShowWindow(ShowINETEnabled);
00843         GetDlgItem(IDC_STATIC_LABEL_IP_4)->ShowWindow(ShowINETEnabled);
00844         GetDlgItem(IDC_BUTTON_CLIPBOARD_COPY)->ShowWindow(ShowINETEnabled);
00845
00846         // Shared by ALL Comm
00847         GetDlgItem(IDC_RADIO_COMMTYPE1)->EnableWindow(TRUE);    // Serial Comm
00848         GetDlgItem(IDC_RADIO_COMMTYPE2)->EnableWindow(TRUE);    // WinUsb
00849         GetDlgItem(IDC_RADIO_COMMTYPE3)->EnableWindow(TRUE);    // Sockets
00850
00851         if (ControlGroup != ETHERNET) {
00852                 lblNetFinder[0].SetNullColor();
00853                 lblNetFinder[1].SetNullColor();
00854                 lblNetFinder[2].SetNullColor();
00855                 lblNetFinder[3].SetNullColor();
00856                 lblDppFound[ETHERNET].SetNullColor();
00857         } else {
00858                 lblNetFinder[0].SetLastColor();
00859                 lblNetFinder[1].SetLastColor();
00860                 lblNetFinder[2].SetLastColor();
00861                 lblNetFinder[3].SetLastColor();
00862                 lblDppFound[ETHERNET].SetLastColor();
00863         }
00864         for(int idxIP=0;idxIP<4;idxIP++){
00865                 GetDlgItem(IpSelectBtn[idxIP])->EnableWindow(isINETEnabled);
00866         }
00867         GetDlgItem(IDC_STATIC_IP_SERIAL_NUM)->EnableWindow(isINETEnabled);
00868
00869 }
00870
00871 void CSelectDP5::OnBnClickedOk()
00872 {
00873         // TODO: Add your control notification handler code here
00874         OnOK();
00875 }
00876
00877 void CSelectDP5::OnBnClickedButtonIpSelect1()
00878 {
00879         if (!bTypeInIPAddress) {
00880                 UpdateNetfinderIpAddr(IpSelectAddr[0]);
00881         }
00882         if (GetDlgItem(IDC_BUTTON_FIND_DP5_IP)->IsWindowEnabled()) {
00883                 OnBnClickedButtonFindDp5Ip();
00884         }
00885 }
00886
00887 void CSelectDP5::OnBnClickedButtonIpSelect2()
00888 {
00889         UpdateNetfinderIpAddr(IpSelectAddr[1]);
00890         if (GetDlgItem(IDC_BUTTON_FIND_DP5_IP)->IsWindowEnabled()) {
00891                 OnBnClickedButtonFindDp5Ip();
00892         }
00893 }
00894
00895 void CSelectDP5::OnBnClickedButtonIpSelect3()
00896 {
00897         UpdateNetfinderIpAddr(IpSelectAddr[2]);
00898         if (GetDlgItem(IDC_BUTTON_FIND_DP5_IP)->IsWindowEnabled()) {
00899                 OnBnClickedButtonFindDp5Ip();
00900         }
00901 }
00902
00903 void CSelectDP5::OnBnClickedButtonIpSelect4()
00904 {
00905         UpdateNetfinderIpAddr(IpSelectAddr[3]);
00906         if (GetDlgItem(IDC_BUTTON_FIND_DP5_IP)->IsWindowEnabled()) {
00907                 OnBnClickedButtonFindDp5Ip();
00908         }
00909 }
00910
00911 void CSelectDP5::OnStnClickedStaticNetfinder1()
00912 {
00913         if (GetDlgItem(IpSelectBtn[0])->IsWindowEnabled()) {
00914                 if (GetDlgItem(IpSelectBtn[0])->IsWindowVisible()) {
00915                         OnBnClickedButtonIpSelect1();
00916                 }
00917         }
00918 }
00919
00920 void CSelectDP5::OnStnClickedStaticNetfinder2()
00921 {
00922         if (GetDlgItem(IpSelectBtn[1])->IsWindowEnabled()) {
00923                 if (GetDlgItem(IpSelectBtn[1])->IsWindowVisible()) {
00924                         OnBnClickedButtonIpSelect2();
00925                 }
00926         }
00927 }
00928
00929 void CSelectDP5::OnStnClickedStaticNetfinder3()
00930 {
00931         if (GetDlgItem(IpSelectBtn[2])->IsWindowEnabled()) {
00932                 if (GetDlgItem(IpSelectBtn[2])->IsWindowVisible()) {
00933                         OnBnClickedButtonIpSelect3();
00934                 }
00935         }
00936 }
00937
00938 void CSelectDP5::OnStnClickedStaticNetfinder4()
00939 {
00940         if (GetDlgItem(IpSelectBtn[3])->IsWindowEnabled()) {
00941                 if (GetDlgItem(IpSelectBtn[3])->IsWindowVisible()) {
00942                         OnBnClickedButtonIpSelect4();
00943                 }
00944         }
00945 }
00946
00947 void CSelectDP5::UpdateNetfinderIpAddr(unsigned long IpAddr)
00948 {
00949         CString strIp;
00950         in_addr inSockAddr;
00951         inSockAddr.S_un.S_addr = IpAddr;
00952         strIp.Format("%d",inSockAddr.S_un.S_un_b.s_b1);
00953         GetDlgItem(IDC_EDIT_IP_ADDR1)->SetWindowText(strIp);
00954         strIp.Format("%d",inSockAddr.S_un.S_un_b.s_b2);
00955         GetDlgItem(IDC_EDIT_IP_ADDR2)->SetWindowText(strIp);
00956         strIp.Format("%d",inSockAddr.S_un.S_un_b.s_b3);
00957         GetDlgItem(IDC_EDIT_IP_ADDR3)->SetWindowText(strIp);
00958         strIp.Format("%d",inSockAddr.S_un.S_un_b.s_b4);
00959         GetDlgItem(IDC_EDIT_IP_ADDR4)->SetWindowText(strIp);
00960 }
00961
00962 void CSelectDP5::OnBnClickedButtonCountDevices()
00963 {
00964
00965         CDppWinUSB DppWinUSB1;
00966         CString strNumDevices;
00967         s.DppWinUSB.NumDevices = DppWinUSB1.CountDP5WinusbDevices();
00968         if (s.DppWinUSB.CurrentDevice > s.DppWinUSB.NumDevices) {
00969                 s.DppWinUSB.CurrentDevice = 1;
00970                 m_SpinSelectDevice.SetPos(1);
00971                 GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText("1");
00972         }
00973         if (s.DppWinUSB.NumDevices > 1) {
00974                 m_SpinSelectDevice.SetRange(1,s.DppWinUSB.NumDevices);
00975                 m_SpinSelectDevice.EnableWindow(TRUE);
00976         } else {
00977                 s.DppWinUSB.CurrentDevice = 1;
00978                 m_SpinSelectDevice.SetPos(1);
00979                 m_SpinSelectDevice.SetRange(1,1);
00980                 GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText("1");
00981                 m_SpinSelectDevice.EnableWindow(FALSE);
00982         }
00983         strNumDevices.Format("%d",s.DppWinUSB.NumDevices);
00984         GetDlgItem(IDC_STATIC_NUM_DEVICES)->SetWindowText(strNumDevices);
00985         UpdateData(FALSE);      // DDEX from var to cntrl, ie sends var value to control
00986 }
00987
00988 void CSelectDP5::OnDeltaposSpinSelectDevice(NMHDR *pNMHDR, LRESULT *pResult)
00989 {
00990         LPNMUPDOWN pNMUpDown = reinterpret_cast<LPNMUPDOWN>(pNMHDR);
00991         CString strPos;
00992         int iMax = 1;
00993         int iMin = 1;
00994         int iVal = 1;           // old value
00995         int iPos = 1;           // new value (if updated)
00996         int iDelta = 0;         // direction of change
00997         int iNewPos = 1;        // final value
00998         m_SpinSelectDevice.GetRange(iMin, iMax);
00999         if ((iMin != 1) || (iMax < 1)) { return; }      // max/min value errors
01000         if (iMax == 1) {                                                        // 0 or 1 devices
01001                 iNewPos = 1;
01002         } else {                                                                        // max must be greater than 1
01003                 GetDlgItem(IDC_STATIC_NUM_DEVICES2)->GetWindowText(strPos);
01004                 iVal = atoi(strPos);
01005                 iPos = pNMUpDown->iPos;
01006                 iDelta = pNMUpDown->iDelta;
01007                 if (iVal != iPos) {                                             // value was updated
01008                         iNewPos = iPos;
01009                 } else {                                                                // control just enabled, has delta but pos not updated
01010                         iNewPos = iPos + iDelta;                        // update value
01011                         if (iNewPos > iMax) {                           // do wrap if needed
01012                                 iNewPos = iMin;
01013                         } else if (iNewPos < iMin) {
01014                                 iNewPos = iMax;
01015                         }
01016                 }
01017         }
01018         //strPos.Format("iVal %d iPos %d iDelta %d iNewPos %d", iVal, iPos, iDelta, iNewPos);
01019         strPos.Format("%d", iNewPos);
01020         //AfxMessageBox(strPos);
01021         s.DppWinUSB.CurrentDevice = iNewPos;
01022         GetDlgItem(IDC_STATIC_NUM_DEVICES2)->SetWindowText(strPos);
01023         *pResult = 0;
01024 }
01025
01026 void CSelectDP5::OnBnClickedButtonCloseDevice()
01027 {
01028         s.DppWinUSB.devInfo.deviceConnected = FALSE;
01029         s.DppWinUSB.CloseWinUsbDevice();
01030         s.WinusbNotify.RemoveDeviceNotification();
01031         GetDlgItem(IDC_EDIT_STATUS2)->SetWindowText("Device Connection Closed");
01032         lblDppFound[USB].ShowWindow(SW_HIDE);
01033         s.isDppFound[USB] = FALSE;
01034 }
01035
01036 void CSelectDP5::OnBnClickedCheckTypeIpAddress()
01037 {
01038         bTypeInIPAddress = m_TypeInIPAddressCheck.GetCheck();
01039 }
01040
01041 void CSelectDP5::OnBnClickedConnectOK()
01042 {
01043         CString strDataRefresh;
01044         long lDataRefresh;
01045
01046         if (m_bModified) {
01047                 m_SpectrumRefreshTimeCtrl.GetWindowText(strDataRefresh);
01048                 lDataRefresh = atoi(strDataRefresh);
01049                 if ((lDataRefresh < 500) || (lDataRefresh > 20000)) { // 500-20,000 milli seconds
01050                         lDataRefresh = 1000;
01051                         s.profile->data_refresh = 1000;
01052                 } else {
01053                         s.profile->data_refresh = lDataRefresh;
01054                 }
01055         }
01056         CDialog::OnOK();
01057 }
01058
01059 void CSelectDP5::OnOK()
01060 {
01061         //DISABLE DEFAULT
01062 }
01063
01064 void CSelectDP5::CopyTextToClip(CString strTitle, CString strDesc)
01065 {
01066         CString strText;
01067         strText = strTitle + "\r\n" + "\r\n" + strDesc + "\r\n" ;
01068         AfxGetApp()->m_pMainWnd->OpenClipboard() ;
01069         EmptyClipboard();
01070         CSharedFile     sf(GMEM_MOVEABLE|GMEM_DDESHARE|GMEM_ZEROINIT);
01071         sf.Write(strText, strText.GetLength());
01072         HGLOBAL hMem = sf.Detach();
01073         if (!hMem) return;
01074         SetClipboardData(CF_TEXT, hMem);
01075         CloseClipboard();
01076 }
01077
01078 void CSelectDP5::OnBnClickedButtonClipboardCopy()
01079 {
01080         CString strText;
01081         CString strTextAll;
01082
01083         strTextAll = "";
01084         GetDlgItem(IDC_STATIC_NETFINDER1)->GetWindowText(strText);
01085         strTextAll += strText + "\r\n";
01086         GetDlgItem(IDC_STATIC_NETFINDER2)->GetWindowText(strText);
01087         strTextAll += strText + "\r\n";
01088         GetDlgItem(IDC_STATIC_NETFINDER3)->GetWindowText(strText);
01089         strTextAll += strText + "\r\n";
01090         GetDlgItem(IDC_STATIC_NETFINDER4)->GetWindowText(strText);
01091         strTextAll += strText + "\r\n";
01092         CopyTextToClip("Ethernet NetFinder",strTextAll);
01093 }
01094
01095 void CSelectDP5::SetModified(BOOL bChanged)
01096 {
01097         m_bModified = bChanged;
01098 }
01099
01100 void CSelectDP5::OnEnChangeSpectrumRefreshTime()
01101 {
01102         SetModified(TRUE);
01103 }
01104
01105 void CSelectDP5::OnBnClickedButtonSpectrumRefreshDefault()
01106 {
01107         m_SpectrumRefreshTimeCtrl.SetWindowText("1000");
01108         s.profile->data_refresh = 1000;
01109         SetModified(FALSE);
01110 }
01111
01112 BOOL CSelectDP5::OnHelpInfo(HELPINFO* pHelpInfo)
01113 {
01114         CString strHelp;
01115         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
01116                 if (pHelpInfo->dwContextId == 0) {
01117                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_DP5_CONNECT);
01118                 } else {
01119                         //
01120                 }
01121         }
01122         return true;
01123 }
01124
01125
01126
01127
01128
01129
01130
01131
01132
01133
01134
01135
01136
01137
01138
01139
01140
01141
01142
01143
01144
01145
01146
01147
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SelectDP5.h Source File

DeviceIO/SelectDP5.h
Go to the documentation of this file.
00001 #pragma once
00002 #ifndef SELECTDP5_H
00003 #define SELECTDP5_H
00004 //#include "Resource.h"
00005 #include "SCommon.h"
00006 #include "Label.h"
00007 #include "afxwin.h"
00008 #include "NetFinder.h"
00009 #include "afxadv.h"     // for cfg file clipboard copy
00010
00011
00012 #ifdef _DEBUG
00013 #define isDebug true
00014 #else
00015 #define isDebug false
00016 #endif
00017
00018
00019
00020 // CSelectDP5 dialog
00021
00022 //DS_FIXEDSYS |
00023 //#define IDD_DP5_CONNECT                 129
00024
00025 class CSelectDP5 : public CDialog
00026 {
00027         //DECLARE_DYNAMIC(CSelectDP5)
00028
00029 public:
00030         //CSelectDP5(CWnd* pParent = NULL);   // standard constructor
00031         CSelectDP5();
00032         //virtual ~CSelectDP5();
00033
00034 // Dialog Data
00035         //enum { IDD = IDD_DP5_CONNECT };
00036
00037 protected:
00038         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00039
00040         DECLARE_MESSAGE_MAP()
00041         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00042
00043 public:
00044         virtual BOOL OnInitDialog();
00045
00046         // ===== RS232 ==========================================
00047         void ComPortEnum();
00048         int GetComPortID();
00049         void SetComPortID(int iComPort);
00050
00051         afx_msg void OnCbnSelchangeComboComport();
00052         afx_msg void OnBnClickedButtonClosePort();              // serial communications controls
00053         afx_msg void OnBnClickedButtonOpenPort();
00054         afx_msg void OnBnClickedButtonSerialReqData();
00055
00056         void SetDataRcvTimer(long Bytes);
00057         CComboBox cboComPort;
00058         // Communications Timer RS232 100ms Timer 1
00059         UINT_PTR m_nTmrRS232Id;                 // return SetTimer Return Value (0=false,TimerID if OK)
00060         UINT_PTR m_nTmrRS232EventId;    // Timer Event Identifier
00061         UINT m_nTmrRS232Elapse;                 // Timeout value in milliseconds
00062         void ReqDataStatus();
00063         DP4_FORMAT_STATUS m_DP5_Status;
00064
00065         //void Process_Status(DP4_FORMAT_STATUS *m_DP5_Status);
00066
00067         unsigned char DataIn[4096];
00068         afx_msg void OnTimer(UINT nIDEvent);
00069         afx_msg LONG OnCommunication(UINT, LONG);
00070         void OnComm();
00071         // ======================================================
00072
00073         // ===== USB ============================================
00074         afx_msg void OnBnClickedButtonFindUsbDevice();
00075         // ======================================================
00076
00077         // ===== ETHERNET =======================================
00078         afx_msg void OnBnClickedButtonFindDp5Ip();
00079         //void OnReceive(int nErrorCode);
00080         afx_msg LONG OnReceive(UINT, LONG);
00081         void SendBroadcast(BOOL NewRand);
00082         void ReceivePacket();
00083         void UpdateNetFinderStatus(CString strStatus, COLORREF rgbConnect, int idxEntry);
00084         void ClearNetFinderStatus(int idxEntry);
00085         void ClearNetFinderStatusAll();
00086         void ReqDataStatusSock(unsigned long DppAddr);
00087         CLabel lblNetFinder[4];                         // CStatic netfinder display
00088         CNetFinder FindDpp;                                     // netfinder helper class
00089
00090         CNetFinder FindDppRS232;                                        // netfinder helper class
00091         CNetFinder FindDppUSB;                                  // netfinder helper class
00092
00093         SocketOwnerType m_PrevOwner;            // previous socket owner
00094         // ======================================================
00095
00096         virtual BOOL DestroyWindow();                                   // has ethernet previous owner swap
00097
00098         // ===== shared functions ===============================
00099         void EnableCommFunctions(int ControlGroup);             // enables/disables control groups
00100         // radio button selects communications type
00101         afx_msg void OnBnClickedRadioCommtype1();               // rs232
00102         afx_msg void OnBnClickedRadioCommtype2();               // usb
00103         afx_msg void OnBnClickedRadioCommtype3();               // ethernet
00104         CLabel lblDppFound[3];                                                  // displays dpp found by comm type
00105         // ======================================================
00106
00107         afx_msg void OnBnClickedOk();
00108         int IpSelectBtn[4];
00109         unsigned long IpSelectAddr[4];
00110         void UpdateNetfinderIpAddr(unsigned long IpAddr);
00111
00112         afx_msg void OnBnClickedButtonIpSelect1();
00113         afx_msg void OnBnClickedButtonIpSelect2();
00114         afx_msg void OnBnClickedButtonIpSelect3();
00115         afx_msg void OnBnClickedButtonIpSelect4();
00116         afx_msg void OnStnClickedStaticNetfinder1();
00117         afx_msg void OnStnClickedStaticNetfinder2();
00118         afx_msg void OnStnClickedStaticNetfinder3();
00119         afx_msg void OnStnClickedStaticNetfinder4();
00120
00121         afx_msg void OnBnClickedButtonCountDevices();
00122         CSpinButtonCtrl m_SpinSelectDevice;
00123         afx_msg void OnDeltaposSpinSelectDevice(NMHDR *pNMHDR, LRESULT *pResult);
00124         afx_msg void OnBnClickedButtonCloseDevice();
00125
00126         afx_msg void OnBnClickedCheckTypeIpAddress();
00127         CButton m_TypeInIPAddressCheck;
00128         afx_msg void OnBnClickedConnectOK();
00129         virtual void OnOK();
00130         //virtual void OnCancel();
00131         //afx_msg void OnDestroy();
00132         BOOL bTypeInIPAddress;
00133         void CopyTextToClip(CString strTitle, CString strDesc);
00134         afx_msg void OnBnClickedButtonClipboardCopy();
00135         void SetModified(BOOL bChanged);
00136         BOOL m_bModified;
00137
00138         CEdit m_SpectrumRefreshTimeCtrl;
00139         afx_msg void OnEnChangeSpectrumRefreshTime();
00140         afx_msg void OnBnClickedButtonSpectrumRefreshDefault();
00141
00142         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00143
00144 };
00145
00146 #endif //SELECTDP5_H
00147
00148
00149
00150
00151
00152
00153
00154
00155
00156
00157
00158
00159
00160
00161
00162
00163
00164
00165
00166
00167
00168
00169
00170
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SelectDP5Res.h Source File

DeviceIO/SelectDP5Res.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by SelectDP5.rc
00004 //
00005 #define IDC_BUTTON_CLIPBOARD_COPY       2048
00006 #define IDC_BUTTON_CLOSE_DEVICE         2049
00007 #define IDC_BUTTON_CLOSE_PORT           2050
00008 #define IDC_BUTTON_COUNT_DEVICES        2051
00009 #define IDC_BUTTON_FIND_DP5_IP          2052
00010 #define IDC_BUTTON_FIND_USB_DEVICE      2053
00011 #define IDC_BUTTON_IP_SELECT1           2054
00012 #define IDC_BUTTON_IP_SELECT2           2055
00013 #define IDC_BUTTON_IP_SELECT3           2056
00014 #define IDC_BUTTON_IP_SELECT4           2057
00015 #define IDC_BUTTON_OPEN_PORT            2058
00016 #define IDC_BUTTON_SERIAL_REQ_DATA      2059
00017 #define IDC_BUTTON_SPECTRUM_REFRESH_DEFAULT 2060
00018 #define IDC_CHECK_TYPE_IP_ADDRESS       2061
00019 #define IDC_COMBO_COMPORT               2062
00020 #define IDC_CONNECTOK                   2063
00021 #define IDC_EDIT_DPPCOMM_STATUS         2064
00022 #define IDC_EDIT_IP_ADDR1               2065
00023 #define IDC_EDIT_IP_ADDR2               2066
00024 #define IDC_EDIT_IP_ADDR3               2067
00025 #define IDC_EDIT_IP_ADDR4               2068
00026 #define IDC_EDIT_IP_PORT                2069
00027 #define IDC_EDIT_STATUS2                2070
00028 #define IDC_RADIO_COMMTYPE1             2071
00029 #define IDC_RADIO_COMMTYPE2             2072
00030 #define IDC_RADIO_COMMTYPE3             2073
00031 #define IDC_SPECTRUM_REFRESH_TIME       2074
00032 #define IDC_SPIN_SELECT_DEVICE          2075
00033 #define IDC_STATIC_FOUND1               2076
00034 #define IDC_STATIC_FOUND2               2077
00035 #define IDC_STATIC_FOUND3               2078
00036 #define IDC_STATIC_IP_ADDRESS_LABEL     2079
00037 #define IDC_STATIC_IP_SERIAL_NUM        2080
00038 #define IDC_STATIC_LABEL_IP_1           2081
00039 #define IDC_STATIC_LABEL_IP_2           2082
00040 #define IDC_STATIC_LABEL_IP_3           2083
00041 #define IDC_STATIC_LABEL_IP_4           2084
00042 #define IDC_STATIC_NETFINDER1           2085
00043 #define IDC_STATIC_NETFINDER2           2086
00044 #define IDC_STATIC_NETFINDER3           2087
00045 #define IDC_STATIC_NETFINDER4           2088
00046 #define IDC_STATIC_NUM_DEVICES          2089
00047 #define IDC_STATIC_NUM_DEVICES2         2090
00048 #define IDC_STATIC_PORT_LABEL           2091
00049 #define IDC_STATIC_SELECT_USB_DEVICE_LABEL 2092
00050
00051 // Next default values for new objects
00052 //
00053 #ifdef APSTUDIO_INVOKED
00054 #ifndef APSTUDIO_READONLY_SYMBOLS
00055 #define _APS_NEXT_RESOURCE_VALUE        6656
00056 #define _APS_NEXT_COMMAND_VALUE         33424
00057 #define _APS_NEXT_CONTROL_VALUE         2093
00058 #define _APS_NEXT_SYMED_VALUE           6656
00059 #endif
00060 #endif
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SendCommand.cpp Source File

DeviceIO/SendCommand.cpp
Go to the documentation of this file.
00001 #include "SendCommand.h"
00002 #include "stringex.h"
00003
00004 CSendCommand::CSendCommand(void)
00005 {
00006 }
00007
00008 CSendCommand::~CSendCommand(void)
00009 {
00010 }
00011
00012 bool CSendCommand::TestPacketCkSumOK(unsigned char Data[])
00013 {
00014     long idxBuffer;
00015     long CS;
00016         long PktLen;
00017         unsigned char CHKSUM_MSB;
00018     //unsigned char CHKSUM_LSB;
00019
00020         PktLen = (Data[4] * 256) + Data[5];
00021     CS = Data[0] + Data[1] + Data[2] + Data[3] + Data[4] + Data[5];
00022         if (PktLen > 0) {
00023                 for (idxBuffer=0; idxBuffer<PktLen;idxBuffer++) {
00024             CS = CS + Data[idxBuffer + 6];
00025                 }
00026     }
00027     CS = (CS ^ 0xFFFF) + 1;
00028     CHKSUM_MSB = (unsigned char)((CS & 0xFF00) / 256);  // calculated checksum
00029     //CHKSUM_LSB = (unsigned char)(CS & 0xFF);
00030         if ((Data[PktLen + 6] == CHKSUM_MSB) && (Data[PktLen + 7] == (CS & 0xFF))) {
00031                 return true;
00032         } else {
00033                 return false;
00034         }
00035 }
00036
00037 //Extend Packet_Out to include entire message
00038 //include send packet data finishing into dp5_cmd
00039 //remove control and interface objects
00040 //move send packet to separate function
00041
00042 bool CSendCommand::DP5_CMD(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd)
00043 {
00044     bool bCmdFound;
00045     string D;
00046     Packet_Out POUT;
00047
00048     bCmdFound = true;
00049     POUT.LEN = 0;
00050         string strCfg;
00051         long lLen;
00052         //long idxData;
00053
00054         switch (XmtCmd) {
00056                 case XMTPT_SEND_STATUS:
00057             POUT.PID1 = PID1_REQ_STATUS;
00058             POUT.PID2 = PID2_SEND_DP4_STYLE_STATUS;   // send status only
00059                         break;
00060         //case XMTPT_SEND_SPECTRUM:
00061                         //break;
00062         //case XMTPT_SEND_CLEAR_SPECTRUM:
00063                         //break;
00064         case XMTPT_SEND_SPECTRUM_STATUS:
00065             POUT.PID1 = PID1_REQ_SPECTRUM;
00066             POUT.PID2 = PID2_SEND_SPECTRUM_STATUS;   // send spectrum & status
00067                         break;
00068         case XMTPT_SEND_CLEAR_SPECTRUM_STATUS:
00069             POUT.PID1 = PID1_REQ_SPECTRUM;
00070             POUT.PID2 = PID2_SEND_CLEAR_SPECTRUM_STATUS;   // send & clear spectrum & status
00071                         break;
00072         //case XMTPT_BUFFER_SPECTRUM:
00073                         //break;
00074         //case XMTPT_BUFFER_CLEAR_SPECTRUM:
00075                         //break;
00076         //case XMTPT_SEND_BUFFER:
00077                         //break;
00078         //case XMTPT_SEND_DP4_STYLE_STATUS:
00079                         //break;
00080         //case XMTPT_SEND_CONFIG:
00081                         //break;
00082         case XMTPT_SEND_SCOPE_DATA:
00083             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00084             POUT.PID2 = PID2_SEND_SCOPE_DATA;
00085                         break;
00086         case XMTPT_SEND_512_BYTE_MISC_DATA:
00087             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00088             POUT.PID2 = PID2_SEND_512_BYTE_MISC_DATA; // request misc data
00089                         break;
00090         case XMTPT_SEND_SCOPE_DATA_REARM:
00091             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00092             POUT.PID2 = PID2_SEND_SCOPE_DATA_REARM;
00093                         break;
00094         //case XMTPT_SEND_ETHERNET_SETTINGS:
00095                         //break;
00096         case XMTPT_SEND_DIAGNOSTIC_DATA:
00097             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00098             POUT.PID2 = PID2_SEND_DIAGNOSTIC_DATA;   // Request Diagnostic Packet
00099             POUT.LEN = 0;
00100                         break;
00101         case XMTPT_SEND_NETFINDER_PACKET:
00102             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00103             POUT.PID2 = PID2_SEND_NETFINDER_READBACK;   // Request NetFinder Packet
00104             POUT.LEN = 0;
00105                         break;
00106         //case XMTPT_SEND_HARDWARE_DESCRIPTION:
00107                         //break;
00108         //case XMTPT_SEND_SCA:
00109                         //break;
00110         //case XMTPT_LATCH_SEND_SCA:
00111                         //break;
00112         //case XMTPT_LATCH_CLEAR_SEND_SCA:
00113                         //break;
00114         //case XMTPT_SEND_ROI_OR_FIXED_BLOCK:
00115                         //break;
00116         //case XMTPT_PX4_STYLE_CONFIG_PACKET:
00117                         //break;
00118                 case XMTPT_SCA_READ_CONFIG_PACKET:
00119                         strCfg = "";
00120                         strCfg = "SCAW=?;";
00121                         strCfg +="SCAI=1;SCAL=?;SCAH=?;SCAO=?;";
00122                         strCfg +="SCAI=2;SCAL=?;SCAH=?;SCAO=?;";
00123                         strCfg +="SCAI=3;SCAL=?;SCAH=?;SCAO=?;";
00124                         strCfg +="SCAI=4;SCAL=?;SCAH=?;SCAO=?;";
00125                         strCfg +="SCAI=5;SCAL=?;SCAH=?;SCAO=?;";
00126                         strCfg +="SCAI=6;SCAL=?;SCAH=?;SCAO=?;";
00127                         strCfg +="SCAI=7;SCAL=?;SCAH=?;SCAO=?;";
00128                         strCfg +="SCAI=8;SCAL=?;SCAH=?;SCAO=?;";
00129                         lLen = (long)strCfg.length();
00130                         if (lLen > 0) {
00131                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00132                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00133                         }
00134             POUT.PID1 = PID1_REQ_CONFIG;
00135             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // read config packet
00136             POUT.LEN = (unsigned short)lLen;
00137                         break;
00138                  case XMTPT_ERASE_FPGA_IMAGE:
00139             POUT.PID1 = PID1_REQ_FPGA_UC;
00140             POUT.PID2 = PID2_ERASE_FPGA_IMAGE;
00141             POUT.LEN = 2;
00142             POUT.DATA[0] = 0x12;
00143             POUT.DATA[1] = 0x34;
00144                         break;
00145         //case XMTPT_UPLOAD_PACKET_FPGA:
00146                         //break;
00147         //case XMTPT_REINITIALIZE_FPGA:
00148                         //break;
00149         //case XMTPT_ERASE_UC_IMAGE_0:
00150                         //break;
00151         case XMTPT_ERASE_UC_IMAGE_1:
00152             POUT.PID1 = PID1_REQ_FPGA_UC;
00153             POUT.PID2 = PID2_ERASE_UC_IMAGE_1;   // erase image #1 (sector 5)
00154             POUT.LEN = 2;
00155             POUT.DATA[0] = 0x12;
00156             POUT.DATA[1] = 0x34;
00157                         break;
00158         //case XMTPT_ERASE_UC_IMAGE_2:
00159                         //break;
00160         //case XMTPT_UPLOAD_PACKET_UC:
00161                         //break;
00162         //case XMTPT_SWITCH_TO_UC_IMAGE_0:
00163                         //break;
00164         case XMTPT_SWITCH_TO_UC_IMAGE_1:
00165             POUT.PID1 = PID1_REQ_FPGA_UC;
00166             POUT.PID2 = PID2_SWITCH_TO_UC_IMAGE_1;   // switch to uC image #1
00167             POUT.LEN = 2;
00168             POUT.DATA[0] = 0xA5; // uC FLASH unlock keys
00169             POUT.DATA[1] = 0xF1;
00170                         break;
00171         //case XMTPT_SWITCH_TO_UC_IMAGE_2:
00172                         //break;
00173         //case XMTPT_UC_FPGA_CHECKSUMS:
00174                         //break;
00176         //case XMTPT_CLEAR_SPECTRUM_BUFFER_A:
00177                         //break;
00178         case XMTPT_ENABLE_MCA_MCS:
00179             POUT.PID1 = PID1_VENDOR_REQ;
00180             POUT.PID2 = PID2_ENABLE_MCA_MCS;
00181             POUT.LEN = 0;
00182                         break;
00183         case XMTPT_DISABLE_MCA_MCS:
00184             POUT.PID1 = PID1_VENDOR_REQ;
00185             POUT.PID2 = PID2_DISABLE_MCA_MCS;
00186             POUT.LEN = 0;
00187                         break;
00188         case XMTPT_ARM_DIGITAL_OSCILLOSCOPE:
00189             POUT.PID1 = PID1_VENDOR_REQ;
00190             POUT.PID2 = PID2_ARM_DIGITAL_OSCILLOSCOPE;   // arm trigger
00191                         break;
00192         //case XMTPT_AUTOSET_INPUT_OFFSET:
00193                         //break;
00194         case XMTPT_AUTOSET_FAST_THRESHOLD:
00195             POUT.PID1 = PID1_VENDOR_REQ;
00196             POUT.PID2 = PID2_AUTOSET_FAST_THRESHOLD;
00197             POUT.LEN = 0;
00198                         break;
00199         //case XMTPT_READ_IO3_0:
00200                         //break;
00201         //case XMTPT_WRITE_IO3_0:
00202                         //break;
00203         //case XMTPT_SET_DCAL:
00204                         //break;
00205         //case XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL:
00206                         //break;
00207         //case XMTPT_SET_PZ_CORRECTION_UC_TEMP_CAL:
00208                         //break;
00209         //case XMTPT_SET_BOOT_FLAGS:
00210                         //break;
00211         //case XMTPT_SET_HV_DP4_EMULATION:
00212                         //break;
00213         //case XMTPT_SET_TEC_DP4_EMULATION:
00214                         //break;
00215         //case XMTPT_SET_INPUT_OFFSET_DP4_EMULATION:
00216                         //break;
00217         //case XMTPT_SET_ADC_CAL_GAIN_OFFSET:
00218                         //break;
00219         //case XMTPT_SET_SPECTRUM_OFFSET:
00220                         //break;
00221         //case XMTPT_REQ_SCOPE_DATA_MISC_DATA_SCA_PACKETS:
00222                         //break;
00223         //case XMTPT_SET_SERIAL_NUMBER:
00224                         //break;
00225         //case XMTPT_CLEAR_GP_COUNTER:
00226                         //break;
00227         //case XMTPT_SWITCH_SUPPLIES:
00228                         //break;
00229         //case XMTPT_SEND_TEST_PACKET:
00230                         //break;
00231         case XMTPT_REQ_ACK_PACKET:
00232             POUT.PID1 = PID1_COMM_TEST;
00233             POUT.PID2 = PID2_ACK_OK;
00234             POUT.LEN = 0;
00235                         break;
00236                 case XMTPT_FORCE_SCOPE_TRIGGER:
00237             POUT.PID1 = PID1_VENDOR_REQ;
00238             POUT.PID2 = PID2_GENERIC_FPGA_WRITE;        // generic FPGA write
00239             POUT.LEN = 2;
00240             POUT.DATA[0] = 119;                                         // force scope trigger
00241             POUT.DATA[1] = 0;                                           // data doesn't matter
00242                         break;
00243                 case XMTPT_AU34_2_RESTART:
00244             POUT.PID1 = PID1_VENDOR_REQ;
00245             POUT.PID2 = PID2_GENERIC_FPGA_WRITE;        // generic FPGA write
00246             POUT.LEN = 2;
00247             POUT.DATA[0] = 0x73;                                        // AU34_2_RESTART
00248             POUT.DATA[1] = 0;                                           // data doesn't matter
00249                         break;
00250         case XMTPT_READ_MCA8000D_OPTION_PA_CAL:
00251             POUT.PID1 = PID1_REQ_SCOPE_MISC;
00252             POUT.PID2 = PID2_SEND_OPTION_PA_CALIBRATION;
00253             POUT.LEN = 0;
00254                         break;
00255                 default:
00256             bCmdFound = false;
00257                         break;
00258         }
00259         if (bCmdFound) {
00260         if (! POUT_Buffer(POUT, Buffer)) {
00261             bCmdFound = false;
00262         }
00263     }
00264         return bCmdFound;
00265 }
00266
00267 //DP5_CMD_Config is for: (requires pc5 and device info)
00268 //              XMTPT_SEND_CONFIG_PACKET_TO_HW
00269 //              XMTPT_SEND_CONFIG_PACKET_EX
00270 //              XMTPT_FULL_READ_CONFIG_PACKET
00271 //              XMTPT_READ_CONFIG_PACKET
00272 //              XMTPT_READ_CONFIG_PACKET_EX
00273 bool CSendCommand::DP5_CMD_Config(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions)
00274 {
00275     bool bCmdFound;
00276     string D;
00277     Packet_Out POUT;
00278     bCmdFound = true;
00279     POUT.LEN = 0;
00280         string strCfg;
00281         long lLen;
00282
00283         switch (XmtCmd) {
00284         case XMTPT_SEND_CONFIG_PACKET_TO_HW:
00285                         // CONFIG_OPTIONS Needed:
00286                         //              CfgOptions.HwCfgDP5Out
00287                         //              CfgOptions.SendCoarseFineGain
00288                         //              CfgOptions.PC5_PRESENT
00289                         //              CfgOptions.DppType
00290                         strCfg = "";
00291                         strCfg = CfgOptions.HwCfgDP5Out;
00292
00293                         if (CfgOptions.SendCoarseFineGain) {
00294                                 strCfg = AsciiCmdUtil.RemoveCmd("GAIN",strCfg);
00295                         } else {
00296                                 strCfg = AsciiCmdUtil.RemoveCmd("GAIA",strCfg);
00297                                 strCfg = AsciiCmdUtil.RemoveCmd("GAIF",strCfg);
00298                         }
00299                         strCfg = AsciiCmdUtil.RemoveCmdByDeviceType(strCfg, CfgOptions.PC5_PRESENT, CfgOptions.DppType, CfgOptions.isDP5_RevDxGains, CfgOptions.DPP_ECO);
00300                         lLen = (long)strCfg.length();
00301                         if (lLen > 0) {
00302                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00303                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00304                         }
00305             POUT.PID1 = PID1_REQ_CONFIG;
00306             POUT.PID2 = PID2_TEXT_CONFIG_PACKET;   // text config packet
00307             POUT.LEN = (unsigned short)lLen;
00308                         break;
00309         case XMTPT_SEND_CONFIG_PACKET_EX:                       // bypass any filters
00310                         // CONFIG_OPTIONS Needed:
00311                         //              CfgOptions.HwCfgDP5Out
00312                         strCfg = "";
00313                         strCfg = CfgOptions.HwCfgDP5Out;
00314                         lLen = (long)strCfg.length();
00315                         if (lLen > 0) {
00316                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00317                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00318                         }
00319             POUT.PID1 = PID1_REQ_CONFIG;
00320             POUT.PID2 = PID2_TEXT_CONFIG_PACKET;   // text config packet
00321             POUT.LEN = (unsigned short)lLen;
00322                         break;
00323          case XMTPT_FULL_READ_CONFIG_PACKET:
00324                         // CONFIG_OPTIONS Needed:
00325                         //              CfgOptions.PC5_PRESENT
00326                         //              CfgOptions.DppType
00327                         strCfg = "";
00328                         strCfg = AsciiCmdUtil.CreateFullReadBackCmd(CfgOptions.PC5_PRESENT, CfgOptions.DppType, CfgOptions.isDP5_RevDxGains, CfgOptions.DPP_ECO);
00329                         lLen = (long)strCfg.length();
00330                         if (lLen > 0) {
00331                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00332                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00333                         }
00334             POUT.PID1 = PID1_REQ_CONFIG;
00335             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // read config packet
00336             POUT.LEN = (unsigned short)lLen;
00337                         break;
00338         case XMTPT_READ_CONFIG_PACKET_EX:                                       // bypass any filters
00339                         strCfg = "";
00340                         strCfg = CfgOptions.HwCfgDP5Out;
00341                         lLen = (long)strCfg.length();
00342                         if (lLen > 0) {
00343                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00344                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);    //ForceASCII_20110606
00345                         }
00346             POUT.PID1 = PID1_REQ_CONFIG;
00347             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // text config packet
00348             POUT.LEN = (unsigned short)lLen;
00349                         break;
00350                 case XMTPT_READ_CONFIG_PACKET:
00351                         strCfg = "";
00352                         strCfg += "CLCK=?;"; // FPGA clock
00353                         strCfg += "TPEA=?;"; // peak time
00354                         strCfg += "GAIN=?;"; // gain
00355                         if (CfgOptions.DppType == dppMCA8000D) {
00356                                 strCfg += "GAIA=?;"; // coarse gain
00357                         }
00358                         strCfg += "MCAS=?;"; // mca mode
00359                         strCfg += "MCAC=?;"; // channels
00360                         strCfg += "INOF=?;"; // osc. Input offset
00361                         strCfg += "THSL=?;"; // LLD thresh
00362                         strCfg += "TFLA=?;"; // flat top width
00363                         strCfg += "THFA=?;"; // fast thresh
00364                         strCfg += "DACO=?;"; // osc. DAC output
00365                         strCfg += "DACF=?;"; // osc. DAC offset
00366                         strCfg += "AUO1=?;"; // osc. AUX_OUT1
00367                         strCfg += "PRET=?;"; // preset actual time
00368                         strCfg += "PRER=?;"; // preset real time
00369                         strCfg += "PREC=?;"; // preset count
00370                         if (CfgOptions.DppType == dppMCA8000D) {
00371                                 strCfg += "PREL=?;"; // preset real time
00372                         }
00373                         strCfg += "HVSE=?;"; // high voltage setting for manufacuting test
00374                         strCfg += "SCOE=?;"; // osc. Scope trigger edge
00375                         strCfg += "SCOT=?;"; // osc. Scope trigger position
00376                         strCfg += "SCOG=?;"; // osc. Scope gain
00377
00378                         lLen = (long)strCfg.length();
00379                         if (lLen > 0) {
00380                                 strCfg = AsciiCmdUtil.MakeUpper(strCfg);
00381                                 AsciiCmdUtil.CopyAsciiData(POUT.DATA, strCfg, lLen);
00382                         }
00383             POUT.PID1 = PID1_REQ_CONFIG;
00384             POUT.PID2 = PID2_CONFIG_READBACK_PACKET;   // read config packet
00385             POUT.LEN = (unsigned short)lLen;
00386                         break;
00387                 default:
00388             bCmdFound = false;
00389                         break;
00390         }
00391         if (bCmdFound) {
00392         if (! POUT_Buffer(POUT, Buffer)) {
00393             bCmdFound = false;
00394         }
00395     }
00396         return bCmdFound;
00397 }
00398
00399
00400 //Extend Packet_Out to include entire message
00401 //include send packet data finishing into dp5_cmd
00402 //remove control and interface objects
00403 //move send packet to separate function
00404 bool CSendCommand::DP5_CMD_Data(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[])
00405 {
00406     bool bCmdFound;
00407     short idxMiscData;
00408     Packet_Out POUT;
00409     long PktLen;
00410
00411     bCmdFound = false;
00412     POUT.LEN = 0;
00413         string strCfg;
00414         long idxData;
00415         switch (XmtCmd) {       //REQUEST_PACKETS_TO_DP5
00416         case XMTPT_WRITE_512_BYTE_MISC_DATA:
00417             POUT.PID1 = PID1_VENDOR_REQ;
00418             POUT.PID2 = PID2_WRITE_512_BYTE_MISC_DATA;                          // write misc data
00419             POUT.LEN = 512;
00420                         for (idxMiscData=0;idxMiscData<=511;idxMiscData++) {    // byte array padded w/NULLs
00421                 POUT.DATA[idxMiscData] = DataOut[idxMiscData];
00422                         }
00423                         bCmdFound = true;
00424                         if (! POUT_Buffer(POUT, Buffer)) {
00425                                 bCmdFound = false;
00426                         }
00427                         break;
00428          case XMTPT_SEND_TEST_PACKET:
00429                         PktLen = (DataOut[4] * 256) + DataOut[5] + 8;           // get entire packet size
00430                         if ((PktLen >= 8) && (PktLen <= 12)) {                          // test data len 0-4 bytes
00431                                 if (TestPacketCkSumOK(DataOut)) {                               // check the message for correct check sum
00432                                         for(idxData=0;idxData<PktLen;idxData++) {       // load the data into the command buffer
00433                                                 Buffer[idxData] = DataOut[idxData];
00434                                         }
00435                                         bCmdFound = true;
00436                                 }
00437                         }
00438                         break;
00439                 default:
00440             bCmdFound = false;
00441                         break;
00442         }
00443         return bCmdFound;
00444 }
00445
00446 bool CSendCommand::POUT_Buffer(Packet_Out POUT, unsigned char Buffer[])
00447 {
00448     long idxBuffer;
00449     long CS;
00450
00451     Buffer[0] = SYNC1_;
00452     Buffer[1] = SYNC2_;
00453     Buffer[2] = POUT.PID1;
00454     Buffer[3] = POUT.PID2;
00455     Buffer[4] = (POUT.LEN & 0xFF00) / 256;
00456     Buffer[5] = POUT.LEN & 0xFF;
00457
00458     CS = SYNC1_ + SYNC2_ + POUT.PID1 + POUT.PID2 + ((POUT.LEN & 0xFF00) / 256) + (POUT.LEN & 0xFF);
00459
00460         if (POUT.LEN > 0) {
00461                 for (idxBuffer=0; idxBuffer<POUT.LEN;idxBuffer++) {
00462             Buffer[idxBuffer + 6] = POUT.DATA[idxBuffer];
00463             CS = CS + POUT.DATA[idxBuffer];
00464                 }
00465     }
00466     CS = (CS ^ 0xFFFF) + 1;
00467     Buffer[POUT.LEN + 6] = (unsigned char)((CS & 0xFF00) / 256);
00468     Buffer[POUT.LEN + 7] = (unsigned char)(CS & 0xFF);
00469     return true;
00470 }
00471
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/SendCommand.h Source File

DeviceIO/SendCommand.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "DppConst.h"
00003 #include "DP5Protocol.h"
00004 #include "AsciiCmdUtilities.h"
00005
00006 typedef struct _CONFIG_OPTIONS
00007 {
00008     bool PC5_PRESENT;
00009     int DppType;
00010         string HwCfgDP5Out;
00011         bool SendCoarseFineGain;
00012         bool isDP5_RevDxGains;
00013         unsigned char DPP_ECO;
00014 } CONFIG_OPTIONS;
00015
00023 class CSendCommand
00024 {
00025 public:
00026         CSendCommand(void);
00027         ~CSendCommand(void);
00028     CAsciiCmdUtilities AsciiCmdUtil;
00029
00031         bool TestPacketCkSumOK(unsigned char Data[]);
00033         bool DP5_CMD(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd);
00035         bool DP5_CMD_Config(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions);
00037         bool DP5_CMD_Data(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[]);
00039         bool POUT_Buffer(Packet_Out POUT, unsigned char Buffer[]);
00040 };
00041
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ShapingPage.cpp Source File

DP5Cfg/ShapingPage.cpp
Go to the documentation of this file.
00001 // ShapingPage.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "afxpriv.h"    // afxpriv.h has WM_COMMANDHELP id
00006 //#include "CDP5Cfg.h"
00007 #include "ShapingPageRes.h"
00008 #include "ShapingPage.h"
00009 #include ".\ShapingPage.h"
00010
00011 #ifdef _DEBUG
00012 #define new DEBUG_NEW
00013 #undef THIS_FILE
00014 static char THIS_FILE[] = __FILE__;
00015 #endif
00016
00018 // CShapingPage property page
00019 //#define IDD_SHAPING_PAGE                107
00020
00021 IMPLEMENT_DYNCREATE(CShapingPage, CCfgPropPage)
00022
00023 //CShapingPage::CShapingPage() : CCfgPropPage(CShapingPage::IDD)
00024 CShapingPage::CShapingPage() : CCfgPropPage("IDD_SHAPING_PAGE")
00025 {
00026         //{{AFX_DATA_INIT(CShapingPage)
00027                 // NOTE: the ClassWizard will add member initialization here
00028         //}}AFX_DATA_INIT
00029 }
00030
00031 CShapingPage::~CShapingPage()
00032 {
00033
00034 }
00035
00036 void CShapingPage::DoDataExchange(CDataExchange* pDX)
00037 {
00038         CCfgPropPage::DoDataExchange(pDX);
00039         //{{AFX_DATA_MAP(CShapingPage)
00040         //}}AFX_DATA_MAP
00041         DDX_Control(pDX, IDC_STATIC_SHAPING_PAGE, m_ShapingPageLabel);
00042         DDX_Control(pDX, IDC_RISECOMBO, m_RiseCombo);
00043         DDX_Control(pDX, IDC_TOPCOMBO, m_TopCombo);
00044         DDX_Control(pDX, IDC_OPT_COMBO_TPFA, m_FastPeakCombo);
00045
00046         DDX_Control(pDX, IDC_STATIC_FPGACLK1, lblFPGAClk[0]);           // current clock value
00047         DDX_Control(pDX, IDC_STATIC_FPGACLK2, lblFPGAClk[1]);           // hw reload message
00048         DDX_Control(pDX, IDC_STATIC_FPGACLK3, lblFPGAClk[2]);           // file reload message
00049
00050         DDX_Control(pDX, IDC_STATIC_SHAPING_ADVANCED, m_ShapingAdvancedLabel);
00051         DDX_Control(pDX, IDC_STATIC_SHAPING_STANDARD, m_ShapingStandardLabel);
00052
00053 }
00054
00055
00056 BEGIN_MESSAGE_MAP(CShapingPage, CCfgPropPage)
00057         ON_CBN_SELCHANGE(IDC_RISECOMBO, OnCbnSelchangeRisecombo)
00058         ON_CBN_SELCHANGE(IDC_TOPCOMBO, OnCbnSelchangeTopcombo)
00059         //{{AFX_MSG_MAP(CShapingPage)
00060         //}}AFX_MSG_MAP
00061         ON_EN_CHANGE(IDC_OPT_TEXT_TFLA, OnEnChangeOptTextTfla)
00062         ON_EN_CHANGE(IDC_OPT_TEXT_THFA, OnEnChangeOptTextThfa)
00063
00064         ON_CBN_SELCHANGE(IDC_OPT_COMBO_PURE, OnCbnSelchangeOptComboPure)
00065         ON_EN_CHANGE(IDC_OPT_TEXT_PURE, OnEnChangeOptTextPure)
00066
00067         ON_CBN_SELCHANGE(IDC_OPT_COMBO_SCTC, OnCbnSelchangeOptComboSctc)
00068         ON_EN_CHANGE(IDC_OPT_TEXT_SCTC, OnEnChangeOptTextSctc)
00069
00070         ON_EN_CHANGE(IDC_OPT_TEXT_TPEA, OnEnChangeOptTextTpea)
00071         ON_CBN_SELCHANGE(IDC_OPT_COMBO_RTDE, OnCbnSelchangeOptComboRtde)
00072         ON_CBN_SELCHANGE(IDC_OPT_COMBO_CUSP, OnCbnSelchangeOptComboCusp)
00073         ON_EN_CHANGE(IDC_OPT_TEXT_RTDS, OnEnChangeOptTextRtds)
00074         ON_EN_CHANGE(IDC_OPT_TEXT_RTDT, OnEnChangeOptTextRtdt)
00075         ON_EN_CHANGE(IDC_OPT_TEXT_BLRD, OnEnChangeOptTextBlrd)
00076         ON_EN_CHANGE(IDC_OPT_TEXT_BLRU, OnEnChangeOptTextBlru)
00077         ON_CBN_SELCHANGE(IDC_OPT_COMBO_BLRM, OnCbnSelchangeOptComboBlrm)
00078         ON_EN_CHANGE(IDC_OPT_TEXT_CUSP, OnEnChangeOptTextCusp)
00079
00080         ON_CBN_SELCHANGE(IDC_OPT_COMBO_CLCK, OnCbnSelchangeOptComboClck)
00081         ON_CBN_SELCHANGE(IDC_OPT_COMBO_TPFA, OnCbnSelchangeOptComboTpfa)
00082
00083         // this function replaces blr quickset 20110504
00084         ON_BN_CLICKED(IDC_BLRQUICKSLOWBUTTON, OnBnClickedBlrquickslowbutton2)
00085
00086         ON_COMMAND(ID_HELP, OnHelp)
00087         ON_WM_HELPINFO()
00088
00089 END_MESSAGE_MAP()
00090
00092 // CShapingPage message handlers
00093
00094 BOOL CShapingPage::OnSetActive()
00095 {
00096         // TODO: Add your specialized code here and/or call the base class
00097         if (s.ReloadCfg) { InitControls(); }
00098         return CCfgPropPage::OnSetActive();
00099 }
00100
00101 BOOL CShapingPage::OnInitDialog()
00102 {
00103         CCfgPropPage::OnInitDialog();
00104
00105         BuildToolTips();
00106
00107         m_ShapingPageLabel
00108                 .SetFontName("Arial")
00109                 .SetFontSize(24)
00110                 .SetTextColor(RGB(0,0,255))
00111                 .SetBkColor(RGB(244, 243, 238))
00112                 .SetFontItalic(TRUE)
00113                 .SetFontBold(TRUE);
00114
00115         m_ShapingAdvancedLabel
00116                 .SetFontName("Arial")
00117                 .SetFontSize(18)
00118                 .SetTextColor(RGB(0, 70, 213))
00119                 .SetBkColor(RGB(247, 247, 246))
00120                 .SetFontItalic(TRUE)
00121                 .SetFontBold(FALSE);
00122
00123         m_ShapingStandardLabel
00124                 .SetFontName("Arial")
00125                 .SetFontSize(18)
00126                 .SetTextColor(RGB(0, 70, 213))
00127                 .SetBkColor(RGB(252, 252, 253))
00128                 .SetFontItalic(TRUE)
00129                 .SetFontBold(FALSE);
00130
00131         lblFPGAClk[0]
00132                 .SetFontName("Arial")
00133                 .SetFontSize(14)
00134                 .SetTextColor(colorLightSlateGray)
00135                 .SetBkColor(colorLightSteelBlue)
00136                 .SetFontBold(TRUE);             // display clock value
00137
00138         lblFPGAClk[1]
00139                 .SetTextColor(colorRed);  // hw restart
00140
00141         lblFPGAClk[2]
00142                 .SetTextColor(colorBlue);  // file restart
00143
00144         InitControls();
00145
00146         // TODO:  Add extra initialization here
00147
00148         return TRUE;  // return TRUE unless you set the focus to a control
00149         // EXCEPTION: OCX Property Pages should return FALSE
00150 }
00151
00152 //dciTFLA       TFLA    0                                       IDC_OPT_TEXT_TFLA       dctTxt          dcgShaping      Flat Top        uS
00153 //dciTHFA       THFA    0                                       IDC_OPT_TEXT_THFA       dctTxt          dcgShaping      Fast Threshold
00154 //dciTPFA       TPFA    IDC_OPT_COMBO_TPFA      0,                                      dctCbo,         dcgShaping,     Fast Peaking Time
00155 //dciPURE       PURE    IDC_OPT_COMBO_PURE      0                                       dctCbo          dcgShaping      PUR Interval On/Off
00156
00157 //dciTPEA       TPEA    0                                       IDC_OPT_TEXT_TPEA       dctTxt          dcgShaping      Peaking Time    uS
00158 //dciRTDS       RTDS    0                                       IDC_OPT_TEXT_RTDS       dctTxt          dcgShaping      RTD Sensitivity %
00159 //dciRTDE       RTDE    IDC_OPT_COMBO_RTDE      0                                       dctCbo          dcgShaping      RTD On/Off
00160
00161 //dciRTDT       RTDT    0                                       IDC_OPT_TEXT_RTDT       dctTxt          dcgShaping      RTD Threshold   %
00162 //dciBLRD       BLRD    0                                       IDC_OPT_TEXT_BLRD       dctTxt          dcgShaping      BLR Down Correction
00163 //dciBLRU       BLRU    0                                       IDC_OPT_TEXT_BLRU       dctTxt          dcgShaping      BLR Up Correction
00164
00165 //dciBLRM       BLRM    IDC_OPT_COMBO_BLRM      0                                       dctCbo          dcgShaping      BLR Mode
00166 //dciCUSP       CUSP    IDC_OPT_COMBO_CUSP      IDC_OPT_TEXT_CUSP       dctCboTxt       dcgShaping      Non-Trapezoidal Shaping %
00167
00168 //dciCLCK       CLCK    IDC_OPT_COMBO_CLCK                                      0       dctCbo          dcgBootOpt      20MHz/80MHz
00169
00170 void CShapingPage::InitControls()
00171 {
00172         HWND hPage = this->GetSafeHwnd();
00173         BOOL bClockEnable;              // enable FPGA clock for current device
00174         BOOL bIsDPG;
00175
00176         bIsDPG =((s.profile->device_type == dppDP5G) || (s.profile->device_type == dppTB5));
00177     bClockEnable = (s.profile->device_type != dppDP5G) && (s.profile->device_type != dppTB5);
00178         if (bIsDPG){
00179                 if (s.DP5Stat.m_DP5_Status.bScintHas80MHzOption) {      // FW6.06.07 or above with ECO enabled
00180                         bClockEnable = TRUE;
00181                         // dp5g/tb5 ECO supports 80mhz clock
00182                         // Allow the software to set the clock cfg value
00183                         // s.DppConfig.b80MHzModeCfg = TRUE;    // sets 80MHz values for controls
00184                 } else {
00185                         s.DppConfig.b80MHzModeCfg = FALSE;              // old dp5g (or no ECO) does not support 80mhz clock
00186                 }
00187         }
00188
00189         GetDlgItem(IDC_OPT_COMBO_CLCK)->EnableWindow(bClockEnable);
00190
00191         if (bIsDPG) {
00192                 GetDlgItem(IDC_OPT_FRAME_SCTC)->ShowWindow(SW_SHOW);
00193                 GetDlgItem(IDC_OPT_COMBO_SCTC)->ShowWindow(SW_SHOW);
00194                 GetDlgItem(IDC_OPT_LIMITS_SCTC)->ShowWindow(SW_SHOW);
00195                 GetDlgItem(IDC_OPT_TEXT_SCTC)->ShowWindow(SW_SHOW);
00196                 GetDlgItem(IDC_OPT_UNITS_SCTC)->ShowWindow(SW_SHOW);
00197         } else {
00198                 GetDlgItem(IDC_OPT_FRAME_SCTC)->ShowWindow(SW_HIDE);
00199                 GetDlgItem(IDC_OPT_COMBO_SCTC)->ShowWindow(SW_HIDE);
00200                 GetDlgItem(IDC_OPT_LIMITS_SCTC)->ShowWindow(SW_HIDE);
00201                 GetDlgItem(IDC_OPT_TEXT_SCTC)->ShowWindow(SW_HIDE);
00202                 GetDlgItem(IDC_OPT_UNITS_SCTC)->ShowWindow(SW_HIDE);
00203         }
00204
00205
00206         InitFastPeakCombo();    //TPFA values are b80MHzModeCfg dependent 20100930
00207         InitBlrMode();                  //BLR Mode 3 added for DP5-X 20170120
00208
00209         InitDlgItem(hPage,s.m_DP5Cfg[dciTFLA]);
00210         InitDlgItem(hPage,s.m_DP5Cfg[dciTHFA]); // 20100930
00211         InitDlgItem(hPage,s.m_DP5Cfg[dciTPFA]);
00212
00213         if (s.profile->device_type != dppMCA8000D) {
00214                 InitDlgItem(hPage,s.m_DP5Cfg[dciPURE]);
00215         }
00216
00217         if (bIsDPG){
00218                 InitDlgItem(hPage,s.m_DP5Cfg[dciSCTC]);
00219         }
00220
00221         InitDlgItem(hPage,s.m_DP5Cfg[dciTPEA]);
00222         InitDlgItem(hPage,s.m_DP5Cfg[dciRTDS]);
00223         InitDlgItem(hPage,s.m_DP5Cfg[dciRTDE]);
00224
00225         InitDlgItem(hPage,s.m_DP5Cfg[dciRTDT]);
00226         InitDlgItem(hPage,s.m_DP5Cfg[dciBLRD]);
00227         InitDlgItem(hPage,s.m_DP5Cfg[dciBLRU]);
00228
00229         InitDlgItem(hPage,s.m_DP5Cfg[dciBLRM]);
00230         InitDlgItem(hPage,s.m_DP5Cfg[dciCUSP]);
00231         //InitDlgItem(hPage,s.m_DP5Cfg[dciPURE]);
00232
00233         InitDlgItem(hPage,s.m_DP5Cfg[dciCLCK]);
00234
00235         if (s.profile->device_type != dppMCA8000D) {
00236                 CboUpdate(dciPURE);
00237         }
00238
00239         if (bIsDPG) {
00240                 CboUpdate(dciSCTC);
00241         }
00242
00243         CboUpdate(dciRTDE);
00244         CboUpdate(dciTPFA);
00245         CboUpdate(dciBLRM);
00246         DisplayBlrMode();
00247
00248         CboUpdate(dciCUSP);
00249         //CboUpdate(dciPURE);
00250
00251         CboUpdate(dciCLCK);
00252
00253         RiseTop.Set80MHzMode(s.DppConfig.b80MHzModeCfg);
00254         RiseTop.Shaping_Setup(&m_RiseCombo,&m_TopCombo);
00255         //Shaping_Setup();
00256
00257         InitComboFromText(hPage,s.m_DP5Cfg[dciTPEA],IDC_RISECOMBO);
00258         RiseTop.SetRiseCombo();
00259         InitComboFromText(hPage,s.m_DP5Cfg[dciTFLA],IDC_TOPCOMBO);
00260         RiseTop.SetTopCombo();
00261
00262         if (s.DppConfig.b80MHzModeCfg) {
00263                 lblFPGAClk[0].SetText("80MHz");
00264                 b80MHzModeCfg_old = TRUE;
00265         } else {
00266                 lblFPGAClk[0].SetText("20MHz");
00267                 b80MHzModeCfg_old = FALSE;
00268         }
00269
00270         lblFPGAClk[1].ShowWindow(SW_HIDE);
00271         lblFPGAClk[2].ShowWindow(SW_HIDE);
00272
00273         // Update THFA (FW6.07.05 and later)
00274         // Select Threshold for Fast Channel for higher range
00275         if (((s.DppConfig.Firmware == 0x67) &&
00276                         (s.DppConfig.Build >= 5)) ||
00277                         (s.DppConfig.Firmware > 0x67))
00278         {
00279                 // update the range label
00280                 GetDlgItem(IDC_OPT_LIMITS_THFA)->SetWindowText("0 to 511.93");
00281         }
00282
00283         //if (s.profile->device_type == dppMCA8000D) {
00284         //      ShowMCA8000D_Controls(SW_HIDE);
00285         //} else {
00286         //      ShowMCA8000D_Controls(SW_SHOW);
00287         //}
00288         //InitComboFromText(hPage,s.m_DP5Cfg[dciTFLA],IDC_RISECOMBO);
00289 }
00290
00291 void CShapingPage::ShowMCA8000D_Controls(int iShowWin)
00292 {
00293         GetDlgItem(IDC_OPT_COMBO_BLRM)->ShowWindow(iShowWin);
00294         GetDlgItem(IDC_OPT_COMBO_CLCK)->ShowWindow(iShowWin);
00295         GetDlgItem(IDC_OPT_COMBO_CUSP)->ShowWindow(iShowWin);
00296         GetDlgItem(IDC_OPT_COMBO_PURE)->ShowWindow(iShowWin);
00297         GetDlgItem(IDC_OPT_COMBO_SCTC)->ShowWindow(iShowWin);
00298         GetDlgItem(IDC_OPT_COMBO_RTDE)->ShowWindow(iShowWin);
00299         GetDlgItem(IDC_OPT_COMBO_TPFA)->ShowWindow(iShowWin);
00300         GetDlgItem(IDC_OPT_FRAME_BLRD)->ShowWindow(iShowWin);
00301         GetDlgItem(IDC_OPT_FRAME_BLRM)->ShowWindow(iShowWin);
00302         GetDlgItem(IDC_OPT_FRAME_BLRU)->ShowWindow(iShowWin);
00303         GetDlgItem(IDC_OPT_FRAME_CLCK)->ShowWindow(iShowWin);
00304         GetDlgItem(IDC_OPT_FRAME_CUSP)->ShowWindow(iShowWin);
00305         GetDlgItem(IDC_OPT_FRAME_PURE)->ShowWindow(iShowWin);
00306         GetDlgItem(IDC_OPT_FRAME_SCTC)->ShowWindow(iShowWin);
00307         GetDlgItem(IDC_OPT_FRAME_RTDE)->ShowWindow(iShowWin);
00308         GetDlgItem(IDC_OPT_FRAME_RTDS)->ShowWindow(iShowWin);
00309         GetDlgItem(IDC_OPT_FRAME_RTDT)->ShowWindow(iShowWin);
00310         GetDlgItem(IDC_OPT_FRAME_TFLA)->ShowWindow(iShowWin);
00311         GetDlgItem(IDC_OPT_FRAME_THFA)->ShowWindow(iShowWin);
00312         GetDlgItem(IDC_OPT_FRAME_TPEA)->ShowWindow(iShowWin);
00313         GetDlgItem(IDC_OPT_FRAME_TPFA)->ShowWindow(iShowWin);
00314         GetDlgItem(IDC_OPT_LIMITS_BLRD)->ShowWindow(iShowWin);
00315         GetDlgItem(IDC_OPT_LIMITS_BLRU)->ShowWindow(iShowWin);
00316         GetDlgItem(IDC_OPT_LIMITS_CUSP)->ShowWindow(iShowWin);
00317         GetDlgItem(IDC_OPT_LIMITS_PURE)->ShowWindow(iShowWin);
00318         GetDlgItem(IDC_OPT_LIMITS_SCTC)->ShowWindow(iShowWin);
00319         GetDlgItem(IDC_OPT_LIMITS_RTDS)->ShowWindow(iShowWin);
00320         GetDlgItem(IDC_OPT_LIMITS_RTDT)->ShowWindow(iShowWin);
00321         GetDlgItem(IDC_OPT_LIMITS_TFLA)->ShowWindow(iShowWin);
00322         GetDlgItem(IDC_OPT_LIMITS_THFA)->ShowWindow(iShowWin);
00323         GetDlgItem(IDC_OPT_LIMITS_TPEA)->ShowWindow(iShowWin);
00324         GetDlgItem(IDC_OPT_TEXT_BLRD)->ShowWindow(iShowWin);
00325         GetDlgItem(IDC_OPT_TEXT_BLRU)->ShowWindow(iShowWin);
00326         GetDlgItem(IDC_OPT_TEXT_CUSP)->ShowWindow(iShowWin);
00327         GetDlgItem(IDC_OPT_TEXT_PURE)->ShowWindow(iShowWin);
00328         GetDlgItem(IDC_OPT_TEXT_SCTC)->ShowWindow(iShowWin);
00329         GetDlgItem(IDC_OPT_TEXT_RTDS)->ShowWindow(iShowWin);
00330         GetDlgItem(IDC_OPT_TEXT_RTDT)->ShowWindow(iShowWin);
00331         GetDlgItem(IDC_OPT_TEXT_TFLA)->ShowWindow(iShowWin);
00332         GetDlgItem(IDC_OPT_TEXT_THFA)->ShowWindow(iShowWin);
00333         GetDlgItem(IDC_OPT_TEXT_TPEA)->ShowWindow(iShowWin);
00334         GetDlgItem(IDC_OPT_UNITS_BLRD)->ShowWindow(iShowWin);
00335         GetDlgItem(IDC_OPT_UNITS_BLRU)->ShowWindow(iShowWin);
00336         GetDlgItem(IDC_OPT_UNITS_CUSP)->ShowWindow(iShowWin);
00337         GetDlgItem(IDC_OPT_UNITS_PURE)->ShowWindow(iShowWin);
00338         GetDlgItem(IDC_OPT_UNITS_SCTC)->ShowWindow(iShowWin);
00339         GetDlgItem(IDC_OPT_UNITS_RESL2)->ShowWindow(iShowWin);
00340         GetDlgItem(IDC_OPT_UNITS_RESL3)->ShowWindow(iShowWin);
00341         GetDlgItem(IDC_OPT_UNITS_RTDS)->ShowWindow(iShowWin);
00342         GetDlgItem(IDC_OPT_UNITS_RTDT)->ShowWindow(iShowWin);
00343         GetDlgItem(IDC_OPT_UNITS_TFLA)->ShowWindow(iShowWin);
00344         GetDlgItem(IDC_OPT_UNITS_THFA)->ShowWindow(iShowWin);
00345         GetDlgItem(IDC_OPT_UNITS_TPEA)->ShowWindow(iShowWin);
00346
00347         GetDlgItem(IDC_STATIC_RTD_FRAME)->ShowWindow(iShowWin);
00348         GetDlgItem(IDC_STATIC_BLR_FRAME)->ShowWindow(iShowWin);
00349         GetDlgItem(IDC_STATIC_FAST_SHAPING_FRAME)->ShowWindow(iShowWin);
00350         GetDlgItem(IDC_BLRQUICKSLOWBUTTON)->ShowWindow(iShowWin);
00351
00352         GetDlgItem(IDC_TIMETOPEAKSTATIC)->ShowWindow(iShowWin);
00353         GetDlgItem(IDC_FLATTOPSTATIC)->ShowWindow(iShowWin);
00354         GetDlgItem(IDC_RISECOMBO)->ShowWindow(iShowWin);
00355         GetDlgItem(IDC_TOPCOMBO)->ShowWindow(iShowWin);
00356         GetDlgItem(IDC_LABEL_QUICK_PICK_SHAPING)->ShowWindow(iShowWin);
00357         GetDlgItem(IDC_LABEL_QUICK_PICK_SHAPING2)->ShowWindow(iShowWin);
00358
00359         GetDlgItem(IDC_STATIC_FPGACLK1)->ShowWindow(iShowWin);
00360         GetDlgItem(IDC_SHAPINGGROUP)->ShowWindow(iShowWin);
00361         GetDlgItem(IDC_LABEL_BLR_MODE_OFF_ON)->ShowWindow(iShowWin);
00362
00363 }
00364
00365 void CShapingPage::InitFastPeakCombo() {
00366     m_FastPeakCombo.ResetContent();
00367         if (s.DppConfig.b80MHzModeCfg) {
00368                 m_FastPeakCombo.AddString("50");
00369                 m_FastPeakCombo.AddString("100");
00370                 m_FastPeakCombo.AddString("200");
00371                 m_FastPeakCombo.AddString("400");
00372                 m_FastPeakCombo.AddString("800");
00373                 m_FastPeakCombo.SetCurSel(1);
00374         } else {
00375                 m_FastPeakCombo.AddString("200");
00376                 m_FastPeakCombo.AddString("400");
00377                 m_FastPeakCombo.AddString("800");
00378                 m_FastPeakCombo.AddString("1600");
00379                 m_FastPeakCombo.AddString("3200");
00380                 m_FastPeakCombo.SetCurSel(1);
00381     }
00382 }
00383
00384 void CShapingPage::InitBlrMode()
00385 {
00386         CString strBLRM;
00387         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_BLRM);
00388         pCombo->ResetContent();
00389         pCombo->AddString("OFF");
00390         pCombo->AddString("1");
00391         if (s.profile->device_type == dppDP5X) {
00392                 pCombo->AddString("3");
00393         }
00394         pCombo->SetCurSel(0);
00395 }
00396
00397 void CShapingPage::InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg)
00398 {
00399         int cboDP5CtrlID = cfg.ListCtrlID;
00400         int txtDP5CtrlID = cfg.TextCtrlID;
00401         CString strVal = cfg.Setting;
00402         int idxList;
00403         CString strUnits;
00404         CString strLimits;
00405
00406         if ((cfg.CtrlType & dctCbo) > 0) {      // try to find list index for any combo
00407                 CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00408                 //idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00409                 idxList = s.CtrlUtil.FindCboIdxExact(hDlg,cboDP5CtrlID,strVal); // try exact first
00410                 if (idxList == LB_ERR) {
00411                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,strVal);
00412                 }
00413                 if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00414                         if ((cfg.CtrlType & dctTxt) > 0) {      // if cbotxt must find mask, else set to 0
00415                                 cfg.TextValue = cfg.Setting;            // overwrite if currently editing
00416                                 idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"#");
00417                                 if (idxList == LB_ERR) { // mask begins with +
00418                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"+");
00419                                 }
00420                                 if (idxList == LB_ERR) { // mask begins with -
00421                                         idxList = s.CtrlUtil.FindCboIdx(hDlg,cboDP5CtrlID,"-");
00422                                 }
00423                                 if (idxList == LB_ERR) { // not found default to 0
00424                                         idxList = 0;
00425                                 }
00426                         } else {
00427                                 idxList = 0;            // set to first item
00428                         }
00429                 }
00430                 cb.SetCurSel(idxList);
00431         }
00432         if ((cfg.CtrlType & dctTxt) > 0) {
00433                 if ((cfg.CtrlType & dctCbo) == 0) {             // cbo update above
00434                         if (cfg.Setting.GetLength() > 0) {
00435                                 cfg.TextValue = cfg.Setting;
00436                         }
00437                 }
00438                 GetDlgItem(txtDP5CtrlID)->SetWindowText(cfg.TextValue);
00439                 strUnits = cfg.Units;
00440                 strLimits = cfg.Limits;
00441                 switch (txtDP5CtrlID) {
00442                         case IDC_OPT_TEXT_TFLA:
00443                                 UNIT_INIT(TFLA, strUnits);
00444                                 LIMIT_INIT(TFLA, strLimits);
00445                                 break;
00446                         case IDC_OPT_TEXT_THFA:
00447                                 UNIT_INIT(THFA, strUnits);
00448                                 LIMIT_INIT(THFA, strLimits);
00449                                 break;
00450                         case IDC_OPT_TEXT_TPEA:
00451                                 UNIT_INIT(TPEA, strUnits);
00452                                 LIMIT_INIT(TPEA, strLimits);
00453                                 break;
00454                         case IDC_OPT_TEXT_RTDS:
00455                                 UNIT_INIT(RTDS, strUnits);
00456                                 LIMIT_INIT(RTDS, strLimits);
00457                                 break;
00458                         case IDC_OPT_TEXT_RTDT:
00459                                 UNIT_INIT(RTDT, strUnits);
00460                                 LIMIT_INIT(RTDT, strLimits);
00461                                 break;
00462                         case IDC_OPT_TEXT_BLRD:
00463                                 UNIT_INIT(BLRD, strUnits);
00464                                 LIMIT_INIT(BLRD, strLimits);
00465                                 break;
00466                         case IDC_OPT_TEXT_BLRU:
00467                                 UNIT_INIT(BLRU, strUnits);
00468                                 LIMIT_INIT(BLRU, strLimits);
00469                                 break;
00470                         case IDC_OPT_TEXT_CUSP:
00471                                 UNIT_INIT(CUSP, strUnits);
00472                                 LIMIT_INIT(CUSP, strLimits);
00473                                 break;
00474                         case IDC_OPT_TEXT_PURE:
00475                                 UNIT_INIT(PURE, strUnits);
00476                                 LIMIT_INIT(PURE, strLimits);
00477                                 break;
00478                         case IDC_OPT_TEXT_SCTC:
00479                                 UNIT_INIT(SCTC, strUnits);
00480                                 LIMIT_INIT(SCTC, strLimits);
00481                                 break;
00482                 }
00483         }
00484 }
00485
00486 // pass dci id to update combo control and display edit controls if any
00487 void CShapingPage::CboUpdate(int nID_dci)
00488 {
00489         CString strCboText;
00490         int nID;
00491         int CmdShow;
00492
00493         nID = s.m_DP5Cfg[nID_dci].ListCtrlID;
00494         if (nID == NULL) { return; }
00495         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00496         int idx = cb.GetCurSel();
00497         if (idx > LB_ERR) {
00498                 cb.GetLBText(idx,strCboText);
00499                 s.m_DP5Cfg[nID_dci].ComboIndex = idx;
00500                 s.m_DP5Cfg[nID_dci].ComboValue = strCboText;
00501         } else {
00502                 return;
00503         }
00504         if (s.m_DP5Cfg[nID_dci].CtrlType == dctCboTxt) {
00505                 if (strCboText.Find('#') >= 0) {
00506                         CmdShow = SW_SHOW;
00507                 } else {
00508                         CmdShow = SW_HIDE;
00509                 }
00510                 switch (nID) {
00511                         case IDC_OPT_COMBO_CUSP:
00512                                 ALL_VIS(CUSP, CmdShow);
00513                                 CBO_TEXT_VIS(CUSP, (CmdShow!=0));
00514                                 break;
00515                         case IDC_OPT_COMBO_PURE:
00516                                 TEXT_VIS(PURE, CmdShow);
00517                                 UNIT_VIS(PURE, CmdShow);
00518                                 LIMIT_VIS(PURE, CmdShow);
00519                                 //ALL_VIS(PURE, CmdShow);       // reserved word causes error in macro
00520                                 CBO_TEXT_VIS(PURE, (CmdShow!=0));
00521                                 break;
00522                         case IDC_OPT_COMBO_SCTC:
00523                                 TEXT_VIS(SCTC, CmdShow);
00524                                 UNIT_VIS(SCTC, CmdShow);
00525                                 LIMIT_VIS(SCTC, CmdShow);
00526                                 //ALL_VIS(SCTC, CmdShow);       // reserved word causes error in macro
00527                                 CBO_TEXT_VIS(SCTC, (CmdShow!=0));
00528                                 break;
00529                 }
00530         }
00531         SetModified(TRUE);
00532 }
00533
00534 //CBO_TEXT_VIS(RESL, (CmdShow!=0));
00535 //CboTextVis(IDC_OPT_COMBO_RESL,IDC_OPT_TEXT_RESL,(CmdShow!=0));
00536 //void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00537 void CShapingPage::CboTextVis(int nIdCbox, int nIdEdit, BOOL isText)
00538 {
00539         UINT ddSize;
00540         RECT lpRect;
00541         CEdit* pEdit;
00542         CComboBox* pCombo;
00543         int btnSize = 20;
00544
00545         pEdit = (CEdit*)GetDlgItem(nIdEdit);            // cast to edit for rect
00546         pEdit->GetRect(&lpRect);                                        // get rect
00547         ddSize = lpRect.right - lpRect.left;            // save width
00548         if (isText) {
00549                 GetDlgItem(nIdEdit)->ShowWindow(SW_SHOW);
00550                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);
00551                 pCombo->GetWindowRect(&lpRect);
00552                 ScreenToClient(&lpRect);
00553                 //int ddSize1 = lpRect.right - lpRect.left;             // save width
00554                 //TRACE("Combo Edit %d\r\n",ddSize1);
00555                 lpRect.right = lpRect.left + btnSize;
00556                 pCombo->MoveWindow(&lpRect,TRUE);
00557                 pCombo->SetDroppedWidth(ddSize + btnSize);
00558         } else {
00559                 GetDlgItem(nIdEdit)->ShowWindow(SW_HIDE);       // hide edit
00560                 //TRACE("Edit %d\r\n",ddSize);
00561                 pCombo = (CComboBox*)GetDlgItem(nIdCbox);       // cast to combo
00562                 pCombo->GetWindowRect(&lpRect);                         // get win size
00563                 ScreenToClient(&lpRect);                                        // adjust to screen
00564                 //int ddSize2 = lpRect.right - lpRect.left;             // save width
00565                 //TRACE("Combo %d\r\n",ddSize2);
00566                 lpRect.right = lpRect.left + ddSize + btnSize;  // get restored combo size
00567                 pCombo->MoveWindow(&lpRect,TRUE);                       // restore combo
00568                 pCombo->SetDroppedWidth(ddSize);                        // restore combo
00569         }
00570 }
00571
00572 // pass dci id to update combo control and display edit controls if any
00573 void CShapingPage::TextUpdate(int nID_dci)
00574 {
00575         CString strText;
00576         int nID;
00577
00578         nID = s.m_DP5Cfg[nID_dci].TextCtrlID;
00579         if (nID == NULL) { return; }
00580
00581         GetDlgItem(nID)->GetWindowText(strText);
00582         s.m_DP5Cfg[nID_dci].TextValue = strText;
00583         SetModified(TRUE);
00584 }
00585
00586 void CShapingPage::OnCbnSelchangeOptComboPure()
00587 {
00588         if (s.profile->device_type != dppMCA8000D) {
00589                 CboUpdate(dciPURE);
00590         }
00591 }
00592
00593 void CShapingPage::OnCbnSelchangeOptComboSctc()
00594 {
00595         BOOL bIsDPG =((s.profile->device_type == dppDP5G) || (s.profile->device_type == dppTB5));
00596         if (bIsDPG) {
00597                 CboUpdate(dciSCTC);
00598         }
00599 }
00600
00601
00602 void CShapingPage::OnCbnSelchangeOptComboRtde()
00603 {
00604         CboUpdate(dciRTDE);
00605 }
00606
00607 void CShapingPage::OnCbnSelchangeOptComboBlrm()
00608 {
00609         CboUpdate(dciBLRM);
00610         DisplayBlrMode();
00611 }
00612
00613 void CShapingPage::DisplayBlrMode()
00614 {
00615         CString strBLRM;
00616         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_BLRM);
00617         pCombo->GetWindowText(strBLRM);
00618         strBLRM = strBLRM.Left(2);
00619         if (strBLRM == "OF") {
00620                 GetDlgItem(IDC_LABEL_BLR_MODE_OFF_ON)->SetWindowText(_T("BLR OFF"));
00621         } else {
00622                 GetDlgItem(IDC_LABEL_BLR_MODE_OFF_ON)->SetWindowText(_T("BLR ON"));
00623         }
00624 }
00625
00626 void CShapingPage::OnCbnSelchangeOptComboCusp()
00627 {
00628         CboUpdate(dciCUSP);
00629 }
00630
00631 void CShapingPage::OnEnChangeOptTextPure()
00632 {
00633         if (s.profile->device_type != dppMCA8000D) {
00634                 TextUpdate(dciPURE);
00635         }
00636 }
00637
00638 void CShapingPage::OnEnChangeOptTextSctc()
00639 {
00640         BOOL bIsDPG =((s.profile->device_type == dppDP5G) || (s.profile->device_type == dppTB5));
00641         if (bIsDPG) {
00642                 TextUpdate(dciSCTC);
00643         }
00644 }
00645
00646 void CShapingPage::OnCbnSelchangeOptComboTpfa()
00647 {
00648         CboUpdate(dciTPFA);
00649 }
00650
00651 void CShapingPage::OnEnChangeOptTextTfla()
00652 {
00653         TextUpdate(dciTFLA);
00654 }
00655
00656 void CShapingPage::OnEnChangeOptTextThfa()
00657 {
00658         TextUpdate(dciTHFA);
00659 }
00660
00661 void CShapingPage::OnEnChangeOptTextTpea()
00662 {
00663         TextUpdate(dciTPEA);
00664 }
00665
00666 void CShapingPage::OnEnChangeOptTextRtds()
00667 {
00668         TextUpdate(dciRTDS);
00669 }
00670
00671 void CShapingPage::OnEnChangeOptTextRtdt()
00672 {
00673         TextUpdate(dciRTDT);
00674 }
00675
00676 void CShapingPage::OnEnChangeOptTextBlrd()
00677 {
00678         TextUpdate(dciBLRD);
00679 }
00680
00681 void CShapingPage::OnEnChangeOptTextBlru()
00682 {
00683         TextUpdate(dciBLRU);
00684 }
00685
00686 void CShapingPage::OnEnChangeOptTextCusp()
00687 {
00688         TextUpdate(dciCUSP);
00689 }
00690
00691 void CShapingPage::OnCbnSelchangeOptComboClck()
00692 {
00693         CString strClck;
00694         CString strOldClck;
00695
00696         CComboBox* pCombo = (CComboBox*)GetDlgItem(IDC_OPT_COMBO_CLCK);
00697         pCombo->GetWindowText(strClck);
00698
00699         if (atoi(strClck) == 20) {
00700                 s.DppConfig.b80MHzModeCfg = FALSE;
00701         } else if (atoi(strClck) == 80) {
00702                 s.DppConfig.b80MHzModeCfg = TRUE;
00703         }
00704         //AfxMessageBox(strClck);
00705         CboUpdate(dciCLCK);
00706         lblFPGAClk[1].ShowWindow(SW_HIDE);
00707         lblFPGAClk[2].ShowWindow(SW_HIDE);
00708         if (b80MHzModeCfg_old != s.DppConfig.b80MHzModeCfg) {
00709                 if (s.isDppConnected) {
00710                         lblFPGAClk[1].ShowWindow(SW_SHOW);
00711                 } else {
00712                         lblFPGAClk[2].ShowWindow(SW_SHOW);
00713                 }
00714         }
00715         UpdateData(FALSE);
00716 }
00717
00718 void CShapingPage::BLRQuickSet(CString strMode, CString strDown, CString strUp)
00719 {
00720         int idxList;
00721         HWND hDlg = this->GetSafeHwnd();
00722         CString strVal = strMode;                       // set BLR to MODE 1
00723         CComboBox &cb = *(CComboBox *) GetDlgItem(IDC_OPT_COMBO_BLRM);
00724
00725         //idxList = s.CtrlUtil.FindCboIdx(hDlg,IDC_OPT_COMBO_BLRM,strVal);
00726         idxList = s.CtrlUtil.FindCboIdxExact(hDlg,IDC_OPT_COMBO_BLRM,strVal);   // try exact first
00727         if (idxList == LB_ERR) {
00728                 idxList = s.CtrlUtil.FindCboIdx(hDlg,IDC_OPT_COMBO_BLRM,strVal);
00729         }
00730
00731         if (idxList == LB_ERR) { // not found default to 0
00732                 idxList = 0;
00733         }
00734         cb.SetCurSel(idxList);
00735         CboUpdate(dciBLRM);
00736
00737         GetDlgItem(IDC_OPT_TEXT_BLRD)->SetWindowText(strDown);
00738         TextUpdate(dciBLRD);
00739
00740         GetDlgItem(IDC_OPT_TEXT_BLRU)->SetWindowText(strUp);
00741         TextUpdate(dciBLRU);
00742 }
00743
00744 BOOL CShapingPage::PreTranslateMessage(MSG* pMsg)
00745 {
00746         // TODO: Add your specialized code here and/or call the base class
00747
00748         //==================================================================
00749         MSG msg = *pMsg;
00750         if (msg.message == WM_MOUSEMOVE) {      // Relay events to the tooltip control
00751                 msg.hwnd = (HWND)m_ToolTip.SendMessage(TTM_WINDOWFROMPOINT, 0, (LPARAM)&msg.pt);
00752                 CPoint pt = pMsg->pt;
00753                 ::ScreenToClient(msg.hwnd, &pt);
00754                 msg.lParam = MAKELONG(pt.x, pt.y);
00755                 m_ToolTip.Activate(TRUE);   // make sure tooltip is active
00756                 m_ToolTip.RelayEvent(&msg); // Let the ToolTip process this message.
00757         } else if ( pMsg->message == WM_KEYDOWN && pMsg->wParam == VK_RETURN ) {
00758                 CWnd* pCurrent= GetFocus();
00759                 int ctrl = pCurrent->GetDlgCtrlID();
00760                 //if (ctrl == IDC_OPT_TEXT_MCST) {
00761                 if (isCEditBox(ctrl)) {
00762                         ::SendMessage(this->m_hWnd, WM_COMMAND, MAKEWPARAM(ctrl, EN_CHANGE), (LPARAM) m_hWnd);
00763                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00764                         pMsg->wParam = VK_TAB;
00765                         //if ( pNext != NULL ) {
00766                         //      if (pNext->GetDlgCtrlID() != IDOK ) {
00767                         //              pNext->SetFocus();
00768                         //              return TRUE;
00769                         //      }
00770                         //}
00771                 } else if (isCComboBox(ctrl)) {
00772                         CWnd* pNext= pCurrent->GetNextWindow( GW_HWNDNEXT );
00773                         pMsg->wParam = VK_TAB;
00774                 }
00775         }
00776
00777         //==================================================================
00778         return CCfgPropPage::PreTranslateMessage(pMsg);
00779 }
00780
00781 BOOL CShapingPage::isCEditBox(int nID)
00782 {
00783         BOOL isEdit = FALSE;
00784         switch (nID) {
00785                 case IDC_OPT_TEXT_TFLA:
00786                         isEdit = TRUE;
00787                         break;
00788                 case IDC_OPT_TEXT_THFA:
00789                         isEdit = TRUE;
00790                         break;
00791                 case IDC_OPT_TEXT_TPEA:
00792                         isEdit = TRUE;
00793                         break;
00794                 case IDC_OPT_TEXT_RTDS:
00795                         isEdit = TRUE;
00796                         break;
00797                 case IDC_OPT_TEXT_RTDT:
00798                         isEdit = TRUE;
00799                         break;
00800                 case IDC_OPT_TEXT_BLRD:
00801                         isEdit = TRUE;
00802                         break;
00803                 case IDC_OPT_TEXT_BLRU:
00804                         isEdit = TRUE;
00805                         break;
00806                 case IDC_OPT_TEXT_CUSP:
00807                         isEdit = TRUE;
00808                         break;
00809                 case IDC_OPT_TEXT_PURE:
00810                         isEdit = TRUE;
00811                         break;
00812                 case IDC_OPT_TEXT_SCTC:
00813                         isEdit = TRUE;
00814                         break;
00815                 case IDC_OPT_TEXT_TLLD:
00816                         isEdit = TRUE;
00817                         break;
00818         }
00819         return isEdit;
00820 }
00821
00822 BOOL CShapingPage::isCComboBox(int nID)
00823 {
00824         BOOL isCombo = FALSE;
00825         switch (nID) {
00826                 case IDC_OPT_COMBO_CLCK:
00827                         isCombo = TRUE;
00828                         break;
00829                 case IDC_OPT_COMBO_PURE:
00830                         isCombo = TRUE;
00831                         break;
00832                 case IDC_OPT_COMBO_SCTC:
00833                         isCombo = TRUE;
00834                         break;
00835                 case IDC_OPT_COMBO_RTDE:
00836                         isCombo = TRUE;
00837                         break;
00838                 case IDC_OPT_COMBO_BLRM:
00839                         isCombo = TRUE;
00840                         break;
00841                 case IDC_OPT_COMBO_CUSP:
00842                         isCombo = TRUE;
00843                         break;
00844                 case IDC_OPT_COMBO_TLLD:
00845                         isCombo = TRUE;
00846                         break;
00847                 case IDC_OPT_COMBO_TPFA:
00848                         isCombo = TRUE;
00849                         break;
00850         }
00851         return isCombo;
00852 }
00853
00854 void CShapingPage::SetCboItem(int nID, CString strVal)
00855 {
00856         HWND hPage = this->GetSafeHwnd();
00857         int cboDP5CtrlID = nID;
00858         int idxList;
00859
00860         CComboBox &cb = *(CComboBox *) GetDlgItem(cboDP5CtrlID);
00861         idxList = s.CtrlUtil.FindCboIdxExact(hPage,cboDP5CtrlID,strVal);        // try exact first
00862         if (idxList == LB_ERR) {
00863                 idxList = s.CtrlUtil.FindCboIdx(hPage,cboDP5CtrlID,strVal);
00864         }
00865         if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00866                 idxList = 0;            // set to first item
00867         }
00868         cb.SetCurSel(idxList);
00869 }
00870
00871 void CShapingPage::OnCbnSelchangeRisecombo()
00872 {
00873         CString strRise;
00874         RiseTop.SetRiseCombo();
00875         m_RiseCombo.GetWindowText(strRise);
00876         GetDlgItem(IDC_OPT_TEXT_TPEA)->SetWindowText(strRise);
00877         TextUpdate(dciTPEA);
00878         SetCboItem(IDC_TOPCOMBO,"0.200");
00879         OnCbnSelchangeTopcombo();
00880 }
00881
00882 void CShapingPage::OnCbnSelchangeTopcombo()
00883 {
00884         CString strTop;
00885         RiseTop.SetTopCombo();
00886         m_TopCombo.GetWindowText(strTop);
00887         GetDlgItem(IDC_OPT_TEXT_TFLA)->SetWindowText(strTop);
00888         TextUpdate(dciTFLA);
00889 }
00890
00891 void CShapingPage::InitComboFromText(HWND hDlg, DP5_CONFIGURATION cfg, int nID)
00892 {
00893         CString strVal = cfg.Setting;
00894         int idxList;
00895
00896         CComboBox &cb = *(CComboBox *) GetDlgItem(nID);
00897         idxList = s.CtrlUtil.FindCboIdx(hDlg,nID,strVal);
00898
00899         idxList = s.CtrlUtil.FindCboIdxExact(hDlg,nID,strVal);  // try exact first
00900         if (idxList == LB_ERR) {
00901                 idxList = s.CtrlUtil.FindCboIdx(hDlg,nID,strVal);
00902         }
00903
00904         if (idxList == LB_ERR) {        // if (idxList != LB_ERR) we already found the value
00905                 strVal = cfg.TextValue;
00906                 idxList = s.CtrlUtil.FindCboIdx(hDlg,nID,strVal);
00907                 if (idxList == LB_ERR) { // not found default to 0
00908                         idxList = 0;
00909                 }
00910         }
00911         cb.SetCurSel(idxList);
00912 }
00913
00914 // this function replaces blr quickset 20110504
00915 void CShapingPage::OnBnClickedBlrquickslowbutton2()
00916 {
00917         BLRQuickSet("1","3","0");
00918 }
00919
00921 // HtmlHelp for shared dialog
00922 // NOTE: shared dialogs use string type IDD, not global IDD
00923 BOOL CShapingPage::OnHelpInfo(HELPINFO* pHelpInfo)
00924 {
00925         CString strHelp;
00926         if (pHelpInfo->iContextType == HELPINFO_WINDOW) {
00927                 if (pHelpInfo->dwContextId == 0) {
00928                         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_SHAPING_PAGE);
00929                 } else {
00930                         //
00931                 }
00932         }
00933         return true;
00934 }
00935
00936 void CShapingPage::OnHelp()                             // enable property sheet help button help
00937 {
00938         ::HtmlHelp(this->GetSafeHwnd(), theApp.m_pszHelpFilePath, HH_HELP_CONTEXT, HIDD_SHAPING_PAGE);
00939     //SendMessage(WM_COMMANDHELP);      //
00940 }
00942
00943 void CShapingPage::BuildToolTips()
00944 {
00945         if (!m_ToolTip.Create(this)) {
00946                 TRACE0("Unable to create ToolTip control\n");
00947         } else {
00948         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_BLRD), IDS_TT_BLR_DOWN_CORRECTION);
00949         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_BLRD), IDS_TT_BLR_DOWN_CORRECTION);
00950         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_BLRD), IDS_TT_BLR_DOWN_CORRECTION);
00951         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_BLRD), IDS_TT_BLR_DOWN_CORRECTION);
00952         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_BLRM), IDS_TT_BLR_MODE);
00953         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_BLRM), IDS_TT_BLR_MODE);
00954         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_BLRU), IDS_TT_BLR_UP_CORRECTION);
00955         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_BLRU), IDS_TT_BLR_UP_CORRECTION);
00956         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_BLRU), IDS_TT_BLR_UP_CORRECTION);
00957         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_BLRU), IDS_TT_BLR_UP_CORRECTION);
00958         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_CLCK), IDS_TT_FPGA_CLOCK_SPEED);
00959         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_CLCK), IDS_TT_FPGA_CLOCK_SPEED);
00960         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_CUSP), IDS_TT_NON_TRAPEZOIDAL_SHAPING);
00961         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_CUSP), IDS_TT_NON_TRAPEZOIDAL_SHAPING);
00962         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_CUSP), IDS_TT_NON_TRAPEZOIDAL_SHAPING);
00963         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_CUSP), IDS_TT_NON_TRAPEZOIDAL_SHAPING);
00964         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_CUSP), IDS_TT_NON_TRAPEZOIDAL_SHAPING);
00966         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_PURE), IDS_TT_PUR_ON_OFF);
00967         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_PURE), IDS_TT_PUR_ON_OFF);
00968         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_PURE), IDS_TT_PUR_ON_OFF);
00969         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_PURE), IDS_TT_PUR_ON_OFF);
00970         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_PURE), IDS_TT_PUR_ON_OFF);
00971         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_SCTC), IDS_TT_SCTC);
00972         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_SCTC), IDS_TT_SCTC);
00973         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_SCTC), IDS_TT_SCTC);
00974         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_SCTC), IDS_TT_SCTC);
00975         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_SCTC), IDS_TT_SCTC);
00976         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_RTDE), IDS_TT_RTD_ON_OFF);
00977         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_RTDE), IDS_TT_RTD_ON_OFF);
00978         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_RTDS), IDS_TT_RTD_SENSITIVITY);
00979         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_RTDS), IDS_TT_RTD_SENSITIVITY);
00980         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_RTDS), IDS_TT_RTD_SENSITIVITY);
00981         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_RTDS), IDS_TT_RTD_SENSITIVITY);
00982         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_RTDT), IDS_TT_RTD_THRESHOLD);
00983         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_RTDT), IDS_TT_RTD_THRESHOLD);
00984         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_RTDT), IDS_TT_RTD_THRESHOLD);
00985         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_RTDT), IDS_TT_RTD_THRESHOLD);
00986         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_TFLA), IDS_TT_FLAT_TOP_WIDTH);
00987         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_TFLA), IDS_TT_FLAT_TOP_WIDTH);
00988         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_TFLA), IDS_TT_FLAT_TOP_WIDTH);
00989         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TFLA), IDS_TT_FLAT_TOP_WIDTH);
00990         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_THFA), IDS_TT_FAST_THRESHOLD);
00991         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_THFA), IDS_TT_FAST_THRESHOLD);
00992         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_THFA), IDS_TT_FAST_THRESHOLD);
00993         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_THFA), IDS_TT_FAST_THRESHOLD);
00994         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_TLLD), IDS_TT);
00995         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_TLLD), IDS_TT);
00996         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_TLLD), IDS_TT);
00997         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_TLLD), IDS_TT);
00998         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TLLD), IDS_TT);
00999         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_TEXT_TPEA), IDS_TT_PEAKING_TIME);
01000         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_LIMITS_TPEA), IDS_TT_PEAKING_TIME);
01001         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TPEA), IDS_TT_PEAKING_TIME);
01002         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_TPEA), IDS_TT_PEAKING_TIME);
01003         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_COMBO_TPFA), IDS_TT_FAST_PEAKING_TIME);
01004         m_ToolTip.AddTool(GetDlgItem(IDC_OPT_FRAME_TPFA), IDS_TT_FAST_PEAKING_TIME);
01005         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_FPGACLK1), IDS_TT);
01006         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_FPGACLK2), IDS_TT);
01007         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_FPGACLK3), IDS_TT);
01008         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_SHAPING_ADVANCED), IDS_TT);
01009         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_PULSE_SHAPING), IDS_TT);
01010         m_ToolTip.AddTool(GetDlgItem(IDC_LABEL_QUICK_PICK_SHAPING), IDS_TT_PEAKING_QPICK);
01011         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_SHAPING_BASIC), IDS_TT);
01012         m_ToolTip.AddTool(GetDlgItem(IDC_TOPCOMBO), IDS_TT_PEAKING_QPICK);
01013         m_ToolTip.AddTool(GetDlgItem(IDC_RISECOMBO), IDS_TT_PEAKING_QPICK);
01014         //m_ToolTip.AddTool(GetDlgItem(IDC_SHAPINGGROUP), IDS_TT);
01015         //m_ToolTip.AddTool(GetDlgItem(IDC_STATIC_SHAPING_STANDARD), IDS_TT);
01016         m_ToolTip.AddTool(GetDlgItem(IDC_LABEL_QUICK_PICK_SHAPING2), IDS_TT_PEAKING_QPICK);
01017         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_RESL2), IDS_TT);
01018         //m_ToolTip.AddTool(GetDlgItem(IDC_OPT_UNITS_RESL3), IDS_TT);
01019         //m_ToolTip.AddTool(GetDlgItem(IDC_TIMETOPEAKSTATIC), IDS_TT);
01020         //m_ToolTip.AddTool(GetDlgItem(IDC_FLATTOPSTATIC), IDS_TT);
01021         m_ToolTip.AddTool(GetDlgItem(IDC_BLRQUICKSLOWBUTTON), IDS_TT_BLR_QUICKSET);
01022
01023                 m_ToolTip.Activate(TRUE);
01024                 m_ToolTip.SetMaxTipWidth(200);
01025         }
01026 }
01027
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ShapingPage.h Source File

DP5Cfg/ShapingPage.h
Go to the documentation of this file.
00001 #if !defined(AFX_ShapingPage_H__INCLUDED_)
00002 #define AFX_ShapingPage_H__INCLUDED_
00003
00004 #if _MSC_VER > 1000
00005 #pragma once
00006 #endif // _MSC_VER > 1000
00007 // ShapingPage.h : header file
00008 //
00009
00010 #include "CfgPropSheet.h"
00011 #include "afxwin.h"
00012 #include "label.h"
00013 #include ".\dppshaping.h"
00014
00016 // CShapingPage dialog
00017
00018 class CShapingPage : public CCfgPropPage
00019 {
00020         DECLARE_DYNCREATE(CShapingPage)
00021
00022 // Construction
00023 public:
00024         CShapingPage();
00025         ~CShapingPage();
00026
00027 // Dialog Data
00028         //{{AFX_DATA(CShapingPage)
00029         //enum { IDD = IDD_SHAPING_PAGE };
00030         //}}AFX_DATA
00031
00032
00033 // Overrides
00034         // ClassWizard generate virtual function overrides
00035         //{{AFX_VIRTUAL(CShapingPage)
00036         protected:
00037         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00038         //}}AFX_VIRTUAL
00039
00040 // Implementation
00041 protected:
00042         // Generated message map functions
00043         //{{AFX_MSG(CShapingPage)
00044         //}}AFX_MSG
00045         DECLARE_MESSAGE_MAP()
00046         CToolTipCtrl m_ToolTip;                                                         // Tooltip control
00047
00048 public:
00049         void BuildToolTips();                                                           // Tooltip control
00050
00051         //CStatic m_ShapingPageLabel;
00052         CLabel m_ShapingPageLabel;
00053         //CStatic m_ShapingAdvancedLabel;
00054         CLabel m_ShapingAdvancedLabel;
00055         //CStatic m_ShapingStandardLabel;
00056         CLabel m_ShapingStandardLabel;
00057         virtual BOOL OnSetActive();
00058         virtual BOOL OnInitDialog();
00059
00060         void InitControls();
00061         void ShowMCA8000D_Controls(int iShowWin);
00062
00063         void InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg);
00064         void CboUpdate(int nID_dci);
00065         void TextUpdate(int nID_dci);
00066
00067         afx_msg void OnCbnSelchangeOptComboPure();
00068         afx_msg void OnCbnSelchangeOptComboSctc();
00069         afx_msg void OnCbnSelchangeOptComboRtde();
00070         afx_msg void OnCbnSelchangeOptComboBlrm();
00071         void DisplayBlrMode();
00072         afx_msg void OnCbnSelchangeOptComboCusp();
00073         afx_msg void OnEnChangeOptTextTfla();
00074         afx_msg void OnEnChangeOptTextThfa();
00075         afx_msg void OnEnChangeOptTextTpea();
00076         afx_msg void OnEnChangeOptTextRtds();
00077         afx_msg void OnEnChangeOptTextRtdt();
00078         afx_msg void OnEnChangeOptTextBlrd();
00079         afx_msg void OnEnChangeOptTextBlru();
00080         afx_msg void OnEnChangeOptTextCusp();
00081         afx_msg void OnEnChangeOptTextPure();
00082         afx_msg void OnEnChangeOptTextSctc();
00083         afx_msg void OnCbnSelchangeOptComboClck();
00084
00085         void BLRQuickSet(CString strMode, CString strDown, CString strUp);
00086         void CboTextVis(int nIdCbox, int nIdEdit, BOOL isText);
00087
00088         virtual BOOL PreTranslateMessage(MSG* pMsg);
00089         BOOL isCEditBox(int nID);
00090         BOOL isCComboBox(int nID);
00091
00092         CDppShaping RiseTop;
00093         CComboBox m_RiseCombo;
00094         CComboBox m_TopCombo;
00095         CComboBox m_FastPeakCombo;
00096         void InitFastPeakCombo();
00097         void InitBlrMode();
00098
00099         void SetCboItem(int nID, CString strVal);
00100         afx_msg void OnCbnSelchangeRisecombo();
00101         afx_msg void OnCbnSelchangeTopcombo();
00102
00103         void InitComboFromText(HWND hDlg, DP5_CONFIGURATION cfg, int nID);
00104         CLabel lblFPGAClk[3];                                                   // displays dpp found by comm type
00105         BOOL b80MHzModeCfg_old;
00106
00107         afx_msg void OnCbnSelchangeOptComboTpfa();
00108         afx_msg void OnBnClickedBlrquickslowbutton2();  // 20110504 replaces blr quickset
00109
00110         afx_msg void OnHelp();
00111         afx_msg BOOL OnHelpInfo(HELPINFO* pHelpInfo);
00112
00113 };
00114
00115 //{{AFX_INSERT_LOCATION}}
00116 // Microsoft Visual C++ will insert additional declarations immediately before the previous line.
00117
00118 #endif // !defined(AFX_ShapingPage_H__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DP5Cfg/ShapingPageRes.h Source File

DP5Cfg/ShapingPageRes.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by ShapingPage.rc
00004 //
00005 #define IDC_OPT_COMBO_TLLD              1289
00006 #define IDC_OPT_FRAME_TLLD              1305
00007 #define IDC_OPT_LIMITS_TLLD             1316
00008 #define IDC_OPT_TEXT_TLLD               1327
00009 #define IDC_OPT_UNITS_TLLD              1338
00010 #define IDC_BLRQUICKSLOWBUTTON          1408
00011 #define IDC_FLATTOPSTATIC               1410
00012 #define IDC_LABEL_QUICK_PICK_SHAPING    1411
00013 #define IDC_LABEL_QUICK_PICK_SHAPING2   1412
00014 #define IDC_OPT_COMBO_BLRM              1413
00015 #define IDC_OPT_COMBO_CLCK              1414
00016 #define IDC_OPT_COMBO_CUSP              1415
00017 #define IDC_OPT_COMBO_PURE              1416
00018 #define IDC_OPT_COMBO_RTDE              1417
00019 #define IDC_OPT_COMBO_TPFA              1418
00020 #define IDC_OPT_FRAME_BLRD              1419
00021 #define IDC_OPT_FRAME_BLRM              1420
00022 #define IDC_OPT_FRAME_BLRU              1421
00023 #define IDC_OPT_FRAME_CLCK              1422
00024 #define IDC_OPT_FRAME_CUSP              1423
00025 #define IDC_OPT_FRAME_PURE              1424
00026 #define IDC_OPT_FRAME_RTDE              1425
00027 #define IDC_OPT_FRAME_RTDS              1426
00028 #define IDC_OPT_FRAME_RTDT              1427
00029 #define IDC_OPT_FRAME_TFLA              1428
00030 #define IDC_OPT_FRAME_THFA              1429
00031 #define IDC_OPT_FRAME_TPEA              1430
00032 #define IDC_OPT_FRAME_TPFA              1431
00033 #define IDC_OPT_LIMITS_BLRD             1432
00034 #define IDC_OPT_LIMITS_BLRU             1433
00035 #define IDC_OPT_LIMITS_CUSP             1434
00036 #define IDC_OPT_LIMITS_RTDS             1435
00037 #define IDC_OPT_LIMITS_RTDT             1436
00038 #define IDC_OPT_LIMITS_TFLA             1437
00039 #define IDC_OPT_LIMITS_THFA             1438
00040 #define IDC_OPT_LIMITS_TPEA             1439
00041 #define IDC_OPT_TEXT_BLRD               1440
00042 #define IDC_OPT_TEXT_BLRU               1441
00043 #define IDC_OPT_TEXT_CUSP               1442
00044 #define IDC_OPT_TEXT_RTDS               1443
00045 #define IDC_OPT_TEXT_RTDT               1444
00046 #define IDC_OPT_TEXT_TFLA               1445
00047 #define IDC_OPT_TEXT_THFA               1446
00048 #define IDC_OPT_TEXT_TPEA               1447
00049 #define IDC_OPT_UNITS_BLRD              1448
00050 #define IDC_OPT_UNITS_BLRU              1449
00051 #define IDC_OPT_UNITS_CUSP              1450
00052 #define IDC_OPT_UNITS_RESL2             1451
00053 #define IDC_OPT_UNITS_RESL3             1452
00054 #define IDC_OPT_UNITS_RTDS              1453
00055 #define IDC_OPT_UNITS_RTDT              1454
00056 #define IDC_OPT_UNITS_TFLA              1455
00057 #define IDC_OPT_UNITS_THFA              1456
00058 #define IDC_OPT_UNITS_TPEA              1457
00059 #define IDC_RISECOMBO                   1458
00060 #define IDC_SHAPINGGROUP                1459
00061 #define IDC_STATIC_FPGACLK1             1460
00062 #define IDC_STATIC_FPGACLK2             1461
00063 #define IDC_STATIC_FPGACLK3             1462
00064 #define IDC_STATIC_PULSE_SHAPING        1463
00065 #define IDC_STATIC_SHAPING_ADVANCED     1464
00066 #define IDC_STATIC_SHAPING_BASIC        1465
00067 #define IDC_STATIC_SHAPING_PAGE         1466
00068 #define IDC_STATIC_SHAPING_STANDARD     1467
00069 #define IDC_TIMETOPEAKSTATIC            1468
00070 #define IDC_TOPCOMBO                    1469
00071 #define IDC_LABEL_BLR_MODE_OFF_ON       1470
00072 #define IDC_STATIC_RTD_FRAME            1471
00073 #define IDC_STATIC_BLR_FRAME            1472
00074 #define IDC_STATIC_FAST_SHAPING_FRAME   1473
00075 #define IDC_OPT_LIMITS_PURE             1474
00076 #define IDC_OPT_TEXT_PURE               1475
00077 #define IDC_OPT_UNITS_PURE              1476
00078 #define IDC_OPT_FRAME_SCTC              1477
00079 #define IDC_OPT_COMBO_SCTC              1478
00080 #define IDC_OPT_LIMITS_SCTC             1479
00081 #define IDC_OPT_TEXT_SCTC               1480
00082 #define IDC_OPT_UNITS_SCTC              1481
00083 #define IDS_TT_PEAKING_TIME             5376
00084 #define IDS_TT_PEAKING_QPICK            5377
00085 #define IDS_TT_FLAT_TOP_WIDTH           5378
00086 #define IDS_TT_PUR_ON_OFF               5379
00087 #define IDS_TT_FAST_PEAKING_TIME        5380
00088 #define IDS_TT_FAST_THRESHOLD           5381
00089 #define IDS_TT_FPGA_CLOCK_SPEED         5382
00090 #define IDS_TT_NON_TRAPEZOIDAL_SHAPING  5383
00091 #define IDS_TT_BLR_QUICKSET             5384
00092 #define IDS_TT_RTD_ON_OFF               5385
00093 #define IDS_TT_RTD_THRESHOLD            5386
00094 #define IDS_TT_RTD_SENSITIVITY          5387
00095 #define IDS_TT_BLR_DOWN_CORRECTION      5388
00096 #define IDS_TT_BLR_UP_CORRECTION        5389
00097 #define IDS_TT_BLR_MODE                 5390
00098 #define IDS_TT_SCTC                     5391
00099
00100 // Next default values for new objects
00101 //
00102 #ifdef APSTUDIO_INVOKED
00103 #ifndef APSTUDIO_READONLY_SYMBOLS
00104 #define _APS_NEXT_RESOURCE_VALUE        5391
00105 #define _APS_NEXT_COMMAND_VALUE         33344
00106 #define _APS_NEXT_CONTROL_VALUE         1477
00107 #define _APS_NEXT_SYMED_VALUE           5391
00108 #endif
00109 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectraList.cpp Source File

SpectraList.cpp
Go to the documentation of this file.
00001 #include ".\spectralist.h"
00002
00003 CSpectraList::CSpectraList(void)
00004 {
00005 }
00006
00007 CSpectraList::~CSpectraList(void)
00008 {
00009 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectraList.h Source File

SpectraList.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "StdAfx.h"
00003 #include ".\spectrum.h"
00004
00005 class CSpectraList
00006 {
00007 public:
00008         CSpectraList(void);
00009         ~CSpectraList(void);
00010         CSpectrum *m_currentSpectrum;
00011 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Spectrum.cpp Source File

Spectrum.cpp
Go to the documentation of this file.
00001 #include ".\spectrum.h"
00002
00003
00004 CSpectrum::CSpectrum(void)
00005 {
00006 }
00007
00008 CSpectrum::~CSpectrum(void)
00009 {
00010 }
00011
00012
00013 int CSpectrum::PosToChannel(double pos)
00014 {
00015     int ipos = int(pos + 0.5);
00016     return (PosToChannel(ipos));
00017 }
00018
00019 int CSpectrum::PosToChannel(int pos)
00020 {
00021     int res = (pos >> (MAX_GAIN_INDEX - m_attr.gainIndex));
00022     return res;
00023 }
00024
00025
00026
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Spectrum.h Source File

Spectrum.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "stdafx.h"
00003 #include ".\spectrumattr.h"
00004 #include "Roi.h"
00005
00006 class CSpectrum
00007 {
00008 public:
00009         CSpectrum(void);
00010         ~CSpectrum(void);
00011         int PosToChannel(double pos);
00012         int PosToChannel(int pos);
00013         CSpectrumAttr m_attr;
00014         CRoi m_roi;
00015 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectrumAttr.cpp Source File

SpectrumAttr.cpp
Go to the documentation of this file.
00001 #pragma once
00002
00003 #include ".\spectrumattr.h"
00004
00005 CSpectrumAttr::CSpectrumAttr(void)
00006 {
00007 }
00008
00009 CSpectrumAttr::~CSpectrumAttr(void)
00010 {
00011 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: SpectrumAttr.h Source File

SpectrumAttr.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "StdAfx.h"
00003 #define MAX_GAIN_INDEX 6
00004
00005 class CSpectrumAttr
00006 {
00007 public:
00008         CSpectrumAttr(void);
00009         ~CSpectrumAttr(void);
00010     int gainIndex;
00011     CString file;
00012     CString tag;
00013     CString description;
00014         CString generalNotes;
00015         CString notesNotes;
00016         CString systemNotes;
00017     CString expressionText;
00018     int contourWidth;
00019     COLORREF contourColor;
00020     BOOL isExpression;
00021         BOOL printNotes;
00022     void SetDefaultAttr(void);
00023     BOOL ValidateTag(void);
00024
00025
00026 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: StdAfx.cpp Source File

StdAfx.cpp
Go to the documentation of this file.
00001 // stdafx.cpp : source file that includes just the standard includes
00002 //      Pmca.pch will be the pre-compiled header
00003 //      stdafx.obj will contain the pre-compiled type information
00004
00005 #include "stdafx.h"
00006
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: StdAfx.h Source File

StdAfx.h
Go to the documentation of this file.
00001 // stdafx.h : include file for standard system include files,
00002 //  or project specific include files that are used frequently, but
00003 //      are changed infrequently
00004 //
00005
00006 #if !defined(AFX_STDAFX_H__3767FA76_575A_11D2_9A26_00403354E42C__INCLUDED_)
00007 #define AFX_STDAFX_H__3767FA76_575A_11D2_9A26_00403354E42C__INCLUDED_
00008
00009 #define _CRT_SECURE_NO_DEPRECATE 1
00010 #pragma warning(disable:4995)
00011 #pragma warning(disable:4996)
00012
00013 #define _SETUPAPI_VER 0x0501
00014
00015 // Modify the following defines if you have to target an OS before the ones
00016 // specified in the following code. See MSDN for the latest information
00017 // about corresponding values for different operating systems.
00018 #ifndef WINVER          // Permit use of features specific to Windows 95 and Windows NT 4.0 or later.
00019 #define WINVER 0x0501   // Change this to the appropriate value to target
00020 #endif                     // Windows 98 and Windows 2000 or later.
00021
00022 // _WIN32_WINNT to be #defined at 0x0500 for vs2010
00023 #ifndef _WIN32_WINNT    // Permit use of features specific to Windows NT 4.0 or later.
00024 #define _WIN32_WINNT 0x0501     // Change this to the appropriate value to target
00025 #endif                   // Windows 98 and Windows 2000 or later.
00026
00027 #ifndef _WIN32_WINDOWS        // Permit use of features specific to Windows 98 or later.
00028 #define _WIN32_WINDOWS 0x0410    // Change this to the appropriate value to target
00029 #endif                        // Windows Millennium Edition or later.
00030
00031 #ifndef _WIN32_IE               // Permit use of features specific to Internet Explorer 4.0 or later.
00032 #define _WIN32_IE 0x0600   // Change this to the appropriate value to target
00033 #endif                  // Internet Explorer 5.0 or later.
00034
00035 #if _MSC_VER >= 1000
00036 #pragma once
00037 #endif // _MSC_VER >= 1000
00038
00039 #define VC_EXTRALEAN            // Exclude rarely-used stuff from Windows headers
00040
00041 #include <afxwin.h>         // MFC core and standard components
00042 #include <afxext.h>         // MFC extensions
00043 #include <afxole.h>         // MFC OLE classes
00044 #include <afxdisp.h>        // MFC Automation classes
00045 #include <afxdtctl.h>           // MFC support for Internet Explorer 4 Common Controls
00046 #include <vector>
00047 #ifndef _AFX_NO_AFXCMN_SUPPORT
00048 #include <afxcmn.h>                     // MFC support for Windows Common Controls
00049 #endif // _AFX_NO_AFXCMN_SUPPORT
00050 #include <afxdlgs.h>
00051 #include <afxtempl.h>
00052
00053 #include <afxsock.h>            // MFC socket extensions
00054
00055 //{{AFX_INSERT_LOCATION}}
00056 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00057
00058 #endif // !defined(AFX_STDAFX_H__3767FA76_575A_11D2_9A26_00403354E42C__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyComboBox.cpp Source File

Controls/TrapKeyComboBox.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\trapkeyComboBox.h"
00003
00004 CTrapKeyComboBox::CTrapKeyComboBox(void)
00005 {
00006         isEnterKey = false;
00007         isLButton = false;
00008 }
00009
00010 CTrapKeyComboBox::~CTrapKeyComboBox(void)
00011 {
00012 }
00013
00014 BOOL CTrapKeyComboBox::PreTranslateMessage(MSG* pMsg)
00015 {
00016
00017         if (pMsg->message == WM_KEYDOWN)
00018         {
00019                 int nVirtKey = (int) pMsg->wParam;
00020                 if (nVirtKey == VK_RETURN) {
00021                         //AfxMessageBox("Return");
00022                         isEnterKey = true;
00023                 }
00024         }
00025         if (pMsg->message == WM_LBUTTONDOWN)
00026         {
00027                 //AfxMessageBox("Left Mouse Up");
00028                 isLButton = true;
00029         }
00030         return CComboBox::PreTranslateMessage(pMsg);
00031 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyComboBox.h Source File

Controls/TrapKeyComboBox.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "afxwin.h"
00003
00004 // this class inheritance is as follows
00005 // CObject->CCmdTarget->CWin->CComboBox->CTrapKeyComboBox
00006
00007 //to use:
00008 //1. create a dialog witha CDialog object compatible class
00009 //2. create a CComboBox type ComboBox on the dialog page
00010 //3. add a control variable for the ComboBox box
00011 //4. rename the control variable class type to this class
00012
00013 class CTrapKeyComboBox :
00014         public CComboBox
00015 {
00016 public:
00017         CTrapKeyComboBox(void);
00018     virtual ~CTrapKeyComboBox();
00019         bool isEnterKey;
00020         bool isLButton;
00021         virtual BOOL PreTranslateMessage(MSG* pMsg);
00022 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyEdit.cpp Source File

Controls/TrapKeyEdit.cpp
Go to the documentation of this file.
00001 #include "stdafx.h"
00002 #include ".\trapkeyedit.h"
00003
00004 CTrapKeyEdit::CTrapKeyEdit(void)
00005 {
00006         isEnterKey = false;
00007         isLButton = false;
00008         m_bFocusFlag = false;
00009         //isNumber = false;
00010 }
00011
00012 CTrapKeyEdit::~CTrapKeyEdit(void)
00013 {
00014 }
00015
00016 BEGIN_MESSAGE_MAP(CTrapKeyEdit, CEdit)
00017     ON_WM_GETDLGCODE()
00018     ON_WM_KEYUP()
00019         ON_WM_LBUTTONUP()
00020         ON_CONTROL_REFLECT(EN_KILLFOCUS, OnKillfocus)
00021 END_MESSAGE_MAP()
00022
00023 UINT CTrapKeyEdit::OnGetDlgCode()
00024 {
00025     return DLGC_WANTARROWS|DLGC_WANTALLKEYS|DLGC_WANTCHARS;
00026 }
00027
00028 void CTrapKeyEdit::DispatchEventEN_CHANGE() {
00029         HWND parent = GetParent()->m_hWnd;
00030         int ctrl = GetDlgCtrlID();
00031         ::SendMessage(
00032                 parent,
00033                 WM_COMMAND,
00034                 MAKEWPARAM(ctrl, EN_CHANGE),
00035                 (LPARAM) m_hWnd);
00036 }
00037
00038 // process/detect keystrokes, dispatch events to alert base class
00039 void CTrapKeyEdit::OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags)
00040 {
00041         //UINT nCharNew;
00042     //Check if the key pressed was a DOWN ARROW key
00043         //if (nChar == VK_LBUTTON)      //    AfxMessageBox("It is a left button press!");
00044     //if (nChar == VK_DOWN)             //    AfxMessageBox("It is a down arrow key!");
00045     //if (nChar == VK_RIGHT)    //    AfxMessageBox("It is a right arrow key!");
00046     //if (nChar == VK_LEFT)             //    AfxMessageBox("It is a left arrow key!");
00047     //if (nChar == VK_UP)               //    AfxMessageBox("It is a up arrow key!");
00048         if (nChar == VK_RETURN)         //        AfxMessageBox("It is a enter key!");
00049         {
00050                 isEnterKey = true;
00051                 DispatchEventEN_CHANGE();
00052                 //nCharNew = VK_TAB;
00053                 //        AfxMessageBox("It is a enter key!");
00054         }
00055
00056         //if ((nChar >= '0') && (nChar <= '9'))
00057         //{
00058         //      isNumber = true;
00059         //      DispatchEventEN_CHANGE();
00060         //}
00061         CEdit::OnKeyUp(nChar, nRepCnt, nFlags);         // pass on the info to the base class
00062 }
00063
00064 void CTrapKeyEdit::OnLButtonUp(UINT nFlags, CPoint point)
00065 {
00066         CEdit::OnLButtonUp(nFlags, point);
00067
00068         int nStartChar, nEndChar;
00069         if (!m_bFocusFlag) {
00070                 GetSel(nStartChar, nEndChar);
00071                 SetSel(nStartChar, nEndChar);
00072         }
00073         m_bFocusFlag = true;
00074         if (!isLButton && GetModify()) {
00075                 isLButton = true;
00076                 DispatchEventEN_CHANGE();
00077         }
00078         //AfxMessageBox("It is a left button press!");
00079 }
00080
00081 void CTrapKeyEdit::OnKillfocus()
00082 {
00083         m_bFocusFlag = false;
00084 }
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/TrapKeyEdit.h Source File

Controls/TrapKeyEdit.h
Go to the documentation of this file.
00001 #pragma once
00002 #include "afxwin.h"
00003
00004 // this class inheritance is as follows
00005 // CObject->CCmdTarget->CWin->CEdit->CTrapKeyEdit
00006
00007 //to use:
00008 //1. create a dialog witha CDialog object compatible class
00009 //2. create a CEdit type text edit box on the dialog page
00010 //3. add a control variable for the edit box
00011 //4. rename the control variable class type to this class
00012
00013 class CTrapKeyEdit :
00014         public CEdit
00015 {
00016 public:
00017         CTrapKeyEdit(void);
00018         //~CTrapKeyEdit(void);
00019     virtual ~CTrapKeyEdit();
00020         void DispatchEventEN_CHANGE();
00021         bool isEnterKey;
00022         bool isLButton;
00023         //bool isNumber;
00024         bool m_bFocusFlag;
00025         //bool m_b;
00026
00027 protected:
00028     afx_msg UINT OnGetDlgCode();
00029     afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
00030         afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
00031         afx_msg void OnKillfocus();
00032     DECLARE_MESSAGE_MAP()
00033 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/TuneSlowThreshold.cpp Source File

Config/TuneSlowThreshold.cpp
Go to the documentation of this file.
00001
00002 //vcDP5 SDK
00003 #include "stdafx.h"
00004 #include ".\tuneslowthreshold.h"
00005 #include "DppSlowThreshold.h"
00006 #include "SCommon.h"
00007 #include "UserMsgs.h"
00008
00009 CTuneSlowThreshold::CTuneSlowThreshold(void)
00010 {
00011 }
00012
00013 CTuneSlowThreshold::~CTuneSlowThreshold(void)
00014 {
00015 }
00016
00017 void CTuneSlowThreshold::GetSpectrumData(double * dblMCAData, long * lngMCAData, int mcaCH)
00018 {
00019         for (int chan=0; chan < mcaCH; chan++)
00020                 dblMCAData[chan] = lngMCAData[chan];
00021 }
00022
00023 void CTuneSlowThreshold::SetSlowThreshToChPos(int ChPosIn, int mcaCH)
00024 {
00025         CDppSlowThreshold SlowThreshNew;
00026         CString strChPos;
00027         int ChPos;
00028         double FSReal;
00029
00030         ChPos = ChPosIn;
00031         if (ChPos == 0) ChPos = 1;
00032         SlowThreshNew.SetGain(mcaCH);
00033         SlowThreshNew.GetSlowThresholdSettingFromChannels((double)ChPos);
00034         s.DppConfig.SlowChThreshold = SlowThreshNew.GetSlowChThreshold();
00035         FSReal = (double)s.DppConfig.SlowChThreshold / 1024.0;
00036         s.DppConfig.SlowThresholdPct = FSReal;
00037         if (s.isDppConnected) {
00038                 s.HwCfgDP5Out.Format("THSL=%.2f;",(FSReal * 100.0));
00039                 s.HwCfgReady = TRUE;
00040                 ::PostMessage(s.hWnd_Main,WM_USER_SEND_CONFIG_TO_HW,0L,0L);
00041         }
00042 }
00043
00044 int CTuneSlowThreshold::GetSlowThreshCalStart(double * SpectrumBuffer, double UpperChMax, int mcaCH)
00045 {
00046         int MinValidChan = 40;
00047         int MaxValidChan = 245;
00048         int LastSlwCh = (int)(mcaCH * 0.24);
00049         int StartCh = LastSlwCh;
00050         CString strStatus;
00051
00052         //DisplaySpecBuf25(SpectrumBuffer);
00053         for (int i = LastSlwCh; i >= 0; i--) {
00054                 if (SpectrumBuffer[i] <= UpperChMax) {
00055                         if (i < StartCh) StartCh = i;
00056                         strStatus.Format(" Finding Slow Threshold Test Channel %d ...", i);
00057                 } else {
00058                         break;
00059                 }
00060         }
00061         if ((StartCh > 1) && (StartCh < LastSlwCh - 1)) StartCh++;      // remove the last (bad) ch
00062         // try to tweak 3x if really bad
00063         if ((SpectrumBuffer[StartCh] > UpperChMax) && (StartCh < LastSlwCh - 1)) {
00064                 StartCh++;
00065         }
00066         if ((SpectrumBuffer[StartCh] > UpperChMax) && (StartCh < LastSlwCh - 1)) {
00067                 StartCh++;
00068         }
00069         if ((SpectrumBuffer[StartCh] > UpperChMax) && (StartCh < LastSlwCh - 1)) {
00070                 StartCh++;
00071         }
00072         MinValidChan = GetSlowThreshChStrFromVal(6, mcaCH);
00073         if (StartCh < MinValidChan) {   // set to >= 0.5% FS if no slow thresh needed
00074                 StartCh = MinValidChan;
00075         }
00076         MaxValidChan = GetSlowThreshChStrFromVal(245, mcaCH);
00077         if (StartCh > MaxValidChan) {   // set to >= 24.02% FS if no slow thresh needed
00078                 StartCh = MaxValidChan;
00079                 AfxMessageBox("Slow threshold value too high. \n Please check your settings.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
00080         }
00081         return StartCh;
00082 }
00083
00084 double CTuneSlowThreshold::GetUpperChCounts(double * SpectrumBuffer, int mcaCH)
00085 {
00086         int LastSlwCh = (int)(mcaCH * 0.24);
00087         double ChCounts = 0;
00088         double CurChCount = 0;
00089         for (int i = LastSlwCh; i < mcaCH; i++) {
00090                 CurChCount = SpectrumBuffer[i];
00091                 if (CurChCount > 0) {
00092                         ChCounts += CurChCount;
00093                 }
00094         }
00095         return ChCounts;
00096 }
00097
00098 double CTuneSlowThreshold::GetUpperChMax(double * SpectrumBuffer, int mcaCH)
00099 {
00100         int LastSlwCh = (int)(mcaCH * 0.24);
00101         double ChCount = 0;
00102         double CurChCount = 0;
00103         for (int i = LastSlwCh; i < mcaCH; i++) {
00104                 CurChCount = SpectrumBuffer[i];
00105                 if (CurChCount > ChCount) ChCount = CurChCount;
00106         }
00107         return ChCount;
00108 }
00109
00110 void CTuneSlowThreshold::DelayTask(DWORD d)
00111 {
00112     MSG msg;
00113     d += GetCurrentTime();
00114     while (GetCurrentTime() < d)
00115     {
00116                 if (PeekMessage(&msg, NULL, NULL, NULL, PM_REMOVE))
00117                 {
00118                 TranslateMessage(&msg);
00119                 DispatchMessage(&msg);
00120                 }
00121         }
00122 }
00123
00124 int CTuneSlowThreshold::UpdatePlotCursorPosFromIntChPos(int CurCh, double dblPixPerChan)
00125 {
00126         double dblPixPos;
00127         double dblChanPerPix;
00128         if (dblPixPerChan > 0.0) {
00129                 dblChanPerPix = 1.0 / dblPixPerChan;
00130                 dblPixPos = (double)CurCh * dblChanPerPix;
00131                 int dpos = (int)dblPixPos;
00132         return dpos;    } else {
00133                 return CurCh;
00134         }
00135 }
00136
00137 void CTuneSlowThreshold::DisplaySpecBuf25(double * SpectrumBuffer)
00138 {
00139         CString strBuffer("");
00140         CString strChan("");
00141         for (int i=0;i<25;i++) {
00142                 strChan.Format("%f\n",SpectrumBuffer[i]);
00143                 strBuffer += strChan;
00144         }
00145         AfxMessageBox(strBuffer);
00146 }
00147
00151 int CTuneSlowThreshold::GetSlowThreshChStrFromVal(unsigned char byteSlowThres, int mcaCH)
00152 {
00153         long intSlowThresh;
00154         double GainChannels;
00155         GainChannels = (double)mcaCH;
00156         intSlowThresh = (int)(((double)byteSlowThres * GainChannels / 1024.0) + 0.5);
00157         return intSlowThresh;
00158 }
00159
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Config/TuneSlowThreshold.h Source File

Config/TuneSlowThreshold.h
Go to the documentation of this file.
00001 #pragma once
00002
00003 //vcDP5 SDK
00004
00005 #include "afxcmn.h"
00006 #include "afxwin.h"
00007 #include "resource.h"
00008
00009 class CTuneSlowThreshold
00010 {
00011 public:
00012         CTuneSlowThreshold(void);
00013         ~CTuneSlowThreshold(void);
00014         void SetSlowThreshToChPos(int ChPosIn, int mcaCH);
00015         void DelayTask(DWORD d);
00016         int GetSlowThreshCalStart(double * SpectrumBuffer, double UpperChMax, int mcaCH);
00017         double GetUpperChCounts(double * SpectrumBuffer, int mcaCH);
00018         double GetUpperChMax(double * SpectrumBuffer, int mcaCH);
00019         void GetSpectrumData(double * dblMCAData, long * lngMCAData, int mcaCH);
00020         int UpdatePlotCursorPosFromIntChPos(int CurCh, double dblPixPerChan);
00021         void DisplaySpecBuf25(double * SpectrumBuffer);
00022         int GetSlowThreshChStrFromVal(unsigned char byteSlowThres, int mcaCH);
00023 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: UserMsgs.h Source File

UserMsgs.h
Go to the documentation of this file.
00001 #ifndef __FPUSERMSGS_H__
00002 #define __FPUSERMSGS_H__
00003
00004 #define WM_USER_PMCA_REQUEST_PARAMETER          (WM_USER + 256)
00005 #define WM_USER_FPGUI_REQUEST_PARAMETER         (WM_USER + 257)
00006
00007 #define WM_USER_LOAD_FILE                                       (WM_USER + 300)
00008 #define WM_USER_UPDATE_STATUS_BAR                       (WM_USER + 301)
00009 #define WM_USER_UPDATE_MENU                                     (WM_USER + 302)
00010 #define WM_USER_SHOW_SPECTRA_LIST_DLG           (WM_USER + 303)
00011
00012 //#define WM_USER_USB_CONNECT                                   (WM_USER + 304)
00013 #define WM_USER_SEND_CONFIG_TO_HW                       (WM_USER + 305)
00014 #define WM_USER_REPEAT_MEASUREMENT                      (WM_USER + 306)
00015 #define WM_USER_READ_DPP_CONFIG                         (WM_USER + 307)
00016 //#define WM_USER_DISPLAY_SCOPE_DIALOG      (WM_USER + 308)
00017 #define WM_USER_SAVE_CONFIG_TO_FILE             (WM_USER + 309)
00018 //#define WM_USER_RESTART_DLG_WITH_NEW_CONFIG   (WM_USER + 310)
00019 //#define WM_USER_RESTART_DLG_WITH_NEWCONFIG2 (WM_USER + 311)
00020 #define WM_USER_COARSE_AUTO_INPUT_OFFSET        (WM_USER + 312)
00021 #define WM_USER_FINE_AUTO_INPUT_OFFSET      (WM_USER + 313)
00022 #define WM_USER_DPP_AUTO_FAST_THESHOLD      (WM_USER + 314)
00023 #define WM_USER_DPP_AUTO_SLOW_THESHOLD      (WM_USER + 315)
00024 #define WM_USER_SHOW_CONNECT_DIALOG                     (WM_USER + 316)
00025 #define WM_USER_READ_SCA_CONFIG                         (WM_USER + 317)
00026 #define WM_USER_READ_DPP_CONFIG_EX                      (WM_USER + 319)
00027
00028 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WINUSB.H Source File

DeviceIO/WINUSB.H
Go to the documentation of this file.
00001 /*++
00002
00003 Copyright (c) 2002 Microsoft Corporation
00004
00005 Module Name:
00006
00007         wusb.h
00008
00009 Abstract:
00010
00011         Public interface to winusb.dll
00012
00013 Environment:
00014
00015         Kernel Mode Only
00016
00017 Notes:
00018
00019         THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY
00020         KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00021         IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR
00022         PURPOSE.
00023
00024         Copyright (c) 2001 Microsoft Corporation.  All Rights Reserved.
00025
00026
00027 Revision History:
00028
00029         11/19/2002 : created
00030
00031 Authors:
00032
00033 --*/
00034
00035 #ifndef __WUSB_H__
00036 #define __WUSB_H__
00037
00038 #ifdef __cplusplus
00039 extern "C" {
00040 #endif
00041
00042 #include "winusbio.h"
00043
00044
00045 typedef PVOID WINUSB_INTERFACE_HANDLE, *PWINUSB_INTERFACE_HANDLE;
00046
00047
00048 #pragma pack(1)
00049
00050 typedef struct _WINUSB_SETUP_PACKET {
00051     UCHAR   RequestType;
00052     UCHAR   Request;
00053     USHORT  Value;
00054     USHORT  Index;
00055     USHORT  Length;
00056 } WINUSB_SETUP_PACKET, *PWINUSB_SETUP_PACKET;
00057
00058 #pragma pack()
00059
00060
00061
00062 BOOL __stdcall
00063 WinUsb_Initialize(
00064     IN HANDLE DeviceHandle,
00065     OUT PWINUSB_INTERFACE_HANDLE InterfaceHandle
00066     );
00067
00068
00069 BOOL __stdcall
00070 WinUsb_Free(
00071     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle
00072     );
00073
00074
00075 BOOL __stdcall
00076 WinUsb_GetAssociatedInterface(
00077     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00078     IN UCHAR AssociatedInterfaceIndex,
00079     OUT PWINUSB_INTERFACE_HANDLE AssociatedInterfaceHandle
00080     );
00081
00082
00083
00084 BOOL __stdcall
00085 WinUsb_GetDescriptor(
00086     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00087     IN  UCHAR DescriptorType,
00088     IN  UCHAR Index,
00089     IN  USHORT LanguageID,
00090     OUT PUCHAR Buffer,
00091     IN  ULONG BufferLength,
00092     OUT PULONG LengthTransferred
00093     );
00094
00095 BOOL __stdcall
00096 WinUsb_QueryInterfaceSettings(
00097     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00098     IN UCHAR AlternateInterfaceNumber,
00099     OUT PUSB_INTERFACE_DESCRIPTOR UsbAltInterfaceDescriptor
00100     );
00101
00102 BOOL __stdcall
00103 WinUsb_QueryDeviceInformation(
00104     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00105     IN ULONG InformationType,
00106     IN OUT PULONG BufferLength,
00107     OUT PVOID Buffer
00108     );
00109
00110 BOOL __stdcall
00111 WinUsb_SetCurrentAlternateSetting(
00112     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00113     IN  UCHAR SettingNumber
00114     );
00115
00116 BOOL __stdcall
00117 WinUsb_GetCurrentAlternateSetting(
00118     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00119     OUT PUCHAR SettingNumber
00120     );
00121
00122
00123 BOOL __stdcall
00124 WinUsb_QueryPipe(
00125     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00126     IN  UCHAR AlternateInterfaceNumber,
00127     IN  UCHAR PipeIndex,
00128     OUT PWINUSB_PIPE_INFORMATION PipeInformation
00129     );
00130
00131
00132 BOOL __stdcall
00133 WinUsb_SetPipePolicy(
00134     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00135     IN  UCHAR PipeID,
00136     IN  ULONG PolicyType,
00137     IN  ULONG ValueLength,
00138     IN  PVOID Value
00139     );
00140
00141 BOOL __stdcall
00142 WinUsb_GetPipePolicy(
00143     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00144     IN UCHAR PipeID,
00145     IN ULONG PolicyType,
00146     IN OUT PULONG ValueLength,
00147     OUT PVOID Value
00148     );
00149
00150 BOOL __stdcall
00151 WinUsb_ReadPipe(
00152     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00153     IN  UCHAR PipeID,
00154     IN  PUCHAR Buffer,
00155     IN  ULONG BufferLength,
00156     OUT PULONG LengthTransferred,
00157     IN  LPOVERLAPPED Overlapped
00158     );
00159
00160 BOOL __stdcall
00161 WinUsb_WritePipe(
00162     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00163     IN  UCHAR PipeID,
00164     IN  PUCHAR Buffer,
00165     IN  ULONG BufferLength,
00166     OUT PULONG LengthTransferred,
00167     IN  LPOVERLAPPED Overlapped
00168     );
00169
00170 BOOL __stdcall
00171 WinUsb_ControlTransfer(
00172     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00173     IN  WINUSB_SETUP_PACKET SetupPacket,
00174     IN  PUCHAR Buffer,
00175     IN  ULONG BufferLength,
00176     OUT PULONG LengthTransferred,
00177     IN  LPOVERLAPPED Overlapped
00178     );
00179
00180 BOOL __stdcall
00181 WinUsb_ResetPipe(
00182     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00183     IN  UCHAR PipeID
00184     );
00185
00186 BOOL __stdcall
00187 WinUsb_AbortPipe(
00188     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00189     IN  UCHAR PipeID
00190     );
00191
00192 BOOL __stdcall
00193 WinUsb_FlushPipe(
00194     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00195     IN  UCHAR PipeID
00196     );
00197
00198 BOOL __stdcall
00199 WinUsb_SetPowerPolicy(
00200     IN  WINUSB_INTERFACE_HANDLE InterfaceHandle,
00201     IN  ULONG PolicyType,
00202     IN  ULONG ValueLength,
00203     IN  PVOID Value
00204     );
00205
00206 BOOL __stdcall
00207 WinUsb_GetPowerPolicy(
00208     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00209     IN ULONG PolicyType,
00210     IN OUT PULONG ValueLength,
00211     OUT PVOID Value
00212     );
00213
00214 BOOL __stdcall
00215 WinUsb_GetOverlappedResult(
00216     IN WINUSB_INTERFACE_HANDLE InterfaceHandle,
00217     IN LPOVERLAPPED lpOverlapped,
00218     OUT LPDWORD lpNumberOfBytesTransferred,
00219     BOOL bWait
00220     );
00221
00222
00223 PUSB_INTERFACE_DESCRIPTOR __stdcall
00224 WinUsb_ParseConfigurationDescriptor(
00225     IN PUSB_CONFIGURATION_DESCRIPTOR ConfigurationDescriptor,
00226     IN PVOID StartPosition,
00227     IN LONG InterfaceNumber,
00228     IN LONG AlternateSetting,
00229     IN LONG InterfaceClass,
00230     IN LONG InterfaceSubClass,
00231     IN LONG InterfaceProtocol
00232     );
00233
00234 PUSB_COMMON_DESCRIPTOR __stdcall
00235 WinUsb_ParseDescriptors(
00236     IN PVOID    DescriptorBuffer,
00237     IN ULONG    TotalLength,
00238     IN PVOID    StartPosition,
00239     IN LONG     DescriptorType
00240     );
00241
00242
00243 #ifdef __cplusplus
00244 }
00245 #endif
00246
00247
00248 #endif //__WUSB_H__
00249
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WINUSBIO.H Source File

DeviceIO/WINUSBIO.H
Go to the documentation of this file.
00001 /***************************************************************************
00002
00003 Copyright (c) 2002 Microsoft Corporation
00004
00005 Module Name:
00006
00007         wusbio.h
00008
00009 Abstract:
00010
00011         Public header for WINUSB
00012
00013 Environment:
00014
00015         User and Kernel Mode
00016
00017 Notes:
00018
00019         THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY
00020         KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00021         IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A PARTICULAR
00022         PURPOSE.
00023
00024         Copyright (c) 2001 Microsoft Corporation.  All Rights Reserved.
00025
00026
00027 Revision History:
00028
00029         11/12/2002 : created
00030
00031
00032 ****************************************************************************/
00033
00034 #ifndef __WUSBIO_H__
00035 #define __WUSBIO_H__
00036
00037 #include "usb.h"
00038
00039 // Pipe policy types
00040 #define SHORT_PACKET_TERMINATE  0x01
00041 #define AUTO_CLEAR_STALL        0x02
00042 #define PIPE_TRANSFER_TIMEOUT   0x03
00043 #define IGNORE_SHORT_PACKETS    0x04
00044 #define ALLOW_PARTIAL_READS     0x05
00045 #define AUTO_FLUSH              0x06
00046 #define RAW_IO                  0x07
00047 #define MAXIMUM_TRANSFER_SIZE   0x08
00048
00049 // Power policy types
00050 //
00051 // Add 0x80 for Power policy types in order to prevent overlap with
00052 // Pipe policy types to prevent "accidentally" setting the wrong value for the
00053 // wrong type.
00054 //
00055 #define AUTO_SUSPEND            0x81
00056 #define SUSPEND_DELAY           0x83
00057
00058 // Device Information types
00059 #define DEVICE_SPEED            0x01
00060
00061 // Device Speeds
00062 #define LowSpeed                0x01
00063 #define FullSpeed               0x02
00064 #define HighSpeed               0x03
00065
00066 // {DA812BFF-12C3-46a2-8E2B-DBD3B7834C43}
00067 #include <initguid.h>
00068 DEFINE_GUID(WinUSB_TestGuid, 0xda812bff, 0x12c3, 0x46a2, 0x8e, 0x2b, 0xdb, 0xd3, 0xb7, 0x83, 0x4c, 0x43);
00069
00070
00071 typedef struct _WINUSB_PIPE_INFORMATION {
00072     USBD_PIPE_TYPE  PipeType;
00073     UCHAR           PipeId;
00074     USHORT          MaximumPacketSize;
00075     UCHAR           Interval;
00076 } WINUSB_PIPE_INFORMATION, *PWINUSB_PIPE_INFORMATION;
00077
00078 #endif // __WUSBIO_H__
00079
00080
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlg.cpp Source File

waitdlg/WaitDlg.cpp
Go to the documentation of this file.
00001 // WaitDlg.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "WaitDialog.h"
00006 #include "WaitDlg.h"
00007 #include "resource.h"
00008
00009 //#ifdef _DEBUG
00010 //#define new DEBUG_NEW
00011 //#undef THIS_FILE
00012 //static char THIS_FILE[] = __FILE__;
00013 //#endif
00014
00016 // cWaitDlg dialog
00017
00018
00019 cWaitDlg::cWaitDlg(CWnd* pParent /*=NULL*/)
00020         : CDialog(cWaitDlg::IDD, pParent)
00021 {
00022         //{{AFX_DATA_INIT(cWaitDlg)
00023                 // NOTE: the ClassWizard will add member initialization here
00024         //}}AFX_DATA_INIT
00025    m_Text = "";
00026    m_bShowCancelButton = false;
00027 }
00028
00029
00030 void cWaitDlg::DoDataExchange(CDataExchange* pDX)
00031 {
00032         CDialog::DoDataExchange(pDX);
00033         //{{AFX_DATA_MAP(cWaitDlg)
00034                 // NOTE: the ClassWizard will add DDX and DDV calls here
00035         //}}AFX_DATA_MAP
00036 }
00037
00038
00039 BEGIN_MESSAGE_MAP(cWaitDlg, CDialog)
00040         //{{AFX_MSG_MAP(cWaitDlg)
00041         ON_WM_TIMER()
00042         //}}AFX_MSG_MAP
00043 END_MESSAGE_MAP()
00044
00046 // cWaitDlg message handlers
00047 void cWaitDlg::OnCancel()
00048 {
00049    //Override this so the user cannot cancel by hiting ESC
00050    return;
00051 }
00052
00053 void cWaitDlg::OnOK()
00054 {
00055    //Ignore this unless the button is visible
00056    if (m_bShowCancelButton)
00057       {
00058            m_Thread->m_Event->SetEvent();
00059            CDialog::OnOK();
00060       }
00061 }
00062
00063 BOOL cWaitDlg::OnInitDialog()
00064 {
00065         CDialog::OnInitDialog();
00066
00067    if (m_Text.GetLength() > 0)
00068       GetDlgItem(IDC_BUSY_TEXT)->SetWindowText(m_Text);
00069
00070    GetDlgItem(IDOK)->ShowWindow(m_bShowCancelButton ? SW_SHOW : SW_HIDE);
00071
00072    CRect rect;
00073    GetDlgItem(IDC_BUSY_PIC)->GetWindowRect(rect);
00074    ScreenToClient(&rect);
00075
00076    m_Anim.Create(WS_VISIBLE|WS_CHILD, rect, this, IDC_BUSY_PIC);
00077    m_Anim.SetImageList(IDB_SPECTRUM_ANIM, 70, 56, RGB(255,0,255));
00078    m_Anim.StartAnim(250);
00079
00080         //SetTimer(1,500,NULL);
00081         SetTimer(1,250,NULL);
00082         return TRUE;  // return TRUE unless you set the focus to a control
00083                       // EXCEPTION: OCX Property Pages should return FALSE
00084 }
00085
00086 void cWaitDlg::OnTimer(UINT nIDEvent)
00087 {
00088         CSingleLock lock(m_Thread->m_Event, FALSE);
00089
00090    if (lock.Lock(0))
00091       {
00092       CDialog::OnOK();
00093       }
00094
00095         //CDialog::OnTimer(nIDEvent);
00096 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlg.h Source File

waitdlg/WaitDlg.h
Go to the documentation of this file.
00001 #if !defined(AFX_WAITDLG_H__55050813_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
00002 #define AFX_WAITDLG_H__55050813_F8E6_11D2_837D_00500406DAEB__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // WaitDlg.h : header file
00008 //
00009 #include <afxmt.h>
00010
00011 #include "WaitDlgThread.h"
00012 #include "AnimWnd.h"
00013 #include "resource.h"
00014
00016 // cWaitDlg dialog
00017
00018 class cWaitDlg : public CDialog
00019 {
00020 // Construction
00021 public:
00022         cWaitDlg(CWnd* pParent = NULL);   // standard constructor
00023
00024 // Dialog Data
00025         //{{AFX_DATA(cWaitDlg)
00026         enum { IDD = IDD_BUSY_DLG };
00027                 // NOTE: the ClassWizard will add data members here
00028         //}}AFX_DATA
00029    cWaitDlgThread       *m_Thread;
00030    cAnimWnd                m_Anim;
00031    CString        m_Text;
00032    bool           m_bShowCancelButton;
00033
00034 // Overrides
00035         // ClassWizard generated virtual function overrides
00036         //{{AFX_VIRTUAL(cWaitDlg)
00037         protected:
00038         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00039         //}}AFX_VIRTUAL
00040
00041 // Implementation
00042 protected:
00043
00044         virtual void OnCancel();
00045         // Generated message map functions
00046         //{{AFX_MSG(cWaitDlg)
00047         virtual void OnOK();
00048         virtual BOOL OnInitDialog();
00049         afx_msg void OnTimer(UINT nIDEvent);
00050         //}}AFX_MSG
00051         DECLARE_MESSAGE_MAP()
00052 };
00053
00054 //{{AFX_INSERT_LOCATION}}
00055 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00056
00057 #endif // !defined(AFX_WAITDLG_H__55050813_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlgThread.cpp Source File

waitdlg/WaitDlgThread.cpp
Go to the documentation of this file.
00001 // WaitDlgThread.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 //#include "WaitDialog.h"
00006 #include "WaitDlgThread.h"
00007 #include "WaitDlg.h"
00008
00009
00010 //#ifdef _DEBUG
00011 //#define new DEBUG_NEW
00012 //#undef THIS_FILE
00013 //static char THIS_FILE[] = __FILE__;
00014 //#endif
00015
00017 // cWaitDlgThread
00018
00019 IMPLEMENT_DYNCREATE(cWaitDlgThread, CWinThread)
00020
00021 cWaitDlgThread::cWaitDlgThread()
00022 {
00023    m_bShowCancelButton = false;
00024    m_Text = "";
00025 }
00026
00027 cWaitDlgThread::~cWaitDlgThread()
00028 {
00029 }
00030
00031 BOOL cWaitDlgThread::InitInstance()
00032 {
00033         // TODO:  perform and per-thread initialization here
00034    cWaitDlg dlg;
00035
00036    m_pMainWnd = &dlg;
00037    m_Event = new CEvent(FALSE, TRUE, m_Eventname);
00038    dlg.m_bShowCancelButton = m_bShowCancelButton;
00039    dlg.m_Text = m_Text;
00040    dlg.m_Thread = this;
00041    dlg.DoModal();
00042    delete m_Event;
00043
00044    return FALSE;
00045 }
00046
00047 int cWaitDlgThread::ExitInstance()
00048 {
00049         // TODO:  perform any per-thread cleanup here
00050   return CWinThread::ExitInstance();
00051 }
00052
00053 BEGIN_MESSAGE_MAP(cWaitDlgThread, CWinThread)
00054         //{{AFX_MSG_MAP(cWaitDlgThread)
00055                 // NOTE - the ClassWizard will add and remove mapping macros here.
00056         //}}AFX_MSG_MAP
00057 END_MESSAGE_MAP()
00058
00060 // cWaitDlgThread message handlers
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/WaitDlgThread.h Source File

waitdlg/WaitDlgThread.h
Go to the documentation of this file.
00001 #if !defined(AFX_WAITDLGTHREAD_H__55050812_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
00002 #define AFX_WAITDLGTHREAD_H__55050812_F8E6_11D2_837D_00500406DAEB__INCLUDED_
00003
00004 #if _MSC_VER >= 1000
00005 #pragma once
00006 #endif // _MSC_VER >= 1000
00007 // WaitDlgThread.h : header file
00008 //
00010 // Author: Todd Andrews
00011 // Email:  tmandrews@mindspring.com
00012 // Copyright 1999, Todd Andrews
00013 //
00014 // You may freely use or modify this code provided this
00015 // Copyright is included in all derived versions.
00016 //
00017 //
00018 // This class implements a worker thread
00019
00020 #include <afxmt.h>
00021
00023 // WaitDlgThread thread
00024
00025 class cWaitDlgThread : public CWinThread
00026 {
00027         DECLARE_DYNCREATE(cWaitDlgThread)
00028
00029 public:
00030    cWaitDlgThread();           // protected constructor used by dynamic creation
00031
00032 protected:
00033 // Attributes
00034
00035 public:
00036    CString  m_Eventname;
00037    CEvent   *m_Event;
00038    bool     m_bShowCancelButton;
00039    CString  m_Text;
00040
00041 // Operations
00042 public:
00043
00044 // Overrides
00045         // ClassWizard generated virtual function overrides
00046         //{{AFX_VIRTUAL(cWaitDlgThread)
00047         public:
00048         virtual BOOL InitInstance();
00049         virtual int ExitInstance();
00050         //}}AFX_VIRTUAL
00051
00052 // Implementation
00053 public:
00054         virtual ~cWaitDlgThread();
00055
00056 protected:
00057
00058         // Generated message map functions
00059         //{{AFX_MSG(cWaitDlgThread)
00060                 // NOTE - the ClassWizard will add and remove member functions here.
00061         //}}AFX_MSG
00062
00063         DECLARE_MESSAGE_MAP()
00064 };
00065
00067
00068 //{{AFX_INSERT_LOCATION}}
00069 // Microsoft Developer Studio will insert additional declarations immediately before the previous line.
00070
00071 #endif // !defined(AFX_WAITDLGTHREAD_H__55050812_F8E6_11D2_837D_00500406DAEB__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WinusbNotify.cpp Source File

DeviceIO/WinusbNotify.cpp
Go to the documentation of this file.
00001 #include "StdAfx.h"
00002 #include "WinusbNotify.h"
00003
00004 CWinusbNotify::CWinusbNotify(void)
00005 {
00006         m_hWndOwner = NULL;
00007         DeviceNotificationHandle = NULL;
00008 }
00009
00010 CWinusbNotify::~CWinusbNotify(void)
00011 {
00012 }
00013
00014 void CWinusbNotify::SetNotificationWindow(HWND m_hWnd)
00015 {
00016         m_hWndOwner = m_hWnd;
00017 }
00018
00019 void CWinusbNotify::InitDeviceInfo()
00020 {
00021         DeviceNotificationHandle = NULL;
00022 }
00023
00024 void CWinusbNotify::RegDeviceNotification()
00025 {
00026         DEV_BROADCAST_DEVICEINTERFACE DevBroadcastDeviceInterface;
00027         DevBroadcastDeviceInterface.dbcc_size = sizeof(DevBroadcastDeviceInterface);
00028         DevBroadcastDeviceInterface.dbcc_devicetype = DBT_DEVTYP_DEVICEINTERFACE;
00029         DevBroadcastDeviceInterface.dbcc_classguid = GUID_DP5_INTERFACE_CLASS;
00030         DeviceNotificationHandle = RegisterDeviceNotification(m_hWndOwner,
00031                                                                         &DevBroadcastDeviceInterface,
00032                                                                         DEVICE_NOTIFY_WINDOW_HANDLE);
00033 }
00034
00035 BOOL CWinusbNotify::GetDevNotifyInfo(DWORD_PTR dwData, char devicePath[])
00036 {
00037         CString DeviceNameString;
00038         //CString strDevicepath("%s", devicePath);
00039         PDEV_BROADCAST_HDR lDBH = (PDEV_BROADCAST_HDR)dwData;
00040         if (lDBH->dbch_devicetype == DBT_DEVTYP_DEVICEINTERFACE)
00041         {
00042                 PDEV_BROADCAST_DEVICEINTERFACE lDBDI = (PDEV_BROADCAST_DEVICEINTERFACE)dwData;
00043                 DeviceNameString = lDBDI->dbcc_name;
00044                 //AfxMessageBox(DeviceNameString);
00045                 if      ((DeviceNameString.CompareNoCase(devicePath)) == 0) {
00046                         //AfxMessageBox("The names match.");
00047                         return true;
00048                 } else {
00049                         //AfxMessageBox("It’s a different device.");
00050                         return false;
00051                 }
00052         }
00053         return false;
00054 }
00055
00056 void CWinusbNotify::RemoveDeviceNotification()
00057 {
00058         if (DeviceNotificationHandle != NULL) {
00059                 UnregisterDeviceNotification(DeviceNotificationHandle);
00060         }
00061 }
00062
00063 BOOL CWinusbNotify::UnregDeviceNotification(HDEVNOTIFY Handle)
00064 {
00065         return UnregisterDeviceNotification(Handle);
00066 }
00067
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/WinusbNotify.h Source File

DeviceIO/WinusbNotify.h
Go to the documentation of this file.
00001
00002 #pragma once
00003 #include "DppWinUSB.h"
00004
00005 class CWinusbNotify
00006 {
00007 public:
00008         CWinusbNotify(void);
00009         ~CWinusbNotify(void);
00010         HDEVNOTIFY DeviceNotificationHandle;
00011         void InitDeviceInfo();
00012         HWND m_hWndOwner;
00013         void SetNotificationWindow(HWND m_hWnd);
00014         void RegDeviceNotification();
00015         BOOL GetDevNotifyInfo(DWORD_PTR dwData, char devicePath[]);
00016         void RemoveDeviceNotification();
00017         BOOL UnregDeviceNotification(HDEVNOTIFY Handle);
00018
00019 };
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Controls/X11Color.h Source File

Controls/X11Color.h
Go to the documentation of this file.
00001 #ifndef __X11COLOR_H__INCLUDED_
00002 #define __X11COLOR_H__INCLUDED_
00003
00004 #pragma once
00005
00006 // X11Color.h : header file
00007
00008
00009 const COLORREF colorAliceBlue            = RGB(0xF0,0xF8,0xFF); //RGB(240,248,255)
00010 const COLORREF colorAmptekBlue           = RGB(0x7A,0xCE,0xFC); //RGB(122,206,252)
00011 const COLORREF colorAntiqueWhite         = RGB(0xFA,0xEB,0xD7); //RGB(250,235,215)
00012 const COLORREF colorAqua                 = RGB(0x00,0xFF,0xFF); //RGB(  0,255,255)
00013 const COLORREF colorAquamarine           = RGB(0x7F,0xFF,0xD4); //RGB(127,255,212)
00014 const COLORREF colorAzure                = RGB(0xF0,0xFF,0xFF); //RGB(240,255,255)
00015 const COLORREF colorBeige                = RGB(0xF5,0xF5,0xDC); //RGB(245,245,220)
00016 const COLORREF colorBisque               = RGB(0xFF,0xE4,0xC4); //RGB(255,228,196)
00017 const COLORREF colorBlack                = RGB(0x00,0x00,0x00); //RGB(  0,  0,  0)
00018 const COLORREF colorBlanchedAlmond       = RGB(0xFF,0xEB,0xCD); //RGB(255,235,205)
00019 const COLORREF colorBlue                 = RGB(0x00,0x00,0xFF); //RGB(  0,  0,255)
00020 const COLORREF colorBlueViolet           = RGB(0x8A,0x2B,0xE2); //RGB(138, 43,226)
00021 const COLORREF colorBrown                = RGB(0xA5,0x2A,0x2A); //RGB(165, 42, 42)
00022 const COLORREF colorBurlyWood            = RGB(0xDE,0xB8,0x87); //RGB(222,184,135)
00023 const COLORREF colorCadetBlue            = RGB(0x5F,0x9E,0xA0); //RGB( 95,158,160)
00024 const COLORREF colorChartreuse           = RGB(0x7F,0xFF,0x00); //RGB(127,255,  0)
00025 const COLORREF colorChocolate            = RGB(0xD2,0x69,0x1E); //RGB(210,105, 30)
00026 const COLORREF colorCoral                = RGB(0xFF,0x7F,0x50); //RGB(255,127, 80)
00027 const COLORREF colorCornflowerBlue       = RGB(0x64,0x95,0xED); //RGB(100,149,237)
00028 const COLORREF colorCornsilk             = RGB(0xFF,0xF8,0xDC); //RGB(255,248,220)
00029 const COLORREF colorCrimson              = RGB(0xDC,0x14,0x3C); //RGB(220, 20, 60)
00030 const COLORREF colorCyan                 = RGB(0x00,0xFF,0xFF); //RGB(  0,255,255)
00031 const COLORREF colorDarkBlue             = RGB(0x00,0x00,0x8B); //RGB(  0,  0,139)
00032 const COLORREF colorDarkCyan             = RGB(0x00,0x8B,0x8B); //RGB(  0,139,139)
00033 const COLORREF colorDarkGoldenrod        = RGB(0xB8,0x86,0x0B); //RGB(184,134, 11)
00034 const COLORREF colorDarkGray             = RGB(0xA9,0xA9,0xA9); //RGB(169,169,169)
00035 const COLORREF colorDarkGreen            = RGB(0x00,0x64,0x00); //RGB(  0,100,  0)
00036 const COLORREF colorDarkKhaki            = RGB(0xBD,0xB7,0x6B); //RGB(189,183,107)
00037 const COLORREF colorDarkMagenta          = RGB(0x8B,0x00,0x8B); //RGB(139,  0,139)
00038 const COLORREF colorDarkOliveGreen       = RGB(0x55,0x6B,0x2F); //RGB( 85,107, 47)
00039 const COLORREF colorDarkOrange           = RGB(0xFF,0x8C,0x00); //RGB(255,140,  0)
00040 const COLORREF colorDarkOrchid           = RGB(0x99,0x32,0xCC); //RGB(153, 50,204)
00041 const COLORREF colorDarkRed              = RGB(0x8B,0x00,0x00); //RGB(139,  0,  0)
00042 const COLORREF colorDarkSalmon           = RGB(0xE9,0x96,0x7A); //RGB(233,150,122)
00043 const COLORREF colorDarkSeaGreen         = RGB(0x8F,0xBC,0x8F); //RGB(143,188,143)
00044 const COLORREF colorDarkSlateBlue        = RGB(0x48,0x3D,0x8B); //RGB( 72, 61,139)
00045 const COLORREF colorDarkSlateGray        = RGB(0x2F,0x4F,0x4F); //RGB( 47, 79, 79)
00046 const COLORREF colorDarkTurquoise        = RGB(0x00,0xCE,0xD1); //RGB(  0,206,209)
00047 const COLORREF colorDarkViolet           = RGB(0x94,0x00,0xD3); //RGB(148,  0,211)
00048 const COLORREF colorDeepPink             = RGB(0xFF,0x14,0x93); //RGB(255, 20,147)
00049 const COLORREF colorDeepSkyBlue          = RGB(0x00,0xBF,0xFF); //RGB(  0,191,255)
00050 const COLORREF colorDimGray              = RGB(0x69,0x69,0x69); //RGB(105,105,105)
00051 const COLORREF colorDodgerBlue           = RGB(0x1E,0x90,0xFF); //RGB( 30,144,255)
00052 const COLORREF colorFireBrick            = RGB(0xB2,0x22,0x22); //RGB(178, 34, 34)
00053 const COLORREF colorFloralWhite          = RGB(0xFF,0xFA,0xF0); //RGB(255,250,240)
00054 const COLORREF colorForestGreen          = RGB(0x22,0x8B,0x22); //RGB( 34,139, 34)
00055 const COLORREF colorFuchsia              = RGB(0xFF,0x00,0xFF); //RGB(255,  0,255)
00056 const COLORREF colorGainsboro            = RGB(0xDC,0xDC,0xDC); //RGB(220,220,220)
00057 const COLORREF colorGhostWhite           = RGB(0xF8,0xF8,0xFF); //RGB(248,248,255)
00058 const COLORREF colorGold                 = RGB(0xFF,0xD7,0x00); //RGB(255,215,  0)
00059 const COLORREF colorGoldenrod            = RGB(0xDA,0xA5,0x20); //RGB(218,165, 32)
00060 const COLORREF colorGray                 = RGB(0x80,0x80,0x80); //RGB(128,128,128)
00061 const COLORREF colorGreen                = RGB(0x00,0x80,0x00); //RGB(  0,128,  0)
00062 const COLORREF colorGreenYellow          = RGB(0xAD,0xFF,0x2F); //RGB(173,255, 47)
00063 const COLORREF colorHoneydew             = RGB(0xF0,0xFF,0xF0); //RGB(240,255,240)
00064 const COLORREF colorHotPink              = RGB(0xFF,0x69,0xB4); //RGB(255,105,180)
00065 const COLORREF colorIndianRed            = RGB(0xCD,0x5C,0x5C); //RGB(205, 92, 92)
00066 const COLORREF colorIndigo               = RGB(0x4B,0x00,0x82); //RGB( 75,  0,130)
00067 const COLORREF colorIvory                = RGB(0xFF,0xFF,0xF0); //RGB(255,255,240)
00068 const COLORREF colorKhaki                = RGB(0xF0,0xE6,0x8C); //RGB(240,230,140)
00069 const COLORREF colorLavender             = RGB(0xE6,0xE6,0xFA); //RGB(230,230,250)
00070 const COLORREF colorLavenderBlush        = RGB(0xFF,0xF0,0xF5); //RGB(255,240,245)
00071 const COLORREF colorLawnGreen            = RGB(0x7C,0xFC,0x00); //RGB(124,252,  0)
00072 const COLORREF colorLemonChiffon         = RGB(0xFF,0xFA,0xCD); //RGB(255,250,205)
00073 const COLORREF colorLightBlue            = RGB(0xAD,0xD8,0xE6); //RGB(173,216,230)
00074 const COLORREF colorLightCoral           = RGB(0xF0,0x80,0x80); //RGB(240,128,128)
00075 const COLORREF colorLightCyan            = RGB(0xE0,0xFF,0xFF); //RGB(224,255,255)
00076 const COLORREF colorLightGoldenrodYellow = RGB(0xFA,0xFA,0xD2); //RGB(250,250,210)
00077 const COLORREF colorLightGray            = RGB(0xD3,0xD3,0xD3); //RGB(211,211,211)
00078 const COLORREF colorLightGreen           = RGB(0x90,0xEE,0x90); //RGB(144,238,144)
00079 const COLORREF colorLightGrey            = RGB(0xD3,0xD3,0xD3); //RGB(211,211,211)
00080 const COLORREF colorLightPink            = RGB(0xFF,0xB6,0xC1); //RGB(255,182,193)
00081 const COLORREF colorLightSalmon          = RGB(0xFF,0xA0,0x7A); //RGB(255,160,122)
00082 const COLORREF colorLightSeaGreen        = RGB(0x20,0xB2,0xAA); //RGB( 32,178,170)
00083 const COLORREF colorLightSkyBlue         = RGB(0x87,0xCE,0xFA); //RGB(135,206,250)
00084 const COLORREF colorLightSlateGray       = RGB(0x77,0x88,0x99); //RGB(119,136,153)
00085 const COLORREF colorLightSteelBlue       = RGB(0xB0,0xC4,0xDE); //RGB(176,196,222)
00086 const COLORREF colorLightYellow          = RGB(0xFF,0xFF,0xE0); //RGB(255,255,224)
00087 const COLORREF colorLime                 = RGB(0x00,0xFF,0x00); //RGB(  0,255,  0)
00088 const COLORREF colorLimeGreen            = RGB(0x32,0xCD,0x32); //RGB( 50,205, 50)
00089 const COLORREF colorLinen                = RGB(0xFA,0xF0,0xE6); //RGB(250,240,230)
00090 const COLORREF colorMagenta              = RGB(0xFF,0x00,0xFF); //RGB(255,  0,255)
00091 const COLORREF colorMaroon               = RGB(0x80,0x00,0x00); //RGB(128,  0,  0)
00092 const COLORREF colorMediumAquamarine     = RGB(0x66,0xCD,0xAA); //RGB(102,205,170)
00093 const COLORREF colorMediumBlue           = RGB(0x00,0x00,0xCD); //RGB(  0,  0,205)
00094 const COLORREF colorMediumOrchid         = RGB(0xBA,0x55,0xD3); //RGB(186, 85,211)
00095 const COLORREF colorMediumPurple         = RGB(0x93,0x70,0xDB); //RGB(147,112,219)
00096 const COLORREF colorMediumSeaGreen       = RGB(0x3C,0xB3,0x71); //RGB( 60,179,113)
00097 const COLORREF colorMediumSlateBlue      = RGB(0x7B,0x68,0xEE); //RGB(123,104,238)
00098 const COLORREF colorMediumSpringGreen    = RGB(0x00,0xFA,0x9A); //RGB(  0,250,154)
00099 const COLORREF colorMediumTurquoise      = RGB(0x48,0xD1,0xCC); //RGB( 72,209,204)
00100 const COLORREF colorMediumVioletRed      = RGB(0xC7,0x15,0x85); //RGB(199, 21,133)
00101 const COLORREF colorMidnightBlue         = RGB(0x19,0x19,0x70); //RGB( 25, 25,112)
00102 const COLORREF colorMintCream            = RGB(0xF5,0xFF,0xFA); //RGB(245,255,250)
00103 const COLORREF colorMistyRose            = RGB(0xFF,0xE4,0xE1); //RGB(255,228,225)
00104 const COLORREF colorMoccasin             = RGB(0xFF,0xE4,0xB5); //RGB(255,228,181)
00105 const COLORREF colorNavajoWhite          = RGB(0xFF,0xDE,0xAD); //RGB(255,222,173)
00106 const COLORREF colorNavy                 = RGB(0x00,0x00,0x80); //RGB(  0,  0,128)
00107 const COLORREF colorOldLace              = RGB(0xFD,0xF5,0xE6); //RGB(253,245,230)
00108 const COLORREF colorOlive                = RGB(0x80,0x80,0x00); //RGB(128,128,  0)
00109 const COLORREF colorOliveDrab            = RGB(0x6B,0x8E,0x23); //RGB(107,142, 35)
00110 const COLORREF colorOrange               = RGB(0xFF,0xA5,0x00); //RGB(255,165,  0)
00111 const COLORREF colorOrangeRed            = RGB(0xFF,0x45,0x00); //RGB(255, 69,  0)
00112 const COLORREF colorOrchid               = RGB(0xDA,0x70,0xD6); //RGB(218,112,214)
00113 const COLORREF colorPaleGoldenrod        = RGB(0xEE,0xE8,0xAA); //RGB(238,232,170)
00114 const COLORREF colorPaleGreen            = RGB(0x98,0xFB,0x98); //RGB(152,251,152)
00115 const COLORREF colorPaleTurquoise        = RGB(0xAF,0xEE,0xEE); //RGB(175,238,238)
00116 const COLORREF colorPaleVioletRed        = RGB(0xDB,0x70,0x93); //RGB(219,112,147)
00117 const COLORREF colorPapayaWhip           = RGB(0xFF,0xEF,0xD5); //RGB(255,239,213)
00118 const COLORREF colorPeachPuff            = RGB(0xFF,0xDA,0xB9); //RGB(255,218,185)
00119 const COLORREF colorPeru                 = RGB(0xCD,0x85,0x3F); //RGB(205,133, 63)
00120 const COLORREF colorPink                 = RGB(0xFF,0xC0,0xCB); //RGB(255,192,203)
00121 const COLORREF colorPlum                 = RGB(0xDD,0xA0,0xDD); //RGB(221,160,221)
00122 const COLORREF colorPowderBlue           = RGB(0xB0,0xE0,0xE6); //RGB(176,224,230)
00123 const COLORREF colorPurple               = RGB(0x80,0x00,0x80); //RGB(128,  0,128)
00124 const COLORREF colorRed                  = RGB(0xFF,0x00,0x00); //RGB(255,  0,  0)
00125 const COLORREF colorRosyBrown            = RGB(0xBC,0x8F,0x8F); //RGB(188,143,143)
00126 const COLORREF colorRoyalBlue            = RGB(0x41,0x69,0xE1); //RGB( 65,105,225)
00127 const COLORREF colorSaddleBrown          = RGB(0x8B,0x45,0x13); //RGB(139, 69, 19)
00128 const COLORREF colorSalmon               = RGB(0xFA,0x80,0x72); //RGB(250,128,114)
00129 const COLORREF colorSandyBrown           = RGB(0xF4,0xA4,0x60); //RGB(244,164, 96)
00130 const COLORREF colorSeaGreen             = RGB(0x2E,0x8B,0x57); //RGB( 46,139, 87)
00131 const COLORREF colorSeaShell             = RGB(0xFF,0xF5,0xEE); //RGB(255,245,238)
00132 const COLORREF colorSienna               = RGB(0xA0,0x52,0x2D); //RGB(160, 82, 45)
00133 const COLORREF colorSilver               = RGB(0xC0,0xC0,0xC0); //RGB(192,192,192)
00134 const COLORREF colorSkyBlue              = RGB(0x87,0xCE,0xEB); //RGB(135,206,235)
00135 const COLORREF colorSlateBlue            = RGB(0x6A,0x5A,0xCD); //RGB(106, 90,205)
00136 const COLORREF colorSlateGray            = RGB(0x70,0x80,0x90); //RGB(112,128,144)
00137 const COLORREF colorSnow                 = RGB(0xFF,0xFA,0xFA); //RGB(255,250,250)
00138 const COLORREF colorSpringGreen          = RGB(0x00,0xFF,0x7F); //RGB(  0,255,127)
00139 const COLORREF colorSteelBlue            = RGB(0x46,0x82,0xB4); //RGB( 70,130,180)
00140 const COLORREF colorTan                  = RGB(0xD2,0xB4,0x8C); //RGB(210,180,140)
00141 const COLORREF colorTeal                 = RGB(0x00,0x80,0x80); //RGB(  0,128,128)
00142 const COLORREF colorThistle              = RGB(0xD8,0xBF,0xD8); //RGB(216,191,216)
00143 const COLORREF colorTomato               = RGB(0xFF,0x63,0x47); //RGB(255, 99, 71)
00144 const COLORREF colorTurquoise            = RGB(0x40,0xE0,0xD0); //RGB( 64,224,208)
00145 const COLORREF colorViolet               = RGB(0xEE,0x82,0xEE); //RGB(238,130,238)
00146 const COLORREF colorWheat                = RGB(0xF5,0xDE,0xB3); //RGB(245,222,179)
00147 const COLORREF colorWhite                = RGB(0xFF,0xFF,0xFF); //RGB(255,255,255)
00148 const COLORREF colorWhiteSmoke           = RGB(0xF5,0xF5,0xF5); //RGB(245,245,245)
00149 const COLORREF colorYellow               = RGB(0xFF,0xFF,0x00); //RGB(255,255,  0)
00150 const COLORREF colorYellowGreen          = RGB(0x9A,0xCD,0x32); //RGB(154,205, 50)
00151
00152 #endif // __X11COLOR_H__INCLUDED_
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
_CONFIG_OPTIONS |
_COORD_LONG |
_DiagDataType |
_DP5_CONFIGURATION |
_DppStateType |
_Packet_In |
_SpectrumFileType |
_WINUSB_PIPE_INFORMATION |
_WINUSB_SETUP_PACKET |
CAboutDlg |
cAnimWnd |
CAsciiCmdUtilities |
CBootOptPage |
CCfgPropPage |
CCfgPropSheet |
CDlgStatusBar |
CDlgToolBar |
CDP5CfgWnd |
CDP5ControlUtil |
CDP5Protocol |
CDP5Status |
CDppComm |
CDppConfig |
CDppGain |
CDppLibUsb |
CDppShaping |
CDppSlowThreshold |
CDppSocket |
CDppUtilities |
CDppWinUSB |
CFileBrowse |
CFilePage |
CGainPzPage |
CINI |
CIniEx |
CIniUtil |
CLabel |
CMcaPage |
cMemDC |
CMiscPage |
CMSecTimer |
CMsgBox |
CNetFinder |
CParsePacket |
CPlot |
CPlotCanvas |
CPowerPage |
CRoi |
CRoiEntry |
CSca |
CScaFn |
CSCommon |
CSelectDP5 |
CSendCommand |
CShapingPage |
CSpectraList |
CSpectrum |
CSpectrumAttr |
CSProfile |
CTrapKeyComboBox |
CTrapKeyEdit |
CTuneSlowThreshold |
CvcDP5App |
CvcDP5Dlg |
cWaitDialog |
cWaitDlg |
cWaitDlgThread |
CWinusbNotify |
DP5_DP4_FORMAT_STATUS |
NETDISPLAY_ENTRY |
Packet_Out |
Spec |
stringex |
WINUSB_DEVICE_INFO | Holds WinUSB device information
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CAboutDlg Member List
This is the complete list of members for CAboutDlg, including all inherited members.
CAboutDlg() | CAboutDlg |
DoDataExchange(CDataExchange *pDX) | CAboutDlg | [protected, virtual]
IDD enum value | CAboutDlg |
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CAsciiCmdUtilities Member List
This is the complete list of members for CAsciiCmdUtilities, including all inherited members.
CAsciiCmdUtilities(void) | CAsciiCmdUtilities
CopyAsciiData(unsigned char Data[], string strCfg, long lLen) | CAsciiCmdUtilities
CreateFullReadBackCmd(bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO) | CAsciiCmdUtilities
CreateFullReadBackCmdMCA8000D(int DppType) | CAsciiCmdUtilities
CreateResTestReadBackCmd(bool bSendCoarseFineGain, int DppType) | CAsciiCmdUtilities
GetCmdChunk(std::string strCmd) | CAsciiCmdUtilities
GetDP5CfgStr(std::string strFilename) | CAsciiCmdUtilities
GetDP5ScaStr(std::string strFilename) | CAsciiCmdUtilities
MakeUpper(std::string myString) | CAsciiCmdUtilities
Remove_MCA8000D_Cmds(std::string strCfgDataIn, int DppType) | CAsciiCmdUtilities
RemoveCmd(std::string strCmd, std::string strCfgData) | CAsciiCmdUtilities
RemoveCmdByDeviceType(std::string strCfgDataIn, bool PC5_PRESENT, int DppType, bool isDP5_RevDxGains, unsigned char DPP_ECO) | CAsciiCmdUtilities
RemoveCmdByDeviceTypeDP5DxK(std::string strCfgDataIn, bool PC5_PRESENT, int DppType) | CAsciiCmdUtilities
RemWhitespace(std::string strLine) | CAsciiCmdUtilities
ReplaceCmdText(std::string strInTextIn, std::string strFrom, std::string strTo) | CAsciiCmdUtilities
~CAsciiCmdUtilities(void) | CAsciiCmdUtilities
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CBootOptPage Member List
This is the complete list of members for CBootOptPage, including all inherited members.
CBootOptPage() | CBootOptPage |
CboUpdate(int nID_dci) | CBootOptPage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
DoDataExchange(CDataExchange *pDX) | CBootOptPage | [protected, virtual]
IDD enum value | CBootOptPage |
InitControls() | CBootOptPage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CBootOptPage |
m_BootOptPageLabel | CBootOptPage |
OnInitDialog() | CBootOptPage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CBootOptPage | [virtual]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
~CBootOptPage() | CBootOptPage |
~CCfgPropPage() | CCfgPropPage |
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CCfgPropPage Member List
This is the complete list of members for CCfgPropPage, including all inherited members.
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
DoDataExchange(CDataExchange *pDX) | CCfgPropPage | [protected, virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
~CCfgPropPage() | CCfgPropPage |
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CCfgPropSheet Member List
This is the complete list of members for CCfgPropSheet, including all inherited members.
ActivePage | CCfgPropSheet |
AddPage(CCfgPropPage *pPage) | CCfgPropSheet |
CCfgPropPage class | CCfgPropSheet | [friend]
CCfgPropSheet(UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0, HBITMAP hbmWatermark=NULL, HPALETTE hpalWatermark=NULL, HBITMAP hbmHeader=NULL) | CCfgPropSheet |
CCfgPropSheet(LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0, HBITMAP hbmWatermark=NULL, HPALETTE hpalWatermark=NULL, HBITMAP hbmHeader=NULL) | CCfgPropSheet |
DoModal() | CCfgPropSheet | [virtual]
GetCurrentButtonState() | CCfgPropSheet |
GetStatusBar() | CCfgPropSheet | [inline]
GetToolBar() | CCfgPropSheet | [inline]
InitCfgPropSheet(BOOL bToolTips=FALSE, BOOL bStatusBar=FALSE, UINT *pIndicators=NULL, UINT nIndicators=0, UINT uiMenu=0, UINT uiToolBar=0, DWORD dwToolBarStyle=TBSTYLE_FLAT|WS_CHILD|WS_VISIBLE|CBRS_TOP|CBRS_GRIPPER|CBRS_TOOLTIPS|CBRS_FLYBY|CBRS_SIZE_DYNAMIC) | CCfgPropSheet |
m_bKillItself | CCfgPropSheet | [protected]
m_bMenu | CCfgPropSheet | [protected]
m_bModal | CCfgPropSheet | [protected]
m_bResetPrompt | CCfgPropSheet | [protected]
m_bStatusBar | CCfgPropSheet | [protected]
m_bToolBar | CCfgPropSheet | [protected]
m_bToolTips | CCfgPropSheet | [protected]
m_CSBCtrlStatus | CCfgPropSheet | [protected]
m_CSToolBar | CCfgPropSheet | [protected]
m_nIDLastMessage | CCfgPropSheet | [protected]
m_nIDTracking | CCfgPropSheet | [protected]
m_Timer | CCfgPropSheet | [protected]
OnCancel() | CCfgPropSheet | [virtual]
OnEnterIdle(UINT nWhy, CWnd *pWho) | CCfgPropSheet | [protected]
OnFileTab() | CCfgPropSheet |
OnFileTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnGainPzTab() | CCfgPropSheet |
OnGainPzTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnInitMenuPopup(CMenu *pPopupMenu, UINT nIndex, BOOL bSysMenu) | CCfgPropSheet | [protected]
OnKickIdle(WPARAM, LPARAM lCount) | CCfgPropSheet | [protected]
OnMcaTab() | CCfgPropSheet |
OnMcaTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnMenuSelect(UINT nItemID, UINT nFlags, HMENU hSysMenu) | CCfgPropSheet | [protected]
OnMiscTab() | CCfgPropSheet |
OnMiscTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropSheet | [protected]
OnPopMessageString(WPARAM wParam, LPARAM lParam) | CCfgPropSheet | [protected]
OnPowerTab() | CCfgPropSheet |
OnPowerTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnSelectTab(UINT NewActivePage, int nPage) | CCfgPropSheet |
OnSetMessageString(WPARAM wParam, LPARAM lParam=0L) | CCfgPropSheet | [protected]
OnShapingTab() | CCfgPropSheet |
OnShapingTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnStatusBarCheck() | CCfgPropSheet | [protected]
OnTB1() | CCfgPropSheet |
OnTimer(UINT nIDEvent) | CCfgPropSheet | [protected]
OnToolBarCheck() | CCfgPropSheet | [protected]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropSheet | [protected]
OnUpdateKeyIndicator(CCmdUI *pCmdUI) | CCfgPropSheet | [protected]
OnUpdateStatusBarMenu(CCmdUI *pCmdUI) | CCfgPropSheet | [protected]
OnUpdateToolBarMenu(CCmdUI *pCmdUI) | CCfgPropSheet | [protected]
PostNcDestroy() | CCfgPropSheet | [protected, virtual]
UpdateAll() | CCfgPropSheet |
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDP5CfgWnd Member List
This is the complete list of members for CDP5CfgWnd, including all inherited members.
ActivePage | CCfgPropSheet |
AddPage(CCfgPropPage *pPage) | CCfgPropSheet |
AddPages(void) | CDP5CfgWnd | [protected]
CCfgPropPage class | CCfgPropSheet | [friend]
CCfgPropSheet(UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0, HBITMAP hbmWatermark=NULL, HPALETTE hpalWatermark=NULL, HBITMAP hbmHeader=NULL) | CCfgPropSheet |
CCfgPropSheet(LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0, HBITMAP hbmWatermark=NULL, HPALETTE hpalWatermark=NULL, HBITMAP hbmHeader=NULL) | CCfgPropSheet |
CDP5CfgWnd(UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0) | CDP5CfgWnd |
CDP5CfgWnd(LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0) | CDP5CfgWnd |
DoModal() | CDP5CfgWnd | [virtual]
GetCurrentButtonState() | CCfgPropSheet |
GetStatusBar() | CCfgPropSheet | [inline]
GetToolBar() | CCfgPropSheet | [inline]
InitCfgPropSheet(BOOL bToolTips=FALSE, BOOL bStatusBar=FALSE, UINT *pIndicators=NULL, UINT nIndicators=0, UINT uiMenu=0, UINT uiToolBar=0, DWORD dwToolBarStyle=TBSTYLE_FLAT|WS_CHILD|WS_VISIBLE|CBRS_TOP|CBRS_GRIPPER|CBRS_TOOLTIPS|CBRS_FLYBY|CBRS_SIZE_DYNAMIC) | CCfgPropSheet |
m_bKillItself | CCfgPropSheet | [protected]
m_bMenu | CCfgPropSheet | [protected]
m_bModal | CDP5CfgWnd |
m_bResetPrompt | CCfgPropSheet | [protected]
m_bStatusBar | CCfgPropSheet | [protected]
m_bToolBar | CCfgPropSheet | [protected]
m_bToolTips | CCfgPropSheet | [protected]
m_CSBCtrlStatus | CCfgPropSheet | [protected]
m_CSToolBar | CCfgPropSheet | [protected]
m_FilePage | CDP5CfgWnd |
m_GainPzPage | CDP5CfgWnd |
m_McaPage | CDP5CfgWnd |
m_MiscPage | CDP5CfgWnd |
m_nIDLastMessage | CCfgPropSheet | [protected]
m_nIDTracking | CCfgPropSheet | [protected]
m_PowerPage | CDP5CfgWnd |
m_ShapingPage | CDP5CfgWnd |
m_Timer | CCfgPropSheet | [protected]
OnCancel() | CCfgPropSheet | [virtual]
OnEnterIdle(UINT nWhy, CWnd *pWho) | CCfgPropSheet | [protected]
OnFileTab() | CCfgPropSheet |
OnFileTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnGainPzTab() | CCfgPropSheet |
OnGainPzTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnInitDialog() | CDP5CfgWnd | [virtual]
OnInitMenuPopup(CMenu *pPopupMenu, UINT nIndex, BOOL bSysMenu) | CCfgPropSheet | [protected]
OnKickIdle(WPARAM, LPARAM lCount) | CCfgPropSheet | [protected]
OnMcaTab() | CCfgPropSheet |
OnMcaTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnMenuSelect(UINT nItemID, UINT nFlags, HMENU hSysMenu) | CCfgPropSheet | [protected]
OnMiscTab() | CCfgPropSheet |
OnMiscTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropSheet | [protected]
OnPopMessageString(WPARAM wParam, LPARAM lParam) | CCfgPropSheet | [protected]
OnPowerTab() | CCfgPropSheet |
OnPowerTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnSelectTab(UINT NewActivePage, int nPage) | CCfgPropSheet |
OnSetMessageString(WPARAM wParam, LPARAM lParam=0L) | CCfgPropSheet | [protected]
OnShapingTab() | CCfgPropSheet |
OnShapingTab2(CCmdUI *pCmdUI) | CCfgPropSheet |
OnStatusBarCheck() | CCfgPropSheet | [protected]
OnTB1() | CCfgPropSheet |
OnTimer(UINT nIDEvent) | CCfgPropSheet | [protected]
OnToolBarCheck() | CCfgPropSheet | [protected]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropSheet | [protected]
OnUpdateKeyIndicator(CCmdUI *pCmdUI) | CCfgPropSheet | [protected]
OnUpdateStatusBarMenu(CCmdUI *pCmdUI) | CCfgPropSheet | [protected]
OnUpdateToolBarMenu(CCmdUI *pCmdUI) | CCfgPropSheet | [protected]
PostNcDestroy() | CCfgPropSheet | [protected, virtual]
UpdateAll() | CCfgPropSheet |
~CDP5CfgWnd() | CDP5CfgWnd | [virtual]
Generated on Thu Sep 21 2017 15:25:21 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDP5ControlUtil Member List
This is the complete list of members for CDP5ControlUtil, including all inherited members.
AppendUnitsToSettingString(DP5_CONFIGURATION *cfg) | CDP5ControlUtil
AppendUnitsToString(CString strValue, CString strUnits) | CDP5ControlUtil
CDP5ControlUtil(void) | CDP5ControlUtil
FindCboIdx(HWND hDlg, int cboDP5CtrlID, CString strVal) | CDP5ControlUtil
FindCboIdxExact(HWND hDlg, int cboDP5CtrlID, CString strVal) | CDP5ControlUtil
FindUnitsInString(CString strValue, CString strUnits) | CDP5ControlUtil
GetValueWithUnitsString(DP5_CONFIGURATION cfg) | CDP5ControlUtil
IsAllNumericString(CString strValue) | CDP5ControlUtil
LoadingCfg | CDP5ControlUtil
OrderOut(int IndexIn) | CDP5ControlUtil
RemoveUnitsFromDecString(DP5_CONFIGURATION *cfg) | CDP5ControlUtil
SetCboIdxByStr(HWND hDlg, DP5_CONFIGURATION cfg) | CDP5ControlUtil
strFindCtrl | CDP5ControlUtil
strFindIdx | CDP5ControlUtil
strFindTab | CDP5ControlUtil
UpdateSetting(DP5_CONFIGURATION *cfg) | CDP5ControlUtil
UpdateSettingOsc(DP5_CONFIGURATION *cfg) | CDP5ControlUtil
~CDP5ControlUtil(void) | CDP5ControlUtil
Generated on Thu Sep 21 2017 15:25:21 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDP5Protocol Member List
This is the complete list of members for CDP5Protocol, including all inherited members.
ACK_Received | CDP5Protocol
BufferOUT | CDP5Protocol
CDP5Protocol(void) | CDP5Protocol
CommError | CDP5Protocol
InPacketType | CDP5Protocol
MiscData | CDP5Protocol
Netfinder_active | CDP5Protocol
Netfinder_Seq | CDP5Protocol
Packet_Received | CDP5Protocol
PacketIn | CDP5Protocol
PIN | CDP5Protocol
RS232_RThreshold | CDP5Protocol
RS232BytesInBuffer | CDP5Protocol
RS232HeaderReceived | CDP5Protocol
RS232PacketPtr | CDP5Protocol
ScaleAuto | CDP5Protocol
Scope | CDP5Protocol
SPECTRUM | CDP5Protocol
Timeout_flag | CDP5Protocol
UDP_offset | CDP5Protocol
USB_Default_Timeout | CDP5Protocol
~CDP5Protocol(void) | CDP5Protocol
Generated on Thu Sep 21 2017 15:25:21 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDP5Status Member List
This is the complete list of members for CDP5Status, including all inherited members.
CDP5Status(void) | CDP5Status
DiagData | CDP5Status
DiagnosticsToString(DiagDataType dd, int device_type) | CDP5Status
DiagStrPX5Option(DiagDataType dd, int device_type) | CDP5Status
DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn) | CDP5Status
DP5_Dx_OptionFlags(unsigned char DP5_Dx_Options) | CDP5Status
DppUtil | CDP5Status
FmtHex(long FmtHex, long HexDig) | CDP5Status
FmtHvPwr(float fVal) | CDP5Status
FmtLng(long lVal) | CDP5Status
FmtPc5Pwr(float fVal) | CDP5Status
FmtPc5Temp(float fVal) | CDP5Status
GetDeviceNameFromVal(int DeviceTypeVal) | CDP5Status
GetStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status) | CDP5Status
IsAorB(bool bIsA, string strA, string strB) | CDP5Status
m_DP5_Status | CDP5Status
OnOffStr(bool bOn) | CDP5Status
Process_Diagnostics(Packet_In PIN, DiagDataType *dd, int device_type) | CDP5Status
Process_Status(DP4_FORMAT_STATUS *m_DP5_Status) | CDP5Status
PX5_OptionsString(DP4_FORMAT_STATUS m_DP5_Status) | CDP5Status
SaveStringDataToFile(string strData) | CDP5Status
ShowStatusValueStrings(DP4_FORMAT_STATUS m_DP5_Status) | CDP5Status
VersionToStr(unsigned char bVersion) | CDP5Status
~CDP5Status(void) | CDP5Status
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDlgStatusBar Member List
This is the complete list of members for CDlgStatusBar, including all inherited members.
CDlgStatusBar() | CDlgStatusBar |
OnIdleUpdateCmdUI(WPARAM wParam, LPARAM) | CDlgStatusBar | [protected]
~CDlgStatusBar() | CDlgStatusBar | [virtual]
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDlgToolBar Member List
This is the complete list of members for CDlgToolBar, including all inherited members.
CDlgToolBar() | CDlgToolBar |
EnableButton(int nId, BOOL bEnable) | CDlgToolBar |
OnIdleUpdateCmdUI(WPARAM wParam, LPARAM) | CDlgToolBar | [protected]
tbBtnMap | CDlgToolBar | [protected]
~CDlgToolBar() | CDlgToolBar | [virtual]
Generated on Thu Sep 21 2017 15:25:20 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppComm Member List
This is the complete list of members for CDppComm, including all inherited members.
CDppComm() | CDppComm |
ClosePort() | CDppComm |
DppCommThread(LPVOID pParam) | CDppComm | [protected, static]
GetCommErrStr(char *ErrorText) | CDppComm | [protected]
GetComPortID() | CDppComm |
ghThreadExitEvent | CDppComm | [protected]
IsPortOpen() | CDppComm |
m_bThreadRunning | CDppComm | [protected]
m_CommTimeouts | CDppComm | [protected]
m_csCommunicationSync | CDppComm | [protected]
m_dcb | CDppComm | [protected]
m_dwCommEvents | CDppComm | [protected]
m_hDppComm | CDppComm | [protected]
m_hEvents | CDppComm | [protected]
m_hWriteEvent | CDppComm | [protected]
m_nWriteBufferSize | CDppComm | [protected]
m_pOwner | CDppComm | [protected]
m_szWriteBuffer | CDppComm | [protected]
m_WinThread | CDppComm | [protected]
OpenPort() | CDppComm |
osIO | CDppComm | [protected]
PortIDSetting | CDppComm | [protected]
PortIsOpen | CDppComm | [protected]
ReceiveByte(CDppComm *port, COMSTAT comStat) | CDppComm | [protected, static]
SendPacketRS232(unsigned char Buffer[], CDppComm *CommPort) | CDppComm |
Settings(CWnd *hPortWnd, UINT PortID=1, UINT BaudRate=115200, char Parity= 'N', UINT DataBits=8, UINT StopBits=1, DWORD dwCommEvents=EV_RXCHAR, UINT nBufferSize=1024) | CDppComm |
WriteByte(CDppComm *port) | CDppComm | [protected, static]
WriteData(unsigned char *string, size_t NumBytes) | CDppComm |
~CDppComm() | CDppComm | [virtual]
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppConfig Member List
This is the complete list of members for CDppConfig, including all inherited members.
AccumulationTime | CDppConfig
AcqMode | CDppConfig
AuxOut | CDppConfig
Avg | CDppConfig
b80MHzMode | CDppConfig
b80MHzModeCfg | CDppConfig
bAnalogPolarity | CDppConfig
BaselineOn | CDppConfig
bb_BootFlags | CDppConfig
bb_DeadTimeCounter | CDppConfig
bb_DiodeCalDACSet | CDppConfig
bb_HVDACSet | CDppConfig
bb_InputOffsetTuning | CDppConfig
bb_SpectrumOffset | CDppConfig
bb_TECCurrentLimit | CDppConfig
bb_TECDACSet | CDppConfig
bb_uCTempCal | CDppConfig
bBootHVPolarity | CDppConfig
bConfigHVPolarity | CDppConfig
bFPGAAutoClock | CDppConfig
bGammaRadHVMode | CDppConfig
BLR | CDppConfig
BoardTemp | CDppConfig
BoardTempCStr | CDppConfig
BootStatus | CDppConfig
bPC5Detected | CDppConfig
BufferSelect | CDppConfig
Build | CDppConfig
CDppConfig(void) | CDppConfig
CfgModCount | CDppConfig
CfgReadBack | CDppConfig
DAC | CDppConfig
DAC_Enable | CDppConfig
dblConfigHV | CDppConfig
DCal | CDppConfig
DetReset | CDppConfig
DeviceType | CDppConfig
DisplayCfg | CDppConfig
DisplaySca | CDppConfig
FastChThreshold | CDppConfig
FastCount | CDppConfig
Firmware | CDppConfig
FlatTop | CDppConfig
FlatTopUS | CDppConfig
FPGA | CDppConfig
Gain | CDppConfig
GainDelta | CDppConfig
Gate | CDppConfig
GetDeviceNameFromVal(int DeviceTypeVal) | CDppConfig
GPCount | CDppConfig
HV | CDppConfig
HVEnabled | CDppConfig
HVMonitor | CDppConfig
HVMonitorCStr | CDppConfig
HVRangeInd | CDppConfig
HwCfgFromDLG | CDppConfig
IndBuzzer | CDppConfig
IndLED | CDppConfig
InvertEn | CDppConfig
isCfgChanged | CDppConfig
isDeltaMode | CDppConfig
isDPP5 | CDppConfig
isPresetAcq | CDppConfig
LiveTime | CDppConfig
LoadRestartFastThresh | CDppConfig
LoadRestartInProgress | CDppConfig
LoadRestartInputOffset | CDppConfig
LoadRestartInputOffsetSlow | CDppConfig
LoadRestartSlowThresh | CDppConfig
LoadRestartStatus | CDppConfig
MCA | CDppConfig
mcaCH | CDppConfig
MCAEnable | CDppConfig
MCSDone | CDppConfig
MCSEnable | CDppConfig
MCSTimebase | CDppConfig
NavPanelUpdate | CDppConfig
NeedsDP5ReBoot | CDppConfig
Offset | CDppConfig
PoleZero | CDppConfig
Port | CDppConfig
Preset | CDppConfig
PresetAcq | CDppConfig
PresetCount | CDppConfig
PresetCountExpired | CDppConfig
PresetLt | CDppConfig
PresetLtDone | CDppConfig
PresetRt | CDppConfig
PresetRtDone | CDppConfig
PrintCfg | CDppConfig
ProcessUSBData() | CDppConfig
PUREnable | CDppConfig
PwrBtnConfig | CDppConfig
PwrCtrl5VA | CDppConfig
PwrCtrl9V | CDppConfig
PX4FineGain | CDppConfig
PX4Gain | CDppConfig
PX4InputOffset | CDppConfig
RealTime | CDppConfig
RefreshDppGainPZ | CDppConfig
RefreshDppGeneral | CDppConfig
RefreshDppMCA | CDppConfig
RefreshDppMisc | CDppConfig
RefreshDppPower | CDppConfig
RefreshDppShaping | CDppConfig
RefreshDppTest | CDppConfig
Rise | CDppConfig
RiseUS | CDppConfig
RTDFast | CDppConfig
RTDOn | CDppConfig
RTDSlow | CDppConfig
SaveCfg | CDppConfig
SCA | CDppConfig
ScaReadBack | CDppConfig
Scope | CDppConfig
ScopeTriggerFalling | CDppConfig
ScopeTriggerPosition | CDppConfig
SEL8_5V | CDppConfig
SerialNumber | CDppConfig
SetFastThreshDone | CDppConfig
SetInputOffsetDone | CDppConfig
SlowChThreshold | CDppConfig
SlowCount | CDppConfig
SlowThresholdPct | CDppConfig
StartTime | CDppConfig
StatDevInd | CDppConfig
StatMcaEnabled | CDppConfig
strAnalogOut | CDppConfig
strGainDisplayValue | CDppConfig
strInputOffset | CDppConfig
strMcaMode | CDppConfig
strOutputOffset | CDppConfig
strPercentDeadTime | CDppConfig
strPresetCmd | CDppConfig
strPresetVal | CDppConfig
strScopeGain | CDppConfig
strTriggerPosition | CDppConfig
strTriggerSlope | CDppConfig
strTriggerSource | CDppConfig
SwConfigRcvd | CDppConfig
TEC | CDppConfig
TECEnabled | CDppConfig
TECMonitor | CDppConfig
TECMonitorCStr | CDppConfig
UCHARVersionToDouble(unsigned char Version) | CDppConfig
UpdateScopeCfg | CDppConfig
USBDataRefreshRate | CDppConfig
XR100 | CDppConfig
~CDppConfig(void) | CDppConfig
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppGain Member List
This is the complete list of members for CDppGain, including all inherited members.
CDppGain(void) | CDppGain
FixTotalGainRange(CString strTotalGain, DppAGainTable GainTable) | CDppGain
FixTotalGainRangeDbl(double dblTotalGain, DppAGainTable GainTable) | CDppGain
GainTable | CDppGain
GainTableCount | CDppGain
GetGainCount(DppAGainTable GainTable) | CDppGain
GetGainTablePtr(DppAGainTable GainTable) | CDppGain
GetTotalGainLimitsLabel(DppAGainTable GainTable) | CDppGain
GetTotalGainLimitsMax(DppAGainTable GainTable) | CDppGain
GetTotalGainLimitsMin(DppAGainTable GainTable) | CDppGain
isInTotalGainRange(CString strTotalGain, DppAGainTable GainTable) | CDppGain
LoadGainTableIndexes(CComboBox *m_CoarseGain, DppAGainTable GainTable) | CDppGain
LoadGainTableValues(CComboBox *m_CoarseGain, DppAGainTable GainTable) | CDppGain
MaxGain | CDppGain
MinGain | CDppGain
ptrGainTable | CDppGain
~CDppGain(void) | CDppGain
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppLibUsb Member List
This is the complete list of members for CDppLibUsb, including all inherited members.
bDeviceConnected | CDppLibUsb
bDeviceReady | CDppLibUsb
bLibusbReady | CDppLibUsb
CDppLibUsb(void) | CDppLibUsb
CloseUSBDevice(libusb_device_handle *devh) | CDppLibUsb
CountDP5LibusbDevices() | CDppLibUsb
CurrentDevice | CDppLibUsb
data_in | CDppLibUsb
data_out | CDppLibUsb
DeinitializeLibusb() | CDppLibUsb
DppLibusbHandle | CDppLibUsb
FindUSBDevice(int idxAmptekDevice) | CDppLibUsb
InitializeLibusb() | CDppLibUsb
isAmptekDP5Device(libusb_device_descriptor desc) | CDppLibUsb
LastLibUsbError | CDppLibUsb
libusb_strerror(enum libusb_error error_code) | CDppLibUsb
NumDevices | CDppLibUsb
PrintDevices() | CDppLibUsb
SendPacketUSB(libusb_device_handle *devh, unsigned char data_out[], unsigned char data_in[]) | CDppLibUsb
~CDppLibUsb(void) | CDppLibUsb
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppShaping Member List
This is the complete list of members for CDppShaping, including all inherited members.
b80MHzMode | CDppShaping
CDppShaping(void) | CDppShaping
dbl_to_uS(double dblVal) | CDppShaping
dblPeakingMult | CDppShaping
GetDblValFromComboText(CComboBox *m_ComboBoxCtrl) | CDppShaping
GetDefaultFlatTopFromRiseIndex(int RiseIndex, double dblFlatTop) | CDppShaping
GetRiseValueFromIndex(int RiseIndex, BOOL isRiseAveCalc) | CDppShaping
Set80MHzMode(BOOL is80Mhz) | CDppShaping
SetRiseCombo() | CDppShaping
SetTopCombo() | CDppShaping
Shaping_Setup(CComboBox *cboRiseObj, CComboBox *cboTopObj) | CDppShaping
~CDppShaping(void) | CDppShaping
Generated on Thu Sep 21 2017 15:25:22 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppSlowThreshold Member List
This is the complete list of members for CDppSlowThreshold, including all inherited members.
CDppSlowThreshold(void) | CDppSlowThreshold
DPPThreshold(int SpinPos) | CDppSlowThreshold
GetSlowChThreshold() | CDppSlowThreshold
GetSlowChThresStrFromVal(unsigned char byteSlowThres) | CDppSlowThreshold
GetSlowThreshChStr() | CDppSlowThreshold
GetSlowThreshChStrFromVal(unsigned char byteSlowThres) | CDppSlowThreshold
GetSlowThresholdSettingFromChannels(double dblSlowThreshChannels) | CDppSlowThreshold
GetSlowThresholdSettingFromPercent(double dblSlowThresh) | CDppSlowThreshold
GetSlowThreshPcntStr() | CDppSlowThreshold
SetGain(long GainVal) | CDppSlowThreshold
SetSlowChThreshold(unsigned char SlowChThresholdVal) | CDppSlowThreshold
SetSlowChThresholdConfigFromStr(CString strSlowThresh) | CDppSlowThreshold
SetSlowChThresholdFromStr(CString strSlowThresh) | CDppSlowThreshold
SetSlowChThresholdFromVal(int intSlowThresh) | CDppSlowThreshold
Thresholds_Setup(CSpinButtonCtrl *udThresholdObj, CEdit *lblThresholdObj, CEdit *lblThresholdChannelsObj) | CDppSlowThreshold
txtSlowThreshold_Click() | CDppSlowThreshold
txtSlowThresholdChannels_Click() | CDppSlowThreshold
UpdateSlowThresChDisplay() | CDppSlowThreshold
~CDppSlowThreshold(void) | CDppSlowThreshold
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppSocket Member List
This is the complete list of members for CDppSocket, including all inherited members.
CDppSocket() | CDppSocket |
CloseSocket() | CDppSocket |
CreateSocket(CWnd *pEvtDlg) | CDppSocket |
DppAddr | CDppSocket |
DppPort | CDppSocket |
HaveHeader | CDppSocket |
IsSocketOpen() | CDppSocket |
m_DataMode | CDppSocket | [protected]
m_Owner | CDppSocket |
m_pEvtDlg | CDppSocket | [protected]
m_SocketOpen | CDppSocket | [protected]
OnReceive(int nErrorCode) | CDppSocket | [virtual]
RcvCount | CDppSocket |
RcvTotal | CDppSocket |
ResetEventDlg() | CDppSocket |
SendPacketInet(unsigned char Buffer[], CDppSocket *DppSock) | CDppSocket |
SetEventDlg(CWnd *pEvtDlg) | CDppSocket |
~CDppSocket() | CDppSocket | [virtual]
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppUtilities Member List
This is the complete list of members for CDppUtilities, including all inherited members.
BYTEVersionToDouble(unsigned char Version) | CDppUtilities
BYTEVersionToString(unsigned char Version) | CDppUtilities
CDppUtilities(void) | CDppUtilities
LongWordToDouble(int lwStart, unsigned char buffer[]) | CDppUtilities
~CDppUtilities(void) | CDppUtilities
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CDppWinUSB Member List
This is the complete list of members for CDppWinUSB, including all inherited members.
CDppWinUSB(void) | CDppWinUSB
CloseDeviceHandle() | CDppWinUSB
CloseWinUsbDevice() | CDppWinUSB
CountDP5WinusbDevices(void) | CDppWinUSB
CurrentDevice | CDppWinUSB
devInfo | CDppWinUSB
Disable_WinUsb() | CDppWinUSB
DisplayBufferArray(unsigned char buffer[], unsigned long bufSizeIn) | CDppWinUSB
FindUSBDevice(DWORD MemberIndex) | CDppWinUSB
GetDevicePath(LPGUID InterfaceGuid, PCHAR DevicePath, size_t BufLen, DWORD MemberIndex) | CDppWinUSB
InitDeviceInfo() | CDppWinUSB
Initialize_Device(DWORD MemberIndex) | CDppWinUSB
isDppFound | CDppWinUSB
NumDevices | CDppWinUSB
NumPipes | CDppWinUSB
OpenDevice(BOOL bSync, DWORD MemberIndex) | CDppWinUSB
PipeId | CDppWinUSB
PipeTimeout | CDppWinUSB
SaveStringDataToFile(string strData) | CDppWinUSB
SendPacketUSB(unsigned char Buffer[], DEVICE_INFO TestDevInfo, unsigned char PacketIn[]) | CDppWinUSB
USB_Default_Timeout | CDppWinUSB
USBStatusString(DPP_USB_STATUS USBStatus) | CDppWinUSB
WinUsb_Disabled | CDppWinUSB
~CDppWinUSB(void) | CDppWinUSB
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CFileBrowse Member List
This is the complete list of members for CFileBrowse, including all inherited members.
AllFileFilter | CFileBrowse
BmpFileFilter | CFileBrowse
CfgFileFilter | CFileBrowse
CFileBrowse(void) | CFileBrowse
DialogType enum name | CFileBrowse
DoModal(int DlgType, CString DlgTitle, CString FileFilter, CString DefaultExt, CString InitDir, CString *Filename) | CFileBrowse
ExeFileFilter | CFileBrowse
LibFileFilter | CFileBrowse
McaFileFilter | CFileBrowse
OPEN enum value | CFileBrowse
SAVE enum value | CFileBrowse
TxtFileFilter | CFileBrowse
~CFileBrowse(void) | CFileBrowse
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CFilePage Member List
This is the complete list of members for CFilePage, including all inherited members.
CboUpdate(int nID_dci) | CFilePage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CFilePage() | CFilePage |
DoDataExchange(CDataExchange *pDX) | CFilePage | [protected, virtual]
EnableControls(BOOL bEnable) | CFilePage |
EnableDeviceSelection(BOOL bEnable) | CFilePage |
GetAmptekDC_NP_Section() | CFilePage |
GetCmdKeyData(CString strCmd, CString strCfgData) | CFilePage |
InitControls() | CFilePage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CFilePage |
isCComboBox(int nID) | CFilePage |
isCEditBox(int nID) | CFilePage |
isClosing | CFilePage |
m_FileAdvancedLabel | CFilePage |
m_FilePageLabel | CFilePage |
m_FileStandardLabel | CFilePage |
m_nTmrConfigElapse | CFilePage |
m_nTmrConfigEventId | CFilePage |
m_nTmrConfigId | CFilePage |
m_ReadDetectorConfigCombo | CFilePage |
m_strConfigIn | CFilePage |
m_strConfigOut | CFilePage |
m_ToolTip | CFilePage | [protected]
OnApply() | CFilePage | [virtual]
OnBnClickedButtonEditConfigFromHw() | CFilePage |
OnBnClickedButtonReadConfig() | CFilePage |
OnBnClickedButtonSaveConfig() | CFilePage |
OnBnClickedButtonSendCommand() | CFilePage |
OnBnClickedButtonSendCommand2() | CFilePage |
OnBnClickedButtonSendToHardware() | CFilePage |
OnBnClickedButtonSendToHardwareNoEdit() | CFilePage |
OnBnClickedCheckDP5DxGains() | CFilePage |
OnBnClickedCheckPc5Present() | CFilePage |
OnBnClickedRadioDppDeviceType1() | CFilePage |
OnBnClickedRadioDppDeviceType2() | CFilePage |
OnBnClickedRadioDppDeviceType3() | CFilePage |
OnBnClickedRadioDppDeviceType4() | CFilePage |
OnBnClickedRadioDppDeviceType5() | CFilePage |
OnBnClickedRadioDppDeviceType6() | CFilePage |
OnCancel() | CFilePage | [virtual]
OnCbnSelchangeOptComboResc() | CFilePage |
OnCbnSelchangeReaddetectorconfigcombo() | CFilePage |
OnCbnSelendokReaddetectorconfigcombo() | CFilePage |
OnHelp() | CFilePage |
OnHelpInfo(HELPINFO *pHelpInfo) | CFilePage |
OnInitDialog() | CFilePage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CFilePage | [virtual]
OnStnClickedStaticReadConfig() | CFilePage |
OnStnClickedStaticSaveConfig() | CFilePage |
OnTimer(UINT nIDEvent) | CFilePage |
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
PreTranslateMessage(MSG *pMsg) | CFilePage | [virtual]
ReadAmptekDetectorConfigNames() | CFilePage |
ReadConfig() | CFilePage |
ReadConfigFromAmptek_NP(CString strFilename, CString strKeyName) | CFilePage |
SaveConfigString() | CFilePage |
SelectRadioDppDeviceType(int DeviceType) | CFilePage |
SetCheckDP5DxGains() | CFilePage |
SetCheckPc5Present() | CFilePage |
SetDppDeviceType(int DeviceType) | CFilePage |
~CCfgPropPage() | CCfgPropPage |
~CFilePage() | CFilePage |
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CGainPzPage Member List
This is the complete list of members for CGainPzPage, including all inherited members.
bEnableNewRESL | CGainPzPage |
BuildToolTips() | CGainPzPage |
CboTextVis(int nIdCbox, int nIdEdit, BOOL isText) | CGainPzPage |
CboUpdate(int nID_dci) | CGainPzPage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CGainPzPage() | CGainPzPage |
CheckMCA8000D_FineGain() | CGainPzPage |
dblGAIF_Max | CGainPzPage |
dblGAIF_Min | CGainPzPage |
DoDataExchange(CDataExchange *pDX) | CGainPzPage | [protected, virtual]
DppGain | CGainPzPage |
InitCombo(HWND hDlg, DP5_CONFIGURATION cfg, int nID) | CGainPzPage |
InitControls() | CGainPzPage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CGainPzPage |
isCComboBox(int nID) | CGainPzPage |
isCEditBox(int nID) | CGainPzPage |
m_CoarseGain_GAIA_index | CGainPzPage |
m_CoarseGain_GAIA_value | CGainPzPage |
m_GainAdvancedLabel | CGainPzPage |
m_GainPzPageLabel | CGainPzPage |
m_GainStandardLabel | CGainPzPage |
m_PowerHvWarning | CGainPzPage |
m_ToolTip | CGainPzPage | [protected]
OnBnClickedButtonCoarseFineToTotal() | CGainPzPage |
OnBnClickedButtonFineGainEnter() | CGainPzPage |
OnBnClickedButtonTotalToCoarseFine() | CGainPzPage |
OnCbnSelchangeOptComboAinp() | CGainPzPage |
OnCbnSelchangeOptComboGaia() | CGainPzPage |
OnCbnSelchangeOptComboGaia2() | CGainPzPage |
OnCbnSelchangeOptComboGainSelect() | CGainPzPage |
OnCbnSelchangeOptComboInof() | CGainPzPage |
OnCbnSelchangeOptComboPapz() | CGainPzPage |
OnCbnSelchangeOptComboResl() | CGainPzPage |
OnCbnSelchangeOptComboResl2() | CGainPzPage |
OnEnChangeOptTextGaif() | CGainPzPage |
OnEnChangeOptTextGain() | CGainPzPage |
OnEnChangeOptTextInof() | CGainPzPage |
OnEnChangeOptTextPapz() | CGainPzPage |
OnEnChangeOptTextResl() | CGainPzPage |
OnHelp() | CGainPzPage |
OnHelpInfo(HELPINFO *pHelpInfo) | CGainPzPage |
OnInitDialog() | CGainPzPage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CGainPzPage | [virtual]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
PreTranslateMessage(MSG *pMsg) | CGainPzPage | [virtual]
SetDetResetValues(int nID, BOOL is80MHz) | CGainPzPage |
SetHvPowerWarning() | CGainPzPage |
ShowMCA8000D_Controls(int iShowWin) | CGainPzPage |
TextUpdate(int nID_dci) | CGainPzPage |
UpdateGainValue() | CGainPzPage |
UpdateOptComboGAIA() | CGainPzPage |
~CCfgPropPage() | CCfgPropPage |
~CGainPzPage() | CGainPzPage |
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CINI Member List
This is the complete list of members for CINI, including all inherited members.
CINI(CString strFile) | CINI |
CINI() | CINI | [inline]
DeleteKey(CString strKey, CString strSection) | CINI |
DeleteSection(CString strSection) | CINI |
getKeyValue(CString strKey, CString strSection) | CINI |
getSectionData(CString strSection) | CINI |
getSectionNames() | CINI |
sectionExists(CString strSection) | CINI |
setINIFileName(CString strINIFile) | CINI |
setKey(CString strValue, CString strKey, CString strSection) | CINI |
~CINI() | CINI | [virtual]
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CIniEx Member List
This is the complete list of members for CIniEx, including all inherited members.
CIniEx(void) | CIniEx
~CIniEx(void) | CIniEx
Generated on Thu Sep 21 2017 15:25:23 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CIniUtil Member List
This is the complete list of members for CIniUtil, including all inherited members.
CIniUtil(void) | CIniUtil
ConvertCmdListToCString(CStringList *strCmdList, BOOL AddNewLines, BOOL RemoveComments) | CIniUtil
DeleteDP5Key(CString m_strINIFile, CString m_strSection, CString cmdKey) | CIniUtil
GetDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString *cmdData, CString *Comments) | CIniUtil
GetDP5Section(CString m_strINIFile, CString m_strSection, CStringList *m_strListDP5section) | CIniUtil
GetMsIniItem(CString strCmdIn) | CIniUtil
ini | CIniUtil
SaveDP5Data(CString m_strINIFile, CString m_strSection, CString cmdKey, CString cmdData, CString Comments) | CIniUtil
~CIniUtil(void) | CIniUtil
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CLabel Member List
This is the complete list of members for CLabel, including all inherited members.
CLabel() | CLabel |
CtlColor(CDC *pDC, UINT nCtlColor) | CLabel | [protected]
FlashBackground(BOOL bActivate) | CLabel |
FlashText(BOOL bActivate) | CLabel |
LastBkColor | CLabel |
LastTextColor | CLabel |
m_bLink | CLabel | [protected]
m_bState | CLabel | [protected]
m_bTimer | CLabel | [protected]
m_crText | CLabel | [protected]
m_font | CLabel | [protected]
m_hBrush | CLabel | [protected]
m_hCursor | CLabel | [protected]
m_hwndBrush | CLabel | [protected]
m_lf | CLabel | [protected]
m_strText | CLabel | [protected]
m_Type | CLabel | [protected]
NullBkColor | CLabel |
NullSet | CLabel |
NullTextColor | CLabel |
OnLButtonDown(UINT nFlags, CPoint point) | CLabel | [protected]
OnSetCursor(CWnd *pWnd, UINT nHitTest, UINT message) | CLabel | [protected]
OnTimer(UINT nIDEvent) | CLabel | [protected]
ReconstructFont() | CLabel | [protected]
SetBkColor(COLORREF crBkgnd) | CLabel |
SetBorder(BOOL bSet) | CLabel |
SetFontBold(BOOL bBold) | CLabel |
SetFontItalic(BOOL bSet) | CLabel |
SetFontName(const CString &strFont) | CLabel |
SetFontSize(int nSize) | CLabel |
SetFontUnderline(BOOL bSet) | CLabel |
SetLastColor() | CLabel |
SetLink(BOOL bLink) | CLabel |
SetLinkCursor(HCURSOR hCursor) | CLabel |
SetNullColor() | CLabel |
SetSunken(BOOL bSet) | CLabel |
SetText(const CString &strText) | CLabel |
SetTextColor(COLORREF crText) | CLabel |
~CLabel() | CLabel | [virtual]
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CMSecTimer Member List
This is the complete list of members for CMSecTimer, including all inherited members.
CMSecTimer(void) | CMSecTimer
msTimeDiff(DWORD msStartTime, DWORD msTestTime) | CMSecTimer
msTimeExpired(DWORD msStartTime, DWORD msDelay) | CMSecTimer
msTimer(DWORD msDelay) | CMSecTimer
~CMSecTimer(void) | CMSecTimer
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CMcaPage Member List
This is the complete list of members for CMcaPage, including all inherited members.
BuildToolTips() | CMcaPage |
CboTextVis(int nIdCbox, int nIdEdit, BOOL isText) | CMcaPage |
CboUpdate(int nID_dci) | CMcaPage |
CboUpdateDMCA(int nID_dci, int nID) | CMcaPage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CMcaPage() | CMcaPage |
DoDataExchange(CDataExchange *pDX) | CMcaPage | [protected, virtual]
InitControls() | CMcaPage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CMcaPage |
InitDlgItemDMCA(HWND hDlg, DP5_CONFIGURATION cfg, int cboDP5CtrlID) | CMcaPage |
isCComboBox(int nID) | CMcaPage |
isCEditBox(int nID) | CMcaPage |
isDMcaControls | CMcaPage |
m_McaAdvancedLabel | CMcaPage |
m_McaPageLabel | CMcaPage |
m_McaStandardLabel | CMcaPage |
m_ToolTip | CMcaPage | [protected]
MoveCtrl(int nID, long deltaX, long deltaY) | CMcaPage |
MoveCtrlEx(int nID, int nID_Left, int nID_Top) | CMcaPage |
OnBnClickedPresetcountcursorbutton() | CMcaPage |
OnBnClickedPresetcountroibutton() | CMcaPage |
OnCbnSelchangeOptComboDmcaGaia() | CMcaPage |
OnCbnSelchangeOptComboDmcaPure() | CMcaPage |
OnCbnSelchangeOptComboGate() | CMcaPage |
OnCbnSelchangeOptComboMcac() | CMcaPage |
OnCbnSelchangeOptComboMcae() | CMcaPage |
OnCbnSelchangeOptComboMcas() | CMcaPage |
OnCbnSelchangeOptComboPdmd() | CMcaPage |
OnCbnSelchangeOptComboPrec() | CMcaPage |
OnCbnSelchangeOptComboPrel() | CMcaPage |
OnCbnSelchangeOptComboPrer() | CMcaPage |
OnCbnSelchangeOptComboPret() | CMcaPage |
OnCbnSelchangeOptComboSoff() | CMcaPage |
OnCbnSelchangeOptComboTlld() | CMcaPage |
OnEnChangeOptTextMcsh() | CMcaPage |
OnEnChangeOptTextMcsl() | CMcaPage |
OnEnChangeOptTextMcst() | CMcaPage |
OnEnChangeOptTextPrch() | CMcaPage |
OnEnChangeOptTextPrcl() | CMcaPage |
OnEnChangeOptTextPrec() | CMcaPage |
OnEnChangeOptTextPrel() | CMcaPage |
OnEnChangeOptTextPrer() | CMcaPage |
OnEnChangeOptTextPret() | CMcaPage |
OnEnChangeOptTextSoff() | CMcaPage |
OnEnChangeOptTextThsl() | CMcaPage |
OnEnChangeOptTextTlld() | CMcaPage |
OnHelp() | CMcaPage |
OnHelpInfo(HELPINFO *pHelpInfo) | CMcaPage |
OnInitDialog() | CMcaPage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CMcaPage | [virtual]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
PreTranslateMessage(MSG *pMsg) | CMcaPage | [virtual]
ShowMCA8000D_Controls(int iShowWin) | CMcaPage |
TextUpdate(int nID_dci) | CMcaPage |
~CCfgPropPage() | CCfgPropPage |
~CMcaPage() | CMcaPage |
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CMiscPage Member List
This is the complete list of members for CMiscPage, including all inherited members.
BuildToolTips() | CMiscPage |
CboTextVis(int nIdCbox, int nIdEdit, BOOL isText) | CMiscPage |
CboUpdate(int nID_dci) | CMiscPage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CMiscPage() | CMiscPage |
DoDataExchange(CDataExchange *pDX) | CMiscPage | [protected, virtual]
EnableControl(int nID, BOOL Enable=TRUE, BOOL isVisible=TRUE) | CMiscPage |
EnableScaControls(BOOL Enable=TRUE, BOOL isVisible=TRUE) | CMiscPage |
GetCheckBOOL(int nID) | CMiscPage |
GetComboIndex(int nID) | CMiscPage |
GetComboValue(int nID) | CMiscPage |
InitAuxControls() | CMiscPage |
InitControls() | CMiscPage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CMiscPage |
isCComboBox(int nID) | CMiscPage |
isCEditBox(int nID) | CMiscPage |
m_MiscAdvancedLabel | CMiscPage |
m_MiscPageLabel | CMiscPage |
m_MiscQuicksetLabel | CMiscPage |
m_ToolTip | CMiscPage | [protected]
OnBnClickedButtonOutputQuickset1() | CMiscPage |
OnBnClickedButtonOutputQuickset2() | CMiscPage |
OnBnClickedButtonOutputQuickset3() | CMiscPage |
OnBnClickedButtonPreviewSca() | CMiscPage |
OnBnClickedButtonScaDefaults() | CMiscPage |
OnBnClickedCheckEnableSca() | CMiscPage |
OnCbnSelchangeComboOutputLevel() | CMiscPage |
OnCbnSelchangeComboScaIndex() | CMiscPage |
OnCbnSelchangeComboScaPulseWidth() | CMiscPage |
OnCbnSelchangeOptComboAuo1() | CMiscPage |
OnCbnSelchangeOptComboAuo2() | CMiscPage |
OnCbnSelchangeOptComboCon1() | CMiscPage |
OnCbnSelchangeOptComboCon2() | CMiscPage |
OnCbnSelchangeOptComboDaco() | CMiscPage |
OnCbnSelchangeOptComboGped() | CMiscPage |
OnCbnSelchangeOptComboGpga() | CMiscPage |
OnCbnSelchangeOptComboGpin() | CMiscPage |
OnCbnSelchangeOptComboGpmc() | CMiscPage |
OnCbnSelchangeOptComboGpme() | CMiscPage |
OnCbnSelchangeOptComboScoe() | CMiscPage |
OnCbnSelchangeOptComboScog() | CMiscPage |
OnCbnSelchangeOptComboScot() | CMiscPage |
OnCbnSelchangeOptComboTpmo() | CMiscPage |
OnCbnSelchangeOptComboVolu() | CMiscPage |
OnEnChangeEditHighThreshold() | CMiscPage |
OnEnChangeEditLowThreshold() | CMiscPage |
OnEnChangeOptTextAuo1() | CMiscPage |
OnEnChangeOptTextAuo2() | CMiscPage |
OnEnChangeOptTextDacf() | CMiscPage |
OnEnChangeOptTextDaco() | CMiscPage |
OnEnChangeOptTextGpin() | CMiscPage |
OnHelp() | CMiscPage |
OnHelpInfo(HELPINFO *pHelpInfo) | CMiscPage |
OnInitDialog() | CMiscPage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CMiscPage | [virtual]
OnSetPageFocus(UINT wParam, LONG lParam) | CMiscPage |
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
OutputQuickset(CString strDAC, CString strOutputOffset, CString strAUX2, CString strAUX1, CString strCONN1, CString strCONN2) | CMiscPage |
PreTranslateMessage(MSG *pMsg) | CMiscPage | [virtual]
SetAuxList(int nAuxID, BOOL bNeedsNewAux) | CMiscPage |
SetCboItem(int nID, CString strVal) | CMiscPage |
SetCheckBOOL(int nID, BOOL isChecked) | CMiscPage |
SetSCAComboIndex(int nID, CString strValue) | CMiscPage |
ShowMCA8000D_Controls(int iShowWin) | CMiscPage |
TextUpdate(int nID_dci) | CMiscPage |
UpdateSCAControls() | CMiscPage |
~CCfgPropPage() | CCfgPropPage |
~CMiscPage() | CMiscPage |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CMsgBox Member List
This is the complete list of members for CMsgBox, including all inherited members.
CMsgBox(CWnd *pParent=NULL) | CMsgBox |
DoDataExchange(CDataExchange *pDX) | CMsgBox | [protected, virtual]
IDD enum value | CMsgBox |
m_strDelimiter | CMsgBox |
m_strMessage | CMsgBox |
m_strTitle | CMsgBox |
OnInitDialog() | CMsgBox | [virtual]
SetMessage(CString strMsg, CString m_strDelimiter) | CMsgBox |
~CMsgBox() | CMsgBox | [virtual]
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CNetFinder Member List
This is the complete list of members for CNetFinder, including all inherited members.
AddEntry(NETDISPLAY_ENTRY *pEntry, unsigned char *buffer, UINT destPort) | CNetFinder
AlertByteToCOLORREF(unsigned char alert_level) | CNetFinder
AlertEntryToCOLORREF(NETDISPLAY_ENTRY *pEntry) | CNetFinder
CNetFinder(void) | CNetFinder
DppEntries | CNetFinder
DppEntryIdx | CNetFinder
DppFound | CNetFinder
DppSockAddr | CNetFinder
EntryToStr(NETDISPLAY_ENTRY *pEntry) | CNetFinder
EntryToStrRS232(NETDISPLAY_ENTRY *pEntry, CString strPort) | CNetFinder
EntryToStrUSB(NETDISPLAY_ENTRY *pEntry, CString strPort) | CNetFinder
FindEntry(unsigned long SockAddr) | CNetFinder
InitAllEntries() | CNetFinder
InitEntry(NETDISPLAY_ENTRY *pEntry) | CNetFinder
LastEntry | CNetFinder
m_rand | CNetFinder
SockAddr_ByteToInAddr(unsigned char *ip) | CNetFinder
SockAddr_ByteToStr(unsigned char *ip) | CNetFinder
SockAddr_ByteToULong(unsigned char *ip) | CNetFinder
SockAddr_DlgToStr(CDialog *dlg, int id1, int id2, int id3, int id4) | CNetFinder
SockAddr_InAddrToStr(in_addr inSockAddr) | CNetFinder
SockAddr_StrToInAddr(CString strSockAddr) | CNetFinder
SockAddr_StrToULong(CString strSockAddr) | CNetFinder
SockAddr_ULongToInAddr(unsigned long SockAddr) | CNetFinder
SockAddr_ULongToStr(unsigned long SockAddr) | CNetFinder
SockPort_DlgToUINT(CDialog *dlg, int id1) | CNetFinder
~CNetFinder(void) | CNetFinder
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CParsePacket Member List
This is the complete list of members for CParsePacket, including all inherited members.
CParsePacket(void) | CParsePacket
DppState | CParsePacket
ParsePacket(unsigned char P[], Packet_In *PIN) | CParsePacket
ParsePacketStatus(unsigned char P[], Packet_In *PIN) | CParsePacket
PID2_TextToString(string strPacketSource, unsigned char PID2) | CParsePacket
~CParsePacket(void) | CParsePacket
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CPlot Member List
This is the complete list of members for CPlot, including all inherited members.
CPlot(void) | CPlot |
m_xCursorData | CPlot |
m_xCursorPos | CPlot |
m_xMax | CPlot |
m_xMin | CPlot |
m_xPixels | CPlot |
m_yCursorPos | CPlot |
m_yMax | CPlot |
m_yMin | CPlot |
m_yPixels | CPlot |
MovePlot(int xmin, int xmax, unsigned long ymin, unsigned long ymax) | CPlot |
PixelToPosition(int pixel) | CPlot | [inline]
PositionToPixel(double pos) | CPlot | [inline]
~CPlot(void) | CPlot |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CPlotCanvas Member List
This is the complete list of members for CPlotCanvas, including all inherited members.
ClearTrace() | CPlotCanvas |
CPlotCanvas() | CPlotCanvas |
CursorPosition | CPlotCanvas |
DataAcq(long DataBuffer[8192], int NumChan) | CPlotCanvas |
DrawCursor() | CPlotCanvas |
DrawCursor(CDC *dcMem, long YPlotBufferIn[8192], bool EraseCursor) | CPlotCanvas |
hasBackground | CPlotCanvas |
Invalidate() | CPlotCanvas |
m_crCursorColor | CPlotCanvas |
m_crDisplayBGColor | CPlotCanvas |
m_crPlotColor | CPlotCanvas |
m_crTextBGColor | CPlotCanvas |
m_crTextFGColor | CPlotCanvas |
OldCursorPosition | CPlotCanvas |
OldPlotCursor | CPlotCanvas |
OnEraseBkgnd(CDC *pDC) | CPlotCanvas | [protected]
OnLButtonDown(UINT nFlags, CPoint point) | CPlotCanvas |
OnPaint() | CPlotCanvas | [protected]
OnRefreshBkgnd() | CPlotCanvas |
OptPlotType | CPlotCanvas |
OptScaleType | CPlotCanvas |
PersistenceMode | CPlotCanvas |
PlotCursor | CPlotCanvas |
PlotTrace(long YPlotBufferIn[8192]) | CPlotCanvas |
SetCursorPosition(int CursorPos) | CPlotCanvas |
SetPersistenceMode(bool Persistence) | CPlotCanvas |
XPlotMAX | CPlotCanvas |
YPlotBuffer | CPlotCanvas |
YPlotMAX | CPlotCanvas |
~CPlotCanvas() | CPlotCanvas | [virtual]
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CPowerPage Member List
This is the complete list of members for CPowerPage, including all inherited members.
BuildToolTips() | CPowerPage |
CboTextVis(int nIdCbox, int nIdEdit, BOOL isText) | CPowerPage |
CboUpdate(int nID_dci) | CPowerPage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CPowerPage() | CPowerPage |
DoDataExchange(CDataExchange *pDX) | CPowerPage | [protected, virtual]
Init_PAPS_Controls() | CPowerPage |
InitControls() | CPowerPage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CPowerPage |
isCComboBox(int nID) | CPowerPage |
isCEditBox(int nID) | CPowerPage |
isHVSignInString(CString strHV) | CPowerPage |
isHVSignPositive(CString strHV) | CPowerPage |
m_PowerAdvancedLabel | CPowerPage |
m_PowerHvSign1 | CPowerPage |
m_PowerHvSign2 | CPowerPage |
m_PowerHvWarning | CPowerPage |
m_PowerPageLabel | CPowerPage |
m_PowerStandardLabel | CPowerPage |
m_ToolTip | CPowerPage | [protected]
OnBnClickedRadioHvSign1() | CPowerPage |
OnBnClickedRadioHvSign2() | CPowerPage |
OnCbnSelchangeOptComboBoot() | CPowerPage |
OnCbnSelchangeOptComboHvse() | CPowerPage |
OnCbnSelchangeOptComboPaps() | CPowerPage |
OnCbnSelchangeOptComboTecs() | CPowerPage |
OnEnChangeOptTextHvse() | CPowerPage |
OnEnChangeOptTextTecs() | CPowerPage |
OnHelp() | CPowerPage |
OnHelpInfo(HELPINFO *pHelpInfo) | CPowerPage |
OnInitDialog() | CPowerPage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CPowerPage | [virtual]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
PreTranslateMessage(MSG *pMsg) | CPowerPage | [virtual]
SetHvPowerWarning() | CPowerPage |
SetHVSign(BOOL isPOS) | CPowerPage |
ShowMCA8000D_Controls(int iShowWin) | CPowerPage |
TextUpdate(int nID_dci) | CPowerPage |
~CCfgPropPage() | CCfgPropPage |
~CPowerPage() | CPowerPage |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CRoi Member List
This is the complete list of members for CRoi, including all inherited members.
AddRoi(int st, int en) | CRoi | [inline]
AtChannel(int chan) | CRoi |
CalculateRoiInfo(double *buffer) | CRoi |
Clear(void) | CRoi |
CopyRoi(CRoi &src) | CRoi | [inline]
CRoi() | CRoi | [inline]
Insert(int i, int st, int en) | CRoi |
InsertSorted(int st, int en) | CRoi |
m_count | CRoi |
m_selectIndex | CRoi |
Remove(int i) | CRoi |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CRoiEntry Member List
This is the complete list of members for CRoiEntry, including all inherited members.
CRoiEntry() | CRoiEntry | [inline]
CRoiEntry(int st, int en) | CRoiEntry | [inline]
m_centroid | CRoiEntry |
m_end | CRoiEntry |
m_fwhm | CRoiEntry |
m_leftWidth | CRoiEntry |
m_max | CRoiEntry |
m_net | CRoiEntry |
m_rightWidth | CRoiEntry |
m_start | CRoiEntry |
m_status | CRoiEntry |
m_total | CRoiEntry |
m_uncertainty | CRoiEntry |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSCommon Member List
This is the complete list of members for CSCommon, including all inherited members.
baud_rate | CSCommon |
ComPort | CSCommon |
CreateDP5Cfg() | CSCommon |
CSCommon(void) | CSCommon |
CtrlUtil | CSCommon |
CurrentInterface | CSCommon |
DP5CfgCmd(DP5_CMD_INDEX idxDP5Cfg, CString Command, int ListCtrlID, int TextCtrlID, DP5_CTRL_TYPE CtrlType, DP5_CTRL_GROUP CtrlGroup, CString Description, CString Units, CString Limits) | CSCommon |
Dp5CmdList | CSCommon |
DP5Proto | CSCommon |
DP5Stat | CSCommon |
DppCommStatusInd | CSCommon |
DppCommStatusIndOld | CSCommon |
DppConfig | CSCommon |
DppWinUSB | CSCommon |
FindCommand | CSCommon |
FindCtrlID | CSCommon |
Get(LPCTSTR profile, LPCTSTR entry, LPCTSTR def) | CSCommon |
Get(LPCTSTR profile, LPCTSTR entry, int def) | CSCommon |
GetDeviceNameFromVal(int DeviceTypeVal) | CSCommon | [inline]
HaveConfig | CSCommon |
HwCfgDP5 | CSCommon |
HwCfgDP5Out | CSCommon |
HwCfgExReady | CSCommon |
HwCfgReady | CSCommon |
hWnd_Main | CSCommon |
isDppConnected | CSCommon |
isDppFound | CSCommon |
isPlotLine | CSCommon |
isScaleLog | CSCommon |
LoadProfile() | CSCommon |
m_DP5Cfg | CSCommon |
m_DppPort | CSCommon |
m_DppSck | CSCommon |
m_plot | CSCommon |
m_Spectrum | CSCommon |
NetfinderActive | CSCommon |
ParsePkt | CSCommon |
plot | CSCommon |
profile | CSCommon |
profileCls | CSCommon |
Put(LPCTSTR profile, LPCTSTR entry, LPCTSTR def) | CSCommon |
Put(LPCTSTR profile, LPCTSTR entry, int def) | CSCommon |
ReloadCfg | CSCommon |
SaveProfile() | CSCommon |
sca | CSCommon |
SCAEnabled | CSCommon |
scafn | CSCommon |
SndCmd | CSCommon |
SockAddr | CSCommon |
spectraList | CSCommon |
strHelpFilePath | CSCommon |
strSockAddr | CSCommon |
WinusbNotify | CSCommon |
~CSCommon(void) | CSCommon |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSProfile Member List
This is the complete list of members for CSProfile, including all inherited members.
baud_rate | CSProfile |
ComPort | CSProfile |
CSProfile() | CSProfile | [inline]
CurrentInterface | CSProfile |
data_refresh | CSProfile |
device_type | CSProfile |
profile | CSProfile |
sca | CSProfile |
SCAEnabled | CSProfile |
scafn | CSProfile |
SendCoarseFineGain | CSProfile |
SockAddr | CSProfile |
strDevice | CSProfile |
~CSProfile() | CSProfile | [inline]
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSca Member List
This is the complete list of members for CSca, including all inherited members.
CSca(void) | CSca
CurIndex | CSca
HaveCurIndex | CSca
HaveScaUpdate | CSca
High | CSca
Index | CSca
Low | CSca
Output | CSca
PulseWidth | CSca
strIniFilename | CSca
~CSca(void) | CSca
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CScaFn Member List
This is the complete list of members for CScaFn, including all inherited members.
CFG_SECTION | CScaFn
CScaFn(void) | CScaFn
DeleteIniSettingEx(CString strFilename, CString strSection, CString strKey) | CScaFn
GetFromIniEx(CString strFilename, CString strSection, CString strKey, CString strDefault) | CScaFn
GetNextCMD(CString strCMDList) | CScaFn
GetSCASettingsINI(CSca *sca, long Index) | CScaFn
GetSCASetupINI(CSca *sca) | CScaFn
InitSCA(CSca *sca, long lChannels=8191, BOOL bTest=FALSE) | CScaFn
ReadSCASetting(CSca *sca, CString strSCAInfo) | CScaFn
SaveSCASettingsINI(CSca sca, long Index) | CScaFn
SaveSCASetupINI(CSca sca) | CScaFn
SaveToIniEx(CString strFilename, CString strSection, CString strKey, CString strData) | CScaFn
SCA_SECTION | CScaFn
SCACfgParser(CSca *sca, CString strSCASettings) | CScaFn
SCASettingsString(CSca sca, long Index, BOOL bDppMsg=TRUE) | CScaFn
SCASetupString(CSca sca, BOOL bDppMsg=TRUE) | CScaFn
SCAString(CString strCmd, CString strData, BOOL bDppMsg=TRUE) | CScaFn
SCAStringALL(CSca sca, BOOL bDppMsg=TRUE) | CScaFn
SCAStringALLDisplay(CSca sca) | CScaFn
SplitData(CString strData, CString *varValue, CString strDefault) | CScaFn
varValueToIndex(CString varData) | CScaFn
~CScaFn(void) | CScaFn
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSelectDP5 Member List
This is the complete list of members for CSelectDP5, including all inherited members.
bTypeInIPAddress | CSelectDP5 |
cboComPort | CSelectDP5 |
ClearNetFinderStatus(int idxEntry) | CSelectDP5 |
ClearNetFinderStatusAll() | CSelectDP5 |
ComPortEnum() | CSelectDP5 |
CopyTextToClip(CString strTitle, CString strDesc) | CSelectDP5 |
CSelectDP5() | CSelectDP5 |
DataIn | CSelectDP5 |
DestroyWindow() | CSelectDP5 | [virtual]
DoDataExchange(CDataExchange *pDX) | CSelectDP5 | [protected, virtual]
EnableCommFunctions(int ControlGroup) | CSelectDP5 |
FindDpp | CSelectDP5 |
FindDppRS232 | CSelectDP5 |
FindDppUSB | CSelectDP5 |
GetComPortID() | CSelectDP5 |
IpSelectAddr | CSelectDP5 |
IpSelectBtn | CSelectDP5 |
lblDppFound | CSelectDP5 |
lblNetFinder | CSelectDP5 |
m_bModified | CSelectDP5 |
m_DP5_Status | CSelectDP5 |
m_nTmrRS232Elapse | CSelectDP5 |
m_nTmrRS232EventId | CSelectDP5 |
m_nTmrRS232Id | CSelectDP5 |
m_PrevOwner | CSelectDP5 |
m_SpectrumRefreshTimeCtrl | CSelectDP5 |
m_SpinSelectDevice | CSelectDP5 |
m_ToolTip | CSelectDP5 | [protected]
m_TypeInIPAddressCheck | CSelectDP5 |
OnBnClickedButtonClipboardCopy() | CSelectDP5 |
OnBnClickedButtonCloseDevice() | CSelectDP5 |
OnBnClickedButtonClosePort() | CSelectDP5 |
OnBnClickedButtonCountDevices() | CSelectDP5 |
OnBnClickedButtonFindDp5Ip() | CSelectDP5 |
OnBnClickedButtonFindUsbDevice() | CSelectDP5 |
OnBnClickedButtonIpSelect1() | CSelectDP5 |
OnBnClickedButtonIpSelect2() | CSelectDP5 |
OnBnClickedButtonIpSelect3() | CSelectDP5 |
OnBnClickedButtonIpSelect4() | CSelectDP5 |
OnBnClickedButtonOpenPort() | CSelectDP5 |
OnBnClickedButtonSerialReqData() | CSelectDP5 |
OnBnClickedButtonSpectrumRefreshDefault() | CSelectDP5 |
OnBnClickedCheckTypeIpAddress() | CSelectDP5 |
OnBnClickedConnectOK() | CSelectDP5 |
OnBnClickedOk() | CSelectDP5 |
OnBnClickedRadioCommtype1() | CSelectDP5 |
OnBnClickedRadioCommtype2() | CSelectDP5 |
OnBnClickedRadioCommtype3() | CSelectDP5 |
OnCbnSelchangeComboComport() | CSelectDP5 |
OnComm() | CSelectDP5 |
OnCommunication(UINT, LONG) | CSelectDP5 |
OnDeltaposSpinSelectDevice(NMHDR *pNMHDR, LRESULT *pResult) | CSelectDP5 |
OnEnChangeSpectrumRefreshTime() | CSelectDP5 |
OnHelpInfo(HELPINFO *pHelpInfo) | CSelectDP5 |
OnInitDialog() | CSelectDP5 | [virtual]
OnOK() | CSelectDP5 | [virtual]
OnReceive(UINT, LONG) | CSelectDP5 |
OnStnClickedStaticNetfinder1() | CSelectDP5 |
OnStnClickedStaticNetfinder2() | CSelectDP5 |
OnStnClickedStaticNetfinder3() | CSelectDP5 |
OnStnClickedStaticNetfinder4() | CSelectDP5 |
OnTimer(UINT nIDEvent) | CSelectDP5 |
ReceivePacket() | CSelectDP5 |
ReqDataStatus() | CSelectDP5 |
ReqDataStatusSock(unsigned long DppAddr) | CSelectDP5 |
SendBroadcast(BOOL NewRand) | CSelectDP5 |
SetComPortID(int iComPort) | CSelectDP5 |
SetDataRcvTimer(long Bytes) | CSelectDP5 |
SetModified(BOOL bChanged) | CSelectDP5 |
UpdateNetfinderIpAddr(unsigned long IpAddr) | CSelectDP5 |
UpdateNetFinderStatus(CString strStatus, COLORREF rgbConnect, int idxEntry) | CSelectDP5 |
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSendCommand Member List
This is the complete list of members for CSendCommand, including all inherited members.
AsciiCmdUtil | CSendCommand
CSendCommand(void) | CSendCommand
DP5_CMD(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd) | CSendCommand
DP5_CMD_Config(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, CONFIG_OPTIONS CfgOptions) | CSendCommand
DP5_CMD_Data(unsigned char Buffer[], TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[]) | CSendCommand
POUT_Buffer(Packet_Out POUT, unsigned char Buffer[]) | CSendCommand
TestPacketCkSumOK(unsigned char Data[]) | CSendCommand
~CSendCommand(void) | CSendCommand
Generated on Thu Sep 21 2017 15:25:26 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CShapingPage Member List
This is the complete list of members for CShapingPage, including all inherited members.
b80MHzModeCfg_old | CShapingPage |
BLRQuickSet(CString strMode, CString strDown, CString strUp) | CShapingPage |
BuildToolTips() | CShapingPage |
CboTextVis(int nIdCbox, int nIdEdit, BOOL isText) | CShapingPage |
CboUpdate(int nID_dci) | CShapingPage |
CCfgPropPage() | CCfgPropPage |
CCfgPropPage(UINT nIDTemplate, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CCfgPropPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0, UINT nIDHeaderTitle=0, UINT nIDHeaderSubTitle=0) | CCfgPropPage |
CShapingPage() | CShapingPage |
DisplayBlrMode() | CShapingPage |
DoDataExchange(CDataExchange *pDX) | CShapingPage | [protected, virtual]
InitBlrMode() | CShapingPage |
InitComboFromText(HWND hDlg, DP5_CONFIGURATION cfg, int nID) | CShapingPage |
InitControls() | CShapingPage |
InitDlgItem(HWND hDlg, DP5_CONFIGURATION cfg) | CShapingPage |
InitFastPeakCombo() | CShapingPage |
isCComboBox(int nID) | CShapingPage |
isCEditBox(int nID) | CShapingPage |
lblFPGAClk | CShapingPage |
m_FastPeakCombo | CShapingPage |
m_RiseCombo | CShapingPage |
m_ShapingAdvancedLabel | CShapingPage |
m_ShapingPageLabel | CShapingPage |
m_ShapingStandardLabel | CShapingPage |
m_ToolTip | CShapingPage | [protected]
m_TopCombo | CShapingPage |
OnBnClickedBlrquickslowbutton2() | CShapingPage |
OnCbnSelchangeOptComboBlrm() | CShapingPage |
OnCbnSelchangeOptComboClck() | CShapingPage |
OnCbnSelchangeOptComboCusp() | CShapingPage |
OnCbnSelchangeOptComboPure() | CShapingPage |
OnCbnSelchangeOptComboRtde() | CShapingPage |
OnCbnSelchangeOptComboSctc() | CShapingPage |
OnCbnSelchangeOptComboTpfa() | CShapingPage |
OnCbnSelchangeRisecombo() | CShapingPage |
OnCbnSelchangeTopcombo() | CShapingPage |
OnEnChangeOptTextBlrd() | CShapingPage |
OnEnChangeOptTextBlru() | CShapingPage |
OnEnChangeOptTextCusp() | CShapingPage |
OnEnChangeOptTextPure() | CShapingPage |
OnEnChangeOptTextRtds() | CShapingPage |
OnEnChangeOptTextRtdt() | CShapingPage |
OnEnChangeOptTextSctc() | CShapingPage |
OnEnChangeOptTextTfla() | CShapingPage |
OnEnChangeOptTextThfa() | CShapingPage |
OnEnChangeOptTextTpea() | CShapingPage |
OnHelp() | CShapingPage |
OnHelpInfo(HELPINFO *pHelpInfo) | CShapingPage |
OnInitDialog() | CShapingPage | [virtual]
OnMouseMove(UINT nFlags, CPoint point) | CCfgPropPage | [protected]
OnSetActive() | CShapingPage | [virtual]
OnToolTipText(UINT, NMHDR *pNMHDR, LRESULT *pResult) | CCfgPropPage | [protected]
PreTranslateMessage(MSG *pMsg) | CShapingPage | [virtual]
RiseTop | CShapingPage |
SetCboItem(int nID, CString strVal) | CShapingPage |
ShowMCA8000D_Controls(int iShowWin) | CShapingPage |
TextUpdate(int nID_dci) | CShapingPage |
~CCfgPropPage() | CCfgPropPage |
~CShapingPage() | CShapingPage |
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSpectraList Member List
This is the complete list of members for CSpectraList, including all inherited members.
CSpectraList(void) | CSpectraList
m_currentSpectrum | CSpectraList
~CSpectraList(void) | CSpectraList
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSpectrum Member List
This is the complete list of members for CSpectrum, including all inherited members.
CSpectrum(void) | CSpectrum
m_attr | CSpectrum
m_roi | CSpectrum
PosToChannel(double pos) | CSpectrum
PosToChannel(int pos) | CSpectrum
~CSpectrum(void) | CSpectrum
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CSpectrumAttr Member List
This is the complete list of members for CSpectrumAttr, including all inherited members.
contourColor | CSpectrumAttr
contourWidth | CSpectrumAttr
CSpectrumAttr(void) | CSpectrumAttr
description | CSpectrumAttr
expressionText | CSpectrumAttr
file | CSpectrumAttr
gainIndex | CSpectrumAttr
generalNotes | CSpectrumAttr
isExpression | CSpectrumAttr
notesNotes | CSpectrumAttr
printNotes | CSpectrumAttr
SetDefaultAttr(void) | CSpectrumAttr
systemNotes | CSpectrumAttr
tag | CSpectrumAttr
ValidateTag(void) | CSpectrumAttr
~CSpectrumAttr(void) | CSpectrumAttr
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CTrapKeyComboBox Member List
This is the complete list of members for CTrapKeyComboBox, including all inherited members.
CTrapKeyComboBox(void) | CTrapKeyComboBox |
isEnterKey | CTrapKeyComboBox |
isLButton | CTrapKeyComboBox |
PreTranslateMessage(MSG *pMsg) | CTrapKeyComboBox | [virtual]
~CTrapKeyComboBox() | CTrapKeyComboBox | [virtual]
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CTrapKeyEdit Member List
This is the complete list of members for CTrapKeyEdit, including all inherited members.
CTrapKeyEdit(void) | CTrapKeyEdit |
DispatchEventEN_CHANGE() | CTrapKeyEdit |
isEnterKey | CTrapKeyEdit |
isLButton | CTrapKeyEdit |
m_bFocusFlag | CTrapKeyEdit |
OnGetDlgCode() | CTrapKeyEdit | [protected]
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CTrapKeyEdit | [protected]
OnKillfocus() | CTrapKeyEdit | [protected]
OnLButtonUp(UINT nFlags, CPoint point) | CTrapKeyEdit | [protected]
~CTrapKeyEdit() | CTrapKeyEdit | [virtual]
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CTuneSlowThreshold Member List
This is the complete list of members for CTuneSlowThreshold, including all inherited members.
CTuneSlowThreshold(void) | CTuneSlowThreshold
DelayTask(DWORD d) | CTuneSlowThreshold
DisplaySpecBuf25(double *SpectrumBuffer) | CTuneSlowThreshold
GetSlowThreshCalStart(double *SpectrumBuffer, double UpperChMax, int mcaCH) | CTuneSlowThreshold
GetSlowThreshChStrFromVal(unsigned char byteSlowThres, int mcaCH) | CTuneSlowThreshold
GetSpectrumData(double *dblMCAData, long *lngMCAData, int mcaCH) | CTuneSlowThreshold
GetUpperChCounts(double *SpectrumBuffer, int mcaCH) | CTuneSlowThreshold
GetUpperChMax(double *SpectrumBuffer, int mcaCH) | CTuneSlowThreshold
SetSlowThreshToChPos(int ChPosIn, int mcaCH) | CTuneSlowThreshold
UpdatePlotCursorPosFromIntChPos(int CurCh, double dblPixPerChan) | CTuneSlowThreshold
~CTuneSlowThreshold(void) | CTuneSlowThreshold
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CWinusbNotify Member List
This is the complete list of members for CWinusbNotify, including all inherited members.
CWinusbNotify(void) | CWinusbNotify
DeviceNotificationHandle | CWinusbNotify
GetDevNotifyInfo(DWORD_PTR dwData, char devicePath[]) | CWinusbNotify
InitDeviceInfo() | CWinusbNotify
m_hWndOwner | CWinusbNotify
RegDeviceNotification() | CWinusbNotify
RemoveDeviceNotification() | CWinusbNotify
SetNotificationWindow(HWND m_hWnd) | CWinusbNotify
UnregDeviceNotification(HDEVNOTIFY Handle) | CWinusbNotify
~CWinusbNotify(void) | CWinusbNotify
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CvcDP5App Member List
This is the complete list of members for CvcDP5App, including all inherited members.
CvcDP5App() | CvcDP5App |
InitInstance() | CvcDP5App | [virtual]
Generated on Thu Sep 21 2017 15:25:27 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CvcDP5Dlg Member List
This is the complete list of members for CvcDP5Dlg, including all inherited members.
AppendCmdDesc(string strCmd, string strCfgData) | CvcDP5Dlg |
BOOL_TO_bool(BOOL bValue) | CvcDP5Dlg |
CallReadDppConfig(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
CallReadDppConfigEx(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
CallReadScaConfig(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
ConvertStatusDP5ToDP4(DP4_FORMAT_STATUS m_DP5_Status) | CvcDP5Dlg |
CopyDp5CfgToClip(CString strCfg, CString strDesc) | CvcDP5Dlg |
CopyTextToClip(CString strTextIn) | CvcDP5Dlg |
CreateDTS(string strFormat) | CvcDP5Dlg |
CreateMCAData(long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst) | CvcDP5Dlg |
CreateSpectrumConfig(string strRawCfgIn) | CvcDP5Dlg |
CreateTextBlockTest() | CvcDP5Dlg |
CurrentChannel | CvcDP5Dlg |
CursorPosition | CvcDP5Dlg |
CvcDP5Dlg(CWnd *pParent=NULL) | CvcDP5Dlg |
DataTest() | CvcDP5Dlg |
DisplayError(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
DoDataExchange(CDataExchange *pDX) | CvcDP5Dlg | [protected, virtual]
Dp5CmdList | CvcDP5Dlg |
DppSendConfigToHw(WPARAM wParam, LPARAM lParam) | CvcDP5Dlg |
EnableDPPFunctions(BOOL isEnabled) | CvcDP5Dlg |
ExtractNote(CString &rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep) | CvcDP5Dlg |
GetCmdData(string strCmd, string strCfgData) | CvcDP5Dlg |
GetCmdDataMS(CString strCmd, CString strCfgData) | CvcDP5Dlg |
GetCmdDesc(string strCmd) | CvcDP5Dlg |
GetCmdDescMS(CString strCmd) | CvcDP5Dlg |
GetDeviceNameFromVal(int DeviceTypeVal) | CvcDP5Dlg |
GetPixPerChannel() | CvcDP5Dlg |
HavePlot | CvcDP5Dlg |
HaveTrace | CvcDP5Dlg |
IDD enum value | CvcDP5Dlg |
isConnectedTest() | CvcDP5Dlg |
lblMiscStatus | CvcDP5Dlg |
lblSelectCommunications | CvcDP5Dlg |
lblStatus | CvcDP5Dlg |
m_hIcon | CvcDP5Dlg | [protected]
m_nTmrRS232Elapse | CvcDP5Dlg |
m_nTmrRS232EventId | CvcDP5Dlg |
m_nTmrRS232Id | CvcDP5Dlg |
m_nTmrSpectrumElapse | CvcDP5Dlg |
m_nTmrSpectrumEventId | CvcDP5Dlg |
m_nTmrSpectrumId | CvcDP5Dlg |
m_nTmrTimeoutElapse | CvcDP5Dlg |
m_nTmrTimeoutEventId | CvcDP5Dlg |
m_nTmrTimeoutId | CvcDP5Dlg |
m_PicturePlot | CvcDP5Dlg |
m_PictureScope | CvcDP5Dlg |
MakeDp5CmdList() | CvcDP5Dlg |
OnBnClickedBtnSaveFile() | CvcDP5Dlg |
OnBnClickedButtonArmTrigger() | CvcDP5Dlg |
OnBnClickedButtonAutotune() | CvcDP5Dlg |
OnBnClickedButtonClearDataAndGraph() | CvcDP5Dlg |
OnBnClickedButtonClearMiscData() | CvcDP5Dlg |
OnBnClickedButtonClearRoi() | CvcDP5Dlg |
OnBnClickedButtonDiag() | CvcDP5Dlg |
OnBnClickedButtonEditConfig() | CvcDP5Dlg |
OnBnClickedButtonFindDevice() | CvcDP5Dlg |
OnBnClickedButtonGetSpectrum() | CvcDP5Dlg |
OnBnClickedButtonReadMiscData() | CvcDP5Dlg |
OnBnClickedButtonRoiEnd() | CvcDP5Dlg |
OnBnClickedButtonRoiStart() | CvcDP5Dlg |
OnBnClickedButtonSaveFile() | CvcDP5Dlg |
OnBnClickedButtonSelectComm() | CvcDP5Dlg |
OnBnClickedButtonShowConfig() | CvcDP5Dlg |
OnBnClickedButtonSingleUpdate() | CvcDP5Dlg |
OnBnClickedButtonStartAcquisition() | CvcDP5Dlg |
OnBnClickedButtonStopAcquisition() | CvcDP5Dlg |
OnBnClickedButtonWriteMiscData() | CvcDP5Dlg |
OnBnClickedButtonWriteTextBlock() | CvcDP5Dlg |
OnBnClickedCancel() | CvcDP5Dlg |
OnBnClickedOk() | CvcDP5Dlg |
OnBnClickedRadioPlotScaleLinear() | CvcDP5Dlg |
OnBnClickedRadioPlotScaleLog() | CvcDP5Dlg |
OnBnClickedRadioPlotTypeLine() | CvcDP5Dlg |
OnBnClickedRadioPlotTypeSolid() | CvcDP5Dlg |
OnComm() | CvcDP5Dlg |
OnCommunication(UINT, LONG) | CvcDP5Dlg |
OnDestroy() | CvcDP5Dlg |
OnDeviceChange(UINT nEventType, DWORD_PTR dwData) | CvcDP5Dlg |
OnInitDialog() | CvcDP5Dlg | [protected, virtual]
OnLButtonDown(UINT nFlags, CPoint point) | CvcDP5Dlg |
OnPaint() | CvcDP5Dlg | [protected]
OnQueryDragIcon() | CvcDP5Dlg | [protected]
OnReceive(UINT, LONG) | CvcDP5Dlg |
OnResetCommunications() | CvcDP5Dlg |
OnStnClickedPlotpicturecontrol() | CvcDP5Dlg |
OnSysCommand(UINT nID, LPARAM lParam) | CvcDP5Dlg | [protected]
OnTimer(UINT nIDEvent) | CvcDP5Dlg |
OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult) | CvcDP5Dlg |
ParsePacketEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ParsePerformanceNotes(CString str) | CvcDP5Dlg |
ParseTextBlockNotes(CString strTextBlock) | CvcDP5Dlg |
PlotBuffer | CvcDP5Dlg |
PlotData(long DataBuffer[8192], int NumChan) | CvcDP5Dlg |
PreTranslateMessage(MSG *pMsg) | CvcDP5Dlg | [virtual]
ProcessAck(unsigned char PID2) | CvcDP5Dlg |
ProcessCfgReadEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessDiagDataEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessScopeDataEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessSpectrumEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessStatusEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
ProcessTextDataEx(Packet_In PIN, DppStateType DppState) | CvcDP5Dlg |
RemCallParsePacket(unsigned char PacketIn[]) | CvcDP5Dlg |
ReplaceCmdDesc(string strCmd, string strCfgData) | CvcDP5Dlg |
ReplaceCmdDescMS(CString strCmd, CString strCfgData) | CvcDP5Dlg |
RequestScopeData(BOOL ScopeDataReady) | CvcDP5Dlg |
SaveMCAFile(string strFilename, string strMCA) | CvcDP5Dlg |
ScopeBuffer | CvcDP5Dlg |
ScopeDisplay(unsigned char ScopeData[2048]) | CvcDP5Dlg |
SendCommand(TRANSMIT_PACKET_TYPE XmtCmd) | CvcDP5Dlg |
SendCommandConfig(TRANSMIT_PACKET_TYPE XmtCmd) | CvcDP5Dlg |
SendCommandData(TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[]) | CvcDP5Dlg |
SendDppInfoTextBlock(CString strLowerTextBlock, CString strInfoTextBlock) | CvcDP5Dlg |
SendManufacturingTextBlock(CString generalNotes) | CvcDP5Dlg |
SetPlotChannel() | CvcDP5Dlg |
SetStartTime() | CvcDP5Dlg |
ShowStatus(CString strStatus) | CvcDP5Dlg |
strLowerMiscData | CvcDP5Dlg |
strUpperMiscData | CvcDP5Dlg |
szSettings | CvcDP5Dlg |
TextToBlockString(CString &str, char *prefix) | CvcDP5Dlg |
TimeoutFlag | CvcDP5Dlg |
TuneFastSlowThresh() | CvcDP5Dlg |
UpdatePlot() | CvcDP5Dlg |
UpdateScope() | CvcDP5Dlg |
WriteTextBlock() | CvcDP5Dlg |
XPlotMAX | CvcDP5Dlg |
YPlotMAX | CvcDP5Dlg |
~CvcDP5Dlg() | CvcDP5Dlg |
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
cAnimWnd Member List
This is the complete list of members for cAnimWnd, including all inherited members.
cAnimWnd() | cAnimWnd |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | cAnimWnd | [virtual]
GetImageCount() | cAnimWnd |
m_Bitmap | cAnimWnd | [protected]
m_Height | cAnimWnd | [protected]
m_ImageIndex | cAnimWnd | [protected]
m_MemDC | cAnimWnd | [protected]
m_TransparentColor | cAnimWnd | [protected]
m_Width | cAnimWnd | [protected]
OnPaint() | cAnimWnd | [protected]
OnTimer(UINT nIDEvent) | cAnimWnd | [protected]
SetImageList(UINT BitmapID, short Size, short Sizey, COLORREF TransparentColor=-1) | cAnimWnd |
StartAnim(short Delay=50) | cAnimWnd |
StopAnim() | cAnimWnd |
~cAnimWnd() | cAnimWnd | [virtual]
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
cMemDC Member List
This is the complete list of members for cMemDC, including all inherited members.
cMemDC(CDC *pDC, const CRect &rcBounds, long BackColor=RGB(255, 255, 255)) | cMemDC | [inline]
operator->() | cMemDC | [inline]
~cMemDC() | cMemDC | [inline]
Generated on Thu Sep 21 2017 15:25:24 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
cWaitDialog Member List
This is the complete list of members for cWaitDialog, including all inherited members.
Close() | cWaitDialog |
m_bShowCancelButton | cWaitDialog |
m_Event | cWaitDialog |
m_EventName | cWaitDialog |
m_Text | cWaitDialog |
m_Thread | cWaitDialog |
Show() | cWaitDialog |
~cWaitDialog() | cWaitDialog | [virtual]
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
cWaitDlg Member List
This is the complete list of members for cWaitDlg, including all inherited members.
cWaitDlg(CWnd *pParent=NULL) | cWaitDlg |
DoDataExchange(CDataExchange *pDX) | cWaitDlg | [protected, virtual]
IDD enum value | cWaitDlg |
m_Anim | cWaitDlg |
m_bShowCancelButton | cWaitDlg |
m_Text | cWaitDlg |
m_Thread | cWaitDlg |
OnCancel() | cWaitDlg | [protected, virtual]
OnInitDialog() | cWaitDlg | [protected, virtual]
OnOK() | cWaitDlg | [protected, virtual]
OnTimer(UINT nIDEvent) | cWaitDlg | [protected]
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
cWaitDlgThread Member List
This is the complete list of members for cWaitDlgThread, including all inherited members.
cWaitDlgThread() | cWaitDlgThread |
ExitInstance() | cWaitDlgThread | [virtual]
InitInstance() | cWaitDlgThread | [virtual]
m_bShowCancelButton | cWaitDlgThread |
m_Event | cWaitDlgThread |
m_Eventname | cWaitDlgThread |
m_Text | cWaitDlgThread |
~cWaitDlgThread() | cWaitDlgThread | [virtual]
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Index

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Index
C | D | N | P | S | W | _
C
CDppShaping CParsePacket CTuneSlowThreshold stringex
CDppSlowThreshold CPlot CvcDP5App
W
CAboutDlg CDppSocket CPlotCanvas CvcDP5Dlg
cAnimWnd CDppUtilities CPowerPage cWaitDialog WINUSB_DEVICE_INFO
CAsciiCmdUtilities CDppWinUSB CRoi cWaitDlg
_
CBootOptPage CFileBrowse CRoiEntry cWaitDlgThread
CCfgPropPage CFilePage CSca CWinusbNotify _CONFIG_OPTIONS
CCfgPropSheet CGainPzPage CScaFn
D
_COORD_LONG
CDlgStatusBar CINI CSCommon _DiagDataType
CDlgToolBar CIniEx CSelectDP5 DP5_DP4_FORMAT_STATUS _DP5_CONFIGURATION
CDP5CfgWnd CIniUtil CSendCommand
N
_DppStateType
CDP5ControlUtil CLabel CShapingPage _Packet_In
CDP5Protocol CMcaPage CSpectraList NETDISPLAY_ENTRY _SpectrumFileType
CDP5Status cMemDC CSpectrum
P
_WINUSB_PIPE_INFORMATION
CDppComm CMiscPage CSpectrumAttr _WINUSB_SETUP_PACKET
CDppConfig CMSecTimer CSProfile Packet_Out
CDppGain CMsgBox CTrapKeyComboBox
S
CDppLibUsb CNetFinder CTrapKeyEdit
Spec
C | D | N | P | S | W | _
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
stringex Member List
This is the complete list of members for stringex, including all inherited members.
Format(const char *fmt,...) | stringex
MakeLower(string StdString) | stringex
MakeUpper(string StdString) | stringex
stringex(void) | stringex
~stringex(void) | stringex
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: File List

File List
Here is a list of all files with brief descriptions:
MsgBox.cpp [code]
MsgBox.h [code]
Plot.cpp [code]
Plot.h [code]
resource.h [code]
Roi.cpp [code]
roi.h [code]
SCommon.cpp [code]
SCommon.h [code]
SpectraList.cpp [code]
SpectraList.h [code]
Spectrum.cpp [code]
Spectrum.h [code]
SpectrumAttr.cpp [code]
SpectrumAttr.h [code]
StdAfx.cpp [code]
StdAfx.h [code]
stringex.cpp [code]
stringex.h [code]
stringSplit.h [code]
STypes.cpp [code]
STypes.h [code]
UserMsgs.h [code]
vcDP5.cpp [code]
vcDP5.h [code]
vcDP5_Shared_HIDD.h [code]
vcDP5_Shared_IDD.h [code]
vcDP5Dlg.cpp [code]
vcDP5Dlg.h [code]
CIni/DP5ControlUtil.cpp [code]
CIni/DP5ControlUtil.h [code]
CIni/INI.cpp [code]
CIni/INI.h [code]
CIni/IniEx.cpp [code]
CIni/IniEx.h [code]
CIni/IniUtil.cpp [code]
CIni/IniUtil.h [code]
Config/DppConfig.cpp [code]
Config/DppConfig.h [code]
Config/DppShaping.cpp [code]
Config/DppShaping.h [code]
Config/DppSlowThreshold.cpp [code]
Config/DppSlowThreshold.h [code]
Config/TuneSlowThreshold.cpp [code]
Config/TuneSlowThreshold.h [code]
Controls/Label.cpp [code]
Controls/Label.h [code]
Controls/PlotCanvas.cpp [code]
Controls/PlotCanvas.h [code]
Controls/TrapKeyComboBox.cpp [code]
Controls/TrapKeyComboBox.h [code]
Controls/TrapKeyEdit.cpp [code]
Controls/TrapKeyEdit.h [code]
Controls/X11Color.h [code]
DeviceIO/AsciiCmdUtilities.cpp [code]
DeviceIO/AsciiCmdUtilities.h [code]
DeviceIO/DP5Protocol.cpp [code]
DeviceIO/DP5Protocol.h [code]
DeviceIO/DP5Status.cpp [code]
DeviceIO/DP5Status.h [code]
DeviceIO/DppComm.cpp [code]
DeviceIO/DppComm.h [code]
DeviceIO/DppConst.h [code]
DeviceIO/DppLibUsb.cpp [code]
DeviceIO/DppLibUsb.h [code]
DeviceIO/DppSocket.cpp [code]
DeviceIO/DppSocket.h [code]
DeviceIO/DppUtilities.cpp [code]
DeviceIO/DppUtilities.h [code]
DeviceIO/DppWinUSB.cpp [code]
DeviceIO/DppWinUSB.h [code]
DeviceIO/guid.h [code]
DeviceIO/MSecTimer.cpp [code]
DeviceIO/MSecTimer.h [code]
DeviceIO/NetFinder.cpp [code]
DeviceIO/NetFinder.h [code]
DeviceIO/ParsePacket.cpp [code]
DeviceIO/ParsePacket.h [code]
DeviceIO/SelectDP5.cpp [code]
DeviceIO/SelectDP5.h [code]
DeviceIO/SelectDP5Res.h [code]
DeviceIO/SendCommand.cpp [code]
DeviceIO/SendCommand.h [code]
DeviceIO/WINUSB.H [code]
DeviceIO/WINUSBIO.H [code]
DeviceIO/WinusbNotify.cpp [code]
DeviceIO/WinusbNotify.h [code]
DP5Cfg/BootOptPage.cpp [code]
DP5Cfg/BootOptPage.h [code]
DP5Cfg/CfgPropSheet.cpp [code]
DP5Cfg/CfgPropSheet.h [code]
DP5Cfg/Dlgbars.cpp [code]
DP5Cfg/Dlgbars.h [code]
DP5Cfg/DP5CfgWnd.cpp [code]
DP5Cfg/DP5CfgWnd.h [code]
DP5Cfg/DppGain.cpp [code]
DP5Cfg/DppGain.h [code]
DP5Cfg/FileBrowse.cpp [code]
DP5Cfg/FileBrowse.h [code]
DP5Cfg/FilePage.cpp [code]
DP5Cfg/FilePage.h [code]
DP5Cfg/FilePageRes.h [code]
DP5Cfg/GainPzPage.cpp [code]
DP5Cfg/GainPzPage.h [code]
DP5Cfg/GainPzPageRes.h [code]
DP5Cfg/McaPage.cpp [code]
DP5Cfg/McaPage.h [code]
DP5Cfg/McaPageRes.h [code]
DP5Cfg/MiscPage.cpp [code]
DP5Cfg/MiscPage.h [code]
DP5Cfg/MiscPageRes.h [code]
DP5Cfg/PowerPage.cpp [code]
DP5Cfg/PowerPage.h [code]
DP5Cfg/PowerPageRes.h [code]
DP5Cfg/Sca.cpp [code]
DP5Cfg/Sca.h [code]
DP5Cfg/ScaFn.cpp [code]
DP5Cfg/ScaFn.h [code]
DP5Cfg/ShapingPage.cpp [code]
DP5Cfg/ShapingPage.h [code]
DP5Cfg/ShapingPageRes.h [code]
hlp/HTMLDefines.h [code]
waitdlg/AnimWnd.cpp [code]
waitdlg/AnimWnd.h [code]
waitdlg/CmdWaitDlg.cpp [code]
waitdlg/CmdWaitDlg.h [code]
waitdlg/memdc.h [code]
waitdlg/WaitDlg.cpp [code]
waitdlg/WaitDlg.h [code]
waitdlg/WaitDlgThread.cpp [code]
waitdlg/WaitDlgThread.h [code]
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: DeviceIO/guid.h Source File

DeviceIO/guid.h
Go to the documentation of this file.
00001 //
00002 // $History: guid.h $
00003 //
00004 //Amptek DP5 WinUSB    Date: 03/08/2011    Time: 02:49:49 PM
00005
00006 #ifndef GUID_INC
00007 #define GUID_INC
00008
00009 #pragma once
00010
00011 #ifndef DEFINE_GUID
00012 #include <objbase.h>
00013 #endif
00014
00015 #include <initguid.h>
00016
00018 DEFINE_GUID(GUID_DP5_INTERFACE_CLASS, 0x5a8ed6a1, 0x7fc3, 0x4b6a, 0xa5, 0x36, 0x95, 0xdf, 0x35, 0xd0, 0x34, 0x48);
00019
00021 DEFINE_GUID(GUID_DP5_SETUP_CLASS, 0x6a4e9a2d, 0x9368, 0x4f01, 0x8e, 0x60, 0xb3, 0xf9, 0xcd, 0xba, 0xb5, 0xe8);
00022
00023
00024 #endif // end, #ifndef GUID_INC
Generated on Thu Sep 21 2017 15:25:17 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Hierarchy

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • _CONFIG_OPTIONS
  • _COORD_LONG
  • _DiagDataType
  • _DP5_CONFIGURATION
  • _DppStateType
  • _Packet_In
  • _SpectrumFileType
  • _WINUSB_PIPE_INFORMATION
  • _WINUSB_SETUP_PACKET
  • CAboutDlg
  • cAnimWnd
  • CAsciiCmdUtilities
  • CCfgPropPage
    • CBootOptPage
    • CFilePage
    • CGainPzPage
    • CMcaPage
    • CMiscPage
    • CPowerPage
    • CShapingPage
  • CCfgPropSheet
    • CDP5CfgWnd
  • CDlgStatusBar
  • CDlgToolBar
  • CDP5ControlUtil
  • CDP5Protocol
  • CDP5Status
  • CDppComm
  • CDppConfig
  • CDppGain
  • CDppLibUsb
  • CDppShaping
  • CDppSlowThreshold
  • CDppSocket
  • CDppUtilities
  • CDppWinUSB
  • CFileBrowse
  • CINI
  • CIniEx
  • CIniUtil
  • CLabel
  • cMemDC
  • CMSecTimer
  • CMsgBox
  • CNetFinder
  • CParsePacket
  • CPlot
  • CPlotCanvas
  • CRoi
  • CRoiEntry
  • CSca
  • CScaFn
  • CSCommon
  • CSelectDP5
  • CSendCommand
  • CSpectraList
  • CSpectrum
  • CSpectrumAttr
  • CSProfile
  • CTrapKeyComboBox
  • CTrapKeyEdit
  • CTuneSlowThreshold
  • CvcDP5App
  • CvcDP5Dlg
  • cWaitDialog
  • cWaitDlg
  • cWaitDlgThread
  • CWinusbNotify
  • DP5_DP4_FORMAT_STATUS
  • NETDISPLAY_ENTRY
  • Packet_Out
  • Spec
  • stringex
  • WINUSB_DEVICE_INFO
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Class Hierarchy

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Hierarchy

Go to the textual class hierarchy

Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: waitdlg/memdc.h Source File

waitdlg/memdc.h
Go to the documentation of this file.
00001 #ifndef _MEMDC_H_
00002 #define _MEMDC_H_
00003
00005 // Author: Keith Rule
00006 // Email:  keithr@europa.com
00007 // Copyright 1996-1997, Keith Rule
00008 //
00009 // You may freely use or modify this code provided this
00010 // Copyright is included in all derived versions
00011 //
00012 // History - 10/3/97 Fixed scrolling bug.
00013 //                   Added print support.//
00014 // This class implements a memory Device Context
00015
00016 // History - 3/1/99 Modified from Keith Rule's CMemDC.
00017 //
00018 // This class implements a memory Device Context
00019
00020 class cMemDC : public CDC
00021 {
00022 private:
00023         CBitmap*        m_bitmap;
00024         CBitmap*        m_oldBitmap;
00025         CDC*            m_pDC;
00026         CRect           m_rcBounds;
00027 public:
00028         cMemDC(CDC* pDC, const CRect& rcBounds, long BackColor = RGB(255,255,255)) :
00029       CDC(), m_oldBitmap(NULL), m_pDC(pDC), m_rcBounds(rcBounds)
00030            {
00031                 CreateCompatibleDC(pDC);
00032                 m_bitmap = new CBitmap;
00033                 m_bitmap->CreateCompatibleBitmap(pDC, rcBounds.Width(), rcBounds.Height());
00034                 CBrush *pBack = new CBrush(BackColor);
00035       FillRect(m_rcBounds, pBack);
00036       delete pBack;
00037       m_oldBitmap = SelectObject(m_bitmap);
00038                 //m_pDC = pDC;
00039                 //m_rcBounds = rcBounds;
00040            }
00041
00042         ~cMemDC()
00043            {
00044                 SelectObject(m_oldBitmap);
00045                 if (m_bitmap != NULL) delete m_bitmap;
00046            }
00047
00048    cMemDC* operator->() {return this;}
00049 };
00050
00051 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
stringSplit
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: readme.txt File Reference

readme.txt File Reference
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: resource.h Source File

resource.h
Go to the documentation of this file.
00001 //{{NO_DEPENDENCIES}}
00002 // Microsoft Visual C++ generated include file.
00003 // Used by vcDP5.rc
00004 //
00005 #define IDM_ABOUTBOX                    16
00006 #define IDD_ABOUTBOX                    100
00007 #define IDS_ABOUTBOX                    101
00008 #define IDC_BUSY_PIC                    1029
00009 #define IDC_BUSY_TEXT                   1030
00010 #define IDC_MESSAGE1                    1105
00011 #define IDC_MESSAGE2                    1106
00012 #define IDC_BUTTON_ADD_ROI              2304
00013 #define IDC_BUTTON_ARM_TRIGGER          2305
00014 #define IDC_BUTTON_CLEAR_DATA_AND_GRAPH 2306
00015 #define IDC_BUTTON_CLEAR_MISC_DATA      2307
00016 #define IDC_BUTTON_CLEAR_ROI            2308
00017 #define IDC_BUTTON_DIAG                 2309
00018 #define IDC_BUTTON_EDIT_CONFIG          2310
00019 #define IDC_BUTTON_FIND_DEVICE          2311
00020 #define IDC_BUTTON_READ_MISC_DATA       2312
00021 #define IDC_BUTTON_ROI_END              2313
00022 #define IDC_BUTTON_ROI_START            2314
00023 #define IDC_BUTTON_SAVE_FILE            2315
00024 #define IDC_BUTTON_SELECT_COMM          2316
00025 #define IDC_BUTTON_SHOW_CONFIG          2317
00026 #define IDC_BUTTON_SINGLE_UPDATE        2318
00027 #define IDC_BUTTON_START_ACQUISITION    2319
00028 #define IDC_BUTTON_STOP_ACQUISITION     2320
00029 #define IDC_BUTTON_WRITE_MISC_DATA      2321
00030 #define IDC_CHECK_AUTO_REARM            2322
00031 #define IDC_CHECK_DELTA                 2323
00032 #define IDC_EDIT_DESCRIPTION            2324
00033 #define IDC_EDIT_DIAG                   2325
00034 #define IDC_EDIT_MISC_DATA              2326
00035 #define IDC_EDIT_START_TIME             2327
00036 #define IDC_EDIT_STATUS                 2328
00037 #define IDC_EDIT_TAG                    2329
00038 #define IDC_GROUP_PLOT_SCALE            2330
00039 #define IDC_PICTURE_PLOT                2331
00040 #define IDC_PICTURE_SCOPE               2332
00041 #define IDC_PLOTTYPEGROUP               2333
00042 #define IDC_RADIO_PLOT_SCALE_LINEAR     2334
00043 #define IDC_RADIO_PLOT_SCALE_LOG        2335
00044 #define IDC_RADIO_PLOT_TYPE_SOLID       2336
00045 #define IDC_RADIO_PLOT_TYPE_LINE        2337
00046 #define IDC_STATIC_                     2338
00047 #define IDC_STATIC_MISC_STATUS          2339
00048 #define IDC_STATIC_ROI_COUNT            2340
00049 #define IDC_STATIC_ROI_END              2341
00050 #define IDC_STATIC_ROI_INDEX            2342
00051 #define IDC_STATIC_ROI_START            2343
00052 #define IDC_STATIC_SELECT_COMMUNICATIONS 2344
00053 #define IDC_STATIC_SPECTRUM_STATUS      2345
00054 #define IDC_STATIC_STATUS               2346
00055 #define IDC_BUTTON_AUTOTUNE             2347
00056 #define IDB_BITMAP_DP5_DLG              4105
00057 #define IDB_SPECTRUM_ANIM               4144
00058 #define IDD_BUSY_DLG                    4150
00059 #define IDD_MESSAGE_BOX                 4159
00060 #define IDP_SOCKETS_INIT_FAILED         4186
00061 #define IDR_MAINFRAME                   4188
00062 #define IDR_MENU                        4189
00063 #define IDR_TOOLBAR                     4196
00064 #define IDR_TOOLBAR_DP5_DLG             4197
00065 #define IDS_BTNSTRING_MODAL             4198
00066 #define IDS_BTNSTRING_MODELESS          4199
00067 #define IDS_CAPTION                     4200
00068 #define IDD_vcDP5_DIALOG                7168
00069 #define ID_FILE_TAB                     33064
00070 #define ID_GAINPZ_TAB                   33073
00071 #define ID_MCA_TAB                      33092
00072 #define ID_MISC_TAB                     33095
00073 #define ID_POWER_TAB                    33102
00074 #define ID_SHAPING_TAB                  33120
00075 #define ID_HELP_ABOUT                   40003
00076
00077 // Next default values for new objects
00078 //
00079 #ifdef APSTUDIO_INVOKED
00080 #ifndef APSTUDIO_READONLY_SYMBOLS
00081 #define _APS_NEXT_RESOURCE_VALUE        7171
00082 #define _APS_NEXT_COMMAND_VALUE         33456
00083 #define _APS_NEXT_CONTROL_VALUE         2349
00084 #define _APS_NEXT_SYMED_VALUE           7171
00085 #endif
00086 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: roi.h Source File

roi.h
Go to the documentation of this file.
00001 // Roi.h: interface for the CRoiA class.
00002 //
00004
00005 #if !defined(AFX_ROI_H__95D6F283_575E_11D2_9A26_00403354E42C__INCLUDED_)
00006 #define AFX_ROI_H__95D6F283_575E_11D2_9A26_00403354E42C__INCLUDED_
00007
00008 #if _MSC_VER >= 1000
00009 #pragma once
00010 #endif // _MSC_VER >= 1000
00011
00012 typedef enum
00013 {
00014     ROI_DATA_INVALID,
00015     ROI_DATA_BAD,
00016     ROI_DATA_MARGINAL,
00017     ROI_DATA_GOOD
00018 } RoiDataKind;
00019
00020 class CRoiEntry
00021 {
00022 public:
00023         //int m_gain;
00024     int m_start;    // channel
00025     int m_end;
00026     double m_total;
00027     double m_net;
00028     double m_centroid;
00029     double m_uncertainty;
00030     double m_fwhm;
00031     double m_max;
00032     double m_leftWidth;
00033     double m_rightWidth;
00034     int m_status;
00035
00036         //void ThreePointROISmooth(double *buffer);
00037         //void FivePointROISmooth(double *buffer);
00038         //double VarianceFWHM(double VMu,       double VNet, double Vdnoise, double Vnoise1, double *Vdata, int Vlen);
00039  //   void CalculatePeakData(double *buffer);
00040
00041     CRoiEntry(){m_status = ROI_DATA_INVALID;}
00042     CRoiEntry(int st, int en)
00043     {
00044         m_start = st;
00045         m_end = en;
00046         m_status = ROI_DATA_INVALID;
00047     }
00048 };
00049
00050 class CRoi : public CArray<CRoiEntry, CRoiEntry&>
00051 {
00052 public:
00053     int m_count;
00054     int m_selectIndex;
00055         //int m_gain;
00056     CRoi(){m_count = 0; m_selectIndex = -1;}
00057     void Insert(int i, int st, int en);
00058     int InsertSorted(int st, int en);
00059     void AddRoi(int st, int en){Insert(m_count, st, en);}
00060     void Remove(int i);
00061     void Clear(void);
00062     void CopyRoi(CRoi &src){Copy(src); m_count = src.m_count;
00063             m_selectIndex = src.m_selectIndex;}
00064     int AtChannel(int chan);
00065     void CalculateRoiInfo(double *buffer);
00066 };
00067
00069 // CRoiDlg dialog
00070
00071 typedef enum
00072 {
00073     ROI_DLG_FOCUS_NONE,
00074     ROI_DLG_FOCUS_START,
00075     ROI_DLG_FOCUS_END
00076 } RoiFocus;
00077
00078 class CSpectrum;
00079
00080 #endif // !defined(AFX_ROI_H__95D6F283_575E_11D2_9A26_00403354E42C__INCLUDED_)
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringSplit.h File Reference

Namespaces | Typedefs | Functions
stringSplit.h File Reference
#include <string>
#include <vector>
Include dependency graph for stringSplit.h:

Go to the source code of this file.

Namespaces

namespace | stringSplit

Typedefs

typedef string::size_type(string::* | stringSplit::FindToken )(const string &strDelimiter, string::size_type sztOffset) const

Functions

vector< string > | stringSplit::Split (const string &strIn, const string &strDelimiters, bool bRemoveEmpty=false, bool bMatchAll=false)
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringSplit.h Source File

stringSplit.h
Go to the documentation of this file.
00001 #include <string>
00002 #include <vector>
00003
00004 namespace stringSplit
00005 {
00006     using namespace std;
00007     typedef string::size_type (string::*FindToken)(const string& strDelimiter, string::size_type sztOffset) const;
00008     // Split a string using a delimiter string or string character set, returns split string as a vector<string>
00009         // strIn - string being split
00010         // strDelimiters - delimiter string or character list in a string for splitting strIn
00011         // bRemoveEmpty - remove empty strings from list
00012         // bMatchAll - true=use delimiter string, false=use string as character set matching any chars in set
00013     vector<string> Split(const string& strIn, const string& strDelimiters, bool bRemoveEmpty=false, bool bMatchAll=false)
00014     {
00015         vector<string> VecStrTokens;                                            // return container for strTokens
00016         string::size_type SearchStart = 0;                                      // starting position for searches
00017         string::size_type SkipPosition = 1;                                     // positions to SkipPosition after a strDelimiters
00018         FindToken FindPosition = &string::find_first_of;        // search algorithm for matches
00019         if (bMatchAll)
00020         {
00021             SkipPosition = strDelimiters.length();
00022             FindPosition = &string::find;
00023         }
00024         while (SearchStart != string::npos)
00025         {
00026             string::size_type SearchEnd = (strIn.*FindPosition)(strDelimiters, SearchStart);    // get a complete range [SearchStart..SearchEnd)
00027             if (SkipPosition == 0) SearchEnd = string::npos;    // no match ret whole string if skip is null
00028             string strToken = strIn.substr(SearchStart, SearchEnd - SearchStart);
00029             if (!(bRemoveEmpty && strToken.empty()))
00030             {
00031                 VecStrTokens.push_back(strToken);                                 // extract the strToken and add it to the VecStrTokens list
00032             }
00033             if ((SearchStart = SearchEnd) != string::npos) SearchStart += SkipPosition; // SearchStart the next range
00034         }
00035         return VecStrTokens;
00036     }
00037 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringex.cpp Source File

stringex.cpp
Go to the documentation of this file.
00001 #include "stringex.h"
00002
00003 #ifdef _MSC_VER
00004         #pragma warning(disable:4996)
00005         #define vsnprintf _vsnprintf
00006 #endif
00007
00008 stringex::stringex(void)
00009 {
00010 }
00011
00012 stringex::~stringex(void)
00013 {
00014 }
00015
00016 std::string stringex::vformat (const char *fmt, va_list ap)
00017 {
00018     size_t size = 1024;
00019     char stackbuf[1024];
00020     std::vector<char> dynamicbuf;
00021     char *buf = &stackbuf[0];
00022     while (1) {
00023         int needed = vsnprintf (buf, size, fmt, ap);
00024         if (needed <= (int)size && needed >= 0) {
00025             return std::string (buf, (size_t) needed);
00026         }
00027         size = (needed > 0) ? (needed+1) : (size*2);
00028         dynamicbuf.resize (size);
00029         buf = &dynamicbuf[0];
00030     }
00031 }
00032
00033 std::string stringex::Format (const char *fmt, ...)
00034 {
00035     va_list ap;
00036     va_start (ap, fmt);
00037     std::string buf = vformat (fmt, ap);
00038     va_end (ap);
00039     return buf;
00040 }
00041
00042 std::string stringex::MakeUpper(string StdString)
00043 {
00044   const int length = (int)StdString.length();
00045   for(int i=0; i<length ; ++i)
00046   {
00047           StdString[i] = std::toupper(StdString[i]);
00048   }
00049   return StdString;
00050 }
00051
00052 std::string stringex::MakeLower(string StdString)
00053 {
00054   const int length = (int)StdString.length();
00055   for(int i=0; i<length ; ++i)
00056   {
00057           StdString[i] = std::tolower(StdString[i]);
00058   }
00059   return StdString;
00060 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: stringex.h Source File

stringex.h
Go to the documentation of this file.
00001 #pragma once
00002 #ifndef STRINGEX_H
00003 #define STRINGEX_H
00004 #ifdef _MSC_VER
00005         #pragma warning(disable:4996)  // uses _vsnprintf, disable warning, can use _CRT_SECURE_NO_WARNINGS
00006 //      #define _CRT_SECURE_NO_WARNINGS
00007 #endif
00008 #include <stdio.h>
00009 #include <stdarg.h>
00010 #include <cstdarg>
00011 #include <vector>
00012 #include <string>
00013 #include <cctype> // std::toupper, std::tolower
00014 using namespace std;
00015
00016 class stringex
00017 {
00018 public:
00019         stringex(void);
00020         ~stringex(void);
00021         std::string Format (const char *fmt, ...);
00022         std::string MakeUpper(string StdString);
00023         std::string MakeLower(string StdString);
00024
00025 private:
00026         std::string vformat (const char *fmt, va_list ap);
00027
00028 };
00029
00030 #endif
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_CONFIG_OPTIONS Member List
This is the complete list of members for _CONFIG_OPTIONS, including all inherited members.
DPP_ECO | _CONFIG_OPTIONS
DppType | _CONFIG_OPTIONS
HwCfgDP5Out | _CONFIG_OPTIONS
isDP5_RevDxGains | _CONFIG_OPTIONS
PC5_PRESENT | _CONFIG_OPTIONS
SendCoarseFineGain | _CONFIG_OPTIONS
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_COORD_LONG Member List
This is the complete list of members for _COORD_LONG, including all inherited members.
X | _COORD_LONG
Y | _COORD_LONG
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_DP5_CONFIGURATION Member List
This is the complete list of members for _DP5_CONFIGURATION, including all inherited members.
bAppendUnits | _DP5_CONFIGURATION
ComboIndex | _DP5_CONFIGURATION
ComboValue | _DP5_CONFIGURATION
Command | _DP5_CONFIGURATION
Comments | _DP5_CONFIGURATION
CtrlGroup | _DP5_CONFIGURATION
CtrlType | _DP5_CONFIGURATION
Description | _DP5_CONFIGURATION
Limits | _DP5_CONFIGURATION
ListCtrlID | _DP5_CONFIGURATION
Setting | _DP5_CONFIGURATION
TextCtrlID | _DP5_CONFIGURATION
TextValue | _DP5_CONFIGURATION
Units | _DP5_CONFIGURATION
ValComments | _DP5_CONFIGURATION
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_DiagDataType Member List
This is the complete list of members for _DiagDataType, including all inherited members.
ADC_V | _DiagDataType
DiagData | _DiagDataType
Firmware | _DiagDataType
FPGA | _DiagDataType
HVOn | _DiagDataType
Is8_5VPreAmp | _DiagDataType
IsPosHV | _DiagDataType
PC5_PRESENT | _DiagDataType
PC5_SN | _DiagDataType
PC5_V | _DiagDataType
PC5DCAL | _DiagDataType
PC5Initialized | _DiagDataType
PreAmpON | _DiagDataType
SRAMTestData | _DiagDataType
SRAMTestPass | _DiagDataType
strTempCal | _DiagDataType
strTempRaw | _DiagDataType
Sup9VOn | _DiagDataType
TECOn | _DiagDataType
TempOffset | _DiagDataType
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_DppStateType Member List
This is the complete list of members for _DppStateType, including all inherited members.
HaveScopeData | _DppStateType
Interface | _DppStateType
ReqProcess | _DppStateType
ScopeAutoRearm | _DppStateType
ScopeOverFlow | _DppStateType
strPort | _DppStateType
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_Packet_In Member List
This is the complete list of members for _Packet_In, including all inherited members.
CheckSum | _Packet_In
DATA | _Packet_In
LEN | _Packet_In
PID1 | _Packet_In
PID2 | _Packet_In
STATUS | _Packet_In
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_SpectrumFileType Member List
This is the complete list of members for _SpectrumFileType, including all inherited members.
m_iNumChan | _SpectrumFileType
SerialNumber | _SpectrumFileType
strDescription | _SpectrumFileType
strSpectrumConfig | _SpectrumFileType
strSpectrumStatus | _SpectrumFileType
strStartTime | _SpectrumFileType
strTag | _SpectrumFileType
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_WINUSB_PIPE_INFORMATION Member List
This is the complete list of members for _WINUSB_PIPE_INFORMATION, including all inherited members.
Interval | _WINUSB_PIPE_INFORMATION
MaximumPacketSize | _WINUSB_PIPE_INFORMATION
PipeId | _WINUSB_PIPE_INFORMATION
PipeType | _WINUSB_PIPE_INFORMATION
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
_WINUSB_SETUP_PACKET Member List
This is the complete list of members for _WINUSB_SETUP_PACKET, including all inherited members.
Index | _WINUSB_SETUP_PACKET
Length | _WINUSB_SETUP_PACKET
Request | _WINUSB_SETUP_PACKET
RequestType | _WINUSB_SETUP_PACKET
Value | _WINUSB_SETUP_PACKET
Generated on Thu Sep 21 2017 15:25:19 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DP5_DP4_FORMAT_STATUS Member List
This is the complete list of members for DP5_DP4_FORMAT_STATUS, including all inherited members.
AccumulationTime | DP5_DP4_FORMAT_STATUS
ADC_GAIN_CAL | DP5_DP4_FORMAT_STATUS
ADC_OFFSET_CAL | DP5_DP4_FORMAT_STATUS
AFAST_LOCKED | DP5_DP4_FORMAT_STATUS
AN_IN | DP5_DP4_FORMAT_STATUS
AOFFSET_LOCKED | DP5_DP4_FORMAT_STATUS
AU34_2 | DP5_DP4_FORMAT_STATUS
b80MHzMode | DP5_DP4_FORMAT_STATUS
bFPGAAutoClock | DP5_DP4_FORMAT_STATUS
bScintHas80MHzOption | DP5_DP4_FORMAT_STATUS
Build | DP5_DP4_FORMAT_STATUS
DCAL | DP5_DP4_FORMAT_STATUS
DET_TEMP | DP5_DP4_FORMAT_STATUS
DEVICE_ID | DP5_DP4_FORMAT_STATUS
DP5_CONFIGURED | DP5_DP4_FORMAT_STATUS
DP5_TEMP | DP5_DP4_FORMAT_STATUS
DPP_ECO | DP5_DP4_FORMAT_STATUS
DPP_options | DP5_DP4_FORMAT_STATUS
FastCount | DP5_DP4_FORMAT_STATUS
Firmware | DP5_DP4_FORMAT_STATUS
FPGA | DP5_DP4_FORMAT_STATUS
GP_COUNTER | DP5_DP4_FORMAT_STATUS
HPGe_HV_INH | DP5_DP4_FORMAT_STATUS
HPGe_HV_INH_POL | DP5_DP4_FORMAT_STATUS
HV | DP5_DP4_FORMAT_STATUS
isAscEnabled | DP5_DP4_FORMAT_STATUS
isAscInstalled | DP5_DP4_FORMAT_STATUS
isDP5_RevDxGains | DP5_DP4_FORMAT_STATUS
LiveTime | DP5_DP4_FORMAT_STATUS
MCA_EN | DP5_DP4_FORMAT_STATUS
MCS_DONE | DP5_DP4_FORMAT_STATUS
PC5_8_5V | DP5_DP4_FORMAT_STATUS
PC5_HV_POL | DP5_DP4_FORMAT_STATUS
PC5_PRESENT | DP5_DP4_FORMAT_STATUS
PC5_SN | DP5_DP4_FORMAT_STATUS
PRECNT_REACHED | DP5_DP4_FORMAT_STATUS
PresetLtDone | DP5_DP4_FORMAT_STATUS
PresetRtDone | DP5_DP4_FORMAT_STATUS
PX4 | DP5_DP4_FORMAT_STATUS
PZCORR | DP5_DP4_FORMAT_STATUS
RAM_TEST_ERROR | DP5_DP4_FORMAT_STATUS
RAM_TEST_RUN | DP5_DP4_FORMAT_STATUS
RAW | DP5_DP4_FORMAT_STATUS
RealTime | DP5_DP4_FORMAT_STATUS
ReBootFlag | DP5_DP4_FORMAT_STATUS
SCOPE_DR | DP5_DP4_FORMAT_STATUS
SerialNumber | DP5_DP4_FORMAT_STATUS
SlowCount | DP5_DP4_FORMAT_STATUS
SPECTRUM_OFFSET | DP5_DP4_FORMAT_STATUS
SUPPLIES_ON | DP5_DP4_FORMAT_STATUS
TEC_Voltage | DP5_DP4_FORMAT_STATUS
UC_TEMP_OFFSET | DP5_DP4_FORMAT_STATUS
VREF_IN | DP5_DP4_FORMAT_STATUS
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
NETDISPLAY_ENTRY Member List
This is the complete list of members for NETDISPLAY_ENTRY, including all inherited members.
alert_level | NETDISPLAY_ENTRY
ccConnectRGB | NETDISPLAY_ENTRY
event1_days | NETDISPLAY_ENTRY
event1_hours | NETDISPLAY_ENTRY
event1_minutes | NETDISPLAY_ENTRY
event1_seconds | NETDISPLAY_ENTRY
event2_days | NETDISPLAY_ENTRY
event2_hours | NETDISPLAY_ENTRY
event2_minutes | NETDISPLAY_ENTRY
event2_seconds | NETDISPLAY_ENTRY
gateway | NETDISPLAY_ENTRY
HasData | NETDISPLAY_ENTRY
ip | NETDISPLAY_ENTRY
mac | NETDISPLAY_ENTRY
port | NETDISPLAY_ENTRY
SockAddr | NETDISPLAY_ENTRY
str_description | NETDISPLAY_ENTRY
str_display | NETDISPLAY_ENTRY
str_ev1 | NETDISPLAY_ENTRY
str_ev2 | NETDISPLAY_ENTRY
str_type | NETDISPLAY_ENTRY
subnet | NETDISPLAY_ENTRY
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Packet_Out Member List
This is the complete list of members for Packet_Out, including all inherited members.
DATA | Packet_Out
EXPECTEDRESPONSE | Packet_Out
LEN | Packet_Out
PID1 | Packet_Out
PID2 | Packet_Out
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Spec Member List
This is the complete list of members for Spec, including all inherited members.
CHANNELS | Spec
DATA | Spec
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
WINUSB_DEVICE_INFO Member List
This is the complete list of members for WINUSB_DEVICE_INFO, including all inherited members.
bulkInPipe | WINUSB_DEVICE_INFO
bulkOutPipe | WINUSB_DEVICE_INFO
deviceConnected | WINUSB_DEVICE_INFO
deviceHandle | WINUSB_DEVICE_INFO
devicePath | WINUSB_DEVICE_INFO
deviceSpeed | WINUSB_DEVICE_INFO
interruptPipe | WINUSB_DEVICE_INFO
winUSBHandle | WINUSB_DEVICE_INFO
Generated on Thu Sep 21 2017 15:25:31 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5.cpp Source File

vcDP5.cpp
Go to the documentation of this file.
00001 // vcDP5.cpp : Defines the class behaviors for the application.
00002 //
00003
00004 #include "stdafx.h"
00005 #include "vcDP5.h"
00006 #include "vcDP5Dlg.h"
00007 #include "SCommon.h"
00008
00009 #ifdef _DEBUG
00010 #define new DEBUG_NEW
00011 #endif
00012
00013
00014 // CvcDP5App
00015
00016 BEGIN_MESSAGE_MAP(CvcDP5App, CWinApp)
00017         ON_COMMAND(ID_HELP, CWinApp::OnHelp)
00018 END_MESSAGE_MAP()
00019
00020
00021 // CvcDP5App construction
00022
00023 CvcDP5App::CvcDP5App()
00024 {
00025         EnableHtmlHelp();
00026
00027         // TODO: add construction code here,
00028         // Place all significant initialization in InitInstance
00029 }
00030
00031
00032 // The one and only CvcDP5App object
00033
00034 CvcDP5App theApp;
00035 CSCommon s;
00036
00037 // CvcDP5App initialization
00038
00039 BOOL CvcDP5App::InitInstance()
00040 {
00041         // InitCommonControls() is required on Windows XP if an application
00042         // manifest specifies use of ComCtl32.dll version 6 or later to enable
00043         // visual styles.  Otherwise, any window creation will fail.
00044         InitCommonControls();
00045
00046         CWinApp::InitInstance();
00047
00048         if (!AfxSocketInit())
00049         {
00050                 AfxMessageBox(IDP_SOCKETS_INIT_FAILED);
00051                 return FALSE;
00052         }
00053
00054         AfxEnableControlContainer();
00055
00056         // Standard initialization
00057         // If you are not using these features and wish to reduce the size
00058         // of your final executable, you should remove from the following
00059         // the specific initialization routines you do not need
00060         // Change the registry key under which our settings are stored
00061         // TODO: You should modify this string to be something appropriate
00062         // such as the name of your company or organization
00063         SetRegistryKey(_T("Amptek\\vcDP5"));
00064         s.SCAEnabled = s.profile->SCAEnabled;                           // 20110810 sca support
00065         s.scafn.InitSCA(&s.sca, 8192);
00066
00067         s.LoadProfile();
00068         s.strHelpFilePath = this->m_pszHelpFilePath;
00069
00070         CvcDP5Dlg dlg;
00071         m_pMainWnd = &dlg;
00072         INT_PTR nResponse = dlg.DoModal();
00073         if (nResponse == IDOK)
00074         {
00075                 // TODO: Place code here to handle when the dialog is
00076                 //  dismissed with OK
00077         }
00078         else if (nResponse == IDCANCEL)
00079         {
00080                 // TODO: Place code here to handle when the dialog is
00081                 //  dismissed with Cancel
00082         }
00083
00084         // Since the dialog has been closed, return FALSE so that we exit the
00085         //  application, rather than start the application's message pump.
00086         return FALSE;
00087 }
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5.h Source File

vcDP5.h
Go to the documentation of this file.
00001 // vcDP5.h : main header file for the PROJECT_NAME application
00002 //
00003
00004 #pragma once
00005
00006 #ifndef __AFXWIN_H__
00007         #error include 'stdafx.h' before including this file for PCH
00008 #endif
00009
00010 #include "resource.h"           // main symbols
00011 #include <SetupAPI.h>
00012
00013 // CvcDP5App:
00014 // See vcDP5.cpp for the implementation of this class
00015 //
00016
00017 class CvcDP5App : public CWinApp
00018 {
00019 public:
00020         CvcDP5App();
00021
00022 // Overrides
00023         public:
00024         virtual BOOL InitInstance();
00025
00026 // Implementation
00027
00028         DECLARE_MESSAGE_MAP()
00029 };
00030
00031 extern CvcDP5App theApp;
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5_Shared_HIDD.h Source File

vcDP5_Shared_HIDD.h
Go to the documentation of this file.
00001
00002 // Generated Help Map file.  Used by vcDP5.HHP.
00003 // Shared dialogs do not have integer IDD_ defines.
00005
00007 // HTML Defines for Shared Dialogs
00009
00010 // Dialogs (IDD_*)
00011 #define HIDD_DP5_CONNECT                        0x20191
00012 #define HIDD_FILE_PAGE                          0x20192
00013 #define HIDD_MCA_PAGE                           0x20193
00014 #define HIDD_SHAPING_PAGE                       0x20194
00015 #define HIDD_GAINPZ_PAGE                        0x20195
00016 #define HIDD_POWER_PAGE                         0x20196
00017 #define HIDD_MISC_PAGE                          0x20197
00018
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5_Shared_IDD.h Source File

vcDP5_Shared_IDD.h
Go to the documentation of this file.
00001 #define IDD_DP5_CONNECT                 401
00002 #define IDD_FILE_PAGE                   402
00003 #define IDD_MCA_PAGE                    403
00004 #define IDD_SHAPING_PAGE                404
00005 #define IDD_GAINPZ_PAGE                 405
00006 #define IDD_POWER_PAGE                  406
00007 #define IDD_MISC_PAGE                   407
00008
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5Dlg.cpp Source File

vcDP5Dlg.cpp
Go to the documentation of this file.
00001 // vcDP5Dlg.cpp : implementation file
00002 //
00003
00004 #include "stdafx.h"
00005 #include "vcDP5.h"
00006 #include "vcDP5Dlg.h"
00007 #include ".\vcdp5dlg.h"
00008 #include "SelectDP5.h"
00009 #include ".\msectimer.h"
00010 #include ".\waitdlg\CmdWaitDlg.h"
00011 #include "UserMsgs.h"
00012 #include "FileBrowse.h"
00013 #include "DppGain.h"
00014 #include "afxadv.h"     // for cfg file clipboard copy
00015 #include "TuneSlowThreshold.h"
00016 #include "MsgBox.h"
00017
00018 #ifdef _DEBUG
00019 #define new DEBUG_NEW
00020 #endif
00021
00022 // CAboutDlg dialog used for App About
00023
00024 class CAboutDlg : public CDialog
00025 {
00026 public:
00027         CAboutDlg();
00028
00029 // Dialog Data
00030         enum { IDD = IDD_ABOUTBOX };
00031
00032         protected:
00033         virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
00034
00035 // Implementation
00036 protected:
00037         DECLARE_MESSAGE_MAP()
00038 };
00039
00040 CAboutDlg::CAboutDlg() : CDialog(CAboutDlg::IDD)
00041 {
00042 }
00043
00044 void CAboutDlg::DoDataExchange(CDataExchange* pDX)
00045 {
00046         CDialog::DoDataExchange(pDX);
00047 }
00048
00049 BEGIN_MESSAGE_MAP(CAboutDlg, CDialog)
00050 END_MESSAGE_MAP()
00051
00052
00053 // CvcDP5Dlg dialog
00054
00055 CvcDP5Dlg::CvcDP5Dlg(CWnd* pParent /*=NULL*/)
00056         : CDialog(CvcDP5Dlg::IDD, pParent)
00057 {
00058         int idxBuffer;
00059         m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME);
00060         m_PicturePlot.SetCursorPosition(0);
00061
00062         // assign the timer values
00063         m_nTmrRS232EventId = 1;
00064         m_nTmrSpectrumEventId = 2;
00065         m_nTmrTimeoutEventId = 3;
00066
00067         m_nTmrSpectrumId = 0;
00068
00069         m_nTmrRS232Elapse = 100;
00070         m_nTmrSpectrumElapse = 1000;
00071         m_nTmrTimeoutElapse = 10;
00072
00073         HavePlot = FALSE;
00074         HaveTrace = FALSE;
00075         for(idxBuffer = 0; idxBuffer < 8192; idxBuffer++) {
00076                 PlotBuffer[idxBuffer] = 0;    //holds y position data for cursor updates
00077         }
00078         for(idxBuffer = 0; idxBuffer < 2048; idxBuffer++) {
00079                 ScopeBuffer[idxBuffer] = 0;
00080         }
00081         XPlotMAX = 0;
00082         YPlotMAX = 0;
00083         m_PicturePlot.OptScaleType = false;
00084         m_PicturePlot.OptPlotType = false;
00085
00086         //MakeDp5CmdList(&Dp5CmdList);
00087     Dp5CmdList = MakeDp5CmdList();      // ascii text command list for adding comments
00088         s.HwCfgDP5 = "";
00089
00090         s.DP5Proto.SPECTRUM.CHANNELS = 1024;
00091         CurrentChannel = 0;
00092
00093 }
00094
00095 CvcDP5Dlg::~CvcDP5Dlg()
00096 {
00097
00098 }
00099
00100 void CvcDP5Dlg::DoDataExchange(CDataExchange* pDX)
00101 {
00102         CDialog::DoDataExchange(pDX);
00103         DDX_Control(pDX, IDC_PICTURE_PLOT, m_PicturePlot);
00104         DDX_Control(pDX, IDC_PICTURE_SCOPE, m_PictureScope);
00105         DDX_Control(pDX, IDC_STATIC_SELECT_COMMUNICATIONS, lblSelectCommunications);
00106         DDX_Control(pDX, IDC_STATIC_STATUS, lblStatus);
00107         DDX_Control(pDX, IDC_STATIC_MISC_STATUS, lblMiscStatus);
00108 }
00109
00110 BEGIN_MESSAGE_MAP(CvcDP5Dlg, CDialog)
00111         ON_MESSAGE(WM_DPPCOMM_RCV_CHAR, OnCommunication)
00112         ON_MESSAGE(WM_DPPSOCKET_RCV_BUFFER, OnReceive)
00113         ON_MESSAGE(WM_USER_SEND_CONFIG_TO_HW, DppSendConfigToHw)
00114         ON_MESSAGE(WM_USER_READ_DPP_CONFIG, CallReadDppConfig)
00115         ON_MESSAGE(WM_USER_READ_DPP_CONFIG_EX, CallReadDppConfigEx)
00116         ON_MESSAGE(WM_USER_READ_SCA_CONFIG, CallReadScaConfig)
00117         ON_WM_SYSCOMMAND()
00118         ON_WM_PAINT()
00119         ON_WM_QUERYDRAGICON()
00120         //}}AFX_MSG_MAP
00121         ON_WM_DEVICECHANGE()
00122         ON_WM_DESTROY()
00123         ON_BN_CLICKED(IDC_BUTTON_FIND_DEVICE, OnBnClickedButtonFindDevice)
00124         ON_WM_TIMER()
00125         ON_BN_CLICKED(IDC_BUTTON_ARM_TRIGGER, OnBnClickedButtonArmTrigger)
00126         ON_BN_CLICKED(IDC_BUTTON_SAVE_FILE, OnBnClickedButtonSaveFile)
00127         ON_BN_CLICKED(IDC_BUTTON_CLEAR_DATA_AND_GRAPH, OnBnClickedButtonClearDataAndGraph)
00128         ON_BN_CLICKED(IDC_BUTTON_SINGLE_UPDATE, OnBnClickedButtonSingleUpdate)
00129         ON_BN_CLICKED(IDC_BUTTON_CLEAR_MISC_DATA, OnBnClickedButtonClearMiscData)
00130         ON_BN_CLICKED(IDC_BUTTON_READ_MISC_DATA, OnBnClickedButtonReadMiscData)
00131         ON_BN_CLICKED(IDC_BUTTON_WRITE_MISC_DATA, OnBnClickedButtonWriteMiscData)
00132         ON_BN_CLICKED(IDC_BUTTON_DIAG, OnBnClickedButtonDiag)
00133         ON_BN_CLICKED(IDC_BUTTON_SELECT_COMM, OnBnClickedButtonSelectComm)
00134         ON_BN_CLICKED(IDC_BUTTON_START_ACQUISITION, OnBnClickedButtonStartAcquisition)
00135         ON_BN_CLICKED(IDC_BUTTON_STOP_ACQUISITION, OnBnClickedButtonStopAcquisition)
00136         ON_BN_CLICKED(IDC_BUTTON_EDIT_CONFIG, OnBnClickedButtonEditConfig)
00137         ON_BN_CLICKED(IDC_BUTTON_SHOW_CONFIG, OnBnClickedButtonShowConfig)
00138         ON_BN_CLICKED(IDC_RADIO_PLOT_SCALE_LINEAR, OnBnClickedRadioPlotScaleLinear)
00139         ON_BN_CLICKED(IDC_RADIO_PLOT_SCALE_LOG, OnBnClickedRadioPlotScaleLog)
00140         ON_BN_CLICKED(IDC_RADIO_PLOT_TYPE_SOLID, OnBnClickedRadioPlotTypeSolid)
00141         ON_BN_CLICKED(IDC_RADIO_PLOT_TYPE_LINE, OnBnClickedRadioPlotTypeLine)
00142
00143         ON_STN_CLICKED(IDC_PICTURE_PLOT, OnStnClickedPlotpicturecontrol)
00144         ON_WM_LBUTTONDOWN()
00145         ON_BN_CLICKED(IDOK, OnBnClickedOk)
00146         ON_BN_CLICKED(IDCANCEL, OnBnClickedCancel)
00147         ON_BN_CLICKED(IDC_BUTTON_CLEAR_ROI, OnBnClickedButtonClearRoi)
00148         ON_BN_CLICKED(IDC_BUTTON_ROI_END, OnBnClickedButtonRoiEnd)
00149         ON_BN_CLICKED(IDC_BUTTON_ROI_START, OnBnClickedButtonRoiStart)
00150         ON_NOTIFY_EX_RANGE(TTN_NEEDTEXT, 0, 0xFFFF, OnToolTipNotify)
00151         ON_BN_CLICKED(IDC_BUTTON_AUTOTUNE, OnBnClickedButtonAutotune)
00152 END_MESSAGE_MAP()
00153
00154
00155 // CvcDP5Dlg message handlers
00156
00157 BOOL CvcDP5Dlg::OnInitDialog()
00158 {
00159         CDialog::OnInitDialog();
00160
00161         EnableToolTips();
00162         // Add "About..." menu item to system menu.
00163
00164         // IDM_ABOUTBOX must be in the system command range.
00165         ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);
00166         ASSERT(IDM_ABOUTBOX < 0xF000);
00167
00168         CMenu* pSysMenu = GetSystemMenu(FALSE);
00169         if (pSysMenu != NULL)
00170         {
00171                 CString strAboutMenu;
00172                 strAboutMenu.LoadString(IDS_ABOUTBOX);
00173                 if (!strAboutMenu.IsEmpty())
00174                 {
00175                         pSysMenu->AppendMenu(MF_SEPARATOR);
00176                         pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu);
00177                 }
00178         }
00179
00180         lblSelectCommunications
00181                 .SetFontName("Arial")
00182                 .SetFontSize(14)
00183                 .SetTextColor(colorBlack)
00184                 .SetBkColor(colorAmptekBlue)
00185                 .SetFontBold(TRUE);
00186
00187         lblMiscStatus
00188                 .SetTextColor(colorBlue)
00189                 .SetBkColor(colorAmptekBlue);
00190
00191
00192         // Set the icon for this dialog.  The framework does this automatically
00193         //  when the application's main window is not a dialog
00194         SetIcon(m_hIcon, TRUE);                 // Set big icon
00195         SetIcon(m_hIcon, FALSE);                // Set small icon
00196
00197         s.hWnd_Main = this->GetSafeHwnd();
00198
00199         // TODO: Add extra initialization here
00200         s.WinusbNotify.SetNotificationWindow(this->m_hWnd);
00201         s.DppWinUSB.devInfo.deviceConnected = FALSE;
00202
00203         // no device selected upon startup
00204         s.isDppFound[RS232] = FALSE;
00205         s.isDppFound[USB] = FALSE;
00206         s.isDppFound[ETHERNET] = FALSE;
00207
00208         m_PicturePlot.OptScaleType = BOOL_TO_bool(s.isScaleLog);
00209         m_PicturePlot.OptPlotType = BOOL_TO_bool(s.isPlotLine);
00210
00211         if (m_PicturePlot.OptScaleType) {
00212                 CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LOG);
00213         } else {
00214                 CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LINEAR);
00215         }
00216
00217         if (m_PicturePlot.OptPlotType) {
00218                 CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_LINE);
00219         } else {
00220                 CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_SOLID);
00221         }
00222
00223         EnableDPPFunctions(FALSE);
00224
00225
00226         return TRUE;  // return TRUE  unless you set the focus to a control
00227 }
00228
00229 bool CvcDP5Dlg::BOOL_TO_bool(BOOL bValue)
00230 {
00231         if (bValue) {
00232                 return true;
00233         } else {
00234                 return false;
00235         }
00236 }
00237
00238 void CvcDP5Dlg::OnSysCommand(UINT nID, LPARAM lParam)
00239 {
00240         if ((nID & 0xFFF0) == IDM_ABOUTBOX)
00241         {
00242                 CAboutDlg dlgAbout;
00243                 dlgAbout.DoModal();
00244         }
00245         else
00246         {
00247                 CDialog::OnSysCommand(nID, lParam);
00248         }
00249 }
00250
00251 // if you add a minimize button to your dialog, you will need the code below
00252 //  to draw the icon.  For MFC applications using the document/view model,
00253 //  this is automatically done for you by the framework.
00254
00255 void CvcDP5Dlg::OnPaint()
00256 {
00257         if (IsIconic())
00258         {
00259                 CPaintDC dc(this); // device context for painting
00260
00261                 SendMessage(WM_ICONERASEBKGND, reinterpret_cast<WPARAM>(dc.GetSafeHdc()), 0);
00262
00263                 // Center icon in client rectangle
00264                 int cxIcon = GetSystemMetrics(SM_CXICON);
00265                 int cyIcon = GetSystemMetrics(SM_CYICON);
00266                 CRect rect;
00267                 GetClientRect(&rect);
00268                 int x = (rect.Width() - cxIcon + 1) / 2;
00269                 int y = (rect.Height() - cyIcon + 1) / 2;
00270
00271                 // Draw the icon
00272                 dc.DrawIcon(x, y, m_hIcon);
00273         }
00274         else
00275         {
00276                 UpdateScope();
00277                 CDialog::OnPaint();
00278         }
00279 }
00280
00281 // The system calls this function to obtain the cursor to display while the user drags
00282 //  the minimized window.
00283 HCURSOR CvcDP5Dlg::OnQueryDragIcon()
00284 {
00285         return static_cast<HCURSOR>(m_hIcon);
00286 }
00287
00288 BOOL CvcDP5Dlg::OnDeviceChange(UINT nEventType, DWORD_PTR dwData)
00289 {
00290         //CDialog::OnDeviceChange(nEventType, dwData);
00291         CString strStatus;
00292         CString strDevice;
00293
00294         switch(nEventType) {
00295                 case DBT_DEVICEARRIVAL:
00296                         //return TRUE;
00297                         lblStatus.SetText(strStatus);
00298                         if (s.WinusbNotify.GetDevNotifyInfo(dwData, s.DppWinUSB.devInfo.devicePath)) {
00299                                 strStatus = "                                          ";
00300                                 lblStatus.SetText(strStatus);
00301                                 strStatus = "";
00302                                 lblStatus.SetText(strStatus);
00303                                 strStatus = "Device Connected. Reconnecting to device.";
00304                                 lblStatus.SetText(strStatus);
00305                                 OnBnClickedButtonFindDevice();
00306                         }
00307                         break;
00308                 case DBT_DEVICEREMOVECOMPLETE:
00309                         if (s.WinusbNotify.GetDevNotifyInfo(dwData, s.DppWinUSB.devInfo.devicePath)) {
00310                                 EnableDPPFunctions(FALSE);
00311                                 s.DppWinUSB.devInfo.deviceConnected = FALSE;
00312                                 strStatus = "Device Removed";
00313                                 lblStatus.SetText(strStatus);
00314                         }
00315                         break;
00316                 default:
00317                         break;
00318                         //AfxMessageBox("Unknown");
00319         }
00320         // TODO: Add your message handler code here
00321         return true;
00322 }
00323
00324 void CvcDP5Dlg::OnResetCommunications()
00325 {
00326         //Sleep(1000);  // make sure timer is done
00327         //s.SaveProfile();
00328         s.DppWinUSB.devInfo.deviceConnected = FALSE;
00329         s.DppWinUSB.CloseWinUsbDevice();
00330         s.WinusbNotify.RemoveDeviceNotification();
00331         if (s.m_DppPort.IsPortOpen()) {                 // close the port
00332                 s.m_DppPort.ClosePort();
00333         }
00334         if (s.m_DppSck.IsSocketOpen()) {                // close the port
00335                 s.m_DppSck.CloseSocket();
00336         }
00337 }
00338
00339 void CvcDP5Dlg::OnDestroy()
00340 {
00341         s.isDppConnected = FALSE;
00342         CDialog::OnDestroy();
00343         CMSecTimer tmr;
00344         s.SaveProfile();
00345         if (m_nTmrSpectrumId > 0) {
00346                 KillTimer(m_nTmrSpectrumId);
00347                 m_nTmrSpectrumId = 0;
00348                 tmr.msTimer(1000);              // put refresh rate here
00349         }
00350         OnResetCommunications();
00351 }
00352
00353 unsigned long CvcDP5Dlg::DataTest()
00354 {
00355         BOOL bResult;
00356         USHORT bufSizeOut = 8;
00357         unsigned char szBufferOut[8] = { 0xF5, 0xFA, 0x02, 0x03, 0x00, 0x00, 0xFE, 0x0C };
00358         unsigned long bytesWritten;
00359         USHORT bufSizeIn = 32767;
00360         unsigned char szBufferIn[32767];
00361         unsigned long bytesRead;
00362         string bufOut;
00363         USHORT idxStatus;
00364
00365         bytesRead = 0;
00366         bResult = WinUsb_WritePipe(s.DppWinUSB.devInfo.winUSBHandle, s.DppWinUSB.devInfo.bulkOutPipe, szBufferOut, bufSizeOut, &bytesWritten, NULL);
00367         Sleep(10);
00368         if (bResult) {
00369                 bResult = WinUsb_ReadPipe(s.DppWinUSB.devInfo.winUSBHandle, s.DppWinUSB.devInfo.bulkInPipe, szBufferIn, bufSizeIn, &bytesRead, NULL);
00370                 if (bResult) {
00371                         if (bytesRead == 840) {
00372                                 for(idxStatus = 0; idxStatus<64; idxStatus++) {
00373                                         s.DP5Stat.m_DP5_Status.RAW[idxStatus] = szBufferIn[774 + idxStatus];
00374                                         s.DP5Stat.Process_Status(&s.DP5Stat.m_DP5_Status);
00375                                 }
00376                                 bufOut = s.DppWinUSB.DisplayBufferArray(szBufferIn, bytesRead);
00377                                 s.DppWinUSB.SaveStringDataToFile(bufOut);
00378                         }
00379                 }
00380     }
00381         return bytesRead;
00382 }
00383
00384 void CvcDP5Dlg::OnBnClickedButtonFindDevice()
00385 {
00386         string strUSBStatus;
00387         DPP_USB_STATUS USBStatus;       //0=do nothing, 1=new connect, 2=cannot connect
00388         USBStatus = s.DppWinUSB.FindUSBDevice(s.DppWinUSB.CurrentDevice - 1);
00389         if (USBStatus != dusbStatNoAction) {
00390                 strUSBStatus = s.DppWinUSB.USBStatusString(USBStatus);
00391                 lblStatus.SetText(strUSBStatus.c_str());
00392                 if (USBStatus == dusbStatNewConnect) {
00393                         EnableDPPFunctions(TRUE);
00394                 }
00395         }
00396 }
00397
00398 void CvcDP5Dlg::RemCallParsePacket(unsigned char PacketIn[])
00399 {
00400     s.ParsePkt.DppState.ReqProcess = s.ParsePkt.ParsePacket(PacketIn, &s.DP5Proto.PIN);
00401     ParsePacketEx(s.DP5Proto.PIN, s.ParsePkt.DppState);
00402 }
00403
00404 void CvcDP5Dlg::ParsePacketEx(Packet_In PIN, DppStateType DppState)
00405 {
00406     switch (DppState.ReqProcess) {
00407         case preqProcessStatus:
00408             ProcessStatusEx(PIN, DppState);
00409                         break;
00410         case preqProcessSpectrum:
00411             ProcessSpectrumEx(PIN, DppState);
00412                         break;
00413         case preqProcessScopeData:
00414             ProcessScopeDataEx(PIN, DppState);
00415                         break;
00416         case preqProcessTextData:
00417             ProcessTextDataEx(PIN, DppState);
00418                         break;
00419
00420 //====================================================================
00421 //        case preqProcessScopeDataOverFlow:
00422 //            ProcessScopeDataEx(PIN, DppState);
00423 //            //ProcessScopeDataOverFlowEx(PIN, DppState);
00424 //                      break;
00425 //        case preqProcessInetSettings:
00426 //            ProcessInetSettingsEx(PIN, DppState);
00427 //                      break;
00428         case preqProcessDiagData:
00429             ProcessDiagDataEx(PIN, DppState);
00430                         break;
00431 //        case preqProcessHwDesc:
00432 //            rocessHwDescEx(PIN, DppState);
00433 //                      break;
00434                 case preqProcessCfgRead:
00435                         ProcessCfgReadEx(PIN, DppState);
00436                         break;
00437         //     case preqProcessNetFindRead:
00438         //         //ProcessNetFindReadEx(PIN, DppState);
00439                         //break;
00440 //        case preqProcessSCAData:
00441 //            ProcessSCADataEx(PIN, DppState);
00442 //                      break;
00443 //====================================================================
00444
00445         case preqProcessAck:
00446             ProcessAck(PIN.PID2);
00447                         break;
00448         case preqProcessError:
00449             DisplayError(PIN, DppState);
00450                         break;
00451         default:
00452             //do nothing
00453                                 break;
00454     }
00455 }
00456
00457 void CvcDP5Dlg::DisplayError(Packet_In PIN, DppStateType DppState)
00458 {
00459         CString strError;
00460         ShowStatus(s.ParsePkt.PID2_TextToString("Received Packet", PIN.STATUS).c_str());
00461     // bad PID, assigned by ParsePacket
00462     if (PIN.STATUS == PID2_ACK_PID_ERROR) {
00463                 strError.Format("Received packet: PID1=0x.2X PID1=0x.2X LEN=%d",PIN.PID1,PIN.PID2,PIN.LEN);
00464                 ShowStatus(strError);
00465     }
00466 }
00467
00468 void CvcDP5Dlg::ProcessAck(unsigned char PID2)
00469 {
00470     ShowStatus(s.ParsePkt.PID2_TextToString("ACK", PID2).c_str());
00471 }
00472
00473 void CvcDP5Dlg::ProcessStatusEx(Packet_In PIN, DppStateType DppState)
00474 {
00475     long idxStatus;
00476         for(idxStatus=0;idxStatus<64;idxStatus++) {
00477         s.DP5Stat.m_DP5_Status.RAW[idxStatus] = PIN.DATA[idxStatus];
00478         }
00479     s.DP5Stat.Process_Status(&s.DP5Stat.m_DP5_Status);
00480         ConvertStatusDP5ToDP4(s.DP5Stat.m_DP5_Status);
00481     RequestScopeData(s.DP5Stat.m_DP5_Status.SCOPE_DR);
00482     ShowStatus("Received Status");
00483 }
00484
00485 // holds dp4/px4/dp5(px4emul) status and configuration
00486 // will be replaced by DP5 or generic status/config classes
00487 void CvcDP5Dlg::ConvertStatusDP5ToDP4(DP4_FORMAT_STATUS m_DP5_Status)
00488 {
00489         //=================================================
00490         // DP5 DP4 Status Values
00491         //=================================================
00492         s.DppConfig.SetFastThreshDone = m_DP5_Status.AFAST_LOCKED;        //BOOL
00493
00494
00495         //=================================================
00496         //dp4/px4/dp5(px4emul) status and configuration
00497         //=================================================
00498         s.DppConfig.SerialNumber = m_DP5_Status.SerialNumber;        //unsigned long
00499         s.DppConfig.FastCount = m_DP5_Status.FastCount;        //double
00500         s.DppConfig.SlowCount = m_DP5_Status.SlowCount;        //double
00501
00502         s.DppConfig.FPGA = m_DP5_Status.FPGA;        //unsigned char
00503         s.DppConfig.Firmware = m_DP5_Status.Firmware;        //unsigned char
00504         s.DppConfig.Build = m_DP5_Status.Build;        //unsigned char
00505
00506         s.DppConfig.AccumulationTime = m_DP5_Status.AccumulationTime;        //double
00507
00508         s.DppConfig.HVMonitor = m_DP5_Status.HV;        //double
00509         s.DppConfig.HVMonitorCStr.Format("%.0fV",s.DppConfig.HVMonitor);
00510
00511         s.DppConfig.TECMonitor = m_DP5_Status.DET_TEMP;        //double
00512         s.DppConfig.TECMonitorCStr.Format("%.0fK",s.DppConfig.TECMonitor);
00513
00514         s.DppConfig.BoardTemp = (int)m_DP5_Status.DP5_TEMP;        //double
00515         s.DppConfig.BoardTempCStr.Format("%d°C",s.DppConfig.BoardTemp);
00516
00517         //acquisition flags -> mca/mcs/preset status
00518         s.DppConfig.StatMcaEnabled = m_DP5_Status.MCA_EN;        //BOOL
00519         s.DppConfig.MCSDone = m_DP5_Status.MCS_DONE;        //BOOL
00520         s.DppConfig.PresetCountExpired = m_DP5_Status.PRECNT_REACHED;        //BOOL
00521         s.DppConfig.PresetRtDone = m_DP5_Status.PresetRtDone;   //BOOL
00522
00523         s.DppConfig.RealTime = m_DP5_Status.RealTime;
00524
00525         s.DppConfig.b80MHzMode = m_DP5_Status.b80MHzMode;
00526     s.DppConfig.bFPGAAutoClock = m_DP5_Status.bFPGAAutoClock;
00527
00528
00530
00531         // GammaRad HV
00532         s.DppConfig.bGammaRadHVMode = (BOOL)(m_DP5_Status.DEVICE_ID == 2);
00533
00534         // PC5 connected/PX5 HV Pwr Error
00535         s.DppConfig.bPC5Detected = m_DP5_Status.PC5_PRESENT;        //BOOL
00536
00537         // HV Polarity from status packet
00538         s.DppConfig.bBootHVPolarity = m_DP5_Status.PC5_HV_POL;        //BOOL
00539
00540 }
00541
00542 void CvcDP5Dlg::ProcessDiagDataEx(Packet_In PIN, DppStateType DppState)
00543 {
00544         string strDiagData;
00545         s.DP5Stat.Process_Diagnostics(PIN, &s.DP5Stat.DiagData, s.profile->device_type);
00546         strDiagData = s.DP5Stat.DiagnosticsToString(s.DP5Stat.DiagData, s.profile->device_type);
00547         GetDlgItem(IDC_EDIT_DIAG)->SetWindowText(strDiagData.c_str());
00548 }
00549
00550 void CvcDP5Dlg::ProcessSpectrumEx(Packet_In PIN, DppStateType DppState)
00551 {
00552         long idxSpectrum;
00553         long idxStatus;
00554         string strStatus;
00555
00556         s.DP5Proto.SPECTRUM.CHANNELS = (SHORT)(256 * pow(2.0,(((PIN.PID2 - 1) & 14) / 2)));
00557
00558         for(idxSpectrum=0;idxSpectrum<s.DP5Proto.SPECTRUM.CHANNELS;idxSpectrum++) {
00559         s.DP5Proto.SPECTRUM.DATA[idxSpectrum] = (long)(PIN.DATA[idxSpectrum * 3]) + (long)(PIN.DATA[idxSpectrum * 3 + 1]) * 256 + (long)(PIN.DATA[idxSpectrum * 3 + 2]) * 65536;
00560         }
00561
00562     if ((PIN.PID2 & 1) == 0) {    // spectrum + status
00563                 for(idxStatus=0;idxStatus<64;idxStatus++) {
00564                         s.DP5Stat.m_DP5_Status.RAW[idxStatus] = PIN.DATA[idxStatus + s.DP5Proto.SPECTRUM.CHANNELS * 3];
00565                 }
00566         s.DP5Stat.Process_Status(&s.DP5Stat.m_DP5_Status);
00567                 //strStatus = s.DP5Stat.ShowStatusValueStrings(s.DP5Stat.m_DP5_Status);
00568                 strStatus = s.DP5Stat.GetStatusValueStrings(s.DP5Stat.m_DP5_Status);
00569
00570                 //IDC_STATIC_SPECTRUM_STATUS
00571                 GetDlgItem(IDC_STATIC_SPECTRUM_STATUS)->SetWindowText(strStatus.c_str());
00572                 string strMiscInfo;
00573
00574                 strMiscInfo = "Preset Mode  ";
00575                 strMiscInfo += s.DppConfig.strPresetCmd;
00576                 strMiscInfo += "\r\n";
00577                 strMiscInfo += "Preset       ";
00578                 strMiscInfo += s.DppConfig.strPresetVal;
00579                 strMiscInfo += "\r\n";
00580
00581                 lblMiscStatus.SetText(strMiscInfo.c_str());
00582         RequestScopeData(s.DP5Stat.m_DP5_Status.SCOPE_DR);
00583     }
00584         m_PicturePlot.DataAcq(s.DP5Proto.SPECTRUM.DATA, s.DP5Proto.SPECTRUM.CHANNELS);  // plot data
00585 }
00586
00587 void CvcDP5Dlg::ProcessScopeDataEx(Packet_In PIN, DppStateType DppState)
00588 {
00589         ScopeDisplay(PIN.DATA);
00590         if (IsDlgButtonChecked(IDC_CHECK_AUTO_REARM)) {
00591                 SendCommand(XMTPT_ARM_DIGITAL_OSCILLOSCOPE);  //Call btnArmTrigger_Click
00592         }
00593 }
00594
00595 void CvcDP5Dlg::ProcessTextDataEx(Packet_In PIN, DppStateType DppState)
00596 {
00597     long idxTextData;
00598         CString strTextData;
00599         CString strCh;
00600
00601     strTextData = "";
00602         for(idxTextData=0;idxTextData<512;idxTextData++) {
00603                 strCh.Format("%c",PIN.DATA[idxTextData]);
00604         strTextData += strCh;
00605         }
00606         GetDlgItem(IDC_EDIT_MISC_DATA)->SetWindowText(strTextData);
00607 }
00608
00609 void CvcDP5Dlg::RequestScopeData(BOOL ScopeDataReady)
00610 {
00611     if (ScopeDataReady) {
00612                 SendCommand(XMTPT_SEND_SCOPE_DATA);
00613         }
00614 }
00615
00616 void CvcDP5Dlg::SendCommand(TRANSMIT_PACKET_TYPE XmtCmd)
00617 {
00618     BOOL HaveBuffer;
00619     BOOL SentPkt;
00620         //CONFIG_OPTIONS CfgOptions;
00621
00622         //CfgOptions.DppType = s.DP5Stat.m_DP5_Status.DEVICE_ID;
00623         //CfgOptions.HwCfgDP5Out = s.HwCfgDP5Out;
00624         //CfgOptions.PC5_PRESENT = s.DP5Stat.m_DP5_Status.PC5_PRESENT;
00625         //CfgOptions.SendCoarseFineGain = FALSE;
00626
00627     HaveBuffer = s.SndCmd.DP5_CMD(s.DP5Proto.BufferOUT, XmtCmd);
00628     if (HaveBuffer) {
00629                 switch (s.CurrentInterface) {
00630                         case RS232:
00631                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn)); // flush input
00632                                 s.DP5Proto.RS232BytesInBuffer = 0;
00633                                 s.DP5Proto.RS232HeaderReceived = FALSE;
00634                                 s.DP5Proto.RS232_RThreshold = 8;
00635                                 s.DP5Proto.ACK_Received = false;
00636                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00637                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00638                                 SentPkt = s.m_DppPort.SendPacketRS232(s.DP5Proto.BufferOUT, &s.m_DppPort);
00639                                 break;
00640                         case USB:
00641                                 s.DP5Proto.ACK_Received = false;
00642                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00643                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00644                                 SentPkt = s.DppWinUSB.SendPacketUSB(s.DP5Proto.BufferOUT, s.DppWinUSB.devInfo, s.DP5Proto.PacketIn);
00645                     if (SentPkt) {
00646                         RemCallParsePacket(s.DP5Proto.PacketIn);
00647                                         } else {
00648                         //Timer2.Enabled = False
00649                     }
00650                                 break;
00651                         case ETHERNET:
00652                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn));
00653                                 s.m_DppSck.RcvTotal = 0;                                 // reset vars
00654                                 s.m_DppSck.RcvCount = 0;
00655                                 s.m_DppSck.HaveHeader = FALSE;
00656                                 s.DP5Proto.ACK_Received = false;
00657                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00658                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00659                 SentPkt = s.m_DppSck.SendPacketInet(s.DP5Proto.BufferOUT, &s.m_DppSck);
00660                                 break;
00661                         default:
00662                                 break;
00663                 }
00664     }
00665 }
00666
00667 //DP5_CMD_Config is for: (requires pc5 and device info)
00668 //              XMTPT_SEND_CONFIG_PACKET_TO_HW
00669 //              XMTPT_SEND_CONFIG_PACKET_EX
00670 //              XMTPT_FULL_READ_CONFIG_PACKET
00671 //              XMTPT_READ_CONFIG_PACKET
00672 //              XMTPT_READ_CONFIG_PACKET_EX
00673 void CvcDP5Dlg::SendCommandConfig(TRANSMIT_PACKET_TYPE XmtCmd)
00674 {
00675     BOOL HaveBuffer;
00676     BOOL SentPkt;
00677         CONFIG_OPTIONS CfgOptions;
00678
00679         CfgOptions.DppType = s.DP5Stat.m_DP5_Status.DEVICE_ID;
00680         CfgOptions.HwCfgDP5Out = s.HwCfgDP5Out;
00681         CfgOptions.PC5_PRESENT = s.DP5Stat.m_DP5_Status.PC5_PRESENT;
00682         CfgOptions.SendCoarseFineGain = FALSE;
00683         CfgOptions.isDP5_RevDxGains = s.DP5Stat.m_DP5_Status.isDP5_RevDxGains;
00684         CfgOptions.DPP_ECO = s.DP5Stat.m_DP5_Status.DPP_ECO;
00685
00686     HaveBuffer = s.SndCmd.DP5_CMD_Config(s.DP5Proto.BufferOUT, XmtCmd, CfgOptions);
00687     if (HaveBuffer) {
00688   //      SentPkt = s.DppWinUSB.SendPacketUSB(s.DP5Proto.BufferOUT, s.DppWinUSB.devInfo, s.DP5Proto.PacketIn);
00689   //      if (SentPkt) {
00690   //          RemCallParsePacket(s.DP5Proto.PacketIn);
00691                 //} else {
00692   //          //Timer2.Enabled = False
00693   //      }
00694                 switch (s.CurrentInterface) {
00695                         case RS232:
00696                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn)); // flush input
00697                                 s.DP5Proto.RS232BytesInBuffer = 0;
00698                                 s.DP5Proto.RS232HeaderReceived = FALSE;
00699                                 s.DP5Proto.RS232_RThreshold = 8;
00700                                 s.DP5Proto.ACK_Received = false;
00701                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00702                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00703                                 SentPkt = s.m_DppPort.SendPacketRS232(s.DP5Proto.BufferOUT, &s.m_DppPort);
00704                                 break;
00705                         case USB:
00706                                 s.DP5Proto.ACK_Received = false;
00707                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00708                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00709                 SentPkt = s.DppWinUSB.SendPacketUSB(s.DP5Proto.BufferOUT, s.DppWinUSB.devInfo, s.DP5Proto.PacketIn);
00710                 if (SentPkt) {
00711                     RemCallParsePacket(s.DP5Proto.PacketIn);
00712                                 } else {
00713                     //Timer2.Enabled = False
00714                 }
00715                                 break;
00716                         case ETHERNET:
00717                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn));
00718                                 s.m_DppSck.RcvTotal = 0;                                 // reset vars
00719                                 s.m_DppSck.RcvCount = 0;
00720                                 s.m_DppSck.HaveHeader = FALSE;
00721                                 s.DP5Proto.ACK_Received = false;
00722                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00723                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00724                 SentPkt = s.m_DppSck.SendPacketInet(s.DP5Proto.BufferOUT, &s.m_DppSck);
00725                                 break;
00726                         default:
00727                                 break;
00728                 }
00729     }
00730 }
00731
00732 string CvcDP5Dlg::CreateSpectrumConfig(string strRawCfgIn)
00733 {
00734         string strDisplayCfgOut;
00735         string strCmdD;
00736
00737         strDisplayCfgOut = strRawCfgIn;
00738         if (Dp5CmdList.size() > 0) {
00739                 for (unsigned int idxCmd=0;idxCmd<Dp5CmdList.size();idxCmd++) {
00740                         strCmdD = Dp5CmdList[idxCmd];
00741                         if (strCmdD.length() > 0) {
00742                                 strDisplayCfgOut = AppendCmdDesc(strCmdD,strDisplayCfgOut);
00743                         }
00744                 }
00745         }
00746         return strDisplayCfgOut;
00747 }
00748
00749 void CvcDP5Dlg::SendCommandData(TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[])
00750 {
00751     BOOL HaveBuffer;
00752     BOOL SentPkt;
00753
00754     HaveBuffer = s.SndCmd.DP5_CMD_Data(s.DP5Proto.BufferOUT, XmtCmd, DataOut);
00755     if (HaveBuffer) {
00756                 switch (s.CurrentInterface) {
00757                         case RS232:
00758                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn)); // flush input
00759                                 s.DP5Proto.RS232BytesInBuffer = 0;
00760                                 s.DP5Proto.RS232HeaderReceived = FALSE;
00761                                 s.DP5Proto.RS232_RThreshold = 8;
00762                                 s.DP5Proto.ACK_Received = false;
00763                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00764                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00765                                 SentPkt = s.m_DppPort.SendPacketRS232(s.DP5Proto.BufferOUT, &s.m_DppPort);
00766                                 break;
00767                         case USB:
00768                                 s.DP5Proto.ACK_Received = false;
00769                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00770                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00771                 SentPkt = s.DppWinUSB.SendPacketUSB(s.DP5Proto.BufferOUT, s.DppWinUSB.devInfo, s.DP5Proto.PacketIn);
00772                 if (SentPkt) {
00773                     RemCallParsePacket(s.DP5Proto.PacketIn);
00774                                 } else {
00775                     //Timer2.Enabled = False
00776                 }
00777                                 break;
00778                         case ETHERNET:
00779                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn));
00780                                 s.m_DppSck.RcvTotal = 0;                                 // reset vars
00781                                 s.m_DppSck.RcvCount = 0;
00782                                 s.m_DppSck.HaveHeader = FALSE;
00783                                 s.DP5Proto.ACK_Received = false;
00784                                 s.DP5Proto.Packet_Received = false; // a response packet is always expected
00785                                 s.DP5Proto.PIN.STATUS = 0xFF;   // packet invalid - will be overwritten soon by response/ACK packet
00786                 SentPkt = s.m_DppSck.SendPacketInet(s.DP5Proto.BufferOUT, &s.m_DppSck);
00787                                 break;
00788                         default:
00789                                 break;
00790                 }
00791     }
00792 }
00793
00794 void CvcDP5Dlg::OnTimer(UINT nIDEvent)
00795 {
00796         if (nIDEvent == m_nTmrRS232Id) {                        //100ms RS232
00797                 //m_nTmrRS232Id = SetTimer(m_nTmrRS232EventId, m_nTmrRS232Elapse, NULL);
00798                 //MSComm1.RThreshold = 8  ' 8 byte ACK packet expected
00799                 //KillTimer(m_nTmrRS232Id);
00800         } else if (nIDEvent == m_nTmrSpectrumId) {      // 1000ms AutoSpectrum
00801                 if (IsDlgButtonChecked(IDC_CHECK_DELTA)) {
00802                         SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00803                 } else {
00804                         SendCommand(XMTPT_SEND_SPECTRUM_STATUS);
00805                 }
00806         } else if (nIDEvent == m_nTmrTimeoutId) {       // 10ms Comm TimeOut
00807                 //m_nTmrTimeoutId = SetTimer(m_nTmrTimeoutEventId, m_nTmrTimeoutElapse, NULL);
00808                 TimeoutFlag = TRUE;
00809         }
00810         CDialog::OnTimer(nIDEvent);
00811 }
00812
00813 void CvcDP5Dlg::OnBnClickedButtonArmTrigger()
00814 {
00815         SendCommand(XMTPT_ARM_DIGITAL_OSCILLOSCOPE);
00816 }
00817
00818 void CvcDP5Dlg::OnBnClickedButtonClearDataAndGraph()
00819 {
00820     SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00821         m_PicturePlot.ClearTrace();
00822 }
00823
00824 void CvcDP5Dlg::OnBnClickedButtonSingleUpdate()
00825 {
00826         if (m_nTmrSpectrumId > 0) {
00827                 KillTimer(m_nTmrSpectrumId);
00828                 m_nTmrSpectrumId = 0;
00829         }
00830         if (IsDlgButtonChecked(IDC_CHECK_DELTA)) {
00831                 SendCommand(XMTPT_SEND_CLEAR_SPECTRUM_STATUS);
00832         } else {
00833                 SendCommand(XMTPT_SEND_SPECTRUM_STATUS);
00834         }
00835 }
00836
00837 void CvcDP5Dlg::OnBnClickedButtonClearMiscData()
00838 {
00839         GetDlgItem(IDC_EDIT_MISC_DATA)->SetWindowText("");
00840 }
00841
00842 void CvcDP5Dlg::OnBnClickedButtonReadMiscData()
00843 {
00844         SendCommand(XMTPT_SEND_512_BYTE_MISC_DATA);
00845 }
00846
00847 void CvcDP5Dlg::OnBnClickedButtonWriteMiscData()
00848 {
00849         CString strMiscData;
00850         unsigned char byteMiscData[512];
00851         int idxCh;
00852         int DataLen;
00853
00854         GetDlgItem(IDC_EDIT_MISC_DATA)->GetWindowText(strMiscData);
00855         DataLen = strMiscData.GetLength();
00856         for(idxCh=0;idxCh<512;idxCh++) {
00857                 if (idxCh < DataLen) {
00858                         byteMiscData[idxCh] = (unsigned char)strMiscData.GetAt(idxCh);
00859                 } else {
00860                         byteMiscData[idxCh] = 0;
00861                 }
00862         }
00863     SendCommandData(XMTPT_WRITE_512_BYTE_MISC_DATA, byteMiscData);
00864 }
00865
00866 void CvcDP5Dlg::ShowStatus(CString strStatus)
00867 {
00868         GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strStatus);
00869 }
00870
00871 //-------------------------------------------------------------------
00872 // UpdateScope
00873 // Draws the scope display with the current scope buffer
00874 //-------------------------------------------------------------------
00875 void CvcDP5Dlg::UpdateScope()
00876 {
00877         CDC *dc=m_PictureScope.GetDC();                 // device context for plot
00878         CRect rect;
00879         CPen pen,*oldpen;
00880         m_PictureScope.GetClientRect(&rect);            // get plot client area
00881
00882         // Draw background rectangle
00883         if (HaveTrace) {
00884                 pen.CreatePen(PS_SOLID,1,RGB(0xFF,0x00,0x00));                  // drawing pen color
00885         } else {
00886                 pen.CreatePen(PS_SOLID,1,RGB(0xFF,0xFF,0xFF));                  // drawing pen color
00887         }
00888         oldpen=dc->SelectObject(&pen);                                                  // save old pen to restore
00889         CBrush WorkSpaceBrush( RGB(0xFF,0xFF,0xFF) );                   // fill brush color
00890         CBrush *oldbrush = dc->SelectObject(&WorkSpaceBrush);   // save old brush to restore
00891         dc->Rectangle(&rect);
00892         dc->Draw3dRect(&rect, (COLORREF)GetSysColor(COLOR_3DSHADOW), (COLORREF)GetSysColor(COLOR_3DHILIGHT));
00893
00894         // === needs to be updated,
00895         dc->SetMapMode(MM_ANISOTROPIC);                                         // x!=y
00896         dc->SetViewportOrg(0,rect.Height());                            // move 0,0 to bottom left
00897         dc->SetWindowExt(2048, -256);   // 2048 scope channels, 256 levels (invert y scale)
00898         dc->SetViewportExt(rect.Width(), rect.Height());        // viewport is pic control size
00899         //double y1, y2;
00900         for(int X=0; X<2047; X++) {
00901                 dc->MoveTo(X, ScopeBuffer[X]);
00902                 dc->LineTo(X+1, ScopeBuffer[X+1]);
00903         }
00904         dc->SelectObject(oldpen);
00905         pen.DeleteObject();
00906         dc->SelectObject(oldbrush);
00907         WorkSpaceBrush.DeleteObject();
00908         m_PictureScope.ReleaseDC(dc);
00909 }
00910
00911 //-------------------------------------------------------------------
00912 // ScopeDisplay
00913 // Calculates and saves the plot buffer data then calls UpdatePlot
00914 //-------------------------------------------------------------------
00915 void CvcDP5Dlg::ScopeDisplay(unsigned char ScopeData[2048])
00916 {
00917         int i;
00918     for (i = 0; i < 2048;i++ ) {                //get the largest value to be displayed
00919                 ScopeBuffer[i] = ScopeData[i];
00920     }
00921         HaveTrace = TRUE;
00922         UpdateScope();
00923 }
00924
00925 void CvcDP5Dlg::EnableDPPFunctions(BOOL isEnabled)
00926 {
00927         // find device is always enabled
00928         //GetDlgItem(IDC_BUTTON_FIND_DEVICE)->EnableWindow(isEnabled);  //Find Device
00929
00930         // Config
00931         //GetDlgItem(IDC_BUTTON_EDIT_CONFIG)->EnableWindow(isEnabled);  //CONFIG
00932         GetDlgItem(IDC_BUTTON_SHOW_CONFIG)->EnableWindow(isEnabled);    //CONFIG
00933
00934         // MCA functions
00935         GetDlgItem(IDC_BUTTON_SINGLE_UPDATE)->EnableWindow(isEnabled);  //Single Update
00936         GetDlgItem(IDC_BUTTON_START_ACQUISITION)->EnableWindow(isEnabled);      //Start Acquire
00937         GetDlgItem(IDC_BUTTON_STOP_ACQUISITION)->EnableWindow(isEnabled);       //Stop Acquire
00938         GetDlgItem(IDC_BUTTON_CLEAR_DATA_AND_GRAPH)->EnableWindow(isEnabled);   //Clear Data and Graph
00939         GetDlgItem(IDC_BUTTON_SAVE_FILE)->EnableWindow(isEnabled);      //Save File
00940
00941         // Scope
00942         GetDlgItem(IDC_BUTTON_ARM_TRIGGER)->EnableWindow(isEnabled); //Arm Trigger
00943
00944         //Text Data Buttons
00945         GetDlgItem(IDC_BUTTON_READ_MISC_DATA)->EnableWindow(isEnabled); //Read
00946         GetDlgItem(IDC_BUTTON_WRITE_MISC_DATA)->EnableWindow(isEnabled);        //Write
00947         GetDlgItem(IDC_BUTTON_CLEAR_MISC_DATA)->EnableWindow(isEnabled);        //Clear
00948
00949         // diagnostics
00950         GetDlgItem(IDC_BUTTON_DIAG)->EnableWindow(isEnabled);   //CONFIG
00951
00952 }
00953
00954 void CvcDP5Dlg::OnBnClickedButtonDiag()
00955 {
00956         SendCommand(XMTPT_SEND_DIAGNOSTIC_DATA);
00957 }
00958
00959 void CvcDP5Dlg::OnBnClickedButtonSelectComm()
00960 {
00961         CString strSelected;
00962         CSelectDP5 SelectDP5;
00963         CMSecTimer tmr;
00964         cWaitDialog dlg;        // display dialog box
00965         dlg.m_Text = "Adjusting Communications...please wait";
00966         dlg.Show();
00967         strSelected = "Select Communications";
00968         if (m_nTmrSpectrumId > 0) {
00969                 KillTimer(m_nTmrSpectrumId);
00970                 m_nTmrSpectrumId = 0;
00971                 tmr.msTimer(1000);              // put refresh rate here
00972         }
00973         OnResetCommunications();
00974         tmr.msTimer(200);
00975         dlg.Close();            // close wait dlg
00976         INT_PTR nResponse = SelectDP5.DoModal();
00977         if (nResponse == IDOK)
00978         {
00979                 EnableDPPFunctions(FALSE);
00980                 // TODO: Place code here to handle when the dialog is
00981                 //  dismissed with OK
00982                 // update communications controls
00983                 if (s.CurrentInterface == RS232) {
00984                         if (s.isDppFound[RS232]) {
00985                                 Sleep(100);
00986                                 if (s.m_DppPort.IsPortOpen()) {  // close the port
00987                                         s.m_DppPort.ClosePort();
00988                                 }
00989                                 Sleep(100);
00990                                 if (!s.m_DppPort.IsPortOpen()) {        // init the port
00991                                         if (s.m_DppPort.Settings(this, s.ComPort, 115200, 'N', 8, 1, EV_RXCHAR, 1024)) {
00992                                                 s.m_DppPort.OpenPort();
00993                                         }
00994                                 }
00995                                 Sleep(100);
00996                                 if (s.m_DppPort.IsPortOpen()) {         // success
00997                                         strSelected.Format("RS232 - COM%d", s.ComPort);
00998                                         EnableDPPFunctions(TRUE);
00999                                 }
01000                                 Sleep(100);
01001                         }
01002                 } if (s.CurrentInterface == USB) {
01003                         if (s.DppWinUSB.devInfo.deviceConnected) {
01004                                 strSelected = "USB - WinUSB";
01005                                 EnableDPPFunctions(TRUE);
01006                         }
01007                 } else  if (s.CurrentInterface == ETHERNET) {
01008                         if (s.isDppFound[ETHERNET]) {
01009                                 strSelected = "IP " + s.strSockAddr;
01010                                 s.m_DppSck.CloseSocket();
01011                                 s.m_DppSck.CreateSocket(this);
01012                                 s.m_DppSck.m_Owner = sockownMainDlg;
01013                                 EnableDPPFunctions(TRUE);
01014
01015                         }
01016                 }
01017                 isConnectedTest();
01018                 lblSelectCommunications.SetText(strSelected);
01019         }
01020         else if (nResponse == IDCANCEL)
01021         {
01022                 // TODO: Place code here to handle when the dialog is
01023                 //  dismissed with Cancel
01024         }
01025 }
01026
01027 CString CvcDP5Dlg::GetDeviceNameFromVal(int DeviceTypeVal)
01028 {
01029     CString strDeviceType;
01030         switch(DeviceTypeVal) {
01031                 case dppDP5:
01032             strDeviceType = "DP5";
01033                         break;
01034                 case dppPX5:
01035             strDeviceType = "PX5";
01036                         break;
01037                 case dppDP5G:
01038             strDeviceType = "DP5G";
01039                         break;
01040                 case dppMCA8000D:
01041             strDeviceType = "MCA8000D";
01042                         break;
01043                 case dppTB5:
01044             strDeviceType = "TB5";
01045                         break;
01046                 case dppDP5X:
01047             strDeviceType = "DP5-X";
01048                         break;
01049                 default:           //if unknown set to DP5
01050             strDeviceType = "DP5";
01051                         break;
01052         }
01053     return strDeviceType;
01054 }
01055
01056
01057 // sets/returns if DPP is connected based on CurrentInterface and isDppFound[]
01058 BOOL CvcDP5Dlg::isConnectedTest()
01059 {
01060         unsigned char CurrentInterface;
01061         BOOL isDppFound;
01062         CMSecTimer tmr;
01063
01064         // test if CurrentInterface is set
01065         if ((s.CurrentInterface >= RS232) && (s.CurrentInterface <= ETHERNET)) {
01066                 // test if unit is found
01067                 CurrentInterface = s.CurrentInterface;
01068                 isDppFound = s.isDppFound[CurrentInterface];
01069                 s.isDppConnected = isDppFound;
01070
01071                 if (s.isDppConnected) {
01072                         SendCommand(XMTPT_SEND_STATUS); // request status
01073                         tmr.msTimer(500);
01074                 }
01075
01076                 s.profile->device_type = s.DP5Stat.m_DP5_Status.DEVICE_ID;
01077                 s.DppConfig.DeviceType = s.DP5Stat.m_DP5_Status.DEVICE_ID;
01078                 s.profile->strDevice = GetDeviceNameFromVal(s.profile->device_type);
01079
01080                 s.DppCommStatusInd = (int)(s.CurrentInterface * 2) + (int)isDppFound;
01081                 return isDppFound;
01082         } else {
01083                 s.isDppConnected = FALSE;
01084                 return FALSE;
01085         }
01086 }
01087
01088 // Serial Comm Port Character Received Event
01089 LONG CvcDP5Dlg::OnCommunication(WPARAM ch, LPARAM Bytes)
01090 {
01091
01092         DWORD BytesRead;
01093         BytesRead = (DWORD)Bytes;
01094         if (BytesRead == 0)
01095                 return -1;
01096
01097         s.DP5Proto.PacketIn[s.DP5Proto.RS232BytesInBuffer]=(unsigned char)ch;
01098         s.DP5Proto.RS232BytesInBuffer+=BytesRead;
01099
01100         // this calls OnComm for RxChar Events
01101         if (s.DP5Proto.RS232_RThreshold == 0) { // always call if thresh == 0
01102                 OnComm();
01103         } else if (s.DP5Proto.RS232BytesInBuffer >= s.DP5Proto.RS232_RThreshold) {
01104                 OnComm();
01105         }
01106         return 0;
01107 }
01108
01109 // Serial Comm Port Bulk Character Processing
01110 void CvcDP5Dlg::OnComm()
01111 {
01112         long pktLen;
01113
01114         if (s.DP5Proto.RS232HeaderReceived) {
01115                 s.DP5Proto.RS232HeaderReceived = FALSE;
01116                 // the buffer should have the data, oncomm only call when rthresh bytes
01117                 if (s.DP5Proto.RS232BytesInBuffer == s.DP5Proto.RS232_RThreshold) {
01118                         //KillTimer(m_nTmrRS232Id);
01119                         RemCallParsePacket(s.DP5Proto.PacketIn);
01120                 }
01121                 s.DP5Proto.RS232_RThreshold = 8;        // reset oncomm for next message
01122         } else {
01123                 if (s.DP5Proto.RS232BytesInBuffer >= s.DP5Proto.RS232_RThreshold) {
01124                         if ((s.DP5Proto.PacketIn[0] == 0xF5) && (s.DP5Proto.PacketIn[1] == 0xFA)) {
01125                                 pktLen = (long)((s.DP5Proto.PacketIn[4] * 256) + s.DP5Proto.PacketIn[5] + 8);   // temporarily save the length field
01126                 if (pktLen > 0) {
01127                     s.DP5Proto.RS232_RThreshold = pktLen;   // additional bytes to read = data length
01128                                         //SetDataRcvTimer(RS232_RThreshold);
01129                     s.DP5Proto.RS232HeaderReceived = TRUE;
01130                 } else {
01131                     //ParsePacket(DataIn[]);
01132                 }
01133             } else {
01134                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn));  // flush the buffer by emptying it
01135                         }
01136                 }
01137         }
01138 }
01139
01140 //void CvcDP5Dlg::OnReceive(int nErrorCode)
01141 LONG CvcDP5Dlg::OnReceive(WPARAM ch, LPARAM Bytes)
01142 {
01143         CString SourceIPAddr;
01144         UINT SourcePort;
01145         unsigned char buffer[1024] = {0};
01146         int RcvBytes;
01147         int idxNewData;
01148         long pktLen;
01149         CString strStatus;
01150         BOOL HavePkt;
01151
01152
01153     memset(&buffer, 0, sizeof(buffer));  // flush the buffer by emptying it
01154         RcvBytes = s.m_DppSck.ReceiveFrom(&buffer, sizeof(buffer), SourceIPAddr, SourcePort);
01155
01156
01157         // Check for errors
01158         if(RcvBytes > sizeof(buffer)){                  // buffer overflow
01159                 // Handle Error
01160                 return 0;
01161                 //return;
01162         } else if((s.m_DppSck.RcvCount +  RcvBytes) > sizeof(s.DP5Proto.PacketIn)){
01163                 // Handle Error // buffer overflow
01164                 return 0;
01165                 //return;
01166         } else if(RcvBytes == SOCKET_ERROR) {   // Call GetLastError To Get Message
01167                 // Handle Error
01168                 return 0;
01169                 //return;
01170         }
01171
01172         if((s.m_DppSck.RcvCount +  RcvBytes) > sizeof(s.DP5Proto.PacketIn)){
01173                 // Handle Error // buffer overflow
01174                 return 0;
01175                 //return;
01176         }
01177
01178         HavePkt = FALSE;
01179
01180         if (s.m_DppSck.HaveHeader) {  // have header and new data, add data to packet
01181                 for(idxNewData=0;idxNewData<RcvBytes;idxNewData++){
01182                         s.DP5Proto.PacketIn[s.m_DppSck.RcvCount] = buffer[idxNewData];
01183                         s.m_DppSck.RcvCount++;
01184                 }
01185                 if (s.m_DppSck.RcvCount >= s.m_DppSck.RcvTotal) {
01186                         HavePkt = TRUE;
01187
01188                         RemCallParsePacket(s.DP5Proto.PacketIn); // have packet, process packet
01189                         s.m_DppSck.RcvTotal = 0;                                 // reset vars
01190                         s.m_DppSck.RcvCount = 0;
01191                         s.m_DppSck.HaveHeader = FALSE;
01192                 }
01193         } else {                                        // no header found yet, get packet info
01194                 if (RcvBytes >= 8) {    // 1st packet must always have header, check header/length
01195                         if ((buffer[0] == 0xF5) && (buffer[1] == 0xFA)) {
01196                                 pktLen = (long)((buffer[4] * 256) + buffer[5] + 8);   // temporarily save the length field
01197                 s.m_DppSck.RcvTotal = pktLen;   // additional bytes to read = data length
01198                                 s.m_DppSck.RcvCount = 0;                // haven't saved the data yet
01199                 s.m_DppSck.HaveHeader = TRUE;
01200                                 for(idxNewData=0;idxNewData<RcvBytes;idxNewData++){
01201                                         s.DP5Proto.PacketIn[s.m_DppSck.RcvCount] = buffer[idxNewData];
01202                                         s.m_DppSck.RcvCount++;
01203                                 }
01204                                 if ((pktLen == 8) || (s.m_DppSck.RcvCount >= s.m_DppSck.RcvTotal)) {
01205                                         RemCallParsePacket(s.DP5Proto.PacketIn); // have packet, process packet
01206                                         s.m_DppSck.RcvTotal = 0;                                 // reset vars
01207                                         s.m_DppSck.RcvCount = 0;
01208                                         s.m_DppSck.HaveHeader = FALSE;
01209                 }
01210                         } else {                                                // this is an error
01212                                 memset(&s.DP5Proto.PacketIn, 0, sizeof(s.DP5Proto.PacketIn));
01213                                 s.m_DppSck.RcvTotal = 0;                                 // reset vars
01214                                 s.m_DppSck.RcvCount = 0;
01215                                 s.m_DppSck.HaveHeader = FALSE;
01216                         }
01217                 }
01218         }
01219         return 0;
01220         //return;
01221 }
01222
01223 void CvcDP5Dlg::OnBnClickedButtonStartAcquisition()
01224 {
01225         SendCommand(XMTPT_ENABLE_MCA_MCS);
01226         m_nTmrSpectrumId = SetTimer(m_nTmrSpectrumEventId, m_nTmrSpectrumElapse, NULL);
01227 }
01228
01229 void CvcDP5Dlg::OnBnClickedButtonStopAcquisition()
01230 {
01231         SendCommand(XMTPT_DISABLE_MCA_MCS);
01232 }
01233
01234 void CvcDP5Dlg::OnBnClickedButtonEditConfig()
01235 {
01236         CDP5CfgWnd *m_pdlg;
01237         s.DppConfig.b80MHzModeCfg = s.DppConfig.b80MHzMode;
01238         m_pdlg = new CDP5CfgWnd(IDS_CAPTION);
01239         INT_PTR nResponse = m_pdlg->DoModal();
01240         if (nResponse == IDOK) {
01241                 // TODO: Place code here to handle when the dialog is
01242                 //  dismissed with OK
01243         } else if (nResponse == IDCANCEL)
01244         {
01245                 // TODO: Place code here to handle when the dialog is
01246                 //  dismissed with Cancel
01247         }
01248         delete m_pdlg;
01249 }
01250
01251 LRESULT CvcDP5Dlg::DppSendConfigToHw(WPARAM wParam, LPARAM lParam)
01252 {
01253         if (s.isDppConnected) {
01254                 if (s.HwCfgReady) {
01255                         SendCommandConfig(XMTPT_SEND_CONFIG_PACKET_TO_HW);      // send the packet
01256                         s.HwCfgReady = FALSE;
01257                         //AfxMessageBox("Config Sent To HW");
01258                 } else if (s.HwCfgExReady) {
01259                         SendCommandConfig(XMTPT_SEND_CONFIG_PACKET_EX); // send the packet
01260                         s.HwCfgExReady = FALSE;
01261                 }
01262         }
01263         CMSecTimer tmr;
01264         if (s.isDppConnected) {
01265                 tmr.msTimer(20);
01266                 //Sleep(20);                                                            // wait a short time
01267                 SendCommandConfig(XMTPT_READ_CONFIG_PACKET);  // get info for display
01268                 tmr.msTimer(20);
01269         }
01270         return (Default());
01271 }
01272
01273 LRESULT CvcDP5Dlg::CallReadDppConfig(WPARAM wParam, LPARAM lParam)
01274 {
01275         if (s.isDppConnected) {
01276                 s.DppConfig.CfgReadBack = TRUE;
01277                 SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
01278         }
01279         return (Default());
01280 }
01281
01282 LRESULT CvcDP5Dlg::CallReadDppConfigEx(WPARAM wParam, LPARAM lParam)
01283 {
01284         if (s.isDppConnected) {
01285                 s.DppConfig.CfgReadBack = TRUE;
01286                 SendCommandConfig(XMTPT_READ_CONFIG_PACKET_EX);
01287         }
01288         return (Default());
01289 }
01290
01291 LRESULT CvcDP5Dlg::CallReadScaConfig(WPARAM wParam, LPARAM lParam)
01292 {
01293         if (s.isDppConnected) {
01294                 s.DppConfig.ScaReadBack = TRUE;
01295                 SendCommand(XMTPT_SCA_READ_CONFIG_PACKET);
01296         }
01297         return (Default());
01298 }
01299
01300 void CvcDP5Dlg::ProcessCfgReadEx(Packet_In PIN, DppStateType DppState)
01301 {
01302         CString strRawCfgIn;
01303         CString strRawCfgOut;
01304         CString strCh;
01305         CString strCmdData;
01306         strRawCfgIn = "";
01307         CString strCmdD;
01308         CString strCfg;
01309         BOOL isScaCfg = FALSE;
01310         CString strDisplayCfgOut;
01311
01312         strRawCfgOut = "";
01313         // ==========================================================
01314         // ===== Create Raw Configuration Buffer From Hardware ======
01315         for (int idxCfg=0;idxCfg<PIN.LEN;idxCfg++) {
01316                 strCh.Format("%c",PIN.DATA[idxCfg]);
01317                 strRawCfgIn += strCh;
01318                 strRawCfgOut += strCh;
01319                 if (PIN.DATA[idxCfg] == ';') {
01320                         strRawCfgIn += "\r\n";
01321                 }
01322         }
01323
01324         // ==========================================================
01325         if (s.DppConfig.DisplayCfg) {
01326                 s.DppConfig.DisplayCfg = FALSE;
01327                 strCfg = strRawCfgIn;
01328                 strDisplayCfgOut = strRawCfgIn;
01329                 for (int idxCmd=0;idxCmd<=s.Dp5CmdList.GetUpperBound();idxCmd++) {
01330                         strCmdD = s.Dp5CmdList[idxCmd];
01331                         if (strCmdD.GetLength() > 0) {
01332                                 strDisplayCfgOut = ReplaceCmdDescMS(strCmdD,strDisplayCfgOut);
01333                         }
01334                 }
01335                 CopyDp5CfgToClip(strCfg,strDisplayCfgOut);
01336                 CMsgBox MsgBox;
01337                 MsgBox.m_strTitle = "DPP Configuration";
01338                 MsgBox.m_strMessage = strDisplayCfgOut;
01339                 MsgBox.m_strDelimiter = ";";
01340                 MsgBox.DoModal();
01341                 return;
01342         } else if (s.DppConfig.CfgReadBack) {
01343                 s.DppConfig.CfgReadBack = FALSE;
01344                 s.HwCfgDP5 = strRawCfgIn;
01345                 s.HwCfgReady = TRUE;
01346         } else if (s.DppConfig.ScaReadBack) {
01347                 //s.HwCfgDP5 = strRawCfgIn;
01348         //s.strRawCfgIn = strRawCfgIn;
01349                 s.scafn.SCACfgParser(&s.sca, strRawCfgOut);
01350         s.HwCfgReady = TRUE;
01351                 //if (s.DppConfig.DisplaySCA) {
01352             //AfxMessageBox(SCAStringALLDisplay(sca));
01353                 //}
01354     }
01355         s.DppConfig.SaveCfg = FALSE;
01356         s.DppConfig.PrintCfg = FALSE;
01357         s.DppConfig.DisplayCfg = FALSE;
01358         s.DppConfig.CfgReadBack = FALSE;
01359
01360         isScaCfg = (BOOL)(s.DppConfig.ScaReadBack || s.DppConfig.DisplaySca);
01361         s.DppConfig.ScaReadBack = FALSE;
01362         s.DppConfig.DisplaySca = FALSE;
01363         if (isScaCfg) {
01364                 return;
01365         }
01366         strCmdData = GetCmdDataMS("MCAS",strRawCfgIn); // mca mode
01367         strCmdData = GetCmdDataMS("MCAC",strRawCfgIn); // channels
01368         if ((atoi(strCmdData) > 0) && (atoi(strCmdData) <= 8192)) {
01369                 s.DppConfig.mcaCH = atoi(strCmdData);
01370         } else {
01371                 s.DppConfig.mcaCH = 1024;
01372         }
01373
01374         strCmdData = GetCmdDataMS("THSL",strRawCfgIn); // LLD thresh
01375         s.DppConfig.SlowThresholdPct = atof(strCmdData);
01376
01377         strCmdData = GetCmdDataMS("THFA",strRawCfgIn); // fast thresh
01378         s.DppConfig.FastChThreshold = atoi(strCmdData);
01379
01380         strCmdData = GetCmdDataMS("TPEA",strRawCfgIn); // peak time
01381         s.DppConfig.RiseUS = atof(strCmdData);
01382
01383         strCmdData = GetCmdDataMS("GAIN",strRawCfgIn); // gain
01384         s.DppConfig.strGainDisplayValue = strCmdData + "x";
01385
01386         s.DppConfig.strPresetCmd = "";
01387         s.DppConfig.strPresetVal = "";
01388
01389         strCmdData = GetCmdDataMS("PREC",strRawCfgIn); //preset count
01390         s.DppConfig.PresetCount = atoi(strCmdData);
01391         if (s.DppConfig.PresetCount > 0) {
01392                 if (s.DppConfig.strPresetCmd.GetLength() > 0) { s.DppConfig.strPresetCmd += "/"; }
01393                 if (s.DppConfig.strPresetVal.GetLength() > 0) { s.DppConfig.strPresetVal += "/"; }
01394                 s.DppConfig.strPresetCmd += "Cnt";
01395                 s.DppConfig.strPresetVal += strCmdData;
01396         }
01397
01398         strCmdData = GetCmdDataMS("PRET",strRawCfgIn); //preset actual time
01399         s.DppConfig.PresetAcq = atof(strCmdData);
01400         if (s.DppConfig.PresetAcq > 0) {
01401                 if (s.DppConfig.strPresetCmd.GetLength() > 0) { s.DppConfig.strPresetCmd += "/"; }
01402                 if (s.DppConfig.strPresetVal.GetLength() > 0) { s.DppConfig.strPresetVal += "/"; }
01403                 s.DppConfig.strPresetCmd += "Acq";
01404                 s.DppConfig.strPresetVal += strCmdData;
01405         }
01406
01407         strCmdData = GetCmdDataMS("PRER",strRawCfgIn); // preset real time
01408         s.DppConfig.PresetRt = atof(strCmdData);
01409         if (s.DppConfig.PresetRt > 0) {
01410                 if (s.DppConfig.strPresetCmd.GetLength() > 0) { s.DppConfig.strPresetCmd += "/"; }
01411                 if (s.DppConfig.strPresetVal.GetLength() > 0) { s.DppConfig.strPresetVal += "/"; }
01412                 s.DppConfig.strPresetCmd += "Real";
01413                 s.DppConfig.strPresetVal += strCmdData;
01414         }
01415
01416         if (s.DppConfig.strPresetCmd.GetLength() == 0) {
01417                 s.DppConfig.strPresetCmd += "None";
01418         }
01419         if (s.DppConfig.strPresetVal.GetLength() == 0) {
01420                 //s.DppConfig.strPresetVal += "";
01421         }
01422
01423         strCmdData = GetCmdDataMS("CLCK",strRawCfgIn); // fpga clock mode
01424         if (atoi(strCmdData) == 80) {
01425                 s.DppConfig.b80MHzMode = TRUE;
01426         } else {
01427                 s.DppConfig.b80MHzMode = FALSE;
01428         }
01429
01430         // DP5 oscilloscope support
01431         strCmdData = GetCmdDataMS("INOF",strRawCfgIn); // osc. Input offset
01432         s.DppConfig.strInputOffset = strCmdData;
01433
01434         strCmdData = GetCmdDataMS("DACO",strRawCfgIn); // osc. DAC output
01435         s.DppConfig.strAnalogOut = strCmdData;
01436
01437         strCmdData = GetCmdDataMS("DACF",strRawCfgIn); // osc. DAC offset
01438         s.DppConfig.strOutputOffset = strCmdData;
01439
01440         strCmdData = GetCmdDataMS("AUO1",strRawCfgIn); // osc. AUX_OUT1
01441         s.DppConfig.strTriggerSource = strCmdData;
01442
01443         strCmdData = GetCmdDataMS("SCOE",strRawCfgIn); // osc. Scope trigger edge
01444         s.DppConfig.strTriggerSlope = strCmdData;
01445
01446         strCmdData = GetCmdDataMS("SCOT",strRawCfgIn); // osc. Scope trigger position
01447         s.DppConfig.strTriggerPosition = strCmdData;
01448
01449         strCmdData = GetCmdDataMS("SCOG",strRawCfgIn); // osc. Scope gain
01450         s.DppConfig.strScopeGain = strCmdData;
01451
01452         strCmdData = GetCmdDataMS("MCAS",strRawCfgIn); // Acq Mode
01453         s.DppConfig.AcqMode = 0;
01454         s.DppConfig.strMcaMode = "MCA";
01455         if (strCmdData == "NORM") {
01456                 s.DppConfig.strMcaMode = "MCA";
01457         } else if (strCmdData == "MCS") {
01458                 s.DppConfig.strMcaMode = "MCS";
01459                 s.DppConfig.AcqMode = 1;
01460         } else if (strCmdData.GetLength() > 0) {
01461                 s.DppConfig.strMcaMode = strCmdData;
01462         }
01463         s.DppConfig.UpdateScopeCfg = TRUE;
01464 }
01465
01466 CString CvcDP5Dlg::GetCmdDataMS(CString strCmd, CString strCfgData)
01467 {
01468         int iStart,iEnd,iCmd;
01469         CString strCmdData;
01470
01471         strCmdData = "";
01472         if (strCfgData.GetLength() < 7) { return strCmdData; }  // no data
01473         if (strCmd.GetLength() != 4) {  return strCmdData; }            // bad command
01474         iCmd = strCfgData.Find(strCmd+"=",0);
01475         if (iCmd == -1) { return strCmdData; }                  // cmd not found
01476         iStart = strCfgData.Find("=",iCmd);
01477         if (iStart == -1) { return strCmdData; }                // data start not found
01478         iEnd = strCfgData.Find(";",iCmd);
01479         if (iEnd == -1) {return strCmdData; }                   // data end found
01480         if (iStart >= iEnd) { return strCmdData; }              // data error
01481         strCmdData = strCfgData.Mid(iStart+1,(iEnd - (iStart+1)));
01482         //AfxMessageBox(strCmdData);
01483         return strCmdData;
01484 }
01485
01486 string CvcDP5Dlg::GetCmdData(string strCmd, string strCfgData)
01487 {
01488         int iStart,iEnd,iCmd;
01489         string strCmdData;
01490
01491         strCmdData = "";
01492         if (strCfgData.length() < 7) { return strCmdData; }     // no data
01493         if (strCmd.length() != 4) {     return strCmdData; }            // bad command
01494         iCmd = (int)strCfgData.find(strCmd+"=",0);
01495         if (iCmd == -1) { return strCmdData; }                  // cmd not found
01496         iStart = (int)strCfgData.find("=",iCmd);
01497         if (iStart == -1) { return strCmdData; }                // data start not found
01498         iEnd = (int)strCfgData.find(";",iCmd);
01499         if (iEnd == -1) {return strCmdData; }                   // data end found
01500         if (iStart >= iEnd) { return strCmdData; }              // data error
01501         strCmdData = strCfgData.substr(iStart+1,(iEnd - (iStart+1)));
01502         return strCmdData;
01503 }
01504
01505 CString CvcDP5Dlg::ReplaceCmdDescMS(CString strCmd, CString strCfgData)
01506 {
01507         int iStart,iCmd;        //iEnd,
01508         CString strNew;
01509         CString strDesc;
01510
01511         strNew = "";
01512         if (strCfgData.GetLength() < 7) { return strCfgData; }  // no data
01513         if (strCmd.GetLength() != 4) {  return strCfgData; }            // bad command
01514         iCmd = strCfgData.Find(strCmd+"=",0);
01515         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
01516
01517         strDesc = GetCmdDescMS(strCmd);
01518         if (strDesc.GetLength() == 0) { return strCfgData; }            // cmd desc  not found
01519         iStart = strCfgData.Find("=",iCmd);
01520         if (iStart != (iCmd + 4)) { return strCfgData; }                        // data start not found
01521         if (iCmd <= 0) {        // usually left string has iCmd-1
01522                 iCmd = 1;               // in this case left has 0 chars, set offset
01523         }
01524         strNew = strCfgData.Left(iCmd-1) + strDesc + strCfgData.Mid(iStart);
01525         return strNew;
01526 }
01527
01528
01529 string CvcDP5Dlg::ReplaceCmdDesc(string strCmd, string strCfgData)
01530 {
01531         int iStart,iCmd;        //iEnd,
01532         string strNew;
01533         string strDesc;
01534
01535         strNew = "";
01536         if (strCfgData.length() < 7) { return strCfgData; }     // no data
01537         if (strCmd.length() != 4) {     return strCfgData; }            // bad command
01538         iCmd = (int)strCfgData.find(strCmd+"=",0);
01539         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
01540
01541         strDesc = GetCmdDesc(strCmd);
01542         if (strDesc.length() == 0) { return strCfgData; }               // cmd desc  not found
01543         iStart = (int)strCfgData.find("=",iCmd);
01544         if (iStart != (iCmd + 4)) { return strCfgData; }                        // data start not found
01545         if (iCmd <= 0) {        // usually left string has iCmd-1
01546                 iCmd = 1;               // in this case left has 0 chars, set offset
01547         }
01548         strNew = strCfgData.substr(0,iCmd-1) + strDesc + strCfgData.substr(iStart);
01549         return strNew;
01550 }
01551
01552 string CvcDP5Dlg::AppendCmdDesc(string strCmd, string strCfgData)
01553 {
01554         int iStart,iEnd,iCmd;
01555         string strNew;
01556         string strDesc;
01557
01558         strNew = "";
01559         if (strCfgData.length() < 7) { return strCfgData; }     // no data
01560         if (strCmd.length() != 4) {     return strCfgData; }            // bad command
01561         iCmd = (int)strCfgData.find(strCmd+"=",0);
01562         if (iCmd == -1) { return strCfgData; }                                          // cmd not found
01563         iEnd = (int)strCfgData.find(";",iCmd);
01564         if (iEnd == -1) {return strCfgData; }                   // data end found
01565         iStart = (int)strCfgData.find("=",iCmd);
01566         if (iStart != (iCmd + 4)) { return strCfgData; }                        // data start not found
01567         if (iStart >= iEnd) { return strCfgData; }              // data error
01568         strDesc = GetCmdDesc(strCmd);
01569         if (strDesc.length() == 0) { return strCfgData; }               // cmd desc  not found
01570         strNew = strCfgData.substr(0,iEnd+1) + "    " + strDesc + strCfgData.substr(iEnd+1);
01571         return strNew;
01572 }
01573
01574 vector<string> CvcDP5Dlg::MakeDp5CmdList()
01575 {
01576         vector<string> cstrCfgArr;
01577         cstrCfgArr.clear();
01578         cstrCfgArr.push_back("RESC");
01579         cstrCfgArr.push_back("CLCK");
01580         cstrCfgArr.push_back("TPEA");
01581         cstrCfgArr.push_back("GAIF");
01582         cstrCfgArr.push_back("GAIN");
01583         cstrCfgArr.push_back("RESL");
01584         cstrCfgArr.push_back("TFLA");
01585         cstrCfgArr.push_back("TPFA");
01586         cstrCfgArr.push_back("PURE");
01587         cstrCfgArr.push_back("RTDE");
01588         cstrCfgArr.push_back("MCAS");
01589         cstrCfgArr.push_back("MCAC");
01590         cstrCfgArr.push_back("SOFF");
01591         cstrCfgArr.push_back("AINP");
01592         cstrCfgArr.push_back("INOF");
01593         cstrCfgArr.push_back("GAIA");
01594         cstrCfgArr.push_back("CUSP");
01595         cstrCfgArr.push_back("PDMD");
01596         cstrCfgArr.push_back("THSL");
01597         cstrCfgArr.push_back("TLLD");
01598         cstrCfgArr.push_back("THFA");
01599         cstrCfgArr.push_back("DACO");
01600         cstrCfgArr.push_back("DACF");
01601         cstrCfgArr.push_back("RTDS");
01602         cstrCfgArr.push_back("RTDT");
01603         cstrCfgArr.push_back("BLRM");
01604         cstrCfgArr.push_back("BLRD");
01605         cstrCfgArr.push_back("BLRU");
01606         cstrCfgArr.push_back("GATE");
01607         cstrCfgArr.push_back("AUO1");
01608         cstrCfgArr.push_back("PRET");
01609         cstrCfgArr.push_back("PRER");
01610         cstrCfgArr.push_back("PREL");
01611         cstrCfgArr.push_back("PREC");
01612         cstrCfgArr.push_back("PRCL");
01613         cstrCfgArr.push_back("PRCH");
01614         cstrCfgArr.push_back("HVSE");
01615         cstrCfgArr.push_back("TECS");
01616         cstrCfgArr.push_back("PAPZ");
01617         cstrCfgArr.push_back("PAPS");
01618         cstrCfgArr.push_back("SCOE");
01619         cstrCfgArr.push_back("SCOT");
01620         cstrCfgArr.push_back("SCOG");
01621         cstrCfgArr.push_back("MCSL");
01622         cstrCfgArr.push_back("MCSH");
01623         cstrCfgArr.push_back("MCST");
01624         cstrCfgArr.push_back("AUO2");
01625         cstrCfgArr.push_back("TPMO");
01626         cstrCfgArr.push_back("GPED");
01627         cstrCfgArr.push_back("GPIN");
01628         cstrCfgArr.push_back("GPME");
01629         cstrCfgArr.push_back("GPGA");
01630         cstrCfgArr.push_back("GPMC");
01631         cstrCfgArr.push_back("MCAE");
01632         cstrCfgArr.push_back("VOLU");
01633         cstrCfgArr.push_back("CON1");
01634         cstrCfgArr.push_back("CON2");
01635         cstrCfgArr.push_back("BOOT");
01636         return cstrCfgArr;
01637 }
01638
01639 CString CvcDP5Dlg::GetCmdDescMS(CString strCmd)
01640 {
01641         CString strCmdName = "";
01642         if (strCmd == "RESC") {
01643                 strCmdName = "Reset Configuration";
01644         } else if (strCmd == "CLCK") {
01645                 strCmdName = "20MHz/80MHz";
01646         } else if (strCmd == "TPEA") {
01647                 strCmdName = "peaking time";
01648         } else if (strCmd == "GAIF") {
01649                 strCmdName = "Fine gain";
01650         } else if (strCmd == "GAIN") {
01651                 strCmdName = "Total Gain (analog * fine)";
01652         } else if (strCmd == "RESL") {
01653                 strCmdName = "Detector Reset lockout";
01654         } else if (strCmd == "TFLA") {
01655                 strCmdName = "Flat top";
01656         } else if (strCmd == "TPFA") {
01657                 strCmdName = "Fast channel peaking time";
01658         } else if (strCmd == "RTDE") {
01659                 strCmdName = "RTD on/off";
01660         } else if (strCmd == "MCAS") {
01661                 strCmdName = "MCA Source";
01662         } else if (strCmd == "RTDD") {
01663                 strCmdName = "Custom RTD oneshot delay";
01664         } else if (strCmd == "RTDW") {
01665                 strCmdName = "Custom RTD oneshot width";
01666         } else if (strCmd == "PURE") {
01667                 strCmdName = "PUR interval on/off";
01668         } else if (strCmd == "SOFF") {
01669                 strCmdName = "Set spectrum offset";
01670         } else if (strCmd == "INOF") {
01671                 strCmdName = "Input offset";
01672         } else if (strCmd == "ACKE") {
01673                 strCmdName = "ACK / Don't ACK packets with errors";
01674         } else if (strCmd == "AINP") {
01675                 strCmdName = "Analog input pos/neg";
01676         } else if (strCmd == "AUO1") {
01677                 strCmdName = "AUX_OUT selection";
01678         } else if (strCmd == "AUO2") {
01679                 strCmdName = "AUX_OUT2 selection";
01680         } else if (strCmd == "BLRD") {
01681                 strCmdName = "BLR down correction";
01682         } else if (strCmd == "BLRM") {
01683                 strCmdName = "BLR mode";
01684         } else if (strCmd == "BLRU") {
01685                 strCmdName = "BLR up correction";
01686         } else if (strCmd == "BOOT") {
01687                 strCmdName = "Turn supplies on/off at power up";
01688         } else if (strCmd == "CUSP") {
01689                 strCmdName = "Non-trapezoidal shaping";
01690         } else if (strCmd == "DACF") {
01691                 strCmdName = "DAC offset";
01692         } else if (strCmd == "DACO") {
01693                 strCmdName = "DAC output";
01694         } else if (strCmd == "GAIA") {
01695                 strCmdName = "Analog gain index";
01696         } else if (strCmd == "GATE") {
01697                 strCmdName = "Gate control";
01698         } else if (strCmd == "GPED") {
01699                 strCmdName = "G.P. counter edge";
01700         } else if (strCmd == "GPGA") {
01701                 strCmdName = "G.P. counter uses GATE?";
01702         } else if (strCmd == "GPIN") {
01703                 strCmdName = "G.P. counter input";
01704         } else if (strCmd == "GPMC") {
01705                 strCmdName = "G.P. counter cleared with MCA counters?";
01706         } else if (strCmd == "GPME") {
01707                 strCmdName = "G.P. counter uses MCA_EN?";
01708         } else if (strCmd == "HVSE") {
01709                 strCmdName = "HV set";
01710         } else if (strCmd == "MCAC") {
01711                 strCmdName = "MCA/MCS channels";
01712         } else if (strCmd == "MCAE") {
01713                 strCmdName = "MCA/MCS enable";
01714         } else if (strCmd == "MCSL") {
01715                 strCmdName = "MCS low threshold";
01716         } else if (strCmd == "MCSH") {
01717                 strCmdName = "MCS high threshold";
01718         } else if (strCmd == "MCST") {
01719                 strCmdName = "MCS timebase";
01720         } else if (strCmd == "PAPS") {
01721                 strCmdName = "preamp 8.5/5 (N/A)";
01722         } else if (strCmd == "PAPZ") {
01723                 strCmdName = "Pole-Zero";
01724         } else if (strCmd == "PDMD") {
01725                 strCmdName = "Peak detect mode (min/max)";
01726         } else if (strCmd == "PRCL") {
01727                 strCmdName = "Preset counts low threshold";
01728         } else if (strCmd == "PRCH") {
01729                 strCmdName = "Preset counts high threshold";
01730         } else if (strCmd == "PREC") {
01731                 strCmdName = "Preset counts";
01732         } else if (strCmd == "PRER") {
01733                 strCmdName = "Preset Real Time";
01734         } else if (strCmd == "PRET") {
01735                 strCmdName = "Preset time";
01736         } else if (strCmd == "RTDS") {
01737                 strCmdName = "RTD sensitivity";
01738         } else if (strCmd == "RTDT") {
01739                 strCmdName = "RTD threshold";
01740         } else if (strCmd == "SCAH") {
01741                 strCmdName = "SCAx high threshold";
01742         } else if (strCmd == "SCAI") {
01743                 strCmdName = "SCA index";
01744         } else if (strCmd == "SCAL") {
01745                 strCmdName = "SCAx low theshold";
01746         } else if (strCmd == "SCAO") {
01747                 strCmdName = "SCAx output (SCA1-8 only)";
01748         } else if (strCmd == "SCAW") {
01749                 strCmdName = "SCA pulse width (not indexed - SCA1-8)";
01750         } else if (strCmd == "SCOE") {
01751                 strCmdName = "Scope trigger edge";
01752         } else if (strCmd == "SCOG") {
01753                 strCmdName = "Digital scope gain";
01754         } else if (strCmd == "SCOT") {
01755                 strCmdName = "Scope trigger position";
01756         } else if (strCmd == "TECS") {
01757                 strCmdName = "TEC set";
01758         } else if (strCmd == "THFA") {
01759                 strCmdName = "Fast threshold";
01760         } else if (strCmd == "THSL") {
01761                 strCmdName = "Slow threshold";
01762         } else if (strCmd == "TLLD") {
01763                 strCmdName = "LLD threshold";
01764         } else if (strCmd == "TPMO") {
01765                 strCmdName = "Test pulser on/off";
01766         } else if (strCmd == "VOLU") {
01767                 strCmdName = "Speaker On/Off";
01768         } else if (strCmd == "CON1") {
01769                 strCmdName = "Connector 1";
01770         } else if (strCmd == "CON2") {
01771                 strCmdName = "Connector 2";
01772         }
01773         return strCmdName;
01774 }
01775
01776 string CvcDP5Dlg::GetCmdDesc(string strCmd)
01777 {
01778         string strCmdName = "";
01779         if (strCmd == "RESC") {
01780                 strCmdName = "Reset Configuration";
01781         } else if (strCmd == "CLCK") {
01782                 strCmdName = "20MHz/80MHz";
01783         } else if (strCmd == "TPEA") {
01784                 strCmdName = "peaking time";
01785         } else if (strCmd == "GAIF") {
01786                 strCmdName = "Fine gain";
01787         } else if (strCmd == "GAIN") {
01788                 strCmdName = "Total Gain (analog * fine)";
01789         } else if (strCmd == "RESL") {
01790                 strCmdName = "Detector Reset lockout";
01791         } else if (strCmd == "TFLA") {
01792                 strCmdName = "Flat top";
01793         } else if (strCmd == "TPFA") {
01794                 strCmdName = "Fast channel peaking time";
01795         } else if (strCmd == "RTDE") {
01796                 strCmdName = "RTD on/off";
01797         } else if (strCmd == "MCAS") {
01798                 strCmdName = "MCA Source";
01799         } else if (strCmd == "RTDD") {
01800                 strCmdName = "Custom RTD oneshot delay";
01801         } else if (strCmd == "RTDW") {
01802                 strCmdName = "Custom RTD oneshot width";
01803         } else if (strCmd == "PURE") {
01804                 strCmdName = "PUR interval on/off";
01805         } else if (strCmd == "SOFF") {
01806                 strCmdName = "Set spectrum offset";
01807         } else if (strCmd == "INOF") {
01808                 strCmdName = "Input offset";
01809         } else if (strCmd == "ACKE") {
01810                 strCmdName = "ACK / Don't ACK packets with errors";
01811         } else if (strCmd == "AINP") {
01812                 strCmdName = "Analog input pos/neg";
01813         } else if (strCmd == "AUO1") {
01814                 strCmdName = "AUX_OUT selection";
01815         } else if (strCmd == "AUO2") {
01816                 strCmdName = "AUX_OUT2 selection";
01817         } else if (strCmd == "BLRD") {
01818                 strCmdName = "BLR down correction";
01819         } else if (strCmd == "BLRM") {
01820                 strCmdName = "BLR mode";
01821         } else if (strCmd == "BLRU") {
01822                 strCmdName = "BLR up correction";
01823         } else if (strCmd == "BOOT") {
01824                 strCmdName = "Turn supplies on/off at power up";
01825         } else if (strCmd == "CUSP") {
01826                 strCmdName = "Non-trapezoidal shaping";
01827         } else if (strCmd == "DACF") {
01828                 strCmdName = "DAC offset";
01829         } else if (strCmd == "DACO") {
01830                 strCmdName = "DAC output";
01831         } else if (strCmd == "GAIA") {
01832                 strCmdName = "Analog gain index";
01833         } else if (strCmd == "GATE") {
01834                 strCmdName = "Gate control";
01835         } else if (strCmd == "GPED") {
01836                 strCmdName = "G.P. counter edge";
01837         } else if (strCmd == "GPGA") {
01838                 strCmdName = "G.P. counter uses GATE?";
01839         } else if (strCmd == "GPIN") {
01840                 strCmdName = "G.P. counter input";
01841         } else if (strCmd == "GPMC") {
01842                 strCmdName = "G.P. counter cleared with MCA counters?";
01843         } else if (strCmd == "GPME") {
01844                 strCmdName = "G.P. counter uses MCA_EN?";
01845         } else if (strCmd == "HVSE") {
01846                 strCmdName = "HV set";
01847         } else if (strCmd == "MCAC") {
01848                 strCmdName = "MCA/MCS channels";
01849         } else if (strCmd == "MCAE") {
01850                 strCmdName = "MCA/MCS enable";
01851         } else if (strCmd == "MCSL") {
01852                 strCmdName = "MCS low threshold";
01853         } else if (strCmd == "MCSH") {
01854                 strCmdName = "MCS high threshold";
01855         } else if (strCmd == "MCST") {
01856                 strCmdName = "MCS timebase";
01857         } else if (strCmd == "PAPS") {
01858                 strCmdName = "preamp 8.5/5 (N/A)";
01859         } else if (strCmd == "PAPZ") {
01860                 strCmdName = "Pole-Zero";
01861         } else if (strCmd == "PDMD") {
01862                 strCmdName = "Peak detect mode (min/max)";
01863         } else if (strCmd == "PRCL") {
01864                 strCmdName = "Preset counts low threshold";
01865         } else if (strCmd == "PRCH") {
01866                 strCmdName = "Preset counts high threshold";
01867         } else if (strCmd == "PREC") {
01868                 strCmdName = "Preset counts";
01869         } else if (strCmd == "PRER") {
01870                 strCmdName = "Preset Real Time";
01871         } else if (strCmd == "PRET") {
01872                 strCmdName = "Preset time";
01873         } else if (strCmd == "RTDS") {
01874                 strCmdName = "RTD sensitivity";
01875         } else if (strCmd == "RTDT") {
01876                 strCmdName = "RTD threshold";
01877         } else if (strCmd == "SCAH") {
01878                 strCmdName = "SCAx high threshold";
01879         } else if (strCmd == "SCAI") {
01880                 strCmdName = "SCA index";
01881         } else if (strCmd == "SCAL") {
01882                 strCmdName = "SCAx low theshold";
01883         } else if (strCmd == "SCAO") {
01884                 strCmdName = "SCAx output (SCA1-8 only)";
01885         } else if (strCmd == "SCAW") {
01886                 strCmdName = "SCA pulse width (not indexed - SCA1-8)";
01887         } else if (strCmd == "SCOE") {
01888                 strCmdName = "Scope trigger edge";
01889         } else if (strCmd == "SCOG") {
01890                 strCmdName = "Digital scope gain";
01891         } else if (strCmd == "SCOT") {
01892                 strCmdName = "Scope trigger position";
01893         } else if (strCmd == "TECS") {
01894                 strCmdName = "TEC set";
01895         } else if (strCmd == "THFA") {
01896                 strCmdName = "Fast threshold";
01897         } else if (strCmd == "THSL") {
01898                 strCmdName = "Slow threshold";
01899         } else if (strCmd == "TLLD") {
01900                 strCmdName = "LLD threshold";
01901         } else if (strCmd == "TPMO") {
01902                 strCmdName = "Test pulser on/off";
01903         } else if (strCmd == "VOLU") {
01904                 strCmdName = "Speaker On/Off";
01905         } else if (strCmd == "CON1") {
01906                 strCmdName = "Connector 1";
01907         } else if (strCmd == "CON2") {
01908                 strCmdName = "Connector 2";
01909         }
01910         return strCmdName;
01911 }
01912
01913 void CvcDP5Dlg::CopyDp5CfgToClip(CString strCfg, CString strDesc)
01914 {
01915         CString strConfig;
01916         strConfig = "[DP5 Configuration File]\r\n" + strCfg + "\r\n" + "\r\n" + strDesc;
01917         AfxGetApp()->m_pMainWnd->OpenClipboard() ;
01918         EmptyClipboard();
01919         CSharedFile     sf(GMEM_MOVEABLE|GMEM_DDESHARE|GMEM_ZEROINIT);
01920         sf.Write(strConfig, strConfig.GetLength());
01921         HGLOBAL hMem = sf.Detach();
01922         if (!hMem) return;
01923         SetClipboardData(CF_TEXT, hMem);
01924         CloseClipboard();
01925 }
01926
01927 void CvcDP5Dlg::OnBnClickedButtonShowConfig()
01928 {
01929         if (s.isDppConnected) {
01930                 s.DppConfig.DisplayCfg = TRUE;
01931                 SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
01932         }
01933 }
01934
01935 //-------------------------------------------------------------------
01936 // OnBnClickedPlotscaleradiolinear
01937 // Selects linear plot scale
01938 //-------------------------------------------------------------------
01939 void CvcDP5Dlg::OnBnClickedRadioPlotScaleLinear()
01940 {
01941         m_PicturePlot.OptScaleType = LINEAR_PLOT_SCALE;
01942         CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LINEAR);
01943         s.isScaleLog = FALSE;
01944 }
01945
01946 //-------------------------------------------------------------------
01947 // OnBnClickedPlotscaleradiolog
01948 // Selects log plot scale
01949 //-------------------------------------------------------------------
01950 void CvcDP5Dlg::OnBnClickedRadioPlotScaleLog()
01951 {
01952         m_PicturePlot.OptScaleType = LOG_PLOT_SCALE;
01953         CheckRadioButton(IDC_RADIO_PLOT_SCALE_LINEAR, IDC_RADIO_PLOT_SCALE_LOG, IDC_RADIO_PLOT_SCALE_LOG);
01954         s.isScaleLog = TRUE;
01955 }
01956
01957 //-------------------------------------------------------------------
01958 // OnBnClickedPlottyperadiosolid
01959 // Selects solid (bar) plot type
01960 //-------------------------------------------------------------------
01961 void CvcDP5Dlg::OnBnClickedRadioPlotTypeSolid()
01962 {
01963         m_PicturePlot.OptPlotType = SOLID_PLOT_TYPE;
01964         CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_SOLID);
01965         s.isPlotLine = FALSE;
01966 }
01967
01968 //-------------------------------------------------------------------
01969 // OnBnClickedPlottyperadioline
01970 // Selects line plot type
01971 //-------------------------------------------------------------------
01972 void CvcDP5Dlg::OnBnClickedRadioPlotTypeLine()
01973 {
01974         m_PicturePlot.OptPlotType = LINE_PLOT_TYPE;
01975         CheckRadioButton(IDC_RADIO_PLOT_TYPE_SOLID, IDC_RADIO_PLOT_TYPE_LINE, IDC_RADIO_PLOT_TYPE_LINE);
01976         s.isPlotLine = TRUE;
01977 }
01978
01979 //    SaveSpectrum(SPECTRUM, STATUS, CommonDialog1)
01980 void CvcDP5Dlg::OnBnClickedButtonSaveFile()
01981 {
01982         CFileBrowse BR;
01983         CString strDfltExt;
01984         string strSpectrum;                                                                                     // holds final spectrum file
01985         SpectrumFileType sfInfo;
01986         CString strFilename;
01987
01988         s.DppConfig.CfgReadBack = TRUE;
01989         s.DppConfig.DisplayCfg = FALSE;
01990         SendCommandConfig(XMTPT_FULL_READ_CONFIG_PACKET);
01991         sfInfo.strSpectrumConfig = CreateSpectrumConfig(s.HwCfgDP5.GetString());        // append configuration comments
01992     sfInfo.strTag.reserve(20);
01993         GetDlgItemText(IDC_EDIT_TAG, (char*)sfInfo.strTag.c_str(),20);                                  // tag
01994         if (sfInfo.strTag.length() == 0) {
01995                 sfInfo.strTag = "TestTag";
01996         }
01997         sfInfo.strDescription.reserve(128);
01998         GetDlgItemText(IDC_EDIT_DESCRIPTION, (char*)sfInfo.strDescription.c_str(),128); // description
01999         if (sfInfo.strDescription.length() == 0) {
02000                 sfInfo.strDescription = "Amptek Spectrum File";
02001         }
02002         sfInfo.strStartTime.reserve(64);
02003         GetDlgItemText(IDC_EDIT_START_TIME, (char*)sfInfo.strStartTime.c_str(),64);
02004         // save last status after acquisition
02005         sfInfo.strSpectrumStatus = s.DP5Stat.ShowStatusValueStrings(s.DP5Stat.m_DP5_Status);
02006         sfInfo.m_iNumChan = s.DP5Proto.SPECTRUM.CHANNELS;                                               // number channels in spectrum
02007         sfInfo.SerialNumber = s.DP5Stat.m_DP5_Status.SerialNumber;      // dpp serial number
02008         // create spectrum file, save file to string
02009     strSpectrum = CreateMCAData(s.DP5Proto.SPECTRUM.DATA,sfInfo,s.DP5Stat.m_DP5_Status);
02010
02011         if (strSpectrum.length() > 256) {
02012                 strDfltExt = _T("mca");
02013                 if (BR.DoModal(BR.SAVE,
02014                                 "Save Spectrum",
02015                                 BR.McaFileFilter,
02016                                 strDfltExt,
02017                                 _T(""),
02018                                 &strFilename)) {
02019
02020                         std::string stdstrFilename(strFilename, strFilename.GetLength());
02021
02022                         SaveMCAFile(stdstrFilename, strSpectrum);               // save spectrum file string to file
02023                 }
02024         }
02025 }
02026
02027 void CvcDP5Dlg::SaveMCAFile(string strFilename, string strMCA)
02028 {
02029         CFile cf(strFilename.c_str(), CFile::modeCreate | CFile::modeWrite);
02030         cf.Write(strMCA.c_str(), (unsigned int)strMCA.length());
02031         cf.Close();
02032 }
02033
02034 string CvcDP5Dlg::CreateMCAData(long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst)
02035 {
02036         string strMCA;
02037         string strText;
02038         string strADC;
02039         long idxChan;
02040         string strData;
02041         stringex strfn; // = strfn.
02042
02043         if (cfgStatusLst.SerialNumber <= 0)
02044         {
02045                 return ("");
02046         }
02047         strText = "";
02048         strMCA = "";
02049     switch(sfInfo.m_iNumChan){
02050         case 16384:
02051             strADC = "6";
02052                                 break;
02053         case 8192:
02054             strADC = "5";
02055                                 break;
02056         case 4096:
02057             strADC = "4";
02058                                 break;
02059         case 2048:
02060             strADC = "3";
02061                                 break;
02062         case 1024:
02063             strADC = "2";
02064                                 break;
02065         case 512:
02066             strADC = "1";
02067                                 break;
02068         case 256:
02069             strADC = "0";
02070                                 break;
02071     }
02072         strMCA += "<<PMCA SPECTRUM>>\r\n";
02073         strMCA += "TAG - " + sfInfo.strTag + "\r\n";
02074         strMCA += "DESCRIPTION - " + sfInfo.strDescription + "\r\n";
02075         strMCA += "GAIN - " + strADC + "\r\n";
02076         strMCA += "THRESHOLD - 0\r\n";
02077         strMCA += "LIVE_MODE - 0\r\n";
02078         strMCA += "PRESET_TIME - \r\n";
02079         strText = strfn.Format("%lf", cfgStatusLst.AccumulationTime);
02080         strMCA += "LIVE_TIME - " + strText + "\r\n";
02081         strText = strfn.Format("%lf", cfgStatusLst.RealTime);
02082         strMCA += "REAL_TIME - " + strText + "\r\n";
02083         strMCA += "START_TIME - \r\n";
02084         strText = strfn.Format("%i", sfInfo.SerialNumber);
02085         strMCA += "SERIAL_NUMBER - " + strText + "\r\n";
02086         strMCA += "<<DATA>>\r\n";
02087         for (idxChan=0;idxChan<sfInfo.m_iNumChan;idxChan++) {
02088                 strData = strfn.Format("%i", m_larDataBuffer[idxChan]);
02089                 strMCA += strData + "\r\n";
02090         }
02091         strMCA += "<<END>>\r\n";
02092         strMCA += "<<DP5 CONFIGURATION>>\r\n";
02093         strMCA += sfInfo.strSpectrumConfig;
02094         strMCA += "<<DP5 CONFIGURATION END>>\r\n";
02095         strMCA += "<<DPP STATUS>>\r\n";
02096         strMCA += sfInfo.strSpectrumStatus;     // this functin is included in most examples
02097         strMCA += "<<DPP STATUS END>>\r\n";
02098         return (strMCA);
02099 }
02100
02101 //-------------------------------------------------------------------
02102 // OnStnClickedPlotpicturecontrol
02103 // Moves cursor
02104 //-------------------------------------------------------------------
02105 void CvcDP5Dlg::OnStnClickedPlotpicturecontrol()
02106 {
02107         m_PicturePlot.SetCursorPosition(CursorPosition.x);
02108         //CString strCursorPos;
02109         //strCursorPos.Format("%d,%d",CursorPosition.x,CursorPosition.y);
02110         //AfxMessageBox(strCursorPos);
02111         m_PicturePlot.DrawCursor();
02112 }
02113
02114 //-------------------------------------------------------------------
02115 // OnLButtonDown
02116 // Moves cursor
02117 //-------------------------------------------------------------------
02118 void CvcDP5Dlg::OnLButtonDown(UINT nFlags, CPoint point)
02119 {
02120         CursorPosition = point;
02121
02122         //check if in picturebox rectangle (13,13)-(442,259)
02123         if (((CursorPosition.x > 12) && (CursorPosition.x < 443)) &&
02124                 ((CursorPosition.y > 12) && (CursorPosition.y < 260))) {
02125                 m_PicturePlot.SetCursorPosition(CursorPosition.x-14);   //14=sprite pointer offset
02126                 CString strCursorPos;
02127                 strCursorPos.Format("%d,%d",CursorPosition.x,CursorPosition.y);
02128                 //GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strCursorPos);
02129                 m_PicturePlot.DrawCursor();
02130                 SetPlotChannel();
02131         }
02132         CDialog::OnLButtonDown(nFlags, point);
02133 }
02134
02135 BOOL CvcDP5Dlg::PreTranslateMessage(MSG* pMsg)
02136 {
02137         POINT pt;
02138         CString strCursorPos;
02139
02140
02141         if (pMsg->message == WM_KEYDOWN) {
02142                 GetCursorPos(&pt);                      // Get the cursor position for a screen
02143                 ScreenToClient(&pt);            // Convert to  window co-ordinates
02144                 strCursorPos.Format("%d,%d",pt.x,pt.y);
02145                 //GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strCursorPos);
02146                 if (((pt.x > 12) && (pt.x < 443)) &&
02147                         ((pt.y > 12) && (pt.y < 260))) {
02148                         if(pMsg->message == WM_KEYDOWN){
02149                                 // DIRECTION
02150                                 if (pMsg->wParam == 37)        //left
02151                                 {
02152                                         CursorPosition.x--;
02153                                 }
02154                                 if (pMsg->wParam == 39)       //right
02155                                 {
02156                                         CursorPosition.x++;
02157                                 }
02158                         }
02159                         if (CursorPosition.x < 12) { CursorPosition.x = 12; }
02160                         if (CursorPosition.x > 443) { CursorPosition.x = 443; }
02161                         SetPlotChannel();
02162                         return TRUE;
02163                 }
02164         }
02165         return CDialog::PreTranslateMessage(pMsg);
02166 }
02167
02168 void CvcDP5Dlg::SetPlotChannel()
02169 {
02170         //BOOL isROI = FALSE;
02171         m_PicturePlot.SetCursorPosition(CursorPosition.x - 14); //14=sprite pointer offset
02172         m_PicturePlot.DrawCursor();
02173         CRect rect;
02174         m_PicturePlot.GetClientRect(&rect);
02175         int x_min = 0;
02176         int x_max = rect.Width();
02177         if (s.DP5Proto.SPECTRUM.CHANNELS < 256) { s.DP5Proto.SPECTRUM.CHANNELS = 1024; }
02178         double pixperchan = (double)s.DP5Proto.SPECTRUM.CHANNELS / (double)x_max;
02179         if ((CursorPosition.x - 14) < 0) { CursorPosition.x = 14; }
02180         if ((CursorPosition.x - 14) > x_max) { CursorPosition.x = x_max + 14; }
02181         s.plot->m_xCursorData = (double)(CursorPosition.x - 14) * pixperchan;
02182         CString strChan;
02183         //strChan.Format("Channel %.2f",s.plot->m_xCursorData);
02184         int CurChan = (int)(s.plot->m_xCursorData + 0.5);
02185         if (CurChan > s.DP5Proto.SPECTRUM.CHANNELS - 1) {
02186                 CurChan = s.DP5Proto.SPECTRUM.CHANNELS - 1;
02187         }
02188         CurrentChannel = CurChan;
02189         //if (s.m_Spectrum.m_roi.m_count > 0) {
02190         //      isROI = TRUE
02191         //}
02192         strChan.Format("Channel %d",CurChan);
02193         GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strChan);
02194 }
02195
02196 double CvcDP5Dlg::GetPixPerChannel()
02197 {
02198         CRect rect;
02199         m_PicturePlot.GetClientRect(&rect);
02200         int x_min = 0;
02201         int x_max = rect.Width();
02202         if (s.DP5Proto.SPECTRUM.CHANNELS < 256) { s.DP5Proto.SPECTRUM.CHANNELS = 1024; }
02203         double pixperchan = (double)s.DP5Proto.SPECTRUM.CHANNELS / (double)x_max;
02204         return pixperchan;
02205 }
02206
02207 void CvcDP5Dlg::OnBnClickedOk()
02208 {
02209         OnOK();
02210 }
02211
02212 void CvcDP5Dlg::OnBnClickedCancel()
02213 {
02214         OnCancel();
02215 }
02216
02217 void CvcDP5Dlg::OnBnClickedButtonClearRoi()
02218 {
02219         // TODO: Add your control notification handler code here
02220 }
02221
02222 void CvcDP5Dlg::OnBnClickedButtonRoiEnd()
02223 {
02224         //CSelectDP5 dlgSelectDP5;
02225         //dlgSelectDP5.DoModal();
02226
02227         //CAboutDlg dlgAbout;
02228         //dlgAbout.DoModal();
02229
02230 }
02231
02232 void CvcDP5Dlg::OnBnClickedButtonRoiStart()
02233 {
02234         // TODO: Add your control notification handler code here
02235 }
02236
02237 //EnableToolTips();
02238 //ON_NOTIFY_EX_RANGE(TTN_NEEDTEXT, 0, 0xFFFF, OnToolTipNotify)
02239 //afx_msg BOOL OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult);
02240 BOOL CvcDP5Dlg::OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult)
02241 {
02242     TOOLTIPTEXT *pTTT = (TOOLTIPTEXT *)pNMHDR;
02243     UINT_PTR CtrlHandle = pNMHDR->idFrom;
02244     if (pTTT->uFlags & TTF_IDISHWND) {
02245         UINT_PTR nID = ::GetDlgCtrlID(HWND(CtrlHandle));
02246                 CWnd *p = CWnd::FromHandle(pNMHDR->hwndFrom);
02247                 p->SendMessage(TTM_SETMAXTIPWIDTH, 0, 300);
02248         switch(nID) {
02249         case IDC_BUTTON_SELECT_COMM:
02250             pTTT->lpszText = _T("Open Connect Dialog \r\nto select Amptek DPP device.");
02251             break;
02252         case IDC_RADIO_PLOT_TYPE_LINE:
02253             pTTT->lpszText = _T("Line Plot Type");
02254             break;
02255         default:
02256             //pTTT->lpszText = _T("Default Tooltip");
02257             break;
02258         }
02259         return TRUE;
02260         } else {
02261                 AfxMessageBox("!");
02262     }
02263     return FALSE;
02264 }
02265
02267 // Function:   TuneFastSlowThresh
02268 //      Calls CalcFastThresh and CalcSlowThresh usb functions
02269 // Arguments:
02270 //      none
02271 // Returns:
02272 //      Default
02274 void CvcDP5Dlg::TuneFastSlowThresh()
02275 {
02276
02277         if (! s.isDppConnected) { return; }
02278
02279         CMSecTimer tmr;
02280
02281         // fast threshold vars
02282         DWORD MaxTime = 5000;           // max timeout for tuning
02283         int LoopCounter = 0;
02284
02285         // slow threshold vars
02286         bool WasInMCAMode = false;
02287         int SlowThreshCh = 0;
02288         double UpperChCounts = 0.0;
02289         double UpperChMax = 0.0;
02290         CTuneSlowThreshold TuneSlowThresh;
02291         int mcaCh;
02292
02293         cWaitDialog dlg;
02294         dlg.m_Text = "Tuning...please wait";
02295         dlg.Show();
02296         tmr.msTimer(200);
02297         if (m_nTmrSpectrumId == 0) {            // acquire Status != ACQUIRING
02298                 dlg.Close();
02299                 tmr.msTimer(100);
02300                 AfxMessageBox("Please start an acquisition then remove the source before setting the thresholds.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
02301                 return;
02302         }
02303
02304         // Status byte 23, D6=0 -> auto fast threshold not locked; =1 -> locked
02305         s.DP5Stat.m_DP5_Status.AFAST_LOCKED = FALSE;    // reset flag before call
02306         s.DppConfig.SetFastThreshDone = s.DP5Stat.m_DP5_Status.AFAST_LOCKED;        //BOOL
02307         SendCommand(XMTPT_AUTOSET_FAST_THRESHOLD); // call tune fast thresh
02308         tmr.msTimer(50);
02309     MaxTime += GetCurrentTime();                        // monitor flag until done or timeout
02310     while ((GetCurrentTime() < MaxTime) && (!s.DppConfig.SetFastThreshDone))
02311     {
02312                 tmr.msTimer(100);
02313                 LoopCounter++;
02314                 if (LoopCounter > 5) {
02315                         LoopCounter = 0;
02316                         SendCommand(XMTPT_SEND_STATUS);
02317                 }
02318         }
02319         if (!s.DppConfig.SetFastThreshDone) {
02320                 dlg.Close();
02321                 AfxMessageBox("Tune fast threshold error.\nPlease remove source if present.\nSet thresholds manually if out of auto tuning range.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
02322                 return;
02323         }
02324
02325         ::SendMessage(s.hWnd_Main,WM_USER_READ_DPP_CONFIG,0L,0L);
02326         tmr.msTimer(200);
02327         tmr.msTimer(200);
02328         if (! s.DppConfig.isDeltaMode) { // check delta mode, if not in delta, set to delta
02329                 WasInMCAMode = true;
02330                 s.DppConfig.isDeltaMode = (! s.DppConfig.isDeltaMode);
02331                 TuneSlowThresh.DelayTask(1000);                 // 1 second to convert to delta mode
02332         }
02333         mcaCh = (int)s.DP5Proto.SPECTRUM.CHANNELS;
02334         TuneSlowThresh.SetSlowThreshToChPos(0, mcaCh);  // set slow thresh to 0
02335         TuneSlowThresh.DelayTask(1200); // wait 1 sec to settle
02336         HGLOBAL hGlobal;
02337         double *SpectrumBuffer;
02338         hGlobal = GlobalAlloc( GPTR, 16384 * sizeof(double) );
02339         if (!hGlobal) {
02340                 dlg.Close();
02341                 tmr.msTimer(100);
02342                 AfxMessageBox("Tune slow threshold error.\nMemory allocation error.\nPlease try again.", MB_TOPMOST | MB_OK | MB_ICONSTOP);
02343                 return;
02344         }
02345         SpectrumBuffer = (double *)GlobalLock( hGlobal );                                       // allocate spectrum buffer
02346         TuneSlowThresh.GetSpectrumData(SpectrumBuffer, s.DP5Proto.SPECTRUM.DATA, mcaCh);
02347         UpperChCounts = TuneSlowThresh.GetUpperChCounts(SpectrumBuffer, mcaCh); // this can be used ave noise
02348         UpperChMax = TuneSlowThresh.GetUpperChMax(SpectrumBuffer, mcaCh);                       // this is the max noise
02349         SlowThreshCh = TuneSlowThresh.GetSlowThreshCalStart(SpectrumBuffer, UpperChMax, mcaCh);
02350
02351         double dblPixPerChan = GetPixPerChannel();
02352         int CurPos = TuneSlowThresh.UpdatePlotCursorPosFromIntChPos(SlowThreshCh, dblPixPerChan);
02353         m_PicturePlot.SetCursorPosition(CurPos);
02354         m_PicturePlot.DrawCursor();
02355
02356         CString strChan;
02357         strChan.Format("Channel %d",CurPos);
02358         //GetDlgItem(IDC_STATIC_STATUS)->SetWindowText(strChan);
02359         GetDlgItem(IDC_EDIT_MISC_DATA)->SetWindowText(strChan);
02360
02361         TuneSlowThresh.SetSlowThreshToChPos(SlowThreshCh, mcaCh);                       // set the calculated setting
02362         GlobalUnlock( hGlobal );
02363         GlobalFree( hGlobal );
02364         if (WasInMCAMode) { // set old delta mode, if in mca, set to delta to false
02365                 s.DppConfig.isDeltaMode = false;
02366         }
02367         dlg.Close();
02368         tmr.msTimer(200);
02369         OnBnClickedButtonClearDataAndGraph();
02370 }
02371
02372 void CvcDP5Dlg::OnBnClickedButtonAutotune()
02373 {
02374         TuneFastSlowThresh();
02375 }
02376
02377 //CTime theTime = CTime::GetCurrentTime();
02378 //string strTime = theTime.Format( "%m/%d/%Y %H:%M:%S" );
02379 //StartTime = strTime;
02380
02381 //#include <time.h>
02382 string CvcDP5Dlg::CreateDTS(string strFormat)
02383 {
02384         //string strFormat("_%Y%m%d_%H%M%S");           // for append filename dts
02385         //string strFormat("%m/%d/%Y %H:%M:%S");   // for spectrum dts
02386         char buffer[256];
02387         time_t rawtime;
02388         struct tm * timeinfo;
02389         string str("");
02390         stringex strfn;
02391
02392         time (&rawtime);
02393         timeinfo = localtime (&rawtime);
02394         strftime(buffer, sizeof(buffer), strFormat.c_str(), timeinfo);
02395         str = strfn.Format("%s",buffer);
02396         return str;
02397 }
02398
02400 // ParsePerformanceNotes formats a test string into an Additional Note
02402 CString CvcDP5Dlg::ParsePerformanceNotes(CString str)
02403 {
02404         int iStart,iHvBias,iEnd;
02405         CString strNote("");
02406         iStart = 0;
02407         iHvBias = 0;
02408         iEnd = 0;
02409         //Test the prefix + first four characters
02410         iStart = str.Find("<not>T = ",0);                               // test for the first line
02411         if (iStart == -1) {
02412                 iStart = str.Find("<not>Ampt",0);                       // test for the last line
02413                 if (iStart == 0) {                                                      // the line starts at 0
02414                         strNote = str.Mid(0, 34) + "\r\n";
02415                         if (strNote.GetLength() == 36) {                // found detector part number
02416                                 return (strNote);
02417                         }
02418                 }
02419         } else {
02420                 if (iStart == 0) {                                                      // the line starts at 0
02421                         iHvBias = str.Find("HV Bias:",0);               // test for the first line
02422                         if (iHvBias > -1) {                                             // the line end test starts at iHvBias
02423                                 iEnd = str.Find(",",iHvBias);                           // test for the end of line
02424                                 if (iEnd > -1) {
02425                                         strNote = str.Mid(0,iEnd+1) + " \r\n";
02426                                         return (strNote);
02427                                 }
02428                         }
02429                 }
02430         }
02431         if (iStart == -1) { return (""); }                      // string not found
02432         return ("");    // string found with parse error
02433 }
02434
02436 // TextToBlockString(CString &str, char *prefix)
02437 // -------------------------------------------------------------------
02438 // Formats Additional Notes Line into TextBlock String
02439 // -------------------------------------------------------------------
02440 // Similar function to SaveMultiString(ar, m_attr.notesNotes, "<not>");
02442 CString CvcDP5Dlg::TextToBlockString(CString &str, char *prefix)
02443 {
02444         int pos;
02445         int length;
02446         int endPos;
02447         CString out;
02448         CString TextBlock;
02449         endPos = (int)strlen(str);
02450         out = "";
02451         TextBlock = "";
02452         for (pos = 0 ; pos < endPos; )
02453         {
02454                 length = str.Mid(pos).Find("\r");
02455                 if (length == -1) length = endPos - pos;
02456                 out = prefix + str.Mid(pos, length) + "\r\n";
02457                 if (prefix == "<not>") {
02458                         out = ParsePerformanceNotes(out);
02459                 }
02460                 TextBlock += out;
02461                 out = "";
02462                 pos += length + 2;
02463         }
02464         return (TextBlock);
02465 }
02466
02468 // Parses TextBlock Additional Manufacturing Notes from DPP
02470 void CvcDP5Dlg::ParseTextBlockNotes(CString strTextBlock)
02471 {
02472         CString strNote;
02473         CStringArray strNotes;
02474         int idxNote = 0;
02475         CString strDisplay;
02476         strDisplay = "";
02477         // last argument is the delimitter
02478         //while (AfxExtractSubString(strNote,strTextBlock,idxNote,_T('\n')))
02479         CString generalNotes("");                       // "<gen>"
02480         CString systemNotes("");                        // "<sys>"
02481         CString notesNotes("");                         // "<not>"
02482
02483         while (ExtractNote(strNote,strTextBlock,idxNote,_T('\n')))
02484         {
02485                 if (strNote.GetLength() > 3) {
02486                         if (strNote.Find("<gen>") == 0) {
02487                                 generalNotes += strNote.Mid(5);
02488                         } else if (strNote.Find("<sys>") == 0) {
02489                                 systemNotes += strNote.Mid(5);
02490                         } else if (strNote.Find("<not>") == 0) {
02491                                 notesNotes += strNote.Mid(5);
02492                         }
02493                         strNotes.Add(strNote);
02494                         //AfxMessageBox(strNote);
02495                 }
02496                 ++idxNote;
02497         }
02498
02499    for (int i = 0; i <= strNotes.GetUpperBound(); i++)
02500       strDisplay += strNotes[i]+"\n";
02501    //CopyTextToClip(strDisplay);
02502    int iPos = 0;
02503    int lCount = 0 ;
02504    for (idxNote = 0; idxNote <= strDisplay.GetLength(); idxNote++) {
02505                 iPos = strDisplay.Find("\n",iPos + 1);
02506                 if (iPos >= 0) {
02507                         lCount +=1;
02508                 } else {
02509                         break;
02510                 }
02511    }
02512         strNote.Format("%d",lCount);
02513         //AfxMessageBox(strNote);
02514         //AfxMessageBox(strDisplay);
02515
02516 }
02517
02519 // Reads/Extracts One Additional Note Text Line from text block of Additional Notes
02521 BOOL CvcDP5Dlg::ExtractNote(CString& rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep)
02522 {
02523         if (lpszFullString == NULL)
02524                 return FALSE;
02525
02526         while (iSubString--)
02527         {
02528                 lpszFullString = _tcschr(lpszFullString, chSep);
02529                 if (lpszFullString == NULL)
02530                 {
02531                         rString.Empty();        // return empty string as well
02532                         return FALSE;
02533                 }
02534                 lpszFullString++;       // point past the separator
02535         }
02536         LPCTSTR lpchEnd = _tcschr(lpszFullString, chSep);
02537         int nLen = (lpchEnd == NULL) ?
02538                 lstrlen(lpszFullString) : (int)(lpchEnd - lpszFullString);
02539         ASSERT(nLen >= 0);
02540         memcpy(rString.GetBufferSetLength(nLen), lpszFullString, nLen*sizeof(TCHAR));
02541         rString.ReleaseBuffer();        // Need to call ReleaseBuffer
02542                                                                 // after calling GetBufferSetLength
02543         return TRUE;
02544 }
02545
02547 // Copies Text to clipboard -- not needed for TextBlock -- testing only
02549 void CvcDP5Dlg::CopyTextToClip(CString strTextIn)
02550 {
02551         CString strText;
02552         strText = strTextIn;
02553         AfxGetApp()->m_pMainWnd->OpenClipboard() ;
02554         EmptyClipboard();
02555         CSharedFile     sf(GMEM_MOVEABLE|GMEM_DDESHARE|GMEM_ZEROINIT);
02556         sf.Write(strText, strText.GetLength());
02557         HGLOBAL hMem = sf.Detach();
02558         if (!hMem) return;
02559         SetClipboardData(CF_TEXT, hMem);
02560         CloseClipboard();
02561 }
02562
02563 //<gen>X-123 S/N: X014487, AXRCR S/N: 158334
02564 //<not>T = 240.0 Degrees K, FWHM@5894.960keV:234.779keV, Tested with 6.4uS Peak Time, HV Bias: 180.0 Volts,
02565 //<not>Amptek Code # ZY-FS43AMD-G3SP
02566 CString CvcDP5Dlg::CreateTextBlockTest()
02567 {
02568         CString strGeneral;
02569         CString strNotes;
02570         CString strTextBlock;
02571         strGeneral = "X-123 S/N: X014487, AXRCR S/N: 158334\r\n";
02572         strTextBlock += TextToBlockString(strGeneral, "<gen>");
02573         strNotes = "T = 240.0 Degrees K, FWHM@5894.960keV:234.779keV, Tested with 6.4uS Peak Time, HV Bias: 180.0 Volts, \r\n";
02574         strNotes += "Amptek Code # ZY-FS43AMD-G3SP\r\n";
02575         strTextBlock += TextToBlockString(strNotes, "<not>");
02576         //AfxMessageBox(strTextBlock);
02577         return (strTextBlock);
02578 }
02579
02580 // strLowerTextBlock bytes 0-255
02581 // strInfoTextBlock bytes 256-511
02582 void CvcDP5Dlg::SendDppInfoTextBlock(CString strLowerTextBlock, CString strInfoTextBlock)
02583 {
02584         BYTE byteMiscData[512];
02585         int idxCh;
02586         int DataLen;
02587
02588         //GetDlgItem(IDC_EDIT_MISC_DATA)->GetWindowText(strMiscData);
02589         DataLen = strLowerTextBlock.GetLength();
02590         for(idxCh=0;idxCh<256;idxCh++) {
02591                 if (idxCh < DataLen) {
02592                         byteMiscData[idxCh] = (BYTE)strLowerTextBlock.GetAt(idxCh);
02593                 } else {
02594                         byteMiscData[idxCh] = 0;
02595                 }
02596         }
02597         DataLen = strInfoTextBlock.GetLength();
02598         for(idxCh=0;(idxCh+256)<512;idxCh++) {
02599                 if (idxCh < DataLen) {
02600                         byteMiscData[idxCh+256] = (BYTE)strInfoTextBlock.GetAt(idxCh);
02601                 } else {
02602                         byteMiscData[idxCh+256] = 0;
02603                 }
02604         }
02605     SendCommandData(XMTPT_WRITE_512_BYTE_MISC_DATA, byteMiscData);
02606 }
02607
02608 void CvcDP5Dlg::WriteTextBlock()
02609 {
02610         CString strInfoTextBlock("");
02611         strInfoTextBlock = CreateTextBlockTest();
02612
02613         // get lower text block
02614         CString strLowerTextBlock("PX5 ATE Test");
02615         SendDppInfoTextBlock(strLowerTextBlock, strInfoTextBlock);
02616
02621
02632 }
02633
02635 // Functions to be completed
02637 // when writing the text block in the future
02638 // 1. Read the Whole Text Block
02639 // 2. Overwrite/edit the lower half (256 bytes) only
02640 // 3. Save the upper half as is
02641 // when reading the user text block
02642 // 1. Read the Whole Text Block
02643 // 2. Only display/edit the lower half (256 bytes) only
02644 // 3. Save the upper half as is
02645 // when reading the manufacturing test information
02646 // 1. Read the Whole Text Block
02647 // 2. Only read the upper half of the buffer
02648 // 3. The upper half is only edited during manufacturing test
02650
02651
02653 // Send Manufacturing Text Block Test
02654 // ----------------------------------
02655 // 20150928 TextBlock
02656 // Test DPP Notes Here for Text Block Save
02657 // if (General Notes (generalNotes) -> ((X-123 S/N: or PX5 S/N: or PC5 S/N:)
02658 //              AND have performance notes (notesNotes)
02659 // parse notesNotes
02660 //              save generalNotes and parsed notesNotes
02661 //              save data to text block
02663 bool CvcDP5Dlg::SendManufacturingTextBlock(CString generalNotes)
02664 {
02665         int iPX5=-1;                    //px5
02666         int iX123=-1;                   //x123
02667         int iPC5=-1;                    //dp5 with pc5
02668         CString strPX5("PX5 S/N:");             //px5
02669         CString strX123("X-123 S/N:");  //x123
02670         CString strPC5("PC5 S/N:");             //dp5 with pc5
02671         bool bSendBlock=false;
02672
02673         iPX5 = generalNotes.Find(strPX5,0);
02674         iX123 = generalNotes.Find(strX123,0);
02675         iPC5 = generalNotes.Find(strPC5,0);
02676         if ((iPX5 >= 0) || (iX123 >= 0) || (iPC5 >= 0)) {
02677                 bSendBlock = true;
02678         }
02679         return bSendBlock;
02680 }
02681
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1


vcDP5 Test C++ SDK: vcDP5Dlg.h Source File

vcDP5Dlg.h
Go to the documentation of this file.
00001 // vcDP5Dlg.h : header file
00002 //
00003
00004 #pragma once
00005 #include "stdafx.h"
00006 #include "afxwin.h"
00007 #include "Resource.h"
00008 #include "SCommon.h"
00009 #include "ParsePacket.h"
00010 #include "Label.h"
00011 #include "PlotCanvas.h"
00012 #include "DP5CfgWnd.h"
00013
00014 #define LINEAR_PLOT_SCALE 0
00015 #define LOG_PLOT_SCALE 1
00016 #define SOLID_PLOT_TYPE 0
00017 #define LINE_PLOT_TYPE 1
00018
00019 typedef struct _SpectrumFileType {
00020     string strTag;
00021     string strDescription;
00022     short m_iNumChan;
00023         unsigned long SerialNumber;
00024         string strStartTime;
00025         string strSpectrumConfig;
00026         string strSpectrumStatus;
00027 } SpectrumFileType;
00028
00029 // CvcDP5Dlg dialog
00030 class CvcDP5Dlg : public CDialog
00031 {
00032 // Construction
00033 public:
00034         CvcDP5Dlg(CWnd* pParent = NULL);        // standard constructor
00035         ~CvcDP5Dlg();
00036
00037 // Dialog Data
00038         enum { IDD = IDD_vcDP5_DIALOG };
00039
00040         protected:
00041         virtual void DoDataExchange(CDataExchange* pDX);        // DDX/DDV support
00042
00043
00044 // Implementation
00045 protected:
00046         HICON m_hIcon;
00047
00048         // Generated message map functions
00049         virtual BOOL OnInitDialog();
00050         afx_msg void OnSysCommand(UINT nID, LPARAM lParam);
00051         afx_msg void OnPaint();
00052         afx_msg HCURSOR OnQueryDragIcon();
00053         DECLARE_MESSAGE_MAP()
00054 public:
00055         bool BOOL_TO_bool(BOOL bValue);
00056         afx_msg void OnBnClickedButtonFindDevice();
00057         afx_msg BOOL OnDeviceChange(UINT nEventType, DWORD_PTR dwData);
00058         afx_msg void OnDestroy();
00059
00060         unsigned long DataTest();
00061         afx_msg void OnTimer(UINT nIDEvent);
00062         afx_msg void OnBnClickedButtonArmTrigger();
00063         afx_msg void OnBnClickedButtonSaveFile();
00064         afx_msg void OnBnClickedButtonClearDataAndGraph();
00065         afx_msg void OnBnClickedButtonSingleUpdate();
00066         afx_msg void OnBnClickedButtonClearMiscData();
00067         afx_msg void OnBnClickedButtonReadMiscData();
00068         afx_msg void OnBnClickedButtonWriteMiscData();
00069         void ShowStatus(CString strStatus);
00070
00071         void ParsePacketEx(Packet_In PIN, DppStateType DppState);
00072         void ProcessDiagDataEx(Packet_In PIN, DppStateType DppState);
00073         void ProcessStatusEx(Packet_In PIN, DppStateType DppState);
00074         void ConvertStatusDP5ToDP4(DP4_FORMAT_STATUS m_DP5_Status);
00075         void ProcessSpectrumEx(Packet_In PIN, DppStateType DppState);
00076         void ProcessScopeDataEx(Packet_In PIN, DppStateType DppState);
00077         void ProcessTextDataEx(Packet_In PIN, DppStateType DppState);
00078         void ProcessAck(unsigned char PID2);
00079         void DisplayError(Packet_In PIN, DppStateType DppState);
00080         void RequestScopeData(BOOL ScopeDataReady);
00081         void SendCommand(TRANSMIT_PACKET_TYPE XmtCmd);
00082         void SendCommandConfig(TRANSMIT_PACKET_TYPE XmtCmd);
00083         string CreateSpectrumConfig(string strRawCfgIn);
00084         void SendCommandData(TRANSMIT_PACKET_TYPE XmtCmd, unsigned char DataOut[]);
00085         void RemCallParsePacket(unsigned char PacketIn[]);
00086
00087         // Communications Timers
00088         // RS232 100ms Timer 1
00089         UINT_PTR m_nTmrRS232Id;                 // return SetTimer Return Value (0=false,TimerID if OK)
00090         UINT_PTR m_nTmrRS232EventId;            // Timer Event Identifier
00091         UINT m_nTmrRS232Elapse;         // Timeout value in milliseconds
00092
00093         // AutoSpectrum 1000ms Timer 2
00094         UINT_PTR m_nTmrSpectrumId;                      // return SetTimer Return Value (0=false,TimerID if OK)
00095         UINT_PTR m_nTmrSpectrumEventId;         // Timer Event Identifier
00096         UINT m_nTmrSpectrumElapse;              // Timeout value in milliseconds
00097
00098         // General Purpose Event Timeout Flag 10ms Timer 3
00099         UINT_PTR m_nTmrTimeoutId;                       // return SetTimer Return Value (0=false,TimerID if OK)
00100         UINT_PTR m_nTmrTimeoutEventId;          // Timer Event Identifier
00101         UINT m_nTmrTimeoutElapse;               // Timeout value in milliseconds
00102         BOOL TimeoutFlag;
00103
00104         //CStatic m_PicturePlot;                // plot display
00105         CPlotCanvas m_PicturePlot;              // plot display
00106
00107         void PlotData(long DataBuffer[8192], int NumChan);      // calculates plot data
00108         void UpdatePlot();                                                                      // draws plot display
00109         long PlotBuffer[8192];  // holds plot data
00110         char szSettings[3000];  // holds settings for mca plot
00111         long XPlotMAX;
00112         long YPlotMAX;
00113
00114         BOOL HavePlot;
00115
00116         CStatic m_PictureScope;                                         // plot display
00117         void ScopeDisplay(unsigned char ScopeData[2048]);       // calculates plot data
00118         void UpdateScope();                                                                     // draws plot display
00119         unsigned char ScopeBuffer[2048];        // holds plot data
00120         BOOL HaveTrace;
00121
00122         void EnableDPPFunctions(BOOL isEnabled);
00123         afx_msg void OnBnClickedButtonDiag();
00124
00125         //void OnReceive(int nErrorCode);       //Sockets Comm
00126         afx_msg LONG OnReceive(UINT, LONG);
00127
00128         afx_msg void OnBnClickedButtonSelectComm();
00129         CLabel lblSelectCommunications; //CStatic
00130         CLabel lblStatus; //CStatic IDC_STATIC_STATUS
00131         CLabel lblMiscStatus; //CStatic IDC_STATIC_MISC_STATUS
00132         afx_msg LONG OnCommunication(UINT, LONG);
00133         void OnComm();
00134         void OnResetCommunications();
00135         afx_msg void OnBnClickedButtonGetSpectrum();
00136         afx_msg void OnBnClickedButtonStartAcquisition();
00137         afx_msg void OnBnClickedButtonStopAcquisition();
00138         afx_msg void OnBnClickedButtonEditConfig();
00139
00140         CString GetDeviceNameFromVal(int DeviceTypeVal);
00141         BOOL isConnectedTest();
00142         afx_msg LRESULT DppSendConfigToHw(WPARAM wParam, LPARAM lParam);
00143         void ProcessCfgReadEx(Packet_In PIN, DppStateType DppState);
00144
00145         //==== Configuration
00146         //==============================================================
00147         string GetCmdData(string strCmd, string strCfgData);
00148         CString GetCmdDataMS(CString strCmd, CString strCfgData);
00149         string GetCmdDesc(string strCmd);
00150         CString GetCmdDescMS(CString strCmd);
00151         string ReplaceCmdDesc(string strCmd, string strCfgData);
00152         CString ReplaceCmdDescMS(CString strCmd, CString strCfgData);
00153         string AppendCmdDesc(string strCmd, string strCfgData);
00154
00155         vector<string> Dp5CmdList;
00156         //void MakeDp5CmdList(CStringArray *strCfgArr);
00157         vector<string> CvcDP5Dlg::MakeDp5CmdList();
00158         void CopyDp5CfgToClip(CString strCfg, CString strDesc);
00159         afx_msg LRESULT CallReadDppConfig(WPARAM wParam, LPARAM lParam);
00160         afx_msg LRESULT CallReadDppConfigEx(WPARAM wParam, LPARAM lParam);
00161         afx_msg LRESULT CallReadScaConfig(WPARAM wParam, LPARAM lParam);
00162         //==============================================================
00163
00164         afx_msg void OnBnClickedButtonShowConfig();
00165         afx_msg void OnBnClickedRadioPlotScaleLinear();
00166         afx_msg void OnBnClickedRadioPlotScaleLog();
00167         afx_msg void OnBnClickedRadioPlotTypeSolid();
00168         afx_msg void OnBnClickedRadioPlotTypeLine();
00169
00170         //==== Configuration
00171         //==============================================================
00172         void SaveMCAFile(string strFilename, string strMCA);
00173         afx_msg void OnBnClickedBtnSaveFile();
00174         string CreateMCAData(long m_larDataBuffer[], SpectrumFileType sfInfo, DP4_FORMAT_STATUS cfgStatusLst);
00175         void SetStartTime();
00176         //==============================================================
00177
00178         CPoint CursorPosition;
00179         int CurrentChannel;
00180         afx_msg void OnStnClickedPlotpicturecontrol();
00181         afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
00182         virtual BOOL PreTranslateMessage(MSG* pMsg);
00183
00184         afx_msg void OnBnClickedOk();
00185         afx_msg void OnBnClickedCancel();
00186         void SetPlotChannel();
00187         afx_msg void OnBnClickedButtonClearRoi();
00188         afx_msg void OnBnClickedButtonRoiEnd();
00189         afx_msg void OnBnClickedButtonRoiStart();
00190         afx_msg BOOL OnToolTipNotify(UINT id, NMHDR *pNMHDR, LRESULT *pResult);
00191         afx_msg void TuneFastSlowThresh();
00192         afx_msg void OnBnClickedButtonAutotune();
00193         double GetPixPerChannel();
00194
00198         //BOOL TestAcqStatusExt();
00199         //void UpdateAcqStatusExt();
00200
00201         //int StatMcaEnabled_OLD;
00202         //int PresetCountExpired_OLD;
00203         //int PresetRtDone_OLD;
00204         //int AcqMode_OLD;
00205         //int MCSDone_OLD;
00206         //int m_acqStatus_OLD;
00210
00211         string CreateDTS(string strFormat);
00212
00216         CString strLowerMiscData;               // lower 256 bytes of misc data buffer
00217         CString strUpperMiscData;               // upper 256 bytes of misc data buffer
00218         CString ParsePerformanceNotes(CString str);
00219         CString TextToBlockString(CString &str, char *prefix);
00220         CString CreateTextBlockTest();
00221         void SendDppInfoTextBlock(CString strLowerTextBlock, CString strInfoTextBlock);
00223         void WriteTextBlock();
00224
00225         void ParseTextBlockNotes(CString strTextBlock);
00226         BOOL ExtractNote(CString& rString, LPCTSTR lpszFullString, int iSubString, TCHAR chSep);
00227         void CopyTextToClip(CString strTextIn);
00228         void OnBnClickedButtonWriteTextBlock();
00229         bool SendManufacturingTextBlock(CString generalNotes);
00230
00231 };
Generated on Thu Sep 21 2017 15:25:18 for vcDP5 Test C++ SDK by doxygen 1.7.6.1