DPPAPI DP4/PX4/DP5 Digital Pulse Processor API

The DP4/PX4/DP5 Digital Pulse Processor API is an Application Programming Interface Library for Amptek DP4, PX4, and DP5 Digital Pulse Processors. The DP4, PX4, and DP5 will be referred to collectively as DPP (Digital Pulse Processor). The DPPAPI communicates to the DPP via USB. The DPPAPI can select a DPP from a number of DPP devices attached to a system. The DPPAPI runs on personal computers with Intel® Pentium® or higher equivalent processor , Microsoft Windows® 98 (SE), Me, 2000, or XP and 64 MB RAM (128 MB recommended).

Application programs invoke DPPAPI functions to establish DPP communications, control DPP operations, and retrieve spectrum data. The DPPAPI is distributed with an import library (.LIB), and a dynamic link library (.DLL) and a type library (.TLB). Applications can be developed with the DPPAPI in C++, Visual Basic and many other programming languages.

The C language representation of DPPAPI functions are defined in the DppApi.h header file. These files are provided with the DPPAPI libraries. The USB drivers provided with your Amptek DPP must be installed and the usbdrvd.dll must be accessible to the DPPAPI in order to function properly.

DppApi API File List

DppApi API File List.htm


Update Notes for DppApi 1.0.1.6 and Older Applications

DP5 added to DppApi.

(See: Update details in the DppApi Reference)

1. Change all DeviceType references to one of these values:

devtypNONE = 0, // no dpp device

devtypDP4 = 1, // dp4

devtypPX4 = 2, //px4

devtypDP4EMUL = 3, // dp5 (dp4 emulation)

devtypPX4EMUL = 4 // dp5 (px4 emulation)

'a quick way to get the serial number and device type is to use GetUSBDppDeviceInfo

DppDevice = GetUSBDppDeviceInfo(objDppApi, USBDevNum, DppSerialNumber) ' get device information

2. Setup the device (DP5). (DP5 FPGA clock speed changes the value of settings by a factor or 4.

a. read the status before reading/writing configurations

OR

b. set the FPGA clock before reading/writing configurations

SetFPGAClockDefault (objDppApi, Dpp80MHzMode, DppDevice);

3. Note: configuration file values are the same for the DP5 except for:

1. The DP5 Coarse Gain value goes from 0-15 (See DP5 Gain Control Index).

2. Peaking Time, Flat Top Width, BLR, and Detector Reset are PX4 values

at 20MHzMode and INTERPRETED as 4x faster in 80MHzMode.

3. RTD has new settings