DppApi DotNet Development

The DppApi provides cut/paste solutions for rapid application development with DotNet languages like VBNet and CSharp. In the past many DotNet examples have been developed for cut/paste solutions. Examples are in the process of being updated for the current DppApi. Below is a list of examples demonstrating the DppApi.

CSharp

  • TestCS - CSharp Demonstration Project

VBNet

  • VBNet Development


CSharp Development

This example provides cut/paste solutions for rapid application development. Below is a list of demonstrated DppApi functions in CSharp.

  • TestCS - CSharp Demonstration Project

    • Demonstrates DppApi control of Amptek USB DPP devices.

    • Start/Stop acquisition.

    • Find connected USB DPP devices.

    • Selects default USB DPP device from a list of connected devices.

    • Acquires spectrum data.

    • Reads/displays DPP status.

    • Reads/displays DPP configuration files.

    • Sends/Receives DPP configurations through USB.

    • CSharp source code.

TestCS - CSharp Demonstration Project


VBNet Development

Many of the Visual Basic examples have been converted to VBNet in the past. Once the examples have been updated to work with the current DppApi, the examples wil be released.


TestCS is a brief C# (VS2003) example of connecting to a DP5, reading the
status/configuration, and acquiring data.

Only the functions used were updated to the correct C# data types.

It is recommended that all the API functions to be used be converted
before creating an end-user application.

Creating a C# Interface for the DPPAPI NOTES:
---------------------------------------------

1. The DPPAPI functions are standard C export functions.
2. Standard C export function data types are standard C\C++ data types.
    see .\Data Conversions\C++ Data Types.pdf
3. The C\C++ data types must be converted to C# data types.
    see .\Data Conversions\csharp Integeral Data Types.pdf
    see .\Data Conversions\csharp Built-in Data Types.pdf
4. DPPAPI (BETA) Reference Documents
    see "DPPAPI_Reference_Beta.pdf" for programming help
    see "DppApi Help.pdf" for DppApi function interface help.